%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Einleitung
Ansicht mit Navigationswerkzeuge

IDM 2.7.0 XML-Schema

Dokumentation

Stand 01 .05.2019

Dokumentiertes XML-Schema:

IDM_2_7_0.xsd

Kontakt

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Grundstruktur des IDM-Schemas
Ansicht mit Navigationswerkzeuge
Einleitung > Grundstruktur des IDM-Schemas

Die Grundstruktur des IDM-Schemas

Das Hauptelement T_NEW_CATALOG definiert, dass ein neuer, vollständiger Katalogdatenbestand bereitgestellt wird.

Dabei sind die XML-Dateien UTF-8 zu kodieren.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_NEW_CATALOG abgebildet werden.

Abbildung 1 - Child-Elemente von T_NEW_CATALOG

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

SUPPLIER

In SUPPLIER werden administrative Informationen zu dem Hersteller hinterlegt. Beispielsweise werden Kontaktdaten, EDI-Kommunikationsparameter oder das Herkunftsland des Herstellers angegeben.

GLOBAL_DEFINITION

Der Datenbereich GLOBAL_DEFINITION ist eine Art Datenpool für Informationen, die in den anderen Datenbereichen verwendet werden. Beispielsweise werden hier Standardgrifflagen oder die Informationen über Serien angelegt.

SERIES

In SERIES werden die Daten für die Beschreibung der Artikel hinterlegt. Dabei werden die Artikel in Produktgruppen wie beispielsweise Unterschränke oder Regale gruppiert.

FEATURE_DEFINITION

In FEATURE_DEFINITION werden Varianteninformationen hinterlegt. Beispielsweise werden Daten Variantenfamilien (FEATURE_CLASS), Variantenarten (FEATURE), die zugehörigen Varianten (OPTION_DEFINITION) oder Prüfverfahren (RESTRICTION) angelegt.

PRICE_DEFINITION

In PRICE_DEFINITION werden Preisinformationen hinterlegt. Beispielsweise werden Daten für Preiseigenschaftsgruppen (PRICE_FEATURE_GROUP), Mehrwertsteuer (VALUE_ADDED_TAXES), Warengruppen (MERCHANDISE_GROUP) oder Preisarten (PRICE_TYPE) nagelegt.

BLOCK_VALUE_CALCULATION

In BLOCK_VALUE_CALCULATON werden Informationen für die Block- und Werteverrechnung hinterlegt. Beispielsweise werden Daten für Blockregelwerke (SET_OF_BLOCK_RULES), Blockbedingungen (BLOCK_CONDITIONS) oder Wertetabellen (GRADING_TABLE) hinterlegt.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Elemente der Katalogstruktur
Ansicht mit Navigationswerkzeuge
Einleitung > Elemente der Katalogstruktur

Elemente der Katalogstruktur anlegen

Serieninformationen anlegen

Serien werden in folgendem Element definiert:

T_NEW_CATALOG/SERIES/SERIE

Alle Child-Elemente werden verwendet, um die Eigenschaften der Serien zu beschreiben. Programme werden Serien über Prüfverfahren (RESTRICTION_REF) zugeordnet.

Programminformationen anlegen

Programme werden im IDM als Varianten definiert. Das Anlegen der Programminformationen erfolgt, in dem die Eigenschaften der Programme als Ausprägungen von Varianten angelegt werden. Anschließend werden die Programmausprägungen der Variantenart "Programm" zugeordnet. Im folgenden Beispiel wird das Anlegen von Programminformationen dargestellt.

Beispiel: Anlegen von Programmen

1. Definition der Programmeigenschaften

Die Programmeigenschaften werden im folgenden Element definiert:

FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

<STYLE STYLE_NO="A1">

<STYLE_NAME>Paris</STYLE_NAME>

</STYLE>

<STYLE STYLE_NO="A2">

<STYLE_NAME>New York</STYLE_NAME>

</STYLE>

</OPTION_DEFINITION>

Es werden die Eigenschaften für die Programme "Paris" und "New York" definiert. Die im Element STYLE verfügbaren Elemente wurden aus Gründen der Übersicht nicht dargestellt.

2. Erstellen der Programmvarianten

Die Programmvarianten werden wie alle anderen Varianten in folgendem Element erstellt:

FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_NO="A1" FEATURE_NO="1">

<STYLE_REF STYLE_NO="A1"/>

</OPTION>

<OPTION OPTION_NO="A2" FEATURE_NO="1">

<STYLE_REF STYLE_NO="A2"/>

</OPTION>

</OPTIONS>

</FEATURE>

In dem obigen Beispiel werden die Programmvarianten für die Programme "Paris" und "New York" erstellt. Programmvarianten werden über die Variantenart "Programm" erstellt, die über die Variantenartennummer 1 definiert wird. Die Programmvariante wird über die Kombination von FEATURE_NO und OPTION_NO eindeutig identifiziert.

Artikelinformationen anlegen

Artikelinformationen werden im folgenden Element angelegt:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Das Element ITEM besitzt eine Vielzahl von Elementen mit denen die Eigenschaften von Artikeln beschrieben werden können. Die Identifizierung eines Artikels erfolgt über das Attribut TYPE_NO.

Hierbei ist jedoch zu beachten, dass ein Artikel in Abhängigkeit der Serie unterschiedliche Eigenschaften haben kann. Demzufolge wird ein Artikel mit seinen Eigenschaften nur eindeutig in Verbindung mit der Serie identifiziert.

Serienspezifische Artikelinformationen

Artikel können in Anhängigkeit der Serie unterschiedliche Eigenschaften haben. Artikel sind einer Serie automatisch zugeordnet, da das Elemente ITEM ein Kind-Element des Elementes SERIE ist.

Varianteninformationen anlegen

Varianteninformationen werden im IDM-Schema wie nachfolgend beschrieben angelegt:

n Anlegen der Ausprägungen für die Varianten

n Zuordnen von Ausprägung und Variantenart

Anlegen der Ausprägungen

Die Ausprägungen für die Varianten werden als Datenpool in dem Element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert.

Abbildung 2 – Das Element OPTION_DEFINITION

Das Element OPTION_DEFINITION enthält Elemente, in denen die jeweilige Ausprägungen angelegt werden:

STYLE | In diesem Element werden die Eigenschaften von Programmen definiert. Programme sind eine Ebene der Katalogstruktur, werden aber über Varianten abgebildet, da diese in Prüfverfahren vielfach verwendet werden.
HANDLE_ORIENTATION | In diesem Element wird eine Standardgrifflage definiert.
MATERIAL | In diesem Element werden die Eigenschaften von Materialien mittels Farben und Texturen definiert. Diese Elemente werden aus Ausführungsvariantenarten (z. B. Sockelausführung) oder Farbvariantenarten (z. B. Sockelfarbe) referenziert.
FORM | In diesem Element werden die Nummern für Formvarianten (FORM_NO) definiert. Zum aktuellen Stand des IDM-Schema werden in diesem Element mit Ausnahme der FORM_NO keine weiteren Eigenschaften gepflegt. Die Ausprägungen dieses Elementes dürfen nur von den Variantenarten 750-756 referenziert werden.
OPTION_MEASURE | In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Sockelhöhe(Variantenart 402)).

Beispiel: Ausprägungen für Farben

<OPTION_DEFINITION>

<COLOR COLOR_NO="1">

<RGB_RED>255</RGB_RED>

<RGB_GREEN>0</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="2">

<RGB_RED>133</RGB_RED>

<RGB_GREEN>273</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="3">

<RGB_RED>0</RGB_RED>

<RGB_GREEN>89</RGB_GREEN>

<RGB_BLUE>89</RGB_BLUE>

</COLOR>

</OPTION_DEFINITION>

Die obigen Elemente definieren drei Farben, die über die Nummern (COLOR_NO) 1-3 identifiziert werden.

Zuordnen von Ausprägung und Variantenart

Die beispielartig definierten Farben müssen, um sie im nutzen zu können, Variantenarten zugeordnet werden, wodurch Varianten entstehen.

Die Zuordnung von Variantenarten (FEATURE) und Ausprägungen (OPTION) zu Varianten erfolgt im Element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE. Eine Variante wird durch die Kombination von FEATURE und OPTION gebildet und identifiziert. Die nachfolgenden XML-Elemente definieren 2 Farbvarianten für die Sockelfarbe (Variantenart 401).

Beispiel: Aufbau der Varianten aus Variantenart und Ausprägungen

<FEATURE FEATURE_NO="401">

<OPTIONS>

<OPTION OPTION_NO="1" FEATURE_NO="401">

<OPTION_TEXT_REF TEXT_NO="4"/>

</OPTION>

<OPTION OPTION_NO="3" FEATURE_NO="401">

<OPTION_TEXT_REF TEXT_NO="6"/>

</OPTION>

</OPTIONS>

<FEATURE_TEXT_REF TEXT_NO="12"/>

<CLASSIFICATION>1</CLASSIFICATION>

<HEADER_POS_VARIATION_TYPE>K</HEADER_POS_VARIATION_TYPE>

</FEATURE>

Die Child-Elemente von FEATURE beschreiben die Eigenschaften der Variantenart und die Child-Elemente von OPTION beschreiben die Eigenschaften der Variante. Entsprechend diesem Prinzip, welches grundlegend für alle Elemente im IDM-Schema gilt, wird durch das Element OPTION_TEXT_REF ein Text referenziert, der die Variante bezeichnet. Das Element FEATURE_TEXT_REF referenziert einen Text, der die Variantenart bezeichnet.

Soll in den Daten eine Variante referenziert werden, muss immer die Kombination aus FEATURE_NO und OPTION_NO als Referenzierungschlüssel angegeben werden.

Kombination von Variantenarten

Wenn die Variantenart 1 (Programm) zusammen mit anderen Varianten angelegt wird, dann steht die Variantenart 1 immer an 1. Stelle.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Aufbauen der Katalogstruktur
Ansicht mit Navigationswerkzeuge
Einleitung > Aufbauen der Katalogstruktur

Aufbauen der Katalogstruktur

Programme Serien zuordnen

Programme werden Serien in folgendem Element zugeordnet:

SERIES/SERIE/RESTRICTION_REF

Das Programm wird der Serie zugeordnet, in dem ein Prüfverfahren referenziert wird, welches das Programm als gültige Kombination definiert.

Das Element zur Beschreibung der Programmeigenschaften ist:

FEATURE_DEFINITION/OPTION_DEFINITION/STYLE

Artikel Serien und Programmen zuordnen

Artikel-Serien Zuordnung

Artikel werden Serien automatisch zugeordnet, da das Element ITEM ein Kind-Element des Elementes SERIES ist:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Artikel-Programm Zuordnung

Programmabhängige Artikel sind grundlegend in allen Programmen verfügbar, die der Serie zugeordnet sind, in welcher der Artikel definiert ist. Soll für einen Artikel Programme ausgeschlossen werden, so sind entsprechende Artikel-spezifische Prüfverfahren von dem Artikel zu referenzieren:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

Ein geeignetes Prüfverfahren, mit dem bei Referenzierung von einem Artikel ein Programm ausgeschlossen wird, ist in dem nachfolgenden Beispiel dargestellt.

Beispiel: Prüfverfahren zur Artikel-Programm-Zuordnung

Element: FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="A1">

<FEATURE_REF FEATURE_NO="1"/>

<OPTION_REF OPTION_NO="A1" FEATURE_NO="1"/>

<TEST_ID>0</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

Das obige Beispiel stellt ein Prüfverfahren dar, in dem die referenzierte Variante eine nicht zulässige Kombination definiert. Die zugehörige Variantendefinition sieht beispielsweise wie folgt aus:

Die referenzierte Programmvariante:

Element: FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_NO="A1" FEATURE_NO="1">

<STYLE_REF STYLE_NO="A1"/>

</OPTION>

</OPTIONS>

</FEATURE>

Die verwendete Programmeigenschaft

Element: FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

<STYLE STYLE_NO="A1">

<STYLE_NAME>Paris</STYLE_NAME>

</STYLE>

</OPTION_DEFINITION>


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Katalogstruktur
Ansicht mit Navigationswerkzeuge
Einleitung > Katalogstruktur

Katalog- und Elementstruktur

Die grundlegende Katalogstruktur der Datenbestände baut sich wie folgt auf:

Abbildung 1 – Katalogstruktur der Datenbestände

Die Katalogstruktur wird im IDM-Schema durch die folgende Elementhierarchie abgebildet:

Abbildung 1 – Elementhierarchie im IDM-Schema

In dem Element SERIE werden die Eigenschaften einer Serie definiert. Über das Element RESTRICTION_REF werden einer Serie Varianten über Prüfverfahren zugeordnet. Innerhalb der Serie werden Produktgruppen (PRODUCT_GROUPS) definiert, in denen Artikel mit gleichartigen Variantenarten zusammengefasst sind. Die Artikel sind einer Serie automatisch zugeordnet, da sie Kind-Elemente des Elementes SERIE sind.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Referenzierung
Ansicht mit Navigationswerkzeuge
Einleitung > Referenzierung

Referenzierung von Elementen

Im IDM-Schema werden Beziehungen zwischen Elementen aufgebaut und Informationen an zentraler Stelle definiert und an anderer Stelle mehrfach verwendet. Die Wiederverwendung der Informationen und der Aufbau von Elementbeziehungen erfolgt über Referenzierung. Die im IDM-Schema angewendete Art der Referenzierung wird nachfolgend beschrieben.

Begriffsdefinition

Im IDM-Schema werden für die Referenzierung von Elementen folgende Begriffe verwendet:

Key-Element | Ein XML-Element, welches von anderen Elementen referenziert wird.
Ref-Element | Ein XML-Element, welches andere Elemente referenziert.

Vorgang der Referenzierung

Das Key-Element besitzt Attribute, über die es eindeutig identifiziert wird. Das Ref-Element besitzt minimal die Key-Attribute des Key-Elementes. Zwischen den Elementen wird die Referenz aufgebaut, in dem die Attributwerte des Ref-Elementes denen des Key-Elementes entsprechen.

Beispiel: Referenzierung der Serie aus dem Artikel

Das nachfolgende Beispiel zeigt, wie aus von einem Artikel (ITEM) eine Serie (SERIE) referenziert wird. Die XML-Elemente sind nur auszugsweise dargestellt.

Key-Element

T_NEW_CATALOG/SERIES/SERIE

<SERIES>

<SERIE SERIE_NO="1"/> … </SERIE>

<SERIE SERIE_NO="2"/> … </SERIE>

<SERIE SERIE_NO="3"/> … </SERIE>

. . .

<SERIE SERIE_NO="99"/> … </SERIE>

</SERIES>

Ref-Element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS>

<ITEM SERIE_NO="1" . . . />

. . .

</ITEMS>

Beispiel: Referenzierung einer Varianten

Im folgenden Beispiel wird eine Variante aus einem Prüfverfahren heraus referenziert.

Key-Element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!-- Sockelausführung -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!-- Sockelfarbe -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

Die XML-Elemente definieren für die Variantenart 400 (FEATURE) drei Varianten (OPTION) mit den Nummern 1-3 sowie für die Variantenart 401 drei Varianten mit den Nummern 1-3. Eine Variante wird identifiziert über die Kombination FEATURE_NO und OPTION_KEY.

Ref-Element

/T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_REF

<RESTRICTION RESTRICTION_NO="1">

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="1" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

In den XML-Elementen wird ein Prüfverfahren für die zulässigen Kombinationen (TEST_ID=1) der Sockelausführungen (FEATURE_NO=400) und der Sockelfarben (FEATURE_NO=401) definiert. Das Ref-Element OPTION_REF mit den grau hinterlegten Attributen referenziert in diesem Beispiel das grau hinterlegte Key-Element OPTION.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Prüfverfahren
Ansicht mit Navigationswerkzeuge
Einleitung > Prüfverfahren

Definition und Zuordnung von Prüfverfahren

Prüfverfahren können Serien-übergreifend, Serien-spezifisch, Programm-spezifisch oder Artikel-spezifisch gültig sein. Je tiefer in der Hierarchie Serie->Programm->Artikel ein Prüfverfahren zugeordnet wird, desto höher ist seine Priorität. Ein Prüfverfahren auf Artikelebene übersteuert beispielsweise ein Prüfverfahren, welches auf Programmebene zugeordnet wurde. Ein übersteuerndes Prüfverfahren kann jedoch nur weitere Einschränkungen definieren. Beispielsweise ist es nicht möglich, dass über ein Artikel-spezifisches Prüfverfahren Varianten wieder verfügbar gemacht werden, die bereits von einem Programm-spezifischen Prüfverfahren ausgeschlossen wurden.

Prüfverfahren werden zunächst unabhängig von ihrer späteren Zuordnung angelegt und dann Serien, Programmen oder Artikeln zugeordnet.

Anlage von Prüfverfahren

Prüfverfahren werden in folgendem Element angelegt:

FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

In dem Element RESTRICTION werden Variantenarten referenziert, für deren Kombinationen das Prüfverfahren angelegt werden soll. In dem Element OPTION_REF werden die Varianten referenziert, deren Kombinationen geprüft werden sollen. Es dürfen nur die Varianten referenziert werden, deren Variantenarten in dem Element RESTRICTION referenziert wurden. Das Element TEST_ID definiert, ob die angegebene Variantenkombination zulässig oder unzulässig ist.

Beispiel: Definition von Prüfverfahren

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="523" FEATURE_1_NO="100" FEATURE2_NO="101">

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA" FEATURE_NO="100"/> #lackiert

<OPTION_REF OPTION_NO="RO" FEATURE_NO="101"/> # rot

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA" FEATURE_NO="100"/> # lackiert

<OPTION_REF OPTION_NO="GR" FEATURE_NO="101"/> # grün

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="FU" FEATURE_NO="100"/> # furniert

<OPTION_REF OPTION_NO="BU" FEATURE_NO="101"/> # buche

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

Im obigen Beispiel ist ein Prüfverfahren definiert, welches die Kombinationen von Varianten der Variantenart „Frontausführung “ (Nr. 100) und der Variantenart „Frontfarbe“ (Nr. 101) definiert. Nach dem obigen Prüfverfahren sind die Kombinationen lackiert-rot, lackiert-grün und furniert-buche erlaubt (TEST_ID = 1). Beim Auflisten der Variantenkombinationen (OPTION_REF) muss die Reihenfolge eingehalten werden, wie diese durch die Attribute von RESTRICTION (FEATURE_1_NO, FEATURE_2_NO) gegeben wird.

Für die Identifizierung wird dem Prüfverfahren eine eindeutige Nummer (RESTRICTION_NO) zugewiesen.

Zuordnung von Prüfverfahren

Serien-übergreifende Zuordnung

Prüfverfahren werden Serien-übergreifend mit folgendem Element zugeordnet:

SERIES/RESTRICTIONS/RESTRICTION_REF

Das Element RESTRICTION_REF ist Kind-Element des Elementes SERIES/RESTRICTIONS, hierdurch werden die in RESTRICTION_REF referenzierten Prüfverfahren allen Serien zugeordnet, die in SERIES/SERIE definiert werden.

Beispiel: Serien-übergreifende Zuordnung von Prüfverfahren

<SERIES>

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="523"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="678"/>

</RESTRICTIONS>

</SERIES>

In dem obigen Beispiel werden die Prüfverfahren 523 und 678 referenziert und damit allen Serien zugeordnet.

Serien-spezifische Zuordnung

Die Serien-spezifische Zuordnung von Prüfverfahren erfolgt nach selbem Muster, wie die Serien-übergreifende Zuordnung. Für die Serien-spezifische Zuordnung wird das folgende Element verwendet:

SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF

Die in RESTRICTION_REF referenzierten Prüfverfahren werden der Serie zugeordnet, innerhalb derer die Referenzierung erfolgte.

Prüfverfahren, in denen Programme zugeordnet werden, sind 1-stufige Prüfungen, in denen nur die Variantenart 1 (Programm) enthalten ist. Diese Prüfverfahren sind Pflicht für Serien > 0 und wenn die Variantenart 1 im Datenbestand definiert ist.

Beispiel: Serien-spezifische Zuordnung von Prüfverfahren

<SERIES>

<SERIE SERIE_NO="2">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="67"/>

</RESTRICTIONS>

</SERIE>

<SERIE SERIE_NO="7">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="123"/>

</RESTRICTIONS>

</SERIE>

</SERIES>

Im obigen Beispiel wurden der Serie „2“ die Prüfverfahren 45 und 67 sowie der Serie „7“ die Prüfverfahren 45 und 123 zugeordnet.

Artikelspezifische Zuordnung

Die Artikel-spezifische Zuordnung von Prüfverfahren erfolgt in folgendem Element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

Die Zuordnung der Prüfverfahren erfolgt wie bei der Serien- oder Programm-spezifischen Zuordnung.

Sind einem Artikel keine Prüfverfahren zugeordnet, dann ist dieser ohne Einschränkungen hinsichtlich der Varianten lieferbar.

Produktgruppen-spezifische Zuordnung

Die Produktgruppen-spezifische Zuordnung von Prüfverfahren erfolgt in folgendem Element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF

Die Zuordnung der Prüfverfahren erfolgt wie bei der Serien-spezifischen Zuordnung.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Datentypen
Ansicht mit Navigationswerkzeuge
Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

Es werden folgende Datentypen genutzt:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDM wird der Datentyp date XML-Schema konform in folgender Weise angewendet: YYYY-MM-DD YYYY = Jahr, MM = Monat, DD = Tag
dateTime | Im IDM wird der Datentyp dateTime XML-Schema konform in folgender Weise angewendet: YYYY-MM-DDThh:mm:ssZ YYYY = Jahr, MM = Monat, DD = Tag T = Beginn der Zeitangabe hh = Stunde, mm = Minute, ss = Sekunde Z = UTC-Zeit
gYear | Im IDM wird der Datentyp dateTime XML-Schema konform in folgender Weise angewendet: YYYY
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDM für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDM für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDM für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.

Die Wertebereiche der obigen Datentypen sind im allgemeinen für die Elemente im IDM eingeschränkt. Über "Restrictions" bei der Datentypdefinition sind Minimal- und Maximalwerte, zulässige Zeichen sowie Wertlisten eingeschränkt.

In der XML-Schema Dokumentation des IDM sind die Wertebereiche durch die Angabe hinter M und P spezifiziert.

Neben den hier genannten XML-Datentypen werden eigene Datentypen für die Texte definiert.

Sie sind am Ende der Dokumentation erklärt.

Siehe auch
languagetexte Complex Type
languagetexte30 Complex Type
languagetexte40 Complex Type
languagetexte60 Complex Type
languagetexte60999 Complex Type


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Erläuterungen zur Dokumentation
Ansicht mit Navigationswerkzeuge
Einleitung > Erläuterungen zur Dokumentation

Erläuterungen zur Dokumentation des IDM

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

EXCHANGE_ID_NO Attribute

Description
" -->
Beschreibung
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Variantenarten
Ansicht mit Navigationswerkzeuge
Einleitung > Variantenarten

Variantenart | Variantentext | Ausführungsart | Bemerkung
1 | Programm | A | Programm als VariantenartProgramm als VariantenartProgramm als Variantenart
2 | Seriennummer | A | Zuordnung einer fünfstelligen Seriennummer
100 | Frontausführung | A |
101 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
102 | Frontfarbe 2 | F | Rahmen
103 | Frontfarbe 3 | F | Lisenen
104 | Kantenfarbe Front | F |
105 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
106 | Frontgruppe | A | Überschreibt die FRONT_GROUP_NO in FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Frontausführung Absetzung 1 | A |
111 | Frontfarbe 1 Absetzung 1 | F | Füllung glatte Front = ganze Fläche
112 | Frontfarbe 2 Absetzung 1 | F | Rahmen
113 | Frontfarbe 3 Absetzung 1 | F | Lisenen
114 | Kantenfarbe Front Absetzung 1 | F |
115 | Front-Kombination Absetzung 1 | K | Darf die Varianten 111 bis 114 enthalten
120 | Frontausführung Absetzung 2 | A |
121 | Frontfarbe 1 Absetzung 2 | F | Füllung glatte Front = ganze Fläche
122 | Frontfarbe 2 Absetzung 2 | F | Rahmen
123 | Frontfarbe 3 Absetzung 2 | F | Lisenen
124 | Kantenfarbe Front Absetzung 2 | F |
125 | Front-Kombination Absetzung 2 | K | Darf die Varianten 121 bis 124 enthalten
150 | Glasausführung | A |
151 | Glasfarbe | F |
152 | Sprossenausführung | A |
153 | Sprossenfarbe | F |
154 | Ausführung Glastürrahmen | A |
155 | Farbe Glastürrahmen | F |
160 | Ausführung Jalousie | A |
161 | Farbe Jalousie | F |
170 | Ausführung Schütte | A |
171 | Farbe Schütte | F |
200 | Korpusausführung | A |
201 | Korpus-Kombination | K | Wenn für mehrere Korpusfarben - innen/außen - nur ein Schlüssel vorhanden ist.
202 | Korpusfarbe außen | F |
203 | Korpusfarbe innen | F |
204 | Kantenausführung Korpus | A |
205 | Kantenfarbe Korpus | F |
206 | Sichtseiten-Ausführung | A |
207 | Sichtseiten-Farbe | F |
208 | Korpusfarbe innen für Glas | F | Glasschränke und offene Schränke, die kein Regal sind.
209 | Korpusausf. innen für Glas | A | Glasschränke und offene Schränke, die kein Regal sind.
300 | Griffausführung | A |
301 | Griff-Farbe 1 | F | Griff-, Knopfsockel- bzw. Hauptfarbe
302 | Griff-Farbe 2 | F | Bügel-, Steg- und Knopfblendenfarbe
303 | Griff-Kombination | K | Wenn nur ein Schlüssel für mehrere Griffbedingungen vorgegeben ist.
304 | Grifflagen | NULL | Siehe Grifflagen S. 5-23
400 | Sockelausführung | A |
401 | Sockelfarbe | F |
402 | Sockelhöhe | A |
410 | Ausführung Sockelboden | A |
411 | Farbe Sockelboden | F |
500 | Ausführung Regale | A |
501 | Farbe Regale | F |
502 | Ausführung Kranzprofil | A | Beinhaltet Form und Material
503 | Farbe Kranzprofil | F |
504 | Ausführung Lichtleiste | A | Beinhaltet Form und Material
505 | Farbe Lichtleiste | F |
506 | Ausführung Deckenblende | A |
507 | Farbe Deckenblende | F |
508 | Ausf. u. Schr.-abschlussleiste | A | Untere Schrankabschlußleiste
509 | Farbe u. Schr.-abschlussleiste | F | Untere Schrankabschlußleiste
510 | Ausführung Oberboden | A |
511 | Farbe Oberboden | F |
512 | Ausführung Oberboden-Kante | A |
513 | Farbe Oberboden-Kante | F |
514 | Ausführung Bord | A |
515 | Farbe Bord | F |
516 | Ausführung Bordkante | A |
517 | Farbe Bordkante | F |
520 | Ausführung Wangen/Riegel | A |
521 | Farbe Wangen/Riegel | F |
522 | Ausführung Wangenkante | A |
523 | Farbe Wangenkante | F |
524 | Ausführung Unterboden | A |
525 | Farbe Unterboden | F |
526 | Ausführung Unterboden-Kante | A |
527 | Farbe Unterboden-Kante | F |
550 | Nischenausführung | A |
551 | Nischenfarbe | F |
560 | Ausführung Nischenzubehör | A |
561 | Farbe Nischenzubehör | F |
562 | Ausführung Pilaster | A |
563 | Farbe Pilaster | F |
564 | Ausführung Pilasterkante | A |
565 | Farbe Pilasterkante | F |
600 | Arbeitsplatten-Ausführung | A |
601 | Arbeitsplatten-Farbe | F |
602 | Arbeitsplattenkantenausführung | A |
603 | Arbeitsplatten-Kantenfarbe | F |
604 | Barplatten-Ausführung | A |
605 | Barplatten-Farbe | F |
606 | Barplatten-Kantenausführung | A |
607 | Barplatten-Kantenfarbe | F |
620 | Abdeckplatten-Ausführung | A |
621 | Abdeckplatten-Farbe | F |
622 | Abdeckplatten-Kantenausführung | A |
623 | Abdeckplatten-Kantenfarbe | F |
624 | Ansetztisch-Ausführung | A |
625 | Ansetztisch-Farbe | F |
626 | Ansetztisch-Kantenausführung | A |
627 | Ansetztisch-Kantenfarbe | F |
650 | WAP-Ausführung | A | Wandabschlussprofil
651 | WAP-Farbe | F | Wandabschlussprofil
700 | Schubkastenausführung | A | Innenausstattung
701 | Schubkastenfarbe | F | Innenausstattung
702 | Auszugsausführung | A | Innenausstattung
703 | Auszugsfarbe | F | Innenausstattung
750 | Arbeitsplattenform | S |
751 | Kranzleistenform | S |
752 | Lichtleistenform | S |
753 | Sockelform | S |
754 | Wandabschlussform | S |
755 | Abdeckplattenform | S |
756 | Barplattenform | S |
800 | Ausführung Elektrogeräte | A |
801 | Farbe Elektrogeräte | F |
802 | Farbe Elektrogeräte-Zubehör | F |
850 | Ausführung Spülen | A |
851 | Farbe Spülen | F |
852 | Farbe Spülenzubehör | F |
853 | Mischbatterien Farbe | F |
854 | Ausführung Mischbatterien | A |
900 | Ausführung Allgemeines Zubehör | A |
901 | Farbe Allgemeines Zubehör | F |
930 | zus. grafisch relevante Ausführung 1 | A | unbedingt den Softwarehäusern separat mitteilen
931 | zus. grafisch relevante Farbe 1 | F | unbedingt den Softwarehäusern separat mitteilen
932 | zus. grafisch relevante Ausführung 2 | A | unbedingt den Softwarehäusern separat mitteilen
933 | zus. grafisch relevante Farbe 2 | F | unbedingt den Softwarehäusern separat mitteilen
934 | zus. grafisch relevante Ausführung 3 | A | unbedingt den Softwarehäusern separat mitteilen
935 | zus. grafisch relevante Farbe 3 | F | unbedingt den Softwarehäusern separat mitteilen
936 | zus. grafisch relevante Ausführung 4 | A | unbedingt den Softwarehäusern separat mitteilen
937 | zus. grafisch relevante Farbe 4 | F | unbedingt den Softwarehäusern separat mitteilen
938 | zus. grafisch relevante Ausführung 5 | A | unbedingt den Softwarehäusern separat mitteilen
939 | zus. grafisch relevante Farbe 5 | F | unbedingt den Softwarehäusern separat mitteilen
950 | Ausführung Diverses 1 | A |
951 | Farbe Diverses 1 | F |
952 | Ausführung Diverses 2 | A |
953 | Farbe Diverses 2 | F |
954 | Ausführung Diverses 3 | A |
955 | Farbe Diverses 3 | F |
956 | Ausführung Diverses 4 | A |
957 | Farbe Diverses 4 | F |
958 | Ausführung Diverses 5 | A |
959 | Farbe Diverses 5 | F |
960 | Ausführung Diverses 6 | A |
961 | Farbe Diverses 6 | F |
962 | Ausführung Diverses 7 | A |
963 | Farbe Diverses 7 | F |
964 | Ausführung Diverses 8 | A |
965 | Farbe Diverses 8 | F |
966 | Ausführung Diverses 9 | A |
967 | Farbe Diverses 9 | F |
968 | Ausführung Diverses 10 | A |
969 | Farbe Diverses 10 | F |
970 | Ausführung Diverses 11 | A |
971 | Farbe Diverses 11 | F |
972 | Ausführung Diverses 12 | A |
973 | Farbe Diverses 12 | F |
974 | Ausführung Diverses 13 | A |
975 | Farbe Diverses 13 | F |
976 | Ausführung Diverses 14 | A |
977 | Farbe Diverses 14 | F |
978 | Ausführung Diverses 15 | A |
979 | Farbe Diverses 15 | F |
980 | Ausführung Diverses 16 | A |
981 | Farbe Diverses 16 | F |
982 | Ausführung Diverses 17 | A |
983 | Farbe Diverses 17 | F |
984 | Ausführung Diverses 18 | A |
985 | Farbe Diverses 18 | F |
986 | Ausführung Diverses 19 | A |
987 | Farbe Diverses 19 | F |
988 | Ausführung Diverses 20 | A |
989 | Farbe Diverses 20 | F |
999 | Fixe Materialzuordnung | F |

Typ: A = Ausführung

F = Farbe

K = Kombination

S = Form


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Geforderte Variantenarten
Ansicht mit Navigationswerkzeuge
Einleitung > Geforderte Variantenarten

Zur Sicherstellung, dass alle benötigten Variantenarten im Planungsprozess bereitstehen werden Muss-Variantenarten definiert, die in Abhängigkeit des Typschlüssels eines Artikels geliefert werden müssen.

Typschlüssel | geforderte Variantenarten
Typenschlüssel-Art 8 oder 27 | 520,521
Typenschlüssel-Art 26 | 562,563
Typenschlüssel-Art 2 | 500,501
Typenschlüssel-Art 29 | 514,515
Typenschlüssel 5 | 550,551
Typenschlüssel 20 oder 21 | 510,511
Typenschlüssel 12 | 504,505
Typenschlüssel 11 | 502,503
Typenschlüssel 14 oder 15 | 400,401,402
Typenschlüssel 18 | 650,651
Typenschlüssel 17 | 600,601
Frontauspraegungsschlüssel 4 | 151, 154, 208
Branch_ID=K | 101,202,203,205

Alle Typenschlüssel sind der Tabelle Typenschlüssel zu entnehmen.

Die Typenschlüssel-Art ist in der Tabelle Typenschlüssel-Arten eingetragen


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Typenschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Typenschlüssel

Typ-Nr. | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Unterschrank | Floor cupboard
2 | Hochschrank | Tal cupboard
3 | Hänge-/Oberschrank | Hanging/wall cupboard
4 | APL-Aufsatz | Work-top mounted cupboard
5 | Nischengestaltung | Recess kit
6 | Highboard | Highboard
7 | Nischenschrank |
8 | Solitärmöbel |
9 | Frontelement | Front element
10 | Modul-Element |
11 | Kranzprofil | Cornice profile
12 | Lichtblende | Pelmet
13 | Deckenblende | Top facing
14 | Sockelblende | Plinth filler
15 | Sockelleiste | Plinth board
17 | Arbeitsplatte | Work-top
18 | WAP | Wall end moulding
19 | Abdeckplatte | Covering plate
20 | Baldachin | Canopy
21 | Überbauboden | Over shelf
22 | Konstruktionsboden | Construction shelf
24 | Kaminesse | Chimney
26 | Elektrogerät | Appliance
27 | Gasgerät | Gas appliance
28 | Kleingerät | Small appliance
29 | Spüle | Sink
30 | Armatur | Tab unit
35 | Beleuchtung | Lighting
37 | Allgem. Zubehör | General accessory
38 | Sonstiges | Other
41 | Block | Block
42 | Mehrausstattung | Additional equipment
43 | Werteverrechnung |
95 | Vorgez. Recyclinggeb. |
98 | Information als Unterp. |
99 | Allgem. Text/Auftrag |


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Ausstattungsschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Ausstattungsschlüssel

AusstattungID | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Allesschneider | Universal cutter
2 | Brot | Bread
3 | Drehboden | Rotating shelf
4 | Flaschen | Bottles
5 | Glas | Glass
6 | Handtuch | Hand towel
7 | Innenschub/-zug |
8 | Putzmittel/Besen |
9 | Reste/Abfallsystem |
10 | Schwenkmechanik |
11 | Ausziehtisch |
12 | Vorrat | Larder
13 | Wäsche | Linen
14 | Gewürz | Spice
16 | Trockner | Dryer
17 | Herd | Cooker
18 | Backofen | Oven
19 | Kochmulde | Hob
20 | Ceranfeld | Ceramic hob
21 | Dunsthaube | Cooker hood
22 | Abzug | Extractor
23 | Lüfterbaustein |
24 | Microwelle | Microwave
25 | Spülmaschine | Dishwasher
26 | Gefrierschrank | Freezer
27 | Kühlschrank | Fridge
28 | Waschmaschine | Washing machine
29 | Funktions-/Schaltkasten |
30 | Doppelbackofen | Double oven
31 | Spüle | Sink
32 | Dampfgarer |
33 | Warmhaltezone |
34 | Grill |
35 | Friteuse |
36 | Schneidbrett beheizt |
37 | Kaffeemaschine |
41 | Kühl-/Gefrierkombination |
42 | Back-Mikro-Kombination |
43 | Backen/Wärmen |
46 | Niederdruck | Low pressure
47 | Hochdruck | High pressure
48 | TV-Gerät |
49 | Wasserspender |
50 | Geschirrwärmer |
51 | Muldenlüfter (Dunstabzug/Lüfterbaustein) |
52 | Eiswürfelspender |
53 | Bierkühler |
54 | Schublade |


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Einbau Info- Schlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Einbau Info- Schlüssel
EinbauInfo-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Integrierbar |
2 | Einbau |
3 | Unterbau |
4 | Standgerät |
5 | Voll Integrierbar |
7 | Nische integriert |
8 | Nische offen |
11 | Frontbündig |
12 | Korpusbündig |
13 | Flächenbündig |
14 | Auflage | Lay-on
15 | Module |
17 | freistehend |
18 | freihängend |
19 | wandhängend |
21 | Sichtseite |
22 | Seitlicher Sockel |
23 | Formstück |
24 | Retoure |
25 | Übergang |
26 | Gehrungszuschlag |
28 | Breitenkürzung |
29 | Tiefenkürzung |
30 | Höhenkürzung |
32 | Ausschnitt | Cut-out
33 | Abschrägung |
34 | Abrundung |
35 | Verbindung |
36 | Ausklinkung | Release
37 | Bearbeitung |
46 | Zeile 60 cm |
47 | Ecke | Edge
48 | Zeile 60 cm + Ecke |
49 | Spezialschrank |


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Materialschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Materialschlüssel
Material-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Kunststoff | Plastic
2 | Corian | Corean
3 | Echtholz | Wood
4 | Naturstein | Natural stone
5 | Metall | Metal
6 | Fliesen | Tiles
7 | Glas | Glass
8 | Verbundwerkstoff | Composite material
9 | Edelstahl | Stainless Steel
10 | Aluminium | Aluminium
11 | Stahl emailliert | Enameled steel
12 | Keramik | Ceramic


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Formschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Formschlüssel
Form-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Rechteckig | Square
2 | Diagonal | Diagonal
3 | Innenrund | Insidecurve
4 | Rund | Round
5 | Halbrund/Rundung | Half-round/rounding
6 | Schräg | Angled
7 | Z-Form / 3-D | Z-Form / 3-D
8 | Wellenform | Wavy
9 | 45-Grad | 45-degree
10 | 90-Grad | 90-degree
11 | 135-Grad | 135-degree
12 | N-Grad | N-degree


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Frontausprägungsschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Frontausprägungsschlüssel
Frontausprägung-Nr. | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Tür | Door
2 | Schubkasten | Drawer
3 | Auszug | Pull-out
4 | Glastür | Glass door
5 | Klappe | Lid/flap
6 | Schaltkastenblende | Switch cabinet bezel
7 | Jalousie | Blind
8 | Schiebetür |
9 | Faltklappentür |
10 | Rollfront |
11 | Tür/Schubkasten | Door/drawer
12 | Auszug/Schubkasten | Pull-out/drawer
13 | Schubkasten/Jalousie | Drawer/blind
14 | Auszug/Tür | Pull-out/door
15 | Auszug/Schubk./Tür | Pull-out/drawer/door
16 | Tür/Klappe | Door/flap
17 | Auszug/Schubk./Klappe | Pull-out/drawer/flap
18 | Schubkasten/Rollfront |
20 | ohne Front |
21 | 1 Becken o. Abtropfb. | 1 bowl without strainer bowl
22 | 1,5 Becken o. Abtropfb. | 1,5 bowls without strainer bowl
23 | 2 Becken o. Abtropfb. | 2 bowls without strainer bowl
24 | 1 Becken m. Abtropfb. | 1 bowl with strainer bowl
25 | 1,5 Becken m. Abtropfb. | 1,5 bowls with strainer bowl
26 | 2 Becken m. Abtropfb. | 2 bowls with strainer bowl
27 | Abtropfbereich | Strainer bowl
28 | 1 Becken m. Abfalls. | 1 bowl with rubbish container
29 | 1,5 Becken m. Abfalls. | 1,5 bowls with rubbish container
30 | 2 Becken m. Abfalls. | 2 bowls with rubbish container
31 | 1 Becken m. Abt.+Abf. | 1 bowl with strainer bowl and rubbish
32 | 1,5 Becken m. Abt.+Abf. | 1,5 bowls with strainer bowl and rubbish
33 | Abfall | Rubbish
36 | m. Rohrauslauf |
37 | m. Rohrauslauf vers./ab. |
38 | m. Schlauchbrause |
39 | m. Schlauchbr. vers./ab. |
41 | 1 Kochfläche | 1 ring
42 | 2 Kochflächen | 2 rings
43 | 3 Kochflächen | 3 rings
44 | 4 Kochflächen | 4 rings
45 | 5 Kochflächen | 5 rings
46 | 6 Kochflächen | 6 rings
47 | 7 Kochflächen | 7 rings
48 | 8 Kochflächen | 8 rings
49 | 9 Kochflächen | 9 rings


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Typenschlüssel- Arten
Ansicht mit Navigationswerkzeuge
Einleitung > Typenschlüssel- Arten
Art-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Normal | Normal
2 | Regal | Shelf
3 | Rahmen | Frame
4 | Seitenverkleidung | Side cladding
5 | Rückwandverkleidung | Rear cladding
6 | Frontblende | Front facing
7 | Dekorblende | Decorative facing
8 | Formwange | Shaped cheek
9 | Raumteiler | Room divider
10 | Unterbau | substructure
11 | Aufsatz | Cap
14 | Paßstück | Filler
15 | Blende | Baffle
16 | Umbau |
17 | Modul-Umbauschrank |
19 | Einlegeboden | Shelf
21 | Barplatte | Bar top
22 | Ansetztisch | Fixed table
26 | Pilaster | Pilaster
27 | Stollen |
28 | Paneel | Panel
29 | Bord/Konsole | Board/table
30 | Reling | Rail
32 | Einhebelmischer |
33 | Zweigriffarmatur |
34 | Sonstige Armaturen |
36 | Umluft |
37 | Abluft |
40 | Zubehör | Accessory


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Informationsschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Informationsschlüssel

Eigenschaft-Nr.

Bezeichnung

Beschreibung

Maßeinheit

Wertangabe

Information für Waschmaschinen

100

RATED_CAPACITY

Nennkapazität in kg Baumwolle für das Standardprogramm „Baumwolle 60 °C“ oder das Standardprogramm

„Baumwolle 40 °C“, jeweils bei vollständiger Befüllung, wobei der geringere der beiden Werte maßgeblich ist

kg

numerisch

101

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse gemäß Tabelle 1

A+++ … D

102

WEIGHTED_ANNUAL_ENERGY_CONSUMPTION

gewichteter jährlicher Energieverbrauch (AE C ) in kWh/Jahr, auf die nächste Ganzzahl aufgerundet. Dieser ist anzugeben als: Energieverbrauch von ‚X‘ kWh/Jahr auf der Grundlage von 220 Standard-Waschzyklen für 60 °C- und 40 °C- Baumwollprogramme bei vollständiger Befüllung und Teilbefüllung sowie dem Verbrauch der Betriebsarten mit geringer Leistungsaufnahme. Der tatsächliche Energieverbrauch hängt von der Art der Nutzung des Geräts ab.

kWh per year

numerisch

103

ENERGY_CONSUMPTION

Energieverbrauch (E t,60 , E t,60½ , E t,40½ ) des Standardprogramms „Baumwolle 60 °C“ bei vollständiger Befüllung und Teilbefüllung sowie des Standardprogramms „Baumwolle 40 °C“ bei Teilbefüllung

kWh

numerisch

104

WEIGHTED_POWER_CONSUMPTION_OFF

gewichtete Leistungsaufnahme im Aus-Zustand

W

numerisch

105

WEIGHTED_POWER_CONSUMPTION_ON

gewichtete Leistungsaufnahme im unausgeschalteten Zustand

W

numerisch

106

WEIGHTED_ANNUAL_WATER_CONSUMPTION

gewichteter jährlicher Wasserverbrauch (AW C ) in Liter/Jahr, auf die nächste Ganzzahl aufgerundet. Dieser ist anzugeben als: Wasserverbrauch von ‚X‘ Liter/Jahr auf der Grundlage von 220 Standard-Waschzyklen für 60 °C- und 40 °C-Baumwollprogramme bei vollständiger Befüllung und Teilbefüllung. Der tatsächliche Wasserverbrauch hängt von der Art der Nutzung des Geräts ab.

litres per year

numerisch

107

SPIN_DRYING_EFFICIENCY_CLASS

Schleudereffizienzklasse, ermittelt gemäß Tabelle 2 und ausgedrückt als Schleudereffizienzklasse ‚X‘ auf einer Skala von G (geringste Effizienz) bis A (höchste Effizienz). Von dieser Darstellungsweise kann abgewichen werden, sofern deutlich wird, das die Skala von G (geringste Effizienz) bis A (höchste Effizienz) reicht

A … G

108

MAX_SPIN_SPEED

maximale Schleuderdrehzahl beim Standardprogramm „Baumwolle 60 °C“ bei vollständiger Befüllung oder beim Standardprogramm „Baumwolle 40 °C“ bei Teilbefüllung, wobei der niedrigere Wert maßgeblich ist, sowie Restfeuchte beim Standardprogramm „Baumwolle 60 °C“ bei vollständiger Befüllung oder beim Standardprogramm „Baumwolle 40 °C“ bei Teilbefüllung, wobei der höhere Wert maßgeblich ist

revolutions per minute

numerisch

109

INDICATION_STANDARD

Hinweise auf den Umstand, dass die Standardprogramme „Baumwolle 60 °C“ und „Baumwolle 40 °C“ die Standard- Waschprogramme sind, auf die sich die Informationen auf dem Etikett und im Datenblatt beziehen, dass diese Programme zur Reinigung normal verschmutzter Baumwollwäsche geeignet und in Bezug auf den kombinierten Energie- und Wasserverbrauch am effizientesten sind

Zeichenfolge ST oder leer

110

PROGRAMME_TIME

Programmdauer des Standardprogramms „Baumwolle 60 °C“ bei vollständiger Befüllung und Teilbefüllung sowie des Standardprogramms „Baumwolle 40 °C“ bei Teilbefüllung in Minuten, auf die nächstliegende Minute gerundet

min

numerisch

111

DURATION_LEFT_ON_MODE

Dauer des unausgeschalteten Zustands (T l ), falls die Haushaltswaschmaschine mit Leistungssteuerung ausgerüstet ist

min

numerisch

112

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Luftschallemissionen in dB(A) re 1 pW, auf die nächstliegende Ganzzahl gerundet, beim Waschen und Schleudern im Standardprogramm „Baumwolle 60 °C“ bei vollständiger Befüllung

dB

numerisch

Information für Geschirrspüler

120

RATED_CAPACITY

Nennkapazität in Standardgedecken für den Standardreinigungszyklus

Anzahl

numerisch

121

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse gemäß Tabelle 3

A+++ … D

122

ANNUAL_ENERGY_CONSUMPTION

jährlicher Energieverbrauch (AE C ) in kWh/Jahr, auf die nächste Ganzzahl aufgerundet. Dieser ist anzugeben als Energieverbrauch ‚X‘ kWh/Jahr auf der Grundlage von 280 Standardreinigungszyklen bei Kaltwasserbefüllung und dem Verbrauch der Betriebsarten mit geringer Leistungsaufnahme. Der tatsächliche Energieverbrauch hängt von der Art der Nutzung des Geräts ab.

kWh per year

numerisch

123

ENERGY_CONSUMPTION

Energieverbrauch (E t ) des Standardreinigungszyklus

kWh

numerisch

124

POWER_CONSUMPTION_OFF

gewichtete Leistungsaufnahme im Aus-Zustand

W

numerisch

125

POWER_CONSUMPTION_ON

gewichtete Leistungsaufnahme im unausgeschalteten Zustand

W

numerisch

126

WEIGHTED_ANNUAL_WATER_CONSUMPTION

gewichteter jährlicher Wasserverbrauch (AW C ) in Liter/Jahr, auf die nächste Ganzzahl aufgerundet. Dieser ist anzugeben als: Wasserverbrauch ‚X‘ Liter/Jahr, auf der Grundlage von 280 Standardreinigungszyklen. Der tatsächliche Wasserverbrauch hängt von der Art der Nutzung des Geräts ab.

litres per year

numerisch

127

DRYING_EFFICIENCY_CLASS

Trocknungseffizienzklasse, ermittelt gemäß Tabelle4 und ausgedrückt als Trocknungseffizienzklasse ‚X‘ auf einer Skala von G (geringste Effizienz) bis A (höchste Effizienz). Erfolgt die Angabe in Tabellenform, kann von dieser Darstellung abgewichen werden, sofern deutlich wird, dass die Skala von G (geringste Effizienz) bis A (höchste Effizienz) reicht.

A … G

128

INDICATION_STANDARD

Hinweise auf den Umstand, dass das „Standardprogramm“ der Reinigungszyklus ist, auf den sich die Informationen auf dem Etikett und im Datenblatt beziehen, dass dieses Programm zur Reinigung normal verschmutzten Geschirrs geeignet und in Bezug auf den kombinierten Energie- und Wasserverbrauch am effizientesten ist

Zeichenfolge ST oder leer

129

PROGRAMME_TIME

Programmdauer des Standardreinigungszyklus in Minuten, auf die nächstliegende Ganzzahl gerundet

min

numerisch

130

DURATION_LEFT_ON_MODE

Dauer des unausgeschalteten Zustands (T l ), falls der Haushaltsgeschirrspüler mit Leistungssteuerung ausgerüstet ist

min

numerisch

131

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Luftschallemissionen in dB(A) re 1 pW, auf die nächstliegende Ganzzahl gerundet

dB

numerisch

Information für Wäschetrocknern

140

RATED_CAPACITY

Nennkapazität in kg Baumwollwäsche für das Standard-Baumwollprogramm bei vollständiger Befüllung

kg

numerisch

141

TUMBLE_KIND

ob es sich bei dem Haushaltswäschetrockner um einen Abluft-, Kondensations- oder gasbeheizten Haushaltswäschetrockner handelt

Zeichen A, C oder G

142

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse gemäß Tabelle 5

A+++ … D

143

WEIGHTED_ANNUAL_ENERGY_CONSUMPTION

für elektrisch beheizte Haushaltswäschetrockner:

gewichteter jährlicher Energieverbrauch (AE c ) auf eine Dezimalstelle aufgerundet. Dieser ist anzugeben als: Energieverbrauch von ‚X‘ kWh/Jahr auf der Grundlage von 160 Trocknungszyklen für das Standard-Baumwollprogramm bei vollständiger Befüllung und Teilbefüllung sowie des Verbrauchs der Betriebsarten mit geringer Leistungsaufnahme. Der tatsächliche Energieverbrauch je Zyklus hängt von der Art der Nutzung des Geräts ab.

für gasbeheizte Haushaltswäschetrockner:

gewichteter jährlicher Energieverbrauch (AE C(Gas) ), auf eine Dezimalstelle aufgerundet. Dieser ist anzugeben als: Energieverbrauch von ‚X‘ kWh-Gas/Jahr auf der Grundlage von 160 Trocknungszyklen für das Standard-Baumwollprogramm bei vollständiger Befüllung und Teilbefüllung. Der tatsächliche Energieverbrauch je Zyklus hängt von der Art der Nutzung des Geräts ab.

und

gewichteter jährlicher Energieverbrauch (AE C(Gas)el ), auf eine Dezimalstelle aufgerundet.Dieser ist anzugeben als: Energieverbrauch von ‚X‘ kWh/Jahr auf der Grundlage von 160 Trocknungszyklen für das Standard-Baumwollprogramm bei vollständiger Befüllung und Teilbefüllung sowie des Verbrauchs der Betriebsarten mit geringer Leistungsaufnahme. Der tatsächliche Energieverbrauch je Zyklus hängt von der Art der Nutzung des Geräts ab.

kWh per year

numerisch

144

AUTOMATIC

ob es sich bei dem Haushaltswäschetrockner um einen „Wäschetrockner mit Automatik“ oder einen „Wäschetrockner ohne Automatik“ handelt

1=true
0=false

145

ENERGY_CONSUMPTION

Energieverbrauch (E dry , E dry½ , Eg dry , Eg dry½ , Eg dry,a , Eg dry½,a ) des Standard-Baumwollprogramms bei vollständiger Befüllung und Teilbefüllung

kWh

numerisch

146

POWER_CONSUMPTION_OFF

Leistungsaufnahme im Aus-Zustand (P o ) für das Standard-Baumwollprogramm bei vollständiger Befüllung

W

numerisch

147

POWER_CONSUMPTION_ON

Leistungsaufnahme im nichtausgeschalteten Zustand (P l ) für das Standard-Baumwollprogramm bei vollständiger Befüllung

W

numerisch

148

DURATION_LEFT_ON_MODE

Dauer des unausgeschalteten Zustands, falls der Haushaltswäschetrockner mit Leistungssteuerung ausgerüstet ist

min

numerisch

149

INDICATION_STANDARD

Hinweise auf den Umstand, dass das „Standard-Baumwollprogramm“ bei vollständiger Befüllung und Teilbefüllung das Standardtrocknungsprogramm ist, auf das sich die Informationen auf dem Etikett und im Datenblatt beziehen, dass dieses Programm zum Trocknen normaler nasser Baumwolltextilien geeignet und in Bezug auf den Energieverbrauch für Baumwolle am effizientesten ist

Zeichenfolge ST oder leer

150

WEIGHTED_PROGRAMME_TIME

gewichtete Programmdauer (T t ) des „Standard-Baumwollprogramms bei vollständiger Befüllung und Teilbefüllung“ in Minuten, auf die nächste ganze Minute auf- oder abgerundet

min

numerisch

151

WEIGHTED_PROGRAMME_TIME

Programmdauer des „Standard-Baumwollprogramms bei vollständiger Befüllung“ (T dry ) in Minuten, auf die nächste ganze Minute auf- oder abgerundet

min

numerisch

152

WEIGHTED_PROGRAMME_TIME

Programmdauer des „Standard-Baumwollprogramms bei Teilbefüllung“ (T dry½ ) in Minuten, auf die nächste ganze Minute auf- oder abgerundet

min

numerisch

153

CONDENSATION_EFFICIENCY

falls der Haushaltswäschetrockner ein Kondensationswäschetrockner ist, die Kondensationseffizienzklasse gemäß Tabelle 6 und ausgedrückt als „Kondensationseffizienzklasse ‚X‘ auf einer Skala von G (geringste Effizienz) bis A (höchste Effizienz)“; von dieser Darstellungsweise kann abgewichen werden, sofern deutlich wird, dass die Skala von G (geringste Effizienz) bis A (höchste Effizienz) reicht

A … G

154

AVERAGE_CONDENSATION_EFFICIENCY

falls der Haushaltswäschetrockner ein Kondensationswäschetrockner ist, die durchschnittliche Kondensationseffizienz C dry und C dry½ des Standard-Baumwollprogramms bei vollständiger Befüllung und Teilbefüllung und die gewichtete Kondensationseffizienz (C t ) für das „Standard-Baumwollprogramm bei vollständiger Befüllung und Teilbefüllung“ als Prozentsatz, auf das nächste ganze Prozent auf- oder abgerundet

%

numerisch

155

SOUND_POWER_LEVEL

Schallleistungspegel (gewichteter Durchschnittswert — L WA ) in dB, auf die nächste Ganzzahl auf- oder abgerundet, für das Standard-Baumwollprogramm bei vollständiger Befüllung

dB

numerisch

Information für kombinierte Wasch-Trockenautomaten

160

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse des Modells gemäß Tabelle 7 ausgedrückt als „ Energieeffizienzklasse . . . auf einer Skala von A (niedriger Energieverbrauch) bis G (hoher Energieverbrauch)". Erfolgt die Angabe in Tabellenform, kann von dieser Darstellung abgewichen werden, sofern deutlich wird, dass die Skala von A (niedriger Energieverbrauch) bis G (hoher Energieverbrauch) reicht.

A … G

161

ENERGY_CONSUMPTION

Energieverbrauch in kWh pro vollständigem Betriebszyklus (Waschen, Schleudern und Trocknen )

kWh

numerisch

162

ENERGY_CONSUMPTION_W_D_ONLY

Energieverbrauch in kWh nur für Wasch- und Schleuderprogramm

kWh

numerisch

163

WASHING_PERFORMANCE

Waschwirkungsklasse gemäß Tabelle 8, ausgedrückt als „Waschwirkungsklasse . . . auf einer Skala von A (besser) bis G schlechter)". Von dieser Darstellungsweise kann abgewichen werden, sofern deutlich wird, dass die Skala von A (besser) bis G (schlechter) reicht.

A … G

164

WATER_EXTRACTION_EFFICIENCY

Schleuderwirkung beim Standardprogramm „ Baumwolle 60 °C ", ausgedrückt als „ nach dem Schleudervorgang verbleibende Restfeuchte ...% (Anteil am Trockengewicht der Wäsche )"

%

numerisch

165

MAX_SPIN_SPEED

maximale Schleuderdrehzahl beim Standardprogramm „Baumwolle 60 °C“

revolutions per minute

numerisch

166

WASH_CAPACITY

Füllmenge (Waschen ) des Gerätes beim Standardprogramm „Baumwolle 60 °C"

kg

numerisch

167

DRY_CAPACITY

Füllmenge (Trocknen) des Gerätes beim Standardprogramm „Baumwolle, schranktrocken"

kg

numerisch

168

WATER_CONSUMPTION

Wasserverbrauch in 1 pro vollständigen Betriebszyklus (Waschen, Schleudern und Trocknen )

litres

numerisch

169

WATER_CONSUMPTION_W_D_ONLY

Wasserverbrauch in 1 nur für Waschen und Schleudern beim Standardprogramm „ Baumwolle 60 °C "

litres

numerisch

170

WASHING_DRYING_TIME

Wasch- und Trockenzeit: Dauer des vollständigen Betriebszyklus (Waschen, Schleudern und Trocknen )bei Verwendung des Standardprogramms „Baumwolle 60 °C " und des Trockenprogramms „ Baumwolle, schranktrocken " bei Nennfüllmenge

min

numerisch

171

ENERGY_WATER_CONSUMPTION

Energie- und Wasserverbrauch ausgehend von 200 Standardzyklen , ausgedrückt als geschätzter Jahresverbrauch eines Vier-Personen-Haushalts, der diesen Wasch-Trockenautomaten immer zum Trocknen verwendet ( 200 Programme )

kWh

numerisch

172

NOISE_EMISSION

Geräuschemissionen während des Wasch-, Schleuder- und TrockenVorgangs beim Standardprogramm „Baumwolle 60 °C" und „Baumwolle, schranktrocken",

dB

numerisch

Information für Kühlgeräte

180

CATEGORY

Kategorie des Haushaltskühlgerätemodells gemäß Tabelle 9 und 10

numerisch

1 … 10

181

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse des Modells gemäß Tabelle 11

A+++ … G

182

ANNUAL_ENERGY_CONSUMPTION

jährlicher Energieverbrauch (AE C ) in kWh/Jahr gemäß Nummer 3 (2) von Anhang VIII, aufgerundet auf die nächste Ganzzahl. Er ist anzugeben als: Energieverbrauch ‚XYZ‘ kWh/Jahr, auf der Grundlage von Ergebnissen der Normprüfung über 24 Stunden. Der tatsächliche Verbrauch hängt von der Nutzung und vom Standort des Geräts ab.

kWh per year

numerisch

183

STORAGE_VOLUMNE

Nutzinhalt jedes Fachs und gegebenenfalls anwendbare Sternekennzeichnung gemäß Summe der Nutzinhalte aller Gefrierfächer, die eine Stern-Einstufung haben (d. h. mit einer Betriebstemperatur ≤ – 6 °C), gerundet auf die nächste Ganzzahl, und Stern-Einstufung des Fachs mit dem höchsten Anteil an dieser Summe; weist das Haushaltskühlgerät keine Gefrierfächer auf, gibt der Lieferant statt eines Werts „– L“ an und lässt die Position für die Stern-Einstufung leer

litres

numerisch

184

DESIGN_TEMPERATURE

Auslegungstemperatur „sonstiger Fächer“ im Sinne von Anhang I Buchstabe n. Bei Weinlagerfächern ist die niedrigste Lagertemperatur anzugeben, die entweder für das Fach voreingestellt ist oder vom Endnutzer gemäß Herstelleranweisungen eingestellt werden kann und dauerhaft aufrechterhalten wird

°C

numerisch

185

FROST_FREE

Angabe „Frostfrei“ für das betreffende Fach/die betreffenden Fächer, die kein Weinlagerfach sind und für die Lagerung bestimmter Lebensmittel bei einer höheren Temperatur als + 14 °C vorgesehen sind

Fach von unten gezählt

numerisch

186

TEMPERATURE_RISE_TIME

„Lagerzeit bei Störung ‚X‘ h“, definiert als „Temperaturanstiegszeit“

h

numerisch

187

FREEZING_CAPACITY

„Gefriervermögen“ in kg/24 h

kg/24 h

numerisch

188

CLIMATE_CLASS

„Klimaklasse“ gemäß Tabelle 12, angegeben als: Klimaklasse: W [Klimaklasse]. Dieses Gerät ist für den Betrieb bei einer Umgebungstemperatur zwischen ‚X‘ [niedrigste Temperatur] °C und ‚X‘ [höchste Temperatur] °C bestimmt.

SN, N, ST oder T

189

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Luftschallemissionen in dB(A) re 1 pW, auf die nächstliegende Ganzzahl gerundet

dB

numerisch

190

WINE_ONLY

für Weinschränke ist die folgende Angabe zu machen: „Dieses Gerät ist ausschließlich zur Lagerung von Wein bestimmt.“ Dies gilt weder für Haushaltskühlgeräte, die nicht speziell für die Weinlagerung ausgelegt sind, aber dennoch für diesen Zweck verwendet werden können, noch für Haushaltskühlgeräte, die über ein Weinlagerfach in Kombination mit einem Fach anderer Art verfügen.

1=true

0=false

Information für Backöfen

200

NUMBER_CAVITY

die Zahl der Garräume

Anzahl

numerisch

201

ENERGY_EFFICIENCY_INDEX

der Energieeffizienzindex (EEIcavity) für den ersten Garraum des Modells, die erste Dezimalstelle gerundet

numerisch

202

ENERGY_EFFICIENCY_CLASS

die Energieeffizienzklasse des Modells für den ersten Garraum gemäß Tabelle 13

A+++ … D

203

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den ersten Garraum im konventionellen Modus soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

204

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den ersten Garraum im Umluft-Modus, soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

205

HEAT_SOURCE_CAVITY

die Wärmequelle des ersten Garraums

E oder G

206

VOLUMNE_ CAVITY

das Volumen des ersten Garraums

litres

numerisch

207

ENERGY_EFFICIENCY_INDEX

der Energieeffizienzindex (EEIcavity) für den zweiten Garraum des Modells, die erste Dezimalstelle gerundet

208

ENERGY_EFFICIENCY_CLASS

die Energieeffizienzklasse des Modells für den zweiten Garraum gemäß Tabelle 13

A+++ … D

209

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den zweiten Garraum im konventionellen Modus, soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

210

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den zweiten Garraum im Umluft-Modus, soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

211

HEAT_SOURCE_CAVITY

die Wärmequelle für den zweiten Garraum

E oder G

212

VOLUMNE_ CAVITY

das Volumen den zweiten Garraums

litres

numerisch

213

ENERGY_EFFICIENCY_INDEX

der Energieeffizienzindex (EEIcavity) für den dritten Garraum des Modells, die erste Dezimalstelle gerundet

numerisch

214

ENERGY_EFFICIENCY_CLASS

die Energieeffizienzklasse des Modells für den dritten Garraum gemäß Tabelle 13

A+++ … D

215

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den dritten Garraum im konventionellen Modus, soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

216

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den dritten Garraum im Umluft-Modus, soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

217

HEAT_SOURCE_CAVITY

die Wärmequelle des dritten Garraums

E oder G

218

VOLUMNE_ CAVITY

das Volumen des dritten Garraums

litres

numerisch

Information für Dunstabzugshauben

220

ANNUAL_ENERGY_CONSUMPTION

der jährliche Energieverbrauch (AEC hood ) in kWh/Jahr, auf die erste Dezimalstelle gerundet

kWh per year

numerisch

221

ENERGY_EFFICIENCY_CLASS

die Energieeffizienzklasse gemäß Tabelle 14

A+++ … G

222

FLUID_DYNAMIC_EFFICIENCY

die berechnete fluiddynamische Effizienz (FDE hood ), auf die erste Dezimalstelle gerundet

numerisch

223

FLUID_DYNAMIC_EFFICIENCY_CLASS

die Klasse für die fluiddynamische Effizienz gemäß Tabelle 15

A … G

224

LIGHTING_EFFICIENCY

der berechnete Beleuchtungseffizienz (LE hood ) in lx/Watt, auf die erste Dezimalstelle gerundet

numerisch

225

LIGHTING _EFFICIENCY_CLASS

die Beleuchtungseffizienzklasse gemäß Tabelle 16; die angegebene Klasse darf nicht besser sein als die in der technischen Dokumentation vermerkte Klasse

A … G

226

GREASE_FILTERING_EFFICIENCY

der berechnete Fettabscheidegrad in Prozent, auf die erste Dezimalstelle gerundet. Der angegebene Wert darf nicht über dem in der technischen Dokumentation vermerkten Wert liegen.

%

numerisch

227

GREASE_FILTERING _EFFICIENCY_CLASS

die Klasse für den Fettabscheidegrad gemäß Tabelle 17

A … G

228

AIR_FLOW

der Luftstrom (in m 3 /h, auf die nächste ganze Zahl gerundet) bei minimaler und bei maximaler Geschwindigkeit im Normalbetrieb, ausgenommen den Betrieb auf der Intensivstufe oder Schnelllaufstufe

m³/h

numerisch

229

AIR_FLOW_INTENSIVE

gegebenenfalls der Luftstrom (in m 3 /h, auf die nächste ganze Zahl gerundet) im Betrieb auf der Intensivstufe oder Schnelllaufstufe

m³/h

numerisch

230

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

die A-bewerteten Luftschallemissionen (in dB, auf die nächste ganze Zahl gerundet) bei minimaler und maximaler verfügbarer Geschwindigkeit im Normalbetrieb

dB

numerisch

231

AIRBORNE_ACOUSTICAL_NOISE_EMISSION_INT

gegebenenfalls die A-bewerteten Luftschallemissionen (in dB, auf die nächste ganze Zahl gerundet) im Betrieb auf der Intensivstufe oder Schnelllaufstufe

dB

numerisch

232

POWER_CONSUMPTION_OFF

gegebenenfalls die Leistungsaufnahme im Aus-Zustand (P o ) in Watt, auf die zweite Dezimalstelle gerundet

W

numerisch

231

POWER_CONSUMPTION_ON

gegebenenfalls die Leistungsaufnahme im Bereitschaftszustand (P s ) in Watt, auf die zweite Dezimalstelle gerundet

W

numerisch

Information für elektrische Lampen und Leuchten

240

ENERGY_EFFICIENCY_CLASS

die Energieeffizienzklasse gemäß Tabelle 18

A++ … E

241

WEIGHTED_ENERGY_CONSUMPTION

gewichteter Energieverbrauch (EC) in kWh/1 000 Stunden auf die nächste Ganzzahl aufgerundet

kWh per 1000 hours

numerisch

242

ENERGY_EFFICIENCY_CLASS_COMPATIBILITY

Energieeffizienzklassen der vom Nutzer austauschbaren Lampen, mit denen die Leuchte gemäß den Anforderungen an die Kompatibilität nach dem Stand der Technik kompatibel ist

A++ … E

243

ENERGY_EFFICIENCY_CLASS_N_COMPATIBILITY

Energieeffizienzklassen von Lampen, mit denen die Leuchte gemäß den Anforderungen an die Kompatibilität nach dem Stand der Technik nicht kompatibel ist

A++ … E

244

ENERGY_EFFICIENCY_CLASS_LED

Energieeffizienzklassen für LED-Module, die nicht dafür bestimmt sind, vom Endnutzer entfernt zu werden

A++ … E

245

ENERGY_EFFICIENCY_CLASS_INCLUDED

Energieeffizienzklassen für Leuchte, die mit Lampen betrieben wird, die vom Endnutzer ausgetauscht werden können, und in der Verpackung der Leuchte enthalten sind

A++ … E

Information für Fernsehgeräte

260

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse des Modells gemäß Tabelle 19

A+++ … G

261

SCREEN_DIAGONAL_CM

sichtbare Bildschirmdiagonale in Zentimeter

cm

numerisch

262

SCREEN_DIAGONAL_INCH

sichtbare Bildschirmdiagonale in Zoll

inch

numerisch

263

POWER_CONSUMPTION_ON

Leistungsaufnahme im Ein-Zustand

W

numerisch

264

ANNUAL_ENERGY_CONSUMPTION

der berechnete jährliche Energieverbrauch in kWh/Jahr, gerundet auf die erste Ganzzahl. Dieser ist anzugeben als: Energieverbrauch XYZ kWh/Jahr, auf der Grundlage eines täglich vierstündigen Betriebs des Fernsehgeräts an 365 Tagen. Der tatsächliche Energieverbrauch hängt von der Art der Nutzung des Fernsehgerätes ab.

kWh per year

numerisch

265

POWER_CONSUMPTION_OFF

Leistungsaufnahme im Aus-Zustand

W

numerisch

266

POWER_CONSUMPTION_STANDBY

Leistungsaufnahme im Bereitschaftszustand

W

numerisch

267

SCREEN_RESOLUTION_HORIZONTAL

Bildschirmauflösung in physischer horizontaler Pixelzahl.

pt

numerisch

268

SCREEN_RESOLUTION_VERTICAL

Bildschirmauflösung in physischer vertikaler Pixelzahl.

pt

numerisch

Information für Heizgräte: 280 -300

Information für Luftkonditionierer: 300 -320

Information für Einzelraumheizgeräte:320-340

Information für Staubsauger: 340-360

Information für gewerbliche Kühllagerschränke: 360-380

Information für Wohnraumlüftungsgeräten: 380-400

Information für Festbrennstoffkesseln und Verbundanlagen einschl. Solareinrichtungen: 400-420

Die numerischen Angaben sind in nichtnegativer Form vorzunehmen. Es werden keinen Tausender Stellen gekennzeichnet. Dezimalstellen sind durch einen Punkt zu trennen.

Für die Werte 800 - 999 können freie Eigenschaften vergeben werden.

1. ENERGIEEFFIZIENZKLASSEN für Waschmaschinen

Die Energieeffizienzklasse einer Haushaltswaschmaschine wird auf der Grundlage ihres Energieeffizienzindex (EEI) gemäß Tabelle 1 ermittelt.

Der Energieeffizienzindex (EEI) einer Haushaltswaschmaschine wird gemäß Tabelle 1 ermittelt.

2. SCHLEUDEREFFIZIENZKLASSEN für Waschmaschinen

Die Schleudereffizienzklasse einer Haushaltswaschmaschine wird anhand der Restfeuchte (D) gemäß Tabelle 2 ermittelt.

3. ENERGIEEFFIZIENZKLASSEN für Geschirrspüler

Die Energieeffizienzklasse eines Haushaltsgeschirrspülers wird auf der Grundlage seines Energieeffizienzindex (EEI)

gemäß Tabelle 3 ermittelt.

4. TROCKNUNGSEFFIZIENZKLASSEN für Geschirrspüler

Tabelle 4

5. ENERGIEEFFIZIENZKLASSEN für Wäschetrockner

Die Energieeffizienzklasse eines Haushaltswäschetrockners wird auf der Grundlage seines Energieeffizienzindex (EEI) gemäß Tabelle 5 ermittelt.

Tabelle 5

6. KONDENSATIONSEFFIZIENZKLASSEN

Die Kondensationseffizienzklasse eines Kondensations-Haushaltswäschetrockners wird auf der Grundlage der gewichteten Kondensationseffizienz (C t ) gemäß Tabelle 6 ermittelt.

Tabelle 6

7. EFFIZIENZKLASSEN für kombinierte Wasch-Trockenautomaten

Tabelle 7: Effizienzklassen

Tabelle 8: Waschwirkungsklassen

8. EINSTUFUNG DER HAUSHALTSKÜHLGERÄTE

Die Haushaltskühlgeräte werden in Kategorien gemäß Tabelle 9 eingestuft.

Jede Kategorie ist durch eine bestimmte Fächerzusammensetzung gemäß Tabelle 10 bestimmt und unabhängig von der Zahl der Türen und/oder Schubladen.

Tabelle 9

Haushaltskühlgeräte, die aufgrund der Fächertemperatur nicht in die Kategorien 1 bis 9 eingestuft werden können, sind in Kategorie 10 einzustufen.

Tabelle 10

Haushaltskühlgeräte-Einstufung und Fächerzusammensetzung

9. EFFIZIENZKLASSEN für Kühlgeräte

Die Energieeffizienzklasse eines Haushaltswäschetrockners wird auf der Grundlage seines Energieeffizienzindex (EEI) gemäß Tabelle 5 ermittelt.

Tabelle 11

Tabelle 12

10. ENERGIEEFFIZIENZKLASSEN für Backöfen

Die Energieeffizienzklassen von Haushaltsbacköfen werden für jeden Garraum anhand der Werte in Tabelle 13 einzeln ermittelt.

11. EFFIZIENZKLASSEN für Dunstabzugshauben

Die Energieeffizienzklassen von Dunstabzugshauben anhand der Werte in Tabelle 14 ermittelt.

Die Klassen für die fluiddynamische Effizienz einer Haushaltsdunstabzugshabe werden anhand ihrer fluiddynamischen Effizienz (FDE hood ) gemäß folgender Tabelle 15 ermittelt.

Die Klassen für die Beleuchtungseffizienz einer Haushaltsdunstabzugshabe werden anhand ihrer Beleuchtungseffizienz (LE hood ) gemäß folgender Tabelle 16 ermittelt.

Die Klassen für den Fettabscheidegrad einer Haushaltsdunstabzugshabe werden anhand ihres Fettabscheidegrads (GFE hood ) gemäß folgender Tabelle 17 ermittelt

12. ENERGIEEFFIZIENZKLASSEN für Lampen

Tabelle 18: Energieeffizienzklassen

13. ENERGIEEFFIZIENZKLASSEN für Fernsehgeräte

Tabelle 19: Energieeffizienzklassen für Fernsehgeräte

Die Amtsblätter der EU zu den Verordnungen der Richtlinien sind unter folgenden Links zu finden:

http://www.newenergylabel.com/index.php/start/

http://ec.europa.eu/energy/sites/ener/files/documents/list_of_enegy_labelling_measures.pdf

Hier kann mehrsprachig zu den einzelnen Produktgruppen verzweigt werden.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Standardgrifflagen
Ansicht mit Navigationswerkzeuge
Einleitung > Standardgrifflagen

Standardgrifflage | Bezeichnung | Abbildung | Beschreibung
0 | Ohne Bohrung mit Griff |  | Gilt für alle Fronttypen
1 | Waagerecht mittig - Senkrecht außen |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
2 | Waagerecht mittig - Waagerecht außen |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
3 | Senkrecht mittig - Senkrecht außen |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
4 | Senkrecht mittig - Waagerecht außen |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
5 | Waagerecht mittig - Senkrecht mittig |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
6 | Waagerecht mittig - Waagerecht mittig |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
7 | Senkrecht mittig - Senkrecht mittig |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
8 | Senkrecht mittig - Waagerecht mittig |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
9 | Waagerecht Gesamtoben - Waagerecht Gesamtoben |  | Anordnung waagerecht oben über die gesamte Breite für: Schubkästen; Auszüge; Jalousien (horizontal). Anordnung waagerecht über die gesamte Breite für: Türen; Glastüren; Klappen; Rollfronten (vertikal).
10 | Waagerecht Gesamtunten - Waagerecht Gesamtoben |  | Anordnung waagerecht unten über die gesamte Breite für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Anordnung waagerecht über die gesamte Breite für: Türen; Glastüren; Rollfronten (vertikal).
11 | Waagerecht Gesamtoben - Senkrecht Gesamtaußen |  | Anordnung waagerecht oben über die gesamte Breite für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Anordnung senkrecht außen über die gesamte Höhe für: Türen; Glastüren; Rollfronten (vertikal).
12 | Waagerecht Gesamtunten - Senkrecht Gesamtaußen |  | Anordnung waagerecht unten über die gesamte Breite für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Anordnung senkrecht außen über die gesamte Höhe für: Türen; Glastüren; Rollfronten (vertikal).
90 | Keine Standardgrifflage passt |  |
91 | Keine Standardgrifflage passt |  |
92 | Keine Standardgrifflage passt |  |
93 | Keine Standardgrifflage passt |  |
94 | Keine Standardgrifflage passt |  |
95 | Keine Standardgrifflage passt |  |
96 | Keine Standardgrifflage passt |  |
97 | Keine Standardgrifflage passt |  |
98 | Keine Standardgrifflage passt |  |
99 | Ohne Bohrung ohne Griff |  |


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Grundformen
Ansicht mit Navigationswerkzeuge
Einleitung > Grundformen

Einleitung

In diesem Teil der Dokumentation des Integrierten Datenmodells werden die für den Datenaustausch notwendigen Grundformen beschrieben.

Bei den Grundformen handelt es sich um parametrisierte grafische Darstellungen. Beim Datenaustausch werden die Parameter mit den individuellen Werten übertragen, nicht die Grafik selbst. In den verarbeitenden Systemen wird anhand einer Grundform eindeutig zugeordneten Nummer und den mit Werten besetzten Parametern eine 3D-Grafik aufgebaut. Im IDM existieren Grundformen für Korpi, Platten und Tische, Fronten, Griffe sowie für Kranzleisten und Lichtblenden.

Allgemeine Hinweise zu Grundformen

Die Angabe der Grundform erfolgt im Element CARCASE_BASIC_SHAPE. Die Typisierung der Korpus- und Ansetztisch-Grundformen erfolgt anhand von Draufsichten auf das jeweilige Objekt. Die Abbildungen der Objekte werden mittels Wertzuweisung zu den einzelnen Parametern vollzogen. Die Maßzuordnung erfolgt auf der Basis von Millimeterangaben. Zur Veranschaulichung ist zu fast allen Grundformen ein perspektivisches Beispiel und ein Beispiel zur Parameterwertzuweisung gegeben.

Die dargestellten Grundformen gelten nur für Schränke/Holzteile und Arbeitsplatten, Lichtleisten, Kranzprofile etc. und nicht für Zubehör und Elektrogeräte. Für Zubehör und Elektro-geräte werden die Grundform Nr. 0 und Nr. 997 - Nr. 999 verwendet. Dabei steht für grafisch nicht relevante Artikel die Grundformnummer 0 zur Verfügung. Für Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap bereitstehen wird die Grundform Nr. 997 verwendet. Dabei ist jedoch sicherzustellen, dass die Felder SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO in ITEM gefüllt sind und Grafik-Informationen des Zulieferers bereitstehen. Bei Artikeln, die ausschließlich über eine Bitmap repräsentiert werden sollen, wird die Grundform Nr. 998 verwendet. Dabei ist sicherzustellen, dass die Felder FILE_NAME_TEXTURE_1/2 in ITEM gefüllt sind. Die Grundform Nr. 999 wird verwendet, wenn statt einer Grundform eine Echtgrafik mitgeliefert wird. Bei allen aufgeführten Grundformnummern (0 und 997 - 999) müssen, soweit vorhanden, die Werte b, h und t in den BASIC_SHAPE_PARAMETERS angelegt werden. Ausnahmen gibt es nur bei dimensionslosen Artikeln, wie z. B. Breitenkürzung.

Für die Füllstufen kleiner Füllstufe 3 ist die Grundformnummer 996 eingeführt worden. Grundformnummer 996 steht für einen grafisch relevanten Artikel, für den derzeit noch keine weiteren Angaben analog zu den Grundformen 997-999 geliefert werden können.

Maße für Breite, Höhe, Tiefe und Durchmesser ohne Indizes können als Stellmaße (Boundingbox) verwendet werden. Zur Unterscheidung wird bei Rundungen, die maßgeblich für Stellmaße sind, der Parameter „Durchmesser“ eingesetzt.

Da das Zeichen "α" als Parameter nicht zu verwenden ist, wird für die Winkelparameterangabe ein "a" verwendet.

Zur Definition von variablen Maßen besteht die Möglichkeit innerhalb von BASIC_SHAPE_PARAMETER, zusätzlich zum Nennmaß(BASIC_SHAPE_NOMINAL_VALUE ) Werte für den erlaubten Bereich („Von“(BASIC_SHAPE_FROM) „Bis“(BASIC_SHAPE_TO)) anzugeben. Um die Möglichkeit für symmetrische Längenänderungen vorzugeben, ist ein Objekt durch die Maße überbestimmt. Folgende Definitionen sind hierbei zu beachten:

Regel 1: Das Gesamtmaß ohne Index muss sich als Summe der Teilmaße ergeben.

Regel 2: Wird eine Maßvariabilität ausschließlich bei dem Gesamtmaß angegeben, werden alle Teilmaße symmetrisch angepasst.

Regel 3: Für das Gesamtmaß (ohne Indizes) gilt, sind keine "Von" und "Bis" Werte angegeben, so ist das Maß fix. Sind "Von" und "Bis" Werte angegeben, so ist das Maß in diesem Bereich variabel.

Regel 4: Wird die Möglichkeit der Maßvariabilität ausschließlich bei den Teilmaßen eingegeben, wird das Objekt nicht symmetrisch verändert, sondern die Summe der Teilmaße muss das Gesamtmaß ergeben.

Regel 5: Durch die Angabe von gleichen Werten in den Feldern "Von" und "Bis" können einzelne Teilmaße (nicht b, h, t) von der symmetrischen Anpassung ausgenommen werden (siehe Beispiel).

Regel 6: Für die Maße mit Indizes (Teilmaße) gilt, sind keine "Von" und "Bis" Werte angegeben, so wird das Maß angepasst (Symmetrische Verteilung, Ergänzung zum Gesamtmaß). Sind "Von" und "Bis" Werte angegeben, so ist das Maß in diesem Bereich variabel.

Die anzugebenden Maße beziehen sich auf die Korpusmaße, Frontstärken werden hier nicht berücksichtigt. Zur Orientierung sind bei den Korpi die Seiten mit Frontoberfläche durch eine doppelte Linie markiert. Diese repräsentiert sowohl Fronten, wie auch Regalöffnungen.

Für jede Grundform wurde die Ausrichtung durch die Darstellung der Wand definiert. Dadurch ergibt sich auch das Unterscheidungsmerkmal für die Grundformnummern 5 und 8 die primär für Solitär- oder Insellösungselemente gedacht sind. Dieses ergibt sich daraus, dass die einzig verplanbare Seite zur Wand hinzeigt.

Sondergeometrien können über Grundformen nicht abgebildet werden. Deshalb gibt es die Grundformnummern 997 - 999 für Artikel, die sich nicht über die abgebildeten Grundformen darstellen lassen. Für Artikel die grafisch nicht relevant sind, wird die Grundformnummer 0 verwendet.

In diesem Beispiel wird der Korpus bei der Eingabe eines Breitenmaßes von 700 mm bei der Breite 1 und der Breite 3 um jeweils 50 mm gegenüber dem Nennmaß vergrößert.

Die angegebenen CONSTRUCTION_ID beziehen sich auf die dargestellten Abbildungen. Wesentlich bei der CONSTRUCTION_ID = N ist, dass der Artikel symmetrisch ist. Durch Variation der Parameter kann ein dargestellter Artikel asymmetrisch werden. Dieses hat zur Folge, dass für diesen Artikel nicht mehr die CONSTRUCTION_ID = N verwendet werden darf. Es besteht nun die Möglichkeit, für jede Bauweise („L“ oder „R“) einen eigenen Artikel anzulegen oder einen Artikel mit der CONSTRUCTION_ID = J. Wird die CONSTRUCTION_ID = J verwendet, so müssen die Parameter für die Linke (CONSTRUCTION_ID „L“) angelegt werden.

Durch die Variation der Parameter dürfen bestimmte Randbedingungen bezüglich der Parallelität von Kanten zu anderen Kanten nicht verändert werden. Könnte dieser Fall auftreten, wird bei den entsprechenden Grundformen noch einmal explizit darauf hingewiesen.

Durch Festlegung eines „führenden“ Parameters soll herstellerübergreifend eine einheitliche Zuordnung zu einer linken bzw. rechten CONSTRUCTION_ID gewährleistet werden. Der führende Parameter wird an der jeweiligen Grundform aufgeführt. Für die Linke CONSTRUCTION_ID muss der Wert dieser Parameter auf der linken dargestellten Seite kleiner sein als der entsprechende Parameter auf der Rechten Seite. Siehe Beispiel unten.

Beispiel für asymmetrische Artikel Darstellung für die Grundform Nr. 4:

symmetrischer Artikel asymmetrischer Artikel asymmetrischer Artikel

mit CONSTRUCTION_ID=N mit CONSTRUCTION_ID=R mit CONSTRUCTION_ID=L

Parameter:

b1=b3 und t1=t2 b1<>b3 und t1<>t2 b1<>b3 und t1<>t2

Bei asymmetrischen Artikeln mit CONSTRUCTION_ID=J wird je nach Auswahl im Händlersoftwaresystem eine Bauweise rechts oder links erzeugt.

Durch Gleichsetzen entsprechender Parameter können Grundformen, die als Bauweise L und Bauweise R dargestellt werden, symmetrisch werden. Beispielsweise kann die Grundform 19 durch gleichsetzen der Parameter t = b und be = te mit der CONSTRUCTION_ID = N hinterlegt werden.

Grundformen die nur in CONSTRUCTION_ID = L und CONSTRUCTION_ID = R dargestellt sind, aber durch Gleichsetzen bestimmter Parameter auch die CONSTRUCTION_ID = N erhalten können haben ihren Referenzpunkt identisch mit der CONSTRUCTION_ID = L. Der Referenzpunkt ist in den Zeichnungen mit einem kleinen Kreis gekennzeichnet.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Grundformen für Korpi
Ansicht mit Navigationswerkzeuge
Einleitung > Grundformen > Grundformen für Korpi

Grundform 1

Parameter: b = Breite h = Höhe t = Tiefe Wertebereich für CONSTUCTION_ID: N L R

Beispiel:

b=600mm, h=720mm, t=560mm, CONSTRUCTION_ID=N

Grundform 2

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) t1=Tiefe1 Wertebereich für CONSTRUCTION_ID: J,L,R

Beispiel:

b=365mm, h=720mm, t=575mm, t1=401mm, CONSTRUCTION_ID=R

Grundform 3

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) b1=Breite1 t1=Tiefe1 Wertebereich für CONSTRUCTION_ID:N

Beispiel1:

b=365mm, h=590mm, t=560mm, t1=460mm, b1=365mm, CONSTRUCTION_ID=R

Beispiel2:

b=900mm, h=720mm, t=600mm, t1=560mm, b1=900mm, CONSTRUCTION_ID=R

Grundform 4

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) b1=Breite1 b2=Breite2 b3=Breite3 t1=Tiefe1 t2=Tiefe2 Wertebereich für CONSTRUCTION_ID:N,L,R,J

Beispiel:

b=600mm, h=720mm, t=365mm b1=120mm, b2=360mm, b3=120mm, t1=120mm, t2=120mm, CONSTRUCTION_ID=N

Anmerkungen:

Die Breiten 1-3 können durch Angaben in den Feldern „Von“ „Bis“ variabel definiert werden. Soll eine symmetrische Variabilität festgelegt werden, muss zusätzlich bei der Breite b ein Wert für die Felder „Von“ „Bis“ festgelegt werden.

CONSTRUCTION_ID = N nur wenn

b1 = b3, t1 = t2

b2 ist immer parallel zu b und es muss gelten

b = b1 + b2+ b3

Führende Parameter sind b1 und b3.

Grundform 5

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) b1=Breite1 b2=Breite2 b3=Breite3 t1=Tiefe1 t3=Tiefe3 Wertebereich für CONSTRUCTION_ID:N,L,R,J

Beispiel:

b=600mm, h=720mm, t=365mm b1=120mm, b2=360mm, b3=120mm, t1=120mm, t3=120mm, CONSTRUCTION_ID=N

Anmerkungen:

Primäre Verwendung als Solitärelement.

Die Breiten 1-3 können durch Angaben in den Feldern „Von“ „Bis“ variabel definiert werden. Soll eine symmetrische Variabilität festgelegt werden, muss zusätzlich bei der Breite b ein Wert für die Felder „Von“ „Bis“ festgelegt werden.

CONSTRUCTION_ID = N nur wenn b1 = b3, t1 = t3

b2 ist immer parallel zu b und es muss gelten

b = b1 + b2+ b3

Führende Parameter sind b1 und b3.

Grundform 6

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) b1=Breite1 b3=Breite3 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 Wertebereich für CONSTRUCTION_ID:L,R,J

Beispiel:

b=365mm, h=724mm, t=585mm b1=120mm, b3=120mm, t1=120mm, t2=360mm, t3=120mm, CONSTRUCTION_ID= R

Anmerkungen:

Die Tiefen 1-3 können durch Angaben in den Feldern „Von“ „Bis“ variabel definiert werden. Soll eine

symmetrische Variabilität festgelegt werden, muss zusätzlich bei der Tiefe b ein Wert für die Felder „Von“ „Bis“

festgelegt werden.

Es muss gelten t = t1 + t2+ t3.

Grundform 7

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) r1=Radius1 r2=Radius2 b1=Breite1 t1=Tiefe1 t2=Tiefe2 Wertebereich für CONSTUCTION_ID:N,L,R,J

Beispiel:

b=500mm, h=720mm, t=300mm, b1=350mm, t1=225mm, t2=225mm, r1=75mm, r2=75mm, CONSTRUCTION_ID=N

Anmerkungen:

CONSTRUCTION_ID = N nur wenn

t1 = t2, r1 = r2

b1 ist immer parallel zu b à t1+r1 = t2+r2 und es muss gelten

b = r1 + b1+ r2, t = t1 + r1 und t = t2 + r2

Führende Parameter sind r1 und r2.

Grundform 8

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) r1=Radius1 r2=Radius2 b1=Breite1 t1=Tiefe1 t2=Tiefe2 Wertebereich für CONSTRUCTION_ID:N,L,R,J

Beispiel:

b=500mm, h=720mm, t=300mm b1=350mm, t1=225mm, t2=225mm, r1=75mm, r2=75mm, CONSTRUCTION_ID=N

Anmerkungen:

Primäre Verwendung als Solitärelement.

Die perspektivischen Beispiele sind für die Korpusgrundformen 8 und 9 identisch. Die Korpusgrundformen unterscheiden sich lediglich in ihrer Ausrichtung zur Wand. CONSTRUCTION_ID = N nur wenn t1 = t2, r1 = r2

b1 ist immer parallel zu b à t1+r1 = t2+r2 und es muss gelten

b = r1 + b1+ r2, t = t1 + r1 und t = t2 + r2

Führende Parameter sind r1 und r2.

Grundform 9

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) r1=Radius1 r2=Radius2 b1=Breite1 b2=Breite2 t1=Tiefe1 Wertebereich für CONSTRUCTION_ID:L,R,J

Beispiel:

b=300mm, h=720mm, t=500mm b1=225mm, b2=225mm, t1=350mm, r1=75mm, r2=75mm, CONSTRUCTION_ID=J

Anmerkungen:

Die perspektivischen Beispiele sind für die Korpusgrundformen 8 und 9 identisch. Die Korpusgrundformen

unterscheiden sich lediglich in ihrer Ausrichtung zur Wand.

Es muss gelten

b = r1 + b1, b = b2 + r2 und t = t2 + r1+ r2

Grundform 10

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) b1=Breite1 t1=Tiefe1 Wertebereich für CONSTRUCTION_ID:N,L,R,J

Beispiel:

b=600mm, h=1900mm, t=560mm b1=300mm, t1=460mm, CONSTRUCTION_ID= N

Anmerkungen:

CONSTRUCTION_ID = N nur wenn

b1 = b/2

Führender Parameter ist b1.

Grundform 11

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) t1=Tiefe1 Wertebereich für CONSTRUCTION_ID:L,R,J

b=365mm, h=590mm, t=560mm, t1=460mm, CONSTRUCTION_ID= R

Grundform 12

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) b1=Breite1 b2=Breite2 b3=Breite3 t1=Tiefe1 Wertebereich für CONSTRUCTION_ID:L,R,J

Beispiel:

b=600mm, h=720mm, t=575mm, b1=150mm, b2=300mm, b3=150mm, t1=460mm, CONSTRUCTION_ID=R

Anmerkungen:

Die Breiten 1-3 können durch Angaben in den Feldern „Von“ „Bis“ variabel definiert werden. Soll eine

symmetrische Variabilität festgelegt werden, muss zusätzlich bei der Breite b ein Wert für die Felder „Von“ „Bis“

festgelegt werden.

Es muss gelten b = b1 + b2+ b3.

Grundform 13

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) b1=Breite1 b2=Breite2 b3=Breite3 t1=Tiefe1 Wertebereich für CONSTRUCTION_ID:L,R,J

Beispiel:

b=900mm, h=720mm, t=575mm, b1=175mm, b2=550mm, b3=175mm, t1=175mm, CONSTRUCTION_ID=L

Anmerkungen:

Die Breiten 1-3 können durch Angaben in den Feldern „Von“ „Bis“ variabel definiert werden. Soll eine

symmetrische Variabilität festgelegt werden, muss zusätzlich bei der Breite b ein Wert für die Felder „Von“ „Bis“

festgelegt werden.

Möglich sind die CONSTRUCTION_ID = L, R, J

Es muss gelten b = b1 + b2+ b3.

Grundform 14

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 b5=Breite5 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 Wertebereich für CONSTRUCTION_ID:N,L,R,J

Beispiel:

b=900mm, h=720mm, t=575mm, b1=175mm, b2=175mm, b3=200mm,b4=175mm, b5=175mm, t1=175mm, t2=400mm, t3=400mm, CONSTRUCTION_ID=N

Anmerkungen:

Die Breiten 1-5 können durch Angaben in den Feldern „Von“ „Bis“ variabel definiert werden. Soll eine

symmetrische Variabilität festgelegt werden, muss zusätzlich bei der Breite b ein Wert für die Felder „Von“ „Bis“

festgelegt werden.

CONSTRUCTION_ID = N nur wenn

b1 = b5, b2 = b4, t2 = t3

b1, b3 und b5 sind immer parallel zu b à b1+b2 = b4 und es muss gelten b = b1 + b2+ b3+ b4+ b5

Führende Parameter sind b1+b2 und b4+b5.

Grundform 15

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) b1=Breite1 b2=Breite2 b3=Breite3 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 Wertebereich für CONSTRUCTION_ID:N,L,R,J

Beispiel:

b=600mm, h=590mm, t=465mm, b1=150mm, b2=300mm, b3=150mm, t1=50mm, t2=50mm, t3=365mm, CONSTRUCTION_ID=N

Anmerkungen:

Die Breiten 1-3 können durch Angaben in den Feldern „Von“ „Bis“ variabel definiert werden. Soll eine

symmetrische Variabilität festgelegt werden, muss zusätzlich bei der Breite b ein Wert für die Felder „Von“ „Bis“

festgelegt werden.

CONSTRUCTION_ID = N nur wenn

b1 = b3

b1 und b3 sind immer parallel zu b.

Führende Parameter sind b1 und b3 und es muss gelten b = b1 + b2+ b3, t = t1 + t2+ t3 .

Grundform 16

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) be=Eckbreite b1=Breite1 te=Ecktiefe t1=Tiefe1 Wertebereich für CONSTRUCTION_ID:L,R,J

Beispiel:

b=365mm, h=720mm, t=575mm, te=0mm, be=0mm, t1=195mm, b1=195mm, CONSTRUCTION_ID=R

Anmerkungen:

auch CONSTRUCTION_ID = N wenn

b = t, b1 = t1, be = te

Grundform 17

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) be=Eckbreite te=Ecktiefe r=Radius Wertebereich für CONSTRUCTION_ID:L,R,J

Beispiel:

b=365mm, h=720mm, t=575mm, te=0mm, be=0mm, r=200mm, CONSTRUCTION_ID=R

Anmerkungen:

auch CONSTRUCTION_ID = N wenn

b = t, be = te

Grundform 18

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) be=Eckbreite b1=Breite1 te=Ecktiefe t1=Tiefe1 Wertebereich für CONSTRUCTION_ID:N,L,R,J

Beispiel:

b=900mm, h=720mm, t=900mm, te=0mm, be=0mm, b1=300mm, t1=300mm, CONSTRUCTION_ID=N

Anmerkungen:

Die primäre Verwendung dieser Grundform ist für Eckschränke vorgesehen.

auch CONSTRUCTION_ID = N wenn

b = t, be = te, b1 = t1

Grundform 19

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) be=Eckbreite te=Ecktiefe r=Radius Wertebereich für CONSTRUCTION_ID:N,L,R,J

Beispiel:

b=900mm, h=720mm, t=900mm, te=70mm, be=70mm, r=300mm, CONSTRUCTION_ID=N

Anmerkungen:

Die primäre Verwendung dieser Grundform ist für Eckschränke vorgesehen.

auch CONSTRUCTION_ID = N wenn

b = t, be = te

Grundform 20

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) be=Eckbreite te=Ecktiefe b1=Breite1 t1=Tiefe1 Wertebereich für CONSTRUCTION_ID:N,L,R,J

Beispiel:

b=900mm, h=720mm, t=900mm, te=0mm, be=0mm, b1=600mm, t1=600mm,CONSTRUCTION_ID=N

Anmerkungen:

Die primäre Verwendung dieser Grundform ist für Eckschränke vorgesehen.

auch CONSTRUCTION_ID = N wenn

b = t, be = te, b1 = t1

Grundform 21

Parameter: b=Breite(Korpus) h=Höhe t=Tiefe(Korpus) be=Eckbreite te=Ecktiefe b1=Breite1 b2=Breite2 b3=Breite3 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 Wertebereich für CONSTRUCTION_ID:N,L,R,J

Beispiel:

b=900mm, h=720mm, t=900mm, te=0mm, be=0mm, b1=600mm, b2=150mm, b3=150mm t1=150mm, t2=150mm, t3=600mm, CONSTRUCTION_ID=N

Anmerkungen:

Die primäre Verwendung dieser Grundform ist für Eckschränke vorgesehen.

auch CONSTRUCTION_ID = N wenn

b = t, be = te, b1 = t3, b3 = t1, b2 = t2

b muss gleich b1+b2+b3 sein und t=t1+t2+t3

Grundform 22

Parameter: b=Breite h=Höhe t=Tiefe be=Eckbreite te=Ecktiefe b1=Breite1 b2=Breite2 t1=Tiefe1 t2=Tiefe2 r=Radius Wertebereich für CONSTRUCTION_ID:N,L,R,J

b=900mm, h=720mm, t=900mm, te=0mm, be=0mm, b1=600mm, b2=250mm, t1=250mm, t2=600mm, r=50mm, CONSTRUCTION_ID=N

Anmerkungen:

Die primäre Verwendung dieser Grundform ist für Eckschränke vorgesehen.

auch CONSTRUCTION_ID = N wenn

b = t, be = te, b1 = t2, b2 = t1

b muss gleich b1+r+b2 sein und t=t1+t2+r

Grundform 23

Parameter: b=Breite h=Höhe t=Tiefe be=Eckbreite te=Ecktiefe b1=Breite1 b2=Breite2 t1=Tiefe1 t2=Tiefe2 r=Radius Wertebereich für CONSTRUCTION_ID:N,L,R,J

b=900mm, h=720mm, t=900mm, te=0mm, be=0mm, b1=600mm, b2=100mm, t1=100mm, t2=600mm, r=200mm, CONSTRUCTION_ID=N

Anmerkungen:

Die primäre Verwendung dieser Grundform ist für Eckschränke vorgesehen.

auch CONSTRUCTION_ID = N wenn

b = t, be = te, b1 = t2, b2 = t1

b muss gleich b1+r+b2 sein und t=t1+t2+r

Grundform 24

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 t1=Tiefe1 t2=Tiefe2 a=Winkelα Wertebereich für CONSTRUCTION_ID:N,L,R,J

Passstück [image] Profil des Passstückes

b=90mm, h=720mm, t=67mm, b1=14mm, b2=14mm, b3=57mm, b4=57mm, t1=380mm, t2=380mm, a=135°, CONSTRUCTION_ID=N

b=900mm, h=720mm, t=670mm, b1=140mm, b2=140mm, b3=570mm, b4=570mm, t1=380mm, t2=380mm, a=135mm, CONSTRUCTION_ID=N

Anmerkungen:

auch CONSTRUCTION_ID = N wenn

b = t, t1 = t2, b1 = b2, b3 = b4 und a = 135°

Grundform 25

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 t1=Tiefe1 t2=Tiefe2 a=Winkelα Wertebereich für CONSTRUCTION_ID:N,L,R,J

b=900mm, h=720mm, t=670mm, te=0mm, b1=140mm, b2=140mm, b3=570mm, b4=570mm, t1=380mm, t2=380mm, a=135mm, CONSTRUCTION_ID=N

Anmerkungen:

auch CONSTRUCTION_ID = N wenn

b = t, t1 = t2, b1 = b2, b3 = b4 und a = 135°

Grundform 26

Parameter: b=Breite h=Höhe(gesamt) t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 t1=Tiefe1 t2=Tiefe2 h1=Höhe Schränke Wertebereich für CONSTRUCTION_ID:N

b=1100mm, h=560mm, t=1100mm, b1=1555mm, b2=400mm, b3=600mm, b4=400mm, t1=300mm, t2=400mm, h1=590mm, CONSTRUCTION_ID=N

Anmerkungen:

b muss gleich t sein.

Grundform 27

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 t1=Tiefe1 Wertebereich für CONSTRUCTION_ID:L,R,J

b=1300mm, h=720mm, t=700mm, b1=600mm, b2=600mm, b3=750mm, t1=600mm, CONSTRUCTION_ID=R

Anmerkungen:

Eine Frontaufteilung bezieht sich auf die Fläche, die durch den Parameter b2 charakterisiert wird.

Grundform 28

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) b1=Breite1 b2=Breite2 h1=Höhe1 h2=Höhe2 Wertebereich für CONSTRUCTION_ID:L,R,J

b=1100mm, h=720mm, t=700mm, b1=500mm, b2=600mm, h1=500mm, h2=220mm, CONSTRUCTION_ID=L

Grundform 29

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) b1=Breite1 b2=Breite2 h1=Höhe1 h2=Höhe2 Wertebereich für CONSTRUCTION_ID: N

b=900mm, h=715mm, t=450mm, b1=0mm, b2=450mm, h1=615mm, h2=100mm, CONSTRUCTION_ID=N

b=900mm, h=715mm, t=450mm, b1=400mm, b2=250mm, h1=615mm, h2=100mm, CONSTRUCTION_ID=N

Anmerkungen:

b2 muss gleich (b-b1)/2 sein.

Grundform 30

Parameter: b=Breite h=Höhe t=Tiefe(Korpus) h1=Höhe1 h2=Höhe2 h3=Höhe3 t1=Tiefe1 t3=Tiefe3 Wertebereich für CONSTRUCTION_ID: N

b=600mm, h=715mm, t=365mm, h1=0mm, h2=515mm, h3=200mm, t1=365mm, t3=150mm CONSTRUCTION_ID=N

Anmerkungen:

h muss gleich h1+h2+h3 sein.

Grundform 51

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 Wertebereich für CONSTRUCTION_ID: L,R

Beispiel:

b=600mm, h=50mm, t=1200mm, b1=200mm, b2=400mm, b3=500mm, CONSTRUCTION_ID=N

Anmerkungen:

wird eingesetzt, wenn bis zum Abschluss einer Wand ein Passstück verwendet wird.

Anstelle eines Passstückes reicht eine Tür (Parameter 1) bis zur Wand.

Grundform 52

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 Wertebereich für CONSTRUCTION_ID: L,R

Anmerkungen:

wird eingesetzt, wenn bis zum Abschluss einer Wand kein Passstück verwendet wird.

Anstelle eines Passstückes reicht Korpusmaterial oder ggf.eine Sichtseite (Parameter 1) bis zur Wand.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Grundformen für Platten und Tische
Ansicht mit Navigationswerkzeuge
Einleitung > Grundformen > Grundformen für Platten und Tische

Grundform 31

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 t4=Tiefe4 Wertebereich für CONSTRUCTION_ID: N,L,R,J

b=1200mm, h=40mm, t=1200mm, b1=250mm, b2=250mm, b3=250mm, b4=250mm, t1=250mm, t2=250mm, t3=250mm, t4=250mm, CONSTRUCTION_ID=N

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

CONSTRUCTION_ID = N nur wenn

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Grundform 32

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 t4=Tiefe4 Wertebereich für CONSTRUCTION_ID: N,L,R,J

b=1200mm, h=40mm, t=1200mm, b1=250mm, b2=250mm, b3=250mm, b4=250mm, t1=250mm, t2=250mm, t3=250mm, t4=250mm, CONSTRUCTION_ID=R

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 33

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 b5=Breite5 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 t4=Tiefe4 t5=Tiefe5 Wertebereich für CONSTRUCTION_ID: N,L,R,J

b=900mm, h=40mm, t=1500mm, b1=100mm, b2=100mm, b3=100mm, b4=100mm, b5=400mm, t1=100mm, t2=100mm, t3=100mm, t4=100mm, t5=500mm, CONSTRUCTION_ID=N

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

CONSTRUCTION_ID = N nur wenn

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Grundform 34

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 t4=Tiefe4 a=Winkelα Wertebereich für CONSTRUCTION_ID:L,R,J

b=900mm, h=50mm, t=1500mm, b1=600mm, b2=100mm, b3=100mm, b4=600mm, t1=700mm, t2=100mm, t3=100mm, t4=400mm, a=135°, CONSTRUCTION_ID=L

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 35

Parameter: b=Breite h=Höhe t=Tiefe a=Winkelα Wertebereich für CONSTRUCTION_ID: N

b=1200mm, h=40mm, t=600mm, a=90°, CONSTRUCTION_ID=N

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 36

Parameter: b=Breite h=Höhe t=Tiefe Wertebereich für CONSTRUCTION_ID: N

b=800mm, h=40mm, t=800mm, CONSTRUCTION_ID=N

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 37

Parameter: b=Breite h=Höhe b1=Breite1 t1=Tiefe1 d=Durchmesser Wertebereich für CONSTRUCTION_ID: L,R,J

b=800mm, h=40mm, d=800mm, b1=550mm, t1=190mm, CONSTRUCTION_ID=L

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 38

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 Wertebereich für CONSTRUCTION_ID: L,R,J

b=600mm, h=40mm, t=1200mm, b1=400mm, CONSTRUCTION_ID=R

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 39

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 t1=Tiefe1 t2=Tiefe2 r=Radius a=Winkelα Wertebereich für CONSTRUCTION_ID: L,R,J

b=900mm, h=50mm, t=1500mm, b1=700mm, t1=400mm, t2=600mm, r=1500mm, a=135°, CONSTRUCTION_ID=L

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 40

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 t1=Tiefe1 r=Radius Wertebereich für CONSTRUCTION_ID: N,L,R,J

b=600mm, h=50mm, t=1200mm, b1=200mm, t1=30mm, r=200mm,, CONSTRUCTION_ID=L

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Auch CONSTRUCTION_ID = N wenn

b1 = 0, t1 = 0, r=b/2

Grundform 41

wie Grundform 31, jedoch getauschte Parameter b und t

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 t4=Tiefe4 Wertebereich für CONSTRUCTION_ID: N,L,R,J

b=1200mm, h=40mm, t=1200mm, b1=250mm, b2=250mm, b3=250mm, b4=250mm, t1=250mm, t2=250mm, t3=250mm, t4=250mm, CONSTRUCTION_ID=N

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

CONSTRUCTION_ID = N nur wenn

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Grundform 42

wie Grundform 32, jedoch getauschte Parameter b und t

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 t4=Tiefe4 Wertebereich für CONSTRUCTION_ID: L,R,J

b=1500mm, h=40mm, t=900mm, b1=100mm, b2=100mm, b3=100mm, b4=500mm, t1=100mm, t2=100mm, t3=100mm, t4=600mm, CONSTRUCTION_ID=R

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 43
wie Grundform 33, jedoch getauschte Parameter b und t

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 b5=Breite5 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 t4=Tiefe4 t5=Tiefe5 Wertebereich für CONSTRUCTION_ID: N,L,R,J

b=1500mm, h=40mm, t=900mm, b1=100mm, b2=100mm, b3=100mm, b4=100mm, b5=400mm, t1=100mm, t2=100mm, t3=100mm, t4=100mm, t5=500mm CONSTRUCTION_ID=N

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

CONSTRUCTION_ID = N nur wenn

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Grundform 44
wie Grundform 34, jedoch getauschte Parameter b und t

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 b3=Breite3 b4=Breite4 t1=Tiefe1 t2=Tiefe2 t3=Tiefe3 t4=Tiefe4 a=Winkelα Wertebereich für CONSTRUCTION_ID: L,R,J

b=1500mm, h=50mm, t=900mm, b1=700mm, b2=100mm, b3=100mm, b4=400mm, t1=600mm, t2=100mm, t3=100mm, t4=600mm, a=135° CONSTRUCTION_ID=L

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 45
wie Grundform 35, jedoch getauschte Parameter b und t

Parameter: b=Breite h=Höhe t=Tiefe a=Winkelα, Wertebereich für CONSTRUCTION_ID: N

b=600mm, h=40mm, t=1200mm, a=90° CONSTRUCTION_ID=N

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 46
wie Grundform 36, jedoch getauschte Parameter b und t

Parameter: b=Breite h=Höhe t=Tiefe Wertebereich für CONSTRUCTION_ID: N

b=800mm, h=40mm, t=800mm, CONSTRUCTION_ID=N

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 47
wie Grundform 37, jedoch getauschte Parameter b und t

Parameter: b=Breite h=Höhe d=Durchmesser b1=Breite1 t1=Tiefe1 Wertebereich für CONSTRUCTION_ID: L,R,J

b=800mm, h=40mm, d=800mm, b1=190mm, t1=550mm, CONSTRUCTION_ID=L

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 48
wie Grundform 38, jedoch getauschte Parameter b und t

Parameter: b=Breite h=Höhe t=Tiefe t1=Tiefe1 Wertebereich für CONSTRUCTION_ID: L,R,J

b=1200mm, h=40mm, t=600mm, t1=400mm, CONSTRUCTION_ID=R

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 49
wie Grundform 39, jedoch getauschte Parameter b und t

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 b2=Breite2 t1=Tiefe1 r=Radius a=Winkelα Wertebereich für CONSTRUCTION_ID: L,R,J

b=1500mm, h=50mm, t=900mm, b1=400mm, b2=600mm, t1=700mm, r=1500mm, a=135°, CONSTRUCTION_ID=L

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Grundform 50
wie Grundform 40, jedoch getauschte Parameter b und t

Parameter: b=Breite h=Höhe t=Tiefe b1=Breite1 t1=Tiefe1 r=Radius Wertebereich für CONSTRUCTION_ID: N,L,R,J

b=1200mm, h=50mm, t=600mm, b1=30mm, t1=200mm, r=200mm,, CONSTRUCTION_ID=L

Anmerkungen:

Wird vorwiegend für Arbeitsplatten und Ansetztische verwendet.

Auch CONSTRUCTION_ID = N wenn

b1 = 0, t1 = 0, r=t/2


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Sprachenschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Niederländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Länderschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Länderschlüssel

Länderkennzeichen | Ländername(deutsch) | Ländername(englisch)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Einkaufsverbände
Ansicht mit Navigationswerkzeuge
Einleitung > Einkaufsverbände

Verbandskunde | Verbandsname | Strasse | PLZ | Ort | Telefon | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13 A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Beinhaltet Form und Material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunscheig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co. KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Typen für Detailinformation
Ansicht mit Navigationswerkzeuge
Einleitung > Typen für Detailinformation

Für die Beschreibung der Art der Detailinformation gibt es folgende Info-Typen:

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Dateibenennung
Ansicht mit Navigationswerkzeuge
Einleitung > Dateibenennung

Für den Dateinamen eines Datensatzes werden folgende Empfehlungen gegeben:

· Der Name des Datensatzes darf nicht auf 8 Zeichen begrenzt sein.

· Möglichst sollten alle Bestandteile aus dem Element CATALOG_IDENTIFICATION genutzt werden:

· Folgende Bestandteile wurden vorgeschlagen:

· Herstellernummer

· IDM-Version

· Kundennummer (Wert aus dem Element ASSOC_CTM_NO)

· Sämtliche Sprachen

· Jahreszahl

· Haupt-Nummer (MAJOR)

· Zeitstempel der Dateifreigabe (FILE_RELEASE_DATE)


%%LocalItemTitle%%

Elemente
Element | Beschreibung
T_NEW_CATALOG | In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.
Komplexe Typen
Complex Type | Beschreibung
languagetexte | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.
languagetexte30 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
languagetexte40 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.
languagetexte60 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.
languagetexte60999 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bstehend aus bis zu 999 Zeilen der Länge 60.

© 2020 All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Elementreferenz
Ansicht mit Navigationswerkzeuge


%%LocalItemTitle%%

T_NEW_CATALOG Element

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

IDM 2.7.0 XML-Schema : T_NEW_CATALOG Element

Beschreibung

In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.

Namensraum

(none)

Diagramm

Overview

T_NEW_CATALOG
In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.

MAJOR required Restriction of xs:positiveInteger

Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION.

D nonNegativeInteger
P
M [2]

MINOR required Restriction of xs:nonNegativeInteger

Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.

D nonNegativeInteger
P
M [0:99]

REVISION required Restriction of xs:nonNegativeInteger

Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.

D nonNegativeInteger
P
M [0:99]

Sequence

Signature optional

Dieses Element dient der Angabe einer Veschlüsselung

Das Wurzelelement einer digitalen Signatur mit XML wird durch das Element Signature dargestellt.

Signature besitzt zwei Kindelemente, wovon die beiden Elemente SignedInfo und SignatureValue Pflicht sind.

Sequence

SignedInfo

Das erste und auch komplexeste Element innerhalb von Signature ist SignedInfo und enthält die verwendeten Algorithmen zur Kanonisierung und Signierung, eine oder mehrere Referenzen auf die signierten Daten, eventuelle Transformationen und die Hashwerte dieser Daten. SignedInfo enthält also alle Informationen zu den zu signierenden Ressourcen und ist damit der Teil, über den die digitale Signatur erstellt wird.

Mit dem Signieren der verwendeten Algorithmen erhöht sich die Sicherheit. Ein sicherer Algorithmus kann so nicht gegen einen unsicheren ausgetauscht werden, ohne dass die Signatur ungültig wird.

Kindelemente von SignedInfo sind die Pflichtelemente CanonicalizationMethod und SignatureMethod sowie ein oder mehrere Reference Elemente.

Sequence

CanonicalizationMethod Extension of xs:string

Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

Das Dokument wird in UTF-8 kodiert
Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
Attributwerte werden normalisiert (wie bei einem validierenden Parser)
Character- und parsed-entity Referenzen werden ersetzt
CDATA Abschnitte werden durch ihren Inhalt ersetzt
Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
Überflüssige Namespace Deklarationen werden von jedem Element entfernt
Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
Namespace Deklarationen und Attribute werden alphanumerisch sortiert

Algorithm optional xs:anyURI

Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI.

D anyURI
P
M

SignatureMethod Extension of xs:string
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.

Algorithm optional xs:anyURI

Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.

D anyURI
P
M

Reference

Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.

URI optional xs:string

Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.

D anyURI
P
M

Sequence

Transforms

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Sequence

Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

D string
P
M

Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

D anyURI
P
M

DigestMethod Extension of xs:string
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.

Algorithm optional xs:anyURI

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M

DigestValue xs:string

Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon).

D string
P
M

SignatureValue xs:string

Das Element SignatureValue enthält in binärer Form (immer Base-64 encoding) den über das gesamte SignedInfo Element berechneten Hashwert der Signatur. Dieser Hashwert wird mit dem in der SignatureMethod angegebenen Algorithmus, den kanonisierten Daten und dem privaten Schlüssel berechnet. Damit wird nicht die Nachricht selbst, sondern deren - in der Regel viel kürzerer - Hashwert unterschrieben (Hash-Then-Sign Paradigma).

In den unterschriebenen Daten sind somit sämtliche Informationen über die signierten Referenzen und deren Hashwerte enthalten. Damit ist es nicht erforderlich, dass die Daten selbst im Dokument vorliegen. Die Angaben über die verwendeten Algorithmen fließen jedoch mit in die Signaturberechnung ein. Dadurch werden nachträgliche Manipulationen verhindert.

Da alle Referenzen vor dem Signieren zusammengefasst und gemeinsam signiert werden existiert für die gesamte Signatur immer genau ein SignatureValue Element.

D string
P
M

CATALOG
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.

Sequence

FILE_RELEASE_DATE xs:dateTime

Das Element FILE_RELEASE_DATE sollte automatisch beim Export der Daten gesetzt werden und das aktuelle Datum und die UTC-Uhrzeit beinhalten.

D dateTime
P
M

CATALOG_IDENTIFICATION
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.

Sequence

MANUFACTURER_ID Restriction of xs:nonNegativeInteger

In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben.

D nonNegativeInteger
P
M [0:9999]

ISO_LANGUAGE_ID 1..∞ Restriction of xs:language

Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind.

D language
P [A-Z]{2}
M [2:2]

CURRENCY_KEY Restriction of xs:string

In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden.

D string
P [A-Z]{1,3}
M [1:3]

COUNTRY_ID Restriction of xs:string

In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen.

D string
P [A-Z]{2}
M [2:2]

CATALOG_KIND Restriction of xs:positiveInteger

Dieses Element ist ein Pflichtfeld zur Kennzeichnung der Katalogart. CATALOG_KIND hat die Werte
1 für Basiskatalog,
2 für Verbandskatalog und
3 für kundenspezifischen Katalog.

D positiveInteger
P
M [1:3]

ASSOC_CTM_NO optional Restriction of xs:string

Ist das Feld CATALOG_KIND mit 2 oder 3 gefüllt, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände").

D string
P
M [1:15]

PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

D positiveInteger
P
M [1:999]

PRICE_ID Restriction of xs:positiveInteger

In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im
Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Wenn kein Preis, sondern Identnummern verwendet werden, so muss dem Datenbestand die Informationen des Ident-EK-Blatt im Element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden.

D positiveInteger
P
M [1:3]

VAT Restriction of xs:boolean

In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung.

D boolean
P
M

CATALOG_NUMBER Restriction of xs:string

In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen.

D string
P
M [1:10]

CATALOG_YEAR xs:gYear

Dieses Element bezieht sich auf das Kalenderjahr der Katalogdaten.

D gYear
P
M

MAJOR_NO Restriction of xs:positiveInteger

Wird ein neuer Katalog heraus gegeben oder werden Löschungen in einem Katalog vorgenommen, ändert sich, diese Hauptnummer (MAJOR_NO). Wird die Änderung in einem neuen Jahr vollzogen, wird dass Kalenderjahr (CATALOG_YEAR) angepasst und die Hauptnummer auf 1 gesetzt. Wird in einem Jahr kein neuer Katalog bereitgestellt und keine Löschungen durchgeführt, bleibt das Kalenderjahr und die Hauptnummer bestehen.

D positiveInteger
P
M 1:99

CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,30}
M [1:30]

DATA_VERSION Restriction of xs:date

Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden.

D date
P
M

VALID_FROM_DATE Restriction of xs:date

Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben.

D date
P
M

FILE_ID Restriction of xs:boolean

Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten

D boolean
P
M

CATALOG_MARK Restriction of xs:string

Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)

handelt.

D string
P [BKV]
M [1:1]

FILLING_LEVEL Restriction of xs:string

Über die Füllstufe (FILLING_LEVEL) wird definiert, mit welchem Detaillierungsgrad die Katalogdaten beschrieben werden. Im Grundsatz steigt mit zunehmender Füllstufe die Datenqualität, da mit dem steigenden Detaillierungsgrad die Herstellerspezifik der Daten zunimmt.
Die Füllstufen werden bei der Datenzertifizierung ausgewertet: Anhand der Füllstufe wird überprüft, welche Informationen in den Daten vorhanden sein müssen, um die angegebene Füllstufe zu erreichen. Ist eine geforderte Information nicht vorhanden, so wird der Datenbestand nicht zertifiziert.
Die Füllstufen sind wie folgt definiert:
- Füllstufe 1: Es werden Basisinformationen mit Ausnahme der Elemente zur Beschreibung von Texturinformationen
- Füllstufe 2a: Die Füllstufe 1 wird ergänzt um Informationen über Texturen und Material (Farben RGB, Transparenz und Glanz)
- Füllstufe 2b: Die Füllstufe 1 wird ergänzt um Informationen über Frontaufteilungen und Frontausprägungen
- Füllstufe 2c: Die Füllstufe 1 wird ergänzt um Informationen über Griffe
- Füllstufe 2d: Die Füllstufe 1 wird ergänzt um Informationen über Artikeltexturen

Es sind auch Kombinationen der Füllstufen 2a-2d möglich. Folgende Aufschlüsselung der Kombinationen sind definiert:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Füllstufe 3. Um die Füllstufe 3 zu erreichen, müssen die Informationen aus den Füllstufen 1 und 2a - 2d enthalten sein und um Informationen über Echtgrafik ergänzt werden. Mit der Füllstufe 3 werden die Möglichkeiten des Datenformates zur herstellerspezifischen Abbildung gänzlich angewendet.
Die Definition, welche Informationen von welcher Füllstufe gefordert werden, erfolgt im Tabellenteil "Füllstufen".

D string
P [123]|2[a-n]
M [1:2]

PRICING_TERMS optional Restriction of xs:string

Mit diesem Element wird definiert, welche Preise in den Daten angelegt werden.
Dieses Element wird zur Unterscheidung beim Datenimport herangezogen, um zu vermeiden, dass sich die Preise bei gleichen Katalogen überschreiben.

Folgende Werte sind möglich:
0 = die angegebenen Preise sind Einkaufspreise für den Handel
1 = die angegebenen Preise sind unverbindliche Preisempfehlungen (UPE)

Entsprechend dem angegebenem Wert müssen die richtigen Preise in den Daten angelegt werden.

D string
P [01]
M [1:1]

CATALOG_INFO languagetexte60999 Complex Type
In diesem Element werden die Informationstexte abgelegt.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.

SEQUENCE_NO required Restriction of xs:positiveInteger

Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen.

D positiveInteger
P
M

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,60}
M [1:60]

FALL_BACK_LANGUAGE optional Restriction of xs:language

Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen.

D language
P [A-Z]{2}
M [2:2]

DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.

Sequence

DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.

DETAIL_INFO_NO required Restriction of xs:positiveInteger

In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.

D positiveInteger
P
M [1:999999999]

SUPPLIER
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.

Sequence

EDI_INFO 0..∞
In diesem Element werden den Geschäftspartnern die möglichen EDI-Kommunikationen mitgeteilt. Für jede EDI-Nachricht eines EDI-Formates wird ein Element angelegt.

Sequence

EDI_FORMAT optional Restriction of xs:string

Hier wird das unterstützte EDI-Format angegeben (z. B. EDIDATA).

D string
P EANCOM|EAN 97|EAN 97 A|EDIDATA
M [1:20]

EDI_FORMAT_VERSION optional Restriction of xs:string

Hier wird angegeben, welche Version des im Element EDI_FORMAT angegebenen EDI-Formates unterstützt wird.

D string
P [1-9]\.[0-9]{2}
M [1:10]

EDI_MESSAGE optional Restriction of xs:string

Hier werden die vom Hersteller unterstützten Nachrichten des EDI-Formates angegeben (z. B. Order, Order Response).

D string
P
M [1:20]

EDI_COMMUNICATION optional Restriction of xs:string

Hier wird angegeben, auf welchem Weg die EDI-Kommunikation erfolgt (z. B. X.400, Telebox, E-Mail).

D string
P
M [1:20]

EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string

Hier wird die Adresse für den angegebenen Kommunikationsweg angegeben (z. B. X.400 Adresse, E-Mail-Adresse oder nach Rücksprache).

D string
P
M [1:40]

EDI_CONTACT optional Restriction of xs:string

Hier wird die Person angegeben, die beim Hersteller als Kontakt für Details zur EDI Abwicklung zur Verfügung steht. Die Angabe der Kontaktinformationen ist frei, d. h. es können im Rahmen der max. Feldlänge die notwendigen Informationen wie beispielsweise Name, Telefon oder E-Mail angegeben werden.

D string
P
M [1:60]

BRANCH_ID Restriction of xs:string

In diesem Element wird das Kennzeichen für die Herstellerbranche angegeben. Derzeit sind folgende Branchenkennzeichen definiert:

A = Arbeitsplattenhersteller
B = Badmöbelhersteller
G = Gerätehersteller
K = Küchenmöbelhersteller
O = Büromöbelhersteller
P = Polstermöbelhersteller
S = Sanitärhersteller
W = Wohnmöbelhersteller
Z = Zubehörhersteller

D string
P [ABGKOPSWZ]
M [1:1]

ISO_COUNTRY_ID Restriction of xs:string

In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben.

D string
P [A-Z]{2}
M [2:2]

GLN_NO optional Restriction of xs:string

In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN Nummer ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.

D string
P [0-9]{13}
M [13:13]

WEEE_NO optional Restriction of xs:string

In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen.

D string
P
M

CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.

Sequence

CONTACT_PERSON_NO Restriction of xs:positiveInteger

In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme)

D positiveInteger
P
M [1:2]

CONTACT_ROLE Restriction of xs:string

In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher).

D string
P
M [1:60]

CONTACT_NAME Restriction of xs:string

In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben.

D string
P
M [1:20]

FIRST_NAME Restriction of xs:string

In diesem Element wird der Vorname des direkten Ansprechpartners angegeben.

D string
P
M [1:20]

FORM_OF_ADDRESS Restriction of xs:positiveInteger

Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr.

D positiveInteger
P
M [1:2]

DEPARTMENT optional Restriction of xs:string

Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben.

D string
P
M [1:15]

TELEPHONE Restriction of xs:string

Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.

D string
P
M [1:18]

FAX optional Restriction of xs:string

Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284.

D string
P
M [1:18]

EMAIL optional Restriction of xs:string

In diesem Element wird die E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M

STREET optional Restriction of xs:string

In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben.

D string
P
M [1:30]

ZIPCODE_STREET optional Restriction of xs:string

In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben.

D string
P
M [1:8]

CITY optional Restriction of xs:string

In diesem Element wird der Sitz des Herstellers angegeben.

D string
P
M [1:30]

CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.

Sequence

MANUFACTURER_NAME_1 Restriction of xs:string

In diesem Element wird die 1. Zeile des Firmennamens angegeben.

D string
P
M [1:30]

MANUFACTURER_NAME_2 optional Restriction of xs:string

Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben.

D string
P
M [1:30]

EMAIL optional Restriction of xs:string

In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string

In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de).

D string
P
M

STREET Restriction of xs:string

In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben.

D string
P
M [1:30]

ZIPCODE_STREET Restriction of xs:string

In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben.

D string
P
M [1:8]

CITY Restriction of xs:string

In diesem Element wird der Sitz des Herstellers angegeben.

D string
P
M [1:30]

ZIPCODE_POSTBOX optional Restriction of xs:string

In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben.

D string
P
M [1:8]

POSTBOX optional Restriction of xs:string

In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden.

D string
P [0-9a-zA-Z]{0,10}
M [0:10]

TELEPHONE_SWITCHBOARD Restriction of xs:string

Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.

D string
P
M [1:18]

FAX_SWITCHBOARD Restriction of xs:string

Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.

D string
P
M [1:18]

GLOBAL_DEFINITION optional
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.

Sequence

CLEARING_GROUP 0..∞
Das Element dient zur Definition von Verrechnungsgruppen. Eine Verrechnungsgruppe wird durch das Zusammenfassen mehrere Tausch-ID (Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID) gebildet.

Die Verrechnungsgruppen werden in Blockbedingungen (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) und den Wertestaffeln (BLOCK_VALUE_CALCULATION/GRADING_TABLE) zur Bestimmung von Mindestwerten bestimmter Typenbereiche verwendet. Die Typenbereiche werden durch die Tausch-ID identifiziert.

Die Beträge aller Auftragsposition, deren Tausch-ID in einer Verrechnungsgruppe enthalten sind, werden summiert. Je Verrechnungsgruppe resultiert eine Summe, die als Vergleichskriterium zum Einstieg in die Blockbedingungen und in die Wertestaffel verwendet wird.

CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger

Dieses Attribut identifiziert eine Verechnungsgruppe.

D nonNegativeInteger
P
M [0:999]

Sequence

EXCHANGE_ID_REF 1..∞
Dieses Element referenziert eine Tausch-ID.

EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger

Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

CLEARING_GROUP_NAME languagetexte60 Complex Type
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,60}
M [1:60]

FRONTS_HANDLE_POSITIONS optional
In diesem Element werden Grifflagen definiert. Es können Basisgrifflagen und spezielle Grifflagen definiert werden. Basisgrifflagen sind global gültig, spezielle Grifflagen definieren die Grifflagen unter spezifischen Bedigungen.

Sequence

SPECIFIC_HANDLE_POSITIONS optional
In diesem Element können spezielle Grifflagen, Änderungen von Grifflagen und Griffwechsel definiert werden. Im Weiteren wird für diese Situationen der Begriff "spezielle Grifflage" verwendet. Alle Kind-Elemente können beliebig kombiniert werden. Je mehr Kind-Elemente gefüllt sind, desto spezieller ist die Situation für eine spezielle Grifflage beschrieben. Neben dem Element PRIORITY (Pfad1 ) muss mindestens ein Key-Feld gefüllt werden.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/

Sequence

SPECIFIC_HANDLE_ORIENTATION 1..∞
In diesem Element wird eine spezifische Grifflage definiert.

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine spezielle Grifflage identifiziert.

D nonNegativeInteger
P
M [0:99999]

Sequence

STYLE_REF optional
Über Referenzierung wird definiert, für welches Programm die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Programme gültig.

STYLE_NO required Restriction of xs:string

In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Elementpfade:
Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/

D string
P
M [1:5]

FRONT_TYPE_GROUP_REF optional
Hier wird definiert, für welche Fronttypgruppe die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Fronttypgruppen gültig.

FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Fronttypgruppe referenziert.

D nonNegativeInteger
P
M [1:99]

WIDTH_FROM optional Restriction of xs:positiveInteger

Hier wird definiert, ab welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Wenn dieses Element gefüllt ist, muss auch dass Element WIDTH_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels.

D nonNegativeInteger
P
M [1:9999]

WIDTH_TO optional Restriction of xs:positiveInteger

Hier wird definiert, bis zu welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Dieses Element muss gefüllt werden, wenn das Element WIDTH_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft angegeben, am Rand bis zur Außenseite des Artikels.

D nonNegativeInteger
P
M [1:9999]

HEIGHT_FROM optional Restriction of xs:nonNegativeInteger

Hier wird definiert, ab welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Wenn dieses Element gefüllt ist, muss auch dass Element HEIGHT_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels.

D nonNegativeInteger
P
M [1:9999]

HEIGHT_TO optional Restriction of xs:nonNegativeInteger

Hier wird definiert, bis zu welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Dieses Element muss gefüllt werden, wenn das Element HEIGHT_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels.

D nonNegativeInteger
P
M [1:9999]

OPTION_REF
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Aufgrund der in der Praxis vorkommenden Situationen dürfen hier nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Element gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) enthält.

FEATURE_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird eine Variantenart angegeben. Es kann nur die Variantenart 154 angegeben werden.

D nonNegativeInteger
P
M [154:154]

OPTION_KEY required Restriction of xs:string

Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Hier dürfen nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Feld gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Glastürrahmenausführung" (154) enthält.

D string
P
M [1:5]

HANDLE_EXCHANGE optional
In diesem Element wird ein Griffwechsel definiert, der angewendet wird wenn die im Element SPECIFIC_HANDLE_ORIENTATION definierten Bedingungen erfüllt sind.

Sequence

FEATURE_REF
Dieses Element referenziert eine Variantenart, die im Element FEATURE_DEFINITION/FEATURES/FEATURE definiert sein muss.

FROM_HANDLE
In diesem Element wird definiert von welchem Griff gewechselt wird.

TO_HANDLE
In diesem Element wird definiert, auf welchen Griff gewechselt wird.

HANDLE_ORIENTATION_EXCHANGE optional
In diesem Element wird ein Wechsel von Grifflagen definiert.

Sequence

FROM_HANDLE_ORIENTATION_REF
Hier wird definiert, bei welcher Basisgrifflage die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Basisgrifflagen.
Die Grifflage muss im Element BASIC_HANDLE_POSITIONS (Pfad1) definiert sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/

TO_HANDLE_ORIENTATION_REF
In diesem Element wird angegeben, auf welche Grifflage gewechselt wird.

PRIORITY Restriction of xs:nonNegativeInteger

In diesem Element wird die Priorität einer speziellen Grifflage definiert.
Bei der Anwendung der im Element SPECIFIC_HANDLE_ORIENTATION (Pfad 1) angelegten speziellen Grifflagen, ist es möglich, dass mehrere Grifflagen gültig angewendet werden können, was zu unerwünschten Ergebnissen führen kann.
Zur Vermeidung dieser Situation wird der speziellen Grifflage eine Priorität zugeordnet.
Die Priorität nimmt mit steigendem Zahlenwert zu. Unter einer Priorität können mehrere Grifflagen zusammengefasst werden. Bei Grifflagen einer Priorität müssen die gleichen Key-Elemente gefüllt sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS

D nonNegativeInteger
P
M [1:999]

BASIC_HANDLE_POSITIONS

In diesem Element wird beschrieben, welche Lage und Position Griffe auf bestimmten Fronttypen aufweisen. Die in diesem Element definierten Basisgrifflagen sind global gültig.

Die Basisgrifflagen sollten sich an den vordefierten Standardgrifflagen des Abschnittes Standardgrifflagen orientieren. Allerdings ist hier zu beachten, dass für die Basisgrifflagen der Wert 0 nicht benutzt werden kann.

Sequence

HANDLE_ORIENTATION 1..∞
Dieses Element ist ein Container-Element, in dem die unterschiedlichen Basisgrifflagen definiert werden.

HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger

Mit diesem Attribut wird eine Basisgrifflage identifiziert.

D positiveInteger
P
M [1:9999]

Sequence

FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird in dem Attribut FRONT_TYPE_CODE angegeben.

FRONT_TYPE_CODE required Restriction of xs:string

Hier wird definiert, für welchen Fronttyp eine Grifflage beschrieben wird. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung

D string
P [SAKJTR]|GT
M [1:2]

Sequence

ORIENTATION Restriction of xs:string

Hier wird definiert, welche Lage die Griffe bei dem Fronttyp haben.
H = horizontal
V = vertikal

D string
P [HV]
M [1:1]

POSITION Restriction of xs:string

Hier wird definiert, welche Position die Griffe bei dem Fronttyp haben.

M = mittig (z. B. auch für durchgehende Griffleiste, anschlagsneutral)
A = außen (auch für Griffleiste abhängig vom Anschlag)
D = doppelt (zwei Griffe außen)
G = ohne Bohrung mit Griff (Griff wird geliefert, Bohrung bauseits)
0 (Null) = ohne Bohrung ohne Griff (Griff wird nicht geliefert, auch Grifflose Küche)

Bei der Position A = außen wird die konkrete Position rechts/links über den Anschlag des Artikel bestimmt.

D string
P [MADG0]
M [1:1]

FRONT_TYPES_GROUPS optional
Für die effiziente Verwendung von Fronttypen bei der Definition von spezifischen Grifflagen im Element SPECIFIC_HANDLE_ORIENTATION (Pfad1) können Fronttypen zu Fronttyp-Gruppen zusammengefasst werden.

Elementpfade
Pfad1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/

Sequence

FRONT_TYPES_GROUP 1..99
In diesem Element wird eine Gruppe von Fronttypen definiert.

FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Fronttypgruppe identifiziert.

D nonNegativeInteger
P
M [1:99]

Sequence

FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird über das Attribut FRONT_TYPE_CODE angegeben.

FRONT_TYPE_CODE required Restriction of xs:string

Hier werden die Fronttypen angegeben, die zu einer Fronttypgruppe zusammengefasst werden sollen. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung)
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung)

D string
P [SAKJTR]|GT
M [1:2]

FRONT_APPEARANCES optional
In diesem Element werden die Frontausprägungen eines Programms, einer Ausführung oder eines Artikels definiert. Hier definierte Frontausprägungen werden von Programmen (FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF), Ausführungen (FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF) oder von Artikeln (SERIES/.../ITEM/FRONT_APPEARANCE_REF) referenziert.
Ein Frontausprägung wird grundlegend definiert, in dem eine Grundformnummer für ein Frontelement zugeordnet und die Geometrie über Angabe der Maße bestimmt wird.

Sequence

FRONT_APPEARANCE 1..999
In diesem Element wird eine Frontausprägung definiert.

FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger

Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird.

D positiveInteger
P
M [1:999]

Sequence

FRONT_TYPE 1..900
Wenn alle Frontelemente unabhängig vom Fronttyp gleiches Aussehen haben, wird eine Definition mit dem Fronttyp 0 angelegt. Dann dürfen keine weiteren mit abweichenden Fronttypen angelegt werden. Wenn für eine Frontausprägungs-ID ein Datensatz mit einem Fronttyp angelegt wurde, so müssen für alle verwendeten Fronttypen ebenfalls Datensätze angelegt werden.

Sequence

FRONT_TYPE_NO Restriction of xs:positiveInteger

In diesem Attribut wird der Schlüsselwert des Fronttyps angegeben.

D positiveInteger
P
M [0:1000]

Sequence 1..∞

FRONT_CONSTRAINTS optional
Für die Elemente WIDTH_FROM/TO und HEIGTH_FROM/TO gelten folgende Regeln:

- Wenn die Elemente WIDTH_TO oder HEIGHT_TO nicht angelegt sind, so entspricht dies dem Wert „unendlich“.
- Wenn die Elemente WIDTH_FROM oder HEIGHT_FROM nicht angelegt sind, so entspricht dies dem Wert 0.
- Der Wert 0 ist in den Elementen WIDTH_FROM/TO oder HEIGTH_FROM/TO nicht zulässig.
- Die angegebenen Intervalle dürfen sich nicht überlappen und müssen immer den gesamten Bereich
von 0 bis unendlich abdecken. Es dürfen keine Lücken entstehen.

Sequence

WIDTH_FROM optional Restriction of xs:positiveInteger

In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird (Maße in mm).

D positiveInteger
P
M [1:999999]

WIDTH_TO optional Restriction of xs:positiveInteger

In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm).

D positiveInteger
P
M [1:999999]

HEIGHT_FROM optional Restriction of xs:positiveInteger

In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm).

D positiveInteger
P
M [1:999999]

HEIGHT_TO optional Restriction of xs:positiveInteger

In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm).

D positiveInteger
P
M [1:999999]

FRONT_SHAPE
In diesem Element sind die Elemente zur geometrischen Beschreibung eines Frontelementes zusammengefasst.

Sequence

GLASS Restriction of xs:boolean

Durch dieses Element kann festgelegt werden, ob es sich bei dem angegebenen Fronttyp um eine Glasversion (Wert 1/true) oder um eine normale Version (Wert 0/false) handelt. Die Werte in diesem Element dürfen für einen Fronttyp nicht wechseln. Durch diese Regel wird verhindert, dass beispielsweise aus einer Glastür durch Auswahl eines anderen Programms eine Massivtür wird.

D boolean
P
M

Choice

MODELING_GRAPHIC_ID optional Restriction of xs:string

Hier kann eine Echtgrafik angegeben werden.

Das Format muss dahingehend noch ausformuliert werden.

D string
P
M [1:15]

BASIC_FRONT_SHAPE optional
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.

MODULE_RULE_SET_DEFINITIONS optional
In diesem Element werden die Regeln für Modulschränke und die darin zu verbauenden Module gesammelt.

Sequence

MODULE_RULE_SET_DEFINITION 1..∞
In diesem Element werden die Regeln für Modulränke und die darin zu verbauenden Module definiert. Hier definierte Modulregeln werden von Artikeln (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) oder (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) referenziert.

MODULE_RULE_SET_NO required xs:nonNegativeInteger

In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren.

D nonNegativeInteger
P
M

Sequence

MODULE_RULE_SET_NAME languagetexte60 Complex Type
In diesem Element wir die Bezeichnung des Regelwerks hinterlegt.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,60}
M [1:60]

DETAIL_INFOS optional
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.

Sequence

DETAIL_INFO 1..∞

In diesem Element wird eine Detailinformation definiert.

DETAIL_INFO_NO required Restriction of xs:positiveInteger

Dieses Attribut identifiziert eine Detailinformation.

D positiveInteger
P
M [1:999999999]

Sequence

CLASSIFICATION Restriction of xs:string

Dieses Element dient der Klassifizierung der Detailinformation.

D string
P
M [1:8]

INFO_TYPE Restriction of xs:positiveInteger

Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges

D positiveInteger
P [1-9]|1[01]|99
M [1:11],99

EXTERNAL_NAME optional languagetexte Complex Type
Anzeigename des Links (z.B. "Magic Corner in Bewegung").

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

D string
P
M

INTERNAL_NAME languagetexte40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,40}
M [1:40]

GUID Restriction of xs:string

Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen).

D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]

TOOL_TIP optional languagetexte Complex Type
Dieses Element enthält Text für einen Tooltip zum Link.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

D string
P
M

URL
Dieses Element ist für die URL zur Detailinformation.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:anyURI

In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist..

D anyURI
P
M [1:1024]

HASH_VALUE optional Restriction of xs:string

Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads.

D string
P
M [1:64]

RESOLUTION optional Restriction of xs:positiveInteger

Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei .

D positiveInteger
P
M [1:4]

PROPERTIES optional

Dieses Element dient zur Aufnahme zusätzlicher Informationen und Eigenschafen wie z. B. Energielabel, Effizienzklassen und ähnlicher Daten. Es werden nur die Eigenschaften definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Die Schlüssel sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

Sequence

PROPERTY 1..∞

In diesem Element wird eine Eigenschaft definiert.

Die Schlüssel, der Text und die Maßeinheit sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

PROPERTY_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die Eigenschaft identifiziert.

Ihre Nummer ist der Tabelle der Informationsschlüssel zu eintnehmen.

D nonNegativeInteger
P
M [0:999]

Sequence

PROPERTY_TEXT languagetexte Complex Type

Dieses Element enthält Texte für Eigenschaften/Merkmale.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

D string
P
M

PROPERTY_UNIT optional languagetexte30 Complex Type

In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,30}
M [1:30]

GROUP_TITLES optional
Hier werden an zentraler Stelle alle möglichen Bezeichnungen für Gruppen von optionalen und zwingenden Zusatzartikeln gespeichert.

Sequence

GROUP_TITLE 1..∞
Dieses Element dient zur Speicherung eines Gruppentitels.

GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird eine eindeutige Nummer zur späteren Referenzierung des Gruppentitels gespeichert.

D nonNegativeInteger
P
M [0-999]

Sequence

GROUP_TITLE_NAME languagetexte60 Complex Type
Dieses Element enthält Namen für Gruppen von Zusatzartikeln.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,60}
M [1:60]

SERIES
In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren Eigenschaften und zugeordneten Elementen wie beipsielsweise Produktgruppen oder Artikeln hinterlegt.

Sequence

SERIE 1..100

In diesem Element werden die Serien definiert.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

SERIE_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird die Seriennummer der Serie definiert.

D nonNegativeInteger
P
M [0:99]

Sequence

FEATURE_CLASS_REF optional
Mit diesem Element wird eine Variantenfamilie referenziert die der Serie zugeordnet werden soll.
Hierdurch können die in einer Serie gültigen Variantenarten zugeordnet werden.
Die hier zugeordnete Variantenfamilie stellt eine Obermenge der Variantenarten dar, die sich aus der Summe aller Variantenarten der Variantenfamilien aller Programme und aller Artikel in dieser Serie ergibt. Daher sind die einer Serie zugeordneten Variantenarten für eine Bestellung nicht ZWINGEND anzugeben. Für eine Bestellung sind aber die Summe der Varianten eines Artikels in Summe mit denen des Programms in dem der Artikel bestellt wird anzugeben.
Die einer Serie zugeordneten Variantenarten werden dem Anwender bei der Eingabe der Kopfvarianten zur Eingabe angeboten.

FEATURE_CLASS_NO required Restriction of xs:positiveInteger

Dieses Attribut referenziert eine Variantenfamilie. Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/

D positiveInteger
P
M [1:999]

SERIES_NAME
Dieses Element gibt den Seriennamen an.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D string
P [A-Z]{2}
M [2:2]

Sequence

TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet den Text.

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,30}
M [1:30]

FULL_TEXT optional xs:string

In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P
M

PURCHASE_RETAIL_ID Restriction of xs:boolean

Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:
0 = EK-Preis
1 = VK-Preis
In Abhängigkeit der Preis-ID (Element PRICE_ID (Pfad1)) wird der Preis wie folgt definiert:

Preis-ID = 1 (Preis), dann wird der Wert aus dem Element ITEM_PRICE (Pfad2) verwendet.

Preis-ID = 2 (Identnummer), dann wird der Preis aus dem Element IDENT_NUMBER/PRICE (Pfad3), dem Element ITEM_PRICE/PRICE_MINIMUM_BASIC (Pfad2) oder dem Element ADDITIONAL_PRICE (Pfad5) verwendet.

Preis_ID = 3 (Verrechnungspunkt), dann wird der Wert aus aus den Elementen ITEM_PRICE (Pfad2) oder PRICE_MINIMUM_BASIC multipliziert mit dem Verrechnungsfaktor aus dem Element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR verwendet.

Aufgrund des Schlüssels kann innerhalb einer Serie nur eine Preisstellung (Kombination der Elemente VAT (Pfad4) und PURCHASE_RETAIL_ID (Pfad4)) angegeben werden.
Werden in einer Datei sowohl EK- wie auch VK-Preise aufgeführt, so dürfen bei Typen mit EK-Preisen nicht die gleichen Kalkulationsgruppen (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) wie bei Typen mit VK-Preisen vergeben werden.
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Elementpfade
Pfad1: CATALOG/CATALOG_IDENTIFICATION/
Pfad2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
Pfad3: PRICE_DEFINITION/IDENT_NUMBERS
Pfad4: CATALOG/CATALOG_IDENTIFICATION
Pfad5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

D boolean
P
M

RESTRICTIONS optional
Dieses Element referenziert Prüfverfahren, die für die Serie angewendet werden (Serien-spezifische Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.

Sequence

RESTRICTION_REF 0..∞
Dieses Element referenziert ein Prüfverfahren, das für die Serie angewendet wird (Serien-spezifisches Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.

SEQUENCE required Restriction of xs:nonNegativeInteger

Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …).

D nonNegativeInteger
P
M [1:99999]

RESTRICTION_NO required Restriction of xs:nonNegativeInteger

Durch dieses Attribut werden Serien-spezifische Prüfverfahren referenziert.

D nonNegativeInteger
P
M [0:99999]

SUGGESTIONS optional
Dieses Element referenziert Vorbelegungen, die für die Serie angewendet werden.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.

Sequence

SUGGESTION_REF 0..∞
Dieses Element referenziert eine Vorbelegung, die für die Serie angewendet wird.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.

SEQUENCE required Restriction of xs:nonNegativeInteger

Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Vorbelegungen bei der Ersterfassung einer Planung vorgeschlagen werden.

Die Nummerierung (SEQUENCE) steuert die Prioritäten

D nonNegativeInteger
P
M [1:99999]

SUGGESTION_NO required Restriction of xs:nonNegativeInteger

Durch dieses Attribut wird eine Vorbelegungen referenziert.

D nonNegativeInteger
P
M [0:99999]

PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).

Sequence

PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.

Sequence

PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.

FEATURE_CLASS_NO required Restriction of xs:positiveInteger

Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert.

D positiveInteger
P
M [1:999]

ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.

Sequence

ITEM 1..∞
In diesem Element werden Artikel und Blöcke definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Die Elemente OLD_SERIA_NO (Pfad 1) und OLD_TYPE_NO (Pfad 1) dürfen nur verwendet werden, wenn der dort angegebene Artikel in allen geometrischen Daten identisch dem aktuellen Artikel ist.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Maße B, H und T dieses E-Gerätes im Element PARAMETERS (Pfad 3) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES

RESTRICTIONS optional
In diesem Element werden die Prüfverfahren einer Produktgruppe zusammengefasst.

Sequence

RESTRICTION_REF 1..∞
Dieses Element referenziert ein, der Produktgruppe zugeordnetes Prüfverfahren.

DEFAULT_OPTION_GROUPS optional
In diesem Element werden Standard-Vorbelegungen von Programmvarianten als Vorschlag und Entscheidungshilfe für den Anwender definiert. Die vorgeschlagenen Kombinationen müssen kompatibel zu den Prüfverfahren sein.

Sequence

DEFAULT_OPTION_GROUP 1..∞
In diesem Element wird ein Standardvorschlag definiert.
Jede Variantenart darf je DEFAULT_OPTION_GROUP nur einmal referenziert werden.

DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger

In diesem Attribut wird eine numerischer Wert zur Identifizierung der Standardgruppe angelegt.

D positiveInteger
P
M [1:999999999]

Sequence

DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
In diesem Element wird ein freier Name für einen Standardvorschlag angegeben. Der Name kann beispielsweise für die Auswahl eines Standardvorschlages vom Benutzer des Planungssystems verwendet werden.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

FILE_NAME optional Restriction of xs:string

In diesem Element wird der Dateiname eines JPEG-Bildes angegeben, dass ein beispielartiges Bild des Standardvorschlages darstellt.

D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M

OPTION_REF 1..∞
In diesem Element werden die Varianten referenziert, die zu einem Standardvorschlag zusammengestellt werden.

FEATURE_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird die Variantenart der referenzierten Variante angegeben.

D noNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

In diesem Attribut wird die Variante referenziert, die dem Standardvorschlag zugeordnet wird.

D string
P
M [1:5]

DETAIL_INFOS optional
Dieses Element dient der Angabe von Bildern unterhalb des Standardvorschlages.

Sequence

DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.

DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks zur Serie hinterlegt werden.

Sequence

DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.

DETAIL_INFO_NO required Restriction of xs:positiveInteger

In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.

D positiveInteger
P
M [1:999999999]

RESTRICTIONS optional
In diesem Element werden Serien-übergreifende Prüfverfahren gesammelt.

Sequence

RESTRICTION_REF 0..∞
Mit diesem Element werden Serien-übergreifende Prüfverfahren referenziert.

SEQUENCE required Restriction of xs:nonNegativeInteger

Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Alle Prüfverfahren müssen einen unterschiedlichen Wert für die SEQUENCE_NO enthalten. Über die Prüfungen wird die Schnittmenge gebildet.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …).

D nonNegativeInteger
P
M [1:99999]

RESTRICTION_NO required Restriction of xs:nonNegativeInteger

Durch dieses Attribut werden Serien-übergreifende Prüfverfahren referenziert.

D nonNegativeInteger
P
M [0:99999]

FEATURE_DEFINITION optional
In diesem Element werden variantenabhängige Informationen hinterlegt.

Sequence

FEATURE_CLASSES
In diesem Element werden Variantenarten zu Familien zusammengefasst. Mittels dieser Variantenfamilien können Plausibilitäts- und Vollständigkeitsprüfungen bezüglich der gültigen Variantenarten durchgeführt werden.

Die definierten Variantenfamilien können Serien, Programmen oder Produktgruppen zugeordnet werden. Zwischen Variantenfamilien auf Serien-, Programm- oder Artikelebene (über die ihm übergeordnete Produktgruppe) besteht keine Beziehung hinsichtlich einer Priorität. Die Anzahl der an einem Artikel gültigen Variantenarten ergibt sich aus der Summe der Variantenarten, die in der Variantenfamilie des Programms und der Variantenfamilie der dem Artikel übergeordneten Produktgruppe deklariert sind. Variantenfamilien, die aus dem Element FEATURE_CLASS_REF (Pfad 1) referenziert werden, dürfen nur Variantenarten enthalten, die in dem Element FEATURES (Pfad 2) als Kopfvariantenarten deklariert sind

Alle Variantenarten, die über die Elemente in PRICE_FEATURE_GROUP (Pfad 3), PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 4) und FINISH (Pfad 5) referenziert werden, müssen in der Variantenfamilie der Produktgruppe des Artikels enthalten sein.

Ebenso müssen die über die Elemente RESTRICTION_REF (Pfad 6), RESTRICTION_REF (Pfad 1) und RESTRICTION_REF (Pfad 8)verwendeten Variantenarten in der Variantenfamilie Produktgruppe des Artikels enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
Pfad 2: FEATURE_DEFINITION
Pfad 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 6: SERIES/SERIE/RESTRICTIONS
Pfad 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS

Sequence

FEATURE_CLASS 1..∞
In diesem Element wird eine Variantenfamilie definiert

FEATURE_CLASS_NO required Restriction of xs:positiveInteger

Mit diesem Attribut wird eine Variantenfamilie identifiziert.

D nonNegativeInteger
P
M [1:999]

Sequence

FEATURE_REF 1..∞
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels (zugeordnet über die Produktgruppe) dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Regals keine Variantenarten für z. B. Griffe enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES

FEATURE_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Variantenart referenziert.

D nonNegativeInteger
P
M [0:999]

FEATURES
In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten definiert. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Für die unterschiedlichen Variantenarten werden mit Ausnahme der Kombivariantenarten und der Variantenarten 701 und 703 immer die Kombinationen aus Ausführung und Farbe verwendet.

Variantenarten müssen immer paarweise angelegt werden. Zu jeder Ausführungsvariantenart existiert die zugehörige Farbvariantenart und zu jeder Farbvariantenart existiert eine zugehörige Ausführungsvariantenart.

Ausgenommen von dieser Regelung sind die Variantenarten 701 und 703, zu denen keine Farbvariantenart angelegt werden muss.

Variantenarten > 950 sind grafisch nur für Echtgrafik relevant, daher dürfen diese nicht als Kombivarianten deklariert werden.

Sind im Herstellerkatalog Kombivarianten angegeben (z. B. furniert grün), so sind diese im Element COMBINED_FEATURE (Pfad 1) zu erfassen.

In diesem Element müssen die im Element COMBINED_FEATURE (Pfad 1) verwendeten Detailvarianten als unsichtbare Kopfvarianten (HEADER_POS_VARIATION_TYPE (Pfad 2) = U) definiert werden.

Variantenarten, die als unsichtbare Variantenarten deklariert sind, dürfen nicht in einer Variantenfamilie referenziert werden.

Alle Variantenarten, im Element FEATURES (Pfad 3), die nicht als unsichtbare Kopfvariantenart deklariert sind, müssen mindestens in einer Variantenfamilie referenziert werden.

Es existieren MUSS-Variantenarten, die in Abhängigkeit des Typschlüssel eines Artikels angelegt werden müssen. Diese sind für eine vollständige Katalogbeschreibung jedoch im Allgemeinen nicht ausreichend. Die Zuordnung Typenschlüssel zu MUSS-Variantenart ist in der Tabelle "Typschlüssel-MUSS-Variantenart" definiert.
Weitere Erläuterungen zu den Variantenarten sind zu finden unter "Hinweise zur Verwendung der Variantenarten"

Das Element ist für Küchenhersteller (SUPPLIER/BRANCH_ID = K) zwingend anzulegen.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 3: FEATURE_DEFINITION

Sequence

COMBINED_FEATURE 0..∞
In diesem Element werden Varianten zu Kombi-Varianten zusammengefasst. Die in Kombi-Varianten zusammengefassten Varianten werden als Detailvarianten bezeichnet.

Varianten-Prüfungen und -Zuordnungen dürfen nur auf die hier definierten Kombivarianten und nicht auf die darunterliegenden Detailvariantenarten angewendet werden.

Detailvariantenarten müssen im Element HEADER_POS_VARIATION_TYPE (Pfad 1) als unsichtbar deklariert werden. Die Detailvarianten dürfen in keinem weiteren Element außer OPTION (Pfad 2) verwendet werden.

Wird eine Kombivariante angelegt, so muss diese durchgängig angelegt werden. Wird beispielsweise eine Kombi-Variante mit der Variantenart 303 und den Detailvariantenarten 301 und 302 angelegt, so müssen alle weiteren Varianten für Griffe als Kombi-Varianten mit der Variantenart 303 angelegt werden.

Hinsichtlich der Verarbeitung von Kombivarianten wurden nachfolgende Vereinbarungen getroffen: Wird beispielsweise eine Unifarbene Front angelegt, so wird in einer Kombivariante die Variantenart Frontfarbe 1 (101) angelegt. Die Farbe dieser Variante vererbt sich auf die Variantenart Frontfarbe 2 (102).

Bei einer Griff-Kombination (Variantenart 303), muss mindestens Variantenart 300 und eine der Variantenarten 301 oder 302 dieser Kombi-Variante zugeordnet werden.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS

FEATURE_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Variantenart referenziert.

D nonNegativeInteger
P (105)|(115)|(125)|(201)|(303)
M [105:303]

OPTION_KEY required Restriction of xs:string

Mit diesem Attribut wird eine Variantenausprägung referenziert.

D string
P
M [1:5]

Sequence

OPTION_REF 2..5
Mit diesem Element werden Varianten referenziert, die zu einer Kombi-Varianten zusammengefasst werden sollen.

Variantenarten > 950 sind grafisch nur für Echtgrafik relevant, daher dürfen diese nicht als Kombivarianten angelegt werden.

FEATURE_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Variantenart referenziert.

D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]

OPTION_KEY required Restriction of xs:string

Mit diesem Attribut wird eine Variantenausprägung referenziert.

D string
P
M [1:5]

FEATURE 1..∞
In diesem Element wird eine Variantenart definiert.

FEATURE_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die Variantenart identifiziert.

D nonNegativeInteger
P
M [0:999]

Sequence

OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.

Sequence

OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werde und haben Priorität gegenüber entsprechenden Farbvarianten.

FEATURE_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein.

D nonNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

Mit diesem Attribut wird eine Variantenausprägung definiert. Falls es sich hierbei um eine Ausprägung der Variantenart 1 (d. h. Programm) handelt muss, falls in STYLE_REF ein Programm über STYLE_NO referenziert wird, der Wert von diesem Attribut identisch mit der referenzierten STYLE_NO sein.

D string
P
M [1:5]

SEQUENCE_NO optional Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Sortierung der Varianten ermöglicht. Das Attribut muss nicht durchgehend gefüllt werden. Es können alle Varianten mit diesem Sortierkriterium versehen werden.

D nonNegativeInteger
P
M

Sequence

Choice optional

STYLE_REF
Dieses Element referenziert ein Programm.

MATERIAL_REF
Dieses Element referenziert ein Material.

HANDLE_ORIENTATION_REF
Dieses Element referenziert eine Grifflage.

FORM_REF
Dieses Element referenziert eine Form.

OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert. Zur Zeit kann dieses Element nur für die Sockelhöhe (Variantenart 402) verwendet werden.

HANDLE_POSITION_REF
Dieses Element referenziert eine Griffpositionierung.

OPTION_TEXT languagetexte60 Complex Type
In diesem Element wird ein Variantentext definiert.

OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.

VALID_FROM optional Restriction of xs:date

Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.

D date
P
M

VALID_UNTIL optional Restriction of xs:date

Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss.

D date
P
M

MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger

In diesem Element wird die Mindestlieferzeit in Wochen angegeben. Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung)

D nonNegativeInteger
P
M [0:999]

FRONT_APPEARANCE_REF optional
Durch dieses Element wird eine Beziehung zwischen der definierten Variante und einer Frontausprägung definiert. Eine hier referenzierte Frontausprägung muss im Element Pfad1/FRONT_APPEARANCE definiert sein.

Dieses Element Feld darf genutzt werden, wenn die im Attribut Pfad2/FEATURE_NO angelegte Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) ist.

Für die Verarbeitung dieses Elementes gilt folgende Regelung:
Besitzt ein Artikel eine Glastür, die Variantenart 154 ist in der Variantenfamilie des Artikels enthalten, so wird die FRONT_APPEARANCE_NO dieses Elementes verwendet. In allen anderen Situationen wird Pfad3/FRONT_APPEARANCE_REF verwendet.

Ab Füllstufe 2b muss dieses Feld gefüllt werden.

Elementpfade:
Pfad1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
Pfad2 = FEATURE_DEFINITION/FEATURES/FEATURE
Pfad3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.

FEATURE_TEXT languagetexte60 Complex Type
Dieses Element enthält Texte für Variantenarten.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,60}
M [1:60]

SEQUENCE_NO Restriction of xs:nonNegativeInteger

In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad1)), wird das Element nicht gefüllt.

Elementpfade
Pfad1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/

D nonNegativeInteger
P
M [0:999]

HEADER_POS_VARIATION_TYPE Restriction of xs:string

Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante,
U = unsichtbare Kopfvariante,
P = Positions-Variantenart oder
V = erbende Variantenart
ist.

Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.
Unsichtbare Kopfvarianten dürfen nur in den Elementen OPTION (Pfad 1) und COMBINED_FEATURE (Pfad 2) verwendet werden.

Das Kennzeichen V wird gesetzt, wenn es sich um eine Variantenart handelt, die Informationen einer anderen Variantenart erbt. Die Vererbung erfolgt innerhalb eines Artikels, daher darf dieses Kennzeichen nur bei den Variantenarten 202, 203, 205 und 208 gesetzt werden. Ist das Kennzeichen gesetzt, muss das
Element INHERIT_VARIATION_TYPE_REF (Pfad 3) zwingend mit einer Variantenart 202, 203, 205 oder 208 gefüllt sein, die im Element HEADER_POS_VARIATION_TYPE (Pfad 3) das Kennzeichen K oder P enthält.
Erbende Variantenarten dürfen in keinem anderen Element verwendet werden.
Mit „I“ gekennzeichnete Varianten sind unsichtbare Varianten, die aber für Prüfungen zur Verfügung stehen. Derzeit fällt unter Kennzeichnung "I" nur die Variantenart 305 = Bohrschema.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
Pfad 2: FEATURE_DEFINITION/FEATURES
Pfad 3: FEATURE_DEFINITION/FEATURES/FEATURE

D nonNegativeInteger
P
M [0:999]

INHERIT_VARIATION_TYPE_REF optional
In diesem Element wird die Variantenart referenziert, von der die Variantenart Informationen erben soll.
Die Variantenarten 202, 203, 205 und 208 dürfen auch untereinander Informationen vererben.
Die hier angegebene Variantenart darf keine als "unsichtbar" deklarierte Variantenart sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird die referenzierte Variantenart angegeben.

D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]

OPTION_DEFINITION
In diesem Element werden die Ausprägungen von Farben, Materialien, Griffen, Formvarianten und Programmen definiert.

Sequence

STYLE 0..∞
In diesem Element werden die Programme definiert.
Die hier definierten Programme werden über das Element STYLE_REF (Pfad1) als Variante angelegt. Das Programm hat die Variantenart 1 (FEATURE_NO = 1).

Die Attribute eines Programms dürfen sich über die Serien hinweg nicht unterscheiden. Da ein Programm nur in diesem Element beschrieben und von den Serien referenziert wird, ist die vorgenannte Bedingung durch die Struktur implizit abgebildet.

Dieses Element ist nur optional, wenn im Element SUPPLIER/BRANCH_ID der Wert für die Branchen-ID "G" oder "Z" ist.

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES/

STYLE_NO required Restriction of xs:string

In diesem Attribut wird der herstellerspezifische Programmschlüssel angegeben. Es wird vom Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

P1: FEATURE_DEFINITION/OPTION_DEFINITION/

D string
P
M [1:5]

Sequence

FRONT_DEPTH optional Restriction of xs:nonNegativeInteger

In diesem Element wird die programmspezifische Fronttiefe [mm] definiert. Als Vorgabewert bei keiner Angabe gilt 20 mm.
Dieses Element muss gefüllt werden, wenn das Element FRONT_APEREANCE_NO (Pfad1) gefüllt ist.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/

D nonNegativeInteger
P
M [1:99]

FRONT_DISTANCE optional Restriction of xs:nonNegativeInteger

In diesem Element wird der programmspezifische Türpuffer[mm] definiert. Es stellt den Abstand zwischen Tür und dahinter gelagertem Korpus dar.

D nonNegativeInteger
P
M [1:99]

FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Programm eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.

FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger

Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird.

D positiveInteger
P
M [1:999]

FRONT_GROUP_REF optional
Mit diesem Element wird einem Programm eine Frontgruppe zugeordnet.
Sind die Frontaufteilungen von Artikeln über mehrere Programme gleich, können diese angegeben, in der mehrere Programme zusammengefasst werden können. Die Programme können zusammengefasst werden, wenn sich deren Frontaufteilungen nicht unterscheiden.
Dieses Element referenziert das Attribut SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
Bei Herstellern, deren Frontaufteilungen einzelner Schränke in einzelnen Programmen unterschiedlich sind, wird für die entsprechenden Programme eine Frontgruppe angelegt.
Bei Herstellern, deren Frontaufteilungen für alle Schränke programmunabhängig sind, wird keine Frontgruppe angegeben.
Häufig können beispielsweise alle Stilfronten zu einer Frontgruppe zusammengefasst werden, da sie in der Regel bei einer hohen Tür in der gleichen Weise unterteilt werden.
Die unterschiedlichen Frontaufteilungen bei beispielsweise verschiedenen Einbaugeräten ist unabhängig von der Frontgruppe.
Wird für ein Programm eine Frontgruppe angelegt, so müssen allen Programmen Frontgruppen zugeordnet werden.

FRONT_GROUP_NO required Restriction of xs:positiveInteger

Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein.

D positiveInteger
P
M [1:99]

FEATURE_CLASS_REF optional
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/

FEATURE_CLASS_NO required Restriction of xs:positiveInteger

Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/

D nonNegativeInteger
P
M [1:999]

DEFAULT_OPTION_GROUP_REF 0..∞
Mit diesem Element werden dem Programm Standardvorschläge zugeordnet.

DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger

Mit diesem Attribut wird ein Standardvorschlag referenziert.

D positiveInteger
P
M [1:999999999]

RESTRICTIONS optional
Dieses Element referenziert Prüfverfahren, die für das Programm angewendet werden (Programm-spezifische Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.

Sequence

RESTRICTION_REF 1..∞
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.

RESTRICTION_NO required Restriction of xs:nonNegativeInteger

Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.

D nonNegativeInteger
P
M [1:99999]

SEQUENCE required Restriction of xs:positiveInteger

Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element SEQUENCE erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …).

D positiveInteger
P
M [1:99999]

HANDLE_ORIENTATION 0..∞
In diesem Element wird eine Grifflage definiert.

HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger

Mit diesem Attribut wird eine Griffausprägung identifiziert.

D string
P
M [1:5]

Sequence

DEFAULT_HANDLE_ORIENTATION_REF optional

In diesem Element wird eine Variante für eine Basisgrifflage angelegt. Es wird eine Basisgrifflage referenziert, die im Element BASIC_HANDLE_POSITIONS (Pfad 1) definiert ist.

Im Element OPTION_KEY (Pfad 2) wird die herstellerspezifische Bezeichnung einer eingetragen.

Das Element Standard-Grifflage muss gefüllt werden, wenn im Element FEATURE (Pfad 3) die Variantenart 304 (Grifflage) eingetragen ist.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
Pfad 3: FEATURE_DEFINITION/FEATURES

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Standardgrifflage identifiziert.

D nonNegativeInteger
P
M [1:99999]

MATERIAL 0..∞
In diesem Element wird ein Material definiert.

Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur (TEXTURE) noch Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.

MATERIAL_NO required Restriction of xs:string

Mit diesem Attribut wird ein Material identifiziert.

D string
P
M [1:5]

Sequence

Choice optional

COLOR
In diesem Element werden Farben definiert.

Sequence

RGB_RED Restriction of xs:nonNegativeInteger

Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein.

D nonNegativeInteger
P
M [0:255]

RGB_GREEN Restriction of xs:nonNegativeInteger

Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein.

D nonNegativeInteger
P
M [0:255]

RGB_BLUE Restriction of xs:nonNegativeInteger

Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein.

D nonNegativeInteger
P
M [0:255]

TEXTURE
In diesem Element werden die Informationen für Texturen hinterlegt.

Sequence

FILE_NAME_TEXTURE Restriction of xs:string

In dieses Element werden Verweise auf Dateien mit Materialtexturen hinterlegt.

D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]

TEXTURE_REPEAT optional
Über dieses Element wird definiertgekennzeichnet, ob eine Textur einmal oder sich wiederholend aufgebracht wird (gekachelt). Soll die Textur gekachelt werden, wird das Element angelegt und die notwendigen Daten in den entsprechenden Kindelementen hinterlegt.
Kachelungsfaktor wird von der Software auf Basis der Texturgröße (DPI, Anzahl Pixel) bestimmt.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein.

TEXTURE_TILE optional Restriction of xs:int

Über dieses Attribut wird gekennzeichnet, ob eine Textur einmal (0 = nicht kacheln) oder sich wiederholend (1 = kacheln) aufgebracht wird.

D integer
P
M [0:1]

Sequence

REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger

Hier wird das reale Maß der Textur in X-Richtung angegeben. Der Wert wird in mm angegeben.

D nonNegativeInteger
P
M [1:9999]

REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger

Hier wird das reale Maß der Textur in Y-Richtung angegeben. Der Wert wird in mm angegeben.

D nonNegativeInteger
P
M [1:9999]

MASKING optional Restriction of xs:boolean

Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein.

D boolean
P
M

TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string

Mit diesem Attribut wird eine Standardgrifflage identifiziert.

D string
P |[HV]
M [0:1]

TRANSPARENCY optional Restriction of xs:nonNegativeInteger

Dieses Element definiert den Grad der Transparenz eines Materials (RGB-Wert oder Textur).
0 = opak
9 = max. Transparenz
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein.

D nonNegativeInteger
P
M [0:9]

BRIGHTNESS optional Restriction of xs:nonNegativeInteger

Dieses Element definiert den Grad des Glanzes eines Materials (RGB-Wert oder Textur).
0 = matt
8 = Hochglanz
9 = Spiegelung
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein.

D nonNegativeInteger
P
M [0:9]

FORM 0..∞
In diesem Element wird eine Formvariante definiert.

FORM_NO required Restriction of xs:string

Mit diesem Attribut wird eine Profilform identifiziert.

D string
P
M [1:5]

Sequence

PROFILE_KEY Restriction of xs:string

In diesem Element wird der herstellerspezifische Key für eine Profilform hinterlegt. Mit diesem Element werden Varianten der Variantenarten 750-756 gebildet. Das Element FORM kann nur von den Variantenarten 750-756 genutzt werden. Die gebildete Varianten werden vom Artikel (ITEM) referenziert, der das Profil darstellt.

D string
P
M [1:5]

OPTION_MEASURE 0..∞
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Sockelhöhe (Variantenart 402)).

OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine maßliche Ausprägung identifiziert.

D nonNegativeInteger
P
M [1:99999]

Sequence

PLINTH_HEIGHT Restriction of xs:nonNegativeInteger

In diesem Element wird die Sockelhöhe in mm angegeben.

D nonNegativeInteger
P
M [0:999999999]

STANDARD_PLINTH optional xs:boolean

In diesem Element wird angegeben, ob es sich bei der entsprechenden Sockelhöhe um einen Standard handelt, oder ob die Höhe vom Standard abweicht. Ist der Wert false(0), handelt es sich bei der Sockelhöhe um eine vom Standard abweichende Höhe, die eventuell mit einem Mehrpreis für die Sockelfüße verbunden ist.

Fehlt das Element, entspricht es dem Wert true(1).

Gibt es verknüpfte Artikel mit der Zuordnungsart CLASS = 21, muss dieses Element angegeben werden.

D boolean
P
M [0:1]

RESTRICTIONS optional
In diesem Element werden die Prüfverfahren angelegt.

Sequence

RESTRICTION 1..99999
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1

RESTRICTION_NO required Restriction of xs:nonNegativeInteger

Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert.

D nonNegativeInteger
P
M [1:99999]

FEATURE_1_NO required Restriction of xs:nonNegativeInteger

In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln.

D nonNegativeInteger
P
M [0:999]

FEATURE_2_NO optional Restriction of xs:nonNegativeInteger

In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln.

D nonNegativeInteger
P
M [0:999]

FEATURE_3_NO optional Restriction of xs:nonNegativeInteger

In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln.

D nonNegativeInteger
P
M [0:999]

VALIDATION_TYPE required Restriction of xs:int

Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefüllt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405)

D nonNegativeInteger
P
M [0:1]

Sequence

RESTRICTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,60}
M [1:60]

OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination gebildet.

Sequence

OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.

FEATURE_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Variantenart referenziert.

D nonNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

Mit diesem Attribut wird eine Variantenausprägung referenziert.

D string
P
M [1:5]

Sequence optional

MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES

DIMENSION_TYPE required Restriction of xs:string

In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe

D string
P [WHD]
M [1:1]

DIMENSION_VALUE required Restriction of xs:nonNegativeInteger

In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES

D nonNegativeInteger
P
M [1:9999]

MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.

DIMENSION_TYPE required Restriction of xs:string

In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe .

D string
P [WHD]
M [1:1]

DIMENSION_VALUE required Restriction of xs:nonNegativeInteger

Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.

D nonNegativeInteger
P
M [1:9999]

TEST_ID Restriction of xs:boolean

Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt

D boolean
P
M

SUGGESTIONS optional
In diesem Element werden Vorbelegungen angelegt.

Sequence

SUGGESTION 1..99999

In diesem Element wird eine Vorbelegung für Variantenarten mit bestimmten Varianten definiert und beschrieben.

Diese Möglichkeit der Vorbelegung ist nur für Kopfvarianten vorgesehen und wirksam bei der Ersterfassung einer Planung.

Ähnlich wie ein Standardvorschlag (DEFAULT_OPTION_GROUP) wird sie unterhalb der Serie referenziert, wobei der Standardvorschlag mit höherer Priorität greift.

Über OPTION_COMBINATION können auch Paare von Varianten für variantenabhängige Vorbelegungen zur Verfügung gestellt werden.

Dabei ist die unter FEATURE_1_NO angegebene Variantenart die führende.

Die Vorbelegungen dürfen nicht den dazugehörigen Prüfungen widersprechen.

SUGGESTION_NO required Restriction of xs:nonNegativeInteger

Durch dieses Attribut werden Vorbelegungen eindeutig identifiziert.

D nonNegativeInteger
P
M [1:99999]

FEATURE_1_NO required Restriction of xs:nonNegativeInteger

In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden.

D nonNegativeInteger
P
M [0:999]

FEATURE_2_NO optional Restriction of xs:nonNegativeInteger

In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden.

D nonNegativeInteger
P
M [0:999]

FEATURE_3_NO optional Restriction of xs:nonNegativeInteger

In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden.

D nonNegativeInteger
P
M [0:999]

Sequence

SUGGESTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wird die Bezeichnung einer Vorbelegung hinterlegt.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,60}
M [1:60]

OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination für die Vorbelegung gebildet.

Sequence

OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einer Vorbelegung angegeben werden.

FEATURE_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Variantenart referenziert.

D nonNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

Mit diesem Attribut wird eine Variantenausprägung referenziert.

D string
P
M [1:5]

PRICE_DEFINITION
In diesem Element werden Informationen hinterlegt, die für die Preisberechnung notwengig sind wie beispielsweise Preistabellen und Ausführungsgruppen.

Sequence

PRICE_FEATURE_GROUPS
In diesem Element werden Preisvariantengruppen definiert.

Sequence

PRICE_FEATURE_GROUP 1..∞
In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

Eine Preisvariantengruppe wird vom Artikel referenziert. beim Artikel werden auch die konkreten Preise hinterlegt.

Für die Preisvariantengruppe bzw. für Artikel gelten folgende Regelungen:
- Ein preisgruppenneutraler Artikel hat keine Varianten.
- Preisgruppenabhängige Artikel haben die Variantenart 1 (Programm), die in FEATURE_NO_1 eingetragen werden muss, und optional die Variantenarten 101 (Frontfarbe 1) oder 105 (Frontkombination). Falls bei mindestens einer Preisfindung die Variantenart 101 oder 105 im Element FINISH/OPTION_REF angegeben wird, soll der entsprechende Wert in FEATURE_NO_2 eingetragen werden.
- Ausführungsabhängige Artikel haben ein oder zwei Variantenarten.
- Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0)

Es dürfen nicht mehrere Preisvariantengruppen mit der selben Kombination von Variantenarten angelegt werden. Beispielsweise sollte eine Preisvariantengruppe mit der Variantenart Griffausführung nur einmal existieren und alles abbilden was mit Griffausführung zusammenhängt.

PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger

Mit diesem Attribut wird eine PRICE_FEATURE_GROUP identifiziert.

D positiveInteger
P
M [1:99999]

ADDITIONAL_PRICE required Restriction of xs:boolean

Dieses Attribut ist ein Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis):
Wird eine Mehrpreisgruppe definiert (ADDITIONAL_PRICE=1), so darf über diese Mehrpreisgruppe kein "Preis auf Anfrage" gebildet werden. Bei einem Artikel, der diese Mehrpreisgruppe referenziert, darf das Element PRICE_ON_REQUEST (Pfad 1) nicht angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST

D boolean
P
M

PRICE_CALC_METHOD required Restriction of xs:nonNegativeInteger

In diesem Attribut wird definiert nach welcher grundsätzlichen Methode der Preis berechnet wird.

Folgende Methoden sind möglich:

0 = Preis auf Anfrage;
1 = programmneutraler Preis;
2 = programmabhängiger Preis;
3 = ausführungsabhängiger Preis.

Eine PRICE_FEATURE_GROUP, in der das Attribut PRICE_CALC_METHOD den Wert 0 (Preis auf Anfrage) hat, darf nur 1x angelegt werden.

D nonNegativeInteger
P
M [0:3]

FEATURE_NO_1 optional Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die erste Variantenart für die Preisfindung identifiziert.
Die in dem ersten Attribut OPTION_REF/FEATURE_NO angegebene Variantenart darf nicht von der im Attribut FEATURE_NO_1 angegebenen abweichen.

D nonNegativeInteger
P
M [0:999]

FEATURE_NO_2 optional Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die zweite Variantenart für die Preisfindung identifiziert.
Die in dem zweiten Attribut OPTION_REF/FEATURE_NO angegebene Variantenart darf nicht von der im Attribut FEATURE_NO_2 angegebenen abweichen.

D nonNegativeInteger
P
M [0:999]

Sequence

PRICE_FEATURE_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält Texte für Ausführungsgruppen.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,60}
M [1:60]

FINISH 0..∞
In diesem Element werden gültigen Variantenkombinationen Preisfelder (Preisfeld, Blockpreisfeld) und eine Herstellerpreisgruppe zugeordnet.

Wenn das Attribut PRICE_CALC_METHOD den Wert 0 hat (Preis auf Anfrage), darf das Element FINISH nicht angelegt werden.

Sequence

OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.

FEATURE_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Variantenart referenziert.

D nonNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

Mit diesem Attribut wird eine Variantenausprägung referenziert.

D string
P
M [1:5]

PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

D positiveInteger
P
M [1:250]

BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

D nonNegativeInteger
P
M [1:250]

SUPPLIER_PRICE_GROUP Restriction of xs:string

In diesem Element wird die Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet.

D string
P
M [1:10]

SET_OF_EXCHANGE_IDS optional
In diesem Element werden die herstellerspezifischen Tausch-IDs definiert.

Liefert ein Hersteller Blöcke, so muss dieses Element in der Katalogdatei enthalten sein. Das Element muss auch dann in der Katalogdatei enthalten sein, wenn ein Hersteller außerhalb der Katalogdatei, zu einem späteren Zeitpunkt Blöcke liefert. Das Element darf in einer Blockdatei nicht enthalten sein.

Sequence

EXCHANGE_ID 1..∞
Das Element EXCHANGE_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS verwendet werden.

EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger

Das Attribut dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

Sequence

EXCHANGE_ID_TEXT languagetexte40 Complex Type
Der Text in diesem Element erläutert die Tauschgruppen, beispielsweise:
- Möbelteile
- Arbeitsplatten
- Lichtblenden/Kranzprofile
- Zubehör
- Elektrogeräte.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,40}
M [1:40]

VALUE_ADDED_TAXES
In diesem Element werden die gültigen Mehrwertsteuersätze definiert, die von Artikeln referenziert werden. Die angegebenen Steuersätze müssen mit dem angegebenen Land korrespondieren, welches im Element COUNTRY_ID (Pfad 1) angegeben wurde.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION

Sequence

VALUE_ADDED_TAX 1..100
In diesem Element wird ein Mehrwertsteuersatz definiert.

VAT_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird eine ID für einen Mehrwertsteuersatz hinterlegt. Die ID 0 ist für Artikel reserviert, die keiner Mehrwertsteuer unterliegen.

D nonNegativeInteger
P
M [0:99]

Sequence

VAT_RATE Restriction of xs:nonNegativeInteger

In diesem Element wird der zugehörige Mehrwertsteuersatz in Prozent inklusive zwei Nachkommastellen angegeben (z. B. 1600 für 16,00 % oder 10 für 0,1%).

D nonNegativeInteger
P
M [0:9999]

IDENT_NUMBERS optional
In diesem Element werden die Identnummern definiert. Alle im Datenbestand verwendeten Identnummern müssen hier definiert werden.

Sequence

IDENT_NUMBER 0..9999
In diesem Element werden die Identnummern definiert. Alle im Datenbestand verwendeten Identnummern müssen hier definiert werden.

IDENT_NO required Restriction of xs:positiveInteger

In diesem Attribut wird eine Identnummer definiert.

D positiveInteger
P
M [1:9999]

Sequence

SERIE_REF 1..99
Das Element referenziert eine Serie. Wird keine Serie referenziert, sind die angegebenen Identnummern serienübergreifend gültig.

SERIE_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.

D nonNegativeInteger
P
M [0:99]

PRICE Restriction of xs:integer

In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden -> -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt.

D nonNegativeInteger
P
M [0:99]

MERCHANDISE_GROUP 1..∞
Mit diesem Element wird eine Warengruppe angelegt. Die Warengruppe (Konditionsschiene des Herstellers) sowie der dazugehörige Text müssen mit dem Konditionsblatt des Herstellers übereinstimmen. Einer Warengruppe werden 1-n Kalkulationsgruppen zugeordnet.

MERCHANDISE_GROUP_NO required Restriction of xs:string

Mit diesem Attribut wird eine Warengruppe identifiziert.

D string
P
M [1:5]

Sequence

MERCHANDISE_GROUP_TEXT languagetexte30 Complex Type
Dieses Element enthält Texte für Warengruppen.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,30}
M [1:30]

Sequence

CALC_GROUP 1..∞

In diesem Element werden die möglichen Kalkulationsgruppen definiert. Die Verwendung kann beispielsweise für unterschiedliche Rabattierungen sinnvoll sein. Dies bedeutet, dass je nach Anzahl der Rabattstaffelungen hier entsprechend viele Kalkulationsgruppen gebildet werden können. Im Element ITEM werden die Artikel einer Kalkulationsgruppe zugeordnet. Es dürfen nur Kalkulationsgruppen definiert werden, die von Artikeln referenziert werden. Schlüssel ist das Feld CALC_GROUP_NO.

Bei der Nutzung derselben Kalkulationsgruppe wird auch die gleiche Preisfindung verwendet.

Eine Kalkulationsgruppe kann innerhalb aller Elemente MERCHANDISE_GROUP nur ein Mal verwendet werden. Das heiß, das eine Kalkulationsgruppe nur in einer einzigen MERCHANDISE_GROUP verwendet werden darf und nicht in mehreren MERCHANDISE_GROUP's.

Die Kalkulationsgruppe wird über das Attribut CALC_GROUP_NO angegeben.

CALC_GROUP_NO required Restriction of xs:positiveInteger

Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination "00" ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
8 = diverses 1
9 = diverses 2

Einstellige Zahlen 0 – 9 sind ausgeschlossen, d.h. führende Nullen sind nicht erlaubt.

Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers.

D positiveInteger
P
M [10:99]

Sequence

CALC_GROUP_TEXT languagetexte30 Complex Type
Dieses Element enthält Texte für Kalkulationsgruppen.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,30}
M [1:30]

CALCULATION_FACTOR optional Restriction of xs:nonNegativeInteger

Dieses Element darf nur verwendet werden, wenn das Element PRICE_ID (Pfad 1) den Wert 3 hat.

Wenn Verrechnungspunkte verwendet werden, so muss in diesem Element der entsprechende Verrechnungsfaktor angegeben werden.
Der Verrechnungfaktor wird mit maximal fünf Vorkommastellen und genau drei Nachkommastellen (ohne das Komma selbst) eingetragen. Der Verrechnungsfaktor muss größer Null sein.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION

D nonNegativeInteger
P
M [1:99999999]

PRICE_TYPES
In diesem Element werden die Preisarten zur stück- oder maßvariablen Berechnung von programmneutralen und programmabhängigen Artikeln definiert.
Die Kind-Elemente WIDTH_X, DEPTH_Y, HEIGHT_Z geben an, ob der Preis für einen Artikel, der nach dieser Preisart berechnet wird, breiten-, höhen-, tiefen-, flächen- bzw. volumenabhängig ist.
Wenn für keine Dimension eine "1" angegeben ist, ist der Preis nicht maßabhängig, wird also per Stück berechnet (beispielsweise ein Unterschrank). Dann werden die Elemente BASIC_UNIT und ROUNDING_UNIT mit dem Wert 0 belegt.
Wird für genau eine Dimension eine "1" angegeben, so wird diese Dimension für die Preisberechnung herangezogen (beispielsweise Lichtleisten).
Wenn für genau zwei Dimensionen eine "1" angegeben ist, so ist der Preis flächenabhängig (beispielsweise Verkleidungsmaterial).
Wenn für genau drei Dimensionen eine "1" angegeben ist, so ist der Preis volumenabhängig (beispielsweise Lacke, Beizen).

Sequence 1..∞

PRICE_TYPE
In diesem Element wird eine Preisart definiert.

PRICE_TYPE_NO required Restriction of xs:positiveInteger

Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert.

D positiveInteger
P
M [1:250]

Sequence

WIDTH_X Restriction of xs:boolean

Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen.

D boolean
P
M

DEPTH_Y Restriction of xs:boolean

Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen.

D boolean
P
M

HEIGHT_Z Restriction of xs:boolean

Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen.

D boolean
P
M

BASIC_UNIT Restriction of xs:nonNegativeInteger

Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (Pfad1) und ADDITIONAL_PRICE (Pfad2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in diesem Element "1000" anzugeben, bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³]. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein.

Pfad1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
Pfad2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/

D nonNegativeInteger
P
M [0:999999999999]

ROUNDING_UNIT Restriction of xs:nonNegativeInteger

Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein.

D nonNegativeInteger
P
M [0:999999999999]

BASIC_PRICE_DEPENDENT Restriction of xs:boolean

Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben, der sich auf die im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis unter Berücksichtigung der im Element definierten Logik zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

D boolean
P
M

PRICE_TYPE_FORMULA optional Restriction of xs:string

Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_X (Pfad1) (b), DEPTH_Y (Pfad1) (t) oder HEIGHT_Z (Pfad1) (h) auf true gesetzt werden;
- es können die Grundrechenarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (Pfad1), ROUNDING_UNIT (Pfad1) und BASIC_PRICE_DEPENDENT (Pfad1) gelten auch in Verbindung mit der Preisartformel

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/

D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]

PRICE_TYPE_NAME optional languagetexte60 Complex Type
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,60}
M [1:60]

BLOCK_VALUE_CALCULATION optional
In diesem Element wird die Block- und Werteverrechnung definiert.

Sequence

BLOCK_CONDITIONS optional
In diesem Element werden Bedingungen formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.

Ein Block darf für einen Auftrag angewendet werden, wenn alle für diesen Block formulierten Bedingungen erfüllt sind. Die einem Block zugeordneten Bedingungen werden durch das Tupel ITEM_REF (Pfad 1) und OPERATION_ID (Pfad 1) gebildet.

Grundbedingung für die Anwendung der Blockbedingung ist, dass ein Block in einem der Programme existiert, die im Auftrag verplant wurden. Sind in einem Auftrag mehrer Programme ausgewählt, gilt das erste Programm im Auftrag auf Kopfebene.

Ein Block unterliegt der Programm- und Variantensteuerung wie "normale" Artikel. Wenn ein Verrechnungsblock in einer Preisgruppe existieren soll, so wird ein entsprechendes Element ITEM_PRICE (Pfad 2) mit dem Preis 0 angelegt.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein, damit der Block für die Werteverrechnung oder die Blockverrechnung angewendet werden darf.

Pfad 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence

BLOCK_CONDITION 1..∞
In diesem Element wird eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.

Sequence

ITEM_REF
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.

TYPE_NO required Restriction of xs:string

In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60).

D string
P
M [1:15]

SERIE_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.

D nonNegativeInteger
P
M [0:99]

CONDITION_RULES
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.

Sequence

CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.

Sequence

CLEARING_GROUP_REF 1..999
Dieses Element referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder ein zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.

Choice

MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger

Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Wert bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt.

D nonNegativeInteger
P
M [0:999999999]

MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger

Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt.

D nonNegativeInteger
P
M [0:999999]

BLOCK_SALE_PRICES optional
In diesem Element werden Blockaktionspreise formuliert.

Sequence

BLOCK_SALE_PRICE 1..∞
Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie dürfen nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich außer Kraft gesetzt.
Es wird genau die Informationen zeitlich aßser Kraft gesetzt, die in dem Element angegebne sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wird durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Sequence

ITEM_REF
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.

TYPE_NO required Restriction of xs:string

In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60).

D string
P
M [1:15]

SERIE_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.

D nonNegativeInteger
P
M [0:99]

VARIATION_PRICE_DEFINITION 1..∞
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.

Sequence

VALID_FROM Restriction of xs:date

Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen.

D date
P
M

VALID_UNTIL Restriction of xs:date

Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen.

D date
P
M

OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.

FEATURE_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird eine Variantenart referenziert.

D nonNegativeInteger
P
M [0:999]

OPTION_KEY required Restriction of xs:string

Mit diesem Attribut wird eine Variantenausprägung referenziert.

D string
P
M [1:5]

PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger

In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

D nonNegativeInteger
P
M [0:999999999]

GRADING_TABLE optional

In diesem Element werden die Wertestaffeln zur Verrechnung der Gutschriften oder Aufschläge definiert.

Wenn ein Verrechnungsblock für einen Auftrag gültig ist, kann mit dem Block in die Wertestaffel eingestiegen werden. Je gültigem Block in der Wertstaffel wird eine Vergleichssumme für die in dem Element angegebene Verrechnungsgruppe (CLEARING_GROUP (Pfad 1)) bestimmt. Entspricht der Wert der Vergleichssumme dem angegebenen Wertebereich (Elemente VALUE_FROM (Pfad 2) und VALUE_TO (Pfad 2)), so wird das Element angewendet, d. h. die im Element TYPE_CREDIT (Pfad 2) und/oder TYPE_DEBIT (Pfad 2) hinterlegte Type wird verrechnet. Die Berechnung erfolgt auf die Summe der Kalkulationsgruppe, die für die Gutschrift- oder Belastungstype angegeben ist (Element ITEM (Pfad 3)).

Für einen Block können mehrere Staffelbereiche angelegt werden. Jeder Staffelbereich wird einem Element COMPARING_RULES (Pfad 4) zugeordnet. In einer Staffel eines Blocks müssen die Bedingungen aller Wertebereiche mit jeweiliger Verrechnungsgruppe erfüllt sein, bevor die Positionen verrechnet werden können. Die einzelnen Elemente (COMPARING_RULE) sind UND-verknüpft.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein.

Werden auf dem Element GRADING_TABLE mehrere Datensätze eines Verrechnungsblocks angewendet, so wird der Wert des Blocks (ITEM (Pfad 3)), ITEM_PRICE (Pfad 5)) jedoch nur einmal berechnet.

Pfad 1: GLOBAL_DEFINITION
Pfad 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence

CREDIT_SURCHARGE_CLEARING 1..∞
In diesem Element wird ein Wertebereich der Wertestaffel definiert.

Sequence

ITEM_REF

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string

In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60).

D string
P
M [1:15]

SERIE_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.

D nonNegativeInteger
P
M [0:99]

COMPARING_RULES 1..∞
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.

Sequence

COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.

Sequence

CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger

Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.

D nonNegativeInteger
P
M [0:999]

VALUE_FROM Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

D nonNegativeInteger
P
M [0:999999999]

VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

D nonNegativeInteger
P
M [0:999999999]

TYPE_CREDIT optional Restriction of xs:string

Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.
Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

D string
P
M [1:15]

TYPE_DEBIT optional Restriction of xs:string

Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.
Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

D nonNegativeInteger
P
M [1:250]

SET_OF_BLOCK_RULES
In diesem Element und den Kind-Elementen werden die herstellerspezifischen Regelwerke beschrieben.

Sequence

EXCHANGE_ID_GROUP 1..∞
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.

Sequence

EXCHANGE_ID_1_REF
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Kommissions- bzw. Planungsartikel.

EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger

Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Kommissions- bzw. Planungsartikels.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

EXCHANGE_ID_2_REF
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Artikels aus einem Block.

EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger

Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Blockartikels.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

RULE 1..99
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.

RULE_NO required Restriction of xs:nonNegativeInteger

In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben.

D nonNegativeInteger
P
M [1:99]

Sequence

RULE_TEXT languagetexte60999 Complex Type
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.

RULE_SET_TEXT languagetexte60999 Complex Type
In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.

Sequence

LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.

ISO_LANGUAGE_ID required Restriction of xs:language

In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.

D language
P [A-Z]{2}
M [2:2]

Sequence

TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.

SEQUENCE_NO required Restriction of xs:positiveInteger

Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen.

D positiveInteger
P
M

Sequence

TEXT Restriction of xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

D string
P [\S ]{1,60}
M [1:60]

Attribute

Name

Typ

Verwenden

Standard

Festgelegt

Beschreibung

MAJOR

Restriction of xs:positiveInteger

required

Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION.

D nonNegativeInteger
P
M [2]

MINOR

Restriction of xs:nonNegativeInteger

required

Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.

D nonNegativeInteger
P
M [0:99]

REVISION

Restriction of xs:nonNegativeInteger

required

Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.

D nonNegativeInteger
P
M [0:99]

Bemerkung

Quelle
<xs:element name="T_NEW_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Signature" minOccurs="0" maxOccurs="1">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SignedInfo">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CanonicalizationMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SignatureMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="Reference">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="Transforms">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="Transform">
                                <xs:complexType>
                                  <xs:simpleContent>
                                    <xs:extension base="xs:string">
                                      <xs:attribute name="Algorithm" type="xs:anyURI" />
                                    </xs:extension>
                                  </xs:simpleContent>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DigestMethod">
                          <xs:complexType>
                            <xs:simpleContent>
                              <xs:extension base="xs:string">
                                <xs:attribute name="Algorithm" type="xs:anyURI" />
                              </xs:extension>
                            </xs:simpleContent>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DigestValue" type="xs:string" />
                      </xs:sequence>
                      <xs:attribute name="URI" type="xs:string" />
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SignatureValue" type="xs:string" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FILE_RELEASE_DATE" type="xs:dateTime">
              <xs:annotation>
                <xs:documentation>100--2--Dateifreigabe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_ID">
                    <xs:annotation>
                      <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--13--Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_KIND">
                    <xs:annotation>
                      <xs:documentation>Katalog-Art</xs:documentation>
                      <xs:documentation>1 für Basiskatalog</xs:documentation>
                      <xs:documentation>2 für Verbandskatalog</xs:documentation>
                      <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
                      <xs:documentation>geändert 17.04.2019</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ASSOC_CTM_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRODUCT_BRANDNAME">
                    <xs:annotation>
                      <xs:documentation>100--40--Produktmarke</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_ID">
                    <xs:annotation>
                      <xs:documentation>100--49--Preis_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT">
                    <xs:annotation>
                      <xs:documentation>200--4--MwSt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_YEAR" type="xs:gYear">
              <xs:annotation>
                <xs:documentation>Jahr der Neuerstellung</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="MAJOR_NO">
              <xs:annotation>
                <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DATA_VERSION">
              <xs:annotation>
                <xs:documentation>100--11--Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_FROM_DATE">
              <xs:annotation>
                <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_ID">
              <xs:annotation>
                <xs:documentation>100--14--Datei_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MARK">
              <xs:annotation>
                <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BKV]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILLING_LEVEL">
              <xs:annotation>
                <xs:documentation>100--44--Fuellstufe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[123]|2[a-n]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICING_TERMS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--48--Preisstellung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="1" />
                  <xs:pattern value="[01]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>110--3--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FALL_BACK_LANGUAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
                <xs:documentation>K. Richter 29.06.2017</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
                <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW  </xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW </xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>105--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EDI_FORMAT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--2--EDI_Format</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                        <xs:pattern value="EANCOM|EAN 97|EAN 97 A|EDIDATA" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="10" />
                        <xs:pattern value="[1-9]\.[0-9]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_MESSAGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_COMMUNICATION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="40" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_CONTACT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="BRANCH_ID">
              <xs:annotation>
                <xs:documentation>100--8--Branchen_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[ABGKOPSWZ]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="GLN_NO" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>100--45--GLN_Nr 30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, verpflichtend, K. Richter 21.08.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9]{13}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="WEEE_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--47--WEEE_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_PERSON" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONTACT_PERSON_NO">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_ROLE">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_NAME">
                    <xs:annotation>
                      <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FIRST_NAME">
                    <xs:annotation>
                      <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FORM_OF_ADDRESS">
                    <xs:annotation>
                      <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPARTMENT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE">
                    <xs:annotation>
                      <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONTACT_SUPPLIER">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_NAME_1">
                    <xs:annotation>
                      <xs:documentation>100--16--Herstellername_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--17--Herstellername_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INTERNET_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET">
                    <xs:annotation>
                      <xs:documentation>100--20--Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET">
                    <xs:annotation>
                      <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY">
                    <xs:annotation>
                      <xs:documentation>100--22--Ort</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--24--Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GLOBAL_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>120--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="CLEARING_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONTS_HANDLE_POSITIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SPECIFIC_HANDLE_POSITIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SPECIFIC_HANDLE_ORIENTATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="STYLE_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="STYLE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="WIDTH_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--4--Breite_von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="WIDTH_TO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--5--Breite_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HEIGHT_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--6--Hoehe_von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HEIGHT_TO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--7--Hoehe_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OPTION_REF">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="154" />
                                        <xs:maxInclusive value="154" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HANDLE_EXCHANGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FEATURE_REF">
                                      <xs:annotation>
                                        <xs:documentation>232--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FROM_HANDLE">
                                      <xs:annotation>
                                        <xs:documentation>232--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="OPTION_REF">
                                            <xs:annotation>
                                              <xs:documentation>232--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>232--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="300" />
                                                    <xs:maxInclusive value="303" />
                                                    <xs:pattern value="300|303" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>232--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="5" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TO_HANDLE">
                                      <xs:annotation>
                                        <xs:documentation>232--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="OPTION_REF">
                                            <xs:annotation>
                                              <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="300" />
                                                    <xs:maxInclusive value="303" />
                                                    <xs:pattern value="300|303" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="5" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FROM_HANDLE_ORIENTATION_REF">
                                      <xs:annotation>
                                        <xs:documentation>232--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TO_HANDLE_ORIENTATION_REF">
                                      <xs:annotation>
                                        <xs:documentation>----</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>----</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRIORITY">
                                <xs:annotation>
                                  <xs:documentation>232--14--Prioritaet</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="BASIC_HANDLE_POSITIONS">
                    <xs:annotation>
                      <xs:documentation>230--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="HANDLE_ORIENTATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>230--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_TYPE" maxOccurs="7">
                                <xs:annotation>
                                  <xs:documentation>230--3--Fronttyp</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ORIENTATION">
                                      <xs:annotation>
                                        <xs:documentation>230--4--Lage</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[HV]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="POSITION">
                                      <xs:annotation>
                                        <xs:documentation>230--5--Position</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[MADG0]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="FRONT_TYPE_CODE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>230--3--Fronttyp</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[SAKJTR]|GT" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>230--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FRONT_TYPES_GROUPS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>231--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_TYPES_GROUP" maxOccurs="99">
                          <xs:annotation>
                            <xs:documentation>231--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_TYPE" maxOccurs="7">
                                <xs:annotation>
                                  <xs:documentation>231--3--Fronttyp</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FRONT_TYPE_CODE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>231--3--Fronttyp</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[SAKJTR]|GT" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>231--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_APPEARANCES" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_APPEARANCE" maxOccurs="999">
                    <xs:annotation>
                      <xs:documentation>520--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_TYPE" maxOccurs="900">
                          <xs:annotation>
                            <xs:documentation>520--3--Fronttyp</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_TYPE_NO">
                                <xs:annotation>
                                  <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="900" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:sequence maxOccurs="unbounded">
                                <xs:element name="FRONT_CONSTRAINTS" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="WIDTH_FROM" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>520/570--6--Breite_von</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="WIDTH_TO" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>520/570--7--Breite_von</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="HEIGHT_FROM" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="HEIGHT_TO" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="FRONT_SHAPE">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="GLASS">
                                        <xs:annotation>
                                          <xs:documentation>520--10--Glas</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:boolean" />
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:choice>
                                        <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="BASIC_FRONT_SHAPE_ID">
                                                <xs:annotation>
                                                  <xs:documentation>520--4--Front_Grundform</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="3" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PARAMETERS" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="VALUE">
                                                    <xs:annotation>
                                                      <xs:documentation>520--5--Wert</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:maxLength value="12" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="PARAMETER">
                                                    <xs:annotation>
                                                      <xs:documentation>570--4--Parameter</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:minLength value="1" />
                                                        <xs:maxLength value="5" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:choice>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>520--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MODULE_RULE_SET_DEFINITIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MODULE_RULE_SET_DEFINITION" maxOccurs="unbounded">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MODULE_RULE_SET_NAME" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Um Mehrsprachenfaehigkeit erweitert AK 28.02.2012</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="8" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INFO_TYPE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                            <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                            <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[01]|99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="INTERNAL_NAME" type="languagetexte40">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="GUID">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="URL">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:anyURI">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="1024" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HASH_VALUE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="64" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESOLUTION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="4" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>Version 2.3 </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROPERTY" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>Version 2.3</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PROPERTY_TEXT" type="languagetexte" minOccurs="1" maxOccurs="1" />
                        <xs:element name="PROPERTY_UNIT" type="languagetexte30" minOccurs="0" maxOccurs="1" />
                      </xs:sequence>
                      <xs:attribute name="PROPERTY_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="GROUP_TITLES" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>120--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="GROUP_TITLE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>120--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="GROUP_TITLE_NAME" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="GROUP_TITLE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE" maxOccurs="100">
              <xs:annotation>
                <xs:documentation>200--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SERIES_NAME">
                    <xs:annotation>
                      <xs:documentation>200--3--Serienname</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>200--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>200--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PURCHASE_RETAIL_ID">
                    <xs:annotation>
                      <xs:documentation>200--5--EK_VK_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RESTRICTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="RESTRICTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SUGGESTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SUGGESTION_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SUGGESTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRODUCT_GROUPS">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_CLASS_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEMS">
                                <xs:annotation>
                                  <xs:documentation>400--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECO_MOBILIER" minOccurs="0">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[0-9]{11}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="NET_WEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                            <xs:annotation>
                                              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence minOccurs="0">
                                                <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>450/470--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="PRICE_FIELD">
                                                        <xs:annotation>
                                                          <xs:documentation>450--4--Preisfeld</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="250" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PRICE">
                                                        <xs:annotation>
                                                          <xs:documentation>450--5--Preis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:integer">
                                                            <xs:minInclusive value="-99999999" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:boolean" />
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>470--4--Preis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:integer">
                                                            <xs:minInclusive value="-99999999" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="99999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="PRICE_TYPE_REF">
                                            <xs:annotation>
                                              <xs:documentation>400/407--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400/407--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CALC_GROUP_REF">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="CALC_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="10" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PRICE_FEATURE_GROUP_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>460--1--Satzart</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="PRICE_FIELD">
                                                              <xs:annotation>
                                                                <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="250" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="PRICE">
                                                              <xs:annotation>
                                                                <xs:documentation>460--5--Preis</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:integer">
                                                                  <xs:minInclusive value="-99999999" />
                                                                  <xs:maxInclusive value="999999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="99999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="CALC_GROUP_REF" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="CALC_GROUP_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="10" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="[0-9]|[1-8][0-9]" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="PRICE_TYPE_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>407--5--Preisart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>407--5--Preisart</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="RESTRICTIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>409--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>409--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="RESTRICTION_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>409--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SEQUENCE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>409--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:maxInclusive value="99999" />
                                                          <xs:minInclusive value="1" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>406--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                                        <xs:annotation>
                                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                                          <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>120--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                            <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="SERIE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="99" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="TYPE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:minLength value="1" />
                                                                      <xs:maxLength value="15" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                    <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger">
                                                                      <xs:minInclusive value="1" />
                                                                      <xs:maxInclusive value="999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="SEQUENCE" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>Version 2.4.1</xs:documentation>
                                                                    <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:maxInclusive value="99999" />
                                                                      <xs:minInclusive value="1" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SET_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="9" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                                        <xs:annotation>
                                                          <xs:documentation>406--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>120--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                            <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="SERIE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="99" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="TYPE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:minLength value="1" />
                                                                      <xs:maxLength value="15" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                    <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger">
                                                                      <xs:minInclusive value="1" />
                                                                      <xs:maxInclusive value="999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="SEQUENCE" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>Version 2.4.1</xs:documentation>
                                                                    <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:maxInclusive value="99999" />
                                                                      <xs:minInclusive value="1" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SET_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="9" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="OPERATION_ITEM" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="SCOPE" maxOccurs="5">
                                                        <xs:annotation>
                                                          <xs:documentation>411--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>411--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="CLASS">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--7--Art</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="21" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="ITEM_REF" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:complexType>
                                                                      <xs:attribute name="SERIE_NO" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>411--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="99" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="TYPE_NO" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>411--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:string">
                                                                            <xs:minLength value="1" />
                                                                            <xs:maxLength value="15" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                    </xs:complexType>
                                                                  </xs:element>
                                                                  <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[LNR]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="COVER" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--9--Abdeckung</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="3" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="VALUE" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--10--Wert</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="VALUE_MIN" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                                                      <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="VALUE_MAX" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                                                      <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SCOPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>411--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="5" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="HINGE">
                                            <xs:annotation>
                                              <xs:documentation>400--4--Anschlag</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[BEJLMNR]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="EDP_NUMBER" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="EAN_NUMBER" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="9" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_IDENTIFICATION">
                                            <xs:annotation>
                                              <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[BEKSMZVPNOG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CATALOG_PAGE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="40" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                                              <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                                              <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:maxInclusive value="999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VAT_ID_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="VAT_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="VALID_FROM" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALID_UNTIL" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="WEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--20--Gewicht</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VOLUME" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--21--Volumen</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CONSTRUCTION_ID">
                                            <xs:annotation>
                                              <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[JLNRAE]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="OLD_SERIE_NO" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="99" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="OLD_TYPE_NO" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--27--Type_Alt</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="MASKING" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--30--Maskierung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:boolean" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="RANGE_DEPENDENT">
                                            <xs:annotation>
                                              <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:boolean" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="2" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BASIC_PROFILE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:choice>
                                                  <xs:element name="CARCASE_BASIC_SHAPE">
                                                    <xs:annotation>
                                                      <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                                          <xs:annotation>
                                                            <xs:documentation>400--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType mixed="true">
                                                            <xs:sequence>
                                                              <xs:element name="OPTION_REF">
                                                                <xs:annotation>
                                                                  <xs:documentation>430--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:complexType>
                                                                  <xs:attribute name="FEATURE_NO" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>430--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="OPTION_KEY" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>430--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:minLength value="1" />
                                                                        <xs:maxLength value="5" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                </xs:complexType>
                                                              </xs:element>
                                                            </xs:sequence>
                                                            <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>400--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[\S ]{1,5}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                          </xs:complexType>
                                                        </xs:element>
                                                        <xs:element name="BASIC_SHAPE_PARAMETERS">
                                                          <xs:annotation>
                                                            <xs:documentation>500--1--Satzart</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:sequence>
                                                              <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                                <xs:annotation>
                                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:complexType>
                                                                  <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--Parameter</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--5--Nennwert</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="BASIC_SHAPE_FROM">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--6--Von</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="BASIC_SHAPE_TO">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--7--Bis</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                </xs:complexType>
                                                              </xs:element>
                                                            </xs:sequence>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                      <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                  <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                                    <xs:annotation>
                                                      <xs:documentation>400--32--Massbild</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                                          <xs:annotation>
                                                            <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:string">
                                                              <xs:minLength value="1" />
                                                              <xs:maxLength value="240" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:element>
                                                        <xs:element name="DIMENSIONAL_PARAMETERS">
                                                          <xs:annotation>
                                                            <xs:documentation>500--1--Satzart</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:sequence>
                                                              <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                                <xs:annotation>
                                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:complexType>
                                                                  <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="DIMENSIONAL_FROM">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="DIMENSIONAL_TO">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                  <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:decimal">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="999999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:attribute>
                                                                </xs:complexType>
                                                              </xs:element>
                                                            </xs:sequence>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                      <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>400--32--Massbild</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:minLength value="1" />
                                                            <xs:maxLength value="20" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:choice>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="BLOCK_PARTS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="BLOCK_SEQUENTIAL_NO">
                                                        <xs:annotation>
                                                          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF">
                                                        <xs:annotation>
                                                          <xs:documentation>401--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>401--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="FEATURE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="OPTION_KEY" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="5" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="HINGE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--6--Anschlag</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[BEJLMNR]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="EXCHANGE_CONDITION">
                                                        <xs:annotation>
                                                          <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="2" />
                                                            <xs:maxInclusive value="3" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="STATUS">
                                                        <xs:annotation>
                                                          <xs:documentation>401--8--Status</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[ABELSZ]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[JLNRAE]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="MODULE_PARTS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="MODULE_PART" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="PART_SEQUENTIAL_NO">
                                                        <xs:annotation>
                                                          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:maxInclusive value="999" />
                                                            <xs:minInclusive value="0" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF">
                                                        <xs:annotation>
                                                          <xs:documentation>401--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:element>
                                                      <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SHORT_TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT_LINE" maxOccurs="3">
                                                              <xs:annotation>
                                                                <xs:documentation>410--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="TEXT">
                                                                    <xs:annotation>
                                                                      <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[\S ]{1,30}" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                                <xs:attribute name="SEQUENCE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger" />
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:language">
                                                                <xs:pattern value="[A-Z]{2}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="TYPE_KEY">
                                            <xs:annotation>
                                              <xs:documentation>445--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_TYPE">
                                                  <xs:annotation>
                                                    <xs:documentation>445--4--TS_Typ</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_CLASS">
                                                  <xs:annotation>
                                                    <xs:documentation>445--5--TS_Art</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                                  <xs:annotation>
                                                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                                <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="9999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger" />
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                                      <xs:annotation>
                                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="TK_MATERIAL" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--21--TS_Material</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-2]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_SHAPE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--22--TS_Form</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-2]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS">
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="ECLASS_NO">
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:totalDigits value="8" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FRONT_DIVISIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>510--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="FRONT_GROUP" maxOccurs="99">
                                                  <xs:annotation>
                                                    <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="FRONT_DIVISION_DEF">
                                                              <xs:annotation>
                                                                <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:minLength value="1" />
                                                                  <xs:maxLength value="250" />
                                                                  <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:minLength value="1" />
                                                                  <xs:maxLength value="15" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="FRONT_CELL_NO">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--6--Zellennummer</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="99" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="FRONT_TYPE" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--7--Fronttyp</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="900" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="4" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="4" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="PARAMETER_1" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--12--Parameter_1</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="99" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="PARAMETER_2" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--13--Parameter_2</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:positiveInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="99" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="9999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="9999" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                  </xs:element>
                                                                  <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                  </xs:element>
                                                                  <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                  </xs:element>
                                                                  <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                  </xs:element>
                                                                  <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="0" />
                                                                        <xs:maxInclusive value="4" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="UPPER_JOIN" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="|[VLSG]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="LOWER_JOIN" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="|[VLSG]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="LEFT_JOIN" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="|[VLSG]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="RIGHT_JOIN" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="|[VLSG]" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                  <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                                                    <xs:annotation>
                                                                      <xs:documentation>540--0--NEW</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                                        <xs:minInclusive value="1" />
                                                                        <xs:maxInclusive value="2" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="FRONT_GROUP_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:choice minOccurs="0">
                                            <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                            <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="MODULE_RULES">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:sequence>
                                                              <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                                                <xs:annotation>
                                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:complexType>
                                                                  <xs:sequence>
                                                                    <xs:element name="MODULE_POSITION">
                                                                      <xs:annotation>
                                                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:string">
                                                                          <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                                                          <xs:enumeration value="LINE_BOTTOM" />
                                                                          <xs:enumeration value="LINE_TOP" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:element>
                                                                    <xs:element name="MAX_VALUE" minOccurs="0">
                                                                      <xs:annotation>
                                                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="0" />
                                                                          <xs:maxInclusive value="99999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:element>
                                                                    <xs:element name="MIN_VALUE" minOccurs="0">
                                                                      <xs:annotation>
                                                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="0" />
                                                                          <xs:maxInclusive value="99999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:element>
                                                                  </xs:sequence>
                                                                </xs:complexType>
                                                              </xs:element>
                                                            </xs:sequence>
                                                          </xs:complexType>
                                                        </xs:element>
                                                        <xs:element name="MODULE_RULE_SET_REF">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                            </xs:attribute>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:choice>
                                          <xs:element name="DETAIL_INFOS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="PROPERTIES" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="PROPERTY_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="VALUE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="RESTRICTIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="RESTRICTION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:maxInclusive value="99999" />
                                              <xs:minInclusive value="1" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DEFAULT_OPTION_GROUPS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>295--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DEFAULT_OPTION_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30">
                                <xs:annotation>
                                  <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="FILE_NAME" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>296--6--Dateiname</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OPTION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>295--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>295--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>295--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
                                  <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_CLASSES">
              <xs:annotation>
                <xs:documentation>255--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>255--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FEATURE_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>255--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>255--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>255--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURES">
              <xs:annotation>
                <xs:documentation>250--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="COMBINED_FEATURE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>265--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" minOccurs="2" maxOccurs="5">
                          <xs:annotation>
                            <xs:documentation>265--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>265--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="10[012346]|11[01234]|12[01234]|20[02345]|30[012]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>265--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>265--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="(105)|(115)|(125)|(201)|(303)" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>265--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:choice minOccurs="0">
                                      <xs:element name="STYLE_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="STYLE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MATERIAL_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MATERIAL_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="HANDLE_ORIENTATION_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="FORM_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="FORM_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_MEASURE_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="HANDLE_POSITION_REF">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="HANDLE_POSITION_NO" use="required">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999" />
                                                <xs:totalDigits value="3" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                    <xs:element name="OPTION_TEXT" type="languagetexte60">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FEATURE_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>250--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="SEQUENCE_NO">
                          <xs:annotation>
                            <xs:documentation>250--4--Sortierung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEADER_POS_VARIATION_TYPE">
                          <xs:annotation>
                            <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[IKUPV]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INHERIT_VARIATION_TYPE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>250--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>250--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="(202)|(203)|(205)|(208)" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_DEFINITION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="STYLE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>210--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_DEPTH" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>210--6--Front_Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FRONT_DISTANCE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>210--6--Türpuffer</xs:documentation>
                            <xs:documentation>K.Richter/13.06.2018</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FRONT_GROUP_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>210--12--Frontgruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>210--12--Frontgruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_CLASS_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>210--13--Var_Familien_Nr</xs:documentation>
                                <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DEFAULT_OPTION_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>295--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>295--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESTRICTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                            <xs:documentation>von minOcc 1 auf optional 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="RESTRICTION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="STYLE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>210--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HANDLE_ORIENTATION" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DEFAULT_HANDLE_ORIENTATION_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:choice minOccurs="0">
                          <xs:annotation>
                            <xs:documentation />
                            <xs:documentation>AK 28.02.2012. Optional gesetzt um die alte 1.7 Logik zu erhalten.</xs:documentation>
                          </xs:annotation>
                          <xs:element name="COLOR">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="RGB_RED">
                                  <xs:annotation>
                                    <xs:documentation>260--11--RGB_Rot</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="255" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="RGB_GREEN">
                                  <xs:annotation>
                                    <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="255" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="RGB_BLUE">
                                  <xs:annotation>
                                    <xs:documentation>260--13--RGB_Blau</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="255" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="TEXTURE">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="FILE_NAME_TEXTURE">
                                  <xs:annotation>
                                    <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="TEXTURE_REPEAT" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="REAL_MEASUREMENT_X">
                                        <xs:annotation>
                                          <xs:documentation>260--17--Realmass_X</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="REAL_MEASUREMENT_Y">
                                        <xs:annotation>
                                          <xs:documentation>260--18--Realmass_Y</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="TEXTURE_TILE">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:int">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="1" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MASKING" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>260--10--Maskierung</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:boolean" />
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="TEXTURE_DELIVERED_ORIENTATION">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:pattern value="|[HV]" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:element name="TRANSPARENCY" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--14--Transparenz</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BRIGHTNESS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--15--Glanz</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="MATERIAL_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FORM" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PROFILE_KEY">
                          <xs:annotation>
                            <xs:documentation>430--4/5--Varianten_Art_Profilform/Var_Schluessel_</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FORM_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PLINTH_HEIGHT">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="STANDARD_PLINTH" type="xs:boolean" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Kennzeichnung zur Abweichung von Standardsockelhöhe</xs:documentation>
                            <xs:documentation>hinzugefügt K.Richter, 29.02.2016</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPTION_MEASURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>270/271--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION" maxOccurs="99999">
                    <xs:annotation>
                      <xs:documentation>270/271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>270--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:sequence minOccurs="0">
                                <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                                  <xs:annotation>
                                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="DIMENSION_TYPE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[WHD]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSION_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                                  <xs:annotation>
                                    <xs:documentation>405--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="DIMENSION_TYPE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[WHD]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSION_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TEST_ID">
                          <xs:annotation>
                            <xs:documentation>270--4--Pruef_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_1_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_2_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_3_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="VALIDATION_TYPE" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:int">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SUGGESTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>270/271--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SUGGESTION" maxOccurs="99999">
                    <xs:annotation>
                      <xs:documentation>270/271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SUGGESTION_NAME_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>270--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SUGGESTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_1_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_2_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_3_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_DEFINITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>300--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                                <xs:annotation>
                                  <xs:documentation>311--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>311--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>311--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_FIELD">
                                <xs:annotation>
                                  <xs:documentation>311--5--Preisfeld</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="SUPPLIER_PRICE_GROUP">
                                <xs:annotation>
                                  <xs:documentation>311--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="10" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="ADDITIONAL_PRICE" use="required">
                        <xs:annotation>
                          <xs:documentation>300--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:boolean" />
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="PRICE_CALC_METHOD" use="required">
                        <xs:annotation>
                          <xs:documentation>300--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="3" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_NO_1">
                        <xs:annotation>
                          <xs:documentation>300--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_NO_2">
                        <xs:annotation>
                          <xs:documentation>300--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_OF_EXCHANGE_IDS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>115--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>115--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="EXCHANGE_ID_TEXT" type="languagetexte40">
                          <xs:annotation>
                            <xs:documentation>115--3--Tausch_ID_Text</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>115--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="VALUE_ADDED_TAXES">
              <xs:annotation>
                <xs:documentation>360--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="VALUE_ADDED_TAX" maxOccurs="100">
                    <xs:annotation>
                      <xs:documentation>360--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="VAT_RATE">
                          <xs:annotation>
                            <xs:documentation>360--3--MwSt_Satz</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="VAT_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>360--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="IDENT_NUMBERS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>351--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="IDENT_NUMBER" minOccurs="0" maxOccurs="9999">
                    <xs:annotation>
                      <xs:documentation>351--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SERIE_REF" maxOccurs="99">
                          <xs:annotation>
                            <xs:documentation>351--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>351--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE">
                          <xs:annotation>
                            <xs:documentation>351--4--Preis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="-99999999" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="IDENT_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>351--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MERCHANDISE_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>350--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MERCHANDISE_GROUP_TEXT" type="languagetexte30">
                    <xs:annotation>
                      <xs:documentation>350--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>350--6--Warengruppentext</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:sequence>
                    <xs:element name="CALC_GROUP" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>350--1--Satzart</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="CALC_GROUP_TEXT" type="languagetexte30">
                            <xs:annotation>
                              <xs:documentation>350--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                          </xs:element>
                          <xs:element name="CALCULATION_FACTOR" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>350--4--Verrechnungsfaktor</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="99999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="CALC_GROUP_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>350--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="10" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:sequence>
                <xs:attribute name="MERCHANDISE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>350--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_TYPES">
              <xs:annotation>
                <xs:documentation>150--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence maxOccurs="unbounded">
                  <xs:element name="PRICE_TYPE">
                    <xs:annotation>
                      <xs:documentation>150--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="WIDTH_X">
                          <xs:annotation>
                            <xs:documentation>150--3--Breite_X</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DEPTH_Y">
                          <xs:annotation>
                            <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEIGHT_Z">
                          <xs:annotation>
                            <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_UNIT">
                          <xs:annotation>
                            <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ROUNDING_UNIT">
                          <xs:annotation>
                            <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_PRICE_DEPENDENT">
                          <xs:annotation>
                            <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="100" />
                              <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_NAME" type="languagetexte60" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>150--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="250" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BLOCK_VALUE_CALCULATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_CONDITIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>420--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>420--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>420--3--Type_Block</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--3--Type_Block</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--3--Type_Block</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CONDITION_RULES">
                          <xs:annotation>
                            <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>420--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                                      <xs:annotation>
                                        <xs:documentation>420--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="CLEARING_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>420--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:choice>
                                      <xs:element name="MINIMUM_VALUE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                    </xs:choice>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="BLOCK_SALE_PRICES" minOccurs="0">
              <xs:annotation>
                <xs:documentation>480--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>480--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>480--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>480--100--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="VALID_FROM">
                                <xs:annotation>
                                  <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL">
                                <xs:annotation>
                                  <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                                <xs:annotation>
                                  <xs:documentation>480--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>480--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>480--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_OR_CALCULATION_POINT">
                                <xs:annotation>
                                  <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="GRADING_TABLE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>421--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>421--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>421--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>421--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLEARING_GROUP_ID">
                                      <xs:annotation>
                                        <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_FROM">
                                      <xs:annotation>
                                        <xs:documentation>421--6--Wert_von</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_TO">
                                      <xs:annotation>
                                        <xs:documentation>421--7--Wert_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TYPE_CREDIT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TYPE_DEBIT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>421--9--Type_Belastung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_OF_BLOCK_RULES">
              <xs:annotation>
                <xs:documentation>111--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="EXCHANGE_ID_1_REF">
                          <xs:annotation>
                            <xs:documentation>117--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>117--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EXCHANGE_ID_2_REF">
                          <xs:annotation>
                            <xs:documentation>117--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>117--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RULE" maxOccurs="99">
                    <xs:annotation>
                      <xs:documentation>111--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RULE_TEXT" type="languagetexte60999">
                          <xs:annotation>
                            <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="RULE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>113--3--Regel_Nr</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
                    <xs:annotation>
                      <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" use="required">
      <xs:annotation>
        <xs:documentation>100--3--Versionsnummer</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="2" />
          <xs:maxInclusive value="2" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>100--4--Sub_Versions_Nr</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch

IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Signature Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : Signature Element
Beschreibung

Dieses Element dient der Angabe einer Veschlüsselung

Das Wurzelelement einer digitalen Signatur mit XML wird durch das Element Signature dargestellt.

Signature besitzt zwei Kindelemente, wovon die beiden Elemente SignedInfo und SignatureValue Pflicht sind.

Namensraum (none)
Diagramm
SignatureValue Element SignedInfo Element Sequence Signature Element
Overview
Signature optional

Dieses Element dient der Angabe einer Veschlüsselung

Das Wurzelelement einer digitalen Signatur mit XML wird durch das Element Signature dargestellt.

Signature besitzt zwei Kindelemente, wovon die beiden Elemente SignedInfo und SignatureValue Pflicht sind.

Sequence
SignedInfo

Das erste und auch komplexeste Element innerhalb von Signature ist SignedInfo und enthält die verwendeten Algorithmen zur Kanonisierung und Signierung, eine oder mehrere Referenzen auf die signierten Daten, eventuelle Transformationen und die Hashwerte dieser Daten. SignedInfo enthält also alle Informationen zu den zu signierenden Ressourcen und ist damit der Teil, über den die digitale Signatur erstellt wird.

Mit dem Signieren der verwendeten Algorithmen erhöht sich die Sicherheit. Ein sicherer Algorithmus kann so nicht gegen einen unsicheren ausgetauscht werden, ohne dass die Signatur ungültig wird.

Kindelemente von SignedInfo sind die Pflichtelemente CanonicalizationMethod und SignatureMethod sowie ein oder mehrere Reference Elemente.

Sequence
CanonicalizationMethod Extension of xs:string

Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

  • Das Dokument wird in UTF-8 kodiert
  • Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
  • Attributwerte werden normalisiert (wie bei einem validierenden Parser)
  • Character- und parsed-entity Referenzen werden ersetzt
  • CDATA Abschnitte werden durch ihren Inhalt ersetzt
  • Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
  • Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
  • Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
  • Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
  • Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
  • Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
  • Überflüssige Namespace Deklarationen werden von jedem Element entfernt
  • Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
  • Namespace Deklarationen und Attribute werden alphanumerisch sortiert

Algorithm optional xs:anyURI

Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI. D anyURI
P
M

SignatureMethod Extension of xs:string
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.
Algorithm optional xs:anyURI

Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.

 D anyURI
P
M
Reference

Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.

URI optional xs:string

Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.

 D anyURI
P
M
Sequence
Transforms

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Sequence
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Algorithm optional xs:anyURI

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
DigestValue xs:string
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
SignatureValue xs:string

Das Element SignatureValue enthält in binärer Form (immer Base-64 encoding) den über das gesamte SignedInfo Element berechneten Hashwert der Signatur. Dieser Hashwert wird mit dem in der SignatureMethod angegebenen Algorithmus, den kanonisierten Daten und dem privaten Schlüssel berechnet. Damit wird nicht die Nachricht selbst, sondern deren - in der Regel viel kürzerer - Hashwert unterschrieben (Hash-Then-Sign Paradigma).

In den unterschriebenen Daten sind somit sämtliche Informationen über die signierten Referenzen und deren Hashwerte enthalten. Damit ist es nicht erforderlich, dass die Daten selbst im Dokument vorliegen. Die Angaben über die verwendeten Algorithmen fließen jedoch mit in die Signaturberechnung ein. Dadurch werden nachträgliche Manipulationen verhindert.

Da alle Referenzen vor dem Signieren zusammengefasst und gemeinsam signiert werden existiert für die gesamte Signatur immer genau ein SignatureValue Element.

 D string
P
M
Quelle
<xs:element name="Signature" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SignedInfo">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CanonicalizationMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="SignatureMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="Reference">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="Transforms">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="Transform">
                          <xs:complexType>
                            <xs:simpleContent>
                              <xs:extension base="xs:string">
                                <xs:attribute name="Algorithm" type="xs:anyURI" />
                              </xs:extension>
                            </xs:simpleContent>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DigestMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DigestValue" type="xs:string" />
                </xs:sequence>
                <xs:attribute name="URI" type="xs:string" />
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SignatureValue" type="xs:string" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignedInfo Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element : SignedInfo Element
Beschreibung

Das erste und auch komplexeste Element innerhalb von Signature ist SignedInfo und enthält die verwendeten Algorithmen zur Kanonisierung und Signierung, eine oder mehrere Referenzen auf die signierten Daten, eventuelle Transformationen und die Hashwerte dieser Daten. SignedInfo enthält also alle Informationen zu den zu signierenden Ressourcen und ist damit der Teil, über den die digitale Signatur erstellt wird.

Mit dem Signieren der verwendeten Algorithmen erhöht sich die Sicherheit. Ein sicherer Algorithmus kann so nicht gegen einen unsicheren ausgetauscht werden, ohne dass die Signatur ungültig wird.

Kindelemente von SignedInfo sind die Pflichtelemente CanonicalizationMethod und SignatureMethod sowie ein oder mehrere Reference Elemente.

Namensraum (none)
Diagramm
Reference Element SignatureMethod Element CanonicalizationMethod Element Sequence SignedInfo Element
Overview
SignedInfo

Das erste und auch komplexeste Element innerhalb von Signature ist SignedInfo und enthält die verwendeten Algorithmen zur Kanonisierung und Signierung, eine oder mehrere Referenzen auf die signierten Daten, eventuelle Transformationen und die Hashwerte dieser Daten. SignedInfo enthält also alle Informationen zu den zu signierenden Ressourcen und ist damit der Teil, über den die digitale Signatur erstellt wird.

Mit dem Signieren der verwendeten Algorithmen erhöht sich die Sicherheit. Ein sicherer Algorithmus kann so nicht gegen einen unsicheren ausgetauscht werden, ohne dass die Signatur ungültig wird.

Kindelemente von SignedInfo sind die Pflichtelemente CanonicalizationMethod und SignatureMethod sowie ein oder mehrere Reference Elemente.

Sequence
CanonicalizationMethod Extension of xs:string

Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

  • Das Dokument wird in UTF-8 kodiert
  • Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
  • Attributwerte werden normalisiert (wie bei einem validierenden Parser)
  • Character- und parsed-entity Referenzen werden ersetzt
  • CDATA Abschnitte werden durch ihren Inhalt ersetzt
  • Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
  • Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
  • Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
  • Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
  • Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
  • Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
  • Überflüssige Namespace Deklarationen werden von jedem Element entfernt
  • Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
  • Namespace Deklarationen und Attribute werden alphanumerisch sortiert

Algorithm optional xs:anyURI

Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI. D anyURI
P
M

SignatureMethod Extension of xs:string
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.
Algorithm optional xs:anyURI

Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.

 D anyURI
P
M
Reference

Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.

URI optional xs:string

Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.

 D anyURI
P
M
Sequence
Transforms

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Sequence
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Algorithm optional xs:anyURI

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
DigestValue xs:string
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
Quelle
<xs:element name="SignedInfo" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CanonicalizationMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="SignatureMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="Reference">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="Transforms">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="Transform">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DigestMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="DigestValue" type="xs:string" />
          </xs:sequence>
          <xs:attribute name="URI" type="xs:string" />
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CanonicalizationMethod Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element : CanonicalizationMethod Element
Beschreibung

Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

  • Das Dokument wird in UTF-8 kodiert
  • Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
  • Attributwerte werden normalisiert (wie bei einem validierenden Parser)
  • Character- und parsed-entity Referenzen werden ersetzt
  • CDATA Abschnitte werden durch ihren Inhalt ersetzt
  • Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
  • Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
  • Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
  • Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
  • Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
  • Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
  • Überflüssige Namespace Deklarationen werden von jedem Element entfernt
  • Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
  • Namespace Deklarationen und Attribute werden alphanumerisch sortiert

Namensraum (none)
Typ
Extension of xs:string
Diagramm
CanonicalizationMethod Element
Overview
CanonicalizationMethod Extension of xs:string

Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

  • Das Dokument wird in UTF-8 kodiert
  • Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
  • Attributwerte werden normalisiert (wie bei einem validierenden Parser)
  • Character- und parsed-entity Referenzen werden ersetzt
  • CDATA Abschnitte werden durch ihren Inhalt ersetzt
  • Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
  • Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
  • Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
  • Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
  • Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
  • Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
  • Überflüssige Namespace Deklarationen werden von jedem Element entfernt
  • Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
  • Namespace Deklarationen und Attribute werden alphanumerisch sortiert

Algorithm optional xs:anyURI

Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI. D anyURI
P
M

Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
Algorithm xs:anyURI optional

Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI. D anyURI
P
M

Quelle
<xs:element name="CanonicalizationMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
Siehe auch
SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignatureMethod Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element : SignatureMethod Element
Beschreibung
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.
Namensraum (none)
Typ
Extension of xs:string
Diagramm
SignatureMethod Element
Overview
SignatureMethod Extension of xs:string
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.
Algorithm optional xs:anyURI

Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.

 D anyURI
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
Algorithm xs:anyURI optional

Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.

 D anyURI
P
M
Quelle
<xs:element name="SignatureMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
Siehe auch
SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Reference Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element : Reference Element
Beschreibung

Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.

Namensraum (none)
Diagramm
DigestValue Element DigestMethod Element Transforms Element Sequence Reference Element
Overview
Reference

Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.

URI optional xs:string

Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.

 D anyURI
P
M
Sequence
Transforms

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Sequence
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Algorithm optional xs:anyURI

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
DigestValue xs:string
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
URI xs:string optional

Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.

 D anyURI
P
M
Quelle
<xs:element name="Reference" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Transforms">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="Transform">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DigestMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="DigestValue" type="xs:string" />
    </xs:sequence>
    <xs:attribute name="URI" type="xs:string" />
  </xs:complexType>
</xs:element>
Siehe auch
SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Transforms Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : Transforms Element
Beschreibung

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Namensraum (none)
Diagramm
Transform Element Sequence Transforms Element
Overview
Transforms

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Sequence
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
Quelle
<xs:element name="Transforms" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Transform">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
Reference Element | SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Transform Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element > Reference Element > Transforms Element : Transform Element
Beschreibung

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Namensraum (none)
Typ
Extension of xs:string
Diagramm
Transform Element
Overview
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
Algorithm xs:anyURI optional

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
Quelle
<xs:element name="Transform" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
Siehe auch
Transforms Element | Reference Element | SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DigestMethod Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : DigestMethod Element
Beschreibung
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Namensraum (none)
Typ
Extension of xs:string
Diagramm
DigestMethod Element
Overview
DigestMethod Extension of xs:string
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Algorithm optional xs:anyURI

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
Algorithm xs:anyURI optional

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
Quelle
<xs:element name="DigestMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
Siehe auch
Reference Element | SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DigestValue Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : DigestValue Element
Beschreibung
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
DigestValue Element
Overview
DigestValue xs:string
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
Quelle
<xs:element name="DigestValue" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
Reference Element | SignedInfo Element | Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignatureValue Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > Signature Element : SignatureValue Element
Beschreibung

Das Element SignatureValue enthält in binärer Form (immer Base-64 encoding) den über das gesamte SignedInfo Element berechneten Hashwert der Signatur. Dieser Hashwert wird mit dem in der SignatureMethod angegebenen Algorithmus, den kanonisierten Daten und dem privaten Schlüssel berechnet. Damit wird nicht die Nachricht selbst, sondern deren - in der Regel viel kürzerer - Hashwert unterschrieben (Hash-Then-Sign Paradigma).

In den unterschriebenen Daten sind somit sämtliche Informationen über die signierten Referenzen und deren Hashwerte enthalten. Damit ist es nicht erforderlich, dass die Daten selbst im Dokument vorliegen. Die Angaben über die verwendeten Algorithmen fließen jedoch mit in die Signaturberechnung ein. Dadurch werden nachträgliche Manipulationen verhindert.

Da alle Referenzen vor dem Signieren zusammengefasst und gemeinsam signiert werden existiert für die gesamte Signatur immer genau ein SignatureValue Element.

 D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
SignatureValue Element
Overview
SignatureValue xs:string

Das Element SignatureValue enthält in binärer Form (immer Base-64 encoding) den über das gesamte SignedInfo Element berechneten Hashwert der Signatur. Dieser Hashwert wird mit dem in der SignatureMethod angegebenen Algorithmus, den kanonisierten Daten und dem privaten Schlüssel berechnet. Damit wird nicht die Nachricht selbst, sondern deren - in der Regel viel kürzerer - Hashwert unterschrieben (Hash-Then-Sign Paradigma).

In den unterschriebenen Daten sind somit sämtliche Informationen über die signierten Referenzen und deren Hashwerte enthalten. Damit ist es nicht erforderlich, dass die Daten selbst im Dokument vorliegen. Die Angaben über die verwendeten Algorithmen fließen jedoch mit in die Signaturberechnung ein. Dadurch werden nachträgliche Manipulationen verhindert.

Da alle Referenzen vor dem Signieren zusammengefasst und gemeinsam signiert werden existiert für die gesamte Signatur immer genau ein SignatureValue Element.

 D string
P
M
Quelle
<xs:element name="SignatureValue" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
Signature Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : CATALOG Element
Beschreibung
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Namensraum (none)
Diagramm
DETAIL_INFOS Element FALL_BACK_LANGUAGE Element LANGUAGE Element Sequence CATALOG_INFO Element PRICING_TERMS Element FILLING_LEVEL Element CATALOG_MARK Element FILE_ID Element VALID_FROM_DATE Element DATA_VERSION Element LANGUAGE Element Sequence CATALOG_NAME Element MAJOR_NO Element CATALOG_YEAR Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element FILE_RELEASE_DATE Element Sequence CATALOG Element
Overview
CATALOG
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Sequence
FILE_RELEASE_DATE xs:dateTime
Das Element FILE_RELEASE_DATE sollte automatisch beim Export der Daten gesetzt werden und das aktuelle Datum und die UTC-Uhrzeit beinhalten. D dateTime
P
M
CATALOG_IDENTIFICATION
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger
Dieses Element ist ein Pflichtfeld zur Kennzeichnung der Katalogart. CATALOG_KIND hat die Werte
1 für Basiskatalog,
2 für Verbandskatalog und
3 für kundenspezifischen Katalog. 		D positiveInteger
P
M [1:3]
ASSOC_CTM_NO optional Restriction of xs:string
Ist das Feld CATALOG_KIND mit 2 oder 3 gefüllt, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im
Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Wenn kein Preis, sondern Identnummern verwendet werden, so muss dem Datenbestand die Informationen des Ident-EK-Blatt im Element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_YEAR xs:gYear
Dieses Element bezieht sich auf das Kalenderjahr der Katalogdaten. D gYear
P
M
MAJOR_NO Restriction of xs:positiveInteger
Wird ein neuer Katalog heraus gegeben oder werden Löschungen in einem Katalog vorgenommen, ändert sich, diese Hauptnummer (MAJOR_NO). Wird die Änderung in einem neuen Jahr vollzogen, wird dass Kalenderjahr (CATALOG_YEAR) angepasst und die Hauptnummer auf 1 gesetzt. Wird in einem Jahr kein neuer Katalog bereitgestellt und keine Löschungen durchgeführt, bleibt das Kalenderjahr und die Hauptnummer bestehen. D positiveInteger
P
M 1:99
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)

handelt. 		D string
P [BKV]
M [1:1]
FILLING_LEVEL Restriction of xs:string
Über die Füllstufe (FILLING_LEVEL) wird definiert, mit welchem Detaillierungsgrad die Katalogdaten beschrieben werden. Im Grundsatz steigt mit zunehmender Füllstufe die Datenqualität, da mit dem steigenden Detaillierungsgrad die Herstellerspezifik der Daten zunimmt.
Die Füllstufen werden bei der Datenzertifizierung ausgewertet: Anhand der Füllstufe wird überprüft, welche Informationen in den Daten vorhanden sein müssen, um die angegebene Füllstufe zu erreichen. Ist eine geforderte Information nicht vorhanden, so wird der Datenbestand nicht zertifiziert.
Die Füllstufen sind wie folgt definiert:
- Füllstufe 1: Es werden Basisinformationen mit Ausnahme der Elemente zur Beschreibung von Texturinformationen
- Füllstufe 2a: Die Füllstufe 1 wird ergänzt um Informationen über Texturen und Material (Farben RGB, Transparenz und Glanz)
- Füllstufe 2b: Die Füllstufe 1 wird ergänzt um Informationen über Frontaufteilungen und Frontausprägungen
- Füllstufe 2c: Die Füllstufe 1 wird ergänzt um Informationen über Griffe
- Füllstufe 2d: Die Füllstufe 1 wird ergänzt um Informationen über Artikeltexturen

Es sind auch Kombinationen der Füllstufen 2a-2d möglich. Folgende Aufschlüsselung der Kombinationen sind definiert:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Füllstufe 3. Um die Füllstufe 3 zu erreichen, müssen die Informationen aus den Füllstufen 1 und 2a - 2d enthalten sein und um Informationen über Echtgrafik ergänzt werden. Mit der Füllstufe 3 werden die Möglichkeiten des Datenformates zur herstellerspezifischen Abbildung gänzlich angewendet.
Die Definition, welche Informationen von welcher Füllstufe gefordert werden, erfolgt im Tabellenteil "Füllstufen". 		D string
P [123]|2[a-n]
M [1:2]
PRICING_TERMS optional Restriction of xs:string
Mit diesem Element wird definiert, welche Preise in den Daten angelegt werden.
Dieses Element wird zur Unterscheidung beim Datenimport herangezogen, um zu vermeiden, dass sich die Preise bei gleichen Katalogen überschreiben.

Folgende Werte sind möglich:
0 = die angegebenen Preise sind Einkaufspreise für den Handel
1 = die angegebenen Preise sind unverbindliche Preisempfehlungen (UPE)

Entsprechend dem angegebenem Wert müssen die richtigen Preise in den Daten angelegt werden. 		D string
P [01]
M [1:1]
CATALOG_INFO languagetexte60999 Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FALL_BACK_LANGUAGE optional Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Bemerkung

Quelle
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FILE_RELEASE_DATE" type="xs:dateTime">
        <xs:annotation>
          <xs:documentation>100--2--Dateifreigabe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_ID">
              <xs:annotation>
                <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--13--Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_KIND">
              <xs:annotation>
                <xs:documentation>Katalog-Art</xs:documentation>
                <xs:documentation>1 für Basiskatalog</xs:documentation>
                <xs:documentation>2 für Verbandskatalog</xs:documentation>
                <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
                <xs:documentation>geändert 17.04.2019</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ASSOC_CTM_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRODUCT_BRANDNAME">
              <xs:annotation>
                <xs:documentation>100--40--Produktmarke</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_ID">
              <xs:annotation>
                <xs:documentation>100--49--Preis_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT">
              <xs:annotation>
                <xs:documentation>200--4--MwSt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_YEAR" type="xs:gYear">
        <xs:annotation>
          <xs:documentation>Jahr der Neuerstellung</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="MAJOR_NO">
        <xs:annotation>
          <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DATA_VERSION">
        <xs:annotation>
          <xs:documentation>100--11--Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM_DATE">
        <xs:annotation>
          <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_ID">
        <xs:annotation>
          <xs:documentation>100--14--Datei_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MARK">
        <xs:annotation>
          <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BKV]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILLING_LEVEL">
        <xs:annotation>
          <xs:documentation>100--44--Fuellstufe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[123]|2[a-n]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICING_TERMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--48--Preisstellung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="1" />
            <xs:pattern value="[01]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>110--3--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FALL_BACK_LANGUAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
          <xs:documentation>K. Richter 29.06.2017</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
          <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW </xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_RELEASE_DATE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : FILE_RELEASE_DATE Element
Beschreibung
Das Element FILE_RELEASE_DATE sollte automatisch beim Export der Daten gesetzt werden und das aktuelle Datum und die UTC-Uhrzeit beinhalten. D dateTime
P
M
Namensraum (none)
Typ
xs:dateTime
Diagramm
FILE_RELEASE_DATE Element
Overview
FILE_RELEASE_DATE xs:dateTime
Das Element FILE_RELEASE_DATE sollte automatisch beim Export der Daten gesetzt werden und das aktuelle Datum und die UTC-Uhrzeit beinhalten. D dateTime
P
M
Bemerkung

Quelle
<xs:element name="FILE_RELEASE_DATE" type="xs:dateTime" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--2--Dateifreigabe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_IDENTIFICATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_IDENTIFICATION Element
Beschreibung
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Namensraum (none)
Diagramm
VAT Element PRICE_ID Element PRODUCT_BRANDNAME Element ASSOC_CTM_NO Element CATALOG_KIND Element COUNTRY_ID Element CURRENCY_KEY Element ISO_LANGUAGE_ID Element MANUFACTURER_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger
Dieses Element ist ein Pflichtfeld zur Kennzeichnung der Katalogart. CATALOG_KIND hat die Werte
1 für Basiskatalog,
2 für Verbandskatalog und
3 für kundenspezifischen Katalog. 		D positiveInteger
P
M [1:3]
ASSOC_CTM_NO optional Restriction of xs:string
Ist das Feld CATALOG_KIND mit 2 oder 3 gefüllt, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im
Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Wenn kein Preis, sondern Identnummern verwendet werden, so muss dem Datenbestand die Informationen des Ident-EK-Blatt im Element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Bemerkung

Quelle
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_ID">
        <xs:annotation>
          <xs:documentation>100--5--Hersteller_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--13--Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_KIND">
        <xs:annotation>
          <xs:documentation>Katalog-Art</xs:documentation>
          <xs:documentation>1 für Basiskatalog</xs:documentation>
          <xs:documentation>2 für Verbandskatalog</xs:documentation>
          <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
          <xs:documentation>geändert 17.04.2019</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ASSOC_CTM_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRODUCT_BRANDNAME">
        <xs:annotation>
          <xs:documentation>100--40--Produktmarke</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_ID">
        <xs:annotation>
          <xs:documentation>100--49--Preis_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT">
        <xs:annotation>
          <xs:documentation>200--4--MwSt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANUFACTURER_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : MANUFACTURER_ID Element
Beschreibung
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MANUFACTURER_ID Element
Overview
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
Bemerkung

Quelle
<xs:element name="MANUFACTURER_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--5--Hersteller_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ISO_LANGUAGE_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Beschreibung
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:language
Diagramm
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
Bemerkung

Quelle
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CURRENCY_KEY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Beschreibung
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Bemerkung

Quelle
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COUNTRY_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : COUNTRY_ID Element
Beschreibung
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
COUNTRY_ID Element
Overview
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
Bemerkung

Quelle
<xs:element name="COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--13--Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_KIND Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CATALOG_KIND Element
Beschreibung
Dieses Element ist ein Pflichtfeld zur Kennzeichnung der Katalogart. CATALOG_KIND hat die Werte
1 für Basiskatalog,
2 für Verbandskatalog und
3 für kundenspezifischen Katalog. 		D positiveInteger
P
M [1:3]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CATALOG_KIND Element
Overview
CATALOG_KIND Restriction of xs:positiveInteger
Dieses Element ist ein Pflichtfeld zur Kennzeichnung der Katalogart. CATALOG_KIND hat die Werte
1 für Basiskatalog,
2 für Verbandskatalog und
3 für kundenspezifischen Katalog. 		D positiveInteger
P
M [1:3]
Quelle
<xs:element name="CATALOG_KIND" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Katalog-Art</xs:documentation>
    <xs:documentation>1 für Basiskatalog</xs:documentation>
    <xs:documentation>2 für Verbandskatalog</xs:documentation>
    <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
    <xs:documentation>geändert 17.04.2019</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ASSOC_CTM_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ASSOC_CTM_NO Element
Beschreibung
Ist das Feld CATALOG_KIND mit 2 oder 3 gefüllt, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände"). 		D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ASSOC_CTM_NO Element
Overview
ASSOC_CTM_NO optional Restriction of xs:string
Ist das Feld CATALOG_KIND mit 2 oder 3 gefüllt, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände"). 		D string
P
M [1:15]
Bemerkung

Quelle
<xs:element name="ASSOC_CTM_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_BRANDNAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRODUCT_BRANDNAME Element
Beschreibung

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRODUCT_BRANDNAME Element
Overview
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
Bemerkung

Quelle
<xs:element name="PRODUCT_BRANDNAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--40--Produktmarke</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRICE_ID Element
Beschreibung
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im
Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Wenn kein Preis, sondern Identnummern verwendet werden, so muss dem Datenbestand die Informationen des Ident-EK-Blatt im Element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_ID Element
Overview
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im
Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Wenn kein Preis, sondern Identnummern verwendet werden, so muss dem Datenbestand die Informationen des Ident-EK-Blatt im Element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
Bemerkung

Quelle
<xs:element name="PRICE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--49--Preis_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VAT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : VAT Element
Beschreibung
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
VAT Element
Overview
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Quelle
<xs:element name="VAT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--4--MwSt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NUMBER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_NUMBER Element
Beschreibung
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Bemerkung

Quelle
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_YEAR Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_YEAR Element
Beschreibung
Dieses Element bezieht sich auf das Kalenderjahr der Katalogdaten. D gYear
P
M
Namensraum (none)
Typ
xs:gYear
Diagramm
CATALOG_YEAR Element
Overview
CATALOG_YEAR xs:gYear
Dieses Element bezieht sich auf das Kalenderjahr der Katalogdaten. D gYear
P
M
Quelle
<xs:element name="CATALOG_YEAR" type="xs:gYear" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Jahr der Neuerstellung</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MAJOR_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : MAJOR_NO Element
Beschreibung
Wird ein neuer Katalog heraus gegeben oder werden Löschungen in einem Katalog vorgenommen, ändert sich, diese Hauptnummer (MAJOR_NO). Wird die Änderung in einem neuen Jahr vollzogen, wird dass Kalenderjahr (CATALOG_YEAR) angepasst und die Hauptnummer auf 1 gesetzt. Wird in einem Jahr kein neuer Katalog bereitgestellt und keine Löschungen durchgeführt, bleibt das Kalenderjahr und die Hauptnummer bestehen. D positiveInteger
P
M 1:99
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
MAJOR_NO Element
Overview
MAJOR_NO Restriction of xs:positiveInteger
Wird ein neuer Katalog heraus gegeben oder werden Löschungen in einem Katalog vorgenommen, ändert sich, diese Hauptnummer (MAJOR_NO). Wird die Änderung in einem neuen Jahr vollzogen, wird dass Kalenderjahr (CATALOG_YEAR) angepasst und die Hauptnummer auf 1 gesetzt. Wird in einem Jahr kein neuer Katalog bereitgestellt und keine Löschungen durchgeführt, bleibt das Kalenderjahr und die Hauptnummer bestehen. D positiveInteger
P
M 1:99
Quelle
<xs:element name="MAJOR_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_NAME Element
Beschreibung
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Namensraum (none)
Typ
languagetexte30 Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Bemerkung

Quelle
<xs:element name="CATALOG_NAME" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > languagetexte30 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetexte30 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > languagetexte30 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte30 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DATA_VERSION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : DATA_VERSION Element
Beschreibung
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
DATA_VERSION Element
Overview
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
Bemerkung

Quelle
<xs:element name="DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--11--Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM_DATE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : VALID_FROM_DATE Element
Beschreibung
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM_DATE Element
Overview
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
Bemerkung

Quelle
<xs:element name="VALID_FROM_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : FILE_ID Element
Beschreibung
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
FILE_ID Element
Overview
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
Bemerkung

Quelle
<xs:element name="FILE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--14--Datei_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_MARK Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_MARK Element
Beschreibung
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)

handelt. 		D string
P [BKV]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_MARK Element
Overview
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)

handelt. 		D string
P [BKV]
M [1:1]
Bemerkung

Quelle
<xs:element name="CATALOG_MARK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BKV]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILLING_LEVEL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : FILLING_LEVEL Element
Beschreibung
Über die Füllstufe (FILLING_LEVEL) wird definiert, mit welchem Detaillierungsgrad die Katalogdaten beschrieben werden. Im Grundsatz steigt mit zunehmender Füllstufe die Datenqualität, da mit dem steigenden Detaillierungsgrad die Herstellerspezifik der Daten zunimmt.
Die Füllstufen werden bei der Datenzertifizierung ausgewertet: Anhand der Füllstufe wird überprüft, welche Informationen in den Daten vorhanden sein müssen, um die angegebene Füllstufe zu erreichen. Ist eine geforderte Information nicht vorhanden, so wird der Datenbestand nicht zertifiziert.
Die Füllstufen sind wie folgt definiert:
- Füllstufe 1: Es werden Basisinformationen mit Ausnahme der Elemente zur Beschreibung von Texturinformationen
- Füllstufe 2a: Die Füllstufe 1 wird ergänzt um Informationen über Texturen und Material (Farben RGB, Transparenz und Glanz)
- Füllstufe 2b: Die Füllstufe 1 wird ergänzt um Informationen über Frontaufteilungen und Frontausprägungen
- Füllstufe 2c: Die Füllstufe 1 wird ergänzt um Informationen über Griffe
- Füllstufe 2d: Die Füllstufe 1 wird ergänzt um Informationen über Artikeltexturen

Es sind auch Kombinationen der Füllstufen 2a-2d möglich. Folgende Aufschlüsselung der Kombinationen sind definiert:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Füllstufe 3. Um die Füllstufe 3 zu erreichen, müssen die Informationen aus den Füllstufen 1 und 2a - 2d enthalten sein und um Informationen über Echtgrafik ergänzt werden. Mit der Füllstufe 3 werden die Möglichkeiten des Datenformates zur herstellerspezifischen Abbildung gänzlich angewendet.
Die Definition, welche Informationen von welcher Füllstufe gefordert werden, erfolgt im Tabellenteil "Füllstufen". 		D string
P [123]|2[a-n]
M [1:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FILLING_LEVEL Element
Overview
FILLING_LEVEL Restriction of xs:string
Über die Füllstufe (FILLING_LEVEL) wird definiert, mit welchem Detaillierungsgrad die Katalogdaten beschrieben werden. Im Grundsatz steigt mit zunehmender Füllstufe die Datenqualität, da mit dem steigenden Detaillierungsgrad die Herstellerspezifik der Daten zunimmt.
Die Füllstufen werden bei der Datenzertifizierung ausgewertet: Anhand der Füllstufe wird überprüft, welche Informationen in den Daten vorhanden sein müssen, um die angegebene Füllstufe zu erreichen. Ist eine geforderte Information nicht vorhanden, so wird der Datenbestand nicht zertifiziert.
Die Füllstufen sind wie folgt definiert:
- Füllstufe 1: Es werden Basisinformationen mit Ausnahme der Elemente zur Beschreibung von Texturinformationen
- Füllstufe 2a: Die Füllstufe 1 wird ergänzt um Informationen über Texturen und Material (Farben RGB, Transparenz und Glanz)
- Füllstufe 2b: Die Füllstufe 1 wird ergänzt um Informationen über Frontaufteilungen und Frontausprägungen
- Füllstufe 2c: Die Füllstufe 1 wird ergänzt um Informationen über Griffe
- Füllstufe 2d: Die Füllstufe 1 wird ergänzt um Informationen über Artikeltexturen

Es sind auch Kombinationen der Füllstufen 2a-2d möglich. Folgende Aufschlüsselung der Kombinationen sind definiert:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Füllstufe 3. Um die Füllstufe 3 zu erreichen, müssen die Informationen aus den Füllstufen 1 und 2a - 2d enthalten sein und um Informationen über Echtgrafik ergänzt werden. Mit der Füllstufe 3 werden die Möglichkeiten des Datenformates zur herstellerspezifischen Abbildung gänzlich angewendet.
Die Definition, welche Informationen von welcher Füllstufe gefordert werden, erfolgt im Tabellenteil "Füllstufen". 		D string
P [123]|2[a-n]
M [1:2]
Bemerkung

Quelle
<xs:element name="FILLING_LEVEL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--44--Fuellstufe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[123]|2[a-n]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICING_TERMS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : PRICING_TERMS Element
Beschreibung
Mit diesem Element wird definiert, welche Preise in den Daten angelegt werden.
Dieses Element wird zur Unterscheidung beim Datenimport herangezogen, um zu vermeiden, dass sich die Preise bei gleichen Katalogen überschreiben.

Folgende Werte sind möglich:
0 = die angegebenen Preise sind Einkaufspreise für den Handel
1 = die angegebenen Preise sind unverbindliche Preisempfehlungen (UPE)

Entsprechend dem angegebenem Wert müssen die richtigen Preise in den Daten angelegt werden. 		D string
P [01]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
PRICING_TERMS Element
Overview
PRICING_TERMS optional Restriction of xs:string
Mit diesem Element wird definiert, welche Preise in den Daten angelegt werden.
Dieses Element wird zur Unterscheidung beim Datenimport herangezogen, um zu vermeiden, dass sich die Preise bei gleichen Katalogen überschreiben.

Folgende Werte sind möglich:
0 = die angegebenen Preise sind Einkaufspreise für den Handel
1 = die angegebenen Preise sind unverbindliche Preisempfehlungen (UPE)

Entsprechend dem angegebenem Wert müssen die richtigen Preise in den Daten angelegt werden. 		D string
P [01]
M [1:1]
Bemerkung

Quelle
<xs:element name="PRICING_TERMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--48--Preisstellung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="1" />
      <xs:pattern value="[01]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_INFO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : CATALOG_INFO Element
Beschreibung
In diesem Element werden die Informationstexte abgelegt.
Namensraum (none)
Typ
languagetexte60999 Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO languagetexte60999 Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="CATALOG_INFO" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>110--3--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>150--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>265--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,60}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetexte60999 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element : TEXT_LINE Element
Beschreibung
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
Namensraum (none)
Diagramm
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE_NO Restriction of xs:positiveInteger required
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Quelle
<xs:element name="TEXT_LINE" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte60999 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | languagetexte60999 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FALL_BACK_LANGUAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : FALL_BACK_LANGUAGE Element
Beschreibung
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:language
Diagramm
FALL_BACK_LANGUAGE Element
Overview
FALL_BACK_LANGUAGE optional Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="FALL_BACK_LANGUAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
    <xs:documentation>K. Richter 29.06.2017</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element : DETAIL_INFOS Element
Beschreibung
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
    <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW </xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > CATALOG Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | CATALOG Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUPPLIER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : SUPPLIER Element
Beschreibung
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Namensraum (none)
Diagramm
CONTACT_SUPPLIER Element CONTACT_PERSON Element WEEE_NO Element GLN_NO Element ISO_COUNTRY_ID Element BRANCH_ID Element EDI_INFO Element Sequence SUPPLIER Element
Overview
SUPPLIER
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Sequence
EDI_INFO 0..∞
In diesem Element werden den Geschäftspartnern die möglichen EDI-Kommunikationen mitgeteilt. Für jede EDI-Nachricht eines EDI-Formates wird ein Element angelegt.
Sequence
EDI_FORMAT optional Restriction of xs:string
Hier wird das unterstützte EDI-Format angegeben (z. B. EDIDATA). D string
P EANCOM|EAN 97|EAN 97 A|EDIDATA
M [1:20]
EDI_FORMAT_VERSION optional Restriction of xs:string
Hier wird angegeben, welche Version des im Element EDI_FORMAT angegebenen EDI-Formates unterstützt wird. D string
P [1-9]\.[0-9]{2}
M [1:10]
EDI_MESSAGE optional Restriction of xs:string
Hier werden die vom Hersteller unterstützten Nachrichten des EDI-Formates angegeben (z. B. Order, Order Response). D string
P
M [1:20]
EDI_COMMUNICATION optional Restriction of xs:string
Hier wird angegeben, auf welchem Weg die EDI-Kommunikation erfolgt (z. B. X.400, Telebox, E-Mail). D string
P
M [1:20]
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
Hier wird die Adresse für den angegebenen Kommunikationsweg angegeben (z. B. X.400 Adresse, E-Mail-Adresse oder nach Rücksprache). D string
P
M [1:40]
EDI_CONTACT optional Restriction of xs:string
Hier wird die Person angegeben, die beim Hersteller als Kontakt für Details zur EDI Abwicklung zur Verfügung steht. Die Angabe der Kontaktinformationen ist frei, d. h. es können im Rahmen der max. Feldlänge die notwendigen Informationen wie beispielsweise Name, Telefon oder E-Mail angegeben werden. D string
P
M [1:60]
BRANCH_ID Restriction of xs:string
In diesem Element wird das Kennzeichen für die Herstellerbranche angegeben. Derzeit sind folgende Branchenkennzeichen definiert:

A = Arbeitsplattenhersteller
B = Badmöbelhersteller
G = Gerätehersteller
K = Küchenmöbelhersteller
O = Büromöbelhersteller
P = Polstermöbelhersteller
S = Sanitärhersteller
W = Wohnmöbelhersteller
Z = Zubehörhersteller 		D string
P [ABGKOPSWZ]
M [1:1]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
GLN_NO optional Restriction of xs:string
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN Nummer ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch. D string
P [0-9]{13}
M [13:13]
WEEE_NO optional Restriction of xs:string
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>105--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EDI_FORMAT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--2--EDI_Format</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                  <xs:pattern value="EANCOM|EAN 97|EAN 97 A|EDIDATA" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                  <xs:pattern value="[1-9]\.[0-9]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_MESSAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_COMMUNICATION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="40" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_CONTACT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BRANCH_ID">
        <xs:annotation>
          <xs:documentation>100--8--Branchen_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[ABGKOPSWZ]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="GLN_NO" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>100--45--GLN_Nr 30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, verpflichtend, K. Richter 21.08.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9]{13}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WEEE_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--47--WEEE_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_PERSON" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONTACT_PERSON_NO">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_ROLE">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_NAME">
              <xs:annotation>
                <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FIRST_NAME">
              <xs:annotation>
                <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FORM_OF_ADDRESS">
              <xs:annotation>
                <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPARTMENT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE">
              <xs:annotation>
                <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONTACT_SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_NAME_1">
              <xs:annotation>
                <xs:documentation>100--16--Herstellername_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--17--Herstellername_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INTERNET_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET">
              <xs:annotation>
                <xs:documentation>100--20--Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET">
              <xs:annotation>
                <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY">
              <xs:annotation>
                <xs:documentation>100--22--Ort</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--24--Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_INFO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : EDI_INFO Element
Beschreibung
In diesem Element werden den Geschäftspartnern die möglichen EDI-Kommunikationen mitgeteilt. Für jede EDI-Nachricht eines EDI-Formates wird ein Element angelegt.
Namensraum (none)
Diagramm
EDI_CONTACT Element EDI_COMMUNICATION_ADDRESS Element EDI_COMMUNICATION Element EDI_MESSAGE Element EDI_FORMAT_VERSION Element EDI_FORMAT Element Sequence EDI_INFO Element
Overview
EDI_INFO 0..∞
In diesem Element werden den Geschäftspartnern die möglichen EDI-Kommunikationen mitgeteilt. Für jede EDI-Nachricht eines EDI-Formates wird ein Element angelegt.
Sequence
EDI_FORMAT optional Restriction of xs:string
Hier wird das unterstützte EDI-Format angegeben (z. B. EDIDATA). D string
P EANCOM|EAN 97|EAN 97 A|EDIDATA
M [1:20]
EDI_FORMAT_VERSION optional Restriction of xs:string
Hier wird angegeben, welche Version des im Element EDI_FORMAT angegebenen EDI-Formates unterstützt wird. D string
P [1-9]\.[0-9]{2}
M [1:10]
EDI_MESSAGE optional Restriction of xs:string
Hier werden die vom Hersteller unterstützten Nachrichten des EDI-Formates angegeben (z. B. Order, Order Response). D string
P
M [1:20]
EDI_COMMUNICATION optional Restriction of xs:string
Hier wird angegeben, auf welchem Weg die EDI-Kommunikation erfolgt (z. B. X.400, Telebox, E-Mail). D string
P
M [1:20]
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
Hier wird die Adresse für den angegebenen Kommunikationsweg angegeben (z. B. X.400 Adresse, E-Mail-Adresse oder nach Rücksprache). D string
P
M [1:40]
EDI_CONTACT optional Restriction of xs:string
Hier wird die Person angegeben, die beim Hersteller als Kontakt für Details zur EDI Abwicklung zur Verfügung steht. Die Angabe der Kontaktinformationen ist frei, d. h. es können im Rahmen der max. Feldlänge die notwendigen Informationen wie beispielsweise Name, Telefon oder E-Mail angegeben werden. D string
P
M [1:60]
Bemerkung

Quelle
<xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EDI_FORMAT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--2--EDI_Format</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
            <xs:pattern value="EANCOM|EAN 97|EAN 97 A|EDIDATA" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
            <xs:pattern value="[1-9]\.[0-9]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_MESSAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_COMMUNICATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="40" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_CONTACT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_FORMAT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_FORMAT Element
Beschreibung
Hier wird das unterstützte EDI-Format angegeben (z. B. EDIDATA). D string
P EANCOM|EAN 97|EAN 97 A|EDIDATA
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_FORMAT Element
Overview
EDI_FORMAT optional Restriction of xs:string
Hier wird das unterstützte EDI-Format angegeben (z. B. EDIDATA). D string
P EANCOM|EAN 97|EAN 97 A|EDIDATA
M [1:20]
Bemerkung

Quelle
<xs:element name="EDI_FORMAT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--2--EDI_Format</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
      <xs:pattern value="EANCOM|EAN 97|EAN 97 A|EDIDATA" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_FORMAT_VERSION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_FORMAT_VERSION Element
Beschreibung
Hier wird angegeben, welche Version des im Element EDI_FORMAT angegebenen EDI-Formates unterstützt wird. D string
P [1-9]\.[0-9]{2}
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_FORMAT_VERSION Element
Overview
EDI_FORMAT_VERSION optional Restriction of xs:string
Hier wird angegeben, welche Version des im Element EDI_FORMAT angegebenen EDI-Formates unterstützt wird. D string
P [1-9]\.[0-9]{2}
M [1:10]
Bemerkung

Quelle
<xs:element name="EDI_FORMAT_VERSION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
      <xs:pattern value="[1-9]\.[0-9]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_MESSAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_MESSAGE Element
Beschreibung
Hier werden die vom Hersteller unterstützten Nachrichten des EDI-Formates angegeben (z. B. Order, Order Response). D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_MESSAGE Element
Overview
EDI_MESSAGE optional Restriction of xs:string
Hier werden die vom Hersteller unterstützten Nachrichten des EDI-Formates angegeben (z. B. Order, Order Response). D string
P
M [1:20]
Bemerkung

Quelle
<xs:element name="EDI_MESSAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_COMMUNICATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_COMMUNICATION Element
Beschreibung
Hier wird angegeben, auf welchem Weg die EDI-Kommunikation erfolgt (z. B. X.400, Telebox, E-Mail). D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_COMMUNICATION Element
Overview
EDI_COMMUNICATION optional Restriction of xs:string
Hier wird angegeben, auf welchem Weg die EDI-Kommunikation erfolgt (z. B. X.400, Telebox, E-Mail). D string
P
M [1:20]
Bemerkung

Quelle
<xs:element name="EDI_COMMUNICATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_COMMUNICATION_ADDRESS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_COMMUNICATION_ADDRESS Element
Beschreibung
Hier wird die Adresse für den angegebenen Kommunikationsweg angegeben (z. B. X.400 Adresse, E-Mail-Adresse oder nach Rücksprache). D string
P
M [1:40]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_COMMUNICATION_ADDRESS Element
Overview
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
Hier wird die Adresse für den angegebenen Kommunikationsweg angegeben (z. B. X.400 Adresse, E-Mail-Adresse oder nach Rücksprache). D string
P
M [1:40]
Bemerkung

Quelle
<xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="40" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDI_CONTACT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_CONTACT Element
Beschreibung
Hier wird die Person angegeben, die beim Hersteller als Kontakt für Details zur EDI Abwicklung zur Verfügung steht. Die Angabe der Kontaktinformationen ist frei, d. h. es können im Rahmen der max. Feldlänge die notwendigen Informationen wie beispielsweise Name, Telefon oder E-Mail angegeben werden. D string
P
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_CONTACT Element
Overview
EDI_CONTACT optional Restriction of xs:string
Hier wird die Person angegeben, die beim Hersteller als Kontakt für Details zur EDI Abwicklung zur Verfügung steht. Die Angabe der Kontaktinformationen ist frei, d. h. es können im Rahmen der max. Feldlänge die notwendigen Informationen wie beispielsweise Name, Telefon oder E-Mail angegeben werden. D string
P
M [1:60]
Bemerkung

Quelle
<xs:element name="EDI_CONTACT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BRANCH_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : BRANCH_ID Element
Beschreibung
In diesem Element wird das Kennzeichen für die Herstellerbranche angegeben. Derzeit sind folgende Branchenkennzeichen definiert:

A = Arbeitsplattenhersteller
B = Badmöbelhersteller
G = Gerätehersteller
K = Küchenmöbelhersteller
O = Büromöbelhersteller
P = Polstermöbelhersteller
S = Sanitärhersteller
W = Wohnmöbelhersteller
Z = Zubehörhersteller 		D string
P [ABGKOPSWZ]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
BRANCH_ID Element
Overview
BRANCH_ID Restriction of xs:string
In diesem Element wird das Kennzeichen für die Herstellerbranche angegeben. Derzeit sind folgende Branchenkennzeichen definiert:

A = Arbeitsplattenhersteller
B = Badmöbelhersteller
G = Gerätehersteller
K = Küchenmöbelhersteller
O = Büromöbelhersteller
P = Polstermöbelhersteller
S = Sanitärhersteller
W = Wohnmöbelhersteller
Z = Zubehörhersteller 		D string
P [ABGKOPSWZ]
M [1:1]
Bemerkung

Quelle
<xs:element name="BRANCH_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--8--Branchen_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[ABGKOPSWZ]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ISO_COUNTRY_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : ISO_COUNTRY_ID Element
Beschreibung
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Bemerkung

Quelle
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GLN_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : GLN_NO Element
Beschreibung
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN Nummer ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch. D string
P [0-9]{13}
M [13:13]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
GLN_NO Element
Overview
GLN_NO optional Restriction of xs:string
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN Nummer ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch. D string
P [0-9]{13}
M [13:13]
Bemerkung

Quelle
<xs:element name="GLN_NO" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--45--GLN_Nr 30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, verpflichtend, K. Richter 21.08.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{13}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WEEE_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : WEEE_NO Element
Beschreibung
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
WEEE_NO Element
Overview
WEEE_NO optional Restriction of xs:string
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
Bemerkung

Quelle
<xs:element name="WEEE_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--47--WEEE_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONTACT_PERSON Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : CONTACT_PERSON Element
Beschreibung
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.
Namensraum (none)
Diagramm
CITY Element ZIPCODE_STREET Element STREET Element EMAIL Element FAX Element TELEPHONE Element DEPARTMENT Element FORM_OF_ADDRESS Element FIRST_NAME Element CONTACT_NAME Element CONTACT_ROLE Element CONTACT_PERSON_NO Element Sequence CONTACT_PERSON Element
Overview
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="CONTACT_PERSON" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONTACT_PERSON_NO">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_ROLE">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_NAME">
        <xs:annotation>
          <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FIRST_NAME">
        <xs:annotation>
          <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FORM_OF_ADDRESS">
        <xs:annotation>
          <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPARTMENT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE">
        <xs:annotation>
          <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONTACT_PERSON_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_PERSON_NO Element
Beschreibung
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme) D positiveInteger
P
M [1:2]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CONTACT_PERSON_NO Element
Overview
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme) D positiveInteger
P
M [1:2]
Bemerkung

Quelle
<xs:element name="CONTACT_PERSON_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONTACT_ROLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_ROLE Element
Beschreibung
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONTACT_ROLE Element
Overview
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
Bemerkung

Quelle
<xs:element name="CONTACT_ROLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONTACT_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_NAME Element
Beschreibung
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONTACT_NAME Element
Overview
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
Bemerkung

Quelle
<xs:element name="CONTACT_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FIRST_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FIRST_NAME Element
Beschreibung
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FIRST_NAME Element
Overview
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
Bemerkung

Quelle
<xs:element name="FIRST_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FORM_OF_ADDRESS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FORM_OF_ADDRESS Element
Beschreibung
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
FORM_OF_ADDRESS Element
Overview
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
Bemerkung

Quelle
<xs:element name="FORM_OF_ADDRESS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEPARTMENT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : DEPARTMENT Element
Beschreibung
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
DEPARTMENT Element
Overview
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
Bemerkung

Quelle
<xs:element name="DEPARTMENT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TELEPHONE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : TELEPHONE Element
Beschreibung
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TELEPHONE Element
Overview
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="TELEPHONE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FAX Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FAX Element
Beschreibung
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FAX Element
Overview
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="FAX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EMAIL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : EMAIL Element
Beschreibung
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
Bemerkung

Quelle
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STREET Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : STREET Element
Beschreibung
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
STREET Element
Overview
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : ZIPCODE_STREET Element
Beschreibung
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Bemerkung

Quelle
<xs:element name="ZIPCODE_STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CITY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CITY Element
Beschreibung
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CITY Element
Overview
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="CITY" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONTACT_SUPPLIER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element : CONTACT_SUPPLIER Element
Beschreibung
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Namensraum (none)
Diagramm
FAX_SWITCHBOARD Element TELEPHONE_SWITCHBOARD Element POSTBOX Element ZIPCODE_POSTBOX Element CITY Element ZIPCODE_STREET Element STREET Element INTERNET_ADDRESS Element EMAIL Element MANUFACTURER_NAME_2 Element MANUFACTURER_NAME_1 Element Sequence CONTACT_SUPPLIER Element
Overview
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="CONTACT_SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_NAME_1">
        <xs:annotation>
          <xs:documentation>100--16--Herstellername_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--17--Herstellername_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INTERNET_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--19--Internet_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET">
        <xs:annotation>
          <xs:documentation>100--20--Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET">
        <xs:annotation>
          <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY">
        <xs:annotation>
          <xs:documentation>100--22--Ort</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--24--Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9a-zA-Z]{0,10}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANUFACTURER_NAME_1 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_1 Element
Beschreibung
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MANUFACTURER_NAME_1 Element
Overview
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="MANUFACTURER_NAME_1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--16--Herstellername_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANUFACTURER_NAME_2 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_2 Element
Beschreibung
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MANUFACTURER_NAME_2 Element
Overview
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="MANUFACTURER_NAME_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--17--Herstellername_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EMAIL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : EMAIL Element
Beschreibung
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

Bemerkung

Quelle
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

INTERNET_ADDRESS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : INTERNET_ADDRESS Element
Beschreibung
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
INTERNET_ADDRESS Element
Overview
INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
Bemerkung

Quelle
<xs:element name="INTERNET_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--19--Internet_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STREET Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : STREET Element
Beschreibung
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
STREET Element
Overview
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--20--Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_STREET Element
Beschreibung
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Bemerkung

Quelle
<xs:element name="ZIPCODE_STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CITY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : CITY Element
Beschreibung
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CITY Element
Overview
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="CITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--22--Ort</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ZIPCODE_POSTBOX Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_POSTBOX Element
Beschreibung
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_POSTBOX Element
Overview
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
Bemerkung

Quelle
<xs:element name="ZIPCODE_POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

POSTBOX Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : POSTBOX Element
Beschreibung
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
POSTBOX Element
Overview
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Bemerkung

Quelle
<xs:element name="POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--24--Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9a-zA-Z]{0,10}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TELEPHONE_SWITCHBOARD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : TELEPHONE_SWITCHBOARD Element
Beschreibung
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TELEPHONE_SWITCHBOARD Element
Overview
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="TELEPHONE_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FAX_SWITCHBOARD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : FAX_SWITCHBOARD Element
Beschreibung
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FAX_SWITCHBOARD Element
Overview
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="FAX_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GLOBAL_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : GLOBAL_DEFINITION Element
Beschreibung
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Namensraum (none)
Diagramm
GROUP_TITLES Element PROPERTIES Element DETAIL_INFOS Element MODULE_RULE_SET_DEFINITIONS Element FRONT_APPEARANCES Element FRONTS_HANDLE_POSITIONS Element CLEARING_GROUP Element Sequence GLOBAL_DEFINITION Element
Overview
GLOBAL_DEFINITION optional
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Sequence
CLEARING_GROUP 0..∞
Das Element dient zur Definition von Verrechnungsgruppen. Eine Verrechnungsgruppe wird durch das Zusammenfassen mehrere Tausch-ID (Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID) gebildet.

Die Verrechnungsgruppen werden in Blockbedingungen (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) und den Wertestaffeln (BLOCK_VALUE_CALCULATION/GRADING_TABLE) zur Bestimmung von Mindestwerten bestimmter Typenbereiche verwendet. Die Typenbereiche werden durch die Tausch-ID identifiziert.

Die Beträge aller Auftragsposition, deren Tausch-ID in einer Verrechnungsgruppe enthalten sind, werden summiert. Je Verrechnungsgruppe resultiert eine Summe, die als Vergleichskriterium zum Einstieg in die Blockbedingungen und in die Wertestaffel verwendet wird.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut identifiziert eine Verechnungsgruppe. D nonNegativeInteger
P
M [0:999]
Sequence
EXCHANGE_ID_REF 1..∞
Dieses Element referenziert eine Tausch-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
CLEARING_GROUP_NAME languagetexte60 Complex Type
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FRONTS_HANDLE_POSITIONS optional
In diesem Element werden Grifflagen definiert. Es können Basisgrifflagen und spezielle Grifflagen definiert werden. Basisgrifflagen sind global gültig, spezielle Grifflagen definieren die Grifflagen unter spezifischen Bedigungen.
Sequence
SPECIFIC_HANDLE_POSITIONS optional
In diesem Element können spezielle Grifflagen, Änderungen von Grifflagen und Griffwechsel definiert werden. Im Weiteren wird für diese Situationen der Begriff "spezielle Grifflage" verwendet. Alle Kind-Elemente können beliebig kombiniert werden. Je mehr Kind-Elemente gefüllt sind, desto spezieller ist die Situation für eine spezielle Grifflage beschrieben. Neben dem Element PRIORITY (Pfad1 ) muss mindestens ein Key-Feld gefüllt werden.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/
Sequence
SPECIFIC_HANDLE_ORIENTATION 1..∞
In diesem Element wird eine spezifische Grifflage definiert.
SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine spezielle Grifflage identifiziert. D nonNegativeInteger
P
M [0:99999]
Sequence
STYLE_REF optional
Über Referenzierung wird definiert, für welches Programm die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Programme gültig.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Elementpfade:
Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
FRONT_TYPE_GROUP_REF optional
Hier wird definiert, für welche Fronttypgruppe die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Fronttypgruppen gültig.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Fronttypgruppe referenziert. D nonNegativeInteger
P
M [1:99]
WIDTH_FROM optional Restriction of xs:positiveInteger
Hier wird definiert, ab welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Wenn dieses Element gefüllt ist, muss auch dass Element WIDTH_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
WIDTH_TO optional Restriction of xs:positiveInteger
Hier wird definiert, bis zu welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Dieses Element muss gefüllt werden, wenn das Element WIDTH_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft angegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
Hier wird definiert, ab welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Wenn dieses Element gefüllt ist, muss auch dass Element HEIGHT_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
HEIGHT_TO optional Restriction of xs:nonNegativeInteger
Hier wird definiert, bis zu welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Dieses Element muss gefüllt werden, wenn das Element HEIGHT_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
OPTION_REF
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Aufgrund der in der Praxis vorkommenden Situationen dürfen hier nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Element gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) enthält.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. Es kann nur die Variantenart 154 angegeben werden. D nonNegativeInteger
P
M [154:154]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Hier dürfen nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Feld gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Glastürrahmenausführung" (154) enthält. 		D string
P
M [1:5]
HANDLE_EXCHANGE optional
In diesem Element wird ein Griffwechsel definiert, der angewendet wird wenn die im Element SPECIFIC_HANDLE_ORIENTATION definierten Bedingungen erfüllt sind.
Sequence
FEATURE_REF
Dieses Element referenziert eine Variantenart, die im Element FEATURE_DEFINITION/FEATURES/FEATURE definiert sein muss.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
FROM_HANDLE
In diesem Element wird definiert von welchem Griff gewechselt wird.
Sequence
OPTION_REF
Dieses Element referenziert eine Griffvariante im Element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. Hierdurch wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Griffvarianten.
TO_HANDLE
In diesem Element wird definiert, auf welchen Griff gewechselt wird.
Sequence
OPTION_REF
Hier wird definiert, auf welche Griffvariante in einer beschriebenen Situation gewechselt wird.
HANDLE_ORIENTATION_EXCHANGE optional
In diesem Element wird ein Wechsel von Grifflagen definiert.
Sequence
FROM_HANDLE_ORIENTATION_REF
Hier wird definiert, bei welcher Basisgrifflage die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Basisgrifflagen.
Die Grifflage muss im Element BASIC_HANDLE_POSITIONS (Pfad1) definiert sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage referenziert. D positiveInteger
P
M [1:9999]
TO_HANDLE_ORIENTATION_REF
In diesem Element wird angegeben, auf welche Grifflage gewechselt wird.

HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage identifiziert D positiveInteger
P
M [1:9999]
PRIORITY Restriction of xs:nonNegativeInteger
In diesem Element wird die Priorität einer speziellen Grifflage definiert.
Bei der Anwendung der im Element SPECIFIC_HANDLE_ORIENTATION (Pfad 1) angelegten speziellen Grifflagen, ist es möglich, dass mehrere Grifflagen gültig angewendet werden können, was zu unerwünschten Ergebnissen führen kann.
Zur Vermeidung dieser Situation wird der speziellen Grifflage eine Priorität zugeordnet.
Die Priorität nimmt mit steigendem Zahlenwert zu. Unter einer Priorität können mehrere Grifflagen zusammengefasst werden. Bei Grifflagen einer Priorität müssen die gleichen Key-Elemente gefüllt sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
BASIC_HANDLE_POSITIONS

In diesem Element wird beschrieben, welche Lage und Position Griffe auf bestimmten Fronttypen aufweisen. Die in diesem Element definierten Basisgrifflagen sind global gültig.

Die Basisgrifflagen sollten sich an den vordefierten Standardgrifflagen des Abschnittes Standardgrifflagen orientieren. Allerdings ist hier zu beachten, dass für die Basisgrifflagen der Wert 0 nicht benutzt werden kann.

Sequence
HANDLE_ORIENTATION 1..∞
Dieses Element ist ein Container-Element, in dem die unterschiedlichen Basisgrifflagen definiert werden.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Basisgrifflage identifiziert. D positiveInteger
P
M [1:9999]
Sequence
FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird in dem Attribut FRONT_TYPE_CODE angegeben.
FRONT_TYPE_CODE required Restriction of xs:string
Hier wird definiert, für welchen Fronttyp eine Grifflage beschrieben wird. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung 		D string
P [SAKJTR]|GT
M [1:2]
Sequence
ORIENTATION Restriction of xs:string
Hier wird definiert, welche Lage die Griffe bei dem Fronttyp haben.
H = horizontal
V = vertikal 		D string
P [HV]
M [1:1]
POSITION Restriction of xs:string
Hier wird definiert, welche Position die Griffe bei dem Fronttyp haben.

M = mittig (z. B. auch für durchgehende Griffleiste, anschlagsneutral)
A = außen (auch für Griffleiste abhängig vom Anschlag)
D = doppelt (zwei Griffe außen)
G = ohne Bohrung mit Griff (Griff wird geliefert, Bohrung bauseits)
0 (Null) = ohne Bohrung ohne Griff (Griff wird nicht geliefert, auch Grifflose Küche)

Bei der Position A = außen wird die konkrete Position rechts/links über den Anschlag des Artikel bestimmt. 		D string
P [MADG0]
M [1:1]
FRONT_TYPES_GROUPS optional
Für die effiziente Verwendung von Fronttypen bei der Definition von spezifischen Grifflagen im Element SPECIFIC_HANDLE_ORIENTATION (Pfad1) können Fronttypen zu Fronttyp-Gruppen zusammengefasst werden.

Elementpfade
Pfad1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/
Sequence
FRONT_TYPES_GROUP 1..99
In diesem Element wird eine Gruppe von Fronttypen definiert.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Fronttypgruppe identifiziert. D nonNegativeInteger
P
M [1:99]
Sequence
FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird über das Attribut FRONT_TYPE_CODE angegeben.
FRONT_TYPE_CODE required Restriction of xs:string
Hier werden die Fronttypen angegeben, die zu einer Fronttypgruppe zusammengefasst werden sollen. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung)
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung) 		D string
P [SAKJTR]|GT
M [1:2]

FRONT_APPEARANCES optional
In diesem Element werden die Frontausprägungen eines Programms, einer Ausführung oder eines Artikels definiert. Hier definierte Frontausprägungen werden von Programmen (FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF), Ausführungen (FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF) oder von Artikeln (SERIES/.../ITEM/FRONT_APPEARANCE_REF) referenziert.
Ein Frontausprägung wird grundlegend definiert, in dem eine Grundformnummer für ein Frontelement zugeordnet und die Geometrie über Angabe der Maße bestimmt wird.
Sequence
FRONT_APPEARANCE 1..999
In diesem Element wird eine Frontausprägung definiert.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird. D positiveInteger
P
M [1:999]
Sequence
FRONT_TYPE 1..900
Wenn alle Frontelemente unabhängig vom Fronttyp gleiches Aussehen haben, wird eine Definition mit dem Fronttyp 0 angelegt. Dann dürfen keine weiteren mit abweichenden Fronttypen angelegt werden. Wenn für eine Frontausprägungs-ID ein Datensatz mit einem Fronttyp angelegt wurde, so müssen für alle verwendeten Fronttypen ebenfalls Datensätze angelegt werden.
Sequence
FRONT_TYPE_NO Restriction of xs:positiveInteger
In diesem Attribut wird der Schlüsselwert des Fronttyps angegeben. D positiveInteger
P
M [0:1000]
Sequence 1..∞
FRONT_CONSTRAINTS optional
Für die Elemente WIDTH_FROM/TO und HEIGTH_FROM/TO gelten folgende Regeln:

- Wenn die Elemente WIDTH_TO oder HEIGHT_TO nicht angelegt sind, so entspricht dies dem Wert „unendlich“.
- Wenn die Elemente WIDTH_FROM oder HEIGHT_FROM nicht angelegt sind, so entspricht dies dem Wert 0.
- Der Wert 0 ist in den Elementen WIDTH_FROM/TO oder HEIGTH_FROM/TO nicht zulässig.
- Die angegebenen Intervalle dürfen sich nicht überlappen und müssen immer den gesamten Bereich
von 0 bis unendlich abdecken. Es dürfen keine Lücken entstehen.
Sequence
WIDTH_FROM optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird (Maße in mm). D positiveInteger
P
M [1:999999]
WIDTH_TO optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
HEIGHT_FROM optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
HEIGHT_TO optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
FRONT_SHAPE
In diesem Element sind die Elemente zur geometrischen Beschreibung eines Frontelementes zusammengefasst.
Sequence
GLASS Restriction of xs:boolean
Durch dieses Element kann festgelegt werden, ob es sich bei dem angegebenen Fronttyp um eine Glasversion (Wert 1/true) oder um eine normale Version (Wert 0/false) handelt. Die Werte in diesem Element dürfen für einen Fronttyp nicht wechseln. Durch diese Regel wird verhindert, dass beispielsweise aus einer Glastür durch Auswahl eines anderen Programms eine Massivtür wird. D boolean
P
M
Choice
MODELING_GRAPHIC_ID optional Restriction of xs:string
Hier kann eine Echtgrafik angegeben werden.

Das Format muss dahingehend noch ausformuliert werden. 		D string
P
M [1:15]
BASIC_FRONT_SHAPE optional
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.

Der Wert 999 darf nicht mehr verwendet werden. 		D string
P
M [1:3]
PARAMETERS 1..∞
In diesem Element werden den Frontparametern die Werte zugeordnet.
MODULE_RULE_SET_DEFINITIONS optional
In diesem Element werden die Regeln für Modulschränke und die darin zu verbauenden Module gesammelt.
Sequence
MODULE_RULE_SET_DEFINITION 1..∞
In diesem Element werden die Regeln für Modulränke und die darin zu verbauenden Module definiert. Hier definierte Modulregeln werden von Artikeln (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) oder (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) referenziert.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D nonNegativeInteger
P
M
Sequence
MODULE_RULE_SET_NAME languagetexte60 Complex Type
In diesem Element wir die Bezeichnung des Regelwerks hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS optional
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
Sequence
DETAIL_INFO 1..∞

In diesem Element wird eine Detailinformation definiert.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
Dieses Element enthält Text für einen Tooltip zum Link.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element ist für die URL zur Detailinformation.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
PROPERTIES optional

Dieses Element dient zur Aufnahme zusätzlicher Informationen und Eigenschafen wie z. B. Energielabel, Effizienzklassen und ähnlicher Daten. Es werden nur die Eigenschaften definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Die Schlüssel sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

Sequence
PROPERTY 1..∞

In diesem Element wird eine Eigenschaft definiert.

Die Schlüssel, der Text und die Maßeinheit sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

PROPERTY_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die Eigenschaft identifiziert.

Ihre Nummer ist der Tabelle der Informationsschlüssel zu eintnehmen.

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetexte Complex Type

Dieses Element enthält Texte für Eigenschaften/Merkmale.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PROPERTY_UNIT optional languagetexte30 Complex Type
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
GROUP_TITLES optional
Hier werden an zentraler Stelle alle möglichen Bezeichnungen für Gruppen von optionalen und zwingenden Zusatzartikeln gespeichert.
Sequence
GROUP_TITLE 1..∞
Dieses Element dient zur Speicherung eines Gruppentitels.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine eindeutige Nummer zur späteren Referenzierung des Gruppentitels gespeichert. D nonNegativeInteger
P
M [0-999]
Sequence
GROUP_TITLE_NAME languagetexte60 Complex Type
Dieses Element enthält Namen für Gruppen von Zusatzartikeln.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="GLOBAL_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="CLEARING_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONTS_HANDLE_POSITIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SPECIFIC_HANDLE_POSITIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SPECIFIC_HANDLE_ORIENTATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="STYLE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="STYLE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="WIDTH_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--4--Breite_von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="WIDTH_TO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--5--Breite_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEIGHT_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--6--Hoehe_von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEIGHT_TO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--7--Hoehe_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OPTION_REF">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="154" />
                                  <xs:maxInclusive value="154" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HANDLE_EXCHANGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FEATURE_REF">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FROM_HANDLE">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTION_REF">
                                      <xs:annotation>
                                        <xs:documentation>232--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="300" />
                                              <xs:maxInclusive value="303" />
                                              <xs:pattern value="300|303" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="5" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TO_HANDLE">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTION_REF">
                                      <xs:annotation>
                                        <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="300" />
                                              <xs:maxInclusive value="303" />
                                              <xs:pattern value="300|303" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="5" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FROM_HANDLE_ORIENTATION_REF">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TO_HANDLE_ORIENTATION_REF">
                                <xs:annotation>
                                  <xs:documentation>----</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>----</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRIORITY">
                          <xs:annotation>
                            <xs:documentation>232--14--Prioritaet</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="BASIC_HANDLE_POSITIONS">
              <xs:annotation>
                <xs:documentation>230--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="HANDLE_ORIENTATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>230--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_TYPE" maxOccurs="7">
                          <xs:annotation>
                            <xs:documentation>230--3--Fronttyp</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ORIENTATION">
                                <xs:annotation>
                                  <xs:documentation>230--4--Lage</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[HV]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="POSITION">
                                <xs:annotation>
                                  <xs:documentation>230--5--Position</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[MADG0]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FRONT_TYPE_CODE" use="required">
                              <xs:annotation>
                                <xs:documentation>230--3--Fronttyp</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="[SAKJTR]|GT" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>230--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_TYPES_GROUPS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>231--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_TYPES_GROUP" maxOccurs="99">
                    <xs:annotation>
                      <xs:documentation>231--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_TYPE" maxOccurs="7">
                          <xs:annotation>
                            <xs:documentation>231--3--Fronttyp</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_TYPE_CODE" use="required">
                              <xs:annotation>
                                <xs:documentation>231--3--Fronttyp</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="[SAKJTR]|GT" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>231--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_APPEARANCES" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_APPEARANCE" maxOccurs="999">
              <xs:annotation>
                <xs:documentation>520--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_TYPE" maxOccurs="900">
                    <xs:annotation>
                      <xs:documentation>520--3--Fronttyp</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_TYPE_NO">
                          <xs:annotation>
                            <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="900" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:sequence maxOccurs="unbounded">
                          <xs:element name="FRONT_CONSTRAINTS" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="WIDTH_FROM" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>520/570--6--Breite_von</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="WIDTH_TO" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>520/570--7--Breite_von</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="HEIGHT_FROM" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="HEIGHT_TO" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="FRONT_SHAPE">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="GLASS">
                                  <xs:annotation>
                                    <xs:documentation>520--10--Glas</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:boolean" />
                                  </xs:simpleType>
                                </xs:element>
                                <xs:choice>
                                  <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="BASIC_FRONT_SHAPE_ID">
                                          <xs:annotation>
                                            <xs:documentation>520--4--Front_Grundform</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="3" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PARAMETERS" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="VALUE">
                                              <xs:annotation>
                                                <xs:documentation>520--5--Wert</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:maxLength value="12" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="PARAMETER">
                                              <xs:annotation>
                                                <xs:documentation>570--4--Parameter</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:minLength value="1" />
                                                  <xs:maxLength value="5" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:choice>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>520--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MODULE_RULE_SET_DEFINITIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_RULE_SET_DEFINITION" maxOccurs="unbounded">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MODULE_RULE_SET_NAME" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Um Mehrsprachenfaehigkeit erweitert AK 28.02.2012</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INFO_TYPE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                      <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                      <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[01]|99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="INTERNAL_NAME" type="languagetexte40">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="GUID">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="URL">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:anyURI">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="1024" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HASH_VALUE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="64" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESOLUTION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="4" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>Version 2.3 </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROPERTY" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>Version 2.3</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROPERTY_TEXT" type="languagetexte" minOccurs="1" maxOccurs="1" />
                  <xs:element name="PROPERTY_UNIT" type="languagetexte30" minOccurs="0" maxOccurs="1" />
                </xs:sequence>
                <xs:attribute name="PROPERTY_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GROUP_TITLES" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>120--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="GROUP_TITLE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="GROUP_TITLE_NAME" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="GROUP_TITLE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : CLEARING_GROUP Element
Beschreibung
Das Element dient zur Definition von Verrechnungsgruppen. Eine Verrechnungsgruppe wird durch das Zusammenfassen mehrere Tausch-ID (Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID) gebildet.

Die Verrechnungsgruppen werden in Blockbedingungen (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) und den Wertestaffeln (BLOCK_VALUE_CALCULATION/GRADING_TABLE) zur Bestimmung von Mindestwerten bestimmter Typenbereiche verwendet. Die Typenbereiche werden durch die Tausch-ID identifiziert.

Die Beträge aller Auftragsposition, deren Tausch-ID in einer Verrechnungsgruppe enthalten sind, werden summiert. Je Verrechnungsgruppe resultiert eine Summe, die als Vergleichskriterium zum Einstieg in die Blockbedingungen und in die Wertestaffel verwendet wird.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence CLEARING_GROUP_NAME Element EXCHANGE_ID_REF Element Sequence CLEARING_GROUP Element
Overview
CLEARING_GROUP 0..∞
Das Element dient zur Definition von Verrechnungsgruppen. Eine Verrechnungsgruppe wird durch das Zusammenfassen mehrere Tausch-ID (Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID) gebildet.

Die Verrechnungsgruppen werden in Blockbedingungen (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) und den Wertestaffeln (BLOCK_VALUE_CALCULATION/GRADING_TABLE) zur Bestimmung von Mindestwerten bestimmter Typenbereiche verwendet. Die Typenbereiche werden durch die Tausch-ID identifiziert.

Die Beträge aller Auftragsposition, deren Tausch-ID in einer Verrechnungsgruppe enthalten sind, werden summiert. Je Verrechnungsgruppe resultiert eine Summe, die als Vergleichskriterium zum Einstieg in die Blockbedingungen und in die Wertestaffel verwendet wird.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut identifiziert eine Verechnungsgruppe. D nonNegativeInteger
P
M [0:999]
Sequence
EXCHANGE_ID_REF 1..∞
Dieses Element referenziert eine Tausch-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
CLEARING_GROUP_NAME languagetexte60 Complex Type
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
CLEARING_GROUP_NO Restriction of xs:nonNegativeInteger required
Dieses Attribut identifiziert eine Verechnungsgruppe. D nonNegativeInteger
P
M [0:999]
Bemerkung

Quelle
<xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="CLEARING_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > CLEARING_GROUP Element : EXCHANGE_ID_REF Element
Beschreibung
Dieses Element referenziert eine Tausch-ID.
Namensraum (none)
Diagramm
EXCHANGE_ID_REF Element
Overview
EXCHANGE_ID_REF 1..∞
Dieses Element referenziert eine Tausch-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Bemerkung

Quelle
<xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
CLEARING_GROUP Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > CLEARING_GROUP Element : CLEARING_GROUP_NAME Element
Beschreibung
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence CLEARING_GROUP_NAME Element
Overview
CLEARING_GROUP_NAME languagetexte60 Complex Type
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="CLEARING_GROUP_NAME" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CLEARING_GROUP Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > languagetexte60 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetexte60 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > languagetexte60 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte60 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONTS_HANDLE_POSITIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : FRONTS_HANDLE_POSITIONS Element
Beschreibung
In diesem Element werden Grifflagen definiert. Es können Basisgrifflagen und spezielle Grifflagen definiert werden. Basisgrifflagen sind global gültig, spezielle Grifflagen definieren die Grifflagen unter spezifischen Bedigungen.
Namensraum (none)
Diagramm
FRONT_TYPES_GROUPS Element BASIC_HANDLE_POSITIONS Element SPECIFIC_HANDLE_POSITIONS Element Sequence FRONTS_HANDLE_POSITIONS Element
Overview
FRONTS_HANDLE_POSITIONS optional
In diesem Element werden Grifflagen definiert. Es können Basisgrifflagen und spezielle Grifflagen definiert werden. Basisgrifflagen sind global gültig, spezielle Grifflagen definieren die Grifflagen unter spezifischen Bedigungen.
Sequence
SPECIFIC_HANDLE_POSITIONS optional
In diesem Element können spezielle Grifflagen, Änderungen von Grifflagen und Griffwechsel definiert werden. Im Weiteren wird für diese Situationen der Begriff "spezielle Grifflage" verwendet. Alle Kind-Elemente können beliebig kombiniert werden. Je mehr Kind-Elemente gefüllt sind, desto spezieller ist die Situation für eine spezielle Grifflage beschrieben. Neben dem Element PRIORITY (Pfad1 ) muss mindestens ein Key-Feld gefüllt werden.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/
Sequence
SPECIFIC_HANDLE_ORIENTATION 1..∞
In diesem Element wird eine spezifische Grifflage definiert.
SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine spezielle Grifflage identifiziert. D nonNegativeInteger
P
M [0:99999]
Sequence
STYLE_REF optional
Über Referenzierung wird definiert, für welches Programm die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Programme gültig.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Elementpfade:
Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
FRONT_TYPE_GROUP_REF optional
Hier wird definiert, für welche Fronttypgruppe die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Fronttypgruppen gültig.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Fronttypgruppe referenziert. D nonNegativeInteger
P
M [1:99]
WIDTH_FROM optional Restriction of xs:positiveInteger
Hier wird definiert, ab welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Wenn dieses Element gefüllt ist, muss auch dass Element WIDTH_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
WIDTH_TO optional Restriction of xs:positiveInteger
Hier wird definiert, bis zu welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Dieses Element muss gefüllt werden, wenn das Element WIDTH_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft angegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
Hier wird definiert, ab welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Wenn dieses Element gefüllt ist, muss auch dass Element HEIGHT_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
HEIGHT_TO optional Restriction of xs:nonNegativeInteger
Hier wird definiert, bis zu welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Dieses Element muss gefüllt werden, wenn das Element HEIGHT_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
OPTION_REF
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Aufgrund der in der Praxis vorkommenden Situationen dürfen hier nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Element gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) enthält.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. Es kann nur die Variantenart 154 angegeben werden. D nonNegativeInteger
P
M [154:154]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Hier dürfen nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Feld gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Glastürrahmenausführung" (154) enthält. 		D string
P
M [1:5]
HANDLE_EXCHANGE optional
In diesem Element wird ein Griffwechsel definiert, der angewendet wird wenn die im Element SPECIFIC_HANDLE_ORIENTATION definierten Bedingungen erfüllt sind.
Sequence
FEATURE_REF
Dieses Element referenziert eine Variantenart, die im Element FEATURE_DEFINITION/FEATURES/FEATURE definiert sein muss.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
FROM_HANDLE
In diesem Element wird definiert von welchem Griff gewechselt wird.
Sequence
OPTION_REF
Dieses Element referenziert eine Griffvariante im Element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. Hierdurch wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Griffvarianten.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Varinatenart des Griffes angegeben von dem gewechselt wird. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Feld leer, so gilt die spezielle Grifflage für alle Griffvarianten. D string
P
M [1:5]
TO_HANDLE
In diesem Element wird definiert, auf welchen Griff gewechselt wird.
Sequence
OPTION_REF
Hier wird definiert, auf welche Griffvariante in einer beschriebenen Situation gewechselt wird.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Variantenarten der referenzierten Griffvariante angegeben. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird der Variantenschlüssel der Griffvariante angegeben, auf die gewechselt wird. D string
P
M [1:5)
HANDLE_ORIENTATION_EXCHANGE optional
In diesem Element wird ein Wechsel von Grifflagen definiert.
Sequence
FROM_HANDLE_ORIENTATION_REF
Hier wird definiert, bei welcher Basisgrifflage die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Basisgrifflagen.
Die Grifflage muss im Element BASIC_HANDLE_POSITIONS (Pfad1) definiert sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage referenziert. D positiveInteger
P
M [1:9999]
TO_HANDLE_ORIENTATION_REF
In diesem Element wird angegeben, auf welche Grifflage gewechselt wird.

HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage identifiziert D positiveInteger
P
M [1:9999]
PRIORITY Restriction of xs:nonNegativeInteger
In diesem Element wird die Priorität einer speziellen Grifflage definiert.
Bei der Anwendung der im Element SPECIFIC_HANDLE_ORIENTATION (Pfad 1) angelegten speziellen Grifflagen, ist es möglich, dass mehrere Grifflagen gültig angewendet werden können, was zu unerwünschten Ergebnissen führen kann.
Zur Vermeidung dieser Situation wird der speziellen Grifflage eine Priorität zugeordnet.
Die Priorität nimmt mit steigendem Zahlenwert zu. Unter einer Priorität können mehrere Grifflagen zusammengefasst werden. Bei Grifflagen einer Priorität müssen die gleichen Key-Elemente gefüllt sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
BASIC_HANDLE_POSITIONS

In diesem Element wird beschrieben, welche Lage und Position Griffe auf bestimmten Fronttypen aufweisen. Die in diesem Element definierten Basisgrifflagen sind global gültig.

Die Basisgrifflagen sollten sich an den vordefierten Standardgrifflagen des Abschnittes Standardgrifflagen orientieren. Allerdings ist hier zu beachten, dass für die Basisgrifflagen der Wert 0 nicht benutzt werden kann.

Sequence
HANDLE_ORIENTATION 1..∞
Dieses Element ist ein Container-Element, in dem die unterschiedlichen Basisgrifflagen definiert werden.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Basisgrifflage identifiziert. D positiveInteger
P
M [1:9999]
Sequence
FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird in dem Attribut FRONT_TYPE_CODE angegeben.
FRONT_TYPE_CODE required Restriction of xs:string
Hier wird definiert, für welchen Fronttyp eine Grifflage beschrieben wird. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung 		D string
P [SAKJTR]|GT
M [1:2]
Sequence
ORIENTATION Restriction of xs:string
Hier wird definiert, welche Lage die Griffe bei dem Fronttyp haben.
H = horizontal
V = vertikal 		D string
P [HV]
M [1:1]
POSITION Restriction of xs:string
Hier wird definiert, welche Position die Griffe bei dem Fronttyp haben.

M = mittig (z. B. auch für durchgehende Griffleiste, anschlagsneutral)
A = außen (auch für Griffleiste abhängig vom Anschlag)
D = doppelt (zwei Griffe außen)
G = ohne Bohrung mit Griff (Griff wird geliefert, Bohrung bauseits)
0 (Null) = ohne Bohrung ohne Griff (Griff wird nicht geliefert, auch Grifflose Küche)

Bei der Position A = außen wird die konkrete Position rechts/links über den Anschlag des Artikel bestimmt. 		D string
P [MADG0]
M [1:1]
FRONT_TYPES_GROUPS optional
Für die effiziente Verwendung von Fronttypen bei der Definition von spezifischen Grifflagen im Element SPECIFIC_HANDLE_ORIENTATION (Pfad1) können Fronttypen zu Fronttyp-Gruppen zusammengefasst werden.

Elementpfade
Pfad1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/
Sequence
FRONT_TYPES_GROUP 1..99
In diesem Element wird eine Gruppe von Fronttypen definiert.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Fronttypgruppe identifiziert. D nonNegativeInteger
P
M [1:99]
Sequence
FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird über das Attribut FRONT_TYPE_CODE angegeben.
FRONT_TYPE_CODE required Restriction of xs:string
Hier werden die Fronttypen angegeben, die zu einer Fronttypgruppe zusammengefasst werden sollen. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung)
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung) 		D string
P [SAKJTR]|GT
M [1:2]

Bemerkung

Quelle
<xs:element name="FRONTS_HANDLE_POSITIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SPECIFIC_HANDLE_POSITIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SPECIFIC_HANDLE_ORIENTATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="STYLE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="STYLE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="WIDTH_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--4--Breite_von</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="WIDTH_TO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--5--Breite_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEIGHT_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--6--Hoehe_von</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEIGHT_TO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--7--Hoehe_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OPTION_REF">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="154" />
                            <xs:maxInclusive value="154" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HANDLE_EXCHANGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FEATURE_REF">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FROM_HANDLE">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF">
                                <xs:annotation>
                                  <xs:documentation>232--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="300" />
                                        <xs:maxInclusive value="303" />
                                        <xs:pattern value="300|303" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TO_HANDLE">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF">
                                <xs:annotation>
                                  <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="300" />
                                        <xs:maxInclusive value="303" />
                                        <xs:pattern value="300|303" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FROM_HANDLE_ORIENTATION_REF">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TO_HANDLE_ORIENTATION_REF">
                          <xs:annotation>
                            <xs:documentation>----</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>----</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRIORITY">
                    <xs:annotation>
                      <xs:documentation>232--14--Prioritaet</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BASIC_HANDLE_POSITIONS">
        <xs:annotation>
          <xs:documentation>230--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="HANDLE_ORIENTATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>230--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_TYPE" maxOccurs="7">
                    <xs:annotation>
                      <xs:documentation>230--3--Fronttyp</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ORIENTATION">
                          <xs:annotation>
                            <xs:documentation>230--4--Lage</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[HV]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="POSITION">
                          <xs:annotation>
                            <xs:documentation>230--5--Position</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[MADG0]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FRONT_TYPE_CODE" use="required">
                        <xs:annotation>
                          <xs:documentation>230--3--Fronttyp</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:pattern value="[SAKJTR]|GT" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>230--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_TYPES_GROUPS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>231--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_TYPES_GROUP" maxOccurs="99">
              <xs:annotation>
                <xs:documentation>231--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_TYPE" maxOccurs="7">
                    <xs:annotation>
                      <xs:documentation>231--3--Fronttyp</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_TYPE_CODE" use="required">
                        <xs:annotation>
                          <xs:documentation>231--3--Fronttyp</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:pattern value="[SAKJTR]|GT" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>231--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SPECIFIC_HANDLE_POSITIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element : SPECIFIC_HANDLE_POSITIONS Element
Beschreibung
In diesem Element können spezielle Grifflagen, Änderungen von Grifflagen und Griffwechsel definiert werden. Im Weiteren wird für diese Situationen der Begriff "spezielle Grifflage" verwendet. Alle Kind-Elemente können beliebig kombiniert werden. Je mehr Kind-Elemente gefüllt sind, desto spezieller ist die Situation für eine spezielle Grifflage beschrieben. Neben dem Element PRIORITY (Pfad1 ) muss mindestens ein Key-Feld gefüllt werden.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/
Namensraum (none)
Diagramm
SPECIFIC_HANDLE_ORIENTATION Element Sequence SPECIFIC_HANDLE_POSITIONS Element
Overview
SPECIFIC_HANDLE_POSITIONS optional
In diesem Element können spezielle Grifflagen, Änderungen von Grifflagen und Griffwechsel definiert werden. Im Weiteren wird für diese Situationen der Begriff "spezielle Grifflage" verwendet. Alle Kind-Elemente können beliebig kombiniert werden. Je mehr Kind-Elemente gefüllt sind, desto spezieller ist die Situation für eine spezielle Grifflage beschrieben. Neben dem Element PRIORITY (Pfad1 ) muss mindestens ein Key-Feld gefüllt werden.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/
Sequence
SPECIFIC_HANDLE_ORIENTATION 1..∞
In diesem Element wird eine spezifische Grifflage definiert.
SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine spezielle Grifflage identifiziert. D nonNegativeInteger
P
M [0:99999]
Sequence
STYLE_REF optional
Über Referenzierung wird definiert, für welches Programm die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Programme gültig.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Elementpfade:
Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
FRONT_TYPE_GROUP_REF optional
Hier wird definiert, für welche Fronttypgruppe die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Fronttypgruppen gültig.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Fronttypgruppe referenziert. D nonNegativeInteger
P
M [1:99]
WIDTH_FROM optional Restriction of xs:positiveInteger
Hier wird definiert, ab welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Wenn dieses Element gefüllt ist, muss auch dass Element WIDTH_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
WIDTH_TO optional Restriction of xs:positiveInteger
Hier wird definiert, bis zu welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Dieses Element muss gefüllt werden, wenn das Element WIDTH_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft angegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
Hier wird definiert, ab welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Wenn dieses Element gefüllt ist, muss auch dass Element HEIGHT_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
HEIGHT_TO optional Restriction of xs:nonNegativeInteger
Hier wird definiert, bis zu welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Dieses Element muss gefüllt werden, wenn das Element HEIGHT_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
OPTION_REF
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Aufgrund der in der Praxis vorkommenden Situationen dürfen hier nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Element gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) enthält.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. Es kann nur die Variantenart 154 angegeben werden. D nonNegativeInteger
P
M [154:154]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Hier dürfen nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Feld gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Glastürrahmenausführung" (154) enthält. 		D string
P
M [1:5]
HANDLE_EXCHANGE optional
In diesem Element wird ein Griffwechsel definiert, der angewendet wird wenn die im Element SPECIFIC_HANDLE_ORIENTATION definierten Bedingungen erfüllt sind.
Sequence
FEATURE_REF
Dieses Element referenziert eine Variantenart, die im Element FEATURE_DEFINITION/FEATURES/FEATURE definiert sein muss.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
FROM_HANDLE
In diesem Element wird definiert von welchem Griff gewechselt wird.
Sequence
OPTION_REF
Dieses Element referenziert eine Griffvariante im Element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. Hierdurch wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Griffvarianten.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Varinatenart des Griffes angegeben von dem gewechselt wird. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Feld leer, so gilt die spezielle Grifflage für alle Griffvarianten. D string
P
M [1:5]
TO_HANDLE
In diesem Element wird definiert, auf welchen Griff gewechselt wird.
Sequence
OPTION_REF
Hier wird definiert, auf welche Griffvariante in einer beschriebenen Situation gewechselt wird.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Variantenarten der referenzierten Griffvariante angegeben. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird der Variantenschlüssel der Griffvariante angegeben, auf die gewechselt wird. D string
P
M [1:5)
HANDLE_ORIENTATION_EXCHANGE optional
In diesem Element wird ein Wechsel von Grifflagen definiert.
Sequence
FROM_HANDLE_ORIENTATION_REF
Hier wird definiert, bei welcher Basisgrifflage die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Basisgrifflagen.
Die Grifflage muss im Element BASIC_HANDLE_POSITIONS (Pfad1) definiert sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage referenziert. D positiveInteger
P
M [1:9999]
TO_HANDLE_ORIENTATION_REF
In diesem Element wird angegeben, auf welche Grifflage gewechselt wird.

HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage identifiziert D positiveInteger
P
M [1:9999]
PRIORITY Restriction of xs:nonNegativeInteger
In diesem Element wird die Priorität einer speziellen Grifflage definiert.
Bei der Anwendung der im Element SPECIFIC_HANDLE_ORIENTATION (Pfad 1) angelegten speziellen Grifflagen, ist es möglich, dass mehrere Grifflagen gültig angewendet werden können, was zu unerwünschten Ergebnissen führen kann.
Zur Vermeidung dieser Situation wird der speziellen Grifflage eine Priorität zugeordnet.
Die Priorität nimmt mit steigendem Zahlenwert zu. Unter einer Priorität können mehrere Grifflagen zusammengefasst werden. Bei Grifflagen einer Priorität müssen die gleichen Key-Elemente gefüllt sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
Bemerkung

Quelle
<xs:element name="SPECIFIC_HANDLE_POSITIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SPECIFIC_HANDLE_ORIENTATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="STYLE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="STYLE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="WIDTH_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--4--Breite_von</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="WIDTH_TO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--5--Breite_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEIGHT_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--6--Hoehe_von</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEIGHT_TO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--7--Hoehe_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="OPTION_REF">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="154" />
                      <xs:maxInclusive value="154" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="HANDLE_EXCHANGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_REF">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FROM_HANDLE">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF">
                          <xs:annotation>
                            <xs:documentation>232--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="300" />
                                  <xs:maxInclusive value="303" />
                                  <xs:pattern value="300|303" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>232--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TO_HANDLE">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF">
                          <xs:annotation>
                            <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="300" />
                                  <xs:maxInclusive value="303" />
                                  <xs:pattern value="300|303" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FROM_HANDLE_ORIENTATION_REF">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TO_HANDLE_ORIENTATION_REF">
                    <xs:annotation>
                      <xs:documentation>----</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>----</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRIORITY">
              <xs:annotation>
                <xs:documentation>232--14--Prioritaet</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SPECIFIC_HANDLE_ORIENTATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element : SPECIFIC_HANDLE_ORIENTATION Element
Beschreibung
In diesem Element wird eine spezifische Grifflage definiert.
Namensraum (none)
Diagramm
PRIORITY Element HANDLE_ORIENTATION_EXCHANGE Element HANDLE_EXCHANGE Element OPTION_REF Element HEIGHT_TO Element HEIGHT_FROM Element WIDTH_TO Element WIDTH_FROM Element FRONT_TYPE_GROUP_REF Element STYLE_REF Element Sequence SPECIFIC_HANDLE_ORIENTATION Element
Overview
SPECIFIC_HANDLE_ORIENTATION 1..∞
In diesem Element wird eine spezifische Grifflage definiert.
SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine spezielle Grifflage identifiziert. D nonNegativeInteger
P
M [0:99999]
Sequence
STYLE_REF optional
Über Referenzierung wird definiert, für welches Programm die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Programme gültig.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Elementpfade:
Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
FRONT_TYPE_GROUP_REF optional
Hier wird definiert, für welche Fronttypgruppe die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Fronttypgruppen gültig.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Fronttypgruppe referenziert. D nonNegativeInteger
P
M [1:99]
WIDTH_FROM optional Restriction of xs:positiveInteger
Hier wird definiert, ab welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Wenn dieses Element gefüllt ist, muss auch dass Element WIDTH_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
WIDTH_TO optional Restriction of xs:positiveInteger
Hier wird definiert, bis zu welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Dieses Element muss gefüllt werden, wenn das Element WIDTH_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft angegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
Hier wird definiert, ab welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Wenn dieses Element gefüllt ist, muss auch dass Element HEIGHT_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
HEIGHT_TO optional Restriction of xs:nonNegativeInteger
Hier wird definiert, bis zu welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Dieses Element muss gefüllt werden, wenn das Element HEIGHT_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
OPTION_REF
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Aufgrund der in der Praxis vorkommenden Situationen dürfen hier nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Element gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) enthält.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. Es kann nur die Variantenart 154 angegeben werden. D nonNegativeInteger
P
M [154:154]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Hier dürfen nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Feld gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Glastürrahmenausführung" (154) enthält. 		D string
P
M [1:5]
HANDLE_EXCHANGE optional
In diesem Element wird ein Griffwechsel definiert, der angewendet wird wenn die im Element SPECIFIC_HANDLE_ORIENTATION definierten Bedingungen erfüllt sind.
Sequence
FEATURE_REF
Dieses Element referenziert eine Variantenart, die im Element FEATURE_DEFINITION/FEATURES/FEATURE definiert sein muss.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
FROM_HANDLE
In diesem Element wird definiert von welchem Griff gewechselt wird.
Sequence
OPTION_REF
Dieses Element referenziert eine Griffvariante im Element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. Hierdurch wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Griffvarianten.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Varinatenart des Griffes angegeben von dem gewechselt wird. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Feld leer, so gilt die spezielle Grifflage für alle Griffvarianten. D string
P
M [1:5]
TO_HANDLE
In diesem Element wird definiert, auf welchen Griff gewechselt wird.
Sequence
OPTION_REF
Hier wird definiert, auf welche Griffvariante in einer beschriebenen Situation gewechselt wird.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Variantenarten der referenzierten Griffvariante angegeben. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird der Variantenschlüssel der Griffvariante angegeben, auf die gewechselt wird. D string
P
M [1:5)
HANDLE_ORIENTATION_EXCHANGE optional
In diesem Element wird ein Wechsel von Grifflagen definiert.
Sequence
FROM_HANDLE_ORIENTATION_REF
Hier wird definiert, bei welcher Basisgrifflage die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Basisgrifflagen.
Die Grifflage muss im Element BASIC_HANDLE_POSITIONS (Pfad1) definiert sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage referenziert. D positiveInteger
P
M [1:9999]
TO_HANDLE_ORIENTATION_REF
In diesem Element wird angegeben, auf welche Grifflage gewechselt wird.

HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage identifiziert D positiveInteger
P
M [1:9999]
PRIORITY Restriction of xs:nonNegativeInteger
In diesem Element wird die Priorität einer speziellen Grifflage definiert.
Bei der Anwendung der im Element SPECIFIC_HANDLE_ORIENTATION (Pfad 1) angelegten speziellen Grifflagen, ist es möglich, dass mehrere Grifflagen gültig angewendet werden können, was zu unerwünschten Ergebnissen führen kann.
Zur Vermeidung dieser Situation wird der speziellen Grifflage eine Priorität zugeordnet.
Die Priorität nimmt mit steigendem Zahlenwert zu. Unter einer Priorität können mehrere Grifflagen zusammengefasst werden. Bei Grifflagen einer Priorität müssen die gleichen Key-Elemente gefüllt sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SPECIFIC_HANDLE_ORIENTATION_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine spezielle Grifflage identifiziert. D nonNegativeInteger
P
M [0:99999]
Bemerkung

Quelle
<xs:element name="SPECIFIC_HANDLE_ORIENTATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="STYLE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="STYLE_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="WIDTH_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--4--Breite_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WIDTH_TO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--5--Breite_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--6--Hoehe_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_TO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--7--Hoehe_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="OPTION_REF">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="154" />
                <xs:maxInclusive value="154" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="HANDLE_EXCHANGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_REF">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FROM_HANDLE">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF">
                    <xs:annotation>
                      <xs:documentation>232--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="300" />
                            <xs:maxInclusive value="303" />
                            <xs:pattern value="300|303" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>232--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="TO_HANDLE">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF">
                    <xs:annotation>
                      <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="300" />
                            <xs:maxInclusive value="303" />
                            <xs:pattern value="300|303" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FROM_HANDLE_ORIENTATION_REF">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="TO_HANDLE_ORIENTATION_REF">
              <xs:annotation>
                <xs:documentation>----</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>----</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRIORITY">
        <xs:annotation>
          <xs:documentation>232--14--Prioritaet</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STYLE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : STYLE_REF Element
Beschreibung
Über Referenzierung wird definiert, für welches Programm die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Programme gültig.
Namensraum (none)
Diagramm
STYLE_REF Element
Overview
STYLE_REF optional
Über Referenzierung wird definiert, für welches Programm die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Programme gültig.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Elementpfade:
Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
STYLE_NO Restriction of xs:string required
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Elementpfade:
Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="STYLE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="STYLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : FRONT_TYPE_GROUP_REF Element
Beschreibung
Hier wird definiert, für welche Fronttypgruppe die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Fronttypgruppen gültig.
Namensraum (none)
Diagramm
FRONT_TYPE_GROUP_REF Element
Overview
FRONT_TYPE_GROUP_REF optional
Hier wird definiert, für welche Fronttypgruppe die spezielle Grifflage gültig ist. Ist dieses Element nicht vorhanden, so ist die Grifflage für alle Fronttypgruppen gültig.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Fronttypgruppe referenziert. D nonNegativeInteger
P
M [1:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FRONT_TYPE_GROUP_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Fronttypgruppe referenziert. D nonNegativeInteger
P
M [1:99]
Bemerkung

Quelle
<xs:element name="FRONT_TYPE_GROUP_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WIDTH_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : WIDTH_FROM Element
Beschreibung
Hier wird definiert, ab welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Wenn dieses Element gefüllt ist, muss auch dass Element WIDTH_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
WIDTH_FROM Element
Overview
WIDTH_FROM optional Restriction of xs:positiveInteger
Hier wird definiert, ab welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Wenn dieses Element gefüllt ist, muss auch dass Element WIDTH_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
Bemerkung

Quelle
<xs:element name="WIDTH_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--4--Breite_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WIDTH_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : WIDTH_TO Element
Beschreibung
Hier wird definiert, bis zu welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Dieses Element muss gefüllt werden, wenn das Element WIDTH_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft angegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
WIDTH_TO Element
Overview
WIDTH_TO optional Restriction of xs:positiveInteger
Hier wird definiert, bis zu welcher Breite (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Breiten gültig. Dieses Element muss gefüllt werden, wenn das Element WIDTH_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft angegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
Bemerkung

Quelle
<xs:element name="WIDTH_TO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--5--Breite_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : HEIGHT_FROM Element
Beschreibung
Hier wird definiert, ab welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Wenn dieses Element gefüllt ist, muss auch dass Element HEIGHT_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
HEIGHT_FROM Element
Overview
HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
Hier wird definiert, ab welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Wenn dieses Element gefüllt ist, muss auch dass Element HEIGHT_TO gefüllt sein. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
Bemerkung

Quelle
<xs:element name="HEIGHT_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--6--Hoehe_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : HEIGHT_TO Element
Beschreibung
Hier wird definiert, bis zu welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Dieses Element muss gefüllt werden, wenn das Element HEIGHT_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
HEIGHT_TO Element
Overview
HEIGHT_TO optional Restriction of xs:nonNegativeInteger
Hier wird definiert, bis zu welcher Höhe (Nennmaß des Frontelementes) die spezielle Grifflage gültig ist. Ist dieses Element leer, so ist die Grifflage für alle Höhen gültig. Dieses Element muss gefüllt werden, wenn das Element HEIGHT_FROM gefüllt ist. Die Maße werden von Mitte Luft zu Mitte Luft abgegeben, am Rand bis zur Außenseite des Artikels. D nonNegativeInteger
P
M [1:9999]
Bemerkung

Quelle
<xs:element name="HEIGHT_TO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--7--Hoehe_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : OPTION_REF Element
Beschreibung
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Aufgrund der in der Praxis vorkommenden Situationen dürfen hier nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Element gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) enthält.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Aufgrund der in der Praxis vorkommenden Situationen dürfen hier nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Element gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) enthält.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. Es kann nur die Variantenart 154 angegeben werden. D nonNegativeInteger
P
M [154:154]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Hier dürfen nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Feld gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Glastürrahmenausführung" (154) enthält. 		D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird eine Variantenart angegeben. Es kann nur die Variantenart 154 angegeben werden. D nonNegativeInteger
P
M [154:154]
OPTION_KEY Restriction of xs:string required
Hier wird definiert, bei welcher Glastürrahmenausführung die spezielle Grifflage gültig ist. Hier dürfen nur Varianten der Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) verwendet werden.

Ein Datensatz, in dem dieses Feld gefüllt ist, wird auf einen Artikel nur angewendet, wenn die Variantenfamilie des Artikel die Variantenart "Glastürrahmenausführung" (154) enthält. 		D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="154" />
          <xs:maxInclusive value="154" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_EXCHANGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : HANDLE_EXCHANGE Element
Beschreibung
In diesem Element wird ein Griffwechsel definiert, der angewendet wird wenn die im Element SPECIFIC_HANDLE_ORIENTATION definierten Bedingungen erfüllt sind.
Namensraum (none)
Diagramm
TO_HANDLE Element FROM_HANDLE Element FEATURE_REF Element Sequence HANDLE_EXCHANGE Element
Overview
HANDLE_EXCHANGE optional
In diesem Element wird ein Griffwechsel definiert, der angewendet wird wenn die im Element SPECIFIC_HANDLE_ORIENTATION definierten Bedingungen erfüllt sind.
Sequence
FEATURE_REF
Dieses Element referenziert eine Variantenart, die im Element FEATURE_DEFINITION/FEATURES/FEATURE definiert sein muss.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
FROM_HANDLE
In diesem Element wird definiert von welchem Griff gewechselt wird.
Sequence
OPTION_REF
Dieses Element referenziert eine Griffvariante im Element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. Hierdurch wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Griffvarianten.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Varinatenart des Griffes angegeben von dem gewechselt wird. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Feld leer, so gilt die spezielle Grifflage für alle Griffvarianten. D string
P
M [1:5]
TO_HANDLE
In diesem Element wird definiert, auf welchen Griff gewechselt wird.
Sequence
OPTION_REF
Hier wird definiert, auf welche Griffvariante in einer beschriebenen Situation gewechselt wird.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Variantenarten der referenzierten Griffvariante angegeben. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird der Variantenschlüssel der Griffvariante angegeben, auf die gewechselt wird. D string
P
M [1:5)
Bemerkung

Quelle
<xs:element name="HANDLE_EXCHANGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_REF">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FROM_HANDLE">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF">
              <xs:annotation>
                <xs:documentation>232--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="300" />
                      <xs:maxInclusive value="303" />
                      <xs:pattern value="300|303" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>232--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="TO_HANDLE">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF">
              <xs:annotation>
                <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="300" />
                      <xs:maxInclusive value="303" />
                      <xs:pattern value="300|303" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_EXCHANGE Element : FEATURE_REF Element
Beschreibung
Dieses Element referenziert eine Variantenart, die im Element FEATURE_DEFINITION/FEATURES/FEATURE definiert sein muss.
Namensraum (none)
Diagramm
FEATURE_REF Element
Overview
FEATURE_REF
Dieses Element referenziert eine Variantenart, die im Element FEATURE_DEFINITION/FEATURES/FEATURE definiert sein muss.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
Bemerkung

Quelle
<xs:element name="FEATURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
HANDLE_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FROM_HANDLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_EXCHANGE Element : FROM_HANDLE Element
Beschreibung
In diesem Element wird definiert von welchem Griff gewechselt wird.
Namensraum (none)
Diagramm
OPTION_REF Element Sequence FROM_HANDLE Element
Overview
FROM_HANDLE
In diesem Element wird definiert von welchem Griff gewechselt wird.
Sequence
OPTION_REF
Dieses Element referenziert eine Griffvariante im Element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. Hierdurch wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Griffvarianten.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Varinatenart des Griffes angegeben von dem gewechselt wird. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Feld leer, so gilt die spezielle Grifflage für alle Griffvarianten. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="FROM_HANDLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="300" />
                <xs:maxInclusive value="303" />
                <xs:pattern value="300|303" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
HANDLE_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_EXCHANGE Element > FROM_HANDLE Element : OPTION_REF Element
Beschreibung
Dieses Element referenziert eine Griffvariante im Element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. Hierdurch wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Griffvarianten.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Dieses Element referenziert eine Griffvariante im Element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. Hierdurch wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Griffvarianten.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Varinatenart des Griffes angegeben von dem gewechselt wird. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Feld leer, so gilt die spezielle Grifflage für alle Griffvarianten. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Varinatenart des Griffes angegeben von dem gewechselt wird. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY Restriction of xs:string required
Hier wird definiert, bei welcher Griffvariante die spezielle Grifflage gültig ist. Ist dieses Feld leer, so gilt die spezielle Grifflage für alle Griffvarianten. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="300" />
          <xs:maxInclusive value="303" />
          <xs:pattern value="300|303" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FROM_HANDLE Element | HANDLE_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TO_HANDLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_EXCHANGE Element : TO_HANDLE Element
Beschreibung
In diesem Element wird definiert, auf welchen Griff gewechselt wird.
Namensraum (none)
Diagramm
OPTION_REF Element Sequence TO_HANDLE Element
Overview
TO_HANDLE
In diesem Element wird definiert, auf welchen Griff gewechselt wird.
Sequence
OPTION_REF
Hier wird definiert, auf welche Griffvariante in einer beschriebenen Situation gewechselt wird.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Variantenarten der referenzierten Griffvariante angegeben. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird der Variantenschlüssel der Griffvariante angegeben, auf die gewechselt wird. D string
P
M [1:5)
Bemerkung

Quelle
<xs:element name="TO_HANDLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF">
        <xs:annotation>
          <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="300" />
                <xs:maxInclusive value="303" />
                <xs:pattern value="300|303" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
HANDLE_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_EXCHANGE Element > TO_HANDLE Element : OPTION_REF Element
Beschreibung
Hier wird definiert, auf welche Griffvariante in einer beschriebenen Situation gewechselt wird.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Hier wird definiert, auf welche Griffvariante in einer beschriebenen Situation gewechselt wird.
FEATURE_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Variantenarten der referenzierten Griffvariante angegeben. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY required Restriction of xs:string
Hier wird der Variantenschlüssel der Griffvariante angegeben, auf die gewechselt wird. D string
P
M [1:5)
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Variantenarten der referenzierten Griffvariante angegeben. Es können die Variantenarten 300 und 303 verwendet werden. D positiveInteger
P 300|303
M [300:303]
OPTION_KEY Restriction of xs:string required
Hier wird der Variantenschlüssel der Griffvariante angegeben, auf die gewechselt wird. D string
P
M [1:5)
Bemerkung

Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="300" />
          <xs:maxInclusive value="303" />
          <xs:pattern value="300|303" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>232--12--Nach_Var_Schluessel_Griff</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
TO_HANDLE Element | HANDLE_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION_EXCHANGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : HANDLE_ORIENTATION_EXCHANGE Element
Beschreibung
In diesem Element wird ein Wechsel von Grifflagen definiert.
Namensraum (none)
Diagramm
TO_HANDLE_ORIENTATION_REF Element FROM_HANDLE_ORIENTATION_REF Element Sequence HANDLE_ORIENTATION_EXCHANGE Element
Overview
HANDLE_ORIENTATION_EXCHANGE optional
In diesem Element wird ein Wechsel von Grifflagen definiert.
Sequence
FROM_HANDLE_ORIENTATION_REF
Hier wird definiert, bei welcher Basisgrifflage die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Basisgrifflagen.
Die Grifflage muss im Element BASIC_HANDLE_POSITIONS (Pfad1) definiert sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage referenziert. D positiveInteger
P
M [1:9999]
TO_HANDLE_ORIENTATION_REF
In diesem Element wird angegeben, auf welche Grifflage gewechselt wird.

HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage identifiziert D positiveInteger
P
M [1:9999]
Bemerkung

Quelle
<xs:element name="HANDLE_ORIENTATION_EXCHANGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FROM_HANDLE_ORIENTATION_REF">
        <xs:annotation>
          <xs:documentation>232--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>232--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="TO_HANDLE_ORIENTATION_REF">
        <xs:annotation>
          <xs:documentation>----</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>----</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FROM_HANDLE_ORIENTATION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_ORIENTATION_EXCHANGE Element : FROM_HANDLE_ORIENTATION_REF Element
Beschreibung
Hier wird definiert, bei welcher Basisgrifflage die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Basisgrifflagen.
Die Grifflage muss im Element BASIC_HANDLE_POSITIONS (Pfad1) definiert sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/
Namensraum (none)
Diagramm
FROM_HANDLE_ORIENTATION_REF Element
Overview
FROM_HANDLE_ORIENTATION_REF
Hier wird definiert, bei welcher Basisgrifflage die spezielle Grifflage gültig ist. Ist dieses Element leer, so gilt die spezielle Grifflage für alle Basisgrifflagen.
Die Grifflage muss im Element BASIC_HANDLE_POSITIONS (Pfad1) definiert sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage referenziert. D positiveInteger
P
M [1:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
HANDLE_ORIENTATION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine spezielle Grifflage referenziert. D positiveInteger
P
M [1:9999]
Bemerkung

Quelle
<xs:element name="FROM_HANDLE_ORIENTATION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>232--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0,K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
HANDLE_ORIENTATION_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TO_HANDLE_ORIENTATION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element > HANDLE_ORIENTATION_EXCHANGE Element : TO_HANDLE_ORIENTATION_REF Element
Beschreibung
In diesem Element wird angegeben, auf welche Grifflage gewechselt wird.

Namensraum (none)
Diagramm
TO_HANDLE_ORIENTATION_REF Element
Overview
TO_HANDLE_ORIENTATION_REF
In diesem Element wird angegeben, auf welche Grifflage gewechselt wird.

HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine spezielle Grifflage identifiziert D positiveInteger
P
M [1:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
HANDLE_ORIENTATION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine spezielle Grifflage identifiziert D positiveInteger
P
M [1:9999]
Bemerkung

Quelle
<xs:element name="TO_HANDLE_ORIENTATION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>----</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>----</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
HANDLE_ORIENTATION_EXCHANGE Element | SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRIORITY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_POSITIONS Element > SPECIFIC_HANDLE_ORIENTATION Element : PRIORITY Element
Beschreibung
In diesem Element wird die Priorität einer speziellen Grifflage definiert.
Bei der Anwendung der im Element SPECIFIC_HANDLE_ORIENTATION (Pfad 1) angelegten speziellen Grifflagen, ist es möglich, dass mehrere Grifflagen gültig angewendet werden können, was zu unerwünschten Ergebnissen führen kann.
Zur Vermeidung dieser Situation wird der speziellen Grifflage eine Priorität zugeordnet.
Die Priorität nimmt mit steigendem Zahlenwert zu. Unter einer Priorität können mehrere Grifflagen zusammengefasst werden. Bei Grifflagen einer Priorität müssen die gleichen Key-Elemente gefüllt sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
PRIORITY Element
Overview
PRIORITY Restriction of xs:nonNegativeInteger
In diesem Element wird die Priorität einer speziellen Grifflage definiert.
Bei der Anwendung der im Element SPECIFIC_HANDLE_ORIENTATION (Pfad 1) angelegten speziellen Grifflagen, ist es möglich, dass mehrere Grifflagen gültig angewendet werden können, was zu unerwünschten Ergebnissen führen kann.
Zur Vermeidung dieser Situation wird der speziellen Grifflage eine Priorität zugeordnet.
Die Priorität nimmt mit steigendem Zahlenwert zu. Unter einer Priorität können mehrere Grifflagen zusammengefasst werden. Bei Grifflagen einer Priorität müssen die gleichen Key-Elemente gefüllt sein.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS 		D nonNegativeInteger
P
M [1:999]
Bemerkung

Quelle
<xs:element name="PRIORITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>232--14--Prioritaet</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SPECIFIC_HANDLE_ORIENTATION Element | SPECIFIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_HANDLE_POSITIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element : BASIC_HANDLE_POSITIONS Element
Beschreibung

In diesem Element wird beschrieben, welche Lage und Position Griffe auf bestimmten Fronttypen aufweisen. Die in diesem Element definierten Basisgrifflagen sind global gültig.

Die Basisgrifflagen sollten sich an den vordefierten Standardgrifflagen des Abschnittes Standardgrifflagen orientieren. Allerdings ist hier zu beachten, dass für die Basisgrifflagen der Wert 0 nicht benutzt werden kann.

Namensraum (none)
Diagramm
HANDLE_ORIENTATION Element Sequence BASIC_HANDLE_POSITIONS Element
Overview
BASIC_HANDLE_POSITIONS

In diesem Element wird beschrieben, welche Lage und Position Griffe auf bestimmten Fronttypen aufweisen. Die in diesem Element definierten Basisgrifflagen sind global gültig.

Die Basisgrifflagen sollten sich an den vordefierten Standardgrifflagen des Abschnittes Standardgrifflagen orientieren. Allerdings ist hier zu beachten, dass für die Basisgrifflagen der Wert 0 nicht benutzt werden kann.

Sequence
HANDLE_ORIENTATION 1..∞
Dieses Element ist ein Container-Element, in dem die unterschiedlichen Basisgrifflagen definiert werden.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Basisgrifflage identifiziert. D positiveInteger
P
M [1:9999]
Sequence
FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird in dem Attribut FRONT_TYPE_CODE angegeben.
FRONT_TYPE_CODE required Restriction of xs:string
Hier wird definiert, für welchen Fronttyp eine Grifflage beschrieben wird. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung 		D string
P [SAKJTR]|GT
M [1:2]
Sequence
ORIENTATION Restriction of xs:string
Hier wird definiert, welche Lage die Griffe bei dem Fronttyp haben.
H = horizontal
V = vertikal 		D string
P [HV]
M [1:1]
POSITION Restriction of xs:string
Hier wird definiert, welche Position die Griffe bei dem Fronttyp haben.

M = mittig (z. B. auch für durchgehende Griffleiste, anschlagsneutral)
A = außen (auch für Griffleiste abhängig vom Anschlag)
D = doppelt (zwei Griffe außen)
G = ohne Bohrung mit Griff (Griff wird geliefert, Bohrung bauseits)
0 (Null) = ohne Bohrung ohne Griff (Griff wird nicht geliefert, auch Grifflose Küche)

Bei der Position A = außen wird die konkrete Position rechts/links über den Anschlag des Artikel bestimmt. 		D string
P [MADG0]
M [1:1]
Bemerkung

Quelle
<xs:element name="BASIC_HANDLE_POSITIONS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>230--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="HANDLE_ORIENTATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>230--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_TYPE" maxOccurs="7">
              <xs:annotation>
                <xs:documentation>230--3--Fronttyp</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ORIENTATION">
                    <xs:annotation>
                      <xs:documentation>230--4--Lage</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[HV]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="POSITION">
                    <xs:annotation>
                      <xs:documentation>230--5--Position</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[MADG0]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FRONT_TYPE_CODE" use="required">
                  <xs:annotation>
                    <xs:documentation>230--3--Fronttyp</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[SAKJTR]|GT" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>230--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > BASIC_HANDLE_POSITIONS Element : HANDLE_ORIENTATION Element
Beschreibung
Dieses Element ist ein Container-Element, in dem die unterschiedlichen Basisgrifflagen definiert werden.
Namensraum (none)
Diagramm
FRONT_TYPE Element Sequence HANDLE_ORIENTATION Element
Overview
HANDLE_ORIENTATION 1..∞
Dieses Element ist ein Container-Element, in dem die unterschiedlichen Basisgrifflagen definiert werden.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Basisgrifflage identifiziert. D positiveInteger
P
M [1:9999]
Sequence
FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird in dem Attribut FRONT_TYPE_CODE angegeben.
FRONT_TYPE_CODE required Restriction of xs:string
Hier wird definiert, für welchen Fronttyp eine Grifflage beschrieben wird. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung 		D string
P [SAKJTR]|GT
M [1:2]
Sequence
ORIENTATION Restriction of xs:string
Hier wird definiert, welche Lage die Griffe bei dem Fronttyp haben.
H = horizontal
V = vertikal 		D string
P [HV]
M [1:1]
POSITION Restriction of xs:string
Hier wird definiert, welche Position die Griffe bei dem Fronttyp haben.

M = mittig (z. B. auch für durchgehende Griffleiste, anschlagsneutral)
A = außen (auch für Griffleiste abhängig vom Anschlag)
D = doppelt (zwei Griffe außen)
G = ohne Bohrung mit Griff (Griff wird geliefert, Bohrung bauseits)
0 (Null) = ohne Bohrung ohne Griff (Griff wird nicht geliefert, auch Grifflose Küche)

Bei der Position A = außen wird die konkrete Position rechts/links über den Anschlag des Artikel bestimmt. 		D string
P [MADG0]
M [1:1]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
HANDLE_ORIENTATION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Basisgrifflage identifiziert. D positiveInteger
P
M [1:9999]
Bemerkung

Quelle
<xs:element name="HANDLE_ORIENTATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>230--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_TYPE" maxOccurs="7">
        <xs:annotation>
          <xs:documentation>230--3--Fronttyp</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ORIENTATION">
              <xs:annotation>
                <xs:documentation>230--4--Lage</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[HV]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="POSITION">
              <xs:annotation>
                <xs:documentation>230--5--Position</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[MADG0]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FRONT_TYPE_CODE" use="required">
            <xs:annotation>
              <xs:documentation>230--3--Fronttyp</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[SAKJTR]|GT" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>230--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BASIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > BASIC_HANDLE_POSITIONS Element > HANDLE_ORIENTATION Element : FRONT_TYPE Element
Beschreibung
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird in dem Attribut FRONT_TYPE_CODE angegeben.
Namensraum (none)
Diagramm
POSITION Element ORIENTATION Element Sequence FRONT_TYPE Element
Overview
FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird in dem Attribut FRONT_TYPE_CODE angegeben.
FRONT_TYPE_CODE required Restriction of xs:string
Hier wird definiert, für welchen Fronttyp eine Grifflage beschrieben wird. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung 		D string
P [SAKJTR]|GT
M [1:2]
Sequence
ORIENTATION Restriction of xs:string
Hier wird definiert, welche Lage die Griffe bei dem Fronttyp haben.
H = horizontal
V = vertikal 		D string
P [HV]
M [1:1]
POSITION Restriction of xs:string
Hier wird definiert, welche Position die Griffe bei dem Fronttyp haben.

M = mittig (z. B. auch für durchgehende Griffleiste, anschlagsneutral)
A = außen (auch für Griffleiste abhängig vom Anschlag)
D = doppelt (zwei Griffe außen)
G = ohne Bohrung mit Griff (Griff wird geliefert, Bohrung bauseits)
0 (Null) = ohne Bohrung ohne Griff (Griff wird nicht geliefert, auch Grifflose Küche)

Bei der Position A = außen wird die konkrete Position rechts/links über den Anschlag des Artikel bestimmt. 		D string
P [MADG0]
M [1:1]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FRONT_TYPE_CODE Restriction of xs:string required
Hier wird definiert, für welchen Fronttyp eine Grifflage beschrieben wird. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung 		D string
P [SAKJTR]|GT
M [1:2]
Bemerkung

Quelle
<xs:element name="FRONT_TYPE" maxOccurs="7" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>230--3--Fronttyp</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ORIENTATION">
        <xs:annotation>
          <xs:documentation>230--4--Lage</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[HV]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="POSITION">
        <xs:annotation>
          <xs:documentation>230--5--Position</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[MADG0]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FRONT_TYPE_CODE" use="required">
      <xs:annotation>
        <xs:documentation>230--3--Fronttyp</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[SAKJTR]|GT" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
HANDLE_ORIENTATION Element | BASIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ORIENTATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > BASIC_HANDLE_POSITIONS Element > HANDLE_ORIENTATION Element > FRONT_TYPE Element : ORIENTATION Element
Beschreibung
Hier wird definiert, welche Lage die Griffe bei dem Fronttyp haben.
H = horizontal
V = vertikal 		D string
P [HV]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ORIENTATION Element
Overview
ORIENTATION Restriction of xs:string
Hier wird definiert, welche Lage die Griffe bei dem Fronttyp haben.
H = horizontal
V = vertikal 		D string
P [HV]
M [1:1]
Bemerkung

Quelle
<xs:element name="ORIENTATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>230--4--Lage</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[HV]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_TYPE Element | HANDLE_ORIENTATION Element | BASIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

POSITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > BASIC_HANDLE_POSITIONS Element > HANDLE_ORIENTATION Element > FRONT_TYPE Element : POSITION Element
Beschreibung
Hier wird definiert, welche Position die Griffe bei dem Fronttyp haben.

M = mittig (z. B. auch für durchgehende Griffleiste, anschlagsneutral)
A = außen (auch für Griffleiste abhängig vom Anschlag)
D = doppelt (zwei Griffe außen)
G = ohne Bohrung mit Griff (Griff wird geliefert, Bohrung bauseits)
0 (Null) = ohne Bohrung ohne Griff (Griff wird nicht geliefert, auch Grifflose Küche)

Bei der Position A = außen wird die konkrete Position rechts/links über den Anschlag des Artikel bestimmt. 		D string
P [MADG0]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
POSITION Element
Overview
POSITION Restriction of xs:string
Hier wird definiert, welche Position die Griffe bei dem Fronttyp haben.

M = mittig (z. B. auch für durchgehende Griffleiste, anschlagsneutral)
A = außen (auch für Griffleiste abhängig vom Anschlag)
D = doppelt (zwei Griffe außen)
G = ohne Bohrung mit Griff (Griff wird geliefert, Bohrung bauseits)
0 (Null) = ohne Bohrung ohne Griff (Griff wird nicht geliefert, auch Grifflose Küche)

Bei der Position A = außen wird die konkrete Position rechts/links über den Anschlag des Artikel bestimmt. 		D string
P [MADG0]
M [1:1]
Bemerkung

Quelle
<xs:element name="POSITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>230--5--Position</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[MADG0]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_TYPE Element | HANDLE_ORIENTATION Element | BASIC_HANDLE_POSITIONS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPES_GROUPS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element : FRONT_TYPES_GROUPS Element
Beschreibung
Für die effiziente Verwendung von Fronttypen bei der Definition von spezifischen Grifflagen im Element SPECIFIC_HANDLE_ORIENTATION (Pfad1) können Fronttypen zu Fronttyp-Gruppen zusammengefasst werden.

Elementpfade
Pfad1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/
Namensraum (none)
Diagramm
FRONT_TYPES_GROUP Element Sequence FRONT_TYPES_GROUPS Element
Overview
FRONT_TYPES_GROUPS optional
Für die effiziente Verwendung von Fronttypen bei der Definition von spezifischen Grifflagen im Element SPECIFIC_HANDLE_ORIENTATION (Pfad1) können Fronttypen zu Fronttyp-Gruppen zusammengefasst werden.

Elementpfade
Pfad1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/
Sequence
FRONT_TYPES_GROUP 1..99
In diesem Element wird eine Gruppe von Fronttypen definiert.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Fronttypgruppe identifiziert. D nonNegativeInteger
P
M [1:99]
Sequence
FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird über das Attribut FRONT_TYPE_CODE angegeben.
FRONT_TYPE_CODE required Restriction of xs:string
Hier werden die Fronttypen angegeben, die zu einer Fronttypgruppe zusammengefasst werden sollen. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung)
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung) 		D string
P [SAKJTR]|GT
M [1:2]

Bemerkung

Quelle
<xs:element name="FRONT_TYPES_GROUPS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>231--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_TYPES_GROUP" maxOccurs="99">
        <xs:annotation>
          <xs:documentation>231--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_TYPE" maxOccurs="7">
              <xs:annotation>
                <xs:documentation>231--3--Fronttyp</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_TYPE_CODE" use="required">
                  <xs:annotation>
                    <xs:documentation>231--3--Fronttyp</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[SAKJTR]|GT" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>231--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPES_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > FRONT_TYPES_GROUPS Element : FRONT_TYPES_GROUP Element
Beschreibung
In diesem Element wird eine Gruppe von Fronttypen definiert.
Namensraum (none)
Diagramm
FRONT_TYPE Element Sequence FRONT_TYPES_GROUP Element
Overview
FRONT_TYPES_GROUP 1..99
In diesem Element wird eine Gruppe von Fronttypen definiert.
FRONT_TYPE_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Fronttypgruppe identifiziert. D nonNegativeInteger
P
M [1:99]
Sequence
FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird über das Attribut FRONT_TYPE_CODE angegeben.
FRONT_TYPE_CODE required Restriction of xs:string
Hier werden die Fronttypen angegeben, die zu einer Fronttypgruppe zusammengefasst werden sollen. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung)
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung) 		D string
P [SAKJTR]|GT
M [1:2]

Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FRONT_TYPE_GROUP_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Fronttypgruppe identifiziert. D nonNegativeInteger
P
M [1:99]
Bemerkung

Quelle
<xs:element name="FRONT_TYPES_GROUP" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>231--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_TYPE" maxOccurs="7">
        <xs:annotation>
          <xs:documentation>231--3--Fronttyp</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_TYPE_CODE" use="required">
            <xs:annotation>
              <xs:documentation>231--3--Fronttyp</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[SAKJTR]|GT" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FRONT_TYPE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>231--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FRONT_TYPES_GROUPS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONTS_HANDLE_POSITIONS Element > FRONT_TYPES_GROUPS Element > FRONT_TYPES_GROUP Element : FRONT_TYPE Element
Beschreibung
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird über das Attribut FRONT_TYPE_CODE angegeben.
Namensraum (none)
Diagramm
FRONT_TYPE Element
Overview
FRONT_TYPE 1..7
In diesem Element werden die Grifflagen und Griffpositionen für die Fronttypen angelegt. Der Fronttyp selbst wird über das Attribut FRONT_TYPE_CODE angegeben.
FRONT_TYPE_CODE required Restriction of xs:string
Hier werden die Fronttypen angegeben, die zu einer Fronttypgruppe zusammengefasst werden sollen. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung)
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung) 		D string
P [SAKJTR]|GT
M [1:2]

Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FRONT_TYPE_CODE Restriction of xs:string required
Hier werden die Fronttypen angegeben, die zu einer Fronttypgruppe zusammengefasst werden sollen. Folgende Fronttypen stehen zur Verfügung:
S = Schubkasten
A = Auszug
K = Klappe
J = Jalousie (vertikale Bedienung)
T = Tür
GT = Glastür
R = Rollage (horizontale Bedienung) 		D string
P [SAKJTR]|GT
M [1:2]

Bemerkung

Quelle
<xs:element name="FRONT_TYPE" maxOccurs="7" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>231--3--Fronttyp</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_TYPE_CODE" use="required">
      <xs:annotation>
        <xs:documentation>231--3--Fronttyp</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[SAKJTR]|GT" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FRONT_TYPES_GROUP Element | FRONT_TYPES_GROUPS Element | FRONTS_HANDLE_POSITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_APPEARANCES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : FRONT_APPEARANCES Element
Beschreibung
In diesem Element werden die Frontausprägungen eines Programms, einer Ausführung oder eines Artikels definiert. Hier definierte Frontausprägungen werden von Programmen (FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF), Ausführungen (FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF) oder von Artikeln (SERIES/.../ITEM/FRONT_APPEARANCE_REF) referenziert.
Ein Frontausprägung wird grundlegend definiert, in dem eine Grundformnummer für ein Frontelement zugeordnet und die Geometrie über Angabe der Maße bestimmt wird.
Namensraum (none)
Diagramm
FRONT_APPEARANCE Element Sequence FRONT_APPEARANCES Element
Overview
FRONT_APPEARANCES optional
In diesem Element werden die Frontausprägungen eines Programms, einer Ausführung oder eines Artikels definiert. Hier definierte Frontausprägungen werden von Programmen (FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF), Ausführungen (FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF) oder von Artikeln (SERIES/.../ITEM/FRONT_APPEARANCE_REF) referenziert.
Ein Frontausprägung wird grundlegend definiert, in dem eine Grundformnummer für ein Frontelement zugeordnet und die Geometrie über Angabe der Maße bestimmt wird.
Sequence
FRONT_APPEARANCE 1..999
In diesem Element wird eine Frontausprägung definiert.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird. D positiveInteger
P
M [1:999]
Sequence
FRONT_TYPE 1..900
Wenn alle Frontelemente unabhängig vom Fronttyp gleiches Aussehen haben, wird eine Definition mit dem Fronttyp 0 angelegt. Dann dürfen keine weiteren mit abweichenden Fronttypen angelegt werden. Wenn für eine Frontausprägungs-ID ein Datensatz mit einem Fronttyp angelegt wurde, so müssen für alle verwendeten Fronttypen ebenfalls Datensätze angelegt werden.
Sequence
FRONT_TYPE_NO Restriction of xs:positiveInteger
In diesem Attribut wird der Schlüsselwert des Fronttyps angegeben. D positiveInteger
P
M [0:1000]
Sequence 1..∞
FRONT_CONSTRAINTS optional
Für die Elemente WIDTH_FROM/TO und HEIGTH_FROM/TO gelten folgende Regeln:

- Wenn die Elemente WIDTH_TO oder HEIGHT_TO nicht angelegt sind, so entspricht dies dem Wert „unendlich“.
- Wenn die Elemente WIDTH_FROM oder HEIGHT_FROM nicht angelegt sind, so entspricht dies dem Wert 0.
- Der Wert 0 ist in den Elementen WIDTH_FROM/TO oder HEIGTH_FROM/TO nicht zulässig.
- Die angegebenen Intervalle dürfen sich nicht überlappen und müssen immer den gesamten Bereich
von 0 bis unendlich abdecken. Es dürfen keine Lücken entstehen.
Sequence
WIDTH_FROM optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird (Maße in mm). D positiveInteger
P
M [1:999999]
WIDTH_TO optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
HEIGHT_FROM optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
HEIGHT_TO optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
FRONT_SHAPE
In diesem Element sind die Elemente zur geometrischen Beschreibung eines Frontelementes zusammengefasst.
Sequence
GLASS Restriction of xs:boolean
Durch dieses Element kann festgelegt werden, ob es sich bei dem angegebenen Fronttyp um eine Glasversion (Wert 1/true) oder um eine normale Version (Wert 0/false) handelt. Die Werte in diesem Element dürfen für einen Fronttyp nicht wechseln. Durch diese Regel wird verhindert, dass beispielsweise aus einer Glastür durch Auswahl eines anderen Programms eine Massivtür wird. D boolean
P
M
Choice
MODELING_GRAPHIC_ID optional Restriction of xs:string
Hier kann eine Echtgrafik angegeben werden.

Das Format muss dahingehend noch ausformuliert werden. 		D string
P
M [1:15]
BASIC_FRONT_SHAPE optional
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.

Der Wert 999 darf nicht mehr verwendet werden. 		D string
P
M [1:3]
PARAMETERS 1..∞
In diesem Element werden den Frontparametern die Werte zugeordnet.
VALUE optional Restriction of xs:string
In diesem Attribut wird dem Parameter der Frontgrundform ein Masswert zugeordnet. D decimal
P
M
PARAMETER optional Restriction of xs:string
In diesem Attribut wird derParameter der Frontgrundform angegeben. Im Element VALUE wird diesem Parameter ein Masswert zugeordnet. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="FRONT_APPEARANCES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_APPEARANCE" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>520--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_TYPE" maxOccurs="900">
              <xs:annotation>
                <xs:documentation>520--3--Fronttyp</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_TYPE_NO">
                    <xs:annotation>
                      <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="900" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:sequence maxOccurs="unbounded">
                    <xs:element name="FRONT_CONSTRAINTS" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="WIDTH_FROM" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>520/570--6--Breite_von</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="WIDTH_TO" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>520/570--7--Breite_von</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="HEIGHT_FROM" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="HEIGHT_TO" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="FRONT_SHAPE">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="GLASS">
                            <xs:annotation>
                              <xs:documentation>520--10--Glas</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:boolean" />
                            </xs:simpleType>
                          </xs:element>
                          <xs:choice>
                            <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="BASIC_FRONT_SHAPE_ID">
                                    <xs:annotation>
                                      <xs:documentation>520--4--Front_Grundform</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="3" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PARAMETERS" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="VALUE">
                                        <xs:annotation>
                                          <xs:documentation>520--5--Wert</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:maxLength value="12" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="PARAMETER">
                                        <xs:annotation>
                                          <xs:documentation>570--4--Parameter</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:minLength value="1" />
                                            <xs:maxLength value="5" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:choice>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>520--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_APPEARANCE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element : FRONT_APPEARANCE Element
Beschreibung
In diesem Element wird eine Frontausprägung definiert.
Namensraum (none)
Diagramm
FRONT_TYPE Element Sequence FRONT_APPEARANCE Element
Overview
FRONT_APPEARANCE 1..999
In diesem Element wird eine Frontausprägung definiert.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird. D positiveInteger
P
M [1:999]
Sequence
FRONT_TYPE 1..900
Wenn alle Frontelemente unabhängig vom Fronttyp gleiches Aussehen haben, wird eine Definition mit dem Fronttyp 0 angelegt. Dann dürfen keine weiteren mit abweichenden Fronttypen angelegt werden. Wenn für eine Frontausprägungs-ID ein Datensatz mit einem Fronttyp angelegt wurde, so müssen für alle verwendeten Fronttypen ebenfalls Datensätze angelegt werden.
Sequence
FRONT_TYPE_NO Restriction of xs:positiveInteger
In diesem Attribut wird der Schlüsselwert des Fronttyps angegeben. D positiveInteger
P
M [0:1000]
Sequence 1..∞
FRONT_CONSTRAINTS optional
Für die Elemente WIDTH_FROM/TO und HEIGTH_FROM/TO gelten folgende Regeln:

- Wenn die Elemente WIDTH_TO oder HEIGHT_TO nicht angelegt sind, so entspricht dies dem Wert „unendlich“.
- Wenn die Elemente WIDTH_FROM oder HEIGHT_FROM nicht angelegt sind, so entspricht dies dem Wert 0.
- Der Wert 0 ist in den Elementen WIDTH_FROM/TO oder HEIGTH_FROM/TO nicht zulässig.
- Die angegebenen Intervalle dürfen sich nicht überlappen und müssen immer den gesamten Bereich
von 0 bis unendlich abdecken. Es dürfen keine Lücken entstehen.
Sequence
WIDTH_FROM optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird (Maße in mm). D positiveInteger
P
M [1:999999]
WIDTH_TO optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
HEIGHT_FROM optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
HEIGHT_TO optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
FRONT_SHAPE
In diesem Element sind die Elemente zur geometrischen Beschreibung eines Frontelementes zusammengefasst.
Sequence
GLASS Restriction of xs:boolean
Durch dieses Element kann festgelegt werden, ob es sich bei dem angegebenen Fronttyp um eine Glasversion (Wert 1/true) oder um eine normale Version (Wert 0/false) handelt. Die Werte in diesem Element dürfen für einen Fronttyp nicht wechseln. Durch diese Regel wird verhindert, dass beispielsweise aus einer Glastür durch Auswahl eines anderen Programms eine Massivtür wird. D boolean
P
M
Choice
MODELING_GRAPHIC_ID optional Restriction of xs:string
Hier kann eine Echtgrafik angegeben werden.

Das Format muss dahingehend noch ausformuliert werden. 		D string
P
M [1:15]
BASIC_FRONT_SHAPE optional
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.

Der Wert 999 darf nicht mehr verwendet werden. 		D string
P
M [1:3]
PARAMETERS 1..∞
In diesem Element werden den Frontparametern die Werte zugeordnet.
VALUE optional Restriction of xs:string
In diesem Attribut wird dem Parameter der Frontgrundform ein Masswert zugeordnet. D decimal
P
M
PARAMETER optional Restriction of xs:string
In diesem Attribut wird derParameter der Frontgrundform angegeben. Im Element VALUE wird diesem Parameter ein Masswert zugeordnet. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FRONT_APPEARANCE_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird. D positiveInteger
P
M [1:999]
Bemerkung

Quelle
<xs:element name="FRONT_APPEARANCE" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_TYPE" maxOccurs="900">
        <xs:annotation>
          <xs:documentation>520--3--Fronttyp</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_TYPE_NO">
              <xs:annotation>
                <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="900" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:sequence maxOccurs="unbounded">
              <xs:element name="FRONT_CONSTRAINTS" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="WIDTH_FROM" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>520/570--6--Breite_von</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="WIDTH_TO" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>520/570--7--Breite_von</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="HEIGHT_FROM" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="HEIGHT_TO" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
              <xs:element name="FRONT_SHAPE">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="GLASS">
                      <xs:annotation>
                        <xs:documentation>520--10--Glas</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:boolean" />
                      </xs:simpleType>
                    </xs:element>
                    <xs:choice>
                      <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="BASIC_FRONT_SHAPE_ID">
                              <xs:annotation>
                                <xs:documentation>520--4--Front_Grundform</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="3" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PARAMETERS" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="VALUE">
                                  <xs:annotation>
                                    <xs:documentation>520--5--Wert</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:maxLength value="12" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="PARAMETER">
                                  <xs:annotation>
                                    <xs:documentation>570--4--Parameter</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="5" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:choice>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>520--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element : FRONT_TYPE Element
Beschreibung
Wenn alle Frontelemente unabhängig vom Fronttyp gleiches Aussehen haben, wird eine Definition mit dem Fronttyp 0 angelegt. Dann dürfen keine weiteren mit abweichenden Fronttypen angelegt werden. Wenn für eine Frontausprägungs-ID ein Datensatz mit einem Fronttyp angelegt wurde, so müssen für alle verwendeten Fronttypen ebenfalls Datensätze angelegt werden.
Namensraum (none)
Diagramm
FRONT_SHAPE Element FRONT_CONSTRAINTS Element Sequence FRONT_TYPE_NO Element Sequence FRONT_TYPE Element
Overview
FRONT_TYPE 1..900
Wenn alle Frontelemente unabhängig vom Fronttyp gleiches Aussehen haben, wird eine Definition mit dem Fronttyp 0 angelegt. Dann dürfen keine weiteren mit abweichenden Fronttypen angelegt werden. Wenn für eine Frontausprägungs-ID ein Datensatz mit einem Fronttyp angelegt wurde, so müssen für alle verwendeten Fronttypen ebenfalls Datensätze angelegt werden.
Sequence
FRONT_TYPE_NO Restriction of xs:positiveInteger
In diesem Attribut wird der Schlüsselwert des Fronttyps angegeben. D positiveInteger
P
M [0:1000]
Sequence 1..∞
FRONT_CONSTRAINTS optional
Für die Elemente WIDTH_FROM/TO und HEIGTH_FROM/TO gelten folgende Regeln:

- Wenn die Elemente WIDTH_TO oder HEIGHT_TO nicht angelegt sind, so entspricht dies dem Wert „unendlich“.
- Wenn die Elemente WIDTH_FROM oder HEIGHT_FROM nicht angelegt sind, so entspricht dies dem Wert 0.
- Der Wert 0 ist in den Elementen WIDTH_FROM/TO oder HEIGTH_FROM/TO nicht zulässig.
- Die angegebenen Intervalle dürfen sich nicht überlappen und müssen immer den gesamten Bereich
von 0 bis unendlich abdecken. Es dürfen keine Lücken entstehen.
Sequence
WIDTH_FROM optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird (Maße in mm). D positiveInteger
P
M [1:999999]
WIDTH_TO optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
HEIGHT_FROM optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
HEIGHT_TO optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
FRONT_SHAPE
In diesem Element sind die Elemente zur geometrischen Beschreibung eines Frontelementes zusammengefasst.
Sequence
GLASS Restriction of xs:boolean
Durch dieses Element kann festgelegt werden, ob es sich bei dem angegebenen Fronttyp um eine Glasversion (Wert 1/true) oder um eine normale Version (Wert 0/false) handelt. Die Werte in diesem Element dürfen für einen Fronttyp nicht wechseln. Durch diese Regel wird verhindert, dass beispielsweise aus einer Glastür durch Auswahl eines anderen Programms eine Massivtür wird. D boolean
P
M
Choice
MODELING_GRAPHIC_ID optional Restriction of xs:string
Hier kann eine Echtgrafik angegeben werden.

Das Format muss dahingehend noch ausformuliert werden. 		D string
P
M [1:15]
BASIC_FRONT_SHAPE optional
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.

Der Wert 999 darf nicht mehr verwendet werden. 		D string
P
M [1:3]
PARAMETERS 1..∞
In diesem Element werden den Frontparametern die Werte zugeordnet.
VALUE optional Restriction of xs:string
In diesem Attribut wird dem Parameter der Frontgrundform ein Masswert zugeordnet. D decimal
P
M
PARAMETER optional Restriction of xs:string
In diesem Attribut wird derParameter der Frontgrundform angegeben. Im Element VALUE wird diesem Parameter ein Masswert zugeordnet. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="FRONT_TYPE" maxOccurs="900" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520--3--Fronttyp</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_TYPE_NO">
        <xs:annotation>
          <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="900" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:sequence maxOccurs="unbounded">
        <xs:element name="FRONT_CONSTRAINTS" minOccurs="0">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="WIDTH_FROM" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>520/570--6--Breite_von</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="WIDTH_TO" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>520/570--7--Breite_von</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="HEIGHT_FROM" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="HEIGHT_TO" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
        <xs:element name="FRONT_SHAPE">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="GLASS">
                <xs:annotation>
                  <xs:documentation>520--10--Glas</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:boolean" />
                </xs:simpleType>
              </xs:element>
              <xs:choice>
                <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="BASIC_FRONT_SHAPE_ID">
                        <xs:annotation>
                          <xs:documentation>520--4--Front_Grundform</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="3" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PARAMETERS" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="VALUE">
                            <xs:annotation>
                              <xs:documentation>520--5--Wert</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:maxLength value="12" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                          <xs:attribute name="PARAMETER">
                            <xs:annotation>
                              <xs:documentation>570--4--Parameter</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:minLength value="1" />
                                <xs:maxLength value="5" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
              </xs:choice>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element : FRONT_TYPE_NO Element
Beschreibung
In diesem Attribut wird der Schlüsselwert des Fronttyps angegeben. D positiveInteger
P
M [0:1000]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
FRONT_TYPE_NO Element
Overview
FRONT_TYPE_NO Restriction of xs:positiveInteger
In diesem Attribut wird der Schlüsselwert des Fronttyps angegeben. D positiveInteger
P
M [0:1000]
Bemerkung

Quelle
<xs:element name="FRONT_TYPE_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520/570--3/3--Fronttyp</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="900" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_CONSTRAINTS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element : FRONT_CONSTRAINTS Element
Beschreibung
Für die Elemente WIDTH_FROM/TO und HEIGTH_FROM/TO gelten folgende Regeln:

- Wenn die Elemente WIDTH_TO oder HEIGHT_TO nicht angelegt sind, so entspricht dies dem Wert „unendlich“.
- Wenn die Elemente WIDTH_FROM oder HEIGHT_FROM nicht angelegt sind, so entspricht dies dem Wert 0.
- Der Wert 0 ist in den Elementen WIDTH_FROM/TO oder HEIGTH_FROM/TO nicht zulässig.
- Die angegebenen Intervalle dürfen sich nicht überlappen und müssen immer den gesamten Bereich
von 0 bis unendlich abdecken. Es dürfen keine Lücken entstehen.
Namensraum (none)
Diagramm
HEIGHT_TO Element HEIGHT_FROM Element WIDTH_TO Element WIDTH_FROM Element Sequence FRONT_CONSTRAINTS Element
Overview
FRONT_CONSTRAINTS optional
Für die Elemente WIDTH_FROM/TO und HEIGTH_FROM/TO gelten folgende Regeln:

- Wenn die Elemente WIDTH_TO oder HEIGHT_TO nicht angelegt sind, so entspricht dies dem Wert „unendlich“.
- Wenn die Elemente WIDTH_FROM oder HEIGHT_FROM nicht angelegt sind, so entspricht dies dem Wert 0.
- Der Wert 0 ist in den Elementen WIDTH_FROM/TO oder HEIGTH_FROM/TO nicht zulässig.
- Die angegebenen Intervalle dürfen sich nicht überlappen und müssen immer den gesamten Bereich
von 0 bis unendlich abdecken. Es dürfen keine Lücken entstehen.
Sequence
WIDTH_FROM optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird (Maße in mm). D positiveInteger
P
M [1:999999]
WIDTH_TO optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
HEIGHT_FROM optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
HEIGHT_TO optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
Bemerkung

Quelle
<xs:element name="FRONT_CONSTRAINTS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="WIDTH_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>520/570--6--Breite_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WIDTH_TO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>520/570--7--Breite_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_TO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WIDTH_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_CONSTRAINTS Element : WIDTH_FROM Element
Beschreibung
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird (Maße in mm). D positiveInteger
P
M [1:999999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
WIDTH_FROM Element
Overview
WIDTH_FROM optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird (Maße in mm). D positiveInteger
P
M [1:999999]
Bemerkung

Quelle
<xs:element name="WIDTH_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520/570--6--Breite_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CONSTRAINTS Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WIDTH_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_CONSTRAINTS Element : WIDTH_TO Element
Beschreibung
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
WIDTH_TO Element
Overview
WIDTH_TO optional Restriction of xs:positiveInteger
In den Elementen WIDTH_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
Bemerkung

Quelle
<xs:element name="WIDTH_TO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520/570--7--Breite_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CONSTRAINTS Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_CONSTRAINTS Element : HEIGHT_FROM Element
Beschreibung
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
HEIGHT_FROM Element
Overview
HEIGHT_FROM optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
Bemerkung

Quelle
<xs:element name="HEIGHT_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520/570--8--Hoehe_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CONSTRAINTS Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_CONSTRAINTS Element : HEIGHT_TO Element
Beschreibung
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
HEIGHT_TO Element
Overview
HEIGHT_TO optional Restriction of xs:positiveInteger
In den Elementen HEIGHT_FROM/TO wird der Breitenbereich angegeben, in dem die Frontgrundform oder die Echtgrafik verwendet wird. (Maße in mm). D positiveInteger
P
M [1:999999]
Bemerkung

Quelle
<xs:element name="HEIGHT_TO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520/570--9--Hoehe_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CONSTRAINTS Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_SHAPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element : FRONT_SHAPE Element
Beschreibung
In diesem Element sind die Elemente zur geometrischen Beschreibung eines Frontelementes zusammengefasst.
Namensraum (none)
Diagramm
BASIC_FRONT_SHAPE Element MODELING_GRAPHIC_ID Element Choice GLASS Element Sequence FRONT_SHAPE Element
Overview
FRONT_SHAPE
In diesem Element sind die Elemente zur geometrischen Beschreibung eines Frontelementes zusammengefasst.
Sequence
GLASS Restriction of xs:boolean
Durch dieses Element kann festgelegt werden, ob es sich bei dem angegebenen Fronttyp um eine Glasversion (Wert 1/true) oder um eine normale Version (Wert 0/false) handelt. Die Werte in diesem Element dürfen für einen Fronttyp nicht wechseln. Durch diese Regel wird verhindert, dass beispielsweise aus einer Glastür durch Auswahl eines anderen Programms eine Massivtür wird. D boolean
P
M
Choice
MODELING_GRAPHIC_ID optional Restriction of xs:string
Hier kann eine Echtgrafik angegeben werden.

Das Format muss dahingehend noch ausformuliert werden. 		D string
P
M [1:15]
BASIC_FRONT_SHAPE optional
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.

Der Wert 999 darf nicht mehr verwendet werden. 		D string
P
M [1:3]
PARAMETERS 1..∞
In diesem Element werden den Frontparametern die Werte zugeordnet.
VALUE optional Restriction of xs:string
In diesem Attribut wird dem Parameter der Frontgrundform ein Masswert zugeordnet. D decimal
P
M
PARAMETER optional Restriction of xs:string
In diesem Attribut wird derParameter der Frontgrundform angegeben. Im Element VALUE wird diesem Parameter ein Masswert zugeordnet. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="FRONT_SHAPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GLASS">
        <xs:annotation>
          <xs:documentation>520--10--Glas</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:choice>
        <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
          <xs:annotation>
            <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:string">
              <xs:minLength value="1" />
              <xs:maxLength value="15" />
            </xs:restriction>
          </xs:simpleType>
        </xs:element>
        <xs:element name="BASIC_FRONT_SHAPE" minOccurs="0">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="BASIC_FRONT_SHAPE_ID">
                <xs:annotation>
                  <xs:documentation>520--4--Front_Grundform</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="3" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="PARAMETERS" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="VALUE">
                    <xs:annotation>
                      <xs:documentation>520--5--Wert</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:maxLength value="12" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                  <xs:attribute name="PARAMETER">
                    <xs:annotation>
                      <xs:documentation>570--4--Parameter</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GLASS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_SHAPE Element : GLASS Element
Beschreibung
Durch dieses Element kann festgelegt werden, ob es sich bei dem angegebenen Fronttyp um eine Glasversion (Wert 1/true) oder um eine normale Version (Wert 0/false) handelt. Die Werte in diesem Element dürfen für einen Fronttyp nicht wechseln. Durch diese Regel wird verhindert, dass beispielsweise aus einer Glastür durch Auswahl eines anderen Programms eine Massivtür wird. D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
GLASS Element
Overview
GLASS Restriction of xs:boolean
Durch dieses Element kann festgelegt werden, ob es sich bei dem angegebenen Fronttyp um eine Glasversion (Wert 1/true) oder um eine normale Version (Wert 0/false) handelt. Die Werte in diesem Element dürfen für einen Fronttyp nicht wechseln. Durch diese Regel wird verhindert, dass beispielsweise aus einer Glastür durch Auswahl eines anderen Programms eine Massivtür wird. D boolean
P
M
Bemerkung

Quelle
<xs:element name="GLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520--10--Glas</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_SHAPE Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODELING_GRAPHIC_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_SHAPE Element : MODELING_GRAPHIC_ID Element
Beschreibung
Hier kann eine Echtgrafik angegeben werden.

Das Format muss dahingehend noch ausformuliert werden. 		D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MODELING_GRAPHIC_ID Element
Overview
MODELING_GRAPHIC_ID optional Restriction of xs:string
Hier kann eine Echtgrafik angegeben werden.

Das Format muss dahingehend noch ausformuliert werden. 		D string
P
M [1:15]
Bemerkung

Quelle
<xs:element name="MODELING_GRAPHIC_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520--5--Echtgrafik_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_SHAPE Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_FRONT_SHAPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_SHAPE Element : BASIC_FRONT_SHAPE Element
Beschreibung
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.
Namensraum (none)
Diagramm
PARAMETERS Element BASIC_FRONT_SHAPE_ID Element Sequence BASIC_FRONT_SHAPE Element
Overview
BASIC_FRONT_SHAPE optional
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.
Sequence
BASIC_FRONT_SHAPE_ID Restriction of xs:string
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.

Der Wert 999 darf nicht mehr verwendet werden. 		D string
P
M [1:3]
PARAMETERS 1..∞
In diesem Element werden den Frontparametern die Werte zugeordnet.
VALUE optional Restriction of xs:string
In diesem Attribut wird dem Parameter der Frontgrundform ein Masswert zugeordnet. D decimal
P
M
PARAMETER optional Restriction of xs:string
In diesem Attribut wird derParameter der Frontgrundform angegeben. Im Element VALUE wird diesem Parameter ein Masswert zugeordnet. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="BASIC_FRONT_SHAPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BASIC_FRONT_SHAPE_ID">
        <xs:annotation>
          <xs:documentation>520--4--Front_Grundform</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PARAMETERS" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="VALUE">
            <xs:annotation>
              <xs:documentation>520--5--Wert</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:maxLength value="12" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="PARAMETER">
            <xs:annotation>
              <xs:documentation>570--4--Parameter</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FRONT_SHAPE Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_FRONT_SHAPE_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_SHAPE Element > BASIC_FRONT_SHAPE Element : BASIC_FRONT_SHAPE_ID Element
Beschreibung
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.

Der Wert 999 darf nicht mehr verwendet werden. 		D string
P
M [1:3]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
BASIC_FRONT_SHAPE_ID Element
Overview
BASIC_FRONT_SHAPE_ID Restriction of xs:string
In diesem Element wird eine Grundform angegeben, über die das Aussehen eines Frontelementes beschrieben wird.
Die Frontgrundformen sind im Tabellenteil "Grundformen" beschrieben.

Der Wert 999 darf nicht mehr verwendet werden. 		D string
P
M [1:3]
Bemerkung

Quelle
<xs:element name="BASIC_FRONT_SHAPE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>520--4--Front_Grundform</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BASIC_FRONT_SHAPE Element | FRONT_SHAPE Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PARAMETERS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > FRONT_APPEARANCES Element > FRONT_APPEARANCE Element > FRONT_TYPE Element > FRONT_SHAPE Element > BASIC_FRONT_SHAPE Element : PARAMETERS Element
Beschreibung
In diesem Element werden den Frontparametern die Werte zugeordnet.
Namensraum (none)
Diagramm
PARAMETERS Element
Overview
PARAMETERS 1..∞
In diesem Element werden den Frontparametern die Werte zugeordnet.
VALUE optional Restriction of xs:string
In diesem Attribut wird dem Parameter der Frontgrundform ein Masswert zugeordnet. D decimal
P
M
PARAMETER optional Restriction of xs:string
In diesem Attribut wird derParameter der Frontgrundform angegeben. Im Element VALUE wird diesem Parameter ein Masswert zugeordnet. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
VALUE Restriction of xs:string optional
In diesem Attribut wird dem Parameter der Frontgrundform ein Masswert zugeordnet. D decimal
P
M
PARAMETER Restriction of xs:string optional
In diesem Attribut wird derParameter der Frontgrundform angegeben. Im Element VALUE wird diesem Parameter ein Masswert zugeordnet. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="PARAMETERS" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="VALUE">
      <xs:annotation>
        <xs:documentation>520--5--Wert</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="12" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="PARAMETER">
      <xs:annotation>
        <xs:documentation>570--4--Parameter</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 8</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BASIC_FRONT_SHAPE Element | FRONT_SHAPE Element | FRONT_TYPE Element | FRONT_APPEARANCE Element | FRONT_APPEARANCES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET_DEFINITIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : MODULE_RULE_SET_DEFINITIONS Element
Beschreibung
In diesem Element werden die Regeln für Modulschränke und die darin zu verbauenden Module gesammelt.
Namensraum (none)
Diagramm
MODULE_RULE_SET_DEFINITION Element Sequence MODULE_RULE_SET_DEFINITIONS Element
Overview
MODULE_RULE_SET_DEFINITIONS optional
In diesem Element werden die Regeln für Modulschränke und die darin zu verbauenden Module gesammelt.
Sequence
MODULE_RULE_SET_DEFINITION 1..∞
In diesem Element werden die Regeln für Modulränke und die darin zu verbauenden Module definiert. Hier definierte Modulregeln werden von Artikeln (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) oder (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) referenziert.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D nonNegativeInteger
P
M
Sequence
MODULE_RULE_SET_NAME languagetexte60 Complex Type
In diesem Element wir die Bezeichnung des Regelwerks hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="MODULE_RULE_SET_DEFINITIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_RULE_SET_DEFINITION" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_RULE_SET_NAME" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Um Mehrsprachenfaehigkeit erweitert AK 28.02.2012</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > MODULE_RULE_SET_DEFINITIONS Element : MODULE_RULE_SET_DEFINITION Element
Beschreibung
In diesem Element werden die Regeln für Modulränke und die darin zu verbauenden Module definiert. Hier definierte Modulregeln werden von Artikeln (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) oder (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) referenziert.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence MODULE_RULE_SET_NAME Element Sequence MODULE_RULE_SET_DEFINITION Element
Overview
MODULE_RULE_SET_DEFINITION 1..∞
In diesem Element werden die Regeln für Modulränke und die darin zu verbauenden Module definiert. Hier definierte Modulregeln werden von Artikeln (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) oder (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) referenziert.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D nonNegativeInteger
P
M
Sequence
MODULE_RULE_SET_NAME languagetexte60 Complex Type
In diesem Element wir die Bezeichnung des Regelwerks hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MODULE_RULE_SET_NO xs:nonNegativeInteger required
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D nonNegativeInteger
P
M
Bemerkung

Quelle
<xs:element name="MODULE_RULE_SET_DEFINITION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_RULE_SET_NAME" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Um Mehrsprachenfaehigkeit erweitert AK 28.02.2012</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MODULE_RULE_SET_DEFINITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > MODULE_RULE_SET_DEFINITIONS Element > MODULE_RULE_SET_DEFINITION Element : MODULE_RULE_SET_NAME Element
Beschreibung
In diesem Element wir die Bezeichnung des Regelwerks hinterlegt.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence MODULE_RULE_SET_NAME Element
Overview
MODULE_RULE_SET_NAME languagetexte60 Complex Type
In diesem Element wir die Bezeichnung des Regelwerks hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="MODULE_RULE_SET_NAME" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Um Mehrsprachenfaehigkeit erweitert AK 28.02.2012</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
MODULE_RULE_SET_DEFINITION Element | MODULE_RULE_SET_DEFINITIONS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : DETAIL_INFOS Element
Beschreibung
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
Namensraum (none)
Diagramm
DETAIL_INFO Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
Sequence
DETAIL_INFO 1..∞

In diesem Element wird eine Detailinformation definiert.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
Dieses Element enthält Text für einen Tooltip zum Link.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element ist für die URL zur Detailinformation.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INFO_TYPE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[01]|99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="INTERNAL_NAME" type="languagetexte40">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="GUID">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="URL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:anyURI">
                              <xs:minLength value="1" />
                              <xs:maxLength value="1024" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HASH_VALUE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="64" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESOLUTION" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="4" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element : DETAIL_INFO Element
Beschreibung

In diesem Element wird eine Detailinformation definiert.

Namensraum (none)
Diagramm
RESOLUTION Element URL Element LANGUAGE Element Sequence TOOL_TIP Element GUID Element LANGUAGE Element Sequence INTERNAL_NAME Element LANGUAGE Element Sequence EXTERNAL_NAME Element INFO_TYPE Element CLASSIFICATION Element Sequence DETAIL_INFO Element
Overview
DETAIL_INFO 1..∞

In diesem Element wird eine Detailinformation definiert.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
Dieses Element enthält Text für einen Tooltip zum Link.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element ist für die URL zur Detailinformation.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INFO_TYPE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
          <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
          <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[01]|99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="INTERNAL_NAME" type="languagetexte40">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="GUID">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="URL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:anyURI">
                        <xs:minLength value="1" />
                        <xs:maxLength value="1024" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HASH_VALUE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="64" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESOLUTION" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="4" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLASSIFICATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : CLASSIFICATION Element
Beschreibung
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CLASSIFICATION Element
Overview
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
Quelle
<xs:element name="CLASSIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

INFO_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INFO_TYPE Element
Beschreibung
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
INFO_TYPE Element
Overview
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
Quelle
<xs:element name="INFO_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
    <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
    <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[01]|99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXTERNAL_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : EXTERNAL_NAME Element
Beschreibung
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Namensraum (none)
Typ
languagetexte Complex Type
Diagramm
LANGUAGE Element Sequence EXTERNAL_NAME Element
Overview
EXTERNAL_NAME optional languagetexte Complex Type
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > languagetexte Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetexte Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

INTERNAL_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INTERNAL_NAME Element
Beschreibung
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Namensraum (none)
Typ
languagetexte40 Complex Type
Diagramm
LANGUAGE Element Sequence INTERNAL_NAME Element
Overview
INTERNAL_NAME languagetexte40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="INTERNAL_NAME" type="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > languagetexte40 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetexte40 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GUID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : GUID Element
Beschreibung
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
GUID Element
Overview
GUID Restriction of xs:string
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
Quelle
<xs:element name="GUID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TOOL_TIP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : TOOL_TIP Element
Beschreibung
Dieses Element enthält Text für einen Tooltip zum Link.
Namensraum (none)
Typ
languagetexte Complex Type
Diagramm
LANGUAGE Element Sequence TOOL_TIP Element
Overview
TOOL_TIP optional languagetexte Complex Type
Dieses Element enthält Text für einen Tooltip zum Link.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

URL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : URL Element
Beschreibung
Dieses Element ist für die URL zur Detailinformation.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence URL Element
Overview
URL
Dieses Element ist für die URL zur Detailinformation.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
Quelle
<xs:element name="URL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:anyURI">
                  <xs:minLength value="1" />
                  <xs:maxLength value="1024" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HASH_VALUE" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="64" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
HASH_VALUE Element TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:anyURI">
            <xs:minLength value="1" />
            <xs:maxLength value="1024" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HASH_VALUE" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="64" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
Namensraum (none)
Typ
Restriction of xs:anyURI
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:anyURI">
      <xs:minLength value="1" />
      <xs:maxLength value="1024" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HASH_VALUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : HASH_VALUE Element
Beschreibung
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
HASH_VALUE Element
Overview
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
Quelle
<xs:element name="HASH_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="64" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESOLUTION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : RESOLUTION Element
Beschreibung
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
RESOLUTION Element
Overview
RESOLUTION optional Restriction of xs:positiveInteger
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
Quelle
<xs:element name="RESOLUTION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="4" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTIES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : PROPERTIES Element
Beschreibung

Dieses Element dient zur Aufnahme zusätzlicher Informationen und Eigenschafen wie z. B. Energielabel, Effizienzklassen und ähnlicher Daten. Es werden nur die Eigenschaften definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Die Schlüssel sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

Namensraum (none)
Diagramm
PROPERTY Element Sequence PROPERTIES Element
Overview
PROPERTIES optional

Dieses Element dient zur Aufnahme zusätzlicher Informationen und Eigenschafen wie z. B. Energielabel, Effizienzklassen und ähnlicher Daten. Es werden nur die Eigenschaften definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Die Schlüssel sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

Sequence
PROPERTY 1..∞

In diesem Element wird eine Eigenschaft definiert.

Die Schlüssel, der Text und die Maßeinheit sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

PROPERTY_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die Eigenschaft identifiziert.

Ihre Nummer ist der Tabelle der Informationsschlüssel zu eintnehmen.

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetexte Complex Type

Dieses Element enthält Texte für Eigenschaften/Merkmale.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PROPERTY_UNIT optional languagetexte30 Complex Type
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Version 2.3 </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Version 2.3</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROPERTY_TEXT" type="languagetexte" minOccurs="1" maxOccurs="1" />
            <xs:element name="PROPERTY_UNIT" type="languagetexte30" minOccurs="0" maxOccurs="1" />
          </xs:sequence>
          <xs:attribute name="PROPERTY_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element : PROPERTY Element
Beschreibung

In diesem Element wird eine Eigenschaft definiert.

Die Schlüssel, der Text und die Maßeinheit sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence PROPERTY_UNIT Element LANGUAGE Element Sequence PROPERTY_TEXT Element Sequence PROPERTY Element
Overview
PROPERTY 1..∞

In diesem Element wird eine Eigenschaft definiert.

Die Schlüssel, der Text und die Maßeinheit sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

PROPERTY_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die Eigenschaft identifiziert.

Ihre Nummer ist der Tabelle der Informationsschlüssel zu eintnehmen.

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetexte Complex Type

Dieses Element enthält Texte für Eigenschaften/Merkmale.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PROPERTY_UNIT optional languagetexte30 Complex Type
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PROPERTY_NO Restriction of xs:nonNegativeInteger required

Mit diesem Attribut wird die Eigenschaft identifiziert.

Ihre Nummer ist der Tabelle der Informationsschlüssel zu eintnehmen.

 D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="PROPERTY" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Version 2.3</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY_TEXT" type="languagetexte" minOccurs="1" maxOccurs="1" />
      <xs:element name="PROPERTY_UNIT" type="languagetexte30" minOccurs="0" maxOccurs="1" />
    </xs:sequence>
    <xs:attribute name="PROPERTY_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTY_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element > PROPERTY Element : PROPERTY_TEXT Element
Beschreibung

Dieses Element enthält Texte für Eigenschaften/Merkmale.

Namensraum (none)
Typ
languagetexte Complex Type
Diagramm
LANGUAGE Element Sequence PROPERTY_TEXT Element
Overview
PROPERTY_TEXT languagetexte Complex Type

Dieses Element enthält Texte für Eigenschaften/Merkmale.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="PROPERTY_TEXT" type="languagetexte" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
PROPERTY Element | PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTY_UNIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element > PROPERTY Element : PROPERTY_UNIT Element
Beschreibung
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Namensraum (none)
Typ
languagetexte30 Complex Type
Diagramm
LANGUAGE Element Sequence PROPERTY_UNIT Element
Overview
PROPERTY_UNIT optional languagetexte30 Complex Type
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="PROPERTY_UNIT" type="languagetexte30" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
PROPERTY Element | PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GROUP_TITLES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : GROUP_TITLES Element
Beschreibung
Hier werden an zentraler Stelle alle möglichen Bezeichnungen für Gruppen von optionalen und zwingenden Zusatzartikeln gespeichert.
Namensraum (none)
Diagramm
GROUP_TITLE Element Sequence GROUP_TITLES Element
Overview
GROUP_TITLES optional
Hier werden an zentraler Stelle alle möglichen Bezeichnungen für Gruppen von optionalen und zwingenden Zusatzartikeln gespeichert.
Sequence
GROUP_TITLE 1..∞
Dieses Element dient zur Speicherung eines Gruppentitels.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine eindeutige Nummer zur späteren Referenzierung des Gruppentitels gespeichert. D nonNegativeInteger
P
M [0-999]
Sequence
GROUP_TITLE_NAME languagetexte60 Complex Type
Dieses Element enthält Namen für Gruppen von Zusatzartikeln.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="GROUP_TITLES" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GROUP_TITLE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="GROUP_TITLE_NAME" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="GROUP_TITLE_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GROUP_TITLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > GROUP_TITLES Element : GROUP_TITLE Element
Beschreibung
Dieses Element dient zur Speicherung eines Gruppentitels.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence GROUP_TITLE_NAME Element Sequence GROUP_TITLE Element
Overview
GROUP_TITLE 1..∞
Dieses Element dient zur Speicherung eines Gruppentitels.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine eindeutige Nummer zur späteren Referenzierung des Gruppentitels gespeichert. D nonNegativeInteger
P
M [0-999]
Sequence
GROUP_TITLE_NAME languagetexte60 Complex Type
Dieses Element enthält Namen für Gruppen von Zusatzartikeln.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
GROUP_TITLE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird eine eindeutige Nummer zur späteren Referenzierung des Gruppentitels gespeichert. D nonNegativeInteger
P
M [0-999]
Quelle
<xs:element name="GROUP_TITLE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GROUP_TITLE_NAME" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="GROUP_TITLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
GROUP_TITLES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GROUP_TITLE_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > GROUP_TITLES Element > GROUP_TITLE Element : GROUP_TITLE_NAME Element
Beschreibung
Dieses Element enthält Namen für Gruppen von Zusatzartikeln.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence GROUP_TITLE_NAME Element
Overview
GROUP_TITLE_NAME languagetexte60 Complex Type
Dieses Element enthält Namen für Gruppen von Zusatzartikeln.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="GROUP_TITLE_NAME" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
GROUP_TITLE Element | GROUP_TITLES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : SERIES Element
Beschreibung
In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren Eigenschaften und zugeordneten Elementen wie beipsielsweise Produktgruppen oder Artikeln hinterlegt.
Namensraum (none)
Diagramm
RESTRICTIONS Element SERIE Element Sequence SERIES Element
Overview
SERIES
In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren Eigenschaften und zugeordneten Elementen wie beipsielsweise Produktgruppen oder Artikeln hinterlegt.
Sequence
SERIE 1..100

In diesem Element werden die Serien definiert.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung ( SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:99]
Sequence
FEATURE_CLASS_REF optional
Mit diesem Element wird eine Variantenfamilie referenziert die der Serie zugeordnet werden soll.
Hierdurch können die in einer Serie gültigen Variantenarten zugeordnet werden.
Die hier zugeordnete Variantenfamilie stellt eine Obermenge der Variantenarten dar, die sich aus der Summe aller Variantenarten der Variantenfamilien aller Programme und aller Artikel in dieser Serie ergibt. Daher sind die einer Serie zugeordneten Variantenarten für eine Bestellung nicht ZWINGEND anzugeben. Für eine Bestellung sind aber die Summe der Varianten eines Artikels in Summe mit denen des Programms in dem der Artikel bestellt wird anzugeben.
Die einer Serie zugeordneten Variantenarten werden dem Anwender bei der Eingabe der Kopfvarianten zur Eingabe angeboten.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Variantenfamilie. Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D positiveInteger
P
M [1:999]
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PURCHASE_RETAIL_ID Restriction of xs:boolean
Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:
0 = EK-Preis
1 = VK-Preis
In Abhängigkeit der Preis-ID (Element PRICE_ID (Pfad1)) wird der Preis wie folgt definiert:

Preis-ID = 1 (Preis), dann wird der Wert aus dem Element ITEM_PRICE (Pfad2) verwendet.

Preis-ID = 2 (Identnummer), dann wird der Preis aus dem Element IDENT_NUMBER/PRICE (Pfad3), dem Element ITEM_PRICE/PRICE_MINIMUM_BASIC (Pfad2) oder dem Element ADDITIONAL_PRICE (Pfad5) verwendet.

Preis_ID = 3 (Verrechnungspunkt), dann wird der Wert aus aus den Elementen ITEM_PRICE (Pfad2) oder PRICE_MINIMUM_BASIC multipliziert mit dem Verrechnungsfaktor aus dem Element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR verwendet.

Aufgrund des Schlüssels kann innerhalb einer Serie nur eine Preisstellung (Kombination der Elemente VAT (Pfad4) und PURCHASE_RETAIL_ID (Pfad4)) angegeben werden.
Werden in einer Datei sowohl EK- wie auch VK-Preise aufgeführt, so dürfen bei Typen mit EK-Preisen nicht die gleichen Kalkulationsgruppen (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) wie bei Typen mit VK-Preisen vergeben werden.
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Elementpfade
Pfad1: CATALOG/CATALOG_IDENTIFICATION/
Pfad2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
Pfad3: PRICE_DEFINITION/IDENT_NUMBERS
Pfad4: CATALOG/CATALOG_IDENTIFICATION
Pfad5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP 		D boolean
P
M
RESTRICTIONS optional
Dieses Element referenziert Prüfverfahren, die für die Serie angewendet werden (Serien-spezifische Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Sequence
RESTRICTION_REF 0..∞
Dieses Element referenziert ein Prüfverfahren, das für die Serie angewendet wird (Serien-spezifisches Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Serien-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SUGGESTIONS optional
Dieses Element referenziert Vorbelegungen, die für die Serie angewendet werden.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.
Sequence
SUGGESTION_REF 0..∞
Dieses Element referenziert eine Vorbelegung, die für die Serie angewendet wird.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.
SEQUENCE required Restriction of xs:nonNegativeInteger

Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Vorbelegungen bei der Ersterfassung einer Planung vorgeschlagen werden.

Die Nummerierung (SEQUENCE) steuert die Prioritäten

 D nonNegativeInteger
P
M [1:99999]
SUGGESTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut wird eine Vorbelegungen referenziert. D nonNegativeInteger
P
M [0:99999]
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:999]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Die Elemente OLD_SERIA_NO (Pfad 1) und OLD_TYPE_NO (Pfad 1) dürfen nur verwendet werden, wenn der dort angegebene Artikel in allen geometrischen Daten identisch dem aktuellen Artikel ist.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Maße B, H und T dieses E-Gerätes im Element PARAMETERS (Pfad 3) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Der Code drückt unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

In diesem Attribut wird das Nettogewicht angegeben.

Dabei drückt der Code im vorhergehenden Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisvariantengruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
RESTRICTIONS optional
In diesem Element werden artikelspezifische Prüfverfahren zugeordnet.

Es dürfen nur Prüfverfahren referenziert werden, deren Variantenarten in der Variantenfamilie des Artikels enthalten sind.

Wenn ein Artikel Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Artikelspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
HINGE Restriction of xs:string

Dieses Element wird verwendet, um die Informationen über den Türanschlag des Artikels zu hinterlegen. Es werden keine geometrischen Informationen der Grundform des Artikels gesteuert. Hierzu wird das Feld CONSTRUCTION_ID verwendet.

Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.

Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID => das Element HINGE muss mit dem Wert "N" gefüllt werden.

Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) der Wert "J" enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element wird die äquivalente Katalogseite des Artikels angegeben. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall sollte die erste Seitennummer auf der der Artikel/ die Type auftaucht, verwendet werden. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

In diesem Element kann die äquivalente Katalogseite des Artikels in dem als .pdf-Datei abgelegten Kataloges angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gespeicherten Katalogs.

In dem Element DETAIL_INFO (auf Katalogebene) ist die URL der .pdf-Datei hinterlegt Da es Artikel gibt, die auf mehreren Seiten im Katalog aufgeführt sind, ist sicher zu stellen, dass die Angabe für die .pdf-Datei mit der 40-stelligen Katalogseite CATALOG_PAGE übereinstimmt, das heißt, beide Angaben verweisen auf die selbe Seite.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

In dieses Element wird das Gewicht des Artikels [100 g] inklusive Verpackungsmaterial angegeben. (z. B. 50 = 5000 g).
Dabei drückt der Code im Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.
Langteile werden entsprechend des Brutto-Gwichts je Preiseinheit berechnet.

Beispiel:
Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³] des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt, wird in diesem Element die Herstellernummer eingetragen.

Handelt es sich bei diesem Artikel um ein sichtbares Zulieferteil, so müssen entweder die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO oder die Elemente FILE_NAME_TEXTURE_1/2 gefüllt werden.

Die Herstellernummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Herstellernummer im Verkauf nicht öffentlich zu machen. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt (SUBCONTRACTOR_ID muss gefüllt sein), wird in diesem Element die Artikelnummer des Herstellers eingetragen.

Die Artikelnummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Artikelnummer im Verkauf nicht öffentlich zu machen. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist mindestens eines der Elemente FILENAME_TEXTURE_1/2 gefüllt, so ist dieses Element nicht optional. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
Dieses Element dient der Referenzierung auf eine Echtgrafik. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung). 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

Über dieses Element werden die werkseitigen Änderungsmöglichkeiten eines Artikels gesteuert. Die Änderungsmöglichkeiten der Artikel sind abhängig von der Definition seiner Grundformparameter im Element PARAMETERS (Pfad 1).

0 = alle Maßparameter (PARAMETERS (Pfad 1)) sind gesperrt, eine Maßänderung ist nicht möglich;

1 = die Maßparameter (PARAMETERS (Pfad 1)) sind im Rahmen der in SA500 angelegten Daten änderbar. Das zu ändernde Maß muss vom Benutzer abgefragt werden;

2 = alle Maßparameter (PARAMETERS (Pfad 1)) sind änderbar, gesperrte Parameter müssen identische Werte in den Attributen NOMINAL_VALUE (Pfad 1), FROM (Pfad 1) und TO (Pfad 1) haben.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
MODULE_PARTS optional

Falls der entsprechende Artikel ein Varioschrank ist, enthält dieses Element eine Stückliste von Modulelementen, wobei das erste Element ein Basisschrank mit der Position 0 ist und danach von unten nach oben die Modulelemente folgen. Dieses Element darf nicht angegeben werden, wenn der dazu gehörige Artikel kein Varioschrank ist.

Der Varioschrank hat einen festen Preis. Sobald der Varioschrank verändert wird, ergibt sich der neue Preis aus Preis für Basisschrank + Preis für die Module. Dabei entfällt der Varioschrank, der Basisschrank wird Hauptposition und hat alle anderen Modulelemente als Unterposition in der Reihenfolge von unten nach oben.

Die Modulelemente können programm- und ausführungsabhängig sein.

Für Modulelemente können Regeln bezüglich ihrer Höhe innerhalb des Basisschrankes über MODUL_RULE_SETS festgelegt werden. Dabei wird die global definierte Modulregel referenziert.

Dem Basisschrank kann solch eine Regel über MODULE_RULE_SET_REF zugeordnet werden.

ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
FRONT_DIVISIONS optional
In diesem Element werden die möglichen Frontaufteilungen für einen Artikel definiert.
Die Frontaufteilungen können in Abhängigkeit des Programms unterschiedlich sein oder der Artikel hat in Abhängigkeit von Einbaugeräten unterschiedliche Frontaufteilungen.

Frontaufteilungen, die in mehrere Programme gleich sind, können in Frontgruppen zusammengefasst werden. Die Frontgruppen werden dann von den Programmen referenziert.

Die Frontaufteilungen beziehen sich auf die linke Bauweise. Ist der Artikel auch in rechter Bauweise vorhanden, so wird die Frontaufteilung von der Planungssoftware gespiegelt.
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Artikel eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Frontausprägungen, die mit diesem Element zugeordnet werden, sind programmunabhängig.
Choice optional
MODULE_RULE_SET_REF optional
Mit diesem Element referenziert der Artikel eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS. Nur Modulschränke (Typenschlüsselart = 17) können an dieser Stelle ein Modulregelset referenzieren. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden.
MODULE_RULE_SETS optional
Dieses Element enthält die Modulregelwerke für Modulelemente. Ist der Artikel ein Modulelement (Typenschlüssel = 10), dann werden hier die Regeln für die Verplanung des Moduls hinterlegt. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
RESTRICTIONS optional
In diesem Element werden die Prüfverfahren einer Produktgruppe zusammengefasst.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, der Produktgruppe zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]

DEFAULT_OPTION_GROUPS optional
In diesem Element werden Standard-Vorbelegungen von Programmvarianten als Vorschlag und Entscheidungshilfe für den Anwender definiert. Die vorgeschlagenen Kombinationen müssen kompatibel zu den Prüfverfahren sein.
Sequence
DEFAULT_OPTION_GROUP 1..∞
In diesem Element wird ein Standardvorschlag definiert.
Jede Variantenart darf je DEFAULT_OPTION_GROUP nur einmal referenziert werden.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
In diesem Attribut wird eine numerischer Wert zur Identifizierung der Standardgruppe angelegt. D positiveInteger
P
M [1:999999999]
Sequence
DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
In diesem Element wird ein freier Name für einen Standardvorschlag angegeben. Der Name kann beispielsweise für die Auswahl eines Standardvorschlages vom Benutzer des Planungssystems verwendet werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FILE_NAME optional Restriction of xs:string
In diesem Element wird der Dateiname eines JPEG-Bildes angegeben, dass ein beispielartiges Bild des Standardvorschlages darstellt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
OPTION_REF 1..∞
In diesem Element werden die Varianten referenziert, die zu einem Standardvorschlag zusammengestellt werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart der referenzierten Variante angegeben. D noNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
In diesem Attribut wird die Variante referenziert, die dem Standardvorschlag zugeordnet wird. D string
P
M [1:5]
DETAIL_INFOS optional
Dieses Element dient der Angabe von Bildern unterhalb des Standardvorschlages.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks zur Serie hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
RESTRICTIONS optional
In diesem Element werden Serien-übergreifende Prüfverfahren gesammelt.
Sequence
RESTRICTION_REF 0..∞
Mit diesem Element werden Serien-übergreifende Prüfverfahren referenziert.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Alle Prüfverfahren müssen einen unterschiedlichen Wert für die SEQUENCE_NO enthalten. Über die Prüfungen wird die Schnittmenge gebildet.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Serien-übergreifende Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
Bemerkung

Quelle
<xs:element name="SERIES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE" maxOccurs="100">
        <xs:annotation>
          <xs:documentation>200--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SERIES_NAME">
              <xs:annotation>
                <xs:documentation>200--3--Serienname</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>200--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PURCHASE_RETAIL_ID">
              <xs:annotation>
                <xs:documentation>200--5--EK_VK_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SUGGESTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SUGGESTION_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SUGGESTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRODUCT_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_CLASS_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEMS">
                          <xs:annotation>
                            <xs:documentation>400--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECO_MOBILIER" minOccurs="0">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[0-9]{11}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="NET_WEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                      <xs:annotation>
                                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence minOccurs="0">
                                          <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>450/470--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PRICE_FIELD">
                                                  <xs:annotation>
                                                    <xs:documentation>450--4--Preisfeld</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="250" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PRICE">
                                                  <xs:annotation>
                                                    <xs:documentation>450--5--Preis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:integer">
                                                      <xs:minInclusive value="-99999999" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:boolean" />
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>470--4--Preis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:integer">
                                                      <xs:minInclusive value="-99999999" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="PRICE_TYPE_REF">
                                      <xs:annotation>
                                        <xs:documentation>400/407--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="PRICE_TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400/407--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CALC_GROUP_REF">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="CALC_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="10" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PRICE_FEATURE_GROUP_REF">
                                            <xs:annotation>
                                              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>460--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="PRICE_FIELD">
                                                        <xs:annotation>
                                                          <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="250" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PRICE">
                                                        <xs:annotation>
                                                          <xs:documentation>460--5--Preis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:integer">
                                                            <xs:minInclusive value="-99999999" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="99999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CALC_GROUP_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="CALC_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="10" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[0-9]|[1-8][0-9]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="PRICE_TYPE_REF">
                                            <xs:annotation>
                                              <xs:documentation>407--5--Preisart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>407--5--Preisart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="RESTRICTIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>409--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>409--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="RESTRICTION_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>409--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SEQUENCE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>409--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:maxInclusive value="99999" />
                                                    <xs:minInclusive value="1" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>406--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                                    <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>120--0--NEW</xs:documentation>
                                                              <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>406--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                            <xs:annotation>
                                                              <xs:documentation>406--7--Anzahl</xs:documentation>
                                                              <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="SEQUENCE" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>Version 2.4.1</xs:documentation>
                                                              <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:maxInclusive value="99999" />
                                                                <xs:minInclusive value="1" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SET_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="9" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>120--0--NEW</xs:documentation>
                                                              <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>406--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                            <xs:annotation>
                                                              <xs:documentation>406--7--Anzahl</xs:documentation>
                                                              <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="SEQUENCE" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>Version 2.4.1</xs:documentation>
                                                              <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:maxInclusive value="99999" />
                                                                <xs:minInclusive value="1" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SET_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="9" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPERATION_ITEM" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SCOPE" maxOccurs="5">
                                                  <xs:annotation>
                                                    <xs:documentation>411--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>411--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="CLASS">
                                                              <xs:annotation>
                                                                <xs:documentation>411--7--Art</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="21" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="ITEM_REF" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="SERIE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>411--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="99" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="TYPE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>411--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:minLength value="1" />
                                                                      <xs:maxLength value="15" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                            <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[LNR]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="COVER" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--9--Abdeckung</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="3" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="VALUE" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--10--Wert</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="VALUE_MIN" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                                                <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="VALUE_MAX" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                                                <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SCOPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>411--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="5" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="HINGE">
                                      <xs:annotation>
                                        <xs:documentation>400--4--Anschlag</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[BEJLMNR]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="EDP_NUMBER" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="EAN_NUMBER" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_IDENTIFICATION">
                                      <xs:annotation>
                                        <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[BEKSMZVPNOG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CATALOG_PAGE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="40" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                                        <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                                        <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VAT_ID_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="VAT_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="WEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--20--Gewicht</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VOLUME" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--21--Volumen</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CONSTRUCTION_ID">
                                      <xs:annotation>
                                        <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[JLNRAE]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="OLD_SERIE_NO" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="99" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="OLD_TYPE_NO" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--27--Type_Alt</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MASKING" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--30--Maskierung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="RANGE_DEPENDENT">
                                      <xs:annotation>
                                        <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="2" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BASIC_PROFILE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:choice>
                                            <xs:element name="CARCASE_BASIC_SHAPE">
                                              <xs:annotation>
                                                <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                                    <xs:annotation>
                                                      <xs:documentation>400--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType mixed="true">
                                                      <xs:sequence>
                                                        <xs:element name="OPTION_REF">
                                                          <xs:annotation>
                                                            <xs:documentation>430--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:attribute name="FEATURE_NO" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>430--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="OPTION_KEY" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>430--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:minLength value="1" />
                                                                  <xs:maxLength value="5" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                      <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>400--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[\S ]{1,5}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                  <xs:element name="BASIC_SHAPE_PARAMETERS">
                                                    <xs:annotation>
                                                      <xs:documentation>500--1--Satzart</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                          <xs:annotation>
                                                            <xs:documentation>500--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--Parameter</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>500--5--Nennwert</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="BASIC_SHAPE_FROM">
                                                              <xs:annotation>
                                                                <xs:documentation>500--6--Von</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="BASIC_SHAPE_TO">
                                                              <xs:annotation>
                                                                <xs:documentation>500--7--Bis</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                              <xs:annotation>
                                                                <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                                <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                            <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                              <xs:annotation>
                                                <xs:documentation>400--32--Massbild</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                                    <xs:annotation>
                                                      <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:minLength value="1" />
                                                        <xs:maxLength value="240" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:element>
                                                  <xs:element name="DIMENSIONAL_PARAMETERS">
                                                    <xs:annotation>
                                                      <xs:documentation>500--1--Satzart</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                          <xs:annotation>
                                                            <xs:documentation>500--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="DIMENSIONAL_FROM">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="DIMENSIONAL_TO">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                            <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:decimal">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="999999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:attribute>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                                <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>400--32--Massbild</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="20" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:choice>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="BLOCK_PARTS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BLOCK_SEQUENTIAL_NO">
                                                  <xs:annotation>
                                                    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="FEATURE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="OPTION_KEY" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="5" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="HINGE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--6--Anschlag</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[BEJLMNR]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="EXCHANGE_CONDITION">
                                                  <xs:annotation>
                                                    <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="2" />
                                                      <xs:maxInclusive value="3" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="STATUS">
                                                  <xs:annotation>
                                                    <xs:documentation>401--8--Status</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[ABELSZ]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[JLNRAE]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="MODULE_PARTS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="MODULE_PART" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PART_SEQUENTIAL_NO">
                                                  <xs:annotation>
                                                    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:maxInclusive value="999" />
                                                      <xs:minInclusive value="0" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SHORT_TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT_LINE" maxOccurs="3">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT">
                                                              <xs:annotation>
                                                                <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[\S ]{1,30}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SEQUENCE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger" />
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:language">
                                                          <xs:pattern value="[A-Z]{2}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TYPE_KEY">
                                      <xs:annotation>
                                        <xs:documentation>445--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_TYPE">
                                            <xs:annotation>
                                              <xs:documentation>445--4--TS_Typ</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_CLASS">
                                            <xs:annotation>
                                              <xs:documentation>445--5--TS_Art</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                            <xs:annotation>
                                              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                          <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="9999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger" />
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                                <xs:annotation>
                                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="TK_MATERIAL" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--21--TS_Material</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-2]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_SHAPE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--22--TS_Form</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-2]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS">
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS_NO">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:totalDigits value="8" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FRONT_DIVISIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>510--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="FRONT_GROUP" maxOccurs="99">
                                            <xs:annotation>
                                              <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="FRONT_DIVISION_DEF">
                                                        <xs:annotation>
                                                          <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:minLength value="1" />
                                                            <xs:maxLength value="250" />
                                                            <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:minLength value="1" />
                                                            <xs:maxLength value="15" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="FRONT_CELL_NO">
                                                              <xs:annotation>
                                                                <xs:documentation>540--6--Zellennummer</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="99" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="FRONT_TYPE" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--7--Fronttyp</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="900" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="4" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="4" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="PARAMETER_1" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--12--Parameter_1</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="99" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="PARAMETER_2" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--13--Parameter_2</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:positiveInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="99" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="9999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="9999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                            </xs:element>
                                                            <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                            </xs:element>
                                                            <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                            </xs:element>
                                                            <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                            </xs:element>
                                                            <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="4" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="UPPER_JOIN" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="|[VLSG]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="LOWER_JOIN" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="|[VLSG]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="LEFT_JOIN" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="|[VLSG]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="RIGHT_JOIN" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="|[VLSG]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>540--0--NEW</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="1" />
                                                                  <xs:maxInclusive value="2" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="FRONT_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:choice minOccurs="0">
                                      <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="MODULE_RULES">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:complexType>
                                                            <xs:sequence>
                                                              <xs:element name="MODULE_POSITION">
                                                                <xs:annotation>
                                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:string">
                                                                    <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                                                    <xs:enumeration value="LINE_BOTTOM" />
                                                                    <xs:enumeration value="LINE_TOP" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:element>
                                                              <xs:element name="MAX_VALUE" minOccurs="0">
                                                                <xs:annotation>
                                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="0" />
                                                                    <xs:maxInclusive value="99999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:element>
                                                              <xs:element name="MIN_VALUE" minOccurs="0">
                                                                <xs:annotation>
                                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="0" />
                                                                    <xs:maxInclusive value="99999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:element>
                                                            </xs:sequence>
                                                          </xs:complexType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                    </xs:complexType>
                                                  </xs:element>
                                                  <xs:element name="MODULE_RULE_SET_REF">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="PROPERTIES" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="PROPERTY_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="VALUE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESTRICTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="RESTRICTION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="99999" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DEFAULT_OPTION_GROUPS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>295--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DEFAULT_OPTION_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30">
                          <xs:annotation>
                            <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="FILE_NAME" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>296--6--Dateiname</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OPTION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>295--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>295--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>295--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
                            <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element : SERIE Element
Beschreibung

In diesem Element werden die Serien definiert.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung ( SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Namensraum (none)
Diagramm
DETAIL_INFOS Element DEFAULT_OPTION_GROUPS Element PRODUCT_GROUPS Element SUGGESTIONS Element RESTRICTIONS Element PURCHASE_RETAIL_ID Element SERIES_NAME Element FEATURE_CLASS_REF Element Sequence SERIE Element
Overview
SERIE 1..100

In diesem Element werden die Serien definiert.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung ( SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:99]
Sequence
FEATURE_CLASS_REF optional
Mit diesem Element wird eine Variantenfamilie referenziert die der Serie zugeordnet werden soll.
Hierdurch können die in einer Serie gültigen Variantenarten zugeordnet werden.
Die hier zugeordnete Variantenfamilie stellt eine Obermenge der Variantenarten dar, die sich aus der Summe aller Variantenarten der Variantenfamilien aller Programme und aller Artikel in dieser Serie ergibt. Daher sind die einer Serie zugeordneten Variantenarten für eine Bestellung nicht ZWINGEND anzugeben. Für eine Bestellung sind aber die Summe der Varianten eines Artikels in Summe mit denen des Programms in dem der Artikel bestellt wird anzugeben.
Die einer Serie zugeordneten Variantenarten werden dem Anwender bei der Eingabe der Kopfvarianten zur Eingabe angeboten.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Variantenfamilie. Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D positiveInteger
P
M [1:999]
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PURCHASE_RETAIL_ID Restriction of xs:boolean
Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:
0 = EK-Preis
1 = VK-Preis
In Abhängigkeit der Preis-ID (Element PRICE_ID (Pfad1)) wird der Preis wie folgt definiert:

Preis-ID = 1 (Preis), dann wird der Wert aus dem Element ITEM_PRICE (Pfad2) verwendet.

Preis-ID = 2 (Identnummer), dann wird der Preis aus dem Element IDENT_NUMBER/PRICE (Pfad3), dem Element ITEM_PRICE/PRICE_MINIMUM_BASIC (Pfad2) oder dem Element ADDITIONAL_PRICE (Pfad5) verwendet.

Preis_ID = 3 (Verrechnungspunkt), dann wird der Wert aus aus den Elementen ITEM_PRICE (Pfad2) oder PRICE_MINIMUM_BASIC multipliziert mit dem Verrechnungsfaktor aus dem Element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR verwendet.

Aufgrund des Schlüssels kann innerhalb einer Serie nur eine Preisstellung (Kombination der Elemente VAT (Pfad4) und PURCHASE_RETAIL_ID (Pfad4)) angegeben werden.
Werden in einer Datei sowohl EK- wie auch VK-Preise aufgeführt, so dürfen bei Typen mit EK-Preisen nicht die gleichen Kalkulationsgruppen (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) wie bei Typen mit VK-Preisen vergeben werden.
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Elementpfade
Pfad1: CATALOG/CATALOG_IDENTIFICATION/
Pfad2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
Pfad3: PRICE_DEFINITION/IDENT_NUMBERS
Pfad4: CATALOG/CATALOG_IDENTIFICATION
Pfad5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP 		D boolean
P
M
RESTRICTIONS optional
Dieses Element referenziert Prüfverfahren, die für die Serie angewendet werden (Serien-spezifische Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Sequence
RESTRICTION_REF 0..∞
Dieses Element referenziert ein Prüfverfahren, das für die Serie angewendet wird (Serien-spezifisches Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Serien-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SUGGESTIONS optional
Dieses Element referenziert Vorbelegungen, die für die Serie angewendet werden.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.
Sequence
SUGGESTION_REF 0..∞
Dieses Element referenziert eine Vorbelegung, die für die Serie angewendet wird.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.
SEQUENCE required Restriction of xs:nonNegativeInteger

Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Vorbelegungen bei der Ersterfassung einer Planung vorgeschlagen werden.

Die Nummerierung (SEQUENCE) steuert die Prioritäten

 D nonNegativeInteger
P
M [1:99999]
SUGGESTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut wird eine Vorbelegungen referenziert. D nonNegativeInteger
P
M [0:99999]
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:999]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Die Elemente OLD_SERIA_NO (Pfad 1) und OLD_TYPE_NO (Pfad 1) dürfen nur verwendet werden, wenn der dort angegebene Artikel in allen geometrischen Daten identisch dem aktuellen Artikel ist.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Maße B, H und T dieses E-Gerätes im Element PARAMETERS (Pfad 3) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Der Code drückt unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

In diesem Attribut wird das Nettogewicht angegeben.

Dabei drückt der Code im vorhergehenden Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisvariantengruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
CALC_GROUP_REF optional
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
EXCHANGE_ID_REF optional
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID referenziert Blockartikel.
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad11/PRICE_TYPE definiert.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_TYPES
RESTRICTIONS optional
In diesem Element werden artikelspezifische Prüfverfahren zugeordnet.

Es dürfen nur Prüfverfahren referenziert werden, deren Variantenarten in der Variantenfamilie des Artikels enthalten sind.

Wenn ein Artikel Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Artikelspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Artikel zugeordnetes Prüfverfahren.
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden. Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
OPERATION_ITEM optional

Durch dieses Element ist es möglich, eine Verknüpfung zwischen Artikeln und beispielsweise für die Artikel gültige Sonderanfertigungsarten, Gehrungszuschläge, Sichtseiten oder Ausklingungen zu definieren. Die Art der Verknüpfung wird über die Elemente ITEM_REF/SCOPE (Pfad 1) und CLASS (Pfad 1) beschrieben.

Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.

Folgende beispielartige Möglichkeiten können mit diesem Element abgebildet werden:

- Kranz, Licht- oder Sockelleisten Gehrungszuschläge zuweisen

- Artikeln zugehörige Sichtseiten zuweisen (Ausführungsabhängig/-unabhängig)

- Kranz, Licht- oder Sockelleisten zugehörige Formstücke, Retouren oder Übergänge zuweisen

- Sockelleisten die zugehörigen seitlichen Sockel zuweisen

- Arbeitsplatten die zugehörigen Ausschnitte, Ausklingungen oder Nut- und Federverbindungen zuweisen

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenkürzungen zugewiesen werden

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenerweiterungen zugewiesen werden

- Artikeln können Abweichungen von der Standardsockelhöhe zugewiesen werden.

Werden Artikel in diesem Element Sonderanfertigungsarten zugewiesen, so sind nur die zugeordneten gültig, werden keine zugeordnet, so sind alle Sonderanfertigungen an den Artikeln erlaubt.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/

HINGE Restriction of xs:string

Dieses Element wird verwendet, um die Informationen über den Türanschlag des Artikels zu hinterlegen. Es werden keine geometrischen Informationen der Grundform des Artikels gesteuert. Hierzu wird das Feld CONSTRUCTION_ID verwendet.

Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.

Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID => das Element HINGE muss mit dem Wert "N" gefüllt werden.

Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) der Wert "J" enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element wird die äquivalente Katalogseite des Artikels angegeben. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall sollte die erste Seitennummer auf der der Artikel/ die Type auftaucht, verwendet werden. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

In diesem Element kann die äquivalente Katalogseite des Artikels in dem als .pdf-Datei abgelegten Kataloges angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gespeicherten Katalogs.

In dem Element DETAIL_INFO (auf Katalogebene) ist die URL der .pdf-Datei hinterlegt Da es Artikel gibt, die auf mehreren Seiten im Katalog aufgeführt sind, ist sicher zu stellen, dass die Angabe für die .pdf-Datei mit der 40-stelligen Katalogseite CATALOG_PAGE übereinstimmt, das heißt, beide Angaben verweisen auf die selbe Seite.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

In dieses Element wird das Gewicht des Artikels [100 g] inklusive Verpackungsmaterial angegeben. (z. B. 50 = 5000 g).
Dabei drückt der Code im Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.
Langteile werden entsprechend des Brutto-Gwichts je Preiseinheit berechnet.

Beispiel:
Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³] des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt, wird in diesem Element die Herstellernummer eingetragen.

Handelt es sich bei diesem Artikel um ein sichtbares Zulieferteil, so müssen entweder die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO oder die Elemente FILE_NAME_TEXTURE_1/2 gefüllt werden.

Die Herstellernummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Herstellernummer im Verkauf nicht öffentlich zu machen. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt (SUBCONTRACTOR_ID muss gefüllt sein), wird in diesem Element die Artikelnummer des Herstellers eingetragen.

Die Artikelnummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Artikelnummer im Verkauf nicht öffentlich zu machen. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist mindestens eines der Elemente FILENAME_TEXTURE_1/2 gefüllt, so ist dieses Element nicht optional. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
Dieses Element dient der Referenzierung auf eine Echtgrafik. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung). 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

Über dieses Element werden die werkseitigen Änderungsmöglichkeiten eines Artikels gesteuert. Die Änderungsmöglichkeiten der Artikel sind abhängig von der Definition seiner Grundformparameter im Element PARAMETERS (Pfad 1).

0 = alle Maßparameter (PARAMETERS (Pfad 1)) sind gesperrt, eine Maßänderung ist nicht möglich;

1 = die Maßparameter (PARAMETERS (Pfad 1)) sind im Rahmen der in SA500 angelegten Daten änderbar. Das zu ändernde Maß muss vom Benutzer abgefragt werden;

2 = alle Maßparameter (PARAMETERS (Pfad 1)) sind änderbar, gesperrte Parameter müssen identische Werte in den Attributen NOMINAL_VALUE (Pfad 1), FROM (Pfad 1) und TO (Pfad 1) haben.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie Dateiname_Textur_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente FILE_NAME_TEXTURE_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden.
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn im Element ITEM (Pfad 1) mindestens ein Element mit dem Element Artikelkennung = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

MODULE_PARTS optional

Falls der entsprechende Artikel ein Varioschrank ist, enthält dieses Element eine Stückliste von Modulelementen, wobei das erste Element ein Basisschrank mit der Position 0 ist und danach von unten nach oben die Modulelemente folgen. Dieses Element darf nicht angegeben werden, wenn der dazu gehörige Artikel kein Varioschrank ist.

Der Varioschrank hat einen festen Preis. Sobald der Varioschrank verändert wird, ergibt sich der neue Preis aus Preis für Basisschrank + Preis für die Module. Dabei entfällt der Varioschrank, der Basisschrank wird Hauptposition und hat alle anderen Modulelemente als Unterposition in der Reihenfolge von unten nach oben.

Die Modulelemente können programm- und ausführungsabhängig sein.

Für Modulelemente können Regeln bezüglich ihrer Höhe innerhalb des Basisschrankes über MODUL_RULE_SETS festgelegt werden. Dabei wird die global definierte Modulregel referenziert.

Dem Basisschrank kann solch eine Regel über MODULE_RULE_SET_REF zugeordnet werden.

Sequence
MODULE_PART 1..∞

Dieses Element entspricht einem Teil der Stückliste von Modulelementen eines Varioschrankes. Die Elemente müssen in ihrer Reihenfolge von unten nach oben angegeben werden. Die Position 0 (PART_SEQUENTIAL_NO) ist der leere Basisschrank (Schrank mit Typ-Art 17). Danach folgen von unten nach oben die Modulelemente (Schränke mit Typ-Schlüssel 10). Der Anschlag des Basisschrankes ist identisch zu Anschlag des Varioschrankes.

ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT

Dieses Element enthält Kurztexte.

Der Kurztext darf maximal drei Zeilen lang sein und muss mit einem den Artikel näher beschreibenden Text gefüllt werden. Der Kurztext muss alleinstehend auf Kundenformularen druckbar sein. Dieser Text muss einen endverbraucherorientierten Inhalt haben. Der Kurztext muss immer vorhanden sein. Die letzte Zeile eines Kurztextes darf am Zeilenende keine Trennzeichen (z. B. – oder /) enthalten.

FULL_TEXT optional languagetexte Complex Type

Der Volltext ergänzt den Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten " der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
FRONT_DIVISIONS optional
In diesem Element werden die möglichen Frontaufteilungen für einen Artikel definiert.
Die Frontaufteilungen können in Abhängigkeit des Programms unterschiedlich sein oder der Artikel hat in Abhängigkeit von Einbaugeräten unterschiedliche Frontaufteilungen.

Frontaufteilungen, die in mehrere Programme gleich sind, können in Frontgruppen zusammengefasst werden. Die Frontgruppen werden dann von den Programmen referenziert.

Die Frontaufteilungen beziehen sich auf die linke Bauweise. Ist der Artikel auch in rechter Bauweise vorhanden, so wird die Frontaufteilung von der Planungssoftware gespiegelt.
Sequence
FRONT_GROUP 1..99
In diesem Element werden die Frontaufteilungen definiert und zu einer Frontgruppe zusammengefasst.
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Artikel eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Frontausprägungen, die mit diesem Element zugeordnet werden, sind programmunabhängig.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Durch dieses Feld wird eine Beziehung zwischen der im Datensatz definierten Variante und einer Frontausprägung definiert. D positiveInteger
P
M
Choice optional
MODULE_RULE_SET_REF optional
Mit diesem Element referenziert der Artikel eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS. Nur Modulschränke (Typenschlüsselart = 17) können an dieser Stelle ein Modulregelset referenzieren. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D positiveInteger
P
M
MODULE_RULE_SETS optional
Dieses Element enthält die Modulregelwerke für Modulelemente. Ist der Artikel ein Modulelement (Typenschlüssel = 10), dann werden hier die Regeln für die Verplanung des Moduls hinterlegt. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden
Sequence
MODULE_RULE_SET 1..∞
In diesem Element wird dem Modulelement ein Set von Regeln zugewiesen. Jedes Set von Regeln referenziert über die MODULE_RULE_SET_NO das zugehörige Umbaumodul. Dadurch ist es möglich einem Artikel für verschiedene Umbaumodule unterschiedliche Regelwerke mitzugeben.
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
RESTRICTIONS optional
In diesem Element werden die Prüfverfahren einer Produktgruppe zusammengefasst.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, der Produktgruppe zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]

DEFAULT_OPTION_GROUPS optional
In diesem Element werden Standard-Vorbelegungen von Programmvarianten als Vorschlag und Entscheidungshilfe für den Anwender definiert. Die vorgeschlagenen Kombinationen müssen kompatibel zu den Prüfverfahren sein.
Sequence
DEFAULT_OPTION_GROUP 1..∞
In diesem Element wird ein Standardvorschlag definiert.
Jede Variantenart darf je DEFAULT_OPTION_GROUP nur einmal referenziert werden.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
In diesem Attribut wird eine numerischer Wert zur Identifizierung der Standardgruppe angelegt. D positiveInteger
P
M [1:999999999]
Sequence
DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
In diesem Element wird ein freier Name für einen Standardvorschlag angegeben. Der Name kann beispielsweise für die Auswahl eines Standardvorschlages vom Benutzer des Planungssystems verwendet werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FILE_NAME optional Restriction of xs:string
In diesem Element wird der Dateiname eines JPEG-Bildes angegeben, dass ein beispielartiges Bild des Standardvorschlages darstellt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
OPTION_REF 1..∞
In diesem Element werden die Varianten referenziert, die zu einem Standardvorschlag zusammengestellt werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart der referenzierten Variante angegeben. D noNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
In diesem Attribut wird die Variante referenziert, die dem Standardvorschlag zugeordnet wird. D string
P
M [1:5]
DETAIL_INFOS optional
Dieses Element dient der Angabe von Bildern unterhalb des Standardvorschlages.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks zur Serie hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:99]
Bemerkung

Quelle
<xs:element name="SERIE" maxOccurs="100" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES_NAME">
        <xs:annotation>
          <xs:documentation>200--3--Serienname</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>200--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PURCHASE_RETAIL_ID">
        <xs:annotation>
          <xs:documentation>200--5--EK_VK_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUGGESTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SUGGESTION_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SUGGESTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRODUCT_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEMS">
                    <xs:annotation>
                      <xs:documentation>400--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECO_MOBILIER" minOccurs="0">
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[0-9]{11}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="NET_WEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                <xs:annotation>
                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence minOccurs="0">
                                    <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>450/470--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PRICE_FIELD">
                                            <xs:annotation>
                                              <xs:documentation>450--4--Preisfeld</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="250" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE">
                                            <xs:annotation>
                                              <xs:documentation>450--5--Preis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:integer">
                                                <xs:minInclusive value="-99999999" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:boolean" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>470--4--Preis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:integer">
                                                <xs:minInclusive value="-99999999" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_TYPE_REF">
                                <xs:annotation>
                                  <xs:documentation>400/407--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="PRICE_TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400/407--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CALC_GROUP_REF">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="CALC_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="10" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PRICE_FEATURE_GROUP_REF">
                                      <xs:annotation>
                                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>460--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PRICE_FIELD">
                                                  <xs:annotation>
                                                    <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="250" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PRICE">
                                                  <xs:annotation>
                                                    <xs:documentation>460--5--Preis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:integer">
                                                      <xs:minInclusive value="-99999999" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CALC_GROUP_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="CALC_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="10" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[0-9]|[1-8][0-9]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="PRICE_TYPE_REF">
                                      <xs:annotation>
                                        <xs:documentation>407--5--Preisart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="PRICE_TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>407--5--Preisart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="RESTRICTIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>409--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>409--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="RESTRICTION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>409--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>409--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:maxInclusive value="99999" />
                                              <xs:minInclusive value="1" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>406--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                              <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>120--0--NEW</xs:documentation>
                                                        <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                      <xs:annotation>
                                                        <xs:documentation>406--7--Anzahl</xs:documentation>
                                                        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SEQUENCE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>Version 2.4.1</xs:documentation>
                                                        <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:maxInclusive value="99999" />
                                                          <xs:minInclusive value="1" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SET_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="9" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>120--0--NEW</xs:documentation>
                                                        <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                      <xs:annotation>
                                                        <xs:documentation>406--7--Anzahl</xs:documentation>
                                                        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SEQUENCE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>Version 2.4.1</xs:documentation>
                                                        <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:maxInclusive value="99999" />
                                                          <xs:minInclusive value="1" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SET_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="9" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPERATION_ITEM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SCOPE" maxOccurs="5">
                                            <xs:annotation>
                                              <xs:documentation>411--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>411--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="CLASS">
                                                        <xs:annotation>
                                                          <xs:documentation>411--7--Art</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="21" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>411--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>411--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[LNR]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="COVER" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--9--Abdeckung</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="3" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="VALUE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--10--Wert</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="VALUE_MIN" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                                          <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="VALUE_MAX" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                                          <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SCOPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>411--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="5" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HINGE">
                                <xs:annotation>
                                  <xs:documentation>400--4--Anschlag</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[BEJLMNR]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="EDP_NUMBER" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="EAN_NUMBER" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_IDENTIFICATION">
                                <xs:annotation>
                                  <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[BEKSMZVPNOG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CATALOG_PAGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="40" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                                  <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                                  <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VAT_ID_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="VAT_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="WEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VOLUME" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--21--Volumen</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CONSTRUCTION_ID">
                                <xs:annotation>
                                  <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[JLNRAE]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OLD_SERIE_NO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="99" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OLD_TYPE_NO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--27--Type_Alt</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MASKING" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--30--Maskierung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="RANGE_DEPENDENT">
                                <xs:annotation>
                                  <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="2" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BASIC_PROFILE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:choice>
                                      <xs:element name="CARCASE_BASIC_SHAPE">
                                        <xs:annotation>
                                          <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>400--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType mixed="true">
                                                <xs:sequence>
                                                  <xs:element name="OPTION_REF">
                                                    <xs:annotation>
                                                      <xs:documentation>430--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:attribute name="FEATURE_NO" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>430--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="OPTION_KEY" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>430--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:minLength value="1" />
                                                            <xs:maxLength value="5" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                                <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>400--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[\S ]{1,5}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                            <xs:element name="BASIC_SHAPE_PARAMETERS">
                                              <xs:annotation>
                                                <xs:documentation>500--1--Satzart</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                    <xs:annotation>
                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--Parameter</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>500--5--Nennwert</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="BASIC_SHAPE_FROM">
                                                        <xs:annotation>
                                                          <xs:documentation>500--6--Von</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="BASIC_SHAPE_TO">
                                                        <xs:annotation>
                                                          <xs:documentation>500--7--Bis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                        <xs:annotation>
                                                          <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                          <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                        <xs:annotation>
                                          <xs:documentation>400--32--Massbild</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:minLength value="1" />
                                                  <xs:maxLength value="240" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:element>
                                            <xs:element name="DIMENSIONAL_PARAMETERS">
                                              <xs:annotation>
                                                <xs:documentation>500--1--Satzart</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                    <xs:annotation>
                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="DIMENSIONAL_FROM">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="DIMENSIONAL_TO">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                      <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:decimal">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:attribute>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                          <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>400--32--Massbild</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="20" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="BLOCK_PARTS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BLOCK_SEQUENTIAL_NO">
                                            <xs:annotation>
                                              <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="5" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="HINGE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--6--Anschlag</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[BEJLMNR]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="EXCHANGE_CONDITION">
                                            <xs:annotation>
                                              <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="2" />
                                                <xs:maxInclusive value="3" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="STATUS">
                                            <xs:annotation>
                                              <xs:documentation>401--8--Status</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[ABELSZ]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[JLNRAE]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="MODULE_PARTS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="MODULE_PART" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PART_SEQUENTIAL_NO">
                                            <xs:annotation>
                                              <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:maxInclusive value="999" />
                                                <xs:minInclusive value="0" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SHORT_TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT_LINE" maxOccurs="3">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT">
                                                        <xs:annotation>
                                                          <xs:documentation>410--6--Textzeile</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[\S ]{1,30}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger" />
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:language">
                                                    <xs:pattern value="[A-Z]{2}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TYPE_KEY">
                                <xs:annotation>
                                  <xs:documentation>445--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_TYPE">
                                      <xs:annotation>
                                        <xs:documentation>445--4--TS_Typ</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_CLASS">
                                      <xs:annotation>
                                        <xs:documentation>445--5--TS_Art</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                      <xs:annotation>
                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                    <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="9999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                          <xs:annotation>
                                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TK_MATERIAL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--21--TS_Material</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-2]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_SHAPE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--22--TS_Form</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-2]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS">
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS_NO">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:totalDigits value="8" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FRONT_DIVISIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>510--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FRONT_GROUP" maxOccurs="99">
                                      <xs:annotation>
                                        <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="FRONT_DIVISION_DEF">
                                                  <xs:annotation>
                                                    <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="250" />
                                                      <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="15" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="FRONT_CELL_NO">
                                                        <xs:annotation>
                                                          <xs:documentation>540--6--Zellennummer</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="FRONT_TYPE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--7--Fronttyp</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="900" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="4" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="4" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PARAMETER_1" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--12--Parameter_1</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PARAMETER_2" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--13--Parameter_2</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="9999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="9999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:element>
                                                      <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:element>
                                                      <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:element>
                                                      <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                      </xs:element>
                                                      <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="4" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="UPPER_JOIN" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[VLSG]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="LOWER_JOIN" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[VLSG]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="LEFT_JOIN" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[VLSG]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="RIGHT_JOIN" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[VLSG]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>540--0--NEW</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="2" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="FRONT_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:choice minOccurs="0">
                                <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="MODULE_RULES">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:complexType>
                                                      <xs:sequence>
                                                        <xs:element name="MODULE_POSITION">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:string">
                                                              <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                                              <xs:enumeration value="LINE_BOTTOM" />
                                                              <xs:enumeration value="LINE_TOP" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:element>
                                                        <xs:element name="MAX_VALUE" minOccurs="0">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="0" />
                                                              <xs:maxInclusive value="99999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:element>
                                                        <xs:element name="MIN_VALUE" minOccurs="0">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="0" />
                                                              <xs:maxInclusive value="99999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:element>
                                                      </xs:sequence>
                                                    </xs:complexType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                            <xs:element name="MODULE_RULE_SET_REF">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PROPERTIES" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="PROPERTY_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="VALUE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESTRICTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="RESTRICTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="99999" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DEFAULT_OPTION_GROUPS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>295--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DEFAULT_OPTION_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30">
                    <xs:annotation>
                      <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="FILE_NAME" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>296--6--Dateiname</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OPTION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>295--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>295--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>295--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
                      <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_CLASS_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : FEATURE_CLASS_REF Element
Beschreibung
Mit diesem Element wird eine Variantenfamilie referenziert die der Serie zugeordnet werden soll.
Hierdurch können die in einer Serie gültigen Variantenarten zugeordnet werden.
Die hier zugeordnete Variantenfamilie stellt eine Obermenge der Variantenarten dar, die sich aus der Summe aller Variantenarten der Variantenfamilien aller Programme und aller Artikel in dieser Serie ergibt. Daher sind die einer Serie zugeordneten Variantenarten für eine Bestellung nicht ZWINGEND anzugeben. Für eine Bestellung sind aber die Summe der Varianten eines Artikels in Summe mit denen des Programms in dem der Artikel bestellt wird anzugeben.
Die einer Serie zugeordneten Variantenarten werden dem Anwender bei der Eingabe der Kopfvarianten zur Eingabe angeboten.
Namensraum (none)
Diagramm
FEATURE_CLASS_REF Element
Overview
FEATURE_CLASS_REF optional
Mit diesem Element wird eine Variantenfamilie referenziert die der Serie zugeordnet werden soll.
Hierdurch können die in einer Serie gültigen Variantenarten zugeordnet werden.
Die hier zugeordnete Variantenfamilie stellt eine Obermenge der Variantenarten dar, die sich aus der Summe aller Variantenarten der Variantenfamilien aller Programme und aller Artikel in dieser Serie ergibt. Daher sind die einer Serie zugeordneten Variantenarten für eine Bestellung nicht ZWINGEND anzugeben. Für eine Bestellung sind aber die Summe der Varianten eines Artikels in Summe mit denen des Programms in dem der Artikel bestellt wird anzugeben.
Die einer Serie zugeordneten Variantenarten werden dem Anwender bei der Eingabe der Kopfvarianten zur Eingabe angeboten.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Variantenfamilie. Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D positiveInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
Dieses Attribut referenziert eine Variantenfamilie. Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D positiveInteger
P
M [1:999]
Bemerkung

Quelle
<xs:element name="FEATURE_CLASS_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--6--Var_Familien_Nr</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIES_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : SERIES_NAME Element
Beschreibung
Dieses Element gibt den Seriennamen an.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence SERIES_NAME Element
Overview
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Bemerkung

Quelle
<xs:element name="SERIES_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--3--Serienname</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>200--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Bemerkung

Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>200--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element : TEXT_LINE Element
Beschreibung
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet den Text.
Namensraum (none)
Diagramm
FULL_TEXT Element TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Bemerkung

Quelle
<xs:element name="TEXT_LINE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Bemerkung

Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FULL_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : FULL_TEXT Element
Beschreibung
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
FULL_TEXT Element
Overview
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="FULL_TEXT" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PURCHASE_RETAIL_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : PURCHASE_RETAIL_ID Element
Beschreibung
Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:
0 = EK-Preis
1 = VK-Preis
In Abhängigkeit der Preis-ID (Element PRICE_ID (Pfad1)) wird der Preis wie folgt definiert:

Preis-ID = 1 (Preis), dann wird der Wert aus dem Element ITEM_PRICE (Pfad2) verwendet.

Preis-ID = 2 (Identnummer), dann wird der Preis aus dem Element IDENT_NUMBER/PRICE (Pfad3), dem Element ITEM_PRICE/PRICE_MINIMUM_BASIC (Pfad2) oder dem Element ADDITIONAL_PRICE (Pfad5) verwendet.

Preis_ID = 3 (Verrechnungspunkt), dann wird der Wert aus aus den Elementen ITEM_PRICE (Pfad2) oder PRICE_MINIMUM_BASIC multipliziert mit dem Verrechnungsfaktor aus dem Element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR verwendet.

Aufgrund des Schlüssels kann innerhalb einer Serie nur eine Preisstellung (Kombination der Elemente VAT (Pfad4) und PURCHASE_RETAIL_ID (Pfad4)) angegeben werden.
Werden in einer Datei sowohl EK- wie auch VK-Preise aufgeführt, so dürfen bei Typen mit EK-Preisen nicht die gleichen Kalkulationsgruppen (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) wie bei Typen mit VK-Preisen vergeben werden.
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Elementpfade
Pfad1: CATALOG/CATALOG_IDENTIFICATION/
Pfad2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
Pfad3: PRICE_DEFINITION/IDENT_NUMBERS
Pfad4: CATALOG/CATALOG_IDENTIFICATION
Pfad5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
PURCHASE_RETAIL_ID Element
Overview
PURCHASE_RETAIL_ID Restriction of xs:boolean
Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:
0 = EK-Preis
1 = VK-Preis
In Abhängigkeit der Preis-ID (Element PRICE_ID (Pfad1)) wird der Preis wie folgt definiert:

Preis-ID = 1 (Preis), dann wird der Wert aus dem Element ITEM_PRICE (Pfad2) verwendet.

Preis-ID = 2 (Identnummer), dann wird der Preis aus dem Element IDENT_NUMBER/PRICE (Pfad3), dem Element ITEM_PRICE/PRICE_MINIMUM_BASIC (Pfad2) oder dem Element ADDITIONAL_PRICE (Pfad5) verwendet.

Preis_ID = 3 (Verrechnungspunkt), dann wird der Wert aus aus den Elementen ITEM_PRICE (Pfad2) oder PRICE_MINIMUM_BASIC multipliziert mit dem Verrechnungsfaktor aus dem Element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR verwendet.

Aufgrund des Schlüssels kann innerhalb einer Serie nur eine Preisstellung (Kombination der Elemente VAT (Pfad4) und PURCHASE_RETAIL_ID (Pfad4)) angegeben werden.
Werden in einer Datei sowohl EK- wie auch VK-Preise aufgeführt, so dürfen bei Typen mit EK-Preisen nicht die gleichen Kalkulationsgruppen (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) wie bei Typen mit VK-Preisen vergeben werden.
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Elementpfade
Pfad1: CATALOG/CATALOG_IDENTIFICATION/
Pfad2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
Pfad3: PRICE_DEFINITION/IDENT_NUMBERS
Pfad4: CATALOG/CATALOG_IDENTIFICATION
Pfad5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP 		D boolean
P
M
Bemerkung

Quelle
<xs:element name="PURCHASE_RETAIL_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--5--EK_VK_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : RESTRICTIONS Element
Beschreibung
Dieses Element referenziert Prüfverfahren, die für die Serie angewendet werden (Serien-spezifische Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Namensraum (none)
Diagramm
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
Dieses Element referenziert Prüfverfahren, die für die Serie angewendet werden (Serien-spezifische Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Sequence
RESTRICTION_REF 0..∞
Dieses Element referenziert ein Prüfverfahren, das für die Serie angewendet wird (Serien-spezifisches Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Serien-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
Bemerkung

Quelle
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > RESTRICTIONS Element : RESTRICTION_REF Element
Beschreibung
Dieses Element referenziert ein Prüfverfahren, das für die Serie angewendet wird (Serien-spezifisches Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Namensraum (none)
Diagramm
RESTRICTION_REF Element
Overview
RESTRICTION_REF 0..∞
Dieses Element referenziert ein Prüfverfahren, das für die Serie angewendet wird (Serien-spezifisches Prüfverfahren).

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Serien-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE Restriction of xs:nonNegativeInteger required
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
Durch dieses Attribut werden Serien-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
Bemerkung

Quelle
<xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
RESTRICTIONS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUGGESTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : SUGGESTIONS Element
Beschreibung
Dieses Element referenziert Vorbelegungen, die für die Serie angewendet werden.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.
Namensraum (none)
Diagramm
SUGGESTION_REF Element Sequence SUGGESTIONS Element
Overview
SUGGESTIONS optional
Dieses Element referenziert Vorbelegungen, die für die Serie angewendet werden.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.
Sequence
SUGGESTION_REF 0..∞
Dieses Element referenziert eine Vorbelegung, die für die Serie angewendet wird.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.
SEQUENCE required Restriction of xs:nonNegativeInteger

Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Vorbelegungen bei der Ersterfassung einer Planung vorgeschlagen werden.

Die Nummerierung (SEQUENCE) steuert die Prioritäten

 D nonNegativeInteger
P
M [1:99999]
SUGGESTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut wird eine Vorbelegungen referenziert. D nonNegativeInteger
P
M [0:99999]
Quelle
<xs:element name="SUGGESTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SUGGESTION_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SUGGESTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUGGESTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SUGGESTIONS Element : SUGGESTION_REF Element
Beschreibung
Dieses Element referenziert eine Vorbelegung, die für die Serie angewendet wird.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.
Namensraum (none)
Diagramm
SUGGESTION_REF Element
Overview
SUGGESTION_REF 0..∞
Dieses Element referenziert eine Vorbelegung, die für die Serie angewendet wird.

Wird an der Serie zusätzlich ein Standardvorschlag (DEFAULT_OPTION_GROUPS) angegeben, wirkt dieser vorrangig bei der Ersterfassung einer Planung.
SEQUENCE required Restriction of xs:nonNegativeInteger

Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Vorbelegungen bei der Ersterfassung einer Planung vorgeschlagen werden.

Die Nummerierung (SEQUENCE) steuert die Prioritäten

 D nonNegativeInteger
P
M [1:99999]
SUGGESTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut wird eine Vorbelegungen referenziert. D nonNegativeInteger
P
M [0:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE Restriction of xs:nonNegativeInteger required

Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Vorbelegungen bei der Ersterfassung einer Planung vorgeschlagen werden.

Die Nummerierung (SEQUENCE) steuert die Prioritäten

 D nonNegativeInteger
P
M [1:99999]
SUGGESTION_NO Restriction of xs:nonNegativeInteger required
Durch dieses Attribut wird eine Vorbelegungen referenziert. D nonNegativeInteger
P
M [0:99999]
Quelle
<xs:element name="SUGGESTION_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SUGGESTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SUGGESTIONS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUPS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : PRODUCT_GROUPS Element
Beschreibung
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).
Namensraum (none)
Diagramm
PRODUCT_GROUP Element Sequence PRODUCT_GROUPS Element
Overview
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:999]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Die Elemente OLD_SERIA_NO (Pfad 1) und OLD_TYPE_NO (Pfad 1) dürfen nur verwendet werden, wenn der dort angegebene Artikel in allen geometrischen Daten identisch dem aktuellen Artikel ist.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Maße B, H und T dieses E-Gerätes im Element PARAMETERS (Pfad 3) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Der Code drückt unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

In diesem Attribut wird das Nettogewicht angegeben.

Dabei drückt der Code im vorhergehenden Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisvariantengruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf das Preisfeld. D positiveInteger
P
M [1:250]

PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
Über dieses Element wird definiert, dass es sich bei dem angegebenen Preis um einen Preis auf
Anfrage handelt. Das Element wird im Kombination mit dem Element PRICE_CALC_METHOD ausgewertet.

Bedeutung der Werte:
1/true = Preis auf Anfrage.

Wenn das Element angelegt wird, ist nur true erlaubt.

Das Element darf nur angelegt werden, wenn der Artikel in mehreren Preisgruppen vorhanden ist.

Definition "Preis auf Anfrage" für eine Preisgruppe des Artikels:
Das Element ITEM_PRICE wird mit der entsprechenden Preisgruppe angelegt. Das Element
PRICE_ON_REQUEST wird mit dem Wert true angelegt. Die Werte im Element PRICE haben dann folgende Bedeutung:
- der Wert 0 hat keine Bedeutung,
- ein Wert ungleich 0 stellt einen Richtwert für den Preis dar, der verbindliche Preis
muss dennoch beim Hersteller angefragt werden.

Definition "Preis auf Anfrage" für den gesamten Artikel:
Element ITEM_PRICE wird nicht angelegt. In dem Element PRICE_FEATURE_GROUP wird über das Attribut PRICE_CALC_METHOD (P1) definiert, dass die Preise für den Artikel beim Hersteller erfragt werden müssen. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 € = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (P3/PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (P5/BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (P5/PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (P3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (P1/PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Mehrpreisgruppe referenziert. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
CALC_GROUP_REF optional
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination „00“ ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers. 		D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID referenziert Blockartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Der Wert 0 darf nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad11/PRICE_TYPE definiert.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
RESTRICTIONS optional
In diesem Element werden artikelspezifische Prüfverfahren zugeordnet.

Es dürfen nur Prüfverfahren referenziert werden, deren Variantenarten in der Variantenfamilie des Artikels enthalten sind.

Wenn ein Artikel Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Artikelspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Artikel zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden. Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
OPERATION_ITEM optional

Durch dieses Element ist es möglich, eine Verknüpfung zwischen Artikeln und beispielsweise für die Artikel gültige Sonderanfertigungsarten, Gehrungszuschläge, Sichtseiten oder Ausklingungen zu definieren. Die Art der Verknüpfung wird über die Elemente ITEM_REF/SCOPE (Pfad 1) und CLASS (Pfad 1) beschrieben.

Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.

Folgende beispielartige Möglichkeiten können mit diesem Element abgebildet werden:

- Kranz, Licht- oder Sockelleisten Gehrungszuschläge zuweisen

- Artikeln zugehörige Sichtseiten zuweisen (Ausführungsabhängig/-unabhängig)

- Kranz, Licht- oder Sockelleisten zugehörige Formstücke, Retouren oder Übergänge zuweisen

- Sockelleisten die zugehörigen seitlichen Sockel zuweisen

- Arbeitsplatten die zugehörigen Ausschnitte, Ausklingungen oder Nut- und Federverbindungen zuweisen

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenkürzungen zugewiesen werden

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenerweiterungen zugewiesen werden

- Artikeln können Abweichungen von der Standardsockelhöhe zugewiesen werden.

Werden Artikel in diesem Element Sonderanfertigungsarten zugewiesen, so sind nur die zugeordneten gültig, werden keine zugeordnet, so sind alle Sonderanfertigungen an den Artikeln erlaubt.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/

Sequence
SCOPE 1..5
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden.
HINGE Restriction of xs:string

Dieses Element wird verwendet, um die Informationen über den Türanschlag des Artikels zu hinterlegen. Es werden keine geometrischen Informationen der Grundform des Artikels gesteuert. Hierzu wird das Feld CONSTRUCTION_ID verwendet.

Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.

Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID => das Element HINGE muss mit dem Wert "N" gefüllt werden.

Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) der Wert "J" enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element wird die äquivalente Katalogseite des Artikels angegeben. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall sollte die erste Seitennummer auf der der Artikel/ die Type auftaucht, verwendet werden. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

In diesem Element kann die äquivalente Katalogseite des Artikels in dem als .pdf-Datei abgelegten Kataloges angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gespeicherten Katalogs.

In dem Element DETAIL_INFO (auf Katalogebene) ist die URL der .pdf-Datei hinterlegt Da es Artikel gibt, die auf mehreren Seiten im Katalog aufgeführt sind, ist sicher zu stellen, dass die Angabe für die .pdf-Datei mit der 40-stelligen Katalogseite CATALOG_PAGE übereinstimmt, das heißt, beide Angaben verweisen auf die selbe Seite.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

In dieses Element wird das Gewicht des Artikels [100 g] inklusive Verpackungsmaterial angegeben. (z. B. 50 = 5000 g).
Dabei drückt der Code im Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.
Langteile werden entsprechend des Brutto-Gwichts je Preiseinheit berechnet.

Beispiel:
Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³] des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt, wird in diesem Element die Herstellernummer eingetragen.

Handelt es sich bei diesem Artikel um ein sichtbares Zulieferteil, so müssen entweder die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO oder die Elemente FILE_NAME_TEXTURE_1/2 gefüllt werden.

Die Herstellernummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Herstellernummer im Verkauf nicht öffentlich zu machen. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt (SUBCONTRACTOR_ID muss gefüllt sein), wird in diesem Element die Artikelnummer des Herstellers eingetragen.

Die Artikelnummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Artikelnummer im Verkauf nicht öffentlich zu machen. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist mindestens eines der Elemente FILENAME_TEXTURE_1/2 gefüllt, so ist dieses Element nicht optional. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
Dieses Element dient der Referenzierung auf eine Echtgrafik. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung). 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

Über dieses Element werden die werkseitigen Änderungsmöglichkeiten eines Artikels gesteuert. Die Änderungsmöglichkeiten der Artikel sind abhängig von der Definition seiner Grundformparameter im Element PARAMETERS (Pfad 1).

0 = alle Maßparameter (PARAMETERS (Pfad 1)) sind gesperrt, eine Maßänderung ist nicht möglich;

1 = die Maßparameter (PARAMETERS (Pfad 1)) sind im Rahmen der in SA500 angelegten Daten änderbar. Das zu ändernde Maß muss vom Benutzer abgefragt werden;

2 = alle Maßparameter (PARAMETERS (Pfad 1)) sind änderbar, gesperrte Parameter müssen identische Werte in den Attributen NOMINAL_VALUE (Pfad 1), FROM (Pfad 1) und TO (Pfad 1) haben.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie Dateiname_Textur_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente FILE_NAME_TEXTURE_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie FILE_NAME_TEXTURE_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente Dateiname_Textur_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern in angegeben werden.
Nur bei dem Parameter B dürfen die Attrubute FROM (Wert von) und TO (Wert bis) gefüllt werden.
Dieses Element darf nur gefüllt werden, wenn es sich bei dem Artikel um eine Kranz-, Licht- oder Sockelleiste, Arbeitsplatte, Abdeckplatte, Barplatte oder Wandabschlussprofil handelt.
BASIC_SHAPE_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.
Die anzugebenen Daten sind abhängig von den Grundformen und den Abschnitten unterhalb der Grundformen zu entnehmen.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn im Element ITEM (Pfad 1) mindestens ein Element mit dem Element Artikelkennung = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
MODULE_PARTS optional

Falls der entsprechende Artikel ein Varioschrank ist, enthält dieses Element eine Stückliste von Modulelementen, wobei das erste Element ein Basisschrank mit der Position 0 ist und danach von unten nach oben die Modulelemente folgen. Dieses Element darf nicht angegeben werden, wenn der dazu gehörige Artikel kein Varioschrank ist.

Der Varioschrank hat einen festen Preis. Sobald der Varioschrank verändert wird, ergibt sich der neue Preis aus Preis für Basisschrank + Preis für die Module. Dabei entfällt der Varioschrank, der Basisschrank wird Hauptposition und hat alle anderen Modulelemente als Unterposition in der Reihenfolge von unten nach oben.

Die Modulelemente können programm- und ausführungsabhängig sein.

Für Modulelemente können Regeln bezüglich ihrer Höhe innerhalb des Basisschrankes über MODUL_RULE_SETS festgelegt werden. Dabei wird die global definierte Modulregel referenziert.

Dem Basisschrank kann solch eine Regel über MODULE_RULE_SET_REF zugeordnet werden.

Sequence
MODULE_PART 1..∞

Dieses Element entspricht einem Teil der Stückliste von Modulelementen eines Varioschrankes. Die Elemente müssen in ihrer Reihenfolge von unten nach oben angegeben werden. Die Position 0 (PART_SEQUENTIAL_NO) ist der leere Basisschrank (Schrank mit Typ-Art 17). Danach folgen von unten nach oben die Modulelemente (Schränke mit Typ-Schlüssel 10). Der Anschlag des Basisschrankes ist identisch zu Anschlag des Varioschrankes.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels innerhalb des Varioschrankes angegeben. Dabei muss der Basisschrank (Typ_Art 17) den Positionswert 0 beinhalten. Die Modulelemente (Typ-Schlüssel 10) erhalten in der Reihenfolge von unten nach oben weitere Positionsnummern. D nonNegativeInteger
P
M [0:999]
ITEM_REF
In diesem Element werden der Basisschrank (Typ-Art 17) und die einzelnen Modulelemente (Typschlüssel 10) referenziert.
Dabei muss dem Basisschrank die Position (PART_SEQUENTIAL_NO) 0 zugewiesen werden. Die übrigen Modulelemente müssen passend zu dem Attribut PART_SEQUENTIAL_NO in der Reihenfolge von unten nach oben referenziert werden.
HEIGHT_VARIABLE optional xs:boolean
Ist der Wert von diesem Flag auf true(1) gesetzt, bedeutet es, dass das entsprechende Modulelement Veränderungen bei Veränderungen anderer Elemente innerhalb der Liste aufnimmt. Das bedeutet, wird ein anderes Modulelement größer oder kleiner, passt sich das mit HEIGT_VARIABLE true gekennzeichnete Modulelement so an, dass die Gesamthöhe aller Modulelemente innerhalb des Basisschrankes wieder erreicht wird. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
Ein Modulelement kann variabel sein, hat in der Liste aber eine feste Höhe, die bei variablen Maßen in diesem Element angegeben werden muss. D nonNegativeInteger
P
M [1:99999]
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT

Dieses Element enthält Kurztexte.

Der Kurztext darf maximal drei Zeilen lang sein und muss mit einem den Artikel näher beschreibenden Text gefüllt werden. Der Kurztext muss alleinstehend auf Kundenformularen druckbar sein. Dieser Text muss einen endverbraucherorientierten Inhalt haben. Der Kurztext muss immer vorhanden sein. Die letzte Zeile eines Kurztextes darf am Zeilenende keine Trennzeichen (z. B. – oder /) enthalten.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
FULL_TEXT optional languagetexte Complex Type

Der Volltext ergänzt den Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten " der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel " der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.
Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
FRONT_DIVISIONS optional
In diesem Element werden die möglichen Frontaufteilungen für einen Artikel definiert.
Die Frontaufteilungen können in Abhängigkeit des Programms unterschiedlich sein oder der Artikel hat in Abhängigkeit von Einbaugeräten unterschiedliche Frontaufteilungen.

Frontaufteilungen, die in mehrere Programme gleich sind, können in Frontgruppen zusammengefasst werden. Die Frontgruppen werden dann von den Programmen referenziert.

Die Frontaufteilungen beziehen sich auf die linke Bauweise. Ist der Artikel auch in rechter Bauweise vorhanden, so wird die Frontaufteilung von der Planungssoftware gespiegelt.
Sequence
FRONT_GROUP 1..99
In diesem Element werden die Frontaufteilungen definiert und zu einer Frontgruppe zusammengefasst.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein.

Ist die FRONT_GROUP gültig für alle Programme, so wird 0 hinterlegt. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
In diesem Element wird eine Frontaufteilung definiert und die einzelnen Zellen der Frontaufteilung beschrieben.
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Artikel eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Frontausprägungen, die mit diesem Element zugeordnet werden, sind programmunabhängig.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Durch dieses Feld wird eine Beziehung zwischen der im Datensatz definierten Variante und einer Frontausprägung definiert. D positiveInteger
P
M
Choice optional
MODULE_RULE_SET_REF optional
Mit diesem Element referenziert der Artikel eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS. Nur Modulschränke (Typenschlüsselart = 17) können an dieser Stelle ein Modulregelset referenzieren. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D positiveInteger
P
M
MODULE_RULE_SETS optional
Dieses Element enthält die Modulregelwerke für Modulelemente. Ist der Artikel ein Modulelement (Typenschlüssel = 10), dann werden hier die Regeln für die Verplanung des Moduls hinterlegt. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden
Sequence
MODULE_RULE_SET 1..∞
In diesem Element wird dem Modulelement ein Set von Regeln zugewiesen. Jedes Set von Regeln referenziert über die MODULE_RULE_SET_NO das zugehörige Umbaumodul. Dadurch ist es möglich einem Artikel für verschiedene Umbaumodule unterschiedliche Regelwerke mitzugeben.
Sequence
MODULE_RULES
Ein Set von Regeln für den Einbau des Moduls in einen Modulschrank.
MODULE_RULE_SET_REF
Mit diesem Element referenziert das Regelwerk eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS und die Umbauschränke, für die das betreffende Regelwerk gilt.
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
RESTRICTIONS optional
In diesem Element werden die Prüfverfahren einer Produktgruppe zusammengefasst.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, der Produktgruppe zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]

Bemerkung

Quelle
<xs:element name="PRODUCT_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEMS">
              <xs:annotation>
                <xs:documentation>400--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECO_MOBILIER" minOccurs="0">
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[0-9]{11}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="NET_WEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                          <xs:annotation>
                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence minOccurs="0">
                              <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>450/470--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PRICE_FIELD">
                                      <xs:annotation>
                                        <xs:documentation>450--4--Preisfeld</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="250" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE">
                                      <xs:annotation>
                                        <xs:documentation>450--5--Preis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:integer">
                                          <xs:minInclusive value="-99999999" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>470--4--Preis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:integer">
                                          <xs:minInclusive value="-99999999" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_REF">
                          <xs:annotation>
                            <xs:documentation>400/407--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="PRICE_TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400/407--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CALC_GROUP_REF">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="CALC_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="10" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_FEATURE_GROUP_REF">
                                <xs:annotation>
                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>460--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PRICE_FIELD">
                                            <xs:annotation>
                                              <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="250" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE">
                                            <xs:annotation>
                                              <xs:documentation>460--5--Preis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:integer">
                                                <xs:minInclusive value="-99999999" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CALC_GROUP_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="CALC_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="10" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[0-9]|[1-8][0-9]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_TYPE_REF">
                                <xs:annotation>
                                  <xs:documentation>407--5--Preisart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="PRICE_TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>407--5--Preisart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESTRICTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>409--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>409--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="RESTRICTION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>409--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>409--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="99999" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>406--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>120--0--NEW</xs:documentation>
                                                  <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                <xs:annotation>
                                                  <xs:documentation>406--7--Anzahl</xs:documentation>
                                                  <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SEQUENCE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>Version 2.4.1</xs:documentation>
                                                  <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:maxInclusive value="99999" />
                                                    <xs:minInclusive value="1" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SET_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="GROUP_TITLE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>120--0--NEW</xs:documentation>
                                                  <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                <xs:annotation>
                                                  <xs:documentation>406--7--Anzahl</xs:documentation>
                                                  <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SEQUENCE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>Version 2.4.1</xs:documentation>
                                                  <xs:documentation>geändert 13.09.2016</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:maxInclusive value="99999" />
                                                    <xs:minInclusive value="1" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SET_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPERATION_ITEM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SCOPE" maxOccurs="5">
                                      <xs:annotation>
                                        <xs:documentation>411--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>411--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="CLASS">
                                                  <xs:annotation>
                                                    <xs:documentation>411--7--Art</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="21" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>411--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>411--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[LNR]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="COVER" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--9--Abdeckung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="3" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="VALUE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--10--Wert</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="VALUE_MIN" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                                    <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="VALUE_MAX" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                                    <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SCOPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>411--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="5" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HINGE">
                          <xs:annotation>
                            <xs:documentation>400--4--Anschlag</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[BEJLMNR]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EDP_NUMBER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EAN_NUMBER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_IDENTIFICATION">
                          <xs:annotation>
                            <xs:documentation>400--14--Artikelkennung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[BEKSMZVPNOG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CATALOG_PAGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="40" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                            <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                            <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VAT_ID_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="VAT_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="WEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--20--Gewicht</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VOLUME" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--21--Volumen</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CONSTRUCTION_ID">
                          <xs:annotation>
                            <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[JLNRAE]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OLD_SERIE_NO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OLD_TYPE_NO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--27--Type_Alt</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MASKING" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--30--Maskierung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="RANGE_DEPENDENT">
                          <xs:annotation>
                            <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="2" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_PROFILE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:choice>
                                <xs:element name="CARCASE_BASIC_SHAPE">
                                  <xs:annotation>
                                    <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>400--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType mixed="true">
                                          <xs:sequence>
                                            <xs:element name="OPTION_REF">
                                              <xs:annotation>
                                                <xs:documentation>430--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:attribute name="FEATURE_NO" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>430--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="OPTION_KEY" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>430--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="5" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                          <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[\S ]{1,5}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="BASIC_SHAPE_PARAMETERS">
                                        <xs:annotation>
                                          <xs:documentation>500--1--Satzart</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                              <xs:annotation>
                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--Parameter</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>500--5--Nennwert</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="BASIC_SHAPE_FROM">
                                                  <xs:annotation>
                                                    <xs:documentation>500--6--Von</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="BASIC_SHAPE_TO">
                                                  <xs:annotation>
                                                    <xs:documentation>500--7--Bis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                  <xs:annotation>
                                                    <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                  <xs:annotation>
                                    <xs:documentation>400--32--Massbild</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:minLength value="1" />
                                            <xs:maxLength value="240" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="DIMENSIONAL_PARAMETERS">
                                        <xs:annotation>
                                          <xs:documentation>500--1--Satzart</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                              <xs:annotation>
                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="DIMENSIONAL_FROM">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="DIMENSIONAL_TO">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                                <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:decimal">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>400--32--Massbild</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="20" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="BLOCK_PARTS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BLOCK_SEQUENTIAL_NO">
                                      <xs:annotation>
                                        <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="5" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="HINGE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--6--Anschlag</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[BEJLMNR]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="EXCHANGE_CONDITION">
                                      <xs:annotation>
                                        <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="2" />
                                          <xs:maxInclusive value="3" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="STATUS">
                                      <xs:annotation>
                                        <xs:documentation>401--8--Status</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[ABELSZ]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[JLNRAE]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="MODULE_PARTS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="MODULE_PART" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PART_SEQUENTIAL_NO">
                                      <xs:annotation>
                                        <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:maxInclusive value="999" />
                                          <xs:minInclusive value="0" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_TEXT">
                          <xs:annotation>
                            <xs:documentation>410--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SHORT_TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT_LINE" maxOccurs="3">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--6--Textzeile</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[\S ]{1,30}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger" />
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:language">
                                              <xs:pattern value="[A-Z]{2}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TYPE_KEY">
                          <xs:annotation>
                            <xs:documentation>445--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_TYPE">
                                <xs:annotation>
                                  <xs:documentation>445--4--TS_Typ</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_CLASS">
                                <xs:annotation>
                                  <xs:documentation>445--5--TS_Art</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                <xs:annotation>
                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TK_MATERIAL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--21--TS_Material</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-2]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_SHAPE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--22--TS_Form</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-2]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CLASSIFICATIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS">
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS_NO">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:totalDigits value="8" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FRONT_DIVISIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>510--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_GROUP" maxOccurs="99">
                                <xs:annotation>
                                  <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="FRONT_DIVISION_DEF">
                                            <xs:annotation>
                                              <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="250" />
                                                <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="FRONT_CELL_NO">
                                                  <xs:annotation>
                                                    <xs:documentation>540--6--Zellennummer</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="FRONT_TYPE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--7--Fronttyp</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="900" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="4" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="4" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PARAMETER_1" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--12--Parameter_1</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PARAMETER_2" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--13--Parameter_2</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="9999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="9999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="4" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="UPPER_JOIN" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[VLSG]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="LOWER_JOIN" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[VLSG]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="LEFT_JOIN" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[VLSG]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="RIGHT_JOIN" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[VLSG]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>540--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="2" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="FRONT_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:choice minOccurs="0">
                          <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="MODULE_RULES">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:complexType>
                                                <xs:sequence>
                                                  <xs:element name="MODULE_POSITION">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                                        <xs:enumeration value="LINE_BOTTOM" />
                                                        <xs:enumeration value="LINE_TOP" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:element>
                                                  <xs:element name="MAX_VALUE" minOccurs="0">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="99999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:element>
                                                  <xs:element name="MIN_VALUE" minOccurs="0">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="99999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:element>
                                                </xs:sequence>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MODULE_RULE_SET_REF">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PROPERTIES" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="PROPERTY_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="VALUE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="99999" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element : PRODUCT_GROUP Element
Beschreibung
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Namensraum (none)
Diagramm
RESTRICTIONS Element ITEMS Element FEATURE_CLASS_REF Element LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element Sequence PRODUCT_GROUP Element
Overview
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:999]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Die Elemente OLD_SERIA_NO (Pfad 1) und OLD_TYPE_NO (Pfad 1) dürfen nur verwendet werden, wenn der dort angegebene Artikel in allen geometrischen Daten identisch dem aktuellen Artikel ist.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Maße B, H und T dieses E-Gerätes im Element PARAMETERS (Pfad 3) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Der Code drückt unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

In diesem Attribut wird das Nettogewicht angegeben.

Dabei drückt der Code im vorhergehenden Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisvariantengruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf das Preisfeld. D positiveInteger
P
M [1:250]

PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
Über dieses Element wird definiert, dass es sich bei dem angegebenen Preis um einen Preis auf
Anfrage handelt. Das Element wird im Kombination mit dem Element PRICE_CALC_METHOD ausgewertet.

Bedeutung der Werte:
1/true = Preis auf Anfrage.

Wenn das Element angelegt wird, ist nur true erlaubt.

Das Element darf nur angelegt werden, wenn der Artikel in mehreren Preisgruppen vorhanden ist.

Definition "Preis auf Anfrage" für eine Preisgruppe des Artikels:
Das Element ITEM_PRICE wird mit der entsprechenden Preisgruppe angelegt. Das Element
PRICE_ON_REQUEST wird mit dem Wert true angelegt. Die Werte im Element PRICE haben dann folgende Bedeutung:
- der Wert 0 hat keine Bedeutung,
- ein Wert ungleich 0 stellt einen Richtwert für den Preis dar, der verbindliche Preis
muss dennoch beim Hersteller angefragt werden.

Definition "Preis auf Anfrage" für den gesamten Artikel:
Element ITEM_PRICE wird nicht angelegt. In dem Element PRICE_FEATURE_GROUP wird über das Attribut PRICE_CALC_METHOD (P1) definiert, dass die Preise für den Artikel beim Hersteller erfragt werden müssen. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 € = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (P3/PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (P5/BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (P5/PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (P3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (P1/PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Mehrpreisgruppe referenziert. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf die Preisgruppe. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden : -900) 		D integer
P
M [-99999999:999999999]
CALC_GROUP_REF optional
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination „00“ ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers. 		D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID referenziert Blockartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Der Wert 0 darf nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad11/PRICE_TYPE definiert.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
RESTRICTIONS optional
In diesem Element werden artikelspezifische Prüfverfahren zugeordnet.

Es dürfen nur Prüfverfahren referenziert werden, deren Variantenarten in der Variantenfamilie des Artikels enthalten sind.

Wenn ein Artikel Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Artikelspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Artikel zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden. Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von notwendigen Zusatzartikeln definiert werden. Aus der Menge der notwendigen Zusatzartikel muss genau ein Artikel ausgewählt werden. Wird in einer Menge von notwendigen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
OPERATION_ITEM optional

Durch dieses Element ist es möglich, eine Verknüpfung zwischen Artikeln und beispielsweise für die Artikel gültige Sonderanfertigungsarten, Gehrungszuschläge, Sichtseiten oder Ausklingungen zu definieren. Die Art der Verknüpfung wird über die Elemente ITEM_REF/SCOPE (Pfad 1) und CLASS (Pfad 1) beschrieben.

Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.

Folgende beispielartige Möglichkeiten können mit diesem Element abgebildet werden:

- Kranz, Licht- oder Sockelleisten Gehrungszuschläge zuweisen

- Artikeln zugehörige Sichtseiten zuweisen (Ausführungsabhängig/-unabhängig)

- Kranz, Licht- oder Sockelleisten zugehörige Formstücke, Retouren oder Übergänge zuweisen

- Sockelleisten die zugehörigen seitlichen Sockel zuweisen

- Arbeitsplatten die zugehörigen Ausschnitte, Ausklingungen oder Nut- und Federverbindungen zuweisen

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenkürzungen zugewiesen werden

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenerweiterungen zugewiesen werden

- Artikeln können Abweichungen von der Standardsockelhöhe zugewiesen werden.

Werden Artikel in diesem Element Sonderanfertigungsarten zugewiesen, so sind nur die zugeordneten gültig, werden keine zugeordnet, so sind alle Sonderanfertigungen an den Artikeln erlaubt.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/

Sequence
SCOPE 1..5
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden.
SCOPE_NO required Restriction of xs:positiveInteger
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
In diesem Element werden die Informationen zusammengefasst, dem Artikel innerhalb des Bereich (z. B. Type, Sockel, Kranzleiste, Lichtleiste, Arbeitsplatte) zugeordnet werden.
HINGE Restriction of xs:string

Dieses Element wird verwendet, um die Informationen über den Türanschlag des Artikels zu hinterlegen. Es werden keine geometrischen Informationen der Grundform des Artikels gesteuert. Hierzu wird das Feld CONSTRUCTION_ID verwendet.

Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.

Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID => das Element HINGE muss mit dem Wert "N" gefüllt werden.

Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) der Wert "J" enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element wird die äquivalente Katalogseite des Artikels angegeben. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall sollte die erste Seitennummer auf der der Artikel/ die Type auftaucht, verwendet werden. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

In diesem Element kann die äquivalente Katalogseite des Artikels in dem als .pdf-Datei abgelegten Kataloges angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gespeicherten Katalogs.

In dem Element DETAIL_INFO (auf Katalogebene) ist die URL der .pdf-Datei hinterlegt Da es Artikel gibt, die auf mehreren Seiten im Katalog aufgeführt sind, ist sicher zu stellen, dass die Angabe für die .pdf-Datei mit der 40-stelligen Katalogseite CATALOG_PAGE übereinstimmt, das heißt, beide Angaben verweisen auf die selbe Seite.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

In dieses Element wird das Gewicht des Artikels [100 g] inklusive Verpackungsmaterial angegeben. (z. B. 50 = 5000 g).
Dabei drückt der Code im Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.
Langteile werden entsprechend des Brutto-Gwichts je Preiseinheit berechnet.

Beispiel:
Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³] des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt, wird in diesem Element die Herstellernummer eingetragen.

Handelt es sich bei diesem Artikel um ein sichtbares Zulieferteil, so müssen entweder die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO oder die Elemente FILE_NAME_TEXTURE_1/2 gefüllt werden.

Die Herstellernummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Herstellernummer im Verkauf nicht öffentlich zu machen. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt (SUBCONTRACTOR_ID muss gefüllt sein), wird in diesem Element die Artikelnummer des Herstellers eingetragen.

Die Artikelnummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Artikelnummer im Verkauf nicht öffentlich zu machen. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist mindestens eines der Elemente FILENAME_TEXTURE_1/2 gefüllt, so ist dieses Element nicht optional. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
Dieses Element dient der Referenzierung auf eine Echtgrafik. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung). 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

Über dieses Element werden die werkseitigen Änderungsmöglichkeiten eines Artikels gesteuert. Die Änderungsmöglichkeiten der Artikel sind abhängig von der Definition seiner Grundformparameter im Element PARAMETERS (Pfad 1).

0 = alle Maßparameter (PARAMETERS (Pfad 1)) sind gesperrt, eine Maßänderung ist nicht möglich;

1 = die Maßparameter (PARAMETERS (Pfad 1)) sind im Rahmen der in SA500 angelegten Daten änderbar. Das zu ändernde Maß muss vom Benutzer abgefragt werden;

2 = alle Maßparameter (PARAMETERS (Pfad 1)) sind änderbar, gesperrte Parameter müssen identische Werte in den Attributen NOMINAL_VALUE (Pfad 1), FROM (Pfad 1) und TO (Pfad 1) haben.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie Dateiname_Textur_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente FILE_NAME_TEXTURE_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie FILE_NAME_TEXTURE_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente Dateiname_Textur_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern in angegeben werden.
Nur bei dem Parameter B dürfen die Attrubute FROM (Wert von) und TO (Wert bis) gefüllt werden.
Dieses Element darf nur gefüllt werden, wenn es sich bei dem Artikel um eine Kranz-, Licht- oder Sockelleiste, Arbeitsplatte, Abdeckplatte, Barplatte oder Wandabschlussprofil handelt.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
Als OPTION_KEY wird der herstellerspezifische Key für die Profilform verwendet, wie dieser auch im Verkaufhandbuch angegeben ist.
Im Element BASIC_PROFILE_SHAPE/OPTION_REF dürfen nur die Variantenarten 750-756 verwendet werden.
BASIC_SHAPE_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.
Die anzugebenen Daten sind abhängig von den Grundformen und den Abschnitten unterhalb der Grundformen zu entnehmen.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn im Element ITEM (Pfad 1) mindestens ein Element mit dem Element Artikelkennung = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
MODULE_PARTS optional

Falls der entsprechende Artikel ein Varioschrank ist, enthält dieses Element eine Stückliste von Modulelementen, wobei das erste Element ein Basisschrank mit der Position 0 ist und danach von unten nach oben die Modulelemente folgen. Dieses Element darf nicht angegeben werden, wenn der dazu gehörige Artikel kein Varioschrank ist.

Der Varioschrank hat einen festen Preis. Sobald der Varioschrank verändert wird, ergibt sich der neue Preis aus Preis für Basisschrank + Preis für die Module. Dabei entfällt der Varioschrank, der Basisschrank wird Hauptposition und hat alle anderen Modulelemente als Unterposition in der Reihenfolge von unten nach oben.

Die Modulelemente können programm- und ausführungsabhängig sein.

Für Modulelemente können Regeln bezüglich ihrer Höhe innerhalb des Basisschrankes über MODUL_RULE_SETS festgelegt werden. Dabei wird die global definierte Modulregel referenziert.

Dem Basisschrank kann solch eine Regel über MODULE_RULE_SET_REF zugeordnet werden.

Sequence
MODULE_PART 1..∞

Dieses Element entspricht einem Teil der Stückliste von Modulelementen eines Varioschrankes. Die Elemente müssen in ihrer Reihenfolge von unten nach oben angegeben werden. Die Position 0 (PART_SEQUENTIAL_NO) ist der leere Basisschrank (Schrank mit Typ-Art 17). Danach folgen von unten nach oben die Modulelemente (Schränke mit Typ-Schlüssel 10). Der Anschlag des Basisschrankes ist identisch zu Anschlag des Varioschrankes.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels innerhalb des Varioschrankes angegeben. Dabei muss der Basisschrank (Typ_Art 17) den Positionswert 0 beinhalten. Die Modulelemente (Typ-Schlüssel 10) erhalten in der Reihenfolge von unten nach oben weitere Positionsnummern. D nonNegativeInteger
P
M [0:999]
ITEM_REF
In diesem Element werden der Basisschrank (Typ-Art 17) und die einzelnen Modulelemente (Typschlüssel 10) referenziert.
Dabei muss dem Basisschrank die Position (PART_SEQUENTIAL_NO) 0 zugewiesen werden. Die übrigen Modulelemente müssen passend zu dem Attribut PART_SEQUENTIAL_NO in der Reihenfolge von unten nach oben referenziert werden.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikeltype eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
HEIGHT_VARIABLE optional xs:boolean
Ist der Wert von diesem Flag auf true(1) gesetzt, bedeutet es, dass das entsprechende Modulelement Veränderungen bei Veränderungen anderer Elemente innerhalb der Liste aufnimmt. Das bedeutet, wird ein anderes Modulelement größer oder kleiner, passt sich das mit HEIGT_VARIABLE true gekennzeichnete Modulelement so an, dass die Gesamthöhe aller Modulelemente innerhalb des Basisschrankes wieder erreicht wird. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
Ein Modulelement kann variabel sein, hat in der Liste aber eine feste Höhe, die bei variablen Maßen in diesem Element angegeben werden muss. D nonNegativeInteger
P
M [1:99999]
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT

Dieses Element enthält Kurztexte.

Der Kurztext darf maximal drei Zeilen lang sein und muss mit einem den Artikel näher beschreibenden Text gefüllt werden. Der Kurztext muss alleinstehend auf Kundenformularen druckbar sein. Dieser Text muss einen endverbraucherorientierten Inhalt haben. Der Kurztext muss immer vorhanden sein. Die letzte Zeile eines Kurztextes darf am Zeilenende keine Trennzeichen (z. B. – oder /) enthalten.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
FULL_TEXT optional languagetexte Complex Type

Der Volltext ergänzt den Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten " der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel " der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.
Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
FRONT_DIVISIONS optional
In diesem Element werden die möglichen Frontaufteilungen für einen Artikel definiert.
Die Frontaufteilungen können in Abhängigkeit des Programms unterschiedlich sein oder der Artikel hat in Abhängigkeit von Einbaugeräten unterschiedliche Frontaufteilungen.

Frontaufteilungen, die in mehrere Programme gleich sind, können in Frontgruppen zusammengefasst werden. Die Frontgruppen werden dann von den Programmen referenziert.

Die Frontaufteilungen beziehen sich auf die linke Bauweise. Ist der Artikel auch in rechter Bauweise vorhanden, so wird die Frontaufteilung von der Planungssoftware gespiegelt.
Sequence
FRONT_GROUP 1..99
In diesem Element werden die Frontaufteilungen definiert und zu einer Frontgruppe zusammengefasst.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein.

Ist die FRONT_GROUP gültig für alle Programme, so wird 0 hinterlegt. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
In diesem Element wird eine Frontaufteilung definiert und die einzelnen Zellen der Frontaufteilung beschrieben.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
Die Frontaufteilung wird nach der im Anhang beschriebenen Syntax eingegeben. Regalaufteilungen werden nicht über diese Syntax realisiert, sondern als eine Zelle betrachtet (siehe FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
In diesem Element werden die intern unterschiedlichen Bestellnummern für einen Artikel eingegeben, der in verschiedenen Frontaufteilungen lieferbar ist und im Katalog nur eine Artikelkennung besitzt. D string
P
M [1:15]
FRONT_CELL 1..∞
In diesem Element werden die einzelnen Zellen einer Frontaufteilung definiert.
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Artikel eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Frontausprägungen, die mit diesem Element zugeordnet werden, sind programmunabhängig.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Durch dieses Feld wird eine Beziehung zwischen der im Datensatz definierten Variante und einer Frontausprägung definiert. D positiveInteger
P
M
Choice optional
MODULE_RULE_SET_REF optional
Mit diesem Element referenziert der Artikel eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS. Nur Modulschränke (Typenschlüsselart = 17) können an dieser Stelle ein Modulregelset referenzieren. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D positiveInteger
P
M
MODULE_RULE_SETS optional
Dieses Element enthält die Modulregelwerke für Modulelemente. Ist der Artikel ein Modulelement (Typenschlüssel = 10), dann werden hier die Regeln für die Verplanung des Moduls hinterlegt. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden
Sequence
MODULE_RULE_SET 1..∞
In diesem Element wird dem Modulelement ein Set von Regeln zugewiesen. Jedes Set von Regeln referenziert über die MODULE_RULE_SET_NO das zugehörige Umbaumodul. Dadurch ist es möglich einem Artikel für verschiedene Umbaumodule unterschiedliche Regelwerke mitzugeben.
Sequence
MODULE_RULES
Ein Set von Regeln für den Einbau des Moduls in einen Modulschrank.
Sequence
MODULE_RULE 1..∞
Eine Regel für den Einbau des Moduls in einen Modulschrank.
Die Regel definiert unter welchen Voraussetzungen ein Modul in einem Umbauschrank plaziert werden kann.

Ein Modul muss den Typenschlüssel 10 haben.
MODULE_RULE_SET_REF
Mit diesem Element referenziert das Regelwerk eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS und die Umbauschränke, für die das betreffende Regelwerk gilt.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut referenziert das Regelwerk auf die MODULE_RULE_SET_DEFINITION und die Umbauschränke für die das Regelwerk mit diesem Artikel gültig ist. D nonNegativeInteger
P
M
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
RESTRICTIONS optional
In diesem Element werden die Prüfverfahren einer Produktgruppe zusammengefasst.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, der Produktgruppe zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]

Bemerkung

Quelle
<xs:element name="PRODUCT_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEMS">
        <xs:annotation>
          <xs:documentation>400--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECO_MOBILIER" minOccurs="0">
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[0-9]{11}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="NET_WEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                    <xs:annotation>
                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence minOccurs="0">
                        <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>450/470--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_FIELD">
                                <xs:annotation>
                                  <xs:documentation>450--4--Preisfeld</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE">
                                <xs:annotation>
                                  <xs:documentation>450--5--Preis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:integer">
                                    <xs:minInclusive value="-99999999" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>470--4--Preis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:integer">
                                    <xs:minInclusive value="-99999999" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_REF">
                    <xs:annotation>
                      <xs:documentation>400/407--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400/407--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CALC_GROUP_REF">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="CALC_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="10" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FEATURE_GROUP_REF">
                          <xs:annotation>
                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>460--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PRICE_FIELD">
                                      <xs:annotation>
                                        <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="250" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE">
                                      <xs:annotation>
                                        <xs:documentation>460--5--Preis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:integer">
                                          <xs:minInclusive value="-99999999" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CALC_GROUP_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="CALC_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="10" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>407--7--Tausch_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>407--7--Tausch_ID</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_REF">
                          <xs:annotation>
                            <xs:documentation>407--5--Preisart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="PRICE_TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>407--5--Preisart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESTRICTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>409--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>409--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="RESTRICTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>409--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>409--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="99999" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>406--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="GROUP_TITLE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>120--0--NEW</xs:documentation>
                                            <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                          <xs:annotation>
                                            <xs:documentation>406--7--Anzahl</xs:documentation>
                                            <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>Version 2.4.1</xs:documentation>
                                            <xs:documentation>geändert 13.09.2016</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:maxInclusive value="99999" />
                                              <xs:minInclusive value="1" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SET_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="GROUP_TITLE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>120--0--NEW</xs:documentation>
                                            <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                          <xs:annotation>
                                            <xs:documentation>406--7--Anzahl</xs:documentation>
                                            <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>Version 2.4.1</xs:documentation>
                                            <xs:documentation>geändert 13.09.2016</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:maxInclusive value="99999" />
                                              <xs:minInclusive value="1" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SET_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPERATION_ITEM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SCOPE" maxOccurs="5">
                                <xs:annotation>
                                  <xs:documentation>411--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>411--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="CLASS">
                                            <xs:annotation>
                                              <xs:documentation>411--7--Art</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="21" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>411--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>411--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[LNR]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="COVER" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--9--Abdeckung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="3" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALUE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--10--Wert</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALUE_MIN" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                              <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALUE_MAX" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                              <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SCOPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>411--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HINGE">
                    <xs:annotation>
                      <xs:documentation>400--4--Anschlag</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[BEJLMNR]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDP_NUMBER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EAN_NUMBER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_IDENTIFICATION">
                    <xs:annotation>
                      <xs:documentation>400--14--Artikelkennung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[BEKSMZVPNOG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_PAGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="40" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                      <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                      <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT_ID_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="VAT_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="WEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--20--Gewicht</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VOLUME" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--21--Volumen</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONSTRUCTION_ID">
                    <xs:annotation>
                      <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[JLNRAE]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OLD_SERIE_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OLD_TYPE_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--27--Type_Alt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MASKING" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--30--Maskierung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RANGE_DEPENDENT">
                    <xs:annotation>
                      <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_PROFILE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:choice>
                          <xs:element name="CARCASE_BASIC_SHAPE">
                            <xs:annotation>
                              <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>400--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType mixed="true">
                                    <xs:sequence>
                                      <xs:element name="OPTION_REF">
                                        <xs:annotation>
                                          <xs:documentation>430--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="FEATURE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>430--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPTION_KEY" use="required">
                                            <xs:annotation>
                                              <xs:documentation>430--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,5}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="BASIC_SHAPE_PARAMETERS">
                                  <xs:annotation>
                                    <xs:documentation>500--1--Satzart</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                        <xs:annotation>
                                          <xs:documentation>500--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                            <xs:annotation>
                                              <xs:documentation>500--0--Parameter</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                            <xs:annotation>
                                              <xs:documentation>500--5--Nennwert</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="BASIC_SHAPE_FROM">
                                            <xs:annotation>
                                              <xs:documentation>500--6--Von</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="BASIC_SHAPE_TO">
                                            <xs:annotation>
                                              <xs:documentation>500--7--Bis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                            <xs:annotation>
                                              <xs:documentation>500--8--Schrittweite</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                            <xs:annotation>
                              <xs:documentation>400--32--Massbild</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="240" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="DIMENSIONAL_PARAMETERS">
                                  <xs:annotation>
                                    <xs:documentation>500--1--Satzart</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                        <xs:annotation>
                                          <xs:documentation>500--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="DIMENSIONAL_FROM">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="DIMENSIONAL_TO">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:decimal">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>400--32--Massbild</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="20" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="BLOCK_PARTS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BLOCK_SEQUENTIAL_NO">
                                <xs:annotation>
                                  <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_REF">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HINGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--6--Anschlag</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[BEJLMNR]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="EXCHANGE_CONDITION">
                                <xs:annotation>
                                  <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="2" />
                                    <xs:maxInclusive value="3" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="STATUS">
                                <xs:annotation>
                                  <xs:documentation>401--8--Status</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[ABELSZ]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[JLNRAE]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="MODULE_PARTS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MODULE_PART" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PART_SEQUENTIAL_NO">
                                <xs:annotation>
                                  <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:maxInclusive value="999" />
                                    <xs:minInclusive value="0" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_REF">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_TEXT">
                    <xs:annotation>
                      <xs:documentation>410--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SHORT_TEXT">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT_LINE" maxOccurs="3">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--6--Textzeile</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[\S ]{1,30}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TYPE_KEY">
                    <xs:annotation>
                      <xs:documentation>445--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_TYPE">
                          <xs:annotation>
                            <xs:documentation>445--4--TS_Typ</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_CLASS">
                          <xs:annotation>
                            <xs:documentation>445--5--TS_Art</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                          <xs:annotation>
                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                              <xs:annotation>
                                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TK_MATERIAL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--21--TS_Material</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-2]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_SHAPE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--22--TS_Form</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-2]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CLASSIFICATIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS_NO">
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:totalDigits value="8" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FRONT_DIVISIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>510--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_GROUP" maxOccurs="99">
                          <xs:annotation>
                            <xs:documentation>510/540--0/0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FRONT_DIVISION_DEF">
                                      <xs:annotation>
                                        <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="250" />
                                          <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="FRONT_CELL_NO">
                                            <xs:annotation>
                                              <xs:documentation>540--6--Zellennummer</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="FRONT_TYPE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--7--Fronttyp</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="900" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="4" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="4" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PARAMETER_1" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--12--Parameter_1</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PARAMETER_2" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--13--Parameter_2</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="4" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="UPPER_JOIN" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[VLSG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="LOWER_JOIN" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[VLSG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="LEFT_JOIN" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[VLSG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="RIGHT_JOIN" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[VLSG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>540--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="2" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FRONT_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>510/540--0/0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:choice minOccurs="0">
                    <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="MODULE_RULES">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:sequence>
                                            <xs:element name="MODULE_POSITION">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                                  <xs:enumeration value="LINE_BOTTOM" />
                                                  <xs:enumeration value="LINE_TOP" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:element>
                                            <xs:element name="MAX_VALUE" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="99999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:element>
                                            <xs:element name="MIN_VALUE" minOccurs="0">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="99999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:element>
                                          </xs:sequence>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MODULE_RULE_SET_REF">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PROPERTIES" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="PROPERTY_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="VALUE" use="required">
                              <xs:annotation>
                                <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="99999" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUP_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : PRODUCT_GROUP_TEXT Element
Beschreibung
Dieses Element enthält die Bezeichung einer Produktgruppe.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element
Overview
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_CLASS_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : FEATURE_CLASS_REF Element
Beschreibung
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
Namensraum (none)
Diagramm
FEATURE_CLASS_REF Element
Overview
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:999]
Bemerkung

Quelle
<xs:element name="FEATURE_CLASS_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEMS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : ITEMS Element
Beschreibung
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Namensraum (none)
Diagramm
ITEM Element Sequence ITEMS Element
Overview
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Die Elemente OLD_SERIA_NO (Pfad 1) und OLD_TYPE_NO (Pfad 1) dürfen nur verwendet werden, wenn der dort angegebene Artikel in allen geometrischen Daten identisch dem aktuellen Artikel ist.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Maße B, H und T dieses E-Gerätes im Element PARAMETERS (Pfad 3) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Der Code drückt unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

In diesem Attribut wird das Nettogewicht angegeben.

Dabei drückt der Code im vorhergehenden Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisvariantengruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf das Preisfeld. D positiveInteger
P
M [1:250]

PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
Über dieses Element wird definiert, dass es sich bei dem angegebenen Preis um einen Preis auf
Anfrage handelt. Das Element wird im Kombination mit dem Element PRICE_CALC_METHOD ausgewertet.

Bedeutung der Werte:
1/true = Preis auf Anfrage.

Wenn das Element angelegt wird, ist nur true erlaubt.

Das Element darf nur angelegt werden, wenn der Artikel in mehreren Preisgruppen vorhanden ist.

Definition "Preis auf Anfrage" für eine Preisgruppe des Artikels:
Das Element ITEM_PRICE wird mit der entsprechenden Preisgruppe angelegt. Das Element
PRICE_ON_REQUEST wird mit dem Wert true angelegt. Die Werte im Element PRICE haben dann folgende Bedeutung:
- der Wert 0 hat keine Bedeutung,
- ein Wert ungleich 0 stellt einen Richtwert für den Preis dar, der verbindliche Preis
muss dennoch beim Hersteller angefragt werden.

Definition "Preis auf Anfrage" für den gesamten Artikel:
Element ITEM_PRICE wird nicht angelegt. In dem Element PRICE_FEATURE_GROUP wird über das Attribut PRICE_CALC_METHOD (P1) definiert, dass die Preise für den Artikel beim Hersteller erfragt werden müssen. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 € = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (P3/PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (P5/BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (P5/PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (P3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (P1/PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Mehrpreisgruppe referenziert. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf die Preisgruppe. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden : -900) 		D integer
P
M [-99999999:999999999]
CALC_GROUP_REF optional
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination „00“ ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers. 		D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID referenziert Blockartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Der Wert 0 darf nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad11/PRICE_TYPE definiert.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
RESTRICTIONS optional
In diesem Element werden artikelspezifische Prüfverfahren zugeordnet.

Es dürfen nur Prüfverfahren referenziert werden, deren Variantenarten in der Variantenfamilie des Artikels enthalten sind.

Wenn ein Artikel Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Artikelspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Artikel zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden. Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von notwendigen Zusatzartikeln definiert werden. Aus der Menge der notwendigen Zusatzartikel muss genau ein Artikel ausgewählt werden. Wird in einer Menge von notwendigen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
OPERATION_ITEM optional

Durch dieses Element ist es möglich, eine Verknüpfung zwischen Artikeln und beispielsweise für die Artikel gültige Sonderanfertigungsarten, Gehrungszuschläge, Sichtseiten oder Ausklingungen zu definieren. Die Art der Verknüpfung wird über die Elemente ITEM_REF/SCOPE (Pfad 1) und CLASS (Pfad 1) beschrieben.

Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.

Folgende beispielartige Möglichkeiten können mit diesem Element abgebildet werden:

- Kranz, Licht- oder Sockelleisten Gehrungszuschläge zuweisen

- Artikeln zugehörige Sichtseiten zuweisen (Ausführungsabhängig/-unabhängig)

- Kranz, Licht- oder Sockelleisten zugehörige Formstücke, Retouren oder Übergänge zuweisen

- Sockelleisten die zugehörigen seitlichen Sockel zuweisen

- Arbeitsplatten die zugehörigen Ausschnitte, Ausklingungen oder Nut- und Federverbindungen zuweisen

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenkürzungen zugewiesen werden

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenerweiterungen zugewiesen werden

- Artikeln können Abweichungen von der Standardsockelhöhe zugewiesen werden.

Werden Artikel in diesem Element Sonderanfertigungsarten zugewiesen, so sind nur die zugeordneten gültig, werden keine zugeordnet, so sind alle Sonderanfertigungen an den Artikeln erlaubt.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/

Sequence
SCOPE 1..5
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden.
SCOPE_NO required Restriction of xs:positiveInteger
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
In diesem Element werden die Informationen zusammengefasst, dem Artikel innerhalb des Bereich (z. B. Type, Sockel, Kranzleiste, Lichtleiste, Arbeitsplatte) zugeordnet werden.
Sequence
CLASS Restriction of xs:positiveInteger

Hier wird definiert welcher Art die Zuordnungen sind. Es sind folgende Zuordnungsarten möglich:
1 = Sichtseite
2 = seitlicher Sockel
3 = Formstück
4 = Retoure
5 = Übergang
6 = Gehrungszuschlag
7 = Breitenkürzung
8 = Tiefenkürzung
9 = Höhenkürzung
10 = Ausschnitt
11 = Ausschnitt Rechteck
12 = Ausschnitt Rund
13 = Ausklinkung
14 = Abschrägung
15 = Abrundung
16 = Nut und Feder Verbindung
17 = Kante zu WERT 5
18 = Breitenerweiterung zu WERT 1
19 = Tiefenerweiterung zu WERT 1
20 = Höhenerweiterung zu WERT 1
21 = Abweichung vom Standardsockel

Die hier eingetragenen Werte sind abhängig von dem im Element SCOPE eingetragenem Wert und unterliegen folgender Regelung:

Element SCOPE Wert 1 => Element CLASS Werte 1, 2, 3, 7, 8, 9, 18 bis 20
Element SCOPE Wert 2 => Element CLASS Werte 2 bis 6, Wert 21
Element SCOPE Wert 3 oder 4 => Element CLASS Werte 3 bis 6
Element SCOPE Wert 5 => Element CLASS Werte 10 bis 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Hier wird die Type (Verknüpfungs-Type) referenziert, die der Ziel-Type zugeordnet wird. Die Verknüpfungs-Type muss in der gleichen Serie wie die Ziel-Type oder der Serie 0 angelegt sein.

Dieses Element muss angelegt werden, wenn im Element CLASS (Pfad 1) die Werte für Formstück (3), Retoure (4) oder Übergang (5) eingetragen sind.

Wenn dieses Element nicht angelegt wird, muss das Element VALUE (Pfad 1) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene, Bauweise eines Artikels.

L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist. 		D string
P [LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
Ist im Element CLASS der Wert 3 für Formstück eingetragen, so muss dieses Element gefüllt werden. Bei anderen Werten darf dieses Element nicht gefüllt werden. Es wird unterschieden zwischen der Basis-, Teil-, und Vollabdeckung. Die unterschiedlichen Abdeckungen für Formteile sind in Abhängigkeit der Grundform definiert und im Teil "Zuordnung der Abdeckungsarten" zu finden.

Entsprechend der ausgewählten Abdeckung sind hier folgende Werte möglich:
1 = Basisabdeckung
2 = Teilabdeckung
3 = Vollabdeckung 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
Werden Zuordnungen für die Bereiche Sockel-, Kranz- und Lichtleiste (Bereiche 2-4) definiert, so ist in diesem Element einzutragen, bei welcher Grundform die Zuordnung anzuwenden ist. Dieses Element muss gefüllt werden, wenn im Element SCOPE die Werte 2 bis 4 eingetragen sind. Bei den Werten 1 und 5 im Element SCOPE darf dieses Element nicht gefüllt werden. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für einen Gehrungszuschlag angegeben. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Mindestwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Maximalwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
HINGE Restriction of xs:string

Dieses Element wird verwendet, um die Informationen über den Türanschlag des Artikels zu hinterlegen. Es werden keine geometrischen Informationen der Grundform des Artikels gesteuert. Hierzu wird das Feld CONSTRUCTION_ID verwendet.

Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.

Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID => das Element HINGE muss mit dem Wert "N" gefüllt werden.

Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) der Wert "J" enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element wird die äquivalente Katalogseite des Artikels angegeben. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall sollte die erste Seitennummer auf der der Artikel/ die Type auftaucht, verwendet werden. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

In diesem Element kann die äquivalente Katalogseite des Artikels in dem als .pdf-Datei abgelegten Kataloges angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gespeicherten Katalogs.

In dem Element DETAIL_INFO (auf Katalogebene) ist die URL der .pdf-Datei hinterlegt Da es Artikel gibt, die auf mehreren Seiten im Katalog aufgeführt sind, ist sicher zu stellen, dass die Angabe für die .pdf-Datei mit der 40-stelligen Katalogseite CATALOG_PAGE übereinstimmt, das heißt, beide Angaben verweisen auf die selbe Seite.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

In dieses Element wird das Gewicht des Artikels [100 g] inklusive Verpackungsmaterial angegeben. (z. B. 50 = 5000 g).
Dabei drückt der Code im Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.
Langteile werden entsprechend des Brutto-Gwichts je Preiseinheit berechnet.

Beispiel:
Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³] des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt, wird in diesem Element die Herstellernummer eingetragen.

Handelt es sich bei diesem Artikel um ein sichtbares Zulieferteil, so müssen entweder die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO oder die Elemente FILE_NAME_TEXTURE_1/2 gefüllt werden.

Die Herstellernummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Herstellernummer im Verkauf nicht öffentlich zu machen. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt (SUBCONTRACTOR_ID muss gefüllt sein), wird in diesem Element die Artikelnummer des Herstellers eingetragen.

Die Artikelnummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Artikelnummer im Verkauf nicht öffentlich zu machen. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist mindestens eines der Elemente FILENAME_TEXTURE_1/2 gefüllt, so ist dieses Element nicht optional. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
Dieses Element dient der Referenzierung auf eine Echtgrafik. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung). 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

Über dieses Element werden die werkseitigen Änderungsmöglichkeiten eines Artikels gesteuert. Die Änderungsmöglichkeiten der Artikel sind abhängig von der Definition seiner Grundformparameter im Element PARAMETERS (Pfad 1).

0 = alle Maßparameter (PARAMETERS (Pfad 1)) sind gesperrt, eine Maßänderung ist nicht möglich;

1 = die Maßparameter (PARAMETERS (Pfad 1)) sind im Rahmen der in SA500 angelegten Daten änderbar. Das zu ändernde Maß muss vom Benutzer abgefragt werden;

2 = alle Maßparameter (PARAMETERS (Pfad 1)) sind änderbar, gesperrte Parameter müssen identische Werte in den Attributen NOMINAL_VALUE (Pfad 1), FROM (Pfad 1) und TO (Pfad 1) haben.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie Dateiname_Textur_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente FILE_NAME_TEXTURE_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie FILE_NAME_TEXTURE_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente Dateiname_Textur_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern in angegeben werden.
Nur bei dem Parameter B dürfen die Attrubute FROM (Wert von) und TO (Wert bis) gefüllt werden.
Dieses Element darf nur gefüllt werden, wenn es sich bei dem Artikel um eine Kranz-, Licht- oder Sockelleiste, Arbeitsplatte, Abdeckplatte, Barplatte oder Wandabschlussprofil handelt.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
Als OPTION_KEY wird der herstellerspezifische Key für die Profilform verwendet, wie dieser auch im Verkaufhandbuch angegeben ist.
Im Element BASIC_PROFILE_SHAPE/OPTION_REF dürfen nur die Variantenarten 750-756 verwendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:5]
BASIC_SHAPE_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.
Die anzugebenen Daten sind abhängig von den Grundformen und den Abschnitten unterhalb der Grundformen zu entnehmen.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn im Element ITEM (Pfad 1) mindestens ein Element mit dem Element Artikelkennung = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
MODULE_PARTS optional

Falls der entsprechende Artikel ein Varioschrank ist, enthält dieses Element eine Stückliste von Modulelementen, wobei das erste Element ein Basisschrank mit der Position 0 ist und danach von unten nach oben die Modulelemente folgen. Dieses Element darf nicht angegeben werden, wenn der dazu gehörige Artikel kein Varioschrank ist.

Der Varioschrank hat einen festen Preis. Sobald der Varioschrank verändert wird, ergibt sich der neue Preis aus Preis für Basisschrank + Preis für die Module. Dabei entfällt der Varioschrank, der Basisschrank wird Hauptposition und hat alle anderen Modulelemente als Unterposition in der Reihenfolge von unten nach oben.

Die Modulelemente können programm- und ausführungsabhängig sein.

Für Modulelemente können Regeln bezüglich ihrer Höhe innerhalb des Basisschrankes über MODUL_RULE_SETS festgelegt werden. Dabei wird die global definierte Modulregel referenziert.

Dem Basisschrank kann solch eine Regel über MODULE_RULE_SET_REF zugeordnet werden.

Sequence
MODULE_PART 1..∞

Dieses Element entspricht einem Teil der Stückliste von Modulelementen eines Varioschrankes. Die Elemente müssen in ihrer Reihenfolge von unten nach oben angegeben werden. Die Position 0 (PART_SEQUENTIAL_NO) ist der leere Basisschrank (Schrank mit Typ-Art 17). Danach folgen von unten nach oben die Modulelemente (Schränke mit Typ-Schlüssel 10). Der Anschlag des Basisschrankes ist identisch zu Anschlag des Varioschrankes.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels innerhalb des Varioschrankes angegeben. Dabei muss der Basisschrank (Typ_Art 17) den Positionswert 0 beinhalten. Die Modulelemente (Typ-Schlüssel 10) erhalten in der Reihenfolge von unten nach oben weitere Positionsnummern. D nonNegativeInteger
P
M [0:999]
ITEM_REF
In diesem Element werden der Basisschrank (Typ-Art 17) und die einzelnen Modulelemente (Typschlüssel 10) referenziert.
Dabei muss dem Basisschrank die Position (PART_SEQUENTIAL_NO) 0 zugewiesen werden. Die übrigen Modulelemente müssen passend zu dem Attribut PART_SEQUENTIAL_NO in der Reihenfolge von unten nach oben referenziert werden.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikeltype eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
HEIGHT_VARIABLE optional xs:boolean
Ist der Wert von diesem Flag auf true(1) gesetzt, bedeutet es, dass das entsprechende Modulelement Veränderungen bei Veränderungen anderer Elemente innerhalb der Liste aufnimmt. Das bedeutet, wird ein anderes Modulelement größer oder kleiner, passt sich das mit HEIGT_VARIABLE true gekennzeichnete Modulelement so an, dass die Gesamthöhe aller Modulelemente innerhalb des Basisschrankes wieder erreicht wird. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
Ein Modulelement kann variabel sein, hat in der Liste aber eine feste Höhe, die bei variablen Maßen in diesem Element angegeben werden muss. D nonNegativeInteger
P
M [1:99999]
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT

Dieses Element enthält Kurztexte.

Der Kurztext darf maximal drei Zeilen lang sein und muss mit einem den Artikel näher beschreibenden Text gefüllt werden. Der Kurztext muss alleinstehend auf Kundenformularen druckbar sein. Dieser Text muss einen endverbraucherorientierten Inhalt haben. Der Kurztext muss immer vorhanden sein. Die letzte Zeile eines Kurztextes darf am Zeilenende keine Trennzeichen (z. B. – oder /) enthalten.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type

Der Volltext ergänzt den Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten " der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel " der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.
Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
FRONT_DIVISIONS optional
In diesem Element werden die möglichen Frontaufteilungen für einen Artikel definiert.
Die Frontaufteilungen können in Abhängigkeit des Programms unterschiedlich sein oder der Artikel hat in Abhängigkeit von Einbaugeräten unterschiedliche Frontaufteilungen.

Frontaufteilungen, die in mehrere Programme gleich sind, können in Frontgruppen zusammengefasst werden. Die Frontgruppen werden dann von den Programmen referenziert.

Die Frontaufteilungen beziehen sich auf die linke Bauweise. Ist der Artikel auch in rechter Bauweise vorhanden, so wird die Frontaufteilung von der Planungssoftware gespiegelt.
Sequence
FRONT_GROUP 1..99
In diesem Element werden die Frontaufteilungen definiert und zu einer Frontgruppe zusammengefasst.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein.

Ist die FRONT_GROUP gültig für alle Programme, so wird 0 hinterlegt. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
In diesem Element wird eine Frontaufteilung definiert und die einzelnen Zellen der Frontaufteilung beschrieben.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
Die Frontaufteilung wird nach der im Anhang beschriebenen Syntax eingegeben. Regalaufteilungen werden nicht über diese Syntax realisiert, sondern als eine Zelle betrachtet (siehe FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
In diesem Element werden die intern unterschiedlichen Bestellnummern für einen Artikel eingegeben, der in verschiedenen Frontaufteilungen lieferbar ist und im Katalog nur eine Artikelkennung besitzt. D string
P
M [1:15]
FRONT_CELL 1..∞
In diesem Element werden die einzelnen Zellen einer Frontaufteilung definiert.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
In diesem Attribut wird die Nummer der Zelle angegeben, die definiert werden soll. Die Zellennummer wird in der Frontaufteilung (FRONT_DIVISION_DEF) festgelegt. D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
In diesem Element wird angegeben, welchen Fronttyp die Zelle hat. Die Zuordnung eines Frontelementes erfolgt über den Fronttyp (siehe Element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

Folgende Fronttypen können zugeordnet werden:

1 - 100 = Türen
101 - 200 = Schubladen
201 - 300 = Auszüge
301 – 400 = Klappen
401 – 450 = Nischen mit Blende
451 – 500 = Nischen ohne Blende
501 – 550 = offene Fächer/Fachnischen
551 – 600 = Regale
601 – 650 = feste Blenden
651 – 700 = Schaltkastenblenden
701 – 750 = Jalousien
751 – 800 = Rollfronten
801 – 900 = Diverses 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
Die Elemente PARAMETER_1 und PARAMETER_2 werden für sichtbare Fachböden (z. B. Regale, Glasschränke) verwendet, um die Anzahl der Fachböden anzugeben.
PARAMETER_1 gibt die Anzahl der horizontalen Fachböden an. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
Dieses Element gibt die Anzahl der vertikalen Unterteilungen bei Regalen an. Gilt für sichtbare Fachböden (z. B. Regale, Glasschränke). D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle)
3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) keine Spiegelung
1) Spiegelung nur bei Änderung des Anschlags
2) Spiegelung nur bei Änderung der Bauweise
3) Spiegelung wenn sich entweder Anschlag oder Bauweise verändert
4) Spiegelung wenn Anschlag und Bauweise gemeinsam verändert werden.

Festlegungen werden im Kopftext dokumentiert und anhand von Beispielen verdeutlicht.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

Hier wird die Position der Kehlleiste definiert

1) = horizontal
2) = vertikal

 D nonNegativeInteger
P
M [1:2]
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Artikel eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Frontausprägungen, die mit diesem Element zugeordnet werden, sind programmunabhängig.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Durch dieses Feld wird eine Beziehung zwischen der im Datensatz definierten Variante und einer Frontausprägung definiert. D positiveInteger
P
M
Choice optional
MODULE_RULE_SET_REF optional
Mit diesem Element referenziert der Artikel eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS. Nur Modulschränke (Typenschlüsselart = 17) können an dieser Stelle ein Modulregelset referenzieren. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D positiveInteger
P
M
MODULE_RULE_SETS optional
Dieses Element enthält die Modulregelwerke für Modulelemente. Ist der Artikel ein Modulelement (Typenschlüssel = 10), dann werden hier die Regeln für die Verplanung des Moduls hinterlegt. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden
Sequence
MODULE_RULE_SET 1..∞
In diesem Element wird dem Modulelement ein Set von Regeln zugewiesen. Jedes Set von Regeln referenziert über die MODULE_RULE_SET_NO das zugehörige Umbaumodul. Dadurch ist es möglich einem Artikel für verschiedene Umbaumodule unterschiedliche Regelwerke mitzugeben.
Sequence
MODULE_RULES
Ein Set von Regeln für den Einbau des Moduls in einen Modulschrank.
Sequence
MODULE_RULE 1..∞
Eine Regel für den Einbau des Moduls in einen Modulschrank.
Die Regel definiert unter welchen Voraussetzungen ein Modul in einem Umbauschrank plaziert werden kann.

Ein Modul muss den Typenschlüssel 10 haben.
Sequence
MODULE_POSITION Restriction of xs:string
Hier wird definiert welcher Wert geprüft werden soll.

LINE_BOTTOM | Unterkante des Modulelements in mm
LINE_TOP | Oberkante des Modulelements

Bei diesen Prüfungen sind MIN_VALUE oder MAX_VALUE anzugeben.
 D string
P LINE_BOTTOM|LINE_TOP

M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Maximalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Minimalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
MODULE_RULE_SET_REF
Mit diesem Element referenziert das Regelwerk eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS und die Umbauschränke, für die das betreffende Regelwerk gilt.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut referenziert das Regelwerk auf die MODULE_RULE_SET_DEFINITION und die Umbauschränke für die das Regelwerk mit diesem Artikel gültig ist. D nonNegativeInteger
P
M
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Bemerkung

Quelle
<xs:element name="ITEMS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECO_MOBILIER" minOccurs="0">
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9]{11}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="NET_WEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
              <xs:annotation>
                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence minOccurs="0">
                  <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>450/470--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FIELD">
                          <xs:annotation>
                            <xs:documentation>450--4--Preisfeld</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE">
                          <xs:annotation>
                            <xs:documentation>450--5--Preis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="-99999999" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>470--4--Preis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="-99999999" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_TYPE_REF">
              <xs:annotation>
                <xs:documentation>400/407--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="PRICE_TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400/407--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CALC_GROUP_REF">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="CALC_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="10" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP_REF">
                    <xs:annotation>
                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>460--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_FIELD">
                                <xs:annotation>
                                  <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE">
                                <xs:annotation>
                                  <xs:documentation>460--5--Preis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:integer">
                                    <xs:minInclusive value="-99999999" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CALC_GROUP_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="CALC_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="10" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>407--7--Tausch_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>407--7--Tausch_ID</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_REF">
                    <xs:annotation>
                      <xs:documentation>407--5--Preisart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>407--5--Preisart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>409--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>409--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>409--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>409--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="99999" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>406--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="GROUP_TITLE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>120--0--NEW</xs:documentation>
                                      <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>406--7--Anzahl</xs:documentation>
                                      <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>Version 2.4.1</xs:documentation>
                                      <xs:documentation>geändert 13.09.2016</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="99999" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SET_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="GROUP_TITLE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>120--0--NEW</xs:documentation>
                                      <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>406--7--Anzahl</xs:documentation>
                                      <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>Version 2.4.1</xs:documentation>
                                      <xs:documentation>geändert 13.09.2016</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="99999" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SET_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPERATION_ITEM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SCOPE" maxOccurs="5">
                          <xs:annotation>
                            <xs:documentation>411--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>411--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLASS">
                                      <xs:annotation>
                                        <xs:documentation>411--7--Art</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="21" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>411--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>411--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[LNR]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="COVER" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--9--Abdeckung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="3" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--10--Wert</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_MIN" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                        <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_MAX" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                        <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SCOPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>411--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="HINGE">
              <xs:annotation>
                <xs:documentation>400--4--Anschlag</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BEJLMNR]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDP_NUMBER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EAN_NUMBER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>400--14--Artikelkennung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BEKSMZVPNOG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_PAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="40" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
                <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
                <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT_ID_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="VAT_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="WEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--20--Gewicht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VOLUME" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--21--Volumen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONSTRUCTION_ID">
              <xs:annotation>
                <xs:documentation>400--23--Bauweise_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[JLNRAE]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="OLD_SERIE_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="OLD_TYPE_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--27--Type_Alt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MASKING" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--30--Maskierung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="RANGE_DEPENDENT">
              <xs:annotation>
                <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_PROFILE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:choice>
                    <xs:element name="CARCASE_BASIC_SHAPE">
                      <xs:annotation>
                        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>400--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType mixed="true">
                              <xs:sequence>
                                <xs:element name="OPTION_REF">
                                  <xs:annotation>
                                    <xs:documentation>430--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="FEATURE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>430--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPTION_KEY" use="required">
                                      <xs:annotation>
                                        <xs:documentation>430--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,5}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="BASIC_SHAPE_PARAMETERS">
                            <xs:annotation>
                              <xs:documentation>500--1--Satzart</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>500--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                      <xs:annotation>
                                        <xs:documentation>500--0--Parameter</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>500--5--Nennwert</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="BASIC_SHAPE_FROM">
                                      <xs:annotation>
                                        <xs:documentation>500--6--Von</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="BASIC_SHAPE_TO">
                                      <xs:annotation>
                                        <xs:documentation>500--7--Bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                      <xs:annotation>
                                        <xs:documentation>500--8--Schrittweite</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                      <xs:annotation>
                        <xs:documentation>400--32--Massbild</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:minLength value="1" />
                                <xs:maxLength value="240" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="DIMENSIONAL_PARAMETERS">
                            <xs:annotation>
                              <xs:documentation>500--1--Satzart</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>500--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSIONAL_FROM">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSIONAL_TO">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:decimal">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>400--32--Massbild</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="20" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="BLOCK_PARTS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="BLOCK_SEQUENTIAL_NO">
                          <xs:annotation>
                            <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HINGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--6--Anschlag</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[BEJLMNR]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXCHANGE_CONDITION">
                          <xs:annotation>
                            <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="2" />
                              <xs:maxInclusive value="3" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="STATUS">
                          <xs:annotation>
                            <xs:documentation>401--8--Status</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[ABELSZ]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[JLNRAE]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MODULE_PARTS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MODULE_PART" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PART_SEQUENTIAL_NO">
                          <xs:annotation>
                            <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:maxInclusive value="999" />
                              <xs:minInclusive value="0" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_TEXT">
              <xs:annotation>
                <xs:documentation>410--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SHORT_TEXT">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--6--Textzeile</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="TYPE_KEY">
              <xs:annotation>
                <xs:documentation>445--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_TYPE">
                    <xs:annotation>
                      <xs:documentation>445--4--TS_Typ</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_CLASS">
                    <xs:annotation>
                      <xs:documentation>445--5--TS_Art</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                    <xs:annotation>
                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                        <xs:annotation>
                          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TK_MATERIAL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--21--TS_Material</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-2]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_SHAPE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--22--TS_Form</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-2]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CLASSIFICATIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS_NO">
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:totalDigits value="8" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_DIVISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>510--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_GROUP" maxOccurs="99">
                    <xs:annotation>
                      <xs:documentation>510/540--0/0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>510/540--0/0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_DIVISION_DEF">
                                <xs:annotation>
                                  <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="250" />
                                    <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="FRONT_CELL_NO">
                                      <xs:annotation>
                                        <xs:documentation>540--6--Zellennummer</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FRONT_TYPE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--7--Fronttyp</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="900" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="4" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="4" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PARAMETER_1" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--12--Parameter_1</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PARAMETER_2" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--13--Parameter_2</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="4" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="UPPER_JOIN" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[VLSG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="LOWER_JOIN" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[VLSG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="LEFT_JOIN" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[VLSG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="RIGHT_JOIN" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[VLSG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>540--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="2" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FRONT_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>510/540--0/0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:choice minOccurs="0">
              <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="MODULE_RULE_SETS" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="MODULE_RULES">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:sequence>
                                      <xs:element name="MODULE_POSITION">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                            <xs:enumeration value="LINE_BOTTOM" />
                                            <xs:enumeration value="LINE_TOP" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="MAX_VALUE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="99999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="MIN_VALUE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="99999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                    </xs:sequence>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MODULE_RULE_SET_REF">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:choice>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PROPERTIES" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="PROPERTY_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="VALUE" use="required">
                        <xs:annotation>
                          <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element : ITEM Element
Beschreibung
In diesem Element werden Artikel und Blöcke definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Die Elemente OLD_SERIA_NO (Pfad 1) und OLD_TYPE_NO (Pfad 1) dürfen nur verwendet werden, wenn der dort angegebene Artikel in allen geometrischen Daten identisch dem aktuellen Artikel ist.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Maße B, H und T dieses E-Gerätes im Element PARAMETERS (Pfad 3) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
Namensraum (none)
Diagramm
PROPERTIES Element DETAIL_INFOS Element MODULE_RULE_SETS Element MODULE_RULE_SET_REF Element Choice FRONT_APPEARANCE_REF Element FRONT_DIVISIONS Element CLASSIFICATIONS Element TYPE_KEY Element ITEM_TEXT Element MODULE_PARTS Element BLOCK_PARTS Element BASIC_PROFILE Element EX_FACTORY_MODIFICATION Element MINIMUM_DELIVERY_TIME Element RANGE_DEPENDENT Element MODELING_GRAPHIC_ID Element MASKING Element FILE_NAME_TEXTURE_2 Element FILE_NAME_TEXTURE_1 Element OLD_TYPE_NO Element OLD_SERIE_NO Element SUBCONTRACTOR_ITEM_NO Element SUBCONTRACTOR_ID Element CONSTRUCTION_ID Element VOLUME Element WEIGHT Element VALID_UNTIL Element VALID_FROM Element VAT_ID_REF Element CATALOG_PAGE_PDF Element CATALOG_PAGE Element ITEM_IDENTIFICATION Element BLOCK_PRICE_STATUS Element EAN_NUMBER Element EDP_NUMBER Element HINGE Element ADDITIONAL_ITEMS Element RESTRICTIONS Element ADDITIONAL_PRICE_GROUP Element EXCHANGE_ID_REF Element CALC_GROUP_REF Element PRICE_TYPE_REF Element PRICE_FEATURE_GROUP_BASE_PRICE_REF Element NET_WEIGHT Element ECO_MOBILIER Element Sequence ITEM Element
Overview
ITEM 1..∞
In diesem Element werden Artikel und Blöcke definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Die Elemente OLD_SERIA_NO (Pfad 1) und OLD_TYPE_NO (Pfad 1) dürfen nur verwendet werden, wenn der dort angegebene Artikel in allen geometrischen Daten identisch dem aktuellen Artikel ist.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Maße B, H und T dieses E-Gerätes im Element PARAMETERS (Pfad 3) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Der Code drückt unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D string
P [0-9]{11}
M [11:11]

NET_WEIGHT optional Restriction of xs:nonNegativeInteger

In diesem Attribut wird das Nettogewicht angegeben.

Dabei drückt der Code im vorhergehenden Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]

PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisvariantengruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf das Preisfeld. D positiveInteger
P
M [1:250]

PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
Über dieses Element wird definiert, dass es sich bei dem angegebenen Preis um einen Preis auf
Anfrage handelt. Das Element wird im Kombination mit dem Element PRICE_CALC_METHOD ausgewertet.

Bedeutung der Werte:
1/true = Preis auf Anfrage.

Wenn das Element angelegt wird, ist nur true erlaubt.

Das Element darf nur angelegt werden, wenn der Artikel in mehreren Preisgruppen vorhanden ist.

Definition "Preis auf Anfrage" für eine Preisgruppe des Artikels:
Das Element ITEM_PRICE wird mit der entsprechenden Preisgruppe angelegt. Das Element
PRICE_ON_REQUEST wird mit dem Wert true angelegt. Die Werte im Element PRICE haben dann folgende Bedeutung:
- der Wert 0 hat keine Bedeutung,
- ein Wert ungleich 0 stellt einen Richtwert für den Preis dar, der verbindliche Preis
muss dennoch beim Hersteller angefragt werden.

Definition "Preis auf Anfrage" für den gesamten Artikel:
Element ITEM_PRICE wird nicht angelegt. In dem Element PRICE_FEATURE_GROUP wird über das Attribut PRICE_CALC_METHOD (P1) definiert, dass die Preise für den Artikel beim Hersteller erfragt werden müssen. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 € = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (P3/PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (P5/BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (P5/PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (P3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (P1/PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Mehrpreisgruppe referenziert. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf die Preisgruppe. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden : -900) 		D integer
P
M [-99999999:999999999]
CALC_GROUP_REF optional
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination „00“ ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers. 		D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID referenziert Blockartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Der Wert 0 darf nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad11/PRICE_TYPE definiert.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
RESTRICTIONS optional
In diesem Element werden artikelspezifische Prüfverfahren zugeordnet.

Es dürfen nur Prüfverfahren referenziert werden, deren Variantenarten in der Variantenfamilie des Artikels enthalten sind.

Wenn ein Artikel Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Artikelspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Artikel zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden. Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von notwendigen Zusatzartikeln definiert werden. Aus der Menge der notwendigen Zusatzartikel muss genau ein Artikel ausgewählt werden. Wird in einer Menge von notwendigen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
OPERATION_ITEM optional

Durch dieses Element ist es möglich, eine Verknüpfung zwischen Artikeln und beispielsweise für die Artikel gültige Sonderanfertigungsarten, Gehrungszuschläge, Sichtseiten oder Ausklingungen zu definieren. Die Art der Verknüpfung wird über die Elemente ITEM_REF/SCOPE (Pfad 1) und CLASS (Pfad 1) beschrieben.

Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.

Folgende beispielartige Möglichkeiten können mit diesem Element abgebildet werden:

- Kranz, Licht- oder Sockelleisten Gehrungszuschläge zuweisen

- Artikeln zugehörige Sichtseiten zuweisen (Ausführungsabhängig/-unabhängig)

- Kranz, Licht- oder Sockelleisten zugehörige Formstücke, Retouren oder Übergänge zuweisen

- Sockelleisten die zugehörigen seitlichen Sockel zuweisen

- Arbeitsplatten die zugehörigen Ausschnitte, Ausklingungen oder Nut- und Federverbindungen zuweisen

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenkürzungen zugewiesen werden

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenerweiterungen zugewiesen werden

- Artikeln können Abweichungen von der Standardsockelhöhe zugewiesen werden.

Werden Artikel in diesem Element Sonderanfertigungsarten zugewiesen, so sind nur die zugeordneten gültig, werden keine zugeordnet, so sind alle Sonderanfertigungen an den Artikeln erlaubt.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/

Sequence
SCOPE 1..5
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden.
SCOPE_NO required Restriction of xs:positiveInteger
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
In diesem Element werden die Informationen zusammengefasst, dem Artikel innerhalb des Bereich (z. B. Type, Sockel, Kranzleiste, Lichtleiste, Arbeitsplatte) zugeordnet werden.
Sequence
CLASS Restriction of xs:positiveInteger

Hier wird definiert welcher Art die Zuordnungen sind. Es sind folgende Zuordnungsarten möglich:
1 = Sichtseite
2 = seitlicher Sockel
3 = Formstück
4 = Retoure
5 = Übergang
6 = Gehrungszuschlag
7 = Breitenkürzung
8 = Tiefenkürzung
9 = Höhenkürzung
10 = Ausschnitt
11 = Ausschnitt Rechteck
12 = Ausschnitt Rund
13 = Ausklinkung
14 = Abschrägung
15 = Abrundung
16 = Nut und Feder Verbindung
17 = Kante zu WERT 5
18 = Breitenerweiterung zu WERT 1
19 = Tiefenerweiterung zu WERT 1
20 = Höhenerweiterung zu WERT 1
21 = Abweichung vom Standardsockel

Die hier eingetragenen Werte sind abhängig von dem im Element SCOPE eingetragenem Wert und unterliegen folgender Regelung:

Element SCOPE Wert 1 => Element CLASS Werte 1, 2, 3, 7, 8, 9, 18 bis 20
Element SCOPE Wert 2 => Element CLASS Werte 2 bis 6, Wert 21
Element SCOPE Wert 3 oder 4 => Element CLASS Werte 3 bis 6
Element SCOPE Wert 5 => Element CLASS Werte 10 bis 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Hier wird die Type (Verknüpfungs-Type) referenziert, die der Ziel-Type zugeordnet wird. Die Verknüpfungs-Type muss in der gleichen Serie wie die Ziel-Type oder der Serie 0 angelegt sein.

Dieses Element muss angelegt werden, wenn im Element CLASS (Pfad 1) die Werte für Formstück (3), Retoure (4) oder Übergang (5) eingetragen sind.

Wenn dieses Element nicht angelegt wird, muss das Element VALUE (Pfad 1) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene, Bauweise eines Artikels.

L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist. 		D string
P [LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
Ist im Element CLASS der Wert 3 für Formstück eingetragen, so muss dieses Element gefüllt werden. Bei anderen Werten darf dieses Element nicht gefüllt werden. Es wird unterschieden zwischen der Basis-, Teil-, und Vollabdeckung. Die unterschiedlichen Abdeckungen für Formteile sind in Abhängigkeit der Grundform definiert und im Teil "Zuordnung der Abdeckungsarten" zu finden.

Entsprechend der ausgewählten Abdeckung sind hier folgende Werte möglich:
1 = Basisabdeckung
2 = Teilabdeckung
3 = Vollabdeckung 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
Werden Zuordnungen für die Bereiche Sockel-, Kranz- und Lichtleiste (Bereiche 2-4) definiert, so ist in diesem Element einzutragen, bei welcher Grundform die Zuordnung anzuwenden ist. Dieses Element muss gefüllt werden, wenn im Element SCOPE die Werte 2 bis 4 eingetragen sind. Bei den Werten 1 und 5 im Element SCOPE darf dieses Element nicht gefüllt werden. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für einen Gehrungszuschlag angegeben. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Mindestwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Maximalwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
HINGE Restriction of xs:string

Dieses Element wird verwendet, um die Informationen über den Türanschlag des Artikels zu hinterlegen. Es werden keine geometrischen Informationen der Grundform des Artikels gesteuert. Hierzu wird das Feld CONSTRUCTION_ID verwendet.

Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.

Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID => das Element HINGE muss mit dem Wert "N" gefüllt werden.

Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) der Wert "J" enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral.

 D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element wird die äquivalente Katalogseite des Artikels angegeben. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall sollte die erste Seitennummer auf der der Artikel/ die Type auftaucht, verwendet werden. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

In diesem Element kann die äquivalente Katalogseite des Artikels in dem als .pdf-Datei abgelegten Kataloges angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gespeicherten Katalogs.

In dem Element DETAIL_INFO (auf Katalogebene) ist die URL der .pdf-Datei hinterlegt Da es Artikel gibt, die auf mehreren Seiten im Katalog aufgeführt sind, ist sicher zu stellen, dass die Angabe für die .pdf-Datei mit der 40-stelligen Katalogseite CATALOG_PAGE übereinstimmt, das heißt, beide Angaben verweisen auf die selbe Seite.

 D positiveInteger
P
M [1:999]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT optional Restriction of xs:nonNegativeInteger

In dieses Element wird das Gewicht des Artikels [100 g] inklusive Verpackungsmaterial angegeben. (z. B. 50 = 5000 g).
Dabei drückt der Code im Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.
Langteile werden entsprechend des Brutto-Gwichts je Preiseinheit berechnet.

Beispiel:
Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³] des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
CONSTRUCTION_ID Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P [JLNRAE]
M [1:1]
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt, wird in diesem Element die Herstellernummer eingetragen.

Handelt es sich bei diesem Artikel um ein sichtbares Zulieferteil, so müssen entweder die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO oder die Elemente FILE_NAME_TEXTURE_1/2 gefüllt werden.

Die Herstellernummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Herstellernummer im Verkauf nicht öffentlich zu machen. 		D nonNegativeInteger
P
M [0:9999]
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt (SUBCONTRACTOR_ID muss gefüllt sein), wird in diesem Element die Artikelnummer des Herstellers eingetragen.

Die Artikelnummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Artikelnummer im Verkauf nicht öffentlich zu machen. 		D string
P
M [1:15]
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D nonNegativeInteger
P
M [0:99]
OLD_TYPE_NO optional Restriction of xs:string
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D string
P
M [1:15]
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist mindestens eines der Elemente FILENAME_TEXTURE_1/2 gefüllt, so ist dieses Element nicht optional. 		D boolean
P
M
MODELING_GRAPHIC_ID optional Restriction of xs:string
Dieses Element dient der Referenzierung auf eine Echtgrafik. D string
P
M [1:15]
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung). 		D nonNegativeInteger
P
M [0:999]
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

Über dieses Element werden die werkseitigen Änderungsmöglichkeiten eines Artikels gesteuert. Die Änderungsmöglichkeiten der Artikel sind abhängig von der Definition seiner Grundformparameter im Element PARAMETERS (Pfad 1).

0 = alle Maßparameter (PARAMETERS (Pfad 1)) sind gesperrt, eine Maßänderung ist nicht möglich;

1 = die Maßparameter (PARAMETERS (Pfad 1)) sind im Rahmen der in SA500 angelegten Daten änderbar. Das zu ändernde Maß muss vom Benutzer abgefragt werden;

2 = alle Maßparameter (PARAMETERS (Pfad 1)) sind änderbar, gesperrte Parameter müssen identische Werte in den Attributen NOMINAL_VALUE (Pfad 1), FROM (Pfad 1) und TO (Pfad 1) haben.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie Dateiname_Textur_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente FILE_NAME_TEXTURE_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie FILE_NAME_TEXTURE_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente Dateiname_Textur_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern in angegeben werden.
Nur bei dem Parameter B dürfen die Attrubute FROM (Wert von) und TO (Wert bis) gefüllt werden.
Dieses Element darf nur gefüllt werden, wenn es sich bei dem Artikel um eine Kranz-, Licht- oder Sockelleiste, Arbeitsplatte, Abdeckplatte, Barplatte oder Wandabschlussprofil handelt.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
Als OPTION_KEY wird der herstellerspezifische Key für die Profilform verwendet, wie dieser auch im Verkaufhandbuch angegeben ist.
Im Element BASIC_PROFILE_SHAPE/OPTION_REF dürfen nur die Variantenarten 750-756 verwendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:5]
BASIC_SHAPE_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.
Die anzugebenen Daten sind abhängig von den Grundformen und den Abschnitten unterhalb der Grundformen zu entnehmen.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn im Element ITEM (Pfad 1) mindestens ein Element mit dem Element Artikelkennung = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
MODULE_PARTS optional

Falls der entsprechende Artikel ein Varioschrank ist, enthält dieses Element eine Stückliste von Modulelementen, wobei das erste Element ein Basisschrank mit der Position 0 ist und danach von unten nach oben die Modulelemente folgen. Dieses Element darf nicht angegeben werden, wenn der dazu gehörige Artikel kein Varioschrank ist.

Der Varioschrank hat einen festen Preis. Sobald der Varioschrank verändert wird, ergibt sich der neue Preis aus Preis für Basisschrank + Preis für die Module. Dabei entfällt der Varioschrank, der Basisschrank wird Hauptposition und hat alle anderen Modulelemente als Unterposition in der Reihenfolge von unten nach oben.

Die Modulelemente können programm- und ausführungsabhängig sein.

Für Modulelemente können Regeln bezüglich ihrer Höhe innerhalb des Basisschrankes über MODUL_RULE_SETS festgelegt werden. Dabei wird die global definierte Modulregel referenziert.

Dem Basisschrank kann solch eine Regel über MODULE_RULE_SET_REF zugeordnet werden.

Sequence
MODULE_PART 1..∞

Dieses Element entspricht einem Teil der Stückliste von Modulelementen eines Varioschrankes. Die Elemente müssen in ihrer Reihenfolge von unten nach oben angegeben werden. Die Position 0 (PART_SEQUENTIAL_NO) ist der leere Basisschrank (Schrank mit Typ-Art 17). Danach folgen von unten nach oben die Modulelemente (Schränke mit Typ-Schlüssel 10). Der Anschlag des Basisschrankes ist identisch zu Anschlag des Varioschrankes.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels innerhalb des Varioschrankes angegeben. Dabei muss der Basisschrank (Typ_Art 17) den Positionswert 0 beinhalten. Die Modulelemente (Typ-Schlüssel 10) erhalten in der Reihenfolge von unten nach oben weitere Positionsnummern. D nonNegativeInteger
P
M [0:999]
ITEM_REF
In diesem Element werden der Basisschrank (Typ-Art 17) und die einzelnen Modulelemente (Typschlüssel 10) referenziert.
Dabei muss dem Basisschrank die Position (PART_SEQUENTIAL_NO) 0 zugewiesen werden. Die übrigen Modulelemente müssen passend zu dem Attribut PART_SEQUENTIAL_NO in der Reihenfolge von unten nach oben referenziert werden.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikeltype eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
HEIGHT_VARIABLE optional xs:boolean
Ist der Wert von diesem Flag auf true(1) gesetzt, bedeutet es, dass das entsprechende Modulelement Veränderungen bei Veränderungen anderer Elemente innerhalb der Liste aufnimmt. Das bedeutet, wird ein anderes Modulelement größer oder kleiner, passt sich das mit HEIGT_VARIABLE true gekennzeichnete Modulelement so an, dass die Gesamthöhe aller Modulelemente innerhalb des Basisschrankes wieder erreicht wird. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
Ein Modulelement kann variabel sein, hat in der Liste aber eine feste Höhe, die bei variablen Maßen in diesem Element angegeben werden muss. D nonNegativeInteger
P
M [1:99999]
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT

Dieses Element enthält Kurztexte.

Der Kurztext darf maximal drei Zeilen lang sein und muss mit einem den Artikel näher beschreibenden Text gefüllt werden. Der Kurztext muss alleinstehend auf Kundenformularen druckbar sein. Dieser Text muss einen endverbraucherorientierten Inhalt haben. Der Kurztext muss immer vorhanden sein. Die letzte Zeile eines Kurztextes darf am Zeilenende keine Trennzeichen (z. B. – oder /) enthalten.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type

Der Volltext ergänzt den Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten " der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel " der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.
Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
FRONT_DIVISIONS optional
In diesem Element werden die möglichen Frontaufteilungen für einen Artikel definiert.
Die Frontaufteilungen können in Abhängigkeit des Programms unterschiedlich sein oder der Artikel hat in Abhängigkeit von Einbaugeräten unterschiedliche Frontaufteilungen.

Frontaufteilungen, die in mehrere Programme gleich sind, können in Frontgruppen zusammengefasst werden. Die Frontgruppen werden dann von den Programmen referenziert.

Die Frontaufteilungen beziehen sich auf die linke Bauweise. Ist der Artikel auch in rechter Bauweise vorhanden, so wird die Frontaufteilung von der Planungssoftware gespiegelt.
Sequence
FRONT_GROUP 1..99
In diesem Element werden die Frontaufteilungen definiert und zu einer Frontgruppe zusammengefasst.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein.

Ist die FRONT_GROUP gültig für alle Programme, so wird 0 hinterlegt. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
In diesem Element wird eine Frontaufteilung definiert und die einzelnen Zellen der Frontaufteilung beschrieben.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
Die Frontaufteilung wird nach der im Anhang beschriebenen Syntax eingegeben. Regalaufteilungen werden nicht über diese Syntax realisiert, sondern als eine Zelle betrachtet (siehe FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
In diesem Element werden die intern unterschiedlichen Bestellnummern für einen Artikel eingegeben, der in verschiedenen Frontaufteilungen lieferbar ist und im Katalog nur eine Artikelkennung besitzt. D string
P
M [1:15]
FRONT_CELL 1..∞
In diesem Element werden die einzelnen Zellen einer Frontaufteilung definiert.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
In diesem Attribut wird die Nummer der Zelle angegeben, die definiert werden soll. Die Zellennummer wird in der Frontaufteilung (FRONT_DIVISION_DEF) festgelegt. D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
In diesem Element wird angegeben, welchen Fronttyp die Zelle hat. Die Zuordnung eines Frontelementes erfolgt über den Fronttyp (siehe Element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

Folgende Fronttypen können zugeordnet werden:

1 - 100 = Türen
101 - 200 = Schubladen
201 - 300 = Auszüge
301 – 400 = Klappen
401 – 450 = Nischen mit Blende
451 – 500 = Nischen ohne Blende
501 – 550 = offene Fächer/Fachnischen
551 – 600 = Regale
601 – 650 = feste Blenden
651 – 700 = Schaltkastenblenden
701 – 750 = Jalousien
751 – 800 = Rollfronten
801 – 900 = Diverses 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
Die Elemente PARAMETER_1 und PARAMETER_2 werden für sichtbare Fachböden (z. B. Regale, Glasschränke) verwendet, um die Anzahl der Fachböden anzugeben.
PARAMETER_1 gibt die Anzahl der horizontalen Fachböden an. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
Dieses Element gibt die Anzahl der vertikalen Unterteilungen bei Regalen an. Gilt für sichtbare Fachböden (z. B. Regale, Glasschränke). D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle)
3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) keine Spiegelung
1) Spiegelung nur bei Änderung des Anschlags
2) Spiegelung nur bei Änderung der Bauweise
3) Spiegelung wenn sich entweder Anschlag oder Bauweise verändert
4) Spiegelung wenn Anschlag und Bauweise gemeinsam verändert werden.

Festlegungen werden im Kopftext dokumentiert und anhand von Beispielen verdeutlicht.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

Hier wird die Position der Kehlleiste definiert

1) = horizontal
2) = vertikal

 D nonNegativeInteger
P
M [1:2]
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Artikel eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Frontausprägungen, die mit diesem Element zugeordnet werden, sind programmunabhängig.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Durch dieses Feld wird eine Beziehung zwischen der im Datensatz definierten Variante und einer Frontausprägung definiert. D positiveInteger
P
M
Choice optional
MODULE_RULE_SET_REF optional
Mit diesem Element referenziert der Artikel eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS. Nur Modulschränke (Typenschlüsselart = 17) können an dieser Stelle ein Modulregelset referenzieren. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D positiveInteger
P
M
MODULE_RULE_SETS optional
Dieses Element enthält die Modulregelwerke für Modulelemente. Ist der Artikel ein Modulelement (Typenschlüssel = 10), dann werden hier die Regeln für die Verplanung des Moduls hinterlegt. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden
Sequence
MODULE_RULE_SET 1..∞
In diesem Element wird dem Modulelement ein Set von Regeln zugewiesen. Jedes Set von Regeln referenziert über die MODULE_RULE_SET_NO das zugehörige Umbaumodul. Dadurch ist es möglich einem Artikel für verschiedene Umbaumodule unterschiedliche Regelwerke mitzugeben.
Sequence
MODULE_RULES
Ein Set von Regeln für den Einbau des Moduls in einen Modulschrank.
Sequence
MODULE_RULE 1..∞
Eine Regel für den Einbau des Moduls in einen Modulschrank.
Die Regel definiert unter welchen Voraussetzungen ein Modul in einem Umbauschrank plaziert werden kann.

Ein Modul muss den Typenschlüssel 10 haben.
Sequence
MODULE_POSITION Restriction of xs:string
Hier wird definiert welcher Wert geprüft werden soll.

LINE_BOTTOM | Unterkante des Modulelements in mm
LINE_TOP | Oberkante des Modulelements

Bei diesen Prüfungen sind MIN_VALUE oder MAX_VALUE anzugeben.
 D string
P LINE_BOTTOM|LINE_TOP

M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Maximalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Minimalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
MODULE_RULE_SET_REF
Mit diesem Element referenziert das Regelwerk eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS und die Umbauschränke, für die das betreffende Regelwerk gilt.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut referenziert das Regelwerk auf die MODULE_RULE_SET_DEFINITION und die Umbauschränke für die das Regelwerk mit diesem Artikel gültig ist. D nonNegativeInteger
P
M
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Bemerkung

Quelle
<xs:element name="ITEM" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECO_MOBILIER" minOccurs="0">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9]{11}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="NET_WEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
        <xs:annotation>
          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence minOccurs="0">
            <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>450/470--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>450--4--Preisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE">
                    <xs:annotation>
                      <xs:documentation>450--5--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>470--4--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPE_REF">
        <xs:annotation>
          <xs:documentation>400/407--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400/407--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CALC_GROUP_REF">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="CALC_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="10" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP_REF">
              <xs:annotation>
                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>460--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FIELD">
                          <xs:annotation>
                            <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE">
                          <xs:annotation>
                            <xs:documentation>460--5--Preis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="-99999999" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CALC_GROUP_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="CALC_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="10" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>407--7--Tausch_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>407--7--Tausch_ID</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_TYPE_REF">
              <xs:annotation>
                <xs:documentation>407--5--Preisart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="PRICE_TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>407--5--Preisart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>409--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>409--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>409--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>409--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="99999" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>406--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="GROUP_TITLE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>120--0--NEW</xs:documentation>
                                <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                              <xs:annotation>
                                <xs:documentation>406--7--Anzahl</xs:documentation>
                                <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>Version 2.4.1</xs:documentation>
                                <xs:documentation>geändert 13.09.2016</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="99999" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SET_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MANDATORY_ITEMS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="GROUP_TITLE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>120--0--NEW</xs:documentation>
                                <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                              <xs:annotation>
                                <xs:documentation>406--7--Anzahl</xs:documentation>
                                <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>Version 2.4.1</xs:documentation>
                                <xs:documentation>geändert 13.09.2016</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="99999" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SET_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPERATION_ITEM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SCOPE" maxOccurs="5">
                    <xs:annotation>
                      <xs:documentation>411--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>411--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLASS">
                                <xs:annotation>
                                  <xs:documentation>411--7--Art</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="21" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>411--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>411--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[LNR]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="COVER" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--9--Abdeckung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="3" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--10--Wert</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_MIN" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--10--minimaler Wert</xs:documentation>
                                  <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_MAX" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>411--10--maximaler Wert</xs:documentation>
                                  <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SCOPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>411--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="HINGE">
        <xs:annotation>
          <xs:documentation>400--4--Anschlag</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BEJLMNR]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDP_NUMBER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--10--EDV_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EAN_NUMBER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>400--14--Artikelkennung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BEKSMZVPNOG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_PAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--15--Katalog_Seite</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="40" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_PAGE_PDF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
          <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
          <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT_ID_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="VAT_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="WEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--20--Gewicht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VOLUME" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--21--Volumen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONSTRUCTION_ID">
        <xs:annotation>
          <xs:documentation>400--23--Bauweise_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[JLNRAE]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SUBCONTRACTOR_ID" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="OLD_SERIE_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="OLD_TYPE_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--27--Type_Alt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MASKING" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--30--Maskierung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="MODELING_GRAPHIC_ID" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RANGE_DEPENDENT">
        <xs:annotation>
          <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_PROFILE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:choice>
              <xs:element name="CARCASE_BASIC_SHAPE">
                <xs:annotation>
                  <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>400--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType mixed="true">
                        <xs:sequence>
                          <xs:element name="OPTION_REF">
                            <xs:annotation>
                              <xs:documentation>430--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="FEATURE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>430--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPTION_KEY" use="required">
                                <xs:annotation>
                                  <xs:documentation>430--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,5}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="BASIC_SHAPE_PARAMETERS">
                      <xs:annotation>
                        <xs:documentation>500--1--Satzart</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>500--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                <xs:annotation>
                                  <xs:documentation>500--0--Parameter</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>500--5--Nennwert</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="BASIC_SHAPE_FROM">
                                <xs:annotation>
                                  <xs:documentation>500--6--Von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="BASIC_SHAPE_TO">
                                <xs:annotation>
                                  <xs:documentation>500--7--Bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                <xs:annotation>
                                  <xs:documentation>500--8--Schrittweite</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                <xs:annotation>
                  <xs:documentation>400--32--Massbild</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:minLength value="1" />
                          <xs:maxLength value="240" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="DIMENSIONAL_PARAMETERS">
                      <xs:annotation>
                        <xs:documentation>500--1--Satzart</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>500--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSIONAL_FROM">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSIONAL_TO">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:decimal">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>400--32--Massbild</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:choice>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BLOCK_PARTS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_PART" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_SEQUENTIAL_NO">
                    <xs:annotation>
                      <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HINGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--6--Anschlag</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[BEJLMNR]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXCHANGE_CONDITION">
                    <xs:annotation>
                      <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="2" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STATUS">
                    <xs:annotation>
                      <xs:documentation>401--8--Status</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[ABELSZ]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[JLNRAE]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MODULE_PARTS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_PART" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PART_SEQUENTIAL_NO">
                    <xs:annotation>
                      <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:maxInclusive value="999" />
                        <xs:minInclusive value="0" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_TEXT">
        <xs:annotation>
          <xs:documentation>410--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SHORT_TEXT">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--6--Textzeile</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="TYPE_KEY">
        <xs:annotation>
          <xs:documentation>445--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_TYPE">
              <xs:annotation>
                <xs:documentation>445--4--TS_Typ</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_CLASS">
              <xs:annotation>
                <xs:documentation>445--5--TS_Art</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
              <xs:annotation>
                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                  <xs:annotation>
                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="TK_MATERIAL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--21--TS_Material</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-2]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_SHAPE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--22--TS_Form</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-2]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CLASSIFICATIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS_NO">
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:totalDigits value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_DIVISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>510--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_GROUP" maxOccurs="99">
              <xs:annotation>
                <xs:documentation>510/540--0/0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>510/540--0/0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_DIVISION_DEF">
                          <xs:annotation>
                            <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="250" />
                              <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FRONT_CELL_NO">
                                <xs:annotation>
                                  <xs:documentation>540--6--Zellennummer</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FRONT_TYPE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--7--Fronttyp</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="900" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--8--Griffposition_1</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--9--Griffposition_2</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--10--Grifflage_1</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="4" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--11--Grifflage_2</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="4" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PARAMETER_1" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--12--Parameter_1</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PARAMETER_2" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--13--Parameter_2</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="4" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="UPPER_JOIN" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[VLSG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="LOWER_JOIN" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[VLSG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="LEFT_JOIN" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[VLSG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="RIGHT_JOIN" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[VLSG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="DOUCINE_POSITION" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>540--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="2" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FRONT_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>510/540--0/0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:choice minOccurs="0">
        <xs:element name="MODULE_RULE_SET_REF" minOccurs="0">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="MODULE_RULE_SETS" minOccurs="0">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="MODULE_RULES">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="MODULE_POSITION">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                                      <xs:enumeration value="LINE_BOTTOM" />
                                      <xs:enumeration value="LINE_TOP" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="MAX_VALUE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="99999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="MIN_VALUE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="99999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MODULE_RULE_SET_REF">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
      </xs:choice>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PROPERTIES" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="PROPERTY_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="VALUE" use="required">
                  <xs:annotation>
                    <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ECO_MOBILIER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ECO_MOBILIER Element
Beschreibung

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Der Code drückt unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D string
P [0-9]{11}
M [11:11]

Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ECO_MOBILIER Element
Overview
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Der Code drückt unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D string
P [0-9]{11}
M [11:11]

Bemerkung

Quelle
<xs:element name="ECO_MOBILIER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{11}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

NET_WEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : NET_WEIGHT Element
Beschreibung

In diesem Attribut wird das Nettogewicht angegeben.

Dabei drückt der Code im vorhergehenden Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]

Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
NET_WEIGHT Element
Overview
NET_WEIGHT optional Restriction of xs:nonNegativeInteger

In diesem Attribut wird das Nettogewicht angegeben.

Dabei drückt der Code im vorhergehenden Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.

Langteile werden entsprechend des Netto-Gwichts je Preiseinheit berechnet.

Beispiel:

Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]

Bemerkung

Quelle
<xs:element name="NET_WEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Nettogewicht je Preiseinheit</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Beschreibung
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisvariantengruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
Namensraum (none)
Diagramm
ITEM_PRICE Element Sequence PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Overview
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisvariantengruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf das Preisfeld. D positiveInteger
P
M [1:250]

PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
Über dieses Element wird definiert, dass es sich bei dem angegebenen Preis um einen Preis auf
Anfrage handelt. Das Element wird im Kombination mit dem Element PRICE_CALC_METHOD ausgewertet.

Bedeutung der Werte:
1/true = Preis auf Anfrage.

Wenn das Element angelegt wird, ist nur true erlaubt.

Das Element darf nur angelegt werden, wenn der Artikel in mehreren Preisgruppen vorhanden ist.

Definition "Preis auf Anfrage" für eine Preisgruppe des Artikels:
Das Element ITEM_PRICE wird mit der entsprechenden Preisgruppe angelegt. Das Element
PRICE_ON_REQUEST wird mit dem Wert true angelegt. Die Werte im Element PRICE haben dann folgende Bedeutung:
- der Wert 0 hat keine Bedeutung,
- ein Wert ungleich 0 stellt einen Richtwert für den Preis dar, der verbindliche Preis
muss dennoch beim Hersteller angefragt werden.

Definition "Preis auf Anfrage" für den gesamten Artikel:
Element ITEM_PRICE wird nicht angelegt. In dem Element PRICE_FEATURE_GROUP wird über das Attribut PRICE_CALC_METHOD (P1) definiert, dass die Preise für den Artikel beim Hersteller erfragt werden müssen. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 € = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (P3/PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (P5/BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (P5/PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (P3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (P1/PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Bemerkung

Quelle
<xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence minOccurs="0">
      <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>450/470--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>450--4--Preisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>450--5--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
              <xs:annotation>
                <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
              <xs:annotation>
                <xs:documentation>470--4--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element : ITEM_PRICE Element
Beschreibung
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Namensraum (none)
Diagramm
BASIC_PRICE_UNIT Element PRICE_MINIMUM_BASIC Element PRICE_ON_REQUEST Element PRICE Element PRICE_FIELD Element Sequence ITEM_PRICE Element
Overview
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf das Preisfeld. D positiveInteger
P
M [1:250]

PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_ON_REQUEST optional Restriction of xs:boolean
Über dieses Element wird definiert, dass es sich bei dem angegebenen Preis um einen Preis auf
Anfrage handelt. Das Element wird im Kombination mit dem Element PRICE_CALC_METHOD ausgewertet.

Bedeutung der Werte:
1/true = Preis auf Anfrage.

Wenn das Element angelegt wird, ist nur true erlaubt.

Das Element darf nur angelegt werden, wenn der Artikel in mehreren Preisgruppen vorhanden ist.

Definition "Preis auf Anfrage" für eine Preisgruppe des Artikels:
Das Element ITEM_PRICE wird mit der entsprechenden Preisgruppe angelegt. Das Element
PRICE_ON_REQUEST wird mit dem Wert true angelegt. Die Werte im Element PRICE haben dann folgende Bedeutung:
- der Wert 0 hat keine Bedeutung,
- ein Wert ungleich 0 stellt einen Richtwert für den Preis dar, der verbindliche Preis
muss dennoch beim Hersteller angefragt werden.

Definition "Preis auf Anfrage" für den gesamten Artikel:
Element ITEM_PRICE wird nicht angelegt. In dem Element PRICE_FEATURE_GROUP wird über das Attribut PRICE_CALC_METHOD (P1) definiert, dass die Preise für den Artikel beim Hersteller erfragt werden müssen. 		D boolean
P
M
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 € = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (P3/PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (P5/BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (P5/PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (P3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (P1/PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
Quelle
<xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450/470--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>450--4--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>450--5--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_ON_REQUEST" minOccurs="0">
        <xs:annotation>
          <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
        <xs:annotation>
          <xs:documentation>470--4--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FIELD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_FIELD Element
Beschreibung
Dieses Element refrenziert auf das Preisfeld. D positiveInteger
P
M [1:250]

Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf das Preisfeld. D positiveInteger
P
M [1:250]

Quelle
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--4--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE Element
Beschreibung
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
Namensraum (none)
Typ
Restriction of xs:integer
Diagramm
PRICE Element
Overview
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
Quelle
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--5--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_ON_REQUEST Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_ON_REQUEST Element
Beschreibung
Über dieses Element wird definiert, dass es sich bei dem angegebenen Preis um einen Preis auf
Anfrage handelt. Das Element wird im Kombination mit dem Element PRICE_CALC_METHOD ausgewertet.

Bedeutung der Werte:
1/true = Preis auf Anfrage.

Wenn das Element angelegt wird, ist nur true erlaubt.

Das Element darf nur angelegt werden, wenn der Artikel in mehreren Preisgruppen vorhanden ist.

Definition "Preis auf Anfrage" für eine Preisgruppe des Artikels:
Das Element ITEM_PRICE wird mit der entsprechenden Preisgruppe angelegt. Das Element
PRICE_ON_REQUEST wird mit dem Wert true angelegt. Die Werte im Element PRICE haben dann folgende Bedeutung:
- der Wert 0 hat keine Bedeutung,
- ein Wert ungleich 0 stellt einen Richtwert für den Preis dar, der verbindliche Preis
muss dennoch beim Hersteller angefragt werden.

Definition "Preis auf Anfrage" für den gesamten Artikel:
Element ITEM_PRICE wird nicht angelegt. In dem Element PRICE_FEATURE_GROUP wird über das Attribut PRICE_CALC_METHOD (P1) definiert, dass die Preise für den Artikel beim Hersteller erfragt werden müssen. 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
PRICE_ON_REQUEST Element
Overview
PRICE_ON_REQUEST optional Restriction of xs:boolean
Über dieses Element wird definiert, dass es sich bei dem angegebenen Preis um einen Preis auf
Anfrage handelt. Das Element wird im Kombination mit dem Element PRICE_CALC_METHOD ausgewertet.

Bedeutung der Werte:
1/true = Preis auf Anfrage.

Wenn das Element angelegt wird, ist nur true erlaubt.

Das Element darf nur angelegt werden, wenn der Artikel in mehreren Preisgruppen vorhanden ist.

Definition "Preis auf Anfrage" für eine Preisgruppe des Artikels:
Das Element ITEM_PRICE wird mit der entsprechenden Preisgruppe angelegt. Das Element
PRICE_ON_REQUEST wird mit dem Wert true angelegt. Die Werte im Element PRICE haben dann folgende Bedeutung:
- der Wert 0 hat keine Bedeutung,
- ein Wert ungleich 0 stellt einen Richtwert für den Preis dar, der verbindliche Preis
muss dennoch beim Hersteller angefragt werden.

Definition "Preis auf Anfrage" für den gesamten Artikel:
Element ITEM_PRICE wird nicht angelegt. In dem Element PRICE_FEATURE_GROUP wird über das Attribut PRICE_CALC_METHOD (P1) definiert, dass die Preise für den Artikel beim Hersteller erfragt werden müssen. 		D boolean
P
M
Quelle
<xs:element name="PRICE_ON_REQUEST" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--6--Preis_auf_Anfrage</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_MINIMUM_BASIC Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_MINIMUM_BASIC Element
Beschreibung
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 € = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (P3/PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (P5/BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (P5/PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (P3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
Namensraum (none)
Typ
Restriction of xs:integer
Diagramm
PRICE_MINIMUM_BASIC Element
Overview
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 € = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (P3/PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (P5/BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (P5/PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (P3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
Quelle
<xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>470--4--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_PRICE_UNIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : BASIC_PRICE_UNIT Element
Beschreibung
Wenn eine Preisart (P1/PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BASIC_PRICE_UNIT Element
Overview
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (P1/PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [-99999999:999999999]
Quelle
<xs:element name="BASIC_PRICE_UNIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_TYPE_REF Element
Beschreibung
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
Namensraum (none)
Diagramm
PRICE_TYPE_REF Element
Overview
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_TYPE_NO Restriction of xs:positiveInteger required
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Bemerkung

Quelle
<xs:element name="PRICE_TYPE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400/407--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400/407--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CALC_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CALC_GROUP_REF Element
Beschreibung
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
Namensraum (none)
Diagramm
CALC_GROUP_REF Element
Overview
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
CALC_GROUP_NO Restriction of xs:positiveInteger required
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
Bemerkung

Quelle
<xs:element name="CALC_GROUP_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="CALC_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="10" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EXCHANGE_ID_REF Element
Beschreibung
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
Namensraum (none)
Diagramm
EXCHANGE_ID_REF Element
Overview
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Bemerkung

Quelle
<xs:element name="EXCHANGE_ID_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ADDITIONAL_PRICE_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ADDITIONAL_PRICE_GROUP Element
Beschreibung
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Namensraum (none)
Diagramm
PRICE_TYPE_REF Element EXCHANGE_ID_REF Element CALC_GROUP_REF Element PRICE_FEATURE_GROUP_REF Element Sequence ADDITIONAL_PRICE_GROUP Element
Overview
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Mehrpreisgruppe referenziert. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf die Preisgruppe. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden : -900) 		D integer
P
M [-99999999:999999999]
CALC_GROUP_REF optional
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination „00“ ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers. 		D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID referenziert Blockartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Der Wert 0 darf nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad11/PRICE_TYPE definiert.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Bemerkung

Quelle
<xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP_REF">
        <xs:annotation>
          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>460--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE">
                    <xs:annotation>
                      <xs:documentation>460--5--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CALC_GROUP_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="CALC_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="10" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>407--7--Tausch_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--7--Tausch_ID</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPE_REF">
        <xs:annotation>
          <xs:documentation>407--5--Preisart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--5--Preisart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : PRICE_FEATURE_GROUP_REF Element
Beschreibung
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
Namensraum (none)
Diagramm
ITEM_PRICE Element Sequence PRICE_FEATURE_GROUP_REF Element
Overview
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Mehrpreisgruppe referenziert. D positiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf die Preisgruppe. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden : -900) 		D integer
P
M [-99999999:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Mehrpreisgruppe referenziert. D positiveInteger
P
M [1:99999]
Quelle
<xs:element name="PRICE_FEATURE_GROUP_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>460--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>460--5--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element : ITEM_PRICE Element
Beschreibung
In diesem Element wird der Artikelpreis hinterlegt.
Namensraum (none)
Diagramm
PRICE Element PRICE_FIELD Element Sequence ITEM_PRICE Element
Overview
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf die Preisgruppe. D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden : -900) 		D integer
P
M [-99999999:999999999]
Quelle
<xs:element name="ITEM_PRICE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>460--5--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FIELD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element > ITEM_PRICE Element : PRICE_FIELD Element
Beschreibung
Dieses Element refrenziert auf die Preisgruppe. D positiveInteger
P
M [1:250]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger
Dieses Element refrenziert auf die Preisgruppe. D positiveInteger
P
M [1:250]
Quelle
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element > ITEM_PRICE Element : PRICE Element
Beschreibung
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden : -900) 		D integer
P
M [-99999999:999999999]
Namensraum (none)
Typ
Restriction of xs:integer
Diagramm
PRICE Element
Overview
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden : -900) 		D integer
P
M [-99999999:999999999]
Quelle
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--5--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CALC_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : CALC_GROUP_REF Element
Beschreibung
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
Namensraum (none)
Diagramm
CALC_GROUP_REF Element
Overview
CALC_GROUP_REF optional
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen (PRICE_DEFINITION/MERCHANDISE_GROUP) definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination „00“ ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers. 		D positiveInteger
P
M [10:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
CALC_GROUP_NO Restriction of xs:positiveInteger required
Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination „00“ ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers. 		D positiveInteger
P
M [10:99]
Quelle
<xs:element name="CALC_GROUP_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="CALC_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="10" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : EXCHANGE_ID_REF Element
Beschreibung
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID referenziert Blockartikel.
Namensraum (none)
Diagramm
EXCHANGE_ID_REF Element
Overview
EXCHANGE_ID_REF optional
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID referenziert Blockartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Der Wert 0 darf nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Der Wert 0 darf nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]
M [1:89]
Quelle
<xs:element name="EXCHANGE_ID_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>407--7--Tausch_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--7--Tausch_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : PRICE_TYPE_REF Element
Beschreibung
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad11/PRICE_TYPE definiert.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_TYPES
Namensraum (none)
Diagramm
PRICE_TYPE_REF Element
Overview
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad11/PRICE_TYPE definiert.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_TYPE_NO Restriction of xs:positiveInteger required
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Quelle
<xs:element name="PRICE_TYPE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>407--5--Preisart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--5--Preisart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : RESTRICTIONS Element
Beschreibung
In diesem Element werden artikelspezifische Prüfverfahren zugeordnet.

Es dürfen nur Prüfverfahren referenziert werden, deren Variantenarten in der Variantenfamilie des Artikels enthalten sind.

Wenn ein Artikel Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Artikelspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.
Namensraum (none)
Diagramm
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
In diesem Element werden artikelspezifische Prüfverfahren zugeordnet.

Es dürfen nur Prüfverfahren referenziert werden, deren Variantenarten in der Variantenfamilie des Artikels enthalten sind.

Wenn ein Artikel Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Artikelspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Artikel zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>409--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>409--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>409--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>409--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99999" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > RESTRICTIONS Element : RESTRICTION_REF Element
Beschreibung
Dieses Element referenziert ein, dem Artikel zugeordnetes Prüfverfahren.
Namensraum (none)
Diagramm
RESTRICTION_REF Element
Overview
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Artikel zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE Restriction of xs:nonNegativeInteger required
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="RESTRICTION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>409--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>409--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>409--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99999" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
RESTRICTIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ADDITIONAL_ITEMS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ADDITIONAL_ITEMS Element
Beschreibung
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Namensraum (none)
Diagramm
OPERATION_ITEM Element MANDATORY_ITEMS Element OPTIONAL_ITEMS Element Sequence ADDITIONAL_ITEMS Element
Overview
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden. Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von notwendigen Zusatzartikeln definiert werden. Aus der Menge der notwendigen Zusatzartikel muss genau ein Artikel ausgewählt werden. Wird in einer Menge von notwendigen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
OPERATION_ITEM optional

Durch dieses Element ist es möglich, eine Verknüpfung zwischen Artikeln und beispielsweise für die Artikel gültige Sonderanfertigungsarten, Gehrungszuschläge, Sichtseiten oder Ausklingungen zu definieren. Die Art der Verknüpfung wird über die Elemente ITEM_REF/SCOPE (Pfad 1) und CLASS (Pfad 1) beschrieben.

Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.

Folgende beispielartige Möglichkeiten können mit diesem Element abgebildet werden:

- Kranz, Licht- oder Sockelleisten Gehrungszuschläge zuweisen

- Artikeln zugehörige Sichtseiten zuweisen (Ausführungsabhängig/-unabhängig)

- Kranz, Licht- oder Sockelleisten zugehörige Formstücke, Retouren oder Übergänge zuweisen

- Sockelleisten die zugehörigen seitlichen Sockel zuweisen

- Arbeitsplatten die zugehörigen Ausschnitte, Ausklingungen oder Nut- und Federverbindungen zuweisen

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenkürzungen zugewiesen werden

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenerweiterungen zugewiesen werden

- Artikeln können Abweichungen von der Standardsockelhöhe zugewiesen werden.

Werden Artikel in diesem Element Sonderanfertigungsarten zugewiesen, so sind nur die zugeordneten gültig, werden keine zugeordnet, so sind alle Sonderanfertigungen an den Artikeln erlaubt.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/

Sequence
SCOPE 1..5
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden.
SCOPE_NO required Restriction of xs:positiveInteger
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
In diesem Element werden die Informationen zusammengefasst, dem Artikel innerhalb des Bereich (z. B. Type, Sockel, Kranzleiste, Lichtleiste, Arbeitsplatte) zugeordnet werden.
Sequence
CLASS Restriction of xs:positiveInteger

Hier wird definiert welcher Art die Zuordnungen sind. Es sind folgende Zuordnungsarten möglich:
1 = Sichtseite
2 = seitlicher Sockel
3 = Formstück
4 = Retoure
5 = Übergang
6 = Gehrungszuschlag
7 = Breitenkürzung
8 = Tiefenkürzung
9 = Höhenkürzung
10 = Ausschnitt
11 = Ausschnitt Rechteck
12 = Ausschnitt Rund
13 = Ausklinkung
14 = Abschrägung
15 = Abrundung
16 = Nut und Feder Verbindung
17 = Kante zu WERT 5
18 = Breitenerweiterung zu WERT 1
19 = Tiefenerweiterung zu WERT 1
20 = Höhenerweiterung zu WERT 1
21 = Abweichung vom Standardsockel

Die hier eingetragenen Werte sind abhängig von dem im Element SCOPE eingetragenem Wert und unterliegen folgender Regelung:

Element SCOPE Wert 1 => Element CLASS Werte 1, 2, 3, 7, 8, 9, 18 bis 20
Element SCOPE Wert 2 => Element CLASS Werte 2 bis 6, Wert 21
Element SCOPE Wert 3 oder 4 => Element CLASS Werte 3 bis 6
Element SCOPE Wert 5 => Element CLASS Werte 10 bis 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Hier wird die Type (Verknüpfungs-Type) referenziert, die der Ziel-Type zugeordnet wird. Die Verknüpfungs-Type muss in der gleichen Serie wie die Ziel-Type oder der Serie 0 angelegt sein.

Dieses Element muss angelegt werden, wenn im Element CLASS (Pfad 1) die Werte für Formstück (3), Retoure (4) oder Übergang (5) eingetragen sind.

Wenn dieses Element nicht angelegt wird, muss das Element VALUE (Pfad 1) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene, Bauweise eines Artikels.

L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist. 		D string
P [LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
Ist im Element CLASS der Wert 3 für Formstück eingetragen, so muss dieses Element gefüllt werden. Bei anderen Werten darf dieses Element nicht gefüllt werden. Es wird unterschieden zwischen der Basis-, Teil-, und Vollabdeckung. Die unterschiedlichen Abdeckungen für Formteile sind in Abhängigkeit der Grundform definiert und im Teil "Zuordnung der Abdeckungsarten" zu finden.

Entsprechend der ausgewählten Abdeckung sind hier folgende Werte möglich:
1 = Basisabdeckung
2 = Teilabdeckung
3 = Vollabdeckung 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
Werden Zuordnungen für die Bereiche Sockel-, Kranz- und Lichtleiste (Bereiche 2-4) definiert, so ist in diesem Element einzutragen, bei welcher Grundform die Zuordnung anzuwenden ist. Dieses Element muss gefüllt werden, wenn im Element SCOPE die Werte 2 bis 4 eingetragen sind. Bei den Werten 1 und 5 im Element SCOPE darf dieses Element nicht gefüllt werden. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für einen Gehrungszuschlag angegeben. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Mindestwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Maximalwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="ADDITIONAL_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="GROUP_TITLE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                        <xs:annotation>
                          <xs:documentation>406--7--Anzahl</xs:documentation>
                          <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>Version 2.4.1</xs:documentation>
                          <xs:documentation>geändert 13.09.2016</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="99999" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SET_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MANDATORY_ITEMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="GROUP_TITLE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="GROUP_TITLE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                        <xs:annotation>
                          <xs:documentation>406--7--Anzahl</xs:documentation>
                          <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>Version 2.4.1</xs:documentation>
                          <xs:documentation>geändert 13.09.2016</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="99999" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SET_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPERATION_ITEM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SCOPE" maxOccurs="5">
              <xs:annotation>
                <xs:documentation>411--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>411--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASS">
                          <xs:annotation>
                            <xs:documentation>411--7--Art</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="21" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>411--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>411--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[LNR]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="COVER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--9--Abdeckung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="3" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--10--Wert</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_MIN" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--10--minimaler Wert</xs:documentation>
                            <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_MAX" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>411--10--maximaler Wert</xs:documentation>
                            <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SCOPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>411--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTIONAL_ITEMS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element : OPTIONAL_ITEMS Element
Beschreibung
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden. Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.
Namensraum (none)
Diagramm
OPTIONAL_ITEM_GROUP Element Sequence OPTIONAL_ITEMS Element
Overview
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden. Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="OPTIONAL_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="GROUP_TITLE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="GROUP_TITLE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                  <xs:annotation>
                    <xs:documentation>406--7--Anzahl</xs:documentation>
                    <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>Version 2.4.1</xs:documentation>
                    <xs:documentation>geändert 13.09.2016</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="99999" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SET_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTIONAL_ITEM_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element : OPTIONAL_ITEM_GROUP Element
Beschreibung
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
Namensraum (none)
Diagramm
ITEM_REF Element GROUP_TITLE_REF Element Sequence OPTIONAL_ITEM_GROUP Element
Overview
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SET_NO Restriction of xs:positiveInteger required
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE xs:boolean required
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Quelle
<xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GROUP_TITLE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="GROUP_TITLE_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
            <xs:annotation>
              <xs:documentation>406--7--Anzahl</xs:documentation>
              <xs:documentation>K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>Version 2.4.1</xs:documentation>
              <xs:documentation>geändert 13.09.2016</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99999" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SET_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GROUP_TITLE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element > OPTIONAL_ITEM_GROUP Element : GROUP_TITLE_REF Element
Beschreibung
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
Namensraum (none)
Diagramm
GROUP_TITLE_REF Element
Overview
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
GROUP_TITLE_NO Restriction of xs:nonNegativeInteger required
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
Quelle
<xs:element name="GROUP_TITLE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="GROUP_TITLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONAL_ITEM_GROUP Element | OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element > OPTIONAL_ITEM_GROUP Element : ITEM_REF Element
Beschreibung
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
OPTIONAL_QUANTITY Restriction of xs:positiveInteger optional
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar. D nonNegativeInteger
P
M [1:999]
SEQUENCE Restriction of xs:nonNegativeInteger required
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="ITEM_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
      <xs:annotation>
        <xs:documentation>406--7--Anzahl</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>Version 2.4.1</xs:documentation>
        <xs:documentation>geändert 13.09.2016</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99999" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONAL_ITEM_GROUP Element | OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANDATORY_ITEMS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element : MANDATORY_ITEMS Element
Beschreibung
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Namensraum (none)
Diagramm
MANDATORY_ITEM_GROUP Element Sequence MANDATORY_ITEMS Element
Overview
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von notwendigen Zusatzartikeln definiert werden. Aus der Menge der notwendigen Zusatzartikel muss genau ein Artikel ausgewählt werden. Wird in einer Menge von notwendigen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="MANDATORY_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="GROUP_TITLE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="GROUP_TITLE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                  <xs:annotation>
                    <xs:documentation>406--7--Anzahl</xs:documentation>
                    <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>Version 2.4.1</xs:documentation>
                    <xs:documentation>geändert 13.09.2016</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="99999" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SET_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANDATORY_ITEM_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > MANDATORY_ITEMS Element : MANDATORY_ITEM_GROUP Element
Beschreibung
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
Namensraum (none)
Diagramm
ITEM_REF Element GROUP_TITLE_REF Element Sequence MANDATORY_ITEM_GROUP Element
Overview
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von notwendigen Zusatzartikeln definiert werden. Aus der Menge der notwendigen Zusatzartikel muss genau ein Artikel ausgewählt werden. Wird in einer Menge von notwendigen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
Sequence
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SET_NO Restriction of xs:positiveInteger required
Je Artikel kann eine Menge von notwendigen Zusatzartikeln definiert werden. Aus der Menge der notwendigen Zusatzartikel muss genau ein Artikel ausgewählt werden. Wird in einer Menge von notwendigen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
Quelle
<xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GROUP_TITLE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="GROUP_TITLE_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MANDATORY_QUANTITY" use="optional">
            <xs:annotation>
              <xs:documentation>406--7--Anzahl</xs:documentation>
              <xs:documentation>K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>Version 2.4.1</xs:documentation>
              <xs:documentation>geändert 13.09.2016</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99999" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SET_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MANDATORY_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GROUP_TITLE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > MANDATORY_ITEMS Element > MANDATORY_ITEM_GROUP Element : GROUP_TITLE_REF Element
Beschreibung
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
Namensraum (none)
Diagramm
GROUP_TITLE_REF Element
Overview
GROUP_TITLE_REF optional
Dieses Element referenziert einen Gruppentitel. Die Gruppentitel sind innerhalb des Elementes (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE) definiert.
GROUP_TITLE_NO required Restriction of xs:nonNegativeInteger
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
GROUP_TITLE_NO Restriction of xs:nonNegativeInteger required
Über dieses Attribut wird ein Gruppentitel identifiziert. D positiveInteger
P
M [0:999]
Quelle
<xs:element name="GROUP_TITLE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="GROUP_TITLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version 2.4.1 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MANDATORY_ITEM_GROUP Element | MANDATORY_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > MANDATORY_ITEMS Element > MANDATORY_ITEM_GROUP Element : ITEM_REF Element
Beschreibung
Dieses Element referenziert einen Artikel.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
MANDATORY_QUANTITY optional Restriction of xs:positiveInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
MANDATORY_QUANTITY Restriction of xs:positiveInteger optional
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
SEQUENCE Restriction of xs:nonNegativeInteger required
Durch das Attribut SEQUENCE soll in der XML-Datei eine eindeutige Reihenfolge der Zusatzartikel von 1 aufsteigend festgelegt sein. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="ITEM_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MANDATORY_QUANTITY" use="optional">
      <xs:annotation>
        <xs:documentation>406--7--Anzahl</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>Version 2.4.1</xs:documentation>
        <xs:documentation>geändert 13.09.2016</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99999" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MANDATORY_ITEM_GROUP Element | MANDATORY_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPERATION_ITEM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element : OPERATION_ITEM Element
Beschreibung

Durch dieses Element ist es möglich, eine Verknüpfung zwischen Artikeln und beispielsweise für die Artikel gültige Sonderanfertigungsarten, Gehrungszuschläge, Sichtseiten oder Ausklingungen zu definieren. Die Art der Verknüpfung wird über die Elemente ITEM_REF/SCOPE (Pfad 1) und CLASS (Pfad 1) beschrieben.

Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.

Folgende beispielartige Möglichkeiten können mit diesem Element abgebildet werden:

- Kranz, Licht- oder Sockelleisten Gehrungszuschläge zuweisen

- Artikeln zugehörige Sichtseiten zuweisen (Ausführungsabhängig/-unabhängig)

- Kranz, Licht- oder Sockelleisten zugehörige Formstücke, Retouren oder Übergänge zuweisen

- Sockelleisten die zugehörigen seitlichen Sockel zuweisen

- Arbeitsplatten die zugehörigen Ausschnitte, Ausklingungen oder Nut- und Federverbindungen zuweisen

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenkürzungen zugewiesen werden

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenerweiterungen zugewiesen werden

- Artikeln können Abweichungen von der Standardsockelhöhe zugewiesen werden.

Werden Artikel in diesem Element Sonderanfertigungsarten zugewiesen, so sind nur die zugeordneten gültig, werden keine zugeordnet, so sind alle Sonderanfertigungen an den Artikeln erlaubt.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/

Namensraum (none)
Diagramm
SCOPE Element Sequence OPERATION_ITEM Element
Overview
OPERATION_ITEM optional

Durch dieses Element ist es möglich, eine Verknüpfung zwischen Artikeln und beispielsweise für die Artikel gültige Sonderanfertigungsarten, Gehrungszuschläge, Sichtseiten oder Ausklingungen zu definieren. Die Art der Verknüpfung wird über die Elemente ITEM_REF/SCOPE (Pfad 1) und CLASS (Pfad 1) beschrieben.

Verknüpfartikel dürfen nicht als Zusatzartikel vorkommen.

Folgende beispielartige Möglichkeiten können mit diesem Element abgebildet werden:

- Kranz, Licht- oder Sockelleisten Gehrungszuschläge zuweisen

- Artikeln zugehörige Sichtseiten zuweisen (Ausführungsabhängig/-unabhängig)

- Kranz, Licht- oder Sockelleisten zugehörige Formstücke, Retouren oder Übergänge zuweisen

- Sockelleisten die zugehörigen seitlichen Sockel zuweisen

- Arbeitsplatten die zugehörigen Ausschnitte, Ausklingungen oder Nut- und Federverbindungen zuweisen

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenkürzungen zugewiesen werden

- Artikeln können die zulässigen Breiten-, Höhen- oder Tiefenerweiterungen zugewiesen werden

- Artikeln können Abweichungen von der Standardsockelhöhe zugewiesen werden.

Werden Artikel in diesem Element Sonderanfertigungsarten zugewiesen, so sind nur die zugeordneten gültig, werden keine zugeordnet, so sind alle Sonderanfertigungen an den Artikeln erlaubt.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/

Sequence
SCOPE 1..5
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden.
SCOPE_NO required Restriction of xs:positiveInteger
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
In diesem Element werden die Informationen zusammengefasst, dem Artikel innerhalb des Bereich (z. B. Type, Sockel, Kranzleiste, Lichtleiste, Arbeitsplatte) zugeordnet werden.
Sequence
CLASS Restriction of xs:positiveInteger

Hier wird definiert welcher Art die Zuordnungen sind. Es sind folgende Zuordnungsarten möglich:
1 = Sichtseite
2 = seitlicher Sockel
3 = Formstück
4 = Retoure
5 = Übergang
6 = Gehrungszuschlag
7 = Breitenkürzung
8 = Tiefenkürzung
9 = Höhenkürzung
10 = Ausschnitt
11 = Ausschnitt Rechteck
12 = Ausschnitt Rund
13 = Ausklinkung
14 = Abschrägung
15 = Abrundung
16 = Nut und Feder Verbindung
17 = Kante zu WERT 5
18 = Breitenerweiterung zu WERT 1
19 = Tiefenerweiterung zu WERT 1
20 = Höhenerweiterung zu WERT 1
21 = Abweichung vom Standardsockel

Die hier eingetragenen Werte sind abhängig von dem im Element SCOPE eingetragenem Wert und unterliegen folgender Regelung:

Element SCOPE Wert 1 => Element CLASS Werte 1, 2, 3, 7, 8, 9, 18 bis 20
Element SCOPE Wert 2 => Element CLASS Werte 2 bis 6, Wert 21
Element SCOPE Wert 3 oder 4 => Element CLASS Werte 3 bis 6
Element SCOPE Wert 5 => Element CLASS Werte 10 bis 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Hier wird die Type (Verknüpfungs-Type) referenziert, die der Ziel-Type zugeordnet wird. Die Verknüpfungs-Type muss in der gleichen Serie wie die Ziel-Type oder der Serie 0 angelegt sein.

Dieses Element muss angelegt werden, wenn im Element CLASS (Pfad 1) die Werte für Formstück (3), Retoure (4) oder Übergang (5) eingetragen sind.

Wenn dieses Element nicht angelegt wird, muss das Element VALUE (Pfad 1) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene, Bauweise eines Artikels.

L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist. 		D string
P [LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
Ist im Element CLASS der Wert 3 für Formstück eingetragen, so muss dieses Element gefüllt werden. Bei anderen Werten darf dieses Element nicht gefüllt werden. Es wird unterschieden zwischen der Basis-, Teil-, und Vollabdeckung. Die unterschiedlichen Abdeckungen für Formteile sind in Abhängigkeit der Grundform definiert und im Teil "Zuordnung der Abdeckungsarten" zu finden.

Entsprechend der ausgewählten Abdeckung sind hier folgende Werte möglich:
1 = Basisabdeckung
2 = Teilabdeckung
3 = Vollabdeckung 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
Werden Zuordnungen für die Bereiche Sockel-, Kranz- und Lichtleiste (Bereiche 2-4) definiert, so ist in diesem Element einzutragen, bei welcher Grundform die Zuordnung anzuwenden ist. Dieses Element muss gefüllt werden, wenn im Element SCOPE die Werte 2 bis 4 eingetragen sind. Bei den Werten 1 und 5 im Element SCOPE darf dieses Element nicht gefüllt werden. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für einen Gehrungszuschlag angegeben. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Mindestwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Maximalwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="OPERATION_ITEM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SCOPE" maxOccurs="5">
        <xs:annotation>
          <xs:documentation>411--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>411--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASS">
                    <xs:annotation>
                      <xs:documentation>411--7--Art</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="21" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>411--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>411--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[LNR]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="COVER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--9--Abdeckung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--10--Wert</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_MIN" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--10--minimaler Wert</xs:documentation>
                      <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_MAX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>411--10--maximaler Wert</xs:documentation>
                      <xs:documentation>13.06.2018/K.Richter</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SCOPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>411--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SCOPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element : SCOPE Element
Beschreibung
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden.
Namensraum (none)
Diagramm
ITEM_INFORMATION Element Sequence SCOPE Element
Overview
SCOPE 1..5
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden.
SCOPE_NO required Restriction of xs:positiveInteger
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden. 		D positiveInteger
P
M [1:5]
Sequence
ITEM_INFORMATION 1..∞
In diesem Element werden die Informationen zusammengefasst, dem Artikel innerhalb des Bereich (z. B. Type, Sockel, Kranzleiste, Lichtleiste, Arbeitsplatte) zugeordnet werden.
Sequence
CLASS Restriction of xs:positiveInteger

Hier wird definiert welcher Art die Zuordnungen sind. Es sind folgende Zuordnungsarten möglich:
1 = Sichtseite
2 = seitlicher Sockel
3 = Formstück
4 = Retoure
5 = Übergang
6 = Gehrungszuschlag
7 = Breitenkürzung
8 = Tiefenkürzung
9 = Höhenkürzung
10 = Ausschnitt
11 = Ausschnitt Rechteck
12 = Ausschnitt Rund
13 = Ausklinkung
14 = Abschrägung
15 = Abrundung
16 = Nut und Feder Verbindung
17 = Kante zu WERT 5
18 = Breitenerweiterung zu WERT 1
19 = Tiefenerweiterung zu WERT 1
20 = Höhenerweiterung zu WERT 1
21 = Abweichung vom Standardsockel

Die hier eingetragenen Werte sind abhängig von dem im Element SCOPE eingetragenem Wert und unterliegen folgender Regelung:

Element SCOPE Wert 1 => Element CLASS Werte 1, 2, 3, 7, 8, 9, 18 bis 20
Element SCOPE Wert 2 => Element CLASS Werte 2 bis 6, Wert 21
Element SCOPE Wert 3 oder 4 => Element CLASS Werte 3 bis 6
Element SCOPE Wert 5 => Element CLASS Werte 10 bis 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Hier wird die Type (Verknüpfungs-Type) referenziert, die der Ziel-Type zugeordnet wird. Die Verknüpfungs-Type muss in der gleichen Serie wie die Ziel-Type oder der Serie 0 angelegt sein.

Dieses Element muss angelegt werden, wenn im Element CLASS (Pfad 1) die Werte für Formstück (3), Retoure (4) oder Übergang (5) eingetragen sind.

Wenn dieses Element nicht angelegt wird, muss das Element VALUE (Pfad 1) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene, Bauweise eines Artikels.

L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist. 		D string
P [LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
Ist im Element CLASS der Wert 3 für Formstück eingetragen, so muss dieses Element gefüllt werden. Bei anderen Werten darf dieses Element nicht gefüllt werden. Es wird unterschieden zwischen der Basis-, Teil-, und Vollabdeckung. Die unterschiedlichen Abdeckungen für Formteile sind in Abhängigkeit der Grundform definiert und im Teil "Zuordnung der Abdeckungsarten" zu finden.

Entsprechend der ausgewählten Abdeckung sind hier folgende Werte möglich:
1 = Basisabdeckung
2 = Teilabdeckung
3 = Vollabdeckung 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
Werden Zuordnungen für die Bereiche Sockel-, Kranz- und Lichtleiste (Bereiche 2-4) definiert, so ist in diesem Element einzutragen, bei welcher Grundform die Zuordnung anzuwenden ist. Dieses Element muss gefüllt werden, wenn im Element SCOPE die Werte 2 bis 4 eingetragen sind. Bei den Werten 1 und 5 im Element SCOPE darf dieses Element nicht gefüllt werden. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für einen Gehrungszuschlag angegeben. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Mindestwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Maximalwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SCOPE_NO Restriction of xs:positiveInteger required
Hier wird definiert für welchen Bereich die Zuordnungen angelegt wird.

Es sind folgende Zuordnungsbereiche möglich:
1 = Type
2 = Sockel
3 = Kranzleiste
4 = Lichtleiste
5 = Arbeitsplatte

Beispielsweise bedeutet der Zuordnungsbereich 1 (Type), dass der Ziel-Type als solches etwas zugeordnet wird, nicht aber, dass der Ziel-Type eine Type zugeordnet wird.
Sind in diesem Element die Werte 1 oder 5 eingetragen, so dürfen die Elemente BASIC_SHAPE_REFERENCE und COVER nicht gefüllt werden. Sind die Werte 2 bis 3 eingetragen, so müssen die Elemente BASIC_SHAPE_REFERENCE und COVER entsprechend den Regelungen zu diesem Elementen gefüllt werden. 		D positiveInteger
P
M [1:5]
Quelle
<xs:element name="SCOPE" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_INFORMATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>411--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASS">
              <xs:annotation>
                <xs:documentation>411--7--Art</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="21" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>411--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>411--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONSTRUCTION_ID" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--4--Bauweise_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[LNR]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="COVER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--9--Abdeckung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--10--Wert</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_MIN" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--10--minimaler Wert</xs:documentation>
                <xs:documentation>13.06.2018/K.Richter</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_MAX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>411--10--maximaler Wert</xs:documentation>
                <xs:documentation>13.06.2018/K.Richter</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SCOPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>411--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_INFORMATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element : ITEM_INFORMATION Element
Beschreibung
In diesem Element werden die Informationen zusammengefasst, dem Artikel innerhalb des Bereich (z. B. Type, Sockel, Kranzleiste, Lichtleiste, Arbeitsplatte) zugeordnet werden.
Namensraum (none)
Diagramm
VALUE_MAX Element VALUE_MIN Element VALUE Element BASIC_SHAPE_REFERENCE Element COVER Element CONSTRUCTION_ID Element ITEM_REF Element CLASS Element Sequence ITEM_INFORMATION Element
Overview
ITEM_INFORMATION 1..∞
In diesem Element werden die Informationen zusammengefasst, dem Artikel innerhalb des Bereich (z. B. Type, Sockel, Kranzleiste, Lichtleiste, Arbeitsplatte) zugeordnet werden.
Sequence
CLASS Restriction of xs:positiveInteger

Hier wird definiert welcher Art die Zuordnungen sind. Es sind folgende Zuordnungsarten möglich:
1 = Sichtseite
2 = seitlicher Sockel
3 = Formstück
4 = Retoure
5 = Übergang
6 = Gehrungszuschlag
7 = Breitenkürzung
8 = Tiefenkürzung
9 = Höhenkürzung
10 = Ausschnitt
11 = Ausschnitt Rechteck
12 = Ausschnitt Rund
13 = Ausklinkung
14 = Abschrägung
15 = Abrundung
16 = Nut und Feder Verbindung
17 = Kante zu WERT 5
18 = Breitenerweiterung zu WERT 1
19 = Tiefenerweiterung zu WERT 1
20 = Höhenerweiterung zu WERT 1
21 = Abweichung vom Standardsockel

Die hier eingetragenen Werte sind abhängig von dem im Element SCOPE eingetragenem Wert und unterliegen folgender Regelung:

Element SCOPE Wert 1 => Element CLASS Werte 1, 2, 3, 7, 8, 9, 18 bis 20
Element SCOPE Wert 2 => Element CLASS Werte 2 bis 6, Wert 21
Element SCOPE Wert 3 oder 4 => Element CLASS Werte 3 bis 6
Element SCOPE Wert 5 => Element CLASS Werte 10 bis 17

 D positiveInteger
P
M [1:21]
ITEM_REF optional
Hier wird die Type (Verknüpfungs-Type) referenziert, die der Ziel-Type zugeordnet wird. Die Verknüpfungs-Type muss in der gleichen Serie wie die Ziel-Type oder der Serie 0 angelegt sein.

Dieses Element muss angelegt werden, wenn im Element CLASS (Pfad 1) die Werte für Formstück (3), Retoure (4) oder Übergang (5) eingetragen sind.

Wenn dieses Element nicht angelegt wird, muss das Element VALUE (Pfad 1) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene, Bauweise eines Artikels.

L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist. 		D string
P [LNR]
M [1:1]
COVER optional Restriction of xs:positiveInteger
Ist im Element CLASS der Wert 3 für Formstück eingetragen, so muss dieses Element gefüllt werden. Bei anderen Werten darf dieses Element nicht gefüllt werden. Es wird unterschieden zwischen der Basis-, Teil-, und Vollabdeckung. Die unterschiedlichen Abdeckungen für Formteile sind in Abhängigkeit der Grundform definiert und im Teil "Zuordnung der Abdeckungsarten" zu finden.

Entsprechend der ausgewählten Abdeckung sind hier folgende Werte möglich:
1 = Basisabdeckung
2 = Teilabdeckung
3 = Vollabdeckung 		D nonNegativeInteger
P
M [1:3]
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
Werden Zuordnungen für die Bereiche Sockel-, Kranz- und Lichtleiste (Bereiche 2-4) definiert, so ist in diesem Element einzutragen, bei welcher Grundform die Zuordnung anzuwenden ist. Dieses Element muss gefüllt werden, wenn im Element SCOPE die Werte 2 bis 4 eingetragen sind. Bei den Werten 1 und 5 im Element SCOPE darf dieses Element nicht gefüllt werden. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
VALUE optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für einen Gehrungszuschlag angegeben. D nonNegativeInteger
P
M [0:999999999]
VALUE_MIN optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Mindestwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
VALUE_MAX optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Maximalwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="ITEM_INFORMATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASS">
        <xs:annotation>
          <xs:documentation>411--7--Art</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="21" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>411--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>411--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--4--Bauweise_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[LNR]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="COVER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--9--Abdeckung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--10--Wert</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_MIN" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--10--minimaler Wert</xs:documentation>
          <xs:documentation>13.06.2018/K.Richter</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_MAX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>411--10--maximaler Wert</xs:documentation>
          <xs:documentation>13.06.2018/K.Richter</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLASS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : CLASS Element
Beschreibung

Hier wird definiert welcher Art die Zuordnungen sind. Es sind folgende Zuordnungsarten möglich:
1 = Sichtseite
2 = seitlicher Sockel
3 = Formstück
4 = Retoure
5 = Übergang
6 = Gehrungszuschlag
7 = Breitenkürzung
8 = Tiefenkürzung
9 = Höhenkürzung
10 = Ausschnitt
11 = Ausschnitt Rechteck
12 = Ausschnitt Rund
13 = Ausklinkung
14 = Abschrägung
15 = Abrundung
16 = Nut und Feder Verbindung
17 = Kante zu WERT 5
18 = Breitenerweiterung zu WERT 1
19 = Tiefenerweiterung zu WERT 1
20 = Höhenerweiterung zu WERT 1
21 = Abweichung vom Standardsockel

Die hier eingetragenen Werte sind abhängig von dem im Element SCOPE eingetragenem Wert und unterliegen folgender Regelung:

Element SCOPE Wert 1 => Element CLASS Werte 1, 2, 3, 7, 8, 9, 18 bis 20
Element SCOPE Wert 2 => Element CLASS Werte 2 bis 6, Wert 21
Element SCOPE Wert 3 oder 4 => Element CLASS Werte 3 bis 6
Element SCOPE Wert 5 => Element CLASS Werte 10 bis 17

 D positiveInteger
P
M [1:21]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CLASS Element
Overview
CLASS Restriction of xs:positiveInteger

Hier wird definiert welcher Art die Zuordnungen sind. Es sind folgende Zuordnungsarten möglich:
1 = Sichtseite
2 = seitlicher Sockel
3 = Formstück
4 = Retoure
5 = Übergang
6 = Gehrungszuschlag
7 = Breitenkürzung
8 = Tiefenkürzung
9 = Höhenkürzung
10 = Ausschnitt
11 = Ausschnitt Rechteck
12 = Ausschnitt Rund
13 = Ausklinkung
14 = Abschrägung
15 = Abrundung
16 = Nut und Feder Verbindung
17 = Kante zu WERT 5
18 = Breitenerweiterung zu WERT 1
19 = Tiefenerweiterung zu WERT 1
20 = Höhenerweiterung zu WERT 1
21 = Abweichung vom Standardsockel

Die hier eingetragenen Werte sind abhängig von dem im Element SCOPE eingetragenem Wert und unterliegen folgender Regelung:

Element SCOPE Wert 1 => Element CLASS Werte 1, 2, 3, 7, 8, 9, 18 bis 20
Element SCOPE Wert 2 => Element CLASS Werte 2 bis 6, Wert 21
Element SCOPE Wert 3 oder 4 => Element CLASS Werte 3 bis 6
Element SCOPE Wert 5 => Element CLASS Werte 10 bis 17

 D positiveInteger
P
M [1:21]
Quelle
<xs:element name="CLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--7--Art</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="21" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : ITEM_REF Element
Beschreibung
Hier wird die Type (Verknüpfungs-Type) referenziert, die der Ziel-Type zugeordnet wird. Die Verknüpfungs-Type muss in der gleichen Serie wie die Ziel-Type oder der Serie 0 angelegt sein.

Dieses Element muss angelegt werden, wenn im Element CLASS (Pfad 1) die Werte für Formstück (3), Retoure (4) oder Übergang (5) eingetragen sind.

Wenn dieses Element nicht angelegt wird, muss das Element VALUE (Pfad 1) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF optional
Hier wird die Type (Verknüpfungs-Type) referenziert, die der Ziel-Type zugeordnet wird. Die Verknüpfungs-Type muss in der gleichen Serie wie die Ziel-Type oder der Serie 0 angelegt sein.

Dieses Element muss angelegt werden, wenn im Element CLASS (Pfad 1) die Werte für Formstück (3), Retoure (4) oder Übergang (5) eingetragen sind.

Wenn dieses Element nicht angelegt wird, muss das Element VALUE (Pfad 1) angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Quelle
<xs:element name="ITEM_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>411--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>411--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONSTRUCTION_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : CONSTRUCTION_ID Element
Beschreibung
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene, Bauweise eines Artikels.

L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist. 		D string
P [LNR]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONSTRUCTION_ID Element
Overview
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene, Bauweise eines Artikels.

L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist. 		D string
P [LNR]
M [1:1]
Quelle
<xs:element name="CONSTRUCTION_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--4--Bauweise_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[LNR]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COVER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : COVER Element
Beschreibung
Ist im Element CLASS der Wert 3 für Formstück eingetragen, so muss dieses Element gefüllt werden. Bei anderen Werten darf dieses Element nicht gefüllt werden. Es wird unterschieden zwischen der Basis-, Teil-, und Vollabdeckung. Die unterschiedlichen Abdeckungen für Formteile sind in Abhängigkeit der Grundform definiert und im Teil "Zuordnung der Abdeckungsarten" zu finden.

Entsprechend der ausgewählten Abdeckung sind hier folgende Werte möglich:
1 = Basisabdeckung
2 = Teilabdeckung
3 = Vollabdeckung 		D nonNegativeInteger
P
M [1:3]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
COVER Element
Overview
COVER optional Restriction of xs:positiveInteger
Ist im Element CLASS der Wert 3 für Formstück eingetragen, so muss dieses Element gefüllt werden. Bei anderen Werten darf dieses Element nicht gefüllt werden. Es wird unterschieden zwischen der Basis-, Teil-, und Vollabdeckung. Die unterschiedlichen Abdeckungen für Formteile sind in Abhängigkeit der Grundform definiert und im Teil "Zuordnung der Abdeckungsarten" zu finden.

Entsprechend der ausgewählten Abdeckung sind hier folgende Werte möglich:
1 = Basisabdeckung
2 = Teilabdeckung
3 = Vollabdeckung 		D nonNegativeInteger
P
M [1:3]
Quelle
<xs:element name="COVER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--9--Abdeckung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_SHAPE_REFERENCE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : BASIC_SHAPE_REFERENCE Element
Beschreibung
Werden Zuordnungen für die Bereiche Sockel-, Kranz- und Lichtleiste (Bereiche 2-4) definiert, so ist in diesem Element einzutragen, bei welcher Grundform die Zuordnung anzuwenden ist. Dieses Element muss gefüllt werden, wenn im Element SCOPE die Werte 2 bis 4 eingetragen sind. Bei den Werten 1 und 5 im Element SCOPE darf dieses Element nicht gefüllt werden. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BASIC_SHAPE_REFERENCE Element
Overview
BASIC_SHAPE_REFERENCE optional Restriction of xs:nonNegativeInteger
Werden Zuordnungen für die Bereiche Sockel-, Kranz- und Lichtleiste (Bereiche 2-4) definiert, so ist in diesem Element einzutragen, bei welcher Grundform die Zuordnung anzuwenden ist. Dieses Element muss gefüllt werden, wenn im Element SCOPE die Werte 2 bis 4 eingetragen sind. Bei den Werten 1 und 5 im Element SCOPE darf dieses Element nicht gefüllt werden. D nonNegativeInteger
P |[0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [1:3]
Quelle
<xs:element name="BASIC_SHAPE_REFERENCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--8--Grundform_Bezug</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:pattern value="|[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : VALUE Element
Beschreibung
In diesem Element wird das Maß in mm für einen Gehrungszuschlag angegeben. D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
VALUE Element
Overview
VALUE optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für einen Gehrungszuschlag angegeben. D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--10--Wert</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_MIN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : VALUE_MIN Element
Beschreibung
In diesem Element wird das Maß in mm für den Mindestwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
VALUE_MIN Element
Overview
VALUE_MIN optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Mindestwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="VALUE_MIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--10--minimaler Wert</xs:documentation>
    <xs:documentation>13.06.2018/K.Richter</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_MAX Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPERATION_ITEM Element > SCOPE Element > ITEM_INFORMATION Element : VALUE_MAX Element
Beschreibung
In diesem Element wird das Maß in mm für den Maximalwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
VALUE_MAX Element
Overview
VALUE_MAX optional Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß in mm für den Maximalwert einer Kürzung oder Erweiterung angegeben und darf nur für die Werte 7, 8, 9, 18, 19, 20 des Elementes CLASS verwendet werden. D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="VALUE_MAX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>411--10--maximaler Wert</xs:documentation>
    <xs:documentation>13.06.2018/K.Richter</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_INFORMATION Element | SCOPE Element | OPERATION_ITEM Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HINGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : HINGE Element
Beschreibung

Dieses Element wird verwendet, um die Informationen über den Türanschlag des Artikels zu hinterlegen. Es werden keine geometrischen Informationen der Grundform des Artikels gesteuert. Hierzu wird das Feld CONSTRUCTION_ID verwendet.

Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.

Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID => das Element HINGE muss mit dem Wert "N" gefüllt werden.

Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) der Wert "J" enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
HINGE Element
Overview
HINGE Restriction of xs:string

Dieses Element wird verwendet, um die Informationen über den Türanschlag des Artikels zu hinterlegen. Es werden keine geometrischen Informationen der Grundform des Artikels gesteuert. Hierzu wird das Feld CONSTRUCTION_ID verwendet.

Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.

Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID => das Element HINGE muss mit dem Wert "N" gefüllt werden.

Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) der Wert "J" enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

 D string
P [BEJLMNR]
M [1:1]
Quelle
<xs:element name="HINGE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--4--Anschlag</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BEJLMNR]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EDP_NUMBER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EDP_NUMBER Element
Beschreibung
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDP_NUMBER Element
Overview
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
Quelle
<xs:element name="EDP_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--10--EDV_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EAN_NUMBER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EAN_NUMBER Element
Beschreibung
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EAN_NUMBER Element
Overview
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
Quelle
<xs:element name="EAN_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--11--EAN_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_PRICE_STATUS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BLOCK_PRICE_STATUS Element
Beschreibung
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_PRICE_STATUS Element
Overview
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
Quelle
<xs:element name="BLOCK_PRICE_STATUS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_IDENTIFICATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_IDENTIFICATION Element
Beschreibung

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral.

 D string
P [BEKSMZVPNOG]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ITEM_IDENTIFICATION Element
Overview
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral.

 D string
P [BEKSMZVPNOG]
M [1:1]
Quelle
<xs:element name="ITEM_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--14--Artikelkennung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BEKSMZVPNOG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_PAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CATALOG_PAGE Element
Beschreibung
In diesem Element wird die äquivalente Katalogseite des Artikels angegeben. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall sollte die erste Seitennummer auf der der Artikel/ die Type auftaucht, verwendet werden. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_PAGE Element
Overview
CATALOG_PAGE optional Restriction of xs:string
In diesem Element wird die äquivalente Katalogseite des Artikels angegeben. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall sollte die erste Seitennummer auf der der Artikel/ die Type auftaucht, verwendet werden. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
Quelle
<xs:element name="CATALOG_PAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--15--Katalog_Seite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="40" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_PAGE_PDF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CATALOG_PAGE_PDF Element
Beschreibung

In diesem Element kann die äquivalente Katalogseite des Artikels in dem als .pdf-Datei abgelegten Kataloges angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gespeicherten Katalogs.

In dem Element DETAIL_INFO (auf Katalogebene) ist die URL der .pdf-Datei hinterlegt Da es Artikel gibt, die auf mehreren Seiten im Katalog aufgeführt sind, ist sicher zu stellen, dass die Angabe für die .pdf-Datei mit der 40-stelligen Katalogseite CATALOG_PAGE übereinstimmt, das heißt, beide Angaben verweisen auf die selbe Seite.

 D positiveInteger
P
M [1:999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CATALOG_PAGE_PDF Element
Overview
CATALOG_PAGE_PDF optional Restriction of xs:positiveInteger

In diesem Element kann die äquivalente Katalogseite des Artikels in dem als .pdf-Datei abgelegten Kataloges angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gespeicherten Katalogs.

In dem Element DETAIL_INFO (auf Katalogebene) ist die URL der .pdf-Datei hinterlegt Da es Artikel gibt, die auf mehreren Seiten im Katalog aufgeführt sind, ist sicher zu stellen, dass die Angabe für die .pdf-Datei mit der 40-stelligen Katalogseite CATALOG_PAGE übereinstimmt, das heißt, beide Angaben verweisen auf die selbe Seite.

 D positiveInteger
P
M [1:999]
Quelle
<xs:element name="CATALOG_PAGE_PDF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Katalog_Seite in .pdf-Datei</xs:documentation>
    <xs:documentation>DETAIL_INFO_REF in CATALOG enthält Verweis auf .pdf-Datei</xs:documentation>
    <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VAT_ID_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VAT_ID_REF Element
Beschreibung
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
Namensraum (none)
Diagramm
VAT_ID_REF Element
Overview
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
VAT_NO Restriction of xs:nonNegativeInteger required
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES 		D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="VAT_ID_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="VAT_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : WEIGHT Element
Beschreibung

In dieses Element wird das Gewicht des Artikels [100 g] inklusive Verpackungsmaterial angegeben. (z. B. 50 = 5000 g).
Dabei drückt der Code im Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.
Langteile werden entsprechend des Brutto-Gwichts je Preiseinheit berechnet.

Beispiel:
Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
WEIGHT Element
Overview
WEIGHT optional Restriction of xs:nonNegativeInteger

In dieses Element wird das Gewicht des Artikels [100 g] inklusive Verpackungsmaterial angegeben. (z. B. 50 = 5000 g).
Dabei drückt der Code im Element ECO_MOBILIER unter anderem das Gewicht der Preiseinheit aus.
Langteile werden entsprechend des Brutto-Gwichts je Preiseinheit berechnet.

Beispiel:
Eine APL wird je m² berechnet, d.h. das Gewicht wird für genau 1 m² angegeben mit dem dazu passenden Code für dieses Gewicht.

 D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="WEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VOLUME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VOLUME Element
Beschreibung
In dieses Element wird das Volumen [dm³] des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
VOLUME Element
Overview
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³] des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="VOLUME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--21--Volumen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONSTRUCTION_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CONSTRUCTION_ID Element
Beschreibung
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P [JLNRAE]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONSTRUCTION_ID Element
Overview
CONSTRUCTION_ID Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform bezogene Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P [JLNRAE]
M [1:1]
Quelle
<xs:element name="CONSTRUCTION_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--23--Bauweise_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[JLNRAE]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUBCONTRACTOR_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : SUBCONTRACTOR_ID Element
Beschreibung
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt, wird in diesem Element die Herstellernummer eingetragen.

Handelt es sich bei diesem Artikel um ein sichtbares Zulieferteil, so müssen entweder die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO oder die Elemente FILE_NAME_TEXTURE_1/2 gefüllt werden.

Die Herstellernummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Herstellernummer im Verkauf nicht öffentlich zu machen. 		D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
SUBCONTRACTOR_ID Element
Overview
SUBCONTRACTOR_ID optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt, wird in diesem Element die Herstellernummer eingetragen.

Handelt es sich bei diesem Artikel um ein sichtbares Zulieferteil, so müssen entweder die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO oder die Elemente FILE_NAME_TEXTURE_1/2 gefüllt werden.

Die Herstellernummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Herstellernummer im Verkauf nicht öffentlich zu machen. 		D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="SUBCONTRACTOR_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--24--Zulieferer_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUBCONTRACTOR_ITEM_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : SUBCONTRACTOR_ITEM_NO Element
Beschreibung
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt (SUBCONTRACTOR_ID muss gefüllt sein), wird in diesem Element die Artikelnummer des Herstellers eingetragen.

Die Artikelnummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Artikelnummer im Verkauf nicht öffentlich zu machen. 		D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
SUBCONTRACTOR_ITEM_NO Element
Overview
SUBCONTRACTOR_ITEM_NO optional Restriction of xs:string
Wenn es sich bei dem abgebildeten Artikel um ein Zulieferteil handelt (SUBCONTRACTOR_ID muss gefüllt sein), wird in diesem Element die Artikelnummer des Herstellers eingetragen.

Die Artikelnummer sollte nach Möglichkeit eingetragen werden um den Datenerfassern und Softwarehäusern eine qualitativ hochwertige Beschreibung und Darstellung der Artikel zu ermöglichen. Die Softwarehäuser verpflichten sich, die Artikelnummer im Verkauf nicht öffentlich zu machen. 		D string
P
M [1:15]
Quelle
<xs:element name="SUBCONTRACTOR_ITEM_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--25--Zulieferer_Art_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OLD_SERIE_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : OLD_SERIE_NO Element
Beschreibung
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D nonNegativeInteger
P
M [0:99]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
OLD_SERIE_NO Element
Overview
OLD_SERIE_NO optional Restriction of xs:nonNegativeInteger
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="OLD_SERIE_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--26--Serien_Nr_Alt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OLD_TYPE_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : OLD_TYPE_NO Element
Beschreibung
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
OLD_TYPE_NO Element
Overview
OLD_TYPE_NO optional Restriction of xs:string
Hat sich die Typenbezeichnung (Kombination Serien_Nr und Type) eines Artikels gegenüber dem Katalog der vorhergehenden Produktrunde geändert, so sind in diese Felder die Informationen aus dem vorhergehendem Katalog einzutragen. Es darf sich nur die Serie und/oder die Typenbezeichnung ändern, der Artikel aus den Feldern Serien_Nr, Type muss in allen anderen Informationen identisch dem Artikel aus Serien_Nr_Alt, Type_Alt sein. D string
P
M [1:15]
Quelle
<xs:element name="OLD_TYPE_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--27--Type_Alt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_NAME_TEXTURE_1 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : FILE_NAME_TEXTURE_1 Element
Beschreibung
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FILE_NAME_TEXTURE_1 Element
Overview
FILE_NAME_TEXTURE_1 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
Quelle
<xs:element name="FILE_NAME_TEXTURE_1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--28--Dateiname_Textur_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_NAME_TEXTURE_2 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : FILE_NAME_TEXTURE_2 Element
Beschreibung
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FILE_NAME_TEXTURE_2 Element
Overview
FILE_NAME_TEXTURE_2 optional Restriction of xs:string
In diesen Elementen werden die Dateinamen von Bitmaps für Zubehörtexturen eingetragen. Für die Dateien wird das Format JPEG verwendet. Da in dem Format JPEG kein Alpha-Kanal angegeben werden kann, wird in diesem Fall der RGB-Farbwert 0,0,255 zur Maskierung verwendet.
Die Elemente werden in Abhängigkeit des Wertes im Element „CONSTRUCTION_ID“ verwendet. Das Element FILE_NAME_TEXTURE_1 beinhaltet die linke Darstellung des Zubehörs und das Element FILE_NAME_TEXTURE_2 die rechte Darstellung des Zubehörs
CONSTRUCTION_ID = N: Die Textur im Element „Dateiname_Textur_1" wird verwendet.
CONSTRUCTION_ID = J: Es werden zwei Möglichkeiten unterschieden:
1. Die Spiegelung erfolgt an der Mittelachse. Dies kann je nach Artikel die Y-Achse oder die Z-Achse sein(z. B. Spülen, KochElemente = Y und Kühlschränke, Mikrowelle = Z): Die Abbildung mit linker Darstellung wird in das Element FILE_NAME_TEXTURE_1 eingetragen.
2. Der Artikel kann nicht an der Mittelachse gespiegelt werden: Die Abbildung der linken Darstellung wird in das Element FILE_NAME_TEXTURE_1 und die Abbildung der rechten Darstellung wird in das Element FILE_NAME_TEXTURE_2 eingetragen.
CONSTRUCTION_ID = L: Der Eintrag erfolgt nur in Element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: Der Eintrag erfolgt nur im Element FILE_NAME_TEXTURE_2
Die Angaben werden im Format [cccccccc.jpg] vorgenommen. 		D string
P [0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [1:1]
Quelle
<xs:element name="FILE_NAME_TEXTURE_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--29--Dateiname_Textur_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MASKING Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MASKING Element
Beschreibung
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist mindestens eines der Elemente FILENAME_TEXTURE_1/2 gefüllt, so ist dieses Element nicht optional. 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
MASKING Element
Overview
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist mindestens eines der Elemente FILENAME_TEXTURE_1/2 gefüllt, so ist dieses Element nicht optional. 		D boolean
P
M
Quelle
<xs:element name="MASKING" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--30--Maskierung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODELING_GRAPHIC_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MODELING_GRAPHIC_ID Element
Beschreibung
Dieses Element dient der Referenzierung auf eine Echtgrafik. D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MODELING_GRAPHIC_ID Element
Overview
MODELING_GRAPHIC_ID optional Restriction of xs:string
Dieses Element dient der Referenzierung auf eine Echtgrafik. D string
P
M [1:15]
Quelle
<xs:element name="MODELING_GRAPHIC_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--31--Echtgrafik_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RANGE_DEPENDENT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : RANGE_DEPENDENT Element
Beschreibung
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
RANGE_DEPENDENT Element
Overview
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
Quelle
<xs:element name="RANGE_DEPENDENT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MINIMUM_DELIVERY_TIME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MINIMUM_DELIVERY_TIME Element
Beschreibung
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung). 		D nonNegativeInteger
P
M [0:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MINIMUM_DELIVERY_TIME Element
Overview
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung). 		D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EX_FACTORY_MODIFICATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EX_FACTORY_MODIFICATION Element
Beschreibung

Über dieses Element werden die werkseitigen Änderungsmöglichkeiten eines Artikels gesteuert. Die Änderungsmöglichkeiten der Artikel sind abhängig von der Definition seiner Grundformparameter im Element PARAMETERS (Pfad 1).

0 = alle Maßparameter (PARAMETERS (Pfad 1)) sind gesperrt, eine Maßänderung ist nicht möglich;

1 = die Maßparameter (PARAMETERS (Pfad 1)) sind im Rahmen der in SA500 angelegten Daten änderbar. Das zu ändernde Maß muss vom Benutzer abgefragt werden;

2 = alle Maßparameter (PARAMETERS (Pfad 1)) sind änderbar, gesperrte Parameter müssen identische Werte in den Attributen NOMINAL_VALUE (Pfad 1), FROM (Pfad 1) und TO (Pfad 1) haben.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
EX_FACTORY_MODIFICATION Element
Overview
EX_FACTORY_MODIFICATION optional Restriction of xs:nonNegativeInteger

Über dieses Element werden die werkseitigen Änderungsmöglichkeiten eines Artikels gesteuert. Die Änderungsmöglichkeiten der Artikel sind abhängig von der Definition seiner Grundformparameter im Element PARAMETERS (Pfad 1).

0 = alle Maßparameter (PARAMETERS (Pfad 1)) sind gesperrt, eine Maßänderung ist nicht möglich;

1 = die Maßparameter (PARAMETERS (Pfad 1)) sind im Rahmen der in SA500 angelegten Daten änderbar. Das zu ändernde Maß muss vom Benutzer abgefragt werden;

2 = alle Maßparameter (PARAMETERS (Pfad 1)) sind änderbar, gesperrte Parameter müssen identische Werte in den Attributen NOMINAL_VALUE (Pfad 1), FROM (Pfad 1) und TO (Pfad 1) haben.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 D nonNegativeInteger
P
M [0:2]
Quelle
<xs:element name="EX_FACTORY_MODIFICATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--37--Werkseitige_Aenderung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_PROFILE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BASIC_PROFILE Element
Beschreibung
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Namensraum (none)
Diagramm
ITEM_DIMENSIONAL_DRAWING Element CARCASE_BASIC_SHAPE Element Choice Sequence BASIC_PROFILE Element
Overview
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie Dateiname_Textur_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente FILE_NAME_TEXTURE_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie FILE_NAME_TEXTURE_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente Dateiname_Textur_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern in angegeben werden.
Nur bei dem Parameter B dürfen die Attrubute FROM (Wert von) und TO (Wert bis) gefüllt werden.
Dieses Element darf nur gefüllt werden, wenn es sich bei dem Artikel um eine Kranz-, Licht- oder Sockelleiste, Arbeitsplatte, Abdeckplatte, Barplatte oder Wandabschlussprofil handelt.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
Als OPTION_KEY wird der herstellerspezifische Key für die Profilform verwendet, wie dieser auch im Verkaufhandbuch angegeben ist.
Im Element BASIC_PROFILE_SHAPE/OPTION_REF dürfen nur die Variantenarten 750-756 verwendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:5]
BASIC_SHAPE_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.
Die anzugebenen Daten sind abhängig von den Grundformen und den Abschnitten unterhalb der Grundformen zu entnehmen.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Quelle
<xs:element name="BASIC_PROFILE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice>
        <xs:element name="CARCASE_BASIC_SHAPE">
          <xs:annotation>
            <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>400--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                </xs:annotation>
                <xs:complexType mixed="true">
                  <xs:sequence>
                    <xs:element name="OPTION_REF">
                      <xs:annotation>
                        <xs:documentation>430--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="FEATURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>430--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>430--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,5}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="BASIC_SHAPE_PARAMETERS">
                <xs:annotation>
                  <xs:documentation>500--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>500--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--Parameter</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>500--5--Nennwert</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_FROM">
                          <xs:annotation>
                            <xs:documentation>500--6--Von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_TO">
                          <xs:annotation>
                            <xs:documentation>500--7--Bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                          <xs:annotation>
                            <xs:documentation>500--8--Schrittweite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
              <xs:annotation>
                <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="ITEM_DIMENSIONAL_DRAWING">
          <xs:annotation>
            <xs:documentation>400--32--Massbild</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="240" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="DIMENSIONAL_PARAMETERS">
                <xs:annotation>
                  <xs:documentation>500--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>500--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSIONAL_NAME" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_FROM">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_TO">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
              <xs:annotation>
                <xs:documentation>400--32--Massbild</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CARCASE_BASIC_SHAPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element : CARCASE_BASIC_SHAPE Element
Beschreibung
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie Dateiname_Textur_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente FILE_NAME_TEXTURE_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
Namensraum (none)
Diagramm
BASIC_SHAPE_PARAMETERS Element BASIC_PROFILE_SHAPE Element Sequence CARCASE_BASIC_SHAPE Element
Overview
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie Dateiname_Textur_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente FILE_NAME_TEXTURE_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie FILE_NAME_TEXTURE_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente Dateiname_Textur_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern in angegeben werden.
Nur bei dem Parameter B dürfen die Attrubute FROM (Wert von) und TO (Wert bis) gefüllt werden.
Dieses Element darf nur gefüllt werden, wenn es sich bei dem Artikel um eine Kranz-, Licht- oder Sockelleiste, Arbeitsplatte, Abdeckplatte, Barplatte oder Wandabschlussprofil handelt.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
Als OPTION_KEY wird der herstellerspezifische Key für die Profilform verwendet, wie dieser auch im Verkaufhandbuch angegeben ist.
Im Element BASIC_PROFILE_SHAPE/OPTION_REF dürfen nur die Variantenarten 750-756 verwendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:5]
BASIC_SHAPE_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.
Die anzugebenen Daten sind abhängig von den Grundformen und den Abschnitten unterhalb der Grundformen zu entnehmen.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
CARCASE_BASIC_SHAPE_NO Restriction of xs:nonNegativeInteger required
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern, die dem Abschnitt Grundformen zu entnehmen sind, können folgende Werte angegeben werden:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element Echtgrafik_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe in SA500 angegeben werden. Zusätzlich können über die Elemente PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIE_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO sowie FILE_NAME_TEXTURE_1/2 Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt. Dafür sind die Elemente Dateiname_Textur_1/2 gefüllt.
997 = Artikel für die weder Grundform, noch Echtgrafik, noch Bitmap (FILE_NAME_TEXTURE_1/2) mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
994 = die Grundformnummer wird für Spülen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite, Tiefe, Höhe (Maß zwischen Oberkante Arbeitsplatte und Oberkante Spüle) und Mindesteinbauhöhe (Maß zwischen Unterkante innenliegender Details und Unterkante Arbeitsplatte).
995 = die Grundformnummer wird für Armaturen verwendet, damit minimal notwendige Maße geliefert werden können. Die erforderlichen Maße sind: Breite (Armatur ohne Auslauf), Tiefe (Armatur ohne Auslauf), Höhe (Armatur ohne Auslauf), Auslauftiefe (ab Mitte Armatur) und Auslaufhöhe (Oberkante Armatur abzüglich Höhe).
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Quelle
<xs:element name="CARCASE_BASIC_SHAPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType mixed="true">
          <xs:sequence>
            <xs:element name="OPTION_REF">
              <xs:annotation>
                <xs:documentation>430--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>430--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>430--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,5}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="BASIC_SHAPE_PARAMETERS">
        <xs:annotation>
          <xs:documentation>500--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>500--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--Parameter</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                  <xs:annotation>
                    <xs:documentation>500--5--Nennwert</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_FROM">
                  <xs:annotation>
                    <xs:documentation>500--6--Von</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_TO">
                  <xs:annotation>
                    <xs:documentation>500--7--Bis</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                  <xs:annotation>
                    <xs:documentation>500--8--Schrittweite</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_PROFILE_SHAPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element : BASIC_PROFILE_SHAPE Element
Beschreibung
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern in angegeben werden.
Nur bei dem Parameter B dürfen die Attrubute FROM (Wert von) und TO (Wert bis) gefüllt werden.
Dieses Element darf nur gefüllt werden, wenn es sich bei dem Artikel um eine Kranz-, Licht- oder Sockelleiste, Arbeitsplatte, Abdeckplatte, Barplatte oder Wandabschlussprofil handelt.
Namensraum (none)
Diagramm
OPTION_REF Element Sequence BASIC_PROFILE_SHAPE Element
Overview
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern in angegeben werden.
Nur bei dem Parameter B dürfen die Attrubute FROM (Wert von) und TO (Wert bis) gefüllt werden.
Dieses Element darf nur gefüllt werden, wenn es sich bei dem Artikel um eine Kranz-, Licht- oder Sockelleiste, Arbeitsplatte, Abdeckplatte, Barplatte oder Wandabschlussprofil handelt.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
Als OPTION_KEY wird der herstellerspezifische Key für die Profilform verwendet, wie dieser auch im Verkaufhandbuch angegeben ist.
Im Element BASIC_PROFILE_SHAPE/OPTION_REF dürfen nur die Variantenarten 750-756 verwendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
BASIC_PROFILE_SHAPE_NO Restriction of xs:string required
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Quelle
<xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType mixed="true">
    <xs:sequence>
      <xs:element name="OPTION_REF">
        <xs:annotation>
          <xs:documentation>430--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>430--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>430--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[\S ]{1,5}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element > BASIC_PROFILE_SHAPE Element : OPTION_REF Element
Beschreibung
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
Als OPTION_KEY wird der herstellerspezifische Key für die Profilform verwendet, wie dieser auch im Verkaufhandbuch angegeben ist.
Im Element BASIC_PROFILE_SHAPE/OPTION_REF dürfen nur die Variantenarten 750-756 verwendet werden.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
Als OPTION_KEY wird der herstellerspezifische Key für die Profilform verwendet, wie dieser auch im Verkaufhandbuch angegeben ist.
Im Element BASIC_PROFILE_SHAPE/OPTION_REF dürfen nur die Variantenarten 750-756 verwendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>430--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>430--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>430--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BASIC_PROFILE_SHAPE Element | CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_SHAPE_PARAMETERS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element : BASIC_SHAPE_PARAMETERS Element
Beschreibung

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.
Die anzugebenen Daten sind abhängig von den Grundformen und den Abschnitten unterhalb der Grundformen zu entnehmen.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

Namensraum (none)
Diagramm
BASIC_SHAPE_PARAMETER Element Sequence BASIC_SHAPE_PARAMETERS Element
Overview
BASIC_SHAPE_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.
Die anzugebenen Daten sind abhängig von den Grundformen und den Abschnitten unterhalb der Grundformen zu entnehmen.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Quelle
<xs:element name="BASIC_SHAPE_PARAMETERS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>500--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="BASIC_SHAPE_NAME" use="required">
            <xs:annotation>
              <xs:documentation>500--0--Parameter</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
            <xs:annotation>
              <xs:documentation>500--5--Nennwert</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_FROM">
            <xs:annotation>
              <xs:documentation>500--6--Von</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_TO">
            <xs:annotation>
              <xs:documentation>500--7--Bis</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
            <xs:annotation>
              <xs:documentation>500--8--Schrittweite</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_SHAPE_PARAMETER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element > BASIC_SHAPE_PARAMETERS Element : BASIC_SHAPE_PARAMETER Element
Beschreibung
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
Namensraum (none)
Diagramm
BASIC_SHAPE_PARAMETER Element
Overview
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
BASIC_SHAPE_NAME Restriction of xs:string required
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE Restriction of xs:decimal required
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM Restriction of xs:decimal optional
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO Restriction of xs:decimal optional
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE Restriction of xs:decimal optional
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Quelle
<xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="BASIC_SHAPE_NAME" use="required">
      <xs:annotation>
        <xs:documentation>500--0--Parameter</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>500--5--Nennwert</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_FROM">
      <xs:annotation>
        <xs:documentation>500--6--Von</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_TO">
      <xs:annotation>
        <xs:documentation>500--7--Bis</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
      <xs:annotation>
        <xs:documentation>500--8--Schrittweite</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BASIC_SHAPE_PARAMETERS Element | CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_DIMENSIONAL_DRAWING Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element : ITEM_DIMENSIONAL_DRAWING Element
Beschreibung
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden.
Namensraum (none)
Diagramm
DIMENSIONAL_PARAMETERS Element DOCUMENT_REFERENCE Element Sequence ITEM_DIMENSIONAL_DRAWING Element
Overview
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ITEM_DIMENSIONAL_DRAWING_NO Restriction of xs:string required
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Geräte- oder Zubehörartikel beschrieben. Handelt es sich bei dem Artikel um Spülen oder Einbaugeräte, so muss dieses Element angelegt werden.

Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.

Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. Möbelteile dürfen über dieses Element ebenfalls nicht abgebildet werden. 		D string
P
M [1:20]
Quelle
<xs:element name="ITEM_DIMENSIONAL_DRAWING" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--32--Massbild</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="240" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DIMENSIONAL_PARAMETERS">
        <xs:annotation>
          <xs:documentation>500--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>500--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DIMENSIONAL_NAME" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_FROM">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_TO">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--32--Massbild</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="20" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DOCUMENT_REFERENCE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element : DOCUMENT_REFERENCE Element
Beschreibung
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
DOCUMENT_REFERENCE Element
Overview
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
Quelle
<xs:element name="DOCUMENT_REFERENCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="240" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DIMENSIONAL_PARAMETERS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element : DIMENSIONAL_PARAMETERS Element
Beschreibung
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Namensraum (none)
Diagramm
DIMENSIONAL_PARAMETER Element Sequence DIMENSIONAL_PARAMETERS Element
Overview
DIMENSIONAL_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER
Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Quelle
<xs:element name="DIMENSIONAL_PARAMETERS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>500--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DIMENSIONAL_NAME" use="required">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_FROM">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_TO">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_STEP_SIZE">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DIMENSIONAL_PARAMETER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element > DIMENSIONAL_PARAMETERS Element : DIMENSIONAL_PARAMETER Element
Beschreibung
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
Namensraum (none)
Diagramm
DIMENSIONAL_PARAMETER Element
Overview
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DIMENSIONAL_NAME Restriction of xs:string required
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE Restriction of xs:decimal required
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM Restriction of xs:decimal optional
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO Restriction of xs:decimal optional
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE Restriction of xs:decimal optional
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Quelle
<xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSIONAL_NAME" use="required">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_FROM">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_TO">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_STEP_SIZE">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DIMENSIONAL_PARAMETERS Element | ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_PARTS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BLOCK_PARTS Element
Beschreibung
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Namensraum (none)
Diagramm
BLOCK_PART Element Sequence BLOCK_PARTS Element
Overview
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn im Element ITEM (Pfad 1) mindestens ein Element mit dem Element Artikelkennung = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Quelle
<xs:element name="BLOCK_PARTS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_PART" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_SEQUENTIAL_NO">
              <xs:annotation>
                <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="HINGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--6--Anschlag</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[BEJLMNR]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXCHANGE_CONDITION">
              <xs:annotation>
                <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="2" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STATUS">
              <xs:annotation>
                <xs:documentation>401--8--Status</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[ABELSZ]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONSTRUCTION_ID" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[JLNRAE]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_PART Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element : BLOCK_PART Element
Beschreibung

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn im Element ITEM (Pfad 1) mindestens ein Element mit dem Element Artikelkennung = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Namensraum (none)
Diagramm
CONSTRUCTION_ID Element BLOCK_ITEM_DIMENSION_DEPTH Element BLOCK_ITEM_DIMENSION_HEIGHT Element BLOCK_ITEM_DIMENSION_WIDTH Element STATUS Element EXCHANGE_CONDITION Element HINGE Element OPTION_REF Element ITEM_REF Element BLOCK_SEQUENTIAL_NO Element Sequence BLOCK_PART Element
Overview
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn im Element ITEM (Pfad 1) mindestens ein Element mit dem Element Artikelkennung = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Quelle
<xs:element name="BLOCK_PART" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_SEQUENTIAL_NO">
        <xs:annotation>
          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="HINGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--6--Anschlag</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[BEJLMNR]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXCHANGE_CONDITION">
        <xs:annotation>
          <xs:documentation>401--7--Tauschbedingung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="2" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STATUS">
        <xs:annotation>
          <xs:documentation>401--8--Status</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[ABELSZ]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--13--Bauweise_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[JLNRAE]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_SEQUENTIAL_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_SEQUENTIAL_NO Element
Beschreibung
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_SEQUENTIAL_NO Element
Overview
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
Quelle
<xs:element name="BLOCK_SEQUENTIAL_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : ITEM_REF Element
Beschreibung

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : OPTION_REF Element
Beschreibung

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HINGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : HINGE Element
Beschreibung
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
HINGE Element
Overview
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
Quelle
<xs:element name="HINGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--6--Anschlag</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[BEJLMNR]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_CONDITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : EXCHANGE_CONDITION Element
Beschreibung

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
EXCHANGE_CONDITION Element
Overview
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
Quelle
<xs:element name="EXCHANGE_CONDITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--7--Tauschbedingung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K.Richter 05.05.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="2" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STATUS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : STATUS Element
Beschreibung
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
STATUS Element
Overview
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
Quelle
<xs:element name="STATUS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--8--Status</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[ABELSZ]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_WIDTH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_WIDTH Element
Beschreibung
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_ITEM_DIMENSION_WIDTH Element
Overview
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_HEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_HEIGHT Element
Beschreibung
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_ITEM_DIMENSION_HEIGHT Element
Overview
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_DEPTH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_DEPTH Element
Beschreibung
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_ITEM_DIMENSION_DEPTH Element
Overview
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONSTRUCTION_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : CONSTRUCTION_ID Element
Beschreibung
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONSTRUCTION_ID Element
Overview
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Quelle
<xs:element name="CONSTRUCTION_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--13--Bauweise_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[JLNRAE]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_PARTS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MODULE_PARTS Element
Beschreibung

Falls der entsprechende Artikel ein Varioschrank ist, enthält dieses Element eine Stückliste von Modulelementen, wobei das erste Element ein Basisschrank mit der Position 0 ist und danach von unten nach oben die Modulelemente folgen. Dieses Element darf nicht angegeben werden, wenn der dazu gehörige Artikel kein Varioschrank ist.

Der Varioschrank hat einen festen Preis. Sobald der Varioschrank verändert wird, ergibt sich der neue Preis aus Preis für Basisschrank + Preis für die Module. Dabei entfällt der Varioschrank, der Basisschrank wird Hauptposition und hat alle anderen Modulelemente als Unterposition in der Reihenfolge von unten nach oben.

Die Modulelemente können programm- und ausführungsabhängig sein.

Für Modulelemente können Regeln bezüglich ihrer Höhe innerhalb des Basisschrankes über MODUL_RULE_SETS festgelegt werden. Dabei wird die global definierte Modulregel referenziert.

Dem Basisschrank kann solch eine Regel über MODULE_RULE_SET_REF zugeordnet werden.

Namensraum (none)
Diagramm
MODULE_PART Element Sequence MODULE_PARTS Element
Overview
MODULE_PARTS optional

Falls der entsprechende Artikel ein Varioschrank ist, enthält dieses Element eine Stückliste von Modulelementen, wobei das erste Element ein Basisschrank mit der Position 0 ist und danach von unten nach oben die Modulelemente folgen. Dieses Element darf nicht angegeben werden, wenn der dazu gehörige Artikel kein Varioschrank ist.

Der Varioschrank hat einen festen Preis. Sobald der Varioschrank verändert wird, ergibt sich der neue Preis aus Preis für Basisschrank + Preis für die Module. Dabei entfällt der Varioschrank, der Basisschrank wird Hauptposition und hat alle anderen Modulelemente als Unterposition in der Reihenfolge von unten nach oben.

Die Modulelemente können programm- und ausführungsabhängig sein.

Für Modulelemente können Regeln bezüglich ihrer Höhe innerhalb des Basisschrankes über MODUL_RULE_SETS festgelegt werden. Dabei wird die global definierte Modulregel referenziert.

Dem Basisschrank kann solch eine Regel über MODULE_RULE_SET_REF zugeordnet werden.

Sequence
MODULE_PART 1..∞

Dieses Element entspricht einem Teil der Stückliste von Modulelementen eines Varioschrankes. Die Elemente müssen in ihrer Reihenfolge von unten nach oben angegeben werden. Die Position 0 (PART_SEQUENTIAL_NO) ist der leere Basisschrank (Schrank mit Typ-Art 17). Danach folgen von unten nach oben die Modulelemente (Schränke mit Typ-Schlüssel 10). Der Anschlag des Basisschrankes ist identisch zu Anschlag des Varioschrankes.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels innerhalb des Varioschrankes angegeben. Dabei muss der Basisschrank (Typ_Art 17) den Positionswert 0 beinhalten. Die Modulelemente (Typ-Schlüssel 10) erhalten in der Reihenfolge von unten nach oben weitere Positionsnummern. D nonNegativeInteger
P
M [0:999]
ITEM_REF
In diesem Element werden der Basisschrank (Typ-Art 17) und die einzelnen Modulelemente (Typschlüssel 10) referenziert.
Dabei muss dem Basisschrank die Position (PART_SEQUENTIAL_NO) 0 zugewiesen werden. Die übrigen Modulelemente müssen passend zu dem Attribut PART_SEQUENTIAL_NO in der Reihenfolge von unten nach oben referenziert werden.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikeltype eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
HEIGHT_VARIABLE optional xs:boolean
Ist der Wert von diesem Flag auf true(1) gesetzt, bedeutet es, dass das entsprechende Modulelement Veränderungen bei Veränderungen anderer Elemente innerhalb der Liste aufnimmt. Das bedeutet, wird ein anderes Modulelement größer oder kleiner, passt sich das mit HEIGT_VARIABLE true gekennzeichnete Modulelement so an, dass die Gesamthöhe aller Modulelemente innerhalb des Basisschrankes wieder erreicht wird. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
Ein Modulelement kann variabel sein, hat in der Liste aber eine feste Höhe, die bei variablen Maßen in diesem Element angegeben werden muss. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="MODULE_PARTS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_PART" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PART_SEQUENTIAL_NO">
              <xs:annotation>
                <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:maxInclusive value="999" />
                  <xs:minInclusive value="0" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_PART Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_PARTS Element : MODULE_PART Element
Beschreibung

Dieses Element entspricht einem Teil der Stückliste von Modulelementen eines Varioschrankes. Die Elemente müssen in ihrer Reihenfolge von unten nach oben angegeben werden. Die Position 0 (PART_SEQUENTIAL_NO) ist der leere Basisschrank (Schrank mit Typ-Art 17). Danach folgen von unten nach oben die Modulelemente (Schränke mit Typ-Schlüssel 10). Der Anschlag des Basisschrankes ist identisch zu Anschlag des Varioschrankes.

Namensraum (none)
Diagramm
MODULE_ITEM_DIMENSION_HEIGHT Element HEIGHT_VARIABLE Element ITEM_REF Element PART_SEQUENTIAL_NO Element Sequence MODULE_PART Element
Overview
MODULE_PART 1..∞

Dieses Element entspricht einem Teil der Stückliste von Modulelementen eines Varioschrankes. Die Elemente müssen in ihrer Reihenfolge von unten nach oben angegeben werden. Die Position 0 (PART_SEQUENTIAL_NO) ist der leere Basisschrank (Schrank mit Typ-Art 17). Danach folgen von unten nach oben die Modulelemente (Schränke mit Typ-Schlüssel 10). Der Anschlag des Basisschrankes ist identisch zu Anschlag des Varioschrankes.

Sequence
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels innerhalb des Varioschrankes angegeben. Dabei muss der Basisschrank (Typ_Art 17) den Positionswert 0 beinhalten. Die Modulelemente (Typ-Schlüssel 10) erhalten in der Reihenfolge von unten nach oben weitere Positionsnummern. D nonNegativeInteger
P
M [0:999]
ITEM_REF
In diesem Element werden der Basisschrank (Typ-Art 17) und die einzelnen Modulelemente (Typschlüssel 10) referenziert.
Dabei muss dem Basisschrank die Position (PART_SEQUENTIAL_NO) 0 zugewiesen werden. Die übrigen Modulelemente müssen passend zu dem Attribut PART_SEQUENTIAL_NO in der Reihenfolge von unten nach oben referenziert werden.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikeltype eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
HEIGHT_VARIABLE optional xs:boolean
Ist der Wert von diesem Flag auf true(1) gesetzt, bedeutet es, dass das entsprechende Modulelement Veränderungen bei Veränderungen anderer Elemente innerhalb der Liste aufnimmt. Das bedeutet, wird ein anderes Modulelement größer oder kleiner, passt sich das mit HEIGT_VARIABLE true gekennzeichnete Modulelement so an, dass die Gesamthöhe aller Modulelemente innerhalb des Basisschrankes wieder erreicht wird. D boolean
P
M
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
Ein Modulelement kann variabel sein, hat in der Liste aber eine feste Höhe, die bei variablen Maßen in diesem Element angegeben werden muss. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="MODULE_PART" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PART_SEQUENTIAL_NO">
        <xs:annotation>
          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:maxInclusive value="999" />
            <xs:minInclusive value="0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
MODULE_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PART_SEQUENTIAL_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_PARTS Element > MODULE_PART Element : PART_SEQUENTIAL_NO Element
Beschreibung
In diesem Element wird die Position des Artikels innerhalb des Varioschrankes angegeben. Dabei muss der Basisschrank (Typ_Art 17) den Positionswert 0 beinhalten. Die Modulelemente (Typ-Schlüssel 10) erhalten in der Reihenfolge von unten nach oben weitere Positionsnummern. D nonNegativeInteger
P
M [0:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
PART_SEQUENTIAL_NO Element
Overview
PART_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels innerhalb des Varioschrankes angegeben. Dabei muss der Basisschrank (Typ_Art 17) den Positionswert 0 beinhalten. Die Modulelemente (Typ-Schlüssel 10) erhalten in der Reihenfolge von unten nach oben weitere Positionsnummern. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="PART_SEQUENTIAL_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:maxInclusive value="999" />
      <xs:minInclusive value="0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
MODULE_PART Element | MODULE_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_PARTS Element > MODULE_PART Element : ITEM_REF Element
Beschreibung
In diesem Element werden der Basisschrank (Typ-Art 17) und die einzelnen Modulelemente (Typschlüssel 10) referenziert.
Dabei muss dem Basisschrank die Position (PART_SEQUENTIAL_NO) 0 zugewiesen werden. Die übrigen Modulelemente müssen passend zu dem Attribut PART_SEQUENTIAL_NO in der Reihenfolge von unten nach oben referenziert werden.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF
In diesem Element werden der Basisschrank (Typ-Art 17) und die einzelnen Modulelemente (Typschlüssel 10) referenziert.
Dabei muss dem Basisschrank die Position (PART_SEQUENTIAL_NO) 0 zugewiesen werden. Die übrigen Modulelemente müssen passend zu dem Attribut PART_SEQUENTIAL_NO in der Reihenfolge von unten nach oben referenziert werden.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikeltype eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikeltype eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MODULE_PART Element | MODULE_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_VARIABLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_PARTS Element > MODULE_PART Element : HEIGHT_VARIABLE Element
Beschreibung
Ist der Wert von diesem Flag auf true(1) gesetzt, bedeutet es, dass das entsprechende Modulelement Veränderungen bei Veränderungen anderer Elemente innerhalb der Liste aufnimmt. Das bedeutet, wird ein anderes Modulelement größer oder kleiner, passt sich das mit HEIGT_VARIABLE true gekennzeichnete Modulelement so an, dass die Gesamthöhe aller Modulelemente innerhalb des Basisschrankes wieder erreicht wird. D boolean
P
M
Namensraum (none)
Typ
xs:boolean
Diagramm
HEIGHT_VARIABLE Element
Overview
HEIGHT_VARIABLE optional xs:boolean
Ist der Wert von diesem Flag auf true(1) gesetzt, bedeutet es, dass das entsprechende Modulelement Veränderungen bei Veränderungen anderer Elemente innerhalb der Liste aufnimmt. Das bedeutet, wird ein anderes Modulelement größer oder kleiner, passt sich das mit HEIGT_VARIABLE true gekennzeichnete Modulelement so an, dass die Gesamthöhe aller Modulelemente innerhalb des Basisschrankes wieder erreicht wird. D boolean
P
M
Quelle
<xs:element name="HEIGHT_VARIABLE" type="xs:boolean" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Flag für Ausgleichselement, falls ein anderes verändert wird</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
MODULE_PART Element | MODULE_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_ITEM_DIMENSION_HEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_PARTS Element > MODULE_PART Element : MODULE_ITEM_DIMENSION_HEIGHT Element
Beschreibung
Ein Modulelement kann variabel sein, hat in der Liste aber eine feste Höhe, die bei variablen Maßen in diesem Element angegeben werden muss. D nonNegativeInteger
P
M [1:99999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MODULE_ITEM_DIMENSION_HEIGHT Element
Overview
MODULE_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
Ein Modulelement kann variabel sein, hat in der Liste aber eine feste Höhe, die bei variablen Maßen in diesem Element angegeben werden muss. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="MODULE_ITEM_DIMENSION_HEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--11--Modulelementmass_Hoehe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
MODULE_PART Element | MODULE_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_TEXT Element
Beschreibung
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence PLANNING_ADVICE Element LANGUAGE Element Sequence FULL_TEXT Element SHORT_TEXT Element Sequence ITEM_TEXT Element
Overview
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT

Dieses Element enthält Kurztexte.

Der Kurztext darf maximal drei Zeilen lang sein und muss mit einem den Artikel näher beschreibenden Text gefüllt werden. Der Kurztext muss alleinstehend auf Kundenformularen druckbar sein. Dieser Text muss einen endverbraucherorientierten Inhalt haben. Der Kurztext muss immer vorhanden sein. Die letzte Zeile eines Kurztextes darf am Zeilenende keine Trennzeichen (z. B. – oder /) enthalten.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type

Der Volltext ergänzt den Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="ITEM_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SHORT_TEXT">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>410--6--Textzeile</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SHORT_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : SHORT_TEXT Element
Beschreibung

Dieses Element enthält Kurztexte.

Der Kurztext darf maximal drei Zeilen lang sein und muss mit einem den Artikel näher beschreibenden Text gefüllt werden. Der Kurztext muss alleinstehend auf Kundenformularen druckbar sein. Dieser Text muss einen endverbraucherorientierten Inhalt haben. Der Kurztext muss immer vorhanden sein. Die letzte Zeile eines Kurztextes darf am Zeilenende keine Trennzeichen (z. B. – oder /) enthalten.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence SHORT_TEXT Element
Overview
SHORT_TEXT

Dieses Element enthält Kurztexte.

Der Kurztext darf maximal drei Zeilen lang sein und muss mit einem den Artikel näher beschreibenden Text gefüllt werden. Der Kurztext muss alleinstehend auf Kundenformularen druckbar sein. Dieser Text muss einen endverbraucherorientierten Inhalt haben. Der Kurztext muss immer vorhanden sein. Die letzte Zeile eines Kurztextes darf am Zeilenende keine Trennzeichen (z. B. – oder /) enthalten.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="SHORT_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>410--6--Textzeile</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>410--6--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 21.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element : TEXT_LINE Element
Beschreibung
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
Namensraum (none)
Diagramm
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE_NO Restriction of xs:positiveInteger required
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Quelle
<xs:element name="TEXT_LINE" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>410--6--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--6--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FULL_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : FULL_TEXT Element
Beschreibung

Der Volltext ergänzt den Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Namensraum (none)
Typ
languagetexte Complex Type
Diagramm
LANGUAGE Element Sequence FULL_TEXT Element
Overview
FULL_TEXT optional languagetexte Complex Type

Der Volltext ergänzt den Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte Complex Type
IDM 2.7.0 XML-Schema : languagetexte Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte Complex Type
Overview
languagetexte

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Verwendet von
EXTERNAL_NAME Element
TOOL_TIP Element
PROPERTY_TEXT Element
FULL_TEXT Element
Quelle
<xs:complexType name="languagetexte" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PLANNING_ADVICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : PLANNING_ADVICE Element
Beschreibung
Dieses Element enthält Planungshinweise.
Namensraum (none)
Typ
languagetexte60999 Complex Type
Diagramm
LANGUAGE Element Sequence PLANNING_ADVICE Element
Overview
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TYPE_KEY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : TYPE_KEY Element
Beschreibung
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Namensraum (none)
Diagramm
TK_FRONT_APPEARANCE Element TK_SHAPE Element TK_MATERIAL Element TK_EQUIPMENT Element TK_CLASS Element TK_TYPE Element Sequence TYPE_KEY Element
Overview
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten " der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel " der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Quelle
<xs:element name="TYPE_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_TYPE">
        <xs:annotation>
          <xs:documentation>445--4--TS_Typ</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_CLASS">
        <xs:annotation>
          <xs:documentation>445--5--TS_Art</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
        <xs:annotation>
          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
            <xs:annotation>
              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="TK_MATERIAL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--21--TS_Material</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-2]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_SHAPE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--22--TS_Form</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-2]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_TYPE Element
Beschreibung
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_TYPE Element
Overview
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
Quelle
<xs:element name="TK_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--4--TS_Typ</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_CLASS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_CLASS Element
Beschreibung
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten " der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_CLASS Element
Overview
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten " der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
Quelle
<xs:element name="TK_CLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--5--TS_Art</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_EQUIPMENT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_EQUIPMENT Element
Beschreibung

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

Namensraum (none)
Diagramm
TK_INSTALLATION_RECESS Element Sequence TK_EQUIPMENT Element
Overview
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel " der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO Restriction of xs:nonNegativeInteger optional

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel " der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Quelle
<xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
      <xs:annotation>
        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_INSTALLATION_RECESS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element : TK_INSTALLATION_RECESS Element
Beschreibung
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Namensraum (none)
Diagramm
TK_RECESS_HEIGHT Element TK_INSTALLATION_INFORMATION Element Sequence TK_INSTALLATION_RECESS Element
Overview
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="TK_INSTALLATION_RECESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
          <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_INSTALLATION_INFORMATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element > TK_INSTALLATION_RECESS Element : TK_INSTALLATION_INFORMATION Element
Beschreibung
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
TK_INSTALLATION_INFORMATION Element
Overview
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
Quelle
<xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TK_INSTALLATION_RECESS Element | TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_RECESS_HEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element > TK_INSTALLATION_RECESS Element : TK_RECESS_HEIGHT Element
Beschreibung
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
TK_RECESS_HEIGHT Element
Overview
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="TK_RECESS_HEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
    <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TK_INSTALLATION_RECESS Element | TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_MATERIAL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_MATERIAL Element
Beschreibung
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_MATERIAL Element
Overview
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Quelle
<xs:element name="TK_MATERIAL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--21--TS_Material</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-2]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_SHAPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_SHAPE Element
Beschreibung
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_SHAPE Element
Overview
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Quelle
<xs:element name="TK_SHAPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--22--TS_Form</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-2]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TK_FRONT_APPEARANCE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_FRONT_APPEARANCE Element
Beschreibung
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_FRONT_APPEARANCE Element
Overview
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Quelle
<xs:element name="TK_FRONT_APPEARANCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLASSIFICATIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CLASSIFICATIONS Element
Beschreibung
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Namensraum (none)
Diagramm
ECLASS Element Sequence CLASSIFICATIONS Element
Overview
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.
Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="CLASSIFICATIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS_NO">
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:totalDigits value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ECLASS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element : ECLASS Element
Beschreibung
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Namensraum (none)
Diagramm
ECLASS_NO Element Sequence ECLASS Element
Overview
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.
Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="ECLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS_NO">
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:totalDigits value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ECLASS_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element > ECLASS Element : ECLASS_NO Element
Beschreibung

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.
Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
ECLASS_NO Element
Overview
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.
Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="ECLASS_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:totalDigits value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ECLASS Element | CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_DIVISIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : FRONT_DIVISIONS Element
Beschreibung
In diesem Element werden die möglichen Frontaufteilungen für einen Artikel definiert.
Die Frontaufteilungen können in Abhängigkeit des Programms unterschiedlich sein oder der Artikel hat in Abhängigkeit von Einbaugeräten unterschiedliche Frontaufteilungen.

Frontaufteilungen, die in mehrere Programme gleich sind, können in Frontgruppen zusammengefasst werden. Die Frontgruppen werden dann von den Programmen referenziert.

Die Frontaufteilungen beziehen sich auf die linke Bauweise. Ist der Artikel auch in rechter Bauweise vorhanden, so wird die Frontaufteilung von der Planungssoftware gespiegelt.
Namensraum (none)
Diagramm
FRONT_GROUP Element Sequence FRONT_DIVISIONS Element
Overview
FRONT_DIVISIONS optional
In diesem Element werden die möglichen Frontaufteilungen für einen Artikel definiert.
Die Frontaufteilungen können in Abhängigkeit des Programms unterschiedlich sein oder der Artikel hat in Abhängigkeit von Einbaugeräten unterschiedliche Frontaufteilungen.

Frontaufteilungen, die in mehrere Programme gleich sind, können in Frontgruppen zusammengefasst werden. Die Frontgruppen werden dann von den Programmen referenziert.

Die Frontaufteilungen beziehen sich auf die linke Bauweise. Ist der Artikel auch in rechter Bauweise vorhanden, so wird die Frontaufteilung von der Planungssoftware gespiegelt.
Sequence
FRONT_GROUP 1..99
In diesem Element werden die Frontaufteilungen definiert und zu einer Frontgruppe zusammengefasst.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein.

Ist die FRONT_GROUP gültig für alle Programme, so wird 0 hinterlegt. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
In diesem Element wird eine Frontaufteilung definiert und die einzelnen Zellen der Frontaufteilung beschrieben.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
Die Frontaufteilung wird nach der im Anhang beschriebenen Syntax eingegeben. Regalaufteilungen werden nicht über diese Syntax realisiert, sondern als eine Zelle betrachtet (siehe FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
In diesem Element werden die intern unterschiedlichen Bestellnummern für einen Artikel eingegeben, der in verschiedenen Frontaufteilungen lieferbar ist und im Katalog nur eine Artikelkennung besitzt. D string
P
M [1:15]
FRONT_CELL 1..∞
In diesem Element werden die einzelnen Zellen einer Frontaufteilung definiert.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
In diesem Attribut wird die Nummer der Zelle angegeben, die definiert werden soll. Die Zellennummer wird in der Frontaufteilung (FRONT_DIVISION_DEF) festgelegt. D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
In diesem Element wird angegeben, welchen Fronttyp die Zelle hat. Die Zuordnung eines Frontelementes erfolgt über den Fronttyp (siehe Element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

Folgende Fronttypen können zugeordnet werden:

1 - 100 = Türen
101 - 200 = Schubladen
201 - 300 = Auszüge
301 – 400 = Klappen
401 – 450 = Nischen mit Blende
451 – 500 = Nischen ohne Blende
501 – 550 = offene Fächer/Fachnischen
551 – 600 = Regale
601 – 650 = feste Blenden
651 – 700 = Schaltkastenblenden
701 – 750 = Jalousien
751 – 800 = Rollfronten
801 – 900 = Diverses 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
Die Elemente PARAMETER_1 und PARAMETER_2 werden für sichtbare Fachböden (z. B. Regale, Glasschränke) verwendet, um die Anzahl der Fachböden anzugeben.
PARAMETER_1 gibt die Anzahl der horizontalen Fachböden an. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
Dieses Element gibt die Anzahl der vertikalen Unterteilungen bei Regalen an. Gilt für sichtbare Fachböden (z. B. Regale, Glasschränke). D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle)
3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) keine Spiegelung
1) Spiegelung nur bei Änderung des Anschlags
2) Spiegelung nur bei Änderung der Bauweise
3) Spiegelung wenn sich entweder Anschlag oder Bauweise verändert
4) Spiegelung wenn Anschlag und Bauweise gemeinsam verändert werden.

Festlegungen werden im Kopftext dokumentiert und anhand von Beispielen verdeutlicht.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

Hier wird die Position der Kehlleiste definiert

1) = horizontal
2) = vertikal

 D nonNegativeInteger
P
M [1:2]
Quelle
<xs:element name="FRONT_DIVISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>510--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_GROUP" maxOccurs="99">
        <xs:annotation>
          <xs:documentation>510/540--0/0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>510/540--0/0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_DIVISION_DEF">
                    <xs:annotation>
                      <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="250" />
                        <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FRONT_CELL" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FRONT_CELL_NO">
                          <xs:annotation>
                            <xs:documentation>540--6--Zellennummer</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FRONT_TYPE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--7--Fronttyp</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="900" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--8--Griffposition_1</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--9--Griffposition_2</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--10--Grifflage_1</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="4" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--11--Grifflage_2</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="4" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PARAMETER_1" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--12--Parameter_1</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PARAMETER_2" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--13--Parameter_2</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="4" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="UPPER_JOIN" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[VLSG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="LOWER_JOIN" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[VLSG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="LEFT_JOIN" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[VLSG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="RIGHT_JOIN" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[VLSG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DOUCINE_POSITION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>540--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="2" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FRONT_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>510/540--0/0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element : FRONT_GROUP Element
Beschreibung
In diesem Element werden die Frontaufteilungen definiert und zu einer Frontgruppe zusammengefasst.
Namensraum (none)
Diagramm
FRONT_DIVISION Element Sequence FRONT_GROUP Element
Overview
FRONT_GROUP 1..99
In diesem Element werden die Frontaufteilungen definiert und zu einer Frontgruppe zusammengefasst.
FRONT_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein.

Ist die FRONT_GROUP gültig für alle Programme, so wird 0 hinterlegt. 		D positiveInteger
P
M [0:99]
Sequence
FRONT_DIVISION 1..∞
In diesem Element wird eine Frontaufteilung definiert und die einzelnen Zellen der Frontaufteilung beschrieben.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
Die Frontaufteilung wird nach der im Anhang beschriebenen Syntax eingegeben. Regalaufteilungen werden nicht über diese Syntax realisiert, sondern als eine Zelle betrachtet (siehe FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
In diesem Element werden die intern unterschiedlichen Bestellnummern für einen Artikel eingegeben, der in verschiedenen Frontaufteilungen lieferbar ist und im Katalog nur eine Artikelkennung besitzt. D string
P
M [1:15]
FRONT_CELL 1..∞
In diesem Element werden die einzelnen Zellen einer Frontaufteilung definiert.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
In diesem Attribut wird die Nummer der Zelle angegeben, die definiert werden soll. Die Zellennummer wird in der Frontaufteilung (FRONT_DIVISION_DEF) festgelegt. D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
In diesem Element wird angegeben, welchen Fronttyp die Zelle hat. Die Zuordnung eines Frontelementes erfolgt über den Fronttyp (siehe Element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

Folgende Fronttypen können zugeordnet werden:

1 - 100 = Türen
101 - 200 = Schubladen
201 - 300 = Auszüge
301 – 400 = Klappen
401 – 450 = Nischen mit Blende
451 – 500 = Nischen ohne Blende
501 – 550 = offene Fächer/Fachnischen
551 – 600 = Regale
601 – 650 = feste Blenden
651 – 700 = Schaltkastenblenden
701 – 750 = Jalousien
751 – 800 = Rollfronten
801 – 900 = Diverses 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
Die Elemente PARAMETER_1 und PARAMETER_2 werden für sichtbare Fachböden (z. B. Regale, Glasschränke) verwendet, um die Anzahl der Fachböden anzugeben.
PARAMETER_1 gibt die Anzahl der horizontalen Fachböden an. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
Dieses Element gibt die Anzahl der vertikalen Unterteilungen bei Regalen an. Gilt für sichtbare Fachböden (z. B. Regale, Glasschränke). D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle)
3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) keine Spiegelung
1) Spiegelung nur bei Änderung des Anschlags
2) Spiegelung nur bei Änderung der Bauweise
3) Spiegelung wenn sich entweder Anschlag oder Bauweise verändert
4) Spiegelung wenn Anschlag und Bauweise gemeinsam verändert werden.

Festlegungen werden im Kopftext dokumentiert und anhand von Beispielen verdeutlicht.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

Hier wird die Position der Kehlleiste definiert

1) = horizontal
2) = vertikal

 D nonNegativeInteger
P
M [1:2]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FRONT_GROUP_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein.

Ist die FRONT_GROUP gültig für alle Programme, so wird 0 hinterlegt. 		D positiveInteger
P
M [0:99]
Quelle
<xs:element name="FRONT_GROUP" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>510/540--0/0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_DIVISION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>510/540--0/0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_DIVISION_DEF">
              <xs:annotation>
                <xs:documentation>510--7--Frontaufteilung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="250" />
                  <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FRONT_CELL" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_CELL_NO">
                    <xs:annotation>
                      <xs:documentation>540--6--Zellennummer</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FRONT_TYPE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--7--Fronttyp</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="900" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HANDLE_POSITION_1" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--8--Griffposition_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HANDLE_POSITION_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--9--Griffposition_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--10--Grifflage_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="4" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--11--Grifflage_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="4" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PARAMETER_1" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--12--Parameter_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PARAMETER_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--13--Parameter_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="4" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="UPPER_JOIN" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[VLSG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="LOWER_JOIN" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[VLSG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="LEFT_JOIN" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[VLSG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RIGHT_JOIN" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[VLSG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DOUCINE_POSITION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>540--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FRONT_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>510/540--0/0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_DIVISION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element : FRONT_DIVISION Element
Beschreibung
In diesem Element wird eine Frontaufteilung definiert und die einzelnen Zellen der Frontaufteilung beschrieben.
Namensraum (none)
Diagramm
FRONT_CELL Element INTERNAL_ORDER_NO Element FRONT_DIVISION_DEF Element Sequence FRONT_DIVISION Element
Overview
FRONT_DIVISION 1..∞
In diesem Element wird eine Frontaufteilung definiert und die einzelnen Zellen der Frontaufteilung beschrieben.
Sequence
FRONT_DIVISION_DEF Restriction of xs:string
Die Frontaufteilung wird nach der im Anhang beschriebenen Syntax eingegeben. Regalaufteilungen werden nicht über diese Syntax realisiert, sondern als eine Zelle betrachtet (siehe FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
INTERNAL_ORDER_NO optional Restriction of xs:string
In diesem Element werden die intern unterschiedlichen Bestellnummern für einen Artikel eingegeben, der in verschiedenen Frontaufteilungen lieferbar ist und im Katalog nur eine Artikelkennung besitzt. D string
P
M [1:15]
FRONT_CELL 1..∞
In diesem Element werden die einzelnen Zellen einer Frontaufteilung definiert.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
In diesem Attribut wird die Nummer der Zelle angegeben, die definiert werden soll. Die Zellennummer wird in der Frontaufteilung (FRONT_DIVISION_DEF) festgelegt. D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
In diesem Element wird angegeben, welchen Fronttyp die Zelle hat. Die Zuordnung eines Frontelementes erfolgt über den Fronttyp (siehe Element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

Folgende Fronttypen können zugeordnet werden:

1 - 100 = Türen
101 - 200 = Schubladen
201 - 300 = Auszüge
301 – 400 = Klappen
401 – 450 = Nischen mit Blende
451 – 500 = Nischen ohne Blende
501 – 550 = offene Fächer/Fachnischen
551 – 600 = Regale
601 – 650 = feste Blenden
651 – 700 = Schaltkastenblenden
701 – 750 = Jalousien
751 – 800 = Rollfronten
801 – 900 = Diverses 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
Die Elemente PARAMETER_1 und PARAMETER_2 werden für sichtbare Fachböden (z. B. Regale, Glasschränke) verwendet, um die Anzahl der Fachböden anzugeben.
PARAMETER_1 gibt die Anzahl der horizontalen Fachböden an. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
Dieses Element gibt die Anzahl der vertikalen Unterteilungen bei Regalen an. Gilt für sichtbare Fachböden (z. B. Regale, Glasschränke). D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle)
3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) keine Spiegelung
1) Spiegelung nur bei Änderung des Anschlags
2) Spiegelung nur bei Änderung der Bauweise
3) Spiegelung wenn sich entweder Anschlag oder Bauweise verändert
4) Spiegelung wenn Anschlag und Bauweise gemeinsam verändert werden.

Festlegungen werden im Kopftext dokumentiert und anhand von Beispielen verdeutlicht.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

Hier wird die Position der Kehlleiste definiert

1) = horizontal
2) = vertikal

 D nonNegativeInteger
P
M [1:2]
Quelle
<xs:element name="FRONT_DIVISION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>510/540--0/0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_DIVISION_DEF">
        <xs:annotation>
          <xs:documentation>510--7--Frontaufteilung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="250" />
            <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INTERNAL_ORDER_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FRONT_CELL" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_CELL_NO">
              <xs:annotation>
                <xs:documentation>540--6--Zellennummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FRONT_TYPE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--7--Fronttyp</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="900" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HANDLE_POSITION_1" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--8--Griffposition_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HANDLE_POSITION_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--9--Griffposition_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--10--Grifflage_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="4" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--11--Grifflage_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="4" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PARAMETER_1" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--12--Parameter_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PARAMETER_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--13--Parameter_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="4" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="UPPER_JOIN" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[VLSG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="LOWER_JOIN" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[VLSG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="LEFT_JOIN" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[VLSG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="RIGHT_JOIN" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[VLSG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DOUCINE_POSITION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>540--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_DIVISION_DEF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element : FRONT_DIVISION_DEF Element
Beschreibung
Die Frontaufteilung wird nach der im Anhang beschriebenen Syntax eingegeben. Regalaufteilungen werden nicht über diese Syntax realisiert, sondern als eine Zelle betrachtet (siehe FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FRONT_DIVISION_DEF Element
Overview
FRONT_DIVISION_DEF Restriction of xs:string
Die Frontaufteilung wird nach der im Anhang beschriebenen Syntax eingegeben. Regalaufteilungen werden nicht über diese Syntax realisiert, sondern als eine Zelle betrachtet (siehe FRONT_CELL/PARAMETER_1/2). D string
P [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}
M [1:250]
Quelle
<xs:element name="FRONT_DIVISION_DEF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>510--7--Frontaufteilung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="250" />
      <xs:pattern value="[Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

INTERNAL_ORDER_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element : INTERNAL_ORDER_NO Element
Beschreibung
In diesem Element werden die intern unterschiedlichen Bestellnummern für einen Artikel eingegeben, der in verschiedenen Frontaufteilungen lieferbar ist und im Katalog nur eine Artikelkennung besitzt. D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
INTERNAL_ORDER_NO Element
Overview
INTERNAL_ORDER_NO optional Restriction of xs:string
In diesem Element werden die intern unterschiedlichen Bestellnummern für einen Artikel eingegeben, der in verschiedenen Frontaufteilungen lieferbar ist und im Katalog nur eine Artikelkennung besitzt. D string
P
M [1:15]
Quelle
<xs:element name="INTERNAL_ORDER_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>510--6--Interne_Bestell_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_CELL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element : FRONT_CELL Element
Beschreibung
In diesem Element werden die einzelnen Zellen einer Frontaufteilung definiert.
Namensraum (none)
Diagramm
DOUCINE_POSITION Element RIGHT_JOIN Element LEFT_JOIN Element LOWER_JOIN Element UPPER_JOIN Element HINGE_BEHAVIOR Element OFFSET_RIGHT Element OFFSET_LEFT Element OFFSET_BELOW Element OFFSET_ABOVE Element MOUNTING_HEIGHT_TO Element MOUNTING_HEIGHT_FROM Element PARAMETER_2 Element PARAMETER_1 Element HANDLE_ORIENTATION_2 Element HANDLE_ORIENTATION_1 Element HANDLE_POSITION_2 Element HANDLE_POSITION_1 Element FRONT_TYPE Element FRONT_CELL_NO Element Sequence FRONT_CELL Element
Overview
FRONT_CELL 1..∞
In diesem Element werden die einzelnen Zellen einer Frontaufteilung definiert.
Sequence
FRONT_CELL_NO Restriction of xs:positiveInteger
In diesem Attribut wird die Nummer der Zelle angegeben, die definiert werden soll. Die Zellennummer wird in der Frontaufteilung (FRONT_DIVISION_DEF) festgelegt. D positiveInteger
P
M [1:99]
FRONT_TYPE optional Restriction of xs:positiveInteger
In diesem Element wird angegeben, welchen Fronttyp die Zelle hat. Die Zuordnung eines Frontelementes erfolgt über den Fronttyp (siehe Element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

Folgende Fronttypen können zugeordnet werden:

1 - 100 = Türen
101 - 200 = Schubladen
201 - 300 = Auszüge
301 – 400 = Klappen
401 – 450 = Nischen mit Blende
451 – 500 = Nischen ohne Blende
501 – 550 = offene Fächer/Fachnischen
551 – 600 = Regale
601 – 650 = feste Blenden
651 – 700 = Schaltkastenblenden
701 – 750 = Jalousien
751 – 800 = Rollfronten
801 – 900 = Diverses 		D positiveInteger
P
M [1:900]
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
PARAMETER_1 optional Restriction of xs:positiveInteger
Die Elemente PARAMETER_1 und PARAMETER_2 werden für sichtbare Fachböden (z. B. Regale, Glasschränke) verwendet, um die Anzahl der Fachböden anzugeben.
PARAMETER_1 gibt die Anzahl der horizontalen Fachböden an. 		D positiveInteger
P
M [1-99]
PARAMETER_2 optional Restriction of xs:positiveInteger
Dieses Element gibt die Anzahl der vertikalen Unterteilungen bei Regalen an. Gilt für sichtbare Fachböden (z. B. Regale, Glasschränke). D positiveInteger
P
M [1-99]
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
OFFSET_ABOVE optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_BELOW optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
OFFSET_LEFT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
OFFSET_RIGHT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle)
3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) keine Spiegelung
1) Spiegelung nur bei Änderung des Anschlags
2) Spiegelung nur bei Änderung der Bauweise
3) Spiegelung wenn sich entweder Anschlag oder Bauweise verändert
4) Spiegelung wenn Anschlag und Bauweise gemeinsam verändert werden.

Festlegungen werden im Kopftext dokumentiert und anhand von Beispielen verdeutlicht.

 D nonNegativeInteger
P
M [0:4]
UPPER_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
LOWER_JOIN optional Restriction of xs:string

Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung

 D string
P |[VLSG]
M [0:1]
LEFT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
RIGHT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

Hier wird die Position der Kehlleiste definiert

1) = horizontal
2) = vertikal

 D nonNegativeInteger
P
M [1:2]
Quelle
<xs:element name="FRONT_CELL" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_CELL_NO">
        <xs:annotation>
          <xs:documentation>540--6--Zellennummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FRONT_TYPE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--7--Fronttyp</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="900" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HANDLE_POSITION_1" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--8--Griffposition_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HANDLE_POSITION_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--9--Griffposition_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HANDLE_ORIENTATION_1" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--10--Grifflage_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="4" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HANDLE_ORIENTATION_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--11--Grifflage_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="4" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PARAMETER_1" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--12--Parameter_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PARAMETER_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--13--Parameter_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="HINGE_BEHAVIOR" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="4" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="UPPER_JOIN" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[VLSG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="LOWER_JOIN" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[VLSG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="LEFT_JOIN" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[VLSG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RIGHT_JOIN" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[VLSG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DOUCINE_POSITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>540--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_CELL_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : FRONT_CELL_NO Element
Beschreibung
In diesem Attribut wird die Nummer der Zelle angegeben, die definiert werden soll. Die Zellennummer wird in der Frontaufteilung (FRONT_DIVISION_DEF) festgelegt. D positiveInteger
P
M [1:99]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
FRONT_CELL_NO Element
Overview
FRONT_CELL_NO Restriction of xs:positiveInteger
In diesem Attribut wird die Nummer der Zelle angegeben, die definiert werden soll. Die Zellennummer wird in der Frontaufteilung (FRONT_DIVISION_DEF) festgelegt. D positiveInteger
P
M [1:99]
Quelle
<xs:element name="FRONT_CELL_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--6--Zellennummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : FRONT_TYPE Element
Beschreibung
In diesem Element wird angegeben, welchen Fronttyp die Zelle hat. Die Zuordnung eines Frontelementes erfolgt über den Fronttyp (siehe Element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

Folgende Fronttypen können zugeordnet werden:

1 - 100 = Türen
101 - 200 = Schubladen
201 - 300 = Auszüge
301 – 400 = Klappen
401 – 450 = Nischen mit Blende
451 – 500 = Nischen ohne Blende
501 – 550 = offene Fächer/Fachnischen
551 – 600 = Regale
601 – 650 = feste Blenden
651 – 700 = Schaltkastenblenden
701 – 750 = Jalousien
751 – 800 = Rollfronten
801 – 900 = Diverses 		D positiveInteger
P
M [1:900]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
FRONT_TYPE Element
Overview
FRONT_TYPE optional Restriction of xs:positiveInteger
In diesem Element wird angegeben, welchen Fronttyp die Zelle hat. Die Zuordnung eines Frontelementes erfolgt über den Fronttyp (siehe Element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

Folgende Fronttypen können zugeordnet werden:

1 - 100 = Türen
101 - 200 = Schubladen
201 - 300 = Auszüge
301 – 400 = Klappen
401 – 450 = Nischen mit Blende
451 – 500 = Nischen ohne Blende
501 – 550 = offene Fächer/Fachnischen
551 – 600 = Regale
601 – 650 = feste Blenden
651 – 700 = Schaltkastenblenden
701 – 750 = Jalousien
751 – 800 = Rollfronten
801 – 900 = Diverses 		D positiveInteger
P
M [1:900]
Quelle
<xs:element name="FRONT_TYPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--7--Fronttyp</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="900" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_POSITION_1 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : HANDLE_POSITION_1 Element
Beschreibung
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
HANDLE_POSITION_1 Element
Overview
HANDLE_POSITION_1 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
Bemerkung

Quelle
<xs:element name="HANDLE_POSITION_1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--8--Griffposition_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_POSITION_2 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : HANDLE_POSITION_2 Element
Beschreibung
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
HANDLE_POSITION_2 Element
Overview
HANDLE_POSITION_2 optional Restriction of xs:positiveInteger
Folgende Griffpositionen sind möglich und werden mit dem entsprechenden Wert angegeben:

Für Stangengriffe ergibt sich die genaue Positionierung durch die angegebene Griffposition und einer dazugehörigen Grifflage (siehe HANDLE_ORIENTATION_1/2 und Variantenart 304) Wenn für den Anschlag des Artikels der Wert "J" gesetzt (Anschlag erfragen), dann wird hier die Griffposition wie bei "L" eingegeben. Diese kann dann bei "R" an der Mittelachse gespiegelt werden. 		D positiveInteger
P
M [1:99]
Quelle
<xs:element name="HANDLE_POSITION_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--9--Griffposition_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-3]|2[0-5]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION_1 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : HANDLE_ORIENTATION_1 Element
Beschreibung
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
HANDLE_ORIENTATION_1 Element
Overview
HANDLE_ORIENTATION_1 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
Quelle
<xs:element name="HANDLE_ORIENTATION_1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--10--Grifflage_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="4" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION_2 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : HANDLE_ORIENTATION_2 Element
Beschreibung
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
HANDLE_ORIENTATION_2 Element
Overview
HANDLE_ORIENTATION_2 optional Restriction of xs:positiveInteger
In diesem Element können die zugehörigen Grifflagen definiert werden:

1 = horizontal -
2 = vertikal |
3 = diagonal fallend \
4 = diagonal steigend /

Die Grifflagen 1 und 2 werden nur verwendet, wenn sie von der in Varianten-Art 304 verwendeten Grifflage abweicht. 		D positiveInteger
P
M [1:4]
Quelle
<xs:element name="HANDLE_ORIENTATION_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--11--Grifflage_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="4" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PARAMETER_1 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : PARAMETER_1 Element
Beschreibung
Die Elemente PARAMETER_1 und PARAMETER_2 werden für sichtbare Fachböden (z. B. Regale, Glasschränke) verwendet, um die Anzahl der Fachböden anzugeben.
PARAMETER_1 gibt die Anzahl der horizontalen Fachböden an. 		D positiveInteger
P
M [1-99]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PARAMETER_1 Element
Overview
PARAMETER_1 optional Restriction of xs:positiveInteger
Die Elemente PARAMETER_1 und PARAMETER_2 werden für sichtbare Fachböden (z. B. Regale, Glasschränke) verwendet, um die Anzahl der Fachböden anzugeben.
PARAMETER_1 gibt die Anzahl der horizontalen Fachböden an. 		D positiveInteger
P
M [1-99]
Quelle
<xs:element name="PARAMETER_1" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--12--Parameter_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PARAMETER_2 Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : PARAMETER_2 Element
Beschreibung
Dieses Element gibt die Anzahl der vertikalen Unterteilungen bei Regalen an. Gilt für sichtbare Fachböden (z. B. Regale, Glasschränke). D positiveInteger
P
M [1-99]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PARAMETER_2 Element
Overview
PARAMETER_2 optional Restriction of xs:positiveInteger
Dieses Element gibt die Anzahl der vertikalen Unterteilungen bei Regalen an. Gilt für sichtbare Fachböden (z. B. Regale, Glasschränke). D positiveInteger
P
M [1-99]
Quelle
<xs:element name="PARAMETER_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--13--Parameter_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MOUNTING_HEIGHT_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : MOUNTING_HEIGHT_FROM Element
Beschreibung
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MOUNTING_HEIGHT_FROM Element
Overview
MOUNTING_HEIGHT_FROM optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
Quelle
<xs:element name="MOUNTING_HEIGHT_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--14--Einbauhoehe_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MOUNTING_HEIGHT_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : MOUNTING_HEIGHT_TO Element
Beschreibung
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MOUNTING_HEIGHT_TO Element
Overview
MOUNTING_HEIGHT_TO optional Restriction of xs:nonNegativeInteger
In den Elementen MOUNTING_HEIGHT_FROM und MOUNTING_HEIGHT_TO wird die Mindesteinbauhöhe [mm] bzw. die maximale Einbauhöhe [mm] einer Nische für Einbaugeräte eingegeben. Mittels des in diesen Feldern eingegebenen Nischenbereichs wird die Gültigkeit einer Frontaufteilung zu einem Einbau-gerät spezifiziert. Ist nur eine Frontaufteilung angegeben, so kann anhand des definierten Wertebereichs die Gültigkeit eines ausgewählten Einbaugerätes für eine Nische geprüft werden. Sind mehrere Frontaufteilungen für einen Artikel definiert, kann anhand der Maße für den Nischenbereich entschieden werden, welche Frontaufteilung für ein Einbaugerät gültig ist. D nonNegativeInteger
P
M [0-9999]
Quelle
<xs:element name="MOUNTING_HEIGHT_TO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--15--Einbauhoehe_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OFFSET_ABOVE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : OFFSET_ABOVE Element
Beschreibung
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
Namensraum (none)
Typ
xs:integer
Diagramm
OFFSET_ABOVE Element
Overview
OFFSET_ABOVE optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
Quelle
<xs:element name="OFFSET_ABOVE" type="xs:integer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OFFSET_BELOW Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : OFFSET_BELOW Element
Beschreibung
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
Namensraum (none)
Typ
xs:integer
Diagramm
OFFSET_BELOW Element
Overview
OFFSET_BELOW optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 		D integer
P
M
Quelle
<xs:element name="OFFSET_BELOW" type="xs:integer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OFFSET_LEFT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : OFFSET_LEFT Element
Beschreibung
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
Namensraum (none)
Typ
xs:integer
Diagramm
OFFSET_LEFT Element
Overview
OFFSET_LEFT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle) 3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
Quelle
<xs:element name="OFFSET_LEFT" type="xs:integer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OFFSET_RIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : OFFSET_RIGHT Element
Beschreibung
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle)
3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
Namensraum (none)
Typ
xs:integer
Diagramm
OFFSET_RIGHT Element
Overview
OFFSET_RIGHT optional xs:integer
1) Positives Offset = Frontelement ist kleiner als Rastermaß der Zelle
2) Negatives Offset = Frontelement steht über (ist größer als Rastermaß der Zelle)
3) Die Luft kann anschlagsabhängig sein (siehe Feld Anschlagsverhalten) 		D integer
P
M
Quelle
<xs:element name="OFFSET_RIGHT" type="xs:integer" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HINGE_BEHAVIOR Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : HINGE_BEHAVIOR Element
Beschreibung

0) keine Spiegelung
1) Spiegelung nur bei Änderung des Anschlags
2) Spiegelung nur bei Änderung der Bauweise
3) Spiegelung wenn sich entweder Anschlag oder Bauweise verändert
4) Spiegelung wenn Anschlag und Bauweise gemeinsam verändert werden.

Festlegungen werden im Kopftext dokumentiert und anhand von Beispielen verdeutlicht.

 D nonNegativeInteger
P
M [0:4]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
HINGE_BEHAVIOR Element
Overview
HINGE_BEHAVIOR optional Restriction of xs:nonNegativeInteger

0) keine Spiegelung
1) Spiegelung nur bei Änderung des Anschlags
2) Spiegelung nur bei Änderung der Bauweise
3) Spiegelung wenn sich entweder Anschlag oder Bauweise verändert
4) Spiegelung wenn Anschlag und Bauweise gemeinsam verändert werden.

Festlegungen werden im Kopftext dokumentiert und anhand von Beispielen verdeutlicht.

 D nonNegativeInteger
P
M [0:4]
Quelle
<xs:element name="HINGE_BEHAVIOR" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="4" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

UPPER_JOIN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : UPPER_JOIN Element
Beschreibung
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
UPPER_JOIN Element
Overview
UPPER_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
Quelle
<xs:element name="UPPER_JOIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[VLSG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LOWER_JOIN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : LOWER_JOIN Element
Beschreibung

Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung

 D string
P |[VLSG]
M [0:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
LOWER_JOIN Element
Overview
LOWER_JOIN optional Restriction of xs:string

Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung

 D string
P |[VLSG]
M [0:1]
Quelle
<xs:element name="LOWER_JOIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[VLSG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LEFT_JOIN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : LEFT_JOIN Element
Beschreibung
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
LEFT_JOIN Element
Overview
LEFT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
Quelle
<xs:element name="LEFT_JOIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[VLSG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RIGHT_JOIN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : RIGHT_JOIN Element
Beschreibung
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
RIGHT_JOIN Element
Overview
RIGHT_JOIN optional Restriction of xs:string
Mit Verstiftung wird angegeben, ob die Frontzelle mit der benachbareten Frontzelle verbunden ist. Ist nichts angegeben, so ist die Frontzelle nicht mit der benachbarten Frontzelle verbunden.

V = verstiftet
L = verlascht
S = Scharnier (für Falt.- bzw. Klapptür)
G = Gehrung 		D string
P |[VLSG]
M [0:1]
Quelle
<xs:element name="RIGHT_JOIN" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[VLSG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DOUCINE_POSITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > FRONT_DIVISIONS Element > FRONT_GROUP Element > FRONT_DIVISION Element > FRONT_CELL Element : DOUCINE_POSITION Element
Beschreibung

Hier wird die Position der Kehlleiste definiert

1) = horizontal
2) = vertikal

 D nonNegativeInteger
P
M [1:2]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
DOUCINE_POSITION Element
Overview
DOUCINE_POSITION optional Restriction of xs:nonNegativeInteger

Hier wird die Position der Kehlleiste definiert

1) = horizontal
2) = vertikal

 D nonNegativeInteger
P
M [1:2]
Quelle
<xs:element name="DOUCINE_POSITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>540--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FRONT_CELL Element | FRONT_DIVISION Element | FRONT_GROUP Element | FRONT_DIVISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_APPEARANCE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : FRONT_APPEARANCE_REF Element
Beschreibung
Mit diesem Element wird dem Artikel eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Frontausprägungen, die mit diesem Element zugeordnet werden, sind programmunabhängig.
Namensraum (none)
Diagramm
FRONT_APPEARANCE_REF Element
Overview
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Artikel eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Frontausprägungen, die mit diesem Element zugeordnet werden, sind programmunabhängig.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Durch dieses Feld wird eine Beziehung zwischen der im Datensatz definierten Variante und einer Frontausprägung definiert. D positiveInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FRONT_APPEARANCE_NO Restriction of xs:positiveInteger required
Durch dieses Feld wird eine Beziehung zwischen der im Datensatz definierten Variante und einer Frontausprägung definiert. D positiveInteger
P
M
Quelle
<xs:element name="FRONT_APPEARANCE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--33--Frontauspraegungs_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MODULE_RULE_SET_REF Element
Beschreibung
Mit diesem Element referenziert der Artikel eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS. Nur Modulschränke (Typenschlüsselart = 17) können an dieser Stelle ein Modulregelset referenzieren. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden.
Namensraum (none)
Diagramm
MODULE_RULE_SET_REF Element
Overview
MODULE_RULE_SET_REF optional
Mit diesem Element referenziert der Artikel eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS. Nur Modulschränke (Typenschlüsselart = 17) können an dieser Stelle ein Modulregelset referenzieren. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D positiveInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MODULE_RULE_SET_NO xs:nonNegativeInteger required
In diesem Attribut wird die Nummer des Regelwerks eingetragen, mit dem die Artikel auf das jeweilige Regelwerk referenzieren. D positiveInteger
P
M
Quelle
<xs:element name="MODULE_RULE_SET_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SETS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MODULE_RULE_SETS Element
Beschreibung
Dieses Element enthält die Modulregelwerke für Modulelemente. Ist der Artikel ein Modulelement (Typenschlüssel = 10), dann werden hier die Regeln für die Verplanung des Moduls hinterlegt. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden
Namensraum (none)
Diagramm
MODULE_RULE_SET Element Sequence MODULE_RULE_SETS Element
Overview
MODULE_RULE_SETS optional
Dieses Element enthält die Modulregelwerke für Modulelemente. Ist der Artikel ein Modulelement (Typenschlüssel = 10), dann werden hier die Regeln für die Verplanung des Moduls hinterlegt. Es kann nur entweder das Element MODULE_RULE_SET_REF oder MODULE_RULE_SETS angegeben werden
Sequence
MODULE_RULE_SET 1..∞
In diesem Element wird dem Modulelement ein Set von Regeln zugewiesen. Jedes Set von Regeln referenziert über die MODULE_RULE_SET_NO das zugehörige Umbaumodul. Dadurch ist es möglich einem Artikel für verschiedene Umbaumodule unterschiedliche Regelwerke mitzugeben.
Sequence
MODULE_RULES
Ein Set von Regeln für den Einbau des Moduls in einen Modulschrank.
Sequence
MODULE_RULE 1..∞
Eine Regel für den Einbau des Moduls in einen Modulschrank.
Die Regel definiert unter welchen Voraussetzungen ein Modul in einem Umbauschrank plaziert werden kann.

Ein Modul muss den Typenschlüssel 10 haben.
Sequence
MODULE_POSITION Restriction of xs:string
Hier wird definiert welcher Wert geprüft werden soll.

LINE_BOTTOM | Unterkante des Modulelements in mm
LINE_TOP | Oberkante des Modulelements

Bei diesen Prüfungen sind MIN_VALUE oder MAX_VALUE anzugeben.
 D string
P LINE_BOTTOM|LINE_TOP

M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Maximalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Minimalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
MODULE_RULE_SET_REF
Mit diesem Element referenziert das Regelwerk eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS und die Umbauschränke, für die das betreffende Regelwerk gilt.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut referenziert das Regelwerk auf die MODULE_RULE_SET_DEFINITION und die Umbauschränke für die das Regelwerk mit diesem Artikel gültig ist. D nonNegativeInteger
P
M
Quelle
<xs:element name="MODULE_RULE_SETS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_RULE_SET" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_RULES">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MODULE_RULE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MODULE_POSITION">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                              <xs:enumeration value="LINE_BOTTOM" />
                              <xs:enumeration value="LINE_TOP" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MAX_VALUE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MIN_VALUE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MODULE_RULE_SET_REF">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element : MODULE_RULE_SET Element
Beschreibung
In diesem Element wird dem Modulelement ein Set von Regeln zugewiesen. Jedes Set von Regeln referenziert über die MODULE_RULE_SET_NO das zugehörige Umbaumodul. Dadurch ist es möglich einem Artikel für verschiedene Umbaumodule unterschiedliche Regelwerke mitzugeben.
Namensraum (none)
Diagramm
MODULE_RULE_SET_REF Element MODULE_RULES Element Sequence MODULE_RULE_SET Element
Overview
MODULE_RULE_SET 1..∞
In diesem Element wird dem Modulelement ein Set von Regeln zugewiesen. Jedes Set von Regeln referenziert über die MODULE_RULE_SET_NO das zugehörige Umbaumodul. Dadurch ist es möglich einem Artikel für verschiedene Umbaumodule unterschiedliche Regelwerke mitzugeben.
Sequence
MODULE_RULES
Ein Set von Regeln für den Einbau des Moduls in einen Modulschrank.
Sequence
MODULE_RULE 1..∞
Eine Regel für den Einbau des Moduls in einen Modulschrank.
Die Regel definiert unter welchen Voraussetzungen ein Modul in einem Umbauschrank plaziert werden kann.

Ein Modul muss den Typenschlüssel 10 haben.
Sequence
MODULE_POSITION Restriction of xs:string
Hier wird definiert welcher Wert geprüft werden soll.

LINE_BOTTOM | Unterkante des Modulelements in mm
LINE_TOP | Oberkante des Modulelements

Bei diesen Prüfungen sind MIN_VALUE oder MAX_VALUE anzugeben.
 D string
P LINE_BOTTOM|LINE_TOP

M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Maximalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Minimalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
MODULE_RULE_SET_REF
Mit diesem Element referenziert das Regelwerk eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS und die Umbauschränke, für die das betreffende Regelwerk gilt.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut referenziert das Regelwerk auf die MODULE_RULE_SET_DEFINITION und die Umbauschränke für die das Regelwerk mit diesem Artikel gültig ist. D nonNegativeInteger
P
M
Quelle
<xs:element name="MODULE_RULE_SET" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_RULES">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_RULE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MODULE_POSITION">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                        <xs:enumeration value="LINE_BOTTOM" />
                        <xs:enumeration value="LINE_TOP" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MAX_VALUE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MIN_VALUE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MODULE_RULE_SET_REF">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element : MODULE_RULES Element
Beschreibung
Ein Set von Regeln für den Einbau des Moduls in einen Modulschrank.
Namensraum (none)
Diagramm
MODULE_RULE Element Sequence MODULE_RULES Element
Overview
MODULE_RULES
Ein Set von Regeln für den Einbau des Moduls in einen Modulschrank.
Sequence
MODULE_RULE 1..∞
Eine Regel für den Einbau des Moduls in einen Modulschrank.
Die Regel definiert unter welchen Voraussetzungen ein Modul in einem Umbauschrank plaziert werden kann.

Ein Modul muss den Typenschlüssel 10 haben.
Sequence
MODULE_POSITION Restriction of xs:string
Hier wird definiert welcher Wert geprüft werden soll.

LINE_BOTTOM | Unterkante des Modulelements in mm
LINE_TOP | Oberkante des Modulelements

Bei diesen Prüfungen sind MIN_VALUE oder MAX_VALUE anzugeben.
 D string
P LINE_BOTTOM|LINE_TOP

M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Maximalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Minimalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
Quelle
<xs:element name="MODULE_RULES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_RULE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MODULE_POSITION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
                  <xs:enumeration value="LINE_BOTTOM" />
                  <xs:enumeration value="LINE_TOP" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MAX_VALUE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MIN_VALUE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element > MODULE_RULES Element : MODULE_RULE Element
Beschreibung
Eine Regel für den Einbau des Moduls in einen Modulschrank.
Die Regel definiert unter welchen Voraussetzungen ein Modul in einem Umbauschrank plaziert werden kann.

Ein Modul muss den Typenschlüssel 10 haben.
Namensraum (none)
Diagramm
MIN_VALUE Element MAX_VALUE Element MODULE_POSITION Element Sequence MODULE_RULE Element
Overview
MODULE_RULE 1..∞
Eine Regel für den Einbau des Moduls in einen Modulschrank.
Die Regel definiert unter welchen Voraussetzungen ein Modul in einem Umbauschrank plaziert werden kann.

Ein Modul muss den Typenschlüssel 10 haben.
Sequence
MODULE_POSITION Restriction of xs:string
Hier wird definiert welcher Wert geprüft werden soll.

LINE_BOTTOM | Unterkante des Modulelements in mm
LINE_TOP | Oberkante des Modulelements

Bei diesen Prüfungen sind MIN_VALUE oder MAX_VALUE anzugeben.
 D string
P LINE_BOTTOM|LINE_TOP

M
MAX_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Maximalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
MIN_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Minimalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
Quelle
<xs:element name="MODULE_RULE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MODULE_POSITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
            <xs:enumeration value="LINE_BOTTOM" />
            <xs:enumeration value="LINE_TOP" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MAX_VALUE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MIN_VALUE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
MODULE_RULES Element | MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_POSITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element > MODULE_RULES Element > MODULE_RULE Element : MODULE_POSITION Element
Beschreibung
Hier wird definiert welcher Wert geprüft werden soll.

LINE_BOTTOM | Unterkante des Modulelements in mm
LINE_TOP | Oberkante des Modulelements

Bei diesen Prüfungen sind MIN_VALUE oder MAX_VALUE anzugeben.
 D string
P LINE_BOTTOM|LINE_TOP

M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MODULE_POSITION Element
Overview
MODULE_POSITION Restriction of xs:string
Hier wird definiert welcher Wert geprüft werden soll.

LINE_BOTTOM | Unterkante des Modulelements in mm
LINE_TOP | Oberkante des Modulelements

Bei diesen Prüfungen sind MIN_VALUE oder MAX_VALUE anzugeben.
 D string
P LINE_BOTTOM|LINE_TOP

M
Quelle
<xs:element name="MODULE_POSITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="LINE_BOTTOM|LINE_TOP" />
      <xs:enumeration value="LINE_BOTTOM" />
      <xs:enumeration value="LINE_TOP" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
MODULE_RULE Element | MODULE_RULES Element | MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MAX_VALUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element > MODULE_RULES Element > MODULE_RULE Element : MAX_VALUE Element
Beschreibung

Hier wird der Maximalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MAX_VALUE Element
Overview
MAX_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Maximalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
Quelle
<xs:element name="MAX_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
MODULE_RULE Element | MODULE_RULES Element | MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MIN_VALUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element > MODULE_RULES Element > MODULE_RULE Element : MIN_VALUE Element
Beschreibung

Hier wird der Minimalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MIN_VALUE Element
Overview
MIN_VALUE optional Restriction of xs:nonNegativeInteger

Hier wird der Minimalwertes entsprechend der Vorgabe festgelegt. Zusätzlich zum Zahlenwert ist auch "99999" zugelassen. "99999" bedeutet bei Ober- und Unter- Kante die Höhe des Umbaus.

 D nonNegativeInteger
P
M [0-99999]
Quelle
<xs:element name="MIN_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
MODULE_RULE Element | MODULE_RULES Element | MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MODULE_RULE_SET_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > MODULE_RULE_SETS Element > MODULE_RULE_SET Element : MODULE_RULE_SET_REF Element
Beschreibung
Mit diesem Element referenziert das Regelwerk eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS und die Umbauschränke, für die das betreffende Regelwerk gilt.
Namensraum (none)
Diagramm
MODULE_RULE_SET_REF Element
Overview
MODULE_RULE_SET_REF
Mit diesem Element referenziert das Regelwerk eine MODULE_RULE_SET_DEFINITION unter T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS und die Umbauschränke, für die das betreffende Regelwerk gilt.
MODULE_RULE_SET_NO required xs:nonNegativeInteger
In diesem Attribut referenziert das Regelwerk auf die MODULE_RULE_SET_DEFINITION und die Umbauschränke für die das Regelwerk mit diesem Artikel gültig ist. D nonNegativeInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MODULE_RULE_SET_NO xs:nonNegativeInteger required
In diesem Attribut referenziert das Regelwerk auf die MODULE_RULE_SET_DEFINITION und die Umbauschränke für die das Regelwerk mit diesem Artikel gültig ist. D nonNegativeInteger
P
M
Quelle
<xs:element name="MODULE_RULE_SET_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MODULE_RULE_SET_NO" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MODULE_RULE_SET Element | MODULE_RULE_SETS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : DETAIL_INFOS Element
Beschreibung
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
Dieses Element referenziert Hyperlinks zu Detailinformationen.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTIES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PROPERTIES Element
Beschreibung
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Namensraum (none)
Diagramm
PROPERTY_REF Element Sequence PROPERTIES Element
Overview
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Quelle
<xs:element name="PROPERTIES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PROPERTY_NO" use="required">
            <xs:annotation>
              <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="VALUE" use="required">
            <xs:annotation>
              <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROPERTY_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PROPERTIES Element : PROPERTY_REF Element
Beschreibung
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
Namensraum (none)
Diagramm
PROPERTY_REF Element
Overview
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PROPERTY_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE Restriction of xs:string required

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Quelle
<xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PROPERTY_NO" use="required">
      <xs:annotation>
        <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="VALUE" use="required">
      <xs:annotation>
        <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PROPERTIES Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : RESTRICTIONS Element
Beschreibung
In diesem Element werden die Prüfverfahren einer Produktgruppe zusammengefasst.
Namensraum (none)
Diagramm
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
In diesem Element werden die Prüfverfahren einer Produktgruppe zusammengefasst.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, der Produktgruppe zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]

Bemerkung

Quelle
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99999" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > RESTRICTIONS Element : RESTRICTION_REF Element
Beschreibung
Dieses Element referenziert ein, der Produktgruppe zugeordnetes Prüfverfahren.
Namensraum (none)
Diagramm
RESTRICTION_REF Element
Overview
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, der Produktgruppe zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P [0:99999]
M
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]

Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P [0:99999]
M
SEQUENCE Restriction of xs:nonNegativeInteger required
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]

Bemerkung

Quelle
<xs:element name="RESTRICTION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99999" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
RESTRICTIONS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEFAULT_OPTION_GROUPS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : DEFAULT_OPTION_GROUPS Element
Beschreibung
In diesem Element werden Standard-Vorbelegungen von Programmvarianten als Vorschlag und Entscheidungshilfe für den Anwender definiert. Die vorgeschlagenen Kombinationen müssen kompatibel zu den Prüfverfahren sein.
Namensraum (none)
Diagramm
DEFAULT_OPTION_GROUP Element Sequence DEFAULT_OPTION_GROUPS Element
Overview
DEFAULT_OPTION_GROUPS optional
In diesem Element werden Standard-Vorbelegungen von Programmvarianten als Vorschlag und Entscheidungshilfe für den Anwender definiert. Die vorgeschlagenen Kombinationen müssen kompatibel zu den Prüfverfahren sein.
Sequence
DEFAULT_OPTION_GROUP 1..∞
In diesem Element wird ein Standardvorschlag definiert.
Jede Variantenart darf je DEFAULT_OPTION_GROUP nur einmal referenziert werden.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
In diesem Attribut wird eine numerischer Wert zur Identifizierung der Standardgruppe angelegt. D positiveInteger
P
M [1:999999999]
Sequence
DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
In diesem Element wird ein freier Name für einen Standardvorschlag angegeben. Der Name kann beispielsweise für die Auswahl eines Standardvorschlages vom Benutzer des Planungssystems verwendet werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FILE_NAME optional Restriction of xs:string
In diesem Element wird der Dateiname eines JPEG-Bildes angegeben, dass ein beispielartiges Bild des Standardvorschlages darstellt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
OPTION_REF 1..∞
In diesem Element werden die Varianten referenziert, die zu einem Standardvorschlag zusammengestellt werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart der referenzierten Variante angegeben. D noNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
In diesem Attribut wird die Variante referenziert, die dem Standardvorschlag zugeordnet wird. D string
P
M [1:5]
DETAIL_INFOS optional
Dieses Element dient der Angabe von Bildern unterhalb des Standardvorschlages.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Bemerkung

Quelle
<xs:element name="DEFAULT_OPTION_GROUPS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>295--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DEFAULT_OPTION_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FILE_NAME" minOccurs="0">
              <xs:annotation>
                <xs:documentation>296--6--Dateiname</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="OPTION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>295--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>295--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>295--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
                <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEFAULT_OPTION_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element : DEFAULT_OPTION_GROUP Element
Beschreibung
In diesem Element wird ein Standardvorschlag definiert.
Jede Variantenart darf je DEFAULT_OPTION_GROUP nur einmal referenziert werden.
Namensraum (none)
Diagramm
DETAIL_INFOS Element OPTION_REF Element FILE_NAME Element LANGUAGE Element Sequence DEFAULT_OPTION_GROUP_NAME Element Sequence DEFAULT_OPTION_GROUP Element
Overview
DEFAULT_OPTION_GROUP 1..∞
In diesem Element wird ein Standardvorschlag definiert.
Jede Variantenart darf je DEFAULT_OPTION_GROUP nur einmal referenziert werden.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
In diesem Attribut wird eine numerischer Wert zur Identifizierung der Standardgruppe angelegt. D positiveInteger
P
M [1:999999999]
Sequence
DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
In diesem Element wird ein freier Name für einen Standardvorschlag angegeben. Der Name kann beispielsweise für die Auswahl eines Standardvorschlages vom Benutzer des Planungssystems verwendet werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FILE_NAME optional Restriction of xs:string
In diesem Element wird der Dateiname eines JPEG-Bildes angegeben, dass ein beispielartiges Bild des Standardvorschlages darstellt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
OPTION_REF 1..∞
In diesem Element werden die Varianten referenziert, die zu einem Standardvorschlag zusammengestellt werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart der referenzierten Variante angegeben. D noNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
In diesem Attribut wird die Variante referenziert, die dem Standardvorschlag zugeordnet wird. D string
P
M [1:5]
DETAIL_INFOS optional
Dieses Element dient der Angabe von Bildern unterhalb des Standardvorschlages.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DEFAULT_OPTION_GROUP_NO Restriction of xs:positiveInteger required
In diesem Attribut wird eine numerischer Wert zur Identifizierung der Standardgruppe angelegt. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DEFAULT_OPTION_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FILE_NAME" minOccurs="0">
        <xs:annotation>
          <xs:documentation>296--6--Dateiname</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="OPTION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>295--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>295--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>295--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
          <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>295--4--Standard_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEFAULT_OPTION_GROUP_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element > DEFAULT_OPTION_GROUP Element : DEFAULT_OPTION_GROUP_NAME Element
Beschreibung
In diesem Element wird ein freier Name für einen Standardvorschlag angegeben. Der Name kann beispielsweise für die Auswahl eines Standardvorschlages vom Benutzer des Planungssystems verwendet werden.
Namensraum (none)
Typ
languagetexte30 Complex Type
Diagramm
LANGUAGE Element Sequence DEFAULT_OPTION_GROUP_NAME Element
Overview
DEFAULT_OPTION_GROUP_NAME languagetexte30 Complex Type
In diesem Element wird ein freier Name für einen Standardvorschlag angegeben. Der Name kann beispielsweise für die Auswahl eines Standardvorschlages vom Benutzer des Planungssystems verwendet werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="DEFAULT_OPTION_GROUP_NAME" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>296--5--Name_Standard_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DEFAULT_OPTION_GROUP Element | DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element > DEFAULT_OPTION_GROUP Element : FILE_NAME Element
Beschreibung
In diesem Element wird der Dateiname eines JPEG-Bildes angegeben, dass ein beispielartiges Bild des Standardvorschlages darstellt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FILE_NAME Element
Overview
FILE_NAME optional Restriction of xs:string
In diesem Element wird der Dateiname eines JPEG-Bildes angegeben, dass ein beispielartiges Bild des Standardvorschlages darstellt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M
Quelle
<xs:element name="FILE_NAME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>296--6--Dateiname</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DEFAULT_OPTION_GROUP Element | DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element > DEFAULT_OPTION_GROUP Element : OPTION_REF Element
Beschreibung
In diesem Element werden die Varianten referenziert, die zu einem Standardvorschlag zusammengestellt werden.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 1..∞
In diesem Element werden die Varianten referenziert, die zu einem Standardvorschlag zusammengestellt werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart der referenzierten Variante angegeben. D noNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
In diesem Attribut wird die Variante referenziert, die dem Standardvorschlag zugeordnet wird. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Variantenart der referenzierten Variante angegeben. D noNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
In diesem Attribut wird die Variante referenziert, die dem Standardvorschlag zugeordnet wird. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>295--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>295--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>295--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DEFAULT_OPTION_GROUP Element | DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element > DEFAULT_OPTION_GROUP Element : DETAIL_INFOS Element
Beschreibung
Dieses Element dient der Angabe von Bildern unterhalb des Standardvorschlages.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
Dieses Element dient der Angabe von Bildern unterhalb des Standardvorschlages.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Version 2.3 27.06.2014 K. Richter</xs:documentation>
    <xs:documentation>Bilder unterhalb des Standardvorschlages</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
DEFAULT_OPTION_GROUP Element | DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DEFAULT_OPTION_GROUPS Element > DEFAULT_OPTION_GROUP Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                                    30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | DEFAULT_OPTION_GROUP Element | DEFAULT_OPTION_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element : DETAIL_INFOS Element
Beschreibung
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks zur Serie hinterlegt werden.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks zur Serie hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element : RESTRICTIONS Element
Beschreibung
In diesem Element werden Serien-übergreifende Prüfverfahren gesammelt.
Namensraum (none)
Diagramm
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
In diesem Element werden Serien-übergreifende Prüfverfahren gesammelt.
Sequence
RESTRICTION_REF 0..∞
Mit diesem Element werden Serien-übergreifende Prüfverfahren referenziert.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Alle Prüfverfahren müssen einen unterschiedlichen Wert für die SEQUENCE_NO enthalten. Über die Prüfungen wird die Schnittmenge gebildet.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Serien-übergreifende Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
Quelle
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > SERIES Element > RESTRICTIONS Element : RESTRICTION_REF Element
Beschreibung
Mit diesem Element werden Serien-übergreifende Prüfverfahren referenziert.
Namensraum (none)
Diagramm
RESTRICTION_REF Element
Overview
RESTRICTION_REF 0..∞
Mit diesem Element werden Serien-übergreifende Prüfverfahren referenziert.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Alle Prüfverfahren müssen einen unterschiedlichen Wert für die SEQUENCE_NO enthalten. Über die Prüfungen wird die Schnittmenge gebildet.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Serien-übergreifende Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE Restriction of xs:nonNegativeInteger required
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Alle Prüfverfahren müssen einen unterschiedlichen Wert für die SEQUENCE_NO enthalten. Über die Prüfungen wird die Schnittmenge gebildet.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D nonNegativeInteger
P
M [1:99999]
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
Durch dieses Attribut werden Serien-übergreifende Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
Quelle
<xs:element name="RESTRICTION_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
RESTRICTIONS Element | SERIES Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : FEATURE_DEFINITION Element
Beschreibung
In diesem Element werden variantenabhängige Informationen hinterlegt.
Namensraum (none)
Diagramm
SUGGESTIONS Element RESTRICTIONS Element OPTION_DEFINITION Element FEATURES Element FEATURE_CLASSES Element Sequence FEATURE_DEFINITION Element
Overview
FEATURE_DEFINITION optional
In diesem Element werden variantenabhängige Informationen hinterlegt.
Sequence
FEATURE_CLASSES
In diesem Element werden Variantenarten zu Familien zusammengefasst. Mittels dieser Variantenfamilien können Plausibilitäts- und Vollständigkeitsprüfungen bezüglich der gültigen Variantenarten durchgeführt werden.

Die definierten Variantenfamilien können Serien, Programmen oder Produktgruppen zugeordnet werden. Zwischen Variantenfamilien auf Serien-, Programm- oder Artikelebene (über die ihm übergeordnete Produktgruppe) besteht keine Beziehung hinsichtlich einer Priorität. Die Anzahl der an einem Artikel gültigen Variantenarten ergibt sich aus der Summe der Variantenarten, die in der Variantenfamilie des Programms und der Variantenfamilie der dem Artikel übergeordneten Produktgruppe deklariert sind. Variantenfamilien, die aus dem Element FEATURE_CLASS_REF (Pfad 1) referenziert werden, dürfen nur Variantenarten enthalten, die in dem Element FEATURES (Pfad 2) als Kopfvariantenarten deklariert sind

Alle Variantenarten, die über die Elemente in PRICE_FEATURE_GROUP (Pfad 3), PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 4) und FINISH (Pfad 5) referenziert werden, müssen in der Variantenfamilie der Produktgruppe des Artikels enthalten sein.

Ebenso müssen die über die Elemente RESTRICTION_REF (Pfad 6), RESTRICTION_REF (Pfad 1) und RESTRICTION_REF (Pfad 8)verwendeten Variantenarten in der Variantenfamilie Produktgruppe des Artikels enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
Pfad 2: FEATURE_DEFINITION
Pfad 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 6: SERIES/SERIE/RESTRICTIONS
Pfad 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS
Sequence
FEATURE_CLASS 1..∞
In diesem Element wird eine Variantenfamilie definiert
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Variantenfamilie identifiziert. D nonNegativeInteger
P
M [1:999]
Sequence
FEATURE_REF 1..∞
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels (zugeordnet über die Produktgruppe) dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Regals keine Variantenarten für z. B. Griffe enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
FEATURES
In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten definiert. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Für die unterschiedlichen Variantenarten werden mit Ausnahme der Kombivariantenarten und der Variantenarten 701 und 703 immer die Kombinationen aus Ausführung und Farbe verwendet.

Variantenarten müssen immer paarweise angelegt werden. Zu jeder Ausführungsvariantenart existiert die zugehörige Farbvariantenart und zu jeder Farbvariantenart existiert eine zugehörige Ausführungsvariantenart.

Ausgenommen von dieser Regelung sind die Variantenarten 701 und 703, zu denen keine Farbvariantenart angelegt werden muss.

Variantenarten > 950 sind grafisch nur für Echtgrafik relevant, daher dürfen diese nicht als Kombivarianten deklariert werden.

Sind im Herstellerkatalog Kombivarianten angegeben (z. B. furniert grün), so sind diese im Element COMBINED_FEATURE (Pfad 1) zu erfassen.

In diesem Element müssen die im Element COMBINED_FEATURE (Pfad 1) verwendeten Detailvarianten als unsichtbare Kopfvarianten (HEADER_POS_VARIATION_TYPE (Pfad 2) = U) definiert werden.

Variantenarten, die als unsichtbare Variantenarten deklariert sind, dürfen nicht in einer Variantenfamilie referenziert werden.

Alle Variantenarten, im Element FEATURES (Pfad 3), die nicht als unsichtbare Kopfvariantenart deklariert sind, müssen mindestens in einer Variantenfamilie referenziert werden.

Es existieren MUSS-Variantenarten, die in Abhängigkeit des Typschlüssel eines Artikels angelegt werden müssen. Diese sind für eine vollständige Katalogbeschreibung jedoch im Allgemeinen nicht ausreichend. Die Zuordnung Typenschlüssel zu MUSS-Variantenart ist in der Tabelle "Typschlüssel-MUSS-Variantenart" definiert.
Weitere Erläuterungen zu den Variantenarten sind zu finden unter "Hinweise zur Verwendung der Variantenarten"

Das Element ist für Küchenhersteller (SUPPLIER/BRANCH_ID = K) zwingend anzulegen.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 3: FEATURE_DEFINITION
Sequence
COMBINED_FEATURE 0..∞
In diesem Element werden Varianten zu Kombi-Varianten zusammengefasst. Die in Kombi-Varianten zusammengefassten Varianten werden als Detailvarianten bezeichnet.

Varianten-Prüfungen und -Zuordnungen dürfen nur auf die hier definierten Kombivarianten und nicht auf die darunterliegenden Detailvariantenarten angewendet werden.

Detailvariantenarten müssen im Element HEADER_POS_VARIATION_TYPE (Pfad 1) als unsichtbar deklariert werden. Die Detailvarianten dürfen in keinem weiteren Element außer OPTION (Pfad 2) verwendet werden.

Wird eine Kombivariante angelegt, so muss diese durchgängig angelegt werden. Wird beispielsweise eine Kombi-Variante mit der Variantenart 303 und den Detailvariantenarten 301 und 302 angelegt, so müssen alle weiteren Varianten für Griffe als Kombi-Varianten mit der Variantenart 303 angelegt werden.

Hinsichtlich der Verarbeitung von Kombivarianten wurden nachfolgende Vereinbarungen getroffen: Wird beispielsweise eine Unifarbene Front angelegt, so wird in einer Kombivariante die Variantenart Frontfarbe 1 (101) angelegt. Die Farbe dieser Variante vererbt sich auf die Variantenart Frontfarbe 2 (102).

Bei einer Griff-Kombination (Variantenart 303), muss mindestens Variantenart 300 und eine der Variantenarten 301 oder 302 dieser Kombi-Variante zugeordnet werden.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P (105)|(115)|(125)|(201)|(303)
M [105:303]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence
OPTION_REF 2..5
Mit diesem Element werden Varianten referenziert, die zu einer Kombi-Varianten zusammengefasst werden sollen.

Variantenarten > 950 sind grafisch nur für Echtgrafik relevant, daher dürfen diese nicht als Kombivarianten angelegt werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
FEATURE 1..∞
In diesem Element wird eine Variantenart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werde und haben Priorität gegenüber entsprechenden Farbvarianten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. Falls es sich hierbei um eine Ausprägung der Variantenart 1 (d. h. Programm) handelt muss, falls in STYLE_REF ein Programm über STYLE_NO referenziert wird, der Wert von diesem Attribut identisch mit der referenzierten STYLE_NO sein. D string
P
M [1:5]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Sortierung der Varianten ermöglicht. Das Attribut muss nicht durchgehend gefüllt werden. Es können alle Varianten mit diesem Sortierkriterium versehen werden. D nonNegativeInteger
P
M
Sequence
Choice optional
STYLE_REF
Dieses Element referenziert ein Programm.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
HANDLE_ORIENTATION_REF
Dieses Element referenziert eine Grifflage.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Griffausprägung referenziert.
 D positiveInteger
P
M [1:9999]
FORM_REF
Dieses Element referenziert eine Form.
FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert.
 D string
P
M [1:5]
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert. Zur Zeit kann dieses Element nur für die Sockelhöhe (Variantenart 402) verwendet werden.
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine referenzierte Maßausprägung identifiziert.
 D nonNegativeInteger
P
M [1:99999]
HANDLE_POSITION_REF
Dieses Element referenziert eine Griffpositionierung.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Griffpositionierung referenziert.
 D nonNegativeInteger
P
M [0:999]
OPTION_TEXT languagetexte60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
VALID_FROM optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss. 		D date
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben. Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung)
 D nonNegativeInteger
P
M [0:999]
FRONT_APPEARANCE_REF optional
Durch dieses Element wird eine Beziehung zwischen der definierten Variante und einer Frontausprägung definiert. Eine hier referenzierte Frontausprägung muss im Element Pfad1/FRONT_APPEARANCE definiert sein.

Dieses Element Feld darf genutzt werden, wenn die im Attribut Pfad2/FEATURE_NO angelegte Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) ist.

Für die Verarbeitung dieses Elementes gilt folgende Regelung:
Besitzt ein Artikel eine Glastür, die Variantenart 154 ist in der Variantenfamilie des Artikels enthalten, so wird die FRONT_APPEARANCE_NO dieses Elementes verwendet. In allen anderen Situationen wird Pfad3/FRONT_APPEARANCE_REF verwendet.

Ab Füllstufe 2b muss dieses Feld gefüllt werden.

Elementpfade:
Pfad1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
Pfad2 = FEATURE_DEFINITION/FEATURES/FEATURE
Pfad3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird.
 D positiveInteger
P
M [1:999]
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
FEATURE_TEXT languagetexte60 Complex Type
Dieses Element enthält Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad1)), wird das Element nicht gefüllt.

Elementpfade
Pfad1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante,
U = unsichtbare Kopfvariante,
P = Positions-Variantenart oder
V = erbende Variantenart
ist.

Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.
Unsichtbare Kopfvarianten dürfen nur in den Elementen OPTION (Pfad 1) und COMBINED_FEATURE (Pfad 2) verwendet werden.

Das Kennzeichen V wird gesetzt, wenn es sich um eine Variantenart handelt, die Informationen einer anderen Variantenart erbt. Die Vererbung erfolgt innerhalb eines Artikels, daher darf dieses Kennzeichen nur bei den Variantenarten 202, 203, 205 und 208 gesetzt werden. Ist das Kennzeichen gesetzt, muss das
Element INHERIT_VARIATION_TYPE_REF (Pfad 3) zwingend mit einer Variantenart 202, 203, 205 oder 208 gefüllt sein, die im Element HEADER_POS_VARIATION_TYPE (Pfad 3) das Kennzeichen K oder P enthält.
Erbende Variantenarten dürfen in keinem anderen Element verwendet werden.
Mit „I“ gekennzeichnete Varianten sind unsichtbare Varianten, die aber für Prüfungen zur Verfügung stehen. Derzeit fällt unter Kennzeichnung "I" nur die Variantenart 305 = Bohrschema.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
Pfad 2: FEATURE_DEFINITION/FEATURES
Pfad 3: FEATURE_DEFINITION/FEATURES/FEATURE 		D nonNegativeInteger
P
M [0:999]
INHERIT_VARIATION_TYPE_REF optional
In diesem Element wird die Variantenart referenziert, von der die Variantenart Informationen erben soll.
Die Variantenarten 202, 203, 205 und 208 dürfen auch untereinander Informationen vererben.
Die hier angegebene Variantenart darf keine als "unsichtbar" deklarierte Variantenart sein.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die referenzierte Variantenart angegeben. D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]
OPTION_DEFINITION
In diesem Element werden die Ausprägungen von Farben, Materialien, Griffen, Formvarianten und Programmen definiert.
Sequence
STYLE 0..∞
In diesem Element werden die Programme definiert.
Die hier definierten Programme werden über das Element STYLE_REF (Pfad1) als Variante angelegt. Das Programm hat die Variantenart 1 (FEATURE_NO = 1).

Die Attribute eines Programms dürfen sich über die Serien hinweg nicht unterscheiden. Da ein Programm nur in diesem Element beschrieben und von den Serien referenziert wird, ist die vorgenannte Bedingung durch die Struktur implizit abgebildet.

Dieses Element ist nur optional, wenn im Element SUPPLIER/BRANCH_ID der Wert für die Branchen-ID "G" oder "Z" ist.

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES/
STYLE_NO required Restriction of xs:string
In diesem Attribut wird der herstellerspezifische Programmschlüssel angegeben. Es wird vom Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

P1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Sequence
FRONT_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird die programmspezifische Fronttiefe [mm] definiert. Als Vorgabewert bei keiner Angabe gilt 20 mm.
Dieses Element muss gefüllt werden, wenn das Element FRONT_APEREANCE_NO (Pfad1) gefüllt ist.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/ 		D nonNegativeInteger
P
M [1:99]
FRONT_DISTANCE optional Restriction of xs:nonNegativeInteger
In diesem Element wird der programmspezifische Türpuffer[mm] definiert. Es stellt den Abstand zwischen Tür und dahinter gelagertem Korpus dar. D nonNegativeInteger
P
M [1:99]
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Programm eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird. D positiveInteger
P
M [1:999]
FRONT_GROUP_REF optional
Mit diesem Element wird einem Programm eine Frontgruppe zugeordnet.
Sind die Frontaufteilungen von Artikeln über mehrere Programme gleich, können diese angegeben, in der mehrere Programme zusammengefasst werden können. Die Programme können zusammengefasst werden, wenn sich deren Frontaufteilungen nicht unterscheiden.
Dieses Element referenziert das Attribut SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
Bei Herstellern, deren Frontaufteilungen einzelner Schränke in einzelnen Programmen unterschiedlich sind, wird für die entsprechenden Programme eine Frontgruppe angelegt.
Bei Herstellern, deren Frontaufteilungen für alle Schränke programmunabhängig sind, wird keine Frontgruppe angegeben.
Häufig können beispielsweise alle Stilfronten zu einer Frontgruppe zusammengefasst werden, da sie in der Regel bei einer hohen Tür in der gleichen Weise unterteilt werden.
Die unterschiedlichen Frontaufteilungen bei beispielsweise verschiedenen Einbaugeräten ist unabhängig von der Frontgruppe.
Wird für ein Programm eine Frontgruppe angelegt, so müssen allen Programmen Frontgruppen zugeordnet werden.
FRONT_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein. D positiveInteger
P
M [1:99]
FEATURE_CLASS_REF optional
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D nonNegativeInteger
P
M [1:999]
DEFAULT_OPTION_GROUP_REF 0..∞
Mit diesem Element werden dem Programm Standardvorschläge zugeordnet.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird ein Standardvorschlag referenziert. D positiveInteger
P
M [1:999999999]
RESTRICTIONS optional
Dieses Element referenziert Prüfverfahren, die für das Programm angewendet werden (Programm-spezifische Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE required Restriction of xs:positiveInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element SEQUENCE erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D positiveInteger
P
M [1:99999]
HANDLE_ORIENTATION 0..∞
In diesem Element wird eine Grifflage definiert.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Griffausprägung identifiziert. D string
P
M [1:5]
Sequence
DEFAULT_HANDLE_ORIENTATION_REF optional

In diesem Element wird eine Variante für eine Basisgrifflage angelegt. Es wird eine Basisgrifflage referenziert, die im Element BASIC_HANDLE_POSITIONS (Pfad 1) definiert ist.

Im Element OPTION_KEY (Pfad 2) wird die herstellerspezifische Bezeichnung einer eingetragen.

Das Element Standard-Grifflage muss gefüllt werden, wenn im Element FEATURE (Pfad 3) die Variantenart 304 (Grifflage) eingetragen ist.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
Pfad 3: FEATURE_DEFINITION/FEATURES

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D nonNegativeInteger
P
M [1:99999]
MATERIAL 0..∞
In diesem Element wird ein Material definiert.

Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur (TEXTURE) noch Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material identifiziert. D string
P
M [1:5]
Sequence
Choice optional
COLOR
In diesem Element werden Farben definiert.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
TEXTURE
In diesem Element werden die Informationen für Texturen hinterlegt.
Sequence
FILE_NAME_TEXTURE Restriction of xs:string
In dieses Element werden Verweise auf Dateien mit Materialtexturen hinterlegt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
TEXTURE_REPEAT optional
Über dieses Element wird definiertgekennzeichnet, ob eine Textur einmal oder sich wiederholend aufgebracht wird (gekachelt). Soll die Textur gekachelt werden, wird das Element angelegt und die notwendigen Daten in den entsprechenden Kindelementen hinterlegt.
Kachelungsfaktor wird von der Software auf Basis der Texturgröße (DPI, Anzahl Pixel) bestimmt.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein.
TEXTURE_TILE optional Restriction of xs:int
Über dieses Attribut wird gekennzeichnet, ob eine Textur einmal (0 = nicht kacheln) oder sich wiederholend (1 = kacheln) aufgebracht wird. D integer
P
M [0:1]
Sequence
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in X-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in Y-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein. 		D boolean
P
M
TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D string
P |[HV]
M [0:1]
TRANSPARENCY optional Restriction of xs:nonNegativeInteger
Dieses Element definiert den Grad der Transparenz eines Materials (RGB-Wert oder Textur).
0 = opak
9 = max. Transparenz
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein. 		D nonNegativeInteger
P
M [0:9]
BRIGHTNESS optional Restriction of xs:nonNegativeInteger
Dieses Element definiert den Grad des Glanzes eines Materials (RGB-Wert oder Textur).
0 = matt
8 = Hochglanz
9 = Spiegelung
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein. 		D nonNegativeInteger
P
M [0:9]
FORM 0..∞
In diesem Element wird eine Formvariante definiert.
FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform identifiziert. D string
P
M [1:5]
Sequence
PROFILE_KEY Restriction of xs:string
In diesem Element wird der herstellerspezifische Key für eine Profilform hinterlegt. Mit diesem Element werden Varianten der Variantenarten 750-756 gebildet. Das Element FORM kann nur von den Variantenarten 750-756 genutzt werden. Die gebildete Varianten werden vom Artikel (ITEM) referenziert, der das Profil darstellt. D string
P
M [1:5]
OPTION_MEASURE 0..∞
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Sockelhöhe (Variantenart 402)).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine maßliche Ausprägung identifiziert. D nonNegativeInteger
P
M [1:99999]
Sequence
PLINTH_HEIGHT Restriction of xs:nonNegativeInteger
In diesem Element wird die Sockelhöhe in mm angegeben. D nonNegativeInteger
P
M [0:999999999]
STANDARD_PLINTH optional xs:boolean

In diesem Element wird angegeben, ob es sich bei der entsprechenden Sockelhöhe um einen Standard handelt, oder ob die Höhe vom Standard abweicht. Ist der Wert false(0), handelt es sich bei der Sockelhöhe um eine vom Standard abweichende Höhe, die eventuell mit einem Mehrpreis für die Sockelfüße verbunden ist.

Fehlt das Element, entspricht es dem Wert true(1).

Gibt es verknüpfte Artikel mit der Zuordnungsart CLASS = 21, muss dieses Element angegeben werden.

D boolean
P
M [0:1]
RESTRICTIONS optional
In diesem Element werden die Prüfverfahren angelegt.
Sequence
RESTRICTION 1..99999
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger

In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefüllt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
SUGGESTIONS optional
In diesem Element werden Vorbelegungen angelegt.
Sequence
SUGGESTION 1..99999

In diesem Element wird eine Vorbelegung für Variantenarten mit bestimmten Varianten definiert und beschrieben.

Diese Möglichkeit der Vorbelegung ist nur für Kopfvarianten vorgesehen und wirksam bei der Ersterfassung einer Planung.

Ähnlich wie ein Standardvorschlag (DEFAULT_OPTION_GROUP) wird sie unterhalb der Serie referenziert, wobei der Standardvorschlag mit höherer Priorität greift.

Über OPTION_COMBINATION können auch Paare von Varianten für variantenabhängige Vorbelegungen zur Verfügung gestellt werden.

Dabei ist die unter FEATURE_1_NO angegebene Variantenart die führende.

Die Vorbelegungen dürfen nicht den dazugehörigen Prüfungen widersprechen.

SUGGESTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Vorbelegungen eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
Sequence
SUGGESTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wird die Bezeichnung einer Vorbelegung hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination für die Vorbelegung gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einer Vorbelegung angegeben werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="FEATURE_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_CLASSES">
        <xs:annotation>
          <xs:documentation>255--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>255--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>255--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>255--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>255--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURES">
        <xs:annotation>
          <xs:documentation>250--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="COMBINED_FEATURE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>265--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" minOccurs="2" maxOccurs="5">
                    <xs:annotation>
                      <xs:documentation>265--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>265--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="10[012346]|11[01234]|12[01234]|20[02345]|30[012]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>265--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>265--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="(105)|(115)|(125)|(201)|(303)" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>265--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:choice minOccurs="0">
                                <xs:element name="STYLE_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="STYLE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MATERIAL_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MATERIAL_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="HANDLE_ORIENTATION_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="FORM_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="FORM_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_MEASURE_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="HANDLE_POSITION_REF">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="HANDLE_POSITION_NO" use="required">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                          <xs:totalDigits value="3" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                              <xs:element name="OPTION_TEXT" type="languagetexte60">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="SEQUENCE_NO">
                    <xs:annotation>
                      <xs:documentation>250--4--Sortierung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEADER_POS_VARIATION_TYPE">
                    <xs:annotation>
                      <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[IKUPV]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INHERIT_VARIATION_TYPE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="(202)|(203)|(205)|(208)" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>250--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_DEFINITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="STYLE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>210--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FRONT_DEPTH" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>210--6--Front_Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FRONT_DISTANCE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>210--6--Türpuffer</xs:documentation>
                      <xs:documentation>K.Richter/13.06.2018</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FRONT_GROUP_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>210--12--Frontgruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>210--12--Frontgruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>210--13--Var_Familien_Nr</xs:documentation>
                          <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DEFAULT_OPTION_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>295--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>295--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESTRICTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                      <xs:documentation>von minOcc 1 auf optional 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="RESTRICTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="STYLE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>210--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="HANDLE_ORIENTATION" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DEFAULT_HANDLE_ORIENTATION_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:choice minOccurs="0">
                    <xs:annotation>
                      <xs:documentation />
                      <xs:documentation>AK 28.02.2012. Optional gesetzt um die alte 1.7 Logik zu erhalten.</xs:documentation>
                    </xs:annotation>
                    <xs:element name="COLOR">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="RGB_RED">
                            <xs:annotation>
                              <xs:documentation>260--11--RGB_Rot</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="255" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="RGB_GREEN">
                            <xs:annotation>
                              <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="255" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="RGB_BLUE">
                            <xs:annotation>
                              <xs:documentation>260--13--RGB_Blau</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="255" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="TEXTURE">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="FILE_NAME_TEXTURE">
                            <xs:annotation>
                              <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="TEXTURE_REPEAT" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="REAL_MEASUREMENT_X">
                                  <xs:annotation>
                                    <xs:documentation>260--17--Realmass_X</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="REAL_MEASUREMENT_Y">
                                  <xs:annotation>
                                    <xs:documentation>260--18--Realmass_Y</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="TEXTURE_TILE">
                                <xs:simpleType>
                                  <xs:restriction base="xs:int">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="1" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MASKING" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>260--10--Maskierung</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:boolean" />
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="TEXTURE_DELIVERED_ORIENTATION">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:pattern value="|[HV]" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:element name="TRANSPARENCY" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--14--Transparenz</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BRIGHTNESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--15--Glanz</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="MATERIAL_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORM" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROFILE_KEY">
                    <xs:annotation>
                      <xs:documentation>430--4/5--Varianten_Art_Profilform/Var_Schluessel_</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FORM_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PLINTH_HEIGHT">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STANDARD_PLINTH" type="xs:boolean" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Kennzeichnung zur Abweichung von Standardsockelhöhe</xs:documentation>
                      <xs:documentation>hinzugefügt K.Richter, 29.02.2016</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPTION_MEASURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>270/271--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION" maxOccurs="99999">
              <xs:annotation>
                <xs:documentation>270/271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>270--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:sequence minOccurs="0">
                          <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                            <xs:annotation>
                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="DIMENSION_TYPE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[WHD]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSION_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                            <xs:annotation>
                              <xs:documentation>405--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="DIMENSION_TYPE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[WHD]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSION_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TEST_ID">
                    <xs:annotation>
                      <xs:documentation>270--4--Pruef_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_1_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_2_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_3_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="VALIDATION_TYPE" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:int">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUGGESTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>270/271--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SUGGESTION" maxOccurs="99999">
              <xs:annotation>
                <xs:documentation>270/271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SUGGESTION_NAME_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>270--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SUGGESTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_1_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_2_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_3_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_CLASSES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : FEATURE_CLASSES Element
Beschreibung
In diesem Element werden Variantenarten zu Familien zusammengefasst. Mittels dieser Variantenfamilien können Plausibilitäts- und Vollständigkeitsprüfungen bezüglich der gültigen Variantenarten durchgeführt werden.

Die definierten Variantenfamilien können Serien, Programmen oder Produktgruppen zugeordnet werden. Zwischen Variantenfamilien auf Serien-, Programm- oder Artikelebene (über die ihm übergeordnete Produktgruppe) besteht keine Beziehung hinsichtlich einer Priorität. Die Anzahl der an einem Artikel gültigen Variantenarten ergibt sich aus der Summe der Variantenarten, die in der Variantenfamilie des Programms und der Variantenfamilie der dem Artikel übergeordneten Produktgruppe deklariert sind. Variantenfamilien, die aus dem Element FEATURE_CLASS_REF (Pfad 1) referenziert werden, dürfen nur Variantenarten enthalten, die in dem Element FEATURES (Pfad 2) als Kopfvariantenarten deklariert sind

Alle Variantenarten, die über die Elemente in PRICE_FEATURE_GROUP (Pfad 3), PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 4) und FINISH (Pfad 5) referenziert werden, müssen in der Variantenfamilie der Produktgruppe des Artikels enthalten sein.

Ebenso müssen die über die Elemente RESTRICTION_REF (Pfad 6), RESTRICTION_REF (Pfad 1) und RESTRICTION_REF (Pfad 8)verwendeten Variantenarten in der Variantenfamilie Produktgruppe des Artikels enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
Pfad 2: FEATURE_DEFINITION
Pfad 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 6: SERIES/SERIE/RESTRICTIONS
Pfad 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS
Namensraum (none)
Diagramm
FEATURE_CLASS Element Sequence FEATURE_CLASSES Element
Overview
FEATURE_CLASSES
In diesem Element werden Variantenarten zu Familien zusammengefasst. Mittels dieser Variantenfamilien können Plausibilitäts- und Vollständigkeitsprüfungen bezüglich der gültigen Variantenarten durchgeführt werden.

Die definierten Variantenfamilien können Serien, Programmen oder Produktgruppen zugeordnet werden. Zwischen Variantenfamilien auf Serien-, Programm- oder Artikelebene (über die ihm übergeordnete Produktgruppe) besteht keine Beziehung hinsichtlich einer Priorität. Die Anzahl der an einem Artikel gültigen Variantenarten ergibt sich aus der Summe der Variantenarten, die in der Variantenfamilie des Programms und der Variantenfamilie der dem Artikel übergeordneten Produktgruppe deklariert sind. Variantenfamilien, die aus dem Element FEATURE_CLASS_REF (Pfad 1) referenziert werden, dürfen nur Variantenarten enthalten, die in dem Element FEATURES (Pfad 2) als Kopfvariantenarten deklariert sind

Alle Variantenarten, die über die Elemente in PRICE_FEATURE_GROUP (Pfad 3), PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 4) und FINISH (Pfad 5) referenziert werden, müssen in der Variantenfamilie der Produktgruppe des Artikels enthalten sein.

Ebenso müssen die über die Elemente RESTRICTION_REF (Pfad 6), RESTRICTION_REF (Pfad 1) und RESTRICTION_REF (Pfad 8)verwendeten Variantenarten in der Variantenfamilie Produktgruppe des Artikels enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
Pfad 2: FEATURE_DEFINITION
Pfad 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 6: SERIES/SERIE/RESTRICTIONS
Pfad 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS
Sequence
FEATURE_CLASS 1..∞
In diesem Element wird eine Variantenfamilie definiert
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Variantenfamilie identifiziert. D nonNegativeInteger
P
M [1:999]
Sequence
FEATURE_REF 1..∞
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels (zugeordnet über die Produktgruppe) dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Regals keine Variantenarten für z. B. Griffe enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE_CLASSES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>255--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>255--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>255--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>255--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_CLASS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURE_CLASSES Element : FEATURE_CLASS Element
Beschreibung
In diesem Element wird eine Variantenfamilie definiert
Namensraum (none)
Diagramm
FEATURE_REF Element Sequence FEATURE_CLASS Element
Overview
FEATURE_CLASS 1..∞
In diesem Element wird eine Variantenfamilie definiert
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Variantenfamilie identifiziert. D nonNegativeInteger
P
M [1:999]
Sequence
FEATURE_REF 1..∞
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels (zugeordnet über die Produktgruppe) dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Regals keine Variantenarten für z. B. Griffe enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Variantenfamilie identifiziert. D nonNegativeInteger
P
M [1:999]
Quelle
<xs:element name="FEATURE_CLASS" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>255--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>255--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>255--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_CLASSES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURE_CLASSES Element > FEATURE_CLASS Element : FEATURE_REF Element
Beschreibung
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels (zugeordnet über die Produktgruppe) dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Regals keine Variantenarten für z. B. Griffe enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Namensraum (none)
Diagramm
FEATURE_REF Element
Overview
FEATURE_REF 1..∞
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels (zugeordnet über die Produktgruppe) dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Regals keine Variantenarten für z. B. Griffe enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>255--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_CLASS Element | FEATURE_CLASSES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : FEATURES Element
Beschreibung
In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten definiert. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Für die unterschiedlichen Variantenarten werden mit Ausnahme der Kombivariantenarten und der Variantenarten 701 und 703 immer die Kombinationen aus Ausführung und Farbe verwendet.

Variantenarten müssen immer paarweise angelegt werden. Zu jeder Ausführungsvariantenart existiert die zugehörige Farbvariantenart und zu jeder Farbvariantenart existiert eine zugehörige Ausführungsvariantenart.

Ausgenommen von dieser Regelung sind die Variantenarten 701 und 703, zu denen keine Farbvariantenart angelegt werden muss.

Variantenarten > 950 sind grafisch nur für Echtgrafik relevant, daher dürfen diese nicht als Kombivarianten deklariert werden.

Sind im Herstellerkatalog Kombivarianten angegeben (z. B. furniert grün), so sind diese im Element COMBINED_FEATURE (Pfad 1) zu erfassen.

In diesem Element müssen die im Element COMBINED_FEATURE (Pfad 1) verwendeten Detailvarianten als unsichtbare Kopfvarianten (HEADER_POS_VARIATION_TYPE (Pfad 2) = U) definiert werden.

Variantenarten, die als unsichtbare Variantenarten deklariert sind, dürfen nicht in einer Variantenfamilie referenziert werden.

Alle Variantenarten, im Element FEATURES (Pfad 3), die nicht als unsichtbare Kopfvariantenart deklariert sind, müssen mindestens in einer Variantenfamilie referenziert werden.

Es existieren MUSS-Variantenarten, die in Abhängigkeit des Typschlüssel eines Artikels angelegt werden müssen. Diese sind für eine vollständige Katalogbeschreibung jedoch im Allgemeinen nicht ausreichend. Die Zuordnung Typenschlüssel zu MUSS-Variantenart ist in der Tabelle "Typschlüssel-MUSS-Variantenart" definiert.
Weitere Erläuterungen zu den Variantenarten sind zu finden unter "Hinweise zur Verwendung der Variantenarten"

Das Element ist für Küchenhersteller (SUPPLIER/BRANCH_ID = K) zwingend anzulegen.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 3: FEATURE_DEFINITION
Namensraum (none)
Diagramm
FEATURE Element COMBINED_FEATURE Element Sequence FEATURES Element
Overview
FEATURES
In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten definiert. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Für die unterschiedlichen Variantenarten werden mit Ausnahme der Kombivariantenarten und der Variantenarten 701 und 703 immer die Kombinationen aus Ausführung und Farbe verwendet.

Variantenarten müssen immer paarweise angelegt werden. Zu jeder Ausführungsvariantenart existiert die zugehörige Farbvariantenart und zu jeder Farbvariantenart existiert eine zugehörige Ausführungsvariantenart.

Ausgenommen von dieser Regelung sind die Variantenarten 701 und 703, zu denen keine Farbvariantenart angelegt werden muss.

Variantenarten > 950 sind grafisch nur für Echtgrafik relevant, daher dürfen diese nicht als Kombivarianten deklariert werden.

Sind im Herstellerkatalog Kombivarianten angegeben (z. B. furniert grün), so sind diese im Element COMBINED_FEATURE (Pfad 1) zu erfassen.

In diesem Element müssen die im Element COMBINED_FEATURE (Pfad 1) verwendeten Detailvarianten als unsichtbare Kopfvarianten (HEADER_POS_VARIATION_TYPE (Pfad 2) = U) definiert werden.

Variantenarten, die als unsichtbare Variantenarten deklariert sind, dürfen nicht in einer Variantenfamilie referenziert werden.

Alle Variantenarten, im Element FEATURES (Pfad 3), die nicht als unsichtbare Kopfvariantenart deklariert sind, müssen mindestens in einer Variantenfamilie referenziert werden.

Es existieren MUSS-Variantenarten, die in Abhängigkeit des Typschlüssel eines Artikels angelegt werden müssen. Diese sind für eine vollständige Katalogbeschreibung jedoch im Allgemeinen nicht ausreichend. Die Zuordnung Typenschlüssel zu MUSS-Variantenart ist in der Tabelle "Typschlüssel-MUSS-Variantenart" definiert.
Weitere Erläuterungen zu den Variantenarten sind zu finden unter "Hinweise zur Verwendung der Variantenarten"

Das Element ist für Küchenhersteller (SUPPLIER/BRANCH_ID = K) zwingend anzulegen.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 3: FEATURE_DEFINITION
Sequence
COMBINED_FEATURE 0..∞
In diesem Element werden Varianten zu Kombi-Varianten zusammengefasst. Die in Kombi-Varianten zusammengefassten Varianten werden als Detailvarianten bezeichnet.

Varianten-Prüfungen und -Zuordnungen dürfen nur auf die hier definierten Kombivarianten und nicht auf die darunterliegenden Detailvariantenarten angewendet werden.

Detailvariantenarten müssen im Element HEADER_POS_VARIATION_TYPE (Pfad 1) als unsichtbar deklariert werden. Die Detailvarianten dürfen in keinem weiteren Element außer OPTION (Pfad 2) verwendet werden.

Wird eine Kombivariante angelegt, so muss diese durchgängig angelegt werden. Wird beispielsweise eine Kombi-Variante mit der Variantenart 303 und den Detailvariantenarten 301 und 302 angelegt, so müssen alle weiteren Varianten für Griffe als Kombi-Varianten mit der Variantenart 303 angelegt werden.

Hinsichtlich der Verarbeitung von Kombivarianten wurden nachfolgende Vereinbarungen getroffen: Wird beispielsweise eine Unifarbene Front angelegt, so wird in einer Kombivariante die Variantenart Frontfarbe 1 (101) angelegt. Die Farbe dieser Variante vererbt sich auf die Variantenart Frontfarbe 2 (102).

Bei einer Griff-Kombination (Variantenart 303), muss mindestens Variantenart 300 und eine der Variantenarten 301 oder 302 dieser Kombi-Variante zugeordnet werden.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P (105)|(115)|(125)|(201)|(303)
M [105:303]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence
OPTION_REF 2..5
Mit diesem Element werden Varianten referenziert, die zu einer Kombi-Varianten zusammengefasst werden sollen.

Variantenarten > 950 sind grafisch nur für Echtgrafik relevant, daher dürfen diese nicht als Kombivarianten angelegt werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
FEATURE 1..∞
In diesem Element wird eine Variantenart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werde und haben Priorität gegenüber entsprechenden Farbvarianten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. Falls es sich hierbei um eine Ausprägung der Variantenart 1 (d. h. Programm) handelt muss, falls in STYLE_REF ein Programm über STYLE_NO referenziert wird, der Wert von diesem Attribut identisch mit der referenzierten STYLE_NO sein. D string
P
M [1:5]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Sortierung der Varianten ermöglicht. Das Attribut muss nicht durchgehend gefüllt werden. Es können alle Varianten mit diesem Sortierkriterium versehen werden. D nonNegativeInteger
P
M
Sequence
Choice optional
STYLE_REF
Dieses Element referenziert ein Programm.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
HANDLE_ORIENTATION_REF
Dieses Element referenziert eine Grifflage.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Griffausprägung referenziert.
 D positiveInteger
P
M [1:9999]
FORM_REF
Dieses Element referenziert eine Form.
FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert.
 D string
P
M [1:5]
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert. Zur Zeit kann dieses Element nur für die Sockelhöhe (Variantenart 402) verwendet werden.
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine referenzierte Maßausprägung identifiziert.
 D nonNegativeInteger
P
M [1:99999]
HANDLE_POSITION_REF
Dieses Element referenziert eine Griffpositionierung.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Griffpositionierung referenziert.
 D nonNegativeInteger
P
M [0:999]
OPTION_TEXT languagetexte60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss. 		D date
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben. Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung)
 D nonNegativeInteger
P
M [0:999]
FRONT_APPEARANCE_REF optional
Durch dieses Element wird eine Beziehung zwischen der definierten Variante und einer Frontausprägung definiert. Eine hier referenzierte Frontausprägung muss im Element Pfad1/FRONT_APPEARANCE definiert sein.

Dieses Element Feld darf genutzt werden, wenn die im Attribut Pfad2/FEATURE_NO angelegte Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) ist.

Für die Verarbeitung dieses Elementes gilt folgende Regelung:
Besitzt ein Artikel eine Glastür, die Variantenart 154 ist in der Variantenfamilie des Artikels enthalten, so wird die FRONT_APPEARANCE_NO dieses Elementes verwendet. In allen anderen Situationen wird Pfad3/FRONT_APPEARANCE_REF verwendet.

Ab Füllstufe 2b muss dieses Feld gefüllt werden.

Elementpfade:
Pfad1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
Pfad2 = FEATURE_DEFINITION/FEATURES/FEATURE
Pfad3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird.
 D positiveInteger
P
M [1:999]
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Durch dieses Element werden Hyperlinks zu Detailinformationen referenziert.
 D positiveInteger
P
M [1:999999999]
FEATURE_TEXT languagetexte60 Complex Type
Dieses Element enthält Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad1)), wird das Element nicht gefüllt.

Elementpfade
Pfad1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante,
U = unsichtbare Kopfvariante,
P = Positions-Variantenart oder
V = erbende Variantenart
ist.

Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.
Unsichtbare Kopfvarianten dürfen nur in den Elementen OPTION (Pfad 1) und COMBINED_FEATURE (Pfad 2) verwendet werden.

Das Kennzeichen V wird gesetzt, wenn es sich um eine Variantenart handelt, die Informationen einer anderen Variantenart erbt. Die Vererbung erfolgt innerhalb eines Artikels, daher darf dieses Kennzeichen nur bei den Variantenarten 202, 203, 205 und 208 gesetzt werden. Ist das Kennzeichen gesetzt, muss das
Element INHERIT_VARIATION_TYPE_REF (Pfad 3) zwingend mit einer Variantenart 202, 203, 205 oder 208 gefüllt sein, die im Element HEADER_POS_VARIATION_TYPE (Pfad 3) das Kennzeichen K oder P enthält.
Erbende Variantenarten dürfen in keinem anderen Element verwendet werden.
Mit „I“ gekennzeichnete Varianten sind unsichtbare Varianten, die aber für Prüfungen zur Verfügung stehen. Derzeit fällt unter Kennzeichnung "I" nur die Variantenart 305 = Bohrschema.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
Pfad 2: FEATURE_DEFINITION/FEATURES
Pfad 3: FEATURE_DEFINITION/FEATURES/FEATURE 		D nonNegativeInteger
P
M [0:999]
INHERIT_VARIATION_TYPE_REF optional
In diesem Element wird die Variantenart referenziert, von der die Variantenart Informationen erben soll.
Die Variantenarten 202, 203, 205 und 208 dürfen auch untereinander Informationen vererben.
Die hier angegebene Variantenart darf keine als "unsichtbar" deklarierte Variantenart sein.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die referenzierte Variantenart angegeben. D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]
Quelle
<xs:element name="FEATURES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="COMBINED_FEATURE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>265--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" minOccurs="2" maxOccurs="5">
              <xs:annotation>
                <xs:documentation>265--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>265--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="10[012346]|11[01234]|12[01234]|20[02345]|30[012]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>265--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>265--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="(105)|(115)|(125)|(201)|(303)" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>265--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:choice minOccurs="0">
                          <xs:element name="STYLE_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="STYLE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MATERIAL_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MATERIAL_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="HANDLE_ORIENTATION_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="FORM_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="FORM_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_MEASURE_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="HANDLE_POSITION_REF">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="HANDLE_POSITION_NO" use="required">
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                    <xs:totalDigits value="3" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:element name="OPTION_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="SEQUENCE_NO">
              <xs:annotation>
                <xs:documentation>250--4--Sortierung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEADER_POS_VARIATION_TYPE">
              <xs:annotation>
                <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[IKUPV]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INHERIT_VARIATION_TYPE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>250--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="(202)|(203)|(205)|(208)" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>250--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COMBINED_FEATURE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element : COMBINED_FEATURE Element
Beschreibung
In diesem Element werden Varianten zu Kombi-Varianten zusammengefasst. Die in Kombi-Varianten zusammengefassten Varianten werden als Detailvarianten bezeichnet.

Varianten-Prüfungen und -Zuordnungen dürfen nur auf die hier definierten Kombivarianten und nicht auf die darunterliegenden Detailvariantenarten angewendet werden.

Detailvariantenarten müssen im Element HEADER_POS_VARIATION_TYPE (Pfad 1) als unsichtbar deklariert werden. Die Detailvarianten dürfen in keinem weiteren Element außer OPTION (Pfad 2) verwendet werden.

Wird eine Kombivariante angelegt, so muss diese durchgängig angelegt werden. Wird beispielsweise eine Kombi-Variante mit der Variantenart 303 und den Detailvariantenarten 301 und 302 angelegt, so müssen alle weiteren Varianten für Griffe als Kombi-Varianten mit der Variantenart 303 angelegt werden.

Hinsichtlich der Verarbeitung von Kombivarianten wurden nachfolgende Vereinbarungen getroffen: Wird beispielsweise eine Unifarbene Front angelegt, so wird in einer Kombivariante die Variantenart Frontfarbe 1 (101) angelegt. Die Farbe dieser Variante vererbt sich auf die Variantenart Frontfarbe 2 (102).

Bei einer Griff-Kombination (Variantenart 303), muss mindestens Variantenart 300 und eine der Variantenarten 301 oder 302 dieser Kombi-Variante zugeordnet werden.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
Namensraum (none)
Diagramm
OPTION_REF Element Sequence COMBINED_FEATURE Element
Overview
COMBINED_FEATURE 0..∞
In diesem Element werden Varianten zu Kombi-Varianten zusammengefasst. Die in Kombi-Varianten zusammengefassten Varianten werden als Detailvarianten bezeichnet.

Varianten-Prüfungen und -Zuordnungen dürfen nur auf die hier definierten Kombivarianten und nicht auf die darunterliegenden Detailvariantenarten angewendet werden.

Detailvariantenarten müssen im Element HEADER_POS_VARIATION_TYPE (Pfad 1) als unsichtbar deklariert werden. Die Detailvarianten dürfen in keinem weiteren Element außer OPTION (Pfad 2) verwendet werden.

Wird eine Kombivariante angelegt, so muss diese durchgängig angelegt werden. Wird beispielsweise eine Kombi-Variante mit der Variantenart 303 und den Detailvariantenarten 301 und 302 angelegt, so müssen alle weiteren Varianten für Griffe als Kombi-Varianten mit der Variantenart 303 angelegt werden.

Hinsichtlich der Verarbeitung von Kombivarianten wurden nachfolgende Vereinbarungen getroffen: Wird beispielsweise eine Unifarbene Front angelegt, so wird in einer Kombivariante die Variantenart Frontfarbe 1 (101) angelegt. Die Farbe dieser Variante vererbt sich auf die Variantenart Frontfarbe 2 (102).

Bei einer Griff-Kombination (Variantenart 303), muss mindestens Variantenart 300 und eine der Variantenarten 301 oder 302 dieser Kombi-Variante zugeordnet werden.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P (105)|(115)|(125)|(201)|(303)
M [105:303]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence
OPTION_REF 2..5
Mit diesem Element werden Varianten referenziert, die zu einer Kombi-Varianten zusammengefasst werden sollen.

Variantenarten > 950 sind grafisch nur für Echtgrafik relevant, daher dürfen diese nicht als Kombivarianten angelegt werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P (105)|(115)|(125)|(201)|(303)
M [105:303]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Quelle
<xs:element name="COMBINED_FEATURE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" minOccurs="2" maxOccurs="5">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>265--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="10[012346]|11[01234]|12[01234]|20[02345]|30[012]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>265--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>265--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="(105)|(115)|(125)|(201)|(303)" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>265--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > COMBINED_FEATURE Element : OPTION_REF Element
Beschreibung
Mit diesem Element werden Varianten referenziert, die zu einer Kombi-Varianten zusammengefasst werden sollen.

Variantenarten > 950 sind grafisch nur für Echtgrafik relevant, daher dürfen diese nicht als Kombivarianten angelegt werden.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 2..5
Mit diesem Element werden Varianten referenziert, die zu einer Kombi-Varianten zusammengefasst werden sollen.

Variantenarten > 950 sind grafisch nur für Echtgrafik relevant, daher dürfen diese nicht als Kombivarianten angelegt werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P 10[012346]|11[01234]|12[01234]|20[02345]|30[012]
M [100:312]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" minOccurs="2" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>265--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="10[012346]|11[01234]|12[01234]|20[02345]|30[012]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>265--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
COMBINED_FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element : FEATURE Element
Beschreibung
In diesem Element wird eine Variantenart definiert.
Namensraum (none)
Diagramm
INHERIT_VARIATION_TYPE_REF Element HEADER_POS_VARIATION_TYPE Element SEQUENCE_NO Element LANGUAGE Element Sequence FEATURE_TEXT Element OPTIONS Element Sequence FEATURE Element
Overview
FEATURE 1..∞
In diesem Element wird eine Variantenart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werde und haben Priorität gegenüber entsprechenden Farbvarianten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. Falls es sich hierbei um eine Ausprägung der Variantenart 1 (d. h. Programm) handelt muss, falls in STYLE_REF ein Programm über STYLE_NO referenziert wird, der Wert von diesem Attribut identisch mit der referenzierten STYLE_NO sein. D string
P
M [1:5]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Sortierung der Varianten ermöglicht. Das Attribut muss nicht durchgehend gefüllt werden. Es können alle Varianten mit diesem Sortierkriterium versehen werden. D nonNegativeInteger
P
M
Sequence
Choice optional
STYLE_REF
Dieses Element referenziert ein Programm.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
HANDLE_ORIENTATION_REF
Dieses Element referenziert eine Grifflage.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Griffausprägung referenziert.
 D positiveInteger
P
M [1:9999]
FORM_REF
Dieses Element referenziert eine Form.
FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert.
 D string
P
M [1:5]
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert. Zur Zeit kann dieses Element nur für die Sockelhöhe (Variantenart 402) verwendet werden.
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine referenzierte Maßausprägung identifiziert.
 D nonNegativeInteger
P
M [1:99999]
HANDLE_POSITION_REF
Dieses Element referenziert eine Griffpositionierung.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Griffpositionierung referenziert.
 D nonNegativeInteger
P
M [0:999]
OPTION_TEXT languagetexte60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss. 		D date
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben. Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung)
 D nonNegativeInteger
P
M [0:999]
FRONT_APPEARANCE_REF optional
Durch dieses Element wird eine Beziehung zwischen der definierten Variante und einer Frontausprägung definiert. Eine hier referenzierte Frontausprägung muss im Element Pfad1/FRONT_APPEARANCE definiert sein.

Dieses Element Feld darf genutzt werden, wenn die im Attribut Pfad2/FEATURE_NO angelegte Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) ist.

Für die Verarbeitung dieses Elementes gilt folgende Regelung:
Besitzt ein Artikel eine Glastür, die Variantenart 154 ist in der Variantenfamilie des Artikels enthalten, so wird die FRONT_APPEARANCE_NO dieses Elementes verwendet. In allen anderen Situationen wird Pfad3/FRONT_APPEARANCE_REF verwendet.

Ab Füllstufe 2b muss dieses Feld gefüllt werden.

Elementpfade:
Pfad1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
Pfad2 = FEATURE_DEFINITION/FEATURES/FEATURE
Pfad3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird.
 D positiveInteger
P
M [1:999]
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Durch dieses Element werden Hyperlinks zu Detailinformationen referenziert.
 D positiveInteger
P
M [1:999999999]
FEATURE_TEXT languagetexte60 Complex Type
Dieses Element enthält Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad1)), wird das Element nicht gefüllt.

Elementpfade
Pfad1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante,
U = unsichtbare Kopfvariante,
P = Positions-Variantenart oder
V = erbende Variantenart
ist.

Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.
Unsichtbare Kopfvarianten dürfen nur in den Elementen OPTION (Pfad 1) und COMBINED_FEATURE (Pfad 2) verwendet werden.

Das Kennzeichen V wird gesetzt, wenn es sich um eine Variantenart handelt, die Informationen einer anderen Variantenart erbt. Die Vererbung erfolgt innerhalb eines Artikels, daher darf dieses Kennzeichen nur bei den Variantenarten 202, 203, 205 und 208 gesetzt werden. Ist das Kennzeichen gesetzt, muss das
Element INHERIT_VARIATION_TYPE_REF (Pfad 3) zwingend mit einer Variantenart 202, 203, 205 oder 208 gefüllt sein, die im Element HEADER_POS_VARIATION_TYPE (Pfad 3) das Kennzeichen K oder P enthält.
Erbende Variantenarten dürfen in keinem anderen Element verwendet werden.
Mit „I“ gekennzeichnete Varianten sind unsichtbare Varianten, die aber für Prüfungen zur Verfügung stehen. Derzeit fällt unter Kennzeichnung "I" nur die Variantenart 305 = Bohrschema.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
Pfad 2: FEATURE_DEFINITION/FEATURES
Pfad 3: FEATURE_DEFINITION/FEATURES/FEATURE 		D nonNegativeInteger
P
M [0:999]
INHERIT_VARIATION_TYPE_REF optional
In diesem Element wird die Variantenart referenziert, von der die Variantenart Informationen erben soll.
Die Variantenarten 202, 203, 205 und 208 dürfen auch untereinander Informationen vererben.
Die hier angegebene Variantenart darf keine als "unsichtbar" deklarierte Variantenart sein.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die referenzierte Variantenart angegeben. D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:choice minOccurs="0">
                    <xs:element name="STYLE_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="STYLE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MATERIAL_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MATERIAL_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="HANDLE_ORIENTATION_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="FORM_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="FORM_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_MEASURE_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_MEASURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="HANDLE_POSITION_REF">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="HANDLE_POSITION_NO" use="required">
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                              <xs:totalDigits value="3" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:element name="OPTION_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="SEQUENCE_NO">
        <xs:annotation>
          <xs:documentation>250--4--Sortierung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEADER_POS_VARIATION_TYPE">
        <xs:annotation>
          <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[IKUPV]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INHERIT_VARIATION_TYPE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>250--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="(202)|(203)|(205)|(208)" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>250--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : OPTIONS Element
Beschreibung
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Namensraum (none)
Diagramm
OPTION Element Sequence OPTIONS Element
Overview
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werde und haben Priorität gegenüber entsprechenden Farbvarianten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. Falls es sich hierbei um eine Ausprägung der Variantenart 1 (d. h. Programm) handelt muss, falls in STYLE_REF ein Programm über STYLE_NO referenziert wird, der Wert von diesem Attribut identisch mit der referenzierten STYLE_NO sein. D string
P
M [1:5]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Sortierung der Varianten ermöglicht. Das Attribut muss nicht durchgehend gefüllt werden. Es können alle Varianten mit diesem Sortierkriterium versehen werden. D nonNegativeInteger
P
M
Sequence
Choice optional
STYLE_REF
Dieses Element referenziert ein Programm.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
HANDLE_ORIENTATION_REF
Dieses Element referenziert eine Grifflage.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Griffausprägung referenziert.
 D positiveInteger
P
M [1:9999]
FORM_REF
Dieses Element referenziert eine Form.
FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert.
 D string
P
M [1:5]
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert. Zur Zeit kann dieses Element nur für die Sockelhöhe (Variantenart 402) verwendet werden.
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine referenzierte Maßausprägung identifiziert.
 D nonNegativeInteger
P
M [1:99999]
HANDLE_POSITION_REF
Dieses Element referenziert eine Griffpositionierung.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Griffpositionierung referenziert.
 D nonNegativeInteger
P
M [0:999]
OPTION_TEXT languagetexte60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss. 		D date
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben. Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung)
 D nonNegativeInteger
P
M [0:999]
FRONT_APPEARANCE_REF optional
Durch dieses Element wird eine Beziehung zwischen der definierten Variante und einer Frontausprägung definiert. Eine hier referenzierte Frontausprägung muss im Element Pfad1/FRONT_APPEARANCE definiert sein.

Dieses Element Feld darf genutzt werden, wenn die im Attribut Pfad2/FEATURE_NO angelegte Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) ist.

Für die Verarbeitung dieses Elementes gilt folgende Regelung:
Besitzt ein Artikel eine Glastür, die Variantenart 154 ist in der Variantenfamilie des Artikels enthalten, so wird die FRONT_APPEARANCE_NO dieses Elementes verwendet. In allen anderen Situationen wird Pfad3/FRONT_APPEARANCE_REF verwendet.

Ab Füllstufe 2b muss dieses Feld gefüllt werden.

Elementpfade:
Pfad1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
Pfad2 = FEATURE_DEFINITION/FEATURES/FEATURE
Pfad3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird.
 D positiveInteger
P
M [1:999]
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Durch dieses Element werden Hyperlinks zu Detailinformationen referenziert.
 D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="OPTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:choice minOccurs="0">
              <xs:element name="STYLE_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="STYLE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="MATERIAL_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="MATERIAL_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="HANDLE_ORIENTATION_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="FORM_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="FORM_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="OPTION_MEASURE_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="OPTION_MEASURE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="HANDLE_POSITION_REF">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="HANDLE_POSITION_NO" use="required">
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                        <xs:totalDigits value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:choice>
            <xs:element name="OPTION_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element : OPTION Element
Beschreibung
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werde und haben Priorität gegenüber entsprechenden Farbvarianten.
Namensraum (none)
Diagramm
DETAIL_INFOS Element FRONT_APPEARANCE_REF Element MINIMUM_DELIVERY_TIME Element VALID_UNTIL Element VALID_FROM Element LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element LANGUAGE Element Sequence OPTION_TEXT Element HANDLE_POSITION_REF Element OPTION_MEASURE_REF Element FORM_REF Element HANDLE_ORIENTATION_REF Element MATERIAL_REF Element STYLE_REF Element Choice Sequence OPTION Element
Overview
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werde und haben Priorität gegenüber entsprechenden Farbvarianten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. Falls es sich hierbei um eine Ausprägung der Variantenart 1 (d. h. Programm) handelt muss, falls in STYLE_REF ein Programm über STYLE_NO referenziert wird, der Wert von diesem Attribut identisch mit der referenzierten STYLE_NO sein. D string
P
M [1:5]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Sortierung der Varianten ermöglicht. Das Attribut muss nicht durchgehend gefüllt werden. Es können alle Varianten mit diesem Sortierkriterium versehen werden. D nonNegativeInteger
P
M
Sequence
Choice optional
STYLE_REF
Dieses Element referenziert ein Programm.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
HANDLE_ORIENTATION_REF
Dieses Element referenziert eine Grifflage.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Griffausprägung referenziert.
 D positiveInteger
P
M [1:9999]
FORM_REF
Dieses Element referenziert eine Form.
FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert.
 D string
P
M [1:5]
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert. Zur Zeit kann dieses Element nur für die Sockelhöhe (Variantenart 402) verwendet werden.
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine referenzierte Maßausprägung identifiziert.
 D nonNegativeInteger
P
M [1:99999]
HANDLE_POSITION_REF
Dieses Element referenziert eine Griffpositionierung.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Griffpositionierung referenziert.
 D nonNegativeInteger
P
M [0:999]
OPTION_TEXT languagetexte60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss. 		D date
P
M
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben. Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung)
 D nonNegativeInteger
P
M [0:999]
FRONT_APPEARANCE_REF optional
Durch dieses Element wird eine Beziehung zwischen der definierten Variante und einer Frontausprägung definiert. Eine hier referenzierte Frontausprägung muss im Element Pfad1/FRONT_APPEARANCE definiert sein.

Dieses Element Feld darf genutzt werden, wenn die im Attribut Pfad2/FEATURE_NO angelegte Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) ist.

Für die Verarbeitung dieses Elementes gilt folgende Regelung:
Besitzt ein Artikel eine Glastür, die Variantenart 154 ist in der Variantenfamilie des Artikels enthalten, so wird die FRONT_APPEARANCE_NO dieses Elementes verwendet. In allen anderen Situationen wird Pfad3/FRONT_APPEARANCE_REF verwendet.

Ab Füllstufe 2b muss dieses Feld gefüllt werden.

Elementpfade:
Pfad1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
Pfad2 = FEATURE_DEFINITION/FEATURES/FEATURE
Pfad3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird.
 D positiveInteger
P
M [1:999]
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Durch dieses Element werden Hyperlinks zu Detailinformationen referenziert.
 D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung definiert. Falls es sich hierbei um eine Ausprägung der Variantenart 1 (d. h. Programm) handelt muss, falls in STYLE_REF ein Programm über STYLE_NO referenziert wird, der Wert von diesem Attribut identisch mit der referenzierten STYLE_NO sein. D string
P
M [1:5]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional
Mit diesem Attribut wird eine Sortierung der Varianten ermöglicht. Das Attribut muss nicht durchgehend gefüllt werden. Es können alle Varianten mit diesem Sortierkriterium versehen werden. D nonNegativeInteger
P
M
Quelle
<xs:element name="OPTION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice minOccurs="0">
        <xs:element name="STYLE_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="STYLE_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="MATERIAL_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="MATERIAL_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="HANDLE_ORIENTATION_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="FORM_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="FORM_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="OPTION_MEASURE_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="OPTION_MEASURE_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="HANDLE_POSITION_REF">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="HANDLE_POSITION_NO" use="required">
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                  <xs:totalDigits value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:choice>
      <xs:element name="OPTION_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STYLE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : STYLE_REF Element
Beschreibung
Dieses Element referenziert ein Programm.
Namensraum (none)
Diagramm
STYLE_REF Element
Overview
STYLE_REF
Dieses Element referenziert ein Programm.
STYLE_NO required Restriction of xs:string
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
STYLE_NO Restriction of xs:string required
In diesem Attribut wird das referenzierte Programm angegeben. Es wird die auf das Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Quelle
<xs:element name="STYLE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="STYLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MATERIAL_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : MATERIAL_REF Element
Beschreibung
Dieses Element referenziert ein Material.
Namensraum (none)
Diagramm
MATERIAL_REF Element
Overview
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MATERIAL_NO Restriction of xs:string required
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
Quelle
<xs:element name="MATERIAL_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MATERIAL_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : HANDLE_ORIENTATION_REF Element
Beschreibung
Dieses Element referenziert eine Grifflage.
Namensraum (none)
Diagramm
HANDLE_ORIENTATION_REF Element
Overview
HANDLE_ORIENTATION_REF
Dieses Element referenziert eine Grifflage.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Griffausprägung referenziert.
 D positiveInteger
P
M [1:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
HANDLE_ORIENTATION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Griffausprägung referenziert.
 D positiveInteger
P
M [1:9999]
Quelle
<xs:element name="HANDLE_ORIENTATION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FORM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : FORM_REF Element
Beschreibung
Dieses Element referenziert eine Form.
Namensraum (none)
Diagramm
FORM_REF Element
Overview
FORM_REF
Dieses Element referenziert eine Form.
FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert.
 D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FORM_NO Restriction of xs:string required
Mit diesem Attribut wird eine Profilform referenziert.
 D string
P
M [1:5]
Quelle
<xs:element name="FORM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FORM_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_MEASURE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_MEASURE_REF Element
Beschreibung
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert. Zur Zeit kann dieses Element nur für die Sockelhöhe (Variantenart 402) verwendet werden.
Namensraum (none)
Diagramm
OPTION_MEASURE_REF Element
Overview
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert. Zur Zeit kann dieses Element nur für die Sockelhöhe (Variantenart 402) verwendet werden.
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine referenzierte Maßausprägung identifiziert.
 D nonNegativeInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_MEASURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine referenzierte Maßausprägung identifiziert.
 D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="OPTION_MEASURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_MEASURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_POSITION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : HANDLE_POSITION_REF Element
Beschreibung
Dieses Element referenziert eine Griffpositionierung.
Namensraum (none)
Diagramm
HANDLE_POSITION_REF Element
Overview
HANDLE_POSITION_REF
Dieses Element referenziert eine Griffpositionierung.
HANDLE_POSITION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Griffpositionierung referenziert.
 D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
HANDLE_POSITION_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Griffpositionierung referenziert.
 D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="HANDLE_POSITION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="HANDLE_POSITION_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
          <xs:totalDigits value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_TEXT Element
Beschreibung
In diesem Element wird ein Variantentext definiert.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence OPTION_TEXT Element
Overview
OPTION_TEXT languagetexte60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="OPTION_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_COMMENT_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_COMMENT_TEXT Element
Beschreibung
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element
Overview
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_FROM Element
Beschreibung
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_UNTIL Element
Beschreibung
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Über diese Elemente werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
• Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
• Beide Elemente leer: uneingeschränkt lieferbar.
• Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
• Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss. 		D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MINIMUM_DELIVERY_TIME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : MINIMUM_DELIVERY_TIME Element
Beschreibung
In diesem Element wird die Mindestlieferzeit in Wochen angegeben. Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung)
 D nonNegativeInteger
P
M [0:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MINIMUM_DELIVERY_TIME Element
Overview
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben. Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung)
 D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--19--Mindest_Lieferzeit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_APPEARANCE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : FRONT_APPEARANCE_REF Element
Beschreibung
Durch dieses Element wird eine Beziehung zwischen der definierten Variante und einer Frontausprägung definiert. Eine hier referenzierte Frontausprägung muss im Element Pfad1/FRONT_APPEARANCE definiert sein.

Dieses Element Feld darf genutzt werden, wenn die im Attribut Pfad2/FEATURE_NO angelegte Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) ist.

Für die Verarbeitung dieses Elementes gilt folgende Regelung:
Besitzt ein Artikel eine Glastür, die Variantenart 154 ist in der Variantenfamilie des Artikels enthalten, so wird die FRONT_APPEARANCE_NO dieses Elementes verwendet. In allen anderen Situationen wird Pfad3/FRONT_APPEARANCE_REF verwendet.

Ab Füllstufe 2b muss dieses Feld gefüllt werden.

Elementpfade:
Pfad1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
Pfad2 = FEATURE_DEFINITION/FEATURES/FEATURE
Pfad3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Namensraum (none)
Diagramm
FRONT_APPEARANCE_REF Element
Overview
FRONT_APPEARANCE_REF optional
Durch dieses Element wird eine Beziehung zwischen der definierten Variante und einer Frontausprägung definiert. Eine hier referenzierte Frontausprägung muss im Element Pfad1/FRONT_APPEARANCE definiert sein.

Dieses Element Feld darf genutzt werden, wenn die im Attribut Pfad2/FEATURE_NO angelegte Variantenart "Ausführung Glastürrahmen" (FEATURE_NO = 154) ist.

Für die Verarbeitung dieses Elementes gilt folgende Regelung:
Besitzt ein Artikel eine Glastür, die Variantenart 154 ist in der Variantenfamilie des Artikels enthalten, so wird die FRONT_APPEARANCE_NO dieses Elementes verwendet. In allen anderen Situationen wird Pfad3/FRONT_APPEARANCE_REF verwendet.

Ab Füllstufe 2b muss dieses Feld gefüllt werden.

Elementpfade:
Pfad1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
Pfad2 = FEATURE_DEFINITION/FEATURES/FEATURE
Pfad3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird.
 D positiveInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FRONT_APPEARANCE_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird.
 D positiveInteger
P
M [1:999]
Quelle
<xs:element name="FRONT_APPEARANCE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--20--Frontauspraegungs_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : DETAIL_INFOS Element
Beschreibung
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Durch dieses Element werden Hyperlinks zu Detailinformationen referenziert.
 D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
Dieses Element referenziert Hyperlinks zu Detailinformationen.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Durch dieses Element werden Hyperlinks zu Detailinformationen referenziert.
 D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
Durch dieses Element werden Hyperlinks zu Detailinformationen referenziert.
 D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : FEATURE_TEXT Element
Beschreibung
Dieses Element enthält Texte für Variantenarten.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence FEATURE_TEXT Element
Overview
FEATURE_TEXT languagetexte60 Complex Type
Dieses Element enthält Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="FEATURE_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SEQUENCE_NO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : SEQUENCE_NO Element
Beschreibung
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad1)), wird das Element nicht gefüllt.

Elementpfade
Pfad1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
SEQUENCE_NO Element
Overview
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad1)), wird das Element nicht gefüllt.

Elementpfade
Pfad1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="SEQUENCE_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--4--Sortierung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEADER_POS_VARIATION_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : HEADER_POS_VARIATION_TYPE Element
Beschreibung
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante,
U = unsichtbare Kopfvariante,
P = Positions-Variantenart oder
V = erbende Variantenart
ist.

Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.
Unsichtbare Kopfvarianten dürfen nur in den Elementen OPTION (Pfad 1) und COMBINED_FEATURE (Pfad 2) verwendet werden.

Das Kennzeichen V wird gesetzt, wenn es sich um eine Variantenart handelt, die Informationen einer anderen Variantenart erbt. Die Vererbung erfolgt innerhalb eines Artikels, daher darf dieses Kennzeichen nur bei den Variantenarten 202, 203, 205 und 208 gesetzt werden. Ist das Kennzeichen gesetzt, muss das
Element INHERIT_VARIATION_TYPE_REF (Pfad 3) zwingend mit einer Variantenart 202, 203, 205 oder 208 gefüllt sein, die im Element HEADER_POS_VARIATION_TYPE (Pfad 3) das Kennzeichen K oder P enthält.
Erbende Variantenarten dürfen in keinem anderen Element verwendet werden.
Mit „I“ gekennzeichnete Varianten sind unsichtbare Varianten, die aber für Prüfungen zur Verfügung stehen. Derzeit fällt unter Kennzeichnung "I" nur die Variantenart 305 = Bohrschema.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
Pfad 2: FEATURE_DEFINITION/FEATURES
Pfad 3: FEATURE_DEFINITION/FEATURES/FEATURE 		D nonNegativeInteger
P
M [0:999]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
HEADER_POS_VARIATION_TYPE Element
Overview
HEADER_POS_VARIATION_TYPE Restriction of xs:string
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante,
U = unsichtbare Kopfvariante,
P = Positions-Variantenart oder
V = erbende Variantenart
ist.

Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.
Unsichtbare Kopfvarianten dürfen nur in den Elementen OPTION (Pfad 1) und COMBINED_FEATURE (Pfad 2) verwendet werden.

Das Kennzeichen V wird gesetzt, wenn es sich um eine Variantenart handelt, die Informationen einer anderen Variantenart erbt. Die Vererbung erfolgt innerhalb eines Artikels, daher darf dieses Kennzeichen nur bei den Variantenarten 202, 203, 205 und 208 gesetzt werden. Ist das Kennzeichen gesetzt, muss das
Element INHERIT_VARIATION_TYPE_REF (Pfad 3) zwingend mit einer Variantenart 202, 203, 205 oder 208 gefüllt sein, die im Element HEADER_POS_VARIATION_TYPE (Pfad 3) das Kennzeichen K oder P enthält.
Erbende Variantenarten dürfen in keinem anderen Element verwendet werden.
Mit „I“ gekennzeichnete Varianten sind unsichtbare Varianten, die aber für Prüfungen zur Verfügung stehen. Derzeit fällt unter Kennzeichnung "I" nur die Variantenart 305 = Bohrschema.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
Pfad 2: FEATURE_DEFINITION/FEATURES
Pfad 3: FEATURE_DEFINITION/FEATURES/FEATURE 		D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="HEADER_POS_VARIATION_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[IKUPV]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

INHERIT_VARIATION_TYPE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : INHERIT_VARIATION_TYPE_REF Element
Beschreibung
In diesem Element wird die Variantenart referenziert, von der die Variantenart Informationen erben soll.
Die Variantenarten 202, 203, 205 und 208 dürfen auch untereinander Informationen vererben.
Die hier angegebene Variantenart darf keine als "unsichtbar" deklarierte Variantenart sein.
Namensraum (none)
Diagramm
INHERIT_VARIATION_TYPE_REF Element
Overview
INHERIT_VARIATION_TYPE_REF optional
In diesem Element wird die Variantenart referenziert, von der die Variantenart Informationen erben soll.
Die Variantenarten 202, 203, 205 und 208 dürfen auch untereinander Informationen vererben.
Die hier angegebene Variantenart darf keine als "unsichtbar" deklarierte Variantenart sein.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die referenzierte Variantenart angegeben. D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die referenzierte Variantenart angegeben. D nonNegativeInteger
P (202)|(203)|(205)|(208)
M [0:999]
Quelle
<xs:element name="INHERIT_VARIATION_TYPE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>250--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="(202)|(203)|(205)|(208)" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : OPTION_DEFINITION Element
Beschreibung
In diesem Element werden die Ausprägungen von Farben, Materialien, Griffen, Formvarianten und Programmen definiert.
Namensraum (none)
Diagramm
OPTION_MEASURE Element FORM Element MATERIAL Element HANDLE_ORIENTATION Element STYLE Element Sequence OPTION_DEFINITION Element
Overview
OPTION_DEFINITION
In diesem Element werden die Ausprägungen von Farben, Materialien, Griffen, Formvarianten und Programmen definiert.
Sequence
STYLE 0..∞
In diesem Element werden die Programme definiert.
Die hier definierten Programme werden über das Element STYLE_REF (Pfad1) als Variante angelegt. Das Programm hat die Variantenart 1 (FEATURE_NO = 1).

Die Attribute eines Programms dürfen sich über die Serien hinweg nicht unterscheiden. Da ein Programm nur in diesem Element beschrieben und von den Serien referenziert wird, ist die vorgenannte Bedingung durch die Struktur implizit abgebildet.

Dieses Element ist nur optional, wenn im Element SUPPLIER/BRANCH_ID der Wert für die Branchen-ID "G" oder "Z" ist.

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES/
STYLE_NO required Restriction of xs:string
In diesem Attribut wird der herstellerspezifische Programmschlüssel angegeben. Es wird vom Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

P1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Sequence
FRONT_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird die programmspezifische Fronttiefe [mm] definiert. Als Vorgabewert bei keiner Angabe gilt 20 mm.
Dieses Element muss gefüllt werden, wenn das Element FRONT_APEREANCE_NO (Pfad1) gefüllt ist.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/ 		D nonNegativeInteger
P
M [1:99]
FRONT_DISTANCE optional Restriction of xs:nonNegativeInteger
In diesem Element wird der programmspezifische Türpuffer[mm] definiert. Es stellt den Abstand zwischen Tür und dahinter gelagertem Korpus dar. D nonNegativeInteger
P
M [1:99]
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Programm eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird. D positiveInteger
P
M [1:999]
FRONT_GROUP_REF optional
Mit diesem Element wird einem Programm eine Frontgruppe zugeordnet.
Sind die Frontaufteilungen von Artikeln über mehrere Programme gleich, können diese angegeben, in der mehrere Programme zusammengefasst werden können. Die Programme können zusammengefasst werden, wenn sich deren Frontaufteilungen nicht unterscheiden.
Dieses Element referenziert das Attribut SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
Bei Herstellern, deren Frontaufteilungen einzelner Schränke in einzelnen Programmen unterschiedlich sind, wird für die entsprechenden Programme eine Frontgruppe angelegt.
Bei Herstellern, deren Frontaufteilungen für alle Schränke programmunabhängig sind, wird keine Frontgruppe angegeben.
Häufig können beispielsweise alle Stilfronten zu einer Frontgruppe zusammengefasst werden, da sie in der Regel bei einer hohen Tür in der gleichen Weise unterteilt werden.
Die unterschiedlichen Frontaufteilungen bei beispielsweise verschiedenen Einbaugeräten ist unabhängig von der Frontgruppe.
Wird für ein Programm eine Frontgruppe angelegt, so müssen allen Programmen Frontgruppen zugeordnet werden.
FRONT_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein. D positiveInteger
P
M [1:99]
FEATURE_CLASS_REF optional
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D nonNegativeInteger
P
M [1:999]
DEFAULT_OPTION_GROUP_REF 0..∞
Mit diesem Element werden dem Programm Standardvorschläge zugeordnet.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird ein Standardvorschlag referenziert. D positiveInteger
P
M [1:999999999]
RESTRICTIONS optional
Dieses Element referenziert Prüfverfahren, die für das Programm angewendet werden (Programm-spezifische Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE required Restriction of xs:positiveInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element SEQUENCE erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D positiveInteger
P
M [1:99999]
HANDLE_ORIENTATION 0..∞
In diesem Element wird eine Grifflage definiert.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Griffausprägung identifiziert. D string
P
M [1:5]
Sequence
DEFAULT_HANDLE_ORIENTATION_REF optional

In diesem Element wird eine Variante für eine Basisgrifflage angelegt. Es wird eine Basisgrifflage referenziert, die im Element BASIC_HANDLE_POSITIONS (Pfad 1) definiert ist.

Im Element OPTION_KEY (Pfad 2) wird die herstellerspezifische Bezeichnung einer eingetragen.

Das Element Standard-Grifflage muss gefüllt werden, wenn im Element FEATURE (Pfad 3) die Variantenart 304 (Grifflage) eingetragen ist.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
Pfad 3: FEATURE_DEFINITION/FEATURES

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D nonNegativeInteger
P
M [1:99999]
MATERIAL 0..∞
In diesem Element wird ein Material definiert.

Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur (TEXTURE) noch Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material identifiziert. D string
P
M [1:5]
Sequence
Choice optional
COLOR
In diesem Element werden Farben definiert.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
TEXTURE
In diesem Element werden die Informationen für Texturen hinterlegt.
Sequence
FILE_NAME_TEXTURE Restriction of xs:string
In dieses Element werden Verweise auf Dateien mit Materialtexturen hinterlegt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
TEXTURE_REPEAT optional
Über dieses Element wird definiertgekennzeichnet, ob eine Textur einmal oder sich wiederholend aufgebracht wird (gekachelt). Soll die Textur gekachelt werden, wird das Element angelegt und die notwendigen Daten in den entsprechenden Kindelementen hinterlegt.
Kachelungsfaktor wird von der Software auf Basis der Texturgröße (DPI, Anzahl Pixel) bestimmt.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein.
TEXTURE_TILE optional Restriction of xs:int
Über dieses Attribut wird gekennzeichnet, ob eine Textur einmal (0 = nicht kacheln) oder sich wiederholend (1 = kacheln) aufgebracht wird. D integer
P
M [0:1]
Sequence
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in X-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in Y-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein. 		D boolean
P
M
TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D string
P |[HV]
M [0:1]
TRANSPARENCY optional Restriction of xs:nonNegativeInteger
Dieses Element definiert den Grad der Transparenz eines Materials (RGB-Wert oder Textur).
0 = opak
9 = max. Transparenz
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein. 		D nonNegativeInteger
P
M [0:9]
BRIGHTNESS optional Restriction of xs:nonNegativeInteger
Dieses Element definiert den Grad des Glanzes eines Materials (RGB-Wert oder Textur).
0 = matt
8 = Hochglanz
9 = Spiegelung
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein. 		D nonNegativeInteger
P
M [0:9]
FORM 0..∞
In diesem Element wird eine Formvariante definiert.
FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform identifiziert. D string
P
M [1:5]
Sequence
PROFILE_KEY Restriction of xs:string
In diesem Element wird der herstellerspezifische Key für eine Profilform hinterlegt. Mit diesem Element werden Varianten der Variantenarten 750-756 gebildet. Das Element FORM kann nur von den Variantenarten 750-756 genutzt werden. Die gebildete Varianten werden vom Artikel (ITEM) referenziert, der das Profil darstellt. D string
P
M [1:5]
OPTION_MEASURE 0..∞
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Sockelhöhe (Variantenart 402)).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine maßliche Ausprägung identifiziert. D nonNegativeInteger
P
M [1:99999]
Sequence
PLINTH_HEIGHT Restriction of xs:nonNegativeInteger
In diesem Element wird die Sockelhöhe in mm angegeben. D nonNegativeInteger
P
M [0:999999999]
STANDARD_PLINTH optional xs:boolean

In diesem Element wird angegeben, ob es sich bei der entsprechenden Sockelhöhe um einen Standard handelt, oder ob die Höhe vom Standard abweicht. Ist der Wert false(0), handelt es sich bei der Sockelhöhe um eine vom Standard abweichende Höhe, die eventuell mit einem Mehrpreis für die Sockelfüße verbunden ist.

Fehlt das Element, entspricht es dem Wert true(1).

Gibt es verknüpfte Artikel mit der Zuordnungsart CLASS = 21, muss dieses Element angegeben werden.

D boolean
P
M [0:1]
Bemerkung

Quelle
<xs:element name="OPTION_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="STYLE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>210--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FRONT_DEPTH" minOccurs="0">
              <xs:annotation>
                <xs:documentation>210--6--Front_Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FRONT_DISTANCE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>210--6--Türpuffer</xs:documentation>
                <xs:documentation>K.Richter/13.06.2018</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FRONT_GROUP_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>210--12--Frontgruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FRONT_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>210--12--Frontgruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>210--13--Var_Familien_Nr</xs:documentation>
                    <xs:documentation>K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DEFAULT_OPTION_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>295--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>295--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                <xs:documentation>von minOcc 1 auf optional 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="STYLE_NO" use="required">
            <xs:annotation>
              <xs:documentation>210--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="HANDLE_ORIENTATION" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DEFAULT_HANDLE_ORIENTATION_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:choice minOccurs="0">
              <xs:annotation>
                <xs:documentation />
                <xs:documentation>AK 28.02.2012. Optional gesetzt um die alte 1.7 Logik zu erhalten.</xs:documentation>
              </xs:annotation>
              <xs:element name="COLOR">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="RGB_RED">
                      <xs:annotation>
                        <xs:documentation>260--11--RGB_Rot</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="255" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="RGB_GREEN">
                      <xs:annotation>
                        <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="255" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="RGB_BLUE">
                      <xs:annotation>
                        <xs:documentation>260--13--RGB_Blau</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="255" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
              <xs:element name="TEXTURE">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="FILE_NAME_TEXTURE">
                      <xs:annotation>
                        <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="TEXTURE_REPEAT" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="REAL_MEASUREMENT_X">
                            <xs:annotation>
                              <xs:documentation>260--17--Realmass_X</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="REAL_MEASUREMENT_Y">
                            <xs:annotation>
                              <xs:documentation>260--18--Realmass_Y</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="TEXTURE_TILE">
                          <xs:simpleType>
                            <xs:restriction base="xs:int">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="1" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MASKING" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>260--10--Maskierung</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:boolean" />
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="TEXTURE_DELIVERED_ORIENTATION">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:pattern value="|[HV]" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:choice>
            <xs:element name="TRANSPARENCY" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--14--Transparenz</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BRIGHTNESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--15--Glanz</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="MATERIAL_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORM" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROFILE_KEY">
              <xs:annotation>
                <xs:documentation>430--4/5--Varianten_Art_Profilform/Var_Schluessel_</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FORM_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PLINTH_HEIGHT">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STANDARD_PLINTH" type="xs:boolean" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Kennzeichnung zur Abweichung von Standardsockelhöhe</xs:documentation>
                <xs:documentation>hinzugefügt K.Richter, 29.02.2016</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPTION_MEASURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STYLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : STYLE Element
Beschreibung
In diesem Element werden die Programme definiert.
Die hier definierten Programme werden über das Element STYLE_REF (Pfad1) als Variante angelegt. Das Programm hat die Variantenart 1 (FEATURE_NO = 1).

Die Attribute eines Programms dürfen sich über die Serien hinweg nicht unterscheiden. Da ein Programm nur in diesem Element beschrieben und von den Serien referenziert wird, ist die vorgenannte Bedingung durch die Struktur implizit abgebildet.

Dieses Element ist nur optional, wenn im Element SUPPLIER/BRANCH_ID der Wert für die Branchen-ID "G" oder "Z" ist.

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES/
Namensraum (none)
Diagramm
RESTRICTIONS Element DEFAULT_OPTION_GROUP_REF Element FEATURE_CLASS_REF Element FRONT_GROUP_REF Element FRONT_APPEARANCE_REF Element FRONT_DISTANCE Element FRONT_DEPTH Element Sequence STYLE Element
Overview
STYLE 0..∞
In diesem Element werden die Programme definiert.
Die hier definierten Programme werden über das Element STYLE_REF (Pfad1) als Variante angelegt. Das Programm hat die Variantenart 1 (FEATURE_NO = 1).

Die Attribute eines Programms dürfen sich über die Serien hinweg nicht unterscheiden. Da ein Programm nur in diesem Element beschrieben und von den Serien referenziert wird, ist die vorgenannte Bedingung durch die Struktur implizit abgebildet.

Dieses Element ist nur optional, wenn im Element SUPPLIER/BRANCH_ID der Wert für die Branchen-ID "G" oder "Z" ist.

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES/
STYLE_NO required Restriction of xs:string
In diesem Attribut wird der herstellerspezifische Programmschlüssel angegeben. Es wird vom Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

P1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Sequence
FRONT_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird die programmspezifische Fronttiefe [mm] definiert. Als Vorgabewert bei keiner Angabe gilt 20 mm.
Dieses Element muss gefüllt werden, wenn das Element FRONT_APEREANCE_NO (Pfad1) gefüllt ist.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/ 		D nonNegativeInteger
P
M [1:99]
FRONT_DISTANCE optional Restriction of xs:nonNegativeInteger
In diesem Element wird der programmspezifische Türpuffer[mm] definiert. Es stellt den Abstand zwischen Tür und dahinter gelagertem Korpus dar. D nonNegativeInteger
P
M [1:99]
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Programm eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird. D positiveInteger
P
M [1:999]
FRONT_GROUP_REF optional
Mit diesem Element wird einem Programm eine Frontgruppe zugeordnet.
Sind die Frontaufteilungen von Artikeln über mehrere Programme gleich, können diese angegeben, in der mehrere Programme zusammengefasst werden können. Die Programme können zusammengefasst werden, wenn sich deren Frontaufteilungen nicht unterscheiden.
Dieses Element referenziert das Attribut SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
Bei Herstellern, deren Frontaufteilungen einzelner Schränke in einzelnen Programmen unterschiedlich sind, wird für die entsprechenden Programme eine Frontgruppe angelegt.
Bei Herstellern, deren Frontaufteilungen für alle Schränke programmunabhängig sind, wird keine Frontgruppe angegeben.
Häufig können beispielsweise alle Stilfronten zu einer Frontgruppe zusammengefasst werden, da sie in der Regel bei einer hohen Tür in der gleichen Weise unterteilt werden.
Die unterschiedlichen Frontaufteilungen bei beispielsweise verschiedenen Einbaugeräten ist unabhängig von der Frontgruppe.
Wird für ein Programm eine Frontgruppe angelegt, so müssen allen Programmen Frontgruppen zugeordnet werden.
FRONT_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein. D positiveInteger
P
M [1:99]
FEATURE_CLASS_REF optional
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D nonNegativeInteger
P
M [1:999]
DEFAULT_OPTION_GROUP_REF 0..∞
Mit diesem Element werden dem Programm Standardvorschläge zugeordnet.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird ein Standardvorschlag referenziert. D positiveInteger
P
M [1:999999999]
RESTRICTIONS optional
Dieses Element referenziert Prüfverfahren, die für das Programm angewendet werden (Programm-spezifische Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE required Restriction of xs:positiveInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element SEQUENCE erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D positiveInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
STYLE_NO Restriction of xs:string required
In diesem Attribut wird der herstellerspezifische Programmschlüssel angegeben. Es wird vom Attribut STYLE_NO im Element STYLE (Pfad1) referenziert.

P1: FEATURE_DEFINITION/OPTION_DEFINITION/ 		D string
P
M [1:5]
Quelle
<xs:element name="STYLE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>210--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FRONT_DEPTH" minOccurs="0">
        <xs:annotation>
          <xs:documentation>210--6--Front_Tiefe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FRONT_DISTANCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>210--6--Türpuffer</xs:documentation>
          <xs:documentation>K.Richter/13.06.2018</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FRONT_APPEARANCE_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FRONT_GROUP_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>210--12--Frontgruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FRONT_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>210--12--Frontgruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>210--13--Var_Familien_Nr</xs:documentation>
              <xs:documentation>K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DEFAULT_OPTION_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>295--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>295--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
          <xs:documentation>von minOcc 1 auf optional 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="STYLE_NO" use="required">
      <xs:annotation>
        <xs:documentation>210--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_DEPTH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : FRONT_DEPTH Element
Beschreibung
In diesem Element wird die programmspezifische Fronttiefe [mm] definiert. Als Vorgabewert bei keiner Angabe gilt 20 mm.
Dieses Element muss gefüllt werden, wenn das Element FRONT_APEREANCE_NO (Pfad1) gefüllt ist.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/ 		D nonNegativeInteger
P
M [1:99]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
FRONT_DEPTH Element
Overview
FRONT_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird die programmspezifische Fronttiefe [mm] definiert. Als Vorgabewert bei keiner Angabe gilt 20 mm.
Dieses Element muss gefüllt werden, wenn das Element FRONT_APEREANCE_NO (Pfad1) gefüllt ist.

Pfad1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/ 		D nonNegativeInteger
P
M [1:99]
Quelle
<xs:element name="FRONT_DEPTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>210--6--Front_Tiefe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_DISTANCE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : FRONT_DISTANCE Element
Beschreibung
In diesem Element wird der programmspezifische Türpuffer[mm] definiert. Es stellt den Abstand zwischen Tür und dahinter gelagertem Korpus dar. D nonNegativeInteger
P
M [1:99]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
FRONT_DISTANCE Element
Overview
FRONT_DISTANCE optional Restriction of xs:nonNegativeInteger
In diesem Element wird der programmspezifische Türpuffer[mm] definiert. Es stellt den Abstand zwischen Tür und dahinter gelagertem Korpus dar. D nonNegativeInteger
P
M [1:99]
Quelle
<xs:element name="FRONT_DISTANCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>210--6--Türpuffer</xs:documentation>
    <xs:documentation>K.Richter/13.06.2018</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_APPEARANCE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : FRONT_APPEARANCE_REF Element
Beschreibung
Mit diesem Element wird dem Programm eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Namensraum (none)
Diagramm
FRONT_APPEARANCE_REF Element
Overview
FRONT_APPEARANCE_REF optional
Mit diesem Element wird dem Programm eine Frontausprägung zugeordnet. Das Element referenziert auf das Attribut GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
FRONT_APPEARANCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird. D positiveInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FRONT_APPEARANCE_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine ID für die Frontausprägung definiert, die von Programmen und Artikeln referenziert wird. D positiveInteger
P
M [1:999]
Quelle
<xs:element name="FRONT_APPEARANCE_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_APPEARANCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>210--11--Frontauspraegungs_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FRONT_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : FRONT_GROUP_REF Element
Beschreibung
Mit diesem Element wird einem Programm eine Frontgruppe zugeordnet.
Sind die Frontaufteilungen von Artikeln über mehrere Programme gleich, können diese angegeben, in der mehrere Programme zusammengefasst werden können. Die Programme können zusammengefasst werden, wenn sich deren Frontaufteilungen nicht unterscheiden.
Dieses Element referenziert das Attribut SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
Bei Herstellern, deren Frontaufteilungen einzelner Schränke in einzelnen Programmen unterschiedlich sind, wird für die entsprechenden Programme eine Frontgruppe angelegt.
Bei Herstellern, deren Frontaufteilungen für alle Schränke programmunabhängig sind, wird keine Frontgruppe angegeben.
Häufig können beispielsweise alle Stilfronten zu einer Frontgruppe zusammengefasst werden, da sie in der Regel bei einer hohen Tür in der gleichen Weise unterteilt werden.
Die unterschiedlichen Frontaufteilungen bei beispielsweise verschiedenen Einbaugeräten ist unabhängig von der Frontgruppe.
Wird für ein Programm eine Frontgruppe angelegt, so müssen allen Programmen Frontgruppen zugeordnet werden.
Namensraum (none)
Diagramm
FRONT_GROUP_REF Element
Overview
FRONT_GROUP_REF optional
Mit diesem Element wird einem Programm eine Frontgruppe zugeordnet.
Sind die Frontaufteilungen von Artikeln über mehrere Programme gleich, können diese angegeben, in der mehrere Programme zusammengefasst werden können. Die Programme können zusammengefasst werden, wenn sich deren Frontaufteilungen nicht unterscheiden.
Dieses Element referenziert das Attribut SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
Bei Herstellern, deren Frontaufteilungen einzelner Schränke in einzelnen Programmen unterschiedlich sind, wird für die entsprechenden Programme eine Frontgruppe angelegt.
Bei Herstellern, deren Frontaufteilungen für alle Schränke programmunabhängig sind, wird keine Frontgruppe angegeben.
Häufig können beispielsweise alle Stilfronten zu einer Frontgruppe zusammengefasst werden, da sie in der Regel bei einer hohen Tür in der gleichen Weise unterteilt werden.
Die unterschiedlichen Frontaufteilungen bei beispielsweise verschiedenen Einbaugeräten ist unabhängig von der Frontgruppe.
Wird für ein Programm eine Frontgruppe angelegt, so müssen allen Programmen Frontgruppen zugeordnet werden.
FRONT_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein. D positiveInteger
P
M [1:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FRONT_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine ID definiert, mit der die Frontgruppe von den Programmen referenziert wird. Diese ID muss über alle Artikel eindeutig sein. D positiveInteger
P
M [1:99]
Quelle
<xs:element name="FRONT_GROUP_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>210--12--Frontgruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FRONT_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>210--12--Frontgruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_CLASS_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : FEATURE_CLASS_REF Element
Beschreibung
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/
Namensraum (none)
Diagramm
FEATURE_CLASS_REF Element
Overview
FEATURE_CLASS_REF optional
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D nonNegativeInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
Dieses Element referenziert eine Variantenfamilie.

Eine Variantenfamilie wird im Element FEATURE_CLASS (Pfad1) definiert und über das enthaltene Attribut FEATURE_CLASS_NO identifiziert.

In der von einem Programm referenzierten Variantenfamilie dürfen nur Variantenarten enthalten sein, die direkt dem Programm zugeordnet sind. Die Summe der für einen Artikel notwendigen Variantenarten resultiert aus der Summe der Variantenarten, die durch die Variantenfamilie der PRODUCT_GROUP und der Variantenfamilie des Programms, in dem der Artikel verfügbar ist, referenziert werden.

Pfad1: FEATURE_DEFINITION/FEATURE_CLASSES/ 		D nonNegativeInteger
P
M [1:999]
Quelle
<xs:element name="FEATURE_CLASS_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>210--13--Var_Familien_Nr</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEFAULT_OPTION_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : DEFAULT_OPTION_GROUP_REF Element
Beschreibung
Mit diesem Element werden dem Programm Standardvorschläge zugeordnet.
Namensraum (none)
Diagramm
DEFAULT_OPTION_GROUP_REF Element
Overview
DEFAULT_OPTION_GROUP_REF 0..∞
Mit diesem Element werden dem Programm Standardvorschläge zugeordnet.
DEFAULT_OPTION_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird ein Standardvorschlag referenziert. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DEFAULT_OPTION_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird ein Standardvorschlag referenziert. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DEFAULT_OPTION_GROUP_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>295--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DEFAULT_OPTION_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>295--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element : RESTRICTIONS Element
Beschreibung
Dieses Element referenziert Prüfverfahren, die für das Programm angewendet werden (Programm-spezifische Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Namensraum (none)
Diagramm
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
Dieses Element referenziert Prüfverfahren, die für das Programm angewendet werden (Programm-spezifische Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE required Restriction of xs:positiveInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element SEQUENCE erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D positiveInteger
P
M [1:99999]
Quelle
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
    <xs:documentation>von minOcc 1 auf optional 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > STYLE Element > RESTRICTIONS Element : RESTRICTION_REF Element
Beschreibung
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
Namensraum (none)
Diagramm
RESTRICTION_REF Element
Overview
RESTRICTION_REF 1..∞
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden.

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein von der Serie oder dem Programm referenziertes Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE required Restriction of xs:positiveInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element SEQUENCE erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D positiveInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
Dieses Element referenziert ein Prüfverfahren, das für das Programm angewendet wird (Programm-spezifisches Prüfverfahren).

Ein Prüfverfahren, dass von einem Programm referenziert wird, darf nicht von einer programmneutralen Ebenen (Serie, Global) referenziert werden

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein, von der Serie oder dem Programm referenzierten Prüfverfahren gibt, welches eine Kombination dieser Varianten ausschließt. Dies entspricht der Bildung der Schnittmenge der Variantenkombinationen über alle Prüfverfahren. 		D nonNegativeInteger
P
M [1:99999]
SEQUENCE Restriction of xs:positiveInteger required
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element SEQUENCE erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, …). 		D positiveInteger
P
M [1:99999]
Quelle
<xs:element name="RESTRICTION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>von optional  auf  minOcc 1 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>291--3--Prog_Schluessel</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
RESTRICTIONS Element | STYLE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HANDLE_ORIENTATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : HANDLE_ORIENTATION Element
Beschreibung
In diesem Element wird eine Grifflage definiert.
Namensraum (none)
Diagramm
DEFAULT_HANDLE_ORIENTATION_REF Element Sequence HANDLE_ORIENTATION Element
Overview
HANDLE_ORIENTATION 0..∞
In diesem Element wird eine Grifflage definiert.
HANDLE_ORIENTATION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Griffausprägung identifiziert. D string
P
M [1:5]
Sequence
DEFAULT_HANDLE_ORIENTATION_REF optional

In diesem Element wird eine Variante für eine Basisgrifflage angelegt. Es wird eine Basisgrifflage referenziert, die im Element BASIC_HANDLE_POSITIONS (Pfad 1) definiert ist.

Im Element OPTION_KEY (Pfad 2) wird die herstellerspezifische Bezeichnung einer eingetragen.

Das Element Standard-Grifflage muss gefüllt werden, wenn im Element FEATURE (Pfad 3) die Variantenart 304 (Grifflage) eingetragen ist.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
Pfad 3: FEATURE_DEFINITION/FEATURES

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D nonNegativeInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
HANDLE_ORIENTATION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Griffausprägung identifiziert. D string
P
M [1:5]
Quelle
<xs:element name="HANDLE_ORIENTATION" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DEFAULT_HANDLE_ORIENTATION_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEFAULT_HANDLE_ORIENTATION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > HANDLE_ORIENTATION Element : DEFAULT_HANDLE_ORIENTATION_REF Element
Beschreibung

In diesem Element wird eine Variante für eine Basisgrifflage angelegt. Es wird eine Basisgrifflage referenziert, die im Element BASIC_HANDLE_POSITIONS (Pfad 1) definiert ist.

Im Element OPTION_KEY (Pfad 2) wird die herstellerspezifische Bezeichnung einer eingetragen.

Das Element Standard-Grifflage muss gefüllt werden, wenn im Element FEATURE (Pfad 3) die Variantenart 304 (Grifflage) eingetragen ist.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
Pfad 3: FEATURE_DEFINITION/FEATURES

Namensraum (none)
Diagramm
DEFAULT_HANDLE_ORIENTATION_REF Element
Overview
DEFAULT_HANDLE_ORIENTATION_REF optional

In diesem Element wird eine Variante für eine Basisgrifflage angelegt. Es wird eine Basisgrifflage referenziert, die im Element BASIC_HANDLE_POSITIONS (Pfad 1) definiert ist.

Im Element OPTION_KEY (Pfad 2) wird die herstellerspezifische Bezeichnung einer eingetragen.

Das Element Standard-Grifflage muss gefüllt werden, wenn im Element FEATURE (Pfad 3) die Variantenart 304 (Grifflage) eingetragen ist.

Elementpfade
Pfad 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS

Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
Pfad 3: FEATURE_DEFINITION/FEATURES

SPECIFIC_HANDLE_ORIENTATION_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D nonNegativeInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SPECIFIC_HANDLE_ORIENTATION_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="DEFAULT_HANDLE_ORIENTATION_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SPECIFIC_HANDLE_ORIENTATION_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
HANDLE_ORIENTATION Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MATERIAL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : MATERIAL Element
Beschreibung
In diesem Element wird ein Material definiert.

Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur (TEXTURE) noch Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.
Namensraum (none)
Diagramm
BRIGHTNESS Element TRANSPARENCY Element TEXTURE Element COLOR Element Choice Sequence MATERIAL Element
Overview
MATERIAL 0..∞
In diesem Element wird ein Material definiert.

Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Tabelle Standardvariantenarten gekennzeichnet durch A), dann dürfen weder eine Textur (TEXTURE) noch Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material identifiziert. D string
P
M [1:5]
Sequence
Choice optional
COLOR
In diesem Element werden Farben definiert.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
TEXTURE
In diesem Element werden die Informationen für Texturen hinterlegt.
Sequence
FILE_NAME_TEXTURE Restriction of xs:string
In dieses Element werden Verweise auf Dateien mit Materialtexturen hinterlegt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
TEXTURE_REPEAT optional
Über dieses Element wird definiertgekennzeichnet, ob eine Textur einmal oder sich wiederholend aufgebracht wird (gekachelt). Soll die Textur gekachelt werden, wird das Element angelegt und die notwendigen Daten in den entsprechenden Kindelementen hinterlegt.
Kachelungsfaktor wird von der Software auf Basis der Texturgröße (DPI, Anzahl Pixel) bestimmt.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein.
TEXTURE_TILE optional Restriction of xs:int
Über dieses Attribut wird gekennzeichnet, ob eine Textur einmal (0 = nicht kacheln) oder sich wiederholend (1 = kacheln) aufgebracht wird. D integer
P
M [0:1]
Sequence
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in X-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in Y-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein. 		D boolean
P
M
TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D string
P |[HV]
M [0:1]
TRANSPARENCY optional Restriction of xs:nonNegativeInteger
Dieses Element definiert den Grad der Transparenz eines Materials (RGB-Wert oder Textur).
0 = opak
9 = max. Transparenz
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein. 		D nonNegativeInteger
P
M [0:9]
BRIGHTNESS optional Restriction of xs:nonNegativeInteger
Dieses Element definiert den Grad des Glanzes eines Materials (RGB-Wert oder Textur).
0 = matt
8 = Hochglanz
9 = Spiegelung
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein. 		D nonNegativeInteger
P
M [0:9]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MATERIAL_NO Restriction of xs:string required
Mit diesem Attribut wird ein Material identifiziert. D string
P
M [1:5]
Quelle
<xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice minOccurs="0">
        <xs:annotation>
          <xs:documentation />
          <xs:documentation>AK 28.02.2012. Optional gesetzt um die alte 1.7 Logik zu erhalten.</xs:documentation>
        </xs:annotation>
        <xs:element name="COLOR">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="RGB_RED">
                <xs:annotation>
                  <xs:documentation>260--11--RGB_Rot</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="255" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="RGB_GREEN">
                <xs:annotation>
                  <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="255" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="RGB_BLUE">
                <xs:annotation>
                  <xs:documentation>260--13--RGB_Blau</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="255" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
        <xs:element name="TEXTURE">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="FILE_NAME_TEXTURE">
                <xs:annotation>
                  <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="TEXTURE_REPEAT" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="REAL_MEASUREMENT_X">
                      <xs:annotation>
                        <xs:documentation>260--17--Realmass_X</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="9999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="REAL_MEASUREMENT_Y">
                      <xs:annotation>
                        <xs:documentation>260--18--Realmass_Y</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="9999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="TEXTURE_TILE">
                    <xs:simpleType>
                      <xs:restriction base="xs:int">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="1" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="MASKING" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>260--10--Maskierung</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:boolean" />
                </xs:simpleType>
              </xs:element>
              <xs:element name="TEXTURE_DELIVERED_ORIENTATION">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:pattern value="|[HV]" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
      </xs:choice>
      <xs:element name="TRANSPARENCY" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--14--Transparenz</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BRIGHTNESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--15--Glanz</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MATERIAL_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COLOR Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element : COLOR Element
Beschreibung
In diesem Element werden Farben definiert.
Namensraum (none)
Diagramm
RGB_BLUE Element RGB_GREEN Element RGB_RED Element Sequence COLOR Element
Overview
COLOR
In diesem Element werden Farben definiert.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
Quelle
<xs:element name="COLOR" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RGB_RED">
        <xs:annotation>
          <xs:documentation>260--11--RGB_Rot</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RGB_GREEN">
        <xs:annotation>
          <xs:documentation>260--12--RGB_Gruen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RGB_BLUE">
        <xs:annotation>
          <xs:documentation>260--13--RGB_Blau</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RGB_RED Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_RED Element
Beschreibung
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
RGB_RED Element
Overview
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
Quelle
<xs:element name="RGB_RED" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--11--RGB_Rot</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RGB_GREEN Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_GREEN Element
Beschreibung
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
RGB_GREEN Element
Overview
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
Quelle
<xs:element name="RGB_GREEN" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--12--RGB_Gruen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RGB_BLUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_BLUE Element
Beschreibung
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
RGB_BLUE Element
Overview
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil
Wird ein Farbwert gesetzt müssen alle Farbwerte sowie die Elemente TRANSPARENCY und BRIGHTNESS gefüllt sein. Die Elemente TEXTURE_REPEAT und MASKING müssen leer bleiben.
Wenn es sich um eine Farbvariante handelt müssen entweder diese Elemente oder das Element FILENAME_TEXTURE gefüllt sein. 		D nonNegativeInteger
P
M [0:255]
Quelle
<xs:element name="RGB_BLUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--13--RGB_Blau</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXTURE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element : TEXTURE Element
Beschreibung
In diesem Element werden die Informationen für Texturen hinterlegt.
Namensraum (none)
Diagramm
TEXTURE_DELIVERED_ORIENTATION Element MASKING Element TEXTURE_REPEAT Element FILE_NAME_TEXTURE Element Sequence TEXTURE Element
Overview
TEXTURE
In diesem Element werden die Informationen für Texturen hinterlegt.
Sequence
FILE_NAME_TEXTURE Restriction of xs:string
In dieses Element werden Verweise auf Dateien mit Materialtexturen hinterlegt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
TEXTURE_REPEAT optional
Über dieses Element wird definiertgekennzeichnet, ob eine Textur einmal oder sich wiederholend aufgebracht wird (gekachelt). Soll die Textur gekachelt werden, wird das Element angelegt und die notwendigen Daten in den entsprechenden Kindelementen hinterlegt.
Kachelungsfaktor wird von der Software auf Basis der Texturgröße (DPI, Anzahl Pixel) bestimmt.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein.
TEXTURE_TILE optional Restriction of xs:int
Über dieses Attribut wird gekennzeichnet, ob eine Textur einmal (0 = nicht kacheln) oder sich wiederholend (1 = kacheln) aufgebracht wird. D integer
P
M [0:1]
Sequence
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in X-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in Y-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein. 		D boolean
P
M
TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D string
P |[HV]
M [0:1]
Quelle
<xs:element name="TEXTURE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FILE_NAME_TEXTURE">
        <xs:annotation>
          <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TEXTURE_REPEAT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="REAL_MEASUREMENT_X">
              <xs:annotation>
                <xs:documentation>260--17--Realmass_X</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="REAL_MEASUREMENT_Y">
              <xs:annotation>
                <xs:documentation>260--18--Realmass_Y</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="TEXTURE_TILE">
            <xs:simpleType>
              <xs:restriction base="xs:int">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MASKING" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--10--Maskierung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="TEXTURE_DELIVERED_ORIENTATION">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[HV]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_NAME_TEXTURE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element : FILE_NAME_TEXTURE Element
Beschreibung
In dieses Element werden Verweise auf Dateien mit Materialtexturen hinterlegt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FILE_NAME_TEXTURE Element
Overview
FILE_NAME_TEXTURE Restriction of xs:string
In dieses Element werden Verweise auf Dateien mit Materialtexturen hinterlegt. D string
P |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))
M [5:64]
Quelle
<xs:element name="FILE_NAME_TEXTURE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--6--Dateiname_Textur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>geaendert von 12 auf 64 Stellen analog 1.7.3 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG))" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXTURE_REPEAT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element : TEXTURE_REPEAT Element
Beschreibung
Über dieses Element wird definiertgekennzeichnet, ob eine Textur einmal oder sich wiederholend aufgebracht wird (gekachelt). Soll die Textur gekachelt werden, wird das Element angelegt und die notwendigen Daten in den entsprechenden Kindelementen hinterlegt.
Kachelungsfaktor wird von der Software auf Basis der Texturgröße (DPI, Anzahl Pixel) bestimmt.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein.
Namensraum (none)
Diagramm
REAL_MEASUREMENT_Y Element REAL_MEASUREMENT_X Element Sequence TEXTURE_REPEAT Element
Overview
TEXTURE_REPEAT optional
Über dieses Element wird definiertgekennzeichnet, ob eine Textur einmal oder sich wiederholend aufgebracht wird (gekachelt). Soll die Textur gekachelt werden, wird das Element angelegt und die notwendigen Daten in den entsprechenden Kindelementen hinterlegt.
Kachelungsfaktor wird von der Software auf Basis der Texturgröße (DPI, Anzahl Pixel) bestimmt.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein.
TEXTURE_TILE optional Restriction of xs:int
Über dieses Attribut wird gekennzeichnet, ob eine Textur einmal (0 = nicht kacheln) oder sich wiederholend (1 = kacheln) aufgebracht wird. D integer
P
M [0:1]
Sequence
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in X-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in Y-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TEXTURE_TILE Restriction of xs:int optional
Über dieses Attribut wird gekennzeichnet, ob eine Textur einmal (0 = nicht kacheln) oder sich wiederholend (1 = kacheln) aufgebracht wird. D integer
P
M [0:1]
Quelle
<xs:element name="TEXTURE_REPEAT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--9--Textur_Kachelung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="REAL_MEASUREMENT_X">
        <xs:annotation>
          <xs:documentation>260--17--Realmass_X</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="REAL_MEASUREMENT_Y">
        <xs:annotation>
          <xs:documentation>260--18--Realmass_Y</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="TEXTURE_TILE">
      <xs:simpleType>
        <xs:restriction base="xs:int">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

REAL_MEASUREMENT_X Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element > TEXTURE_REPEAT Element : REAL_MEASUREMENT_X Element
Beschreibung
Hier wird das reale Maß der Textur in X-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
REAL_MEASUREMENT_X Element
Overview
REAL_MEASUREMENT_X Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in X-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
Quelle
<xs:element name="REAL_MEASUREMENT_X" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--17--Realmass_X</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXTURE_REPEAT Element | TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

REAL_MEASUREMENT_Y Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element > TEXTURE_REPEAT Element : REAL_MEASUREMENT_Y Element
Beschreibung
Hier wird das reale Maß der Textur in Y-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
REAL_MEASUREMENT_Y Element
Overview
REAL_MEASUREMENT_Y Restriction of xs:nonNegativeInteger
Hier wird das reale Maß der Textur in Y-Richtung angegeben. Der Wert wird in mm angegeben. D nonNegativeInteger
P
M [1:9999]
Quelle
<xs:element name="REAL_MEASUREMENT_Y" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--18--Realmass_Y</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXTURE_REPEAT Element | TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MASKING Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element : MASKING Element
Beschreibung
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein. 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
MASKING Element
Overview
MASKING optional Restriction of xs:boolean
Über dieses Element wird gekennzeichnet, ob eine Textur maskiert wird, d. h. bei der Bildberechnung werden entsprechend gekennzeichnete Bereiche nicht sichtbar.
0 = keine Maskierung
1 = Maskierung
Für die Maskierung wird der RGB-Wert 0, 0, 255 verwendet.
Ist das Element FILENAME_TEXTURE gefüllt, so muss auch dieses Element gefüllt sein. 		D boolean
P
M
Quelle
<xs:element name="MASKING" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--10--Maskierung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXTURE_DELIVERED_ORIENTATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > TEXTURE Element : TEXTURE_DELIVERED_ORIENTATION Element
Beschreibung
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D string
P |[HV]
M [0:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXTURE_DELIVERED_ORIENTATION Element
Overview
TEXTURE_DELIVERED_ORIENTATION Restriction of xs:string
Mit diesem Attribut wird eine Standardgrifflage identifiziert. D string
P |[HV]
M [0:1]
Quelle
<xs:element name="TEXTURE_DELIVERED_ORIENTATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[HV]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXTURE Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TRANSPARENCY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element : TRANSPARENCY Element
Beschreibung
Dieses Element definiert den Grad der Transparenz eines Materials (RGB-Wert oder Textur).
0 = opak
9 = max. Transparenz
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein. 		D nonNegativeInteger
P
M [0:9]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
TRANSPARENCY Element
Overview
TRANSPARENCY optional Restriction of xs:nonNegativeInteger
Dieses Element definiert den Grad der Transparenz eines Materials (RGB-Wert oder Textur).
0 = opak
9 = max. Transparenz
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein. 		D nonNegativeInteger
P
M [0:9]
Quelle
<xs:element name="TRANSPARENCY" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--14--Transparenz</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BRIGHTNESS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element : BRIGHTNESS Element
Beschreibung
Dieses Element definiert den Grad des Glanzes eines Materials (RGB-Wert oder Textur).
0 = matt
8 = Hochglanz
9 = Spiegelung
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein. 		D nonNegativeInteger
P
M [0:9]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BRIGHTNESS Element
Overview
BRIGHTNESS optional Restriction of xs:nonNegativeInteger
Dieses Element definiert den Grad des Glanzes eines Materials (RGB-Wert oder Textur).
0 = matt
8 = Hochglanz
9 = Spiegelung
Wenn es sich bei dem Element um eine Farbvariante handelt muss dieses Element gefüllt sein. 		D nonNegativeInteger
P
M [0:9]
Quelle
<xs:element name="BRIGHTNESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--15--Glanz</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FORM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : FORM Element
Beschreibung
In diesem Element wird eine Formvariante definiert.
Namensraum (none)
Diagramm
PROFILE_KEY Element Sequence FORM Element
Overview
FORM 0..∞
In diesem Element wird eine Formvariante definiert.
FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform identifiziert. D string
P
M [1:5]
Sequence
PROFILE_KEY Restriction of xs:string
In diesem Element wird der herstellerspezifische Key für eine Profilform hinterlegt. Mit diesem Element werden Varianten der Variantenarten 750-756 gebildet. Das Element FORM kann nur von den Variantenarten 750-756 genutzt werden. Die gebildete Varianten werden vom Artikel (ITEM) referenziert, der das Profil darstellt. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FORM_NO Restriction of xs:string required
Mit diesem Attribut wird eine Profilform identifiziert. D string
P
M [1:5]
Quelle
<xs:element name="FORM" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROFILE_KEY">
        <xs:annotation>
          <xs:documentation>430--4/5--Varianten_Art_Profilform/Var_Schluessel_</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="5" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FORM_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PROFILE_KEY Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > FORM Element : PROFILE_KEY Element
Beschreibung
In diesem Element wird der herstellerspezifische Key für eine Profilform hinterlegt. Mit diesem Element werden Varianten der Variantenarten 750-756 gebildet. Das Element FORM kann nur von den Variantenarten 750-756 genutzt werden. Die gebildete Varianten werden vom Artikel (ITEM) referenziert, der das Profil darstellt. D string
P
M [1:5]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
PROFILE_KEY Element
Overview
PROFILE_KEY Restriction of xs:string
In diesem Element wird der herstellerspezifische Key für eine Profilform hinterlegt. Mit diesem Element werden Varianten der Variantenarten 750-756 gebildet. Das Element FORM kann nur von den Variantenarten 750-756 genutzt werden. Die gebildete Varianten werden vom Artikel (ITEM) referenziert, der das Profil darstellt. D string
P
M [1:5]
Quelle
<xs:element name="PROFILE_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>430--4/5--Varianten_Art_Profilform/Var_Schluessel_</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="5" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FORM Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_MEASURE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : OPTION_MEASURE Element
Beschreibung
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Sockelhöhe (Variantenart 402)).
Namensraum (none)
Diagramm
STANDARD_PLINTH Element PLINTH_HEIGHT Element Sequence OPTION_MEASURE Element
Overview
OPTION_MEASURE 0..∞
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Sockelhöhe (Variantenart 402)).
OPTION_MEASURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine maßliche Ausprägung identifiziert. D nonNegativeInteger
P
M [1:99999]
Sequence
PLINTH_HEIGHT Restriction of xs:nonNegativeInteger
In diesem Element wird die Sockelhöhe in mm angegeben. D nonNegativeInteger
P
M [0:999999999]
STANDARD_PLINTH optional xs:boolean

In diesem Element wird angegeben, ob es sich bei der entsprechenden Sockelhöhe um einen Standard handelt, oder ob die Höhe vom Standard abweicht. Ist der Wert false(0), handelt es sich bei der Sockelhöhe um eine vom Standard abweichende Höhe, die eventuell mit einem Mehrpreis für die Sockelfüße verbunden ist.

Fehlt das Element, entspricht es dem Wert true(1).

Gibt es verknüpfte Artikel mit der Zuordnungsart CLASS = 21, muss dieses Element angegeben werden.

D boolean
P
M [0:1]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_MEASURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine maßliche Ausprägung identifiziert. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PLINTH_HEIGHT">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STANDARD_PLINTH" type="xs:boolean" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Kennzeichnung zur Abweichung von Standardsockelhöhe</xs:documentation>
          <xs:documentation>hinzugefügt K.Richter, 29.02.2016</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPTION_MEASURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PLINTH_HEIGHT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > OPTION_MEASURE Element : PLINTH_HEIGHT Element
Beschreibung
In diesem Element wird die Sockelhöhe in mm angegeben. D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
PLINTH_HEIGHT Element
Overview
PLINTH_HEIGHT Restriction of xs:nonNegativeInteger
In diesem Element wird die Sockelhöhe in mm angegeben. D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="PLINTH_HEIGHT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION_MEASURE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

STANDARD_PLINTH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > OPTION_MEASURE Element : STANDARD_PLINTH Element
Beschreibung

In diesem Element wird angegeben, ob es sich bei der entsprechenden Sockelhöhe um einen Standard handelt, oder ob die Höhe vom Standard abweicht. Ist der Wert false(0), handelt es sich bei der Sockelhöhe um eine vom Standard abweichende Höhe, die eventuell mit einem Mehrpreis für die Sockelfüße verbunden ist.

Fehlt das Element, entspricht es dem Wert true(1).

Gibt es verknüpfte Artikel mit der Zuordnungsart CLASS = 21, muss dieses Element angegeben werden.

D boolean
P
M [0:1]
Namensraum (none)
Typ
xs:boolean
Diagramm
STANDARD_PLINTH Element
Overview
STANDARD_PLINTH optional xs:boolean

In diesem Element wird angegeben, ob es sich bei der entsprechenden Sockelhöhe um einen Standard handelt, oder ob die Höhe vom Standard abweicht. Ist der Wert false(0), handelt es sich bei der Sockelhöhe um eine vom Standard abweichende Höhe, die eventuell mit einem Mehrpreis für die Sockelfüße verbunden ist.

Fehlt das Element, entspricht es dem Wert true(1).

Gibt es verknüpfte Artikel mit der Zuordnungsart CLASS = 21, muss dieses Element angegeben werden.

D boolean
P
M [0:1]
Quelle
<xs:element name="STANDARD_PLINTH" type="xs:boolean" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Kennzeichnung zur Abweichung von Standardsockelhöhe</xs:documentation>
    <xs:documentation>hinzugefügt K.Richter, 29.02.2016</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION_MEASURE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : RESTRICTIONS Element
Beschreibung
In diesem Element werden die Prüfverfahren angelegt.
Namensraum (none)
Diagramm
RESTRICTION Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
In diesem Element werden die Prüfverfahren angelegt.
Sequence
RESTRICTION 1..99999
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger

In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefüllt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
Quelle
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION" maxOccurs="99999">
        <xs:annotation>
          <xs:documentation>270/271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>270--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:sequence minOccurs="0">
                    <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                      <xs:annotation>
                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSION_TYPE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[WHD]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSION_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                      <xs:annotation>
                        <xs:documentation>405--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSION_TYPE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[WHD]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSION_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="TEST_ID">
              <xs:annotation>
                <xs:documentation>270--4--Pruef_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_1_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_2_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_3_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="VALIDATION_TYPE" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:int">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element : RESTRICTION Element
Beschreibung
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1
Namensraum (none)
Diagramm
TEST_ID Element OPTION_COMBINATION Element LANGUAGE Element Sequence RESTRICTION_NAME_TEXT Element Sequence RESTRICTION Element
Overview
RESTRICTION 1..99999
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger

In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefüllt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO Restriction of xs:nonNegativeInteger required
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO Restriction of xs:nonNegativeInteger optional
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO Restriction of xs:nonNegativeInteger optional

In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE Restriction of xs:int required
Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefüllt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405) 		D nonNegativeInteger
P
M [0:1]
Quelle
<xs:element name="RESTRICTION" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>270--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:sequence minOccurs="0">
              <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                <xs:annotation>
                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="DIMENSION_TYPE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[WHD]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                  <xs:attribute name="DIMENSION_VALUE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                <xs:annotation>
                  <xs:documentation>405--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="DIMENSION_TYPE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[WHD]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                  <xs:attribute name="DIMENSION_VALUE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="TEST_ID">
        <xs:annotation>
          <xs:documentation>270--4--Pruef_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_1_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_2_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_3_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="VALIDATION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:int">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RESTRICTION_NAME_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : RESTRICTION_NAME_TEXT Element
Beschreibung
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence RESTRICTION_NAME_TEXT Element
Overview
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_COMBINATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : OPTION_COMBINATION Element
Beschreibung
In diesem Element wird eine Variantenkombination gebildet.
Namensraum (none)
Diagramm
MIN_DIMENSION Element MAX_DIMENSION Element Sequence OPTION_REF Element Sequence OPTION_COMBINATION Element
Overview
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
Bemerkung

Quelle
<xs:element name="OPTION_COMBINATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:sequence minOccurs="0">
        <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
          <xs:annotation>
            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="DIMENSION_TYPE" use="required">
              <xs:annotation>
                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[WHD]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
            <xs:attribute name="DIMENSION_VALUE" use="required">
              <xs:annotation>
                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
          <xs:annotation>
            <xs:documentation>405--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="DIMENSION_TYPE" use="required">
              <xs:annotation>
                <xs:documentation>405--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[WHD]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
            <xs:attribute name="DIMENSION_VALUE" use="required">
              <xs:annotation>
                <xs:documentation>405--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : OPTION_REF Element
Beschreibung
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="OPTION_REF" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MAX_DIMENSION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : MAX_DIMENSION Element
Beschreibung
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
Namensraum (none)
Diagramm
MAX_DIMENSION Element
Overview
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DIMENSION_TYPE Restriction of xs:string required
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE Restriction of xs:nonNegativeInteger required
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
Quelle
<xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[WHD]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSION_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MIN_DIMENSION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : MIN_DIMENSION Element
Beschreibung
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
Namensraum (none)
Diagramm
MIN_DIMENSION Element
Overview
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DIMENSION_TYPE Restriction of xs:string required
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE Restriction of xs:nonNegativeInteger required
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
Quelle
<xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>405--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>405--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[WHD]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSION_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>405--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEST_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : TEST_ID Element
Beschreibung
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
TEST_ID Element
Overview
TEST_ID Restriction of xs:boolean
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
Quelle
<xs:element name="TEST_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--4--Pruef_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUGGESTIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : SUGGESTIONS Element
Beschreibung
In diesem Element werden Vorbelegungen angelegt.
Namensraum (none)
Diagramm
SUGGESTION Element Sequence SUGGESTIONS Element
Overview
SUGGESTIONS optional
In diesem Element werden Vorbelegungen angelegt.
Sequence
SUGGESTION 1..99999

In diesem Element wird eine Vorbelegung für Variantenarten mit bestimmten Varianten definiert und beschrieben.

Diese Möglichkeit der Vorbelegung ist nur für Kopfvarianten vorgesehen und wirksam bei der Ersterfassung einer Planung.

Ähnlich wie ein Standardvorschlag (DEFAULT_OPTION_GROUP) wird sie unterhalb der Serie referenziert, wobei der Standardvorschlag mit höherer Priorität greift.

Über OPTION_COMBINATION können auch Paare von Varianten für variantenabhängige Vorbelegungen zur Verfügung gestellt werden.

Dabei ist die unter FEATURE_1_NO angegebene Variantenart die führende.

Die Vorbelegungen dürfen nicht den dazugehörigen Prüfungen widersprechen.

SUGGESTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Vorbelegungen eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
Sequence
SUGGESTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wird die Bezeichnung einer Vorbelegung hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination für die Vorbelegung gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einer Vorbelegung angegeben werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Quelle
<xs:element name="SUGGESTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SUGGESTION" maxOccurs="99999">
        <xs:annotation>
          <xs:documentation>270/271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SUGGESTION_NAME_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>270--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SUGGESTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_1_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_2_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_3_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUGGESTION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > SUGGESTIONS Element : SUGGESTION Element
Beschreibung

In diesem Element wird eine Vorbelegung für Variantenarten mit bestimmten Varianten definiert und beschrieben.

Diese Möglichkeit der Vorbelegung ist nur für Kopfvarianten vorgesehen und wirksam bei der Ersterfassung einer Planung.

Ähnlich wie ein Standardvorschlag (DEFAULT_OPTION_GROUP) wird sie unterhalb der Serie referenziert, wobei der Standardvorschlag mit höherer Priorität greift.

Über OPTION_COMBINATION können auch Paare von Varianten für variantenabhängige Vorbelegungen zur Verfügung gestellt werden.

Dabei ist die unter FEATURE_1_NO angegebene Variantenart die führende.

Die Vorbelegungen dürfen nicht den dazugehörigen Prüfungen widersprechen.

Namensraum (none)
Diagramm
OPTION_COMBINATION Element LANGUAGE Element Sequence SUGGESTION_NAME_TEXT Element Sequence SUGGESTION Element
Overview
SUGGESTION 1..99999

In diesem Element wird eine Vorbelegung für Variantenarten mit bestimmten Varianten definiert und beschrieben.

Diese Möglichkeit der Vorbelegung ist nur für Kopfvarianten vorgesehen und wirksam bei der Ersterfassung einer Planung.

Ähnlich wie ein Standardvorschlag (DEFAULT_OPTION_GROUP) wird sie unterhalb der Serie referenziert, wobei der Standardvorschlag mit höherer Priorität greift.

Über OPTION_COMBINATION können auch Paare von Varianten für variantenabhängige Vorbelegungen zur Verfügung gestellt werden.

Dabei ist die unter FEATURE_1_NO angegebene Variantenart die führende.

Die Vorbelegungen dürfen nicht den dazugehörigen Prüfungen widersprechen.

SUGGESTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Vorbelegungen eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
Sequence
SUGGESTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wird die Bezeichnung einer Vorbelegung hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination für die Vorbelegung gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einer Vorbelegung angegeben werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SUGGESTION_NO Restriction of xs:nonNegativeInteger required
Durch dieses Attribut werden Vorbelegungen eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO Restriction of xs:nonNegativeInteger required
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO Restriction of xs:nonNegativeInteger optional
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO Restriction of xs:nonNegativeInteger optional
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Vorbelegungen verwendet werden. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="SUGGESTION" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SUGGESTION_NAME_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>270--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SUGGESTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_1_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_2_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_3_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SUGGESTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUGGESTION_NAME_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > SUGGESTIONS Element > SUGGESTION Element : SUGGESTION_NAME_TEXT Element
Beschreibung
In diesem Element wird die Bezeichnung einer Vorbelegung hinterlegt.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence SUGGESTION_NAME_TEXT Element
Overview
SUGGESTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wird die Bezeichnung einer Vorbelegung hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="SUGGESTION_NAME_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
SUGGESTION Element | SUGGESTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_COMBINATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > SUGGESTIONS Element > SUGGESTION Element : OPTION_COMBINATION Element
Beschreibung
In diesem Element wird eine Variantenkombination für die Vorbelegung gebildet.
Namensraum (none)
Diagramm
OPTION_REF Element Sequence OPTION_COMBINATION Element
Overview
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination für die Vorbelegung gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einer Vorbelegung angegeben werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_COMBINATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SUGGESTION Element | SUGGESTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > SUGGESTIONS Element > SUGGESTION Element > OPTION_COMBINATION Element : OPTION_REF Element
Beschreibung
In diesem Element werden Varianten referenziert, die in einer Vorbelegung angegeben werden.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einer Vorbelegung angegeben werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_COMBINATION Element | SUGGESTION Element | SUGGESTIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : PRICE_DEFINITION Element
Beschreibung
In diesem Element werden Informationen hinterlegt, die für die Preisberechnung notwengig sind wie beispielsweise Preistabellen und Ausführungsgruppen.
Namensraum (none)
Diagramm
PRICE_TYPES Element MERCHANDISE_GROUP Element IDENT_NUMBERS Element VALUE_ADDED_TAXES Element SET_OF_EXCHANGE_IDS Element PRICE_FEATURE_GROUPS Element Sequence PRICE_DEFINITION Element
Overview
PRICE_DEFINITION
In diesem Element werden Informationen hinterlegt, die für die Preisberechnung notwengig sind wie beispielsweise Preistabellen und Ausführungsgruppen.
Sequence
PRICE_FEATURE_GROUPS
In diesem Element werden Preisvariantengruppen definiert.
Sequence
PRICE_FEATURE_GROUP 1..∞
In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

Eine Preisvariantengruppe wird vom Artikel referenziert. beim Artikel werden auch die konkreten Preise hinterlegt.

Für die Preisvariantengruppe bzw. für Artikel gelten folgende Regelungen:
- Ein preisgruppenneutraler Artikel hat keine Varianten.
- Preisgruppenabhängige Artikel haben die Variantenart 1 (Programm), die in FEATURE_NO_1 eingetragen werden muss, und optional die Variantenarten 101 (Frontfarbe 1) oder 105 (Frontkombination). Falls bei mindestens einer Preisfindung die Variantenart 101 oder 105 im Element FINISH/OPTION_REF angegeben wird, soll der entsprechende Wert in FEATURE_NO_2 eingetragen werden.
- Ausführungsabhängige Artikel haben ein oder zwei Variantenarten.
- Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0)

Es dürfen nicht mehrere Preisvariantengruppen mit der selben Kombination von Variantenarten angelegt werden. Beispielsweise sollte eine Preisvariantengruppe mit der Variantenart Griffausführung nur einmal existieren und alles abbilden was mit Griffausführung zusammenhängt.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
Dieses Attribut ist ein Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis):
Wird eine Mehrpreisgruppe definiert (ADDITIONAL_PRICE=1), so darf über diese Mehrpreisgruppe kein "Preis auf Anfrage" gebildet werden. Bei einem Artikel, der diese Mehrpreisgruppe referenziert, darf das Element PRICE_ON_REQUEST (Pfad 1) nicht angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST 		D boolean
P
M
PRICE_CALC_METHOD required Restriction of xs:nonNegativeInteger
In diesem Attribut wird definiert nach welcher grundsätzlichen Methode der Preis berechnet wird.

Folgende Methoden sind möglich:

0 = Preis auf Anfrage;
1 = programmneutraler Preis;
2 = programmabhängiger Preis;
3 = ausführungsabhängiger Preis.

Eine PRICE_FEATURE_GROUP, in der das Attribut PRICE_CALC_METHOD den Wert 0 (Preis auf Anfrage) hat, darf nur 1x angelegt werden. 		D nonNegativeInteger
P
M [0:3]
FEATURE_NO_1 optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die erste Variantenart für die Preisfindung identifiziert.
Die in dem ersten Attribut OPTION_REF/FEATURE_NO angegebene Variantenart darf nicht von der im Attribut FEATURE_NO_1 angegebenen abweichen. 		D nonNegativeInteger
P
M [0:999]
FEATURE_NO_2 optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die zweite Variantenart für die Preisfindung identifiziert.
Die in dem zweiten Attribut OPTION_REF/FEATURE_NO angegebene Variantenart darf nicht von der im Attribut FEATURE_NO_2 angegebenen abweichen. 		D nonNegativeInteger
P
M [0:999]
Sequence
PRICE_FEATURE_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält Texte für Ausführungsgruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FINISH 0..∞
In diesem Element werden gültigen Variantenkombinationen Preisfelder (Preisfeld, Blockpreisfeld) und eine Herstellerpreisgruppe zugeordnet.

Wenn das Attribut PRICE_CALC_METHOD den Wert 0 hat (Preis auf Anfrage), darf das Element FINISH nicht angelegt werden.
Sequence
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
SET_OF_EXCHANGE_IDS optional
In diesem Element werden die herstellerspezifischen Tausch-IDs definiert.

Liefert ein Hersteller Blöcke, so muss dieses Element in der Katalogdatei enthalten sein. Das Element muss auch dann in der Katalogdatei enthalten sein, wenn ein Hersteller außerhalb der Katalogdatei, zu einem späteren Zeitpunkt Blöcke liefert. Das Element darf in einer Blockdatei nicht enthalten sein.
Sequence
EXCHANGE_ID 1..∞
Das Element EXCHANGE_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS verwendet werden.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Sequence
EXCHANGE_ID_TEXT languagetexte40 Complex Type
Der Text in diesem Element erläutert die Tauschgruppen, beispielsweise:
- Möbelteile
- Arbeitsplatten
- Lichtblenden/Kranzprofile
- Zubehör
- Elektrogeräte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
VALUE_ADDED_TAXES
In diesem Element werden die gültigen Mehrwertsteuersätze definiert, die von Artikeln referenziert werden. Die angegebenen Steuersätze müssen mit dem angegebenen Land korrespondieren, welches im Element COUNTRY_ID (Pfad 1) angegeben wurde.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION
Sequence
VALUE_ADDED_TAX 1..100
In diesem Element wird ein Mehrwertsteuersatz definiert.
VAT_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine ID für einen Mehrwertsteuersatz hinterlegt. Die ID 0 ist für Artikel reserviert, die keiner Mehrwertsteuer unterliegen. D nonNegativeInteger
P
M [0:99]
Sequence
VAT_RATE Restriction of xs:nonNegativeInteger
In diesem Element wird der zugehörige Mehrwertsteuersatz in Prozent inklusive zwei Nachkommastellen angegeben (z. B. 1600 für 16,00 % oder 10 für 0,1%). D nonNegativeInteger
P
M [0:9999]
IDENT_NUMBERS optional
In diesem Element werden die Identnummern definiert. Alle im Datenbestand verwendeten Identnummern müssen hier definiert werden.
Sequence
IDENT_NUMBER 0..9999
In diesem Element werden die Identnummern definiert. Alle im Datenbestand verwendeten Identnummern müssen hier definiert werden.
IDENT_NO required Restriction of xs:positiveInteger
In diesem Attribut wird eine Identnummer definiert. D positiveInteger
P
M [1:9999]
Sequence
SERIE_REF 1..99
Das Element referenziert eine Serie. Wird keine Serie referenziert, sind die angegebenen Identnummern serienübergreifend gültig.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden -> -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D nonNegativeInteger
P
M [0:99]
MERCHANDISE_GROUP 1..∞
Mit diesem Element wird eine Warengruppe angelegt. Die Warengruppe (Konditionsschiene des Herstellers) sowie der dazugehörige Text müssen mit dem Konditionsblatt des Herstellers übereinstimmen. Einer Warengruppe werden 1-n Kalkulationsgruppen zugeordnet.
MERCHANDISE_GROUP_NO required Restriction of xs:string
Mit diesem Attribut wird eine Warengruppe identifiziert. D string
P
M [1:5]
Sequence
MERCHANDISE_GROUP_TEXT languagetexte30 Complex Type
Dieses Element enthält Texte für Warengruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Sequence
CALC_GROUP 1..∞

In diesem Element werden die möglichen Kalkulationsgruppen definiert. Die Verwendung kann beispielsweise für unterschiedliche Rabattierungen sinnvoll sein. Dies bedeutet, dass je nach Anzahl der Rabattstaffelungen hier entsprechend viele Kalkulationsgruppen gebildet werden können. Im Element ITEM werden die Artikel einer Kalkulationsgruppe zugeordnet. Es dürfen nur Kalkulationsgruppen definiert werden, die von Artikeln referenziert werden. Schlüssel ist das Feld CALC_GROUP_NO.

Bei der Nutzung derselben Kalkulationsgruppe wird auch die gleiche Preisfindung verwendet.

Eine Kalkulationsgruppe kann innerhalb aller Elemente MERCHANDISE_GROUP nur ein Mal verwendet werden. Das heiß, das eine Kalkulationsgruppe nur in einer einzigen MERCHANDISE_GROUP verwendet werden darf und nicht in mehreren MERCHANDISE_GROUP's.

Die Kalkulationsgruppe wird über das Attribut CALC_GROUP_NO angegeben.

CALC_GROUP_NO required Restriction of xs:positiveInteger

Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination "00" ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
8 = diverses 1
9 = diverses 2

Einstellige Zahlen 0 – 9 sind ausgeschlossen, d.h. führende Nullen sind nicht erlaubt.

Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers.

 D positiveInteger
P
M [10:99]
Sequence
CALC_GROUP_TEXT languagetexte30 Complex Type
Dieses Element enthält Texte für Kalkulationsgruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
CALCULATION_FACTOR optional Restriction of xs:nonNegativeInteger
Dieses Element darf nur verwendet werden, wenn das Element PRICE_ID (Pfad 1) den Wert 3 hat.

Wenn Verrechnungspunkte verwendet werden, so muss in diesem Element der entsprechende Verrechnungsfaktor angegeben werden.
Der Verrechnungfaktor wird mit maximal fünf Vorkommastellen und genau drei Nachkommastellen (ohne das Komma selbst) eingetragen. Der Verrechnungsfaktor muss größer Null sein.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION 		D nonNegativeInteger
P
M [1:99999999]
PRICE_TYPES
In diesem Element werden die Preisarten zur stück- oder maßvariablen Berechnung von programmneutralen und programmabhängigen Artikeln definiert.
Die Kind-Elemente WIDTH_X, DEPTH_Y, HEIGHT_Z geben an, ob der Preis für einen Artikel, der nach dieser Preisart berechnet wird, breiten-, höhen-, tiefen-, flächen- bzw. volumenabhängig ist.
Wenn für keine Dimension eine "1" angegeben ist, ist der Preis nicht maßabhängig, wird also per Stück berechnet (beispielsweise ein Unterschrank). Dann werden die Elemente BASIC_UNIT und ROUNDING_UNIT mit dem Wert 0 belegt.
Wird für genau eine Dimension eine "1" angegeben, so wird diese Dimension für die Preisberechnung herangezogen (beispielsweise Lichtleisten).
Wenn für genau zwei Dimensionen eine "1" angegeben ist, so ist der Preis flächenabhängig (beispielsweise Verkleidungsmaterial).
Wenn für genau drei Dimensionen eine "1" angegeben ist, so ist der Preis volumenabhängig (beispielsweise Lacke, Beizen).
Sequence 1..∞
PRICE_TYPE
In diesem Element wird eine Preisart definiert.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (Pfad1) und ADDITIONAL_PRICE (Pfad2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in diesem Element "1000" anzugeben, bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³]. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein.

Pfad1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
Pfad2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein. D nonNegativeInteger
P
M [0:999999999999]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean
Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben, der sich auf die im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis unter Berücksichtigung der im Element definierten Logik zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet. 		D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_X (Pfad1) (b), DEPTH_Y (Pfad1) (t) oder HEIGHT_Z (Pfad1) (h) auf true gesetzt werden;
- es können die Grundrechenarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (Pfad1), ROUNDING_UNIT (Pfad1) und BASIC_PRICE_DEPENDENT (Pfad1) gelten auch in Verbindung mit der Preisartformel

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetexte60 Complex Type
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="PRICE_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>300--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                          <xs:annotation>
                            <xs:documentation>311--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>311--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>311--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_FIELD">
                          <xs:annotation>
                            <xs:documentation>311--5--Preisfeld</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="SUPPLIER_PRICE_GROUP">
                          <xs:annotation>
                            <xs:documentation>311--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="10" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="ADDITIONAL_PRICE" use="required">
                  <xs:annotation>
                    <xs:documentation>300--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:boolean" />
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="PRICE_CALC_METHOD" use="required">
                  <xs:annotation>
                    <xs:documentation>300--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="3" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_NO_1">
                  <xs:annotation>
                    <xs:documentation>300--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_NO_2">
                  <xs:annotation>
                    <xs:documentation>300--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_OF_EXCHANGE_IDS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>115--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>115--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_TEXT" type="languagetexte40">
                    <xs:annotation>
                      <xs:documentation>115--3--Tausch_ID_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>115--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALUE_ADDED_TAXES">
        <xs:annotation>
          <xs:documentation>360--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="VALUE_ADDED_TAX" maxOccurs="100">
              <xs:annotation>
                <xs:documentation>360--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="VAT_RATE">
                    <xs:annotation>
                      <xs:documentation>360--3--MwSt_Satz</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="VAT_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>360--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="IDENT_NUMBERS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>351--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="IDENT_NUMBER" minOccurs="0" maxOccurs="9999">
              <xs:annotation>
                <xs:documentation>351--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIE_REF" maxOccurs="99">
                    <xs:annotation>
                      <xs:documentation>351--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>351--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE">
                    <xs:annotation>
                      <xs:documentation>351--4--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="IDENT_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>351--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MERCHANDISE_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>350--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MERCHANDISE_GROUP_TEXT" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>350--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>350--6--Warengruppentext</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:sequence>
              <xs:element name="CALC_GROUP" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>350--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="CALC_GROUP_TEXT" type="languagetexte30">
                      <xs:annotation>
                        <xs:documentation>350--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                    </xs:element>
                    <xs:element name="CALCULATION_FACTOR" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>350--4--Verrechnungsfaktor</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="99999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="CALC_GROUP_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>350--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="10" />
                        <xs:maxInclusive value="99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:sequence>
          <xs:attribute name="MERCHANDISE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>350--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPES">
        <xs:annotation>
          <xs:documentation>150--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence maxOccurs="unbounded">
            <xs:element name="PRICE_TYPE">
              <xs:annotation>
                <xs:documentation>150--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="WIDTH_X">
                    <xs:annotation>
                      <xs:documentation>150--3--Breite_X</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPTH_Y">
                    <xs:annotation>
                      <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEIGHT_Z">
                    <xs:annotation>
                      <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_UNIT">
                    <xs:annotation>
                      <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ROUNDING_UNIT">
                    <xs:annotation>
                      <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_PRICE_DEPENDENT">
                    <xs:annotation>
                      <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="100" />
                        <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_NAME" type="languagetexte60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>150--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="250" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUPS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : PRICE_FEATURE_GROUPS Element
Beschreibung
In diesem Element werden Preisvariantengruppen definiert.
Namensraum (none)
Diagramm
PRICE_FEATURE_GROUP Element Sequence PRICE_FEATURE_GROUPS Element
Overview
PRICE_FEATURE_GROUPS
In diesem Element werden Preisvariantengruppen definiert.
Sequence
PRICE_FEATURE_GROUP 1..∞
In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

Eine Preisvariantengruppe wird vom Artikel referenziert. beim Artikel werden auch die konkreten Preise hinterlegt.

Für die Preisvariantengruppe bzw. für Artikel gelten folgende Regelungen:
- Ein preisgruppenneutraler Artikel hat keine Varianten.
- Preisgruppenabhängige Artikel haben die Variantenart 1 (Programm), die in FEATURE_NO_1 eingetragen werden muss, und optional die Variantenarten 101 (Frontfarbe 1) oder 105 (Frontkombination). Falls bei mindestens einer Preisfindung die Variantenart 101 oder 105 im Element FINISH/OPTION_REF angegeben wird, soll der entsprechende Wert in FEATURE_NO_2 eingetragen werden.
- Ausführungsabhängige Artikel haben ein oder zwei Variantenarten.
- Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0)

Es dürfen nicht mehrere Preisvariantengruppen mit der selben Kombination von Variantenarten angelegt werden. Beispielsweise sollte eine Preisvariantengruppe mit der Variantenart Griffausführung nur einmal existieren und alles abbilden was mit Griffausführung zusammenhängt.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
Dieses Attribut ist ein Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis):
Wird eine Mehrpreisgruppe definiert (ADDITIONAL_PRICE=1), so darf über diese Mehrpreisgruppe kein "Preis auf Anfrage" gebildet werden. Bei einem Artikel, der diese Mehrpreisgruppe referenziert, darf das Element PRICE_ON_REQUEST (Pfad 1) nicht angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST 		D boolean
P
M
PRICE_CALC_METHOD required Restriction of xs:nonNegativeInteger
In diesem Attribut wird definiert nach welcher grundsätzlichen Methode der Preis berechnet wird.

Folgende Methoden sind möglich:

0 = Preis auf Anfrage;
1 = programmneutraler Preis;
2 = programmabhängiger Preis;
3 = ausführungsabhängiger Preis.

Eine PRICE_FEATURE_GROUP, in der das Attribut PRICE_CALC_METHOD den Wert 0 (Preis auf Anfrage) hat, darf nur 1x angelegt werden. 		D nonNegativeInteger
P
M [0:3]
FEATURE_NO_1 optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die erste Variantenart für die Preisfindung identifiziert.
Die in dem ersten Attribut OPTION_REF/FEATURE_NO angegebene Variantenart darf nicht von der im Attribut FEATURE_NO_1 angegebenen abweichen. 		D nonNegativeInteger
P
M [0:999]
FEATURE_NO_2 optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die zweite Variantenart für die Preisfindung identifiziert.
Die in dem zweiten Attribut OPTION_REF/FEATURE_NO angegebene Variantenart darf nicht von der im Attribut FEATURE_NO_2 angegebenen abweichen. 		D nonNegativeInteger
P
M [0:999]
Sequence
PRICE_FEATURE_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält Texte für Ausführungsgruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FINISH 0..∞
In diesem Element werden gültigen Variantenkombinationen Preisfelder (Preisfeld, Blockpreisfeld) und eine Herstellerpreisgruppe zugeordnet.

Wenn das Attribut PRICE_CALC_METHOD den Wert 0 hat (Preis auf Anfrage), darf das Element FINISH nicht angelegt werden.
Sequence
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Quelle
<xs:element name="PRICE_FEATURE_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>300--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                    <xs:annotation>
                      <xs:documentation>311--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>311--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>311--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>311--5--Preisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="SUPPLIER_PRICE_GROUP">
                    <xs:annotation>
                      <xs:documentation>311--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="10" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="ADDITIONAL_PRICE" use="required">
            <xs:annotation>
              <xs:documentation>300--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:boolean" />
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="PRICE_CALC_METHOD" use="required">
            <xs:annotation>
              <xs:documentation>300--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="3" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_NO_1">
            <xs:annotation>
              <xs:documentation>300--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_NO_2">
            <xs:annotation>
              <xs:documentation>300--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element : PRICE_FEATURE_GROUP Element
Beschreibung
In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

Eine Preisvariantengruppe wird vom Artikel referenziert. beim Artikel werden auch die konkreten Preise hinterlegt.

Für die Preisvariantengruppe bzw. für Artikel gelten folgende Regelungen:
- Ein preisgruppenneutraler Artikel hat keine Varianten.
- Preisgruppenabhängige Artikel haben die Variantenart 1 (Programm), die in FEATURE_NO_1 eingetragen werden muss, und optional die Variantenarten 101 (Frontfarbe 1) oder 105 (Frontkombination). Falls bei mindestens einer Preisfindung die Variantenart 101 oder 105 im Element FINISH/OPTION_REF angegeben wird, soll der entsprechende Wert in FEATURE_NO_2 eingetragen werden.
- Ausführungsabhängige Artikel haben ein oder zwei Variantenarten.
- Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0)

Es dürfen nicht mehrere Preisvariantengruppen mit der selben Kombination von Variantenarten angelegt werden. Beispielsweise sollte eine Preisvariantengruppe mit der Variantenart Griffausführung nur einmal existieren und alles abbilden was mit Griffausführung zusammenhängt.
Namensraum (none)
Diagramm
FINISH Element LANGUAGE Element Sequence PRICE_FEATURE_GROUP_TEXT Element Sequence PRICE_FEATURE_GROUP Element
Overview
PRICE_FEATURE_GROUP 1..∞
In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

Eine Preisvariantengruppe wird vom Artikel referenziert. beim Artikel werden auch die konkreten Preise hinterlegt.

Für die Preisvariantengruppe bzw. für Artikel gelten folgende Regelungen:
- Ein preisgruppenneutraler Artikel hat keine Varianten.
- Preisgruppenabhängige Artikel haben die Variantenart 1 (Programm), die in FEATURE_NO_1 eingetragen werden muss, und optional die Variantenarten 101 (Frontfarbe 1) oder 105 (Frontkombination). Falls bei mindestens einer Preisfindung die Variantenart 101 oder 105 im Element FINISH/OPTION_REF angegeben wird, soll der entsprechende Wert in FEATURE_NO_2 eingetragen werden.
- Ausführungsabhängige Artikel haben ein oder zwei Variantenarten.
- Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0)

Es dürfen nicht mehrere Preisvariantengruppen mit der selben Kombination von Variantenarten angelegt werden. Beispielsweise sollte eine Preisvariantengruppe mit der Variantenart Griffausführung nur einmal existieren und alles abbilden was mit Griffausführung zusammenhängt.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
Dieses Attribut ist ein Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis):
Wird eine Mehrpreisgruppe definiert (ADDITIONAL_PRICE=1), so darf über diese Mehrpreisgruppe kein "Preis auf Anfrage" gebildet werden. Bei einem Artikel, der diese Mehrpreisgruppe referenziert, darf das Element PRICE_ON_REQUEST (Pfad 1) nicht angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST 		D boolean
P
M
PRICE_CALC_METHOD required Restriction of xs:nonNegativeInteger
In diesem Attribut wird definiert nach welcher grundsätzlichen Methode der Preis berechnet wird.

Folgende Methoden sind möglich:

0 = Preis auf Anfrage;
1 = programmneutraler Preis;
2 = programmabhängiger Preis;
3 = ausführungsabhängiger Preis.

Eine PRICE_FEATURE_GROUP, in der das Attribut PRICE_CALC_METHOD den Wert 0 (Preis auf Anfrage) hat, darf nur 1x angelegt werden. 		D nonNegativeInteger
P
M [0:3]
FEATURE_NO_1 optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die erste Variantenart für die Preisfindung identifiziert.
Die in dem ersten Attribut OPTION_REF/FEATURE_NO angegebene Variantenart darf nicht von der im Attribut FEATURE_NO_1 angegebenen abweichen. 		D nonNegativeInteger
P
M [0:999]
FEATURE_NO_2 optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die zweite Variantenart für die Preisfindung identifiziert.
Die in dem zweiten Attribut OPTION_REF/FEATURE_NO angegebene Variantenart darf nicht von der im Attribut FEATURE_NO_2 angegebenen abweichen. 		D nonNegativeInteger
P
M [0:999]
Sequence
PRICE_FEATURE_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält Texte für Ausführungsgruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FINISH 0..∞
In diesem Element werden gültigen Variantenkombinationen Preisfelder (Preisfeld, Blockpreisfeld) und eine Herstellerpreisgruppe zugeordnet.

Wenn das Attribut PRICE_CALC_METHOD den Wert 0 hat (Preis auf Anfrage), darf das Element FINISH nicht angelegt werden.
Sequence
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
ADDITIONAL_PRICE Restriction of xs:boolean required
Dieses Attribut ist ein Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis):
Wird eine Mehrpreisgruppe definiert (ADDITIONAL_PRICE=1), so darf über diese Mehrpreisgruppe kein "Preis auf Anfrage" gebildet werden. Bei einem Artikel, der diese Mehrpreisgruppe referenziert, darf das Element PRICE_ON_REQUEST (Pfad 1) nicht angelegt werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST 		D boolean
P
M
PRICE_CALC_METHOD Restriction of xs:nonNegativeInteger required
In diesem Attribut wird definiert nach welcher grundsätzlichen Methode der Preis berechnet wird.

Folgende Methoden sind möglich:

0 = Preis auf Anfrage;
1 = programmneutraler Preis;
2 = programmabhängiger Preis;
3 = ausführungsabhängiger Preis.

Eine PRICE_FEATURE_GROUP, in der das Attribut PRICE_CALC_METHOD den Wert 0 (Preis auf Anfrage) hat, darf nur 1x angelegt werden. 		D nonNegativeInteger
P
M [0:3]
FEATURE_NO_1 Restriction of xs:nonNegativeInteger optional
Mit diesem Attribut wird die erste Variantenart für die Preisfindung identifiziert.
Die in dem ersten Attribut OPTION_REF/FEATURE_NO angegebene Variantenart darf nicht von der im Attribut FEATURE_NO_1 angegebenen abweichen. 		D nonNegativeInteger
P
M [0:999]
FEATURE_NO_2 Restriction of xs:nonNegativeInteger optional
Mit diesem Attribut wird die zweite Variantenart für die Preisfindung identifiziert.
Die in dem zweiten Attribut OPTION_REF/FEATURE_NO angegebene Variantenart darf nicht von der im Attribut FEATURE_NO_2 angegebenen abweichen. 		D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>300--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>311--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>311--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>311--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>311--5--Preisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="SUPPLIER_PRICE_GROUP">
              <xs:annotation>
                <xs:documentation>311--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="ADDITIONAL_PRICE" use="required">
      <xs:annotation>
        <xs:documentation>300--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:boolean" />
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="PRICE_CALC_METHOD" use="required">
      <xs:annotation>
        <xs:documentation>300--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_NO_1">
      <xs:annotation>
        <xs:documentation>300--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_NO_2">
      <xs:annotation>
        <xs:documentation>300--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : PRICE_FEATURE_GROUP_TEXT Element
Beschreibung
Dieses Element enthält Texte für Ausführungsgruppen.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence PRICE_FEATURE_GROUP_TEXT Element
Overview
PRICE_FEATURE_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält Texte für Ausführungsgruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FINISH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : FINISH Element
Beschreibung
In diesem Element werden gültigen Variantenkombinationen Preisfelder (Preisfeld, Blockpreisfeld) und eine Herstellerpreisgruppe zugeordnet.

Wenn das Attribut PRICE_CALC_METHOD den Wert 0 hat (Preis auf Anfrage), darf das Element FINISH nicht angelegt werden.
Namensraum (none)
Diagramm
SUPPLIER_PRICE_GROUP Element BLOCK_PRICE_FIELD Element PRICE_FIELD Element OPTION_REF Element Sequence FINISH Element
Overview
FINISH 0..∞
In diesem Element werden gültigen Variantenkombinationen Preisfelder (Preisfeld, Blockpreisfeld) und eine Herstellerpreisgruppe zugeordnet.

Wenn das Attribut PRICE_CALC_METHOD den Wert 0 hat (Preis auf Anfrage), darf das Element FINISH nicht angelegt werden.
Sequence
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Quelle
<xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>311--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>311--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>311--5--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SUPPLIER_PRICE_GROUP">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : OPTION_REF Element
Beschreibung
Mit diesem Element wird eine Variante referenziert.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>311--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>311--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FIELD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : PRICE_FIELD Element
Beschreibung

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
Quelle
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--5--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_PRICE_FIELD Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : BLOCK_PRICE_FIELD Element
Beschreibung

Dieses Feld gibt an, in welchem Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

 D nonNegativeInteger
P
M [1:250]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_PRICE_FIELD Element
Overview
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

 D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="BLOCK_PRICE_FIELD" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUPPLIER_PRICE_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : SUPPLIER_PRICE_GROUP Element
Beschreibung
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
SUPPLIER_PRICE_GROUP Element
Overview
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Quelle
<xs:element name="SUPPLIER_PRICE_GROUP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SET_OF_EXCHANGE_IDS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : SET_OF_EXCHANGE_IDS Element
Beschreibung
In diesem Element werden die herstellerspezifischen Tausch-IDs definiert.

Liefert ein Hersteller Blöcke, so muss dieses Element in der Katalogdatei enthalten sein. Das Element muss auch dann in der Katalogdatei enthalten sein, wenn ein Hersteller außerhalb der Katalogdatei, zu einem späteren Zeitpunkt Blöcke liefert. Das Element darf in einer Blockdatei nicht enthalten sein.
Namensraum (none)
Diagramm
EXCHANGE_ID Element Sequence SET_OF_EXCHANGE_IDS Element
Overview
SET_OF_EXCHANGE_IDS optional
In diesem Element werden die herstellerspezifischen Tausch-IDs definiert.

Liefert ein Hersteller Blöcke, so muss dieses Element in der Katalogdatei enthalten sein. Das Element muss auch dann in der Katalogdatei enthalten sein, wenn ein Hersteller außerhalb der Katalogdatei, zu einem späteren Zeitpunkt Blöcke liefert. Das Element darf in einer Blockdatei nicht enthalten sein.
Sequence
EXCHANGE_ID 1..∞
Das Element EXCHANGE_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS verwendet werden.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Sequence
EXCHANGE_ID_TEXT languagetexte40 Complex Type
Der Text in diesem Element erläutert die Tauschgruppen, beispielsweise:
- Möbelteile
- Arbeitsplatten
- Lichtblenden/Kranzprofile
- Zubehör
- Elektrogeräte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="SET_OF_EXCHANGE_IDS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>115--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>115--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_TEXT" type="languagetexte40">
              <xs:annotation>
                <xs:documentation>115--3--Tausch_ID_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>115--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > SET_OF_EXCHANGE_IDS Element : EXCHANGE_ID Element
Beschreibung
Das Element EXCHANGE_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS verwendet werden.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence EXCHANGE_ID_TEXT Element Sequence EXCHANGE_ID Element
Overview
EXCHANGE_ID 1..∞
Das Element EXCHANGE_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS verwendet werden.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Sequence
EXCHANGE_ID_TEXT languagetexte40 Complex Type
Der Text in diesem Element erläutert die Tauschgruppen, beispielsweise:
- Möbelteile
- Arbeitsplatten
- Lichtblenden/Kranzprofile
- Zubehör
- Elektrogeräte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
Das Attribut dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Quelle
<xs:element name="EXCHANGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>115--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_TEXT" type="languagetexte40">
        <xs:annotation>
          <xs:documentation>115--3--Tausch_ID_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>115--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_OF_EXCHANGE_IDS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > SET_OF_EXCHANGE_IDS Element > EXCHANGE_ID Element : EXCHANGE_ID_TEXT Element
Beschreibung
Der Text in diesem Element erläutert die Tauschgruppen, beispielsweise:
- Möbelteile
- Arbeitsplatten
- Lichtblenden/Kranzprofile
- Zubehör
- Elektrogeräte.
Namensraum (none)
Typ
languagetexte40 Complex Type
Diagramm
LANGUAGE Element Sequence EXCHANGE_ID_TEXT Element
Overview
EXCHANGE_ID_TEXT languagetexte40 Complex Type
Der Text in diesem Element erläutert die Tauschgruppen, beispielsweise:
- Möbelteile
- Arbeitsplatten
- Lichtblenden/Kranzprofile
- Zubehör
- Elektrogeräte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="EXCHANGE_ID_TEXT" type="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>115--3--Tausch_ID_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
EXCHANGE_ID Element | SET_OF_EXCHANGE_IDS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_ADDED_TAXES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : VALUE_ADDED_TAXES Element
Beschreibung
In diesem Element werden die gültigen Mehrwertsteuersätze definiert, die von Artikeln referenziert werden. Die angegebenen Steuersätze müssen mit dem angegebenen Land korrespondieren, welches im Element COUNTRY_ID (Pfad 1) angegeben wurde.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION
Namensraum (none)
Diagramm
VALUE_ADDED_TAX Element Sequence VALUE_ADDED_TAXES Element
Overview
VALUE_ADDED_TAXES
In diesem Element werden die gültigen Mehrwertsteuersätze definiert, die von Artikeln referenziert werden. Die angegebenen Steuersätze müssen mit dem angegebenen Land korrespondieren, welches im Element COUNTRY_ID (Pfad 1) angegeben wurde.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION
Sequence
VALUE_ADDED_TAX 1..100
In diesem Element wird ein Mehrwertsteuersatz definiert.
VAT_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine ID für einen Mehrwertsteuersatz hinterlegt. Die ID 0 ist für Artikel reserviert, die keiner Mehrwertsteuer unterliegen. D nonNegativeInteger
P
M [0:99]
Sequence
VAT_RATE Restriction of xs:nonNegativeInteger
In diesem Element wird der zugehörige Mehrwertsteuersatz in Prozent inklusive zwei Nachkommastellen angegeben (z. B. 1600 für 16,00 % oder 10 für 0,1%). D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="VALUE_ADDED_TAXES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>360--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="VALUE_ADDED_TAX" maxOccurs="100">
        <xs:annotation>
          <xs:documentation>360--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="VAT_RATE">
              <xs:annotation>
                <xs:documentation>360--3--MwSt_Satz</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="VAT_NO" use="required">
            <xs:annotation>
              <xs:documentation>360--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_ADDED_TAX Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > VALUE_ADDED_TAXES Element : VALUE_ADDED_TAX Element
Beschreibung
In diesem Element wird ein Mehrwertsteuersatz definiert.
Namensraum (none)
Diagramm
VAT_RATE Element Sequence VALUE_ADDED_TAX Element
Overview
VALUE_ADDED_TAX 1..100
In diesem Element wird ein Mehrwertsteuersatz definiert.
VAT_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine ID für einen Mehrwertsteuersatz hinterlegt. Die ID 0 ist für Artikel reserviert, die keiner Mehrwertsteuer unterliegen. D nonNegativeInteger
P
M [0:99]
Sequence
VAT_RATE Restriction of xs:nonNegativeInteger
In diesem Element wird der zugehörige Mehrwertsteuersatz in Prozent inklusive zwei Nachkommastellen angegeben (z. B. 1600 für 16,00 % oder 10 für 0,1%). D nonNegativeInteger
P
M [0:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
VAT_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird eine ID für einen Mehrwertsteuersatz hinterlegt. Die ID 0 ist für Artikel reserviert, die keiner Mehrwertsteuer unterliegen. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="VALUE_ADDED_TAX" maxOccurs="100" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>360--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="VAT_RATE">
        <xs:annotation>
          <xs:documentation>360--3--MwSt_Satz</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="VAT_NO" use="required">
      <xs:annotation>
        <xs:documentation>360--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
VALUE_ADDED_TAXES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VAT_RATE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > VALUE_ADDED_TAXES Element > VALUE_ADDED_TAX Element : VAT_RATE Element
Beschreibung
In diesem Element wird der zugehörige Mehrwertsteuersatz in Prozent inklusive zwei Nachkommastellen angegeben (z. B. 1600 für 16,00 % oder 10 für 0,1%). D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
VAT_RATE Element
Overview
VAT_RATE Restriction of xs:nonNegativeInteger
In diesem Element wird der zugehörige Mehrwertsteuersatz in Prozent inklusive zwei Nachkommastellen angegeben (z. B. 1600 für 16,00 % oder 10 für 0,1%). D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="VAT_RATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>360--3--MwSt_Satz</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
VALUE_ADDED_TAX Element | VALUE_ADDED_TAXES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

IDENT_NUMBERS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : IDENT_NUMBERS Element
Beschreibung
In diesem Element werden die Identnummern definiert. Alle im Datenbestand verwendeten Identnummern müssen hier definiert werden.
Namensraum (none)
Diagramm
IDENT_NUMBER Element Sequence IDENT_NUMBERS Element
Overview
IDENT_NUMBERS optional
In diesem Element werden die Identnummern definiert. Alle im Datenbestand verwendeten Identnummern müssen hier definiert werden.
Sequence
IDENT_NUMBER 0..9999
In diesem Element werden die Identnummern definiert. Alle im Datenbestand verwendeten Identnummern müssen hier definiert werden.
IDENT_NO required Restriction of xs:positiveInteger
In diesem Attribut wird eine Identnummer definiert. D positiveInteger
P
M [1:9999]
Sequence
SERIE_REF 1..99
Das Element referenziert eine Serie. Wird keine Serie referenziert, sind die angegebenen Identnummern serienübergreifend gültig.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden -> -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="IDENT_NUMBERS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>351--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="IDENT_NUMBER" minOccurs="0" maxOccurs="9999">
        <xs:annotation>
          <xs:documentation>351--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE_REF" maxOccurs="99">
              <xs:annotation>
                <xs:documentation>351--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>351--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>351--4--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="IDENT_NO" use="required">
            <xs:annotation>
              <xs:documentation>351--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

IDENT_NUMBER Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > IDENT_NUMBERS Element : IDENT_NUMBER Element
Beschreibung
In diesem Element werden die Identnummern definiert. Alle im Datenbestand verwendeten Identnummern müssen hier definiert werden.
Namensraum (none)
Diagramm
PRICE Element SERIE_REF Element Sequence IDENT_NUMBER Element
Overview
IDENT_NUMBER 0..9999
In diesem Element werden die Identnummern definiert. Alle im Datenbestand verwendeten Identnummern müssen hier definiert werden.
IDENT_NO required Restriction of xs:positiveInteger
In diesem Attribut wird eine Identnummer definiert. D positiveInteger
P
M [1:9999]
Sequence
SERIE_REF 1..99
Das Element referenziert eine Serie. Wird keine Serie referenziert, sind die angegebenen Identnummern serienübergreifend gültig.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden -> -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
IDENT_NO Restriction of xs:positiveInteger required
In diesem Attribut wird eine Identnummer definiert. D positiveInteger
P
M [1:9999]
Quelle
<xs:element name="IDENT_NUMBER" minOccurs="0" maxOccurs="9999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>351--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE_REF" maxOccurs="99">
        <xs:annotation>
          <xs:documentation>351--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>351--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>351--4--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="IDENT_NO" use="required">
      <xs:annotation>
        <xs:documentation>351--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
IDENT_NUMBERS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIE_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > IDENT_NUMBERS Element > IDENT_NUMBER Element : SERIE_REF Element
Beschreibung
Das Element referenziert eine Serie. Wird keine Serie referenziert, sind die angegebenen Identnummern serienübergreifend gültig.
Namensraum (none)
Diagramm
SERIE_REF Element
Overview
SERIE_REF 1..99
Das Element referenziert eine Serie. Wird keine Serie referenziert, sind die angegebenen Identnummern serienübergreifend gültig.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="SERIE_REF" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>351--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>351--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
IDENT_NUMBER Element | IDENT_NUMBERS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > IDENT_NUMBERS Element > IDENT_NUMBER Element : PRICE Element
Beschreibung
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden -> -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D nonNegativeInteger
P
M [0:99]
Namensraum (none)
Typ
Restriction of xs:integer
Diagramm
PRICE Element
Overview
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden -> -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>351--4--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
IDENT_NUMBER Element | IDENT_NUMBERS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MERCHANDISE_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : MERCHANDISE_GROUP Element
Beschreibung
Mit diesem Element wird eine Warengruppe angelegt. Die Warengruppe (Konditionsschiene des Herstellers) sowie der dazugehörige Text müssen mit dem Konditionsblatt des Herstellers übereinstimmen. Einer Warengruppe werden 1-n Kalkulationsgruppen zugeordnet.
Namensraum (none)
Diagramm
CALC_GROUP Element Sequence LANGUAGE Element Sequence MERCHANDISE_GROUP_TEXT Element Sequence MERCHANDISE_GROUP Element
Overview
MERCHANDISE_GROUP 1..∞
Mit diesem Element wird eine Warengruppe angelegt. Die Warengruppe (Konditionsschiene des Herstellers) sowie der dazugehörige Text müssen mit dem Konditionsblatt des Herstellers übereinstimmen. Einer Warengruppe werden 1-n Kalkulationsgruppen zugeordnet.
MERCHANDISE_GROUP_NO required Restriction of xs:string
Mit diesem Attribut wird eine Warengruppe identifiziert. D string
P
M [1:5]
Sequence
MERCHANDISE_GROUP_TEXT languagetexte30 Complex Type
Dieses Element enthält Texte für Warengruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Sequence
CALC_GROUP 1..∞

In diesem Element werden die möglichen Kalkulationsgruppen definiert. Die Verwendung kann beispielsweise für unterschiedliche Rabattierungen sinnvoll sein. Dies bedeutet, dass je nach Anzahl der Rabattstaffelungen hier entsprechend viele Kalkulationsgruppen gebildet werden können. Im Element ITEM werden die Artikel einer Kalkulationsgruppe zugeordnet. Es dürfen nur Kalkulationsgruppen definiert werden, die von Artikeln referenziert werden. Schlüssel ist das Feld CALC_GROUP_NO.

Bei der Nutzung derselben Kalkulationsgruppe wird auch die gleiche Preisfindung verwendet.

Eine Kalkulationsgruppe kann innerhalb aller Elemente MERCHANDISE_GROUP nur ein Mal verwendet werden. Das heiß, das eine Kalkulationsgruppe nur in einer einzigen MERCHANDISE_GROUP verwendet werden darf und nicht in mehreren MERCHANDISE_GROUP's.

Die Kalkulationsgruppe wird über das Attribut CALC_GROUP_NO angegeben.

CALC_GROUP_NO required Restriction of xs:positiveInteger

Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination "00" ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
8 = diverses 1
9 = diverses 2

Einstellige Zahlen 0 – 9 sind ausgeschlossen, d.h. führende Nullen sind nicht erlaubt.

Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers.

 D positiveInteger
P
M [10:99]
Sequence
CALC_GROUP_TEXT languagetexte30 Complex Type
Dieses Element enthält Texte für Kalkulationsgruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
CALCULATION_FACTOR optional Restriction of xs:nonNegativeInteger
Dieses Element darf nur verwendet werden, wenn das Element PRICE_ID (Pfad 1) den Wert 3 hat.

Wenn Verrechnungspunkte verwendet werden, so muss in diesem Element der entsprechende Verrechnungsfaktor angegeben werden.
Der Verrechnungfaktor wird mit maximal fünf Vorkommastellen und genau drei Nachkommastellen (ohne das Komma selbst) eingetragen. Der Verrechnungsfaktor muss größer Null sein.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION 		D nonNegativeInteger
P
M [1:99999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MERCHANDISE_GROUP_NO Restriction of xs:string required
Mit diesem Attribut wird eine Warengruppe identifiziert. D string
P
M [1:5]
Quelle
<xs:element name="MERCHANDISE_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>350--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MERCHANDISE_GROUP_TEXT" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>350--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>350--6--Warengruppentext</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:sequence>
        <xs:element name="CALC_GROUP" maxOccurs="unbounded">
          <xs:annotation>
            <xs:documentation>350--1--Satzart</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="CALC_GROUP_TEXT" type="languagetexte30">
                <xs:annotation>
                  <xs:documentation>350--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
              </xs:element>
              <xs:element name="CALCULATION_FACTOR" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>350--4--Verrechnungsfaktor</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="99999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="CALC_GROUP_NO" use="required">
              <xs:annotation>
                <xs:documentation>350--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="10" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:sequence>
    <xs:attribute name="MERCHANDISE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>350--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MERCHANDISE_GROUP_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > MERCHANDISE_GROUP Element : MERCHANDISE_GROUP_TEXT Element
Beschreibung
Dieses Element enthält Texte für Warengruppen.
Namensraum (none)
Typ
languagetexte30 Complex Type
Diagramm
LANGUAGE Element Sequence MERCHANDISE_GROUP_TEXT Element
Overview
MERCHANDISE_GROUP_TEXT languagetexte30 Complex Type
Dieses Element enthält Texte für Warengruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="MERCHANDISE_GROUP_TEXT" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>350--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>350--6--Warengruppentext</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
MERCHANDISE_GROUP Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CALC_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > MERCHANDISE_GROUP Element : CALC_GROUP Element
Beschreibung

In diesem Element werden die möglichen Kalkulationsgruppen definiert. Die Verwendung kann beispielsweise für unterschiedliche Rabattierungen sinnvoll sein. Dies bedeutet, dass je nach Anzahl der Rabattstaffelungen hier entsprechend viele Kalkulationsgruppen gebildet werden können. Im Element ITEM werden die Artikel einer Kalkulationsgruppe zugeordnet. Es dürfen nur Kalkulationsgruppen definiert werden, die von Artikeln referenziert werden. Schlüssel ist das Feld CALC_GROUP_NO.

Bei der Nutzung derselben Kalkulationsgruppe wird auch die gleiche Preisfindung verwendet.

Eine Kalkulationsgruppe kann innerhalb aller Elemente MERCHANDISE_GROUP nur ein Mal verwendet werden. Das heiß, das eine Kalkulationsgruppe nur in einer einzigen MERCHANDISE_GROUP verwendet werden darf und nicht in mehreren MERCHANDISE_GROUP's.

Die Kalkulationsgruppe wird über das Attribut CALC_GROUP_NO angegeben.

Namensraum (none)
Diagramm
CALCULATION_FACTOR Element LANGUAGE Element Sequence CALC_GROUP_TEXT Element Sequence CALC_GROUP Element
Overview
CALC_GROUP 1..∞

In diesem Element werden die möglichen Kalkulationsgruppen definiert. Die Verwendung kann beispielsweise für unterschiedliche Rabattierungen sinnvoll sein. Dies bedeutet, dass je nach Anzahl der Rabattstaffelungen hier entsprechend viele Kalkulationsgruppen gebildet werden können. Im Element ITEM werden die Artikel einer Kalkulationsgruppe zugeordnet. Es dürfen nur Kalkulationsgruppen definiert werden, die von Artikeln referenziert werden. Schlüssel ist das Feld CALC_GROUP_NO.

Bei der Nutzung derselben Kalkulationsgruppe wird auch die gleiche Preisfindung verwendet.

Eine Kalkulationsgruppe kann innerhalb aller Elemente MERCHANDISE_GROUP nur ein Mal verwendet werden. Das heiß, das eine Kalkulationsgruppe nur in einer einzigen MERCHANDISE_GROUP verwendet werden darf und nicht in mehreren MERCHANDISE_GROUP's.

Die Kalkulationsgruppe wird über das Attribut CALC_GROUP_NO angegeben.

CALC_GROUP_NO required Restriction of xs:positiveInteger

Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination "00" ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
8 = diverses 1
9 = diverses 2

Einstellige Zahlen 0 – 9 sind ausgeschlossen, d.h. führende Nullen sind nicht erlaubt.

Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers.

 D positiveInteger
P
M [10:99]
Sequence
CALC_GROUP_TEXT languagetexte30 Complex Type
Dieses Element enthält Texte für Kalkulationsgruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
CALCULATION_FACTOR optional Restriction of xs:nonNegativeInteger
Dieses Element darf nur verwendet werden, wenn das Element PRICE_ID (Pfad 1) den Wert 3 hat.

Wenn Verrechnungspunkte verwendet werden, so muss in diesem Element der entsprechende Verrechnungsfaktor angegeben werden.
Der Verrechnungfaktor wird mit maximal fünf Vorkommastellen und genau drei Nachkommastellen (ohne das Komma selbst) eingetragen. Der Verrechnungsfaktor muss größer Null sein.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION 		D nonNegativeInteger
P
M [1:99999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
CALC_GROUP_NO Restriction of xs:positiveInteger required

Dieses Element ist ein zweistelliger Schlüssel, der durch die nachfolgenden Kalkulationskennzeichen je nach Kalkulationsart wahlweise kombiniert werden kann. Die erste Stelle wird nach dem unten aufgeführten Schlüssel gesetzt. Die zweite Stelle ist frei definierbar. Die Kombination "00" ist nicht erlaubt.
Erste Stelle:
0 = keine Zuordnung;
1 = Möbelteile;
2 = Arbeitsplatten;
3 = Spülen;
4 = Elektrogeräte;
5 = allgemeines Zubehör;
6 = Handelsware;
7 = Blöcke / Mehrausstattungen.
8 = diverses 1
9 = diverses 2

Einstellige Zahlen 0 – 9 sind ausgeschlossen, d.h. führende Nullen sind nicht erlaubt.

Die Kalkulationsgruppe entspricht nicht der Konditionsschiene des Herstellers.

 D positiveInteger
P
M [10:99]
Quelle
<xs:element name="CALC_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>350--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CALC_GROUP_TEXT" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>350--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CALCULATION_FACTOR" minOccurs="0">
        <xs:annotation>
          <xs:documentation>350--4--Verrechnungsfaktor</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="CALC_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>350--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="10" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MERCHANDISE_GROUP Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CALC_GROUP_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > MERCHANDISE_GROUP Element > CALC_GROUP Element : CALC_GROUP_TEXT Element
Beschreibung
Dieses Element enthält Texte für Kalkulationsgruppen.
Namensraum (none)
Typ
languagetexte30 Complex Type
Diagramm
LANGUAGE Element Sequence CALC_GROUP_TEXT Element
Overview
CALC_GROUP_TEXT languagetexte30 Complex Type
Dieses Element enthält Texte für Kalkulationsgruppen.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="CALC_GROUP_TEXT" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>350--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CALC_GROUP Element | MERCHANDISE_GROUP Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CALCULATION_FACTOR Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > MERCHANDISE_GROUP Element > CALC_GROUP Element : CALCULATION_FACTOR Element
Beschreibung
Dieses Element darf nur verwendet werden, wenn das Element PRICE_ID (Pfad 1) den Wert 3 hat.

Wenn Verrechnungspunkte verwendet werden, so muss in diesem Element der entsprechende Verrechnungsfaktor angegeben werden.
Der Verrechnungfaktor wird mit maximal fünf Vorkommastellen und genau drei Nachkommastellen (ohne das Komma selbst) eingetragen. Der Verrechnungsfaktor muss größer Null sein.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION 		D nonNegativeInteger
P
M [1:99999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
CALCULATION_FACTOR Element
Overview
CALCULATION_FACTOR optional Restriction of xs:nonNegativeInteger
Dieses Element darf nur verwendet werden, wenn das Element PRICE_ID (Pfad 1) den Wert 3 hat.

Wenn Verrechnungspunkte verwendet werden, so muss in diesem Element der entsprechende Verrechnungsfaktor angegeben werden.
Der Verrechnungfaktor wird mit maximal fünf Vorkommastellen und genau drei Nachkommastellen (ohne das Komma selbst) eingetragen. Der Verrechnungsfaktor muss größer Null sein.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION 		D nonNegativeInteger
P
M [1:99999999]
Quelle
<xs:element name="CALCULATION_FACTOR" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>350--4--Verrechnungsfaktor</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CALC_GROUP Element | MERCHANDISE_GROUP Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element : PRICE_TYPES Element
Beschreibung
In diesem Element werden die Preisarten zur stück- oder maßvariablen Berechnung von programmneutralen und programmabhängigen Artikeln definiert.
Die Kind-Elemente WIDTH_X, DEPTH_Y, HEIGHT_Z geben an, ob der Preis für einen Artikel, der nach dieser Preisart berechnet wird, breiten-, höhen-, tiefen-, flächen- bzw. volumenabhängig ist.
Wenn für keine Dimension eine "1" angegeben ist, ist der Preis nicht maßabhängig, wird also per Stück berechnet (beispielsweise ein Unterschrank). Dann werden die Elemente BASIC_UNIT und ROUNDING_UNIT mit dem Wert 0 belegt.
Wird für genau eine Dimension eine "1" angegeben, so wird diese Dimension für die Preisberechnung herangezogen (beispielsweise Lichtleisten).
Wenn für genau zwei Dimensionen eine "1" angegeben ist, so ist der Preis flächenabhängig (beispielsweise Verkleidungsmaterial).
Wenn für genau drei Dimensionen eine "1" angegeben ist, so ist der Preis volumenabhängig (beispielsweise Lacke, Beizen).
Namensraum (none)
Diagramm
PRICE_TYPE Element Sequence PRICE_TYPES Element
Overview
PRICE_TYPES
In diesem Element werden die Preisarten zur stück- oder maßvariablen Berechnung von programmneutralen und programmabhängigen Artikeln definiert.
Die Kind-Elemente WIDTH_X, DEPTH_Y, HEIGHT_Z geben an, ob der Preis für einen Artikel, der nach dieser Preisart berechnet wird, breiten-, höhen-, tiefen-, flächen- bzw. volumenabhängig ist.
Wenn für keine Dimension eine "1" angegeben ist, ist der Preis nicht maßabhängig, wird also per Stück berechnet (beispielsweise ein Unterschrank). Dann werden die Elemente BASIC_UNIT und ROUNDING_UNIT mit dem Wert 0 belegt.
Wird für genau eine Dimension eine "1" angegeben, so wird diese Dimension für die Preisberechnung herangezogen (beispielsweise Lichtleisten).
Wenn für genau zwei Dimensionen eine "1" angegeben ist, so ist der Preis flächenabhängig (beispielsweise Verkleidungsmaterial).
Wenn für genau drei Dimensionen eine "1" angegeben ist, so ist der Preis volumenabhängig (beispielsweise Lacke, Beizen).
Sequence 1..∞
PRICE_TYPE
In diesem Element wird eine Preisart definiert.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (Pfad1) und ADDITIONAL_PRICE (Pfad2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in diesem Element "1000" anzugeben, bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³]. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein.

Pfad1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
Pfad2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein. D nonNegativeInteger
P
M [0:999999999999]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean
Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben, der sich auf die im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis unter Berücksichtigung der im Element definierten Logik zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet. 		D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_X (Pfad1) (b), DEPTH_Y (Pfad1) (t) oder HEIGHT_Z (Pfad1) (h) auf true gesetzt werden;
- es können die Grundrechenarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (Pfad1), ROUNDING_UNIT (Pfad1) und BASIC_PRICE_DEPENDENT (Pfad1) gelten auch in Verbindung mit der Preisartformel

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetexte60 Complex Type
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="PRICE_TYPES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element name="PRICE_TYPE">
        <xs:annotation>
          <xs:documentation>150--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="WIDTH_X">
              <xs:annotation>
                <xs:documentation>150--3--Breite_X</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPTH_Y">
              <xs:annotation>
                <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEIGHT_Z">
              <xs:annotation>
                <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_UNIT">
              <xs:annotation>
                <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ROUNDING_UNIT">
              <xs:annotation>
                <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_PRICE_DEPENDENT">
              <xs:annotation>
                <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
              <xs:annotation>
                <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="100" />
                  <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_TYPE_NAME" type="languagetexte60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="250" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element : PRICE_TYPE Element
Beschreibung
In diesem Element wird eine Preisart definiert.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence PRICE_TYPE_NAME Element PRICE_TYPE_FORMULA Element BASIC_PRICE_DEPENDENT Element ROUNDING_UNIT Element BASIC_UNIT Element HEIGHT_Z Element DEPTH_Y Element WIDTH_X Element Sequence PRICE_TYPE Element
Overview
PRICE_TYPE
In diesem Element wird eine Preisart definiert.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (Pfad1) und ADDITIONAL_PRICE (Pfad2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in diesem Element "1000" anzugeben, bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³]. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein.

Pfad1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
Pfad2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein. D nonNegativeInteger
P
M [0:999999999999]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean
Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben, der sich auf die im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis unter Berücksichtigung der im Element definierten Logik zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet. 		D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_X (Pfad1) (b), DEPTH_Y (Pfad1) (t) oder HEIGHT_Z (Pfad1) (h) auf true gesetzt werden;
- es können die Grundrechenarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (Pfad1), ROUNDING_UNIT (Pfad1) und BASIC_PRICE_DEPENDENT (Pfad1) gelten auch in Verbindung mit der Preisartformel

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetexte60 Complex Type
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_TYPE_NO Restriction of xs:positiveInteger required
Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert. D positiveInteger
P
M [1:250]
Quelle
<xs:element name="PRICE_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="WIDTH_X">
        <xs:annotation>
          <xs:documentation>150--3--Breite_X</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPTH_Y">
        <xs:annotation>
          <xs:documentation>150--4--Tiefe_Y</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_Z">
        <xs:annotation>
          <xs:documentation>150--5--Hoehe_Z</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_UNIT">
        <xs:annotation>
          <xs:documentation>150--6--Basis_Einheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ROUNDING_UNIT">
        <xs:annotation>
          <xs:documentation>150--7--Rundungseinheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_PRICE_DEPENDENT">
        <xs:annotation>
          <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
        <xs:annotation>
          <xs:documentation>150--9--Preisart_Formel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="100" />
            <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_TYPE_NAME" type="languagetexte60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="250" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

WIDTH_X Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : WIDTH_X Element
Beschreibung
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
WIDTH_X Element
Overview
WIDTH_X Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Quelle
<xs:element name="WIDTH_X" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--3--Breite_X</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DEPTH_Y Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : DEPTH_Y Element
Beschreibung
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
DEPTH_Y Element
Overview
DEPTH_Y Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Quelle
<xs:element name="DEPTH_Y" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--4--Tiefe_Y</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

HEIGHT_Z Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : HEIGHT_Z Element
Beschreibung
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
HEIGHT_Z Element
Overview
HEIGHT_Z Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Quelle
<xs:element name="HEIGHT_Z" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--5--Hoehe_Z</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_UNIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : BASIC_UNIT Element
Beschreibung
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (Pfad1) und ADDITIONAL_PRICE (Pfad2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in diesem Element "1000" anzugeben, bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³]. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein.

Pfad1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
Pfad2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BASIC_UNIT Element
Overview
BASIC_UNIT Restriction of xs:nonNegativeInteger
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (Pfad1) und ADDITIONAL_PRICE (Pfad2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in diesem Element "1000" anzugeben, bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³]. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein.

Pfad1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
Pfad2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
Quelle
<xs:element name="BASIC_UNIT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--6--Basis_Einheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ROUNDING_UNIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : ROUNDING_UNIT Element
Beschreibung
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein. D nonNegativeInteger
P
M [0:999999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
ROUNDING_UNIT Element
Overview
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit „1“ angegeben, so muss in dieses Element eine „0“ eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich „0“ sein. D nonNegativeInteger
P
M [0:999999999999]
Quelle
<xs:element name="ROUNDING_UNIT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--7--Rundungseinheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BASIC_PRICE_DEPENDENT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : BASIC_PRICE_DEPENDENT Element
Beschreibung
Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben, der sich auf die im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis unter Berücksichtigung der im Element definierten Logik zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet. 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
BASIC_PRICE_DEPENDENT Element
Overview
BASIC_PRICE_DEPENDENT Restriction of xs:boolean
Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben, der sich auf die im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis unter Berücksichtigung der im Element definierten Logik zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet. 		D boolean
P
M
Quelle
<xs:element name="BASIC_PRICE_DEPENDENT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPE_FORMULA Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : PRICE_TYPE_FORMULA Element
Beschreibung
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_X (Pfad1) (b), DEPTH_Y (Pfad1) (t) oder HEIGHT_Z (Pfad1) (h) auf true gesetzt werden;
- es können die Grundrechenarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (Pfad1), ROUNDING_UNIT (Pfad1) und BASIC_PRICE_DEPENDENT (Pfad1) gelten auch in Verbindung mit der Preisartformel

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
PRICE_TYPE_FORMULA Element
Overview
PRICE_TYPE_FORMULA optional Restriction of xs:string
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_X (Pfad1) (b), DEPTH_Y (Pfad1) (t) oder HEIGHT_Z (Pfad1) (h) auf true gesetzt werden;
- es können die Grundrechenarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (Pfad1), ROUNDING_UNIT (Pfad1) und BASIC_PRICE_DEPENDENT (Pfad1) gelten auch in Verbindung mit der Preisartformel

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
Quelle
<xs:element name="PRICE_TYPE_FORMULA" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--9--Preisart_Formel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="100" />
      <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_TYPE_NAME Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : PRICE_TYPE_NAME Element
Beschreibung
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence PRICE_TYPE_NAME Element
Overview
PRICE_TYPE_NAME optional languagetexte60 Complex Type
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="PRICE_TYPE_NAME" type="languagetexte60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_VALUE_CALCULATION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element : BLOCK_VALUE_CALCULATION Element
Beschreibung
In diesem Element wird die Block- und Werteverrechnung definiert.
Namensraum (none)
Diagramm
SET_OF_BLOCK_RULES Element GRADING_TABLE Element BLOCK_SALE_PRICES Element BLOCK_CONDITIONS Element Sequence BLOCK_VALUE_CALCULATION Element
Overview
BLOCK_VALUE_CALCULATION optional
In diesem Element wird die Block- und Werteverrechnung definiert.
Sequence
BLOCK_CONDITIONS optional
In diesem Element werden Bedingungen formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.

Ein Block darf für einen Auftrag angewendet werden, wenn alle für diesen Block formulierten Bedingungen erfüllt sind. Die einem Block zugeordneten Bedingungen werden durch das Tupel ITEM_REF (Pfad 1) und OPERATION_ID (Pfad 1) gebildet.

Grundbedingung für die Anwendung der Blockbedingung ist, dass ein Block in einem der Programme existiert, die im Auftrag verplant wurden. Sind in einem Auftrag mehrer Programme ausgewählt, gilt das erste Programm im Auftrag auf Kopfebene.

Ein Block unterliegt der Programm- und Variantensteuerung wie "normale" Artikel. Wenn ein Verrechnungsblock in einer Preisgruppe existieren soll, so wird ein entsprechendes Element ITEM_PRICE (Pfad 2) mit dem Preis 0 angelegt.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein, damit der Block für die Werteverrechnung oder die Blockverrechnung angewendet werden darf.

Pfad 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Sequence
BLOCK_CONDITION 1..∞
In diesem Element wird eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.
Sequence
ITEM_REF
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Sequence
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Dieses Element referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder ein zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Wert bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
BLOCK_SALE_PRICES optional
In diesem Element werden Blockaktionspreise formuliert.
Sequence
BLOCK_SALE_PRICE 1..∞
Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie dürfen nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich außer Kraft gesetzt.
Es wird genau die Informationen zeitlich aßser Kraft gesetzt, die in dem Element angegebne sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wird durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Sequence
ITEM_REF
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Sequence
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
GRADING_TABLE optional

In diesem Element werden die Wertestaffeln zur Verrechnung der Gutschriften oder Aufschläge definiert.

Wenn ein Verrechnungsblock für einen Auftrag gültig ist, kann mit dem Block in die Wertestaffel eingestiegen werden. Je gültigem Block in der Wertstaffel wird eine Vergleichssumme für die in dem Element angegebene Verrechnungsgruppe (CLEARING_GROUP (Pfad 1)) bestimmt. Entspricht der Wert der Vergleichssumme dem angegebenen Wertebereich (Elemente VALUE_FROM (Pfad 2) und VALUE_TO (Pfad 2)), so wird das Element angewendet, d. h. die im Element TYPE_CREDIT (Pfad 2) und/oder TYPE_DEBIT (Pfad 2) hinterlegte Type wird verrechnet. Die Berechnung erfolgt auf die Summe der Kalkulationsgruppe, die für die Gutschrift- oder Belastungstype angegeben ist (Element ITEM (Pfad 3)).

Für einen Block können mehrere Staffelbereiche angelegt werden. Jeder Staffelbereich wird einem Element COMPARING_RULES (Pfad 4) zugeordnet. In einer Staffel eines Blocks müssen die Bedingungen aller Wertebereiche mit jeweiliger Verrechnungsgruppe erfüllt sein, bevor die Positionen verrechnet werden können. Die einzelnen Elemente (COMPARING_RULE) sind UND-verknüpft.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein.

Werden auf dem Element GRADING_TABLE mehrere Datensätze eines Verrechnungsblocks angewendet, so wird der Wert des Blocks (ITEM (Pfad 3)), ITEM_PRICE (Pfad 5)) jedoch nur einmal berechnet.

Pfad 1: GLOBAL_DEFINITION
Pfad 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
CREDIT_SURCHARGE_CLEARING 1..∞
In diesem Element wird ein Wertebereich der Wertestaffel definiert.
Sequence
ITEM_REF

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Sequence
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.
Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.
Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
SET_OF_BLOCK_RULES
In diesem Element und den Kind-Elementen werden die herstellerspezifischen Regelwerke beschrieben.
Sequence
EXCHANGE_ID_GROUP 1..∞
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.
Sequence
EXCHANGE_ID_1_REF
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Kommissions- bzw. Planungsartikels. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Artikels aus einem Block.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Blockartikels. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RULE 1..99
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
RULE_SET_TEXT languagetexte60999 Complex Type
In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="BLOCK_VALUE_CALCULATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_CONDITIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>420--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>420--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>420--3--Type_Block</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--3--Type_Block</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--3--Type_Block</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CONDITION_RULES">
                    <xs:annotation>
                      <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>420--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                                <xs:annotation>
                                  <xs:documentation>420--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="CLEARING_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>420--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:choice>
                                <xs:element name="MINIMUM_VALUE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:choice>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BLOCK_SALE_PRICES" minOccurs="0">
        <xs:annotation>
          <xs:documentation>480--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>480--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>480--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>480--100--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="VALID_FROM">
                          <xs:annotation>
                            <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL">
                          <xs:annotation>
                            <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                          <xs:annotation>
                            <xs:documentation>480--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_OR_CALCULATION_POINT">
                          <xs:annotation>
                            <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GRADING_TABLE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>421--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>421--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>421--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>421--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLEARING_GROUP_ID">
                                <xs:annotation>
                                  <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_FROM">
                                <xs:annotation>
                                  <xs:documentation>421--6--Wert_von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_TO">
                                <xs:annotation>
                                  <xs:documentation>421--7--Wert_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TYPE_CREDIT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TYPE_DEBIT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>421--9--Type_Belastung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_OF_BLOCK_RULES">
        <xs:annotation>
          <xs:documentation>111--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_1_REF">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>117--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EXCHANGE_ID_2_REF">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>117--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RULE" maxOccurs="99">
              <xs:annotation>
                <xs:documentation>111--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RULE_TEXT" type="languagetexte60999">
                    <xs:annotation>
                      <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="RULE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>113--3--Regel_Nr</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_CONDITIONS Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element : BLOCK_CONDITIONS Element
Beschreibung
In diesem Element werden Bedingungen formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.

Ein Block darf für einen Auftrag angewendet werden, wenn alle für diesen Block formulierten Bedingungen erfüllt sind. Die einem Block zugeordneten Bedingungen werden durch das Tupel ITEM_REF (Pfad 1) und OPERATION_ID (Pfad 1) gebildet.

Grundbedingung für die Anwendung der Blockbedingung ist, dass ein Block in einem der Programme existiert, die im Auftrag verplant wurden. Sind in einem Auftrag mehrer Programme ausgewählt, gilt das erste Programm im Auftrag auf Kopfebene.

Ein Block unterliegt der Programm- und Variantensteuerung wie "normale" Artikel. Wenn ein Verrechnungsblock in einer Preisgruppe existieren soll, so wird ein entsprechendes Element ITEM_PRICE (Pfad 2) mit dem Preis 0 angelegt.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein, damit der Block für die Werteverrechnung oder die Blockverrechnung angewendet werden darf.

Pfad 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Namensraum (none)
Diagramm
BLOCK_CONDITION Element Sequence BLOCK_CONDITIONS Element
Overview
BLOCK_CONDITIONS optional
In diesem Element werden Bedingungen formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.

Ein Block darf für einen Auftrag angewendet werden, wenn alle für diesen Block formulierten Bedingungen erfüllt sind. Die einem Block zugeordneten Bedingungen werden durch das Tupel ITEM_REF (Pfad 1) und OPERATION_ID (Pfad 1) gebildet.

Grundbedingung für die Anwendung der Blockbedingung ist, dass ein Block in einem der Programme existiert, die im Auftrag verplant wurden. Sind in einem Auftrag mehrer Programme ausgewählt, gilt das erste Programm im Auftrag auf Kopfebene.

Ein Block unterliegt der Programm- und Variantensteuerung wie "normale" Artikel. Wenn ein Verrechnungsblock in einer Preisgruppe existieren soll, so wird ein entsprechendes Element ITEM_PRICE (Pfad 2) mit dem Preis 0 angelegt.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein, damit der Block für die Werteverrechnung oder die Blockverrechnung angewendet werden darf.

Pfad 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Sequence
BLOCK_CONDITION 1..∞
In diesem Element wird eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.
Sequence
ITEM_REF
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Sequence
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Dieses Element referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder ein zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Wert bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="BLOCK_CONDITIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>420--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>420--3--Type_Block</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--3--Type_Block</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--3--Type_Block</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONDITION_RULES">
              <xs:annotation>
                <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>420--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                          <xs:annotation>
                            <xs:documentation>420--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="CLEARING_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:choice>
                          <xs:element name="MINIMUM_VALUE" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:choice>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_CONDITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element : BLOCK_CONDITION Element
Beschreibung
In diesem Element wird eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.
Namensraum (none)
Diagramm
CONDITION_RULES Element ITEM_REF Element Sequence BLOCK_CONDITION Element
Overview
BLOCK_CONDITION 1..∞
In diesem Element wird eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.
Sequence
ITEM_REF
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Sequence
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Dieses Element referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder ein zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Wert bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="BLOCK_CONDITION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>420--3--Type_Block</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--3--Type_Block</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--3--Type_Block</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONDITION_RULES">
        <xs:annotation>
          <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>420--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                    <xs:annotation>
                      <xs:documentation>420--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="CLEARING_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:choice>
                    <xs:element name="MINIMUM_VALUE" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:choice>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element : ITEM_REF Element
Beschreibung
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--3--Type_Block</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--3--Type_Block</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--3--Type_Block</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONDITION_RULES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element : CONDITION_RULES Element
Beschreibung
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Namensraum (none)
Diagramm
CONDITION_RULE Element Sequence CONDITION_RULES Element
Overview
CONDITION_RULES
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Sequence
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Dieses Element referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder ein zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Wert bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="CONDITION_RULES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>420--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
              <xs:annotation>
                <xs:documentation>420--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="CLEARING_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:choice>
              <xs:element name="MINIMUM_VALUE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="999999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:choice>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CONDITION_RULE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element : CONDITION_RULE Element
Beschreibung
In diesem Element werden die Blockbedingungen formuliert.
Namensraum (none)
Diagramm
MINIMUM_WIDTH Element MINIMUM_VALUE Element Choice CLEARING_GROUP_REF Element Sequence CONDITION_RULE Element
Overview
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Dieses Element referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder ein zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Wert bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="CONDITION_RULE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>420--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="CLEARING_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:choice>
        <xs:element name="MINIMUM_VALUE" minOccurs="0">
          <xs:annotation>
            <xs:documentation>420--6--Mindest_Wert</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:nonNegativeInteger">
              <xs:minInclusive value="0" />
              <xs:maxInclusive value="999999999" />
            </xs:restriction>
          </xs:simpleType>
        </xs:element>
        <xs:element name="MINIMUM_WIDTH" minOccurs="0">
          <xs:annotation>
            <xs:documentation>420--7--Mindest_Breite</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:nonNegativeInteger">
              <xs:minInclusive value="0" />
              <xs:maxInclusive value="999999" />
            </xs:restriction>
          </xs:simpleType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : CLEARING_GROUP_REF Element
Beschreibung
Dieses Element referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder ein zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
Namensraum (none)
Diagramm
CLEARING_GROUP_REF Element
Overview
CLEARING_GROUP_REF 1..999
Dieses Element referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder ein zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
CLEARING_GROUP_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="CLEARING_GROUP_REF" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="CLEARING_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MINIMUM_VALUE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : MINIMUM_VALUE Element
Beschreibung
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Wert bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MINIMUM_VALUE Element
Overview
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Wert bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="MINIMUM_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--6--Mindest_Wert</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MINIMUM_WIDTH Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : MINIMUM_WIDTH Element
Beschreibung
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MINIMUM_WIDTH Element
Overview
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="MINIMUM_WIDTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--7--Mindest_Breite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_SALE_PRICES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element : BLOCK_SALE_PRICES Element
Beschreibung
In diesem Element werden Blockaktionspreise formuliert.
Namensraum (none)
Diagramm
BLOCK_SALE_PRICE Element Sequence BLOCK_SALE_PRICES Element
Overview
BLOCK_SALE_PRICES optional
In diesem Element werden Blockaktionspreise formuliert.
Sequence
BLOCK_SALE_PRICE 1..∞
Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie dürfen nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich außer Kraft gesetzt.
Es wird genau die Informationen zeitlich aßser Kraft gesetzt, die in dem Element angegebne sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wird durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Sequence
ITEM_REF
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Sequence
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="BLOCK_SALE_PRICES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>480--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>480--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>480--100--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="VALID_FROM">
                    <xs:annotation>
                      <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL">
                    <xs:annotation>
                      <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                    <xs:annotation>
                      <xs:documentation>480--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_OR_CALCULATION_POINT">
                    <xs:annotation>
                      <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_SALE_PRICE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element : BLOCK_SALE_PRICE Element
Beschreibung
Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie dürfen nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich außer Kraft gesetzt.
Es wird genau die Informationen zeitlich aßser Kraft gesetzt, die in dem Element angegebne sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wird durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Namensraum (none)
Diagramm
VARIATION_PRICE_DEFINITION Element ITEM_REF Element Sequence BLOCK_SALE_PRICE Element
Overview
BLOCK_SALE_PRICE 1..∞
Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie dürfen nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich außer Kraft gesetzt.
Es wird genau die Informationen zeitlich aßser Kraft gesetzt, die in dem Element angegebne sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wird durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Sequence
ITEM_REF
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Sequence
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>480--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>480--100--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="VALID_FROM">
              <xs:annotation>
                <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL">
              <xs:annotation>
                <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
              <xs:annotation>
                <xs:documentation>480--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_OR_CALCULATION_POINT">
              <xs:annotation>
                <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element : ITEM_REF Element
Beschreibung
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VARIATION_PRICE_DEFINITION Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element : VARIATION_PRICE_DEFINITION Element
Beschreibung
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Namensraum (none)
Diagramm
PRICE_OR_CALCULATION_POINT Element OPTION_REF Element VALID_UNTIL Element VALID_FROM Element Sequence VARIATION_PRICE_DEFINITION Element
Overview
VARIATION_PRICE_DEFINITION 1..∞
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Sequence
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--100--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="VALID_FROM">
        <xs:annotation>
          <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL">
        <xs:annotation>
          <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
        <xs:annotation>
          <xs:documentation>480--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_OR_CALCULATION_POINT">
        <xs:annotation>
          <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
Quelle
<xs:element name="VALID_FROM" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
Quelle
<xs:element name="VALID_UNTIL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : OPTION_REF Element
Beschreibung
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_OR_CALCULATION_POINT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : PRICE_OR_CALCULATION_POINT Element
Beschreibung
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
PRICE_OR_CALCULATION_POINT Element
Overview
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="PRICE_OR_CALCULATION_POINT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

GRADING_TABLE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element : GRADING_TABLE Element
Beschreibung

In diesem Element werden die Wertestaffeln zur Verrechnung der Gutschriften oder Aufschläge definiert.

Wenn ein Verrechnungsblock für einen Auftrag gültig ist, kann mit dem Block in die Wertestaffel eingestiegen werden. Je gültigem Block in der Wertstaffel wird eine Vergleichssumme für die in dem Element angegebene Verrechnungsgruppe (CLEARING_GROUP (Pfad 1)) bestimmt. Entspricht der Wert der Vergleichssumme dem angegebenen Wertebereich (Elemente VALUE_FROM (Pfad 2) und VALUE_TO (Pfad 2)), so wird das Element angewendet, d. h. die im Element TYPE_CREDIT (Pfad 2) und/oder TYPE_DEBIT (Pfad 2) hinterlegte Type wird verrechnet. Die Berechnung erfolgt auf die Summe der Kalkulationsgruppe, die für die Gutschrift- oder Belastungstype angegeben ist (Element ITEM (Pfad 3)).

Für einen Block können mehrere Staffelbereiche angelegt werden. Jeder Staffelbereich wird einem Element COMPARING_RULES (Pfad 4) zugeordnet. In einer Staffel eines Blocks müssen die Bedingungen aller Wertebereiche mit jeweiliger Verrechnungsgruppe erfüllt sein, bevor die Positionen verrechnet werden können. Die einzelnen Elemente (COMPARING_RULE) sind UND-verknüpft.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein.

Werden auf dem Element GRADING_TABLE mehrere Datensätze eines Verrechnungsblocks angewendet, so wird der Wert des Blocks (ITEM (Pfad 3)), ITEM_PRICE (Pfad 5)) jedoch nur einmal berechnet.

Pfad 1: GLOBAL_DEFINITION
Pfad 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Namensraum (none)
Diagramm
CREDIT_SURCHARGE_CLEARING Element Sequence GRADING_TABLE Element
Overview
GRADING_TABLE optional

In diesem Element werden die Wertestaffeln zur Verrechnung der Gutschriften oder Aufschläge definiert.

Wenn ein Verrechnungsblock für einen Auftrag gültig ist, kann mit dem Block in die Wertestaffel eingestiegen werden. Je gültigem Block in der Wertstaffel wird eine Vergleichssumme für die in dem Element angegebene Verrechnungsgruppe (CLEARING_GROUP (Pfad 1)) bestimmt. Entspricht der Wert der Vergleichssumme dem angegebenen Wertebereich (Elemente VALUE_FROM (Pfad 2) und VALUE_TO (Pfad 2)), so wird das Element angewendet, d. h. die im Element TYPE_CREDIT (Pfad 2) und/oder TYPE_DEBIT (Pfad 2) hinterlegte Type wird verrechnet. Die Berechnung erfolgt auf die Summe der Kalkulationsgruppe, die für die Gutschrift- oder Belastungstype angegeben ist (Element ITEM (Pfad 3)).

Für einen Block können mehrere Staffelbereiche angelegt werden. Jeder Staffelbereich wird einem Element COMPARING_RULES (Pfad 4) zugeordnet. In einer Staffel eines Blocks müssen die Bedingungen aller Wertebereiche mit jeweiliger Verrechnungsgruppe erfüllt sein, bevor die Positionen verrechnet werden können. Die einzelnen Elemente (COMPARING_RULE) sind UND-verknüpft.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein.

Werden auf dem Element GRADING_TABLE mehrere Datensätze eines Verrechnungsblocks angewendet, so wird der Wert des Blocks (ITEM (Pfad 3)), ITEM_PRICE (Pfad 5)) jedoch nur einmal berechnet.

Pfad 1: GLOBAL_DEFINITION
Pfad 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
CREDIT_SURCHARGE_CLEARING 1..∞
In diesem Element wird ein Wertebereich der Wertestaffel definiert.
Sequence
ITEM_REF

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Sequence
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.
Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.
Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="GRADING_TABLE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>421--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>421--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>421--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLEARING_GROUP_ID">
                          <xs:annotation>
                            <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_FROM">
                          <xs:annotation>
                            <xs:documentation>421--6--Wert_von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_TO">
                          <xs:annotation>
                            <xs:documentation>421--7--Wert_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TYPE_CREDIT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TYPE_DEBIT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>421--9--Type_Belastung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CREDIT_SURCHARGE_CLEARING Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element : CREDIT_SURCHARGE_CLEARING Element
Beschreibung
In diesem Element wird ein Wertebereich der Wertestaffel definiert.
Namensraum (none)
Diagramm
COMPARING_RULES Element ITEM_REF Element Sequence CREDIT_SURCHARGE_CLEARING Element
Overview
CREDIT_SURCHARGE_CLEARING 1..∞
In diesem Element wird ein Wertebereich der Wertestaffel definiert.
Sequence
ITEM_REF

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Sequence
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.
Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.
Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>421--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>421--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>421--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLEARING_GROUP_ID">
                    <xs:annotation>
                      <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_FROM">
                    <xs:annotation>
                      <xs:documentation>421--6--Wert_von</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_TO">
                    <xs:annotation>
                      <xs:documentation>421--7--Wert_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TYPE_CREDIT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TYPE_DEBIT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>421--9--Type_Belastung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element : ITEM_REF Element
Beschreibung

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>421--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>421--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COMPARING_RULES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element : COMPARING_RULES Element
Beschreibung
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Namensraum (none)
Diagramm
COMPARING_RULE Element Sequence COMPARING_RULES Element
Overview
COMPARING_RULES 1..∞
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Sequence
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.
Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.
Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="COMPARING_RULES" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP_ID">
              <xs:annotation>
                <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_FROM">
              <xs:annotation>
                <xs:documentation>421--6--Wert_von</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_TO">
              <xs:annotation>
                <xs:documentation>421--7--Wert_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TYPE_CREDIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TYPE_DEBIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--9--Type_Belastung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COMPARING_RULE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element : COMPARING_RULE Element
Beschreibung
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Namensraum (none)
Diagramm
TYPE_DEBIT Element TYPE_CREDIT Element VALUE_TO Element VALUE_FROM Element CLEARING_GROUP_ID Element Sequence COMPARING_RULE Element
Overview
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.
Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.
Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="COMPARING_RULE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP_ID">
        <xs:annotation>
          <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_FROM">
        <xs:annotation>
          <xs:documentation>421--6--Wert_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_TO">
        <xs:annotation>
          <xs:documentation>421--7--Wert_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TYPE_CREDIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TYPE_DEBIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--9--Type_Belastung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_ID Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : CLEARING_GROUP_ID Element
Beschreibung
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
CLEARING_GROUP_ID Element
Overview
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="CLEARING_GROUP_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_FROM Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : VALUE_FROM Element
Beschreibung
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
VALUE_FROM Element
Overview
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="VALUE_FROM" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--6--Wert_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALUE_TO Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : VALUE_TO Element
Beschreibung

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
VALUE_TO Element
Overview
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="VALUE_TO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--7--Wert_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TYPE_CREDIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : TYPE_CREDIT Element
Beschreibung
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.
Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TYPE_CREDIT Element
Overview
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.
Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
Quelle
<xs:element name="TYPE_CREDIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TYPE_DEBIT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : TYPE_DEBIT Element
Beschreibung
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.
Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TYPE_DEBIT Element
Overview
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.
Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="TYPE_DEBIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--9--Type_Belastung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SET_OF_BLOCK_RULES Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element : SET_OF_BLOCK_RULES Element
Beschreibung
In diesem Element und den Kind-Elementen werden die herstellerspezifischen Regelwerke beschrieben.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence RULE_SET_TEXT Element RULE Element EXCHANGE_ID_GROUP Element Sequence SET_OF_BLOCK_RULES Element
Overview
SET_OF_BLOCK_RULES
In diesem Element und den Kind-Elementen werden die herstellerspezifischen Regelwerke beschrieben.
Sequence
EXCHANGE_ID_GROUP 1..∞
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.
Sequence
EXCHANGE_ID_1_REF
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Kommissions- bzw. Planungsartikels. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Artikels aus einem Block.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Blockartikels. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RULE 1..99
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
RULE_SET_TEXT languagetexte60999 Complex Type
In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="SET_OF_BLOCK_RULES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_1_REF">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>117--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="EXCHANGE_ID_2_REF">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>117--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RULE" maxOccurs="99">
        <xs:annotation>
          <xs:documentation>111--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RULE_TEXT" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="RULE_NO" use="required">
            <xs:annotation>
              <xs:documentation>113--3--Regel_Nr</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_GROUP Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : EXCHANGE_ID_GROUP Element
Beschreibung
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.
Namensraum (none)
Diagramm
EXCHANGE_ID_2_REF Element EXCHANGE_ID_1_REF Element Sequence EXCHANGE_ID_GROUP Element
Overview
EXCHANGE_ID_GROUP 1..∞
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.
Sequence
EXCHANGE_ID_1_REF
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Kommissions- bzw. Planungsartikels. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Artikels aus einem Block.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Blockartikels. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Quelle
<xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_1_REF">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>117--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="EXCHANGE_ID_2_REF">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>117--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_1_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > EXCHANGE_ID_GROUP Element : EXCHANGE_ID_1_REF Element
Beschreibung
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Kommissions- bzw. Planungsartikel.
Namensraum (none)
Diagramm
EXCHANGE_ID_1_REF Element
Overview
EXCHANGE_ID_1_REF
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Kommissions- bzw. Planungsartikels. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Kommissions- bzw. Planungsartikels. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Quelle
<xs:element name="EXCHANGE_ID_1_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>117--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
EXCHANGE_ID_GROUP Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_2_REF Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > EXCHANGE_ID_GROUP Element : EXCHANGE_ID_2_REF Element
Beschreibung
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Artikels aus einem Block.
Namensraum (none)
Diagramm
EXCHANGE_ID_2_REF Element
Overview
EXCHANGE_ID_2_REF
Dieses Element verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS definierte Tauschgruppe. Die Tausch-ID entspricht dem Wert im Attribut EXCHANGE_ID_NO eines Artikels aus einem Block.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Blockartikels. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
Dieses Attribut dient der Referenzierung auf den Schlüssel für die Tauschgruppe des Blockartikels. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Quelle
<xs:element name="EXCHANGE_ID_2_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>117--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
EXCHANGE_ID_GROUP Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RULE Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : RULE Element
Beschreibung
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence RULE_TEXT Element Sequence RULE Element
Overview
RULE 1..99
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
RULE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben. D nonNegativeInteger
P
M [1:99]
Quelle
<xs:element name="RULE" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RULE_TEXT" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="RULE_NO" use="required">
      <xs:annotation>
        <xs:documentation>113--3--Regel_Nr</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RULE_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > RULE Element : RULE_TEXT Element
Beschreibung
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Namensraum (none)
Typ
languagetexte60999 Complex Type
Diagramm
LANGUAGE Element Sequence RULE_TEXT Element
Overview
RULE_TEXT languagetexte60999 Complex Type
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="RULE_TEXT" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
RULE Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

RULE_SET_TEXT Element
IDM 2.7.0 XML-Schema > T_NEW_CATALOG Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : RULE_SET_TEXT Element
Beschreibung
In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.
Namensraum (none)
Typ
languagetexte60999 Complex Type
Diagramm
LANGUAGE Element Sequence RULE_SET_TEXT Element
Overview
RULE_SET_TEXT languagetexte60999 Complex Type
In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="RULE_SET_TEXT" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_CATALOG Element | IDM 2.7.0 XML-Schema


%%ItemTitle%%

IDM 2.7.0 XML-Schema Dokumentation
Datentypen
Ansicht mit Navigationswerkzeuge

Für die sprachabhängigen Texte wurden eigene Datentypen definiert.


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > languagetexte Complex Type > LANGUAGE Element : TEXT Element
Beschreibung

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
TEXT Element
Overview
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte30 Complex Type
IDM 2.7.0 XML-Schema : languagetexte30 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte30 Complex Type
Overview
languagetexte30

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Verwendet von
CATALOG_NAME Element
PROPERTY_UNIT Element
DEFAULT_OPTION_GROUP_NAME Element
MERCHANDISE_GROUP_TEXT Element
CALC_GROUP_TEXT Element
Quelle
<xs:complexType name="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte40 Complex Type
IDM 2.7.0 XML-Schema : languagetexte40 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte40 Complex Type
Overview
languagetexte40

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Verwendet von
INTERNAL_NAME Element
EXCHANGE_ID_TEXT Element
Quelle
<xs:complexType name="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 XML-Schema > languagetexte40 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte40 Complex Type | IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte60 Complex Type
IDM 2.7.0 XML-Schema : languagetexte60 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte60 Complex Type
Overview
languagetexte60

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Verwendet von
CLEARING_GROUP_NAME Element
MODULE_RULE_SET_NAME Element
GROUP_TITLE_NAME Element
PRODUCT_GROUP_TEXT Element
OPTION_TEXT Element
OPTION_COMMENT_TEXT Element
FEATURE_TEXT Element
RESTRICTION_NAME_TEXT Element
SUGGESTION_NAME_TEXT Element
PRICE_FEATURE_GROUP_TEXT Element
PRICE_TYPE_NAME Element
Quelle
<xs:complexType name="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>265--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,60}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte60999 Complex Type
IDM 2.7.0 XML-Schema : languagetexte60999 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bstehend aus bis zu 999 Zeilen der Länge 60.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte60999 Complex Type
Overview
languagetexte60999

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bstehend aus bis zu 999 Zeilen der Länge 60.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Verwendet von
CATALOG_INFO Element
PLANNING_ADVICE Element
RULE_TEXT Element
RULE_SET_TEXT Element
Quelle
<xs:complexType name="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelligen Zeilen</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT_LINE" maxOccurs="999">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="TEXT">
                  <xs:annotation>
                    <xs:documentation>265--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[\S ]{1,60}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
              </xs:sequence>
              <xs:attribute name="SEQUENCE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>150--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger" />
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM 2.7.0 XML-Schema