 Einleitung

Ansicht mit Navigationswerkzeuge

IDM 2.8.1 Block XML-Schema

Dokumentation

Stand 03.01.2022

Dokumentiertes XML-Schema:

IDM_2_8_1_Block.xsd

Kontakt DCC e.V.

Geschäftsführer
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37

Verantwortliche IDM Arbeitskreise und Dokumentation
Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telefon 0 52 21/12 65-38


 Grundstruktur des IDM-Schemas

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Grundstruktur des IDM-Schemas

Das Hauptelement T_NEW_BLOCK definiert, dass ein neuer, vollständiger Block-Katalogdatenbestand bereitgestellt wird.

Dabei sind die XML-Dateien UTF-8 zu kodieren.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_NEW_CATALOG abgebildet werden.

Abbildung 1 - Child-Elemente von T_NEW_BLOCK

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

SUPPLIER

In SUPPLIER werden administrative Informationen zu dem Hersteller hinterlegt. Beispielsweise werden Kontaktdaten, EDI-Kommunikationsparameter oder das Herkunftsland des Herstellers angegeben.

GLOBAL_DEFINITION

Der Datenbereich GLOBAL_DEFINITION ist eine Art Datenpool für Informationen, die in den anderen Datenbereichen verwendet werden. Beispielsweise werden hier Verrechnungsgruppen oder die Informationen über Medien angelegt.

SERIES

In SERIES werden die Daten für die Beschreibung der Blöcke hinterlegt. Dabei werden alle Artikel(Blöcke) einer Produktgruppe zugeordnet.

FEATURE_DEFINITION

In FEATURE_DEFINITION werden Prüfverfahren (RESTRICTIONS) angelegt.

BLOCK_VALUE_CALCULATION

In BLOCK_VALUE_CALCULATON werden Informationen für die Block- und Werteverrechnung hinterlegt. Beispielsweise werden Daten für Blockregelwerke (SET_OF_BLOCK_RULES), Blockbedingungen (BLOCK_CONDITIONS) oder Wertetabellen (GRADING_TABLE) hinterlegt.


 Elemente der Katalogstruktur

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Elemente der Katalogstruktur

Elemente der Katalogstruktur anlegen

Grundvoraussetzung für eine Block-XML-Datei sind die Katalogdaten mit Informationen zu Serien, Programmen, Variantenarten, Varianten, Preisfeldern und Artikeldaten in einer vorhandenen Datei.

Darauf aufbauend kann dann nach den Katalogangaben die Datenbereitstellung zu den Blöcken einschließlich ihrer Bestandteile und Preise erfolgen.

Blockinformationen anlegen

Blockinformationen werden im folgenden Element angelegt:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Das Element ITEM besitzt eine Vielzahl von Elementen mit denen die Eigenschaften eines Blockes beschrieben werden können. Die Identifizierung eines Blockes erfolgt über das Attribut TYPE_NO.

Hierbei ist jedoch zu beachten, dass ein Artikel in Abhängigkeit der Serie unterschiedliche Eigenschaften haben kann. Demzufolge wird ein Artikel mit seinen Eigenschaften nur eindeutig in Verbindung mit der Serie identifiziert.

Innnerhalb des Elementes BLOCK_PARTS werden dann die Einzelartikel des Blockes erfasst.


 Katalogstruktur

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Katalogstruktur

Katalog- und Elementstruktur

Die grundlegende Katalogstruktur der Datenbestände baut sich wie folgt auf:

Abbildung 1 – Katalogstruktur der Datenbestände

Die Katalogstruktur wird im IDM-Schema durch die folgende Elementhierarchie abgebildet:

Abbildung 1 – Elementhierarchie im IDM-Schema

In dem Element SERIE werden die Eigenschaften einer Serie definiert. Über das Element RESTRICTION_REF werden einer Serie Varianten über Prüfverfahren zugeordnet. Innerhalb der Serie werden Produktgruppen (PRODUCT_GROUPS) definiert, in denen Artikel mit gleichartigen Variantenarten zusammengefasst sind. Die Artikel sind einer Serie automatisch zugeordnet, da sie Kind-Elemente des Elementes SERIE sind.


 Referenzierung

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Referenzierung

Referenzierung von Elementen

Im IDM-Schema werden Beziehungen zwischen Elementen aufgebaut und Informationen an zentraler Stelle definiert und an anderer Stelle mehrfach verwendet. Die Wiederverwendung der Informationen und der Aufbau von Elementbeziehungen erfolgt über Referenzierung. Die im IDM-Schema angewendete Art der Referenzierung wird nachfolgend beschrieben.

Begriffsdefinition

Im IDM-Schema werden für die Referenzierung von Elementen folgende Begriffe verwendet:

Key-Element | Ein XML-Element, welches von anderen Elementen referenziert wird.
Ref-Element | Ein XML-Element, welches andere Elemente referenziert.

Vorgang der Referenzierung

Das Key-Element besitzt Attribute, über die es eindeutig identifiziert wird. Das Ref-Element besitzt minimal die Key-Attribute des Key-Elementes. Zwischen den Elementen wird die Referenz aufgebaut, in dem die Attributwerte des Ref-Elementes denen des Key-Elementes entsprechen.

Beispiel: Referenzierung der Serie aus dem Artikel

Das nachfolgende Beispiel zeigt, wie aus von einem Artikel ( ITEM ) eine Serie ( SERIE ) referenziert wird. Die XML-Elemente sind nur auszugsweise dargestellt.

Key-Element

T_NEW_CATALOG/SERIES/SERIE

<SERIES>

<SERIE SERIE_NO="1"/> … </SERIE>

<SERIE SERIE_NO="2"/> … </SERIE>

<SERIE SERIE_NO="3"/> … </SERIE>

. . .

<SERIE SERIE_NO="99"/> … </SERIE>

</SERIES>

Ref-Element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS>

<ITEM SERIE_NO="1" . . . />

. . .

</ITEMS>

Beispiel: Referenzierung einer Varianten

Im folgenden Beispiel wird eine Variante aus einem Prüfverfahren heraus referenziert.

Key-Element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!-- Sockelausführung -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!-- Sockelfarbe -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

Die XML-Elemente definieren für die Variantenart 400 (FEATURE) drei Varianten (OPTION) mit den Nummern 1-3 sowie für die Variantenart 401 drei Varianten mit den Nummern 1-3. Eine Variante wird identifiziert über die Kombination FEATURE_NO und OPTION_KEY.

Ref-Element

T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_REF

<RESTRICTION RESTRICTION_NO="1">

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="1" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

In den XML-Elementen wird ein Prüfverfahren für die zulässigen Kombinationen (TEST_ID=1) der Sockelausführungen (FEATURE_NO=400) und der Sockelfarben (FEATURE_NO=401) definiert. Das Ref-Element OPTION_REF mit den grau hinterlegten Attributen referenziert in diesem Beispiel das grau hinterlegte Key-Element OPTION.


 Prüfverfahren

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Prüfverfahren

Definition und Zuordnung von Prüfverfahren

Prüfverfahren können Serien-übergreifend, Serien-spezifisch, Programm-spezifisch oder Artikel-spezifisch gültig sein. Je tiefer in der Hierarchie Serie->Programm->Artikel ein Prüfverfahren zugeordnet wird, desto höher ist seine Priorität. Ein Prüfverfahren auf Artikelebene übersteuert beispielsweise ein Prüfverfahren, welches auf Programmebene zugeordnet wurde. Ein übersteuerndes Prüfverfahren kann jedoch nur weitere Einschränkungen definieren. Beispielsweise ist es nicht möglich, dass über ein Artikel-spezifisches Prüfverfahren Varianten wieder verfügbar gemacht werden, die bereits von einem Programm-spezifischen Prüfverfahren ausgeschlossen wurden.

Prüfverfahren werden zunächst unabhängig von ihrer späteren Zuordnung angelegt und dann Serien, Programmen oder Artikeln zugeordnet.

Anlage von Prüfverfahren

Prüfverfahren werden in folgendem Element angelegt:

FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

In dem Element RESTRICTION werden Variantenarten referenziert, für deren Kombinationen das Prüfverfahren angelegt werden soll. In dem Element OPTION_REF werden die Varianten referenziert, deren Kombinationen geprüft werden sollen. Es dürfen nur die Varianten referenziert werden, deren Variantenarten in dem Element RESTRICTION referenziert wurden. Das Element TEST_ID definiert, ob die angegebene Variantenkombination zulässig oder unzulässig ist.

Beispiel: Definition von Prüfverfahren

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="523" FEATURE_1_NO="100" FEATURE2_NO="101">

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA" FEATURE_NO="100"/> #lackiert

<OPTION_REF OPTION_NO="RO" FEATURE_NO="101"/> # rot

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA" FEATURE_NO="100"/> # lackiert

<OPTION_REF OPTION_NO="GR" FEATURE_NO="101"/> # grün

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="FU" FEATURE_NO="100"/> # furniert

<OPTION_REF OPTION_NO="BU" FEATURE_NO="101"/> # buche

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

Im obigen Beispiel ist ein Prüfverfahren definiert, welches die Kombinationen von Varianten der Variantenart „Frontausführung “ (Nr. 100) und der Variantenart „Frontfarbe“ (Nr. 101) definiert. Nach dem obigen Prüfverfahren sind die Kombinationen lackiert-rot, lackiert-grün und furniert-buche erlaubt (TEST_ID = 1). Beim Auflisten der Variantenkombinationen (OPTION_REF) muss die Reihenfolge eingehalten werden, wie diese durch die Attribute von RESTRICTION (FEATURE_1_NO, FEATURE_2_NO) gegeben wird.

Für die Identifizierung wird dem Prüfverfahren eine eindeutige Nummer (RESTRICTION_NO) zugewiesen.

Zuordnung von Prüfverfahren

Serien-übergreifende Zuordnung

Prüfverfahren werden Serien-übergreifend mit folgendem Element zugeordnet:

SERIES/RESTRICTIONS/RESTRICTION_REF

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Das Element SERIES/RESTRICTIONS/RESTRICTION_REF ist Kind-Element des Elementes SERIES/RESTRICTIONS, hierdurch werden die in RESTRICTION_REF referenzierten Prüfverfahren allen Serien zugeordnet, die in SERIES/SERIE definiert werden.

Beispiel: Serien-übergreifende Zuordnung von Prüfverfahren

<SERIES>

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="523"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="678"/>

</RESTRICTIONS>

</SERIES>

In dem obigen Beispiel werden die Prüfverfahren 523 und 678 referenziert und damit allen Serien zugeordnet.

Serien-spezifische Zuordnung

Die Serien-spezifische Zuordnung von Prüfverfahren erfolgt nach selbem Muster, wie die Serien-übergreifende Zuordnung. Für die Serien-spezifische Zuordnung wird das folgende Element verwendet:

SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF

Die in RESTRICTION_REF referenzierten Prüfverfahren werden der Serie zugeordnet, innerhalb derer die Referenzierung erfolgte.

Prüfverfahren, in denen Programme zugeordnet werden, sind 1-stufige Prüfungen, in denen nur die Variantenart 1 (Programm) enthalten ist. Diese Prüfverfahren sind Pflicht für Serien > 0 und wenn die Variantenart 1 im Datenbestand definiert ist.

Beispiel: Serien-spezifische Zuordnung von Prüfverfahren

<SERIES>

<SERIE SERIE_NO="2">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="67"/>

</RESTRICTIONS>

</SERIE>

<SERIE SERIE_NO="7">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="123"/>

</RESTRICTIONS>

</SERIE>

</SERIES>

Im obigen Beispiel wurden der Serie „2“ die Prüfverfahren 45 und 67 sowie der Serie „7“ die Prüfverfahren 45 und 123 zugeordnet.

Artikelspezifische Zuordnung

Die Artikel-spezifische Zuordnung von Prüfverfahren erfolgt in folgendem Element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

Die Zuordnung der Prüfverfahren erfolgt wie bei der Serien- oder Programm-spezifischen Zuordnung.

Sind einem Artikel keine Prüfverfahren zugeordnet, dann ist dieser ohne Einschränkungen hinsichtlich der Varianten lieferbar.

Produktgruppen-spezifische Zuordnung

Die Produktgruppen-spezifische Zuordnung von Prüfverfahren erfolgt in folgendem Element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF

Die Zuordnung der Prüfverfahren erfolgt wie bei der Serien-spezifischen Zuordnung.


 Datentypen

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

Es werden folgende Datentypen genutzt:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDM wird der Datentyp date XML-Schema konform in folgender Weise angewendet: YYYY-MM-DD YYYY = Jahr, MM = Monat, DD = Tag
dateTime | Im IDM wird der Datentyp dateTime XML-Schema konform in folgender Weise angewendet: YYYY-MM-DDThh:mm:ssZ YYYY = Jahr, MM = Monat, DD = Tag T = Beginn der Zeitangabe hh = Stunde, mm = Minute, ss = Sekunde Z = UTC-Zeit
gYear | Im IDM wird der Datentyp dateTime XML-Schema konform in folgender Weise angewendet: YYYY
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDM für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDM für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDM für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.

Die Wertebereiche der obigen Datentypen sind im allgemeinen für die Elemente im IDM eingeschränkt. Über "Restrictions" bei der Datentypdefinition sind Minimal- und Maximalwerte, zulässige Zeichen sowie Wertlisten eingeschränkt.

In der XML-Schema Dokumentation des IDM sind die Wertebereiche durch die Angabe hinter M und P spezifiziert.

Neben den hier genannten XML-Datentypen werden eigene Datentypen für die Texte definiert.

Sie sind am Ende der Dokumentation erklärt.

Siehe auch

languagetexte Complex Type

languagetexte30 Complex Type

languagetexte40 Complex Type

languagetexte60 Complex Type

languagetexte60999 Complex Type


 Erläuterungen zur Dokumentation

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Erläuterungen zur Dokumentation

Erläuterungen zur Dokumentation des IDM

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

EXCHANGE_ID_NO Attribute Collapse All

Beschreibung

Das Attribut identifiziert eine Tausch-ID.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


 Variantenarten

Ansicht mit Navigationswerkzeuge

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Variantenarten

Varianten-art | Variantentext | Ausführungs-art | Bemerkung
1 | Programm | A | Programm als VariantenartProgramm als VariantenartProgramm als Variantenart
2 | Seriennummer | A | Zuordnung einer fünfstelligen Seriennummer
100 | Frontausführung | A |
101 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
102 | Frontfarbe 2 | F | Rahmen
103 | Frontfarbe 3 | F | Lisenen
104 | Kantenfarbe Front | F |
105 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
106 | Frontgruppe | A | Überschreibt die FRONT_GROUP_NO in FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Frontausführung Absetzung 1 | A |
111 | Frontfarbe 1 Absetzung 1 | F | Füllung glatte Front = ganze Fläche
112 | Frontfarbe 2 Absetzung 1 | F | Rahmen
113 | Frontfarbe 3 Absetzung 1 | F | Lisenen
114 | Kantenfarbe Front Absetzung 1 | F |
115 | Front-Kombination Absetzung 1 | K | Darf die Varianten 111 bis 114 enthalten
120 | Frontausführung Absetzung 2 | A |
121 | Frontfarbe 1 Absetzung 2 | F | Füllung glatte Front = ganze Fläche
122 | Frontfarbe 2 Absetzung 2 | F | Rahmen
123 | Frontfarbe 3 Absetzung 2 | F | Lisenen
124 | Kantenfarbe Front Absetzung 2 | F |
125 | Front-Kombination Absetzung 2 | K | Darf die Varianten 121 bis 124 enthalten
150 | Glasausführung | A |
151 | Glasfarbe | F |
152 | Sprossenausführung | A |
153 | Sprossenfarbe | F |
154 | Ausführung Glastürrahmen | A |
155 | Farbe Glastürrahmen | F |
160 | Ausführung Jalousie | A |
161 | Farbe Jalousie | F |
170 | Ausführung Schütte | A |
171 | Farbe Schütte | F |
200 | Korpusausführung | A |
201 | Korpus-Kombination | K | Wenn für mehrere Korpusfarben - innen/außen - nur ein Schlüssel vorhanden ist.
202 | Korpusfarbe außen | F |
203 | Korpusfarbe innen | F |
204 | Kantenausführung Korpus | A |
205 | Kantenfarbe Korpus | F |
206 | Sichtseiten-Ausführung | A |
207 | Sichtseiten-Farbe | F |
208 | Korpusfarbe innen für Glas | F | Glasschränke und offene Schränke, die kein Regal sind.
209 | Korpusausf. innen für Glas | A | Glasschränke und offene Schränke, die kein Regal sind.
300 | Griffausführung | A |
301 | Griff-Farbe 1 | F | Griff-, Knopfsockel- bzw. Hauptfarbe
302 | Griff-Farbe 2 | F | Bügel-, Steg- und Knopfblendenfarbe
303 | Griff-Kombination | K | Wenn nur ein Schlüssel für mehrere Griffbedingungen vorgegeben ist.
304 | Grifflagen | NULL | Siehe Grifflagen S. 5-23
400 | Sockelausführung | A |
401 | Sockelfarbe | F |
402 | Sockelhöhe | A |
410 | Ausführung Sockelboden | A |
411 | Farbe Sockelboden | F |
500 | Ausführung Regale | A |
501 | Farbe Regale | F |
502 | Ausführung Kranzprofil | A | Beinhaltet Form und Material
503 | Farbe Kranzprofil | F |
504 | Ausführung Lichtleiste | A | Beinhaltet Form und Material
505 | Farbe Lichtleiste | F |
506 | Ausführung Deckenblende | A |
507 | Farbe Deckenblende | F |
508 | Ausf. u. Schr.-abschlussleiste | A | Untere Schrankabschlußleiste
509 | Farbe u. Schr.-abschlussleiste | F | Untere Schrankabschlußleiste
510 | Ausführung Oberboden | A |
511 | Farbe Oberboden | F |
512 | Ausführung Oberboden-Kante | A |
513 | Farbe Oberboden-Kante | F |
514 | Ausführung Bord | A |
515 | Farbe Bord | F |
516 | Ausführung Bordkante | A |
517 | Farbe Bordkante | F |
520 | Ausführung Wangen/Riegel | A |
521 | Farbe Wangen/Riegel | F |
522 | Ausführung Wangenkante | A |
523 | Farbe Wangenkante | F |
524 | Ausführung Unterboden | A |
525 | Farbe Unterboden | F |
526 | Ausführung Unterboden-Kante | A |
527 | Farbe Unterboden-Kante | F |
550 | Nischenausführung | A |
551 | Nischenfarbe | F |
560 | Ausführung Nischenzubehör | A |
561 | Farbe Nischenzubehör | F |
562 | Ausführung Pilaster | A |
563 | Farbe Pilaster | F |
564 | Ausführung Pilasterkante | A |
565 | Farbe Pilasterkante | F |
600 | Arbeitsplatten-Ausführung | A |
601 | Arbeitsplatten-Farbe | F |
602 | Arbeitsplattenkantenausführung | A |
603 | Arbeitsplatten-Kantenfarbe | F |
604 | Barplatten-Ausführung | A |
605 | Barplatten-Farbe | F |
606 | Barplatten-Kantenausführung | A |
607 | Barplatten-Kantenfarbe | F |
620 | Abdeckplatten-Ausführung | A |
621 | Abdeckplatten-Farbe | F |
622 | Abdeckplatten-Kantenausführung | A |
623 | Abdeckplatten-Kantenfarbe | F |
624 | Ansetztisch-Ausführung | A |
625 | Ansetztisch-Farbe | F |
626 | Ansetztisch-Kantenausführung | A |
627 | Ansetztisch-Kantenfarbe | F |
650 | WAP-Ausführung | A | Wandabschlussprofil
651 | WAP-Farbe | F | Wandabschlussprofil
700 | Schubkastenausführung | A | Innenausstattung
701 | Schubkastenfarbe | F | Innenausstattung
702 | Auszugsausführung | A | Innenausstattung
703 | Auszugsfarbe | F | Innenausstattung
750 | Arbeitsplattenform | S |
751 | Kranzleistenform | S |
752 | Lichtleistenform | S |
753 | Sockelform | S |
754 | Wandabschlussform | S |
755 | Abdeckplattenform | S |
756 | Barplattenform | S |
800 | Ausführung Elektrogeräte | A |
801 | Farbe Elektrogeräte | F |
802 | Farbe Elektrogeräte-Zubehör | F |
850 | Ausführung Spülen | A |
851 | Farbe Spülen | F |
852 | Farbe Spülenzubehör | F |
853 | Mischbatterien Farbe | F |
854 | Ausführung Mischbatterien | A |
900 | Ausführung Allgemeines Zubehör | A |
901 | Farbe Allgemeines Zubehör | F |
930 | zus. grafisch relevante Ausführung 1 | A | unbedingt den Softwarehäusern separat mitteilen
931 | zus. grafisch relevante Farbe 1 | F | unbedingt den Softwarehäusern separat mitteilen
932 | zus. grafisch relevante Ausführung 2 | A | unbedingt den Softwarehäusern separat mitteilen
933 | zus. grafisch relevante Farbe 2 | F | unbedingt den Softwarehäusern separat mitteilen
934 | zus. grafisch relevante Ausführung 3 | A | unbedingt den Softwarehäusern separat mitteilen
935 | zus. grafisch relevante Farbe 3 | F | unbedingt den Softwarehäusern separat mitteilen
936 | zus. grafisch relevante Ausführung 4 | A | unbedingt den Softwarehäusern separat mitteilen
937 | zus. grafisch relevante Farbe 4 | F | unbedingt den Softwarehäusern separat mitteilen
938 | zus. grafisch relevante Ausführung 5 | A | unbedingt den Softwarehäusern separat mitteilen
939 | zus. grafisch relevante Farbe 5 | F | unbedingt den Softwarehäusern separat mitteilen
950 | Ausführung Diverses 1 | A |
951 | Farbe Diverses 1 | F |
952 | Ausführung Diverses 2 | A |
953 | Farbe Diverses 2 | F |
954 | Ausführung Diverses 3 | A |
955 | Farbe Diverses 3 | F |
956 | Ausführung Diverses 4 | A |
957 | Farbe Diverses 4 | F |
958 | Ausführung Diverses 5 | A |
959 | Farbe Diverses 5 | F |
960 | Ausführung Diverses 6 | A |
961 | Farbe Diverses 6 | F |
962 | Ausführung Diverses 7 | A |
963 | Farbe Diverses 7 | F |
964 | Ausführung Diverses 8 | A |
965 | Farbe Diverses 8 | F |
966 | Ausführung Diverses 9 | A |
967 | Farbe Diverses 9 | F |
968 | Ausführung Diverses 10 | A |
969 | Farbe Diverses 10 | F |
970 | Ausführung Diverses 11 | A |
971 | Farbe Diverses 11 | F |
972 | Ausführung Diverses 12 | A |
973 | Farbe Diverses 12 | F |
974 | Ausführung Diverses 13 | A |
975 | Farbe Diverses 13 | F |
976 | Ausführung Diverses 14 | A |
977 | Farbe Diverses 14 | F |
978 | Ausführung Diverses 15 | A |
979 | Farbe Diverses 15 | F |
980 | Ausführung Diverses 16 | A |
981 | Farbe Diverses 16 | F |
982 | Ausführung Diverses 17 | A |
983 | Farbe Diverses 17 | F |
984 | Ausführung Diverses 18 | A |
985 | Farbe Diverses 18 | F |
986 | Ausführung Diverses 19 | A |
987 | Farbe Diverses 19 | F |
988 | Ausführung Diverses 20 | A |
989 | Farbe Diverses 20 | F |
998 | kundenspezifische Motive | F |
999 | Fixe Materialzuordnung | F |

Typ: A = Ausführung

F = Farbe

K = Kombination

S = Form


 Typenschlüssel
IDM 2.8.1 Block XML-Schema Dokumentation Ansicht mit NavigationswerkzeugeEinleitung > Typenschlüssel |
Typ-Nr. | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Unterschrank | Floor cupboard
2 | Hochschrank | Tal cupboard
3 | Hänge-/Oberschrank | Hanging/wall cupboard
4 | APL-Aufsatz | Work-top mounted cupboard
5 | Nischengestaltung | Recess kit
6 | Highboard | Highboard
7 | Nischenschrank |
8 | Solitärmöbel |
9 | Frontelement | Front element
10 | Modul-Element |
11 | Kranzprofil | Cornice profile
12 | Lichtblende | Pelmet
13 | Deckenblende | Top facing
14 | Sockelblende | Plinth filler
15 | Sockelleiste | Plinth board
17 | Arbeitsplatte | Work-top
18 | WAP | Wall end moulding
19 | Abdeckplatte | Covering plate
20 | Baldachin | Canopy
21 | Überbauboden | Over shelf
22 | Konstruktionsboden | Construction shelf
24 | Kaminesse | Chimney
26 | Elektrogerät | Appliance
27 | Gasgerät | Gas appliance
28 | Kleingerät | Small appliance
29 | Spüle | Sink
30 | Armatur | Tab unit
35 | Beleuchtung | Lighting
37 | Allgem. Zubehör | General accessory
38 | Sonstiges | Other
41 | Block | Block
42 | Mehrausstattung | Additional equipment
43 | Werteverrechnung |
95 | Vorgez. Recyclinggeb. |
98 | Information als Unterp. |
99 | Allgem. Text/Auftrag |


 Ausstattungsschlüssel
IDM 2.8.1 Block XML-Schema Dokumentation Ansicht mit Navigationswerkzeuge Einleitung > Ausstattungsschlüssel
AusstattungID | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Allesschneider | Universal cutter
2 | Brot | Bread
3 | Drehboden | Rotating shelf
4 | Flaschen | Bottles
5 | Glas | Glass
6 | Handtuch | Hand towel
7 | Innenschub/-zug |
8 | Putzmittel/Besen |
9 | Reste/Abfallsystem |
10 | Schwenkmechanik |
11 | Ausziehtisch |
12 | Vorrat | Larder
13 | Wäsche | Linen
14 | Gewürz | Spice
16 | Trockner | Dryer
17 | Herd | Cooker
18 | Backofen | Oven
19 | Kochmulde | Hob
20 | Ceranfeld | Ceramic hob
21 | Dunsthaube | Cooker hood
22 | Abzug | Extractor
23 | Lüfterbaustein |
24 | Microwelle | Microwave
25 | Spülmaschine | Dishwasher
26 | Gefrierschrank | Freezer
27 | Kühlschrank | Fridge
28 | Waschmaschine | Washing machine
29 | Funktions-/Schaltkasten |
30 | Doppelbackofen | Double oven
31 | Spüle | Sink
32 | Dampfgarer |
33 | Warmhaltezone |
34 | Grill |
35 | Friteuse |
36 | Schneidbrett beheizt |
37 | Kaffeemaschine |
41 | Kühl-/Gefrierkombination |
42 | Back-Mikro-Kombination |
43 | Backen/Wärmen |
46 | Niederdruck | Low pressure
47 | Hochdruck | High pressure
48 | TV-Gerät |
49 | Wasserspender |
50 | Geschirrwärmer |
51 | Muldenlüfter (Dunstabzug/Lüfterbaustein) |
52 | Eiswürfelspender |
53 | Bierkühler |
54 | Schublade |


 Einbau Info- Schlüssel
IDM 2.8.1 Block XML-Schema Dokumentation Ansicht mit NavigationswerkzeugeEinleitung > Einbau Info- Schlüssel
EinbauInfo-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Integrierbar |
2 | Einbau |
3 | Unterbau |
4 | Standgerät |
5 | Voll Integrierbar |
7 | Nische integriert |
8 | Nische offen |
11 | Frontbündig |
12 | Korpusbündig |
13 | Flächenbündig |
14 | Auflage | Lay-on
15 | Module |
17 | freistehend |
18 | freihängend |
19 | wandhängend |
21 | Sichtseite |
22 | Seitlicher Sockel |
23 | Formstück |
24 | Retoure |
25 | Übergang |
26 | Gehrungszuschlag |
28 | Breitenkürzung |
29 | Tiefenkürzung |
30 | Höhenkürzung |
32 | Ausschnitt | Cut-out
33 | Abschrägung |
34 | Abrundung |
35 | Verbindung |
36 | Ausklinkung | Release
37 | Bearbeitung |
46 | Zeile 60 cm |
47 | Ecke | Edge
48 | Zeile 60 cm + Ecke |
49 | Spezialschrank |


 Materialschlüssel
IDM 2.8.1 Block XML-Schema Dokumentation Einleitung > Materialschlüssel
Material-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Kunststoff | Plastic
2 | Corian | Corean
3 | Echtholz | Wood
4 | Naturstein | Natural stone
5 | Metall | Metal
6 | Fliesen | Tiles
7 | Glas | Glass
8 | Verbundwerkstoff | Composite material
9 | Edelstahl | Stainless Steel
10 | Aluminium | Aluminium
11 | Stahl emailliert | Enameled steel
12 | Keramik | Ceramic


 Formschlüssel
IDM 2.8.1 Block XML-Schema Dokumentation Einleitung > Formschlüssel
Form-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Rechteckig | Square
2 | Diagonal | Diagonal
3 | Innenrund | Insidecurve
4 | Rund | Round
5 | Halbrund/Rundung | Half-round/rounding
6 | Schräg | Angled
7 | Z-Form / 3-D | Z-Form / 3-D
8 | Wellenform | Wavy
9 | 45-Grad | 45-degree
10 | 90-Grad | 90-degree
11 | 135-Grad | 135-degree
12 | N-Grad | N-degree


 Frontausprägungsschlüssel
IDM 2.8.1 Block XML-Schema Dokumentation Einleitung > Frontausprägungsschlüssel
Frontausprägung-Nr. | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Tür | Door
2 | Schubkasten | Drawer
3 | Auszug | Pull-out
4 | Glastür | Glass door
5 | Klappe | Lid/flap
6 | Schaltkastenblende | Switch cabinet bezel
7 | Jalousie | Blind
8 | Schiebetür |
9 | Faltklappentür |
10 | Rollfront |
11 | Tür/Schubkasten | Door/drawer
12 | Auszug/Schubkasten | Pull-out/drawer
13 | Schubkasten/Jalousie | Drawer/blind
14 | Auszug/Tür | Pull-out/door
15 | Auszug/Schubk./Tür | Pull-out/drawer/door
16 | Tür/Klappe | Door/flap
17 | Auszug/Schubk./Klappe | Pull-out/drawer/flap
18 | Schubkasten/Rollfront |
20 | ohne Front |
21 | 1 Becken o. Abtropfb. | 1 bowl without strainer bowl
22 | 1,5 Becken o. Abtropfb. | 1,5 bowls without strainer bowl
23 | 2 Becken o. Abtropfb. | 2 bowls without strainer bowl
24 | 1 Becken m. Abtropfb. | 1 bowl with strainer bowl
25 | 1,5 Becken m. Abtropfb. | 1,5 bowls with strainer bowl
26 | 2 Becken m. Abtropfb. | 2 bowls with strainer bowl
27 | Abtropfbereich | Strainer bowl
28 | 1 Becken m. Abfalls. | 1 bowl with rubbish container
29 | 1,5 Becken m. Abfalls. | 1,5 bowls with rubbish container
30 | 2 Becken m. Abfalls. | 2 bowls with rubbish container
31 | 1 Becken m. Abt.+Abf. | 1 bowl with strainer bowl and rubbish
32 | 1,5 Becken m. Abt.+Abf. | 1,5 bowls with strainer bowl and rubbish
33 | Abfall | Rubbish
36 | m. Rohrauslauf |
37 | m. Rohrauslauf vers./ab. |
38 | m. Schlauchbrause |
39 | m. Schlauchbr. vers./ab. |
41 | 1 Kochfläche | 1 ring
42 | 2 Kochflächen | 2 rings
43 | 3 Kochflächen | 3 rings
44 | 4 Kochflächen | 4 rings
45 | 5 Kochflächen | 5 rings
46 | 6 Kochflächen | 6 rings
47 | 7 Kochflächen | 7 rings
48 | 8 Kochflächen | 8 rings
49 | 9 Kochflächen | 9 rings


 Typenschlüssel- Arten

IDM 2.8.1 Block XML-Schema Dokumentation Einleitung > Typenschlüssel-Arten
Art-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Normal | Normal
2 | Regal | Shelf
3 | Rahmen | Frame
4 | Seitenverkleidung | Side cladding
5 | Rückwandverkleidung | Rear cladding
6 | Frontblende | Front facing
7 | Dekorblende | Decorative facing
8 | Formwange | Shaped cheek
9 | Raumteiler | Room divider
10 | Unterbau | substructure
11 | Aufsatz | Cap
14 | Paßstück | Filler
15 | Blende | Baffle
16 | Umbau |
17 | Modul-Umbauschrank |
19 | Einlegeboden | Shelf
21 | Barplatte | Bar top
22 | Ansetztisch | Fixed table
26 | Pilaster | Pilaster
27 | Stollen |
28 | Paneel | Panel
29 | Bord/Konsole | Board/table
30 | Reling | Rail
32 | Einhebelmischer |
33 | Zweigriffarmatur |
34 | Sonstige Armaturen |
36 | Umluft |
37 | Abluft |
40 | Zubehör | Accessory


 Sprachenschlüssel

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Niederländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu


 Länderschlüssel

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Länderschlüssel

Länderkennzeichen | Ländername(deutsch) | Ländername(englisch)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


 Einkaufsverbände
IDM 2.8.1 Block XML-Schema Dokumentation Ansicht mit NavigationswerkzeugeEinleitung > Einkaufsverbände
Verbands-kunde | Verbandsname | Strasse | PLZ | Ort | Telefon | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13 A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Beinhaltet Form und Material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunscheig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co. KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60


 Typen für Detailinformation

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Typen für Detailinformation

Für die Beschreibung der Art der Detailinformation gibt es folgende Info-Typen:

1
= Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges


 Dateibenennung

IDM 2.8.1 Block XML-Schema Dokumentation

Einleitung > Dateibenennung

Für den Dateinamen eines Datensatzes werden folgende Empfehlungen gegeben:

· Der Name des Datensatzes darf nicht auf 8 Zeichen begrenzt sein.

· Möglichst sollten alle Bestandteile aus dem Element CATALOG_IDENTIFICATION genutzt werden:

· Folgende Bestandteile wurden vorgeschlagen:

· Herstellernummer

· IDM-Version

· Kundennummer (Wert aus dem Element ASSOC_CTM_NO)

· Sämtliche Sprachen

· Jahreszahl

· Haupt-Nummer (MAJOR)

· Zeitstempel der Dateifreigabe (FILE_RELEASE_DATE)


 Schema IDM_2_8_1_Block.xsd.DE.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\IDM\Doku IDM_2_8_1_Block\IDM_2_8_1_Block.xsd.DE.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
T_NEW_BLOCK | languagetexte
 | languagetexte30
 | languagetexte40
 | languagetexte60
 | languagetexte60999


 element T_NEW_BLOCK
diagram
properties
content complex
children CATALOG SUPPLIER GLOBAL_DEFINITION SERIES FEATURE_DEFINITION BLOCK_VALUE_CALCULATION
annotation
documentation
In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Block-Kataloges/Datenbestandes hinterlegt.


 attribute T_NEW_BLOCK/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 2 |
maxInclusive | 2 |
annotation
documentation
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION.


 attribute T_NEW_BLOCK/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 8 |
maxInclusive | 8 |
annotation
documentation
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.


 attribute T_NEW_BLOCK/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 1 |
annotation
documentation
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.


 element T_NEW_BLOCK/CATALOG
diagram
properties
content complex
children FILE_RELEASE_DATE CATALOG_IDENTIFICATION CATALOG_NUMBER CATALOG_YEAR MIN_MAJOR_NO CATALOG_NAME DATA_VERSION VALID_FROM_DATE FILE_ID CATALOG_MARK FILLING_LEVEL PRICING_TERMS CATALOG_INFO FALL_BACK_LANGUAGE
annotation
documentation
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.


 element T_NEW_BLOCK/CATALOG/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
Das Element FILE_RELEASE_DATE sollte automatisch beim Export der Daten gesetzt werden und das aktuelle Datum und die UTC-Uhrzeit beinhalten.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children MANUFACTURER_ID ISO_LANGUAGE_ID CURRENCY_KEY COUNTRY_ID CATALOG_KIND ASSOC_CTM_NO PRODUCT_BRANDNAME PRICE_ID VAT
annotation
documentation
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/MANUFACTURER_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/CATALOG_KIND
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
maxInclusive | 3 |
annotation
documentation
Dieses Feld dient der Identifizierung der Verbandskataloge.

Folgende Werte sind möglich:
1 = Basiskatalog
2 = Verbandskatalog
3 =kundenspezifischer Katalog

Ist das Feld mit 2 oder 3 gefüllt, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/ASSOC_CTM_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände").


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/PRODUCT_BRANDNAME
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
In diesem Element wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/PRICE_ID
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis
2 = Identnummer
3 = Verrechnungspunkt

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/VAT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung.


 element T_NEW_BLOCK/CATALOG/CATALOG_NUMBER
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
annotation
documentation
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen.


 element T_NEW_BLOCK/CATALOG/CATALOG_YEAR
diagram
type xs:gYear
properties
content simple
annotation
documentation
Dieses Element bezieht sich auf das Kalenderjahr der Katalogdaten des Hauptkataloges.


 element T_NEW_BLOCK/CATALOG/MIN_MAJOR_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
Wird ein neuer Katalog heraus gegeben oder werden Löschungen in einem Katalog vorgenommen, ändert sich, die Hauptnummer (MAJOR_NO) des Hauptkataloges. Wird die Änderung in einem neuen Jahr vollzogen, wird dass Kalenderjahr (CATALOG_YEAR) angepasst und die Hauptnummer auf 1 gesetzt. Wird in einem Jahr kein neuer Katalog bereitgestellt und keine Löschungen durchgeführt, bleibt das Kalenderjahr und die Hauptnummer bestehen. Das Element MIN_MAJOR_NO enthält den Mindestwert von MAJOR_NO des Hauptkataloges.


 element T_NEW_BLOCK/CATALOG/CATALOG_NAME
diagram
type | languagetexte30
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.


 element languagetexte30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetexte30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetexte30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_NEW_BLOCK/CATALOG/DATA_VERSION
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden.


 element T_NEW_BLOCK/CATALOG/VALID_FROM_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben.


 element T_NEW_BLOCK/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten


 element T_NEW_BLOCK/CATALOG/CATALOG_MARK
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [BKV] |
annotation
documentation
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)

handelt.


 element T_NEW_BLOCK/CATALOG/FILLING_LEVEL
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [123]|2[a-n] |
annotation
documentation
Über die Füllstufe (FILLING_LEVEL) wird definiert, mit welchem Detaillierungsgrad die Katalogdaten beschrieben werden. Im Grundsatz steigt mit zunehmender Füllstufe die Datenqualität, da mit dem steigenden Detaillierungsgrad die Herstellerspezifik der Daten zunimmt.
Die Füllstufen werden bei der Datenzertifizierung ausgewertet: Anhand der Füllstufe wird überprüft, welche Informationen in den Daten vorhanden sein müssen, um die angegebene Füllstufe zu erreichen. Ist eine geforderte Information nicht vorhanden, so wird der Datenbestand nicht zertifiziert.
Die Füllstufen sind wie folgt definiert:
- Füllstufe 1: Es werden Basisinformationen mit Ausnahme der Elemente zur Beschreibung von Texturinformationen
- Füllstufe 2a: Die Füllstufe 1 wird ergänzt um Informationen über Texturen und Material (Farben RGB, Transparenz und Glanz)
- Füllstufe 2b: Die Füllstufe 1 wird ergänzt um Informationen über Frontaufteilungen und Frontausprägungen
- Füllstufe 2c: Die Füllstufe 1 wird ergänzt um Informationen über Griffe
- Füllstufe 2d: Die Füllstufe 1 wird ergänzt um Informationen über Artikeltexturen

Es sind auch Kombinationen der Füllstufen 2a-2d möglich. Folgende Aufschlüsselung der Kombinationen sind definiert:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Füllstufe 3. Um die Füllstufe 3 zu erreichen, müssen die Informationen aus den Füllstufen 1 und 2a - 2d enthalten sein und um Informationen über Echtgrafik ergänzt werden. Mit der Füllstufe 3 werden die Möglichkeiten des Datenformates zur herstellerspezifischen Abbildung gänzlich angewendet.
Die Definition, welche Informationen von welcher Füllstufe gefordert werden, erfolgt im Tabellenteil "Füllstufen".


 element T_NEW_BLOCK/CATALOG/PRICING_TERMS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 1 |
pattern | [01] |
annotation
documentation
Mit diesem Element wird definiert, welche Preise in den Daten angelegt werden.
Dieses Element wird zur Unterscheidung beim Datenimport herangezogen, um zu vermeiden, dass sich die Preise bei gleichen Katalogen überschreiben.

Folgende Werte sind möglich:
0 = die angegebenen Preise sind Einkaufspreise für den Handel
1 = die angegebenen Preise sind unverbindliche Preisempfehlungen (UPE)

Entsprechend dem angegebenem Wert müssen die richtigen Preise in den Daten angelegt werden.


 element T_NEW_BLOCK/CATALOG/CATALOG_INFO
diagram
type | languagetexte60999
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
In diesem Element werden die Informationstexte abgelegt.


 element languagetexte60999/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetexte60999/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetexte60999/LANGUAGE/TEXT_LINE
diagram
properties
minOcc | 1
maxOcc | 999
content | complex
children TEXT
annotation
documentation
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.


 attribute languagetexte60999/LANGUAGE/TEXT_LINE/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen.


 element languagetexte60999/LANGUAGE/TEXT_LINE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,60} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 element T_NEW_BLOCK/CATALOG/FALL_BACK_LANGUAGE
diagram
type restriction of xs:language
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen.


 element T_NEW_BLOCK/SUPPLIER
diagram
properties
content complex
children CONTACT_PERSON CONTACT_SUPPLIER
annotation
documentation
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON
diagram
properties
minOcc | 1
maxOcc | 2
content | complex
children CONTACT_PERSON_NO CONTACT_ROLE CONTACT_NAME FIRST_NAME FORM_OF_ADDRESS DEPARTMENT TELEPHONE FAX EMAIL STREET ZIPCODE_STREET CITY
annotation
documentation
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/CONTACT_PERSON_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme)


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/CONTACT_ROLE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 60 |
annotation
documentation
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher).


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/CONTACT_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/FIRST_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/FORM_OF_ADDRESS
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/DEPARTMENT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/TELEPHONE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/FAX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
In diesem Element wird die E-Mail-Adresse angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/CITY
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Sitz des Herstellers angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER
diagram
properties
content complex
children MANUFACTURER_NAME_1 MANUFACTURER_NAME_2 EMAIL INTERNET_ADDRESS STREET ZIPCODE_STREET CITY ZIPCODE_POSTBOX POSTBOX TELEPHONE_SWITCHBOARD FAX_SWITCHBOARD
annotation
documentation
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_1
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird die 1. Zeile des Firmennamens angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_2
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/INTERNET_ADDRESS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de).


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/CITY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Sitz des Herstellers angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{0,10} |
annotation
documentation
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/TELEPHONE_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/FAX_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.


 element T_NEW_BLOCK/GLOBAL_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CLEARING_GROUP DETAIL_INFOS
annotation
documentation
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children EXCHANGE_ID_REF CLEARING_GROUP_NAME
annotation
documentation
Das Element dient zur Definition von Verrechnungsgruppen. Eine Verrechnungsgruppe wird durch das Zusammenfassen mehrere Tausch-ID gebildet.

Die Verrechnungsgruppen werden in Blockbedingungen (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) und den Wertestaffeln (BLOCK_VALUE_CALCULATION/GRADING_TABLE) zur Bestimmung von Mindestwerten bestimmter Typenbereiche verwendet. Die Typenbereiche werden durch die Tausch-ID identifiziert.

Die Beträge aller Auftragsposition, deren Tausch-ID in einer Verrechnungsgruppe enthalten sind, werden summiert. Je Verrechnungsgruppe resultiert eine Summe, die als Vergleichskriterium zum Einstieg in die Blockbedingungen und in die Wertestaffel verwendet wird.


 attribute T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP/@CLEARING_GROUP_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Dieses Attribut identifiziert eine Verechnungsgruppe.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP/EXCHANGE_ID_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element referenziert eine Tausch-ID.


 attribute T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP/EXCHANGE_ID_REF/@EXCHANGE_ID_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP/CLEARING_GROUP_NAME
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.


 element languagetexte60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetexte60/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetexte60/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,60} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO
annotation
documentation
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION INFO_TYPE EXTERNAL_NAME INTERNAL_NAME TOOL_TIP URL RESOLUTION
annotation
documentation
In diesem Element wird eine Detailinformation definiert.


 attribute T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
Dieses Attribut identifiziert eine Detailinformation.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/CLASSIFICATION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
Dieses Element dient der Klassifizierung der Detailinformation.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INFO_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[01]|99 |
annotation
documentation
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME
diagram
type | languagetexte
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Anzeigename des Links (z.B. "Magic Corner in Bewegung").


 element languagetexte/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute languagetexte/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetexte/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
b Fettdruck
br Zeilenumbruch


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
diagram
type | languagetexte40
properties
content complex
children | LANGUAGE
annotation
documentation
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.


 element languagetexte40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetexte40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetexte40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,40} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
diagram
type | languagetexte
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält Text für einen Tooltip zum Link.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL
diagram
properties
content complex
children LANGUAGE
annotation
documentation
Dieses Element ist für die URL zur Detailinformation.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT HASH_VALUE
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/TEXT
diagram
type restriction of xs:anyURI
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 1024 |
annotation
documentation
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/HASH_VALUE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/RESOLUTION
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 4 |
annotation
documentation
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei.


 element T_NEW_BLOCK/SERIES
diagram
properties
content complex
children SERIE
annotation
documentation
In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren zugeordneten Elementen wie beipsielsweise Blöcke und deren Artikeln hinterlegt.


 element T_NEW_BLOCK/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 100
content | complex
children PRODUCT_GROUPS
annotation
documentation
In diesem Element werden die Serien definiert.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.


 attribute T_NEW_BLOCK/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
In diesem Attribut wird die Seriennummer der Serie definiert.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
content complex
children PRODUCT_GROUP
annotation
documentation
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRODUCT_GROUP_TEXT ITEMS
annotation
documentation
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/PRODUCT_GROUP_TEXT
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält die Bezeichung einer Produktgruppe.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
In diesem Element werden alle Artikel einer Produktgruppe definiert.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_BASE_PRICE_REF PRICE_TYPE_REF CALC_GROUP_REF EXCHANGE_ID_REF RESTRICTIONS EDP_NUMBER BLOCK_PRICE_STATUS ITEM_IDENTIFICATION CATALOG_PAGE VAT_ID_REF VALID_FROM VALID_UNTIL RANGE_DEPENDENT BLOCK_PARTS ITEM_TEXT TYPE_KEY CLASSIFICATIONS DETAIL_INFOS
annotation
documentation
In diesem Element werden Blöcke und deren Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1) des Hauptkataloges.


 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.


 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60).


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1) aus dem Hauptkatalog, in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE
annotation
documentation
In diesem Element wird der Blockpreis hinterlegt.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
Dieses Element refrenziert auf das Blockpreisfeld (BLOCK_PRICE_FIELD unterhalb von PRICE_DEFINITION im Hauptkatalog).

Die Werte von BLOCK_PRICE_FIELD können identisch mit den Werten von PRICE_FIELD sein. Sie können für die einzelnen Programme innerhalb der Katalogpreisgruppen aber auch unterschiedlich vergeben werden.

Dabei gilt folgendes:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE >
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € =&gt; -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Element für die entsprechende Preisgruppe angelegt.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF
diagram
properties
content complex
annotation
documentation
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE des Hauptkataloges definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF/@PRICE_TYPE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF/@PRICE_TYPE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Über dieses Attribut wird eine Preisart identifiziert.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CALC_GROUP_REF
diagram
properties
content complex
annotation
documentation
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen im Hauptkatalog definiert.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CALC_GROUP_REF/@CALC_GROUP_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CALC_GROUP_REF/@CALC_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 10 |
maxInclusive | 99 |
annotation
documentation
Über dieses Attribut wird eine Preisart identifiziert.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID des Hauptkataloges definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF/@EXCHANGE_ID_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF/@EXCHANGE_ID_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
Das Attribut identifiziert eine Tausch-ID.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children RESTRICTION_REF
annotation
documentation
In diesem Element werden blockspezifische Prüfverfahren zugeordnet.

Wenn ein Block Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Blockspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element referenziert ein, dem Block zugeordnetes Prüfverfahren.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@RESTRICTION_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@RESTRICTION_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@SEQUENCE

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@SEQUENCE >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, ...).


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EDP_NUMBER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PRICE_STATUS
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9 |
annotation
documentation
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M"


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_IDENTIFICATION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [BEKSMZVPNOG] |
annotation
documentation
In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CATALOG_PAGE
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 40 |
annotation
documentation
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör".


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VAT_ID_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1 des Hauptkataloges) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VAT_ID_REF/@VAT_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VAT_ID_REF/@VAT_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
Dieses Element referenziert Mehrwertsteuersätze.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RANGE_DEPENDENT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD des Hauptkataloges gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_PART
annotation
documentation
Dies ist das Container-Element für die Blockstücklisten im Katalog.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children BLOCK_SEQUENTIAL_NO ITEM_REF OPTION_REF HINGE EXCHANGE_CONDITION STATUS BLOCK_ITEM_DIMENSION_WIDTH BLOCK_ITEM_DIMENSION_HEIGHT BLOCK_ITEM_DIMENSION_DEPTH CONSTRUCTION_ID
annotation
documentation
In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1 des Hauptkataloges) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn in den Elementen ITEM (Pfad 1) mindestens ein Element mit dem Element ITEM_IDENTFICATION = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_SEQUENTIAL_NO

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_SEQUENTIAL_NO >
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF >
diagram
properties
content complex
annotation
documentation
In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1 des Hauptkataloges) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@TYPE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60).


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@SERIE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1 des Hauptkataloges) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2 des Hauptkataloges) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@FEATURE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@OPTION_KEY

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
Mit diesem Attribut wird eine Variante referenziert.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/HINGE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/HINGE >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[BEJLMNR] |
annotation
documentation
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1 des Hauptkataloges) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/EXCHANGE_CONDITION

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/EXCHANGE_CONDITION >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 2 |
maxInclusive | 3 |
annotation
documentation
In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/STATUS

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/STATUS >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [ABELSZ] |
annotation
documentation
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_WIDTH

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_WIDTH >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_HEIGHT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_HEIGHT >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_DEPTH

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_DEPTH >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/CONSTRUCTION_ID

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/CONSTRUCTION_ID >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[JLNRAE] |
annotation
documentation
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT
diagram
properties
content complex
children SHORT_TEXT FULL_TEXT PLANNING_ADVICE
annotation
documentation
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext
- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT >
diagram
properties
content complex
children LANGUAGE
annotation
documentation
Dieses Element enthält Kurztexte.

Der Kurztext darf maximal drei Zeilen lang sein und muss mit einem den Artikel näher beschreibenden Text gefüllt werden. Der Kurztext muss alleinstehend auf Kundenformularen druckbar sein. Dieser Text muss einen endverbraucherorientierten Inhalt haben. Der Kurztext muss immer vorhanden sein. Die letzte Zeile eines Kurztextes darf am Zeilenende keine Trennzeichen (z. B. – oder /) enthalten.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID >
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE >
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
children TEXT
annotation
documentation
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT >
diagram
type | languagetexte
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Der Volltext ergänzt den Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

b Fettdruck
br Zeilenumbruch


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE >
diagram
type | languagetexte60999
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält Planungshinweise.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY
diagram
properties
content complex
children TK_TYPE TK_CLASS TK_EQUIPMENT TK_MATERIAL TK_SHAPE TK_FRONT_APPEARANCE
annotation
documentation
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589] |
annotation
documentation
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_CLASS

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_CLASS >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0145679]|2[126789]|3[023467]|4[0] |
annotation
documentation
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten" der Einleitung eingetragen.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT >
diagram
properties
minOcc | 0
maxOcc | 5
content | complex
children TK_INSTALLATION_RECESS
annotation
documentation
Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@SEQUENCE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@TK_EQUIPMENT_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@TK_EQUIPMENT_NO >
type restriction of xs:nonNegativeInteger
properties
use optional
facets
Kind | Value | Annotation
pattern | [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4] |
annotation
documentation
Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel" der Einleitung eingetragen.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children TK_INSTALLATION_INFORMATION TK_RECESS_HEIGHT
annotation
documentation
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_INSTALLATION_INFORMATION

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_INSTALLATION_INFORMATION >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789] |
annotation
documentation
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_RECESS_HEIGHT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_RECESS_HEIGHT >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
Hier wird ein Wert für die Nischenhöhe in mm angegeben.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_MATERIAL

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_MATERIAL >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-2] |
annotation
documentation
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_SHAPE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_SHAPE >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-2] |
annotation
documentation
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_FRONT_APPEARANCE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_FRONT_APPEARANCE >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9] |
annotation
documentation
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CLASSIFICATION
annotation
documentation
In diesem Element werden standardisierte Klassifikationsangaben hinterlegt.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION_CODE VALID_FROM VALID_UNTIL
annotation
documentation
In diesem Element werden standardisierte Angaben zu verschiedenen Klassifikationsschemata hinterlegt.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
pattern | ([1-9]{1}|1[0]{2}) |
annotation
documentation
Dieses Attribut gibt das jeweilige Klassifikationsschema an. Zur Auswahl stehen die Werte der folgenden Liste:

ID Klassifikationsschema
1 eCl@ss
2 Verbandsklassifikation Begros
3 Verbandsklassifikation VME
4 Code Eco Mobilier
5 Ecosystem EEE
6 freies Klassifikationsschema
7 freies Klassifikationsschema
8 freies Klassifikationsschema
9 freies Klassifikationsschema
10 freies Klassifikationsschema

Ist das zu pflegende Schema in der Liste nicht aufgeführt ist eine ID ab 6 für freies Klassifikationsschema auszuwählen.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE >
diagram
type xs:string
properties
content simple
annotation
documentation
Dieses Element enthält den Code für die, dem ITEM zuzuordnende Kategorie des jeweiligen Klassifikationsschemas.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM >
diagram
type xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, ab wann die Klassifikationsangabe gültig ist.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL >
diagram
type xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, bis wann die Klassifikationsangabe gültig ist.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element referenziert Hyperlinks zu Detailinformationen.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO >
properties
use required
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.


 element T_NEW_BLOCK/FEATURE_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children RESTRICTIONS
annotation
documentation
In diesem Element werden variantenabhängige Informationen(Prüfungen) hinterlegt.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS
diagram
properties
content complex
children RESTRICTION
annotation
documentation
In diesem Element werden die Prüfverfahren angelegt.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION
diagram
properties
minOcc | 1
maxOcc | 99999
content | complex
children RESTRICTION_NAME_TEXT OPTION_COMBINATION TEST_ID
annotation
documentation
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@RESTRICTION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@FEATURE_1_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@FEATURE_2_NO
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@FEATURE_3_NO
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@VALIDATION_TYPE
type restriction of xs:int
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 1 |
annotation
documentation
Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefällt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405)


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/RESTRICTION_NAME_TEXT
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTION_REF MAX_DIMENSION MIN_DIMENSION
annotation
documentation
In diesem Element wird eine Variantenkombination gebildet.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/OPTION_REF
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
annotation
documentation
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MAX_DIMENSION
diagram
properties
minOcc | 0
maxOcc | 3
content | complex
annotation
documentation
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MAX_DIMENSION/@DIMENSION_TYPE
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [WHD] |
annotation
documentation
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MAX_DIMENSION/@DIMENSION_VALUE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MIN_DIMENSION
diagram
properties
minOcc | 0
maxOcc | 3
content | complex
annotation
documentation
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MIN_DIMENSION/@DIMENSION_TYPE
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [WHD] |
annotation
documentation
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MIN_DIMENSION/@DIMENSION_VALUE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/TEST_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_CONDITIONS BLOCK_SALE_PRICES GRADING_TABLE SET_OF_BLOCK_RULES
annotation
documentation
In diesem Element wird die Block- und Werteverrechnung defiert.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_CONDITION
annotation
documentation
In diesem Element werden Bedingungen formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.

Ein Block darf für einen Auftrag angewendet werden, wenn alle für diesen Block formulierten Bedingungen erfüllt sind. Die einem Block zugeordneten Bedingungen werden durch das Tupel ITEM_REF (Pfad 1) und OPERATION_ID (Pfad 1) gebildet.

Grundbedingung für die Anwendung der Blockbedingung ist, dass ein Block in einem der Programme existiert, die im Auftrag verplant wurden. Sind in einem Auftrag mehrer Programme ausgewählt, gilt das erste Programm im Auftrag auf Kopfebene.

Ein Block unterliegt der Programm- und Variantensteuerung wie "normale" Artikel. Wenn ein Verrechnungsblock in einer Preisgruppe existieren soll, so wird ein entsprechendes Element ITEM_PRICE (Pfad 2) mit dem Preis 0 angelegt.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein, damit der Block für die Werteverrechnung oder die Blockverrechnung angewendet werden darf.

Pfad 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF CONDITION_RULES
annotation
documentation
In diesem Element wird eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/ITEM_REF
diagram
properties
content complex
annotation
documentation
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60).


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES
diagram
properties
content complex
children CONDITION_RULE
annotation
documentation
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLEARING_GROUP_REF MINIMUM_VALUE MINIMUM_WIDTH
annotation
documentation
In diesem Element werden die Blockbedingungen formuliert.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/CLEARING_GROUP_REF
diagram
properties
minOcc | 1
maxOcc | 999
content | complex
annotation
documentation
Dieses Element referenziert eine Verrechnungsgruppe, für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder ein zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/CLEARING_GROUP_REF/@CLEARING_GROUP_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/MINIMUM_VALUE
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Wert bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/MINIMUM_WIDTH
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Dieses Element stellt die Mindestlänge dar, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_SALE_PRICE
annotation
documentation
In diesem Element werden Blockaktionspreise formuliert.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF VARIATION_PRICE_DEFINITION
annotation
documentation
Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie dürfen nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich außer Kraft gesetzt.
Es werden genau die Informationen zeitlich außer Kraft gesetzt, die in dem Element angegeben sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wird durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/ITEM_REF
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60).


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children VALID_FROM VALID_UNTIL OPTION_REF PRICE_OR_CALCULATION_POINT
annotation
documentation
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/VALID_FROM
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/VALID_UNTIL
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/OPTION_REF
diagram
properties
minOcc | 0
maxOcc | 4
content | complex
annotation
documentation
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/PRICE_OR_CALCULATION_POINT
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CREDIT_SURCHARGE_CLEARING
annotation
documentation
In diesem Element werden die Wertestaffeln zur Verrechnung der Gutschriften oder Aufschläge definiert.

Wenn ein Verrechnungsblock für einen Auftrag gültig ist, kann mit dem Block in die Wertestaffel eingestiegen werden. Je gültigem Block in der Wertstaffel wird eine Vergleichssumme für die in dem Element angegebene Verrechnungsgruppe (CLEARING_GROUP (Pfad 1)) bestimmt. Entspricht der Wert der Vergleichssumme dem angegebenen Wertebereich (Elemente VALUE_FROM (Pfad 2) und VALUE_TO (Pfad 2)), so wird das Element angewendet, d. h. die im Element TYPE_CREDIT (Pfad 2) und/oder TYPE_DEBIT (Pfad 2) hinterlegte Type wird verrechnet. Die Berechnung erfolgt auf die Summe der Kalkulationsgruppe, die für die Gutschrift- oder Belastungstype angegeben ist (Element ITEM (Pfad 3)).

Für einen Block können mehrere Staffelbereiche angelegt werden. Jeder Staffelbereich wird einem Element COMPARING_RULES (Pfad 4) zugeordnet. In einer Staffel eines Blocks müssen die Bedingungen aller Wertebereiche mit jeweiliger Verrechnungsgruppe erfüllt sein, bevor die Positionen verrechnet werden können. Die einzelnen Elemente (COMPARING_RULE) sind UND-verknüpft.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein.

Werden auf dem Element GRADING_TABLE mehrere Datensätze eines Verrechnungsblocks angewendet, so wird der Wert des Blocks (ITEM (Pfad 3)), ITEM_PRICE (Pfad 5)) jedoch nur einmal berechnet.

Pfad 1: GLOBAL_DEFINITION
Pfad 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF COMPARING_RULES
annotation
documentation
In diesem Element wird ein Wertebereich der Wertestaffel definiert.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/ITEM_REF
diagram
properties
content complex
annotation
documentation
Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60).


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children COMPARING_RULE
annotation
documentation
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLEARING_GROUP_ID VALUE_FROM VALUE_TO TYPE_CREDIT TYPE_DEBIT
annotation
documentation
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/CLEARING_GROUP_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/VALUE_FROM
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/VALUE_TO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/TYPE_CREDIT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.
Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/TYPE_DEBIT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.
Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.
Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.
Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)
Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.
Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.
Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES
diagram
properties
content complex
children EXCHANGE_ID_GROUP RULE RULE_SET_TEXT
annotation
documentation
In diesem Element und den Kind-Elementen werden die herstellerspezifischen Regelwerke beschrieben.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children EXCHANGE_ID_1_REF EXCHANGE_ID_2_REF
annotation
documentation
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_1_REF
diagram
properties
content complex
annotation
documentation
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_1_REF/@EXCHANGE_ID_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_2_REF
diagram
properties
content complex
annotation
documentation
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_2_REF/@EXCHANGE_ID_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE
diagram
properties
minOcc | 1
maxOcc | 99
content | complex
children RULE_TEXT
annotation
documentation
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE/@RULE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE/RULE_TEXT
diagram
type | languagetexte60999
properties
content complex
children | LANGUAGE
annotation
documentation
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE_SET_TEXT
diagram
type | languagetexte60999
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.


 complexType languagetexte
diagram
children LANGUAGE
used by
elements T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.


 complexType languagetexte30
diagram
children LANGUAGE
used by
element T_NEW_BLOCK/CATALOG/CATALOG_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.


 complexType languagetexte40
diagram
children LANGUAGE
used by
element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.


 complexType languagetexte60
diagram
children LANGUAGE
used by
elements T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP/CLEARING_GROUP_NAME T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/PRODUCT_GROUP_TEXT T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/RESTRICTION_NAME_TEXT
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.


 complexType languagetexte60999
diagram
children LANGUAGE
used by
elements T_NEW_BLOCK/CATALOG/CATALOG_INFO T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE_SET_TEXT T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE/RULE_TEXT
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bestehend aus bis zu 999 Zeilen der Länge 60.