 Introduction

Ansicht mit Navigationswerkzeuge

IDM 2.8.1 Block XML-Schema

Documentation

release 03/01/2022

Documented XML-scheme:

IDM_2_8_1.xsd

Contact DCC e.V.

Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telephon 0 52 21/12 65-37

Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telephon 0 52 21/12 65-38


 Basic structure of the IDM scheme

IDM 2.8.1 XML-Schema Documentation

Introduction > Basic structure of the IDM scheme

The main element T_NEW_BLOCK defines that a new and complete multi-manufacturer catalogue data pool is made available.

XML files must be UTF-8 encrypted.

The IDM schema is subdivided in data ranges that are specified in the subsequent child-elements (see figure 1) in T_NEW_BLOCK.

Picture 1 - Child elements of T_NEW_BLOCK

The data ranges are not used in isolation from each other. In some data ranges, data is initially created and used from other data ranges via referencing.

Description of the data ranges

CATALOG

CATALOG is used to store administrative information concerning the data pool. E.g. the version of the data format, release date or the unique identification of the data pool.

SUPPLIER

SUPPLIER is used to store administrative information about the manufacturer. Example: specification of contact data, EDI communication parameters or the manufacturer's country of origin.

GLOBAL_DEFINITION

The GLOBAL_DEFINITION data range is a kind of data pool for information used in the other data ranges. Example: It is used to create settlement groups or information about media.

SERIES

SERIES is used to store the data for the description of the blocks. All items (blocks) are assigned to a product group.

FEATURE_DEFINITION

FEATURE_DEFINITION serves the purpose of defining assessment procedures (RESTRICTIONS).

BLOCK_VALUE_CALCULATION

BLOCK_VALUE_CALCULATION is used to store information for the block and onward settlement. Example: Data for rules on block prices (SET_OF_BLOCK_RULES), block conditions(BLOCK_CONDITIONS), or value tables (GRADING_TABLE) can be stored.


 Elements of the catalogue structure

IDM 2.8.1 XML-Schema Documentation

Introduction > Elements of the catalogue structure

Creating elements of the catalogue structure

The basic prerequisite for a block XML file are catalogue data with information on series, ranges, version types, versions, price fields and item data in an existing file.

Based on this, the data provisioning for the blocks including their components and prices can take place in accordance with the catalogue information.

Creating block information

Block information are created in the following element:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The element ITEM has a multitude of elements used to describe the properties of a block. A block is identified via the attribute TYPE_NO.

Please note that depending on the series, an item may have different properties. Consequently, an item and its properties can only be unequivocally identified in combination with the series.

The individual items of the block are then specified within the BLOCK_PARTS element.


 Catalogue structure

IDM 2.8.1 XML-Schema Documentation

Introduction > Catalogue structure

Catalogue and element structure

The fundamental catalogue structure of the data pools is arranged as follows:

Pict. 1 - Catalogue structure of the data pools

This catalogue structure is represented by the following element hierarchy in the IDM scheme:

Pict. 1 – Element hierarchy of the IDM scheme

The SERIE element is used to define the properties of a series. The element RESTRICTION_REF is used to assign versions to a series by assessment procedures. Product groups (PRODUCT_GROUPS) in which items with similar version types are combined are defined within the series. The items are automatically assigned to a series because they are child elements of the SERIE element.


 Referencing

IDM 2.8.1 XML-Schema Documentation

Introduction > Referencing

Referencing of elements

The IDM scheme defines references between different elements. Information about these references is stored in a central data area. Multiple use of this information from different data areas is achieved via references. The type of reference which is used in the IDM scheme is described as follows:

Terminology

the following terms for references are used in the IDM scheme:

Key-Element | an XML element which is referenced by other elements.
Ref-Element | an XML element which references other elements.

Reference operation

A key element is identified unambiguously by its attributes. The Ref-element possesses at least the key-attributes of the key-element. A reference between the elements is defined by congruent attributes values of ref- and key-element.

Example: Referencing of a series from an item

The following example shows the way in which way an item ( ITEM ) references a series ( SERIE ). Only an abstract of the XML elements is shown here.

Key-element

T_NEW_CATALOG/SERIES/SERIE

<SERIES>

<SERIE SERIE_NO="1"/> … </SERIE>

<SERIE SERIE_NO="2"/> … </SERIE>

<SERIE SERIE_NO="3"/> … </SERIE>

. . .

<SERIE SERIE_NO="99"/> … </SERIE>

</SERIES>

Ref-element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS>

<ITEM SERIE_NO="1" . . . />

. . .

</ITEMS>

Example: Referencing of a feature

In the following example a feature is referenced by a restriction.

Key-element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!-- Sockelausführung -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!-- Sockelfarbe -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

The XML elements define for feature type 400 (FEATURE) three options (OPTION) numbered 1-3 and for the feature type 401 three options with numbers 1-3. A feature is identified by the combination of FEATURE_NO and OPTION_KEY.

Ref-element

T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_REF

<RESTRICTION RESTRICTION_NO="1">

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="1" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

The XML elements define a restriction for legal combinations (TEST_ID = 1) for the plinth features ( FEATURE_NO=400 ) and plinth colours (FEATURE_NO=401) The ref-element OPTION_REF with the attributes highlighted in grey, reference the key-element OPTION.


 Restrictions

IDM 2.8.1 XML-Schema Documentation

Introduction > Restrictions

Definition and assignment of restrictions

The validity of restrictions may be series specific or comprehensive, programme specific or item specific. The priority of a restriction corresponds with the hierarchy level series -> programme -> item on which the restriction is defined. A restriction defined on item level overrides a restriction which is defined on programme level. Overriding restrictions may only define additional restrictions but not reverse previous restrictions. Example: the availability of an item in a programme is excluded by a restriction defined on item level. A restriction defined on item level may not reverse this exclusion.

First, the restrictions are defined and in a second step they are assigned to series, programmes and items. Definition

Definition of restrictions

Restrictions are defined in the following element:

FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

The element RESTRICTION references the feature combinations for which the restrictions have been defined. The element OPTION_REF references the feature combinations which are subject to control procedures. The element TEST_ID defines a feature combination as legal or illegal combination.

Example: definition of restrictions

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="523" FEATURE_1_NO="100" FEATURE2_NO="101">

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA" FEATURE_NO="100"/> #lacquered

<OPTION_REF OPTION_NO="RO" FEATURE_NO="101"/> # red

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA" FEATURE_NO="100"/> # lacquered

<OPTION_REF OPTION_NO="GR" FEATURE_NO="101"/> # green

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="FU" FEATURE_NO="100"/> # veneered

<OPTION_REF OPTION_NO="BU" FEATURE_NO="101"/> # beech

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

The above mentioned example shows a restriction which defines a legal feature combination of „front finish" (No. 100) and "front colour" (No. 101). According to the above mentioned restriction the combinations lacquer-red, lacquer-green and beech veneer are permitted (TEST_ID = 1). The listing of permitted combinations (OPTION_REF) has to be in accordance with the sequence defined by the attributes in the element RESTRICTION (FEATURE_1_NO, FEATURE_2_NO)

For the purpose of unique and unambiguous identification of a restrictrion a RESTRICTION_NO) is assigned.

Assignment of restrictions

Series independent restriction

Series independent restrictions are assigned by the following elements:

SERIES/RESTRICTIONS/RESTRICTION_REF

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

As the element RESTRICTION_REF is a child element of SERIES/RESTRICTIONS, all restrictions referenced in the element RESTRICTION_REF are assigned to all series which are defined in SERIES/SERIE.

Example: Series independent assignment of restrictions

<SERIES>

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="523"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="678"/>

</RESTRICTIONS>

</SERIES>

In the above mentioned example the restrictions 523 and 678 are referenced and assigned to all series.

Series specific assignment

The rules for a series specific assignment of restrictions correspond to that of series independent assignment. the following element is used for the series-specific assignment:

SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF

The restrictions referenced in the element RESTRICTION_REF are assigned to that series in which the reference was made.

Restrictions which are assigned to programmes are one-level restrictions, containing only the feature No. 1( programme). These restrictions are mandatory if series > 0 and feature No. 1 is defined in the database.

Example: Series-specific assignment of restrictions

<SERIES>

<SERIE SERIE_NO="2">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="67"/>

</RESTRICTIONS>

</SERIE>

<SERIE SERIE_NO="7">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="123"/>

</RESTRICTIONS>

</SERIE>

</SERIES>

In the above mentioned example restrictions 45 and 67 are assigned to series "2" and restrictions 45 and 123 are assigned to series "7".

Item specific assignment

A programme specific assignment of restrictions is defined in the following element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

For item specific assignment the sames rules as for series or programme specific assignment apply.

If no restrictions are assigned to an item, this item is available without any restriction regarding series or programme.

Product group specific assignment

The product group specific assignment of restrictions is defined in the following element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF

The rules for a product group specific assignment of restrictions correspond with the rules for series and programme specific assignment.


 Data types

IDM 2.8.1 XML-Schema Documentation

Introduction > Datatypes

Data types and value ranges

The IDM schema used the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

The following data types are used:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDM, the data type date is used in conformity with the XML schemas as follows: YYYY-MM-DD YYYY = year, MM = month, DD = day
dateTime | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY-MM-DDThh:mm:ssZ YYYY = year, MM = month, DD = day T = Start of time information hh = hour, mm = minute, ss = second Z = UTC time
gYear | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDM for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 or 45.98000 or +27.0.
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDM for mapping URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used for the specification of valid language codes in the IDM.language represents codes for natural languages Tags for the Identification of Languagesas defined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.

The value ranges of the above data types are usually restricted for the elements in the IDM. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters and value lists.

In the XML documentation of the IDM, the value ranges are specified by the information coming after M and P.

In addition to XML data types mentioned here, separate data types are defined for the texts.

They are explained at the end of the documentation.

See also

languagetexte Complex Type

languagetexte30 Complex Type

languagetexte40 Complex Type

languagetexte60 Complex Type

languagetexte60999 Complex Type


 Explanations for the documentation

IDM 2.8.1 XML-Schema Documentation

Introduction > Explanations for the documentation

Explanations for the IDM documentation

This paragraph contains explanations for the documentation of the IDM scheme.

Meaning of element properties

Each element is documented with a description and its properties. The following example shows an element description:

EXCHANGE_ID_NO Attribute Collapse All

Description

This attribute identifies an exchange-ID.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

The properties of the element are listed on the right side. The following abbreviations are used:

D | Documentation of the data type for the element. If no value is set here, the element does not contain user data but further child elements.
P | The values P and M are used to define the range of values. The regular term in P defines the number of legal values.
M | M defines the minium and maximum value in the range of legal values. In a string data type P defines the legal values and M defines the minimum and maximum length of the string. For numerical data types M defines the minimum and maximum value.


 Variation types

Ansicht mit Navigationswerkzeuge

IDM 2.8.1 XML-Schema Documentation

Introduction > Variation types

Variation type | Variation text | Option type | Remark
1 | programm/ style | A | programm asvariation type
2 | serial number | A | assignment of a five-digit serial number
100 | Front finish | A |
101 | Front colour 1 | F | Front filling smooth = complete surface
102 | Front colour 2 | F | Frame
103 | Front colour 3 | F | Pilaster strips
104 | Edge colour front | F |
105 | Front combination | K | If only one key is used for different front information
106 | Front group | A | Overrides the FRONT_GROUP_NO in element FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Front finish contrast colour 1 | A |
111 | Front colour 1 contrast colour 1 | F | Front filling smooth = complete surface
112 | Front colour 2 contrast colour 1 | F | Frame
113 | Front colour 3 contrast colour 1 | F | Pilaster strips
114 | Edge colour front, contrast colour 1 | F |
115 | Front combination, contrast colour 1 | K | The variations 111 - 114 are permitted.
120 | Front finish contrast colour 2 | A |
121 | Front colour 1 contrast colour 2 | F | Front filling smooth = complete surface
122 | Front colour 2 contrast colour 2 | F | Frame
123 | Front colour 3 contrast colour 2 | F | Pilaster strips
124 | Edge colour front, contrast colour 2 | F |
125 | Front combination, contrast colour 2 | K | The variations 121 - 124 are permitted.
150 | Glass finish | A |
151 | Glass colour | F |
152 | Mullion type | A |
153 | Mullion colour | F |
154 | Type glass door frame | A |
155 | Colour glass door frame | F |
160 | Type roller shutter | A |
161 | Colour roller shutter | F |
170 | Type container | A |
171 | Colour container | F |
200 | Type carcase | A |
201 | Carcase combination | K | If only one key is used for several – interior /exterior - carcase colours
202 | Exterior carcase colour | F |
203 | Interior carcase colour | F |
204 | Edge carcase | A |
205 | Edge colour carcase | F |
206 | Type visible side | A |
207 | Colour visible side | F |
208 | Interior carcase colour for glass door cabinets | F | Glass door cabinets and open cabinets, which are not a shelf .
209 | Interior carcase for glass door cabinets | A | Glass door cabinets and open cabinets, which are not a shelf .
300 | Type handle | A |
301 | Handle colour 1 | F | Colour handle, knob or main colour
302 | Handle colour 2 | F | Colour bow, railing, or knob handles
303 | Combination of handles | K | If only one key is defined for several handle conditions
304 | Handle positions | NULL | cf. handle positions p. 5-23
400 | Type plinth | A |
401 | Plinth colour | F |
402 | Plinth height | A |
410 | Type plinth bottom | A |
411 | Colour plinth bottom | F |
500 | Type shelves | A |
501 | Colour shelves | F |
502 | Type cornice | A | Includes shape and material
503 | Colour cornice | F |
504 | Type light pelment | A | Includes shape and material
505 | Colour light pelmet | F |
506 | Type ceiling filler | A |
507 | Colour ceiling filler | F |
508 | Type filler | A | Bottom ledge
509 | Colour bottopm ledge | F | Bottom ledge
510 | Type gallery shelf | A |
511 | Colour gallery shelf | F |
512 | Type gallery shelf edge | A |
513 | Colour gallery shelf edge | F |
514 | Type board | A |
515 | Colour board | F |
516 | Type board edge | A |
517 | Colour board edge | F |
520 | Type side panels/ bars | A |
521 | Colour side panels/ bars | F |
522 | Type bar panel edge | A |
523 | Colour bar panel edge | F |
524 | Type bottom shelf | A |
525 | Colour bottom shelf | F |
526 | Type bottom shelf edge | A |
527 | Colour bottom shelf edge | F |
550 | Type recess | A |
551 | Colour recess | F |
560 | Type recess accessories | A |
561 | Colour recess accessories | F |
562 | Type pilaster | A |
563 | Colour pilaster | F |
564 | Type pilaster edge | A |
565 | Colour pilaster edge | F |
600 | Type worktop | A |
601 | Colour worktop | F |
602 | Type worktop edge | A |
603 | Colour worktop edge | F |
604 | Type countertop | A |
605 | Colour countertop | F |
606 | Type countertop edge | A |
607 | Colour countertop edge | F |
620 | Type cover shelf | A |
621 | Colour cover shelf | F |
622 | Type cover shelf edge | A |
623 | Colour cover shelf | F |
624 | Type attachment table | A |
625 | Colour attachment table | F |
626 | Type attachment table edge | A |
627 | Colour attachment table edge | F |
650 | Type worktop upstand | A | Worktop upstand profile
651 | Colour worktop upstand | F | Worktop upstand profile
700 | Type drawer | A | Interior equipment
701 | Colour drawer | F | Interior equipment
702 | Type pull-out | A | Interior equipment
703 | Colour pull-out | F | Interior equipment
750 | Shape worktop | S |
751 | Shape cornice | S |
752 | Shape light pelmet | S |
753 | Shape plinth | S |
754 | Shape worktop upstand | S |
755 | Shape cover shelf | S |
756 | Shape countertop | S |
800 | Type electrical appliance | A |
801 | Colour electrical appliance | F |
802 | Colour electr. appliances accessories | F |
850 | Type sink | A |
851 | Colour sink | F |
852 | Colour sink accessories | F |
853 | Colour mixer taps | F |
854 | Type mixer taps | A |
900 | Type general accessories | A |
901 | Colour general accessories | F |
930 | additional, graphical relevant information about type 1. | A | The software suppliers have to be informed separately about the meaning.
931 | additional, graphical relevant information about colour 1. | F | The software suppliers have to be informed separately about the meaning.
932 | additional, graphical relevant information about type 2. | A | The software suppliers have to be informed separately about the meaning.
933 | additional, graphical relevant information about colour 2. | F | The software suppliers have to be informed separately about the meaning.
934 | additional, graphical relevant information about type 3. | A | The software suppliers have to be informed separately about the meaning.
935 | additional, graphical relevant information about colour 3. | F | The software suppliers have to be informed separately about the meaning.
936 | additional, graphical relevant information about type 4. | A | The software suppliers have to be informed separately about the meaning.
937 | additional, graphical relevant information about colour 4. | F | The software suppliers have to be informed separately about the meaning.
938 | additional, graphical relevant information about type 5. | A | The software suppliers have to be informed separately about the meaning.
939 | additional, graphical relevant information about colour 5. | F | The software suppliers have to be informed separately about the meaning.
950 | Type miscellaneous 1 | A |
951 | Colour miscellaneous 1 | F |
952 | Type miscellaneous 2 | A |
953 | Colour miscellaneous 2 | F |
954 | Type miscellaneous 3 | A |
955 | Colour miscellaneous 3 | F |
956 | Type miscellaneous 4 | A |
957 | Colour miscellaneous 4 | F |
958 | Type miscellaneous 5 | A |
959 | Colour miscellaneous 5 | F |
960 | Type miscellaneous 6 | A |
961 | Colour miscellaneous 6 | F |
962 | Type miscellaneous 7 | A |
963 | Colour miscellaneous 7 | F |
964 | Type miscellaneous 8 | A |
965 | Colour miscellaneous 8 | F |
966 | Type miscellaneous 9 | A |
967 | Colour miscellaneous 9 | F |
968 | Type miscellaneous 10 | A |
969 | Colour miscellaneous 10 | F |
970 | Type miscellaneous 11 | A |
971 | Colour miscellaneous 11 | F |
972 | Type miscellaneous 12 | A |
973 | Colour miscellaneous 12 | F |
974 | Type miscellaneous 13 | A |
975 | Colour miscellaneous 13 | F |
976 | Type miscellaneous 14 | A |
977 | Colour miscellaneous 14 | F |
978 | Type miscellaneous 15 | A |
979 | Colour miscellaneous 15 | F |
980 | Type miscellaneous 16 | A |
981 | Colour miscellaneous 16 | F |
982 | Type miscellaneous 17 | A |
983 | Colour miscellaneous 17 | F |
984 | Type miscellaneous 18 | A |
985 | Colour miscellaneous 18 | F |
986 | Type miscellaneous 19 | A |
987 | Colour miscellaneous 19 | F |
988 | Type miscellaneous 20 | A |
989 | Colour miscellaneous 20 | F |
998 | customer-specific motifs | F |
999 | Fixed material assignment | F |

Type: A = type

F = colour

K = combination

S = shape


 Type key
IDM 2.8.1 XML-Schema Documentation Introduction > Type key |
Type-No. | Denotation
1 | Base cabinet
2 | Tall cabinet
3 | Wall cabinet
4 | Worktop top cabinet
5 | Recess elements
6 | Highboard
7 | Recess cabinet
8 | Solitaire furniture
9 | Front element
10 | Module element
11 | Cornice profile
12 | Light pelmet
13 | Ceiling filler
14 | Plinth blind
15 | Plinth board
17 | Worktop
18 | Worktop upstand profile
19 | Cover shelf
20 | Gallery shelf
21 | Gallery shelf
22 | Construction shelf
24 | Chimney
26 | Electrical appliance
27 | Gas appliance
28 | Small appliance
29 | Sink
30 | Fitting
35 | Lighting
37 | General Accesories
38 | Miscellaneous
41 | Block
42 | Additional equipment
43 | Value clearing
95 | Recycling fees.
98 | Information as subtext
99 | General text information/ order


 EquipmentID

IDM 2.8.1 XML-Schema Documentation

Introduction > Equipment key

EquipmentID

Bezeichnung (englisch)

1

Universal cutter

2

Bread

3

Rotating shelf

4

Bottles

5

Glass

6

Towel

7

Interior drawer/ pull-out
8 | Detergents/broom
9 | Waste sorter system
10 | Swivel mechanism
11 | Extractable table

Interior drawer/ pull-out

8

Detergents/broom

9

Waste sorter system

10

Swivel mechanism

11

Extractable table

12

Larder

13

Linen

14

Spice

16

Dryer

17

Cooker

18

Oven

19

Hob

20

Ceramic hob

21

Extractor hood

22

Extractor

23

Extractor Element

24

Microwave

25

Dishwasher

26

Freezer

27

Fridge

28

Washing machine

29

Control Panel

30

Double oven

31

Sink

32

Steam cooker

33

Warming zone

34

Grill

35

Fryer Fryer

36

Chopping board

37

Coffee maschine

41

Fridge/ freezer combination

42

Oven-Microwave combination

43

Oven/ Warming

46

Low pressure

47

High pressure

48

TV

49

Water dispenser

50

Dish warmer

51

Downdraft cooktop extractor fan

52

Ice cube cutter

53

Beer cooler

54

Drawer


 Installation information key
IDM 2.8.1 XML-Schema Documentation Introduction > Installation information key |
Installation information no. | Designation
1 | For integrated fitting
2 | Installation
3 | Support base
4 | Stand-alone appliance
5 | Fully integrated
7 | Integrated niche
8 | Open niche
11 | Flush with front
12 | Flush with element
13 | Flush with the surface
14 | Surface-mounted
15 | Modules
17 | Stand alone
18 | Free-hanging
19 | Wall-mounted
21 | Visible side
22 | Side plinth
23 | Moulding
24 | Return
25 | Transition
26 | Mitre profiling surcharge
28 | Width reduction
29 | Depth reduction
30 | Height reduction
32 | Cutout
33 | Angled cut
34 | Rounding
35 | Connection
36 | Cutout
37 | Processing
46 | Row 60 cm
47 | Corner
48 | Row 60 cm + corner
49 | Special cabinet


 Material key
IDM 2.8.1 XML-Schema Documentation Introduction > Material key |
Material no. | Designation
1 | Plastic
2 | Corean
3 | Wood
4 | Natural stone
5 | Metal
6 | Tiles
7 | Glass
8 | Composite material
9 | Stainless Steel
10 | Aluminium
11 | Enameled steel
12 | Ceramic


 Shape key
IDM 2.8.1 XML-Schema Documentation Introduction > Shape key |
Shape no. | Designation
1 | Square
2 | Diagonal
3 | Insidecurve
4 | Round
5 | Half-round/rounding
6 | Angled
7 | Z-Form / 3-D
8 | Wavy
9 | 45-degree
10 | 90-degree
11 | 135-degree
12 | N-degree


 Front appearance ID
IDM 2.8.1 XML-Schema Documentation Introduction > Front appearance ID
Frontausprägung-Nr. | Bezeichnung (deutsch)
1 | Door
2 | Drawer
3 | Pull-out
4 | Glass door
5 | Lid/flap
6 | Switch cabinet bezel
7 | Blind
8 | Sliding door
9 | Folding door
10 | Rollershutter front
11 | Door/drawer
12 | Pull-out/drawer
13 | Drawer/blind
14 | Pull-out/door
15 | Pull-out/drawer/door
16 | Door/flap
17 | Pull-out/drawer/flap
18 | Drawer/rollershutter front
20 | without front
21 | 1 bowl without strainer bowl
22 | 1,5 bowls without strainer bowl
23 | 2 bowls without strainer bowl
24 | 1 bowl with strainer bowl
25 | 1,5 bowls with strainer bowl
26 | 2 bowls with strainer bowl
27 | Strainer bowl
28 | 1 bowl with rubbish container
29 | 1,5 bowls with rubbish container
30 | 2 bowls with rubbish container
31 | 1 bowl with strainer bowl and rubbish
32 | 1,5 bowls with strainer bowl and rubbish
33 | Rubbish
36 | With spout
37 | With spout repositioned/uninstalled
38 | Withe hose spray head
39 | Withe hose spray head repositioned/uninstalled
41 | 1 ring
42 | 2 rings
43 | 3 rings
44 | 4 rings
45 | 5 rings
46 | 6 rings
47 | 7 rings
48 | 8 rings
49 | 9 rings


 Type key arts
IDM 2.8.1 XML-Schema Documentation Introduction > Type key arts
Item number | Bezeichnung (deutsch) | Designation (englisch)
1 | Normal | Normal
2 | Regal | Shelf
3 | Rahmen | Frame
4 | Seitenverkleidung | Side cladding
5 | Rückwandverkleidung | Rear cladding
6 | Frontblende | Front facing
7 | Dekorblende | Decorative facing
8 | Formwange | Shaped cheek
9 | Raumteiler | Room divider
10 | Unterbau | substructure
11 | Aufsatz | Cap
14 | Paßstück | Filler
15 | Blende | Baffle
16 | Umbau |
17 | Modul-Umbauschrank | Module housing
19 | Einlegeboden | Shelf
21 | Barplatte | Bar top
22 | Ansetztisch | Fixed table
26 | Pilaster | Pilaster
27 | Stollen |
28 | Paneel | Panel
29 | Bord/Konsole | Board/table
30 | Reling | Rail
32 | Einhebelmischer |
33 | Zweigriffarmatur |
34 | Sonstige Armaturen |
36 | Umluft |
37 | Abluft |
40 | Zubehör | Accessory


 Language key

IDM 2.8.1 XML-Schema Documentation

Introduction > Language key

Language key | Language name
AA | Afar
AB | Abkhasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AV | Avarisch
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CR | Cree
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundish
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothish
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VE | Tshivenda
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu


 Country code

IDM 2.8.1 XML-Schema Documentation

Introduction > Country code

country code | country
AC | Ascension
AD | Andorra
AE | United Arab Emirates
AF | Afghanistan
AG | Antigua and Barbuda
AI | Anguilla
AL | Albania
AM | Armenia
AN | Dutch Antilles
AO | Angola
AQ | Antarctica
AR | Argentina
AS | American Samoa
AT | Austria
AU | Australia
AW | Aruba
AX | Aland
AZ | Azerbaijan
BA | Bosnia and Herzegovina
BB | Barbados
BD | Bangladesh
BE | Belgium
BF | Burkina Faso
BG | Bulgaria
BH | Bahrain
BI | Burundi
BJ | Benin
BL | Saint-Barthélemy
BM | Bermuda
BN | Brunei Darussalam
BO | Bolivia
BQ | Bonaire, Sint Eustatius and Saba
BR | Brazil
BS | Bahamas
BT | Bhutan
BU | Burma
BV | Bouvet Island
BW | Botswana
BY | Belarus
BZ | Belize
CA | Canada
CC | Cocos) Islands
CD | Democratic Republic of the Congo
CF | Central African Republic
CG | Republic of the Congo
CH | Switzerland
CI | Ivory Coast
CK | Cook Islands
CL | Chile
CM | Cameroon
CN | China
CO | Columbia
CP | Clipperton
CR | Costa Rica
CU | Cuba
CV | Cape Verde
CW | Curaçao
CX | Christmas Island
CY | Cyprus
CZ | Czech Republic
DE | Germany
DG | Diego Garcia
DJ | Djibouti
DK | Denmark
DM | Dominica
DO | Dominican Republic
DZ | Algeria
EA | Ceuta, Melilla
EC | Ecuador
EE | Estonia
EG | Egypt
EH | Westsahara
EN | England
ER | Eritrea
ES | Spain
ET | Ethiopia
FI | Finland
FJ | Fiji
FK | Falklands
FM | Micronesia
FO | Faeroe Islands
FR | France
GA | Gabon
GB | England/Great Britain
GD | Grenada
GE | Georgia
GF | French Guiana
GG | Guernsey (Channel Island)
GH | Ghana
GI | Gibraltar
GL | Greenland
GM | Gambia
GN | Guinea
GP | Guadeloupe
GQ | Equatorial Guinea
GR | Greece
GS | South Georgia and the South Sandwich Islands
GT | Guatemala
GU | Guam
GW | Guinea-Bissau
GY | Guyana
HK | Hong Kong
HM | Heard and McDonald Islands
HN | Honduras
HR | Croatia
HT | Haiti
HU | Hungary
ID | Indonesian
IE | Ireland
IL | Israel
IM | Isle of Man
IN | India
IO | British Indian Ocean Territory
IQ | Iraq
IR | Islamic Republic of Iran
IS | Iceland
IT | Italy
JE | Channel Island of Jersey
JM | Jamaica
JO | Jordan
JP | Japan
KE | Kenya
KG | Kyrgyzstan
KH | Cambodia
KI | Kiribati
KM | Comoros
KN | Saint Kitts and Nevis
KP | Democratic People's Republic of Korea
KR | Republic of Korea
KW | Kuwait
KY | Cayman Islands
KZ | Kazakstan
LA | Laos
LB | Lebanon
LC | Saint Lucia
LI | Liechtenstein
LK | Sri Lanka
LR | Liberia
LS | Lesotho
LT | Lithuania
LU | Luxembourg
LV | Latvia
LY | Libya
MA | Morocco
MC | Monaco
MD | Moldavia
ME | Montenegro
MF | Saint Martin
MG | Madagascar
MH | Marshall Islands
MK | North Macedonia
ML | Mali
MM | Myanmar (Burma)
MN | Mongolia
MO | Macau
MP | Northern Mariana Islands
MQ | Martinique
MR | Mauritania
MS | Montserrat
MT | Malta
MU | Mauritius
MV | Maldives
MW | Malawi
MX | Mexico
MY | Malaysia
MZ | Mozambique
NA | Namibia
NC | New Caledonia
NE | Niger
NF | Norfolk Island
NG | Nigeria
NI | Nicaragua
NL | Netherlands
NO | Norway
NP | Nepal
NR | Nauru
NU | Niue
NZ | New Zealand
OM | Oman
PA | Panama
PE | Peru
PF | French Polynesia
PG | Papuan New Guinea
PH | Philippine
PK | Pakistan
PL | Poland
PM | St. Pierre and Miquelon
PN | Pitcairn Islands
PR | Puerto Rica
PS | Palestine
PT | Portugal
PW | Palau
PY | Paraguay
QA | Qatar
RE | Reunion
RO | Romania
RS | Serbia
RU | Russia
RW | Ruanda
SA | Saudi Arabia
SB | Solomon Islands
SC | Seychelles
SD | Sudan
SE | Sweden
SG | Singapore
SH | St. Helena
SI | Slovenia
SJ | Svalbard and Jan Mayen Islands
SK | Slovak Republic
SL | Sierra Leone
SM | San Marino
SN | Senegal
SO | Somalia
SR | Suriname
SS | South Sudan
ST | Democratic Republic of São Tomé and Príncipe
SV | El Salvador
SX | Sint Maarten
SY | Syrian Arab Republic
SZ | Swaziland
TC | Turks and Caicos Islands
TD | Chad
TF | French Southern and Antarctic Territories
TG | Togo
TH | Thailand
TJ | Tadschikistan
TK | Tokelau
TL | East Timor
TM | Turkmenistan
TN | Tunisia
TO | Tonga
TR | Turkey
TT | Trinidad and Tobago
TV | Tuvalu
TW | Taiwan
TZ | Tanzania
UA | Ukraine
UG | Uganda
UM | United States Minor Outlying Islands
US | United States of America
UY | Uruguay
UZ | Uzbekistan
VA | Vatican City
VC | Saint Vincent and the Grenadines
VE | Venezuela
VG | British Virgin Islands
VI | American Virgin Islands
VN | Vietnam
VU | Vanuatu
WF | Wallis and Futuna Islands
WS | Samoa
YE | Yemen
YT | Mayotte
ZA | South Africa
ZM | Sambia
ZW | Zimbabwe


 Buying associations
IDM 2.8.1 XML-Schema Documentation Introduction > Buying associations
Buying association customer | Name buying association | Street | Postal Code | City | Phone | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13 A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Beinhaltet Form und Material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunscheig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co. KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60


 Types of detail information

IDM 2.8.1 XML-Schema Documentation

Introduction > Types of detail information

The following info types can be used to describe the type of detail information:

1 = milieu photo

2 = item sketch

3 = item photo

4 = version photo

5 = version texture

6 = manufacturer logo/product brand

7 = model description sheets

8 = installation instructions

9 = marketing

10 = pictogram sketch

11 = video

99 = miscellaneous


 Filename

IDM 2.8.1 XML-Schema Documentation

Introduction > Filename

The following is recommended for the file name associated with a data record:

· The name of the data record must not be limited to 8 characters.

· If possible, all components from the CATALOG_IDENTIFICATION should be used:

· The following components are suggested:

· Manufacturer number

· IDM version

· Customer number (value from the ASSOC_CTM_NO element)

· All languages

· Year

· Major number (MAJOR)

· File release timestamp (FILE_RELEASE_DATE)


 Schema IDM_2_8_1_Block.xsd.EN.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\IDM\Doku IDM_2_8_1_Block\IDM_2_8_1_Block.xsd.EN.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
T_NEW_BLOCK | languagetexte
 | languagetexte30
 | languagetexte40
 | languagetexte60
 | languagetexte60999


 element T_NEW_BLOCK
diagram
properties
content complex
children CATALOG SUPPLIER GLOBAL_DEFINITION SERIES FEATURE_DEFINITION BLOCK_VALUE_CALCULATION
annotation
documentation
This element is used for storing and providing all information and data for the issuing of a complete block catalogue/ database.


 attribute T_NEW_BLOCK/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 2 |
maxInclusive | 2 |
annotation
documentation
The version number "MAJOR" indicates the format version of the database. This main version number is only changed if the format is changed completely. The complete definition of a format version consists of the following elements: MAJOR, MINOR and REVISION.


 attribute T_NEW_BLOCK/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 8 |
maxInclusive | 8 |
annotation
documentation
In general the number of the sub-version "MINOR" changes every year. In case the main version number MAJOR is changed, the sub-version number is reset to 0.


 attribute T_NEW_BLOCK/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 1 |
annotation
documentation
During the year the field revision number "REVISION" indicates changes of the format, as agreed upon in the regular sessions of the committee. The different revisions are not issued unless they are necessary corrections. The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0.


 element T_NEW_BLOCK/CATALOG
diagram
properties
content complex
children FILE_RELEASE_DATE CATALOG_IDENTIFICATION CATALOG_NUMBER CATALOG_YEAR MIN_MAJOR_NO CATALOG_NAME DATA_VERSION VALID_FROM_DATE FILE_ID CATALOG_MARK FILLING_LEVEL PRICING_TERMS CATALOG_INFO FALL_BACK_LANGUAGE
annotation
documentation
All administrative information about the catalogue/ database is stored in this element.


 element T_NEW_BLOCK/CATALOG/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contain the current date and time (UTC).


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children MANUFACTURER_ID ISO_LANGUAGE_ID CURRENCY_KEY COUNTRY_ID CATALOG_KIND ASSOC_CTM_NO PRODUCT_BRANDNAME PRICE_ID VAT
annotation
documentation
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/MANUFACTURER_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
The language code defines the language in which the texts in the data pool were created. The ISOLanguage code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/CATALOG_KIND
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
maxInclusive | 3 |
annotation
documentation
This field is used to identify association catalogues.

The following values can be used:
1 = base catalogue
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/ASSOC_CTM_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used to specify the customer number of the Association or customer for which the data pool is available.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations")


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/PRODUCT_BRANDNAME
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/PRICE_ID
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price
2 = identification number
3 = settlement point

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank.


 element T_NEW_BLOCK/CATALOG/CATALOG_IDENTIFICATION/VAT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT

This element is very important for pricing.


 element T_NEW_BLOCK/CATALOG/CATALOG_NUMBER
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
annotation
documentation
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier.


 element T_NEW_BLOCK/CATALOG/CATALOG_YEAR
diagram
type xs:gYear
properties
content simple
annotation
documentation
This element refers to the calendar year of the catalogue data in the main catalogue.


 element T_NEW_BLOCK/CATALOG/MIN_MAJOR_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
The main catalogue's major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. Element MIN_MAJOR_NO contains the minimum value of thee main catalogues's MAJOR_NO.


 element T_NEW_BLOCK/CATALOG/CATALOG_NAME
diagram
type | languagetexte30
properties
content complex
children | LANGUAGE
annotation
documentation
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.


 element languagetexte30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetexte30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_NEW_BLOCK/CATALOG/DATA_VERSION
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database.


 element T_NEW_BLOCK/CATALOG/VALID_FROM_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
This element defines the period of validity for the catalogue and corresponding database.


 element T_NEW_BLOCK/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data


 element T_NEW_BLOCK/CATALOG/CATALOG_MARK
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [BKV] |
annotation
documentation
This element is used to differ between the possible data types

B = block data with prices
K = catalogue data
V = block data without prices (notional prices are required)


 element T_NEW_BLOCK/CATALOG/FILLING_LEVEL
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [123]|2[a-n] |
annotation
documentation
The filling level (FILLING_LEVEL) defines the level of details which are provided in a database. In general, an increase in the filling level corresponds with an increase in data quality. The higher the degree of detail specification in the data, the more specific they are for a certain manufacturer.
The different filling levels are evaluated during the certification procedure: By checking the filling levels it is ascertained which information is required in the data, in order to achieve the filling level. In case the required information is missing in a filling level, the complete set of data is not certified.
The filling levels are defined as follows:
- Filling level 1: provides basic information except from elements for the description of texture information
- Filling level 2a: filling level 1 is supplemented with information regarding textures and material (colours RGB,transparency and brightness)
- Filling level 2b: filling level 1 is amended with information about front division and front finishes
- Filling level 2c: filling level 1 is supplemented with information about handles.
- Filling level 2d: filling level 1 is amended with information about item textures.

Combinations of filling levels 2a-2d are possible. Following itemized breakdowns of combinations are defined:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Filling level 3. To achieve filling level 3 information in the filling levels 1 and 2a - 2d supplemented by information about the modeling graphic is required. In filling level 3 all options of the data format for manufacturer specific illustrations are entirely applied.
A complete definition of the information required for the different filling levels is provided in the table "Filling levels".


 element T_NEW_BLOCK/CATALOG/PRICING_TERMS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 1 |
pattern | [01] |
annotation
documentation
This element defines the pricing terms for the catalog prices.
A complete definition of the information required for the dThis element defines the pricing terms for the catalog prices. The information in this field is used for a correct data import in order to avoid overwriting of price information.

The following values are used:
0 = prices in the catalogue are purchase prices for dealers
1 = prices in the catalogue are recommended retail prices (UPE)

All price information in the catalogue has to correspond to the information in this element.


 element T_NEW_BLOCK/CATALOG/CATALOG_INFO
diagram
type | languagetexte60999
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Information texts are stored in this element.


 element languagetexte60999/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetexte60999/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte60999/LANGUAGE/TEXT_LINE
diagram
properties
minOcc | 1
maxOcc | 999
content | complex
children TEXT
annotation
documentation
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.


 attribute languagetexte60999/LANGUAGE/TEXT_LINE/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in.


 element languagetexte60999/LANGUAGE/TEXT_LINE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,60} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 element T_NEW_BLOCK/CATALOG/FALL_BACK_LANGUAGE
diagram
type restriction of xs:language
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The two-digit ISO language code must be used.


 element T_NEW_BLOCK/SUPPLIER
diagram
properties
content complex
children CONTACT_PERSON CONTACT_SUPPLIER
annotation
documentation
All relevant supplier data, e.g. communication and contact details, are stored in this element.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON
diagram
properties
minOcc | 1
maxOcc | 2
content | complex
children CONTACT_PERSON_NO CONTACT_ROLE CONTACT_NAME FIRST_NAME FORM_OF_ADDRESS DEPARTMENT TELEPHONE FAX EMAIL STREET ZIPCODE_STREET CITY
annotation
documentation
All information concerning the contact person is defined in this element.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/CONTACT_PERSON_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact).


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/CONTACT_ROLE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 60 |
annotation
documentation
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/CONTACT_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
The family name of the direct contact person for the software suppliers is defined in this element.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/FIRST_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
The first name of the direct contact person is entered here.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/FORM_OF_ADDRESS
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/DEPARTMENT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
If applicable, the department of the contact person is defined in this field.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/TELEPHONE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/FAX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
This element contains the E-Mail address of the contact person.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
The street address of the manufacturer is defined in this element.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
The ZIP code for the street address of the manufacturer is defined in this element.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_PERSON/CITY
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
The city name of the manufacturer's address is entered here.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER
diagram
properties
content complex
children MANUFACTURER_NAME_1 MANUFACTURER_NAME_2 EMAIL INTERNET_ADDRESS STREET ZIPCODE_STREET CITY ZIPCODE_POSTBOX POSTBOX TELEPHONE_SWITCHBOARD FAX_SWITCHBOARD
annotation
documentation
All contact information for the specific manufacturer is defined in this element.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_1
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element contains the first line of the manufacturer's name.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_2
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element contains the second line of the manufacturer's name.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
The official E-Mail address of the manufacturer is defined in this element.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/INTERNET_ADDRESS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com).


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
The street address of the manufacturer is defined in this element.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
The ZIP code for the street address of the manufacturer is defined in this element.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/CITY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
The city name of the manufacturer's address is entered here.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
If applicable, the ZIP code of the manufacturer's postbox address is entered here.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{0,10} |
annotation
documentation
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/TELEPHONE_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890.


 element T_NEW_BLOCK/SUPPLIER/CONTACT_SUPPLIER/FAX_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890.


 element T_NEW_BLOCK/GLOBAL_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CLEARING_GROUP DETAIL_INFOS
annotation
documentation
This element is used for defining global data which apply to the complete catalogue/ database (global information).


 element T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children EXCHANGE_ID_REF CLEARING_GROUP_NAME
annotation
documentation
This element is used for the definition of clearing groups. Different exchange_IDs are summarized and made up to a clearing group (element.

The clearing groups in the block conditions (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) and the grading tables (BLOCK_VALUE_CALCULATION/GRADING_TABLE) are used for the definition of a minimum value for a certain type range. The different type ranges can be identified by their corresponding exchange_ID.

The single amounts of all items which belong to a certain exchange_ID are summarized. A total amount is summed up for each clearing group. This amount is defined as reference value for further use in block calculation and for the value clearing grading table.


 attribute T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP/@CLEARING_GROUP_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies a clearing group.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP/EXCHANGE_ID_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references an exchange-ID.


 attribute T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP/EXCHANGE_ID_REF/@EXCHANGE_ID_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP/CLEARING_GROUP_NAME
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
Name for a clearing group. This is used in order to simplify data acquisition.


 element languagetexte60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetexte60/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte60/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,60} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO
annotation
documentation
This element is used for saving hyperlinks with detail information.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION INFO_TYPE EXTERNAL_NAME INTERNAL_NAME TOOL_TIP URL RESOLUTION
annotation
documentation
This element is used to define a detail information.


 attribute T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute identifies detail information.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/CLASSIFICATION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
This element is used for the classification of detail information.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INFO_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[01]|99 |
annotation
documentation
This element is here to describe the type of detailed information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME
diagram
type | languagetexte
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Name of the link (e.g. "magic corner in motion").


 element languagetexte/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.


 attribute languagetexte/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
b Bold font
br Line break


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
diagram
type | languagetexte40
properties
content complex
children | LANGUAGE
annotation
documentation
Element for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.


 element languagetexte40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetexte40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,40} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
diagram
type | languagetexte
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Text information for a tool tip with reference to the link.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL
diagram
properties
content complex
children LANGUAGE
annotation
documentation
This element contains the URL for the detail information.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT HASH_VALUE
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


 attribute T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/TEXT
diagram
type restriction of xs:anyURI
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 1024 |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/HASH_VALUE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not.


 element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/RESOLUTION
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 4 |
annotation
documentation
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file .


 element T_NEW_BLOCK/SERIES
diagram
properties
content complex
children SERIE
annotation
documentation
This element is used to specify all series of the catalogue/data with the elements assigned to them, e.g. blocks and their items.


 element T_NEW_BLOCK/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 100
content | complex
children PRODUCT_GROUPS
annotation
documentation
This element is used for the definition of the series.
Items belonging to series 0 are valid for all series. Therefore items of series 0 must not occur with the same type number (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in other series. Items of other series (unequal 0) may be used with the same type name in different series.
Buying prices are always indicated as the dealer’s buying prices.


 attribute T_NEW_BLOCK/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute defines the serial number of the series.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
content complex
children PRODUCT_GROUP
annotation
documentation
This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRODUCT_GROUP_TEXT ITEMS
annotation
documentation
This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/PRODUCT_GROUP_TEXT
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used for defining a name for a product group.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
This element defines all items belonging to one product group.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_BASE_PRICE_REF PRICE_TYPE_REF CALC_GROUP_REF EXCHANGE_ID_REF RESTRICTIONS EDP_NUMBER BLOCK_PRICE_STATUS ITEM_IDENTIFICATION CATALOG_PAGE VAT_ID_REF VALID_FROM VALID_UNTIL RANGE_DEPENDENT BLOCK_PARTS ITEM_TEXT TYPE_KEY CLASSIFICATIONS DETAIL_INFOS
annotation
documentation
This element is used to define blocks and their items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes of the main catalogue.


 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) of the main catalogue with the value 0 in the element ADDITIONAL_PRICE.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute references a PRICE_FEATURE_GROUP.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE
annotation
documentation
This element is used to specify the block price.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
This element references to the block price field (BLOCK_PRICE_FIELD below PRICE_DEFINITION in the main catalogue).

The values in BLOCK_PRICE_FIELD can be identical to the values in PRICE_FIELD.They can also be assigned differently for individual ranges within the catalogue price groups.

The following applies:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE >
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be &gt; 0, blanks are not permitted.

(example: -9,00 € =&gt; -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPES


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF/@PRICE_TYPE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF/@PRICE_TYPE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies a price type.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CALC_GROUP_REF
diagram
properties
content complex
annotation
documentation
This element references calculation groups. The calculation groups are defined within the product categories in the main catalogue.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CALC_GROUP_REF/@CALC_GROUP_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CALC_GROUP_REF/@CALC_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 10 |
maxInclusive | 99 |
annotation
documentation
This attribute identifies a price type.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references a swap-ID, which is defined in the path1/EXCHANGE_ID element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF/@EXCHANGE_ID_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF/@EXCHANGE_ID_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
This attribute identifies an exchange-ID.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children RESTRICTION_REF
annotation
documentation
This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references an item to an assigned restriction.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@RESTRICTION_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@RESTRICTION_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
This attribute references item specific restrictions.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@SEQUENCE

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@SEQUENCE >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...).


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EDP_NUMBER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PRICE_STATUS
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9 |
annotation
documentation
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M".


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_IDENTIFICATION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [BEKSMZVPNOG] |
annotation
documentation
This element is used to assign an identifier to the article.
B = Block
E = Spare part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CATALOG_PAGE
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 40 |
annotation
documentation
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories".


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VAT_ID_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references VAT tax rates.

The VAT tax rates are specified in the VALUE_ADDED_TAX element (path 1 of the main catalogue). A value of 0 is entered for items that are VAT-free.
If the value of 0 (VAT-free item) is used, the value must also be specified in the VALUE_ADDED_TAX element (path 1).

Element paths
Path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VAT_ID_REF/@VAT_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VAT_ID_REF/@VAT_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This element is used for referencing the different VAT rates.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RANGE_DEPENDENT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD of the main catalogue. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_PART
annotation
documentation
This element is used as a container element for the block parts lists in the catalogue.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children BLOCK_SEQUENTIAL_NO ITEM_REF OPTION_REF HINGE EXCHANGE_CONDITION STATUS BLOCK_ITEM_DIMENSION_WIDTH BLOCK_ITEM_DIMENSION_HEIGHT BLOCK_ITEM_DIMENSION_DEPTH CONSTRUCTION_ID
annotation
documentation
In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2 of the main catalogue), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_SEQUENTIAL_NO

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_SEQUENTIAL_NO >
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This element defines the position of an item in the block arrangement.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF >
diagram
properties
content complex
annotation
documentation
This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2 of the main catalogue) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@TYPE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@SERIE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2 of the main catalogue).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@FEATURE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to specify the version type of a referenced version.
A FEATURE_NO must only occur once.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@OPTION_KEY

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used to reference a version.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/HINGE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/HINGE >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[BEJLMNR] |
annotation
documentation
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/EXCHANGE_CONDITION

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/EXCHANGE_CONDITION >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 2 |
maxInclusive | 3 |
annotation
documentation
401--7--Tauschbedingung Version Beta 2.0 Build 0 This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/STATUS

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/STATUS >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [ABELSZ] |
annotation
documentation
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_WIDTH

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_WIDTH >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_HEIGHT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_HEIGHT >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_DEPTH

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_DEPTH >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/CONSTRUCTION_ID

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/CONSTRUCTION_ID >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[JLNRAE] |
annotation
documentation
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT
diagram
properties
content complex
children SHORT_TEXT FULL_TEXT PLANNING_ADVICE
annotation
documentation
This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT >
diagram
properties
content complex
children LANGUAGE
annotation
documentation
This element contains short text information.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID >
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE >
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
children TEXT
annotation
documentation
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT >
diagram
type | languagetexte
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

b Bold
br Soft return


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE >
diagram
type | languagetexte60999
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains planning advices.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY
diagram
properties
content complex
children TK_TYPE TK_CLASS TK_EQUIPMENT TK_MATERIAL TK_SHAPE TK_FRONT_APPEARANCE
annotation
documentation
This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589] |
annotation
documentation
A value from the column type No., as listed in the table "Type Keys", is required in this field.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_CLASS

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_CLASS >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0145679]|2[126789]|3[023467]|4[0] |
annotation
documentation
A value from the column item No., as listed in the Table "Type key arts", is required in this field.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT >
diagram
properties
minOcc | 0
maxOcc | 5
content | complex
children TK_INSTALLATION_RECESS
annotation
documentation
This element is used for assigning a type key to the installation information and recess height.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@SEQUENCE_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute defines the sequence in which installation information and equipment information is assigned to an item.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@TK_EQUIPMENT_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@TK_EQUIPMENT_NO >
type restriction of xs:nonNegativeInteger
properties
use optional
facets
Kind | Value | Annotation
pattern | [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4] |
annotation
documentation
This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key", is required in this field.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children TK_INSTALLATION_INFORMATION TK_RECESS_HEIGHT
annotation
documentation
This element is used to specify the combination of installation information (see table Installinfo key) and recess height.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_INSTALLATION_INFORMATION

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_INSTALLATION_INFORMATION >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789] |
annotation
documentation
A value from the column InstallInfo in table "installinfo key" is entered here.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_RECESS_HEIGHT

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_RECESS_HEIGHT >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_MATERIAL

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_MATERIAL >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-2] |
annotation
documentation
A value from the column type, as listed in table "Material keys", is required in this field.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_SHAPE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_SHAPE >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-2] |
annotation
documentation
A value from the column shape No., as listed in the table "Shape keys", is required in this field.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_FRONT_APPEARANCE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_FRONT_APPEARANCE >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9] |
annotation
documentation
A value from the column front appearance No., as listed in the table "Front appearance key", is required in this field.


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CLASSIFICATION
annotation
documentation
This element is used to store standardized classification numbers.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION_CODE VALID_FROM VALID_UNTIL


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
pattern | ([1-9]{1}|1[0]{2}) |


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE >
diagram
type xs:string
properties
content simple


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM >
diagram
type xs:date
properties
minOcc | 0
maxOcc | 1
content | simple


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL >
diagram
type xs:date
properties
minOcc | 0
maxOcc | 1
content | simple


 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element summarizes all hyperlinks providing detail information for an item.


element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF

 element T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references hyperlinks to detail information.


attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO

 attribute T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO >
properties
use required
annotation
documentation
This attribute is used for defining the identification number of the referenced detail information.


 element T_NEW_BLOCK/FEATURE_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children RESTRICTIONS
annotation
documentation
All information which is depending on the different variations (restrictions) is defined in this element.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS
diagram
properties
content complex
children RESTRICTION
annotation
documentation
This element is used for the definition of restrictions.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION
diagram
properties
minOcc | 1
maxOcc | 99999
content | complex
children RESTRICTION_NAME_TEXT OPTION_COMBINATION TEST_ID
annotation
documentation
This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@RESTRICTION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute identifies restrictions unambiguously.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@FEATURE_1_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@FEATURE_2_NO
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@FEATURE_3_NO
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@VALIDATION_TYPE
type restriction of xs:int
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 1 |
annotation
documentation
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405)


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/RESTRICTION_NAME_TEXT
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used for the definition of a name for a control procedure.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTION_REF MAX_DIMENSION MIN_DIMENSION
annotation
documentation
This element is used for the definition of a variation combination.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/OPTION_REF
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
annotation
documentation
This element is used for referencing the variation types which are used in the control procedures.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used for referencing a feature.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used for referencing a option.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MAX_DIMENSION
diagram
properties
minOcc | 0
maxOcc | 3
content | complex
annotation
documentation
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MAX_DIMENSION/@DIMENSION_TYPE
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [WHD] |
annotation
documentation
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MAX_DIMENSION/@DIMENSION_VALUE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MIN_DIMENSION
diagram
properties
minOcc | 0
maxOcc | 3
content | complex
annotation
documentation
This element defines the minimum dimension in which an option is available.


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MIN_DIMENSION/@DIMENSION_TYPE
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [WHD] |
annotation
documentation
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth


 attribute T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MIN_DIMENSION/@DIMENSION_VALUE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This element defines the minimum dimension in which an option is available.


 element T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/TEST_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_CONDITIONS BLOCK_SALE_PRICES GRADING_TABLE SET_OF_BLOCK_RULES
annotation
documentation
This element is used for defining the rules which apply to block calculation and value clearing.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_CONDITION
annotation
documentation
This element contains special conditions for the block calculation. Only if a block corresponds with these conditions it can be applied to a certain commission. Rules defined here apply to the value clearing system (value clearing block) as well as to block calculation (item block).

A block may only be applied to a commission,if all conditions for this special block are fulfilled. A tuple, consisting of the fields ITEM_REF (path 1) and OPERATION_ID (path 2), defines the conditions which refer to a certain block.

Basic condition for the correct application of block conditions is, that a block exists in one of the ranges which have been planned in one commission. In case different ranges have been planned in one commission, the first range which appears in the header data is considered as reference.

The settings and definitions of range- and variation controls apply to blocks in the same way as to “ordinary” items. The price information 0 in the element ITEM_PRICE (path 2) indicates that the value clearing block exists in a certain price group.

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

path 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF CONDITION_RULES
annotation
documentation
This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/ITEM_REF
diagram
properties
content complex
annotation
documentation
This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES
diagram
properties
content complex
children CONDITION_RULE
annotation
documentation
Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLEARING_GROUP_REF MINIMUM_VALUE MINIMUM_WIDTH
annotation
documentation
This element is used for defining block conditions.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/CLEARING_GROUP_REF
diagram
properties
minOcc | 1
maxOcc | 999
content | complex
annotation
documentation
This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/CLEARING_GROUP_REF/@CLEARING_GROUP_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used for referencing a clearing group.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/MINIMUM_VALUE
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/MINIMUM_WIDTH
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_SALE_PRICE
annotation
documentation
This element is used for defining block sale prices.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF VARIATION_PRICE_DEFINITION
annotation
documentation
Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/ITEM_REF
diagram
properties
content complex
annotation
documentation
This element is used for referencing an item for which a block sale price has been defined.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children VALID_FROM VALID_UNTIL OPTION_REF PRICE_OR_CALCULATION_POINT
annotation
documentation
This element is used for defining block sale conditions.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/VALID_FROM
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/VALID_UNTIL
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/OPTION_REF
diagram
properties
minOcc | 0
maxOcc | 4
content | complex
annotation
documentation
This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used for referencing a feature.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used for referencing a option.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/PRICE_OR_CALCULATION_POINT
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself).


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CREDIT_SURCHARGE_CLEARING
annotation
documentation
This element is used for defining grading tables containing the surcharges or the credits which are used in the value clearing system.

A clearing block, which is valid for a certain commission, can be used as reference for the grading table. A reference amount is set up for each data record of this record type, to which the valid clearing block belongs CLEARING_GROUP (path 1). This amount is compared to the given amount of the clearing group. If the reference value corresponds with the given grading range (elements VALUE_FROM (path2) and VALUE_TO (path 2), the data record is applied. In this case the settings in the field TYPE_CREDIT (path 2) and/ or TYPE_DEBIT (path 2) are applied. The calculation is based on the amount of the calculation group, which is defined for type_credit or type_surcharge (element ITEM (path 3)).

Different grading ranges can be defined for one block. A freely defined operation_ID is assigned to each grading range COMPARING_RULES (path 4). Different grading ranges with the same operation_ID may appear within one grading range of a clearing block. In this case the conditions of all grading ranges with their corresponding clearing group have to be fulfilled, so that the value clearing system can be applied to the different items of the commission. Single data records are linked by an AND-operation (COMPARING_RULE).

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

In case several data records of a clearing block are applied in the GRADING_TABLE, the value of the block (ITEM (path 3)), ITEM_PRICE (path 5)) is calculated only one time.

path 1: GLOBAL_DEFINITION
path 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
path 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF COMPARING_RULES
annotation
documentation
This element defines value range for a grading table.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/ITEM_REF
diagram
properties
content complex
annotation
documentation
This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children COMPARING_RULE
annotation
documentation
Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLEARING_GROUP_ID VALUE_FROM VALUE_TO TYPE_CREDIT TYPE_DEBIT
annotation
documentation
This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/CLEARING_GROUP_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/VALUE_FROM
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/VALUE_TO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/TYPE_CREDIT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/TYPE_DEBIT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES
diagram
properties
content complex
children EXCHANGE_ID_GROUP RULE RULE_SET_TEXT
annotation
documentation
The manufacturer specific rules are defined in this element and the in the child elements.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children EXCHANGE_ID_1_REF EXCHANGE_ID_2_REF
annotation
documentation
This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_1_REF
diagram
properties
content complex
annotation
documentation
The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_1_REF/@EXCHANGE_ID_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_2_REF
diagram
properties
content complex
annotation
documentation
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_2_REF/@EXCHANGE_ID_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE
diagram
properties
minOcc | 1
maxOcc | 99
content | complex
children RULE_TEXT
annotation
documentation
This element defines a manufacturer specific set of rules.


 attribute T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE/@RULE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
This attribute defines a counter from 1-99 for the manufacturer specific block rules.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE/RULE_TEXT
diagram
type | languagetexte60999
properties
content complex
children | LANGUAGE
annotation
documentation
This element defines the criteria for exchanges in the block processing.


 element T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE_SET_TEXT
diagram
type | languagetexte60999
properties
content complex
children | LANGUAGE
annotation
documentation
This element contains text information and explanations for the set of rules.


 complexType languagetexte
diagram
children LANGUAGE
used by
elements T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
annotation
documentation
This data type is used for multilingual text information of any length.


 complexType languagetexte30
diagram
children LANGUAGE
used by
element T_NEW_BLOCK/CATALOG/CATALOG_NAME
annotation
documentation
This element is used for multilingual text information limited to 30 characters.


 complexType languagetexte40
diagram
children LANGUAGE
used by
element T_NEW_BLOCK/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
annotation
documentation
This element is used for multilingual text information limited to 40 characters.


 complexType languagetexte60
diagram
children LANGUAGE
used by
elements T_NEW_BLOCK/GLOBAL_DEFINITION/CLEARING_GROUP/CLEARING_GROUP_NAME T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/PRODUCT_GROUP_TEXT T_NEW_BLOCK/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/RESTRICTION_NAME_TEXT
annotation
documentation
This element is used for multilingual text information limited to 60 characters.


 complexType languagetexte60999
diagram
children LANGUAGE
used by
elements T_NEW_BLOCK/CATALOG/CATALOG_INFO T_NEW_BLOCK/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE_SET_TEXT T_NEW_BLOCK/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE/RULE_TEXT
annotation
documentation
This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.