 Introduction

Ansicht mit Navigationswerkzeuge

IDM 2.8.1 XML-Schema

Documentation

release 08/04/2022

Documented XML-scheme:

IDM_2_8_1.xsd

Contact DCC e.V.

Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telephon 0 52 21/12 65-37

Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telephon 0 52 21/12 65-38


 Basic structure of the IDM scheme

IDM 2.8.1 XML-Schema Documentation

Introduction > Basic structure of the IDM scheme

The main element T_NEW_CATALOG defines that a complete, new catalogue database is supplied.

The IDM scheme is split up into different data areas represented by the following child elements (cf. pict.1) of T_NEW_CATALOG.

Picture 1 - Child elements of T_NEW_CATALOG

The different data areas are linked. Data which are initially created in some of the areas are used in other areas via references.

Description of the data areas.

CATALOG

The data area CATALOG contains all administrative information about the database, e.g. the version number of the file format, release date or the unique identification of the database.

SUPPLIER

The data area SUPPLIER contains all adiministrative information about the supplier, e.g. contact data, EDI-communication parameters or the manufacturer's country of origin.

GLOBAL_DEFINITION

The data area GLOBAL_DEFINITION is a pool of information which is used in other data areas, e.g. the definition of standard handle positions or information about series.

SERIES

The data area SERIES contains information which is used for describing the catalogue items. The items are assigned to different product groups, e.g. base cabinets, shelves etc.

FEATURE_DEFINITION

The data area FEATURE_DEFINITION provides information about the product variations, e.g. data variation families (FEATURE_CLASS),variation types (FEATURE), the corresponding options (OPTION_DEFINITION), or restrictions (RESTRICTION).

PRICE_DEFINITION

The data area PRICE_DEFINITION contains all relevant price information, e.g. data for price features (PRICE_FEATURE_GROUP), VAT (VALUE_ADDED_TAXES), merchandise groups (MERCHANDISE_GROUP) or price types PRICE_TYPE).

BLOCK_VALUE_CALCULATION

The data area BLOCK_VALUE_CALCULATON contains all information about the rules for block- and value clearing, e.g. data for block rules (SET_OF_BLOCK_RULES), block conditions (BLOCK_CONDITIONS) or grading tables (GRADING_TABLE).


 Elements of the catalogue structure

IDM 2.8.1 XML-Schema Documentation

Introduction > Elements of the catalogue structure

Definition of series information

Series are defined in the following element:

T_NEW_CATALOG/SERIES/SERIE

For a complete description of a series all child elements are used. Programmes are assigned to series via restrictions (RESTRICTION_REF).

Definition of programme information

In the IDM format programmes are defined as variations. First the properties of a programme are defined as options of a variation, following the options are assigned to the variation type "programme". The definition of programme information is done in the following way:

Example: Definition of programme information

1. Definition of programme properties

The properties of a programme are defined in the following element:

FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

<STYLE STYLE_NO="A1">

<STYLE_NAME>Paris</STYLE_NAME>

</STYLE>

<STYLE STYLE_NO="A2">

<STYLE_NAME>New York</STYLE_NAME>

</STYLE>

</OPTION_DEFINITION>

The properties for the programmes "Paris" and "New York" are defined. For reasons of clarity the different available elements of STYLE are neglected in this context.

2. Definition of programme variations

The programme variations are described in the following element:

FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_NO="A1"FEATURE_NO="1">

<STYLE_REF STYLE_NO="A1"/>

</OPTION>

<OPTION OPTION_NO="A2"FEATURE_NO="1">

<STYLE_REF STYLE_NO="A2"/>

</OPTION>

</OPTIONS>

</FEATURE>

The example above contains the variations of the programmes "Paris" and "New York". Programme variations are defined with the feature No. 1 in the feature "programme". Each programme variation is uniquely and unambiguously identified by the combination of FEATURE_NO and OPTION_NO

Definition of item information

Item information is defined in the following element:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The element ITEM is described by a great number of different elements providing additional item information. The attribute TYPE_NO.

Depending on series the attributes of an item may vary. In this respect an item is identified unambiguously only by its attributes in connection with the series.

Series specific item information

Depending on series the attributes of an item may vary. As the element ITEM is a child element of SERIES, items are assigned to a series automatically.

Deifinition of features

Information about the features is provided in the IDM scheme as follows:

Definition of the options for the feature

Assignment of option and feature

Definition of options

The different options of a feature are defined as a data pool in the element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION.

Pict. 2 – The element OPTION_DEFINITION

The element OPTION_DEFINITION contains several elements for the definition of the different options:

STYLE | This element defines the attributes of a programme. Programmes are defined as a level in the catalogue structure but depicted via the features which are frequently used in the restrictions.
HANDLE_ORIENTATION | This element defines a standard handle orientation.
MATERIAL | This element defines the attributes of materials via colours and textures. These elements are referenced from the finish features (e.g. plinth finish) or colour features (e.g. plinth colour).
FORM | This element defines the different numbers for the form features (FORM_NO).The current version of the IDM-scheme supports only the feature FORM_NOThe options of this element may only be referenced by the features 750-756.
OPTION_MEASURE | This element contains measurement values for options which , require measurement information (e.g. plinth height (feature 402)).

Example: colour options

<OPTION_DEFINITION>

<COLOR COLOR_NO="1">

<RGB_RED>255</RGB_RED>

<RGB_GREEN>0</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="2">

<RGB_RED>133</RGB_RED>

<RGB_GREEN>273</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="3">

<RGB_RED>0</RGB_RED>

<RGB_GREEN>89</RGB_GREEN>

<RGB_BLUE>89</RGB_BLUE>

</COLOR>

</OPTION_DEFINITION>

The above mentioned elements define three different colours which are identified by numbers (COLOR_NO) 1-3.

Assignment of option and feature

To use the above mentioned colour examples, an assignment of features to these colours is required.

The assignment of features (FEATURE) and options (OPTION) is done in the element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE. A feature is defined an identified by the combination of FEATURE and OPTION The following XML elements define 2 colour features for plinths (feature 401).

Example: Definition of a feature via feature No. and option

<FEATURE FEATURE_NO="401">

<OPTIONS>

<OPTION OPTION_NO="1" FEATURE_NO="401">

<OPTION_TEXT_REF TEXT_NO="4"/>

</OPTION>

<OPTION OPTION_NO="3" FEATURE_NO="401">

<OPTION_TEXT_REF TEXT_NO="6"/>

</OPTION>

</OPTIONS>

<FEATURE_TEXT_REF TEXT_NO="12"/>

<CLASSIFICATION>1</CLASSIFICATION>

<HEADER_POS_VARIATION_TYPE>K</HEADER_POS_VARIATION_TYPE>

</FEATURE>

The child elements of FEATURE describe the attributes of the feature No. and the child elements of OPTION describe the attributes of the feature. This principle is essential for all elements in the IDM-scheme,e.g. the element OPTION_TEXT_REF references the text information about the option, the element FEATURE_TEXT_REF references text information concerning the feature.

To reference a feature the following combination is required: FEATURE_NO and OPTION_NO define the reference key.

Combination of features

If feature No. 1 (programme) is defined in combination with other features, feature No. 1 is always set in the first place.


 Build of Catalogue structure

IDM 2.8.1 XML-Schema Documentation

Introduction > Build of Catalogue structure

Assignment of programmes to series

Programmes are assigned to series in the following element:

SERIES/SERIE/RESTRICTION_REF

The programme is assigned to that series in which a restriction is referenced that defines the programme as a legal combination of features and options.

The element for the description of programme features is:

FEATURE_DEFINITION/OPTION_DEFINITION/STYLE

Assignment of items to series an programmes

Item-series assignment

As the element ITEM is a child element of the element SERIES, all items are automatically assigned to a series:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Assignment of item to programmes

In general, items depending on programmes are available in all programmes which are assigned to a series. Item specific restrictions are used for excluding the availability of an item in one or more programmes:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

The following example defines a suitable restriction which excludes the availability of an item in a programme:

Example: restriction for the assignment of item and programme

element: FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="A1">

<FEATURE_REF FEATURE_NO="1"/>

<OPTION_REF OPTION_NO="A1" FEATURE_NO="1"/>

<TEST_ID>0</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

The above mentioned restriction defines an illegal combination of feature No. and option No. for the referenced features. The corresponding feature definition is:

The referenced programme feature:

element: FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_NO="A1" FEATURE_NO="1">

<STYLE_REF STYLE_NO="A1"/>

</OPTION>

</OPTIONS>

</FEATURE>

Used programme feature:

element: FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

<STYLE STYLE_NO="A1">

<STYLE_NAME>Paris</STYLE_NAME>

</STYLE>

</OPTION_DEFINITION>


 Catalogue structure

IDM 2.8.1 XML-Schema Documentation

Introduction > Catalogue structure

Catalogue and element structure

The general catalogue structure of the database is built up as follows:

Pict.1 – Catalogue structure of databases

This catalogue structure is represented by the following element hierarchy in the IDM scheme:

Pict. 1 – Element hierarchy of the IDM scheme

The element SERIE is used for defining the properties of a series. The element RESTRICTION_REF assigns features to a series by means of restrictions. Within one series different produkt groups (PRODUCT_GROUPS) are defined which combine all items with similar features to one group. As items are child elements of the element SERIE they are automatically assigned to this series.


 Referencing

IDM 2.8.1 XML-Schema Documentation

Introduction > Referencing

Referencing of elements

The IDM scheme defines references between different elements. Information about these references is stored in a central data area. Multiple use of this information from different data areas is achieved via references. The type of reference which is used in the IDM scheme is described as follows:

Terminology

the following terms for references are used in the IDM scheme:

Key-Element | a XML element which is referenced by other elements.
Ref-Element | a XML element which references other elements.

Reference operation

A key element is identified unambiguously by its attributes. The Ref-element possesses at least the key-attributes of the key-element. A reference between the elements is defined by congruent attributes values of ref- and key-element.

Example: Referencing of a series from an item

The following example shows the way in which way an item ( ITEM ) references a series ( SERIE ). Only an abstract of the XML elements is shown here.

Key-element

T_NEW_CATALOG/SERIES/SERIE

<SERIES>

<SERIE SERIE_NO="1"/> … </SERIE>

<SERIE SERIE_NO="2"/> … </SERIE>

<SERIE SERIE_NO="3"/> … </SERIE>

. . .

<SERIE SERIE_NO="99"/> … </SERIE>

</SERIES>

Ref-element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS>

<ITEM SERIE_NO="1" . . . />

. . .

</ITEMS>

Example: Referencing of a feature

In the following example a feature is referenced by a restriction.

Key-element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!-- Sockelausführung -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!-- Sockelfarbe -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

The XML elements define for feature type 400 (FEATURE) three options (OPTION) numbered 1-3 and for the feature type 401 three options with numbers 1-3. A feature is identified by the combination of FEATURE_NO and OPTION_KEY.

Ref-element

T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_REF

<RESTRICTION RESTRICTION_NO="1">

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="1" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

The XML elements define a restriction for legal combinations (TEST_ID = 1) for the plinth features ( FEATURE_NO=400 ) and plinth colours (FEATURE_NO=401) The ref-element OPTION_REF with the attributes highlighted in grey, reference the key-element OPTION.


 Restrictions

IDM 2.8.1 XML-Schema Documentation

Introduction > Restrictions

Definition and assignment of restrictions

The validity of restrictions may be series specific or comprehensive, programme specific or item specific. The priority of a restriction corresponds with the hierarchy level series -> programme -> item on which the restriction is defined. A restriction defined on item level overrides a restriction which is defined on programme level. Overriding restrictions may only define additional restrictions but not reverse previous restrictions. Example: the availability of an item in a programme is excluded by a restriction defined on item level. A restriction defined on item level may not reverse this exclusion.

First, the restrictions are defined and in a second step they are assigned to series, programmes and items. Definition

Definition of restrictions

Restrictions are defined in the following element:

FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

The element RESTRICTION references the feature combinations for which the restrictions have been defined. The element OPTION_REF references the feature combinations which are subject to control procedures. The element TEST_ID defines a feature combination as legal or illegal combination.

Example: definition of restrictions

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="523" FEATURE_1_NO="100" FEATURE2_NO="101">

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA" FEATURE_NO="100"/> #lacquered

<OPTION_REF OPTION_NO="RO" FEATURE_NO="101"/> # red

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA" FEATURE_NO="100"/> # lacquered

<OPTION_REF OPTION_NO="GR" FEATURE_NO="101"/> # green

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="FU" FEATURE_NO="100"/> # veneered

<OPTION_REF OPTION_NO="BU" FEATURE_NO="101"/> # beech

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

The above mentioned example shows a restriction which defines a legal feature combination of „front finish" (No. 100) and "front colour" (No. 101). According to the above mentioned restriction the combinations lacquer-red, lacquer-green and beech veneer are permitted (TEST_ID = 1). The listing of permitted combinations (OPTION_REF) has to be in accordance with the sequence defined by the attributes in the element RESTRICTION (FEATURE_1_NO, FEATURE_2_NO)

For the purpose of unique and unambiguous identification of a restrictrion a RESTRICTION_NO) is assigned.

Assignment of restrictions

Series independent restriction

Series independent restrictions are assigned by the following elements:

SERIES/RESTRICTIONS/RESTRICTION_REF

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

As the element RESTRICTION_REF is a child element of SERIES/RESTRICTIONS, all restrictions referenced in the element RESTRICTION_REF are assigned to all series which are defined in SERIES/SERIE.

Example: Series independent assignment of restrictions

<SERIES>

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="523"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="678"/>

</RESTRICTIONS>

</SERIES>

In the above mentioned example the restrictions 523 and 678 are referenced and assigned to all series.

Series specific assignment

The rules for a series specific assignment of restrictions correspond to that of series independent assignment. the following element is used for the series-specific assignment:

SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF

The restrictions referenced in the element RESTRICTION_REF are assigned to that series in which the reference was made.

Restrictions which are assigned to programmes are one-level restrictions, containing only the feature No. 1( programme). These restrictions are mandatory if series > 0 and feature No. 1 is defined in the database.

Example: Series-specific assignment of restrictions

<SERIES>

<SERIE SERIE_NO="2">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="67"/>

</RESTRICTIONS>

</SERIE>

<SERIE SERIE_NO="7">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="123"/>

</RESTRICTIONS>

</SERIE>

</SERIES>

In the above mentioned example restrictions 45 and 67 are assigned to series "2" and restrictions 45 and 123 are assigned to series "7".

Item specific assignment

A programme specific assignment of restrictions is defined in the following element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

For item specific assignment the sames rules as for series or programme specific assignment apply.

If no restrictions are assigned to an item, this item is available without any restriction regarding series or programme.

Product group specific assignment

The product group specific assignment of restrictions is defined in the following element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF

The rules for a product group specific assignment of restrictions correspond with the rules for series and programme specific assignment.


 Data types

IDM 2.8.1 XML-Schema Documentation

Introduction > Datatypes

Data types and value ranges

The IDM schema used the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

The following data types are used:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDM, the data type date is used in conformity with the XML schemas as follows: YYYY-MM-DD YYYY = year, MM = month, DD = day
dateTime | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY-MM-DDThh:mm:ssZ YYYY = year, MM = month, DD = day T = Start of time information hh = hour, mm = minute, ss = second Z = UTC time
gYear | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDM for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 or 45.98000 or +27.0.
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDM for mapping URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used for the specification of valid language codes in the IDM.language represents codes for natural languages Tags for the Identification of Languagesas defined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.

The value ranges of the above data types are usually restricted for the elements in the IDM. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters and value lists.

In the XML documentation of the IDM, the value ranges are specified by the information coming after M and P.

In addition to XML data types mentioned here, separate data types are defined for the texts.

They are explained at the end of the documentation.

See also

languagetexte Complex Type

languagetexte30 Complex Type

languagetexte40 Complex Type

languagetexte60 Complex Type

languagetexte60999 Complex Type


 Explanations for the documentation

IDM 2.8.1 XML-Schema Documentation

Introduction > Explanations for the documentation

Explanations for the IDM documentation

This paragraph contains explanations for the documentation of the IDM scheme.

Meaning of element properties

Each element is documented with a description and its properties. The following example shows an element description:

EXCHANGE_ID_NO Attribute Collapse All

Description

This attribute identifies an exchange-ID.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

The properties of the element are listed on the right side. The following abbreviations are used:

D | Documentation of the data type for the element. If no value is set here, the element does not contain user data but further child elements.
P | The values P and M are used to define the range of values. The regular term in P defines the number of legal values.
M | M defines the minium and maximum value in the range of legal values. In a string data type P defines the legal values and M defines the minimum and maximum length of the string. For numerical data types M defines the minimum and maximum value.


 Variation types

Ansicht mit Navigationswerkzeuge

IDM 2.8.1 XML-Schema Documentation

Introduction > Variation types

Variation type | Variation text | Option type | Remark
1 | programm/ style | A | programm asvariation type
2 | serial number | A | assignment of a five-digit serial number
100 | Front finish | A |
101 | Front colour 1 | F | Front filling smooth = complete surface
102 | Front colour 2 | F | Frame
103 | Front colour 3 | F | Pilaster strips
104 | Edge colour front | F |
105 | Front combination | K | If only one key is used for different front information
106 | Front group | A | Overrides the FRONT_GROUP_NO in element FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Front finish contrast colour 1 | A |
111 | Front colour 1 contrast colour 1 | F | Front filling smooth = complete surface
112 | Front colour 2 contrast colour 1 | F | Frame
113 | Front colour 3 contrast colour 1 | F | Pilaster strips
114 | Edge colour front, contrast colour 1 | F |
115 | Front combination, contrast colour 1 | K | The variations 111 - 114 are permitted.
120 | Front finish contrast colour 2 | A |
121 | Front colour 1 contrast colour 2 | F | Front filling smooth = complete surface
122 | Front colour 2 contrast colour 2 | F | Frame
123 | Front colour 3 contrast colour 2 | F | Pilaster strips
124 | Edge colour front, contrast colour 2 | F |
125 | Front combination, contrast colour 2 | K | The variations 121 - 124 are permitted.
150 | Glass finish | A |
151 | Glass colour | F |
152 | Mullion type | A |
153 | Mullion colour | F |
154 | Type glass door frame | A |
155 | Colour glass door frame | F |
160 | Type roller shutter | A |
161 | Colour roller shutter | F |
170 | Type container | A |
171 | Colour container | F |
200 | Type carcase | A |
201 | Carcase combination | K | If only one key is used for several – interior /exterior - carcase colours
202 | Exterior carcase colour | F |
203 | Interior carcase colour | F |
204 | Edge carcase | A |
205 | Edge colour carcase | F |
206 | Type visible side | A |
207 | Colour visible side | F |
208 | Interior carcase colour for glass door cabinets | F | Glass door cabinets and open cabinets, which are not a shelf .
209 | Interior carcase for glass door cabinets | A | Glass door cabinets and open cabinets, which are not a shelf .
300 | Type handle | A |
301 | Handle colour 1 | F | Colour handle, knob or main colour
302 | Handle colour 2 | F | Colour bow, railing, or knob handles
303 | Combination of handles | K | If only one key is defined for several handle conditions
304 | Handle positions | NULL | cf. handle positions p. 5-23
400 | Type plinth | A |
401 | Plinth colour | F |
402 | Plinth height | A |
410 | Type plinth bottom | A |
411 | Colour plinth bottom | F |
500 | Type shelves | A |
501 | Colour shelves | F |
502 | Type cornice | A | Includes shape and material
503 | Colour cornice | F |
504 | Type light pelment | A | Includes shape and material
505 | Colour light pelmet | F |
506 | Type ceiling filler | A |
507 | Colour ceiling filler | F |
508 | Type filler | A | Bottom ledge
509 | Colour bottopm ledge | F | Bottom ledge
510 | Type gallery shelf | A |
511 | Colour gallery shelf | F |
512 | Type gallery shelf edge | A |
513 | Colour gallery shelf edge | F |
514 | Type board | A |
515 | Colour board | F |
516 | Type board edge | A |
517 | Colour board edge | F |
520 | Type side panels/ bars | A |
521 | Colour side panels/ bars | F |
522 | Type bar panel edge | A |
523 | Colour bar panel edge | F |
524 | Type bottom shelf | A |
525 | Colour bottom shelf | F |
526 | Type bottom shelf edge | A |
527 | Colour bottom shelf edge | F |
550 | Type recess | A |
551 | Colour recess | F |
560 | Type recess accessories | A |
561 | Colour recess accessories | F |
562 | Type pilaster | A |
563 | Colour pilaster | F |
564 | Type pilaster edge | A |
565 | Colour pilaster edge | F |
600 | Type worktop | A |
601 | Colour worktop | F |
602 | Type worktop edge | A |
603 | Colour worktop edge | F |
604 | Type countertop | A |
605 | Colour countertop | F |
606 | Type countertop edge | A |
607 | Colour countertop edge | F |
620 | Type cover shelf | A |
621 | Colour cover shelf | F |
622 | Type cover shelf edge | A |
623 | Colour cover shelf | F |
624 | Type attachment table | A |
625 | Colour attachment table | F |
626 | Type attachment table edge | A |
627 | Colour attachment table edge | F |
650 | Type worktop upstand | A | Worktop upstand profile
651 | Colour worktop upstand | F | Worktop upstand profile
700 | Type drawer | A | Interior equipment
701 | Colour drawer | F | Interior equipment
702 | Type pull-out | A | Interior equipment
703 | Colour pull-out | F | Interior equipment
750 | Shape worktop | S |
751 | Shape cornice | S |
752 | Shape light pelmet | S |
753 | Shape plinth | S |
754 | Shape worktop upstand | S |
755 | Shape cover shelf | S |
756 | Shape countertop | S |
800 | Type electrical appliance | A |
801 | Colour electrical appliance | F |
802 | Colour electr. appliances accessories | F |
850 | Type sink | A |
851 | Colour sink | F |
852 | Colour sink accessories | F |
853 | Colour mixer taps | F |
854 | Type mixer taps | A |
900 | Type general accessories | A |
901 | Colour general accessories | F |
930 | additional, graphical relevant information about type 1. | A | The software suppliers have to be informed separately about the meaning.
931 | additional, graphical relevant information about colour 1. | F | The software suppliers have to be informed separately about the meaning.
932 | additional, graphical relevant information about type 2. | A | The software suppliers have to be informed separately about the meaning.
933 | additional, graphical relevant information about colour 2. | F | The software suppliers have to be informed separately about the meaning.
934 | additional, graphical relevant information about type 3. | A | The software suppliers have to be informed separately about the meaning.
935 | additional, graphical relevant information about colour 3. | F | The software suppliers have to be informed separately about the meaning.
936 | additional, graphical relevant information about type 4. | A | The software suppliers have to be informed separately about the meaning.
937 | additional, graphical relevant information about colour 4. | F | The software suppliers have to be informed separately about the meaning.
938 | additional, graphical relevant information about type 5. | A | The software suppliers have to be informed separately about the meaning.
939 | additional, graphical relevant information about colour 5. | F | The software suppliers have to be informed separately about the meaning.
950 | Type miscellaneous 1 | A |
951 | Colour miscellaneous 1 | F |
952 | Type miscellaneous 2 | A |
953 | Colour miscellaneous 2 | F |
954 | Type miscellaneous 3 | A |
955 | Colour miscellaneous 3 | F |
956 | Type miscellaneous 4 | A |
957 | Colour miscellaneous 4 | F |
958 | Type miscellaneous 5 | A |
959 | Colour miscellaneous 5 | F |
960 | Type miscellaneous 6 | A |
961 | Colour miscellaneous 6 | F |
962 | Type miscellaneous 7 | A |
963 | Colour miscellaneous 7 | F |
964 | Type miscellaneous 8 | A |
965 | Colour miscellaneous 8 | F |
966 | Type miscellaneous 9 | A |
967 | Colour miscellaneous 9 | F |
968 | Type miscellaneous 10 | A |
969 | Colour miscellaneous 10 | F |
970 | Type miscellaneous 11 | A |
971 | Colour miscellaneous 11 | F |
972 | Type miscellaneous 12 | A |
973 | Colour miscellaneous 12 | F |
974 | Type miscellaneous 13 | A |
975 | Colour miscellaneous 13 | F |
976 | Type miscellaneous 14 | A |
977 | Colour miscellaneous 14 | F |
978 | Type miscellaneous 15 | A |
979 | Colour miscellaneous 15 | F |
980 | Type miscellaneous 16 | A |
981 | Colour miscellaneous 16 | F |
982 | Type miscellaneous 17 | A |
983 | Colour miscellaneous 17 | F |
984 | Type miscellaneous 18 | A |
985 | Colour miscellaneous 18 | F |
986 | Type miscellaneous 19 | A |
987 | Colour miscellaneous 19 | F |
988 | Type miscellaneous 20 | A |
989 | Colour miscellaneous 20 | F |
998 | customer-specific motifs | F |
999 | Fixed material assignment | F |

Type: A = type

F = colour

K = combination

S = shape


 Required version types

IDM 2.8.1 XML-Schema Documentation

Introduction > Required version types

To assure that all necessary versions are available in the planning process, mandatory version types are defined and must be delivered in accordance with the model code of an item.

Model codes | required version types
Model code type 8 or 27 | 520,521
Model code type 26 | 562,563
Model code type 2 | 500,501
Model code type 29 | 514,515
Model code 5 | 550,551
Model code 20 or 21 | 510511
Model code 12 | 504,505
Model code 11 | 502,503
Model code 14 or 15 | 400,401,402
Model code 18 | 650,651
Model code 17 | 600,601
Front type code 4 | 151, 154, 208
Branch_ID =K | 101,202,203,205

All model codes can be found in the model code table.

The model code type can be found in the model code types table.


 Type key
IDM 2.8.1 XML-Schema Documentation Introduction > Type key |
Type-No. | Denotation
1 | Base cabinet
2 | Tall cabinet
3 | Wall cabinet
4 | Worktop top cabinet
5 | Recess elements
6 | Highboard
7 | Recess cabinet
8 | Solitaire furniture
9 | Front element
10 | Module element
11 | Cornice profile
12 | Light pelmet
13 | Ceiling filler
14 | Plinth blind
15 | Plinth board
17 | Worktop
18 | Worktop upstand profile
19 | Cover shelf
20 | Gallery shelf
21 | Gallery shelf
22 | Construction shelf
24 | Chimney
26 | Electrical appliance
27 | Gas appliance
28 | Small appliance
29 | Sink
30 | Fitting
35 | Lighting
37 | General Accesories
38 | Miscellaneous
41 | Block
42 | Additional equipment
43 | Value clearing
95 | Recycling fees.
98 | Information as subtext
99 | General text information/ order


 EquipmentID

IDM 2.8.1 XML-Schema Documentation

Introduction > Equipment key

EquipmentID

Bezeichnung (englisch)

1

Universal cutter

2

Bread

3

Rotating shelf

4

Bottles

5

Glass

6

Towel

7

Interior drawer/ pull-out
8 | Detergents/broom
9 | Waste sorter system
10 | Swivel mechanism
11 | Extractable table

Interior drawer/ pull-out

8

Detergents/broom

9

Waste sorter system

10

Swivel mechanism

11

Extractable table

12

Larder

13

Linen

14

Spice

16

Dryer

17

Cooker

18

Oven

19

Hob

20

Ceramic hob

21

Extractor hood

22

Extractor

23

Extractor Element

24

Microwave

25

Dishwasher

26

Freezer

27

Fridge

28

Washing machine

29

Control Panel

30

Double oven

31

Sink

32

Steam cooker

33

Warming zone

34

Grill

35

Fryer Fryer

36

Chopping board

37

Coffee maschine

41

Fridge/ freezer combination

42

Oven-Microwave combination

43

Oven/ Warming

46

Low pressure

47

High pressure

48

TV

49

Water dispenser

50

Dish warmer

51

Downdraft cooktop extractor fan

52

Ice cube cutter

53

Beer cooler

54

Drawer


 Installation information key
IDM 2.8.1 XML-Schema Documentation Introduction > Installation information key |
Installation information no. | Designation
1 | For integrated fitting
2 | Installation
3 | Support base
4 | Stand-alone appliance
5 | Fully integrated
7 | Integrated niche
8 | Open niche
11 | Flush with front
12 | Flush with element
13 | Flush with the surface
14 | Surface-mounted
15 | Modules
17 | Stand alone
18 | Free-hanging
19 | Wall-mounted
21 | Visible side
22 | Side plinth
23 | Moulding
24 | Return
25 | Transition
26 | Mitre profiling surcharge
28 | Width reduction
29 | Depth reduction
30 | Height reduction
32 | Cutout
33 | Angled cut
34 | Rounding
35 | Connection
36 | Cutout
37 | Processing
46 | Row 60 cm
47 | Corner
48 | Row 60 cm + corner
49 | Special cabinet


 Material key
IDM 2.8.1 XML-Schema Documentation Introduction > Material key |
Material no. | Designation
1 | Plastic
2 | Corean
3 | Wood
4 | Natural stone
5 | Metal
6 | Tiles
7 | Glass
8 | Composite material
9 | Stainless Steel
10 | Aluminium
11 | Enameled steel
12 | Ceramic


 Shape key
IDM 2.8.1 XML-Schema Documentation Introduction > Shape key |
Shape no. | Designation
1 | Square
2 | Diagonal
3 | Insidecurve
4 | Round
5 | Half-round/rounding
6 | Angled
7 | Z-Form / 3-D
8 | Wavy
9 | 45-degree
10 | 90-degree
11 | 135-degree
12 | N-degree


 Front appearance ID
IDM 2.8.1 XML-Schema Documentation Introduction > Front appearance ID
Frontausprägung-Nr. | Bezeichnung (deutsch)
1 | Door
2 | Drawer
3 | Pull-out
4 | Glass door
5 | Lid/flap
6 | Switch cabinet bezel
7 | Blind
8 | Sliding door
9 | Folding door
10 | Rollershutter front
11 | Door/drawer
12 | Pull-out/drawer
13 | Drawer/blind
14 | Pull-out/door
15 | Pull-out/drawer/door
16 | Door/flap
17 | Pull-out/drawer/flap
18 | Drawer/rollershutter front
20 | without front
21 | 1 bowl without strainer bowl
22 | 1,5 bowls without strainer bowl
23 | 2 bowls without strainer bowl
24 | 1 bowl with strainer bowl
25 | 1,5 bowls with strainer bowl
26 | 2 bowls with strainer bowl
27 | Strainer bowl
28 | 1 bowl with rubbish container
29 | 1,5 bowls with rubbish container
30 | 2 bowls with rubbish container
31 | 1 bowl with strainer bowl and rubbish
32 | 1,5 bowls with strainer bowl and rubbish
33 | Rubbish
36 | With spout
37 | With spout repositioned/uninstalled
38 | Withe hose spray head
39 | Withe hose spray head repositioned/uninstalled
41 | 1 ring
42 | 2 rings
43 | 3 rings
44 | 4 rings
45 | 5 rings
46 | 6 rings
47 | 7 rings
48 | 8 rings
49 | 9 rings


 Type key arts
IDM 2.8.1 XML-Schema Documentation Introduction > Type key arts
Item number | Bezeichnung (deutsch) | Designation (englisch)
1 | Normal | Normal
2 | Regal | Shelf
3 | Rahmen | Frame
4 | Seitenverkleidung | Side cladding
5 | Rückwandverkleidung | Rear cladding
6 | Frontblende | Front facing
7 | Dekorblende | Decorative facing
8 | Formwange | Shaped cheek
9 | Raumteiler | Room divider
10 | Unterbau | substructure
11 | Aufsatz | Cap
14 | Paßstück | Filler
15 | Blende | Baffle
16 | Umbau |
17 | Modul-Umbauschrank | Module housing
19 | Einlegeboden | Shelf
21 | Barplatte | Bar top
22 | Ansetztisch | Fixed table
26 | Pilaster | Pilaster
27 | Stollen |
28 | Paneel | Panel
29 | Bord/Konsole | Board/table
30 | Reling | Rail
32 | Einhebelmischer |
33 | Zweigriffarmatur |
34 | Sonstige Armaturen |
36 | Umluft |
37 | Abluft |
40 | Zubehör | Accessory


 Information key

Ansicht mit Navigationswerkzeuge

IDM 2.8.1 XML-Schema Documentation

Introduction >Information key

Property no.

Designation

Description

Unit of measure

Value

Information for washing machines

100

RATED_CAPACITY

Nominal capacity in kg cotton for the standard program "Cotton 60°C" or the standard program.

"Cotton 40°C", respectively with full load, with the lower of the two values being authoritative.

kg

numerical

101

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 1

A … G

102

WEIGHTED_ANNUAL_ENERGY_CONSUMPTION

weighted annual energy consumption (AE C) in KWh/a, rounded to the next integer. This value must be specified as: Energy consumption of "X" kWh/a on the basis of 220 standard washing cycles at 60°C and 40°C cotton programs with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption depends on the actual use of the appliance.

kWh per year

numerical

103

ENERGY_CONSUMPTION

Energy consumption (E t,60 , E t,60½ , E t,40½ ) of the standard program "Cotton 60°C" with full load and partial load, as well as the "Cotton 40°C" program with partial load.

kWh

numerical

104

WEIGHTED_POWER_CONSUMPTION_OFF

weighted power consumption when switched off

W

Numerical

105

WEIGHTED_POWER_CONSUMPTION_ON

weighted power consumption when switched on

W

Numerical

106

WEIGHTED_ANNUAL_WATER_CONSUMPTION

weighted annual water consumption (AW C) in liters/a, rounded to the next integer. This value must be specified as: Water consumption of "X" litres/a on the basis of 220 standard washing cycles at 60°C and 40°C cotton programs with full load and partial load. The actual water consumption depends on the actual use of the appliance.

litres per year

numerical

107

SPIN_DRYING_EFFICIENCY_CLASS

Spinning efficiency class, determined using table 2 and expressed as spinning efficiency class "X" on a scale from G (lowest efficiency) to A (highest efficiency). A different design can be used as long as it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency).

A … G

108

MAX_SPIN_SPEED

maximum spinning speed for standard program "Cotton 60°C" with full load or for standard program "Cotton 40°C" with partial load, with the lower value being authoritative, as well as residual humidity for standard program "Cotton 60°C" with full load or for standard program "Cotton 40°C" with partial load, with the higher value being authoritative,.

revolutions per minute

numerical

109

INDICATION_STANDARD

Information about the fact that the standard programs "Cotton 60°C" and "Cotton 40°C" are the standard washing programs to which the information on the label and data sheet refer, that these programs are suitable for washing averagely dirty cotton fabrics and the most efficient ones with respect to the combined energy and water consumption.

Zeichenfolge ST oder leer

110

PROGRAMME_TIME

Program duration of the standard program "Cotton 60°C" with full load and partial load, as well as the "Cotton 40°C" program with partial load in minutes, rounded to the next minute.

min

numerical

111

DURATION_LEFT_ON_MODE

Time appliance is in switched on mode (T I ) if the household washing machine is equipped with power control.

min

numerical

112

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Airborne acoustical emissions in db(A) re 1 pW, rounded to the next integer, during washing and spinning in the standard program "Cotton 60°C" with full load.

dB

numerical

Information for dishwashers

120

RATED_CAPACITY

Nominal capacity in standard place settings for the standard cleaning mode

Quantity

numerical

121

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 3

A … G

122

ANNUAL_ENERGY_CONSUMPTION

annual energy consumption (AE C ) in KWh/a, rounded to the next integer. This value must be stated as energy consumption "X" kWh/a on the basis of 280 standard cleaning cycles with cold water and the consumption incurred in the operating modes with the lowest power consumption. The actual energy consumption depends on the actual use of the appliance.

kWh per year

numerical

123

ENERGY_CONSUMPTION

Energy consumption (E t ) of the standard cleaning cycle

kWh

numerical

124

POWER_CONSUMPTION_OFF

weighted power consumption when switched off

W

numerical

125

POWER_CONSUMPTION_ON

weighted power consumption when switched on

W

Numerical

126

WEIGHTED_ANNUAL_WATER_CONSUMPTION

weighted annual water consumption (AW C ) in liters/a, rounded to the next integer. This must be stated as: water consumption "X" litres/a based on 280 standard dishwashing cycles. The actual water consumption depends on the actual use of the appliance.

litres per year

numerical

127

DRYING_EFFICIENCY_CLASS

Drying efficiency class, determined in accordance with table 4 and expressed as the drying efficiency class "X" on a scale from G (lowest efficiency) to A (highest efficiency). A different design may be used if data is displayed in a table, provided it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency).

A … G

128

INDICATION_STANDARD

Information about the fact that the "standard program" is the cleaning cycle to which the information on the label and data sheet refer, that this program is suitable for washing averagely dirty dishes and the most efficient one with respect to the combined energy and water consumption.

Character sequence ST or blank

129

PROGRAMME_TIME

Program duration of the standard cleaning cycle in minutes, rounded to the next integer.

min

numerical

130

DURATION_LEFT_ON_MODE

Time appliance is in switched on mode (T I ) if the household dishwasher is equipped with power control

min

numerical

131

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Airborne acoustical emissions in db(A) re 1 pW, rounded to the next integer.

dB

numerical

Information for tumble dryers

140

RATED_CAPACITY

Nominal capacity in kg cotton clothing for the standard cotton program with full load

kg

numerical

141

TUMBLE_KIND

whether the household tumble dryer is an exhaust air, condensation or gas-heated household tumble dryer

Code A, C or G

142

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 5

A … G

143

WEIGHTED_ANNUAL_ENERGY_CONSUMPTION

for electrically heated household tumble dryers:

weighted annual energy consumption (AE c ) in KWh/a, rounded to one decimal space. This value must be specified as: Energy consumption of "X" kWh/a on the basis of 160 drying cycles for the standard cotton program with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption per cycle depends on the actual use of the appliance.

for gas-heated household tumble dryers:

weighted annual energy consumption (AE c (gas) ) in KWh/a, rounded to one decimal space. This value must be specified as: Energy consumption of "X" gas kWh/a on the basis of 160 drying cycles for the standard cotton program with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption per cycle depends on the actual use of the appliance.

and

weighted annual energy consumption (AE C (gas)el ), rounded to one decimal space. This value must be specified as: Energy consumption of "X" kWh/a on the basis of 160 drying cycles for the standard cotton program with full load and partial load, as well as consumption of operating modes with low power consumption. The actual energy consumption per cycle depends on the actual use of the appliance.

kWh per year

numerical

144

AUTOMATIC

whether the household tumble dryer is a tumble dryer with automatic controls or a tumble dryer without automatic controls

1=true
0=false

145

ENERGY_CONSUMPTION

Energy consumption (E dry , E dry½ , Eg dry , Eg dry½ , Eg dry,a , Eg dry½,a ) of the standard cotton program with full load and partial load.

kWh

numerical

146

POWER_CONSUMPTION_OFF

Power consumption when switched off (P o ) for the standard cotton program with full load

W

numerical

147

POWER_CONSUMPTION_ON

Power consumption when switched on (P I ) for the standard cotton program with full load

W

numerical

148

DURATION_LEFT_ON_MODE

Time appliance is in switched on mode if the household tumble dryer is equipped with power control.

min

Numerical

149

INDICATION_STANDARD

Information about the fact that the "standard cotton program" with full and partial load is the standard drying program to which the information on the label and data sheet refers, that this program is suitable for drying normally wet cotton clothes and the most efficient one for cotton with respect to the energy consumption

Character sequence ST or blank

150

WEIGHTED_PROGRAMME_TIME

weighted program duration (T t ) of the "standard cotton program with full and partial load" in minutes, rounded to the next full minute.

min

numerical

151

WEIGHTED_PROGRAMME_TIME

Program duration of the "standard cotton program" with full load (T dry ) in minutes, rounded to the next full minute.

min

numerical

152

WEIGHTED_PROGRAMME_TIME

Program duration of the "standard cotton program" with partial load (T dry½ ) in minutes, rounded to the next full minute.

min

numerical

153

CONDENSATION_EFFICIENCY

if the household tumble dryer is a condensation dryer, the condensation efficiency class as stated in table 6 expressed as "condensation efficiency class 'X' on a scale from G (lowest efficiency) to A (highest efficiency); a different design can be used provided it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency)

A … G

154

AVERAGE_CONDENSATION_EFFICIENCY

if the household tumble dryer is a condensation dryer, the average condensation efficiency C dry and C dry½ of the standard cotton program with full load and partial load and the weighted condensation efficiency (C t ) for the standard cotton program with full and partial load expressed as a percentage number rounded to the next full percent

%

Numerical

155

SOUND_POWER_LEVEL

Sound power level (weighted average value - L WA ) in db, rounded to the next integer, for the standard cotton program with full load

dB

numerical

Information for combo washer dryers

160

ENERGY_EFFICIENCY_CLASS

Energy efficiency class of the model as per table 7, expressed as "energy efficiency class". . on a scale from A (low energy consumption) to G (high energy consumption)". A different design may be used if data is displayed in a table, provided it is made clear that the scale ranges from G (lowest efficiency) to A (highest efficiency).

A … G

161

ENERGY_CONSUMPTION

Energy consumption in kWh per completed operating cycle (washing, spinning, drying)

kWh

numerical

162

ENERGY_CONSUMPTION_W_D_ONLY

Energy consumption in kWh for the washing and spinning program only

kWh

numerical

163

WASHING_PERFORMANCE

Washing performance class as per table 8, expressed as "washing performance class . on a scale from A (better) to G (poor)". A different design can be used as long as it is made clear that the scale ranges from A (better) to G (poor).

A … G

164

WATER_EXTRACTION_EFFICIENCY

Spinning performance for the standard program "Cotton 60°C", expressed as "residual humidity after spinning ...% (percentage of the dry weight of the load)"

%

numerical

165

MAX_SPIN_SPEED

maximum spinning speed for the standard program "Cotton 60°C"

revolutions per minute

numerical

166

WASH_CAPACITY

Load capacity (washing) of the appliance for the standard program "Cotton 60°C"

kg

numerical

167

DRY_CAPACITY

Load capacity (drying) of the appliance for the standard program "Cotton shelf-dry"

kg

numerical

168

WATER_CONSUMPTION

Water consumption in l per completed operating cycle (washing, spinning and drying)

litres

numerical

169

WATER_CONSUMPTION_W_D_ONLY

Water consumption in 1 for washing and spinning only for the standard program "Cotton 60°C"

litres

numerical

170

WASHING_DRYING_TIME

Washing and drying time: duration until operating cycle (washing, spinning and drying) is completed in the standard program "Cotton 60°C" and the drying program "Cotton shelf-dry" with nominal capacity load

min

numerical

171

ENERGY_WATER_CONSUMPTION

Energy and water consumption based on 200 standard cycles, expressed as the estimated annual consumption of a 4-person household that always uses the combo washer dryer for drying (200 programs)

kWh

numerical

172

NOISE_EMISSION

Noise emissions during washing, spinning and drying in the standard program "Cotton 60°C" and "Cotton, shelf-dry",

dB

numerical

Information for refrigerators

180

CATEGORY

Household refrigerator category as per tables 9 and 10

numerical

1 … 10

181

ENERGY_EFFICIENCY_CLASS

Energy efficiency class of the model as per table 11

A … G

182

ANNUAL_ENERGY_CONSUMPTION

annual energy consumption (AE C ) in KWh/a in accordance with no. 3 (2) of Annex VIII, rounded to the next integer. To be stated as: Energy consumption 'XYZ' kWh/a based on results of standard testing over 24 hours. The actual consumption depends on the use and location of the appliance.

kWh per year

numerical

183

STORAGE_VOLUMNE

Capacity of each compartment and, if applicable, star rating in accordance with the total capacity of all freezer compartments that have a star rating (i.e. with an operating temperature ≤ – 6 °C), rounded to the next integer, and star rating of the compartment with the highest share in the total; if the household refrigerator does not have freezer compartments, the supplier will specify "- L" instead of a value and leave the position for the star ranking blank

litres

numerical

184

DESIGN_TEMPERATURE

Design temperature "other compartments" in the meaning of Annex I letter n. For wine chilling compartments, the lowest chilling temperature that is preset for the compartment, or that can be set by the consumer in accordance with the manufacturer's instructions, and that can be maintained permanently

°C

numerical

185

FROST_FREE

Information "Frost-fee" for the relevant compartment(s) other than wine chilling compartments and intended for storage of certain foods with a temperature higher than + 14 °C

Compartment, counted from the bottom up

numerical

186

TEMPERATURE_RISE_TIME

"Storage time during malfunction 'X' h" defines the "temperature rise time"

h

numerical

187

FREEZING_CAPACITY

"Freezing capacity" in kg/24h

kg/24 h

numerical

188

CLIMATE_CLASS

"Climate class" as per table 12, expressed as: climate class: W [climate class]. This appliance is designed for operation in ambient temperatures between 'X' [lowest temperature] °C and 'X' [highest temperature] °C.

SN, N, ST or T

189

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Airborne acoustical emissions in db(A) re 1 pW, rounded to the next integer.

dB

numerical

190

WINE_ONLY

The following must be stated for wine chillers: "This appliance is intended for the storage of wine only." This does not apply to household refrigerators that are not specifically designed for wine chilling but can be used for this purpose and not to household refrigerators that have a wine chilling compartment that is combined with another type of compartment.

1=true

0=false

Information for ovens

200

NUMBER_CAVITY

number of cooking chambers

Quantity

numerical

201

ENERGY_EFFICIENCY_INDEX

the energy efficiency index (EEIcavity) for the first cooking chamber of the model, rounded to one decimal space

numerical

202

ENERGY_EFFICIENCY_CLASS

the energy efficiency class of the model for the first cooking chamber as per table 13

A+++ … D

203

ENERGY_CONSUMPTION

The energy consumption per cycle for the first cooking chamber in conventional cooking mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

204

ENERGY_CONSUMPTION

The energy consumption per cycle for the first cooking chamber in fan-forced mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

205

HEAT_SOURCE_CAVITY

the heat source for the first cooking chamber

E or G

206

VOLUMNE_ CAVITY

the volume of the first cooking chamber

litres

numerical

207

ENERGY_EFFICIENCY_INDEX

the energy efficiency index (EEIcavity) for the second cooking chamber of the model, rounded to one decimal space

208

ENERGY_EFFICIENCY_CLASS

the energy efficiency class of the model for the second cooking chamber as per table 13

A+++ … D

209

ENERGY_CONSUMPTION

The energy consumption per cycle for the second cooking chamber in conventional cooking mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

210

ENERGY_CONSUMPTION

The energy consumption per cycle for the second cooking chamber in fan-forced mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

211

HEAT_SOURCE_CAVITY

the heat source for the second cooking chamber

E or G

212

VOLUMNE_ CAVITY

the volume of the second cooking chamber

Litres

Numerical

213

ENERGY_EFFICIENCY_INDEX

the energy efficiency index (EEIcavity) for the third cooking chamber of the model, rounded to one decimal space

Numerical

214

ENERGY_EFFICIENCY_CLASS

the energy efficiency class of the model for the third cooking chamber as per table 13

A+++ … D

215

ENERGY_CONSUMPTION

The energy consumption per cycle for the third cooking chamber in conventional cooking mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

216

ENERGY_CONSUMPTION

The energy consumption per cycle for the third cooking chamber in fan-forced mode, if available (the measured energy consumption is expressed in kWh (electrical and gas ovens) and in MJ (gas ovens), rounded to two decimal spaces

kWh

numerical

217

HEAT_SOURCE_CAVITY

the heat source for the third cooking chamber

E or G

218

VOLUMNE_ CAVITY

the volume of the third cooking chamber

Litres

numerical

Information for cooker hoods

220

ANNUAL_ENERGY_CONSUMPTION

the annual energy consumption (AEC hood) in kWh/a, rounded to one decimal space

kWh per year

numerical

221

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 14

A+++ … G

222

FLUID_DYNAMIC_EFFICIENCY

The calculated fluid-dynamic efficiency (FDE hood), rounded to one decimal space

numerical

223

FLUID_DYNAMIC_EFFICIENCY_CLASS

The fluid-dynamic efficiency clause as per table 15

A … G

224

LIGHTING_EFFICIENCY

the calculated lighting efficiency (LE hood) in lx/W, rounded to one decimal space

numerical

225

LIGHTING _EFFICIENCY_CLASS

The lighting efficiency class as per table 16, the specified class must not be higher than the class stated in the technical documentation

A … G

226

GREASE_FILTERING_EFFICIENCY

the calculated grease filtering degree in percent, rounded to one decimal space. The stated value must not be higher than the value stated in the technical documentation.

%

numerical

227

GREASE_FILTERING _EFFICIENCY_CLASS

the class for level of grease separation as per table 17

A … G

228

AIR_FLOW

the air flow (in m 3 /h, rounded to the next integer) at maximum and minimum speed in normal mode, intensive mode and fast mode are excluded

m³/h

numerical

229

AIR_FLOW_INTENSIVE

if applicable, the air flow (in m 3 /h, rounded to the next integer) in intensive mode and fast mode

m³/h

numerical

230

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

the A-rated airborne critical noise emissions (in dB, rounded to the next integer) at minimum and maximum available speed in normal mode

dB

numerical

231

AIRBORNE_ACOUSTICAL_NOISE_EMISSION_INT

if applicable, the A-rated airborne acoustical noise emissions (in dB, rounded to the next integer) in intensive mode and fast mode

dB

numerical

232

POWER_CONSUMPTION_OFF

if applicable, the power consumption while switched off (P o ) in Watt, rounded to two decimal spaces

W

numerical

231

POWER_CONSUMPTION_ON

if applicable, the power consumption in standby mode (P o ) in Watt, rounded to two decimal spaces

W

numerical

Information for electrical lamps and lights

240

ENERGY_EFFICIENCY_CLASS

Energy efficiency class as per table 18

A … G

241

WEIGHTED_ENERGY_CONSUMPTION

weighted annual energy consumption (EC) in KWh/1000h, rounded to the next integer.

kWh per 1000 hours

numerical

242

ENERGY_EFFICIENCY_CLASS_COMPATIBILITY

The energy efficiency classes of lights that can be exchanged by the user and with which the light is compatible in accordance with state-of-the-art compatibility requirements

A … G

243

ENERGY_EFFICIENCY_CLASS_N_COMPATIBILITY

The energy efficiency classes of lights with which the lamp is incompatible in accordance with state-of-the-art compatibility requirements

A … G

244

ENERGY_EFFICIENCY_CLASS_LED

The energy efficiency classes for LED modules not intended for removal by the consumer

A … G

245

ENERGY_EFFICIENCY_CLASS_INCLUDED

The energy efficiency classes for lamps operated with the lights that can be exchanged by the consumer and that are included in the lamp's packaging

A … G

Information for TVs

260

ENERGY_EFFICIENCY_CLASS

Energy efficiency class of the model as per table 19

A … G

261

SCREEN_DIAGONAL_CM

visible screen size in centimetres

cm

numerical

262

SCREEN_DIAGONAL_INCH

visible screen size in inches

inch

numerical

263

POWER_CONSUMPTION_ON

Power consumption while switched on

W

numerical

264

ANNUAL_ENERGY_CONSUMPTION

The calculated annual energy consumption in kWh/a, rounded to the next integer. This value is to be stated as: energy consumption XYZ kWh/a based on four hours of daily operation of the TV on 365 days. The actual energy consumption depends on the actual use of the TV.

kWh per year

numerical

265

POWER_CONSUMPTION_OFF

Power consumption while switched off

W

numerical

266

POWER_CONSUMPTION_STANDBY

Power consumption in standby mode

W

numerical

267

SCREEN_RESOLUTION_HORIZONTAL

Screen resolution, measured in the physical horizontal number of pixels.

pt

numerical

268

SCREEN_RESOLUTION_VERTICAL

Screen resolution, measured in the physical vertical number of pixels.

pt

numerical

Information for heating appliances: 280-300

Information for air-conditioners: 300-320

Information for single room heating appliances: 320-340

Information for vacuum cleaners: 340-360

Information for commercial refrigeration cabinets: 360-380

Information for residential ventilation appliances: 380-400

Information for solid fuel boilers and composite systems including solar installations: 400-420

The required numerical data must not be negative numbers. No decimal comma is used for numbers in the thousand range. Decimal spaces are preceded by a dot.

Properties can be freely assigned to the values 800-999.

1. ENERGY EFFICIENCY CLASSES for washing machines

The energy efficiency class of a household washing machine is determined on the basis of its energy efficiency index (EEI) as per table 1.

The energy efficiency index (EEI) of a household washing machine is determined as per table 1.

Table 1

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

2. SPINNING EFFICIENCY CLASSES for washing machines

The spinning efficiency class of a household washing machine is determined on the basis of the residual humidity (D) as per table 2.

Table 2

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

3. ENERGY EFFICIENCY CLASSES for dishwashers

The energy efficiency class of a household dishwasher is determined on the basis of its energy efficiency index (EEI)

Table 3

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

4. DRYING EFFICIENCY CLASSES for dishwasher

Table 4

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

5. ENERGY EFFICIENCY CLASSES for tumble dryers

The energy efficiency class of a household tumble dryer is determined on the basis of its energy efficiency index (EEI) as per table 5.

Table 5

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

6. CONDENSATION EFFICIENCY CLASSES

The condensation efficiency class of a household condensation tumble dryer is determined on the basis of the weighted condensation efficiency (C t ) as per table 6.

Table 6

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

7. EFFICIENCY CLASSES for combo washer dryers

Table 7: efficiency classes

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

Table 8: washing performance classes

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

8. CLASSIFICATION OF HOUSEHOLD REFRIGERATORS

The household refrigerators are classified in categories in accordance with table 9.

Each category is determined by a certain composition of compartments in accordance with table 10 and independent from the number of doors and/or drawers.

Table 9

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Household refrigerators that cannot be assigned to category 1 to 9 due to their compartment temperatures must be assigned to category 10.

Table 10

Household refrigerator classification and compartment composition Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

9. EFFICIENCY CLASSES for refrigeration appliances

The energy efficiency class of a household tumble dryer is determined on the basis of its energy efficiency index (EEI) as per table 5.

Table 11

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

Table 12

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

10. ENERGY EFFICIENCY CLASSES for ovens

The energy efficiency classes for household ovens are determined for each cooking chamber in accordance with the values in table 13.

Table 13 Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

11. EFFICIENCY CLASSES for a cooker hoods

The energy efficiency classes ofcooker hoodsare determined in accordance with the values in table 14.

Table 14

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

The classes for the fluid-dynamic efficiency of a household cooker hood are determined on the basis of their fluid-dynamic efficiency (FDE hood) in accordance with the following table 15.

Table 15

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

The classes for the illumination efficiency of a household cooker hood are determined on the basis of their illumination efficiency (LE hood) in accordance with the following table 16.

Table 16

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

The classes for the level of grease separation of a household cooker hood are determined on the basis of their grease separation level (GFE hood) in accordance with the following table 17.

Table 17 Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

12. ENERGY EFFICIENCY CLASSES for lamps

Table 18

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

13. ENERGY EFFICIENCY CLASSES for TVs

Table 19

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

The official EU journals pertaining to the relevant directives and regulations can be found at the following links:

https://ec.europa.eu/info/energy-climate-change-environment/standards-tools-and-labels/products-labelling-rules-and-requirements/energy-label-and-ecodesign/energy-efficient-products_en

Links to the individual product groups are available in multiple languages.


 Standard handle orientations

IDM 2.8.1 XML-Schema Documentation

Introduction > Standard handle orientations

Standard handle orientation | Denotation | Picture | Description
0 | Without drilling, with handle |  | valid for all types of front
1 | horizontally centred - vertical at outer edge | Ein Bild, das Platz enthält. Automatisch generierte Beschreibung | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal) vertical orientation at outer edge for: doors; glass doors; roller shutters (vertical)
2 | horizontally centred - horizontal at outer edge | Ein Bild, das Platz enthält. Automatisch generierte Beschreibung | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal) horizontal orientation at outer edge for: doors; glass doors; roller shutters (vertical)
3 | vertically centred - vertical at outer edge | Ein Bild, das Platz enthält. Automatisch generierte Beschreibung | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal) vertical orientation at outer edge for: doors; glass doors; roller shutters (vertical)
4 | vertically centred - horizontal at outer edge | Ein Bild, das Platz enthält. Automatisch generierte Beschreibung | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal) horizontal orientation at outer edge for: doors; glass doors; roller shutters (vertical)
5 | horizontally centred - vertically centred | Ein Bild, das Platz enthält. Automatisch generierte Beschreibung | horizontally centred orientation for: drawers; pull-outs; flap doors; shutters (horizontal) vertical centred orientation for: doors; glass doors; roller shutters (vertical)
6 | Waagerecht mittig - Waagerecht mittig | Ein Bild, das Platz enthält. Automatisch generierte Beschreibung | horizontally centred orientation for: drawers; pull-outs; flap doors; shutters (horizontal) horizontally centred orientation for: doors; glass doors; roller shutters (vertical)
7 | Senkrecht mittig - Senkrecht mittig |  | vertically centred orientation for: drawers; pull-outs; flap doors; shutters (horizontal) vertical centred orientation for: doors; glass doors; roller shutters (vertical)
8 | Senkrecht mittig - Waagerecht mittig |  | vertically centred orientation for: drawers; pull-outs; flap doors; shutters (horizontal) vertical centred orientation for: doors; glass doors; roller shutters (vertical)
9 | Horizontal at the top, full width - horizontal at the top, full width |  | orientation horizontal, full width, for: drawers; pull-outs; flap doors; shutters (horizontal) horizontal orientation full width for: doors; glass doors; flap doors; roller shutters (vertical)
10 | horizontal at the bottom of the element, full width - horizontal at the top of the element, full width |  | orientation at the bottom, full width, for: drawers; pull-outs; flap doors; shutters (horizontal) horizontal orientation full width for: doors; glass doors; roller shutters (vertical)
11 | horizontal at the top, full width - vertical at outer edge, full height | Ein Bild, das Platz enthält. Automatisch generierte Beschreibung | orientation horizontal, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). orientation at the outer edge, full height, for: doors; glass doors; roller shutters (vertical).
12 | horizontal at the bottom, full width - vertical at outer edge, full height |  | orientation at the bottom, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). orientation at the outer edge, full height, for: doors; glass doors; roller shutters (vertical)
90 | No standard handle orientation applicable. |  |
91 | No standard handle orientation applicable. |  |
92 | No standard handle orientation applicable. |  |
93 | No standard handle orientation applicable. |  |
94 | No standard handle orientation applicable. |  |
95 | No standard handle orientation applicable. |  |
96 | No standard handle orientation applicable. |  |
97 | No standard handle orientation applicable. |  |
98 | No standard handle orientation applicable. |  |
99 | Without drilling, without handle |  |


 Basic shapes

IDM 2.8.1 XML-Schema Documentation

Introduction > Basic shapes

Introduction

This part of the IDM documentation describes the necessary basic forms for the data exchange.

The basic shapes are parametrized graphic illustrations. When data is exchanged, the parameters with the individual values are transmitted rather than the illustrations. A 3-D illustration is created in the processing systems on the basis of numbers unequivocally assigned to a basic shape and the parameter values. The IDM contains basic shapes for carcases, panels and tables, fronts, handles as well as for cornices and light pelmets.

General information on basic shapes

The basic shape is specified in the CARCASE_BASIC_SHAPE element. The basic shapes for carcases and table attachments are typified on the basis of top views on the relevant object. The illustrations of the objects are created by assigning values to the individual parameters. The measurements are assigned on the basis of milimeter data. For visualization purposes, almost all basic shapes have a perspective example and an example for the assignment of values to the parameters.

The represented basic shapes are only valid for cabinets/wooden parts and worktops, light pelmets, cornices etc., but not for accessories and electrical appliances. The basic shape no. 0 and no. 997 to no. 999 are used for accessories and electrical appliances. The basic shape no. 0 is available for items that are irrelevant for the illustration. Basic shape no. 997 is used for items for which neither a basic shape nor a real image or bitmap are available. It must be assured that the fields SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO in ITEM are filled and illustration information from the manufacturer are available. Basic shape no. 998 is used for items that are represented using a bitmap only. It must be assured that the fields FILE_NAME_TEXTURE_1/2 in ITEM are filled. Basic shape no. 999 is used if a real image is delivered rather than a basic shape. The values w, h and d must be specified in the BASIC_SHAPE_PARAMETERS for all basic shape numbers (0 and 997 - 999). The only exemptions are items without dimensions, e.g. width adjustments.

Basic shape no. 996 was introduced for filling levels below filling level 3. Basic shape no. 996 represents a visually relevant item for which further details analogous to basic shapes 997-999 are currently unavailable.

Values for width, height, depth and diameter without indices can be used as dimensions (boundingbox). For differentiation purposes, the "diameter" parameter is used for roundings that are relevant for the dimensions.

Because the "α" character cannot be used as a parameter, an "a" is used to specify the angle parameter.

Variable dimensions can be specified by values within the permitted range („from“(BASIC_SHAPE_FROM) „to“(BASIC_SHAPE_TO)) within the BASIC_SHAPE_PARAMETER in addition to the nominal dimensions (BASIC_SHAPE_NOMINAL_VALUE ). To allow for symmetric length adjustments, an object is overdetermined by the dimensions. The following definitions apply:

Rule 1:The overall dimension without index must correspond to the total of all component dimensions.

Rule 2:If a dimension variability is only specified for the overall dimension, all component dimensions are adjusted symmetrically.

Rule 3:The dimensions are fixed if there are no "from " and "to" values specified for the overall dimension (without indices). If values are specified for "from" and "to", the dimensions are flexible within this range.

Rule 4:If the option of dimension variability is only entered for component dimensions, the object will not be modified symmetrically, but the total of the component dimensions must result in the overall dimension.

Rule 5:By specifying equal values in the "from" and "to "fields, individual component dimensions (not w, h, d) can be exempt from the symmetric adjustment (see example).

Rule 6:The dimensions are adjusted (symmetrical distribution, addition to the overall dimension) for dimensions with indices (component dimensions) that have no "from" and "to" values specified. If values are specified for "from" and "to", the dimensions are flexible within this range.

The required dimensions relate to the carcase dimensions and not to front thickness. Guidance is provided by a double line on the sides and front surface of the carcases. This line represents both front panels as well as shelf openings.

For each basic shape, the alignment is defined by illustrating the wall. This is also the reason for the differentiator for basic shapes no. 5 and 8, which are primarily intended as elements for stand-alone and island solutions. This results from the only side available for planning facing the wall.

Special geometries cannot be mapped using the basic shapes. This is why basic shape numbers 997-999 are available for items that cannot be visualized using the available basic shapes. Basic shape no. 0 is used for items that are irrelevant for visualization purposes.

In this example, the carcase with a width of 700 mm for width 1 and width 3 is in each case shortened by 50 mm from the nominal dimensions.

The specified CONSTRUCTION_ID relates to the displayed illustrations. If CONSTRUCTION_ID = N, it is essential for the item to be symmetric. An item on the display may become asymmetric if the parameters are varied. The result is that CONSTRUCTION_ID = N must not be used for this item. It is now possible to create a separate item for each construction type ("L" or "R"), or an item with CONSTRUCTION_ID = J. If CONSTRUCTION_ID = J is used, the parameters for the left (CONSTRUCTION_ID "L") must be specified.

Changing the parameters must not result in changes to certain limiting conditions with regard to the parallelism of edges to other edges. If this case is theoretically possible, the corresponding basic shapes will contain an explicit notice.

Assigning a "leading" parameter aims at assuring a uniform cross-manufacturer allocation to a left or right CONSTRUCTION_ID. The leading parameter is specified for the relevant basic shape. For the left CONSTRUCTION_ID, the values of these parameters must be smaller on the left side of the illustration than the corresponding parameter on the right side. Also see the example below.

Example for an asymmetric item illustration for basic shape no. 4:

symmetric item asymmetric item asymmetric item

with CONSTRUCTION_ID=N with CONSTRUCTION_ID=R with CONSTRUCTION_ID=L

Parameters:

b1=b3 and t1=t2 b1<>b3 and t1<>t2 b1<>b3 and t1<>t2

In the case of asymmetric items with CONSTRUCTION_ID=J, a construction type right or left is created depending on the options in the dealer software system.

By setting the relevant parameters to equal values, basic shapes that are illustrated as construction type L and construction type R can be made symmetric. As an example, basic shape 19 can be specified with CONSTRUCTION_ID = N by setting identical values in parameters d = w and we= de.

Basic shapes that are only specified as CONSTRUCTION_ID = L and CONSTRUCTION_ID = R but that can also be specified as CONSTRUCTION_ID = N by setting identical values in certain parameters have a reference points that is identical to CONSTRUCTION_ID = L. A small circle highlights the reference point in the illustrations.


 Basic carcase forms

IDM 2.8.1 XML-Schema Documentation

Introduction > Basic Shapes > Basic carcase forms

Basic shape 1

Parameters: b = width h = height t = depth value range for CONSTUCTION_ID: N L R

Example:

b=600mm, h=720mm, t=560mm, CONSTRUCTION_ID=N

Basic shape 2

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth(carcase) t1=depth1 value range for CONSTRUCTION_ID: J,L,R

Example:

Ein Bild, das Möbel, Datei enthält. Automatisch generierte Beschreibung

b=365mm, h=720mm, t=575mm, t1=401mm, CONSTRUCTION_ID=R

Basic shape 3

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth(carcase) b1=width1 t1=depth1 value range for CONSTRUCTION_ID: N

Example 1:

b=365mm, h=590mm, t=560mm, t1=460mm, b1=365mm, CONSTRUCTION_ID=R

Example 2:

Ein Bild, das Möbel, Tisch, Handkarren enthält. Automatisch generierte Beschreibung

b=900mm, h=720mm, t=600mm, t1=560mm, b1=900mm, CONSTRUCTION_ID=R

Basic shape 4

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 t1=depth1 t2=depth2 value range for CONSTRUCTION_ID: N,L,R,J

Example:

Ein Bild, das Handkarren, Strichzeichnung enthält. Automatisch generierte Beschreibung

b=600mm,
h=720mm, t=365mm b1=120mm, b2=360mm, b3=120mm, t1=120mm, t2=120mm,
CONSTRUCTION_ID=N

Comments:

Widths 1-3 can be variably defined in the "from" and "to" fields. If a symmetric variability is to be specified, a value for the "from" and "to" fields must be specified for width w.

CONSTRUCTION_ID = N only if

b1 = b3, t1 = t2

b2 is always parallel to b and observe

b = b1 + b2+ b3

The leading parameters are b1 and b3.

Basic shape 5

Parameters: b=width(carcase) h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 t1=depth1 t2=depth2 value range for CONSTRUCTION_ID: N,L,R,J

Example:

Ein Bild, das Handkarren enthält. Automatisch generierte Beschreibung

b=600mm,
h=720mm, t=365mm b1=120mm, b2=360mm, b3=120mm, t1=120mm, t3=120mm,
CONSTRUCTION_ID=N

Comments:

Primary use as a stand-alone element.

Widths 1-3 can be variably defined in the "from" and "to" fields. If a symmetric variability is to be specified, a value for the "from" and "to" fields must be specified for width w.

CONSTRUCTION_ID = N only if b1 = b3, t1 = t3

b2 is always parallel to b and observe

b = b1 + b2+ b3

The leading parameters are b1 and b3.

Basic shape 6

Parameters: b=width(carcase) h=height t=depth(carcase) b1=width1 b3=width3 t1=depth1 t2=depth2 t3=depth3 value range for CONSTRUCTION_ID: L,R,J

Example:

Ein Bild, das Handkarren enthält. Automatisch generierte Beschreibung

b=365mm,
h=724mm, t=585mm b1=120mm, b3=120mm, t1=120mm, t2=360mm, t3=120mm,
CONSTRUCTION_ID= R

Comments:

Depths 1-3 can be variably defined in the "from" and "to" fields. If a

symmetric variability is to be specified, a value for the "from" and "to" fields for depth d

must be specified.

t = t1 + t2+ t3 applies.

Basic shape 7

Parameters: b=width(carcase) h=height t=depth(carcase) r1=radius1 r2=radius2 b1=width1 t1=depth1 t2=depth2 value range for CONSTUCTION_ID:N,L,R,J

Example:

Ein Bild, das Möbel, Tisch, Stand, Arbeitstisch enthält. Automatisch generierte Beschreibung

b=500mm,
h=720mm, t=300mm, b1=350mm, t1=225mm, t2=225mm, r1=75mm, r2=75mm,
CONSTRUCTION_ID=N

Comments:

CONSTRUCTION_ID = N only if

t1 = t2, r1 = r2

b1 is always parallel to bàt1+r1 = t2+r2 and

b = r1 + b1+ r2, t = t1 + r1 and t = t2 + r2 applies.

The leading parameters are r1 and r2.

Basic shape 8

Parameters: b=width(carcase) h=height t=depth(carcase) r1=radius1 r2=radius2 b1=width1 t1=depth1 t2=depth2 value range for CONSTUCTION_ID:N,L,R,J

Example:

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

b=500mm,
h=720mm, t=300mm b1=350mm, t1=225mm, t2=225mm, r1=75mm, r2=75mm,
CONSTRUCTION_ID=N

Comments:

Primary use as a stand-alone element.

The perspective examples are identical for basic carcase forms 8 and 9. The basic carcase forms only differ in their alignment to the wall. CONSTRUCTION_ID = N only if d1 = d2, r1 = r2

b1 is always parallel to bàt1+r1 = t2+r2 and

b = r1 + b1+ r2, t = t1 + r1 and t = t2 + r2 applies.

The leading parameters are r1 and r2.

Basic shape 9

Parameters: b=width(carcase) h=height t=depth(carcase) r1=radius1 r2=radius2 b1=width1 b2=width2 t1=depth1 value range for CONSTUCTION_ID:L,R,J

Example:

Ein Bild, das Tisch enthält. Automatisch generierte Beschreibung

b=300mm,
h=720mm, t=500mm b1=225mm, b2=225mm, t1=350mm, r1=75mm, r2=75mm,
CONSTRUCTION_ID=J

Comments:

The perspective examples are identical for basic carcase forms 8 and 9. The basic carcase forms

only differ in their alignment to the wall.

The formula

b= r1 + b1, b = b2 + r2 and t = t2 + r1 + r2 applies.

Basic shape 10

Parameters: b=width(carcase) h=height t=depth(carcase) b1=width1 t1=depth1 value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=600mm, h=1900mm, t=560mm b1=300mm, t1=460mm, CONSTRUCTION_ID= N

Comments:

CONSTRUCTION_ID = N only if

b1 = b2

The leading parameter is b1.

Basic shape 11

Ein Bild, das dunkel enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth(carcase) t1=depth1 value range for CONSTRUCTION_ID: L,R,J

b=365mm, h=590mm, t=560mm, t1=460mm, CONSTRUCTION_ID= R

Basic shape 12

Ein Bild, das Text, Elektronik, dunkel enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 t1=depth1 value range for CONSTRUCTION_ID: L,R,J

Example:

 b=600mm,
h=720mm, t=575mm, b1=150mm, b2=300mm, b3=150mm, t1=460mm,
CONSTRUCTION_ID=R

Comments:

Widths 1-3 can be variably defined in the "from" and "to" fields. If a

symmetric variability is to be specified, a value for the "from" and "to" fields for width w.

must be specified.

The formula b = b1 + b2 + b3 applies.

Basic shape 13

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 t1=depth1 value range for CONSTRUCTION_ID: L,R,J

Example:

Ein Bild, das Text, Möbel, Tisch enthält. Automatisch generierte Beschreibung

 b=900mm,
h=720mm, t=575mm, b1=175mm, b2=550mm, b3=175mm, t1=175mm,
CONSTRUCTION_ID=L

Comments:

Widths 1-3 can be variably defined in the "from" and "to" fields. If a

symmetric variability is to be specified, a value for the "from" and "to" fields for width w.

must be specified.

The available options are CONSTRUCTION_ID = L, R, J

The formula b = b1 + b2 + b3 applies.

Basic shape 14

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 b5=width5 t1=depth1 t2=depth2 t3=depth3 value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=900mm,
h=720mm, t=575mm, b1=175mm, b2=175mm, b3=200mm,b4=175mm,
b5=175mm, t1=175mm, t2=400mm, t3=400mm, CONSTRUCTION_ID=N

Comments:

Widths 1-5 can be variably defined in the "from" and "to" fields. If a

symmetric variability is to be specified, a value for the "from" and "to" fields for width w.

must be specified.

CONSTRUCTION_ID = N only if

b1 = b5, b2 = b4, t2 = t3

b1, b3 and b5 are always parallel to bàb1+b2 = b4 and b = b1 + b2 + b3 + b4 + b5 applies

The leading parameters are b1+b2 and b4+b5.

Basic shape 15

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 t1=depth1 t2=depth2 t3=depth3 value range for CONSTRUCTION_ID: N,L,R,J

Example:

Ein Bild, das Glas enthält. Automatisch generierte Beschreibung

b=600mm,
h=590mm, t=465mm, b1=150mm, b2=300mm,
b3=150mm, t1=50mm, t2=50mm, t3=365mm, CONSTRUCTION_ID=N

Comments:

Widths 1-3 can be variably defined in the "from" and "to" fields. If a

symmetric variability is to be specified, a value for the "from" and "to" fields for width b.

must be specified.

CONSTRUCTION_ID = N only if

b1 = b3

b1 and b3 are always parallel to w

The leading parameters are b1 and b3 and b = b1 + b2 + b3; t = t1 + t2 + t3 applies .

Basic shape 16

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width b1=width1 te=corner depth value range for CONSTRUCTION_ID: L,R,J

Example:

b=365mm, h=720mm, t=575mm, te=0mm, be=0mm, t1=195mm, b1=195mm, CONSTRUCTION_ID=R

Comments:

CONSTRUCTION_ID = N also if

b = t, b1 = t1, te = be

Basic shape 17

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width te=corner depth r=radius value range for CONSTRUCTION_ID: L,R,J

Example:

b=365mm, h=720mm, t=575mm, te=0mm, be=0mm, r=200mm, CONSTRUCTION_ID=R

Comments:

CONSTRUCTION_ID = N also if

b = t, be = te

Basic shape 18

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width b1=width1 te=corner depth t1=depth1 value range for CONSTRUCTION_ID: L,R,J

Example:

Ein Bild, das Handkarren, Tisch, Konsolentisch, Arbeitstisch enthält. Automatisch generierte Beschreibung

b=900mm,
h=720mm, t=900mm, te=0mm, be=0mm, b1=300mm,
t1=300mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te, b1 = t1

Basic shape 19

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width te=corner depth r=radius value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=900mm, h=720mm, t=900mm, te=70mm, be=70mm, r=300mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te

Basic shape 20

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width te=corner depth b1=width1 t1=depth1 value range for CONSTRUCTION_ID: N,L,R,J

Example:

Ein Bild, das Handkarren, Tisch enthält. Automatisch generierte Beschreibung

b=900mm,
h=720mm, t=900mm, te=0mm,
be=0mm, b1=600mm, t1=600mm,CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te, b1 = t1

Basic shape 21

Parameters: b=width(carcase) h=height t=depth(carcase) be=corner width te=corner depth b1=width1 b2=width2 b3=width3 t1=depth1 t2=depth2 t3=depth3 value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=900mm,
h=720mm, t=900mm, te=0mm, be=0mm, b1=600mm, b2=150mm,
b3=150mm t1=150mm, t2=150mm, t3=600mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te, b1 = t3; b3 = t1, b2 = t2

b must equal b1+b2+b3 and t=t1+t2+t3

Basic shape 22

Parameters: b=width h=height t=depth be=corner width te=corner depth b1=width1 b2=width2 r=radius value range for CONSTRUCTION_ID: N,L,R,J

Example:

b=900mm,
h=720mm, t=900mm, te=0mm, be=0mm, b1=600mm, b2=250mm, t1=250mm,
t2=600mm, r=50mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te, b1 = t2, b2 = t1

b must equal b1+r+b2 and t=t1+t2+r

Basic shape 23

Parameters: b=width h=height d=depth wc=corner width dc=corner depth w1=width1 w2=width2 r=radius value range for CONSTRUCTION_ID: N,L,R,J

b=900mm, h=720mm, t=900mm, te=0mm, be=0mm, b1=600mm, b2=100mm, t1=100mm, t3=600mm, r=200mm, CONSTRUCTION_ID=N

Comments:

This basic shape is primarily intended for corner cabinets.

CONSTRUCTION_ID = N also if

b = t, be = te, b1= t2, b2 = t1

b must equal wb+r+b2 and t=t1+t2+r

Basic shape 24

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 a=angleα value range for CONSTRUCTION_ID: N,L,R,J

Filler [image] Filler profile

b=90mm, h=720mm, t=67mm, b1=14mm, b2=14mm, b3=57mm, b4=57mm, t1=380mm, t2=380mm, a=135°, CONSTRUCTION_ID=N

Ein Bild, das Handkarren, Tisch enthält. Automatisch generierte Beschreibung

b=900mm, h=720mm, t=670mm, b1=140mm, b2=140mm, b3=570mm, b4=570mm, t1=380mm, t2=380mm, a=135mm, CONSTRUCTION_ID=N

Comments:

CONSTRUCTION_ID = N also if

b = t, t1 = t2, b1 = b2, b3 = b4 and a = 135°

Basic shape 25

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 a=angleα value range for CONSTRUCTION_ID: N,L,R,J

Ein Bild, das Tisch, Konsolentisch, Strichzeichnung enthält. Automatisch generierte Beschreibung

b=900mm, h=720mm, t=670mm, te=0mm, b1=140mm, b2=140mm, b3=570mm, b4=570mm, t1=380mm, t2=380mm, a=135mm, CONSTRUCTION_ID=N

Comments:

CONSTRUCTION_ID = N also if

b = t, t1 = t2, b1 = b2, b3 = b4 and a = 135°

Basic shape 26

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height(total) t=depth b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 h1=cabinets height value range for CONSTRUCTION_ID: N

Ein Bild, das Text, Haushaltsgerät enthält. Automatisch generierte Beschreibung

w=1100mm, h=560mm, d=1100mm, w1=1555mm, w2=400mm, w3=600mm, w4=400mm, d1=300mm, d2=400mm, h1=590mm, CONSTRUCTION_ID=N

Comments:

b must be equal to t.

Basic shape 27

Ein Bild, das Text, Elektronik enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 t1=depth1 value range for CONSTRUCTION_ID: L,R,J

Ein Bild, das Tisch, Handkarren, Arbeitstisch enthält. Automatisch generierte Beschreibung

b=1300mm, h=720mm, t=700mm, b1=600mm, b2=600mm, b3=750mm, t1=600mm CONSTRUCTION_ID=R

Comments:

A front partition refers to the surface characterized by the parameter b2.

Basic shape 28

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 h1=height1 h2=height2 value range for CONSTRUCTION_ID: L,R,J

b=1100mm, h=720mm, t=700mm, b1=500mm, b2=600mm, h1=500mm, h2=220mm CONSTRUCTION_ID=L

Basic shape 29

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 h1=height1 h2=height2 value range for CONSTRUCTION_ID: N

Ein Bild, das Möbel, Garderobe enthält. Automatisch generierte Beschreibung

b=900mm, h=715mm, t=450mm, b1=0mm, b2=450mm, h1=615mm, h2=100mm CONSTRUCTION_ID=N

b=900mm, h=715mm, t=450mm, b1=400mm, b2=250mm, h1=615mm, h2=100mm CONSTRUCTION_ID=N

Comments:

w2 must equal (w-w1)/2.

Basic shape 30

Parameters: b=width h=height t=depth(carcase) h1=height1 h2=height2 h3=height3 t1=depth1 t3=depth3 value range for CONSTRUCTION_ID: N

Ein Bild, das Strichzeichnung enthält. Automatisch generierte Beschreibung

b=600mm, h=715mm, t=365mm, h1=0mm, h2=515mm, h3=200mm, t1=365mm , t3=150mm CONSTRUCTION_ID=N

Comments:

h must equal h1+h2+h3.

Basic shape 51

Ein Bild, das Text, Elektronik, Bildschirm, Anzeige enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 value range for CONSTRUCTION_ID: L,R

Example:

b=600mm, h=50mm, t=1200mm, b1=200mm, b2=400mm, b3=500mm CONSTRUCTION_ID=N

Comments:

is used if a filler is installed to close the gap to the wall.

A door (parameter 1) to the wall can be used instead of a filler.

Basic shape 52

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 value range for CONSTRUCTION_ID: L,R

Comments:

is used if a filler is not installed to close the gap to the wall.

Carcase material or, if suitable, a visible side (parameter 1) to the wall can be used instead of a filler.


 Basic shapes for worktops and tables

IDM 2.8.1 XML-Schema Documentation

Introduction >Basic Shapes > Basic shapes for worktops and tables

Basic shape 31

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 value range for CONSTRUCTION_ID: N,L,R,J

b=1200mm, h=40mm, t=1200mm, b1=250mm, b2=250mm, b3=250mm, b4=250mm, t1=250mm, t2=250mm, t3=250mm, t4=250mm, CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N only if

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Basic shape 32

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth(carcase) b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 value range for CONSTRUCTION_ID: N,L,R,J

b=1200mm, h=40mm, t=1200mm, b1=250mm, b2=250mm, b3=250mm, b4=250mm, t1=250mm, t2=250mm, t3=250mm, t4=250mm, CONSTRUCTION_ID=R

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 33

Parameters: b=width h=height t=depth(carcase) b1=width1
b2=width2 b3=width3 b4=width4 b5=width 5
t1=depth1 t2=depth2 t3=depth3 t4=depth4 t5=depth5 value range for
CONSTRUCTION_ID: N,L,R,J

b=900mm, h=40mm, t=1500mm, b1=100mm, b2=100mm, b3=100mm,
b4=100mm, b5=400mm, t1=100mm, t2=100mm, t3=100mm, t4=100mm, t5=500mm
CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N only if

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Basic shape 34

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 a=angleα value range for CONSTRUCTION_ID: L,R,J

b=900mm, h=50mm, t=1500mm, b1=600mm, b2=100mm, b3=100mm, b4=600mm, t1=700mm, t2=100mm, t3=100mm, t4=400mm, a=135° CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 35

Parameters: b=width h=height t=depth a=angleα value range for CONSTRUCTION_ID: N

b=1200mm, h=40mm, t=600mm, a=90° CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 36

Parameters: b=width h=height t=depth value range for CONSTRUCTION_ID: N

b=800mm, h=40mm, t=800mm, CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 37

Parameters: b=width h=height b1=width1 t1=depth1 d=diameter value range for CONSTRUCTION_ID: L,R,J

Ein Bild, das Pfeil enthält. Automatisch generierte Beschreibung

b=800mm, h=40mm, t=800mm, b1=550mm, t1=190mm, CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 38

Parameters: b=width h=height t=depth b1=width1 value range for CONSTRUCTION_ID: L,R,J

b=600mm, h=40mm, t=1200mm, b1=400mm, CONSTRUCTION_ID=R

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 39

Ein Bild, das Text, dunkel, Outdoorobjekt enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth b1=width1 t1=depth1 t2=depth2 r=radius a=angleα value range for CONSTUCTION_ID:L,R,J

Ein Bild, das Sport, Tisch enthält. Automatisch generierte Beschreibung

b=900mm, h=50mm, t=1500mm, b1=700mm, t1=400mm, t2=600mm, r=1500mm, a=135°, CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 40

Parameters: b=width h=height t=depth b1=width1 t1=depth1 r=radius value range for CONSTUCTION_ID:N,L,R,J

b=600mm, h=50mm, t=1200mm, b1=200mm, t1=30mm, r=200mm CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N also if

b1 = 0, t1 = 0, r=b/2

Basic shape 41

same as basic shape 31, but parameters w and d are reversed.

Ein Bild, das Text, Elektronik enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 value range for CONSTRUCTION_ID: N,L,R,J

b=1200mm, h=40mm, t=1200mm, b1=250mm, b2=250mm, b3=250mm, b4=250mm, t1=250mm, t2=250mm, t3=250mm, t4=250mm, CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N only if

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Basic shape 42

same as basic shape 32, but parameters w and d are reversed.

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 value range for CONSTRUCTION_ID: L,R,J

b=1500mm, h=40mm, t=900mm, b1=100mm, b2=100mm, b3=100mm, b4=500mm, t1=100mm, t2=100mm, t3=100mm, t4=600mm, CONSTRUCTION_ID=R

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 43
same as basic shape 33, but parameters w and d are reversed.

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 b4=width4 b5=width 5 t1=depth1 t2=depth2 t3=depth3 t4=depth4 t5=depth5 value range for CONSTRUCTION_ID: N,L,R,J

b=1500mm, h=40mm, t=900mm, b1=100mm, b2=100mm, b3=100mm,
b4=100mm, b5=400mm, t1=100mm, t2=100mm, t3=100mm, t4=100mm, t5=500mm
CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N only if

b1 = b2, b3 = b4, t1 = t2, t3 = t4

Basic shape 44
same as basic shape 34, but parameters w and d are reversed.

Parameters: b=width h=height t=depth b1=width1 b2=width2 b3=width3 b4=width4 t1=depth1 t2=depth2 t3=depth3 t4=depth4 a=angleα value range for CONSTRUCTION_ID: L,R,J

b=1500mm, h=50mm, t=900mm, b1=700mm, b2=100mm, b3=100mm, b4=400mm, t1=600mm, t2=100mm, t3=100mm, t4=600mm, a=135°, CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 45
same as basic shape 35, but parameters w and d are reversed.

Parameters: b=width h=height t=depth a=angleα value range for CONSTRUCTION_ID: N

b=600mm, h=40mm, t=1200mm, a=90° CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 46
same as basic shape 36, but parameters w and d are reversed.

Parameters: b=width h=height t=depth value range for CONSTRUCTION_ID: N

b=800mm, h=40mm, t=800mm, CONSTRUCTION_ID=N

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 47
same as basic shape 37, but parameters w and d are reversed.

Parameters: b=width h=height d=diameter b1=width1 t1=depth1 value range for CONSTRUCTION_ID: L,R,J

Ein Bild, das Pfeil enthält. Automatisch generierte Beschreibung

b=800mm, h=40mm, t=800mm, b1=190mm, t1=550mm, CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 48
same as basic shape 38, but parameters w and d are reversed.

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth t1=depth1 value range for CONSTRUCTION_ID: L,R,J

b=1200mm, h=40mm, t=600mm, t1=400mm, CONSTRUCTION_ID=R

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 49
same as basic shape 39, but parameters w and d are reversed.

Parameters: b=width h=height t=depth b1=width1 b2=width2 t1=depth1 r=radius a=angleα value range for CONSTUCTION_ID:L,R,J

Ein Bild, das Sport, Tisch enthält. Automatisch generierte Beschreibung

b=1500mm, h=50mm, t=900mm, b1=400mm, b2=600mm, t1=700mm, r=1500mm, a=135°, CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

Basic shape 50
same as basic shape 40, but parameters w and d are reversed.

Ein Bild, das Text, dunkel enthält. Automatisch generierte Beschreibung

Parameters: b=width h=height t=depth b1=width1 t1=depth1 r=radius value range for CONSTUCTION_ID:N,L,R,J

b=1200mm, h=50mm, t=600mm, b1=30mm, t1=200mm, r=200mm CONSTRUCTION_ID=L

Comments:

Is predominantly used for worktops and table attachments.

CONSTRUCTION_ID = N also if

b1 = 0, t1 = 0, r=t/2


 Basic front shapes

IDM 2.8.1 XML- Schema Documentation

Intoduction >Basic shapes > Basic front shapes

Given the wide range of front variations for kitchen fronts, a concept has been developed to assign company-specific front designs to generalized basic front shapes. The introduction of basic types reduces the company-specific front designs to the essential characteristics of the various types of kitchen fronts. The front types differ considerably, mainly with regard to the complexity of construction. In general, it is possible to represent the wide range of front variations with the restricted number of basic shapes introduced in this data concept. Special fronts that do not fit in with this concept are considered as special types. On the basis of this concept, ordering and grouping of front shapes is made much easier for the single user.

The typification is made on the basis of simplified representations of front contours. For further explanation, each front shape is identified by a keyword, characterizing the front shape. For practical use, additional explanations on every front are given.

Special parameters are used to register the front details which are specific to the individual manufacturers. The details of each front can be described precisely by assigning values to the different parameters. Dimensions are attributed on the basis of data in millimetres. As a rule, the dimensioning is related to the surface and edges of the type. Information on distances between structural elements is always given as the shortest distance between the corresponding elements (note that some details may not comply with this rule). If circular structures are used, the centre is the reference point. Exceptions to this rule are given in the explanations for the different front types.

With regard to the use of parameters, the basic shapes can be simplified. Sometimes complex representations may contain structural elements that are not significant for the grouping. Therefore, these elements are optional. Certain details can be hidden by assigning the value zero to the corresponding parameter. As an example, radii that meet along a straight line, can be linearized by assigning the value zero, i.e. the radius is transformed into a straight line. All of the parameters have to be filled in. Exceptions to this rule are explained in the Field conditions. Further details are given in the variable declaration. As the reduction of complex shapes to simplified types occurs frequently, these types are represented by independent basic shapes.

A description of all parameters used in the explanation of the basic shapes is listed below. Parameters that require values are marked with W (value parameter). Qualitative parameters are marked with D (decor parameter). Following general descriptions of basic shapes and possible decor parameters, contour lines and mouldings are given.

Other features

Dividing parameters:

The dividing parameters Nh and Nv indicate the number of lattice bars displayed. The width of the single lattice bars or the space between the lattice bars is determined by dividing the front width by the number of lattice bars.

The dividing parameters a1_1 and a2_1 indicate the width of the lattice bars or the distance between the bars. This is useful when the number of lattices or gaps is dependent on the width of the front and the width of the lattices or gaps is constant. The exact width is calculated from the width of the front minus any existing frames etc., divided by the values of the dividing parameters a1_1 und a2_1. This value is rounded up to an integer value. The result gives the number of lattices or gaps. The value which is calculated for the area with lattices (front minus frames, etc.) is divided by the rounded number of lattices. The result gives the number of lattices/ gaps.

The space between the lattices or decoration elements is always measured from centre to centre point. Exceptions to this rule are parameters W1 or H1 which are measured from the exterior edge of the front up to the start of the first decor element.

The parameters a1 and a2 usually indicate the distance to the first decor element (lattice, arch etc.). This parameter is used as a start value, which may differ from the lattice spacing. If this value is reset to –1, it differs from the general definition. In this case the value will be reset to the distance between two decor elements.

Parameter | Description
ai, ai_j | Distance between elements in i=1 horizontal / i=2 vertical direction; valid for all corresponding elements; observe symmetry | W
aKEi | Profile type of the accentuated edges at the corner of the front, i=1 horizontal / i=2 vertical / i=3 diagonal; valid for all corners of the element | D
aKi | Profile type of the accentuated i=1 horizontal / i=2 vertical edge; valid for the corresponding edges of the element | D
B | Inner surface distance, measured at the exterior edge of the front | W
Bk | Contour width, special shape | W
Ed | Corner moulding of the inner decor , e.g. chamfer “2 x 45°, radius “R5”; valid for all corners of the element | W
Hd | decor height | W
Hi | Inner surface distance, measured at the exterior edge of the front | W
Hsi | Edge moulding, Hs=0: straight, Hs0: curve | W
K | Circular decor , parameter values: "0" = does not exist, "1" = exists | W
Li | Length parameter of a contour | W
Nh | Number of horizontal repeats of a style element | W
Ni | Number of repeats of a “diagonal” style element | W
Nv | Number of vertical repeats of a style element | W
P, Pai, Pbi, … | Profile type of a surrounding edge; small letters are used to differentiate various profile types. Sometimes combinations with index numbers are used | D
Pi, Pia, Pib, … | Profile type of the i=1 horizontal / i=2 vertical edge; small letters are used to differentiate various profile types | D
Pspi | Profile type of the i=1 horizontal / i=2 vertical / i=3 diagonal bars | D
RE | Corner moulding of the decor , e.g. chamfer “2 x 45°, radius “R5”; note: usually rounded | W
Rki | Profile type of the i=1 horizontal / i=2 vertical edge; e.g. chamfer “2 x 45°, radius “R5”; note: usually rounded; parameter applies only to the exterior edge of the front for the corresponding orientation of the edge. | W
Rsi | Edge moulding, Rs=0: straight, Rs=R5: curve with radius 5 | W
Si | Width of the i=1 horizontal / i=2 vertical / i=3 diagonal bars | W
ti | Depth parameters: positive sign = lowered, negative sign = embossed. These parameters relate to the front surface. The numbering relates to the recessed surfaces. The different surfaces are counted starting from the outside inwards. In the examples of basic front types, different depth directions are used. Although they represent the most frequent directions, they are not meant as fixed rules. | W

Legend: W (Wert) = value parameter, D = decor parameter

Colour parameters

Detailed parameters for the description of front colours are listed in the following table. Individual colour representations, specific for one manufacturer, are also possible. Different colour parameters are used to assign colours to the different front areas. A variation type is assigned to a certain front area. This front area is represented by a colour parameter.

In colour parameters are assigned to the corresponding variation types. The colour parameter is defined in the field parameter. Settings for the variation type are made in the field value. Entire setting of all colour parameters is required.

Example: In basic front shape D9 the variation_type for front colour 2 (102) is assigned to front area FF1.

Only colour variations (identification = F , cf. table standard variation types) are permitted as colour parameters for the variation types. Several colour parameters of the same variation type can be assigned to a basic front shape.

Front areas without a clear colour definition may result from the setting of several décor parameters (e. g. basic front shape A4, decor parameters aKE1 and aKE3 are set unequal 0). In these cases, the colour parameter with the lowest index from the list of available logical colour parameters is used.

In the given examples colour parameter FF2 has been chosen, since only colour parameters FF2 and FF3 are available.

Colour parameters (summary of available colour parameters)

Parameter | Description
FF1, FF2, … | Assignment of colours to front surfaces
KF1, KF2, … | Assignment of colours to front edges
PF1, PF2, … | Assignment of colours to front areas, which are described by the decor parameters.
AF | Assignment of colours for separated front areas with special front details (e.g. display of wooden nails, see basic front shape D9)
SF, SF1, … | Assignment of colours to lattices
RF | Assignment of colours to frames

Decor Parameter and contour shape

Decor parameters are used to describe the accents and profiles of a kitchen front. The value settings for the decor parameters decide whether the contour gradient of a front is depicted or not.

Examples: aKE3 = 1PR2/7/5: the contour gradient is marked with aKE3 and exists, the profile is PR2. The width of PR2 is 7 mm, the depth is 5 mm.

aKE3 = 0: contour gradient, is marked with aKE3 and does not exist.

If settings for width or/ and depth are not available, the default value of 10/7 is applied. Therefore the value field in RT570 is expanded to 12 digits.

Profile Values
Symbol | Description | Value | Symbol | Description | Value
 | Not existent | 0 |  | Groove | Pr12
 | U-Groove | Pr1 |  | Scarf - Groove | Pr13
 | V-Groove | Pr2 |  | Scarf - Apex -Groove | Pr14
 | W-Groove | Pr3 |  | Scarf - Scarf | Pr15
 | Semicircular Groove | Pr4 |  | Extended V-Groove | Pr16
 | Radius | Pr5 |  | Complex I Groove | Pr17
 | Scarf | Pr6 |  | Complex II Groove | Pr18
 | 1 Step | Pr7 |  | Pyramid Groove | Pr19
 | 2 Steps | Pr8 |  | Y-Groove | Pr20
 | Slim line | Pr9 |  | Slim U | Pr21
 | Scarf - Step | Pr10 |  | Angle | Pr22
 | Step - Scarf | Pr11 |  | Double-bow - Scarf | Pr23

Overview of basic front shapes

Basic front shapes

Type A1 Basic front

Example:

Ein Bild, das Text, Metallwaren, Holz enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A1 represents the basic front type. It is the basis for all further front door variations of type A. This front type is characterized by clear contours and a flat surface without any accents. The variations of this type differ in corner and edge shaping. Parameters can be disabled by setting them to zero. This front type consists of only one surface without any accents.

Front Parameters:

- RE Corner shape

- RK1, RK2 Edge shape

Colour Parameters:

- FF1 Front colour

- KF1, KF2 Edge colour

- PF1, PF2 Profile colour

Type A2 Vertically framed front

Example:

Parameterized View :

Definition:

Type A2 represents a vertical framed front. The depth of the frame panels may vary from that of the inner panel. This probable depth difference is represented by parameter t1. The finish of the inner panel can be either a …

- different colour

- glass inlet

- mirror inlet

Parameter P is used to indicate a profile for the inner panel edges. The exterior edge s can be rounded or chamfered.

Field conditions:

Either parameter ‚distance inner panel’ B1 or B2 can be set.

Front Parameters:

- B1, B2 Distance inner panel

- P Decor parameter

- RE Corner shape

- RK1, RK2 Edge shape

- t1 Depth parameter

- B3 Width inner surface

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2 Profile colour

Type A3 Flat front (1 surface) with frame

Example:

Parameterized View :

Definition:

Type A3 represents a framed front with only one flat surface. The finish of the centre panel can be either a …

- different colour

- glass inlet

- mirror inlet

The edges can be rounded or chamfered.

Front Parameters:

- B1, H1, B2, H2 Distance of centre panel

- Ed, RE Corner shape

- RK1, RK2 Edge shape

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2 Profile colour

Type A4 Flat front (one surface) with frame effect

Example:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A4 represents a front with only one flat surface subdivided by accentuated lines (frame effect). This accent can also be set by a background colour. The exterior edge s can be rounded or chamfered.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- aKE1, aKE2, aKE3, aK1, aK2 Accent parameters

- RE, Ed Corner shape

- RK1, RK2 Edge shape

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4 Profile colour

Type A5 Framed front with decor

Example: Ein Bild, das Text, Fenster enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A5 is characteristic of a subdivided surface with decor. The different types of decor are defined by the accent / decor parameters. The centre panel can be a facette decor , which is created by horizontal and vertical planks. These planks are formed by accentuated lines, e.g. different colouring. The parameters Nh and Nv indicate the number of planks.The plank shaping is defined by the decor parameter. The profile type of the centre panel is defined by parameter P.

Field conditions:

Either divider parameter Nh and Nv or a1_1 and a2_1 can be set. For further information refer to chapter ‚Basic front shapes’.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- aK1, aK2, P Accent / Decor parameter

- RE, Ed Corner shape

- RK1, RK2 Edge shape

- Nh, Nv, a1_1, a2_1Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF Plank colour

- PF1, PF2, PF3 Profile colour

Notes:

Parameter RK2 is within B1.

Type A6 Framed front with mullions

Example:

Ein Bild, das drinnen, Fenster enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A6 is characteristic of a more complex subdivided surface. The inner area is subdivided by horizontal and/ or vertical mullions. Additionally, there is a specific form which divides one segment with mullions. The mullion width is defined by parameters S1, S2, S3. The corresponding shape is defined by parameters Psp1, Psp2, Psp3. Parameters a1 and a2 indicate the distance from the frame to the first mullion. Exception: If parameter a1 is set to 0, a gap follows the frame instead of a mullion. The profile type for the inner panel is defined by parameter P.

Field conditions:

Either divider parameters Nh and Nv or a1_1 and a2_1 can be set. For further information refer to chapter ‚Basic front shapes’.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P1, P2, Psp1, Psp2, Psp3 Decor parameter

- RE, Ed Corner shape

- RK1, RK2 Edge shape

- S1, S2, S3 Mullion width

- a1, a2, Nh, Nv, a1_1, a2_1 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF2, PF3 Profile colour

Notes:

The shown example is a special case of this type.

Type A7 Framed front with mullions (diagonal)

Example:

Ein Bild, das Text, Gebäude, Fenster enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A7 is characteristic of a framed front divided by two diagonal mullions. The witdth of the mullion is defined by parameter S3, and the shape by parameter Psp3. The framing of the inner decor is defined by parameter P. The surface is divided symmetrically.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P, Psp3 Decor parameter

- RE, Ed Corner shape

- RK1, RK2 Edge shape

- S3 Mullion width

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF2, PF3 Profile colour

Type A8 Lattice front (horizontal/ vertical)

Example:

Ein Bild, das Bilderrahmen enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A8 represents a framed front with lattice. The width of the single lattice bars is defined by parameters S1 and S2. The corresponding shape is defined by parameters Psp1 and Psp2. Parameters a1 and a2 are used to define the distance between front frame and first lattice bar (initial distance). The distance between the bars results from the number of bars. The profile type of the frame bars is defined by parameter P.

Field conditions:

For further information on the divider parameters a1_1 and a2_1 refer to chapter ‚Basic front shapes’.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P1, P2, Psp1, Psp2 Decor parameter

- RE Corner shape

- RK1, RK2 Edge shape

- S1, S2 Mullion width

- a1, a2, a1_1, a2_1 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF2, PF3 Profile colour

Type A9 Lattice front (diagonal)

Example:

Ein Bild, das Bilderrahmen enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A9 represents a framed front with a diagonally running lattice. The width of the single lattice bars is defined by parameter S3. The corresponding shape is defined by parameter Psp3. Parameters a1 and a2 are used to define the distance between front frame and first lattice bar (initial distance). An uneven surface distribution is permitted. The profile type of the inner frame is defined by parameter P.

Field conditions:

For further information on the divider parameters a1_1 and a2_1 refer to chapter ‚Basic front shapes’.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P, Psp3 Decor parameter

- RE, Ed Corner shape

- RK1, RK2 Edge shape

- S3 Mullion width

- a1, a2, a1_1, a2_1 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF2, PF3 Profile colour

Type A10 Framed front with mullion and accentuated

edges

Ein Bild, das aus Holz, Holz enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A10 represents a special type of framed front. The inner surface is divided by one mullion. The mullion width is defined by parameter S2 and the shape by parameter Psp2. Parameter a1_i is used to define the decor distances. The type of vertical moulding is defined by parameter P2. The profile type of the inner frame is defined by parameter P. The surface is divided symmetrically.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- aKE2, Hd, P,P2, Psp2 Accent / Decor parameter

- RE, Ed Corner shape

- RK1, RK2 Edge shapeS2 Mullion width

- a1_1, a1_2, a1_3 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF2, PF3, PF4, PF5 Profile colour

Type A11 Profiled framed front

Example:

Ein Bild, das Schrank, Möbel, aus Holz, Holz enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A11 represents a framed front with accentuated lines in the centre panel. The type of accent/ decor is defined by parameter aK2. The number of lines is defined by parameter Nh. The single lines adjoin each other directly. The profile type of the inner frame is defined by parameter P. The surface is divided symmetrically. Divider parameter Nh defines the number of decor mouldings. The total width is the result of the numbers multiplied by the given width of the decor parameter.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- AKE2, aK2, P Accent / Decor parameter

- RE, Ed Corner shape

- RK1, RK2 Edge shape

- S1, S2, S3 Mullion width

- a1_3, Nh Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

Type A12 Roll-up front

Parameterized View :

Definition:

Type A12 is characteristic of a front with accentuated horizontal lines. The distance of the horizontal lines is defined by parameter a2. The width of the vertical lines is defined by parameter B1. The shape of the accentuated lines is defined by accent parameters aK1 and aK2. The use of the divider parameter a2 is analogue to that of divider parameters a1_1 / a2_1, cf.

Front Parameters:

- B1, B2 Distance inner panel

- aK1, aK2 Accent parameter

- RE Corner shape

- RK1, RK2 Edge shape

- a2 Divider parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4 Profile colour

Type A13 Slide front

Parameterized View :

Definition:

Type A13 is characteristic of a front with accentuated vertical lines. The distance of the vertical lines is defined by parameter a1. The width of the horizontal lines is defined by parameter H1. The shape of the accentuated lines is defined by accent parameters aK1 and aK2. The use of the divider parameter a2 is analogue to that of divider parameters a1_1 / a2_1, cf.

Front Parameters:

- H1, H2 Distance inner panel

- AK1, aK2 Accent parameter

- RE Corner shape

- RK1, RK2 Edge shape

- a1 Divider parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4 Profile colour

Type A14 Front with embossed/ lowered inner panel

Example:

Ein Bild, das Text, Behälter enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A14 represents a framed front with different surface levels. The centre panel can be embossed or lowered compared to the main surface level. This depth difference is defined by parameter t1. The frame of the inner panel is described by parameter P. A rounding of the inner panel is defined by parameter Ed. The inner panel can also be made of glass or mirror. The sides of the inner surface areas can have accentuated lines, too (example 2). The parameters are defined for one side.

Field conditions:

Either divider parameters Nh or B3 can be set. If B3 is used, the number of accentuated lines results from the division of B3 by the width of the decor parameter. If Nh is used, the total width results from the number of decor parameters multiplied by the width of a single décor parameter. The width value of the decor parameter is set directly with the decor parameter.

Front Parameters:

- B1, H1, B2, H2, B3 Distance inner panel

- P, aK2 Accent / Decor parameter

- RE, Ed Corner shape

- RK1, RK2 Edge shape

- Nh Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3 Profile parameter

Type A15 Front with embossed/ lowered panel a. accentuated edges

Example:

Ein Bild, das Text, Kasten enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A15 represents a framed front with different surface levels. The centre panel can be embossed or lowered compared to the basic surface. This depth difference is defined by parameter t1. Parameter P defines the profile of the inner panel. By setting parameters aK1 and aK2, a profile frame can be highlighted with a colour accent. A rounding of the inner panel is defined by parameter Ed. The inner panel can be made of glass or mirror.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- aK1, aK2, aKE1, aKE2, aKE3, P Accent / Decor parameter

- RE, Ed Corner shape

- RK1, RK2 Edge shape

- t1 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4, PF5 Profile colour

Type A16 Multi- level framed front

Parameterized View :

Definition:

Type A16 represents a framed front with multiple subdivisions of the surface. The centre panel has an additional inner area. The single areas can have different levels compared to the basic surface. These depth differences are defined by parameters t1 and t2. Frames of the inner panels are indicated by profile parameters Pa and Pb. Roundings of the inner panels are defined by parameters Ed1 and Ed2. The inner panel can be made of glass or mirror.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb Decor parameter

- RE, Ed1, Ed2 Corner shape

- RK1, RK2 Edge shape

- a1 Divider parameter

- t1, t2 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4 Profile colour

Type A17 Stichfront m. akzentuierten Kanten

Example:

Ein Bild, das drinnen, aus Holz, Holz enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A17 represents a framed front with an arch at the upper inner edge. The arch is defined by parameter Hs1. The arch can change into a straight line. Its length is defined by parameter a1. Parameter P defines the profile of the inner panel. The depth difference of the inner panel compared to the basic surface is defined by parameter t1. Accent paramters aK1 and aK2 are used to define a frame of the panel.

Front Parameter:

- B1, H1, B2, H2 Distance inner panel

- P1, aK1, aK2, aKE2 Accent / Decor parameter

- RE, Ed Corner shape

- Hs1, RK1, RK2 Edge shape

- a1 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4, PF5 Profile colour

Type A18 Framed front with arch decor I

Ein Bild, das Text, Badezimmer, Spiegel, alt enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A18 represents a framed front with décor and an arch at the upper inner edge. The arch is defined by parameter Hs1. The arch can change into a straight line. Its length is defined by parameter a1_1. Parameter P defines the profile of the inner panel. The depth difference of the inner panel compared to the basic surface is defined by parameter t1. The decor of the inner panel is formed with bars. In general, these bars have the same width, which is indicated by parameter S2_1. A horizontal centre bar, defined by parameter S2_2, is optional (see example). The decor is fixed, e.g. on a mirror surface. The shape is indicated by corresponding parameters.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P, Hd Decor parameter

- RE, Ed Corner shape

- Hs1, Hs2, Hs3, Hd decor distance

- RK1, RK2 Edge shape

- S2_1, S2_2 Mullion width

- a1_1, a1_2, a2 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

Type A19 Framed Front with arch, decor II

Example:

Ein Bild, das Text, Spiegel, Bilderrahmen, Fenster enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A19 represents a framed front with décor and an arch at the upper inner edge. The arch is defined by parameter Hs1. The arch can change into a straight line. Its length is marked by parameter a1_1. Parameter P defines the profile of the inner panel. The depth difference of the inner panel compared to the basic surface is defined by parameter t1. The decor of the inner panel is formed with bars. In general, these bars have the same width, which is indicated by parameter S2. The decor is fixed, e.g. on a mirror surface. The shape is indicated by corresponding parameters. This front type is a special version of basic shape No. 18. The only difference between both types is the decor .

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P Decor parameter

- RE, Ed Corner shape

- Hs1, Hs2, Hd Decor distance

- RK1, RK2, Rs1 Edge shape

- S2 Mullion width

- a1_1, a1_2, a2, a2_1, a2_2 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF2, PF3 Profile colour

Type A20 Framed front with arch and mullions

Example:

Ein Bild, das Fenster enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A20 represents a framed front with an arch at the upper inner edge. The arch is defined by parameter Hs1. The arch can change into a straight line. Its length is marked by parameter a1_2. Parameter P defines the profile of the inner panel. The depth difference of the inner panel compared to the basic surface is defined by parameter t1. The inner panel is subdivided by mullions. The number, shape and width of mullions, as well as the distance between the single bars, have to be defined. The inner panel can be made of glass or mirror The edges of the outer frame can be accentuated, but only in vertical direction.

Field conditions:

Either divider parameters Nh and Nv or a1_1 and a2_1 can be set. For further information refer to chapter ‚Basic front shapes’.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- AKE2, P, Psp1, Psp2 Accent / Decor parameter

- RE, Ed Corner shape

- Hs1, RK1, RK2 Edge shape

- S1, S2 Mullion width

- a1, a1_1, a1_2, a2, a2_1, Nv, Nh Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF2, PF3 Profile colour

Type A21 Modified framed front with arch and mullions

Ein Bild, das Text, Fenster enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A21 represents a framed front with an arch at the upper inner edge: This arch is defined by parameter Hs1. The arch can change into a straight line. Its length is indicated by parameter a1_2. Parameter P defines the profile of the inner panel. The depth difference of the inner panel compared to the basic surface is defined by parameter t1.The inner panel is subdivided by mullions. The number, shape and width of mullions, as well as the distance between the single bars, have to be defined.The difference to basic shape No. A20 is the decor with vertical mullions. These mullions are limited in length by one horizontal mullion . The inner panel can be made of glass or mirror. The edges of the outer frame can be accentuated, but only in vertical direction.If there are more than two bars for one direction, the distance between the decor elements is calculated proportionally.

Field conditions:

Either divider parameters Nh and Nv or a1_1 and a2_1 can be set. For further information refer to chapter ‚Basic front shapes’.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P, Psp1, Psp2 Decor parameter

- RE, Ed Corner shape

- Hs1, RK1, RK2 Edge shape

- S1, S2 Mullion width

- a1, a1_1, a1_2, a2, a2_1, a2_2, Nv, Nh Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF2, PF3, PF4 Profile colour

Type A22 Framed front with arch and slats I

Parameterized View :

Definition:

Type A22 represents a framed front with an arch at the upper inner edge. As a kind of overlay decor, vertical slats are appended to the arch decor surface. Parameter P defines the profile of the inner panel. The structure of the slat decor is defined by corresponding parameters. The depth difference of the inner panel compared to the basic surface is defined by parameter t1.

Field conditions:

Either divider parameter Nv or a1_1 can be set. For further information refer to chapter ‚Basic front shapes’.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P, aK1, aK2, aKE1, aKE2 Accent / Decor parameter

- RE, Ed Corner shape

- Hs1, RK1, RK2 Edge shape

- a1_1, a2, Nv Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4, PF5 Profile colour

Type A23 Framed front with arch and slats II

Example: Ein Bild, das Text, Badezimmer enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A23 represents a framed front with an arch at the upper inner edge. Vertical slats are appended to this decor surface. The structure of the slat decor is limited to the inner panel. Parameter P defines the profile of the inner panel. The depth difference of the inner panel compared to the basic surface is defined by parameter t1.

Field conditions:

Either divider parameter Nh or a1_1 can be set. For further information refer to chapter ‚Basic front shapes’.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P, aK2 Accent / Decor parameter

- RE, Ed Corner shape

- Hs1, RK1, RK2 Edge shape

- a1_1, Nh Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

Type A24 Framed front with arches

Example: Ein Bild, das drinnen enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A24 represents framed front with arches at the upper and lower inner edge. The two shapes are independent from each other, i.e. upper and lower arch may differ in shape. Parameters Pa and Pb define the profile of the panel frames. The depth difference of the inner panel compared to the basic surface is defined by parameters t1 and t2. Parameters B1 and H1 determine the orientation of the inner decor surface.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, aKE1, aKE2, aKE3 Accent / Decor parameter

- RE, Ed1, Ed2 Corner shape

- Hs1, Hs2, RK1, RK2 Edge shape

- a1_1, a1_2, a1_3, a2 Divider parameter

- t1, t2 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4 Profile colour

Notes:

Decor parameters in the upper left corner stand for the accent/ decor of all corners.

Type A25 Framed front with arches (lateral)

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A25 represents a framed front with arches at the left and right inner edge. The two shapes are independent from each other, i.e. left and right arch may differ in shape. Parameters Pa and Pb define the profile of the panel frames. The depth difference of the inner panel compared to the basic surface is defined by parameters t1 and t2. Parameters B1 and H1 determine the orientation of the inner decor surface. This decor type is mainly used for fixed and drawer blinds.

Example explanation:

The illustrated examples show two possible design types. For both types the parameters aKEi, B1, Ed1, H1, Pa, RE, RK1, RK2, t1, t2 are set to zero (not existing details). Specific parameters are disabled to define the décor.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, aKE1, aKE2, aKE3 Accent / Decor parameter

- RE, Ed1, Ed2 Corner shape

- Hs1, Hs2, RK1, RK2 Edge shape

- a1, a2_1, a2_2, a2_3 Divider parameter

- t1, t2 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4 Profile colour

Notes:

Decor parameters in the upper left corner stand for the accent/ decor of all corners.

Type A26 Vertical wavy framed front

Example:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type A26 represents a vertical framed front. The inner contours of the vertical frames have a wavy shape. The depth difference between the decor surfaces is defined by parameter t1. Parameter P defines the profile of the frame.

Front Parameters:

- B1, B2 Distance inner panel

- P Decor parameter

- RE Corner shape

- Hs1, RK1, RK2 Edge shape

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3 Profile colour

Type A27 Horizontally framed front

Example:

Parameterized View :

Definition:

Type A27 represents a front with horizonal frame posts. The surface of the frame posts may differ to the basic surface. This difference is indicated by parameter t1. The inner surface can be made of mirror or glass. The edges of the inner surface may have a profile p. The exterior edge s may be rounded or chamfered.

Front Parameters:

- H1, H2 Distance inner panel

- P Decor parameter

- RE Corner shape

- RK1, RK2 Edge shape

- t1 Depth parameter

- B3 Width inner surface

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, Profile colour

Type A28 Cassette front with slats

Example:

Parameterized View :

Definition:

Type A28 is characterized by a divided surface which has a decor. The type of décor is indicated by the accent parameters. The inner surface may be a facette decor made up by horizontal and vertical mullions. The mullions are defined as accentuated lines, e.g. accentuated by different colours. Decor parameters aK2 and aK1 define the appearance of the mullions. The profile of the inner frame is defined by parameter p.

Field conditions:

The dividing parameters Nv, Nh, a1_1 and a2_1 are defined as a coherent set . Nv and Nh define the number of divisions (mullions), parameters a1_1 and a2_1 represent the fixed measurement of the outer mullions. The size of the inner mullions is calculated from the number of remaining mullions (Nv-2 resp. Nh-2). For further information refer to chapter ‚Basic front shapes’.

Front Parameters:

- B1, H1, B2, H2 Distance inner surface

- aK1, aK2, P Decor parameter

- RE, Ed Corner shape

- RK1, RK2 Edge shape

- Nh, Nv, a1_1, a2_1 Dividing parameters

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF1 Mullion colour

- PF1, PF2, PF3 Profile colour

Notes:Parameter RK2 is within B1.

Type B1 Basic front

Example: Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type B1 represents a front with flat surface and profiles at top and bottom edge. The horizontal profile is defined by parameters P1a and P1b. By using two independent parameters, top and bottom profile may differ in shape. In special cases, only one side is profiled. The decor parameter for the second profile is then set to 0. The lateral edges of the basic surface can be rounded or chamfered.

Front Parameters:

- P1a, P1b Decor parameter

- RK2 Edge shape

Colour Parameters:

- FF1 Front colour

- KF1, KF2 Edge colour

- PF2, PF3, PF5 Profile colour

Type B2 Vertically framed front

Example:

Ein Bild, das Text, Elektronik, Anzeige enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type B2 represents a vertically framed front with an inner decor panel. The inner panel intersects the horizontally profiled edges. The horizontal profile is defined by parameters P1a and P1b. By using two independent parameters, top and bottom profile may differ in shape. In special cases, only one side is profiled. The decor parameter for the second profile is then set to 0. The lateral edges of the base surface can be rounded or chamfered. The inner panel can be made of glass or mirror. Parameter P defines the profile of the edges of the inner panel.

Field conditions:

Bei den Parametern Abstand Innenfläche darf entweder der Parameter B1 oder der Parameter B2 angelegt sein.

Front Parameters:

- B1, B2 Distance inner panel

- P, P1a, P1b Decor parameter

- RK2 Edge shape

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF2, PF3, PF5 Profile colour

Type B3 Framed front

Example:

Ein Bild, das Bilderrahmen, Wandspiegel, alt, Zeichnung enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type B3 represents a framed front with an inner decor panel integrated into the basic surface. The horizontal profile is defined by parameters P1a and P1b. By using two independent parameters, top and bottom profile may differ in shape. In special cases, only one side is profiled. The decor parameter for the second profile is then set to 0. The lateral edges of the basic surface can be rounded or chamfered. The inner panel can be made of glass or mirror. Parameter P defines the profile of the edges of the inner panel. The corner shape of the inner panel is defined by parameter Ed.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P, P1a, P1b Decor parameter

- Ed Corner shape

- RK2 Edge shape

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- RF Frame colour

- PF2, PF3, PF4, PF5 Profile colour

Type B4 Framed front with multiple panels

Parameterized View :

Definition:

Type B4 represents a framed front with a décor of multiple panels integrated into the inner surface. The horizontal profile is defined by parameters P1a and P1b. By using two independent parameters, top and bottom profile may differ in shape. In special cases, only one side is profiled. The decor parameter for the second profile is then set to 0. The lateral edges of the basic surface can be rounded or chamfered. The inner panel can be made of glass or mirror. Parameters Pa and Pb define the frame of the inner panel. The corner shape of the inner panel is defined by parameters Ed1 and Ed2.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, P1a, P1b Decor parameter

- Ed1, Ed2 Corner shape

- RK2 Edge shape

- a1 Divider parameter

- t1, t2 Depth parameter

Farb-Parameter:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- RF Frame colour

- PF1, PF2, PF3, PF4, PF5, PF6 Profile colour

Type C1 Basic front

Example:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type C1 represents a laterally profiled front. The vertical profile is defined by parameters P2a and P2b. By using two independent parameters, left and right profile may differ in shape. In special cases, only one side is profiled. The decor parameter for the second profile is then set to 0. The top and bottom edges of the basic surface can be rounded or chamfered.

Front Parameters:

- P2a, P2b Decor parameter

- RK1 Edge shape

- RE Corner shape

Colour Parameters:

- FF1 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF4 Profile colour

Type C2 Vertically framed front

Parameterized View :

Definition:

Type C2 represents a vertically framed front with a decor panel integrated into the basic surface. The vertical profile is defined by parameters P2a and P2b. By using two independent parameters, left and right profile may differ in shape. In special cases, only one side is profiled. The decor parameter for the second profile is then set to 0. The top and bottom edges of the basic surface can be rounded or chamfered. The inner panel can be made of mirror or glass. Parameter P defines the edge profile of the inner panel.

Field conditions:

Either parameter ‚distance inner panel’ B1 or B2 can be set.

Front Parameters:

- B1, B2 Distance inner panel

- P, P2a, P2b Decor parameter

- RE Corner shape

- RK1 Edge shape

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4 Profile colour

Type C3 Vertically framed front with panels

Example:

Ein Bild, das drinnen, Wand, Bilderrahmen, Zeichnung enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type C3 represents a vertically framed front with an inner panel integrated into the basic surface. The vertical profile is defined by parameters P2a and P2b. By using two independent parameters, left and right profile may differ in shape. In special cases, only one side is profiled. The decor parameter for the second profile is then set to 0. The top and bottom edges of the basic surface can be rounded or chamfered. The inner panel can be made of mirror or glass. Parameter P defines the edge profile of the inner panel. The position of the inner panel is defined by parameters B1 and H1.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- P, P2a, P2b Decor parameter

- RE, Ed Corner shape

- RK1 Edge shape

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4 Profile colour

Type C4 Framed front, multiple levelled

Parameterized View :

Definition:

Type C4 represents a vertically profiled front with a decor of multiple embossed/ lowered panels integrated into the basic surface. The vertical profile is defined by parameters P2a and P2b. By using two independent parameters, left and right profile may differ in shape. In special cases, only one side is profiled. The decor parameter for the second profile is then set to 0. The top and bottom edges of the basic surface can be rounded or chamfered. The inner panel can be made of mirror or glass. Parameters Pa and Pb define the edge profile of the inner panel. The depth differences are indicated by parameters t1 and t2.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, P2a, P2b Decor parameter

- RE, Ed1, Ed2 Corner shape

- RK1 Edge shape

- a1 Divider parameter

- t1, t2 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- RF Frame colour

- PF1, PF2, PF3, PF4, PF5 Profile colour

Type D1 Basic Front

Parameterized View :

Definition:

Type D1 represents a front with profiled edges on all sides. Decor parameter P defines the profile. The mitres of horizontal and vertical profiles have an angle of 45°.

Front Parameters:

- P Decor parameter

- RE Corner shape

Colour Parameters:

- FF1 Front colour

- KF1, KF2 Edge colour

- PF1 Profile colour

Type D2 Vertically framed front

Parameterized View :

Definition:

Type D2 represents a vertically framed front with profiled edges on all sides and a décor panel integrated into the inner surface. Parameter Pa defines the profile. The mitres of horizontal and vertical profiles have an angle of 45°. A depth difference of the integrated inner panel compared to the basic surface is defined by parameter t1. The position of the inner panel is determined by parameter B1. The frame of the inner panel is defined by décor parameter Pb. The inner panel can be made of glass or mirror. The inner panel intersects the frame profile.

Field conditions:

Either parameter ‚distance inner panel’ B1 or B2 can be set.

Front Parameters:

- B1, B2 Distance inner panel

- Pa, Pb Decor parameter

- RE Corner shape

- t1 Depth parameter

Colour Parameters:

- FF1 Front colour

- KF1, KF2 Edge colour

- PF1, PF3 Profile colour

Type D3 Multiple panel front

Example:

Ein Bild, das Schrank enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D3 represents a front with profiled edges on all sides and a decor of multiple panels in the centre. Decor parameter Pa defines the profile type. The mitres of horizontal and vertical profiles have an angle of 45°. A depth difference of the integrated inner panel compared to the basic surface is defined by parameter t1. The position of the inner panel is determined by parameter B1 and H1. Decor parameter Pb defines the frame of the inner panel. The inner panel can be made of glass, mirror or any other material.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb decor parameter

- RE, Ed Corner shape

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF3 Profile colour

Type D4 Framed front, decor I

Example:

Ein Bild, das Wand, drinnen, Gebäude, Badezimmer enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D4 is represents a front with profiled edges on all sides. The inner decor panel is divided by mullions. Decor parameter Pa defines the profile type. The mitres of horizontal and vertical profiles have an angle of 45°. A depth difference of the integrated inner panel compared to the basic surface is defined by parameter t1. The position of the inner panel is determined by parameter B1 and H1. Decor parameter Pb defines the frame of the inner panel. The inner panel can be made of glass, mirror or any other material. The inner panel is divided by mullions. The corners can be accentuated especially.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, aKE2, aK1, aK2 Accent / Decor parameter

- RE, Ed Corner shape

- S1, S2 Mullion width

- a1, a2_1, a2_2 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF3 Profile colour

Type D5 Framed front, decor II

Ein Bild, das Platz enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D5 is represents a front with profiled edges on all sides. The inner panel has a décor of mullions in rhombus shape. Decor parameter Pa defines the profile type. The mitres of horizontal and vertical profiles have an angle of 45°. A depth difference of the integrated inner panelcompared to the basic surface is defined by parameter t1. The position of the inner panel is determined by parameter B1 and H1. Decor parameter Pb defines the frame of the inner panel. The inner panel can be made of glass, mirror or any other material. The inner panel is divided by mullions. The width of the mullion bars is defined by parameter S2. The length of the rhombus edges is defined by parameters a1 and a2.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb Decor parameter

- RE, Ed Corner shape

- S2 Mullion width

- a1, a2 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- SF1, SF2 Mullion colour

- PF1, PF3 Profile colour

Type D6 Framed front, multiple panels

Example:

Ein Bild, das Tür, offen enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D6 represents a front with profiled edges on all sides, an inner frame, and multiple panels in the centre. Decor parameters Pa, Pb and Pc define the profiles of the different surface elements. Depth differences are set by parameters t1 and t2.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, Pc Decor parameter

- RE, Ed1, Ed2 Corner shape

- a1 Divider parameter

- t1, t2 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- RF Frame colour

- PF1, PF3, PF4 Profile colour

Type D7 Framed front with mullions

Example: Ein Bild, das Shoji, Gebäude, Fenster enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D7 represents a framed front with profiled edges on all sides and an inner panel subdivided by mullions. Parameters a1 and a2 define the horizontal and vertical distance from first mullion to the inner frame. The mullions are arranged symmetrically. The quantity, shape and width of the bars are defined by corresponding parameters. The inner panel can be framed with a profile defined by decor parameter Pb. Decor parameter Pa defines the exterior edge profile on all sides of the front. Parameters Ed and RE define the shape of the corners, e.g. rounded. The inner panel can be made of glass, mirror or any other material.

Field conditions:

Either divider parameters Nh and Nv or a1_1 and a2_1 can be set. For further information refer to chapter ‚Basic front shapes’.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, Psp1, Psp2 Decor parameter

- RE, Ed Corner shape

- S1, S2 Mullion width

- a1, a2, a1_1, a2_1, Nv, Nh Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF3 Profile colour

Type D8 Framed decor front with mullions

Example: Ein Bild, das Fenster, Bilderrahmen enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D8 represents a framed front with profiled edges on all sides and a decor of mullions in rhombus shape. The distance of the horizontal mullion to the inner side of the frame is set by parameter a2. The position of the rhombus edges depends on this value. The front decor is symmetrically arranged to the horizontal middle axis. The quantity is fixed. Shape and width of the bars are defined by parameters Psp1 and S1. Parameter Pb is used to define a profile frame for the inner panel. Decor parameter Pa defines the exterior edge profile on all sides of the front. Parameters Ed and RE define the shape of the corners, e.g. rounded. The inner panel can be made of glass, mirror or any other material.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, Psp1 Decor parameter

- RE, Ed Corner shape

- S1 Mullion width

- a2 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2, FF3, FF4 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF3 Profile colour

Type D9 Framed front with point decor

Example:

Ein Bild, das Text, Bilderrahmen enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D9 represents a framed with profiled edges on all sides. The inner surface is an arch with point decor. This point decor is defined by decor parameter K. The position of these elements is set by special parameters. Parameter Hs1 defines the shape of the arch at the top inner edge of the front. This arch can change into a straight line. The length is determined by parameter a1_1. The inner panel can be framed with a profile, which is defined by decor parameter Pb. Decor parameter Pa defines the exterior edge profile on all sides of the front. Parameters Ed and RE define the shape of the corners, e.g. rounded. The inner panel can be made of glass, mirror or any other material. Depth differences are defined by parameter t1.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, K Decor parameter

- RE, Ed Corner shape

- Hs1 Edge shape

- a1_1, a1_2, a1_3, a2_1, a2_2 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- AF Accent colour

- PF1, PF3 Profile colour

Type D10 Framed front with arch and mullions

Parameterized View :

Definition:

Type D10 represents a framed front with profiled edges on all sides. The inner decor panel is shaped as an arch and subdivided by mullions. The shape, quantity and width of the mullions are defined by special parameters. The partition of the surface is not necessarily symmetrical. Parameter Hs1 defines the shape of the arch at the top inner edge of the front. This arch can change into a straight line. The length is determined by parameter a1_1. The inner panel can be framed with a profile, which is defined by decor parameter Pb. Decor parameter Pa defines the exterior edge profile on all sides of the front. Parameters Ed and RE define the shape of the corners, e.g. rounded. The inner panel can be made of glass, mirror or any other material. The depth difference is defined by parameter t1.

Field conditions:

Settings for at least two of the parameters a1_2, a1_3 and a1_4 are required. The same rule applies to parameters a2_1, a2_2 and a2_3.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, Psp1, Psp2 } Decor parameter

- RE, Ed Corner shape

- Hs1 } Edge shape

- S1, S2 Mullion width

- a1_1, a1_2, a1_3, a1_4, a2_1, a2_2, a2_3 Divider parameter t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- SF Mullion colour

- PF1, PF3 Profile colour

-

Type D11 Multiple framed front with arch

Ein Bild, das Platz enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

pe D11 represents a multiple framed front with arch decor. The single decor elements partly merge into one another. Therefore, their position is defined by the transition into the adjacent profile. The inner panels have an arch decor. The contours of the arches depend on one another. The transition of the arches can change into a straight line. The length is defined by parameter a1. The inner panel can be framed with a profile defined by a corresponding parameter. Decor parameter Pa defines the exterior edge profile on all sides of the front. Parameters Ed and RE define the shape of the corners, e.g. rounded. The inner panel can be made of glass, mirror or any other material, with a mullion decor. The depth difference is defined by parameter t1. The width of the single mullion bars is defined by parameter S2. The shape of the inner decor panel is determined by the surrounding shape.

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- Pa, Pb, Pc, Pd Decor parameter

- RE, Ed1, Ed2, Ed3 Corner shape

- Hs1 Edge shape

- S2 Mullion width

- a1_1, a1_2, a2_1, a2_2, a2_3 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2,

- FF3, FF4 } Front colour

- KF1, KF2 Edge colour

- RF Frame colour

- PF1, PF3, PF4, PF5 Profile colour

Type D12 Front with mullions (without transition)

Example: Ein Bild, das Text, Fenster, Gebäude, drinnen enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D12 represents a framed front with profiled edges on all sides with a special type of mullion decor. The transition of the mullions into one another and into the exterior frame is “smooth”. The shape, quantity and width of the mullions are defined by special parameters. Parameter t1 indicates the position of the resulting front cells. The transition of the mullions is defined by radii, which are defined by parameter Ed. The corners of the basic surface can be accentuated..

Front Parameters:

- B1, H1, B2, H2 Distance inner panel

- AKE1, aKE2, aKE3, Pa, Pb, Psp1, Psp2 Accent / Decor parameter

- RE, Ed Corner shape

- S1, S2 Mullion width

- a2 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF3, PF4 Profile colour

Type D13 Vertical framed profiled front

Example: Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D13 represents a special front decor with carvings, which are defined by corresponding contour parameters. The shape of the carvings is defined by décor parameter Pb. The front decor is built up symmetrically.

Field conditions:

Settings for at least two of the parameters L1, L2 and L3 are required.

Front Parameters:

- B2, B3 Distance inner panel

- Pa, Pb Decor parameter

- Ed Corner shape

- Bk, L1, L2, L3 Contour parameter

- Nh Divider parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1 Profile colour

Type D14 Vertical framed profile front

Example: Ein Bild, das Text, Bilderrahmen enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D14 represents a vertical framed front with profiled edges, carvings and an inner décor panel. The carvings are defined by corresponding contour parameters. The shape of the carvings is defined by décor parameter Pb. The front decor is built up symmetrically. The inner decor panel can be made of glass, mirror or any other material.

Field conditions:

Settings for at least two of the parameters L1, L2 or L3 are required.

Front Parameters:

- B1, B2, B3, B4 Distance inner panel

- Pa, Pb Decor parameter

- Ed Corner shape

- Bk, L1, L2, L3 Contour parameter

- Nh Divider parameter

- t1, t2 Depth parameter

Colour Parameters:

- FF1, FF2, FF3 Front colour

- KF1, KF2 Edge colour

- PF1 Profile colour

-

Type D15 Mullion front (without transition)

Example: Ein Bild, das Text, Fenster, Stein enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type D15 represents a mullion front This front type is characterized by “seamless“ transitions of the mullions into the frame. Shape, number and width of the mullions are specified by the different parameters. The position of the resulting cells is defined by parameter t1. The transitions of the mullions are furnished with radii, determined by parameter Ed. The corners of the basic surface can be accentuated.

Front Parameters:

- B1,H1, B2, H2 Distance inner panel

- aKE1,aKE2,aKE3,Pa, Pb, Psp1,Psp2 Decor parameter

- RE, Ed Corner shape

- S1, S2 Contour parameter

- a2 Divider parameter

- t1 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3 Profile colour

Type E1 Basic front with “strip” frame

Example: Ein Bild, das Text, Wand, drinnen, blau enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type E1 represents a special front type with profiled edges. Inlaid “strips” make the frame stand out. These “strips” are defined by parameters for width and length. Accent/ decor parameters define the types of transition between horizontal and vertical profile edges in the corners of the frame. The resulting angle may be 45° or less. Different settings for the length parameters determine which side of the frame is predominant in the corners. If specific profiles are assigned to one edge, this edge may appear as “invisible”. No accent/ decor is used for the inner panel.

Front Parameters:

- P1a, P1b, P2a, P2b, aKE1, aKE2, aKE3 Accent / Decor parameter

- Bk1, Bk2, L1, L2 Contour parameter

- tk1, tk2 Depth parameter

Colour Parameters:

- FF1 Front colour

- KF1, KF2 Edge colour

- PF1, PF2 Profile colour

Notes:

Decor parameters in the upper left corner represent the different types of transition between the profiles.

Type E2 Basic front with „strip“ frame

Example:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type E2 represents a special type of „strip“ frame front. The edge profile of the frame is realized with inlays of ledges in order to emphasize the frame character. The measurements of these ledges are defined by width and height parameters. Accent/ decor parameters define the types of transition of the profile edges in the corners of the frame. The resulting angle may be 45° or less. Different settings for the length parameters determine which side of the frame is predominant in the corners. If specific profiles are assigned to one edge, this edge may appear as “invisible”. The frame of the inner surface is determined by parameter P. A depth difference of the surfaces is defined by parameter t1.

Field conditions:

The distance of ledges to the inner surface is determined by setting of either parameter B1 or B2.

Front Parameters:

- B1, B2 Distance inner surface

- P1a, P1b, P2a, P2b, aKE1, aKE2, aKE3 Accent / Decor parameter

- Bk1, Bk2, L1, L2 Contour parameter

- t1, tk1, tk2 Depth parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3 Profile colour

Notes:

Decor parameters in the upper left corner represent the different types of transition between the profiles.

Type E3 Cassette front

Example: Ein Bild, das Monitor, Bilderrahmen, Bildschirm, befestigt enthält. Automatisch generierte Beschreibung

Parameterized View :

Definition:

Type E2 represents a special type of „strip“ frame front. The edge profile of the frame is realized with inlays of ledges in order to emphasize the frame character. The measurements of these ledges are defined by width and height parameters. Accent/ decor parameters define the types of transition of the profile edges in the corners of the frame. The resulting angle may be 45° or less. Different settings for the length parameters determine which side of the frame is predominant in the corners. If specific profiles are assigned to one edge, this edge may appear as “invisible”.

Front Parameters:

- B1, H1, B2, H2 Distance inner surface

- Pa, Pb, P1a, P1b, P2a, P2b, aKE1, aKE2, aKE3 Accent / Decor parameter

- Bk1, Bk2, L1, L2 Contour parameter

- t1, t2, tk1, tk2 Depth parameter

- a1 Divider parameter

Colour Parameters:

- FF1, FF2 Front colour

- KF1, KF2 Edge colour

- PF1, PF2, PF3, PF4 Profile colour

- RF Frame colour

Notes:

Decor parameters in the upper left corner represent the different types of transition between the profiles.


 Handles basic shapes

IDM 2.8.1 XML-Schema Documentation

Intoduction >Basic shapes > Handles basic shapes

Simplified basic shapes of handles are depicted in the following list.

For purposes of abstract description of the different handle shapes, the following parameters are used:

· b = maximum width of handle;

· h = maximum height of handle, measured from front door surface;

· t = medium thickness of handle;

· B = distance between the drilling holes.

No. | Description | Illustration
1 | Ball knob |  | B not set
2 | Knob, normal |  | B not set
3 | Knob, normal with plate | Ein Bild, das Text, Antenne enthält. Automatisch generierte Beschreibung
4 | Cylindric knob |  | B not set
10 | Bow-type door handle, square |
11 | Bow-type door handle, straight long |
12 | Bow-type door handle, arch |
13 | Bow-type door handle, arch long |
14 | Bow-type door handle, rounded |
15 | Bow-type door handle, unilateral | Ein Bild, das Text, Bogenschießen enthält. Automatisch generierte Beschreibung
16 | Bow-type door handle, straight with plate |
17 | Bow-type door handle, rounded with plate | Ein Bild, das Text, Uhr enthält. Automatisch generierte Beschreibung
18 | Bow-type door handle, unilateral with plate | Ein Bild, das Text, Uhr enthält. Automatisch generierte Beschreibung
19 | Bow-type door handle, trapezoid | Ein Bild, das Text enthält. Automatisch generierte Beschreibung
20 | Bow-type door handle, round | Ein Bild, das Text, Bogenschießen enthält. Automatisch generierte Beschreibung
30 | Moulded handle Note: The shown view represents the front view. For this reason the parameter “h” is replaced by "t". The parameter "h" is defined as described above. |
40 | Bar handle |  | B, b not set
50 | Fixed handle rail | Ein Bild, das Text enthält. Automatisch generierte Beschreibung | B, b not set


 Basic profile shapes

IDM 2.8.1 XML-Schema Documentation

Intoduction > Basic shapes > Basic profile shapes

In this chapter the basic shapes for worktops, cornices, light pelmets and plinth panels are listed. In this way, graphic information on the profiles of one specific manufacturer can be transferred to the processing software. In case an individual profile cannot be asigned to a defined basic shape, the basic shape with the highest degree of corresponding parameters is chosen as reference.

Parameters of basic profile shapes

With special respect to time and costs expenditures in the field of data definition for the processing software, a detailed parameterization of basic profile shapes is not adequate. The basic profile shapes are defined by the dimension parameters (width, height, depth). Within the given range of these dimension parameters the assignment of detail parameters (e.g. radius, returns…) is defined by the processing software.

The basic profile shapes are defined by parameters X1, and X2.

· X1 Front projection of profile

· X2 Lateral projection of profile

Definition of parameter X1

In the given example of a cornice the parameter X1 is depicted. Parameter X1 defines the front projection of the profile. The exterior edge s of the adjacent elements (e.g. carcase and cornice) are delimiting factors for the projection. For further information please refer to the explanation of parameter X1.

Definition of parameter X2

In the given example of a light pelmet the parameter X2 is depicted. Parameter X2 defines the lateral projection of the profile. The exterior edge s of the adjacent elements (e.g. carcase and light pelmet) are delimiting factors for the projection. For further information please refer to the explanation of parameter X2.

If the nominal values for X1 and X2 are not equal to the maximum value (999999), this has to be processed by the software. In case a maximum value has been defined, front projection and lateral projection are calculated by the processing software.

Worktop parameters

· X1 Distance between the exterior edge of the carcase and front edge of the worktop. Reference point: carcase

· X2 Distance between the lateral edge of the carcase and the lateral edge of the worktop. Reference point: carcase. This definition is valid for left and right side.

Plinth panel parameters

· X1 Distance between the exterior edge of the carcase and front edge of the plinth panel. Reference point: carcase

· X2 Distance between the lateral edge of the carcase and the lateral edge of the plinth panel. Reference point: carcase. This definition is valid for left and right side.

The exterior edge of the plinth panel is set back behind the exterior edge of the carcase. Anyhow, the values for parameters X1 and X2 are given as positive figures.

Parameters for cornices and light pelmets

· X1 Distance between the exterior edge of the carcase and front edge of the cornice/ light pelmet. Reference point: carcase

· X2 Distance between the lateral edge of the carcase and the lateral edge of the cornice/ light pelmet. Reference point: carcase. This definition is valid for left and right side.

Worktop profiles

Basic profile shape – APL1

Side view:

Perspective Example:

Ein Bild, das Text, Visitenkarte enthält. Automatisch generierte Beschreibung

Basic profile shape – APL2

Side view:

Perspective Example:

Basic profile shape – APL3

Side view:

Perspective Example:

Basic profile shape – APL4

Side view:

Perspective Example:

Profiles for plinth panels

Basic profile shape – SL1

Side view:

Perspective Example:

Ein Bild, das Pfeil enthält. Automatisch generierte Beschreibung

Profiles for light pelmets

Basic profile shape – LB1

Side view:

Perspective Example:

Basic profile shape – LB2

Side view:

Perspective Example:

Basic profile shape – LB3

Side view:

Perspective Example:

Basic profile shape – LB4

Side view:

Perspective Example:

Basic profile shape – LB5

Side view:

Perspective Example:

Basic profile shape – LB6

Side view:

Perspective Example:

Basic profile shape – LB7

Side view:

Perspective Example:

Basic profile shape – LB8

Side view:

Perspective Example:

Basic profile shape – LB9

Side view:

Perspective Example:

Ein Bild, das Text, Kasten, Container, Visitenkarte enthält. Automatisch generierte Beschreibung

Basic profile shape – LB10

Side view:

Perspective Example:

Basic profile shape – LB11

Side view:

Perspective Example:

Basic profile shape – LB12

Side view:

Perspective Example:

Basic profile shape – LB13

Side view:

Perspective Example:

Ein Bild, das Text, Kasten, Container, Visitenkarte enthält. Automatisch generierte Beschreibung

Basic profile shape – LB14

Side view:

Perspective Example:

Ein Bild, das Text, Container, Kasten enthält. Automatisch generierte Beschreibung

Basic profile shape – LB15

Side view:

Perspective Example:

Ein Bild, das Text, Container enthält. Automatisch generierte Beschreibung

Basic profile shape – LB16

Side view:

Perspective Example:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Basic profile shape – LB17

Side view:

Perspective Example:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Basic profile shape – LB18

Side view:

Perspective Example:

Ein Bild, das Text, Kasten enthält. Automatisch generierte Beschreibung

Basic profile shape – LB19

Side view:

Perspective Example:

Basic profile shape – LB20

Side view:

Perspective Example:

Profiles for cornices

N In this chapter the basic profile shapes for cornices are listed. In this way, graphic information on the profiles of one specific manufacturer can be transferred to the processing software. In case an individual profile cannot be assigned to a defined basic shape, the basic shape with the highest degree of corresponding parameters is chosen as reference.

Basic profile shape – KP1

Side view:

Perspective Example:

Ein Bild, das Pfeil enthält. Automatisch generierte Beschreibung

Basic profile shape – KP2

Side view:

Perspective Example:

Ein Bild, das Pfeil enthält. Automatisch generierte Beschreibung

Basic profile shape – KP3

Side view:

Perspective Example:

Basic profile shape – KP4

Side view:

Perspective Example:

Ein Bild, das Text, Visitenkarte enthält. Automatisch generierte Beschreibung

Basic profile shape – KP5

Side view:

Perspective Example:

Basic profile shape – KP6

Side view:

Perspective Example:

Ein Bild, das Elektronik enthält. Automatisch generierte Beschreibung

Basic profile shape – KP7

Side view:

Perspective Example:

Basic profile shape – KP8

Side view:

Perspective Example:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Basic profile shape – KP9

Side view:

Perspective Example:

Basic profile shape – KP10

Side view:

Perspective Example:

Basic profile shape – KP11

Side view:

Perspective Example:

Basic profile shape – KP12

Side view:

Perspective Example:

Basic profile shape – KP13

Side view:

Perspective Example:

Basic profile shape – KP14

Side view:

Perspective Example:

Basic profile shape – KP15

Side view:

Perspective Example:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Basic profile shape – KP16

Side view:

Perspective Example:

Basic profile shape – KP17

Side view:

Perspective Example:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Basic profile shape – KP18

Side view:

Perspective Example:

Basic profile shape – KP19

Side view:

Perspective Example:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Basic profile shape – KP20

Side view:

Perspective Example:

Ein Bild, das Text, Visitenkarte enthält. Automatisch generierte Beschreibung


 Basic shape for sinks and mixer tabs

IDM 2.8.1 XML-Schema Documentation

Intoduction >Basic shapes > Basic shape for sinks and mixer tabs

For sinks and mixer tabs is some minimum measure information required. The needed measures are defined with the below listed basic shapes for sinks and mixer tabs.

Basic shape 992 Sink flush with surface

Definition:

Parameter:

· b = width (orthogonal with t)

· t = depth (max. extension of the sink incl. frame)

· e = Minimum installation height (distance between bottom edge of interior elements,e.g. drainer or excen-ter fittings, and bottom edge of worktop)

Basic shape 993 Built-under sink

Definition:

Parameter:

· b = width (orthogonal with t)

· t = depth (max. extension of the sink incl. frame)

· h = height (distance between top edge of the worktop and top edge of the sink) e = Minimum installation height (distance between bottom edge of interior elements,e.g. drainer or excenter fittings, and bottom edge of worktop)

Basic shape 994 Built-in sink

Definition:

Parameter:

· b = width (orthogonal with t)

· t = depth (max. extension of the sink incl. frame)

· h = height (distance between top edge of the worktop and top edge of the sink; handling elements are not taken into account.)

· e = Minimum installation height (distance between bot-tom edge of interior elements,e.g. drainer or excen-ter fittings, and bottom edge of worktop)

Basic shape 992 Mixer tabs

Definition:

Parameter:

· b = width of bounding-box (orthogonal with t),

· t = depth of bounding-box

· h = height of bounding-box

Remarks:

For fittings the measurements b, h, t of the bouding box have to be defined.


 Language key

IDM 2.8.1 XML-Schema Documentation

Introduction > Language key

Language key | Language name
AA | Afar
AB | Abkhazian
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AV | Avarisch
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CR | Cree
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundish
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothish
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VE | Tshivenda
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu


 Country code

IDM 2.8.1 XML-Schema Documentation

Introduction > Country code

country code | country
AC | Ascension
AD | Andorra
AE | United Arab Emirates
AF | Afghanistan
AG | Antigua and Barbuda
AI | Anguilla
AL | Albania
AM | Armenia
AN | Dutch Antilles
AO | Angola
AQ | Antarctica
AR | Argentina
AS | American Samoa
AT | Austria
AU | Australia
AW | Aruba
AX | Aland
AZ | Azerbaijan
BA | Bosnia and Herzegovina
BB | Barbados
BD | Bangladesh
BE | Belgium
BF | Burkina Faso
BG | Bulgaria
BH | Bahrain
BI | Burundi
BJ | Benin
BL | Saint-Barthélemy
BM | Bermuda
BN | Brunei Darussalam
BO | Bolivia
BQ | Bonaire, Sint Eustatius and Saba
BR | Brazil
BS | Bahamas
BT | Bhutan
BU | Burma
BV | Bouvet Island
BW | Botswana
BY | Belarus
BZ | Belize
CA | Canada
CC | Cocos) Islands
CD | Democratic Republic of the Congo
CF | Central African Republic
CG | Republic of the Congo
CH | Switzerland
CI | Ivory Coast
CK | Cook Islands
CL | Chile
CM | Cameroon
CN | China
CO | Columbia
CP | Clipperton
CR | Costa Rica
CU | Cuba
CV | Cape Verde
CW | Curaçao
CX | Christmas Island
CY | Cyprus
CZ | Czech Republic
DE | Germany
DG | Diego Garcia
DJ | Djibouti
DK | Denmark
DM | Dominica
DO | Dominican Republic
DZ | Algeria
EA | Ceuta, Melilla
EC | Ecuador
EE | Estonia
EG | Egypt
EH | Westsahara
EN | England
ER | Eritrea
ES | Spain
ET | Ethiopia
FI | Finland
FJ | Fiji
FK | Falklands
FM | Micronesia
FO | Faeroe Islands
FR | France
GA | Gabon
GB | England/Great Britain
GD | Grenada
GE | Georgia
GF | French Guiana
GG | Guernsey (Channel Island)
GH | Ghana
GI | Gibraltar
GL | Greenland
GM | Gambia
GN | Guinea
GP | Guadeloupe
GQ | Equatorial Guinea
GR | Greece
GS | South Georgia and the South Sandwich Islands
GT | Guatemala
GU | Guam
GW | Guinea-Bissau
GY | Guyana
HK | Hong Kong
HM | Heard and McDonald Islands
HN | Honduras
HR | Croatia
HT | Haiti
HU | Hungary
ID | Indonesian
IE | Ireland
IL | Israel
IM | Isle of Man
IN | India
IO | British Indian Ocean Territory
IQ | Iraq
IR | Islamic Republic of Iran
IS | Iceland
IT | Italy
JE | Channel Island of Jersey
JM | Jamaica
JO | Jordan
JP | Japan
KE | Kenya
KG | Kyrgyzstan
KH | Cambodia
KI | Kiribati
KM | Comoros
KN | Saint Kitts and Nevis
KP | Democratic People's Republic of Korea
KR | Republic of Korea
KW | Kuwait
KY | Cayman Islands
KZ | Kazakstan
LA | Laos
LB | Lebanon
LC | Saint Lucia
LI | Liechtenstein
LK | Sri Lanka
LR | Liberia
LS | Lesotho
LT | Lithuania
LU | Luxembourg
LV | Latvia
LY | Libya
MA | Morocco
MC | Monaco
MD | Moldavia
ME | Montenegro
MF | Saint Martin
MG | Madagascar
MH | Marshall Islands
MK | North Macedonia
ML | Mali
MM | Myanmar (Burma)
MN | Mongolia
MO | Macau
MP | Northern Mariana Islands
MQ | Martinique
MR | Mauritania
MS | Montserrat
MT | Malta
MU | Mauritius
MV | Maldives
MW | Malawi
MX | Mexico
MY | Malaysia
MZ | Mozambique
NA | Namibia
NC | New Caledonia
NE | Niger
NF | Norfolk Island
NG | Nigeria
NI | Nicaragua
NL | Netherlands
NO | Norway
NP | Nepal
NR | Nauru
NU | Niue
NZ | New Zealand
OM | Oman
PA | Panama
PE | Peru
PF | French Polynesia
PG | Papuan New Guinea
PH | Philippine
PK | Pakistan
PL | Poland
PM | St. Pierre and Miquelon
PN | Pitcairn Islands
PR | Puerto Rica
PS | Palestine
PT | Portugal
PW | Palau
PY | Paraguay
QA | Qatar
RE | Reunion
RO | Romania
RS | Serbia
RU | Russia
RW | Ruanda
SA | Saudi Arabia
SB | Solomon Islands
SC | Seychelles
SD | Sudan
SE | Sweden
SG | Singapore
SH | St. Helena
SI | Slovenia
SJ | Svalbard and Jan Mayen Islands
SK | Slovak Republic
SL | Sierra Leone
SM | San Marino
SN | Senegal
SO | Somalia
SR | Suriname
SS | South Sudan
ST | Democratic Republic of São Tomé and Príncipe
SV | El Salvador
SX | Sint Maarten
SY | Syrian Arab Republic
SZ | Swaziland
TC | Turks and Caicos Islands
TD | Chad
TF | French Southern and Antarctic Territories
TG | Togo
TH | Thailand
TJ | Tadschikistan
TK | Tokelau
TL | East Timor
TM | Turkmenistan
TN | Tunisia
TO | Tonga
TR | Turkey
TT | Trinidad and Tobago
TV | Tuvalu
TW | Taiwan
TZ | Tanzania
UA | Ukraine
UG | Uganda
UM | United States Minor Outlying Islands
US | United States of America
UY | Uruguay
UZ | Uzbekistan
VA | Vatican City
VC | Saint Vincent and the Grenadines
VE | Venezuela
VG | British Virgin Islands
VI | American Virgin Islands
VN | Vietnam
VU | Vanuatu
WF | Wallis and Futuna Islands
WS | Samoa
YE | Yemen
YT | Mayotte
ZA | South Africa
ZM | Sambia
ZW | Zimbabwe


 Buying associations
IDM 2.8.1 XML-Schema Documentation Introduction > Buying associations
Buying association customer | Name buying association | Street | Postal Code | City | Phone | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13 A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Beinhaltet Form und Material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunscheig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co. KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60


 Types of detail information

IDM 2.8.1 XML-Schema Documentation

Introduction > Types of detail information

The following info types can be used to describe the type of detail information:

1 = milieu photo

2 = item sketch

3 = item photo

4 = version photo

5 = version texture

6 = manufacturer logo/product brand

7 = model description sheets

8 = installation instructions

9 = marketing

10 = pictogram sketch

11 = video

99 = miscellaneous


 Filename

IDM 2.8.1 XML-Schema Documentation

Introduction > Filename

The following is recommended for the file name associated with a data record:

· The name of the data record must not be limited to 8 characters.

· If possible, all components from the CATALOG_IDENTIFICATION should be used:

· The following components are suggested:

· Manufacturer number

· IDM version

· Customer number (value from the ASSOC_CTM_NO element)

· All languages

· Year

· Major number (MAJOR)

· File release timestamp (FILE_RELEASE_DATE)


 Schema IDM_2_8_1.xsd.EN.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\IDM\Doku IDM Küche\IDM_2_8_1.xsd.EN.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
T_NEW_CATALOG | languagetexte
 | languagetexte30
 | languagetexte40
 | languagetexte60
 | languagetexte60999


 element T_NEW_CATALOG
diagram
properties
content complex
children Signature CATALOG SUPPLIER GLOBAL_DEFINITION SERIES FEATURE_DEFINITION PRICE_DEFINITION BLOCK_VALUE_CALCULATION
annotation
documentation
This element is used for storing and providing all information and data for the issuing of a complete catalogue/ database.


 attribute T_NEW_CATALOG/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 2 |
maxInclusive | 2 |
annotation
documentation
The version number "MAJOR" indicates the format version of the database. This main version number is only changed if the format is changed completely.
The complete definition of a format version consists of the following elements: MAJOR, MINOR and REVISION.


 attribute T_NEW_CATALOG/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 8 |
maxInclusive | 8 |
annotation
documentation
In general the number of the sub-version "MINOR" changes every year. In case the main version number MAJOR is changed, the sub-version number is reset to 0.


 attribute T_NEW_CATALOG/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 1 |
annotation
documentation
The revision number "REVISION" highlights changes during the year resultant from individual working groups. The revisions are not published if they are not concerned with necessary corrections. Revision is reset to 0 with each new "MINOR" sub-version number.


 element T_NEW_CATALOG/Signature
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SignedInfo SignatureValue
annotation
documentation
This element defines the type of encryption.

The root element of a digital signature via XML is represented by the element Signature.

Signature has two child elements in which the elements SignedInfo and SignatureValue are mandatory.


 element T_NEW_CATALOG/Signature/SignedInfo
diagram
properties
content complex
children CanonicalizationMethod SignatureMethod Reference
annotation
documentation
The first and most complex element of Signature is the element SignedInfo. This element contains the utilized algorithms for canonization and signature, one or more references to the signed data, and probable transformations as well as the hash values of these data. Moreover the element SignedInfo contains all relevant information about the resources which are signed and is therefore the part for which the digital signature is defined.

Digital signature of the algorithms is used for the purpose of data security. A secure algorithm cannot be exchanged by an insecure without cancellation of the signature.

Child elements of SignedInfo are the mandatory elements CanonizationMethod and SignatureMethod as well as one or more Reference elements.


 element T_NEW_CATALOG/Signature/SignedInfo/CanonicalizationMethod
diagram
type extension of xs:string
properties
content complex
annotation
documentation
The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

- A document is encoded into UTF-8 format
- Line breaks are normalised to #xA before parsing
- The values of attributes are normalised (similar to validating parsers)
- Character- and parsed-entity references are replaced
- CDATA paragraphs are replaced by their contents
- The XML declaration and a probably existing DTD are removed
- Blank elements are converted to start-end-tag pairs
- Whitespace outside of the document element and inside the start- and end-tags is normalised
- Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
- The values of attributes are given in double quotation marks
- Special characters in attribute values and text knots are replaced by sign references
- Redundant namespace declarations in front of each element are removed
- Default attributes are added to the elements
- The sort order of namespace declarations and attributes is alphanumeric


 attribute T_NEW_CATALOG/Signature/SignedInfo/CanonicalizationMethod/@Algorithm
type xs:anyURI
annotation
documentation
This attribute is used to identify the canonization algorithm that is applied to the data in SignedInfo prior to the signature calculation. It is specified as an URI.


 element T_NEW_CATALOG/Signature/SignedInfo/SignatureMethod
diagram
type extension of xs:string
properties
content complex
annotation
documentation
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.


 attribute T_NEW_CATALOG/Signature/SignedInfo/SignatureMethod/@Algorithm
type xs:anyURI
annotation
documentation
This attribute is used to specify the algorithm for signature generation via an URI.


 element T_NEW_CATALOG/Signature/SignedInfo/Reference
diagram
properties
content complex
children Transforms DigestMethod DigestValue
annotation
documentation
The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.


 attribute T_NEW_CATALOG/Signature/SignedInfo/Reference/@URI
type xs:string
annotation
documentation
The URI attribute is also of the anyURI type and contains the address under which the data to be signed are available. The data that relates to the digital signature do not necessarily have to be contained in the Signature element itself, but can also be referenced via the local file system or an URL.

There are also other URIs that refer to the current document, e.g. URI="". This specific Uniform Resource Identifier represents all XML nodes of the current document, but without any potentially existing comments. The nodes associated with the signature are however included in the selection.


 element T_NEW_CATALOG/Signature/SignedInfo/Reference/Transforms
diagram
properties
content complex
children Transform
annotation
documentation
The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.


 element T_NEW_CATALOG/Signature/SignedInfo/Reference/Transforms/Transform
diagram
type extension of xs:string
properties
content complex
annotation
documentation
The Transform element is used to specify the transformations to be performed. It consists of an Algorithm attribute together with the applicable transformation algorithm.


 attribute T_NEW_CATALOG/Signature/SignedInfo/Reference/Transforms/Transform/@Algorithm
type xs:anyURI
annotation
documentation
This attribute is used for defining a transformation algorithm by means of an URI.


 element T_NEW_CATALOG/Signature/SignedInfo/Reference/DigestMethod
diagram
type extension of xs:string
properties
content complex
annotation
documentation
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.


 attribute T_NEW_CATALOG/Signature/SignedInfo/Reference/DigestMethod/@Algorithm
type xs:anyURI
annotation
documentation
This attribute is used for defining the URI which identifies the message digest algorithm.


 element T_NEW_CATALOG/Signature/SignedInfo/Reference/DigestValue
diagram
type xs:string
properties
content simple
annotation
documentation
The algorithm specified in DigestMethod is used to calculate DigestValue, a unique hash value of the signed object and to store it in this element via Base-64 encoding. The hash value, also known as digital fingerprint, is usually shorter than the signed data and can therefore be signed faster in the step to follow. It is virtually impossible to reconstruct the original message from a hash value. It should also be impossible for two different messages to result in identical hash values (collision and birthday paradox).


 element T_NEW_CATALOG/Signature/SignatureValue
diagram
type xs:string
properties
content simple
annotation
documentation
The SignatureValue element contains the signature's hash value calculated for the entire SignedInfo element in binary format (always Base-64 encoding). This hash value is calculated by the algorithm specified in SignatureMethod using the canonized data and private key. This means that the signature is not affixed to the message itself, but rather to the - usually much shorter - hash value (hash-then-sign paradigm).

The signed data thus contain additional information about the signed references and their hash values. This makes it unnecessary for the data to be present in the document. The information about the applied algorithms is however used in the calculation of the signature. This prevents manipulations down the track.

Because all references are pooled and signed collectively prior to signing, there is precisely one SignatureValue element for the entire signature.


 element T_NEW_CATALOG/CATALOG
diagram
properties
content complex
children FILE_RELEASE_DATE CATALOG_IDENTIFICATION CATALOG_NUMBER CATALOG_YEAR MAJOR_NO CATALOG_NAME DATA_VERSION VALID_FROM_DATE FILE_ID CATALOG_MARK FILLING_LEVEL PRICING_TERMS CATALOG_INFO FALL_BACK_LANGUAGE DETAIL_INFOS
annotation
documentation
All administrative information about the catalogue/ database is stored in this element.


 element T_NEW_CATALOG/CATALOG/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contain the current date and time (UTC).


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children MANUFACTURER_ID ISO_LANGUAGE_ID CURRENCY_KEY COUNTRY_ID CATALOG_KIND ASSOC_CTM_NO PRODUCT_BRANDNAME PRICE_ID VAT
annotation
documentation
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MANUFACTURER_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. This requires entry of the ISO country code.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_KIND
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
maxInclusive | 3 |
annotation
documentation
This element is a mandatory field for identifying the type of catalogue. CATALOG_KIND has the values
1 for a basic catalogue
2 for an association catalogue
3 for a customer-specific catalogue.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/ASSOC_CTM_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
If 2 or 3 is entered in the CATALOG_KIND field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations")


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/PRODUCT_BRANDNAME
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/PRICE_ID
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the
field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If ident numbers are used instead of prices the corresponding information of the ident number purchase price sheet, provided by the manufacturer, has to be filled in in the element PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER. If calculation points are used the the conversion factor has to be defined.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/VAT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing.


 element T_NEW_CATALOG/CATALOG/CATALOG_NUMBER
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
annotation
documentation
This element defines a distinct number for the catalogue which is represented in the database. The catalogue number is manufacturer specific.


 element T_NEW_CATALOG/CATALOG/CATALOG_YEAR
diagram
type xs:gYear
properties
content simple
annotation
documentation
This element refers to the calendar year of the catalogue data.


 element T_NEW_CATALOG/CATALOG/MAJOR_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
The major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged.


 element T_NEW_CATALOG/CATALOG/CATALOG_NAME
diagram
type | languagetexte30
properties
content complex
children | LANGUAGE
annotation
documentation
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.


 element languagetexte30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


 attribute languagetexte30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_NEW_CATALOG/CATALOG/DATA_VERSION
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database.


 element T_NEW_CATALOG/CATALOG/VALID_FROM_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
This element defines the period of validity for the catalogue and corresponding database.


 element T_NEW_CATALOG/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data


 element T_NEW_CATALOG/CATALOG/CATALOG_MARK
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [BKV] |
annotation
documentation
This element is used to differ between the possible data types

B = block data with prices
K = catalogue data
V = block data without prices (notional prices are required)


 element T_NEW_CATALOG/CATALOG/FILLING_LEVEL
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [123]|2[a-n] |
annotation
documentation
The filling level (FILLING_LEVEL) defines the level of details which are provided in a database. In general, an increase in the filling level corresponds with an increase in data quality. The higher the degree of detail specification in the data, the more specific they are for a certain manufacturer.
The different filling levels are evaluated during the certification procedure: By checking the filling levels it is ascertained which information is required in the data, in order to achieve the filling level. In case the required information is missing in a filling level, the complete set of data is not certified.
The filling levels are defined as follows:
- Filling level 1: provides basic information except from elements for the description of texture information
- Filling level 2a: filling level 1 is supplemented with information regarding textures and material (colours RGB,transparency and brightness)
- Filling level 2b: filling level 1 is amended with information about front division and front finishes
- Filling level 2c: filling level 1 is supplemented with information about handles.
- Filling level 2d: filling level 1 is amended with information about item textures.

Combinations of filling levels 2a-2d are possible. Following itemized breakdowns of combinations are defined:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Filling level 3. To achieve filling level 3 information in the filling levels 1 and 2a - 2d supplemented by information about the modeling graphic is required. In filling level 3 all options of the data format for manufacturer specific illustrations are entirely applied.
A complete definition of the information required for the different filling levels is provided in the table "Filling levels".


 element T_NEW_CATALOG/CATALOG/PRICING_TERMS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 1 |
pattern | [01] |
annotation
documentation
This element defines the pricing terms for the catalog prices.
A complete definition of the information required for the dThis element defines the pricing terms for the catalog prices. The information in this field is used for a correct data import in order to avoid overwriting of price information.

The following values are used:
0 = prices in the catalogue are purchase prices for dealers
1 = prices in the catalogue are recommended retail prices (UPE)

All price information in the catalogue has to correspond to the information in this element.


 element T_NEW_CATALOG/CATALOG/CATALOG_INFO
diagram
type | languagetexte60999
properties
content complex
children | LANGUAGE
annotation
documentation
Information texts are stored in this element.


 element languagetexte60999/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


 attribute languagetexte60999/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetexte60999/LANGUAGE/TEXT_LINE
diagram
properties
minOcc | 1
maxOcc | 999
content | complex
children TEXT
annotation
documentation
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.


 attribute languagetexte60999/LANGUAGE/TEXT_LINE/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in.


 element languagetexte60999/LANGUAGE/TEXT_LINE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,60} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 element T_NEW_CATALOG/CATALOG/FALL_BACK_LANGUAGE
diagram
type restriction of xs:language
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The two-digit ISO language code must be used.


 element T_NEW_CATALOG/CATALOG/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element is used for images of the manufacturer catalogue.


 element T_NEW_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used for referencing the detail information.


 attribute T_NEW_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used for defining the identification number of the referenced detail information.


 element T_NEW_CATALOG/SUPPLIER
diagram
properties
content complex
children EDI_INFO BRANCH_ID ISO_COUNTRY_ID GLN_NO WEEE_NO CONTACT_PERSON CONTACT_SUPPLIER
annotation
documentation
All relevant supplier data, e.g. communication and contact details, are stored in this element.


 element T_NEW_CATALOG/SUPPLIER/EDI_INFO
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children EDI_FORMAT EDI_FORMAT_VERSION EDI_MESSAGE EDI_COMMUNICATION EDI_COMMUNICATION_ADDRESS EDI_CONTACT
annotation
documentation
The different possibilities of EDI-communication are defined in this element. For each EDI message of an EDI format exactly one element is defined.


 element T_NEW_CATALOG/SUPPLIER/EDI_INFO/EDI_FORMAT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
pattern | EANCOM|EAN 97|EAN 97 A|EDIDATA |
annotation
documentation
The supported EDI-format is indicated in this field(e.g. EDIDATA).


 element T_NEW_CATALOG/SUPPLIER/EDI_INFO/EDI_FORMAT_VERSION
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
pattern | [1-9]\.[0-9]{2} |
annotation
documentation
This field contains the version of the EDI format defined in the field EDI_FORMAT.


 element T_NEW_CATALOG/SUPPLIER/EDI_INFO/EDI_MESSAGE
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
All different EDI messages supported by a manufacturer are indicated here (e.g. order, order response).


 element T_NEW_CATALOG/SUPPLIER/EDI_INFO/EDI_COMMUNICATION
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
This is used to specify the method for EDI communications (e.g. X400, Telebox, email).


 element T_NEW_CATALOG/SUPPLIER/EDI_INFO/EDI_COMMUNICATION_ADDRESS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 40 |
annotation
documentation
The address for the EDI communication is filled in here (e. g. X.400 address, E-mail address or 'on consultation').


 element T_NEW_CATALOG/SUPPLIER/EDI_INFO/EDI_CONTACT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 60 |
annotation
documentation
The name of a contact person who is responsible for all questions concerning the EDI communication is filled in into this field. This field is not delimited so that all necessary information (i.e. name, phone number etc.) can be entered into one field.


 element T_NEW_CATALOG/SUPPLIER/BRANCH_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [ABGKOPSWZ] |
annotation
documentation
The different branches of manufacturers are indicated by the entries in this element.The following branches are currently differentiated:

A = worktop manufacturer
B = bathroom furniture manufacturer
G = appliance manufacturer
K = kitchen furniture manufacturer
O = office furniture manufacturer
P = upholstery manufacturer
S = sanitary manufacturer
W = manufacturer of living room furniture
Z = manufacturer of accessories


 element T_NEW_CATALOG/SUPPLIER/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
Based on the standards of ISO-norm the country of the manufacturer's headquarter is defined here.


 element T_NEW_CATALOG/SUPPLIER/GLN_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [0-9]{13} |
annotation
documentation
The unambiguous Global Location Number (GLN) of a supplier is defined in this element. This unique identification of companies resp. company units is used especially for the automated electronic data exchange.


 element T_NEW_CATALOG/SUPPLIER/WEEE_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
The WEEE registration number of the supplier is defined in this element. This registration number is required for all manufacturers and importers of electronic devices according to the rules of the German "Elektro- und Elektronikgerätegesetz" (ElektroG).
The German standard of the WEEE numbering is built up in the following way: "DE12345678".
The validity of a WEEE No. can be checked on the internet homepage of "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON
diagram
properties
minOcc | 1
maxOcc | 2
content | complex
children CONTACT_PERSON_NO CONTACT_ROLE CONTACT_NAME FIRST_NAME FORM_OF_ADDRESS DEPARTMENT TELEPHONE FAX EMAIL STREET ZIPCODE_STREET CITY
annotation
documentation
All information concerning the contact person is defined in this element.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CONTACT_PERSON_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact).


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CONTACT_ROLE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 60 |
annotation
documentation
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CONTACT_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
The family name of the direct contact person for the software suppliers is defined in this element.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/FIRST_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
The first name of the direct contact person is entered here.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/FORM_OF_ADDRESS
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/DEPARTMENT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
If applicable, the department of the contact person is defined in this field.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/TELEPHONE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/FAX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
This element contains the E-Mail address of the contact person.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
The street address of the manufacturer is defined in this element.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
The ZIP code for the street address of the manufacturer is defined in this element.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CITY
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
The city name of the manufacturer's address is entered here.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER
diagram
properties
content complex
children MANUFACTURER_NAME_1 MANUFACTURER_NAME_2 EMAIL INTERNET_ADDRESS STREET ZIPCODE_STREET CITY ZIPCODE_POSTBOX POSTBOX TELEPHONE_SWITCHBOARD FAX_SWITCHBOARD
annotation
documentation
All contact information for the specific manufacturer is defined in this element.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_1
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element contains the first line of the manufacturer's name.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_2
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element contains the second line of the manufacturer's name.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
The official E-Mail address of the manufacturer is defined in this element.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/INTERNET_ADDRESS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com).


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
The street address of the manufacturer is defined in this element.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
The ZIP code for the street address of the manufacturer is defined in this element.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/CITY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
The city name of the manufacturer's address is entered here.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
If applicable, the ZIP code of the manufacturer's postbox address is entered here.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{0,10} |
annotation
documentation
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/TELEPHONE_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/FAX_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890.


 element T_NEW_CATALOG/GLOBAL_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CLEARING_GROUP FRONTS_HANDLE_POSITIONS FRONT_APPEARANCES MODULE_RULE_SET_DEFINITIONS DETAIL_INFOS PROPERTIES GROUP_TITLES
annotation
documentation
This element is used for defining global data which apply to the complete catalogue/ database (global information).


 element T_NEW_CATALOG/GLOBAL_DEFINITION/CLEARING_GROUP
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children EXCHANGE_ID_REF CLEARING_GROUP_NAME
annotation
documentation
This element is used for the definition of clearing groups. Different exchange_IDs are summarized and made up to a clearing group (element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID).

The clearing groups in the block conditions (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) and the grading tables (BLOCK_VALUE_CALCULATION/GRADING_TABLE) are used for the definition of a minimum value for a certain type range. The different type ranges can be identified by their corresponding exchange_ID.

The single amounts of all items which belong to a certain exchange_ID are summarized. A total amount is summed up for each clearing group. This amount is defined as reference value for further use in block calculation and for the value clearing grading table.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/CLEARING_GROUP/@CLEARING_GROUP_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies a clearing group.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/CLEARING_GROUP/EXCHANGE_ID_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references an exchange-ID.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/CLEARING_GROUP/EXCHANGE_ID_REF/@EXCHANGE_ID_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/CLEARING_GROUP/CLEARING_GROUP_NAME
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
Name for a clearing group. This is used in order to simplify data acquisition.


 element languagetexte60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


 attribute languagetexte60/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte60/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,60} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SPECIFIC_HANDLE_POSITIONS BASIC_HANDLE_POSITIONS FRONT_TYPES_GROUPS
annotation
documentation
This element is used for the definition of handle positions, either basic or specific positions. The validity of a basic handle position is global, whereas the validity of a specific handle position is subject to special conditions.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SPECIFIC_HANDLE_ORIENTATION
annotation
documentation
Specific handle positions, changes of handle positions or changes of handles can be defined in this element. For all these cases the denotation “specific handle positon” is used. User-defined combinations of the different child elements are permitted. The more child elements are filled in, the more precise is the description of the specific handle position. The PRIORITY field (P1) and at least one key field have to be filled in.

Element paths
Path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children STYLE_REF FRONT_TYPE_GROUP_REF WIDTH_FROM WIDTH_TO HEIGHT_FROM HEIGHT_TO OPTION_REF HANDLE_EXCHANGE HANDLE_ORIENTATION_EXCHANGE PRIORITY
annotation
documentation
This element defines a specific handle orientation.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/@SPECIFIC_HANDLE_ORIENTATION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
This attribute identifies a specific handle orientation.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/STYLE_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
References are used for assigning specific handle orientations to specific programmes. If this element is not defined, the handle orientation is applicable for all programmes.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/STYLE_REF/@STYLE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute defines the referenced programme. It references to the attribute STYLE_NO in the element STYLE (Path1).

element paths:
path1: FEATURE_DEFINITION/OPTION_DEFINITION/


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/FRONT_TYPE_GROUP_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element defines the front type group to which a special handle orientation applies. If this element is not defined the handle orientation is available for all front type groups.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/FRONT_TYPE_GROUP_REF/@FRONT_TYPE_GROUP_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
This attribute references the front type group.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/WIDTH_FROM
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
The given measurement in this element defines the minimum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field require corresponding settings in the field WIDTH_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/WIDTH_TO
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
The given measurement defines the maximum width (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible widths of the front element. Settings in this field are required when the field WIDTH_FROM was filled in. The width is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HEIGHT_FROM
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
The given measurement defines the minimum height (nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field require corresponding settings in the field HEIGHT_TO. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HEIGHT_TO
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
The given measurement defines the maximum height(nominal value of the front element) for which the specified handle orientation is applicable. If this field is left blank, this handle orientation applies to all possible heights of the front element. Settings in this field are required when the field HEIGHT_FROM was filled in. The height is measured from the middle of spacing to middle of spacing, or from the edge up to exterior edge of the item.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/OPTION_REF
diagram
properties
content complex
annotation
documentation
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door" (FEATURE_NO = 154) are permitted.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 154 |
maxInclusive | 154 |
annotation
documentation
This attribute is used for the definition of an option type. Only feature type 154 is permitted.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This element defines for which types of glass frame doors the specific handle orientation is applicable. Only variations of the option "finish glass frame door"" (FEATURE_NO = 154) are permitted.

A data record containing this element is only applied to the item when the feature class "finish glass frame door" (154) is defined for it.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FEATURE_REF FROM_HANDLE TO_HANDLE
annotation
documentation
Specific conditions for a handle exchange are defined in this element. Further conditions defined in the element SPECIFIC_HANDLE_ORIENTATION have to be fulfilled.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/FEATURE_REF
diagram
properties
content complex
annotation
documentation
This element references a feature type which is defined in the element FEATURE_DEFINITION/FEATURES/FEATURE.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/FEATURE_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used for the definition of an option type.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/FROM_HANDLE
diagram
properties
content complex
children OPTION_REF
annotation
documentation
This element defines which handle is exchanged.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/FROM_HANDLE/OPTION_REF
diagram
properties
content complex
annotation
documentation
This element references a handle option in the element FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION. This element defines the handle option which is used for the specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle options.


attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/FROM_HANDLE/OPTION_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/FROM_HANDLE/OPTION_REF/@FEATURE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 300 |
maxInclusive | 303 |
pattern | 300|303 |
annotation
documentation
This attribute defines the variation type of the handle which is changed, options 300 and 303 are permitted.


attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/FROM_HANDLE/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/FROM_HANDLE/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute assigns a handle variation to a specific handle orientation. If this element is not filled in, the specific handle orientation is valid for all handle variations.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/TO_HANDLE
diagram
properties
content complex
children OPTION_REF
annotation
documentation
This element defines the handle which is used as a replacement.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/TO_HANDLE/OPTION_REF
diagram
properties
content complex
annotation
documentation
This element defines the handle which is used as a replacement handle in certain situations.


attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/TO_HANDLE/OPTION_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/TO_HANDLE/OPTION_REF/@FEATURE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 300 |
maxInclusive | 303 |
pattern | 300|303 |
annotation
documentation
This attribute defines the variation type of the referenced handle variation. Options 300 and 303 are permitted.


attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/TO_HANDLE/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_EXCHANGE/TO_HANDLE/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This element defines the handle variation which is used as a replacement.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_ORIENTATION_EXCHANGE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FROM_HANDLE_ORIENTATION_REF TO_HANDLE_ORIENTATION_REF
annotation
documentation
This element defines the exchange of handle orientations.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_ORIENTATION_EXCHANGE/FROM_HANDLE_ORIENTATION_REF
diagram
properties
content complex
annotation
documentation
This element defines for which basic handle orientations the specific handle orientation is valid. If the element is not filled in the specific handle orientation is valid for all basic handle orientations.
The handle orientation has to be defined in the element BASIC_HANDLE_POSITIONS (Path1).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITION


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_ORIENTATION_EXCHANGE/FROM_HANDLE_ORIENTATION_REF/@HANDLE_ORIENTATION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This attribute is used to reference a specific handle position.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_ORIENTATION_EXCHANGE/TO_HANDLE_ORIENTATION_REF
diagram
properties
content complex
annotation
documentation
This element defines the handle orientation which is used as a replacement.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/HANDLE_ORIENTATION_EXCHANGE/TO_HANDLE_ORIENTATION_REF/@HANDLE_ORIENTATION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This attribute is used to reference a specific handle position.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS/SPECIFIC_HANDLE_ORIENTATION/PRIORITY
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
A priority of a handle orientation is defined in this field.
Per definition in the element SPECIFIC_HANDLE_ORIENTATION (Path 1) it is possible that several handle orientations are defined as valid handle orientations which would cause confusing and contradicting situations.
To avoid any ambiguities, priorities can be assigned to handle orientations.
The priority increases with the increase of the numerical values which are used for the definition of priorities. Several handle orientations can be summarized under one priority. Handle orientations with the same priority value require settings in the same key fields.

Element paths:
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/BASIC_HANDLE_POSITIONS
diagram
properties
content complex
children HANDLE_ORIENTATION
annotation
documentation
This element is used to describe the position and alignment of handles installed on certain front types. The basic handle positions defined in this element are valid universally.

The basic handle positions should be guided by the pre-defined standard handle positions in the section named standard handle positions. Please note that 0 must not be used as a value for basic handle positions.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/BASIC_HANDLE_POSITIONS/HANDLE_ORIENTATION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FRONT_TYPE
annotation
documentation
This element is a container element for the definition of different basic handle positions.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/BASIC_HANDLE_POSITIONS/HANDLE_ORIENTATION/@HANDLE_ORIENTATION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This attribute identifies a basic handle orientation.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/BASIC_HANDLE_POSITIONS/HANDLE_ORIENTATION/FRONT_TYPE
diagram
properties
minOcc | 1
maxOcc | 7
content | complex
children ORIENTATION POSITION
annotation
documentation
This element defines the handle position and handle orientation for each front type. The front type itself is defined in the attribute FRONT_TYPE_CODE.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/BASIC_HANDLE_POSITIONS/HANDLE_ORIENTATION/FRONT_TYPE/@FRONT_TYPE_CODE
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [SAKJTR]|GT |
annotation
documentation
Different handle orientation are assigned to different front types. The different front types are listed below:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation)


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/BASIC_HANDLE_POSITIONS/HANDLE_ORIENTATION/FRONT_TYPE/ORIENTATION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [HV] |
annotation
documentation
This element is used for the differentiation of orientations.
H = horizontal
V = vertical


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/BASIC_HANDLE_POSITIONS/HANDLE_ORIENTATION/FRONT_TYPE/POSITION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [MADG0] |
annotation
documentation
This element is used for the differentiation of handle positions in accordance with the chosen front type.

M = middle (e.g. for grip ledges without hinge)
A = exterior (e.g. for grip ledge, dependent on the hinge)
D = double (two handles at the exterior sides)
G =without drilling, with handle (handle is delivered, drilling on site)
0 (zero) = without drilling, without handle (handle is not delivered, no drillings provided)

In case of position A = exterior, the definite position is indicated by the hinge information , i.e. left/ right, for the item.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/FRONT_TYPES_GROUPS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FRONT_TYPES_GROUP
annotation
documentation
For an efficient use of front types in the definition of specific handle orientations in the element SPECIFIC_HANDLE_ORIENTATION (Path1) different front types can be combined to one front type group.

element paths path1:
GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/SPECIFIC_HANDLE_POSITIONS


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/FRONT_TYPES_GROUPS/FRONT_TYPES_GROUP
diagram
properties
minOcc | 1
maxOcc | 99
content | complex
children FRONT_TYPE
annotation
documentation
This element defines a front type group.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/FRONT_TYPES_GROUPS/FRONT_TYPES_GROUP/@FRONT_TYPE_GROUP_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
This attribute identifies a front type group.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/FRONT_TYPES_GROUPS/FRONT_TYPES_GROUP/FRONT_TYPE
diagram
properties
minOcc | 1
maxOcc | 7
content | complex
annotation
documentation
This element defines the handle position and handle orientation for each front type. The front type itself is defined by the attribute FRONT_TYPE_CODE.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS/FRONT_TYPES_GROUPS/FRONT_TYPES_GROUP/FRONT_TYPE/@FRONT_TYPE_CODE
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [SAKJTR]|GT |
annotation
documentation
This element contains the different front types which are combined to a front type group. The following front types are defined:
S = drawer
A = pull-out
K = flap-door
J = shutter (vertical orientation)
T = door
GT = glass door
R = shutter (horizontal orientation)


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FRONT_APPEARANCE
annotation
documentation
The different front appearances of a programme, an option, or an item are defined in this element. These front appearances are referenced by programmes (FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF), options (FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF), or by items (SERIES/.../ITEM/FRONT_APPEARANCE_REF).
The basic definition of a front appearance consists of a basic shape number, assigned to a front element,and geometrical measurement information.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE
diagram
properties
minOcc | 1
maxOcc | 999
content | complex
children FRONT_TYPE
annotation
documentation
This element is used for the definition of a front appearance.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/@FRONT_APPEARANCE_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute defines a specific ID for a front appearance which is referenced by styles and items.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE
diagram
properties
minOcc | 1
maxOcc | 900
content | complex
children FRONT_TYPE_NO FRONT_CONSTRAINTS FRONT_SHAPE
annotation
documentation
The definition of front type 0 is used when all front elements have the same appearance irrespective of the used front type. In this case the definition of divergent front types is not permitted. If a front type has been defined for a front appearance_ID, data sets for all other front types are required.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_TYPE_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 900 |
annotation
documentation
This attribute defines the front type key.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_CONSTRAINTS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children WIDTH_FROM WIDTH_TO HEIGHT_FROM HEIGHT_TO
annotation
documentation
For the elements WIDTH_FROM/TO and HEIGTH_FROM/TO the following rules apply:

- If the elements WIDTH_TO or HEIGHT_TO are not defined, this equals the value "infinite"
- If the elements WIDTH_FROM or HEIGHT_FROM are not defined, this equals the value 0.
- The value 0 is not permitted in the elements WIDTH_FROM/TO or HEIGTH_FROM/TO.
- The intervalls have to cover the complete range
from 0 to infinite. Gaps are not permitted either.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_CONSTRAINTS/WIDTH_FROM
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999 |
annotation
documentation
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm).


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_CONSTRAINTS/WIDTH_TO
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999 |
annotation
documentation
The elements WIDTH_FROM/TO indicate the range of width dimensions in which the basic front shape or modeling graphic may vary (measurements given in mm).


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_CONSTRAINTS/HEIGHT_FROM
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999 |
annotation
documentation
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm).


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_CONSTRAINTS/HEIGHT_TO
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999 |
annotation
documentation
The elements HEIGHT_FROM/TO indicate the range of height dimensions in which the basic front shape or modeling graphic may vary. (measurements given in mm).


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_SHAPE
diagram
properties
content complex
children GLASS MODELING_GRAPHIC_ID BASIC_FRONT_SHAPE
annotation
documentation
This element is used for the geometrical description of a front element.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_SHAPE/GLASS
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Values in this field indicate whether the front type is a glass front (value 1/true) or a simple front (value 0/false). For one front type the values in this element may not vary. This rule makes sure that a glass front is always depicted as glass front even when the programme has been changed.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_SHAPE/MODELING_GRAPHIC_ID
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element may be used for the definition of a modeling graphic.

Further format definitions are required.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_SHAPE/BASIC_FRONT_SHAPE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BASIC_FRONT_SHAPE_ID PARAMETERS
annotation
documentation
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_SHAPE/BASIC_FRONT_SHAPE/BASIC_FRONT_SHAPE_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 3 |
annotation
documentation
This element provides information about a basic shape which is used for the depiction of a front element.
All defined basic shapes are listed in table "basic shapes".

Value 999 is not permitted any longer.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_SHAPE/BASIC_FRONT_SHAPE/PARAMETERS
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used for assigning values to the different front parameters.


attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_SHAPE/BASIC_FRONT_SHAPE/PARAMETERS/@VALUE

 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_SHAPE/BASIC_FRONT_SHAPE/PARAMETERS/@VALUE >
type restriction of xs:string
facets
Kind | Value | Annotation
maxLength | 12 |
annotation
documentation
This attribute is used to assign a measurement to the parameter for the basic front shape.


attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_SHAPE/BASIC_FRONT_SHAPE/PARAMETERS/@PARAMETER

 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEARANCE/FRONT_TYPE/FRONT_SHAPE/BASIC_FRONT_SHAPE/PARAMETERS/@PARAMETER >
type restriction of xs:string
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This element contains the parameter which indicates the basic shape. A dimension value is filled in in the element VALUE.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MODULE_RULE_SET_DEFINITION
annotation
documentation
This element is used for the definition of the rules which apply to module cabinets and their components.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS/MODULE_RULE_SET_DEFINITION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children MODULE_RULE_SET_NAME
annotation
documentation
This element is used for the definition of specifig rules for module cabinets and the single module parts. The defined module rules are referenced by items (SERIES/.../ITEM/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO) or (SERIES/.../ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/MODULE_RULE_SET_NO.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS/MODULE_RULE_SET_DEFINITION/@MODULE_RULE_SET_NO
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute defines the number of the rule set which references an item to the corresponding rule set.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS/MODULE_RULE_SET_DEFINITION/MODULE_RULE_SET_NAME
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
This element defines the name of the module rule set.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO
annotation
documentation
This element is used for saving hyperlinks with detail information.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION INFO_TYPE EXTERNAL_NAME INTERNAL_NAME TOOL_TIP URL RESOLUTION
annotation
documentation
This element is used to define a detail information.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute identifies detail information.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/CLASSIFICATION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
This element is used for the classification of detail information.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INFO_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[01]|99 |
annotation
documentation
This element describes the type of detail information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME
diagram
type | languagetexte
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Name of the link (e.g. "magic corner in motion").


 element languagetexte/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.


 attribute languagetexte/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
diagram
type | languagetexte40
properties
content complex
children | LANGUAGE
annotation
documentation
Element for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.


 element languagetexte40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


 attribute languagetexte40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,40} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
diagram
type | languagetexte
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Text information for a tool tip with reference to the link.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL
diagram
properties
content complex
children LANGUAGE
annotation
documentation
This element contains the URL for the detail information.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT HASH_VALUE
annotation
documentation
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/TEXT
diagram
type restriction of xs:anyURI
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 1024 |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/HASH_VALUE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/RESOLUTION
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 4 |
annotation
documentation
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/PROPERTIES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PROPERTY
annotation
documentation
This element is used to include additional information and characteristics, e.g. energy label, efficiency classes and similar data. Only the characteristics needed for correctly mapping the catalogue are defined.

The keys can be found in the corresponding table (information keys).


 element T_NEW_CATALOG/GLOBAL_DEFINITION/PROPERTIES/PROPERTY
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PROPERTY_TEXT PROPERTY_UNIT
annotation
documentation
This element is used to define a feature.

The key, text and measurement unit can be found in the correspondingtable (information keys)(information keys).


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/PROPERTIES/PROPERTY/@PROPERTY_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to identify the feature.

Its number can be found in the table with the information keys.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/PROPERTIES/PROPERTY/PROPERTY_TEXT
diagram
type | languagetexte
properties
content complex
children | LANGUAGE
annotation
documentation
This element contains text information about the characteristics.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/PROPERTIES/PROPERTY/PROPERTY_UNIT
diagram
type | languagetexte30
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
If applicable, this element contains the measurement unit of the characteristic.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/GROUP_TITLES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children GROUP_TITLE
annotation
documentation
This is a central point to store all kinds of descriptions for groups of optional and mandatory accessories.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children GROUP_TITLE_NAME
annotation
documentation
This element is used to specify a group title.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE/@GROUP_TITLE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to specify a unique number for later referencing of the group title.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE/GROUP_TITLE_NAME
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
This element contains the name for groups of accessories.


 element T_NEW_CATALOG/SERIES
diagram
properties
content complex
children SERIE RESTRICTIONS
annotation
documentation
This element is used for defining all series of a catalogue/ database including properties and assigned elements, e.g. product groups or items.


 element T_NEW_CATALOG/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 100
content | complex
children FEATURE_CLASS_REF SERIES_NAME PURCHASE_RETAIL_ID RESTRICTIONS SUGGESTIONS PRODUCT_GROUPS DEFAULT_OPTION_GROUPS DETAIL_INFOS
annotation
documentation
This element is used for the definition of the series.
Items belonging to series 0 are valid for all series. Therefore items of series 0 must not occur with the same type number (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in other series. Items of other series (unequal 0) may be used with the same type name in different series.
Buying prices are always indicated as the dealer’s buying prices.


 attribute T_NEW_CATALOG/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute defines the serial number of the series.


 element T_NEW_CATALOG/SERIES/SERIE/FEATURE_CLASS_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references the feature class which is assigned to the series.
It is used for assigning all legal variations of a series to this specific series.
The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all programmes and items of a series. Therefore it is not obligatory to state the features of a series in the order. However, in an order it is indispensable to state the sum of features for an item in combination with those of the series.
All features which are assigned to one series can be chosen from a list box while entering the variation header.


 attribute T_NEW_CATALOG/SERIES/SERIE/FEATURE_CLASS_REF/@FEATURE_CLASS_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute references a feature class. A feature class is defined in the element FEATURE_CLASS (path1).

path1: FEATURE_DEFINITION/FEATURE_CLASSES/


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_NAME
diagram
properties
content complex
children LANGUAGE
annotation
documentation
This element defines the name of the series.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages.


 attribute T_NEW_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/TEXT_LINE
diagram
properties
content complex
children TEXT FULL_TEXT
annotation
documentation
This element defines a text line.
The element TEXT contains text information.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/TEXT_LINE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/TEXT_LINE/FULL_TEXT
diagram
type xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_NEW_CATALOG/SERIES/SERIE/PURCHASE_RETAIL_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element is used for defining series specific purchase and retail prices
0 = purchase price
1 = retail price
Depending on the price_ID (element PRICE_ID (path1)) the price is defined as follows

price-ID = 1 (price),the value set in the element ITEM_PRICE (path2) is used

price_ID = 2 (ident number), the price is made up from the values set in element IDENT_NUMBER/PRICE (path3), element ITEM_PRICE/PRICE_MINIMUM_BASIC (path2) or in element ADDITIONAL_PRICE (path5).

price_ID = 3 (calculation point), the price made up from the settings in the elements ITEM_PRICE (path2) or PRICE_MINIMUM_BASIC multiplied with the calculation factor, defined in element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR.

According to the key, only one kind of price calculation (combination of elements VAT (path4) and PURCHASE_RETAIL_ID (path4)) may be used within one series.
If a database contains purchase prices as well as retail prices, items with purchase price may not be assigned to the same calculation group(PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP)as items with retail prices.
This element is of major significance for the correct price calculation! Purchase prices are always given as retailers' purchase prices not manufacturers' purchase prices.

element paths
path1: CATALOG/CATALOG_IDENTIFICATION/
path2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/
path3: PRICE_DEFINITION/IDENT_NUMBERS
path4: CATALOG/CATALOG_IDENTIFICATION
path5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP


 element T_NEW_CATALOG/SERIES/SERIE/RESTRICTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children RESTRICTION_REF
annotation
documentation
This element references restrictions which are specific for one series (series specific restriction).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.


 element T_NEW_CATALOG/SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element references a restriction which is assigned to a series (series specific restrictions).

The number of features selected in a planning is only valid, if none of the feature combinations is excluded by any of the restrictions. The result of all restrictions represents an intersection of the feature combinations.


 attribute T_NEW_CATALOG/SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF/@SEQUENCE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...)


 attribute T_NEW_CATALOG/SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF/@RESTRICTION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
This attribute references series specific restrictions.


 element T_NEW_CATALOG/SERIES/SERIE/SUGGESTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SUGGESTION_REF
annotation
documentation
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.


 element T_NEW_CATALOG/SERIES/SERIE/SUGGESTIONS/SUGGESTION_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element references default settings that are applied to the series.

If the series additionally contains a standard proposal (DEFAULT_OPTION_GROUPS), the standard proposal will take priority when the planning is recorded initially.


 attribute T_NEW_CATALOG/SERIES/SERIE/SUGGESTIONS/SUGGESTION_REF/@SEQUENCE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element is used to specify the sequence in which the assigned default values are suggested when a planning is recorded for the first time.

The numbering (SEQUENCE) determines the priorities.


 attribute T_NEW_CATALOG/SERIES/SERIE/SUGGESTIONS/SUGGESTION_REF/@SUGGESTION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
This attribute references a set of default values.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
content complex
children PRODUCT_GROUP
annotation
documentation
This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types (e.g. shelves).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRODUCT_GROUP_TEXT FEATURE_CLASS_REF ITEMS RESTRICTIONS
annotation
documentation
This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/PRODUCT_GROUP_TEXT
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used for defining a name for a product group.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/FEATURE_CLASS_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element is used for assigning a feature class to a product group. It references a feature class which is defined in the element FEATURE_DEFINITION/FEATURE_CLASSES.


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/FEATURE_CLASS_REF/@FEATURE_CLASS_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies the referenced feature class(FEATURE_CLASS).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
This element defines all items belonging to one product group.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children NET_WEIGHT PRICE_FEATURE_GROUP_BASE_PRICE_REF PRICE_TYPE_REF CALC_GROUP_REF EXCHANGE_ID_REF ADDITIONAL_PRICE_GROUP RESTRICTIONS ADDITIONAL_ITEMS HINGE EDP_NUMBER EAN_NUMBER BLOCK_PRICE_STATUS ITEM_IDENTIFICATION CATALOG_PAGE CATALOG_PAGE_PDF VAT_ID_REF VALID_FROM VALID_UNTIL WEIGHT VOLUME CONSTRUCTION_ID SUBCONTRACTOR_ID SUBCONTRACTOR_ITEM_NO OLD_SERIE_NO OLD_TYPE_NO FILE_NAME_TEXTURE_1 FILE_NAME_TEXTURE_2 MASKING MODELING_GRAPHIC_ID RANGE_DEPENDENT MINIMUM_DELIVERY_TIME EX_FACTORY_MODIFICATION BASIC_PROFILE BLOCK_PARTS MODULE_PARTS ITEM_TEXT TYPE_KEY CLASSIFICATIONS FRONT_DIVISIONS FRONT_APPEARANCE_REF MODULE_RULE_SET_REF MODULE_RULE_SETS DETAIL_INFOS PROPERTIES
annotation
documentation
This element is used for the definition of items and blocks. An item is identified by the attributes SERIE_NO (path 1) and TYPE_NO (path 1)..

The elements OLD_SERIA_NO (path 1) and OLD_TYPE_NO (path 1) may only be used if the geometrical information for the referred item is exactly the same as for the current item.

If an electrical appliance is defined as an item, it is necessary to indicate the dimensions (B, H, T) of this item in the element PARAMETERS (path 3).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/NET_WEIGHT
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This attribute is used to specify the net weight.

The code in the previous element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.

Contiguous parts are calculated on the basis of the net weight per price unit.

Example:

An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) with the value 0 in the element ADDITIONAL_PRICE.

Exactly one basic price feature group has to be assigned to an item. Further price groups can be assigned in the element ADDITIONAL_PRICE_GROUP.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute references a PRICE_FEATURE_GROUP.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE PRICE_ON_REQUEST PRICE_MINIMUM_BASIC BASIC_PRICE_UNIT
annotation
documentation
This element is used for the item price and additional price information.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
This element references to the price field.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE >
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be &gt; 0, blanks are not permitted.

(example: -9,00 € =&gt; -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST >
diagram
type restriction of xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
The use of this element indicates that the price for an item is not fixed but available upon request
. This element is used in combination with the element PRICE_CALC_METHOD.

The following values are defined:
1/true = price on request.

If this element is defined, only the value true is permitted.

This element may only be used if the item is available in different price groups.

Definition of a "price on request" for a price group of item:
The element ITEM_PRICE is defined with a corresponding price group. The value "true" is set in the element
PRICE_ON_REQUEST. The following values can be used in the element PRICE:
- value 0: information without relevance,
- a value unequal 0: reference value for the price. The exact value
has to be requested from the manufacturer.

Definition of a "price on request" for a complete item:
Element ITEM_PRICE is not defined. The attribute PRICE_CALC_METHOD (P1) in the element PRICE_FEATURE_GROUP defines, that all prices for the item have to be requested from the manufacturer.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC >
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
This element is used for the definition of minimum or basic prices of an item. The prices are filled in according to their price groups (price field, PRICE_FIELD).

If the referenced price type is not depending on a basic price, a minimum price is filled in here. In all other cases a basic price is defined. If the value 0 is filled in, the item has no minimum or basic price. The value 0 does not imply that this item is free of charge.

Prices haven to be given in the smallest currency unit (e.g. 300.00 € = 30000 cent). Ident numbers are entered without decimal places. Calculation points are given with exactly two decimal places (without the comma).

If an item is not available in one price group, no data record is defined for this price group.

The basic price is always defined as a price per piece. If the flag basic price has been set, it is not permitted to assign a minimum price to that item.
According to the price calculation rules the total price of an item is made up from the given basic price and the calculated remainder price, taking into account the logic defined in the price type (P3/PRICE_TYPE_REF). Basic prices can only be defined for those items which depend at least on one dimension for the price calculation.

The total item price is calculated according to the following scheme:
The basic price unit (P5/BASIC_PRICE_UNIT) is subtracted from the total item price calculated depending on one or more dimensions. The result of this operation is the remainder. The calculation of the total item price is based on the price calculation rules in combination with the defined item price (P5/PRICE). In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.

This element has to be defined if the price type (P3/PRICE_TYPE_REF) of the item has been defined as basic price depending.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P2: GLOBAL_DEFINITION
P3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
P4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
P5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999999 |
annotation
documentation
If a price type (P1/PRICE_TYPE_REF) has been defined as basic price dependent this element is used for defining the unit for this basic price. The basic price unit depends on the number of dimensions which are set to "1" or "true".

If the price of an item depends on width and the price calculation is based on a unit of one and a half metres, the value "1500" has to be filled in here. If an item depends on volume and the basic unit is "1 m²", the value "1000000000" [mm²] is filled in.
If the price calculation of an item is a price per piece and does not depend on any dimension, the field has to be set to "0".

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF
diagram
properties
content complex
annotation
documentation
This element references a price type. Price types are defined by the element path 1/PRICE_TYPE.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPE


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF/@PRICE_TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF/@PRICE_TYPE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies a price type.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CALC_GROUP_REF
diagram
properties
content complex
annotation
documentation
This element references calculation groups. Calculation groups are defined in the merchandise groups (PRICE_DEFINITION/MERCHANDISE_GROUP).


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CALC_GROUP_REF/@CALC_GROUP_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CALC_GROUP_REF/@CALC_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 10 |
maxInclusive | 99 |
annotation
documentation
This attribute identifies a price type.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references an exchange-ID which is defined in the element path 1/EXCHANGE_ID.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF/@EXCHANGE_ID_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF/@EXCHANGE_ID_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
This attribute identifies an exchange-ID.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_REF CALC_GROUP_REF EXCHANGE_ID_REF PRICE_TYPE_REF
annotation
documentation
This element references PRICE_FEATURE_GROUPS with additional price groups. The basic price feature groups which is referenced excatly one time by an item is defined in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF .

All items which reference the same PRICE_FEATURE_GROUP have also to reference the same calculation group (CALC_GROUP_REF) and exchange-ID (EXCHANGE_ID_REF).

If different price types (item prices/ surcharge prices) are assigned to an item, the following combinations are permitted:


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF >
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
This element references a surcharge group. Surcharge groups which are referenced here may not be used as feature groups.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/@PRICE_FEATURE_GROUP_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute references a surcharge group.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE
annotation
documentation
This element is used for the definition of an item price.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_FIELD

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
This element references a price group.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE >
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
The prices are filled in according to the price groups of an item (price field). Prices have to be defined in the smallest currency unit (e.g. instead of 300,00 [€], 30000 [Cent]). Fields may also contain negative prices. These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be &gt; 0, blanks are not permitted.

(Example: field with 9 digits; the figure minus 9,00 € shall be filled in : -900)


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/CALC_GROUP_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/CALC_GROUP_REF >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references calculation groups. The calculation groups are defined within the merchandise groups(PRICE_DEFINITION/MERCHANDISE_GROUP).


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/CALC_GROUP_REF/@CALC_GROUP_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/CALC_GROUP_REF/@CALC_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 10 |
maxInclusive | 99 |
annotation
documentation
This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
The calculation group does not correspond with the suppliers scales of conditions.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/EXCHANGE_ID_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/EXCHANGE_ID_REF >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS. The exchange-ID references block items.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/EXCHANGE_ID_REF/@EXCHANGE_ID_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/EXCHANGE_ID_REF/@EXCHANGE_ID_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9] |
annotation
documentation
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
All exchange-IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The value 0 may only be used in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF >
diagram
properties
content complex
annotation
documentation
This element references a price type. Price types are defined by the element path 11/PRICE_TYPE.

Element paths:
path1: PRICE_DEFINITION/PRICE_TYPES


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF/@PRICE_TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF/@PRICE_TYPE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies a price type.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children RESTRICTION_REF
annotation
documentation
This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references an item to an assigned restriction.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@RESTRICTION_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@RESTRICTION_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
This attribute references item specific restrictions.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@SEQUENCE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF/@SEQUENCE >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTIONAL_ITEMS MANDATORY_ITEMS OPERATION_ITEM
annotation
documentation
This element is used for assigning additional items. A number of optional and/or mandatory additional items is defined which the user may select from in the planning process.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTIONAL_ITEM_GROUP
annotation
documentation
This element references optional additional items. The number of optional items is not restricted. Items which are defined as linked items may not be used as additional items.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP >
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children GROUP_TITLE_REF ITEM_REF
annotation
documentation
This element is used for defining a group of optional additional items.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@SET_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@SET_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9 |
annotation
documentation
A certain number of optional items is available for the main item. In case the field MULTIPLE_CHOICE is set to "true", different optional items can be selected from the total number of available options. If the number of optional items is limited to one, this optional item is selected automatically.
1-9 = status for the definition of optional additional item groups.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@MULTIPLE_CHOICE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@MULTIPLE_CHOICE >
type xs:boolean
properties
use required
annotation
documentation
This attribute defines if mulitple optional items are available for a main item.

true = multiple selection permitted


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/GROUP_TITLE_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/GROUP_TITLE_REF >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/GROUP_TITLE_REF/@GROUP_TITLE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/GROUP_TITLE_REF/@GROUP_TITLE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to identify a group title.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references an optional additional item.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@OPTIONAL_QUANTITY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@OPTIONAL_QUANTITY >
type restriction of xs:positiveInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Number of additional items. Default value for planning software systems. In case of optional additional items this default value is a non-binding proposal.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@SEQUENCE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@SEQUENCE >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MANDATORY_ITEM_GROUP
annotation
documentation
This element is used for assigning mandatory additional items to a main item. For each main item the number of mandatory additional items is restricted to 1 but different groups of mandatory items may be assigned to one main item.
If only 1 additional item is assigned to a group this additional item is automatically transferred into the planning.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP >
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children GROUP_TITLE_REF ITEM_REF
annotation
documentation
This element is used for defining a group of mandatory additional items. Exactly one of these mandatory additional items has to be chosen in the course of the planning.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/@SET_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/@SET_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9 |
annotation
documentation
A number of mandatory additional items can be defined for one main item. Exactly one item has to be selected from this group of mandatory additional items. If only 1 mandatory additional item is assigned to a group this additional item is automatically selected in the planning.

1-9 = status for the definition of optional additional item groups.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/GROUP_TITLE_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/GROUP_TITLE_REF >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references a group title. The group titles are defined within the element (GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE).


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/GROUP_TITLE_REF/@GROUP_TITLE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/GROUP_TITLE_REF/@GROUP_TITLE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to identify a group title.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references an item.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@MANDATORY_QUANTITY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@MANDATORY_QUANTITY >
type restriction of xs:positiveInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Number of additional items. Default value for planning software systems. For mandatory additional items this default value is binding.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@SEQUENCE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@SEQUENCE >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
The attribute SEQUENCE serves the purpose of specifying an unequivocal order ascending from 1 for the accessories in the XML file.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SCOPE
annotation
documentation
This element is used for assigning items to special models, surcharges for mitres, visible sides, or cut outs. The different ways of combination are defined by the elements ITEM_REF/SCOPE (path 1) and CLASS (path 1).

Linked items may not be used as additional items.
Linked items may not be used as additional items.

The following examples illustrate the different possibilities of combination:
- Assignment of surcharges for mitres for cornices, light pelmets,plinths
- Assignment of visible sides for items (range dependent/ range independent)
- Assignment of formed pieces, returns etc. for cornices, light pelmets, plinths
- Assignment of lateral plinth to straight plinth boards
- Assignment of cut outs, tongue and groove for worktops
- Assignment of legal measurement changes, i.e. width-, height-, depth reductions.

In case special models/ items are assigned to an item in this element, only these specially defined models/ items are legal, if no assignments are explicitly defined, all special models are permitted.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE >
diagram
properties
minOcc | 1
maxOcc | 5
content | complex
children ITEM_INFORMATION
annotation
documentation
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/@SCOPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/@SCOPE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 5 |
annotation
documentation
This element defines the scope to which an item is assigned.

The following scopes are defined:
1 = type
2 = plinth
3 = cornice
4 = light pelmet
5 = worktop

Example: Scope 1 (type) indicates in general that an assignment to the target-type exists but it does not indicate a defined assignment of a type to the target-type.
In case the values 1 or 5 are set in this field, settings in the elements BASIC_SHAPE_REFERENCE and COVER are not permitted. If the values 2 or 3 are filled in, settings in the elements BASIC_SHAPE_REFERENCE and COVER are required.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASS ITEM_REF CONSTRUCTION_ID COVER BASIC_SHAPE_REFERENCE VALUE VALUE_MIN VALUE_MAX
annotation
documentation
This element contains all information referring to the scope of an item (e.g. type, plinth, cornice, light pelmet, worktop).


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/CLASS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/CLASS >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 21 |
annotation
documentation
This element defines the type of assignment. The following types are defined:
1 = visible side
2 = lateral plinth
3 = form piece
4 = return
5 = transitions
6 = surcharge mitre
7 = width reduction
8 = depth reduction
9 = height reduction
10 = cut-out
11 = rectangular cut-out
12 = round cut-out
13 = jog
14 = chamfer
15 = rounding
16 = tongue and groove
17 = edge for VALUE 5
18 = width extension for VALUE 1
19 = depth extension for VALUE 1
20 = height extension to value 1
21 = deviation from default plinth

Values defined in this element refer to the values set in the element SCOPE. The following rules apply:

element SCOPE value 1 =&gt; element CLASS values 1, 2, 3, 7, 8, 9, 18 - 20
element SCOPE value 2 =&gt; element CLASS values 2 to 6, value 21
element SCOPE values 3 or 4 =&gt; element CLASS values 3 and 6
element SCOPE value 5 =&gt; element CLASS values 10 - 17


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/ITEM_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/ITEM_REF >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
Settings in this field indicate the type (operation_item) which is assigned to the target-type. The operation item either requires the same series number as the target-type or it has to be assigned to series 0.

This element has to be defined if the element CLASS (path 1) contains values for form piece (3), return (4), or transition (5).

If this element is not defined the element VALUE (path 1) is required.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/CONSTRUCTION_ID

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/CONSTRUCTION_ID >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [LNR] |
annotation
documentation
This element refers to the method of construction for an item, depending on the basic carcase shape.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/COVER

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/COVER >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
The value 3 (form piece) in the field CLASS requires settings in this element. In all other cases this field has to be left blank. Different types of covers are defined: basic cover, part cover, total cover. The different types of cover for form pieces depend on the defined basic shape.The assignment of cover types is listed in table "Assignment of cover types".

With respect to the chosen cover type the following values are permitted:
1 = basic cover
2 = part cover
3 = total cover


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/BASIC_SHAPE_REFERENCE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/BASIC_SHAPE_REFERENCE >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[0-9]|[1-4][0-9]|5[0-2]|99[2-9] |
annotation
documentation
If assignments for plinth, cornices, light pelmets (scope 2-4) are defined, the assignment to a basic shape has to be defined in this element. Settings in this field are required if values 2 - 4 are entered in the field SCOPE. If the values 1 and 5 are set, this element has to be left blank.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/VALUE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/VALUE >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
The additional measurement for a mitre (given in mm) is defined in this element.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/VALUE_MIN

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/VALUE_MIN >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
This element is used to specify the measurement in mm for the minimum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/VALUE_MAX

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPERATION_ITEM/SCOPE/ITEM_INFORMATION/VALUE_MAX >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
This element is used to specify the measurement in mm for the maximum value of a shortening or extension and is only permitted for the values 7, 8, 9, 18, 19, 20 of the CLASS element.CLASS.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/HINGE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [BEJLMNR] |
annotation
documentation
This element provides information about the orientation of the door hinges. No geometrical information is filled in here. All geometrical information is provided in the element CONSTRUCTION_ID.

The following codes can be used to define the door closing:
J = request for door closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = no hinge or hinges on the exterior edges (double door);
R = hinge right ;
B = corresponding with construction ID i.e. construction-ID left : hinge left;
E = opposite to construction-ID, i.e. construction-ID left : hinge right;

In case of double doors, L and R apply to both doors.

For the item identifier B (block) the placement of the items in a block corresponds to the construction_ID =&gt; value "N" is required in the field HINGE.

Values B and E are only permitted if the value "J" is filled in in the element CONSTRUCTION_ID (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EDP_NUMBER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EAN_NUMBER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
If available the EAN-code of an item is defined in this element.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PRICE_STATUS
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9 |
annotation
documentation
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M".


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_IDENTIFICATION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [BEKSMZVPNOG] |
annotation
documentation
This element is used to assign an identifier to the article.
B = Block
E = Replacement part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CATALOG_PAGE
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 40 |
annotation
documentation
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories".


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CATALOG_PAGE_PDF
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
maxInclusive | 999 |
annotation
documentation
This element can be used to specify the item's catalogue page in the catalogue saved as a .pdf file. This information helps to quickly find an item within the stored catalogue.

The URL of the .pdf file is stored in the DETAIL_INFO element (on catalogue level). Because some items feature on multiple pages within the catalogue, it must be assured that the information for the .pdf file is identical to the 40-digit catalogue page CATALOG_PAGE, meaning they both refer to the same page.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VAT_ID_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VAT_ID_REF/@VAT_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VAT_ID_REF/@VAT_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This element is used for referencing the different VAT rates.

The different VAT rates which apply to the items in the catalogue are defined in the element VALUE_ADDED_TAX (path 1). For items which are not subject to VAT the value 0 is filled in.
If the value 0 (item not subject to VAT) is used, this has to be defined in the element VALUE_ADDED_TAX (path 1).

Element paths
path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/WEIGHT
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This element is used to specify the item weight (100 g) including packaging material. (e.g. 50 = 5000 g).
The code in the element Element ECO_MOBILIER expresses, inter alia, the weight of the price unit.
Contiguous parts are calculated in the basis of the gross weight per price unit.

Example:
An APL is calculated for each m², i.e. the weight is stated for precisely 1m² together with the code matching the weight.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VOLUME
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This element defines the volume of an item including packaging material. The basic unit of the volume is [dm³], e.g. a volume of 50 dm³ is entered as 50.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CONSTRUCTION_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [JLNRAE] |
annotation
documentation
This element defines the basic carcase shape of an item.
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the construction_ID.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
In case the item is provided by a subcontractor, the corresponding supplier number is entered in this element.

If this subcontractor item is a visible part either the elements SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO or the elements FILE_NAME_TEXTURE_1/2 have to be defined.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ITEM_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In case the item is provided by a subcontractor (SUBCONTRACTOR_ID filled in) the corresponding supplier number is entered in this element.

For the purposes of data acquisition and an optimal description and depiction of items it is recommended to fill in the subcontractor identification. The software suppliers commit themselves not to publish the subcontractor identification.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/OLD_SERIE_NO
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/OLD_TYPE_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
If the type name (combination of series_No. and type) has been changed in the course of a catalogue update, series and type information from the previous catalogue have to be filled in in this element. Only the series and/ or type name may be changed. The item in the field series_No., type must be identical with the information in the fields Old_series_No., Type_old.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FILE_NAME_TEXTURE_1
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG)) |
annotation
documentation
These elements are used to enter the file names of bitmaps for accessory textures. The files are JPEG files. Because JPEGs do not allow for an alpha channel, the RGB colour code 0,0,255 is used for masking in this case.
The elements are used depending on the value in the „CONSTRUCTION_ID“ element. The FILE_NAME_TEXTURE_1 element contains the left side illustration of the accessories, the FILE_NAME_TEXTURE_2 the right side illustration of the accessories.
CONSTRUCTION_ID = N: The texture in the „filename_texture_1" is used.
CONSTRUCTION_ID = J: There are two different options:
1. The image is mirrored along the central axle. Depending on the item, this can be the Y-axis or the Z-axis (e.g. inset sinks, cooking elements = Y and refrigerators, microwave = Z): The image showing the left side is entered in the FILE_NAME_TEXTURE_1 element.
2. The item cannot be mirrored along the central axle. The image of the left side is entered in the FILE_NAME_TEXTURE_1, while the image of the right side is entered in the FILE_NAME_TEXTURE_2 element.
CONSTRUCTION_ID = L: The value is only entered in the FILE_NAME_TEXTURE_1 element
CONSTRUCTION_ID = R: The value is only entered in the FILE_NAME_TEXTURE_2 element
The values are specified in [cccccccc.jpg] format.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FILE_NAME_TEXTURE_2
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG)) |
annotation
documentation
This element is used for defining a name for the texture bitmaps of accessories. JPEG is the standard file format. Since the alpha channel is not available in the JPEG-format, the RGB value 0,0,255 is used for masking.
The elements are used depending on the settings in the element "CONSTRUCTION_ID". The element FILE_NAME_TEXTURE_1 implies left-hand depiction of the accessory item and the element FILE_NAME_TEXTURE_2 is used to indicate a right-hand depiction.
CONSTRUCTION_ID = N: the texture defined in the element "FILE_NAME_TEXTURE_1" is used
CONSTRUCTION_ID = J: there are two possibilities:
1. A symmetrical item is mirrored on the centre line, which can be either y or z axis (e.g. sinks, cooking elements = Y and refrigerators, microwave ovens = Z): The left-hand depiction is entered into the element FILE_NAME_TEXTURE_1.
2. The item is not symmetrical and therefore cannot be mirrored: The depiction of the left-hand part is entered into element FILE_NAME_TEXTURE_1 and the depiction of the right-hand part is filled in into element FILE_NAME_TEXTURE_2
CONSTRUCTION_ID = L: only settings in element FILE_NAME_TEXTURE_1
CONSTRUCTION_ID = R: only settings in element FILE_NAME_TEXTURE_2
The general format for all settings is [cccccccc.jpg].


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MASKING
diagram
type restriction of xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
This field is of optional use, unless at least one of the elements FILE_NAME_TEXTURE_1/2is filled in.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODELING_GRAPHIC_ID
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element references a modeling graphic.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RANGE_DEPENDENT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MINIMUM_DELIVERY_TIME
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This element defines the minimum delivery time in weeks.
This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.)


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EX_FACTORY_MODIFICATION
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 2 |
annotation
documentation
This element provides information about possible alterations of an item provided by the manufacturer. Any changes of an item depend on the definitions of the basic shape in the element PARAMETERS (path 1).

0 = all measurement parameters (PARAMETERS (path 1)) are locked, changes of measurements are not possible;

1 = the measurement parameters (PARAMETERS (path 1)) may be changed according to the settings in SA500. The measurement that shall be changed is upon request;

2 = all measurement parameters (PARAMETERS (path 1)) may be changed, locked parameters require identical values in the attribute NOMINAL_VALUE (path 1), FROM (path 1) and TO (path 1).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CARCASE_BASIC_SHAPE ITEM_DIMENSIONAL_DRAWING
annotation
documentation
This element definea the basic shape of an item.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE >
diagram
properties
content complex
children BASIC_PROFILE_SHAPE BASIC_SHAPE_PARAMETERS
annotation
documentation
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information. If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels less than 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/@CARCASE_BASIC_SHAPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/@CARCASE_BASIC_SHAPE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-4][0-9]|5[0-2]|99[2-9] |
annotation
documentation
This element defines the basic shape No. of an item. Besides the predefined shape numbers, the following values are permitted:
0 = item, which has no relevant graphic information and/ or the supplier does not want this item to be depicted. If available, parameters such as width, height, depth shall be filled in, even if the item has no relevant graphic information.
If no measurements are available for items defined with basic shape 0, the parameters width, height, depth have to be set to 0.
999 = items, which have relevant graphic information but cannot be assigned to a predefined basic shape. Those items are depicted as modeling graphic (cf. element modeling_graphic_ID). Even when modeling graphic is used, the parameters width, height, depth have to be defined in RT500. Additional information on this item can be provided in the element PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SERIES/SERIES_REF/SUBCONTRACTOR_ID, SUBCONTRACTOR_ITEM_NO and File_NAME_TEXTURE_1/2.
998 = items, which do not have a basic shape and/ or no modeling graphic. In this case the element FILE_NAME_TEXTURE_1/2 requires settings.
997 = items, which neither have basic shape, nor modeling graphic, nor bitmap (FILE_NAME_TEXTURE_1/2) In this case the element SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO have to be filled in and the manufacturer has to provide graphic information from his subcontractors.
996 = items, which are graphically relevant but do not have graphic information. This basic shape No. is only valid for filling_levels less than 3.
994 = basic shape for sinks, to provide minimum dimension information. The required dimensions are: width, depth, height (distance between upper edge of worktop and upper edge of the sink) and minimum mounting height (distance between lower edge of details and lower edge of worktop).
995 = basic shape for fittings, to provide minimum dimension information. The required dimensions are: width (fitting without discharge), depth (fitting without discharge), height (fitting without discharge), discharge depth (from centre of fitting) and discharge height (upper edge of fitting minus height).
This element is required when the element BASIC_PROFILE_SHAPE is blank.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children OPTION_REF
annotation
documentation
This element defines a basic geometrical shape for a profile. The given measurements for a profile have to correspond with the parameters of the basic profile shape.
Attributes FROM (value from) and TO (value to) are only permitted for parameter B.
This element is only permitted for the following items: cornice, light pelmet, plinth, worktop, cover board, table top, upstand.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/@BASIC_PROFILE_SHAPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/@BASIC_PROFILE_SHAPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [\S ]{1,5} |
annotation
documentation
This element defines the number of the basic shape for a profile.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF >
diagram
properties
content complex
annotation
documentation
This element defines the option type and the option key of a profile shape.
The manufacturer specific key for the profile shape as indicated in the printed sales manual is used as OPTION_KEY.
Only the options types 750-756 are permitted in the element BASIC_PROFILE_SHAPE/OPTION_REF.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used for the definition of an option type.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute references an option which shall be used as basic shape for a profile.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS >
diagram
properties
content complex
children BASIC_SHAPE_PARAMETER
annotation
documentation
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm =&gt; value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element defines the values for the parameters that describe a basic shape.

Instead of filling in a 0 for the parameter basic shape, the knot BASIC_PROFILE may be omitted if no graphic information is required.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NAME

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NAME >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{1,13} |
annotation
documentation
This attribute is used for defining a name for the parameter.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NOMINAL_VALUE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NOMINAL_VALUE >
type restriction of xs:decimal
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_FROM

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_FROM >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_TO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_TO >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_STEP_SIZE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_STEP_SIZE >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING >
diagram
properties
content complex
children DOCUMENT_REFERENCE DIMENSIONAL_PARAMETERS
annotation
documentation
This element is used for the definition of dimensional drawings. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

This element is not permitted if the element BASIC_PROFILE_SHAPE is defined. Dimensional drawings for furniture elements are not permitted.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/@ITEM_DIMENSIONAL_DRAWING_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/@ITEM_DIMENSIONAL_DRAWING_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
This element is used for the definition of a dimensional drawing. The parameters are defined in the element DIMENSIONAL_PARAMETERS. Dimensional drawings depict appliances and accessory items. For sinks and electrical appliances this element is mandatory.

Even if this element is not defined at least the measurements of the bounding box (w, h, d) have to be defined in the element BASIC_PROFILES/PARAMETERS.

This element is not permitted if the element BASIC_PROFILE_SHAPE exists. This element is not permitted for furniture items, too.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DOCUMENT_REFERENCE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DOCUMENT_REFERENCE >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 240 |
annotation
documentation
This element is used for defining a document name or reference.

Documents may contain additional technical information e.g. assembly instructions, or cut-out / drilling patterns.
If only the name of the document is given, this document has to be delivered together with the catalogue data. A document reference is given by an URI/URL.

If a document reference is defined in this element, the element NAME requires the value "23" (= document reference, cf. tables).


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS >
diagram
properties
content complex
children DIMENSIONAL_PARAMETER
annotation
documentation
This element is used for assigning graphical parameters and values to an item.

All possible dimensions of an item are defined in this element in accordance with the information provided in the printed sales manual. If deviant dimensions are requested by the customer the item is defined as custom-made. The availability of custom-made items has to be requested from the individual manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are equal, neither changes of these parameters are permitted, nor custom-made items are available.

If an item is defined as electrical appliance the measurement B(Width), H(Height) and T(Depth) are required.

If necessary (e.g. for diagonal corner blinds) values for the basic shapes 21, 24 and 25 can be given in 1/10 mm. Example: 27,3 mm =&gt; value: 0027.3

This element is not required, if the basic shape NO. is set to „0“ and no dimension is defined, e.g. for items which have an effect on the price calculation but no graphical relevance (surcharge railing handle).

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element defines the values for the parameters that describe a basic shape.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NAME

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NAME >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{1,13} |
annotation
documentation
This attribute is used for defining a name for the parameter.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NOMINAL_VALUE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NOMINAL_VALUE >
type restriction of xs:decimal
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
A fixed nominal value and, optional, a pair of values (from, to) is/ are assigned to each parameter. Variable parameters are useful e.g. for the depiction of legal width reductions.
For length measurements the unit is [mm] without decimal places. Angles are measured in [°] with three digits before and after the decimal point.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_FROM

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_FROM >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This field indicates the smallest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_TO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_TO >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This field indicates the biggest measurement in which an item is available. It has to be filled in, if the measurement of the item varies within the range of these parameters. If it is not variable, the field has to be left blank.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_STEP_SIZE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_STEP_SIZE >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
For variable parameters a step size can be defined. The unit is that of the parameters. The step size has to be smaller than the calculated difference of the values from and to.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_PART
annotation
documentation
This element is used as a container element for the block parts lists in the catalogue.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children BLOCK_SEQUENTIAL_NO ITEM_REF OPTION_REF HINGE EXCHANGE_CONDITION STATUS BLOCK_ITEM_DIMENSION_WIDTH BLOCK_ITEM_DIMENSION_HEIGHT BLOCK_ITEM_DIMENSION_DEPTH CONSTRUCTION_ID
annotation
documentation
In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2)), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_SEQUENTIAL_NO

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_SEQUENTIAL_NO >
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This element defines the position of an item in the block arrangement.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF >
diagram
properties
content complex
annotation
documentation
This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute defines the feature which is referenced by a option.
Each FEATURE_NO may exist only one time in the database.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute references a option.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/HINGE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/HINGE >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[BEJLMNR] |
annotation
documentation
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/EXCHANGE_CONDITION

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/EXCHANGE_CONDITION >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 2 |
maxInclusive | 3 |
annotation
documentation
This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/STATUS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/STATUS >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [ABELSZ] |
annotation
documentation
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_WIDTH

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_WIDTH >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_HEIGHT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_HEIGHT >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_DEPTH

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/BLOCK_ITEM_DIMENSION_DEPTH >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/CONSTRUCTION_ID

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BLOCK_PARTS/BLOCK_PART/CONSTRUCTION_ID >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[JLNRAE] |
annotation
documentation
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MODULE_PART
annotation
documentation
If the relevant item is a 3-D unit, this element contains a list of parts for module elements, with the first element being a base unit with position 0 followed by the module elements from the bottom upwards. This element must be left blank if the associated item is not a 3-D unit.

The 3-D unit has a fixed price. If the 3-D unit is changed, the new price will result from the price for the base unit + the price for the modules. The 3-D unit is deleted, the base unit becomes the main position and contains all other module elements as sub-positions from the bottom upwards.

The module elements can be range or version-specific.

Rules concerning the height of module elements within the base unit can be specified via MODUL_RULE_SETS. The universally defined module rule is referenced in this case.

The base unit can be assigned this kind of rule via MODULE_RULE_SET_REF.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PART_SEQUENTIAL_NO ITEM_REF HEIGHT_VARIABLE MODULE_ITEM_DIMENSION_HEIGHT
annotation
documentation
This element corresponds to a partial list of parts for module elements of a 3-D unit. The elements must be specified in their order from bottom to top. Position 0 (PART_SEQUENTIAL_NO) is the empty base unit (cabinet type code 17) It is followed by the module elements from bottom to top (cabinet type key 10). The base unit hinges are identical to the hinges of the 3-D unit.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/PART_SEQUENTIAL_NO

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/PART_SEQUENTIAL_NO >
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This element is used to specify the item's position within the 3-D unit. The base unit (item type code 17) must include the position value of 0. The module elements (type code 10) contain additional position numbers sorted from bottom to top.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/ITEM_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/ITEM_REF >
diagram
properties
content complex
annotation
documentation
This element is used to refer to the base unit (type code 17) and the individual module elements (type code 10).
The base unit must be assigned position (PART_SEQUENTIAL_NO) 0. The remaining module elements must be referenced in the order from the bottom to the top and in line with the PART_SEQUENTIAL_NO attribute.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used to specify the item type. (e.g. U60).


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used to specify the serial number of the referenced series.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/HEIGHT_VARIABLE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/HEIGHT_VARIABLE >
diagram
type xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
If this flag is set to true(1), this means that the corresponding module element will contain changes relating to changes of other elements within the list. This means that if another module element becomes smaller or larger, the module element designated as true in HEIGHT_VARIABLE will adjust itself so that the total height of all module elements within the base unit is restored.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/MODULE_ITEM_DIMENSION_HEIGHT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_PARTS/MODULE_PART/MODULE_ITEM_DIMENSION_HEIGHT >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
A module element can be variable, but the list contains a fixed height that has to be specified for variable measurements within this element.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT
diagram
properties
content complex
children SHORT_TEXT FULL_TEXT PLANNING_ADVICE
annotation
documentation
This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT >
diagram
properties
content complex
children LANGUAGE
annotation
documentation
This element contains short text information.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
This element is used to store texts in multiple languages. An element is created for each language. The language is specified with the ISO_LANGUAGE_ID attribute. Each element in the database must be assigned the same languages. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID >
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE >
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
children TEXT
annotation
documentation
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT >
diagram
type | languagetexte
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE >
diagram
type | languagetexte60999
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains planning advices.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY
diagram
properties
content complex
children TK_TYPE TK_CLASS TK_EQUIPMENT TK_MATERIAL TK_SHAPE TK_FRONT_APPEARANCE
annotation
documentation
This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589] |
annotation
documentation
A value from the column type No., as listed in the table "Type Keys", is required in this field.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_CLASS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_CLASS >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0145679]|2[126789]|3[023467]|4[0] |
annotation
documentation
A value from the column item No., as listed in the Table "Type keys", is required in this field.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT >
diagram
properties
minOcc | 0
maxOcc | 5
content | complex
children TK_INSTALLATION_RECESS
annotation
documentation
This element is used for assigning a type key to the installation information and recess height.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@SEQUENCE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute defines the sequence in which installation information and equipment information is assigned to an item.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@TK_EQUIPMENT_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/@TK_EQUIPMENT_NO >
type restriction of xs:nonNegativeInteger
properties
use optional
facets
Kind | Value | Annotation
pattern | [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4] |
annotation
documentation
This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key", is required in this field.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children TK_INSTALLATION_INFORMATION TK_RECESS_HEIGHT
annotation
documentation
This element defines the combination of installation information (cf. table Installation information-key) and recess height.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_INSTALLATION_INFORMATION

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_INSTALLATION_INFORMATION >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789] |
annotation
documentation
A value from the column installation information, as listed in table "Installation information-key", is required in this field.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_RECESS_HEIGHT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_EQUIPMENT/TK_INSTALLATION_RECESS/TK_RECESS_HEIGHT >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_MATERIAL

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_MATERIAL >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-2] |
annotation
documentation
A value from the column type, as listed in table "Material keys", is required in this field.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_SHAPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_SHAPE >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-2] |
annotation
documentation
A value from the column shape No., as listed in the table "Shape keys", is required in this field.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_FRONT_APPEARANCE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_FRONT_APPEARANCE >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9] |
annotation
documentation
A value from the column front appearance No., as listed in the table "Front appearance key", is required in this field.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CLASSIFICATION
annotation
documentation
This element is used to store standardized classification information.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION >
diagram
properties
minOcc | 1
maxOcc | 10
content | complex
children CLASSIFICATION_CODE VALID_FROM VALID_UNTIL
annotation
documentation
Standardised information on various classification schemes is stored in this element.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
pattern | ([1-9]{1}|1[0]{2}) |
annotation
documentation
This element specifies the classification scheme. The values in the following list are available to choose from:

ID Classification scheme
1 eCl@ss
2 Begros organisation classification
3 VME organisation classification
4 Code Eco Mobilier
5 EEE eco system
6 Free classification scheme
7 Free classification scheme
8 Free classification scheme
9 Free classification scheme
10 Free classification scheme

If the scheme that is to be maintained is not in the list, then an ID from 6 is to be chosen for free classification scheme.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE >
diagram
type xs:string
properties
content simple
annotation
documentation
This elements contains the code for the category of the classification scheme that is to be assigned to the ITEM.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM >
diagram
type xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element indicates the date from which the classification specification is valid.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL >
diagram
type xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element indicates the date until which the classification specification is valid.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FRONT_GROUP
annotation
documentation
This element is used for defining the possible front divisions of an item.
Different front divisions may be related to the chosen range or built-in appliances.

Similar front divisions in different programmes may be defined in front groups. These front groups are referenced by the programmes.

All front divisions are based on the left-hand construction method. If an item is also available in right-hand construction mode, it is mirrored.If an item is also available in right-hand construction mode, it is mirrored.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP >
diagram
properties
minOcc | 1
maxOcc | 99
content | complex
children FRONT_DIVISION
annotation
documentation
This element defines different front divisions and combines them in one front group.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/@FRONT_GROUP_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/@FRONT_GROUP_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database.

If one FRONT_GROUP is valid for all programmes, the value 0 has to be set.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FRONT_DIVISION_DEF INTERNAL_ORDER_NO FRONT_CELL
annotation
documentation
This element defines a front division and describes the single cells of the front division.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_DIVISION_DEF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_DIVISION_DEF >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 250 |
pattern | [Zz]((\[[1-9]\d{0,1}\])|[ZzSs\(\)]|\d{1,}){1,} |
annotation
documentation
For the definition of the front division the syntax rules provided in the attachment apply. These syntax rules are not used for the description of front divisions for shelves. Shelves are defined as a separate front cell (cf. FRONT_CELL/PARAMETER_1/2).


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/INTERNAL_ORDER_NO

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/INTERNAL_ORDER_NO >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
For items which have different front divisions and only one order number in the catalogue, internal order numbers for the different front divisions are entered in this field.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FRONT_CELL_NO FRONT_TYPE HANDLE_POSITION_1 HANDLE_POSITION_2 HANDLE_ORIENTATION_1 HANDLE_ORIENTATION_2 PARAMETER_1 PARAMETER_2 MOUNTING_HEIGHT_FROM MOUNTING_HEIGHT_TO OFFSET_ABOVE OFFSET_BELOW OFFSET_LEFT OFFSET_RIGHT HINGE_BEHAVIOR UPPER_JOIN LOWER_JOIN LEFT_JOIN RIGHT_JOIN DOUCINE_POSITION
annotation
documentation
This element defines the single cells of a front division.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/FRONT_CELL_NO

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/FRONT_CELL_NO >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
This attribute defines the No. of the cell which has to be described. The cell No. is defined in the front division (FRONT_DIVISION_DEF).


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/FRONT_TYPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/FRONT_TYPE >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 900 |
annotation
documentation
This element defines the front type of the cell. A front element is assigned by the front type (cf. element GLOBAL_DEFINITION/.../FRONT_APPEAREANCE)

The following front types can be assigned:

1 - 100 = doors
101 - 200 = drawers
201 - 300 = pull-outs
301 - 400 = flap doors
401 - 450 = recess with blind
451 - 500 = recess without blind
501 - 550 = open compartment/compartment recess
551 - 600 = shelves
601 - 650 = fixed blinds
651 - 700 = control panel blinds
701 - 750 = shutters
751 - 800 = roller shutter fronts
801 - 900 = miscellaneous


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/HANDLE_POSITION_1

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/HANDLE_POSITION_1 >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-3]|2[0-5] |
annotation
documentation
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L".


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/HANDLE_POSITION_2

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/HANDLE_POSITION_2 >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-9]|1[0-3]|2[0-5] |
annotation
documentation
The following handle positions are possible while these are specified with the following value:

The exact position of bar handles is defined by the given handle position and the corresponding handle orientation (cf.field HANDLE_ORIENTATION_1/2 and variation type 304) If the field door closing is set to "J" (door closing upon request), the handle position in this field is set to "L".


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/HANDLE_ORIENTATION_1

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/HANDLE_ORIENTATION_1 >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 4 |
annotation
documentation
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/HANDLE_ORIENTATION_2

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/HANDLE_ORIENTATION_2 >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 4 |
annotation
documentation
This element defines the corresponding handle orientations:

1 = horizontal -
2 = vertical |
3 = diagonally falling \
4 = diagonally rising /

Handle orientations 1 and 2 are only used when the handle orientation differs from the defined handle orientation in variation type 304.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/PARAMETER_1

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/PARAMETER_1 >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/PARAMETER_2

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/PARAMETER_2 >
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
The elements PARAMETER_1 and PARAMETER_2 indicate the number of visible shelves e.g. for open shelves, glass door cabinets.
PARAMETER_1 indicates the number of horizontal shelves.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/MOUNTING_HEIGHT_FROM

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/MOUNTING_HEIGHT_FROM >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/MOUNTING_HEIGHT_TO

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/MOUNTING_HEIGHT_TO >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
The elements MOUNTING_HEIGHT_FROM and MOUNTING_HEIGHT_TO define the minimum and maximum mounting height [mm] for an appliance. The resulting height of the niche determines the front division of the cabinet and the choice of a fitting appliance. In case only one front division is given for one cabinet, the defined range of values is used to determine, if the selected appliance is fitting in or not. If different front divisions are given for one item the defined range of values is used to define the suitable front division for the selected appliance.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/OFFSET_ABOVE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/OFFSET_ABOVE >
diagram
type xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/OFFSET_BELOW

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/OFFSET_BELOW >
diagram
type xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/OFFSET_LEFT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/OFFSET_LEFT >
diagram
type xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell 3) clearance depends on the hinge (cf. field hinge behaviour)


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/OFFSET_RIGHT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/OFFSET_RIGHT >
diagram
type xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
1) positive offset = front element is smaller than the modular dimension of the cell
2) negative offset = front element is larger (projecting) than the modular dimension of the cell
3) clearance depends on the hinge (cf. field hinge behaviour)


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/HINGE_BEHAVIOR

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/HINGE_BEHAVIOR >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 4 |
annotation
documentation
0) no mirroring
1) mirroring only when the hinge is changed
2) mirroring only when the construction ID is changed
3) mirroring when either hinge OR construction ID is changed
4) mirroring when hinge AND construction ID are changed.

The rules are defined in the header and examples are given.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/UPPER_JOIN

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/UPPER_JOIN >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[VLSG] |
annotation
documentation
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/LOWER_JOIN

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/LOWER_JOIN >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[VLSG] |
annotation
documentation
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/LEFT_JOIN

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/LEFT_JOIN >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[VLSG] |
annotation
documentation
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/RIGHT_JOIN

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/RIGHT_JOIN >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[VLSG] |
annotation
documentation
This element indicates if adjacent front cells are jointed or not. In case this field is left blank, the elements are not jointed.

V = pinned
L = strapped
S = hinge (for folding and flap doors)
G = mitre


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/DOUCINE_POSITION

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_DIVISION/FRONT_CELL/DOUCINE_POSITION >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
This element defines the position of the doucine

1) = horizontal
2) = vertical


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_APPEARANCE_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element is used for assigning a front appearance to an item. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.
Front appearances which are assigned to this element are not dependent on a programme.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_APPEARANCE_REF/@FRONT_APPEARANCE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_APPEARANCE_REF/@FRONT_APPEARANCE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This element is used to define the relationship between the version defined in the data record and a front type.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SET_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SET_REF/@MODULE_RULE_SET_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SET_REF/@MODULE_RULE_SET_NO >
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute defines the number of the rule set which references an item to the corresponding rule set.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MODULE_RULE_SET
annotation
documentation
This element is used for defining a set of rules for module elements. If an item is defined as a module element (type key = 10) the rules for planning this item are defined in this element. It is only possible to define either the element MODULE_RULE_SET_REF or the element MODULE_RULE_SETS.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children MODULE_RULES MODULE_RULE_SET_REF
annotation
documentation
This element assigns a set of rules to a module element. The element MODULE_RULE_SET_NO references each set of rules to the related module housing element. Therefore it is possible to define different set of rules for one item depending on the selected module housing element.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULES

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULES >
diagram
properties
content complex
children MODULE_RULE
annotation
documentation
This element defines a set of rules for the installation of single modules into a module cabinet.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULES/MODULE_RULE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULES/MODULE_RULE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children MODULE_POSITION MAX_VALUE MIN_VALUE
annotation
documentation
A rule for the installation of a module into a module cabinet.
This rule defines whether the installation of a module element into the selected module housing element is permitted or not.

Type key 10 is required for module elements.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULES/MODULE_RULE/MODULE_POSITION

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULES/MODULE_RULE/MODULE_POSITION >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | LINE_BOTTOM|LINE_TOP |
enumeration | LINE_BOTTOM |
enumeration | LINE_TOP |
annotation
documentation
This element defines the values which have to be checked.

LINE_BOTTOM Bottom line of the module element in mm
LINE_TOP Top line of the module element

The control process requires settings MIN_VALUE or MAX_VALUES .


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULES/MODULE_RULE/MAX_VALUE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULES/MODULE_RULE/MAX_VALUE >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
This serves to define the maximum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULES/MODULE_RULE/MIN_VALUE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULES/MODULE_RULE/MIN_VALUE >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
This serves to define the minimum value as per specifications. Any numerical value and "99999" is permitted. "99999" means the height of the casing at the upper and lower edge.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF >
diagram
properties
content complex
annotation
documentation
This element references a rule set MODULE_RULE_SET_DEFINITION under T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS and the module housing units which are subject to this rule set.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/@MODULE_RULE_SET_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MODULE_RULE_SETS/MODULE_RULE_SET/MODULE_RULE_SET_REF/@MODULE_RULE_SET_NO >
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute defines the reference between the rule set and the MODULE_RULE_SET_DEFINITION and the related module housing units.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element summarizes all hyperlinks providing detail information for an item.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references hyperlinks to detail information.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
This attribute is used for defining the identification number of the referenced detail information.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PROPERTIES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PROPERTY_REF
annotation
documentation
This element is used for summarizing the item specific characteristics.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PROPERTIES/PROPERTY_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PROPERTIES/PROPERTY_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references a characteristic which is defined under GLOBAL_DEFINITION/PROPERTIES.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PROPERTIES/PROPERTY_REF/@PROPERTY_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PROPERTIES/PROPERTY_REF/@PROPERTY_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute references a characteristic.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PROPERTIES/PROPERTY_REF/@VALUE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PROPERTIES/PROPERTY_REF/@VALUE >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?) |
annotation
documentation
This attribute defines a value for the characteristic.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children RESTRICTION_REF
annotation
documentation
This element is used for combining all restrictions which apply to one product group.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references a restriction which is assigned to a product group.


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF/@RESTRICTION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
This attribute references item specific restrictions.


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF/@SEQUENCE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...).


 element T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DEFAULT_OPTION_GROUP
annotation
documentation
In this record type, default values for series variations are given as proposals resp. decision support for the user. The proposals made here have to be defined as legal combinations.


 element T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children DEFAULT_OPTION_GROUP_NAME FILE_NAME OPTION_REF DETAIL_INFOS
annotation
documentation
This element defines a standard proposal.
Each feature type may be referenced only one time in the DEFAULT_OPTION_GROUP.


 attribute T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP/@DEFAULT_OPTION_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute defines a numerical counter for the default group.


 element T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP/DEFAULT_OPTION_GROUP_NAME
diagram
type | languagetexte30
properties
content complex
children | LANGUAGE
annotation
documentation
This element contains a freely defined name for the default option, e.g. defined by the user of the planning software.


 element T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP/FILE_NAME
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG)) |
annotation
documentation
This element contains the filename of a JPEG-file which is used as an example of the default option.


 element T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP/OPTION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references the features which are combined in the default option.


 attribute T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute defines the feature type of the referenced feature.


 attribute T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute defines the reference between the feature and the default option.


 element T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element is used for defining pictures which are subordinated to the the standard proposal.


 element T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used for referencing the detail information.


 attribute T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used for defining the identification number of the referenced detail information.


 element T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element is used for defining detailed media information, e.g. photographs, PDF files, video hyperlinks which refer to a series.


 element T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used for referencing the detail information.


 attribute T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced detail information.


 element T_NEW_CATALOG/SERIES/RESTRICTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children RESTRICTION_REF
annotation
documentation
This element is used for summarizing the global restrictions.


 element T_NEW_CATALOG/SERIES/RESTRICTIONS/RESTRICTION_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element references global restrictions.


 attribute T_NEW_CATALOG/SERIES/RESTRICTIONS/RESTRICTION_REF/@SEQUENCE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element defines the sequence in which the different restrictions are processed. Different values in the the field SEQUENCE_NO are required and an intersection of the different restrictions is made up.
The sequence has to be defined in ascending order which may have gaps (e.g. 1,3,10, ...).


 attribute T_NEW_CATALOG/SERIES/RESTRICTIONS/RESTRICTION_REF/@RESTRICTION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
This attribute references global (i.e. not depending on series) restrictions.


 element T_NEW_CATALOG/FEATURE_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FEATURE_CLASSES FEATURES OPTION_DEFINITION RESTRICTIONS SUGGESTIONS
annotation
documentation
All information which is depending on the different variations is defined in this element.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES
diagram
properties
content complex
children FEATURE_CLASS
annotation
documentation
In this element features are grouped into feature classes. By using feature classes different checks concerning plausibility and completeness of the valid variation types can be processed.

Feature classes can be assigned to series, programmes, or product groups. There is no priority to any of these assigned levels. The total number of valid features for one item results from the sum of features which are defined for the feature class of the programme and the feature class of the item. Feature classes which are referenced from the element FEATURE_CLASS_REF(path 1), may only contain features which are defined as header features in the element FEATURES (path 2).

All features referenced by the elements PRICE_FEATURE_GROUP (path 3), PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 4) and FINISH (path 5) have to occur in the feature class of an item.

Also the features used from the elements RESTRICTION_REF (path 6), RESTRICTION_REF (path 1) and RESTRICTION_REF (path 8)have to be part of the feature class of an item.

Element paths:
1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
path 2: FEATURE_DEFINITION
path 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
path 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
path 6: SERIES/SERIE/RESTRICTIONS
path 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FEATURE_REF
annotation
documentation
This element defines the variations of a programme.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/@FEATURE_CLASS_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies the variations of a programme as a feature class.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/FEATURE_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
The feature class refers to the element FEATURE (path 1) .
Only logical and meaningful variations may be referenced in the feature class of an item, e.g. a variation class for shelves must not contain feature types of handles.

Element paths
Pfad 1: FEATURE_DEFINITION/FEATURES


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/FEATURE_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used for referencing a feature class.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES
diagram
properties
content complex
children COMBINED_FEATURE FEATURE
annotation
documentation
This element defines the variation types (FEATURE) and the assigned variations. This element contains only those features which are necessary for the specific catalog.

Except for the combination features and the features 701 and 703 all features are defined by the combination of finish and colour.

Features have necessarily to be defined as pairs, i.e. each finish feature requires a corresponding colour feature and vice versa.

Only the features 701 and 703, which do not require a definition of colour features, are exceptions to this rule.

Features &gt; 950 are only relevant for the modeling graphic and must not be defined as combination variations.

Feature combinations in the catalogue (e.g. veneer green) have to be defined in the element COMBINED_FEATURE (path 1).

All feature details used in the element COMBINED_FEATURE (path 1) have to be defined as invisible header features (HEADER_POS_VARIATION_TYPE (path 2) = U).

Features which are defined as invisible must not be referenced by any feature class.

All variation types which are not marked as invisible header features in the element FEATURES (path 3), have to be referenced by at least one feature class.

Certain MUST_FEATURES are defined which are basically required. In general these features are not sufficient for a complete description of the catalogue. The assignment of a type key and a MUST-feature is defined in the table "type key - MUST features".
Further information about features is provided in the chapter "Remarks for the correct use of features"

This element is mandatory for kitchen furniture manufacturers (SUPPLIER/BRANCH_ID = K).

Element paths
path 1: FEATURE_DEFINITION/FEATURES
path 2: FEATURE_DEFINITION/FEATURES/FEATURE
path 3: FEATURE_DEFINITIO


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/COMBINED_FEATURE
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTION_REF
annotation
documentation
This element is used for grouping single features into feature combinations. In these combinations each feature is a detail feature.

If combined features are used, variation checks and assignments may only be applied to the defined combined features and not to the subordinated detail features.

Detail features have to be defined as invisible in the element HEADER_POS_VARIATION_TYPE (path 1). These may only be used in the element OPTION (path 2).

If a combined feature has been defined, it has to be used continuously. For example: if a combined feature with feature type 303 and and detail feature 301 and 302 has been defined, all further features for handles have to be defined as combined features with feature type 303, too.

Regarding the software processing of combined features the following conventions apply: for monocoloured fronts a combined feature with feature type front colour 1 (101) is defined. The colour of this feature is inherited to feature type front colour 2 (102).

If the combined feature is a handle combination (feature type 303), at least feature type 300 and feature type 301 or 302 have to be assigned to this combined feature.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE
path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/COMBINED_FEATURE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | (105)|(115)|(125)|(201)|(303) |
annotation
documentation
This attribute is used for referencing a feature.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/COMBINED_FEATURE/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used for referencing a option.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/COMBINED_FEATURE/OPTION_REF
diagram
properties
minOcc | 2
maxOcc | 5
content | complex
annotation
documentation
This element references the features which are combined.

Feature types &gt; 950 are only used for the modeling graphic and may not be defined as combined features.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/COMBINED_FEATURE/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | 10[012346]|11[01234]|12[01234]|20[02345]|30[012] |
annotation
documentation
This attribute is used for referencing a feature.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/COMBINED_FEATURE/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used for referencing a option.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTIONS FEATURE_TEXT SEQUENCE_NO HEADER_POS_VARIATION_TYPE INHERIT_VARIATION_TYPE_REF
annotation
documentation
This element defines a feature.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies a feature.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTION
annotation
documentation
This element is used as a container for all possible options of a feature type.
For inheriting features types (HEADER_POS_VARIATION_TYPE=V) this element is not defined.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children STYLE_REF MATERIAL_REF HANDLE_ORIENTATION_REF FORM_REF OPTION_MEASURE_REF HANDLE_POSITION_REF OPTION_TEXT OPTION_COMMENT_TEXT VALID_FROM VALID_UNTIL MINIMUM_DELIVERY_TIME FRONT_APPEARANCE_REF DETAIL_INFOS
annotation
documentation
This element defines the features of a feature class. All features of the complete database are defined in this element. In case of a finish option (cf. table standard variations, flag "A") neither texture (TEXTUR)nor colour values (COLOR) are permitted. The assignment of brightness and transparency is optional. In case they are defined they have priority over the colour variations.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
This attribute defines a sort order for the features. This attribute does not have to be used continuously. The sort order criterion may be be applied to all features.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/STYLE_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a range.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/STYLE_REF/@STYLE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute defines the referenced programme. The attribute STYLE_NO refences to the element STYLE (path 1).

Path1: FEATURE_DEFINITION/OPTION_DEFINITION/


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/MATERIAL_REF
diagram
properties
content complex
annotation
documentation
This element references a material.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/MATERIAL_REF/@MATERIAL_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute references a material.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/HANDLE_ORIENTATION_REF
diagram
properties
content complex
annotation
documentation
This element references a handle orientation.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/HANDLE_ORIENTATION_REF/@HANDLE_ORIENTATION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This attribute defines a handle option.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FORM_REF
diagram
properties
content complex
annotation
documentation
This element references a shape.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FORM_REF/@FORM_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute references a basic profile shape.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_MEASURE_REF
diagram
properties
content complex
annotation
documentation
This element references special dimensions of a feature class. Currently this element can only be used to indicate the different plinth heights (feature 402).


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_MEASURE_REF/@OPTION_MEASURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute identifies the referenced dimension option.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/HANDLE_POSITION_REF
diagram
properties
content complex
annotation
documentation
This element references a handle position.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/HANDLE_POSITION_REF/@HANDLE_POSITION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
totalDigits | 3 |
annotation
documentation
This attribute references a handle position.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used for defining a text concerning a option.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_COMMENT_TEXT
diagram
type | languagetexte60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element references a general comment which provides information about a option. It is only used for the purpose of user-friendliness and must not contain any order relevant information as this text information is not processed by the software.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Fields named VALID_TO must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element defines the period of validity for the features.
In case the validity has expired, a warning note is displayed in the planning system. Anyhow, the feature can be used for further planning purposes. The following rules apply to possible combinations in this element:
• both fields filled in: in feature is available within the given period.
• both fields blank: feature is available without any time restrictions.
• only the element VALID_FROM is filled in: feature is available from this date on.
• only the element VALID_UNTIL is filled in: feature is only available up to the specified date.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Elements named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/MINIMUM_DELIVERY_TIME
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This element defines the minimum delivery time in weeks. This is only a text information which is not processed by the EDP software, e.g. delay of order, part order etc.)


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element defines a reference between feature and front appearance. A front appearance referenced here has to be defined in the element path1/FRONT_APPEARANCE.

This element may be used when feature "glass frame door" (FEATURE_NO = 154) is defined in path2/FEATURE_NO.

For data processing the following rules apply:
If an item is available with glass door, i.e. feature 154 is an element of the feature class of this item, the FRONT_APPEARANCE_NO of this element is used. If the item has no glass door path3/FRONT_APPEARANCE_REF is used.

This element has to be filled in from filling level 2b on.

Element paths:
path1 = GLOBAL_DEFINITION/FRONT_APPEARANCES
path2 = FEATURE_DEFINITION/FEATURES/FEATURE
path3 = SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITE


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/FRONT_APPEARANCE_REF/@FRONT_APPEARANCE_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute defines a specific ID for a front appearance which is referenced by styles and items.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element summarizes all hyperlinks providing detail information for an item.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references hyperlinks to detail information.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
This element references hyperlinks to detail information.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TEXT
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
This element contains text information for the different features.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/SEQUENCE_NO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This element defines a manufacturer specific classification for the feature types.
This classification is a recommendation of the manufacturer, the retailers may use different classifications. The classification is used for a better legibility and display of data on the screen or in print-outs.
In case a classification is defined here, this has to unambiguous and it has to be applied to all data sets.
The field classification must not be filled in if invisible header features (HEADER_POS_VARIATION_TYPE = U (path1)), are used

Element paths
path1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [IKUPV] |
annotation
documentation
This element is used for distinguishing the different feature types
I = implicit variation,
K = header variation,
U = invisible header variation,
P = position variation type or
V = inheriting variation type.

These different types are used to control the software processing of variation types; Variation types marked with "P" may only occur on position level but not in the header.
Invisible header variations may only be used in the elements OPTION (path 1) and COMBINED_FEATURE (path 2).

For variation types that inherit information from another variation type the flag "V" is used. The process of inheritance is only applied within the same item, therefore this flag may only be used for variation types 202, 203, 205 and 208. If the flag "V" is set, the
element INHERIT_VARIATION_TYPE_REF (path 3) requires an entry. Legal entries to be used here are 202, 203, 205 or 208, marked with the flag "K" or "P" in the element HEADER_POS_VARIATION_TYPE (path 3).
Inheriting variation types must not be used in any other record type.
Variations marked with "I" are invisible variations which are used for control procedures. Currently the mark "I" is only used for variation type 305 = drilling pattern.

Element paths
path 1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
path 2: FEATURE_DEFINITION/FEATURES
path 3: FEATURE_DEFINITION/FEATURES/FEATURE


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/INHERIT_VARIATION_TYPE_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references the feature type from which information is inherited.
Feature types 202, 203, 205 and 208 may inherit information among each other.
Feature types used here must not contain the flag „invisible“


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/INHERIT_VARIATION_TYPE_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | (202)|(203)|(205)|(208) |
annotation
documentation
This attribute defines the referenced feature.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION
diagram
properties
content complex
children STYLE HANDLE_ORIENTATION MATERIAL FORM OPTION_MEASURE
annotation
documentation
This element is used for defining the different variations of colours, materials, handles, shapes,and programmes.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children FRONT_DEPTH FRONT_DISTANCE FRONT_APPEARANCE_REF FRONT_GROUP_REF FEATURE_CLASS_REF DEFAULT_OPTION_GROUP_REF RESTRICTIONS
annotation
documentation
This element is used for the definition of programmes/ styles in a catalogue.
Styles are created as features in the element STYLE_REF (path1). A style is defined by feature type 1 (FEATURE_NO = 1).

The attributes of a style must not vary within one series. As a style is only defined in this element and referenced by the series, the aforementioned condition is represented by the structure.

This element is an optional one, if the element SUPPLIER/BRANCH_ID contains the values "G" or "Z".

P1: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
P2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
P3: FEATURE_DEFINITION/FEATURES


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/@STYLE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute defines a manufacturer specific key for a style. It is referenced by the attribute STYLE_NO in the element STYLE (path1).

P1: FEATURE_DEFINITION/OPTION_DEFINITION/


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_DEPTH
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
This element defines the specific depth of a style in [mm]. The default value is 20 mm..
Values in this field are required when the element FRONT_APEREANCE_NO (path1) is filled in.

path1: FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_DISTANCE
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
This element is used to define the range-specific door buffer [mm]. It represents the distance between the door and the carcase behind it.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element assigns a front appearance to a style. This element references the attribute GLOBAL_DEFINITION/FRONT_APPEARANCES/FRONT_APPEAREANCE/FRONT_APPEARANCE_NO.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_APPEARANCE_REF/@FRONT_APPEARANCE_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute defines a specific ID for a front appearance which is referenced by styles and items.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_GROUP_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element is used for assigning a front group to a style.
Several styles which have the same front appearance can be grouped in one front group.
This element references the attribute SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/FRONT_DIVISIONS/FRONT_GROUP/FRONT_GROUP_NO.
For manufacturer catalogues in which the front divisions of the cabinets depend on the different styles a definition of front groups is required.
In some manufacturer catalogues the front divisions of cabinets do not vary in the different styles. In these cases no front group definition is required.
In many cases all traditional style fronts can be grouped into one front group. This is due to the fact that the front divisions of tall cabinet front doors have a similar pattern in traditional styles.
This rule is not applied to cabinets which have different front divisions depending on the varying sizes of appliances.
In case a front group has been defined for one style, front groups have to be assigned to all styles.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FRONT_GROUP_REF/@FRONT_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
This attribute defines a specific ID which references the front groups to the styles. This ID has to be unique and unambiguous for all items of the database.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FEATURE_CLASS_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/FEATURE_CLASS_REF/@FEATURE_CLASS_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This element references a feature class.

The feature class is defined in the element FEATURE_CLASS (path1) and is identified by the attribute FEATURE_CLASS_NO.

The feature class is the superordinated set of all kinds of variations. It comprises all feature types of all feature classes in this series. The sum of mandatory features for one item results from the different number of feature classes, referenced in the element PRODUCT_GROUP.

path1: FEATURE_DEFINITION/FEATURE_CLASSES/


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/DEFAULT_OPTION_GROUP_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element assigns default options to a style.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/DEFAULT_OPTION_GROUP_REF/@DEFAULT_OPTION_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
This attribute references a default option.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/RESTRICTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children RESTRICTION_REF
annotation
documentation
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/RESTRICTIONS/RESTRICTION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/RESTRICTIONS/RESTRICTION_REF/@RESTRICTION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element references a certain restriction which is applied to a style (style dependent restriction).

A restriction which is referenced by a style may not be referenced from neutral levels, e.g. series, global, at the same time.

The number of variations selected in the planning system is only valid if none of the combinations is excluded by any of the test procedures, i.e. an intersection of feature combinations.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/STYLE/RESTRICTIONS/RESTRICTION_REF/@SEQUENCE
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element defines the sequence in which the different test procedures are performed. Several restriction can be grouped (set union), if the value filled in in the element SEQUENCE is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10, ...)


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/HANDLE_ORIENTATION
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children DEFAULT_HANDLE_ORIENTATION_REF
annotation
documentation
This element defines a handle orientation.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/HANDLE_ORIENTATION/@HANDLE_ORIENTATION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This attribute identifies a handle option.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/HANDLE_ORIENTATION/DEFAULT_HANDLE_ORIENTATION_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element defines a variation of the basic handle position. It references a basic handle position defined in the element BASIC_HANDLE_POSITIONS (path 1).

The manufacturer specific name for this position is defined in the element OPTION_KEY (path 2).

The element default handle position has to be filled in if variation type 304 (handle position) is set in the element FEATURE (path 3).

Element paths
path 1: GLOBAL_DEFINITION/FRONTS_HANDLE_POSITIONS
path 2: FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
path 3: FEATURE_DEFINITION/FEATURES


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/HANDLE_ORIENTATION/DEFAULT_HANDLE_ORIENTATION_REF/@SPECIFIC_HANDLE_ORIENTATION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute defines a standard handle position.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children COLOR TEXTURE TRANSPARENCY BRIGHTNESS
annotation
documentation
This element defines a material.

In case of a finish option, (cf. table Standard variation types flag "A"), neither texture (TEXTURE) nor colour (COLOR) values are permitted.

Finish options are defined in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/@MATERIAL_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute identifies a material.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR
diagram
properties
content complex
children RGB_RED RGB_GREEN RGB_BLUE
annotation
documentation
This element defines colours.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR/RGB_RED
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 255 |
annotation
documentation
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR/RGB_GREEN
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 255 |
annotation
documentation
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR/RGB_BLUE
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 255 |
annotation
documentation
This element defines the primary colour (diffuse reflection) for a material with a specific RGB value. This can be used for monocoloured materials only.
0 = no colour component
255 = full colour component
If one colour value has been set, all colour values as well as the elements TRANSPARENCY and BRIGHTNESS have to be filled in. The elements TEXTURE_REPEAT and MASKING habe to be left blank.
If the field feature indicates a colour variation either these fields or the element FILENAME_TEXTURE has to be defined.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/TEXTURE
diagram
properties
content complex
children FILE_NAME_TEXTURE TEXTURE_REPEAT MASKING TEXTURE_DELIVERED_ORIENTATION
annotation
documentation
This element defines information about the textures.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/TEXTURE/FILE_NAME_TEXTURE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | |[0-9a-zA-Z_]{1,60}\.((jpg)|(JPG)) |
annotation
documentation
This element defines references to material textures.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/TEXTURE/TEXTURE_REPEAT
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children REAL_MEASUREMENT_X REAL_MEASUREMENT_Y
annotation
documentation
This element defines if a texture is applied to a material only one time or repeatedly. If a texture repeat is required, this element is defined and the settings are applied to all child elements, too.
According to the basic texture size (DPI, number of pixels) the repeat factor is calculated automatically by the software programme.
If the element FILENAME_TEXTURE is filled in, this element is required, too.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/TEXTURE/TEXTURE_REPEAT/@TEXTURE_TILE
type restriction of xs:int
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 1 |
annotation
documentation
This attribute defines if a texture is applied to a material only one time (0 = no repeat) or several times (1 = repeat).


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/TEXTURE/TEXTURE_REPEAT/REAL_MEASUREMENT_X
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This element defines the dimensions of the texture in X direction. The values are given in mm.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/TEXTURE/TEXTURE_REPEAT/REAL_MEASUREMENT_Y
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This element defines the dimensions of the texture in Y direction. The values are given in mm.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/TEXTURE/MASKING
diagram
type restriction of xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element defines if a texture is masked, i.e. marked areas are excluded from the rendering process.
0 = no masking
1 = masking
The RGB value 0, 0, 255 is used to define the masking.
If the element FILENAME_TEXTURE is filled in, this element is required, too.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/TEXTURE/TEXTURE_DELIVERED_ORIENTATION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | |[HV] |
annotation
documentation
This attribute identifies a default handle position.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/TRANSPARENCY
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9 |
annotation
documentation
This element defines the degree of transparency for a material RGB value or texture).
0 = opaque
9 = max. transparency
If this element is a colour variation settings in this field are required.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/BRIGHTNESS
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9 |
annotation
documentation
This element defines the degree of brightness for a material (RGB value or texture).
0 = opaque
8 = high gloss
9 = reflection
If this element is a colour variation settings in this field are required.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/FORM
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PROFILE_KEY
annotation
documentation
This element is used to define a variation of a shape.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/FORM/@FORM_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute identifies the shape of a profile.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/FORM/PROFILE_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This element defines the manufacturer specific key for a profile shape. This element is used for building the variation types 750-756. Only these variation types 750-756 can use the element FORM. The different variations are referenced by the item (ITEM) which represents the profile.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PLINTH_HEIGHT STANDARD_PLINTH
annotation
documentation
This element defines measurement information for different features, e.g. plinth height (feature type 402).


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/@OPTION_MEASURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute identifies the dimensions of an appearance.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/PLINTH_HEIGHT
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
This element defines the plinth height in mm.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/STANDARD_PLINTH
diagram
type xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to specify whether the relevant plinth height is a standard value or if it is different from the standard. If the value is set to false(0), the plinth height is different from the standard height and may incur an additional price for the plinth feet.

A missing element corresponds to the value true(1).

This element must be specified if there are linked articles with allocation type CLASS = 21.


 element T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children RESTRICTION
annotation
documentation
This element is used for the definition of restrictions.


 element T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION
diagram
properties
minOcc | 1
maxOcc | 99999
content | complex
children RESTRICTION_NAME_TEXT OPTION_COMBINATION TEST_ID
annotation
documentation
This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@RESTRICTION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute identifies restrictions unambiguously.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@FEATURE_1_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@FEATURE_2_NO
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@FEATURE_3_NO
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/@VALIDATION_TYPE
type restriction of xs:int
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 1 |
annotation
documentation
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405)


 element T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/RESTRICTION_NAME_TEXT
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used for the definition of a name for a control procedure.


 element T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTION_REF MAX_DIMENSION MIN_DIMENSION
annotation
documentation
This element is used for the definition of a variation combination.


 element T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/OPTION_REF
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
annotation
documentation
This element is used for referencing the variation types which are used in the control procedures.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used for referencing a feature.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used for referencing a option.


 element T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MAX_DIMENSION
diagram
properties
minOcc | 0
maxOcc | 3
content | complex
annotation
documentation
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MAX_DIMENSION/@DIMENSION_TYPE
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [WHD] |
annotation
documentation
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MAX_DIMENSION/@DIMENSION_VALUE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES


 element T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MIN_DIMENSION
diagram
properties
minOcc | 0
maxOcc | 3
content | complex
annotation
documentation
This element defines the minimum dimension in which an option is available.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MIN_DIMENSION/@DIMENSION_TYPE
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [WHD] |
annotation
documentation
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_COMBINATION/MIN_DIMENSION/@DIMENSION_VALUE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This element defines the minimum dimension in which an option is available.


 element T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/TEST_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted


 element T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SUGGESTION
annotation
documentation
This element is used to specify default values.


 element T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION
diagram
properties
minOcc | 1
maxOcc | 99999
content | complex
children SUGGESTION_NAME_TEXT OPTION_COMBINATION
annotation
documentation
This element is used to define and describe default values for version types with certain versions.

This option to set default values is only provided for head versions and becomes effective when a planning is recorded for the first time.

Similar to a standard proposal (DEFAULT_OPTION_GROUP), it is referenced below the series, with the standard proposal assigned a higher priority.

OPTION_COMBINATION can be used to make pairs of versions for version-specific default values available.

The version type specified at FEATURE_1_NO has the highest priority.

The default values must not conflict with the associated checks.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION/@SUGGESTION_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute assigns unique identifiers to sets of default values.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION/@FEATURE_1_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION/@FEATURE_2_NO
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION/@FEATURE_3_NO
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO are used to specify the version types used in the default values.


 element T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION/SUGGESTION_NAME_TEXT
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to specify the description of a set of default values.


 element T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION/OPTION_COMBINATION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTION_REF
annotation
documentation
This element is used to form a version combination for default values.


 element T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION/OPTION_COMBINATION/OPTION_REF
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
annotation
documentation
This element is used to reference variants that are specified in default settings.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION/OPTION_COMBINATION/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute references the version type.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION/OPTION_COMBINATION/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute references the variant type.


 element T_NEW_CATALOG/PRICE_DEFINITION
diagram
properties
content complex
children PRICE_FEATURE_GROUPS SET_OF_EXCHANGE_IDS VALUE_ADDED_TAXES IDENT_NUMBERS MERCHANDISE_GROUP PRICE_TYPES
annotation
documentation
This element is used for providing all the information which is necessary for a correct calculation of prices, e.g. pricing tables and finish groups.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS
diagram
properties
content complex
children PRICE_FEATURE_GROUP
annotation
documentation
This element is used to defind the price feature groups.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_TEXT FINISH
annotation
documentation
This element contains all relevant pricing information. The settings in the element PRICE_FEATURE_GROUP define specific conditions (e.g. feature combinations) for the item price.

Each item references one PRICE_FEATURE_GROUP. The exact price information is defined on item level.

The following rules for price feature groups or items apply:
- Neutral items, not depending on a price feature group, cannot have features
- for items, depending on features, settings in the fields feature type 1 (style) and optionally the variation type 101 (front colour 1) or 105 (front combination)are required.
- items depending on features require one or two feature types
- each item has to reference exactly one basic price group (ADDITIONAL_PRICE=0)

Similar combinations of feature types for different price feature groups are not permitted, e.g. there should be only one PRICE_FEATURE_GROUP with feature type handle variation, which covers everything having to do with handle variations.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@PRICE_FEATURE_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute identifies a PRICE_FEATURE_GROUP.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@ADDITIONAL_PRICE
type restriction of xs:boolean
properties
use required
annotation
documentation
This attribute is used for defining the different price types, e.g. basic price or additional price. (0 = basic price, 1= additional price):
If an additional price group is defined (ADDITIONAL_PRICE=1), the option "price on request" is not permitted. For items which refer to this additional price group the element PRICE_ON_REQUEST (path 1) is not permitted.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_ON_REQUEST


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@PRICE_CALC_METHOD
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 3 |
annotation
documentation
This attribute is used for defining the basic price calculation method.

The following methods are defined:

0 = price on request;
1 = neutral item; price not depending on style or series
2 = price depending on style or series;
3 = price depending on finish.

A PRICE_FEATURE_GROUP which contains the value 0 (price on request) in the attribute PRICE_CALC_METHOD may occur only one time.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@FEATURE_NO_1
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies the feature type 1.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_1.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@FEATURE_NO_2
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies the feature type 2.
The combination which is defined in the attribute OPTION_REF/FEATURE_NO may not differ from the settings in the attribute FEATURE_NO_2.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_FEATURE_GROUP_TEXT
diagram
type | languagetexte60
properties
content complex
children | LANGUAGE
annotation
documentation
This element provides text information for the finish groups.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTION_REF PRICE_FIELD BLOCK_PRICE_FIELD SUPPLIER_PRICE_GROUP
annotation
documentation
This element is used for assigning price fields (price field, block price field) and the manufacturer price group to legal feature classes.

If the attribute PRICE_CALC_METHOD is set to 0 (price on request), the element FINISH is not permitted.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF
diagram
properties
minOcc | 0
maxOcc | 2
content | complex
annotation
documentation
This element is used to reference a option.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used for referencing a feature.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used for referencing a option.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/PRICE_FIELD
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
This element is used for defining the price field in which the item price is saved. The corresponding price field has to be defined in the element ITEM_PRICE (path 1 or path 2).

If the same catalogue is used for different customer groups the assignment of price groups must not be changed. The same applies to correction files within the same cycle.

Element paths
path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/BLOCK_PRICE_FIELD
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
This field is used to specify in which price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer dies not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/SUPPLIER_PRICE_GROUP
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
annotation
documentation
This element contains the manufacturer's price group.

For prices which depend on series or finishes (PRICE_CALC_METHOD = 3) the value defined in the element PRICE_FIELD is copied to the element SUPPLIER_PRICE_GROUP.
For prices of neutral items (PRICE_CALC_METHOD = 1) values in this field are not taken into consideration.


 element T_NEW_CATALOG/PRICE_DEFINITION/SET_OF_EXCHANGE_IDS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children EXCHANGE_ID
annotation
documentation
This element defines the manufacturer specific ecxchange-IDs.

If blocks are available for one manufacturer, this element has to be defined in the catalogue file. This information is also required if the manufacturer is going to deliver blocks offside the general catalogue in the future. A block file must not contain this element.


 element T_NEW_CATALOG/PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children EXCHANGE_ID_TEXT
annotation
documentation
The element EXCHANGE_ID (exchange-ID) is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only.
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID/@EXCHANGE_ID_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
This element is used as a key for the exchange groups. Freely defined values in the range between 1 and 89 are permitted.
Special exchange_IDs are defined as follows:
0 = exchange of item not permitted
98 = exchange of item with itself only
99 = exchange of item with all other exchange-IDs permitted.
All utilized exchange-ID have to be defined in the data as well as the predefined special exchange-IDs.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/PRICE_GROUP_DEFINITIONS/PRICE_FEATURE_GROUP/EXCHANGE_ID.


 element T_NEW_CATALOG/PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID/EXCHANGE_ID_TEXT
diagram
type | languagetexte40
properties
content complex
children | LANGUAGE
annotation
documentation
Additional information about the exchange group is provided in the field, e.g.:
- furniture
- worktops
- light pelmet/ cornice
- accesories
- electrical appliances


 element T_NEW_CATALOG/PRICE_DEFINITION/VALUE_ADDED_TAXES
diagram
properties
content complex
children VALUE_ADDED_TAX
annotation
documentation
This element is used for defining the different rates of value added tax which are referenced by the items. The tax rates defined in this field have to correspond with the country defined in element COUNTRY_ID (path 1).

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATIO


 element T_NEW_CATALOG/PRICE_DEFINITION/VALUE_ADDED_TAXES/VALUE_ADDED_TAX
diagram
properties
minOcc | 1
maxOcc | 100
content | complex
children VAT_RATE
annotation
documentation
This element defines a VAT rate.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/VALUE_ADDED_TAXES/VALUE_ADDED_TAX/@VAT_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute defines an ID for a VAT rate. The value 0 is reserved for those items which are not subject to VAT.


 element T_NEW_CATALOG/PRICE_DEFINITION/VALUE_ADDED_TAXES/VALUE_ADDED_TAX/VAT_RATE
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This element defines the VAT rate in percent. The value is given with two decimal places, e.g. 1600 for 16,00 % oder 10 für 0,1%).


 element T_NEW_CATALOG/PRICE_DEFINITION/IDENT_NUMBERS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children IDENT_NUMBER
annotation
documentation
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.


 element T_NEW_CATALOG/PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER
diagram
properties
minOcc | 0
maxOcc | 9999
content | complex
children SERIE_REF PRICE
annotation
documentation
This element defines the ident numbers. All ident numbers used in a catalogue have to be defined here.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER/@IDENT_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This attribute is used to define an identifier.


 element T_NEW_CATALOG/PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER/SERIE_REF
diagram
properties
minOcc | 1
maxOcc | 99
content | complex
annotation
documentation
This element references a series. If no series is referenced the ident numbers are valid globally.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER/SERIE_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


 element T_NEW_CATALOG/PRICE_DEFINITION/IDENT_NUMBERS/IDENT_NUMBER/PRICE
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30,000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of EUR -9.00 is entered as -&gt; -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_REF of the item does not contain an element for the corresponding price group.


 element T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children MERCHANDISE_GROUP_TEXT CALC_GROUP
annotation
documentation
This element defines a merchandise group. The merchandise group and the assigned text information have to correspond with the calculation sheet of the manufacturer. For one merchandise group 1-n calculation groups can be defined.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP/@MERCHANDISE_GROUP_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute defines a merchandise group.


 element T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP/MERCHANDISE_GROUP_TEXT
diagram
type | languagetexte30
properties
content complex
children | LANGUAGE
annotation
documentation
This element provides text information about the merchandise groups.


 element T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CALC_GROUP_TEXT CALCULATION_FACTOR
annotation
documentation
This element is used to define the possible calculation groups. It can be helpful when applying different discounts. This means that, depending on the number of discount scales, a corresponding number of calculation groups can be formed here. The element ITEM is used to allocate the items to a calculation group. Only calculation groups with referencing items must be defined. They key ist the CALC_GROUP_NO field.

If the same calculation group is used, the same price finding will also be used.

A calculation group can only be used once within all MERCHANDISE_GROUP elements. This means that a certain calculation group may only be used in a single MERCHANDISE_GROUP and not in multiple MERCHANDISE_GROUP elements.

The calculation group is specified via the CALC_GROUP_NO attribute.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/@CALC_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 10 |
maxInclusive | 99 |
annotation
documentation
This field is a two-digit key. The following combination of calculation marks can be used for indicating the corresponding calculation group. The figures in the first digit are defined according to the table listed below. The second digit can be freely defined. The combination "00" is not permitted.
First digit:
0 = no assigment;
1 = furniture;
2 = worktops;
3 = sinks;
4 = electrical appliances;
5 = general accessories;
6 = merchandise;
7 = blocks / additional equipment.
8 = miscellaneous 1
9 = miscellaneous 2

Single-figure numbers (leading zeroes) are not allowed.
The calculation group does not correspond with the suppliers scales of conditions.


 element T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALC_GROUP_TEXT
diagram
type | languagetexte30
properties
content complex
children | LANGUAGE
annotation
documentation
This element contains text information for a calculation group.


 element T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999999 |
annotation
documentation
The use of this element is only permitted if the value 3 is set in the element PRICE_ID (path 1).

If calculation points are used the corresponding calculation factor has to be defined in this element.
The factor is given as a decimal figure with max. 5 decimal places before the point and exactly three decimal places after the point (the point itself does not count). The calculation factor has to be &gt; 0.

Element paths
path 1: CATALOG/CATALOG_IDENTIFICATION


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES
diagram
properties
content complex
children PRICE_TYPE
annotation
documentation
This element is used for defining the different price types. Neutral as well as model specific items can be charged per piece or depending on certain measurements.
The child elements WIDTH_X, DEPTH_Y, HEIGHT_Z define that the price of an item depends on width, height, depth, surface or volume.
If the value "1" is not entered for any of the dimensions, the price is calculated per piece (e.g. base cabinet) and not depending on measurements. In this case the elements BASIC_UNIT and ROUNDING_UNIT have to be filled in with "0".
In case one dimension field is filled in with "1" , the price calculation is based on this dimension (e.g. light pelmets).
If the value "1" is filled in into two dimension fields, the price will be calculated depending on the surface of the item (e.g. cladding material).
The price calculation is based on volume, in case three dimension fields are filled with the value "1" (e.g. lacquer, stain).


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE
diagram
properties
content complex
children WIDTH_X DEPTH_Y HEIGHT_Z BASIC_UNIT ROUNDING_UNIT BASIC_PRICE_DEPENDENT PRICE_TYPE_FORMULA PRICE_TYPE_NAME
annotation
documentation
This element defines a price type.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/@PRICE_TYPE_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
This attribute identifies a price type unambiguously.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/WIDTH_X
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
If the calculated price is depending on the width of an item, the value 1 has to be set in this field, otherwise the field is set to 0.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/DEPTH_Y
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
If the calculated price is depending on the depth of an item, the value 1 has to be set in this field, otherwise the field is set to 0.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/HEIGHT_Z
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
If the calculated price is depending on the height of an item, the value 1 has to be set in this field, otherwise the field is set to 0.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/BASIC_UNIT
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999999 |
annotation
documentation
The field basic unit (BASIC_UNIT) indicatea the dimension to which the prices in the elements ITEM_PRICE (path1) and ADDITIONAL_PRICE (path2) refer.
The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm². If an item price depending on width is calculated per metre, the value "1000" has to be filled in into the field basic_unit, If the price calculation of an item is based on volume and the calculation unit is 1 m³, the value in the field basic_unit has to be "1000000000" [mm³]. If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0".

path1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/
path2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ROUNDING_UNIT
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999999 |
annotation
documentation
The element rounding unit (ROUNDING_UNIT) indicates the measurement to which length, surface or volume are rounded up. The unit of measurement depends on the number of dimensions marked with "1". Possible units are mm, mm² or mm³. If an item price depending on width is rounded up to full centimeters, the value filled in here has to be "10". If unit pricing applies, i.e. no dimension field is marked with "1", the value "0" has to be filled in here. If no unit pricing applies, the value in this field has to be unequal "0".


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/BASIC_PRICE_DEPENDENT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
A basic price and a corresponding price unit can be defined for those items which are calculated depending on dimensions. No basic price is taken into account, if the value in this field is "0".

The element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC defines the current basic
price of an item. The element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT indicates the corresponding basic price unit.

The element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE defines the remaining measurement price, which refers to the element BASIC_UNIT.
In case the option BASIC_PRICE_DEPENDENT has been defined for an item, the definition of a minimum price is not permitted. The total price of an item is always calculated on the BASIC_PRICE and the additional REMAINDER_PRICE, taking into account the rules defined in this element.

The total item price is calculated according to the following scheme:
The basic price unit is subtracted from the total item price. The result of this operation is the remainder.
The calculation of the total item price is based on the rules defined in the element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE. In case the remainder is less than 0, all further calculation is based on a remaining measurement value of 0.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_FORMULA
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 100 |
pattern | [\+\-\*/\(\)bhtBHT]{0,} |
annotation
documentation
It is possible to define formulas for price calculation (PRICE_TYPE), but these formulas must not be defined for standard calculation price types, i.e. calculation per m² or m³.
The following rules for the definition of price formulas apply:
- Formula parameters b, h and t can be used. Parameters b, h, t correspond to the parameters b, h and t of the basic shapes. Depending on the used parameters b, h, t the corresponding Boolean field WIDTH_X (P1) (b), DEPTH_Y (P1) (t) or HEIGHT_Z (P1) (h) has to be set to true:
- Basic arithmetic operations addition (+), subtraction (-), multiplication (*) and division (/) can be applied;
- rules of parentheses may be applied;
- Algebraic signs must not be used;
- only the final result is rounded;
- All rules of the elements BASIC_UNIT (P1), ROUNDING_UNIT (P1), and BASIC_PRICE_DEPENDENT (P1) also apply in combination with the field PRICE_TYPE_FORMULA

P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_NAME
diagram
type | languagetexte60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This field contains a denotation for the defined price_type.
This denotation is used to simplify the data acquisition for communication purposes. This denotation is not evaluated in the processing software.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_CONDITIONS BLOCK_SALE_PRICES GRADING_TABLE SET_OF_BLOCK_RULES
annotation
documentation
This element is used for defining the rules which apply to block calculation and value clearing.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_CONDITION
annotation
documentation
This element contains special conditions for the block calculation. Only if a block corresponds with these conditions it can be applied to a certain commission. Rules defined here apply to the value clearing system (value clearing block) as well as to block calculation (item block).

A block may only be applied to a commission,if all conditions for this special block are fulfilled. A tuple, consisting of the fields ITEM_REF (path 1) and OPERATION_ID (path 2), defines the conditions which refer to a certain block.

Basic condition for the correct application of block conditions is, that a block exists in one of the ranges which have been planned in one commission. In case different ranges have been planned in one commission, the first range which appears in the header data is considered as reference.

The settings and definitions of range- and variation controls apply to blocks in the same way as to “ordinary” items. The price information 0 in the element ITEM_PRICE (path 2) indicates that the value clearing block exists in a certain price group.

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

path 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF CONDITION_RULES
annotation
documentation
This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/ITEM_REF
diagram
properties
content complex
annotation
documentation
This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES
diagram
properties
content complex
children CONDITION_RULE
annotation
documentation
Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLEARING_GROUP_REF MINIMUM_VALUE MINIMUM_WIDTH
annotation
documentation
This element is used for defining block conditions.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/CLEARING_GROUP_REF
diagram
properties
minOcc | 1
maxOcc | 999
content | complex
annotation
documentation
This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/CLEARING_GROUP_REF/@CLEARING_GROUP_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used for referencing a clearing group.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/MINIMUM_VALUE
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/BLOCK_CONDITION/CONDITION_RULES/CONDITION_RULE/MINIMUM_WIDTH
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children BLOCK_SALE_PRICE
annotation
documentation
This element is used for defining block sale prices.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF VARIATION_PRICE_DEFINITION
annotation
documentation
Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/ITEM_REF
diagram
properties
content complex
annotation
documentation
This element is used for referencing an item for which a block sale price has been defined.


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children VALID_FROM VALID_UNTIL OPTION_REF PRICE_OR_CALCULATION_POINT
annotation
documentation
This element is used for defining block sale conditions.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/VALID_FROM
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/VALID_UNTIL
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/OPTION_REF
diagram
properties
minOcc | 0
maxOcc | 4
content | complex
annotation
documentation
This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used for referencing a feature.


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used for referencing a option.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/BLOCK_SALE_PRICES/BLOCK_SALE_PRICE/VARIATION_PRICE_DEFINITION/PRICE_OR_CALCULATION_POINT
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself).


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CREDIT_SURCHARGE_CLEARING
annotation
documentation
This element is used for defining grading tables containing the surcharges or the credits which are used in the value clearing system.

A clearing block, which is valid for a certain commission, can be used as reference for the grading table. A reference amount is set up for each data record of this record type, to which the valid clearing block belongs CLEARING_GROUP (path 1). This amount is compared to the given amount of the clearing group. If the reference value corresponds with the given grading range (elements VALUE_FROM (path2) and VALUE_TO (path 2), the data record is applied. In this case the settings in the field TYPE_CREDIT (path 2) and/ or TYPE_DEBIT (path 2) are applied. The calculation is based on the amount of the calculation group, which is defined for type_credit or type_surcharge (element ITEM (path 3)).

Different grading ranges can be defined for one block. A freely defined operation_ID is assigned to each grading range COMPARING_RULES (path 4). Different grading ranges with the same operation_ID may appear within one grading range of a clearing block. In this case the conditions of all grading ranges with their corresponding clearing group have to be fulfilled, so that the value clearing system can be applied to the different items of the commission. Single data records are linked by an AND-operation (COMPARING_RULE).

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

In case several data records of a clearing block are applied in the GRADING_TABLE, the value of the block (ITEM (path 3)), ITEM_PRICE (path 5)) is calculated only one time.

path 1: GLOBAL_DEFINITION
path 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
path 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF COMPARING_RULES
annotation
documentation
This element defines value range for a grading table.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/ITEM_REF
diagram
properties
content complex
annotation
documentation
This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used for defining an item short code. (e.g. U60).


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used for defining a serial No. of the referenced series.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children COMPARING_RULE
annotation
documentation
Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLEARING_GROUP_ID VALUE_FROM VALUE_TO TYPE_CREDIT TYPE_DEBIT
annotation
documentation
This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/CLEARING_GROUP_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/VALUE_FROM
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/VALUE_TO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/TYPE_CREDIT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE/TYPE_DEBIT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES
diagram
properties
content complex
children EXCHANGE_ID_GROUP RULE RULE_SET_TEXT
annotation
documentation
The manufacturer specific rules are defined in this element and the in the child elements.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children EXCHANGE_ID_1_REF EXCHANGE_ID_2_REF
annotation
documentation
This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_1_REF
diagram
properties
content complex
annotation
documentation
The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS . The exchange-ID references the items of a commission or planning.


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_1_REF/@EXCHANGE_ID_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_2_REF
diagram
properties
content complex
annotation
documentation
The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS The exchange-ID references the items of a commission or planning.


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/EXCHANGE_ID_GROUP/EXCHANGE_ID_2_REF/@EXCHANGE_ID_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-8][0-9]|9[89] |
annotation
documentation
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE
diagram
properties
minOcc | 1
maxOcc | 99
content | complex
children RULE_TEXT
annotation
documentation
This element defines a manufacturer specific set of rules.


 attribute T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE/@RULE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
This attribute defines a counter from 1-99 for the manufacturer specific block rules.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE/RULE_TEXT
diagram
type | languagetexte60999
properties
content complex
children | LANGUAGE
annotation
documentation
This element defines the criteria for exchanges in the block processing.


 element T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE_SET_TEXT
diagram
type | languagetexte60999
properties
content complex
children | LANGUAGE
annotation
documentation
This element contains text information and explanations for the set of rules.


 complexType languagetexte
diagram
children LANGUAGE
used by
elements T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT T_NEW_CATALOG/GLOBAL_DEFINITION/PROPERTIES/PROPERTY/PROPERTY_TEXT T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
annotation
documentation
This data type is used for multilingual text information of any length.


 complexType languagetexte30
diagram
children LANGUAGE
used by
elements T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALC_GROUP_TEXT T_NEW_CATALOG/CATALOG/CATALOG_NAME T_NEW_CATALOG/SERIES/SERIE/DEFAULT_OPTION_GROUPS/DEFAULT_OPTION_GROUP/DEFAULT_OPTION_GROUP_NAME T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP/MERCHANDISE_GROUP_TEXT T_NEW_CATALOG/GLOBAL_DEFINITION/PROPERTIES/PROPERTY/PROPERTY_UNIT
annotation
documentation
This element is used for multilingual text information limited to 30 characters.


 complexType languagetexte40
diagram
children LANGUAGE
used by
elements T_NEW_CATALOG/PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID/EXCHANGE_ID_TEXT T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
annotation
documentation
This element is used for multilingual text information limited to 40 characters.


 complexType languagetexte60
diagram
children LANGUAGE
used by
elements T_NEW_CATALOG/GLOBAL_DEFINITION/CLEARING_GROUP/CLEARING_GROUP_NAME T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TEXT T_NEW_CATALOG/GLOBAL_DEFINITION/GROUP_TITLES/GROUP_TITLE/GROUP_TITLE_NAME T_NEW_CATALOG/GLOBAL_DEFINITION/MODULE_RULE_SET_DEFINITIONS/MODULE_RULE_SET_DEFINITION/MODULE_RULE_SET_NAME T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_COMMENT_TEXT T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_FEATURE_GROUP_TEXT T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_NAME T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/PRODUCT_GROUP_TEXT T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/RESTRICTION_NAME_TEXT T_NEW_CATALOG/FEATURE_DEFINITION/SUGGESTIONS/SUGGESTION/SUGGESTION_NAME_TEXT
annotation
documentation
This element is used for multilingual text information limited to 60 characters.


 complexType languagetexte60999
diagram
children LANGUAGE
used by
elements T_NEW_CATALOG/CATALOG/CATALOG_INFO T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE_SET_TEXT T_NEW_CATALOG/BLOCK_VALUE_CALCULATION/SET_OF_BLOCK_RULES/RULE/RULE_TEXT
annotation
documentation
This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.