 Einleitung

Ansicht mit Navigationswerkzeuge

Modifikation IDM 3.0.0 XML-Schema

Dokumentation

Stand 01.12.2022

Dokumentiertes XML-Schema:

MODIFY_IDM_3_0_0.xsd

Kontakt DCC e.V.

Geschäftsführer
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37

Verantwortliche IDM Arbeitskreise und Dokumentation
Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telefon 0 52 21/12 65-38


 Grundstruktur des IDM-Schemas

Modifikation IDM 3.0.0 XML-Schema Dokumentation

Einleitung > Grundstruktur des IDM-Schemas

Das Hauptelement T_NEW_CATALOG definiert, dass ein neuer, vollständiger Katalogdatenbestand bereitgestellt wird.

Dabei sind die XML-Dateien UTF-8 zu kodieren.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_NEW_CATALOG abgebildet werden.

Abbildung 1 - Child-Elemente von T_MODIFY_CATALOG

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

 REF_CATALOG In REF_CATAG werden Informationen zum Hauptkataloghinterlegt

SERIES

In SERIES werden die Daten für die Beschreibung der Artikel hinterlegt. Dabei werden die Artikel in Produktgruppen wie beispielsweise Unterschränke oder Regale gruppiert.

FEATURE_DEFINITION

In FEATURE_DEFINITION werden Varianteninformationen hinterlegt. Dabei sind die angegebenen Daten Veränderungen zum Hauptkatalog.

PRICE_DEFINITION

In PRICE_DEFINITION werden Preisinformationen hinterlegt. Die Angeben beziehen sich z. B. auf veränderte Preisfelder gegenüber dem Hauptkatalog.


 Katalogstruktur

Modifikation IDM 3.0.0 XML-Schema Dokumentation

Einleitung > Katalogstruktur

Katalog- und Elementstruktur

Die grundlegende Katalogstruktur der Datenbestände baut sich wie folgt auf:

Abbildung 1 – Katalogstruktur der Datenbestände

Die Katalogstruktur wird im IDM-Schema durch die folgende Elementhierarchie abgebildet:

Abbildung 1 – Elementhierarchie im IDM-Schema

In dem Element SERIE werden die Eigenschaften einer Serie definiert. Über das Element RESTRICTION_REF werden einer Serie Varianten über Prüfverfahren zugeordnet. Innerhalb der Serie werden Produktgruppen (PRODUCT_GROUPS) definiert, in denen Artikel mit gleichartigen Variantenarten zusammengefasst sind. Die Artikel sind einer Serie automatisch zugeordnet, da sie Kind-Elemente des Elementes SERIE sind.


 Referenzierung

Modifikation IDM 3.0.0 XML-Schema Dokumentation

Einleitung > Referenzierung

Referenzierung von Elementen

Im IDM-Schema werden Beziehungen zwischen Elementen aufgebaut und Informationen an zentraler Stelle definiert und an anderer Stelle mehrfach verwendet. Die Wiederverwendung der Informationen und der Aufbau von Elementbeziehungen erfolgt über Referenzierung. Die im IDM-Schema angewendete Art der Referenzierung wird nachfolgend beschrieben.

Begriffsdefinition

Im IDM-Schema werden für die Referenzierung von Elementen folgende Begriffe verwendet:

Key-Element | Ein XML-Element, welches von anderen Elementen referenziert wird.
Ref-Element | Ein XML-Element, welches andere Elemente referenziert.

Vorgang der Referenzierung

Das Key-Element besitzt Attribute, über die es eindeutig identifiziert wird. Das Ref-Element besitzt minimal die Key-Attribute des Key-Elementes. Zwischen den Elementen wird die Referenz aufgebaut, in dem die Attributwerte des Ref-Elementes denen des Key-Elementes entsprechen.

Beispiel: Referenzierung einer Varianten

Im folgenden Beispiel wird eine Variante aus einem Prüfverfahren heraus referenziert.

Key-Element

T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!-- Sockelausführung -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!-- Sockelfarbe -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

Die XML-Elemente definieren für die Variantenart 400 (FEATURE) drei Varianten (OPTION) mit den Nummern 1-3 sowie für die Variantenart 401 drei Varianten mit den Nummern 1-3. Eine Variante wird identifiziert über die Kombination FEATURE_NO und OPTION_KEY.

Ref-Element

T_MODIFY_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_REF

<RESTRICTION RESTRICTION_NO="1">

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="1" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

In den XML-Elementen wird ein Prüfverfahren für die zulässigen Kombinationen (TEST_ID=1) der Sockelausführungen (FEATURE_NO=400) und der Sockelfarben (FEATURE_NO=401) definiert. Das Ref-Element OPTION_REF mit den grau hinterlegten Attributen referenziert in diesem Beispiel das grau hinterlegte Key-Element OPTION.


 Datentypen

Modifikation IDM 3.0.0 XML-Schema Dokumentation

Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

Es werden folgende Datentypen genutzt:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDM wird der Datentyp date XML-Schema konform in folgender Weise angewendet: YYYY-MM-DD YYYY = Jahr, MM = Monat, DD = Tag
dateTime | Im IDM wird der Datentyp dateTime XML-Schema konform in folgender Weise angewendet: YYYY-MM-DDThh:mm:ssZ YYYY = Jahr, MM = Monat, DD = Tag T = Beginn der Zeitangabe hh = Stunde, mm = Minute, ss = Sekunde Z = UTC-Zeit
gYear | Im IDM wird der Datentyp dateTime XML-Schema konform in folgender Weise angewendet: YYYY
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDM für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDM für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDM für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.

Die Wertebereiche der obigen Datentypen sind im allgemeinen für die Elemente im IDM eingeschränkt. Über "Restrictions" bei der Datentypdefinition sind Minimal- und Maximalwerte, zulässige Zeichen sowie Wertlisten eingeschränkt.

In der XML-Schema Dokumentation des IDM sind die Wertebereiche durch die Angabe hinter M und P spezifiziert.

Neben den hier genannten XML-Datentypen werden eigene Datentypen für die Texte definiert.

Sie sind am Ende der Dokumentation erklärt.

Siehe auch

languagetexte Complex Type

languagetexte30 Complex Type

languagetexte40 Complex Type

languagetexte60 Complex Type

languagetexte60999 Complex Type


 Erläuterungen zur Dokumentation

Modifikation IDM 3.0.0 XML-Schema Dokumentation

Einleitung > Erläuterungen zur Dokumentation

Erläuterungen zur Dokumentation des IDM

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

EXCHANGE_ID_NO Attribute Collapse All Expand All

Description

" -->

Beschreibung

Das Attribut identifiziert eine Tausch-ID.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


 Variantenarten

Ansicht mit Navigationswerkzeuge

Modifikation IDM 3.0.0 XML-Schema Dokumentation

Einleitung > Variantenarten

Varianten-art | Variantentext | Ausführungs-art | Bemerkung
1 | Programm | A | Programm als VariantenartProgramm als VariantenartProgramm als Variantenart
2 | Seriennummer | A | Zuordnung einer fünfstelligen Seriennummer
100 | Frontausführung | A |
101 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
102 | Frontfarbe 2 | F | Rahmen
103 | Frontfarbe 3 | F | Lisenen
104 | Kantenfarbe Front | F |
105 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist. Ist die Varianten-Art 105 gefüllt, so setzt sie die Varianten-Arten 100-104 insofern außer Kraft, dass sie nur noch zur internen Verwendung der Softwarefirmen dienen (z. B. interne Farbsteuerung). Diese werden dann im Element HEADER_POS_VARIATION_TYPE als unsichtbare Kopfvariante ("U") gesetzt. Zur externen Verwendung als Auswahl für den Anwender (z. B. Abfrage als Kopf- und Bestell-information) dienen ausschließlich die Elemente unter EDI_INFO.
106 | Frontgruppe | A | Überschreibt die FRONT_GROUP_NO in FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Frontausführung Absetzung 1 | A |
111 | Frontfarbe 1 Absetzung 1 | F | Füllung glatte Front = ganze Fläche
112 | Frontfarbe 2 Absetzung 1 | F | Rahmen
113 | Frontfarbe 3 Absetzung 1 | F | Lisenen
114 | Kantenfarbe Front Absetzung 1 | F |
115 | Front-Kombination Absetzung 1 | K | Darf die Varianten 111 bis 114 enthalten
120 | Frontausführung Absetzung 2 | A |
121 | Frontfarbe 1 Absetzung 2 | F | Füllung glatte Front = ganze Fläche
122 | Frontfarbe 2 Absetzung 2 | F | Rahmen
123 | Frontfarbe 3 Absetzung 2 | F | Lisenen
124 | Kantenfarbe Front Absetzung 2 | F |
125 | Front-Kombination Absetzung 2 | K | Darf die Varianten 121 bis 124 enthalten
150 | Glasausführung | A |
151 | Glasfarbe | F |
152 | Sprossenausführung | A |
153 | Sprossenfarbe | F |
154 | Ausführung Glastürrahmen | A |
155 | Farbe Glastürrahmen | F |
160 | Ausführung Jalousie | A |
161 | Farbe Jalousie | F |
170 | Ausführung Schütte | A |
171 | Farbe Schütte | F |
200 | Korpusausführung | A |
201 | Korpus-Kombination | K | Wenn für mehrere Korpusfarben - innen/außen - nur ein Schlüssel vorhanden ist. Ist die Varianten-Art 201 gefüllt, so setzt sie die Varianten-Arten 200, 202-205 insofern außer Kraft, dass sie nur noch zur internen Verwendung der Softwarefirmen dienen (z. B. interne Farbsteuerung). Diese werden dann im Element HEADER_POS_VARIATION_TYPE als unsichtbare Kopfvariante ("U") gesetzt. Zur externen Verwendung als Auswahl für den Anwender (z. B. Abfrage als Kopf- und Bestell-information) dienen ausschließlich die Elemente unter EDI_INFO.
202 | Korpusfarbe außen | F |
203 | Korpusfarbe innen | F |
204 | Kantenausführung Korpus | A |
205 | Kantenfarbe Korpus | F |
206 | Sichtseiten-Ausführung | A |
207 | Sichtseiten-Farbe | F |
208 | Korpusfarbe innen für Glas | F | Glasschränke und offene Schränke, die kein Regal sind.
209 | Korpusausf. innen für Glas | A | Glasschränke und offene Schränke, die kein Regal sind.
300 | Griffausführung | A |
301 | Griff-Farbe 1 | F | Griff-, Knopfsockel- bzw. Hauptfarbe
302 | Griff-Farbe 2 | F | Bügel-, Steg- und Knopfblendenfarbe
303 | Griff-Kombination | K | Wenn nur ein Schlüssel für mehrere Griffbedingungen vorgegeben ist. Ist die Varianten-Art 303 gefüllt, so setzt sie die Varianten-Arten 300-302 insofern außer Kraft, dass sie nur noch zur internen Verwendung der Softwarefirmen dienen (z. B. interne Farbsteuerung). Diese werden dann im Element HEADER_POS_VARIATION_TYPE als unsichtbare Kopfvariante ("U") gesetzt. Zur externen Verwendung als Auswahl für den Anwender (z. B. Abfrage als Kopf- und Bestell-information) dienen ausschließlich die Elemente unter EDI_INFO.
304 | Grifflagen | NULL | Siehe Grifflagen S. 5-23
400 | Sockelausführung | A |
401 | Sockelfarbe | F |
402 | Sockelhöhe | A |
410 | Ausführung Sockelboden | A |
411 | Farbe Sockelboden | F |
500 | Ausführung Regale | A |
501 | Farbe Regale | F |
502 | Ausführung Kranzprofil | A | Beinhaltet Form und Material
503 | Farbe Kranzprofil | F |
504 | Ausführung Lichtleiste | A | Beinhaltet Form und Material
505 | Farbe Lichtleiste | F |
506 | Ausführung Deckenblende | A |
507 | Farbe Deckenblende | F |
508 | Ausf. u. Schr.-abschlussleiste | A | Untere Schrankabschlußleiste
509 | Farbe u. Schr.-abschlussleiste | F | Untere Schrankabschlußleiste
510 | Ausführung Oberboden | A |
511 | Farbe Oberboden | F |
512 | Ausführung Oberboden-Kante | A |
513 | Farbe Oberboden-Kante | F |
514 | Ausführung Bord | A |
515 | Farbe Bord | F |
516 | Ausführung Bordkante | A |
517 | Farbe Bordkante | F |
520 | Ausführung Wangen/Riegel | A |
521 | Farbe Wangen/Riegel | F |
522 | Ausführung Wangenkante | A |
523 | Farbe Wangenkante | F |
524 | Ausführung Unterboden | A |
525 | Farbe Unterboden | F |
526 | Ausführung Unterboden-Kante | A |
527 | Farbe Unterboden-Kante | F |
550 | Nischenausführung | A |
551 | Nischenfarbe | F |
560 | Ausführung Nischenzubehör | A |
561 | Farbe Nischenzubehör | F |
562 | Ausführung Pilaster | A |
563 | Farbe Pilaster | F |
564 | Ausführung Pilasterkante | A |
565 | Farbe Pilasterkante | F |
600 | Arbeitsplatten-Ausführung | A |
601 | Arbeitsplatten-Farbe | F |
602 | Arbeitsplattenkantenausführung | A |
603 | Arbeitsplatten-Kantenfarbe | F |
604 | Barplatten-Ausführung | A |
605 | Barplatten-Farbe | F |
606 | Barplatten-Kantenausführung | A |
607 | Barplatten-Kantenfarbe | F |
620 | Abdeckplatten-Ausführung | A |
621 | Abdeckplatten-Farbe | F |
622 | Abdeckplatten-Kantenausführung | A |
623 | Abdeckplatten-Kantenfarbe | F |
624 | Ansetztisch-Ausführung | A |
625 | Ansetztisch-Farbe | F |
626 | Ansetztisch-Kantenausführung | A |
627 | Ansetztisch-Kantenfarbe | F |
650 | WAP-Ausführung | A | Wandabschlussprofil
651 | WAP-Farbe | F | Wandabschlussprofil
700 | Schubkastenausführung | A | Innenausstattung
701 | Schubkastenfarbe | F | Innenausstattung
702 | Auszugsausführung | A | Innenausstattung
703 | Auszugsfarbe | F | Innenausstattung
750 | Arbeitsplattenform | S |
751 | Kranzleistenform | S |
752 | Lichtleistenform | S |
753 | Sockelform | S |
754 | Wandabschlussform | S |
755 | Abdeckplattenform | S |
756 | Barplattenform | S |
800 | Ausführung Elektrogeräte | A |
801 | Farbe Elektrogeräte | F |
802 | Farbe Elektrogeräte-Zubehör | F |
850 | Ausführung Spülen | A |
851 | Farbe Spülen | F |
852 | Farbe Spülenzubehör | F |
853 | Mischbatterien Farbe | F |
854 | Ausführung Mischbatterien | A |
900 | Ausführung Allgemeines Zubehör | A |
901 | Farbe Allgemeines Zubehör | F |
930 | zus. grafisch relevante Ausführung 1 | A | unbedingt den Softwarehäusern separat mitteilen
931 | zus. grafisch relevante Farbe 1 | F | unbedingt den Softwarehäusern separat mitteilen
932 | zus. grafisch relevante Ausführung 2 | A | unbedingt den Softwarehäusern separat mitteilen
933 | zus. grafisch relevante Farbe 2 | F | unbedingt den Softwarehäusern separat mitteilen
934 | zus. grafisch relevante Ausführung 3 | A | unbedingt den Softwarehäusern separat mitteilen
935 | zus. grafisch relevante Farbe 3 | F | unbedingt den Softwarehäusern separat mitteilen
936 | zus. grafisch relevante Ausführung 4 | A | unbedingt den Softwarehäusern separat mitteilen
937 | zus. grafisch relevante Farbe 4 | F | unbedingt den Softwarehäusern separat mitteilen
938 | zus. grafisch relevante Ausführung 5 | A | unbedingt den Softwarehäusern separat mitteilen
939 | zus. grafisch relevante Farbe 5 | F | unbedingt den Softwarehäusern separat mitteilen
950 | Ausführung Diverses 1 | A |
951 | Farbe Diverses 1 | F |
952 | Ausführung Diverses 2 | A |
953 | Farbe Diverses 2 | F |
954 | Ausführung Diverses 3 | A |
955 | Farbe Diverses 3 | F |
956 | Ausführung Diverses 4 | A |
957 | Farbe Diverses 4 | F |
958 | Ausführung Diverses 5 | A |
959 | Farbe Diverses 5 | F |
960 | Ausführung Diverses 6 | A |
961 | Farbe Diverses 6 | F |
962 | Ausführung Diverses 7 | A |
963 | Farbe Diverses 7 | F |
964 | Ausführung Diverses 8 | A |
965 | Farbe Diverses 8 | F |
966 | Ausführung Diverses 9 | A |
967 | Farbe Diverses 9 | F |
968 | Ausführung Diverses 10 | A |
969 | Farbe Diverses 10 | F |
970 | Ausführung Diverses 11 | A |
971 | Farbe Diverses 11 | F |
972 | Ausführung Diverses 12 | A |
973 | Farbe Diverses 12 | F |
974 | Ausführung Diverses 13 | A |
975 | Farbe Diverses 13 | F |
976 | Ausführung Diverses 14 | A |
977 | Farbe Diverses 14 | F |
978 | Ausführung Diverses 15 | A |
979 | Farbe Diverses 15 | F |
980 | Ausführung Diverses 16 | A |
981 | Farbe Diverses 16 | F |
982 | Ausführung Diverses 17 | A |
983 | Farbe Diverses 17 | F |
984 | Ausführung Diverses 18 | A |
985 | Farbe Diverses 18 | F |
986 | Ausführung Diverses 19 | A |
987 | Farbe Diverses 19 | F |
988 | Ausführung Diverses 20 | A |
989 | Farbe Diverses 20 | F |
998 | kundenspezifische Motive | F |
999 | Fixe Materialzuordnung | F | Diese Varianten-Art wird global definiert, darf aber nur in den Materialeigenschaften verwendet werden.

Typ: A = Ausführung

F = Farbe

K = Kombination

S = Form


 Sprachenschlüssel

Modifikation IDM 3.0.0 XML-Schema Dokumentation

Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Niederländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu


 Länderschlüssel

Modifikation IDM 3.0.0 XML-Schema Dokumentation

Einleitung > Länderschlüssel

Länderkennzeichen | Ländername(deutsch) | Ländername(englisch)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


 Einkaufsverbände
Modifikation IDM 3.0.0 XML-Schema Dokumentation Ansicht mit NavigationswerkzeugeEinleitung > Einkaufsverbände
Verbands-kunde | Verbandsname | Strasse | PLZ | Ort | Telefon | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13 A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Beinhaltet Form und Material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunscheig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co. KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60


 Dateibenennung

Modifikation IDM 3.0.0 XML-Schema Dokumentation

Einleitung > Dateibenennung

Für den Dateinamen eines Datensatzes werden folgende Empfehlungen gegeben:

· Der Name des Datensatzes darf nicht auf 8 Zeichen begrenzt sein.

· Möglichst sollten alle Bestandteile aus dem Element CATALOG_IDENTIFICATION genutzt werden:

· Folgende Bestandteile wurden vorgeschlagen:

· Herstellernummer

· IDM-Version

· Kundennummer (Wert aus dem Element ASSOC_CTM_NO)

· Sämtliche Sprachen

· Jahreszahl

· Haupt-Nummer (MAJOR)

· Zeitstempel der Dateifreigabe (FILE_RELEASE_DATE)


 Best Practices

Best Practices

für dokumentiertes XML-Schema:

MODIFY_IDM_3_0_0.xsd

Stand 01.12.2022

Kontakt DCC e.V.

Geschäftsführer
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37

Verantwortliche IDM Arbeitskreise und Dokumentation
Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telefon 0 52 21/12 65-38


 Sonderfarben

IDM 3.0.0 XML-Schema Dokumentation

Best Practices > Sonderfarben

Es können nicht alle möglichen Sonderfarben einzeln in einem IDM Katalog angelegt werden.

Darum gilt es eine Struktur zu definieren, die es den Planungssystemen ermöglicht, die anwendbaren Sonderfarben auszuweisen.

Dafür sollen für jedes standardisierte Farbschema, wie z.B. RAL, NCS, SIKKENS, etc. je eine Variante angelegt werden.

Beispiel 1:

Der Lieferant bietet für verschiedene Gestaltungselemente eine Wunschfarbe in den Farbschemata RAL und NCS an.

Richtig:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Falsch:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Beispiel 2:

Der Lieferant bietet die Farbschemata RAL, NCS und SIKKENS an. Je nach Model und Beschaffenheit gibt es separate OPTION_KEYs für jedes Schema.

Richtig:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Beispiel 3:

Der Lieferant bietet bei verschiedenen Oberflächenstrukturen eine Wunschfarbe in den Farbschemata RAL und SIKKENS an, unterscheidet in den Varianten aber nur die Oberflächen.

Falsch:


 Schema MODIFY_IDM_3_0_0.xsd.DE.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\IDM\Doku MODIFY_IDM\MODIFY_IDM_3_0_0.xsd.DE.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
T_MODIFY_CATALOG | languagetexte
 | languagetexte30
 | languagetexte40
 | languagetexte60
 | languagetexte60999


 element T_MODIFY_CATALOG
diagram
properties
content complex
children Signature CATALOG REF_CATALOG SERIES FEATURE_DEFINITION PRICE_DEFINITION
annotation
documentation
In diesem Element werden alle Informationen und Daten für die Modifikation eines vorhandenen Kataloges/Datenbestandes hinterlegt.


 attribute T_MODIFY_CATALOG/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 3 |
maxInclusive | 3 |
annotation
documentation
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION.


 attribute T_MODIFY_CATALOG/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 0 |
annotation
documentation
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.


 attribute T_MODIFY_CATALOG/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 0 |
annotation
documentation
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.


 element T_MODIFY_CATALOG/Signature
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SignedInfo SignatureValue
annotation
documentation
Dieses Element dient der Angabe einer Veschlüsselung.

Das Wurzelelement einer digitalen Signatur mit XML wird durch das Element Signature dargestellt.

Signature besitzt zwei Kindelemente, wovon die beiden Elemente SignedInfo und SignatureValue Pflicht sind.


 element T_MODIFY_CATALOG/Signature/SignedInfo
diagram
properties
content complex
children CanonicalizationMethod SignatureMethod Reference
annotation
documentation
Das erste und auch komplexeste Element innerhalb von Signature ist SignedInfo und enthält die verwendeten Algorithmen zur Kanonisierung und Signierung, eine oder mehrere Referenzen auf die signierten Daten, eventuelle Transformationen und die Hashwerte dieser Daten. SignedInfo enthält also alle Informationen zu den zu signierenden Ressourcen und ist damit der Teil, über den die digitale Signatur erstellt wird.

Mit dem Signieren der verwendeten Algorithmen erhöht sich die Sicherheit. Ein sicherer Algorithmus kann so nicht gegen einen unsicheren ausgetauscht werden, ohne dass die Signatur ungültig wird.

Kindelemente von SignedInfo sind die Pflichtelemente CanonicalizationMethod und SignatureMethod sowie ein oder mehrere Reference Elemente.


 element T_MODIFY_CATALOG/Signature/SignedInfo/CanonicalizationMethod
diagram
type extension of xs:string
properties
content complex
annotation
documentation
Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

- Das Dokument wird in UTF-8 kodiert
- Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
- Attributwerte werden normalisiert (wie bei einem validierenden Parser)
- Character- und parsed-entity Referenzen werden ersetzt
- CDATA Abschnitte werden durch ihren Inhalt ersetzt
- Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
- Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
- Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
- Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
- Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
- Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
- Überflüssige Namespace Deklarationen werden von jedem Element entfernt
- Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
- Namespace Deklarationen und Attribute werden alphanumerisch sortiert


 attribute T_MODIFY_CATALOG/Signature/SignedInfo/CanonicalizationMethod/@Algorithm
type xs:anyURI
annotation
documentation
Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI.


 element T_MODIFY_CATALOG/Signature/SignedInfo/SignatureMethod
diagram
type extension of xs:string
properties
content complex
annotation
documentation
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.


 attribute T_MODIFY_CATALOG/Signature/SignedInfo/SignatureMethod/@Algorithm
type xs:anyURI
annotation
documentation
Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.


 element T_MODIFY_CATALOG/Signature/SignedInfo/Reference
diagram
properties
content complex
children Transforms DigestMethod DigestValue
annotation
documentation
Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.


 attribute T_MODIFY_CATALOG/Signature/SignedInfo/Reference/@URI
type xs:string
annotation
documentation
Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.


 element T_MODIFY_CATALOG/Signature/SignedInfo/Reference/Transforms
diagram
properties
content complex
children Transform
annotation
documentation
Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.


 element T_MODIFY_CATALOG/Signature/SignedInfo/Reference/Transforms/Transform
diagram
type extension of xs:string
properties
content complex
annotation
documentation
Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.


 attribute T_MODIFY_CATALOG/Signature/SignedInfo/Reference/Transforms/Transform/@Algorithm
type xs:anyURI
annotation
documentation
Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.


 element T_MODIFY_CATALOG/Signature/SignedInfo/Reference/DigestMethod
diagram
type extension of xs:string
properties
content complex
annotation
documentation
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.


 attribute T_MODIFY_CATALOG/Signature/SignedInfo/Reference/DigestMethod/@Algorithm
type xs:anyURI
annotation
documentation
In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.


 element T_MODIFY_CATALOG/Signature/SignedInfo/Reference/DigestValue
diagram
type xs:string
properties
content simple
annotation
documentation
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon).


 element T_MODIFY_CATALOG/Signature/SignatureValue
diagram
type xs:string
properties
content simple
annotation
documentation
Das Element SignatureValue enthält in binärer Form (immer Base-64 encoding) den über das gesamte SignedInfo Element berechneten Hashwert der Signatur. Dieser Hashwert wird mit dem in der SignatureMethod angegebenen Algorithmus, den kanonisierten Daten und dem privaten Schlüssel berechnet. Damit wird nicht die Nachricht selbst, sondern deren - in der Regel viel kürzerer - Hashwert unterschrieben (Hash-Then-Sign Paradigma).

In den unterschriebenen Daten sind somit sämtliche Informationen über die signierten Referenzen und deren Hashwerte enthalten. Damit ist es nicht erforderlich, dass die Daten selbst im Dokument vorliegen. Die Angaben über die verwendeten Algorithmen fließen jedoch mit in die Signaturberechnung ein. Dadurch werden nachträgliche Manipulationen verhindert.

Da alle Referenzen vor dem Signieren zusammengefasst und gemeinsam signiert werden existiert für die gesamte Signatur immer genau ein SignatureValue Element.


 element T_MODIFY_CATALOG/CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CATALOG_NAME DATA_VERSION FILE_ID CATALOG_MARK CATALOG_INFO CLASSIFICATION
annotation
documentation
In diesem Element werden administrative Informationen zum Datenbestand hinterlegt.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children MANUFACTURER_ID CATALOG_ID MAJOR_NO MINOR_NO FILE_RELEASE_DATE ISO_LANGUAGE_ID CURRENCY_KEY COUNTRY_ID CATALOG_KIND ASSOC_CTM_NO PRODUCT_BRANDNAME PRICE_ID VAT
annotation
documentation
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MANUFACTURER_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MAJOR_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
Die Katalogversionsnummer MAJOR_NO gibt an in welchem Jahr der Hauptkatalog erstellt wurde. Die vollständige Angabe der Katalogversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MINOR_NO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Die Sub-Katalogversionsnummer MINOR_NO wird in unterjährig bzw. im Zeitraum der Gültigkeit des Hauptkataloges fortlaufenden Nummern angegeben. Die vollständige Angabe der Katalogversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR. Wird die Katalogversion MAJOR geändert, wird die Sub-Katalogversion auf 0 zurückgesetzt.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
Das Element FILE_RELEASE_DATE sollte automatisch beim Export der Daten gesetzt werden und das aktuelle Datum und die UTC-Uhrzeit beinhalten.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.

Bei mehrsprachigen Katalogen, sind alle im Katalog vorkommenden Sprachen hier zu hinterlegen. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind.
Z.B. können in einem Schweizer Katalog hier die ISO_LANGUAGE_ID´s DE (deutsch), FR (französisch) und IT (italienisch) hinterlegt werden.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Element wird der ISO-Ländercode des Zielmarktes eingetragen.
Bei Ländern mit mehreren Sprachen aber gleicher Währung ist auf den korrekten ISO-Ländercode zu achten.
Z.B. können in einem Schweizer Katalog die 3 ISO_LANGUAGE_ID´s DE (deutsch), FR (französisch) und IT (italienisch) enthalten sein. Die COUNTRY_ID ist aber mit CH (Schweiz) anzugeben.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_KIND
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 2 |
maxInclusive | 3 |
annotation
documentation
Dieses Feld dient der Identifizierung der Verbandskataloge.
Folgende Werte sind möglich:
2 = Verbandskatalog
3 =kundenspezifischer Katalog

Da das Feld nur mit 2 oder 3 gefüllt sein darf, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/ASSOC_CTM_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände").


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/PRODUCT_BRANDNAME
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/PRICE_ID
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/VAT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_NAME
diagram
type | languagetexte30
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.


 element languagetexte30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetexte30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetexte30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_MODIFY_CATALOG/CATALOG/DATA_VERSION
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden.


 element T_MODIFY_CATALOG/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten


 element T_MODIFY_CATALOG/CATALOG/CATALOG_MARK
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [M] |
annotation
documentation
Dieses Element dient zur Kennzeichnung, dass es sich bei den bereitgestellten Daten um M = Modifzierungsdaten gegenüber dem Hauptkatalog handelt.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_INFO
diagram
type | languagetexte60999
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element werden die Informationstexte abgelegt.


 element languagetexte60999/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetexte60999/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetexte60999/LANGUAGE/TEXT_LINE
diagram
properties
minOcc | 1
maxOcc | 999
content | complex
children TEXT
annotation
documentation
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.


 attribute languagetexte60999/LANGUAGE/TEXT_LINE/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen.


 element languagetexte60999/LANGUAGE/TEXT_LINE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,60} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 element T_MODIFY_CATALOG/CATALOG/CLASSIFICATION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children ECLASS_VERSION ECLASS_PROPERTY
annotation
documentation
In diesem Element werden die Klassifikationsangaben auf Katalogebene hinterlegt.
Enthält der Katalog auch nur eine Klassifikationsangabe muss die Klassifikationsversion angegeben sein.

Angaben auf tieferen Ebenen zu gleichen Merkmalen überschreiben den auf Katalogebene angegebenen Wert.


 element T_MODIFY_CATALOG/CATALOG/CLASSIFICATION/ECLASS_VERSION
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
pattern |  |
annotation
documentation
In diesem Element wird die Klassifikationsversion hinterlegt.
Es wird nur die Major-No der Version angegeben.


 element T_MODIFY_CATALOG/CATALOG/CLASSIFICATION/ECLASS_PROPERTY
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children ECLASS_VALUE
annotation
documentation
In diesem Element werden die ECLASS Merkmale auf Katalogebene hinterlegt.
Angaben auf tieferen Ebenen zu gleichen Merkmalen überschreiben den auf Katalogebene angegebenen Wert.


 attribute T_MODIFY_CATALOG/CATALOG/CLASSIFICATION/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#02-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
Das Attribut identifiziert das ECLASS Merkmal über die IRDI.


 element T_MODIFY_CATALOG/CATALOG/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Werte des ECLASS Merkmals hinterlegt.


 attribute T_MODIFY_CATALOG/CATALOG/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#07-[A-Z]{3}[0-9]{3}#[0-9]{39} |
annotation
documentation
Das Attribut identifiziert den Wert des ECLASS Merkmals über die IRDI.


 element T_MODIFY_CATALOG/REF_CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CATALOG_NUMBER CATALOG_NAME
annotation
documentation
In diesem Element wird angegeben, auf welchen Katalog sich die Modifikationsdatei bezieht.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children MANUFACTURER_ID ISO_LANGUAGE_ID CURRENCY_KEY COUNTRY_ID ASSOC_CTM_NO PRODUCT_BRANDNAME PRICE_ID VAT
annotation
documentation
In diesem Element wird der Katalog identifiziert, auf den sich diese Modifikationsdatei bezieht. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/MANUFACTURER_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/ASSOC_CTM_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände").


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/PRODUCT_BRANDNAME
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/PRICE_ID
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/VAT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_NUMBER
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
annotation
documentation
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_NAME
diagram
type | languagetexte30
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.


 element T_MODIFY_CATALOG/SERIES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SERIE
annotation
documentation
In diesem Element werden alle Serien des Kataloges/Datenbestandes hinterlegt, an denen Modifikationen zum Basiskatalog vorgenommen werden einschließlich ihrer zugeordneten Elemente wie beipsielsweise Produktgruppen oder Artikeln .


 element T_MODIFY_CATALOG/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 100
content | complex
children SERIES_NAME PRODUCT_GROUPS CLASSIFICATION
annotation
documentation
In diesem Element werden die Serien definiert, bei denen Modifikationen zum Basiskatalog vorgenommen werden.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
In diesem Attribut wird die Seriennummer der Serie referenziert.


 element T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children LANGUAGE
annotation
documentation
Dieses Element gibt den modifizierten Seriennamen an.


 element T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/TEXT_LINE
diagram
properties
content complex
children TEXT FULL_TEXT
annotation
documentation
In diesem Element wird eine Textzeile hinterlegt.
Das Element TEXT beinhaltet den Text.


 element T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/TEXT_LINE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/TEXT_LINE/FULL_TEXT
diagram
type xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
content complex
children PRODUCT_GROUP
annotation
documentation
In diesem Element werden auf die Produktgruppen referenziert, in denen Modifikationen gegenüber dem Basiskatalog vorgenommen werden. In Produktgruppen sind Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEMS
annotation
documentation
In diesem Element werden zu modifizierende Artikel angelegt, die in dem Basiskatalog zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
In diesem Element werden alle zu modifiziernden Artikel einer Produktgruppe referenziert.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children VALID_FROM VALID_UNTIL CLASSIFICATION
annotation
documentation
In diesem Element werden Artikel und Blöcke angegeben, deren Gültigkeit sich gegenüber dem Hauptkatalog ändert. Ein Artikel wird identifiziert über die Attribute SERIE_NO und TYPE_NO


 attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60).


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children ECLASS_IRDI ECLASS_PROPERTY
annotation
documentation
In diesem Element werden die Klassifikationsangaben auf Artikelebene hinterlegt.

Angaben auf tieferen Ebenen zu gleichen Merkmalen überschreiben den auf Artikelebene angegebenen Wert.


element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_IRDI

 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_IRDI >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | 0173-1#01-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
In diesem Element wird die IRDI der 4. Ebene der hierarchischen ECLASS Klassenstruktur hinterlegt.


element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY

 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children ECLASS_VALUE
annotation
documentation
In diesem Element werden die ECLASS Merkmale auf Artikelebene hinterlegt.


attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI

 attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#02-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
Das Attribut identifiziert das ECLASS Merkmal über die IRDI.


element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE

 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Werte des ECLASS Merkmals hinterlegt.


attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI

 attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#07-[A-Z]{3}[0-9]{3}#[0-9]{39} |
annotation
documentation
Das Attribut identifiziert den Wert des ECLASS Merkmals über die IRDI.


 element T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children ECLASS_IRDI ECLASS_PROPERTY
annotation
documentation
In diesem Element können Klassifikationsangaben auf Serienebene hinterlegt werden.

Angaben auf tieferen Ebenen zur Klasse oder gleichen Merkmalen überschreiben den auf Serienebene angegebenen Wert.


 element T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION/ECLASS_IRDI
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | 0173-1#01-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
In diesem Element wird die IRDI der 4. Ebene der hierarchischen ECLASS Klassenstruktur hinterlegt.


 element T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION/ECLASS_PROPERTY
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children ECLASS_VALUE
annotation
documentation
In diesem Element werden die ECLASS Merkmale auf Serienebene hinterlegt.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#02-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
Das Attribut identifiziert das ECLASS Merkmal über die IRDI.


 element T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Werte des ECLASS Merkmals hinterlegt.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#07-[A-Z]{3}[0-9]{3}#[0-9]{39} |
annotation
documentation
Das Attribut identifiziert den Wert des ECLASS Merkmals über die IRDI.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FEATURES
annotation
documentation
In diesem Element werden zu modifizierende variantenabhängige Informationen hinterlegt.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES
diagram
properties
content complex
children FEATURE
annotation
documentation
In diesem Element werden die Variantenarten (FEATURE) und die zughörigen zu modifizieren Varianten definiert. Es werden nur die Variantenarten angegeben, die zur Modifizierung des Kataloges erforderlich sind.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTIONS ECLASS_PROPERTY
annotation
documentation
In diesem Element wird eine Variantenart definiert.


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird die Variantenart identifiziert.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTION
annotation
documentation
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTION_TEXT OPTION_COMMENT_TEXT VALID_FROM VALID_UNTIL ECLASS_PROPERTY ECLASS_VALUE
annotation
documentation
In diesem Element werden die Varianten für eine Variantenart definiert und alle im Datenbestand zu modifizierenden Varianten abgelegt.
Sollte es sich dabei um Sonderfarben handeln, sind für jedes Farbschema (z.B. RAL, NCS, etc…) separate OPTION anzulegen. (siehe auch: Best Practices/Sonderfarben)


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein.


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung definiert.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT
diagram
type | languagetexte60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
In diesem Element wird ein modifizierter Variantentext definiert.


 element languagetexte60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


attribute languagetexte60/LANGUAGE/@ISO_LANGUAGE_ID

 attribute languagetexte60/LANGUAGE/@ISO_LANGUAGE_ID >
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


element languagetexte60/LANGUAGE/TEXT

 element languagetexte60/LANGUAGE/TEXT >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,60} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_COMMENT_TEXT
diagram
type | languagetexte60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante modifiziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

- Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
- Beide Elemente leer: uneingeschränkt lieferbar.
- Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
- Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

- Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
- Beide Elemente leer: uneingeschränkt lieferbar.
- Nur das Element VALID_FROM gefällt: ab diesem Datum lieferbar.
- Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwänscht, muss das Element leer bleiben.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_PROPERTY
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children ECLASS_VALUE
annotation
documentation
In diesem Element werden die ECLASS Merkmale an der Variante hinterlegt.


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#02-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
Das Attribut identifiziert das ECLASS Merkmal über die IRDI.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_PROPERTY/ECLASS_VALUE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Werte des ECLASS Merkmals hinterlegt.


attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI

 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#07-[A-Z]{3}[0-9]{3}#[0-9]{39} |
annotation
documentation
Das Attribut identifiziert den Wert des ECLASS Merkmals über die IRDI.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_VALUE
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Werte eines ECLASS Merkmals hinterlegt.


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_VALUE/@ECLASS_VALUE_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#07-[A-Z]{3}[0-9]{3}#[0-9]{39} |
annotation
documentation
Das Attribut identifiziert den Wert eines ECLASS Merkmals über die IRDI.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/ECLASS_PROPERTY
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die ECLASS Merkmale an der Variantenart hinterlegt.


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#02-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
Das Attribut identifiziert das ECLASS Merkmal über die IRDI.


 element T_MODIFY_CATALOG/PRICE_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PRICE_FEATURE_GROUPS
annotation
documentation
In diesem Element werden Informationen für die Katalogmodfizierung hinterlegt, die für die Preisberechnung notwengig sind wie beispielsweise Preistabellen und Ausführungsgruppen.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS
diagram
properties
content complex
children PRICE_FEATURE_GROUP
annotation
documentation
In diesem Element werden Preisvariantengruppen referenziert, die gegenüber dem Basiskatalog modifiziert werden.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FINISH
annotation
documentation
In diesem Element werden eine Preisvariantengruppe referenziert, die gegenüber dem Basiskatalog Modifikationsinformationen enthalten soll.


 attribute T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@PRICE_FEATURE_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTION_REF PRICE_FIELD BLOCK_PRICE_FIELD SUPPLIER_PRICE_GROUP
annotation
documentation
In diesem Element werden Variantenkombinationen zu modifizierten Preisfeldern (Preisfeld, Blockpreisfeld) und einer Herstellerpreisgruppe zugeordnet.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF
diagram
properties
minOcc | 0
maxOcc | 2
content | complex
annotation
documentation
Mit diesem Element wird eine Variante referenziert.


 attribute T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 attribute T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/PRICE_FIELD
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2 im Basiskatalog) abgelegt.
Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/BLOCK_PRICE_FIELD
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
Dieses Feld gibt an, in welchem veränderten Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2 im Basiskatalog).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/SUPPLIER_PRICE_GROUP
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
annotation
documentation
In diesem Element wird die veränderte Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet.


 complexType languagetexte
diagram
children LANGUAGE
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.


 element languagetexte/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute languagetexte/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetexte/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
b Fettdruck
br Zeilenumbruch


 complexType languagetexte30
diagram
children LANGUAGE
used by
elements T_MODIFY_CATALOG/CATALOG/CATALOG_NAME T_MODIFY_CATALOG/REF_CATALOG/CATALOG_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.


 complexType languagetexte40
diagram
children LANGUAGE
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.


 element languagetexte40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetexte40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetexte40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,40} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 complexType languagetexte60
diagram
children LANGUAGE
used by
elements T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_COMMENT_TEXT T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.


 complexType languagetexte60999
diagram
children LANGUAGE
used by
element T_MODIFY_CATALOG/CATALOG/CATALOG_INFO
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bstehend aus bis zu 999 Zeilen der Länge 60.