 Introduction

Ansicht mit Navigationswerkzeuge

Modification IDM 3.0.0 XML-Schema

Documentation

release 01/12/2022

Documented XML-scheme:

MODIFY_IDM_3_0_0.xsd

Contact DCC e.V.

Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telephon 0 52 21/12 65-37

Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telephon 0 52 21/12 65-38


 Basic structure of the IDM scheme

Modification IDM 3.0.0 XML-Schema Documentation

Introduction > Basic structure of the IDM scheme

The main element T_MODIFY_CATALOG defines that a modification file for a complete catalogue data pool is made available.

XML files must be UTF-8 encrypted.

The IDM schema is subdivided in data ranges that are specified in the subsequent child-elements (see figure 1) in T_MODIFY_CATALOG.

Figure 1 - child elements in T_NEW_CATALOG

The data ranges are not used in isolation from each other. In some data ranges, data is initially created and used from other data ranges via referencing.

Description of the data ranges

CATALOG

Administrative information about the data pool is specified in CATALOG. E.g. the version of the data format, release date or the unique identification of the data pool.

REF_CATALOG

Information about the main catalogue is stored in REF_CATAG.

SERIES

SERIES is used to store the data for the description of the items. Items are combined into product groups, such as base units or shelf units.

FEATURE_DEFINITION

The version information is specified in FEATURE_DEFINITION The specified data are the modifications from the main catalogue.

PRICE_DEFINITION

The price information is specified in PRICE_DEFINITION. The information relates on e.g. modified price fields from the main catalogue.


 Catalogue structure

Modification IDM 3.0.0 XML-Schema Documentation

Introduction > Catalogue structure

Catalogue and element structure

The general catalogue structure of the database is built up as follows:

Pict.1 – Catalogue structure of databases

This catalogue structure is represented by the following element hierarchy in the IDM scheme:

Pict. 1 – Element hierarchy of the IDM scheme

The element SERIE is used for defining the properties of a series. The element RESTRICTION_REF assigns features to a series by means of restrictions. Within one series different produkt groups (PRODUCT_GROUPS) are defined which combine all items with similar features to one group. As items are child elements of the element SERIE they are automatically assigned to this series.


 Referencing

Modification IDM 3.0.0 XML-Schema Documentation

Introduction > Referencing

Referencing of elements

The IDM schema establishes relationships between elements and defines information at a central point which are used on multiple occasions in another position. The reuse of the information and the structure of element relationships takes place via referencing. The type of referencing used in the IDM schema is described in the following.

Definition of terms

The IDM schema uses the following terms for the referencing of elements:

Key-Element | an XML element which is referenced by other elements.
Ref-Element | an XML element which references other elements.

Reference procedure

The key element has attributes that allow for its unequivocal identification. The ref element has at least the key attributes of the key element. The reference in which the attribute values of the ref element are identical to those of the key element is established between the elements.

Example: referencing of a version

The following example shows how to newly reference a version from a design range.

Key-element

T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!—Plinth finish -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!—Plinth colour -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

For version type 400 (FEATURE),FEATUREthe XML elements define three versions (OPTION) numbered 1-3, as well as three versions numbered 1-3 for version type 401. A version is identified via the combination FEATURE_NO and OPTION_KEY.

Ref-element

T_MODIFY_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_REF


 Data types

Modification IDM 3.0.0 XML-Schema Documentation

Introduction > Datatypes

Data types and value ranges

The IDM schema used the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

The following data types are used:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDM, the data type date is used in conformity with the XML schemas as follows: YYYY-MM-DD YYYY = year, MM = month, DD = day
dateTime | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY-MM-DDThh:mm:ssZ YYYY = year, MM = month, DD = day T = Start of time information hh = hour, mm = minute, ss = second Z = UTC time
gYear | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDM for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 or 45.98000 or +27.0.
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDM for mapping URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used for the specification of valid language codes in the IDM.language represents codes for natural languages Tags for the Identification of Languagesas defined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.

The value ranges of the above data types are usually restricted for the elements in the IDM. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters and value lists.

In the XML documentation of the IDM, the value ranges are specified by the information coming after M and P.

In addition to XML data types mentioned here, separate data types are defined for the texts.

They are explained at the end of the documentation.

See also

languagetexte Complex Type

languagetexte30 Complex Type

languagetexte40 Complex Type

languagetexte60 Complex Type

languagetexte60999 Complex Type


 Explanations for the documentation

ModificationIDM 3.0.0 XML-Schema Documentation

Introduction > Explanations for the documentation

Explanations for the IDM documentation

This paragraph contains explanations for the documentation of the IDM scheme.

Meaning of element properties

Each element is documented with a description and its properties. The following example shows an element description:

EXCHANGE_ID_NO Attribute Collapse All

Description

This attribute identifies an exchange-ID.

D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

The properties of the element are listed on the right side. The following abbreviations are used:

D | Documentation of the data type for the element. If no value is set here, the element does not contain user data but further child elements.
P | The values P and M are used to define the range of values. The regular term in P defines the number of legal values.
M | M defines the minium and maximum value in the range of legal values. In a string data type P defines the legal values and M defines the minimum and maximum length of the string. For numerical data types M defines the minimum and maximum value.


 Variation types

Ansicht mit Navigationswerkzeuge

Modification IDM 3.0.0 XML-Schema Documentation

Introduction > Variation types

Variation type | Variation text | Option type | Remark
1 | programm/ style | A | programm asvariation type
2 | serial number | A | assignment of a five-digit serial number
100 | Front finish | A |
101 | Front colour 1 | F | Front filling smooth = complete surface
102 | Front colour 2 | F | Frame
103 | Front colour 3 | F | Pilaster strips
104 | Edge colour front | F |
105 | Front combination | K | If only one key is given for several front information. If variant type 105 is filled, it overrides variant types 100-104 to the extent that they are only for internal use by the software companies (e.g. internal colour control). These are then set as invisible header variants ("U") in the element HEADER_POS_VARIATION_TYPE. For external use as a selection for the user (e.g. query as header and order information), only the elements under EDI_INFO are used.
106 | Front group | A | Overrides the FRONT_GROUP_NO in element FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Front finish contrast colour 1 | A |
111 | Front colour 1 contrast colour 1 | F | Front filling smooth = complete surface
112 | Front colour 2 contrast colour 1 | F | Frame
113 | Front colour 3 contrast colour 1 | F | Pilaster strips
114 | Edge colour front, contrast colour 1 | F |
115 | Front combination, contrast colour 1 | K | The variations 111 - 114 are permitted.
120 | Front finish contrast colour 2 | A |
121 | Front colour 1 contrast colour 2 | F | Front filling smooth = complete surface
122 | Front colour 2 contrast colour 2 | F | Frame
123 | Front colour 3 contrast colour 2 | F | Pilaster strips
124 | Edge colour front, contrast colour 2 | F |
125 | Front combination, contrast colour 2 | K | The variations 121 - 124 are permitted.
150 | Glass finish | A |
151 | Glass colour | F |
152 | Mullion type | A |
153 | Mullion colour | F |
154 | Type glass door frame | A |
155 | Colour glass door frame | F |
160 | Type roller shutter | A |
161 | Colour roller shutter | F |
170 | Type container | A |
171 | Colour container | F |
200 | Type carcase | A |
201 | Carcase combination | K | If there is only one key for several carcase colours - inside/outside. If variant type 201 is filled, it overrides variant types 200, 202-205 to the extent that they are only for internal use by the software companies (e.g. internal colour control). These are then set as invisible header variants ("U") in the element HEADER_POS_VARIATION_TYPE. For external use as a selection for the user (e.g. query as header and order information), only the elements under EDI_INFO are used.
202 | Exterior carcase colour | F |
203 | Interior carcase colour | F |
204 | Edge carcase | A |
205 | Edge colour carcase | F |
206 | Type visible side | A |
207 | Colour visible side | F |
208 | Interior carcase colour for glass door cabinets | F | Glass door cabinets and open cabinets, which are not a shelf .
209 | Interior carcase for glass door cabinets | A | Glass door cabinets and open cabinets, which are not a shelf .
300 | Type handle | A |
301 | Handle colour 1 | F | Colour handle, knob or main colour
302 | Handle colour 2 | F | Colour bow, railing, or knob handles
303 | Combination of handles | K | If only one key is given for several handle conditions. If variant type 303 is filled, it overrides variant types 300-302 to the extent that they are only for internal use by the software companies (e.g. internal colour control). These are then set as invisible header variants ("U") in the element HEADER_POS_VARIATION_TYPE. For external use as a selection for the user (e.g. query as header and order information), only the elements under EDI_INFO are used.
304 | Handle positions | NULL | cf. handle positions p. 5-23
400 | Type plinth | A |
401 | Plinth colour | F |
402 | Plinth height | A |
410 | Type plinth bottom | A |
411 | Colour plinth bottom | F |
500 | Type shelves | A |
501 | Colour shelves | F |
502 | Type cornice | A | Includes shape and material
503 | Colour cornice | F |
504 | Type light pelment | A | Includes shape and material
505 | Colour light pelmet | F |
506 | Type ceiling filler | A |
507 | Colour ceiling filler | F |
508 | Type filler | A | Bottom ledge
509 | Colour bottopm ledge | F | Bottom ledge
510 | Type gallery shelf | A |
511 | Colour gallery shelf | F |
512 | Type gallery shelf edge | A |
513 | Colour gallery shelf edge | F |
514 | Type board | A |
515 | Colour board | F |
516 | Type board edge | A |
517 | Colour board edge | F |
520 | Type side panels/ bars | A |
521 | Colour side panels/ bars | F |
522 | Type bar panel edge | A |
523 | Colour bar panel edge | F |
524 | Type bottom shelf | A |
525 | Colour bottom shelf | F |
526 | Type bottom shelf edge | A |
527 | Colour bottom shelf edge | F |
550 | Type recess | A |
551 | Colour recess | F |
560 | Type recess accessories | A |
561 | Colour recess accessories | F |
562 | Type pilaster | A |
563 | Colour pilaster | F |
564 | Type pilaster edge | A |
565 | Colour pilaster edge | F |
600 | Type worktop | A |
601 | Colour worktop | F |
602 | Type worktop edge | A |
603 | Colour worktop edge | F |
604 | Type countertop | A |
605 | Colour countertop | F |
606 | Type countertop edge | A |
607 | Colour countertop edge | F |
620 | Type cover shelf | A |
621 | Colour cover shelf | F |
622 | Type cover shelf edge | A |
623 | Colour cover shelf | F |
624 | Type attachment table | A |
625 | Colour attachment table | F |
626 | Type attachment table edge | A |
627 | Colour attachment table edge | F |
650 | Type worktop upstand | A | Worktop upstand profile
651 | Colour worktop upstand | F | Worktop upstand profile
700 | Type drawer | A | Interior equipment
701 | Colour drawer | F | Interior equipment
702 | Type pull-out | A | Interior equipment
703 | Colour pull-out | F | Interior equipment
750 | Shape worktop | S |
751 | Shape cornice | S |
752 | Shape light pelmet | S |
753 | Shape plinth | S |
754 | Shape worktop upstand | S |
755 | Shape cover shelf | S |
756 | Shape countertop | S |
800 | Type electrical appliance | A |
801 | Colour electrical appliance | F |
802 | Colour electr. appliances accessories | F |
850 | Type sink | A |
851 | Colour sink | F |
852 | Colour sink accessories | F |
853 | Colour mixer taps | F |
854 | Type mixer taps | A |
900 | Type general accessories | A |
901 | Colour general accessories | F |
930 | additional, graphical relevant information about type 1. | A | The software suppliers have to be informed separately about the meaning.
931 | additional, graphical relevant information about colour 1. | F | The software suppliers have to be informed separately about the meaning.
932 | additional, graphical relevant information about type 2. | A | The software suppliers have to be informed separately about the meaning.
933 | additional, graphical relevant information about colour 2. | F | The software suppliers have to be informed separately about the meaning.
934 | additional, graphical relevant information about type 3. | A | The software suppliers have to be informed separately about the meaning.
935 | additional, graphical relevant information about colour 3. | F | The software suppliers have to be informed separately about the meaning.
936 | additional, graphical relevant information about type 4. | A | The software suppliers have to be informed separately about the meaning.
937 | additional, graphical relevant information about colour 4. | F | The software suppliers have to be informed separately about the meaning.
938 | additional, graphical relevant information about type 5. | A | The software suppliers have to be informed separately about the meaning.
939 | additional, graphical relevant information about colour 5. | F | The software suppliers have to be informed separately about the meaning.
950 | Type miscellaneous 1 | A |
951 | Colour miscellaneous 1 | F |
952 | Type miscellaneous 2 | A |
953 | Colour miscellaneous 2 | F |
954 | Type miscellaneous 3 | A |
955 | Colour miscellaneous 3 | F |
956 | Type miscellaneous 4 | A |
957 | Colour miscellaneous 4 | F |
958 | Type miscellaneous 5 | A |
959 | Colour miscellaneous 5 | F |
960 | Type miscellaneous 6 | A |
961 | Colour miscellaneous 6 | F |
962 | Type miscellaneous 7 | A |
963 | Colour miscellaneous 7 | F |
964 | Type miscellaneous 8 | A |
965 | Colour miscellaneous 8 | F |
966 | Type miscellaneous 9 | A |
967 | Colour miscellaneous 9 | F |
968 | Type miscellaneous 10 | A |
969 | Colour miscellaneous 10 | F |
970 | Type miscellaneous 11 | A |
971 | Colour miscellaneous 11 | F |
972 | Type miscellaneous 12 | A |
973 | Colour miscellaneous 12 | F |
974 | Type miscellaneous 13 | A |
975 | Colour miscellaneous 13 | F |
976 | Type miscellaneous 14 | A |
977 | Colour miscellaneous 14 | F |
978 | Type miscellaneous 15 | A |
979 | Colour miscellaneous 15 | F |
980 | Type miscellaneous 16 | A |
981 | Colour miscellaneous 16 | F |
982 | Type miscellaneous 17 | A |
983 | Colour miscellaneous 17 | F |
984 | Type miscellaneous 18 | A |
985 | Colour miscellaneous 18 | F |
986 | Type miscellaneous 19 | A |
987 | Colour miscellaneous 19 | F |
988 | Type miscellaneous 20 | A |
989 | Colour miscellaneous 20 | F |
998 | customer-specific motifs | F |
999 | Fixed material assignment | F | This variant type is defined globally, but may only be used in the material properties.

Type: A = type

F = colour

K = combination

S = shape


 Language key

Modification IDM 3.0.0 XML-Schema Documentation

Introduction > Language key

Language key | Language name
AA | Afar
AB | Abkhazian
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AV | Avarisch
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CR | Cree
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundish
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothish
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VE | Tshivenda
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu


 Country code

Modification IDM 3.0.0 XML-Schema Documentation

Introduction > Country code

country code | country
AC | Ascension
AD | Andorra
AE | United Arab Emirates
AF | Afghanistan
AG | Antigua and Barbuda
AI | Anguilla
AL | Albania
AM | Armenia
AN | Dutch Antilles
AO | Angola
AQ | Antarctica
AR | Argentina
AS | American Samoa
AT | Austria
AU | Australia
AW | Aruba
AX | Aland
AZ | Azerbaijan
BA | Bosnia and Herzegovina
BB | Barbados
BD | Bangladesh
BE | Belgium
BF | Burkina Faso
BG | Bulgaria
BH | Bahrain
BI | Burundi
BJ | Benin
BL | Saint-Barthélemy
BM | Bermuda
BN | Brunei Darussalam
BO | Bolivia
BQ | Bonaire, Sint Eustatius and Saba
BR | Brazil
BS | Bahamas
BT | Bhutan
BU | Burma
BV | Bouvet Island
BW | Botswana
BY | Belarus
BZ | Belize
CA | Canada
CC | Cocos) Islands
CD | Democratic Republic of the Congo
CF | Central African Republic
CG | Republic of the Congo
CH | Switzerland
CI | Ivory Coast
CK | Cook Islands
CL | Chile
CM | Cameroon
CN | China
CO | Columbia
CP | Clipperton
CR | Costa Rica
CU | Cuba
CV | Cape Verde
CW | Curaçao
CX | Christmas Island
CY | Cyprus
CZ | Czech Republic
DE | Germany
DG | Diego Garcia
DJ | Djibouti
DK | Denmark
DM | Dominica
DO | Dominican Republic
DZ | Algeria
EA | Ceuta, Melilla
EC | Ecuador
EE | Estonia
EG | Egypt
EH | Westsahara
EN | England
ER | Eritrea
ES | Spain
ET | Ethiopia
FI | Finland
FJ | Fiji
FK | Falklands
FM | Micronesia
FO | Faeroe Islands
FR | France
GA | Gabon
GB | England/Great Britain
GD | Grenada
GE | Georgia
GF | French Guiana
GG | Guernsey (Channel Island)
GH | Ghana
GI | Gibraltar
GL | Greenland
GM | Gambia
GN | Guinea
GP | Guadeloupe
GQ | Equatorial Guinea
GR | Greece
GS | South Georgia and the South Sandwich Islands
GT | Guatemala
GU | Guam
GW | Guinea-Bissau
GY | Guyana
HK | Hong Kong
HM | Heard and McDonald Islands
HN | Honduras
HR | Croatia
HT | Haiti
HU | Hungary
ID | Indonesian
IE | Ireland
IL | Israel
IM | Isle of Man
IN | India
IO | British Indian Ocean Territory
IQ | Iraq
IR | Islamic Republic of Iran
IS | Iceland
IT | Italy
JE | Channel Island of Jersey
JM | Jamaica
JO | Jordan
JP | Japan
KE | Kenya
KG | Kyrgyzstan
KH | Cambodia
KI | Kiribati
KM | Comoros
KN | Saint Kitts and Nevis
KP | Democratic People's Republic of Korea
KR | Republic of Korea
KW | Kuwait
KY | Cayman Islands
KZ | Kazakstan
LA | Laos
LB | Lebanon
LC | Saint Lucia
LI | Liechtenstein
LK | Sri Lanka
LR | Liberia
LS | Lesotho
LT | Lithuania
LU | Luxembourg
LV | Latvia
LY | Libya
MA | Morocco
MC | Monaco
MD | Moldavia
ME | Montenegro
MF | Saint Martin
MG | Madagascar
MH | Marshall Islands
MK | North Macedonia
ML | Mali
MM | Myanmar (Burma)
MN | Mongolia
MO | Macau
MP | Northern Mariana Islands
MQ | Martinique
MR | Mauritania
MS | Montserrat
MT | Malta
MU | Mauritius
MV | Maldives
MW | Malawi
MX | Mexico
MY | Malaysia
MZ | Mozambique
NA | Namibia
NC | New Caledonia
NE | Niger
NF | Norfolk Island
NG | Nigeria
NI | Nicaragua
NL | Netherlands
NO | Norway
NP | Nepal
NR | Nauru
NU | Niue
NZ | New Zealand
OM | Oman
PA | Panama
PE | Peru
PF | French Polynesia
PG | Papuan New Guinea
PH | Philippine
PK | Pakistan
PL | Poland
PM | St. Pierre and Miquelon
PN | Pitcairn Islands
PR | Puerto Rica
PS | Palestine
PT | Portugal
PW | Palau
PY | Paraguay
QA | Qatar
RE | Reunion
RO | Romania
RS | Serbia
RU | Russia
RW | Ruanda
SA | Saudi Arabia
SB | Solomon Islands
SC | Seychelles
SD | Sudan
SE | Sweden
SG | Singapore
SH | St. Helena
SI | Slovenia
SJ | Svalbard and Jan Mayen Islands
SK | Slovak Republic
SL | Sierra Leone
SM | San Marino
SN | Senegal
SO | Somalia
SR | Suriname
SS | South Sudan
ST | Democratic Republic of São Tomé and Príncipe
SV | El Salvador
SX | Sint Maarten
SY | Syrian Arab Republic
SZ | Swaziland
TC | Turks and Caicos Islands
TD | Chad
TF | French Southern and Antarctic Territories
TG | Togo
TH | Thailand
TJ | Tadschikistan
TK | Tokelau
TL | East Timor
TM | Turkmenistan
TN | Tunisia
TO | Tonga
TR | Turkey
TT | Trinidad and Tobago
TV | Tuvalu
TW | Taiwan
TZ | Tanzania
UA | Ukraine
UG | Uganda
UM | United States Minor Outlying Islands
US | United States of America
UY | Uruguay
UZ | Uzbekistan
VA | Vatican City
VC | Saint Vincent and the Grenadines
VE | Venezuela
VG | British Virgin Islands
VI | American Virgin Islands
VN | Vietnam
VU | Vanuatu
WF | Wallis and Futuna Islands
WS | Samoa
YE | Yemen
YT | Mayotte
ZA | South Africa
ZM | Sambia
ZW | Zimbabwe


 Buying associations
Modification IDM 3.0.0 XML-Schema Documentation Introduction > Buying associations
Buying association customer | Name buying association | Street | Postal Code | City | Phone | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13 A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Beinhaltet Form und Material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunscheig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co. KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60


 Filename

Modification IDM 3.0.0 XML-Schema Documentation

Introduction > Filename

The following is recommended for the file name associated with a data record:

· The name of the data record must not be limited to 8 characters.

· If possible, all components from the CATALOG_IDENTIFICATION should be used:

· The following components are suggested:

· Manufacturer number

· IDM version

· Customer number (value from the ASSOC_CTM_NO element)

· All languages

· Year

· Major number (MAJOR)

· File release timestamp (FILE_RELEASE_DATE)


 Best Practice

Best Practices

for documented XML schema:

MODIFY_IDM_3_0_0.xsd

Status 01.09.2022

Contact DCC e.V.

Dr.-Ing. Olaf Plümer
E-mail pluemer@dcc-moebel.org
Phone 0 52 21/12 65-37

Anika Degenhard
E-mail degenhard@dcc-moebel.org
Phone 0 52 21/12 65-38


 Special colours

IDM 3.0.0 XML-Schema Documentation

Best Practice > Special colours

Not all possible spot colours can be created individually in an IDM catalogue.

Therefore, it is necessary to define a structure that enables the planning systems to show the applicable special colours.

For this purpose, a option is to be created for each standardised colour scheme, e.g. RAL, NCS, SIKKENS, etc.

Example 1:

The supplier offers a desired colour in the RAL and NCS colour schemes for various design elements.

Correct:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Wrong:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Example 2:

The supplier offers the RAL, NCS and SIKKENS colour schemes. Depending on the model and texture, there are separate OPTION_KEYs for each scheme.

Correct:

Ein Bild, das Text enthält. Automatisch generierte Beschreibung Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Example 3:

The supplier offers a desired colour in the RAL and SIKKENS colour schemes for various surface structures, but only differentiates between the surfaces in the variants.

Wrong:


 Schema MODIFY_IDM_3_0_0.xsd.EN.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\IDM\Doku MODIFY_IDM\MODIFY_IDM_3_0_0.xsd.EN.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
T_MODIFY_CATALOG | languagetexte
 | languagetexte30
 | languagetexte40
 | languagetexte60
 | languagetexte60999


 element T_MODIFY_CATALOG
diagram
properties
content complex
children Signature CATALOG REF_CATALOG SERIES FEATURE_DEFINITION PRICE_DEFINITION
annotation
documentation
This element is used to specify all information and data for the modification of an existing catalogue/data pool.


 attribute T_MODIFY_CATALOG/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 3 |
maxInclusive | 3 |
annotation
documentation
The version number "MAJOR" indicates the format version of the database. This main version number is only changed if the format is changed completely.
The complete definition of a format version consists of the following elements: MAJOR, MINOR and REVISION.


 attribute T_MODIFY_CATALOG/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 0 |
annotation
documentation
In general the number of the sub-version "MINOR" changes every year. In case the main version number MAJOR is changed, the sub-version number is reset to 0.


 attribute T_MODIFY_CATALOG/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 0 |
annotation
documentation
During the year the field revision number "REVISION" indicates changes of the format, as agreed upon in the regular sessions of the committee. The different revisions are not issued unless they are necessary corrections. The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0.


 element T_MODIFY_CATALOG/Signature
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SignedInfo SignatureValue
annotation
documentation
This element defines the type of encryption.

The root element of a digital signature via XML is represented by the element Signature.

Signature has two child elements in which the elements SignedInfo and SignatureValue are mandatory.


 element T_MODIFY_CATALOG/Signature/SignedInfo
diagram
properties
content complex
children CanonicalizationMethod SignatureMethod Reference
annotation
documentation
The first and most complex element of Signature is the element SignedInfo. This element contains the utilized algorithms for canonization and signature, one or more references to the signed data, and probable transformations as well as the hash values of these data. Moreover the element SignedInfo contains all relevant information about the resources which are signed and is therefore the part for which the digital signature is defined.

Digital signature of the algorithms is used for the purpose of data security. A secure algorithm cannot be exchanged by an insecure without cancellation of the signature.

Child elements of SignedInfo are the mandatory elements CanonizationMethod and SignatureMethod as well as one or more Reference elements.


 element T_MODIFY_CATALOG/Signature/SignedInfo/CanonicalizationMethod
diagram
type extension of xs:string
properties
content complex
annotation
documentation
The mandatory element CanonizationMethod contains an Algorithm attribute which identifies the canonization algorithm which is applied to the data with priority over signature evaluation in the element SignedInfo.

The canonization of an XML is split up into the following actions:

- A document is encoded into UTF-8 format
- Line breaks are normalised to #xA before parsing
- The values of attributes are normalised (similar to validating parsers)
- Character- and parsed-entity references are replaced
- CDATA paragraphs are replaced by their contents
- The XML declaration and a probably existing DTD are removed
- Blank elements are converted to start-end-tag pairs
- Whitespace outside of the document element and inside the start- and end-tags is normalised
- Whitespace in text knots is kept (except signs which were removed by the normalisation of line breaks)
- The values of attributes are given in double quotation marks
- Special characters in attribute values and text knots are replaced by sign references
- Redundant namespace declarations in front of each element are removed
- Default attributes are added to the elements
- The sort order of namespace declarations and attributes is alphanumeric


 attribute T_MODIFY_CATALOG/Signature/SignedInfo/CanonicalizationMethod/@Algorithm
type xs:anyURI
annotation
documentation
This attribute identifies the Canonization-algorithm, which is applied to data with priority over the signature calculation in the element SignedInfo. The specification is given by an URI.


 element T_MODIFY_CATALOG/Signature/SignedInfo/SignatureMethod
diagram
type extension of xs:string
properties
content complex
annotation
documentation
SignatureMethod is another mandatory, blank element with an algorithm attribute, which defines the algorithm used for the generation (and following the validation) of the signature. This algorithm is used for converting the canonical element SignedInfo into the element SignatureValue.


 attribute T_MODIFY_CATALOG/Signature/SignedInfo/SignatureMethod/@Algorithm
type xs:anyURI
annotation
documentation
This attribute is used for defining an algorithm for the generation of a signature which is defined by an URI.


 element T_MODIFY_CATALOG/Signature/SignedInfo/Reference
diagram
properties
content complex
children Transforms DigestMethod DigestValue
annotation
documentation
The element reference defines the random data (binary data permitted, too) which are included in the signature calculation. The element reference is therefore the core element of a signature.

XML-signatures never sign the resources directly. First a list of hash values is generated. This list is signed with the defined algorithm. In this way the process of the signature generation is accelerated and simplified as a number of resources is signed simultaneously.

The element reference is linked to the optional attribute URI.


 attribute T_MODIFY_CATALOG/Signature/SignedInfo/Reference/@URI
type xs:string
annotation
documentation
The type of the attribute URI is that of anyURI and contains the address of the data which have to be signed. It is not necessary that the data which the digital signature refers to are part of the element signature. The data can be referenced by a local file system or an hyperlink.

Moreover there are URI which refer to the current document ,e.g. URI="". This special type of Uniform Resource Identifier represents all XML knots of the current XML document but without probable comments. The knots which belong to a signature are part of repertory.


 element T_MODIFY_CATALOG/Signature/SignedInfo/Reference/Transforms
diagram
properties
content complex
children Transform
annotation
documentation
The element transforms defines the type of transformation in the child element transform. The hash value is calculated from the result of the transformation.

The element transforms consists of an algorithm attribute in combination with the transformation algorithm.


 element T_MODIFY_CATALOG/Signature/SignedInfo/Reference/Transforms/Transform
diagram
type extension of xs:string
properties
content complex
annotation
documentation
The element transform defines the type of transformation. It consists of an Algorithm Attribute with the applicable transformation algorithm.


 attribute T_MODIFY_CATALOG/Signature/SignedInfo/Reference/Transforms/Transform/@Algorithm
type xs:anyURI
annotation
documentation
This attribute is used for defining a transformation algorithm by means of an URI.


 element T_MODIFY_CATALOG/Signature/SignedInfo/Reference/DigestMethod
diagram
type extension of xs:string
properties
content complex
annotation
documentation
The blank, mandatory element DigestMethod contains only an URI in the algorithm attribute. This is used for identifying the message digest algorithm.


 attribute T_MODIFY_CATALOG/Signature/SignedInfo/Reference/DigestMethod/@Algorithm
type xs:anyURI
annotation
documentation
This attribute is used for defining the URI which identifies the message digest algorithm.


 element T_MODIFY_CATALOG/Signature/SignedInfo/Reference/DigestValue
diagram
type xs:string
properties
content simple
annotation
documentation
The algorithm defined in the element DigestMethod is used for calculating the DigestValue, which is a unique hash value of the signed object and saved in base-64 encoding format. The hash value is a kind of digital finger print, in general it is shorter than the data which were signed. In this way the following steps of digital signature are accelerated. It is almost impossible to infer the original message from the given hash value.


 element T_MODIFY_CATALOG/Signature/SignatureValue
diagram
type xs:string
properties
content simple
annotation
documentation
The element SignatureValue contains the binary hash value of the signature (always Base-64 encoded) calculated over the complete element SignedInfo . This hash value is given according to the algorithm defined in the element SignatureMethod and calculated from the canonized data and the private key. In this way it is not the message itself which is signed but only its (normally shorter) hash value ( Hash-Then-Sign Paradigma).

The signed data contain all information about the signed references and their hash values. Therefore it is not necessary that the data themselves are available in the document. All information about the utilized algorithms are part of the signature generation and subsequent manipulations are avoided.

As all references are summarized before the signature generation the complete signature has always exactly one SignatureValue element.


 element T_MODIFY_CATALOG/CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CATALOG_NAME DATA_VERSION FILE_ID CATALOG_MARK CATALOG_INFO CLASSIFICATION
annotation
documentation
All administrative information about the catalogue/ database is stored in this element.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children MANUFACTURER_ID CATALOG_ID MAJOR_NO MINOR_NO FILE_RELEASE_DATE ISO_LANGUAGE_ID CURRENCY_KEY COUNTRY_ID CATALOG_KIND ASSOC_CTM_NO PRODUCT_BRANDNAME PRICE_ID VAT
annotation
documentation
This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MANUFACTURER_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
The manufacturer must enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.

A manufacturer catalogue must always have the same ID for the same dealership.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MAJOR_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99 |
annotation
documentation
The catalogue version number MAJOR_NO indicates the year in which the main catalogue was created. The complete specification of the catalogue version in which a dataset is delivered consists of MAJOR and MINOR.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MINOR_NO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
The sub-catalog version number MINOR_NO is given in consecutive numbers during the year or during the period of validity of the main catalog. The complete specification of the catalog version in which a dataset is delivered consists of MAJOR and MINOR. If the catalog version MAJOR is changed, the sub-catalog version is reset to 0.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contains the current date and time (UTC).


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
The language key defines the language in which the texts of the dataset were created. The ISO language key is to be used for this purpose.

In the case of multilingual catalogues, all languages occurring in the catalogue must be entered here. Only the language keys entered in these elements may be used for the texts of the catalogue.
For example, in a Swiss catalogue, the ISO_LANGUAGE_ID's DE (German), FR (French) and IT (Italian) can be stored here.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
This element is used for the definition of the currency ID which applies to all prices given in a catalogue/ database. The rules and definitions of the ISO Currency-ID apply.
A change of currency keys within one database is not permitted. Updates during the year and also block prices haven to be given in the same currency unit as that of the basic file.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
The ISO country code of the target market is entered in this element.
For countries with several languages but the same currency, make sure to use the correct ISO country code.
For example, a Swiss catalogue may contain the 3 ISO_LANGUAGE_ID's DE (German), FR (French) and IT (Italian). However, the COUNTRY_ID must be indicated as CH (Switzerland).


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_KIND
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 2 |
maxInclusive | 3 |
annotation
documentation
This field is used to identify association catalogues.
The following values can be used:
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/ASSOC_CTM_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations")


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/PRODUCT_BRANDNAME
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/PRICE_ID
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
This element is used for the definition of a price ID, i.e. the way in which the prices in a catalogue are given.

The following price IDs are possible:
1 = Price;
2 = Ident number;
3 = calculation point.

If the flags 1 (price) or 2 (ident number) are filled in, a currency has to be filled in the field CURRENCY_KEY. If the flag 3 (calculation point) is set, values in the element CURRENCY_KEY are not permitted. If calculation points are used the the conversion factor has to be defined.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_IDENTIFICATION/VAT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element is used for the definition of the VAT key which is applied to the prices given in a database.
The following values are used:
0/False = prices excluding VAT
1/True = prices including VAT

This element is of essential importance for the pricing.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_NAME
diagram
type | languagetexte30
properties
content complex
children | LANGUAGE
annotation
documentation
This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.


 element languagetexte30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


 attribute languagetexte30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_MODIFY_CATALOG/CATALOG/DATA_VERSION
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database.


 element T_MODIFY_CATALOG/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data


 element T_MODIFY_CATALOG/CATALOG/CATALOG_MARK
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [M] |
annotation
documentation
This element is used to highlight the provision M data = data that has been modified from the main catalogue.


 element T_MODIFY_CATALOG/CATALOG/CATALOG_INFO
diagram
type | languagetexte60999
properties
content complex
children | LANGUAGE
annotation
documentation
Information texts are stored in this element.


 element languagetexte60999/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


 attribute languagetexte60999/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte60999/LANGUAGE/TEXT_LINE
diagram
properties
minOcc | 1
maxOcc | 999
content | complex
children TEXT
annotation
documentation
This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information


 attribute languagetexte60999/LANGUAGE/TEXT_LINE/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in.


 element languagetexte60999/LANGUAGE/TEXT_LINE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,60} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 element T_MODIFY_CATALOG/CATALOG/CLASSIFICATION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children ECLASS_VERSION ECLASS_PROPERTY
annotation
documentation
This element is used to store the classification information at catalog level.
If the catalog contains only one classification, the ECLASS_VERSION must be specified.

Information at lower levels for the same properties overwrites the value specified at catalog level.


 element T_MODIFY_CATALOG/CATALOG/CLASSIFICATION/ECLASS_VERSION
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
pattern |  |
annotation
documentation
The classification version is stored in this element.
Only the major no. of the version is specified.


 element T_MODIFY_CATALOG/CATALOG/CLASSIFICATION/ECLASS_PROPERTY
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children ECLASS_VALUE
annotation
documentation
In this element the ECLASS properties are stored on catalog level.
Specifications at lower levels for the same properties overwrite the value specified at catalog level.


 attribute T_MODIFY_CATALOG/CATALOG/CLASSIFICATION/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#02-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
The attribute identifies the ECLASS property via the IRDI.


 element T_MODIFY_CATALOG/CATALOG/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
The values of the ECLASS property are stored in this element.


 attribute T_MODIFY_CATALOG/CATALOG/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#07-[A-Z]{3}[0-9]{3}#[0-9]{39} |
annotation
documentation
The attribute identifies the value of the ECLASS property via the IRDI.


 element T_MODIFY_CATALOG/REF_CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CATALOG_NUMBER CATALOG_NAME
annotation
documentation
This element is used to specify the catalogue to which the modification file relates.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children MANUFACTURER_ID ISO_LANGUAGE_ID CURRENCY_KEY COUNTRY_ID ASSOC_CTM_NO PRODUCT_BRANDNAME PRICE_ID VAT
annotation
documentation
This element is used to identify the catalogue to which this modification file relates. A catalogue is identified unequivocally by the combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data, the corresponding block data or the value settlement must be identical.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/MANUFACTURER_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This element is used to enter the manufacturer ID valid for the manufacturer. The manufacturer IDs are defined in the table "Manufacturer ID". Leading zeros are omitted in the manufacturer ID.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
The language code defines the language in which the texts in the data pool were created. The ISOLanguage code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element is used to specify the correct country allocation where a language is spoken in multiple countries and the identical currency is specified. The ISO country code must be entered.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/ASSOC_CTM_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used to specify the customer number of the Association or customer for which the data pool is available.
The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "codes for purchasing associations")Purchasing associations


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/PRODUCT_BRANDNAME
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
The product brand assists in the unequivocal definition of a catalogue. It should be kept up-to-date in this element as required.

This is done by specifying a freely-definable number, which must remain identical for the validity of a product by across multiple catalogue rounds. This allows the software houses to allocate a catalogue to the previous year's catalogue, which in turn allows for a more efficient implementation of catalogues.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/PRICE_ID
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price;
2 = identification number;
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. In the case of settlement points, the corresponding settlement factor must be specified.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_IDENTIFICATION/VAT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT
This element is very important for pricing.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_NUMBER
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
annotation
documentation
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier.


 element T_MODIFY_CATALOG/REF_CATALOG/CATALOG_NAME
diagram
type | languagetexte30
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names with years are permitted as the unequivocal identification of the catalogue takes place via the PRODUCT_BRANDNAME element.


 element T_MODIFY_CATALOG/SERIES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SERIE
annotation
documentation
This element is used to specify all series of the catalogue/data pool that were modified from the base catalogue including their assigned elements, such as product groups or articles.


 element T_MODIFY_CATALOG/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 100
content | complex
children SERIES_NAME PRODUCT_GROUPS CLASSIFICATION
annotation
documentation
This element is used to define the series that were modified from the base catalogue.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute defines the serial number of the series.


 element T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children LANGUAGE
annotation
documentation
This element defines the name of the series.


 element T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/TEXT_LINE
diagram
properties
content complex
children TEXT FULL_TEXT
annotation
documentation
This element defines a text line.
The element TEXT contains text information.


 element T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/TEXT_LINE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_MODIFY_CATALOG/SERIES/SERIE/SERIES_NAME/LANGUAGE/TEXT_LINE/FULL_TEXT
diagram
type xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
content complex
children PRODUCT_GROUP
annotation
documentation
This element is used to reference to the product groups that were modified from the base catalogue.Articles with the same version types e.g. shelf units are grouped into product groups.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEMS
annotation
documentation
This element is used to create modified items that are combined in product groups in the base catalogue. "Identical" product groups must therefore not be captured.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
This element is used to reference all articles within a product group that are to be modified.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children VALID_FROM VALID_UNTIL CLASSIFICATION
annotation
documentation
This element is used to specify items and blocks with a different validity than in the base catalogue. An item is identified via the SERIE_NO and TYPE_NO attributes of the main catalogue.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99 |
annotation
documentation
This attribute is used to specify the serial number of the referenced series.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is used to enter the item code. (e.g. U60).


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element specifies the date on which the item becomes available for delivery.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.


 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children ECLASS_IRDI ECLASS_PROPERTY
annotation
documentation
In this element, the classification information is stored at item level.

Information at lower levels for the same properties overwrites the value specified at item level.


element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_IRDI

 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_IRDI >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | 0173-1#01-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
This element stores the IRDI of the 4th level of the hierarchical ECLASS class structure.


element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY

 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children ECLASS_VALUE
annotation
documentation
In this element the ECLASS properties are stored on item level.


attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI

 attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#02-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
The attribute identifies the ECLASS property via the IRDI.


element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE

 element T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
The values of the ECLASS property are stored in this element.


attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI

 attribute T_MODIFY_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#07-[A-Z]{3}[0-9]{3}#[0-9]{39} |
annotation
documentation
The attribute identifies the value of the ECLASS property via the IRDI.


 element T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children ECLASS_IRDI ECLASS_PROPERTY
annotation
documentation
This element can be used to store classification information at series level.

Specifications at lower levels for the class or the same properties overwrites the value specified at series level.


 element T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION/ECLASS_IRDI
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | 0173-1#01-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
This element stores the IRDI of the 4th level of the hierarchical ECLASS class structure.


 element T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION/ECLASS_PROPERTY
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children ECLASS_VALUE
annotation
documentation
In this element the ECLASS properties are stored on series level.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#02-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
The attribute identifies the ECLASS property via the IRDI.


 element T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
The values of the ECLASS property are stored in this element.


 attribute T_MODIFY_CATALOG/SERIES/SERIE/CLASSIFICATION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#07-[A-Z]{3}[0-9]{3}#[0-9]{39} |
annotation
documentation
The attribute identifies the value of the ECLASS property via the IRDI.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FEATURES
annotation
documentation
This element is used to specify version-specific information that is to be modified.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES
diagram
properties
content complex
children FEATURE
annotation
documentation
This element is used to define the version types (FEATURE) and the associated versions to be modified. Only version types that are required for modifying the catalogue are specified.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTIONS ECLASS_PROPERTY
annotation
documentation
This element is used to define a version type.


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies a feature.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTION
annotation
documentation
This element is used as a container for all possible options of a feature type.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTION_TEXT OPTION_COMMENT_TEXT VALID_FROM VALID_UNTIL ECLASS_PROPERTY ECLASS_VALUE
annotation
documentation
In this element, the options for a feature are defined and all options to be modified in the dataset are stored.
If these are special colours, separate OPTIONs must be created for each colour scheme (e.g. RAL, NCS, etc...). (see also: Best Practices/Special Colours)


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute references a feature. It is used to simplify the access to information. It has to be identical with the attribute FEATURE_NO of the superordinated element FEATURE.


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute defines an option. In case it is an option 1 (i.e. programme) and this is referenced by STYLE_NO in the element STYLE_REF identical values in these fields are required.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT
diagram
type | languagetexte60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element is used to define a modified version text.


 element languagetexte60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


attribute languagetexte60/LANGUAGE/@ISO_LANGUAGE_ID

 attribute languagetexte60/LANGUAGE/@ISO_LANGUAGE_ID >
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


element languagetexte60/LANGUAGE/TEXT

 element languagetexte60/LANGUAGE/TEXT >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,60} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_COMMENT_TEXT
diagram
type | languagetexte60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element is used to modify a general comment as a notice of special properties of a version. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

- Both elements filled: available for delivery in the resulting period.
- Both elements left blank: always available for delivery.
- Only the VALID_FRONT element is filled: available from delivery from this date onwards.
- Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
These elements are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:

- Both elements filled: available for delivery in the resulting period.
- Both elements left blank: always available for delivery.
- Only the VALID_FROM element is filled: on available for delivery from this date onwards.
- Only the VALID_UNTIL element is filled: only available for delivery until this date.

Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_PROPERTY
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children ECLASS_VALUE
annotation
documentation
In this element the ECLASS properties are stored at the option.


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#02-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
The attribute identifies the ECLASS property via the IRDI.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_PROPERTY/ECLASS_VALUE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
The values of the ECLASS property are stored in this element.


attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI

 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_PROPERTY/ECLASS_VALUE/@ECLASS_VALUE_IRDI >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#07-[A-Z]{3}[0-9]{3}#[0-9]{39} |
annotation
documentation
The attribute identifies the value of the ECLASS property via the IRDI.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_VALUE
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
The values of an ECLASS property are stored in this element.


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/ECLASS_VALUE/@ECLASS_VALUE_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#07-[A-Z]{3}[0-9]{3}#[0-9]{39} |
annotation
documentation
The attribute identifies the value of an ECLASS property via the IRDI.


 element T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/ECLASS_PROPERTY
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
In this element the ECLASS properties are stored at the feature.


 attribute T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/ECLASS_PROPERTY/@ECLASS_PROPERTY_IRDI
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | 0173-1#02-[A-Z]{3}[0-9]{3}#[0-9]{3} |
annotation
documentation
The attribute identifies the ECLASS property via the IRDI.


 element T_MODIFY_CATALOG/PRICE_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PRICE_FEATURE_GROUPS
annotation
documentation
This element is used to specify information for the catalogue modification that is necessary for the price calculation, such as price tables and design ranges.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS
diagram
properties
content complex
children PRICE_FEATURE_GROUP
annotation
documentation
This element is used to reference price version groups that are modified from the base catalogue.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FINISH
annotation
documentation
This element is used to reference a price version group that contains information on modifications from the base catalogue.


 attribute T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@PRICE_FEATURE_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTION_REF PRICE_FIELD BLOCK_PRICE_FIELD SUPPLIER_PRICE_GROUP
annotation
documentation
This element is used to assign version combinations to modified price fields (price field, block price field) and a manufacturer price group.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF
diagram
properties
minOcc | 0
maxOcc | 2
content | complex
annotation
documentation
This element is used to reference a version.


 attribute T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 attribute T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used to reference a version type.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/PRICE_FIELD
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1or path 2 in the base catalogue).
Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/BLOCK_PRICE_FIELD
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 250 |
annotation
documentation
This field is used to specify in which modified price field the block price for this range is stored. The corresponding price field is referenced for items designated as block (SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM elements with ITEM_IDENTIFICATION=2 in the base catalogue).

If the block prices are not specified for the catalogue price groups, but are rather assigned differently for the individual ranges within the catalogue price groups, this element must be filled as follows:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

The "BLOCK_PRICE_FIELD" must only be left blank if a manufacturer does not offer any blocks. It is in this respect irrelevant whether the normal catalogue file does not have any blocks in it, but rather whether the manufacturer offers blocks via any of its sales channels. A blank "BLOCK_PRICE_FIELD" field is only permitted if there will not be any block activities within the catalogue validity period.


 element T_MODIFY_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/SUPPLIER_PRICE_GROUP
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
annotation
documentation
This catalogue is used to specify the manufacturer's modified price group.

In the case of type-specific prices (PRICE_CALC_METHOD = 3), the value of the PRICE_FIELD element is "copied" into field SUPPLIER_PRICE_GROUP.
For universal prices (PRICE_CALC_METHOD = 1), any content can be used and will not be analysed.


 complexType languagetexte
diagram
children LANGUAGE
annotation
documentation
This data type is used for multilingual text information of any length.


 element languagetexte/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.


 attribute languagetexte/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node

The text must be specified in HTML format:
b Bold font
br line break


 complexType languagetexte30
diagram
children LANGUAGE
used by
elements T_MODIFY_CATALOG/CATALOG/CATALOG_NAME T_MODIFY_CATALOG/REF_CATALOG/CATALOG_NAME
annotation
documentation
This element is used for multilingual text information limited to 30 characters.


 complexType languagetexte40
diagram
children LANGUAGE
annotation
documentation
This element is used for multilingual text information limited to 40 characters.


 element languagetexte40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.


 attribute languagetexte40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute define sthe ISO-Code for the chosen language in the text information.


 element languagetexte40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,40} |
annotation
documentation
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE.


 complexType languagetexte60
diagram
children LANGUAGE
used by
elements T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_COMMENT_TEXT T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT
annotation
documentation
This element is used for multilingual text information limited to 60 characters.


 complexType languagetexte60999
diagram
children LANGUAGE
used by
element T_MODIFY_CATALOG/CATALOG/CATALOG_INFO
annotation
documentation
This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.