%%ItemTitle%%

IDM_MERGE 2.1.1 XML-Schema Dokumentation
Einleitung

IDM_MERGE 2.1.1 XML-Schema

Dokumentation

Stand 01 .05.2020

Dokumentiertes XML-Schema:

IDM_MERGE_2_1_1.xsd

Kontakt

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37


%%ItemTitle%%

IDM_MERGE 2.1.1 XML-Schema Dokumentation
Die Grundstruktur des IDM-Formates
Einleitung > Die Grundstruktur des IDM-Formates

Das Hauptelement T_NEW_MERGE_CATALOGS definiert, dass ein neuer, vollständiger Multihersteller-Katalogdatenbestand bereitgestellt wird.

Das IDM-Format ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Kind-Elemente (siehe Abbildung 1) von T_NEW_MERGE_CATALOGS abgebildet werden.

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

SUPPLIER

In SUPPLIER werden administrative Informationen zu dem Hersteller hinterlegt. Beispielsweise werden Kontaktdaten oder das Herkunftsland des Herstellers angegeben.

GLOBAL_DEFINITION

Der Datenbereich GLOBAL_DEFINITION ist eine Art Datenpool für Informationen, die in den anderen Datenbereichen verwendet werden. Beispielsweise werden hier Medien wie Fotos und Montageanleitungen angelegt.

CATALOG_REFERENCES

In CATALOG_REFERENCES werden über die GLN eines Herstellers und dessen Element CATALOG_ID die Kataloge referenziert, die zu diesem Multiherstellerkatalog gehören.


%%ItemTitle%%

IDM_MERGE 2.1.1 XML-Schema Dokumentation
Erläuterung zur Dokumentation
Einleitung > Erläuterung zur Dokumentation

Erläuterungen zur Dokumentation des IDM

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

IDM_MERGE 1.0.0 XML-Schema Dokumentation
DATA_VERSION Element
IDM_MERGE 1.0.0 XML-Schema Dokumentation > T_NEW_MERGE_CATALOGS Element > CATALOG Element : DATA_VERSION Element

Beschreibung

Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


%%ItemTitle%%

IDM_MERGE 2.1.1 XML-Schema Dokumentation
Datentypen und Wertebereiche
Einleitung > Datentypen und Wertebereiche

Datentypen und Wertebereiche

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

In der Version IDMP 2.4 werden folgende Datentypen verwendet:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDMP wird der Datentyp date XML-Schema konform in folgender Weise angewendet: YYYY-MM-DD Y = Jahr, M = Monat, D = Tag
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDMP für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDMP für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDMP für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.

Zusätzlich gibt es benutzerdefinierten Datentypen:

languagetext | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.
languagetext30 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
languagetext40 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.


%%ItemTitle%%

IDM_MERGE 2.1.1 XML-Schema Dokumentation
Sprachenschlüssel
Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Holländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu


%%ItemTitle%%

IDM_MERGE 2.1.1 XML-Schema Dokumentation
Länderschlüssel
Einleitung > Länderschlüssel

Länderkennzeichen | Ländername(deutsch) | Ländername(englisch)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
YU | Jugoslawien | Yugoslavia
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


%%ItemTitle%%

IDM_MERGE 2.1.1 XML-Schema Dokumentation
Typen für Detailinformationen
Einleitung > Typen für Detailinformationen

Für die Beschreibung der Art der Detailinformation gibt es folgende Info-Typen:

1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Funktionsbeschreibung
16 = Planungshinweis
17 = Katalogbild


%%ItemTitle%%

IDM_MERGE 2.1.1 XML-Schema Dokumentation
Elementreferenz


%%LocalItemTitle%%

IDM_MERGE
IDM_MERGE
Elemente
Element | Beschreibung
NODES | Der Knoten dient einer untergeordneten Gruppe des Einstieges für den Handel. Die Einstiegsstruktur darf maximal dreistufig sein.
T_NEW_MERGE_CATALOGS | In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.
Komplexe Typen
Complex Type | Beschreibung
languagetext | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.
languagetext30 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
languagetext40 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

© 2020 All Rights Reserved.

Send comments on this topic.


%%LocalItemTitle%%

IDM_MERGE
NODES Element
IDM_MERGE : NODES Element
Beschreibung

Der Knoten dient einer untergeordneten Gruppe des Einstieges für den Handel.

Die Einstiegsstruktur darf maximal dreistufig sein.

Namensraum (none)
Diagramm
NODE Element Sequence NODES Element
Overview
NODES

Der Knoten dient einer untergeordneten Gruppe des Einstieges für den Handel.

Die Einstiegsstruktur darf maximal dreistufig sein.

Sequence
NODE 1..∞

Dieses Element dient der Referenzierung durch die Einstiegsstruktur für den Handel bezüglich des Multiherstellerkataloges.

Er enthält die Einstiegsbezeichnung und die dazu gehörigen Katatalogreferenzierungen.

Dazu müssen Kataloge sortimentsentsprechend erfasst und in Multiherstellerkataloge involviert werden.

Ziel ist es, mit den Multiherstellerkatalogen, den Einstieg in das Sortiment zu erleichtern, bzw. zu optimieren. Es einsteht folglich eine Einstiegsstruktur, die möglichst dynamisch und flexibel das Sortiment strukturiert.

Beispiele möglicher Einstiege:

1)

• Stoff

• Leder

2)

• Wohnen

• Polster

3)

• Hausmarke

• Platzierte Modelle

• Freies Verbandssortiment

Das Ganze kann man sich auch noch mehrstufig vorstellen

4)

• Hausmarken

o Wohnen

o Polster

• Platzierte Modelle

o Lieferant A

o Lieferant B

• Freies Verbandssortiment

o Lieferant A

o Lieferant B

Hier sind unzählige Konstellationen denkbar. Jeder Hersteller wird hier seine eigene Vorstellung haben, wie diese Struktur aussehen soll.

NODE_NO required Restriction of xs:nonNegativeInteger
Hier wird der eindeutige Knoten-Identifikator erfasst. D positiveInteger
P
M [1:99]
SEQUENCE_NO required Restriction of xs:nonNegativeInteger
Hier wird die Sortierung realisiert. D nonNegativeInteger
P
M [0:99]
Sequence
NODE_NAME languagetext30 Complex Type
Hier wird die Einstiegsbezeichnung angegeben.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Choice
CATALOG_REFERENCES_REF
Dieses Element dient der Katalogreferenzierung.
Sequence
SUPPLIER_GLN_NO Restriction of xs:string
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
CATALOG_ID Restriction of xs:string

Hier wird die eindeutige ID eines Herstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
NODES

Der Knoten dient einer untergeordneten Gruppe des Einstieges für den Handel.

Die Einstiegsstruktur darf maximal dreistufig sein.

DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern oder anderer Medien für die Einstiegsstruktur.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="NODES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="NODE" minOccurs="1" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="NODE_NAME" type="languagetext30">
              <xs:annotation>
                <xs:documentation>Katalogname</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:choice>
              <xs:element name="CATALOG_REFERENCES_REF">
                <xs:annotation>
                  <xs:documentation>Referenzierung einer Knoteninformation</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="SUPPLIER_GLN_NO">
                      <xs:annotation>
                        <xs:documentation>GLN_Nr </xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:pattern value="[0-9]{13}" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="CATALOG_ID">
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:minLength value="1" />
                          <xs:maxLength value="64" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
              <xs:element ref="NODES" />
            </xs:choice>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>
                                        Angabe von Detailinformationen
                                    </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>
                                                    Referenzierung einer Detailinformation
                                                </xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>
                                                            Nummer der Detailinformation
                                                        </xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="NODE_NO" use="required">
            <xs:annotation>
              <xs:documentation>Knotenidentifikator</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>Sortierung</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
T_NEW_MERGE_CATALOGS Element
IDM_MERGE : T_NEW_MERGE_CATALOGS Element
Beschreibung
In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.
Namensraum (none)
Diagramm
STRUCTURE Element CATALOG_REFERENCES Element GLOBAL_DEFINITION Element SUPPLIER Element CATALOG Element Sequence T_NEW_MERGE_CATALOGS Element
Overview
T_NEW_MERGE_CATALOGS
In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.
MAJOR required Restriction of xs:nonNegativeInteger
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION. 		D positiveInteger
P
M [1:2]
MINOR required Restriction of xs:nonNegativeInteger
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:2]
REVISION required Restriction of xs:nonNegativeInteger
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:2]
Sequence
CATALOG
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Sequence
FILE_RELEASE_DATE Restriction of xs:date
In dieses Element wird das letzte Änderungsdatum des vorliegenden Datenbestandes eingegeben. D date
P
M
CATALOG_NAME languagetext30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben. Er dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt,.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Beginn der Gültigkeit des Multiherstellerkataloges angegeben. D date
P
M
VALID_UNTIL_DATE Restriction of xs:date
Mit dem Element wird das Ende der Gültigkeit des Multiherstellerkataloges angegeben. D date
P
M
CATALOG_INFO languagetext Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
CATALOG_ID Restriction of xs:string

Hier wird die eindeutige ID eines Multiherstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Multiherstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
CATALOG_VERSION Restriction of xs:positiveInteger
Hier muss der Hersteller eine Versions-Nr. für den Katalog vergeben. D positiveInteger
P
M [1:999999999]
DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
SUPPLIER
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Sequence
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
GLN_NO Restriction of xs:string
In dieses Element wird die eindeutige Globale Lokationsnummer ( GLN) des Multiherstellers eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
WEEE_NO optional Restriction of xs:string
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
GLOBAL_DEFINITION
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Sequence
DETAIL_INFOS optional
In diesem Element werden Detail-Informationen hinterlegt.
Sequence
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:17]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
CATALOG_REFERENCES
Dieses Element dient zur Referenzierung auf die Herstellerkataloge.
Sequence
CATALOG_REFERENCE 1..∞

Hier werden die Angaben eines Herstellerkataloges über die GLN des Herstellers und den Identifikator des Kataloges gespeichert.

SUPPLIER_GLN_NO required Restriction of xs:string
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
CATALOG_ID required Restriction of xs:string

Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
STRUCTURE optional

Dieses Element dient der Definition einer Einstiegsstruktur für den Handel.

Dazu müssen Kataloge sortimentsentsprechend erfasst und in Multiherstellerkataloge involviert werden.

Ziel ist es, mit den Multiherstellerkatalogen, den Einstieg in das Sortiment zu erleichtern, bzw. zu optimieren. Es einsteht folglich eine Einstiegsstruktur, die möglichst dynamisch und flexibel das Sortiment strukturiert.

Beispiele möglicher Einstiege:

1)

• Stoff

• Leder

2)

• Wohnen

• Polster

3)

• Hausmarke

• Platzierte Modelle

• Freies Verbandssortiment

Das Ganze kann man sich auch noch mehrstufig vorstellen

4)

• Hausmarken

o Wohnen

o Polster

• Platzierte Modelle

o Lieferant A

o Lieferant B

• Freies Verbandssortiment

o Lieferant A

o Lieferant B

Hier sind unzählige Konstellationen denkbar. Jeder Hersteller wird hier seine eigene Vorstellung haben, wie diese Struktur aussehen soll.

Sequence
NODES

Der Knoten dient einer untergeordneten Gruppe des Einstieges für den Handel.

Die Einstiegsstruktur darf maximal dreistufig sein.

Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MAJOR Restriction of xs:nonNegativeInteger required
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION. 		D positiveInteger
P
M [1:2]
MINOR Restriction of xs:nonNegativeInteger required
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:2]
REVISION Restriction of xs:nonNegativeInteger required
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:2]
Quelle
<xs:element name="T_NEW_MERGE_CATALOGS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>Kataloginformationen</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FILE_RELEASE_DATE">
              <xs:annotation>
                <xs:documentation>Dateifreigabe</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetext30">
              <xs:annotation>
                <xs:documentation>Katalogname</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DATA_VERSION">
              <xs:annotation>
                <xs:documentation>Daten_Version</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_FROM_DATE">
              <xs:annotation>
                <xs:documentation>Gueltig_ab_Datum</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL_DATE">
              <xs:annotation>
                <xs:documentation>Gueltig_bis_Datum</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetext">
              <xs:annotation>
                <xs:documentation>Informationsblatt</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_ID">
              <xs:annotation>
                <xs:documentation xml:lang="DE">
              MERGE_CATALOG_ID
              hier kann der Hersteller eine
              eindeutige ID (z.B.GUID)eingeben, um
              den Katalog eindeutig zu
              identifizieren
            </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="64" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_VERSION">
              <xs:annotation>
                <xs:documentation>Versionsnummer des Herstellers</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>Angabe von Detailinformationen</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>Referenzierung einer Detailinformation</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>Nummer der Detailinformation</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUPPLIER">
        <xs:annotation>
          <xs:documentation>Herstellerinformationen</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>Länderkennzeichen</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="GLN_NO">
              <xs:annotation>
                <xs:documentation>GLN des Herstellers</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9]{13}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="WEEE_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>WEEE_Nr</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_PERSON" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>Ansprechpartner</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONTACT_PERSON_NO">
                    <xs:annotation>
                      <xs:documentation>Nummer der Kontaktperson</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_ROLE">
                    <xs:annotation>
                      <xs:documentation>Bestimmung des Kontaktes</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_NAME">
                    <xs:annotation>
                      <xs:documentation>Nachame</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FIRST_NAME">
                    <xs:annotation>
                      <xs:documentation>Vorname</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FORM_OF_ADDRESS">
                    <xs:annotation>
                      <xs:documentation>Anrede</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPARTMENT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Abteilung</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE">
                    <xs:annotation>
                      <xs:documentation>Telefonnummer</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Faxnummer</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>E-Mail-Adresse</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Straße</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Postleitzahl</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Stadt</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>Länderkennzeichen</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONTACT_SUPPLIER">
              <xs:annotation>
                <xs:documentation>Kontaktdaten des Herstellers</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_NAME_1">
                    <xs:annotation>
                      <xs:documentation>Firmenname 1. Zeile</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Firmenname 2. Zeile</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>E-Mail-Adresse</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INTERNET_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Internet-Adresse</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET">
                    <xs:annotation>
                      <xs:documentation>Straße</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET">
                    <xs:annotation>
                      <xs:documentation>Postleitzahl</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY">
                    <xs:annotation>
                      <xs:documentation>Stadt</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>Länderkennzeichen</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>PLZ des Postfaches</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Postfachnummer</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>Telefonnummer der Zentrale</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>Fax-Nummer der Zentrale</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GLOBAL_DEFINITION">
        <xs:annotation>
          <xs:documentation>Globale Informationen</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>Detailinformationen</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>Detailinformation</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION">
                          <xs:annotation>
                            <xs:documentation>Klassifizierung</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INFO_TYPE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Funktionsbeschreibung
16 = Planungshinweis
17 = Katalogbild
10.03.2020/Kerstin Richter</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:maxInclusive value="17" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Anzeigename</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Information für Softwarehäuser</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Hinweis zum Link</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="URL">
                          <xs:annotation>
                            <xs:documentation>URL</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>Sprachzuordnung</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT" type="xs:anyURI">
                                      <xs:annotation>
                                        <xs:documentation>URI</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="HASH_VALUE">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt. Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="32" />
                                          <xs:maxLength value="32" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>ISO-Sprachcode</xs:documentation>
                                      <xs:documentation />
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="LAYER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          </xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-6]0" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>Nummer der Detailinformation</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_REFERENCES">
        <xs:annotation>
          <xs:documentation>Referenzierung auf Herstellerkataloge</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CATALOG_REFERENCE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>Angaben zu einem Herstellerkatalog</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SUPPLIER_GLN_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>GLN des Herstellers</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9]{13}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="CATALOG_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>Katalogidentifikator</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="64" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="STRUCTURE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Sortimentsstruktur</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element ref="NODES" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" use="required">
      <xs:annotation>
        <xs:documentation>Versionsnummer </xs:documentation>
        <xs:documentation />
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="2" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>Sub-Versionsnummer </xs:documentation>
        <xs:documentation />
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="2" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>Revisionsnummer </xs:documentation>
        <xs:documentation />
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="2" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
languagetext Complex Type
IDM_MERGE : languagetext Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext Complex Type
Overview
languagetext

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Verwendet von
CATALOG_INFO Element
EXTERNAL_NAME Element
TOOL_TIP Element
Quelle
<xs:complexType name="languagetext" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für beliebig lange Texte</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>Sprachzuordnung</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string">
            <xs:annotation>
              <xs:documentation />
            </xs:annotation>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation />
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
languagetext30 Complex Type
IDM_MERGE : languagetext30 Complex Type
Beschreibung
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext30 Complex Type
Overview
languagetext30
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Verwendet von
CATALOG_NAME Element
NODE_NAME Element
Quelle
<xs:complexType name="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>Sprachzuordnung</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation />
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation />
            <xs:documentation />
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
languagetext40 Complex Type
IDM_MERGE : languagetext40 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext40 Complex Type
Overview
languagetext40

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Verwendet von
INTERNAL_NAME Element
Quelle
<xs:complexType name="languagetext40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>Sprachzuordnung</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation />
              <xs:documentation>Längenbeschränkung 1-40</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation />
            <xs:documentation />
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM_MERGE


%%ItemTitle%%

IDM_MERGE 2.1.1 XML-Schema Dokumentation
Elemente
Elemente
Element | Beschreibung
T_NEW_MERGE_CATALOGS | Summary In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.
NODES | Summary Der Knoten dient einer untergeordneten Gruppe des Einstieges für den Handel. Die Einstiegsstruktur darf maximal dreistufig sein. .


%%LocalItemTitle%%

IDM_MERGE
CATALOG Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element : CATALOG Element
Beschreibung
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Namensraum (none)
Diagramm
DETAIL_INFOS Element CATALOG_VERSION Element CATALOG_ID Element LANGUAGE Element Sequence CATALOG_INFO Element VALID_UNTIL_DATE Element VALID_FROM_DATE Element DATA_VERSION Element LANGUAGE Element Sequence CATALOG_NAME Element FILE_RELEASE_DATE Element Sequence CATALOG Element
Overview
CATALOG
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Sequence
FILE_RELEASE_DATE Restriction of xs:date
In dieses Element wird das letzte Änderungsdatum des vorliegenden Datenbestandes eingegeben. D date
P
M
CATALOG_NAME languagetext30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben. Er dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt,.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Beginn der Gültigkeit des Multiherstellerkataloges angegeben. D date
P
M
VALID_UNTIL_DATE Restriction of xs:date
Mit dem Element wird das Ende der Gültigkeit des Multiherstellerkataloges angegeben. D date
P
M
CATALOG_INFO languagetext Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
CATALOG_ID Restriction of xs:string

Hier wird die eindeutige ID eines Multiherstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Multiherstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
CATALOG_VERSION Restriction of xs:positiveInteger
Hier muss der Hersteller eine Versions-Nr. für den Katalog vergeben. D positiveInteger
P
M [1:999999999]
DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Kataloginformationen</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FILE_RELEASE_DATE">
        <xs:annotation>
          <xs:documentation>Dateifreigabe</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetext30">
        <xs:annotation>
          <xs:documentation>Katalogname</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DATA_VERSION">
        <xs:annotation>
          <xs:documentation>Daten_Version</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM_DATE">
        <xs:annotation>
          <xs:documentation>Gueltig_ab_Datum</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL_DATE">
        <xs:annotation>
          <xs:documentation>Gueltig_bis_Datum</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetext">
        <xs:annotation>
          <xs:documentation>Informationsblatt</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_ID">
        <xs:annotation>
          <xs:documentation xml:lang="DE">
              MERGE_CATALOG_ID
              hier kann der Hersteller eine
              eindeutige ID (z.B.GUID)eingeben, um
              den Katalog eindeutig zu
              identifizieren
            </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="64" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_VERSION">
        <xs:annotation>
          <xs:documentation>Versionsnummer des Herstellers</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Angabe von Detailinformationen</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>Referenzierung einer Detailinformation</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>Nummer der Detailinformation</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
FILE_RELEASE_DATE Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG Element : FILE_RELEASE_DATE Element
Beschreibung
In dieses Element wird das letzte Änderungsdatum des vorliegenden Datenbestandes eingegeben. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
FILE_RELEASE_DATE Element
Overview
FILE_RELEASE_DATE Restriction of xs:date
In dieses Element wird das letzte Änderungsdatum des vorliegenden Datenbestandes eingegeben. D date
P
M
Quelle
<xs:element name="FILE_RELEASE_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Dateifreigabe</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
CATALOG Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CATALOG_NAME Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG Element : CATALOG_NAME Element
Beschreibung
In diesem Element wird der Katalogname des Datenbestandes angegeben. Er dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt,.
Namensraum (none)
Typ
languagetext30 Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetext30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben. Er dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt,.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="CATALOG_NAME" type="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Katalogname</xs:documentation>
  </xs:annotation>
</xs:element>
CATALOG Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
DATA_VERSION Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG Element : DATA_VERSION Element
Beschreibung
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
DATA_VERSION Element
Overview
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
Quelle
<xs:element name="DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Daten_Version</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
CATALOG Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
VALID_FROM_DATE Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG Element : VALID_FROM_DATE Element
Beschreibung
Mit dem Element wird der Beginn der Gültigkeit des Multiherstellerkataloges angegeben. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM_DATE Element
Overview
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Beginn der Gültigkeit des Multiherstellerkataloges angegeben. D date
P
M
Quelle
<xs:element name="VALID_FROM_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Gueltig_ab_Datum</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
CATALOG Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
VALID_UNTIL_DATE Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG Element : VALID_UNTIL_DATE Element
Beschreibung
Mit dem Element wird das Ende der Gültigkeit des Multiherstellerkataloges angegeben. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL_DATE Element
Overview
VALID_UNTIL_DATE Restriction of xs:date
Mit dem Element wird das Ende der Gültigkeit des Multiherstellerkataloges angegeben. D date
P
M
Quelle
<xs:element name="VALID_UNTIL_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Gueltig_bis_Datum</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
CATALOG Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CATALOG_INFO Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG Element : CATALOG_INFO Element
Beschreibung
In diesem Element werden die Informationstexte abgelegt.
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO languagetext Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="CATALOG_INFO" type="languagetext" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Informationsblatt</xs:documentation>
  </xs:annotation>
</xs:element>
CATALOG Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CATALOG_ID Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG Element : CATALOG_ID Element
Beschreibung

Hier wird die eindeutige ID eines Multiherstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Multiherstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_ID Element
Overview
CATALOG_ID Restriction of xs:string

Hier wird die eindeutige ID eines Multiherstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Multiherstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Quelle
<xs:element name="CATALOG_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">
              MERGE_CATALOG_ID
              hier kann der Hersteller eine
              eindeutige ID (z.B.GUID)eingeben, um
              den Katalog eindeutig zu
              identifizieren
            </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="64" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
CATALOG Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CATALOG_VERSION Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG Element : CATALOG_VERSION Element
Beschreibung
Hier muss der Hersteller eine Versions-Nr. für den Katalog vergeben. D positiveInteger
P
M [1:999999999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CATALOG_VERSION Element
Overview
CATALOG_VERSION Restriction of xs:positiveInteger
Hier muss der Hersteller eine Versions-Nr. für den Katalog vergeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="CATALOG_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Versionsnummer des Herstellers</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
CATALOG Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
DETAIL_INFOS Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG Element : DETAIL_INFOS Element
Beschreibung
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Angabe von Detailinformationen</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Referenzierung einer Detailinformation</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>Nummer der Detailinformation</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
CATALOG Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
DETAIL_INFO_REF Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Referenzierung einer Detailinformation</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>Nummer der Detailinformation</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | CATALOG Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
SUPPLIER Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element : SUPPLIER Element
Beschreibung
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Namensraum (none)
Diagramm
CONTACT_SUPPLIER Element CONTACT_PERSON Element WEEE_NO Element GLN_NO Element ISO_COUNTRY_ID Element Sequence SUPPLIER Element
Overview
SUPPLIER
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Sequence
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
GLN_NO Restriction of xs:string
In dieses Element wird die eindeutige Globale Lokationsnummer ( GLN) des Multiherstellers eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
WEEE_NO optional Restriction of xs:string
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Quelle
<xs:element name="SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Herstellerinformationen</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>Länderkennzeichen</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="GLN_NO">
        <xs:annotation>
          <xs:documentation>GLN des Herstellers</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9]{13}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WEEE_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>WEEE_Nr</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_PERSON" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>Ansprechpartner</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONTACT_PERSON_NO">
              <xs:annotation>
                <xs:documentation>Nummer der Kontaktperson</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_ROLE">
              <xs:annotation>
                <xs:documentation>Bestimmung des Kontaktes</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_NAME">
              <xs:annotation>
                <xs:documentation>Nachame</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FIRST_NAME">
              <xs:annotation>
                <xs:documentation>Vorname</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FORM_OF_ADDRESS">
              <xs:annotation>
                <xs:documentation>Anrede</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPARTMENT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Abteilung</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE">
              <xs:annotation>
                <xs:documentation>Telefonnummer</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Faxnummer</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>E-Mail-Adresse</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Straße</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Postleitzahl</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Stadt</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>Länderkennzeichen</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONTACT_SUPPLIER">
        <xs:annotation>
          <xs:documentation>Kontaktdaten des Herstellers</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_NAME_1">
              <xs:annotation>
                <xs:documentation>Firmenname 1. Zeile</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Firmenname 2. Zeile</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>E-Mail-Adresse</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INTERNET_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Internet-Adresse</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET">
              <xs:annotation>
                <xs:documentation>Straße</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET">
              <xs:annotation>
                <xs:documentation>Postleitzahl</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY">
              <xs:annotation>
                <xs:documentation>Stadt</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>Länderkennzeichen</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>PLZ des Postfaches</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Postfachnummer</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>Telefonnummer der Zentrale</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>Fax-Nummer der Zentrale</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
ISO_COUNTRY_ID Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element : ISO_COUNTRY_ID Element
Beschreibung
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Länderkennzeichen</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
GLN_NO Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element : GLN_NO Element
Beschreibung
In dieses Element wird die eindeutige Globale Lokationsnummer ( GLN) des Multiherstellers eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
GLN_NO Element
Overview
GLN_NO Restriction of xs:string
In dieses Element wird die eindeutige Globale Lokationsnummer ( GLN) des Multiherstellers eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
Quelle
<xs:element name="GLN_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>GLN des Herstellers</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{13}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
WEEE_NO Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element : WEEE_NO Element
Beschreibung
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
WEEE_NO Element
Overview
WEEE_NO optional Restriction of xs:string
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
Quelle
<xs:element name="WEEE_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>WEEE_Nr</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CONTACT_PERSON Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element : CONTACT_PERSON Element
Beschreibung
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt
Namensraum (none)
Diagramm
ISO_COUNTRY_ID Element CITY Element ZIPCODE_STREET Element STREET Element EMAIL Element FAX Element TELEPHONE Element DEPARTMENT Element FORM_OF_ADDRESS Element FIRST_NAME Element CONTACT_NAME Element CONTACT_ROLE Element CONTACT_PERSON_NO Element Sequence CONTACT_PERSON Element
Overview
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="CONTACT_PERSON" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Ansprechpartner</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONTACT_PERSON_NO">
        <xs:annotation>
          <xs:documentation>Nummer der Kontaktperson</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_ROLE">
        <xs:annotation>
          <xs:documentation>Bestimmung des Kontaktes</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_NAME">
        <xs:annotation>
          <xs:documentation>Nachame</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FIRST_NAME">
        <xs:annotation>
          <xs:documentation>Vorname</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FORM_OF_ADDRESS">
        <xs:annotation>
          <xs:documentation>Anrede</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPARTMENT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Abteilung</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE">
        <xs:annotation>
          <xs:documentation>Telefonnummer</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Faxnummer</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>E-Mail-Adresse</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Straße</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Postleitzahl</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Stadt</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>Länderkennzeichen</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CONTACT_PERSON_NO Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_PERSON_NO Element
Beschreibung
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme) D positiveInteger
P
M [1:2]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CONTACT_PERSON_NO Element
Overview
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme) D positiveInteger
P
M [1:2]
Quelle
<xs:element name="CONTACT_PERSON_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Nummer der Kontaktperson</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CONTACT_ROLE Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_ROLE Element
Beschreibung
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONTACT_ROLE Element
Overview
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
Quelle
<xs:element name="CONTACT_ROLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Bestimmung des Kontaktes</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CONTACT_NAME Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_NAME Element
Beschreibung
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONTACT_NAME Element
Overview
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
Quelle
<xs:element name="CONTACT_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Nachame</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
FIRST_NAME Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : FIRST_NAME Element
Beschreibung
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FIRST_NAME Element
Overview
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
Quelle
<xs:element name="FIRST_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Vorname</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
FORM_OF_ADDRESS Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : FORM_OF_ADDRESS Element
Beschreibung
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
FORM_OF_ADDRESS Element
Overview
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
Quelle
<xs:element name="FORM_OF_ADDRESS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Anrede</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
DEPARTMENT Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : DEPARTMENT Element
Beschreibung
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
DEPARTMENT Element
Overview
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
Quelle
<xs:element name="DEPARTMENT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Abteilung</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
TELEPHONE Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : TELEPHONE Element
Beschreibung
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TELEPHONE Element
Overview
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Quelle
<xs:element name="TELEPHONE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Telefonnummer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
FAX Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : FAX Element
Beschreibung
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FAX Element
Overview
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
Quelle
<xs:element name="FAX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Faxnummer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
EMAIL Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : EMAIL Element
Beschreibung
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Quelle
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>E-Mail-Adresse</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
STREET Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : STREET Element
Beschreibung
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
STREET Element
Overview
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Quelle
<xs:element name="STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Straße</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
ZIPCODE_STREET Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : ZIPCODE_STREET Element
Beschreibung
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Quelle
<xs:element name="ZIPCODE_STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Postleitzahl</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CITY Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : CITY Element
Beschreibung
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CITY Element
Overview
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Quelle
<xs:element name="CITY" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Stadt</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
ISO_COUNTRY_ID Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_PERSON Element : ISO_COUNTRY_ID Element
Beschreibung
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Länderkennzeichen</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CONTACT_SUPPLIER Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element : CONTACT_SUPPLIER Element
Beschreibung
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Namensraum (none)
Diagramm
FAX_SWITCHBOARD Element TELEPHONE_SWITCHBOARD Element POSTBOX Element ZIPCODE_POSTBOX Element ISO_COUNTRY_ID Element CITY Element ZIPCODE_STREET Element STREET Element INTERNET_ADDRESS Element EMAIL Element MANUFACTURER_NAME_2 Element MANUFACTURER_NAME_1 Element Sequence CONTACT_SUPPLIER Element
Overview
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Quelle
<xs:element name="CONTACT_SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Kontaktdaten des Herstellers</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_NAME_1">
        <xs:annotation>
          <xs:documentation>Firmenname 1. Zeile</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Firmenname 2. Zeile</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>E-Mail-Adresse</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INTERNET_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Internet-Adresse</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET">
        <xs:annotation>
          <xs:documentation>Straße</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET">
        <xs:annotation>
          <xs:documentation>Postleitzahl</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY">
        <xs:annotation>
          <xs:documentation>Stadt</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>Länderkennzeichen</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>PLZ des Postfaches</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Postfachnummer</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9a-zA-Z]{0,10}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>Telefonnummer der Zentrale</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>Fax-Nummer der Zentrale</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
MANUFACTURER_NAME_1 Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_1 Element
Beschreibung
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MANUFACTURER_NAME_1 Element
Overview
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Quelle
<xs:element name="MANUFACTURER_NAME_1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Firmenname 1. Zeile</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
MANUFACTURER_NAME_2 Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_2 Element
Beschreibung
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MANUFACTURER_NAME_2 Element
Overview
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Quelle
<xs:element name="MANUFACTURER_NAME_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Firmenname 2. Zeile</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
EMAIL Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : EMAIL Element
Beschreibung
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Quelle
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>E-Mail-Adresse</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
INTERNET_ADDRESS Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : INTERNET_ADDRESS Element
Beschreibung
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
INTERNET_ADDRESS Element
Overview
INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
Quelle
<xs:element name="INTERNET_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Internet-Adresse</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
STREET Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : STREET Element
Beschreibung
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
STREET Element
Overview
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Quelle
<xs:element name="STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Straße</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
ZIPCODE_STREET Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_STREET Element
Beschreibung
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Quelle
<xs:element name="ZIPCODE_STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Postleitzahl</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CITY Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : CITY Element
Beschreibung
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CITY Element
Overview
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Quelle
<xs:element name="CITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Stadt</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
ISO_COUNTRY_ID Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ISO_COUNTRY_ID Element
Beschreibung
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Länderkennzeichen</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
ZIPCODE_POSTBOX Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_POSTBOX Element
Beschreibung
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_POSTBOX Element
Overview
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
Quelle
<xs:element name="ZIPCODE_POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>PLZ des Postfaches</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
POSTBOX Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : POSTBOX Element
Beschreibung
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
POSTBOX Element
Overview
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Quelle
<xs:element name="POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Postfachnummer</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9a-zA-Z]{0,10}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
TELEPHONE_SWITCHBOARD Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : TELEPHONE_SWITCHBOARD Element
Beschreibung
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TELEPHONE_SWITCHBOARD Element
Overview
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Quelle
<xs:element name="TELEPHONE_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Telefonnummer der Zentrale</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
FAX_SWITCHBOARD Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > SUPPLIER Element > CONTACT_SUPPLIER Element : FAX_SWITCHBOARD Element
Beschreibung
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FAX_SWITCHBOARD Element
Overview
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Quelle
<xs:element name="FAX_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Fax-Nummer der Zentrale</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
GLOBAL_DEFINITION Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element : GLOBAL_DEFINITION Element
Beschreibung
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Namensraum (none)
Diagramm
DETAIL_INFOS Element Sequence GLOBAL_DEFINITION Element
Overview
GLOBAL_DEFINITION
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Sequence
DETAIL_INFOS optional
In diesem Element werden Detail-Informationen hinterlegt.
Sequence
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:17]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Quelle
<xs:element name="GLOBAL_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Globale Informationen</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>Detailinformationen</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>Detailinformation</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION">
                    <xs:annotation>
                      <xs:documentation>Klassifizierung</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INFO_TYPE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Funktionsbeschreibung
16 = Planungshinweis
17 = Katalogbild
10.03.2020/Kerstin Richter</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="17" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Anzeigename</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Information für Softwarehäuser</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Hinweis zum Link</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="URL">
                    <xs:annotation>
                      <xs:documentation>URL</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>Sprachzuordnung</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT" type="xs:anyURI">
                                <xs:annotation>
                                  <xs:documentation>URI</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="HASH_VALUE">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt. Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="32" />
                                    <xs:maxLength value="32" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>ISO-Sprachcode</xs:documentation>
                                <xs:documentation />
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="LAYER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          </xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-6]0" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>Nummer der Detailinformation</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
DETAIL_INFOS Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element : DETAIL_INFOS Element
Beschreibung
In diesem Element werden Detail-Informationen hinterlegt.
Namensraum (none)
Diagramm
DETAIL_INFO Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
In diesem Element werden Detail-Informationen hinterlegt.
Sequence
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:17]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Detailinformationen</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Detailinformation</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION">
              <xs:annotation>
                <xs:documentation>Klassifizierung</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="INFO_TYPE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Funktionsbeschreibung
16 = Planungshinweis
17 = Katalogbild
10.03.2020/Kerstin Richter</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="17" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Anzeigename</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Information für Softwarehäuser</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Hinweis zum Link</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="URL">
              <xs:annotation>
                <xs:documentation>URL</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>Sprachzuordnung</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT" type="xs:anyURI">
                          <xs:annotation>
                            <xs:documentation>URI</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="HASH_VALUE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt. Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="32" />
                              <xs:maxLength value="32" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>ISO-Sprachcode</xs:documentation>
                          <xs:documentation />
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="LAYER" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-6]0" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>Nummer der Detailinformation</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
DETAIL_INFO Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element : DETAIL_INFO Element
Beschreibung
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
Namensraum (none)
Diagramm
LAYER Element URL Element LANGUAGE Element Sequence TOOL_TIP Element LANGUAGE Element Sequence INTERNAL_NAME Element LANGUAGE Element Sequence EXTERNAL_NAME Element INFO_TYPE Element CLASSIFICATION Element Sequence DETAIL_INFO Element
Overview
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:17]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Detailinformation</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION">
        <xs:annotation>
          <xs:documentation>Klassifizierung</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="INFO_TYPE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Funktionsbeschreibung
16 = Planungshinweis
17 = Katalogbild
10.03.2020/Kerstin Richter</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="17" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Anzeigename</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Information für Softwarehäuser</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Hinweis zum Link</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="URL">
        <xs:annotation>
          <xs:documentation>URL</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>Sprachzuordnung</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT" type="xs:anyURI">
                    <xs:annotation>
                      <xs:documentation>URI</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="HASH_VALUE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt. Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="32" />
                        <xs:maxLength value="32" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>ISO-Sprachcode</xs:documentation>
                    <xs:documentation />
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="LAYER" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-6]0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>Nummer der Detailinformation</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CLASSIFICATION Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : CLASSIFICATION Element
Beschreibung
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CLASSIFICATION Element
Overview
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
Quelle
<xs:element name="CLASSIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Klassifizierung</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
INFO_TYPE Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INFO_TYPE Element
Beschreibung
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:17]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
INFO_TYPE Element
Overview
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:17]
Quelle
<xs:element name="INFO_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Funktionsbeschreibung
16 = Planungshinweis
17 = Katalogbild
10.03.2020/Kerstin Richter</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="17" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
EXTERNAL_NAME Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : EXTERNAL_NAME Element
Beschreibung
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence EXTERNAL_NAME Element
Overview
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Anzeigename</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
INTERNAL_NAME Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INTERNAL_NAME Element
Beschreibung
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Namensraum (none)
Typ
languagetext40 Complex Type
Diagramm
LANGUAGE Element Sequence INTERNAL_NAME Element
Overview
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Information für Softwarehäuser</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
TOOL_TIP Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : TOOL_TIP Element
Beschreibung

Dieses Element enthält Text für einen Hinweis zum Link.

Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence TOOL_TIP Element
Overview
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="TOOL_TIP" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Hinweis zum Link</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
URL Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : URL Element
Beschreibung
Dieses Element gibt die URL zur Detailinformation an.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence URL Element
Overview
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Quelle
<xs:element name="URL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>URL</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Sprachzuordnung</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT" type="xs:anyURI">
              <xs:annotation>
                <xs:documentation>URI</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="HASH_VALUE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt. Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="32" />
                  <xs:maxLength value="32" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>ISO-Sprachcode</xs:documentation>
              <xs:documentation />
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
LANGUAGE Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
HASH_VALUE Element TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Sprachzuordnung</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:anyURI">
        <xs:annotation>
          <xs:documentation>URI</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="HASH_VALUE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt. Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="32" />
            <xs:maxLength value="32" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>ISO-Sprachcode</xs:documentation>
        <xs:documentation />
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
TEXT Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
Namensraum (none)
Typ
xs:anyURI
Diagramm
TEXT Element
Overview
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
Quelle
<xs:element name="TEXT" type="xs:anyURI" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>URI</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
HASH_VALUE Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : HASH_VALUE Element
Beschreibung
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
HASH_VALUE Element
Overview
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Quelle
<xs:element name="HASH_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt. Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="32" />
      <xs:maxLength value="32" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
LAYER Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : LAYER Element
Beschreibung

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
LAYER Element
Overview
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Quelle
<xs:element name="LAYER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-6]0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CATALOG_REFERENCES Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element : CATALOG_REFERENCES Element
Beschreibung
Dieses Element dient zur Referenzierung auf die Herstellerkataloge.
Namensraum (none)
Diagramm
CATALOG_REFERENCE Element Sequence CATALOG_REFERENCES Element
Overview
CATALOG_REFERENCES
Dieses Element dient zur Referenzierung auf die Herstellerkataloge.
Sequence
CATALOG_REFERENCE 1..∞

Hier werden die Angaben eines Herstellerkataloges über die GLN des Herstellers und den Identifikator des Kataloges gespeichert.

SUPPLIER_GLN_NO required Restriction of xs:string
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
CATALOG_ID required Restriction of xs:string

Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Quelle
<xs:element name="CATALOG_REFERENCES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Referenzierung auf Herstellerkataloge</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG_REFERENCE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Angaben zu einem Herstellerkatalog</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SUPPLIER_GLN_NO" use="required">
            <xs:annotation>
              <xs:documentation>GLN des Herstellers</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9]{13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="CATALOG_ID" use="required">
            <xs:annotation>
              <xs:documentation>Katalogidentifikator</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="64" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CATALOG_REFERENCE Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element > CATALOG_REFERENCES Element : CATALOG_REFERENCE Element
Beschreibung

Hier werden die Angaben eines Herstellerkataloges über die GLN des Herstellers und den Identifikator des Kataloges gespeichert.

Namensraum (none)
Diagramm
CATALOG_REFERENCE Element
Overview
CATALOG_REFERENCE 1..∞

Hier werden die Angaben eines Herstellerkataloges über die GLN des Herstellers und den Identifikator des Kataloges gespeichert.

SUPPLIER_GLN_NO required Restriction of xs:string
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
CATALOG_ID required Restriction of xs:string

Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SUPPLIER_GLN_NO Restriction of xs:string required
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
CATALOG_ID Restriction of xs:string required

Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Quelle
<xs:element name="CATALOG_REFERENCE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Angaben zu einem Herstellerkatalog</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SUPPLIER_GLN_NO" use="required">
      <xs:annotation>
        <xs:documentation>GLN des Herstellers</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9]{13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="CATALOG_ID" use="required">
      <xs:annotation>
        <xs:documentation>Katalogidentifikator</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="64" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
CATALOG_REFERENCES Element | T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
STRUCTURE Element
IDM_MERGE > T_NEW_MERGE_CATALOGS Element : STRUCTURE Element
Beschreibung

Dieses Element dient der Definition einer Einstiegsstruktur für den Handel.

Dazu müssen Kataloge sortimentsentsprechend erfasst und in Multiherstellerkataloge involviert werden.

Ziel ist es, mit den Multiherstellerkatalogen, den Einstieg in das Sortiment zu erleichtern, bzw. zu optimieren. Es einsteht folglich eine Einstiegsstruktur, die möglichst dynamisch und flexibel das Sortiment strukturiert.

Beispiele möglicher Einstiege:

1)

• Stoff

• Leder

2)

• Wohnen

• Polster

3)

• Hausmarke

• Platzierte Modelle

• Freies Verbandssortiment

Das Ganze kann man sich auch noch mehrstufig vorstellen

4)

• Hausmarken

o Wohnen

o Polster

• Platzierte Modelle

o Lieferant A

o Lieferant B

• Freies Verbandssortiment

o Lieferant A

o Lieferant B

Hier sind unzählige Konstellationen denkbar. Jeder Hersteller wird hier seine eigene Vorstellung haben, wie diese Struktur aussehen soll.

Namensraum (none)
Diagramm
NODES Element Sequence STRUCTURE Element
Overview
STRUCTURE optional

Dieses Element dient der Definition einer Einstiegsstruktur für den Handel.

Dazu müssen Kataloge sortimentsentsprechend erfasst und in Multiherstellerkataloge involviert werden.

Ziel ist es, mit den Multiherstellerkatalogen, den Einstieg in das Sortiment zu erleichtern, bzw. zu optimieren. Es einsteht folglich eine Einstiegsstruktur, die möglichst dynamisch und flexibel das Sortiment strukturiert.

Beispiele möglicher Einstiege:

1)

• Stoff

• Leder

2)

• Wohnen

• Polster

3)

• Hausmarke

• Platzierte Modelle

• Freies Verbandssortiment

Das Ganze kann man sich auch noch mehrstufig vorstellen

4)

• Hausmarken

o Wohnen

o Polster

• Platzierte Modelle

o Lieferant A

o Lieferant B

• Freies Verbandssortiment

o Lieferant A

o Lieferant B

Hier sind unzählige Konstellationen denkbar. Jeder Hersteller wird hier seine eigene Vorstellung haben, wie diese Struktur aussehen soll.

Sequence
NODES

Der Knoten dient einer untergeordneten Gruppe des Einstieges für den Handel.

Die Einstiegsstruktur darf maximal dreistufig sein.

Quelle
<xs:element name="STRUCTURE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Sortimentsstruktur</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element ref="NODES" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_MERGE_CATALOGS Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
NODE Element
IDM_MERGE > NODES Element : NODE Element
Beschreibung

Dieses Element dient der Referenzierung durch die Einstiegsstruktur für den Handel bezüglich des Multiherstellerkataloges.

Er enthält die Einstiegsbezeichnung und die dazu gehörigen Katatalogreferenzierungen.

Dazu müssen Kataloge sortimentsentsprechend erfasst und in Multiherstellerkataloge involviert werden.

Ziel ist es, mit den Multiherstellerkatalogen, den Einstieg in das Sortiment zu erleichtern, bzw. zu optimieren. Es einsteht folglich eine Einstiegsstruktur, die möglichst dynamisch und flexibel das Sortiment strukturiert.

Beispiele möglicher Einstiege:

1)

• Stoff

• Leder

2)

• Wohnen

• Polster

3)

• Hausmarke

• Platzierte Modelle

• Freies Verbandssortiment

Das Ganze kann man sich auch noch mehrstufig vorstellen

4)

• Hausmarken

o Wohnen

o Polster

• Platzierte Modelle

o Lieferant A

o Lieferant B

• Freies Verbandssortiment

o Lieferant A

o Lieferant B

Hier sind unzählige Konstellationen denkbar. Jeder Hersteller wird hier seine eigene Vorstellung haben, wie diese Struktur aussehen soll.

Namensraum (none)
Diagramm
DETAIL_INFOS Element NODES Element CATALOG_REFERENCES_REF Element Choice LANGUAGE Element Sequence NODE_NAME Element Sequence NODE Element
Overview
NODE 1..∞

Dieses Element dient der Referenzierung durch die Einstiegsstruktur für den Handel bezüglich des Multiherstellerkataloges.

Er enthält die Einstiegsbezeichnung und die dazu gehörigen Katatalogreferenzierungen.

Dazu müssen Kataloge sortimentsentsprechend erfasst und in Multiherstellerkataloge involviert werden.

Ziel ist es, mit den Multiherstellerkatalogen, den Einstieg in das Sortiment zu erleichtern, bzw. zu optimieren. Es einsteht folglich eine Einstiegsstruktur, die möglichst dynamisch und flexibel das Sortiment strukturiert.

Beispiele möglicher Einstiege:

1)

• Stoff

• Leder

2)

• Wohnen

• Polster

3)

• Hausmarke

• Platzierte Modelle

• Freies Verbandssortiment

Das Ganze kann man sich auch noch mehrstufig vorstellen

4)

• Hausmarken

o Wohnen

o Polster

• Platzierte Modelle

o Lieferant A

o Lieferant B

• Freies Verbandssortiment

o Lieferant A

o Lieferant B

Hier sind unzählige Konstellationen denkbar. Jeder Hersteller wird hier seine eigene Vorstellung haben, wie diese Struktur aussehen soll.

NODE_NO required Restriction of xs:nonNegativeInteger
Hier wird der eindeutige Knoten-Identifikator erfasst. D positiveInteger
P
M [1:99]
SEQUENCE_NO required Restriction of xs:nonNegativeInteger
Hier wird die Sortierung realisiert. D nonNegativeInteger
P
M [0:99]
Sequence
NODE_NAME languagetext30 Complex Type
Hier wird die Einstiegsbezeichnung angegeben.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Choice
CATALOG_REFERENCES_REF
Dieses Element dient der Katalogreferenzierung.
Sequence
SUPPLIER_GLN_NO Restriction of xs:string
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
CATALOG_ID Restriction of xs:string

Hier wird die eindeutige ID eines Herstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
NODES

Der Knoten dient einer untergeordneten Gruppe des Einstieges für den Handel.

Die Einstiegsstruktur darf maximal dreistufig sein.

DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern oder anderer Medien für die Einstiegsstruktur.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
NODE_NO Restriction of xs:nonNegativeInteger required
Hier wird der eindeutige Knoten-Identifikator erfasst. D positiveInteger
P
M [1:99]
SEQUENCE_NO Restriction of xs:nonNegativeInteger required
Hier wird die Sortierung realisiert. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="NODE" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="NODE_NAME" type="languagetext30">
        <xs:annotation>
          <xs:documentation>Katalogname</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:choice>
        <xs:element name="CATALOG_REFERENCES_REF">
          <xs:annotation>
            <xs:documentation>Referenzierung einer Knoteninformation</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="SUPPLIER_GLN_NO">
                <xs:annotation>
                  <xs:documentation>GLN_Nr </xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:pattern value="[0-9]{13}" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="CATALOG_ID">
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="64" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
        <xs:element ref="NODES" />
      </xs:choice>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>
                                        Angabe von Detailinformationen
                                    </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>
                                                    Referenzierung einer Detailinformation
                                                </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>
                                                            Nummer der Detailinformation
                                                        </xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="NODE_NO" use="required">
      <xs:annotation>
        <xs:documentation>Knotenidentifikator</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>Sortierung</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
NODES Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
NODE_NAME Element
IDM_MERGE > NODES Element > NODE Element : NODE_NAME Element
Beschreibung
Hier wird die Einstiegsbezeichnung angegeben.
Namensraum (none)
Typ
languagetext30 Complex Type
Diagramm
LANGUAGE Element Sequence NODE_NAME Element
Overview
NODE_NAME languagetext30 Complex Type
Hier wird die Einstiegsbezeichnung angegeben.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="NODE_NAME" type="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Katalogname</xs:documentation>
  </xs:annotation>
</xs:element>
NODE Element | NODES Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CATALOG_REFERENCES_REF Element
IDM_MERGE > NODES Element > NODE Element : CATALOG_REFERENCES_REF Element
Beschreibung
Dieses Element dient der Katalogreferenzierung.
Namensraum (none)
Diagramm
CATALOG_ID Element SUPPLIER_GLN_NO Element Sequence CATALOG_REFERENCES_REF Element
Overview
CATALOG_REFERENCES_REF
Dieses Element dient der Katalogreferenzierung.
Sequence
SUPPLIER_GLN_NO Restriction of xs:string
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
CATALOG_ID Restriction of xs:string

Hier wird die eindeutige ID eines Herstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Quelle
<xs:element name="CATALOG_REFERENCES_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Referenzierung einer Knoteninformation</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SUPPLIER_GLN_NO">
        <xs:annotation>
          <xs:documentation>GLN_Nr </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9]{13}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_ID">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="64" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
NODE Element | NODES Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
SUPPLIER_GLN_NO Element
IDM_MERGE > NODES Element > NODE Element > CATALOG_REFERENCES_REF Element : SUPPLIER_GLN_NO Element
Beschreibung
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
SUPPLIER_GLN_NO Element
Overview
SUPPLIER_GLN_NO Restriction of xs:string
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
 D string
P [0-9]{13}
M
Quelle
<xs:element name="SUPPLIER_GLN_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>GLN_Nr </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{13}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_REFERENCES_REF Element | NODE Element | NODES Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
CATALOG_ID Element
IDM_MERGE > NODES Element > NODE Element > CATALOG_REFERENCES_REF Element : CATALOG_ID Element
Beschreibung

Hier wird die eindeutige ID eines Herstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_ID Element
Overview
CATALOG_ID Restriction of xs:string

Hier wird die eindeutige ID eines Herstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Quelle
<xs:element name="CATALOG_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="64" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_REFERENCES_REF Element | NODE Element | NODES Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
DETAIL_INFOS Element
IDM_MERGE > NODES Element > NODE Element : DETAIL_INFOS Element
Beschreibung
Dieses Element dient der Angabe von Bildern oder anderer Medien für die Einstiegsstruktur.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern oder anderer Medien für die Einstiegsstruktur.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>
                                        Angabe von Detailinformationen
                                    </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>
                                                    Referenzierung einer Detailinformation
                                                </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>
                                                            Nummer der Detailinformation
                                                        </xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
NODE Element | NODES Element | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
DETAIL_INFO_REF Element
IDM_MERGE > NODES Element > NODE Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>
                                                    Referenzierung einer Detailinformation
                                                </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>
                                                            Nummer der Detailinformation
                                                        </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | NODE Element | NODES Element | IDM_MERGE


%%ItemTitle%%

IDM_MERGE 2.1.1 XML-Schema Dokumentation
Komplexe Typen
Komplexe Typen
Complex Type | Beschreibung
languagetext | Summary Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.
languagetext30 | Summary Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
languagetext40 | Summary Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.


%%LocalItemTitle%%

IDM_MERGE
LANGUAGE Element
IDM_MERGE > languagetext Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Sprachzuordnung</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string">
        <xs:annotation>
          <xs:documentation />
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation />
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetext Complex Type | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
TEXT Element
IDM_MERGE > languagetext Complex Type > LANGUAGE Element : TEXT Element
Beschreibung

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
TEXT Element
Overview
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation />
  </xs:annotation>
</xs:element>
LANGUAGE Element | languagetext Complex Type | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
LANGUAGE Element
IDM_MERGE > languagetext30 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Sprachzuordnung</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation />
        <xs:documentation />
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetext30 Complex Type | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
TEXT Element
IDM_MERGE > languagetext30 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
LANGUAGE Element | languagetext30 Complex Type | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
LANGUAGE Element
IDM_MERGE > languagetext40 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Sprachzuordnung</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation />
          <xs:documentation>Längenbeschränkung 1-40</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation />
        <xs:documentation />
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetext40 Complex Type | IDM_MERGE


%%LocalItemTitle%%

IDM_MERGE
TEXT Element
IDM_MERGE > languagetext40 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation />
    <xs:documentation>Längenbeschränkung 1-40</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
LANGUAGE Element | languagetext40 Complex Type | IDM_MERGE