 Einleitung

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

IDM_MERGE 2.2.0 XML-Schema

Dokumentation

Stand 21.12.2021

Dokumentiertes XML-Schema:

IDM_MERGE_2_2_0.xsd

Kontakt DCC e.V.

Geschäftsführer
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37

Verantwortliche IDM Arbeitskreise und Dokumentation
Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telefon 0 52 21/12 65-38


 Grundstruktur des IDM-Schemas

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] IDM_MERGE 2.2.0 XML-Schema Dokumentation

Einleitung > Grundstruktur des IDM-Schemas

Einleitung > Grundstruktur des IDM-Schemas

Die Grundstruktur des IDMP-Schemas

Das Hauptelement T_NEW_MERGE_CATALOGS definiert, dass ein neuer, vollständiger Multihersteller-Katalogdatenbestand bereitgestellt wird.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_NEW_MERGE_CATALOGS abgebildet werden.

Abbildung 1 - Child-Elemente von T_NEW_MERGE_CATALOGS

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

SUPPLIER

In SUPPLIER werden administrative Informationen zu dem Hersteller hinterlegt. Beispielsweise werden Kontaktdaten oder das Herkunftsland des Herstellers angegeben.

GLOBAL_DEFINITION

Der Datenbereich GLOBAL_DEFINITION ist eine Art Datenpool für Informationen, die in den anderen Datenbereichen verwendet werden. Beispielsweise werden hier Medien wie Fotos und Montageanleitungen angelegt.

CATALOG_REFERENCES

In CATALOG_REFERENCES werden über die GLN eines Herstellers und dessen Element CATALOG_ID die Kataloge referenziert, die zu diesem Multiherstellerkatalog gehören.


 Datentypen

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] IDM_MERGE 2.2.0 XML-Schema Dokumentation

Einleitung > Datentypen

Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

Es werden folgende Datentypen verwendet:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDMP wird der Datentyp date XML-Schema konform in folgender Weise angewendet:
 | YYYY-MM-DD
 | Y = Jahr, M = Monat, D = Tag
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDMP für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDMP für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDMP für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.
Zusätzlich gibt es einen benutzerdefinierte Datentypen:
languagetext |  | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.
languagetext30 |  | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
languagetext40 |  | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.


 Erläuterung zur Dokumentation

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] IDM_MERGE 2.2.0 XML-Schema Dokumentation

Einleitung > Erläuterung zur Dokumentation

Einleitung > Erläuterung zur Dokumentation

Erläuterungen zur Dokumentation des IDM

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

Beschreibung:

GLN_NO

In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben.

D string

P (0-9){13}

M [13:13] D string
P [A-Z]{2}
M [2:2]

In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden.

D string
P [A-Z]{1,3}
M [1:3]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.
D |  | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P |  | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M |  | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


 Sprachenschlüssel

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

IDM_MERGE 2.2.0 XML-Schema Dokumentation

Einleitung > Sprachenschlüssel

Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Niederländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu


 Länderschlüssel

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Einleitung > Länderschlüssel

IDM_MERGE 2.2.0 XML-Schema Dokumentation

Einleitung > Länderschlüssel

AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


 Typen für Detailinformationen

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Einleitung > Länderschlüssel

IDM_MERGE 2.2.0 XML-Schema Dokumentation

Einleitung > Typen für Detailinformationen

Einleitung > Typen für Detailinformationen

Für die Beschreibung der Art der Detailinformation gibt es folgende Info-Typen:

1
= Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Funktionsbeschreibung                                                                                                            16
= Planungshinweis
                                                                                17
= Katalogbild


 Schema IDM_MERGE_2_2_0.xsd.DE.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\MERGE\Doku IDM Merge\IDM_MERGE_2_2_0.xsd.DE.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
NODES | languagetext
T_NEW_MERGE_CATALOGS | languagetext30
 | languagetext40


 element NODES
diagram
properties
content complex
children NODE
used by
elements NODES/NODE T_NEW_MERGE_CATALOGS/STRUCTURE
annotation
documentation
Der Knoten dient einer untergeordneten Gruppe des Einstieges für den Handel.

Die Einstiegsstruktur darf maximal dreistufig sein.


 element NODES/NODE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children NODE_NAME CATALOG_REFERENCES_REF NODES DETAIL_INFOS
annotation
documentation
Dieses Element dient der Referenzierung durch die Einstiegsstruktur für den Handel bezüglich des Multiherstellerkataloges.

Er enthält die Einstiegsbezeichnung und die dazu gehörigen Katatalogreferenzierungen.

Dazu müssen Kataloge sortimentsentsprechend erfasst und in Multiherstellerkataloge involviert werden.

Ziel ist es, mit den Multiherstellerkatalogen, den Einstieg in das Sortiment zu erleichtern, bzw. zu optimieren. Es einsteht folglich eine Einstiegsstruktur, die möglichst dynamisch und flexibel das Sortiment strukturiert.

Beispiele möglicher Einstiege:

1)
• Stoff
• Leder

2)
• Wohnen
• Polster

3)
• Hausmarke
• Platzierte Modelle
• Freies Verbandssortiment

Das Ganze kann man sich auch noch mehrstufig vorstellen

4)
• Hausmarken
o Wohnen
o Polster
• Platzierte Modelle
o Lieferant A
o Lieferant B
• Freies Verbandssortiment
o Lieferant A
o Lieferant B

Hier sind unzählige Konstellationen denkbar. Jeder Hersteller wird hier seine eigene Vorstellung haben, wie diese Struktur aussehen soll.


 attribute NODES/NODE/@NODE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 99 |
annotation
documentation
Hier wird der eindeutige Knoten-Identifikator erfasst.


 attribute NODES/NODE/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 99 |
annotation
documentation
Hier wird die Sortierung realisiert.


 element NODES/NODE/NODE_NAME
diagram
type | languagetext30
properties
content complex
children | LANGUAGE
annotation
documentation
Hier wird die Einstiegsbezeichnung angegeben.


 element languagetext30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute languagetext30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element NODES/NODE/CATALOG_REFERENCES_REF
diagram
properties
content complex
children SUPPLIER_GLN_NO CATALOG_ID
annotation
documentation
Dieses Element dient der Katalogreferenzierung.


 element NODES/NODE/CATALOG_REFERENCES_REF/SUPPLIER_GLN_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [0-9]{13} |
annotation
documentation
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.


 element NODES/NODE/CATALOG_REFERENCES_REF/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
Hier wird die eindeutige ID eines Herstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.


 element NODES/NODE/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children DETAIL_INFO_REF
annotation
documentation
Dieses Element dient der Angabe von Bildern oder anderer Medien für die Einstiegsstruktur.


 element NODES/NODE/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Detailinformationen referenziert.


 attribute NODES/NODE/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.


 attribute NODES/NODE/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut ermöglicht eine selbstdefinierte Sortierreihnfolge der Detailinformationen.


 element T_NEW_MERGE_CATALOGS/STRUCTURE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children NODES
annotation
documentation
Dieses Element dient der Definition einer Einstiegsstruktur für den Handel.

Dazu müssen Kataloge sortimentsentsprechend erfasst und in Multiherstellerkataloge involviert werden.

Ziel ist es, mit den Multiherstellerkatalogen, den Einstieg in das Sortiment zu erleichtern, bzw. zu optimieren. Es entsteht folglich eine Einstiegsstruktur, die möglichst dynamisch und flexibel das Sortiment strukturiert.

Beispiele möglicher Einstiege:

1)

• Stoff
• Leder

2)

• Wohnen
• Polster

3)

• Hausmarke
• Platzierte Modelle
• Freies Verbandssortiment

Das Ganze kann man sich auch noch mehrstufig vorstellen

4)

• Hausmarken
o Wohnen
o Polster

• Platzierte Modelle
o Lieferant A
o Lieferant B

• Freies Verbandssortiment
o Lieferant A
o Lieferant B

Hier sind unzählige Konstellationen denkbar. Jeder Hersteller wird hier seine eigene Vorstellung haben, wie diese Struktur aussehen soll.


 complexType languagetext
diagram
children LANGUAGE
used by
elements T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_INFO T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.


 element languagetext/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute languagetext/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA-Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
b Fettdruck
br Zeilenumbruch


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_INFO
diagram
type | languagetext
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element werden die Informationstexte abgelegt.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält Text für einen Hinweis zum Link.


 element T_NEW_MERGE_CATALOGS
diagram
properties
content complex
children CATALOG SUPPLIER GLOBAL_DEFINITION CATALOG_REFERENCES STRUCTURE
annotation
documentation
In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.


 attribute T_NEW_MERGE_CATALOGS/@MAJOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION.


 attribute T_NEW_MERGE_CATALOGS/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 2 |
annotation
documentation
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.


 attribute T_NEW_MERGE_CATALOGS/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 2 |
annotation
documentation
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.


 element T_NEW_MERGE_CATALOGS/CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CATALOG_NAME DATA_VERSION VALID_FROM_DATE VALID_UNTIL_DATE CATALOG_INFO CATALOG_VERSION DETAIL_INFOS
annotation
documentation
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children GLN_NO CATALOG_ID FILE_RELEASE_DATE
annotation
documentation
In diesem Element werden identifizierende Merkmale des Multihersteller-Kataloges hinterlegt.

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_IDENTIFICATION/GLN_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | (0-9){13} |
annotation
documentation
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_IDENTIFICATION/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
Hier wird die eindeutige ID eines Multiherstellers angegeben, um den Katalog eindeutig zu identifizieren.

Ein Multiherstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_IDENTIFICATION/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
In diesem Element soll der Zeitstempel für die Erstellung des Datenbestandes in der UTC Zeit angegeben werden.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_NAME
diagram
type | languagetext30
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird der Katalogname des Datenbestandes angegeben. Er dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.


 element T_NEW_MERGE_CATALOGS/CATALOG/DATA_VERSION
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden.


 element T_NEW_MERGE_CATALOGS/CATALOG/VALID_FROM_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Mit dem Element wird der Beginn der Gültigkeit des Multiherstellerkataloges angegeben.

Der Gültigkeitszeitraum, der für einen Multiherstellerkatalog innerhalb des Elementes CATALOG angegeben ist, gilt für die Zusammenstellung, sie bezieht sich nicht auf einen in der Zusammenstellung angegebenen Einzelkatalog, wenn dieser für eine Planung als Einzelkatalog genutzt wird.


 element T_NEW_MERGE_CATALOGS/CATALOG/VALID_UNTIL_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Mit dem Element wird das Ende der Gültigkeit des Multiherstellerkataloges angegeben.

Der Gültigkeitszeitraum, der für einen Multiherstellerkatalog innerhalb des Elementes CATALOG angegeben ist, gilt für die Zusammenstellung, sie bezieht sich nicht auf einen in der Zusammenstellung angegebenen Einzelkatalog, wenn dieser für eine Planung als Einzelkatalog genutzt wird.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_VERSION
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
Hier muss der Hersteller eine Versions-Nr. für den Katalog vergeben.


 element T_NEW_MERGE_CATALOGS/CATALOG/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children DETAIL_INFO_REF
annotation
documentation
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.


 element T_NEW_MERGE_CATALOGS/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Detailinformationen referenziert.


 attribute T_NEW_MERGE_CATALOGS/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.


 attribute T_NEW_MERGE_CATALOGS/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Detailinformationen am Katalog mit einer selbstdefinierten Sortierreihenfolge anzulegen.


 element T_NEW_MERGE_CATALOGS/SUPPLIER
diagram
properties
content complex
children ISO_COUNTRY_ID WEEE_NO CONTACT_PERSON CONTACT_SUPPLIER
annotation
documentation
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/WEEE_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON
diagram
properties
minOcc | 1
maxOcc | 2
content | complex
children CONTACT_PERSON_NO CONTACT_ROLE CONTACT_NAME FIRST_NAME FORM_OF_ADDRESS DEPARTMENT TELEPHONE FAX EMAIL STREET ZIPCODE_STREET CITY ISO_COUNTRY_ID
annotation
documentation
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/CONTACT_PERSON_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme)


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/CONTACT_ROLE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 60 |
annotation
documentation
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher).


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/CONTACT_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/FIRST_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/FORM_OF_ADDRESS
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/DEPARTMENT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/TELEPHONE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/FAX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
In diesem Element wird die E-Mail-Adresse angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/CITY
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Sitz des Herstellers angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER
diagram
properties
content complex
children MANUFACTURER_NAME_1 MANUFACTURER_NAME_2 EMAIL INTERNET_ADDRESS STREET ZIPCODE_STREET CITY ISO_COUNTRY_ID ZIPCODE_POSTBOX POSTBOX TELEPHONE_SWITCHBOARD FAX_SWITCHBOARD
annotation
documentation
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_1
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird die 1. Zeile des Firmennamens angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_2
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/INTERNET_ADDRESS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de).


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/CITY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Sitz des Herstellers angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{0,10} |
annotation
documentation
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/TELEPHONE_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/FAX_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION
diagram
properties
content complex
children DETAIL_INFOS
annotation
documentation
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO
annotation
documentation
In diesem Element werden Detail-Informationen hinterlegt.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION INFO_TYPE EXTERNAL_NAME INTERNAL_NAME TOOL_TIP URL LAYER
annotation
documentation
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.


 attribute T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
Dieses Attribut identifiziert eine Detailinformation.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/CLASSIFICATION
diagram
type restriction of xs:string
properties
content simple
annotation
documentation
Dieses Element dient der Klassifizierung der Detailinformation.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INFO_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
maxInclusive | 17 |
annotation
documentation
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen.

Für Milieufotos (INFO_TYPE = 1) wird eine Bildgröße von 2048x2048px empfohlen.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
diagram
type | languagetext40
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.


 element languagetext40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute languagetext40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,40} |
annotation
documentation
Längenbeschränkung 1-40

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL
diagram
properties
content complex
children LANGUAGE
annotation
documentation
Dieses Element gibt die URL zur Detailinformation an.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT HASH_VALUE
annotation
documentation
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/TEXT
diagram
type xs:anyURI
properties
content simple
annotation
documentation
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/HASH_VALUE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 32 |
maxLength | 32 |
annotation
documentation
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/LAYER
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-6]0 |
annotation
documentation
Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:
10 Teppich
20 Sofa/ Möbel/ Tisch (Default-Wert)
30 Kissen
40 Dekorkissen
50 Kopfstütze
60 Plate/ Überwurf


 element T_NEW_MERGE_CATALOGS/CATALOG_REFERENCES
diagram
properties
content complex
children CATALOG_REFERENCE
annotation
documentation
Dieses Element dient zur Referenzierung auf die Herstellerkataloge.

Wenn von einem Herstellerkatalog mehrere Versionen vorliegen, wird immer auf die aktuellste Version referenziert.


 element T_NEW_MERGE_CATALOGS/CATALOG_REFERENCES/CATALOG_REFERENCE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Hier werden die Angaben eines Herstellerkataloges über die GLN des Herstellers und den Identifikator des Kataloges gespeichert.


 attribute T_NEW_MERGE_CATALOGS/CATALOG_REFERENCES/CATALOG_REFERENCE/@SUPPLIER_GLN_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]{13} |
annotation
documentation
In dieses Attribut wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.


 attribute T_NEW_MERGE_CATALOGS/CATALOG_REFERENCES/CATALOG_REFERENCE/@CATALOG_ID
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.


 complexType languagetext30
diagram
children LANGUAGE
used by
elements T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_NAME NODES/NODE/NODE_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.


 complexType languagetext40
diagram
children LANGUAGE
used by
element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.