 Introduction

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

IDM_MERGE 2.2.0 XML schema

Documentation

release 21 December 2021

Documented XML schema:

IDM_MERGE_2_2_0.xsd

Contakt DCC e.V.

Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telephon 0 52 21/12 65-37

Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telephon 0 52 21/12 65-38


 Basic structure of the IDM format

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] IDM_MERGE 2.2.0 XML schema documentation

Introduction > Basic structure of the IDM format

Einleitung > Grundstruktur des IDM-Schemas

Basic structure of the IDM format

The main element T_NEW_MERGE_CATALOGS defines that a new and complete multi-manufacturer catalogue data pool is made available.

The IDM format is subdivided in data ranges that are specified in the subsequent child-elements (see figure 1) in T_NEW_MERGE_CATALOGS.

The data ranges are not used in isolation from each other. In some data ranges, data is initially created and used from other data ranges via referencing.

Description of the data ranges

CATALOG

CATALOG is used to store administrative information concerning the data pool. E.g. the version of the data format, release date or the unique identification of the data pool.

SUPPLIER

SUPPLIER is used to store administrative information concerning the manufacturer. Example: specification of contact data or the manufacturer's country of origin.

GLOBAL_DEFINITION

The GLOBAL_DEFINITION data range is a kind of data pool for information used in the other data ranges. Example: storage of media, e.g. photos and installation instructions.

CATALOG_REFERENCES

CATALOG_REFERENCES are used to reference the catalogues associated with this multi-manufacturer catalogue via the GLN of a manufacturer and its CATALOG_ID element.


 Data types

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] IDM_MERGE 2.2.0 XML schema documentation

Introduction > Data types

Einleitung > Datentypen

Data types and value ranges

The IDM schema used the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

IDMP version 2.4 uses the following data types:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDMP, the data type date is used in conformity with the XML schemas as follows:
 | YYYY-MM-DD
 | Y = year, M = month, D = day
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDMP for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.05 ir 45.98000 or +27.0
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDMP for URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used in the IDMP for the mapping of valid language keys.language represents codes for natural languages as defined in theTags for the Identification of Languages The value range of language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.
Additionally, there are also user-defined data types:
languagetext |  | This data type is used to create multiple-language texts of any length.
languagetext30 |  | This data type is used to create multiple-language texts with a maximum length of 30 characters.
languagetext40 |  | This data type is used to create multiple-language texts with a maximum length of 40 characters.


 Notes to the documentation

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] IDM_MERGE 2.2.0 XML schema documentation

Introduction > Notes to the documentation

Einleitung > Erläuterung zur Dokumentation

Notes to the IDM documentation

Notes to the IDM documentation schema are stored in this section.

Explanation of the element properties

Each element is documented on the basis of a description and its properties. The following shows an example for an element description:

Description:

GLN_NO

This element is used to enter a unique global location number (GLN). The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data. In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben.

D string

P (0-9){13}

M [13:13] D string
P [A-Z]{2}
M [2:2]

In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden.

D string
P [A-Z]{1,3}
M [1:3]

The element properties are documented on the right side. They have the following meaning:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.
D |  | The data type of the element is documented here. If this position is left blank, the element does not contain any reference data but additional child-elements.
P |  | The entries made in P and M document the value range of an element. A regular expression that defines the permitted values must be entered in P.
M |  | The minimum and maximum permitted values must be entered in M. In the case of a string data type, P defines the permitted characters and M the minimum and maximum character length. In the case of a numeric data type, the permitted minimum and maximum value is defined.


 Language key

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

IDM_MERGE 2.2.0 XML schema documentation

Introduction > Language key

Einleitung > Sprachenschlüssel

Language key | Language name
AA | Afar
AB | Abkhazian
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AV | Avarisch
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CR | Cree
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundish
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothish
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VE | Tshivenda
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu

According to the ISO standard, the language keys are generally written with small letters. Capital letters are used for the IDM data.


 Country code

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Einleitung > Länderschlüssel

IDM_MERGE 2.2.0 XML schema documentation

Introduction > Country code

country code | country
AC | Ascension
AD | Andorra
AE | United Arab Emirates
AF | Afghanistan
AG | Antigua and Barbuda
AI | Anguilla
AL | Albania
AM | Armenia
AN | Dutch Antilles
AO | Angola
AQ | Antarctica
AR | Argentina
AS | American Samoa
AT | Austria
AU | Australia
AW | Aruba
AX | Aland
AZ | Azerbaijan
BA | Bosnia and Herzegovina
BB | Barbados
BD | Bangladesh
BE | Belgium
BF | Burkina Faso
BG | Bulgaria
BH | Bahrain
BI | Burundi
BJ | Benin
BL | Saint-Barthélemy
BM | Bermuda
BN | Brunei Darussalam
BO | Bolivia
BQ | Bonaire, Sint Eustatius and Saba
BR | Brazil
BS | Bahamas
BT | Bhutan
BU | Burma
BV | Bouvet Island
BW | Botswana
BY | Belarus
BZ | Belize
CA | Canada
CC | Cocos) Islands
CD | Democratic Republic of the Congo
CF | Central African Republic
CG | Republic of the Congo
CH | Switzerland
CI | Ivory Coast
CK | Cook Islands
CL | Chile
CM | Cameroon
CN | China
CO | Columbia
CP | Clipperton
CR | Costa Rica
CU | Cuba
CV | Cape Verde
CW | Curaçao
CX | Christmas Island
CY | Cyprus
CZ | Czech Republic
DE | Germany
DG | Diego Garcia
DJ | Djibouti
DK | Denmark
DM | Dominica
DO | Dominican Republic
DZ | Algeria
EA | Ceuta, Melilla
EC | Ecuador
EE | Estonia
EG | Egypt
EH | Westsahara
EN | England
ER | Eritrea
ES | Spain
ET | Ethiopia
FI | Finland
FJ | Fiji
FK | Falklands
FM | Micronesia
FO | Faeroe Islands
FR | France
GA | Gabon
GB | England/Great Britain
GD | Grenada
GE | Georgia
GF | French Guiana
GG | Guernsey (Channel Island)
GH | Ghana
GI | Gibraltar
GL | Greenland
GM | Gambia
GN | Guinea
GP | Guadeloupe
GQ | Equatorial Guinea
GR | Greece
GS | South Georgia and the South Sandwich Islands
GT | Guatemala
GU | Guam
GW | Guinea-Bissau
GY | Guyana
HK | Hong Kong
HM | Heard and McDonald Islands
HN | Honduras
HR | Croatia
HT | Haiti
HU | Hungary
ID | Indonesian
IE | Ireland
IL | Israel
IM | Isle of Man
IN | India
IO | British Indian Ocean Territory
IQ | Iraq
IR | Islamic Republic of Iran
IS | Iceland
IT | Italy
JE | Channel Island of Jersey
JM | Jamaica
JO | Jordan
JP | Japan
KE | Kenya
KG | Kyrgyzstan
KH | Cambodia
KI | Kiribati
KM | Comoros
KN | Saint Kitts and Nevis
KP | Democratic People's Republic of Korea
KR | Republic of Korea
KW | Kuwait
KY | Cayman Islands
KZ | Kazakstan
LA | Laos
LB | Lebanon
LC | Saint Lucia
LI | Liechtenstein
LK | Sri Lanka
LR | Liberia
LS | Lesotho
LT | Lithuania
LU | Luxembourg
LV | Latvia
LY | Libya
MA | Morocco
MC | Monaco
MD | Moldavia
ME | Montenegro
MF | Saint Martin
MG | Madagascar
MH | Marshall Islands
MK | North Macedonia
ML | Mali
MM | Myanmar (Burma)
MN | Mongolia
MO | Macau
MP | Northern Mariana Islands
MQ | Martinique
MR | Mauritania
MS | Montserrat
MT | Malta
MU | Mauritius
MV | Maldives
MW | Malawi
MX | Mexico
MY | Malaysia
MZ | Mozambique
NA | Namibia
NC | New Caledonia
NE | Niger
NF | Norfolk Island
NG | Nigeria
NI | Nicaragua
NL | Netherlands
NO | Norway
NP | Nepal
NR | Nauru
NU | Niue
NZ | New Zealand
OM | Oman
PA | Panama
PE | Peru
PF | French Polynesia
PG | Papuan New Guinea
PH | Philippine
PK | Pakistan
PL | Poland
PM | St. Pierre and Miquelon
PN | Pitcairn Islands
PR | Puerto Rica
PS | Palestine
PT | Portugal
PW | Palau
PY | Paraguay
QA | Qatar
RE | Reunion
RO | Romania
RS | Serbia
RU | Russia
RW | Ruanda
SA | Saudi Arabia
SB | Solomon Islands
SC | Seychelles
SD | Sudan
SE | Sweden
SG | Singapore
SH | St. Helena
SI | Slovenia
SJ | Svalbard and Jan Mayen Islands
SK | Slovak Republic
SL | Sierra Leone
SM | San Marino
SN | Senegal
SO | Somalia
SR | Suriname
SS | South Sudan
ST | Democratic Republic of São Tomé and Príncipe
SV | El Salvador
SX | Sint Maarten
SY | Syrian Arab Republic
SZ | Swaziland
TC | Turks and Caicos Islands
TD | Chad
TF | French Southern and Antarctic Territories
TG | Togo
TH | Thailand
TJ | Tadschikistan
TK | Tokelau
TL | East Timor
TM | Turkmenistan
TN | Tunisia
TO | Tonga
TR | Turkey
TT | Trinidad and Tobago
TV | Tuvalu
TW | Taiwan
TZ | Tanzania
UA | Ukraine
UG | Uganda
UM | United States Minor Outlying Islands
US | United States of America
UY | Uruguay
UZ | Uzbekistan
VA | Vatican City
VC | Saint Vincent and the Grenadines
VE | Venezuela
VG | British Virgin Islands
VI | American Virgin Islands
VN | Vietnam
VU | Vanuatu
WF | Wallis and Futuna Islands
WS | Samoa
YE | Yemen
YT | Mayotte
ZA | South Africa
ZM | Sambia
ZW | Zimbabwe


 Types of detailed information

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Einleitung > Länderschlüssel

IDM_MERGE 2.2.0 XML schema documentation

Introduction > Types of detailed information

Einleitung > Typen für Detailinformationen

The following info types can be used to describe the type of detail information:

1 = Milieu photo

2 = Item pictogram (type/item overview)

3 = Magnetic planner drawing (SVGs in top view)

4 = Version photo

5 = Version texture (type of leather, ...)

6 = Manufacturer logo/product brand

7 = Colour consultancy (the versions are defined in an assessment procedure)

8 = Fabric sample book (PDF for fabric groups)

9 = Model description sheets (PDF below series)

10 = Installation instructions

11 = Marketing

12 = Miscellaneous

13 = Colour consultancy wall

14 = Colour consultancy floor

15 = functional description

16 = planning advice

17 = catalogue image


 Schema IDM_MERGE_2_2_0.xsd.EN.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\MERGE\Doku IDM Merge\IDM_MERGE_2_2_0.xsd.EN.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
NODES | languagetext
T_NEW_MERGE_CATALOGS | languagetext30
 | languagetext40


 element NODES
diagram
properties
content complex
children NODE
used by
elements NODES/NODE T_NEW_MERGE_CATALOGS/STRUCTURE
annotation
documentation
The node serves the purpose of enabling a sub-ordinate group to ensure the trade.

The entry structure must not have more than three levels.


 element NODES/NODE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children NODE_NAME CATALOG_REFERENCES_REF NODES DETAIL_INFOS
annotation
documentation
This element serves to reference the entry structure for the trade with respect to the multi-manufacturer catalogue.

It contains the entry designation and the associated catalogue references.

This requires capturing of catalogues is in accordance with the range and their involvement in multi-manufacturer catalogues.

The objective of the multi-manufacturer catalogues is to simplify and/or optimise entry into the product range. It provides a dynamic and flexible infrastructure for the product range.

Examples for possible entries:

1)

• Fabric
• Leather

2)

• Living
• Upholstery

3)

• Private label
• Placed models
• Free product range (trade association)

The above is also possible as a multi-level model

4)

• Private labels
o Living
o Upholstery

• Placed models
o Supplier A
o Supplier B

• Free product range (trade association)
o Supplier A
o Supplier B

Any constellation is possible. Each manufacturer will have its own ideas about this structure.


 attribute NODES/NODE/@NODE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 99 |
annotation
documentation
The unique node identifier is specified here.


 attribute NODES/NODE/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 99 |
annotation
documentation
The sorting takes place here.


 element NODES/NODE/NODE_NAME
diagram
type | languagetext30
properties
content complex
children | LANGUAGE
annotation
documentation
The entry designation the specified here.


 element languagetext30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute languagetext30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute is used to specify theISO code of the language in which the text is stored.


 element languagetext30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element NODES/NODE/CATALOG_REFERENCES_REF
diagram
properties
content complex
children SUPPLIER_GLN_NO CATALOG_ID
annotation
documentation
This element is used to reference the catalogue.


 element NODES/NODE/CATALOG_REFERENCES_REF/SUPPLIER_GLN_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [0-9]{13} |
annotation
documentation
This attribute is used to enter the unique global location number (GLN). The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.


 element NODES/NODE/CATALOG_REFERENCES_REF/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
The unique ID of a manufacturer is specified here in order to provide a unique identification of the catalogue.

A manufacturer catalogue must always have the same ID for the same dealership.


 element NODES/NODE/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element is used to specify images or other media for the entry structure.


 element NODES/NODE/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference the detailed information.


 attribute NODES/NODE/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced detailed information.


 attribute NODES/NODE/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute allows for the detailed information a freely-defined sorting order.


 element T_NEW_MERGE_CATALOGS/STRUCTURE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children NODES
annotation
documentation
This element is used to define an entry structure for retail dealers.

This requires capturing of catalogue is in accordance with the range and their involvement in multi-manufacturer catalogues.

The objective of the multi-manufacturer catalogues is to simplify and/or optimise entry into the product range. It provides a dynamic and flexible infrastructure for the product range.

Examples for possible entries:

1)

• Fabric
• Leather

2)

• Living
• Upholstery

3)

• Private label
• Placed models
• Free product range (trade association)

The above is also possible as a multi-level model

4)

• Private labels
o Living
o Upholstery

• Placed models
o Supplier A
o Supplier B

• Free product range (trade association)
o Supplier A
o Supplier B

Any constellation is possible. Each manufacturer will have its own ideas about this structure.


 complexType languagetext
diagram
children LANGUAGE
used by
elements T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_INFO T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
annotation
documentation
This data type is used to create multiple-language texts of any length.


 element languagetext/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute languagetext/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute is used to specify theISO code of the language in which the text is stored.


 element languagetext/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node

The text must be specified in HTML format:
b Bold font
br line break


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_INFO
diagram
type | languagetext
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to store the information texts.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains the display name of the link (e.g. "sketch 4711").


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains the text for a link note.


 element T_NEW_MERGE_CATALOGS
diagram
properties
content complex
children CATALOG SUPPLIER GLOBAL_DEFINITION CATALOG_REFERENCES STRUCTURE
annotation
documentation
This element is used for storing and providing all information and data for the issuing of a complete catalogue/ database.


 attribute T_NEW_MERGE_CATALOGS/@MAJOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
The version number "MAJOR" indicates the format version of the database. This main version number is only changed if the format is changed completely.
The complete definition of a format version consists of the following elements: MAJOR, MINOR and REVISION.


 attribute T_NEW_MERGE_CATALOGS/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 2 |
annotation
documentation
In general the number of the sub-version "MINOR" changes every year. In case the main version number MAJOR is changed, the sub-version number is reset to 0.


 attribute T_NEW_MERGE_CATALOGS/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 2 |
annotation
documentation
During the year the field revision number "REVISION" indicates changes of the format, as agreed upon in the regular sessions of the committee. The different revisions are not issued unless they are necessary corrections. The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0.


 element T_NEW_MERGE_CATALOGS/CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CATALOG_NAME DATA_VERSION VALID_FROM_DATE VALID_UNTIL_DATE CATALOG_INFO CATALOG_VERSION DETAIL_INFOS
annotation
documentation
All administrative information about the catalogue/ database is stored in this element.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children GLN_NO CATALOG_ID FILE_RELEASE_DATE
annotation
documentation
Identifying features of the multi-manufacturer catalog are stored in this element.

If the content of these elements differs from the base file in an updated catalogue, it is not possible to update the existing catalogue.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_IDENTIFICATION/GLN_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | (0-9){13} |
annotation
documentation
This element is used to enter a unique global location number (GLN). The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_IDENTIFICATION/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
The unique ID of a multi-manufacturer is specified here in order to provide a unique identification of the catalogue.

A multi-manufacturer catalogue must always have the same ID for the same dealership.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_IDENTIFICATION/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
This element provides the time stamp for the creation of the data pool in UTC time.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_NAME
diagram
type | languagetext30
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to specify the catalogue name of the data pool.It serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.


 element T_NEW_MERGE_CATALOGS/CATALOG/DATA_VERSION
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database.


 element T_NEW_MERGE_CATALOGS/CATALOG/VALID_FROM_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
The element is used to specify the validity period start date of the multi-manufacturer catalogue.

The period of validity specified for a multi-manufacturer catalog applies to the compilation, it does not refer to an individual catalog contained in the compilation if this is used for planning as an individual catalogue.


 element T_NEW_MERGE_CATALOGS/CATALOG/VALID_UNTIL_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
The element is used to specify the validity period expiry date of the multi-manufacturer catalogue.

The period of validity specified for a multi-manufacturer catalog applies to the compilation, it does not refer to an individual catalog contained in the compilation if this is used for planning as an individual catalogue.


 element T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_VERSION
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
The manufacturer must assign a version number for the catalogue in this field.


 element T_NEW_MERGE_CATALOGS/CATALOG/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element serves to specify images on catalogue level, e.g. a manufacturer or catalogue logo.


 element T_NEW_MERGE_CATALOGS/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference the detailed information.


 attribute T_NEW_MERGE_CATALOGS/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced detailed information.


 attribute T_NEW_MERGE_CATALOGS/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute allows for the detailed information a freely defined sorting order.


 element T_NEW_MERGE_CATALOGS/SUPPLIER
diagram
properties
content complex
children ISO_COUNTRY_ID WEEE_NO CONTACT_PERSON CONTACT_SUPPLIER
annotation
documentation
This element is used to specify the manufacturer's data, e.g. communication and contact information.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element is used to specify the manufacturer's country in accordance with theISO standard.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/WEEE_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to enter the WEEE registration number. A WEEE registration number is mandatory for everyone classified as a manufacturer or importer of electrical appliances in accordance with the "Electrical and Electronic Equipment Act" (ElektroG).
In Germany, WEE look as follows: "DE12345678".
Dealers can verify the validity of WEE numbers on the website of the register for Waste Electrical Appliances (http://www.stiftung-ear.de).


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON
diagram
properties
minOcc | 1
maxOcc | 2
content | complex
children CONTACT_PERSON_NO CONTACT_ROLE CONTACT_NAME FIRST_NAME FORM_OF_ADDRESS DEPARTMENT TELEPHONE FAX EMAIL STREET ZIPCODE_STREET CITY ISO_COUNTRY_ID
annotation
documentation
This element is used to specify the information of a contact person.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/CONTACT_PERSON_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
This element is used to specify the priorities of methods for making contact with the contact person. (1=1st contact, 2=2nd contact)


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/CONTACT_ROLE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 60 |
annotation
documentation
This element is used to specify the role of the newly created contact. The role designations are certified by the manufacturer (e.g. substitute, person responsible for IT).


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/CONTACT_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
This element is used to specify the last name of the direct contact person for the software house.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/FIRST_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
This element is used to specify the first name of the direct contact person.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/FORM_OF_ADDRESS
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
This element is used to specify the salutation for the direct contact person.
1 = Mrs
2 = Mr


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/DEPARTMENT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is, if present, used to specify the department of the direct contact person.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/TELEPHONE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element is used to specify the telephone number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(1234)56-7890.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/FAX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element is used to specify the fax number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(5251)60-3284.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
This element is used to specify the email address.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to specify the street of the manufacturer's business address.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
This element is used to specify the postcode of the manufacturer's business address.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/CITY
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to specify the manufacturer's place registered office.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_PERSON/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element is used to specify the manufacturer's country in accordance with theISO standard.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER
diagram
properties
content complex
children MANUFACTURER_NAME_1 MANUFACTURER_NAME_2 EMAIL INTERNET_ADDRESS STREET ZIPCODE_STREET CITY ISO_COUNTRY_ID ZIPCODE_POSTBOX POSTBOX TELEPHONE_SWITCHBOARD FAX_SWITCHBOARD
annotation
documentation
This element is used to specify the manufacturer's contact data.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_1
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to specify the first line of the company name.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_2
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
If activated, this element is used to store the second line of the company name.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
This element is used to specify the official email address for the dealership or consumer.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/INTERNET_ADDRESS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element, if present, is used to specify the official URL (e.g. http://www.company.com) for dealerships or consumers.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to specify the street of the manufacturer's business address.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
This element is used to specify the postcode of the manufacturer's business address.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/CITY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to specify the manufacturer's place registered office.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element is used to specify the manufacturer's country in accordance with theISO standard.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
This element, if present, is used to specify the postcode associated with the PO Box.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{0,10} |
annotation
documentation
This element, if present, is used to specify the PO Box line of the manufacturer's address. The word "PO Box" must be omitted.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/TELEPHONE_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element is used to specify the telephone number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890.


 element T_NEW_MERGE_CATALOGS/SUPPLIER/CONTACT_SUPPLIER/FAX_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element is used to specify the fax number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION
diagram
properties
content complex
children DETAIL_INFOS
annotation
documentation
This element is used to specify data that is valid for the entire catalogue/data pool (global information).


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO
annotation
documentation
This element is used to specify detailed information.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION INFO_TYPE EXTERNAL_NAME INTERNAL_NAME TOOL_TIP URL LAYER
annotation
documentation
This element is used to specify URLs to detailed information.


 attribute T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute identifies a detailed information.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/CLASSIFICATION
diagram
type restriction of xs:string
properties
content simple
annotation
documentation
This element is used to classify detailed information.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INFO_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
maxInclusive | 17 |
annotation
documentation
This element is here to describe the type of detailed information.

The values of the available info types can be found in the corresponding table in the introduction.

An image size of 2048x2048px is recommended for images of typical settings (INFO_TYPE = 1).


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
diagram
type | languagetext40
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.


 element languagetext40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute languagetext40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute is used to specify theISO code of the language in which the text is stored.


 element languagetext40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,40} |
annotation
documentation
Längenbeschränkung 1-40

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL
diagram
properties
content complex
children LANGUAGE
annotation
documentation
This element specifies the URL to the detailed information.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT HASH_VALUE
annotation
documentation
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute is used to specify theISO code of the language in which the text is stored.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/TEXT
diagram
type xs:anyURI
properties
content simple
annotation
documentation
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/HASH_VALUE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 32 |
maxLength | 32 |
annotation
documentation
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not.


 element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/LAYER
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [1-6]0 |
annotation
documentation
This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw


 element T_NEW_MERGE_CATALOGS/CATALOG_REFERENCES
diagram
properties
content complex
children CATALOG_REFERENCE
annotation
documentation
This element is used to reference the manufacturer catalogues.

If there are several versions of a manufacturer catalogue, the latest version is always referenced.


 element T_NEW_MERGE_CATALOGS/CATALOG_REFERENCES/CATALOG_REFERENCE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
The information about a manufacturer catalogue are stored here via the manufacturer's GLN and the catalogue identifier.


 attribute T_NEW_MERGE_CATALOGS/CATALOG_REFERENCES/CATALOG_REFERENCE/@SUPPLIER_GLN_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]{13} |
annotation
documentation
This attribute is used to enter the unique global location number (GLN). The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.


 attribute T_NEW_MERGE_CATALOGS/CATALOG_REFERENCES/CATALOG_REFERENCE/@CATALOG_ID
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
The manufacturer must enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.
This ID is required for identification in the case of multi-manufacturer catalogues.

A manufacturer catalogue must always have the same ID for the same dealership.


 complexType languagetext30
diagram
children LANGUAGE
used by
elements T_NEW_MERGE_CATALOGS/CATALOG/CATALOG_NAME NODES/NODE/NODE_NAME
annotation
documentation
This data type is used to create multiple-language texts with a maximum length of 30 characters.


 complexType languagetext40
diagram
children LANGUAGE
used by
element T_NEW_MERGE_CATALOGS/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
annotation
documentation
This data type is used to create multiple-language texts with a maximum length of 40 characters.