 Einleitung

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

ADD_PRICE_IDMP 3.0.1 XML-Schema

Dokumentation

Stand 01.12.2021

Dokumentiertes XML-Schema:

ADD_PRICE_IDMP_3_1_0.xsd

Kontakt DCC e.V.

Geschäftsführer
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37

Verantwortliche IDM Arbeitskreise und Dokumentation
Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telefon 0 52 21/12 65-38


 Grundstruktur des IDM-Schemas

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Grundstruktur des IDM-Schemas

Einleitung > Grundstruktur des IDM-Schemas

Die Grundstruktur des IDMP-Schemas

Das Hauptelement T_ADD_PRICE_CATALOG definiert, dass ein neuer, zusätzlicher Datenbestand mit weitere Preisen neben dem Basiskatalog bereitgestellt wird.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_ADD_PRICE_CATALOG abgebildet werden.

Abbildung 1 - Child-Elemente von T_ADD_PRICE_CATALOG

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.
Darüber hinaus referenzieren viele Datenbereiche auf den zugehörigen Basiskatalog.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

REF_CATALOG

In REF_CATALOG werden Informationen zum Basiskatalog hinterlegt.

GLOBAL_DEFINITION

Der Datenbereich GLOBAL_DEFINITION ist ein Datenpool für Informationen, die in den anderen Datenbereichen verwendet werden. Hier sind es die Angaben zu den Preisarten, zu denen die Zusatzpreise in diesem Datenbestand gespeichert werden.

SERIES

In SERIES werden die zusätzlichen Preise für die Artikel des Basiskataloges hinterlegt. Dabei werden die Artikel in Produktgruppen wie beispielsweise Sessel oder Zwischenelemente gruppiert.


 Datentypen

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Datentypen

Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

Es werden folgende Datentypen verwendet:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDMP wird der Datentyp date XML-Schema konform in folgender Weise angewendet:
 | YYYY-MM-DD
 | Y = Jahr, M = Monat, D = Tag
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDMP für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDMP für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDMP für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.
Zusätzlich gibt es einen benutzerdefinierten Datentyp
operator | Der Datentyp wird im IDMP für Regeln genutzt. Mit diesem einfachen selbst definierten Datentyp wird ein Operator für Vergleiche formuliert. Der Vergleichsoperator stellt sich als string der Länge 1 bis 4 dar und kann der folgende Werte enthalten:
 | eq (ist gleich)
 | ne (ist nicht gleich)
 | in (ist enthalten in einer Menge)
 | nin (ist nicht enthalten in der Menge)
 | gt (größer)
 | lt (kleiner)
 | ge (größer gleich)
 | le (kleiner gleich)


 Erläuterung zur Dokumentation

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Erläuterung zur Dokumentation

Einleitung > Erläuterung zur Dokumentation

Erläuterungen zur Dokumentation des IDMP

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

Beschreibung:

In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden.

D string
P [A-Z]{1,3}
M [1:3]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.
D |  | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P |  | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M |  | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge.
 |  | Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


 Sprachenschlüssel

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Sprachenschlüssel

Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Niederländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu


 Länderschlüssel

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Einleitung > Länderschlüssel

ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Länderschlüssel

AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


 Schema ADD_PRICE_IDMP_3_1_0.xsd.DE.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\ADD_PRICE\Doku_Add_Price\ADD_PRICE_IDMP_3_1_0.xsd.DE.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
T_ADD_PRICE_CATALOG | languagetext
 | languagetext30
 | languagetext60


 element T_ADD_PRICE_CATALOG
diagram
properties
content complex
children CATALOG REF_CATALOG GLOBAL_DEFINITION SERIES
annotation
documentation
Dieses Element bietet den Einstieg für zusätzliche Preisinformation bezogen auf einen Katalog im IDMP-Format. Hersteller dieser Daten kann sowohl der Hersteller der IDMP-Daten (bei Angaben weiterer Preisstellungen) als auch der Handel, die Verbände u. Ä. sein, die für die Artikel zusätzliche Preisinformationen transferieren möchten.


 attribute T_ADD_PRICE_CATALOG/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 3 |
maxInclusive | 3 |
annotation
documentation
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION.


 attribute T_ADD_PRICE_CATALOG/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 1 |
annotation
documentation
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.


 attribute T_ADD_PRICE_CATALOG/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 0 |
annotation
documentation
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.


 element T_ADD_PRICE_CATALOG/CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CURRENCY_KEY CATALOG_LANGUAGE CATALOG_NAME FILE_ID CATALOG_DATA_VERSION CATALOG_INFO CATALOG_VERSION RECEIVER_ID PRICE_SALE_REFS ROUNDING_TYPE ROUNDING_SCALE
annotation
documentation
In diesem Element werden administrative Informationen zum Datenbestand hinterlegt.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children GLN_NO CATALOG_ID FILE_RELEASE_DATE
annotation
documentation
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten müssen identisch sein.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_IDENTIFICATION/GLN_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | (0-9){13} |
annotation
documentation
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) des Datenlieferanten dieses Preisrucksackes (nicht des Lieferanten des Basiskataloges) eingetragen.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_IDENTIFICATION/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
In diesem Element soll der Zeitstempel für die Erstellung des Datenbestandes in der UTC Zeit angegeben werden.


 element T_ADD_PRICE_CATALOG/CATALOG/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_LANGUAGE
diagram
properties
content complex
children ISO_LANGUAGE_ID
annotation
documentation
In diesem Element werden die im Datenbestand verwendeten Sprachen angegeben.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_LANGUAGE/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_NAME
diagram
type | languagetext30
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.


 element languagetext30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetext30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_ADD_PRICE_CATALOG/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_DATA_VERSION
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_INFO
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
In diesem Element werden die Informationstexte abgelegt.


 element languagetext/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute languagetext/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
b Fettdruck
br Zeilenumbruch


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_VERSION
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
Hier kann der Hersteller des Datenbestandes eine Versions-Nr. für den Katalog vergeben. Wird zu einem Basiskatalog ein neuer Preisergänzungsdatanbestand herausgegeben, muss der Wert von CATALOG_VERSION hoch gezählt werden.


 element T_ADD_PRICE_CATALOG/CATALOG/RECEIVER_ID
diagram
type xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Hier wird die ID des Empfängers eingetragen.


 element T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PRICE_SALE_REF
annotation
documentation
Hier können zusätzliche Preise bezogen auf die Preisangaben des Basisikataloges per Faktor global für den ganzen Katalog angegeben werden.


 element T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS/PRICE_SALE_REF
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children PRICE_SALE_FACTOR VALID_FROM VALID_UNTIL
annotation
documentation
In diesem Element erfolgen die Angaben zu einem des Identifikators PRICE_NO entsprechenden Preises.


 attribute T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS/PRICE_SALE_REF/@PRICE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9 |
annotation
documentation
Dieses Attribut referenziert einen Preislistennamen entsprechend der Einträge im Attribut PRICE_SALE_NO unterhalb von PRICE_SALE.


 element T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE_SALE_FACTOR
diagram
type restriction of xs:int
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -9999999 |
maxInclusive | 99999999 |
annotation
documentation
Dieses Element enthält den Faktor, mit dem sich der Preis dieses Preislistennamens bezogen auf die Preise im Basiskatalog errechnet. Die Gültigkeit bei Angabe eines Aufpreises entspricht der der Originaldaten.


 element T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt den Gültigkeitsbeginn des zusätzlich angegeben Preises an.


 element T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Hier wird das Gültigkeitsende des Preises vermerkt.


 element T_ADD_PRICE_CATALOG/CATALOG/ROUNDING_TYPE
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
Rundungseinstellung können bei Angabe eines Faktors zusätzlich angegeben werden.

In diesem Element wird die Art des Rundens angegeben:
1 = Aufrunden
2 = Abrunden
3 = kaufmännisches Runden


 element T_ADD_PRICE_CATALOG/CATALOG/ROUNDING_SCALE
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -3 |
maxInclusive | 2 |
annotation
documentation
Rundungseinstellung können bei Angabe eines Faktors zusätzlich angegeben werden.

Dieses Element gibt an, auf wie viele Stellen gerundet werden soll.
-3 = Runden auf 1000er
-2 = Runden auf 100er
-1 = Runden auf 10er
0 = Runden auf 1er
1 = Runden auf 1 Nachkommastelle
2 = Runden auf 2 Nachkommastellen


 element T_ADD_PRICE_CATALOG/REF_CATALOG
diagram
properties
content complex
annotation
documentation
Hier wird der Katalog, auf den sich die zusätzlichen Preise beziehen, über die GLN des Herstellers und die CATALOG_ID des Basiskataloges referenziert.

Die aktuellste Rucksackdatei ist dabei immer zum aktuellsten Basiskatalog gültig.


 attribute T_ADD_PRICE_CATALOG/REF_CATALOG/@SUPPLIER_GLN_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]{13} |
annotation
documentation
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) des Herstellers des Basiskataloges eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.


 attribute T_ADD_PRICE_CATALOG/REF_CATALOG/@CATALOG_ID
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
Hier wird die eindeutige ID (z.B.GUID) des Herstellers eingeben, um den BasisKatalog eindeutig zu referenziern. Sie muss den gleichen Wert wie die CATALOG_ID unterhalb von CATALOG im Basiskatalog haben.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.


 element T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION
diagram
properties
content complex
children PRICE_SALES
annotation
documentation
In diesem Element werden für den Datenbestand als globale Informationen die Arten der Zusatzpreise hinterlegt.


 element T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION/PRICE_SALES
diagram
properties
content complex
children PRICE_SALE
annotation
documentation
Hier werden alle Preislistennamen hinterlegt, die in diesem Datenbestand als Zusatzpreise zum Basiskatalog angegeben werden.


 element T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children PRICE_NAME
annotation
documentation
In diesem Element werden die Daten zu einem Preislistennamen hinterlegt.


 attribute T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE/@PRICE_SALE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 10 |
annotation
documentation
Dieses Attribut identifiziert den Preislistennamen. Dabei sind folgende Werte entsprechend des Elementes PURCHASE_RETAIL_ID des Basiskataloges für bestimmte Preislisten festgelegt:

0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto
4 = Mitnahmepreis
5 = Abholpreis
6 = Lieferpreis
7 = Servicepreis inkl. Montage
8 = Auszeichnungspreis
9 = Aktionspreis 1
10=Aktionspreis 2

Die Preis-Rucksackdatei darf nur Preislisten ungleich des Basiskataloges enthalten.


 element T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE/PRICE_NAME
diagram
type | languagetext60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Hier wird ein Preisname angegeben, sofern dieser von den definierten Werten im Attribut PRICE_SALE_NO abweichen soll.

Beispiel:
PRICE_SALE_NO PRICE_NAME
9 = Aktionspreis 1 "Sommerschlussverkauf"


 element languagetext60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetext60/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext60/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,60} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 element T_ADD_PRICE_CATALOG/SERIES
diagram
properties
content complex
children SERIE
annotation
documentation
In diesem Element werden alle Serien des Basiskataloges und deren zugeordneten Bestandteile wie beispielsweise Produktgruppen und Artikeln hinterlegt.

Eine Serie entspricht im Allgemeinen einem Modell.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 1000000
content | complex
children PRODUCT_GROUPS PRICE_SALE_REFS
annotation
documentation
In diesem Element wird eine Serie mit ihren entsprechenden Artikeln gespeichert. Einen Serie entspricht einem Modell. Die Angaben der Nummern und Bezeichnungen müssen denen des Basiskataloges entsprechen.


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
In diesem Attribut wird die Seriennummer der Serie des Basiskataloges angegeben.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
content complex
children PRODUCT_GROUP
annotation
documentation
In diesem Element werden Produktgruppen gespeichert. Sie müssen denen des Basiskataloges entsprechen. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Polstermöbel mit Armlehne).


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEMS
annotation
documentation
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
In diesem Element werden alle Artikel einer Produktgruppe definiert.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_BASE_PRICE_REF ADDITIONAL_PRICE_GROUP
annotation
documentation
In diesem Element werden Artikel entsprechend des Basiskataloges gespeichert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
Dieses Element referenziert eine Basispreisgruppe des entsprechenden Basiskataloges. Eine Basispreisgruppe ist eine PRICE_FEATURE_GROUP (Pfad 1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisgruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade des Basiskataloges:
Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE_SALE_REFS
annotation
documentation
In diesem Element werden die zusätzlichen Artikelpreise und weitere Preisdaten hinterlegt.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
In diesem Element wird das Preisfeld für den Preis angegeben.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS >
diagram
properties
content complex
children PRICE_SALE_REF
annotation
documentation
Diesem Element sind die Angaben zu allen unter GLOBAL_DEFINITION/PRICE_SALES gepeicherten Preislistennamen zu entnehmen.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF >
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children PRICE PRICE_SALE_FACTOR PRICE_MINIMUM_BASIC VALID_FROM VALID_UNTIL
annotation
documentation
Hier erfolgen die Informationen zu einem unter GLOBAL_DEFINITION/PRICE_SALES entsprechend der Angabe von PRICE_NO gespeicherten Preislistennamen.


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/@PRICE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9 |
annotation
documentation
Dieses Attribut referenziert den Preislistennamen, der unter GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE definiert ist . Dabei sind folgende Werte für Preislisten festgelegt:

0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto
4 = Mitnahmepreis
5 = Abholpreis
6 = Lieferpreis
7 = Servicepreis inkl. Montage
8 = Auszeichnungspreis
9 = Aktionspreis 1
10=Aktionspreis 2

Die Preis-Rucksackdatei darf nur Preislisten ungleich des Basiskataloges enthalten.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE >
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Zahlen ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € entspricht -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE_SALE_FACTOR >
diagram
type restriction of xs:int
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -9999999 |
maxInclusive | 99999999 |
annotation
documentation
Statt eines Preises kann auch ein Faktor angegeben werden, über den bezogen auf den Preis im Basiskatalog der Zusatzpreis in dem entsprechenden Preislistennamen errechnet wird. Der Faktor ist mit 5 Nachkommastellen anzugeben.
Die Gültigkeit bei Angabe eines Aufpreises entspricht der der Originaldaten.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE_MINIMUM_BASIC >
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisfindung (Pfad1/PRICE_TYPE_REF des Basiskataloges) nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 ? = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisfindung (Pfad1/PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (Pfad2/BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Preislistennamen in Verbindung mit dem Artikelpreis (Pfad2/PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn der Preislsitenname (Pfad 1/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_FROM >
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, ab dem der Preis gültig ist.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_UNTIL >
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, bis zu welchem der Preis gültig ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Gültigkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_REF
annotation
documentation
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Bei der Zuweisung unterschiedlicher Preisfindungen für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel Mehrpreis
Stückpreis Stückpreis
längenabhängig längenabhängig
längenabhängig Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel Mehrpreis
Stückpreis längenabhängig


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF >
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
Dieses Element referenziert eine Mehrpreisgruppe des Basiskataloges. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE_SALE_REFS
annotation
documentation
In diesem Element wird die Artikelpreise hinterlegt.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
In diesem Element wird das Preisfeld für die Zusatzpreise angegeben.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_SALE_REFS >
diagram
properties
content complex
children PRICE_SALE_REF
annotation
documentation
Diesem Element sind die Angaben zu allen unter GLOBAL_DEFINITION/PRICE_SALES gepeicherten Preislistennamen zu entnehmen.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF >
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children PRICE PRICE_SALE_FACTOR
annotation
documentation
Hier erfolgen die Informationen zu einem unter GLOBAL_DEFINITION/PRICE_SALES entsprechend der Angabe von PRICE_NO gespeicherten Preislistennamen.


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/@PRICE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9 |
annotation
documentation
Dieses Attribut referenziert den Preislistennamen, der unter GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE definiert ist . Dabei sind folgende Werte für Preislisten festgelegt:

0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto
4 = Mitnahmepreis
5 = Abholpreis
6 = Lieferpreis
7 = Servicepreis inkl. Montage
8 = Auszeichnungspreis
9 = Aktionspreis 1
10=Aktionspreis 2

Die Preis-Rucksackdatei darf nur Preislisten ungleich des Basiskataloges enthalten.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE >
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden: -900)


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE_SALE_FACTOR >
diagram
type restriction of xs:int
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -9999999 |
maxInclusive | 99999999 |
annotation
documentation
Statt eines Preises kann auch ein Faktor angegeben werden, über den bezogen auf den Preis im Basiskatalog der Zusatzpreis in dem entsprechenden Preislistennamen errechnet wird. Der Faktor ist mit 5 Nachkommastellen anzugeben.
Die Gültigkeit bei Angabe eines Aufpreises entspricht der der Originaldaten.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PRICE_SALE_REF
annotation
documentation
Hier können zusätzliche Preise bezogen auf die Preisangaben des Basisikataloges per Faktor global für die Serie angegeben werden.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS/PRICE_SALE_REF
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children PRICE_SALE_FACTOR VALID_FROM VALID_UNTIL
annotation
documentation
In diesem Element erfolgen die Angaben zu einem des Identifikators PRICE_NO entsprechenden Preises.


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS/PRICE_SALE_REF/@PRICE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9 |
annotation
documentation
Dieses Attribut referenziert einen Preislistennamen entsprechend der Einträge im Attribut PRICE_SALE_NO unterhalb von PRICE_SALE.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE_SALE_FACTOR
diagram
type restriction of xs:int
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -9999999 |
maxInclusive | 99999999 |
annotation
documentation
Dieses Element enthält den Faktor, mit dem sich der Preis dieses Preislistennamens bezogen auf die Preise im Basiskatalog errechnet. Die Gültigkeit bei Angabe eines Aufpreises entspricht der der Originaldaten.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt den Gültigkeitsbeginn des zusätzlich angegeben Preises an.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Hier wird das Gültigkeitsende des Preises vermerkt.


 complexType languagetext
diagram
children LANGUAGE
used by
element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_INFO
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.


 complexType languagetext30
diagram
children LANGUAGE
used by
element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.


 complexType languagetext60
diagram
children LANGUAGE
used by
element T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE/PRICE_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.