 Introduction

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

ADD_PRICE_IDMP 3.0.1 XML schema

Documentation

Last revised 01/12/2021

Documented XML schema:

ADD_PRICE_IDMP_3_1_0.xsd

Contakt DCC e.V.

Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telephon 0 52 21/12 65-37

Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telephon 0 52 21/12 65-38


 Basic structure of the IDM schema

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] ADD_PRICE_IDMP 3.1.0 XML schema Documentation

Einleitung > Basic structure of the IDM schema

Einleitung > Grundstruktur des IDM-Schemas

Basic structure of the IDMP schema

The main element T_ADD_PRICE_CATALOG defines that a new, additional data record with additional prices is made available in addition to the base catalogue.

The IDM schema is subdivided in data ranges that are specified in the subsequent child-elements (see figure 1) in T_ADD_PRICE_CATALOG.

Figure 1 - child elements in T_ADD_PRICE_CATALOG

The data ranges are not used in isolation from each other. In some data ranges, data is initially created and used from other data ranges via referencing.

Additionally, many data ranges contain references to the associated base catalogue.

Description of the data ranges

CATALOG

CATALOG is used to store administrative information concerning the data pool. E.g. the version of the data format, release date or the unique identification of the data pool.

REF_CATALOG

Information on the base catalogue is specified in REF_CATALOG.

GLOBAL_DEFINITION

The GLOBAL_DEFINITION data range is a kind of data pool for information used in the other data ranges. In this case, the information on price types can be assigned additional prices within these data records.

SERIES

The additional prices for the items of the base catalogue are specified in SERIES. Items are combined into product groups, such as armchairs or intermediate elements.


 Data types

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] ADD_PRICE_IDMP 3.1.0 XML schema Documentation

Einleitung > Data types

Einleitung > Datentypen

Data types and value ranges

The IDM schema uses the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

It uses the following data types:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDMP, the data type date is used in conformity with the XML schemas as follows: YYYY-MM-DD Y = year, M = month, D = day
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDMP for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 or -45.98000 or +27.0.
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDMP for URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used in the IDMP for the mapping of valid language keys.language represents codes for natural languages Tags for the Identification of Languagesas defined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.
Additionally, there is also a user-defined data type:
operator | Thy data type is used for rules in the IDMP. This simple, self-defined data type defines an operator for comparisons. The comparison operator is a string of 1 to 4 characters length and may contain the following values:
 | eq (equal)
 | ne (not equal)
 | in (is contained in a quantity)
 | nin (is not contained in a quantity)
 | gt (greater)
 | lt (less)
 | ge (greater than or equal)
 | le (less than or equal)

The value ranges of the above data types are usually restricted for the elements in the IDMP. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters (pattern) and value lists.

In the documentation of the XML schema of the IDM, the value ranges are specified by the information coming after M and P.


 Notes to the documentation

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] ADD_PRICE_IDMP 3.1.0 XML schema Documentation

Einleitung > Notes to the documentation

Einleitung > Erläuterung zur Dokumentation

Notes to the IDMP documentation

Notes to the IDM documentation schema are stored in this section.

Explanation of the element properties

Each element is documented on the basis of a description and its properties. The following shows an example for an element description:

Description:

In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden.

D string
P [A-Z]{1,3}
M [1:3]

The element properties are documented on the right side. They have the following meaning:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.
D |  | The data type of the element is documented here. If this position is left blank, the element does not contain any reference data but additional child-elements.
P |  | The entries made in P and M document the value range of an element. A regular expression that defines the permitted values must be entered in P.
M |  | The minimum and maximum permitted values must be entered in M. In the case of a string data type, P defines the permitted characters and M the minimum and maximum character length. In the case of a numeric data type, the permitted minimum and maximum value is defined.


 Language key

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

ADD_PRICE_IDMP 3.1.0 XML schema Documentation

Einleitung > Language key

Einleitung > Sprachenschlüssel

Language key | Language name
AA | Afar
AB | Abkhazian
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AV | Avarisch
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CR | Cree
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundish
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothish
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VE | Tshivenda
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu

According to the ISO standard, the language keys are generally written with small letters. Capital letters are used for the IDM data.


 Country code

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Einleitung > Länderschlüssel

ADD_PRICE_IDMP 3.1.0 XML schema Documentation

Einleitung > Country code

country code | country
AC | Ascension
AD | Andorra
AE | United Arab Emirates
AF | Afghanistan
AG | Antigua and Barbuda
AI | Anguilla
AL | Albania
AM | Armenia
AN | Dutch Antilles
AO | Angola
AQ | Antarctica
AR | Argentina
AS | American Samoa
AT | Austria
AU | Australia
AW | Aruba
AX | Aland
AZ | Azerbaijan
BA | Bosnia and Herzegovina
BB | Barbados
BD | Bangladesh
BE | Belgium
BF | Burkina Faso
BG | Bulgaria
BH | Bahrain
BI | Burundi
BJ | Benin
BL | Saint-Barthélemy
BM | Bermuda
BN | Brunei Darussalam
BO | Bolivia
BQ | Bonaire, Sint Eustatius and Saba
BR | Brazil
BS | Bahamas
BT | Bhutan
BU | Burma
BV | Bouvet Island
BW | Botswana
BY | Belarus
BZ | Belize
CA | Canada
CC | Cocos) Islands
CD | Democratic Republic of the Congo
CF | Central African Republic
CG | Republic of the Congo
CH | Switzerland
CI | Ivory Coast
CK | Cook Islands
CL | Chile
CM | Cameroon
CN | China
CO | Columbia
CP | Clipperton
CR | Costa Rica
CU | Cuba
CV | Cape Verde
CW | Curaçao
CX | Christmas Island
CY | Cyprus
CZ | Czech Republic
DE | Germany
DG | Diego Garcia
DJ | Djibouti
DK | Denmark
DM | Dominica
DO | Dominican Republic
DZ | Algeria
EA | Ceuta, Melilla
EC | Ecuador
EE | Estonia
EG | Egypt
EH | Westsahara
EN | England
ER | Eritrea
ES | Spain
ET | Ethiopia
FI | Finland
FJ | Fiji
FK | Falklands
FM | Micronesia
FO | Faeroe Islands
FR | France
GA | Gabon
GB | England/Great Britain
GD | Grenada
GE | Georgia
GF | French Guiana
GG | Guernsey (Channel Island)
GH | Ghana
GI | Gibraltar
GL | Greenland
GM | Gambia
GN | Guinea
GP | Guadeloupe
GQ | Equatorial Guinea
GR | Greece
GS | South Georgia and the South Sandwich Islands
GT | Guatemala
GU | Guam
GW | Guinea-Bissau
GY | Guyana
HK | Hong Kong
HM | Heard and McDonald Islands
HN | Honduras
HR | Croatia
HT | Haiti
HU | Hungary
ID | Indonesian
IE | Ireland
IL | Israel
IM | Isle of Man
IN | India
IO | British Indian Ocean Territory
IQ | Iraq
IR | Islamic Republic of Iran
IS | Iceland
IT | Italy
JE | Channel Island of Jersey
JM | Jamaica
JO | Jordan
JP | Japan
KE | Kenya
KG | Kyrgyzstan
KH | Cambodia
KI | Kiribati
KM | Comoros
KN | Saint Kitts and Nevis
KP | Democratic People's Republic of Korea
KR | Republic of Korea
KW | Kuwait
KY | Cayman Islands
KZ | Kazakstan
LA | Laos
LB | Lebanon
LC | Saint Lucia
LI | Liechtenstein
LK | Sri Lanka
LR | Liberia
LS | Lesotho
LT | Lithuania
LU | Luxembourg
LV | Latvia
LY | Libya
MA | Morocco
MC | Monaco
MD | Moldavia
ME | Montenegro
MF | Saint Martin
MG | Madagascar
MH | Marshall Islands
MK | North Macedonia
ML | Mali
MM | Myanmar (Burma)
MN | Mongolia
MO | Macau
MP | Northern Mariana Islands
MQ | Martinique
MR | Mauritania
MS | Montserrat
MT | Malta
MU | Mauritius
MV | Maldives
MW | Malawi
MX | Mexico
MY | Malaysia
MZ | Mozambique
NA | Namibia
NC | New Caledonia
NE | Niger
NF | Norfolk Island
NG | Nigeria
NI | Nicaragua
NL | Netherlands
NO | Norway
NP | Nepal
NR | Nauru
NU | Niue
NZ | New Zealand
OM | Oman
PA | Panama
PE | Peru
PF | French Polynesia
PG | Papuan New Guinea
PH | Philippine
PK | Pakistan
PL | Poland
PM | St. Pierre and Miquelon
PN | Pitcairn Islands
PR | Puerto Rica
PS | Palestine
PT | Portugal
PW | Palau
PY | Paraguay
QA | Qatar
RE | Reunion
RO | Romania
RS | Serbia
RU | Russia
RW | Ruanda
SA | Saudi Arabia
SB | Solomon Islands
SC | Seychelles
SD | Sudan
SE | Sweden
SG | Singapore
SH | St. Helena
SI | Slovenia
SJ | Svalbard and Jan Mayen Islands
SK | Slovak Republic
SL | Sierra Leone
SM | San Marino
SN | Senegal
SO | Somalia
SR | Suriname
SS | South Sudan
ST | Democratic Republic of São Tomé and Príncipe
SV | El Salvador
SX | Sint Maarten
SY | Syrian Arab Republic
SZ | Swaziland
TC | Turks and Caicos Islands
TD | Chad
TF | French Southern and Antarctic Territories
TG | Togo
TH | Thailand
TJ | Tadschikistan
TK | Tokelau
TL | East Timor
TM | Turkmenistan
TN | Tunisia
TO | Tonga
TR | Turkey
TT | Trinidad and Tobago
TV | Tuvalu
TW | Taiwan
TZ | Tanzania
UA | Ukraine
UG | Uganda
UM | United States Minor Outlying Islands
US | United States of America
UY | Uruguay
UZ | Uzbekistan
VA | Vatican City
VC | Saint Vincent and the Grenadines
VE | Venezuela
VG | British Virgin Islands
VI | American Virgin Islands
VN | Vietnam
VU | Vanuatu
WF | Wallis and Futuna Islands
WS | Samoa
YE | Yemen
YT | Mayotte
ZA | South Africa
ZM | Sambia
ZW | Zimbabwe


 Schema ADD_PRICE_IDMP_3_1_0.xsd.EN.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\ADD_PRICE\Doku_Add_Price\ADD_PRICE_IDMP_3_1_0.xsd.EN.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
T_ADD_PRICE_CATALOG | languagetext
 | languagetext30
 | languagetext60


 element T_ADD_PRICE_CATALOG
diagram
properties
content complex
children CATALOG REF_CATALOG GLOBAL_DEFINITION SERIES
annotation
documentation
This element offers an entry point for additional pricing information with respect to a catalogue in IDMP format. This data can be created by the manufacturer of the IDMP data (for details on additional prices), as well as the dealer, the associations and similar parties who would like to transfer additional price information for the items.


 attribute T_ADD_PRICE_CATALOG/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 3 |
maxInclusive | 3 |
annotation
documentation
The version number "MAJOR" specifies the format version the data pool is delivered. The major version number will only change in the case of a fundamental revision of the entire format.
The complete information about the format version in which a data pool is delivered consists of MAJOR, MINOR and REVISION.


 attribute T_ADD_PRICE_CATALOG/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 1 |
annotation
documentation
The sub-version number "MINOR" usually changes every year. If the main version MAJOR is modified, the subversion is reset to 0.


 attribute T_ADD_PRICE_CATALOG/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 0 |
annotation
documentation
The revision number "REVISION" highlights changes during the year resultant from individual working groups. The revisions are not published if they are not concerned with necessary corrections. Revision is reset to 0 with each new MINOR sub-version number.


 element T_ADD_PRICE_CATALOG/CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CURRENCY_KEY CATALOG_LANGUAGE CATALOG_NAME FILE_ID CATALOG_DATA_VERSION CATALOG_INFO CATALOG_VERSION RECEIVER_ID PRICE_SALE_REFS ROUNDING_TYPE ROUNDING_SCALE
annotation
documentation
This element is used to store administrative information concerning the catalogue/data pool.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children GLN_NO CATALOG_ID FILE_RELEASE_DATE
annotation
documentation
This element is used to specify the catalogue's identifying characteristics.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data must be identical.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_IDENTIFICATION/GLN_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | (0-9){13} |
annotation
documentation
This element is used to enter a unique global location number (GLN). The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
The manufacturer must enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.
This ID is required for identification in the case of multi-manufacturer catalogues.

A manufacturer catalogue must always have the same ID for the same dealership.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_IDENTIFICATION/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
This element provides the time stamp for the creation of the data pool in UTC time.


 element T_ADD_PRICE_CATALOG/CATALOG/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
This element is used to specify the currency key for the prices stated in the data pool. For the currency keyISO currency ID is used.
Changing currencies within the same data pool are not permitted. Updates during the year must be delivered in the same currency as the base file.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_LANGUAGE
diagram
properties
content complex
children ISO_LANGUAGE_ID
annotation
documentation
This element indicates the languages used in the data pool.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_LANGUAGE/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_NAME
diagram
type | languagetext30
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to specify the catalogue name of the data pool. It serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.


 element languagetext30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetext30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_ADD_PRICE_CATALOG/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_DATA_VERSION
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element must be filled if the CATALOG_MARK element (catalogue identifier) contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates.


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_INFO
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element is used to store the information texts.


 element languagetext/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute languagetext/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
b Bold font
br line break


 element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_VERSION
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
The manufacturer of the data records can assign a version number for the catalogue in this field. If a new price adjustment data record is released for a base catalogue, the value in CATALOG_VERSION must be increased.


 element T_ADD_PRICE_CATALOG/CATALOG/RECEIVER_ID
diagram
type xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
The recipient ID is entered here.


 element T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PRICE_SALE_REF
annotation
documentation
In this field, additional prices related to the price data in the base catalogue can be specified with a global factor for the entire catalogue.


 element T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS/PRICE_SALE_REF
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children PRICE_SALE_FACTOR VALID_FROM VALID_UNTIL
annotation
documentation
This element is used to specify the details for a price related to the PRICE_NO identifier.


 attribute T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS/PRICE_SALE_REF/@PRICE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9 |
annotation
documentation
This attribute references a price list name in accordance with the values in the PRICE_SALE_NO attribute below PRICE_SALE.


 element T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE_SALE_FACTOR
diagram
type restriction of xs:int
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -9999999 |
maxInclusive | 99999999 |
annotation
documentation
This element contains the factor that is used to calculate the price of this price list name in relation to the prices in the basic catalogue. The validity with the specification of a surcharge corresponds to the original data.


 element T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element states the validity start date of the additionally specified price.


 element T_ADD_PRICE_CATALOG/CATALOG/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
The validity expiry date of the price is stated here.


 element T_ADD_PRICE_CATALOG/CATALOG/ROUNDING_TYPE
diagram
type restriction of xs:positiveInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
Rounding settings may be stated separately if a factor is provided.

This element specifies the type of rounding.
1 = rounding up
2 = rounding down
3 = commercial rounding


 element T_ADD_PRICE_CATALOG/CATALOG/ROUNDING_SCALE
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -3 |
maxInclusive | 2 |
annotation
documentation
Rounding settings may be stated separately if a factor is provided.

This element indicates how many digits to round to.
-3 = round to 1000s
-2 = round to 100s
-1 = round to 10s
0 = round to 1s
1 = round to 1 decimal place
2 = round to 2 decimal places


 element T_ADD_PRICE_CATALOG/REF_CATALOG
diagram
properties
content complex
annotation
documentation
This references the catalogue to which the additional prices relate via the manufacturer's GLN and the CATALOG_ID of the base catalogue.

The latest backpack file is always valid with the latest basic catalogue.


 attribute T_ADD_PRICE_CATALOG/REF_CATALOG/@SUPPLIER_GLN_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]{13} |
annotation
documentation
This element is used to enter a unique global location number (GLN) of the manufacturer of the base catalogue. The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.


 attribute T_ADD_PRICE_CATALOG/REF_CATALOG/@CATALOG_ID
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
The unique ID (e.g. GUID) of a manufacturer is entered here in order to provide a unique identification of the base catalogue. The value must be identical to the value of CATALOG_ID under CATALOG in the base catalogue.

A manufacturer catalogue must always have the same ID for the same dealership.


 element T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION
diagram
properties
content complex
children PRICE_SALES
annotation
documentation
This element is used to specify the additional price types for the data records (global information).


 element T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION/PRICE_SALES
diagram
properties
content complex
children PRICE_SALE
annotation
documentation
The price list names that are specified as additional prices to the base catalogue in this data record are defined here.


 element T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children PRICE_NAME
annotation
documentation
The data pertaining to a price list name are specified here.


 attribute T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE/@PRICE_SALE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 10 |
annotation
documentation
This attribute identifies the price list name. The following values are already pre-set for certain price lists in accordance with the element PURCHASE_RETAIL_ID:

0 = purchasing price including VAT (or list price)
1 = sales price including VAT (recommended sales price)
2 = purchasing price excluding VAT
3 = purchasing price excl. VAT/VAT
4 = cash-and-carry price
5 = self-collect price
6 = delivery price
7 = service price including assembly
8 = display price
9 = offer price 1
10= offer price 2

The price backpack file may only contain price lists that are not in the basic catalogue.


 element T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE/PRICE_NAME
diagram
type | languagetext60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Here a price name is provided if it is different from the defined values in attribute PRICE_SALE_NO.

Example:
PRICE_SALE_NO PRICE_NAME
9 = offer price 1 "End of season sale"


 element languagetext60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetext60/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext60/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,60} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 element T_ADD_PRICE_CATALOG/SERIES
diagram
properties
content complex
children SERIE
annotation
documentation
This element is used to specify all series of the catalogue/data and the elements assigned to them, e.g. product groups or items.

A series usually corresponds to a model.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 1000000
content | complex
children PRODUCT_GROUPS PRICE_SALE_REFS
annotation
documentation
This element is used to store a series together with the corresponding items. A series corresponds to a model. The numbers and designations stated here must correspond to those in the base catalogue.


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the serial number of the base catalogue.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
content complex
children PRODUCT_GROUP
annotation
documentation
This element if used to specify the product groups. They must correspond to those in the base catalogue.Product groups are used to combine articles with identical version types (e.g. upholstered furniture with armrests).


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEMS
annotation
documentation
This element is used to create modified items that are combined in product groups.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
This element is used to define all items of a product group.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_BASE_PRICE_REF ADDITIONAL_PRICE_GROUP
annotation
documentation
This element is used to specify items in accordance with the base catalogue. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.

Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to enter the item code/item type.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
This element is used to reference a base price group of the respective base catalogue. A base price group is a PRICE_FEATURE_GROUP (path 1) where the ADDITIONAL_PRICE element has a value of 0.

An item must reference precisely one base price group. Additional price groups are assigned via the ADDITIONAL_PRICE_GROUP element.

Element paths of the base catalogue:
Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute is used to reference a PRICE_FEATURE_GROUP.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE_SALE_REFS
annotation
documentation
This element is used to specify the additional item prices and additional price data.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This element is used to specify the price field for the price.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS >
diagram
properties
content complex
children PRICE_SALE_REF
annotation
documentation
The element contains the information on all price list names specified in GLOBAL_DEFINITION/PRICE_SALES.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF >
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children PRICE PRICE_SALE_FACTOR PRICE_MINIMUM_BASIC VALID_FROM VALID_UNTIL
annotation
documentation
This is used to store the information for a price list name stored under GLOBAL_DEFINITION/PRICE_SALES in accordance with the stated PRICE_NO.


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/@PRICE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9 |
annotation
documentation
This attribute references the price list name defined under GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE. The following values are set for price lists:

0 = purchasing price including VAT (or list price)
1 = sales price including VAT (recommended sales price)
2 = purchasing price excluding VAT
3 = purchasing price excl. VAT/VAT
4 = cash-and-carry price
5 = self-collect price
6 = delivery price
7 = service price including assembly
8 = display price
9 = offer price 1
10= offer price 2

The price backpack file may only contain price lists that are not in the basic catalogue.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE >
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
The prices according to their price groups (price field, element PRICE_FIELD) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: EUR -9.00 corresponds to -900)

If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_BASE_PRICE_REF of the item does not contain an element for the corresponding price group.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE_SALE_FACTOR >
diagram
type restriction of xs:int
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -9999999 |
maxInclusive | 99999999 |
annotation
documentation
Instead of a price, a factor may be specified and used to calculate the additional price of the corresponding price list name on the basis of the price in the basic catalogue. It is specified as a factor with five decimal places.
The validity with the specification of a surcharge corresponds to the original data.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE_MINIMUM_BASIC >
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
This element is used to enter minimum prices or base prices. The prices are entered in accordance with their price groups (price field, PRICE_FIELD).

If the price determination referenced by the item (Path1/PRICE_TYPE_REF of the basic catalogue) is not base price-dependent, the minimum price is entered, otherwise a base price. If a price of 0 is entered, the item does not have a minimum or base price, but is also not free of charge.

The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 ? = 30000 cents). Identification numbers are entered without decimal places. Settlement points are entered with exactly 2 decimal places (excluding the decimal point itself).

If an item within a price group is unavailable, no data record of the corresponding price group is specified.

The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price.
The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined by the price type (path1/PRICE_TYPE_REF). Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.

The effective item prices are calculated as follows:
The dimensions of the base price unit (path2/BASIC_PRICE_UNIT) must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions. To calculate the price for the infill dimensions, the logic from the price list name in conjunction with the item price (path2/PRICE) is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

This element must be specified for an item if the item's price list name (Path 1/PRICE_TYPE_REF) is base price-dependent.

Element paths:
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_EF/ITEM_PRICE


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_FROM >
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to specify the date from which date onwards the price is valid.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_UNTIL >
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element specifies the date until which the price is valid. If the date element is left blank, the validity is indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_REF
annotation
documentation
This element is used to reference PRICE_FEATURE_GROUPS with additional price groups. The base price group that must be referenced precisely 1x by an item is specified in the PRICE_FEATURE_GROUP_BASE_PRICE_REF element.

The following combinations are permitted when assigning different price determinations to items and surcharges for the same item:

Item Surcharge
Unit price Unit price
length-dependent length-dependent
length-dependent Unit price

The following combination is not permitted:

Item Surcharge
Unit price length-dependent


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF >
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
This element is used to reference a surcharge group of the base catalogue. Surcharge groups referenced here must not be used as design ranges.


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute is used to reference a PRICE_FEATURE_GROUP.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE_SALE_REFS
annotation
documentation
This element is used to specify the item prices.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This element is used to specify the price field for the additional prices.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_SALE_REFS >
diagram
properties
content complex
children PRICE_SALE_REF
annotation
documentation
The element contains the information on all price list names specified in GLOBAL_DEFINITION/PRICE_SALES.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF >
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children PRICE PRICE_SALE_FACTOR
annotation
documentation
This is used to store the information for a price list name stored under GLOBAL_DEFINITION/PRICE_SALES in accordance with the stated PRICE_NO.


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/@PRICE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9 |
annotation
documentation
This attribute references the price list name defined under GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE. The following values are set for price lists:

0 = purchasing price including VAT (or list price)
1 = sales price including VAT (recommended sales price)
2 = purchasing price excluding VAT
3 = purchasing price excl. VAT/VAT
4 = cash-and-carry price
5 = self-collect price
6 = delivery price
7 = service price including assembly
8 = display price
9 = offer price 1
10= offer price 2

The price backpack file may only contain price lists that are not in the basic catalogue.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE >
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.

(Example: field with 9 digits. The value of minus EUR 9.00 is entered as -900)


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE_SALE_FACTOR >
diagram
type restriction of xs:int
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -9999999 |
maxInclusive | 99999999 |
annotation
documentation
Instead of a price, a factor may be specified and used to calculate the additional price of the corresponding price list name on the basis of the price in the basic catalogue. It is specified as a factor with five decimal places.
The validity with the specification of a surcharge corresponds to the original data.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PRICE_SALE_REF
annotation
documentation
In this field, additional prices related to the price data in the base catalogue can be specified with a global factor for the series.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS/PRICE_SALE_REF
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children PRICE_SALE_FACTOR VALID_FROM VALID_UNTIL
annotation
documentation
This element is used to specify the details for a price related to the PRICE_NO identifier.


 attribute T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS/PRICE_SALE_REF/@PRICE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9 |
annotation
documentation
This attribute references a price list name in accordance with the values in the PRICE_SALE_NO attribute below PRICE_SALE.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS/PRICE_SALE_REF/PRICE_SALE_FACTOR
diagram
type restriction of xs:int
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -9999999 |
maxInclusive | 99999999 |
annotation
documentation
This element contains the factor that is used to calculate the price of this price list name in relation to the prices in the basic catalogue. The validity with the specification of a surcharge corresponds to the original data.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element states the validity start date of the additionally specified price.


 element T_ADD_PRICE_CATALOG/SERIES/SERIE/PRICE_SALE_REFS/PRICE_SALE_REF/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
The validity expiry date of the price is stated here.


 complexType languagetext
diagram
children LANGUAGE
used by
element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_INFO
annotation
documentation
This data type is used to create multiple-language texts of any length.


 complexType languagetext30
diagram
children LANGUAGE
used by
element T_ADD_PRICE_CATALOG/CATALOG/CATALOG_NAME
annotation
documentation
This data type is used to create multiple-language texts with a maximum length of 30 characters.


 complexType languagetext60
diagram
children LANGUAGE
used by
element T_ADD_PRICE_CATALOG/GLOBAL_DEFINITION/PRICE_SALES/PRICE_SALE/PRICE_NAME
annotation
documentation
This data type is used to create multiple-language texts with a maximum length of 60 characters.