 Einleitung

Ansicht mit Navigationswerkzeuge

IDMP 3.1.0 XML-Schema

Dokumentation

Stand 22.11.2021

Dokumentiertes XML-Schema:

IDMP_3_1_0.xsd

Kontakt DCC e.V.

Geschäftsführer
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37

Verantwortliche IDM Arbeitskreise und Dokumentation
Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telefon 0 52 21/12 65-38


 Grundstruktur des IDM-Schemas

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Grundstruktur des IDM-Schemas

Das Hauptelement T_NEW_CATALOG definiert, dass ein neuer, vollständiger Katalogdatenbestand bereitgestellt wird.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_NEW_CATALOG abgebildet werden.

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Abbildung 1 - Child-Elemente von T_NEW_CATALOG

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

SUPPLIER

In SUPPLIER werden administrative Informationen zu dem Hersteller hinterlegt. Beispielsweise werden Kontaktdaten, EDI-Kommunikationsparameter oder das Herkunftsland des Herstellers angegeben.

GLOBAL_DEFINITION

Der Datenbereich GLOBAL_DEFINITION ist eine Art Datenpool für Informationen, die in den anderen Datenbereichen verwendet werden. Beispielsweise werden hier Medien wie Fotos und Montageanleitungen bzw, verschiedene Hinweise angelegt.

SERIES

In SERIES werden die Daten für die Beschreibung der Artikel hinterlegt. Dabei werden die Artikel in Produktgruppen wie beispielsweise Sessel oder Zwischenelemente gruppiert.

PART_LISTS

In PART_LISTS werden die Daten für die Beschreibung der dynamischen Stücklisten hinterlegt, wobei die Unterpositionen Regeln (DECISIONS) tragen können, die variantenabhängig bestimmen, in welcher anzahl die jeweilige Position in der Stückliste auftaucht.

FEATURE_DEFINITION

In FEATURE_DEFINITION werden Varianteninformationen hinterlegt. Beispielsweise werden Daten für Variantenfamilien (FEATURE_CLASS), Variantenarten (FEATURE), die zugehörigen Varianten (OPTIONS) oder Regeln (DECISIONS) angelegt.

PRICE_DEFINITION

In PRICE_DEFINITION werden Preisinformationen hinterlegt. Beispielsweise werden Daten für Preiseigenschaftsgruppen (PRICE_FEATURE_GROUP), Mehrwertsteuer (VALUE_ADDED_TAXES), Warengruppen (MERCHANDISE_GROUP) oder Preisarten (PRICE_TYPE) angelegt.


 Elemente der Katalogstruktur

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Elemente der Katalogstruktur

Elemente der Katalogstruktur anlegen

Serieninformationen anlegen

Serien werden in folgendem Element definiert:

T_NEW_CATALOG/SERIES/SERIE

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Alle Child-Elemente werden verwendet, um die Eigenschaften der Serien zu beschreiben. Varianten werden Serien über Prüfverfahren (RESTRICTION_REF) zugeordnet.

Varianten anlegen

Beispiel: Anlegen von Varianten

1. Definition der Varianteneigenschaften/ Variantenausprägungen

Die Varianteneigenschaften werden im folgenden Element definiert:

FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

</OPTION_DEFINITION>

In diesem Element werden die Ausprägungen von Farben, Materialien, Formvarianten und Maßen definiert.

2. Erstellen der Varianten

Die Varianten werden in folgendem Element erstellt:

FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_KEY="L"

</OPTION>

<OPTION OPTION_KEY="S"

</OPTION>

</OPTIONS>

</FEATURE>

Variantenarten werden über Variantenartennummern z. B. 1 definiert. Die Variante wird über die Kombination von FEATURE_NO in FEATURE_DEFINITION/FEATURES/FEATURE und OPTION_KEY in FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION eindeutig identifiziert.

Artikelinformationen anlegen

Artikelinformationen werden im folgenden Element angelegt:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Das Element ITEM besitzt eine Vielzahl von Elementen mit denen die Eigenschaften von Artikeln beschrieben werden können. Die Identifizierung eines Artikels erfolgt über das Attribut TYPE_NO.

Hierbei ist jedoch zu beachten, dass ein Artikel in Abhängigkeit der Serie unterschiedliche Eigenschaften haben kann. Demzufolge wird ein Artikel mit seinen Eigenschaften nur eindeutig in Verbindung mit der Serie identifiziert.

Serienspezifische Artikelinformationen

Artikel können in Anhängigkeit der Serie unterschiedliche Eigenschaften haben. Artikel sind einer Serie automatisch zugeordnet, da das Elemente ITEM ein Kind-Element des Elementes SERIE ist.

Varianteninformationen anlegen

Varianteninformationen werden im IDM-Schema wie nachfolgend beschrieben angelegt:

- Anlegen der Ausprägungen für die Varianten

- Zuordnen von Ausprägung und Variantenart

Anlegen der Ausprägungen

Die Ausprägungen für die Varianten werden als Datenpool in dem Element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert.

Abbildung 2 – Das Element OPTION_DEFINITION

Das Element OPTION_DEFINITION enthält Elemente, in denen die jeweiligen Ausprägungen angelegt werden:

MATERIAL | In diesem Element werden die Eigenschaften von Materialien mittels Farben und Texturen definiert. Diese Elemente werden aus Ausführungsvariantenarten referenziert.
OPTION_MEASURE | In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Sitzhöhe(Variantenart 35).

Beispiel: Ausprägungen für Farben

<OPTION_DEFINITION>

<MATERIAL>

<COLOR COLOR_NO="1">

<RGB_RED>255</RGB_RED>

<RGB_GREEN>0</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="2">

<RGB_RED>133</RGB_RED>

<RGB_GREEN>273</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="3">

<RGB_RED>0</RGB_RED>

<RGB_GREEN>89</RGB_GREEN>

<RGB_BLUE>89</RGB_BLUE>

</COLOR>

</MATERIAL>

</OPTION_DEFINITION>

Die obigen Elemente definieren drei Farben, die über die Nummern (COLOR_NO) 1-3 identifiziert werden.

Zuordnen von Ausprägung und Variantenart

Die beispielartig definierten Farben müssen, um sie nutzen zu können, Variantenarten zugeordnet werden, wodurch Varianten entstehen.

Die Zuordnung von Variantenarten (FEATURE) und Ausprägungen (OPTION) zu Varianten erfolgt im Element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE. Eine Variante wird durch die Kombination von FEATURE und OPTION gebildet und identifiziert. Die nachfolgenden XML-Elemente definieren 2 Fußhöhen (Variantenart 15).

Beispiel: Aufbau der Varianten aus Variantenart und Ausprägungen

<FEATURE FEATURE_NO="15">

<OPTIONS>

<OPTION OPTION_KEY="10">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

<OPTION OPTION_KEY="30">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

</OPTIONS>

<FEATURE_TEXT>

</FEATURE_TEXT>

<HEADER_POS_VARIATION_TYPE>K</HEADER_POS_VARIATION_TYPE>

</FEATURE>

Die Child-Elemente von FEATURE beschreiben die Eigenschaften der Variantenart und die Child-Elemente von OPTION beschreiben die Eigenschaften der Variante. Entsprechend diesem Prinzip, welches grundlegend für alle Elemente im IDM-Schema gilt, wird durch das Element OPTION_TEXT ein Text definiert, der die Variante bezeichnet. Das Element FEATURE_TEXT definiert einen Text, der die Variantenart bezeichnet.

Soll in den Daten eine Variante referenziert werden, muss immer die Kombination aus FEATURE_NO und OPTION_KEY als Referenzierungschlüssel angegeben werden.

Soll in den Daten eine Variante referenziert werden, muss immer die Kombination aus FEATURE_NO und OPTION_KEY als Referenzierungsschlüssel angegeben werden.

Soll in den Daten eine Variante referenziert werden, muss immer die Kombination aus FEATURE_NO und OPTION_KEY als Referenzierungschlüssel angegeben werden.Soll in den Daten eine Variante referenziert werden, muss immer die Kombination aus FEATURE_NO und OPTION_KEY als Referenzierungschlüssel angegeben werden.


 Aufbauen der Katalogstruktur

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Aufbauen der Katalogstruktur

Aufbauen der Katalogstruktur

Varianten Serien zuordnen

Varianten werden allen Serien in folgendem Element zugeordnet:

SERIES/DECISIONS/DECISION_REF

Die Variante wird der Serie zugeordnet, in dem eine Regel referenziert wird, welches die Variante als gültige Kombination definiert in dem Element SERIES/SERIE/DECISIONS/DECISION_REF.

Artikel, Serien und Varianten zuordnen

Artikel-Serien Zuordnung

Artikel werden Serien automatisch zugeordnet, da das Element ITEM ein Kind-Element des Elementes SERIES ist:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Es können Artikelspezifisch Regeln über SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISIONS_REF formuliert werden.

Beispiel: Regel zur Varianten-Zuordnung

Element: FEATURE_DEFINITION/DECISIONS/DECISION

<DECISIONS>
 <DECISIONVALIDATION_TYPE="0"DECISION_NO="1">
 <DECISION_NAME_TEXT>
 <LANGUAGEISO_LANGUAGE_ID="EN">
 <TEXT_LINESEQUENCE_NO="1">
 <TEXT>item numbers</TEXT>
 </TEXT_LINE>
 </LANGUAGE>
 </DECISION_NAME_TEXT>
 <OPTION_COMBINATIONSEQUENCE="1">
 <FEATURE_REFFEATURE_NO="1">
 <OPTION_REF_OPOPTION_KEY="1"OPERATOR="eq"/>
 </FEATURE_REF>
 <FEATURE_REFFEATURE_NO="201">
 <OPTION_REF_OPOPTION_KEY="0"OPERATOR="eq"/>
 </FEATURE_REF>
 <FEATURE_REFFEATURE_NO="202">
 <OPTION_REF_OPOPTION_KEY="00"OPERATOR="eq"/>
 </FEATURE_REF>
 <ACTIONS>
 <SET_FEATURE_FIXEDFEATURE_NO="204">
 <OPTION_REFOPTION_KEY="1000"/>
 </SET_FEATURE_FIXED>
 </ACTIONS>
 </OPTION_COMBINATION>
 </DECISION>
 </DECISIONS>


 Katalogstruktur

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Katalogstruktur

Katalog- und Elementstruktur

Die Katalogstruktur wird im IDM-Schema durch die folgende Elementhierarchie abgebildet:

Abbildung 1 – Elementhierarchie im IDM-Schema

In dem Element SERIE werden die Eigenschaften einer Serie definiert. Innerhalb der Serie werden Produktgruppen (PRODUCT_GROUPS) definiert, in denen Artikel (SERIE) mit gleichartigen Variantenarten zusammengefasst sind. Die Artikel sind einer Serie automatisch zugeordnet, da sie Kind-Elemente des Elementes SERIE sind. Über die Elemente DECISIONS werden serienübergreifend, einer Serie, einer Produktgruppe oder einem Artikel Varianten über Regeln zugeordnet. Zusätzlich ist es möglich, den über DECISIONS formulierten Regeln Aktionen (ACTIONS) zuzuordnen.


 Referenzierung

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Referenzierung

Referenzierung von Elementen

Im IDM-Schema werden Beziehungen zwischen Elementen aufgebaut und Informationen an zentraler Stelle definiert und an anderer Stelle mehrfach verwendet. Die Wiederverwendung der Informationen und der Aufbau von Elementbeziehungen erfolgt über Referenzierung. Die im IDM-Schema angewendete Art der Referenzierung wird nachfolgend beschrieben.

Begriffsdefinition

Im IDM-Schema werden für die Referenzierung von Elementen folgende Begriffe verwendet:

Key-Element | Ein XML-Element, welches von anderen Elementen referenziert wird.
Ref-Element | Ein XML-Element, welches andere Elemente referenziert.

Vorgang der Referenzierung

Das Key-Element besitzt Attribute, über die es eindeutig identifiziert wird. Das Ref-Element besitzt minimal die Key-Attribute des Key-Elementes. Zwischen den Elementen wird die Referenz aufgebaut, in dem die Attributwerte des Ref-Elementes denen des Key-Elementes entsprechen.

Beispiel: Referenzierung der Serie aus dem Artikel

Das nachfolgende Beispiel zeigt, wie aus von einem Artikel ( ITEM ) eine Serie ( SERIE ) referenziert wird. Die XML-Elemente sind nur auszugsweise dargestellt.

Key-Element

T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS

<DECISIONS>                                                                                                                        <DECISION DECISION_NO="1"/>
… </DECISION>                                                                   <DECISION DECISION_NO="2"/>
… </DECISION>                                                                   <DECISION DECISION_NO="3"/>
… </DECISION>                                                                    . . .
</DECISIONS>

Ref-Element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS> <ITEM TYPE_NO="1111"> <DECISIONS> <DECISION_REF DECISION_NO="1" > … </DECISION_REF> . . . </ITEMS>

Beispiel: Referenzierung einer Varianten

Im folgenden Beispiel wird eine Variante aus einem Prüfverfahren heraus referenziert.

Key-Element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>                                                                                                                          <FEATURE FEATURE_NO="15">
<!-- Fußhöhe -->                                                                               <OPTIONS>                                                                                                                                      <OPTION OPTION_KEY="100"> … </OPTION>                                                                        <OPTION OPTION_KEY="120">
… </OPTION>                                                                            <OPTION OPTION_KEY="30"> … </OPTION>                                                                  </OPTIONS>                                                                                                          </FEATURE>                                                                                                              <FEATURE FEATURE_NO="17">
<!-- Fußform -->                                                                         <OPTIONS>                                                                                                                                      <OPTION OPTION_KEY="F00">
… </OPTION>                                                                        <OPTION OPTION_KEY="F3Z">
… </OPTION>                                                                        <OPTION OPTION_KEY="F70"> … </OPTION>                                                            </OPTIONS>                                                                                                              </FEATURE>
</FEATURES>

Die XML-Elemente definieren für die Variantenart 15 (FEATURE) drei Varianten (OPTION) mit den Schlüsseln 100,120,30 sowie für die Variantenart 17 drei Varianten mit den Schlüsseln F00, F3Z, F70. Eine Variante wird identifiziert über die Kombination FEATURE_NO und OPTION_KEY.


 Prüfverfahren

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Prüfverfahren

Definition und Zuordnung von Regeln

Die früheren Prüfungen (RESTRICTIONS) werden jetzt vollständig durch Regeln (DECISIONS) ersetzt.

Eine Zuordnung der Regeln/Prüfverfahren zu Serien oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien oder Artikeln referenziert werden.

Regeln, die von Artikeln referenziert werden, haben Vorrang gegenüber den Regeln, die von Serien referenziert werden.

Bei den DECISIONS findet man 3 Typen von Regeln (über die TEST_ID gekennzeichnet).

Abhängig von dem Element TEST_ID können unterschiedliche Regeln formuliert werden.

Ist der Wert von TEST_ID 1, handelt es sich um eine Erstellungsregel (Preparation Rule).

Hierüber können nun Mengen von gültigen Varianten in OPTION_COMBINATION definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

Die Bedingungen wurden um Operatoren ergänzt. Hierfür wurde ein extra Datentyp definiert. Dieser kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Die einzelnen OPTION_COMBINATIONs sind allerdings als ELSE Zweige zu betrachten. Das heißt, sobald eine Bedingungszeile (OPTION_COMBINATIONS) einen Treffer bekommen hat, werden die anderen nicht mehr durchlaufen.

Ist der Wert von TEST_ID 2, handelt es sich um eine Aktionsregel (Action Rule). Hier können zusätzlich zu den Bedingungen noch Aktionen definiert werden.

Wenn alle Bedingungen innerhalb einer „OPTION_COMBINATION“ erfüllt sind, dann werden alle zugeordneten Aktionen (ACTIONS) ausgeführt, die abhängig von Bedingungen Werte setzen oder auch Variantenarten (FEATURES) ausblenden können. Ist eine OPTION_COMBINATION erfüllt, werden auch hier die anderen Bedingungen nicht mehr durchlaufen.

Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

· Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

o   Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

o   das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

o   das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

· Das Setzen von Defaultvarianten (SET_FEATURE_DEFAULT):
Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

· Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

Action Rules werden im Konfigurator meistens genutzt, wenn sich ein Optionswert (eine Variante) ändert. So kann z.B. dann, wenn sich die Fußvariante von Edelstahl auf Holz ändert, eine Variantenart für den Beizton angezeigt werden.


 Datentypen

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

Es werden folgende Datentypen genutzt:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDMP wird der Datentyp date XML-Schema konform in folgender Weise angewendet:
 | YYYY-MM-DD
 | Y = Jahr, M = Monat, D = Tag
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDMP für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDMP für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDMP für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.
Zusätzlich gibt es einen benutzerdefinierten Datentyp
operator | Der Datentyp wird im IDMP für Regeln genutzt. Mit diesem einfachen selbst definierten Datentyp wird ein Operator für Vergleiche formuliert. Der Vergleichsoperator stellt sich als string der Länge 1 bis 4 dar und kann der folgende Werte enthalten:
 | eq (ist gleich)
 | ne (ist nicht gleich)
 | in (ist enthalten in einer Menge)
 | nin (ist nicht enthalten in der Menge)
 | gt (größer)
 | lt (kleiner)
 | ge (größer gleich)
 | le (kleiner gleich)

Die Wertebereiche der obigen Datentypen sind im Allgemeinen für die Elemente im IDMP eingeschränkt. Über "restrictions" bei der Datentypdefinition sind Minimal- und Maximalwerte, zulässige Zeichen (pattern) sowie Wertlisten eingeschränkt.

In der Dokumentation zum XML-Schema des IDMP sind die Wertebereiche durch die Angabe hinter M und P spezifiziert.

Neben den hier genannten XML-Datentypen werden eigene Datentypen für die Texte definiert.

Sie sind am Ende der Dokumentation erklärt.

Siehe auch

languagetexte Complex Type

languagetexte30 Complex Type

languagetexte40 Complex Type

languagetexte60 Complex Type

languagetexte60999 Complex Type


 Erläuterungen zur Dokumentation

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Erläuterungen zur Dokumentation

Erläuterungen zur Dokumentation des IDM

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

Beschreibung:

In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.

Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden.

D string

P [A-Z]{1,3}

M [1:3]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


 Variantenarten

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Variantenarten

Variantenarten

Folgende Variantenarten wurden definiert:

Ab 213 bis 999 stehen freie Variantenarten zur Verfügung.

Typ: A = Ausführung F = Farbe P = Planung

Varianten Art | Varianten_Art_Text | Typ | Bemerkung / mögliche Ausprägungen
1 | Bezugsart | A |
2 | Hauptbezugsart | A |
3 | Hauptbezugsfarbe | F |
4 | Absatzbezugsausführung | A |
5 | Absatzbezugsfarbe | F |
6 | Rückenbezugsart | A |
7 | Rückenbezugsfarbe | F |
8 | Rückenbild | A | mit/ohne Kimme, mit/ohne Steppung etc.
9 | Sitzkissenausführung | A |
10 | Sitzkissenfarbe | F |
11 | Zierkissenausführung | A | lose, fest, rund, rechteckig, …
12 | Zierkissenfarbe | F |
13 | Kontrastfadenart / -ausführung | A |
14 | Kontrastfadenfarbe | F |
15 | Fußhöhe | A |
16 | Fußmaterial | A | Metall, Holz, Kunststoff, Buche, …
17 | Fußform | A | Kufe, Rehling, Einzelfuß, Rollen, Gleiter, …
18 | Fußfarbe | F |
19 | Holz- / Chatosenausführung | A |
20 | Holz- / Chatosenfarbe / -beizton | F |
21 | Behangausführung | A |
22 | Behangfarbe | F |
23 | Besatzausführung | A |
24 | Besatzfarbe | F |
25 | Seitentaschenausführung | A |
26 | Seitentaschenfarbe | F |
27 | Kederausführung | A |
28 | Kederfarbe | F |
29 | Drellausführung | A |
30 | Drellfarbe | F |
31 | Reissverschlussausführung | A |
32 | Reissverschlussfarbe | F |
33 | Sitzhärte, - qualität | A | mit /ohne Federkern, …
34 | Antriebsart | A | Schlaufe, manuell, Gasdruckfeder, Motor Netz, Motor Accu, Do
35 | Sitzhöhe | A |
36 | Sitztiefe | A |
37 | Sitzbreite | A |
38 | Rückenhöhe | A |
39 | Rückenkissenhöhe | A |
40 | Rückenkissenausführung | A |
41 | Armlehnen- / Seitenteilanordnung | A | ohne, links, rechts, beidseitig, …
42 | Armlehnen- / Seitenteilausführung | A |
43 | Seitenteilverstellung | A |
44 | Kopfstützenausführung | A | lose, fest, Nackenstütze, …
45 | Kopfstützenfarbe | F |
46 | Vorderblendenausführung | A | bodeneben, bodenfrei
47 | Stoffkombination | K |
48 | Brand- / Flammschutz | A |
49 | Liegeflächenausführung | A |
50 | Liegeflächenfarbe | F |
51 | Länderausführung | A |
52 | Querschläfer | A |
53 | Sitzneigungsverstellung | A |
54 | Sitztiefenverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
55 | Rückenverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
56 | Fußstützenverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
57 | Massagefunktion | A |
58 | Sitzheizung | A |
59 | Lordose | A |
60 | Drehgestell | A |
61 | Aufstehhilfe | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
62 | Klapptisch | A |
63 | Stecktisch | A |
64 | Ausziehtisch | A |
65 | Getränkehalter | A |
66 | Kopfteil | A | Form 1, Form 2 usw., Kopfteilkürzung gegen Mehrpreis, ohne K
67 | Kopfteilbezug | A |
68 | Tagesdecke | A | kurz, halblang, lang, Haube
69 | Tagesdeckenbezug | A |
70 | Liegefläche | A | 160x200, 180x200, 200x200 usw., Sonderlänge gegen Mehrpreis
71 | Bettkasten | A | Standard, Einlegevorrichtung, Highline usw.
72 | Bettkastenbezug | A |
73 | Lattenrost | A | Standard oder Alternativen gegen Mehrpreis, ggf. Einlegelatten
74 | Matratze | A | Standard oder Alternativen gegen Mehrpreis >> Härtegrad H2,
75 | Griffe (bei Konsolen) | F |
76 | Konsolen | A | Schub mit Kunststoff oder Metallführung
77 | Lampenfarbe und -ausführung | A |
78 | Knopfbezug | F |
79 | Lattenrostverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, mehrfach …
80 | Funktion / Verstellung allgemein | A |
81 | freie Variantenart | F |
82 | freie Variantenart | F |
83 | freie Variantenart | F |
84 | freie Variantenart | F |
85 | freie Variantenart | F |
86 | freie Variantenart | F |
87 | freie Variantenart | F |
88 | freie Variantenart | F |
89 | Anschlusstyp L | P |
90 | Anschlusstyp R | P |
91 | freie Variantenart | F |
92 | freie Variantenart | F |
93 | freie Variantenart | F |
94 | freie Variantenart | F |
95 | Planungsbreite | P | Breite des Artikels
96 | Planungstiefe | P | Tiefe des Artikels
97 | Planungshöhe | P | Höhe des Artikels
98 | Antriebsposition | A |
99 | Tischfarbe | F |
100 | Kopfteilverstellung | A |
101 | Relaxfunktion | A |
102 | Vitalfunktion | A |
103 | Stromquelle/Motor | A |
104 | Zubehör | A |
105 | Auflagetisch | A |
106 | Rückenhalter | A |
107 | Steckrücken | A |
108 | Zwischentisch | A |
109 | Zeitschriftenablage | A |
110 | Schwenkfunktion | A |
111 | Leseleuchte | A |
112 | Decoartikel | A |
150 | freie Variantenart | F |
151 | freie Variantenart | F |
152 | freie Variantenart | F |
153 | freie Variantenart | F |
154 | freie Variantenart | F |
155 | freie Variantenart | F |
160 | Anschlusstyp Oben 1 | P | ID des Anschlussvektors in der SVG: AVO1
161 | Anschlusstyp Oben 2 | P | ID des Anschlussvektors in der SVG: AVO2
162 | Anschlusstyp Oben 3 | P | ID des Anschlussvektors in der SVG: AVO3
163 | Anschlusstyp Oben 4 | P | ID des Anschlussvektors in der SVG: AVO4
164 | Anschlusstyp Oben 5 | P | ID des Anschlussvektors in der SVG: AVO5
165 | Anschlusstyp Unten 1 | P | ID des Anschlussvektors in der SVG: AVU1
166 | Anschlusstyp Unten 2 | P | ID des Anschlussvektors in der SVG: AVU2
167 | Anschlusstyp Unten 3 | P | ID des Anschlussvektors in der SVG: AVU3
168 | Anschlusstyp Unten 4 | P | ID des Anschlussvektors in der SVG: AVU4
169 | Anschlusstyp Unten 5 | P | ID des Anschlussvektors in der SVG: AVU5
170 | Anschlusstyp Oben 6 | P | ID des Anschlussvektors in der SVG: AVO6
171 | Anschlusstyp Oben 7 | P | ID des Anschlussvektors in der SVG: AVO7
172 | Anschlusstyp Oben 8 | P | ID des Anschlussvektors in der SVG: AVO8
173 | Anschlusstyp Oben 9 | P | ID des Anschlussvektors in der SVG: AVO9
174 | Anschlusstyp Oben 10 | P | ID des Anschlussvektors in der SVG: AVO10
175 | Anschlusstyp Unten 6 | P | ID des Anschlussvektors in der SVG: AVU6
176 | Anschlusstyp Unten 7 | P | ID des Anschlussvektors in der SVG: AVU7
177 | Anschlusstyp Unten 8 | P | ID des Anschlussvektors in der SVG: AVU8
178 | Anschlusstyp Unten 9 | P | ID des Anschlussvektors in der SVG: AVU9
179 | Anschlusstyp Unten 10 | P | ID des Anschlussvektors in der SVG: AVU10
180 | Anschlusstyp Nord 1 | P | ID des Anschlussvektors in der SVG: AVN1
181 | Anschlusstyp Nord 2 | P | ID des Anschlussvektors in der SVG: AVN2
182 | Anschlusstyp Nord 3 | P | ID des Anschlussvektors in der SVG: AVN3
183 | Anschlusstyp Nord 4 | P | ID des Anschlussvektors in der SVG: AVN4
184 | Anschlusstyp Nord 5 | P | ID des Anschlussvektors in der SVG: AVN5
185 | Anschlusstyp Nord 6 | P | ID des Anschlussvektors in der SVG: AVN6
186 | Anschlusstyp Nord 7 | P | ID des Anschlussvektors in der SVG: AVN7
187 | Anschlusstyp Nord 8 | P | ID des Anschlussvektors in der SVG: AVN8
188 | Anschlusstyp Nord 9 | P | ID des Anschlussvektors in der SVG: AVN9
189 | Anschlusstyp Nord 10 | P | ID des Anschlussvektors in der SVG: AVN10
190 | Anschlusstyp Süd 1 | P | ID des Anschlussvektors in der SVG: AVS1
191 | Anschlusstyp Süd 2 | P | ID des Anschlussvektors in der SVG: AVS2
192 | Anschlusstyp Süd 3 | P | ID des Anschlussvektors in der SVG: AVS3
193 | Anschlusstyp Süd 4 | P | ID des Anschlussvektors in der SVG: AVS4
194 | Anschlusstyp Süd 5 | P | ID des Anschlussvektors in der SVG: AVS5
195 | Anschlusstyp Süd 6 | P | ID des Anschlussvektors in der SVG: AVS6
196 | Anschlusstyp Süd 7 | P | ID des Anschlussvektors in der SVG: AVS7
197 | Anschlusstyp Süd 8 | P | ID des Anschlussvektors in der SVG: AVS8
198 | Anschlusstyp Süd 9 | P | ID des Anschlussvektors in der SVG: AVS9
199 | Anschlusstyp Süd 10 | P | ID des Anschlussvektors in der SVG: AVS10
200 | freie Variantenart | F |
201 | freie Variantenart | F |
202 | freie Variantenart | F |
203 | freie Variantenart | F |
204 | freie Variantenart | F |
205 | freie Variantenart | F |
206 | freie Variantenart | F |
207 | freie Variantenart | F |
208 | freie Variantenart | F |
209 | freie Variantenart | F |
210 | freie Variantenart | F |
211 | Stoffbedarf | A | in laufenden m
212 | Lederbedarf | A | in m²


 Typenschlüssel

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Typenschlüssel

Typenschlüssel

Der Typenschlüssel wird in folgendem Element hinterlegt:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

Folgende Typenschlüssel wurden definiert:

Typ-Nr. | Bezeichnung (deutsch)
1 | Sessel / Hochlehnsessel
2 | Clubchair
3 | TV-Sessel / Ruhe- / Liege- / Relaxsessel
4 | Longchair
5 | Sofa / Canapé
6 | Zwischenelement
7 | Ecke / Trapezteil
8 | Einzelliege / Recamiere / Ottomane / Cheselon / Chaiselongue
9 | Hocker
10 | Kissen
11 | Couchtisch / Anstelltische / Stecktische ...
12 | Esstisch
13 | Kombinationen
14 | Abschlusselement
15 | Bettsofa / Bettcouch / Liegesofa / Schlafelement / Polsterliegen
16 | Sitzbank, Essplatzbank, Dinnersofa, ...
17 | Stühle
18 | Fußbank
19 | Kopfstütze
20 | Leuchten
21 | Teppiche
22 | Zubehör / Kleinteile
23 | Polsterbetten / Polsterbett-Systeme
24 | Polsterbettgestelle
25 | Metrage
26 | Sonstiges


 Sprachenschlüssel

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Niederländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu

Nach ISO-Norm werden die Sprachenschlüssel im Allgemeinen mit kleinen Buchstaben geschrieben. Für die IDM-Daten sind große Buchstaben beschlossen.


 Länderschlüssel

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Länderschlüssel

Länderkennzeichen | Ländername(deutsch) | Ländername(englisch)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


 Typen für Detailinformation

IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Typen für Detailinformation

Für die Beschreibung der Art der Detailinformation gibt es folgende Info-Typen:

1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Funktionsbeschreibung
16 = Planungshinweis
17 =
Katalogbild


 Schema IDMP_3_1_0.xsd.DE.xsd

schema location: | C:\Users\degenhard\Desktop\Doku IDMP\IDMP_3_1_0.xsd.DE.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types | Simple types
T_NEW_CATALOG | languagetext | measure_unit
 | languagetext30 | operator
 | languagetext40 |
 | languagetext60 |


 element T_NEW_CATALOG
diagram
properties
content complex
children CATALOG SUPPLIER GLOBAL_DEFINITION SERIES PART_LISTS FEATURE_DEFINITION PRICE_DEFINITION
annotation
documentation
In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.


 attribute T_NEW_CATALOG/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 3 |
maxInclusive | 3 |
annotation
documentation
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION.


 attribute T_NEW_CATALOG/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 1 |
annotation
documentation
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.


 attribute T_NEW_CATALOG/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 0 |
annotation
documentation
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.


 attribute T_NEW_CATALOG/@FORMAT
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [ABGKOPSWZ] |
annotation
documentation
In diesem Element wird das Kennzeichen für die Herstellerbranche angegeben. Derzeit sind folgende Branchenkennzeichen definiert:

A = Arbeitsplattenhersteller
B = Badmöbelhersteller
G = Gerätehersteller
K = Küchenmöbelhersteller
O = Büromöbelhersteller
P = Polstermöbelhersteller
S = Sanitärhersteller
W = Wohnmöbelhersteller
Z = Zubehörhersteller


 element T_NEW_CATALOG/CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CURRENCY_KEY CATALOG_LANGUAGE CATALOG_NAME DATA_VERSION VALID_FROM_DATE VALID_UNTIL_DATE FILE_ID CATALOG_MARK CATALOG_MERGE_TYPE CATALOG_DATA_VERSION CATALOG_INFO CATALOG_VERSION FALL_BACK_LANGUAGE DETAIL_INFOS
annotation
documentation
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children GLN_NO CATALOG_ID MAJOR_NO MINOR_NO FILE_RELEASE_DATE
annotation
documentation
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/GLN_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | (0-9){13} |
annotation
documentation
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MAJOR_NO
diagram
type restriction of xs:gYear
properties
content simple
annotation
documentation
Die Katalogversionsnummer MAJOR_NO gibt an in welchem Jahr der Datenbestand erstellt wurde. Die vollständige Angabe der Katalogversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MINOR_NO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Die Sub-Katalogversionsnummer MINOR_NO wird in unterjährig fortlaufenden Nummern angegeben. Die vollständige Angabe der Katalogversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR. Wird die Katalogversion MAJOR geändert, wird die Sub-Katalogversion auf 0 zurückgesetzt.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
In diesem Element soll der Zeitstempel für die Erstellung des Datenbestandes in der UTC Zeit angegeben werden.


 element T_NEW_CATALOG/CATALOG/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden.


 element T_NEW_CATALOG/CATALOG/CATALOG_LANGUAGE
diagram
properties
content complex
children ISO_LANGUAGE_ID
annotation
documentation
In diesem Element werden die im Datenbestand verwendeten Sprachen angegeben.


 element T_NEW_CATALOG/CATALOG/CATALOG_LANGUAGE/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen.


 element T_NEW_CATALOG/CATALOG/CATALOG_NAME
diagram
type | languagetext30
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.


 element languagetext30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetext30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_NEW_CATALOG/CATALOG/DATA_VERSION
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden.


 element T_NEW_CATALOG/CATALOG/VALID_FROM_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben.


 element T_NEW_CATALOG/CATALOG/VALID_UNTIL_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben.


 element T_NEW_CATALOG/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten


 element T_NEW_CATALOG/CATALOG/CATALOG_MARK
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [BKVF] |
annotation
documentation
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt.


 element T_NEW_CATALOG/CATALOG/CATALOG_MERGE_TYPE
diagram
type xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element CATALOG_MERGE_TYPE ist optional und vom Datentyp boolean mit folgenden Werten:

0: entspricht dem Wert, wenn das Element nicht vorhanden ist und bedeutet, dieser Katalog muss nicht Bestandteil eines Multiherstellerkataloges sein.

1: Dieser Katalog ist immer Bestandteil eines Multiherstellerkataloges.


 element T_NEW_CATALOG/CATALOG/CATALOG_DATA_VERSION
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht.


 element T_NEW_CATALOG/CATALOG/CATALOG_INFO
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
In diesem Element werden die Informationstexte abgelegt.


 element languagetext/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute languagetext/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
b Fettdruck
br Zeilenumbruch


 element T_NEW_CATALOG/CATALOG/CATALOG_VERSION
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
Hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben.


 element T_NEW_CATALOG/CATALOG/FALL_BACK_LANGUAGE
diagram
type restriction of xs:language
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen. Die angegebene Fallbacksprache muss im Katalog enthalten sein.


 element T_NEW_CATALOG/CATALOG/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.


 element T_NEW_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Detailinformationen referenziert.


 attribute T_NEW_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.


 attribute T_NEW_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut ermöglicht eine selbstdefinierte Sortierreihnfolge der Detailinformationen.


 element T_NEW_CATALOG/SUPPLIER
diagram
properties
content complex
children ISO_COUNTRY_ID WEEE_NO CONTACT_PERSON CONTACT_SUPPLIER
annotation
documentation
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.


 element T_NEW_CATALOG/SUPPLIER/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben.


 element T_NEW_CATALOG/SUPPLIER/WEEE_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON
diagram
properties
minOcc | 1
maxOcc | 2
content | complex
children CONTACT_PERSON_NO CONTACT_ROLE CONTACT_NAME FIRST_NAME FORM_OF_ADDRESS DEPARTMENT TELEPHONE FAX EMAIL STREET ZIPCODE_STREET CITY ISO_COUNTRY_ID
annotation
documentation
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CONTACT_PERSON_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme)


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CONTACT_ROLE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 60 |
annotation
documentation
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher).


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CONTACT_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/FIRST_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/FORM_OF_ADDRESS
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/DEPARTMENT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/TELEPHONE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/FAX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
In diesem Element wird die E-Mail-Adresse angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CITY
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Sitz des Herstellers angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER
diagram
properties
content complex
children MANUFACTURER_NAME_1 MANUFACTURER_NAME_2 EMAIL INTERNET_ADDRESS STREET ZIPCODE_STREET CITY ISO_COUNTRY_ID ZIPCODE_POSTBOX POSTBOX TELEPHONE_SWITCHBOARD FAX_SWITCHBOARD
annotation
documentation
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_1
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird die 1. Zeile des Firmennamens angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_2
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/INTERNET_ADDRESS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de).


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/CITY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Sitz des Herstellers angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{0,10} |
annotation
documentation
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/TELEPHONE_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/FAX_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890.


 element T_NEW_CATALOG/GLOBAL_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFOS MESSAGES
annotation
documentation
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO
annotation
documentation
In diesem Element werden Detail-Informationen hinterlegt.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION INFO_TYPE EXTERNAL_NAME INTERNAL_NAME TOOL_TIP URL LAYER
annotation
documentation
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
Dieses Attribut identifiziert eine Detailinformation.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/CLASSIFICATION
diagram
type restriction of xs:string
properties
content simple
annotation
documentation
Dieses Element dient der Klassifizierung der Detailinformation.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INFO_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 17 |
annotation
documentation
Dieses Element beschreibt die Art der Detailinformation.
Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen.
Für Milieufotos (INFO_TYPE = 1) wird eine Bildgröße von 2048x2048px empfohlen.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
diagram
type | languagetext40
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.
Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.


 element languagetext40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetext40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,40} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält Text für einen Hinweis zum Link.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL
diagram
properties
content complex
children LANGUAGE
annotation
documentation
Dieses Element gibt die URL zur Detailinformation an. In mehrsprachigen Katalogen ist die URL nur einmalig in der angegebenen Fallbacksprache zu hinterlegen.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT HASH_VALUE
annotation
documentation
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/TEXT
diagram
type xs:anyURI
properties
content simple
annotation
documentation
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/HASH_VALUE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 32 |
maxLength | 32 |
annotation
documentation
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/LAYER
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children LAYER_TYPE DPI
annotation
documentation
Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.
Möglich ist dieses Element nur für SVG-Dateien.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/LAYER/LAYER_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-6]0 |
annotation
documentation
Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.
Innerhalb des Outline-Typs (OLT) einer SVG gilt:
Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
Für das Element gelten folgende Werte:
10 Teppich
20 Sofa/ Möbel/ Tisch (Default-Wert)
30 Kissen
40 Dekorkissen
50 Kopfstütze
60 Plate/ Überwurf


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/LAYER/DPI
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
enumeration | 72 |
enumeration | 96 |
annotation
documentation
In diesem Element wird die Punktdichte (dpi) der zum Datenbestand gehörenden SVG-Dateien angegeben. Diese beträgt bei den gängigen Zeichentools entweder 72 dpi (z.B. Adobe Illustrator) oder 96 dpi (z.B. Coral Draw).


 element T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MESSAGE
annotation
documentation
Dieses Element bietet die Möglichkeit der Bereitstellung von Warnungen und Informationen.
Unterhalb dieses Elementes werden die möglichen Warnungen und Hinweise mit dem entsprechenden Text, der Stufe und dem eindeutigen Identifikatorr gespeichert.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES/MESSAGE
diagram
properties
minOcc | 1
maxOcc | 99999
content | complex
children MESSAGE_TEXT
annotation
documentation
Dieses Element dient zur Speicherung einer Nachricht.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES/MESSAGE/@MESSAGE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
Mit diesen Attribut wird die Nachricht identifiziert.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES/MESSAGE/@LEVEL
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 1 |
annotation
documentation
Hier wird die Stufe der Nachricht angegeben:
0 Hinweis/ Information
1 Warnung


 element T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES/MESSAGE/MESSAGE_TEXT
diagram
type | languagetext
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird der Text der Nachricht abgelegt.


 element T_NEW_CATALOG/SERIES
diagram
properties
content complex
children SERIE DECISIONS SERIE_GROUPS
annotation
documentation
In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren Eigenschaften und zugeordneten Elementen wie beispielsweise Produktgruppen oder Artikeln hinterlegt.
Eine Serie entspricht im Allgemeinen einem Modell.


 element T_NEW_CATALOG/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 1000000
content | complex
children SERIES_TEXT PURCHASE_RETAIL_ID DECISIONS PRODUCT_GROUPS COLOR_CONSULTANCIES DETAIL_INFOS VALID_FROM VALID_UNTIL OPTIONAL_CONNECTION
annotation
documentation
In diesem Element werden die Serien definiert. Eine Serie entspricht im Allgemeinen einem Modell.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.


 attribute T_NEW_CATALOG/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
In diesem Attribut wird die Seriennummer der Serie definiert.


 attribute T_NEW_CATALOG/SERIES/SERIE/@SEQUENCE_NO
type xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Serien mit einer selbstdefinierten Sortierreihenfolge anzulegen.
Wird für eine Serie eine SEQUENCE_NO angegeben, muss für alle Serien eine SEQUENCE_NO angegeben werden.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT
diagram
properties
content complex
children SHORT_TEXT FULL_TEXT PLANNING_ADVICE
annotation
documentation
In diesem Element werden die serienspezifischen Texte definiert. Dies können bezeichnende Kurz-, beschreibende Lang- und Planungshinweistexte sein. Für jede Serie muss mindestens ein Serienkurztext angelegt werden.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/SHORT_TEXT
diagram
properties
content complex
children LANGUAGE
annotation
documentation
Dieses Element enthält einen die Serie bezeichnenden Kurztext.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/SHORT_TEXT/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE
diagram
properties
content complex
children TEXT
annotation
documentation
In diesem Element wird eine Textzeile hinterlegt.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/FULL_TEXT
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Im Volltext steht die komplette Beschreibung der Serie. Innerhalb des Textes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden. Bilder dürfen nicht enthalten sein.
Dieses Element enthält den Volltext in einem CDATA - Knoten. Die Formatierung des Textes ist HTML konform anzugeben:
b Fettdruck
br Zeilenumbruch


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/PLANNING_ADVICE
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält Planungshinweise, die für die gesamte Serie gelten.


 element T_NEW_CATALOG/SERIES/SERIE/PURCHASE_RETAIL_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 3 |
annotation
documentation
Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:
EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.


 element T_NEW_CATALOG/SERIES/SERIE/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
In diesem Element werden Serien-spezifische Regeln gesammelt.


 element T_NEW_CATALOG/SERIES/SERIE/DECISIONS/DECISION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element referenziert eine der Serie zugeordnete Regel.


 attribute T_NEW_CATALOG/SERIES/SERIE/DECISIONS/DECISION_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird eine Regel referenziert.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
content complex
children PRODUCT_GROUP
annotation
documentation
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Polstermöbel mit Armlehne).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRODUCT_GROUP_TEXT FEATURE_CLASS_REF ITEMS DECISIONS
annotation
documentation
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/PRODUCT_GROUP_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält die Bezeichung einer Produktgruppe.


 element languagetext60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetext60/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext60/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,60} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/FEATURE_CLASS_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/FEATURE_CLASS_REF/@FEATURE_CLASS_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
In diesem Element werden alle Artikel einer Produktgruppe definiert.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF PRICE_FEATURE_GROUP_BASE_PRICE_REF PRICE_TYPE_REF ADDITIONAL_PRICE_GROUP MINIMUM_PRICE DECISIONS ADDITIONAL_ITEMS EDP_NUMBER EAN_NUMBER ITEM_IDENTIFICATION CATALOG_PAGE VALID_FROM VALID_UNTIL WEIGHT_BRUTTO WEIGHT_NETTO VOLUME MINIMUM_DELIVERY_TIME BASIC_PROFILE ITEM_TEXT TYPE_KEY CLASSIFICATIONS DETAIL_INFOS SALES_NUMBER PART_LIST_REF PART_LIST_EXCLUSIVE
annotation
documentation
In diesem Element werden Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Zu jedem Artikel werden entweder die Merkmale/Eigenschaften oder eine Referenzierung über ITEM_REF auf eine andere Serie (SERIE_NO) und die dort gültige Artikelnummer (TYPE_NO) gespeichert. Ist das Element ITEM_REF gefüllt, handelt es sich um einen Referenzartikel, der zu einer anderen Serie gehört, im anderen Fall gehört der Artikel zu dieser Serie in der er an dieser Stelle angegeben ist.
Bei der Bestellung eines Referenzartikels ist die Artikelnummer der referenzierten Serie und nicht die der Originalserie anzugeben.
Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben.


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@SEQUENCE_NO
type restriction of xs:positiveInteger
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.
Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_REF
diagram
properties
content complex
annotation
documentation
Dieses Element dient der Referenzierung eines Artikels, der bereits in einer anderen Serie erstellt und ausgeprägt wurde.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Dieses Attribut gibt die Artikelnummer des referenzierten Artikels an.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
Dieses Element referenziert eine Basispreisgruppe. Eine Basispreisgruppe ist eine PRICE_FEATURE_GROUP (Pfad 1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.
Einem Artikel muss genau eine Basispreisgruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE PRICE_MINIMUM_BASIC BASIC_PRICE_UNIT VALID_FROM VALID_UNTIL
annotation
documentation
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
In diesem Element wird das Preisfeld für den Preis angegeben.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE >
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Zahlen ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.
(Beispiel: -9,00 € entspricht -900)
Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC >
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.
Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.
Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 ? = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).
Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.
Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (Pfad1/PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.
Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (Pfad2/BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (Pfad2/PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.
Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (Pfad 1/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999999 |
annotation
documentation
Wenn eine Preisart (Pfad 1/PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.
Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/VALID_FROM

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/VALID_FROM >
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_SINCE dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/VALID_UNTIL

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/VALID_UNTIL >
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF
diagram
properties
content complex
annotation
documentation
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF/@PRICE_TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF/@PRICE_TYPE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Über dieses Attribut wird eine Preisart identifiziert.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_REF PRICE_TYPE_REF
annotation
documentation
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel Mehrpreis
Stückpreis Stückpreis
längenabhängig längenabhängig
längenabhängig Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel: Mehrpreis:
Stückpreis längenabhängig


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF >
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/@PRICE_FEATURE_GROUP_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE
annotation
documentation
In diesem Element wird der Artikelpreis hinterlegt.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_FIELD

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
In diesem Element wird das Preisfeld für den Preis angegeben.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE >
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.
(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden: -900)


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF >
diagram
properties
content complex
annotation
documentation
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF/@PRICE_TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF/@PRICE_TYPE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Über dieses Attribut wird eine Preisart identifiziert.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MINIMUM_PRICE
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
Dieses Element gibt den Mindestpreis eines Artikels an.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
In diesem Element werden Artikel-spzezifische Regeln zusammengefasst.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISION_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISION_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element referenziert eine dem Artikel zugeordnete Regel.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISION_REF/@DECISION_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISION_REF/@DECISION_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird eine Regel referenziert.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTIONAL_ITEMS MANDATORY_ITEMS
annotation
documentation
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTIONAL_ITEM_GROUP
annotation
documentation
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP >
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children GROUP_TITLE ITEM_REF
annotation
documentation
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@SET_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@SET_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9 |
annotation
documentation
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist. Wird in einer Menge von optionalen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.
1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@MULTIPLE_CHOICE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@MULTIPLE_CHOICE >
type xs:boolean
properties
use required
annotation
documentation
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.
true = Mehrfachauswahl möglich.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/GROUP_TITLE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/GROUP_TITLE >
diagram
type | languagetext60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Dieses Element dient der Bezeichnung der Gruppe von optionalen Artikeln.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Artikelkurzcode eingegeben.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@OPTIONAL_QUANTITY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@OPTIONAL_QUANTITY >
type restriction of xs:nonNegativeInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar, für Pflichtartikel ist die Anzahl in der Planung bindend.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MANDATORY_ITEM_GROUP
annotation
documentation
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP >
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children ITEM_REF
annotation
documentation
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/@SET_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/@SET_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9 |
annotation
documentation
Je Artikel kann eine Menge von optionalen Zusatzartikeln und neun Mengen zwingender Zusatzartikel definiert werden.
Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden. Aus den Mengen von zwingenden Zusatzartikeln darf je Menge nur ein Artikel ausgewählt werden.
Wird in einer Menge von zwingenden Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.
1-9 = Status zur Definition der Mengen von zwingenden Zusatzartikeln.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element referenziert einen Artikel.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Artikelkurzcode eingegeben.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@MANDATORY_QUANTITY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@MANDATORY_QUANTITY >
type restriction of xs:nonNegativeInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EDP_NUMBER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EAN_NUMBER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_IDENTIFICATION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [K123] |
annotation
documentation
In diesem Element wird dem Artikel eine Kennung zugewiesen:

K = Katalogartikel
1 = Planungsvorschlag
2 = Vorzugskombi
3 = Vorzugskombi mit Preisfindung auf Einzelartikelebene

Für den Planungsvorschlag (1) gilt folgendes:
Die einzelnen Artikel können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

Für die Vorzugskombi mit Preisfindung auf Einzelartikelebene ergibt sich der Preis aus der Hauptposition und den Einzelartikeln.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CATALOG_PAGE
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 7 |
annotation
documentation
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör".


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/WEIGHT_BRUTTO
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
In dieses Element wird das Brutto-Gewicht des Artikels [100 g] angegeben, d.h. inklusive Verpackungsmaterial. (z. B. 50 = 5000 g).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/WEIGHT_NETTO
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
In dieses Element wird das Netto-Gewicht des Artikels [100 g] angegeben, d.h. exlusive Verpackungsmaterial. (z. B. 50 = 5000 g).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VOLUME
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
In dieses Element wird das Volumen [dm³] des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³)


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MINIMUM_DELIVERY_TIME
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CARCASE_BASIC_SHAPE ITEM_DIMENSIONAL_DRAWING
annotation
documentation
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE >
diagram
properties
content complex
children BASIC_PROFILE_SHAPE BASIC_SHAPE_PARAMETERS
annotation
documentation
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/@CARCASE_BASIC_SHAPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/@CARCASE_BASIC_SHAPE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-4][0-9]|5[0-2]|99[2-9] |
annotation
documentation
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden . Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe angegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt.
997 = Artikel für die weder Grundform, noch Echtgrafik, mitgeliefert werden.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden.
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
Für den Bereich Polster wird im Allgemeinen nur die Grundform 1 genutzt.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children OPTION_REF
annotation
documentation
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern angegeben werden.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/@BASIC_PROFILE_SHAPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/@BASIC_PROFILE_SHAPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [\S ]{1,5} |
annotation
documentation
In diesem Element wird die Nummer der Profilgrundform hinterlegt.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF >
diagram
properties
content complex
annotation
documentation
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
In diesem Attribut wird eine Variantenart angegeben.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS >
diagram
properties
content complex
children BASIC_SHAPE_PARAMETER
annotation
documentation
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Maßbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Fußform) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NAME

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NAME >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{1,13} |
annotation
documentation
In diesem Attribut wird der Parametername angegeben.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NOMINAL_VALUE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NOMINAL_VALUE >
type restriction of xs:decimal
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (von, bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_FROM

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_FROM >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_TO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_TO >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_STEP_SIZE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_STEP_SIZE >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING >
diagram
properties
content complex
children DOCUMENT_REFERENCE DIMENSIONAL_PARAMETERS
annotation
documentation
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/@ITEM_DIMENSIONAL_DRAWING_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/@ITEM_DIMENSIONAL_DRAWING_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DOCUMENT_REFERENCE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DOCUMENT_REFERENCE >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 240 |
annotation
documentation
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.
Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.
Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen).


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS >
diagram
properties
content complex
children DIMENSIONAL_PARAMETER
annotation
documentation
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.
Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.
Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.
Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.
Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm =&gt; Elementinhalt : 0027.3
Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NAME

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NAME >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{1,13} |
annotation
documentation
In diesem Attribut wird der Parametername angegeben.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NOMINAL_VALUE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NOMINAL_VALUE >
type restriction of xs:decimal
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_FROM

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_FROM >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Das Element beinhaltet das kleinste lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_TO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_TO >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_STEP_SIZE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_STEP_SIZE >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT
diagram
properties
content complex
children SHORT_TEXT FULL_TEXT PLANNING_ADVICE
annotation
documentation
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.
Der Kurztext darf aus drei Zeilen bestehen.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT >
diagram
properties
content complex
children LANGUAGE
annotation
documentation
Dieses Element enthält Kurztexte.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID >
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE >
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
children TEXT
annotation
documentation
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.
Das Element TEXT beinhaltet den Text.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT >
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.
Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:
b Fettdruck
br Zeilenumbruch


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE >
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält Planungshinweise.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY
diagram
properties
content complex
children TK_TYPE
annotation
documentation
In diesem Element wird der Typschlüssel eines Artikels definiert.
Die Werte der Typschlüssel werden in einer Tabelle der Einleitung, Abschnitt Typenschlüssel bereitgestellt.
Der Typschlüssel wird genau einmal pro Artikel angelegt.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
maxInclusive | 26 |
annotation
documentation
Hier wird ein Wert aus der Spalte Typ der Tabelle "Typschlüssel" der Einleitung eingetragen.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CLASSIFICATION
annotation
documentation
In diesem Element werden standardisierte Klassifikationen hinterlegt.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION_CODE VALID_FROM VALID_UNTIL
annotation
documentation
Dieses Element enthält die Merkmale eines Klassifikationsschemas.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
pattern | ([1-9]{1}|1[0]{2}) |
annotation
documentation
Dieses Attribut gibt das jeweilige Klassifikationsschema an. Zur Auswahl stehen die Werte der folgenden Liste:

ID Klassifikationsschema
1 eCl@ss
2 Verbandsklassifikation Begros
3 Verbandsklassifikation VME
4 Code Eco Mobilier
5 Ecosystem EEE
6 freies Klassifikationsschema
7 freies Klassifikationsschema
8 freies Klassifikationsschema
9 freies Klassifikationsschema
10 freies Klassifikationsschema

Ist das zu pflegende Schema in der Liste nicht aufgeführt ist eine ID ab 6 für freies Klassifikationsschema auszuwählen.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE >
diagram
type xs:string
properties
content simple
annotation
documentation
Dieses Element enthält den Code für die, dem ITEM zuzuordnende Kategorie des jeweiligen Klassifikationsschemas.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM >
diagram
type xs:date
properties
content simple
annotation
documentation
Dieses Element gibt das Datum an, ab wann die Klassifikationsangabe gültig ist.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL >
diagram
type xs:date
properties
content simple
annotation
documentation
Dieses Element gibt das Datum an, bis wann die Klassifikationsangabe gültig ist.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.
Die Zuordnung erfolgt über DETAIL_INFO_NO und DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.
Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.
Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DECISION_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DECISION_NO >
type restriction of xs:positiveInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Detailinformationen am Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SALES_NUMBER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In dieses Element muss, falls vorhanden, die Verkaufs-Nummer des Artikels eingetragen werden.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PART_LIST_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
Dieses Element referenziert eine im Artikel enthaltene Stückliste.
Der Artikel vererbt dabei seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleiche Variantenarten (FEATURES) tragen.
An den Unterpositionen kann es Regeln geben, die bestimmen, ob eine Unterposition dargestellt wird. Die Angabe der Unterposition erfolgt dann mit der entsprechenden Stückzahl.
Artikel, die nur als Unterposition zulässig sind, werden separat markiert (Element PARTS_LIST_EXCLUSIVE).
Handelt es sich bei dem Artikel um einen Katalogartikel (ITEM_IDENTIFICATION 'K'), können dem Artikel Preise zugeordnet werden. Der Gesamtpreis des Katalogartikels ergibt sich aus dem ihm zugeordneten Preis und den Preisen der Bestandteile der Stückliste.
Für den Planungsvorschlag (ITEM_IDENTIFICATION '1'), gilt folgendes:
Die einzelnen Artikel der Stückliste können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.
Die Vorzugskombi (ITEM_IDENTIFICATION '2') unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.
Für die Vorzugskombi mit Preisfindung auf Einzelartikelebene (ITEM_IDENTIFICATION '3') ergibt sich der Preis aus der Hauptposition und den Einzelartikeln.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PART_LIST_REF/@PART_LIST_KEY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PART_LIST_REF/@PART_LIST_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Attribut wird der Schlüssel der Stückliste angegeben.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PART_LIST_EXCLUSIVE
diagram
type restriction of xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element markiert, ob der Artikel nur als Unterposition einer Stückliste zulässig ist (Wert auf 1(true) gesetzt).
Der Wert 0 (false) hat die gleiche Bedeutung wie ein fehlender Wert.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
In diesem Element werden Produktgruppen-spzezifische Regeln zusammengefasst.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/DECISIONS/DECISION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element referenziert eine der Produktgruppe zugeordnete Regel.


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/DECISIONS/DECISION_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird eine Regel referenziert.


 element T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children COLOR_CONSULTANCY
annotation
documentation
In diesem Element werden Farbberatungen definiert.
Jede Farbberatung COLOR_CONSULTANCY enthält beliebig viele Referenzen auf Kombinationen von Detailinfos und Prüfungen FEATURE_DETAIL_INFO_REF, die durch SEQUENCE_NO sortiert sind. Die verwendeten Prüfungen müssen Farbvarianten enthalten.


 element T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FEATURE_DETAIL_INFO_REF
annotation
documentation
Über dieses Element können Regeln direkt den Bildlayern zugeordnet werden.
Die verwendeten Regeln müssen Farbvarianten enthalten.


 attribute T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY/@COLOR_CONSULTANCY_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
In diesem Attribut wird die Farbberatungsnummer definiert.


 element T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY/FEATURE_DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Über dieses Element kann genau eine Prüfung oder Regel direkt den Bildlayern zugeordnet werden.
Dabei muss eine Farbvariantenart in der Prüfung bzw. Regel enthalten sein. Die Zuordnung erfolgt über DETAIL_INFO_NO, SEQUENCE_NO und RESTRICTION_NO oder DECISION_NO. Es kann entweder eine Prüfung (RESTRICTION) oder Regel (DECISION) zugeordnet werden.


 attribute T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY/FEATURE_DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
Dieses Attribut referenziert eine Detailinformation.


 attribute T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY/FEATURE_DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut definiert die Reihenfolge der Farbberatung.


 attribute T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY/FEATURE_DETAIL_INFO_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Dieses Attribut referenziert eine Regel.


 element T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.


 element T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Detailinformationen referenziert.


 attribute T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.


 attribute T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Detailinformationen an der Serie mit einer selbstdefinierten Sortierreihenfolge anzulegen.


 element T_NEW_CATALOG/SERIES/SERIE/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, ab dem die Serie lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt.


 element T_NEW_CATALOG/SERIES/SERIE/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.


 element T_NEW_CATALOG/SERIES/SERIE/OPTIONAL_CONNECTION
diagram
type restriction of xs:boolean
properties
content | simple
default | 0
annotation
documentation
Dieses Element ermöglicht über die normalen Anstellmöglichkeiten hinaus weitere Anstellmöglichkeiten zu erlauben.
0 = keine zusätzlichen Anstellmöglichkeiten, nur Anstellmöglichkeiten wie in der 2D-Doku beschrieben
1 = zusätzliche Anstellmöglichkeiten AVN1-n an AVL und AVS1-n an AVR


 element T_NEW_CATALOG/SERIES/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
In diesem Element werden Serien-übergreifende Regeln gesammelt.


 element T_NEW_CATALOG/SERIES/DECISIONS/DECISION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element referenziert eine Serie-übergreifende Regel.


 attribute T_NEW_CATALOG/SERIES/DECISIONS/DECISION_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird eine Regel referenziert.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SERIE_GROUP
annotation
documentation
Dieses Element gibt die Möglichkeit verschiedene Serien in Gruppen (Modellgruppen) zusammenzufassen.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children SERIE_REF SERIE_GROUP_TEXT DETAIL_INFOS
annotation
documentation
Hier wird eine Modellgruppe (Gruppierung von mehreren Serien) definiert.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/@SERIE_GROUP_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Durch dieses Attribut werden Sereiengruppen/Modellgruppen eindeutig identifiziert.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Seriengruppen mit einer selbstdefinierten Sortierreihenfolge anzulegen.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/SERIE_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Mit diesem Element werden Serien referenziert.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/SERIE_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Mit diesem Attribut wird eine Serie referenziert.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/SERIE_REF/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
Dieses Attribut definiert die Reihenfolge der Serien innerhalb der Sereingruppe.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/SERIE_GROUP_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird die Bezeichnung ser Sereingruppe/Modellgruppe hinterlegt.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children DETAIL_INFO_REF
annotation
documentation
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Detailinformationen referenziert.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
Dieses Attribut referenziert eine Detailinformation.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Detailinformationen an der Serien-Gruppe mit einer selbstdefinierten Sortierreihenfolge anzulegen.


 element T_NEW_CATALOG/PART_LISTS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PART_LIST
annotation
documentation
Dieses Element dient dem Aufbau von dynamischen Stücklisten, wobei die Unterpositionen Regeln tragen können, die variantenabhängig bestimmen, in welcher Anzahl die jeweilige Position in der Stückliste vorhanden ist.
Es sind nur Artikel einer entsprechenden Serie oder Artikel der Serie 0 enthalten.
In Stücklisten können Artikel beliebiger Serien aufgenommen werden.
Der Artikel, der eine Stückliste enthält, vererbt seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleichen Variantenarten (FEATURES) tragen.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PART_LIST_POS
annotation
documentation
In diesem Element wird eine Stückliste definiert.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/@PART_LIST_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Stückliste referenziert.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/@INCLUDE_INORDER
type xs:boolean
properties
use | optional
default | 0
annotation
documentation
Dieses Attribut kann einer Stückliste zugeordnet werden. Der Wert true(1) bedeutet, die Stückliste wird als Position in eine Bestellung aufgenommen, der Wert false(0) heißt, sie steht nicht in der Bestellung, der Standard-Wert ist true.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children SEQUENCE_NO ITEM_REF DECISIONS POS_COUNT_VALUE DECISION_POS_COUNT POS_INVISIBILITY CONFIGURATION_MODE
annotation
documentation
Dieses Element dient der Beschreibung der einzelnen Stücklistenpositionen.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/@INCLUDE_INORDER
type xs:boolean
properties
use | optional
default | 0
annotation
documentation
Dieses Attribut kann jeder Position der Stückliste zugeordnet werden. Der Wert true(1) bedeutet, die Position in wird eine Bestellung aufgenommen, der Wert false(0) heißt, sie steht nicht in der Bestellung, der Standard-Wert ist true.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/SEQUENCE_NO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Stücklisten mit einer selbstdefinierten Sortierreihenfolge anzulegen.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/ITEM_REF
diagram
properties
content complex
annotation
documentation
Dieses Element dient der Referenzierung eines Artikels.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
In diesem Element werden Regeln für die entsprechende Stücklistenposition gesammelt. Es beeinflusst damit die für diese Position verfügbaren Varianten und Maße..
Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISIONS/DECISION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element referenziert eine der Stücklistenposition entsprechende Regel und beeinflusst damit die für diese Position verfügbaren Varianten und Maße. Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISIONS/DECISION_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird eine Regel referenziert.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/POS_COUNT_VALUE
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
Dieses Element gibt die Anzahl des Artikels in der Stückliste an.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISION_POS_COUNT
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
In diesem Element wird eine Regel angegeben, die den Mengenfaktor setzt. Es darf maximal eine davon pro Position geben. Diese Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISION_POS_COUNT/DECISION_REF
diagram
properties
content complex
annotation
documentation
Dieses Element referenziert eine Regel, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISION_POS_COUNT/DECISION_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird eine Regel referenziert, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/POS_INVISIBILITY
diagram
type restriction of xs:boolean
properties
content | simple
default | 0
annotation
documentation
Dieses Element steuert die Sichtbarkeit einer Position im Konfigurator. Die Unsichtbarkeit gilt aber nur für die entsprechende Position, nicht für einen eventuell vorhandenen Unterbaum. Das heißt, diese muss für so einen Fall an jeder Unterposition ausgeprägt werden.
0 = sichtbar komplett
1 = gar nicht sichtbar


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/CONFIGURATION_MODE
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
default | 0
facets
Kind | Value | Annotation
maxInclusive | 2 |
annotation
documentation
Für jedes Element PART_LIST_POS kann ein Wert CONFIGURATION_MODE angegeben werden:

0 = Konfiguration erlaubt für nicht geerbte Varianten
1 = komplett konfigurierbar
2 = Konfiguration nicht erlaubt

Der Standardwert ist 0.


 element T_NEW_CATALOG/FEATURE_DEFINITION
diagram
properties
content complex
children FEATURE_CLASSES FEATURES OPTION_DEFINITION DECISIONS OPTION_GROUPS FORMULAS
annotation
documentation
In diesem Element werden variantenabhängige Informationen hinterlegt.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES
diagram
properties
content complex
children FEATURE_CLASS
annotation
documentation
In diesem Element werden Variantenarten zu Familien zusammengefasst. Mittels dieser Variantenfamilien können Plausibilitäts- und Vollständigkeitsprüfungen bezüglich der gültigen Variantenarten durchgeführt werden.

Die definierten Variantenfamilien(Pfad 1) können Serien oder Produktgruppen über FEATURE_CLASS_REF in SERIE und PRODUCT_GROUP zugeordnet werden. Zwischen Variantenfamilien auf Serien- oder Artikelebene besteht keine Beziehung hinsichtlich einer Priorität. Die Anzahl der an einem Artikel gültigen Variantenarten ergibt sich aus der Summe der Variantenarten, die in der Produktgruppe des Artikels deklariert sind.

Alle Variantenarten, die über die Elemente in PRICE_FEATURE_GROUP (Pfad 3), PRICE_FEATURE_BASE_PRICE_GROUP_REF (Pfad 4), FINISH (Pfad 5) und PERCENTAGE_SURCHARGE (Pfad 5) referenziert werden, müssen in der Variantenfamilie des Artikels enthalten sein.

Ebenso müssen die über die Regeln (Elemente DECISION_REF (Pfad 6, 7 und 8)) verwendeten Variantenarten in der Variantenfamilie des Artikels enthalten sein.

Elementpfade
Pfad 1 : FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
Pfad 2 : FEATURE_DEFINITION/FEATURES
Pfad 3 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 4 : SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 6 : SERIES/DECISIONS/DECISION_REF
Pfad 7 : SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS
Pfad 8: SERIES/SERIE/DECISIONS


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FEATURE_REF
annotation
documentation
In diesem Element wird eine Variantenfamilie definiert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/@FEATURE_CLASS_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenfamilie identifiziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/FEATURE_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Kissens keine Variantenarten für z. B. Fußformen enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/FEATURE_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/FEATURE_REF/@INVISIBLE
type xs:boolean
annotation
documentation
Ist der Wert von diesem Attribut wahr (bzw. 1), wird angegeben dass die entsprechende Variantenart unsichtbar ist.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES
diagram
properties
content complex
children FEATURE
annotation
documentation
In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten definiert. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Für einige Variantenarten werden die Kombinationen aus Ausführung und Farbe verwendet.

Variantenarten müssen dann immer paarweise angelegt werden. Zu den entsprechenden Ausführungsvariantenarten existiert die zugehörige Farbvariantenart und zu der Farbvariantenart existiert eine zugehörige Ausführungsvariantenart.

Variantenarten, die als unsichtbare Variantenarten deklariert sind, dürfen nicht in einer Variantenfamilie referenziert werden.

Alle Variantenarten, im Element FEATURES (Pfad 3), die nicht als unsichtbare Kopfvariantenart deklariert sind, müssen mindestens in einer Variantenfamilie referenziert werden.

Weitere Erläuterungen zu den Variantenarten sind zu finden in der Einleitung im Abschnitt " Variantenarten"

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 3: FEATURE_DEFINITION


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTIONS FEATURE_TEXT SEQUENCE_NO HEADER_POS_VARIATION_TYPE FEATURE_TYPE DETAIL_INFOS
annotation
documentation
In diesem Element wird eine Variantart definiert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird die Variantenart identifiziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTION
annotation
documentation
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children MATERIAL_REF OPTION_MEASURE_REF OPTION_TEXT OPTION_COMMENT_TEXT VALID_FROM VALID_UNTIL DETAIL_INFOS OPTION_FREETEXT
annotation
documentation
In diesem Element werden die Varianten für die übergeordnete Variantenart definiert. Dabei werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Einleitung: Tabelle Variantenarten gekennzeichnet durch Typ A), dann dürfen keine Farbwerte angegeben werden.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/MATERIAL_REF
diagram
properties
content complex
annotation
documentation
Dieses Element referenziert ein Material.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/MATERIAL_REF/@MATERIAL_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
Mit diesem Attribut wird ein Material referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_MEASURE_REF
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_MEASURE_REF/@OPTION_MEASURE_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine Maßausprägung referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird ein Variantentext definiert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_COMMENT_TEXT
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
Dieses Element dient der Zuordnung von Medien. Es ist möglich einer Variante mehrere Detail-Informationen zuzuordnen, und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild nur in der entsprechenden Serie oder beim bestimmten Artikel angezeigt.
Die Referenzierung von Medien(Detailinformationen) an Varianten, die zusätzlich noch Angaben zu Serien bzw. Artikeln beinhalten kann, darf nur einmal pro Medium (Detailinformation) erfolgen, das bedeutet, werden mehrere Serien bzw. Artikel referenziert, müssen sie alle bei der einen Angabe der Detailinformation aufgelistet werden.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children SERIE_REF ITEM_REF
annotation
documentation
In diesem Element werden die Detailinformationen referenziert.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Detailinformationen an den Optionen mit einer selbstdefinierten Sortierreihenfolge anzulegen.


element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF

 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element wird die Serie referenziert.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF/@SERIE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben.


element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF

 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element dient der Referenzierung eines Artikels.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_FREETEXT
diagram
type restriction of xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält Texte für Variantenarten.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/SEQUENCE_NO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [IKP] |
annotation
documentation
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariantenart oder
P = Positions-Variantenart
ist.
Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.
Mit I gekennzeichnete Variantenarten sind sichtbar und ergeben sich implizit aus anderen Variantenarten.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE
diagram
properties
content complex
children MEASURE
annotation
documentation
Dieses Element dient der Kennzeichnung, welchem Variantentyp die Variantenart entspricht. Eine Varintenart kann Maßvarianten (Wert von FEATURE_T "M"), Farbvarianten (Wert von FEATURE_T "C") oder anderen Variantentypen (Wert von FEATURE_T "O") zugeordnet werden.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE/@FEATURE_T
type restriction of xs:string
facets
Kind | Value | Annotation
length | 1 |
pattern | [MCO] |
annotation
documentation
Mit diesem Attribut wird für der der Variantenart zugeordneten Varianten entsprechende Variantentyp definiert.
M = Maßvarianten
C = Farbvarianten
O = andere Varianten


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE/MEASURE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MEASURE_UNIT MEASURE_PARAMETER
annotation
documentation
Falls die der Variantenart zugeordneten Varianten Maßvarianten sind, werden in diesem Element die Maßinformationen eingetragen.
Diese bestehen aus einem Maßparameter und der Maßeinheit und können dann z. B. in Formeln der Regeln (DECISIONS) genutzt werden.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE/MEASURE/MEASURE_UNIT
diagram
type measure_unit
properties
content simple
facets
Kind | Value | Annotation
enumeration | MMT |
enumeration | CMT |
enumeration | DMT |
enumeration | MTR |
enumeration | KTM |
enumeration | INH |
enumeration | FOT |
enumeration | YRD |
enumeration | MMK |
enumeration | CMK |
enumeration | DMK |
enumeration | MTK |
enumeration | INK |
enumeration | FTK |
enumeration | YDK |
enumeration | MGM |
enumeration | GRM |
enumeration | KGM |
enumeration | TNE |
enumeration | LBR |
enumeration | MMQ |
enumeration | CMQ |
enumeration | DMQ |
enumeration | MTQ |
enumeration | INQ |
enumeration | FTQ |
enumeration | YDQ |
enumeration | HLT |
enumeration | LTR |
enumeration | MLT |
enumeration | H87 |
annotation
documentation
In diesem Element wird die Maßeinheit hinterlegt.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE/MEASURE/MEASURE_PARAMETER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
maxLength | 20 |
annotation
documentation
In diesem Element werden die Parameter hinterlegt, die der Definition einer Formel dienen, z. B. Planungsbreite =2*st + sb,
wobei st für Seitenteilbreite und sb für Sitzbreite als Parameter stehen.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
Dieses Element dient der Zuordnung von Medien. Es ist möglich einer Variantenart mehrere Detail-Informationen zuzuordnen, und jedes Bild der Variantenart kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild nur in der entsprechenden Serie oder beim bestimmten Artikel angezeigt.
Die Referenzierung von Medien(Detailinformationen) an Variantenarten, die zusätzlich noch Angaben zu Serien bzw. Artikeln beinhalten kann, darf nur einmal pro Medium (Detailinformation) erfolgen, das bedeutet, werden mehrere Serien bzw. Artikel referenziert, müssen sie alle bei der einen Angabe der Detailinformation aufgelistet werden.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children SERIE_REF ITEM_REF
annotation
documentation
In diesem Element werden die Detailinformationen referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Detailinformationen an den Features mit einer selbstdefinierten Sortierreihenfolge anzulegen.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element wird die Serie referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element dient der Referenzierung eines Artikels.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MATERIAL OPTION_MEASURE
annotation
documentation
In diesem Element werden die Ausprägungen von Farben, Materialien und Maßen definiert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children COLOR
annotation
documentation
In diesem Element wird ein Material definiert.
Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante ( gekennzeichnet durch A), dann dürfen keine Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/@MATERIAL_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
Mit diesem Attribut wird ein Material identifiziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR
diagram
properties
content complex
children RGB_RED RGB_GREEN RGB_BLUE
annotation
documentation
In diesem Element werden Farben definiert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR/RGB_RED
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 255 |
annotation
documentation
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für ein-farbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR/RGB_GREEN
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 255 |
annotation
documentation
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR/RGB_BLUE
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 255 |
annotation
documentation
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children MEASURE_VALUE MEASURE_UNIT
annotation
documentation
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Rücken-, Sitzkissenhöhe).


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/@OPTION_MEASURE_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine maßliche Ausprägung identifiziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/MEASURE_VALUE
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
In diesem Element wird das Maß angegeben.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/MEASURE_UNIT
diagram
type measure_unit
properties
content simple
facets
Kind | Value | Annotation
enumeration | MMT |
enumeration | CMT |
enumeration | DMT |
enumeration | MTR |
enumeration | KTM |
enumeration | INH |
enumeration | FOT |
enumeration | YRD |
enumeration | MMK |
enumeration | CMK |
enumeration | DMK |
enumeration | MTK |
enumeration | INK |
enumeration | FTK |
enumeration | YDK |
enumeration | MGM |
enumeration | GRM |
enumeration | KGM |
enumeration | TNE |
enumeration | LBR |
enumeration | MMQ |
enumeration | CMQ |
enumeration | DMQ |
enumeration | MTQ |
enumeration | INQ |
enumeration | FTQ |
enumeration | YDQ |
enumeration | HLT |
enumeration | LTR |
enumeration | MLT |
enumeration | H87 |
annotation
documentation
In diesem Element wird die Maßeinheit hinterlegt.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION
annotation
documentation
In diesem Element werden Regeln für Varianten und Variantenarten formuliert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION
diagram
properties
minOcc | 1
maxOcc | 99999
content | complex
children DECISION_NAME_TEXT OPTION_COMBINATION VALID_FROM VALID_UNTIL FEATURE_REF PRIO
annotation
documentation
In diesem Element wird eine Regel definiert und beschrieben, die technisch machbare Konfigurationen abbildet.
Eine Zuordnung der Regeln zu Serien oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Regeln entweder aus Serien oder Artikeln referenziert werden.

Abhängig von dem Attribut DECISION_TYPE können unterschiedliche Regeln formuliert werden.
Ist der Wert von DECISION_TYPE 0 oder1, handelt es sich um eine Vorbereitungsregel (Preparation Rule).

Hierüber können nun Mengen von ungültigen bzw. gültigen Varianten in OPTION_COMBINATION definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

Die Bedingungen wurden um Operatoren ergänzt. Hierfür wurde ein extra Datentyp operator definiert. Dieser kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

Die einzelnen OPTION_COMBINATIONs sind als ELSE-Zweige zu betrachten. Das heißt, sobald eine Bedingungszeile (OPTION_COMBINATION) einen Treffer bekommen hat, werden die anderen nicht mehr durchlaufen.

Ist der Wert von DECISION_TYPE 2, handelt es sich um eine Ausführungsregel (Action Rule). Hier können abhängig von den Bedingungen noch Aktionen definiert werden.

Wenn alle Bedingungen innerhalb einer „OPTION_COMBINATION“ erfüllt sind, dann werden alle zugeordneten Aktionen (ACTIONS) ausgeführt, die abhängig von Bedingungen Werte setzen oder auch Variantenarten (FEATURES) ausblenden können. Ist eine OPTION_COMBINATION erfüllt, werden auch hier die anderen Bedingungen nicht mehr durchlaufen.

Aktionen (ACTIONS)
sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

Direkt, wie z.B. Haupstoff = „blau“ (OPTION)
das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff
das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2 * st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

Das Setzen von Standardvarianten (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

Ausführungsregeln werden im Konfigurator meistens genutzt, wenn sich ein Optionswert (eine Variante) ändert. So kann z.B. dann, wenn sich die Fußvariante von Edelstahl auf Holz ändert, eine Variantenart für den Beizton angezeigt werden.

Ist der Wert von DECISION_TYPE 3, handelt es sich um eine Ausführungsregel (Action Rule) für Stücklisten. Hier kann abhängig von den Bedingungen noch die Anzahl (SET_POS_COUNT_VALUE) in der Stückliste definiert werden.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird die Regel identifiziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/@DECISION_TYPE
type restriction of xs:int
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 3 |
annotation
documentation
Mit diesem Attribut wird der Typ einer Regel angegeben.

0 = ausschließende Vorbereitungsregel
Hierüber können Mengen von ungültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die ungültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind

1 = Vorbereitungsregel (PreparationRule)
Hierüber können Mengen von gültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

2 = Ausführungsregel (Action Rule)
Hier können zusätzlich zu den Bedingungen noch Aktionen definiert werden.
Die Regeln werden vor Eingabe einer Variante am Artikel ausgewertet.
Wenn dann ein Wert ausgewählt wurde, greifen die Aktionsregeln, welche dann Werte setzen oder Variantenarten ausblenden können.
Bei Action Rules greift immer die erste Zeile (OPTIONS_SET_REF), die zutrifft. In dem Fall werden alle zugehörigen ACTIONS ausgeführt.

3 = Ausführungsregel für Anzahl in Stücklisten (PositionCounter Rule)
Hier kann abhängig von den Bedingungen über die Aktion SET_POS_COUNT_VALUE die Anzahl in der Stückliste definiert werden.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/DECISION_NAME_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird die Bezeichnung einer Regel hinterlegt.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTIONS_SET_REF ACTIONS
annotation
documentation
In diesem Element wird eine Variantenkombination gebildet, die mit bestimmten Bedingungen verknüpft ist.
Ist der Wert von DECISION_TYPE 2 oder 3, können der Variantenkombination noch Aktionen (ACTIONS) zugeordnet werden.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/@SEQUENCE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTION_INTERVAL OPTION_LIST OPTION_GROUP_REF_OP OPTION_REF_OP OPTION_LIKE FEATURE_REF_OP MEASURE_VALUE_OP MEASURE_INTERVAL
annotation
documentation
Mit diesem Element wird auf die Variantenart referenziert und eine Regel für ihre Variantenausprägungen definiert. Die Regeln können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/@REF_LEVEL
type restriction of xs:nonNegativeInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
In Stücklisten können Unterpositionen Variantenarten der Hauptposition (PARENT), der obersten Position (ROOT) und von dem Artikel selbst (SELF) über den REF_LEVEL abfragen und abhängig davon eine Aktion auslösen oder diese in einer Bedingung integrieren.
1 = ROOT
2 = PARENT
3 = SELF (Default ist SELF, wenn kein REF-Level angegeben ist)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_INTERVAL
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MIN
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MAX
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird der Endewert des Intervalls angegeben.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST
diagram
properties
content complex
children OPTION_REF
annotation
documentation
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_GROUP_REF_OP
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPTION_GROUP_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantengruppe referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_REF_OP
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird ein Vergleich mit einer Variante formuliert.
Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_REF_OP/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.
Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIKE
diagram
properties
content complex
annotation
documentation
Dieses Element dient dem Textmustervergleich bezüglich Variantenausprägungen.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIKE/@LIKE_VALUE
type restriction of xs:string
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Hier wird die Vergleichszeichenfolge eingetragen. Ähnlich wie beim SQL-Vergleichsoperator LIKE darf sie die Zeichen '_' für ein beliebiges Zeichens und '%' für eine beliebige Zeichenfolge beinhalten.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/FEATURE_REF_OP
diagram
properties
content complex
annotation
documentation
Mit diesem Element kann direkt die Variantenart verglichen werden.
Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/FEATURE_REF_OP/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/FEATURE_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird ein Vergleich mit einer Variantenart formuliert.
Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_VALUE_OP
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_VALUE_OP/@MEASURE_VALUE
type xs:nonNegativeInteger
properties
use required
annotation
documentation
Mit diesem Attribut wird der Vergleichsmaßwert angegeben.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.
Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MIN
type xs:nonNegativeInteger
properties
use required
annotation
documentation
Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MAX
type xs:nonNegativeInteger
properties
use required
annotation
documentation
Mit diesem Attribut wird der Endewert des Intervalls angegeben.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_STEP
type xs:nonNegativeInteger
annotation
documentation
Mit diesem Attribut kann die Schrittweite des Intervalls angegeben werden.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SET_FEATURE_DEFAULT SET_FEATURE_FIXED ENABLE_DECISION DISABLE_DECISION SET_FEATURE_VISIBLE SET_FEATURE_INVISIBLE SET_FEATURE SET_FEATURE_DEFAULT_NULL SET_POS_COUNT_VALUE SET_MESSAGE
annotation
documentation
ACTIONS optional
Dieses Element dient der Festlegung von Aktionen, die bei bestimmten Bedingungen durchgeführt werden.

Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

- Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:
° Direkt, wie z.B. Haupstoff = „blau“ (OPTION)
° das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff
° das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf. Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“). Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

- Das Setzen von Standardvarianten (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

- Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT
diagram
properties
content complex
children FEATURE_REF OPTION_REF FORMULA_REF
annotation
documentation
Mit dieser Aktion können Standardvarianten gesetzt werden.

Bei der Aktion SET_FEATURE_DEFAULT kann ein Wert nur gesetzt werden, wenn der vorhandene Wert durch SET_FEATURE_DEFAULT_NULL gesetzt oder NULL ist das heißt, noch kein Wert eingegeben wurde.

Für das Setzen von Varianten gibt es folgende Möglichkeiten:

Direkt, wie z.B. Haupstoff = „blau“ (OPTION)
das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff
das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).

Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FEATURE_REF
diagram
properties
content complex
annotation
documentation
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FEATURE_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FEATURE_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/OPTION_REF
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt als Standard gesetzt wird.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FORMULA_REF
diagram
properties
content complex
annotation
documentation
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Standardwerten.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FORMULA_REF/@FORMULA_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FORMULA_REF/@FORMULA_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Formel referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED
diagram
properties
content complex
children FEATURE_REF OPTION_REF FORMULA_REF
annotation
documentation
Mit dieser Aktion können Varianten gesetzt werden.

Für das Setzen von Varianten gibt es folgende Möglichkeiten:

- Direkt, wie z.B. Haupstoff = „blau“ (OPTION)
- das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff
- das Rechnen von Varianten (z.B. Sitzhöhe + 5cm). Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf. Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“). Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FEATURE_REF
diagram
properties
content complex
annotation
documentation
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FEATURE_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FEATURE_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/OPTION_REF
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FORMULA_REF
diagram
properties
content complex
annotation
documentation
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FORMULA_REF/@FORMULA_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FORMULA_REF/@FORMULA_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Formel referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/ENABLE_DECISION
diagram
properties
content complex
annotation
documentation
Mit dieser Aktion können Regeln eingeschaltet werden.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/ENABLE_DECISION/@DECISION_NO
type restriction of xs:positiveInteger
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird eine Regel referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/DISABLE_DECISION
diagram
properties
content complex
annotation
documentation
Mit dieser Aktion können Regeln ausgeschaltet werden.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/DISABLE_DECISION/@DECISION_NO
type restriction of xs:positiveInteger
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
Mit diesem Attribut wird eine Regel referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_VISIBLE
diagram
properties
content complex
annotation
documentation
Mit dieser Aktion können Variantenarten sichtbar gemacht werden.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_VISIBLE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_INVISIBLE
diagram
properties
content complex
annotation
documentation
Mit dieser Aktion können Variantenarten unsichtbar gemacht werden.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_INVISIBLE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE
diagram
properties
content complex
children FEATURE_REF OPTION_REF FORMULA_REF
annotation
documentation
Mittels dieser Aktion kann ein Wert für eine Variante einer Variantenart gesetzt werden. Dieser Wert kann im Gegensatz zu „SET_FEATURE FIXED“ verändert werden, wenn die Bedingungen das zulassen. Diese Wertebelegung greift auch dann, wenn das entsprechende Feld vorher durch einen Default oder manuell belegt wurde.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FEATURE_REF
diagram
properties
content complex
annotation
documentation
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FEATURE_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FEATURE_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/OPTION_REF
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FORMULA_REF
diagram
properties
content complex
annotation
documentation
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FORMULA_REF/@FORMULA_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FORMULA_REF/@FORMULA_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Formel referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL
diagram
properties
content complex
children FEATURE_REF OPTION_REF FORMULA_REF
annotation
documentation
Mit dieser Aktion können Standardvarianten gesetzt werden.
Diese Vorbelegung greift nur wenn das entsprechende Variantenfeld vorher leer war.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FEATURE_REF
diagram
properties
content complex
annotation
documentation
Dieses Element referenziert auf eine andere Variantenart für das Setzen von NULL.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FEATURE_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FEATURE_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/OPTION_REF
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die auf NULL gesetzt wird.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FORMULA_REF
diagram
properties
content complex
annotation
documentation
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FORMULA_REF/@FORMULA_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FORMULA_REF/@FORMULA_KEY >
type restriction of xs:string
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Formel referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
Mit diesem Element wird eine Anzahl in der Stückliste gesetzt.
Diese Aktion darf nur bei Regeln mit DECISION_TYPE = 3 angegeben werden.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_MESSAGE
diagram
properties
content complex
annotation
documentation
Dieses Element dient zum Setzen einer Nachricht, so dass bei bestimmten Variantenkombinationen Warnungen oder Hinweise ausgelöst werden können.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_MESSAGE/@MESSAGE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Mit diesem Attribut wird eine Nachricht referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, ab dem eine Regel gültig ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, bis zu welchem eine Regel gültig ist.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/FEATURE_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
Mit diesem Element wird auf die Variantenart referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/FEATURE_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/PRIO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
Dieses Element dient der Angabe eines Wertes für die Priorität einer Regel.
Dabei stellt ein kleiner Wert ein hohe Priorität dar. Das heißt, je größer dieser Wert ist, desto schlechter ist der Vorrang dieser Regel.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTION_GROUP
annotation
documentation
Dieses Element dient der Gruppierung von Mengen mehrerer Varianten. Sie können in den Regeln unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTION OPTION_GROUP_TEXT
annotation
documentation
Dieses Element dient zur Festlegung eine Variantengruppe.
Sie kann in den Prüfungen unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/@OPTION_GROUP_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantengruppe identifiziert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/OPTION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
Mit diesem Element wird auf eine Variante referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/OPTION/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/OPTION/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
Dieses Attribut definiert die Reihenfolge der Varianten in einer Variantengruppe.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/OPTION_GROUP_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält Texte für Variantengruppen.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FORMULAS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FORMULA
annotation
documentation
Dieses Element steht für das Rechnen von Varianten (z.B. Sitzhöhe + 5cm) zur Verfügung. Die Funktion ist allerdings nur für Maßvarianten erlaubt, deren Variantenart den Wert ″M″ enthält, in dem Element MEASURE_UNIT die Maßeinheit und in MEASURE_PARAMETER der Parameter (z. B. sh für Sitzhöhe) eingetragen werden kann. Das Rechnen geschieht über einen Formelstring, der Parameter und Werte enthalten darf.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FORMULAS/FORMULA
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FORMULA_STRING
annotation
documentation
Das Element dient der Definition einer Formel.The attribute FORMULA_KEY contains the identifier, the FORMULA_STRING contains the actual formula.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FORMULAS/FORMULA/@FORMULA_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird der Schlüssel für die Formel definiert.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FORMULAS/FORMULA/FORMULA_STRING
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [+\-*/()A-Za-z0-9. ]* |
annotation
documentation
Dieses Element dient der Angabe einer Formel.


 element T_NEW_CATALOG/PRICE_DEFINITION
diagram
properties
content complex
children PRICE_FEATURE_GROUPS PRICE_TYPES
annotation
documentation
In diesem Element werden Informationen hinterlegt, die für die Preisberechnung notwendig sind wie beispielsweise Preistabellen und Ausführungsgruppen.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS
diagram
properties
content complex
children PRICE_FEATURE_GROUP
annotation
documentation
In diesem Element werden PRICE_FEATURE_GROUPS definiert.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_TEXT FINISH PERCENTAGE_SURCHARGE
annotation
documentation
In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

Eine PRICE_FEATURE_GROUP wird vom Artikel referenziert. Beim Artikel werden auch die konkreten Preise hinterlegt.

Für die PRICE_FEATURE_GROUP bzw. für Artikel gelten folgende Regelungen:
- Preisgruppenneutrale Artikel können Varianten haben, die sich jedoch nicht preislich auswirken. Ihr Preis muss nicht in Preisfeld 1 stehen, sie dürfen jedoch nur ein Element FINISH für die Preisfeldangabe haben. Für preisfeldunabhängige Artikel, für die nur ein Element FINISH in der PRICE_FEATURE_GROUP existiert, in dem der Preis festgehalten wird, dürfen nur einen zugeordneten Preis entsprechend des im FINISH-Element angegebenen Preisfeldes haben.

- Ausführungsabhängige Artikel haben ein oder mehrere Variantenarten.
- Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0).

- Es dürfen prinzipiell mehrere PRICE_FEATURE_GROUPs mit derselben Kombination von Variantenarten angelegt werden.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@PRICE_FEATURE_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP eindeutig identifiziert.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@ADDITIONAL_PRICE
type restriction of xs:boolean
properties
use required
annotation
documentation
Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis).


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_FEATURE_GROUP_TEXT
diagram
type | languagetext60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält Texte für Ausführungsgruppen:


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTIONS_SET_REF PRICE_FIELD SUPPLIER_PRICE_GROUP VALID_FROM VALID_UNTIL
annotation
documentation
In diesem Element werden gültigen Variantenkombinationen Preisfelder (PRICE_FIELD) und eine Herstellerpreisgruppe zugeordnet.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/@SEQUENCE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt die Preisgruppe.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTION_INTERVAL OPTION_LIST OPTION_GROUP_REF_OP OPTION_REF_OP MEASURE_VALUE_OP MEASURE_INTERVAL
annotation
documentation
Mit diesem Element wird auf die Variantenart referenziert und eine Preisgruppe für ihre Variantenausprägungen definiert. Die Preisgruppen können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.
Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:
eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_INTERVAL
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt. 

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN kleiner/gleich zu_prüfender_wert kleiner/gleich OPTION_KEY_MAX.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MIN
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MAX
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird der Endewert des Intervalls angegeben.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST
diagram
properties
content complex
children OPTION_REF
annotation
documentation
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.


attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_GROUP_REF_OP
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPTION_GROUP_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantengruppe referenziert.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_REF_OP
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird ein Vergleich mit einer Variante formuliert.
Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_REF_OP/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.
Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_VALUE_OP
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_VALUE_OP/@MEASURE_VALUE
type xs:nonNegativeInteger
properties
use required
annotation
documentation
Mit diesem Attribut wird der Vergleichsmaßwert angegeben.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.
Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_INTERVAL
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MIN
type xs:nonNegativeInteger
properties
use required
annotation
documentation
Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MAX
type xs:nonNegativeInteger
properties
use required
annotation
documentation
Mit diesem Attribut wird der Endewert des Intervalls angegeben.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/PRICE_FIELD
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/SUPPLIER_PRICE_GROUP
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
annotation
documentation
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, ab dem das Preisfeld gültig ist.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, bis wann das Preisfeld gültig ist.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTIONS_SET_REF PRICE_FACTOR PRICE_FEATURE_GROUP_REF VALID_FROM VALID_UNTIL
annotation
documentation
Um prozentuale Mehrpreise zu ermöglichen, gibt es zusätzlich zu dem Element FINISH unterhalb von PRICE_FEATURE_GROUP das Element PERCENTAGE_SURCHARGE bestehend aus OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM und VALID_UNTIL.
Dieses Element darf nur für PRICE_FEATURE_GROUP's genutzt werden, für die das Kennzeichen ADDITIONAL_PRICE auf 1 gesetzt ist (1=Mehrpreis).
Der prozentuale Mehrpreis kann sich auf unterschiedliche PRICE_FEATURE_GROUPs beziehen:

Fall 1
Basispreis 500,00
Aufpreis Kopfstütze 50,00
Aufpreis Funktion 66,00
Aufpreis Sitzheizung 10% auf Basispreis --&gt; Faktor 0,1 * 500 = 50
Aufpreis Rapport 10% auf Basis + Kopfstütze --&gt; Faktor 0,1 * (500+50) = 55
Aufpreis XY 20% auf alles --&gt; Faktor 0,2 * (500+50+66+50+55) = 144,20
Positionswert = 865,20

Fall 2
Basispreis 500,00
Aufpreis Sitzheizung 10% auf Basispreis --&gt; Faktor 0,1 * 500 = 50
Positionswert = 550,00

Fall 3
Basispreis 500,00
Aufpreis Kopfstütze 50,00
Aufpreis Funktion 66,00
Aufpreis XY 20% auf Basispreis + Kopfstütze + Funktion --&gt; Faktor 0,2 * (500+50+66)=123,20
Positionswert = 739,20

Fall 4
Basispreis 500,00
Aufpreis Kopfstütze 50,00
Aufpreis Funktion 66,00
Aufpreis XY 20% auf ( Basispreis + Kopfstütze + Funktion ) --&gt; Faktor 0,2 * (500+50+66)=123,20
Aufpreis ZZ -10% auf ( Basispreis + Funktion ) --&gt; Faktor -0,1 * (500+66)= -56,60
Positionswert = 682,60

Fall 5
Basispreis 500,00
Aufpreis Kopfstütze 50,00
Aufpreis Funktion 66,00
Konditionswert 616,00
Aufpreis Global1 10% auf alles --&gt; Faktor 0,1 * 616 entspricht Konditionswert = 61,60
Aufpreis Global2 20% auf alles --&gt; Faktor 0,2 * 616 entspricht Konditionswert = 123,20
Positionswert = 800,80

Der Wert des Faktors ist im Element PRICE_FACTOR festzuhalten.
Die Preisgruppen, auf die sich der prozentuale Aufschlag bezieht, werden unter PRICE_FEATURE_GROUP_REF angegeben.
Die Gültigkeit ist in den Elementen VALID_FROM und VALID_UNTIL vermerkt.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/@SEQUENCE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt den prozentualen Mehrpreis.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTION_INTERVAL OPTION_LIST OPTION_GROUP_REF_OP OPTION_REF_OP MEASURE_VALUE_OP MEASURE_INTERVAL
annotation
documentation
Mit diesem Element wird auf die Variantenart referenziert und ein prozentualer Mehrpreis für ihre Variantenausprägungen definiert. Die prozentualen Mehrpreise können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:
eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
Mit diesem Attribut wird eine Variantenart referenziert.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_INTERVAL
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt.

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN kleiner/gleich zu_prüfender_wert kleiner/gleich OPTION_KEY_MAX.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MIN
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MAX
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird der Endewert des Intervalls angegeben.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST
diagram
properties
content complex
children OPTION_REF
annotation
documentation
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.


attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_GROUP_REF_OP
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPTION_GROUP_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantengruppe referenziert.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_REF_OP
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_REF_OP/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
Mit diesem Attribut wird eine Variantenausprägung referenziert.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.
Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_VALUE_OP
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_VALUE_OP/@MEASURE_VALUE
type xs:nonNegativeInteger
properties
use required
annotation
documentation
Mit diesem Attribut wird der Vergleichsmaßwert angegeben.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.
Der Vergleichsoperator kann folgende Werte enthalten:
eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_INTERVAL
diagram
properties
content complex
annotation
documentation
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MIN
type xs:nonNegativeInteger
properties
use required
annotation
documentation
Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MAX
type xs:nonNegativeInteger
properties
use required
annotation
documentation
Mit diesem Attribut wird der Endewert des Intervalls angegeben.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/PRICE_FACTOR
diagram
type extension of xs:int
properties
content complex
annotation
documentation
Dieses Element gibt einen prozentualen Mehrpreis an. Er wird mit 5 Nachkommastellen angegeben.

Der Wert 1050000 entspricht einem Aufschlag von 10,5 %, d. h. einem Faktor von 0,105.
Der Wert -1000000 entspricht einem Aufpreis von -10 %, d. h. einem Fakor von -0,1.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/PRICE_FACTOR/@ROUNDING_TYPE
type restriction of xs:positiveInteger
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
In diesem Element wird die Art des Rundens angegeben:
1 = Aufrunden
2 = Abrunden
3 = kaufmännisches Runden


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/PRICE_FACTOR/@ROUNDING_SCALE
type restriction of xs:integer
facets
Kind | Value | Annotation
minInclusive | -3 |
maxInclusive | 2 |
annotation
documentation
Dieses Element gibt an, auf wie viele Stellen gerundet werden soll.
-3 = Runden auf 1000er
-2 = Runden auf 100er
-1 = Runden auf 10er
0 = Runden auf 1er
1 = Runden auf 1 Nachkommastelle
2 = Runden auf 2 Nachkommastellen


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/PRICE_FEATURE_GROUP_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
Dieses Element referenziert eine Preisgruppe abhängig von der Variantenart bzw. Kalkulationsmethode (PRICE_FEATURE_GROUP).


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/PRICE_FEATURE_GROUP_REF/@PRICE_FEATURE_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, ab dem der prozentuale Mehrpreis gültig ist.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element gibt das Datum an, bis wann der prozentuale Mehrpreis gültig ist.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES
diagram
properties
content complex
children PRICE_TYPE
annotation
documentation
In diesem Element werden die Preisarten zur stück- oder maßvariablen Berechnung von variantenneutralen und variantenabhängigen Artikeln definiert.
Die Kind-Elemente WIDTH_X, DEPTH_Y, HEIGHT_Z geben an, ob der Preis für einen Artikel, der nach dieser Preisart berechnet wird, breiten-, höhen-, tiefen-, flächen- bzw. volumenabhängig ist.
Wenn für keine Dimension eine "1" angegeben ist, ist der Preis nicht maßabhängig, wird also per Stück berechnet (beispielsweise ein Sitzelement). Dann werden die Elemente BASIC_UNIT und ROUNDING_UNIT mit dem Wert 0 belegt.
Wird für genau eine Dimension eine "1" angegeben, so wird diese Dimension für die Preisberechnung herangezogen (beispielsweise Stoffe).
Wenn für genau zwei Dimensionen eine "1" angegeben ist, so ist der Preis flächenabhängig (beispielsweise Teppiche).
Wenn für genau drei Dimensionen eine "1" angegeben ist, so ist der Preis volumenabhängig (beispielsweise Liegeteile).


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE
diagram
properties
content complex
children WIDTH_X DEPTH_Y HEIGHT_Z BASIC_UNIT ROUNDING_UNIT ROUNDING_TYPE BASIC_PRICE_DEPENDENT PRICE_TYPE_FORMULA PRICE_TYPE_NAME PRICE_TYPE_RULES
annotation
documentation
In diesem Element wird eine Preisart definiert.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/@PRICE_TYPE_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/WIDTH_X
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/DEPTH_Y
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/HEIGHT_Z
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/BASIC_UNIT
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999999 |
annotation
documentation
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (P1) und ADDITIONAL_PRICE (P2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in dieses Element "1000" anzugeben. Bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³] eingegeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein.

Pfad 1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ROUNDING_UNIT
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999999 |
annotation
documentation
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ROUNDING_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
Um die unterschiedlichen Arten der Rundung angeben zu können, wird zusätzlich zum Element ROUNDING_UNIT das Element ROUNDING_TYPE mit den möglichen Werten 1, 2 und 3 aufgenommen, um ein Auf-, Ab- und kaufmännisches Runden zu kennzeichnen.

Die Werte haben folgende Bedeutung:
1 Aufrunden
2 Abrunden
3 Kaufmännisches Runden


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/BASIC_PRICE_DEPENDENT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem
Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben, der sich auf im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der im Element definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

##LINK:PRICE_DEFINITION_PRICE_TYPE_BASIC_PRICE_DEPENDENT.JPG##


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_FORMULA
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 100 |
pattern | [\+\-\*/\(\)bhtBHT]{0,} |
annotation
documentation
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_X (P1) (b), DEPTH_Y (P1) (t) oder HEIGHT_Z (P1) (h) auf true gesetzt werden;
- es können die Grundrechendarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (P1), ROUNDING_UNIT (P1) und BASIC_PRICE_DEPENDENT (P1) gelten auch in Verbindung mit der Preisartformel

Pfad:
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_NAME
diagram
type | languagetext60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_RULES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PRICE_TYPE_RULE
annotation
documentation
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_RULES/PRICE_TYPE_RULE
diagram
properties
minOcc | 1
maxOcc | 100
content | complex
children RULE
annotation
documentation
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_RULES/PRICE_TYPE_RULE/@RULE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
In diesem Element wird die Nummer der Regel hinterlegt.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_RULES/PRICE_TYPE_RULE/RULE
diagram
type xs:string
properties
content simple
annotation
documentation
In diesem Element wird die Regel definiert.


 complexType languagetext
diagram
children LANGUAGE
used by
elements T_NEW_CATALOG/CATALOG/CATALOG_INFO T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/FULL_TEXT T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES/MESSAGE/MESSAGE_TEXT T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_COMMENT_TEXT T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/PLANNING_ADVICE T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.


 simpleType measure_unit
type restriction of xs:string
properties
base xs:string
used by
elements T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE/MEASURE/MEASURE_UNIT T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/MEASURE_UNIT
facets
Kind | Value | Annotation
enumeration | MMT |
enumeration | CMT |
enumeration | DMT |
enumeration | MTR |
enumeration | KTM |
enumeration | INH |
enumeration | FOT |
enumeration | YRD |
enumeration | MMK |
enumeration | CMK |
enumeration | DMK |
enumeration | MTK |
enumeration | INK |
enumeration | FTK |
enumeration | YDK |
enumeration | MGM |
enumeration | GRM |
enumeration | KGM |
enumeration | TNE |
enumeration | LBR |
enumeration | MMQ |
enumeration | CMQ |
enumeration | DMQ |
enumeration | MTQ |
enumeration | INQ |
enumeration | FTQ |
enumeration | YDQ |
enumeration | HLT |
enumeration | LTR |
enumeration | MLT |
enumeration | H87 |
annotation
documentation
Mit diesem einfachen Datentyp wird eine Werteliste für Maßeinheiten im Common Code definiert.


 complexType languagetext30
diagram
children LANGUAGE
used by
element T_NEW_CATALOG/CATALOG/CATALOG_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.


 simpleType operator
type restriction of xs:string
properties
base xs:string
used by
attributes T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/FEATURE_REF_OP/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR
facets
Kind | Value | Annotation
maxLength | 4 |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
Mit diesem einfachen Datentyp wird ein Operator für Vergleiche formuliert.
Der Vergleichsoperator kann der folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 complexType languagetext40
diagram
children LANGUAGE
used by
element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.


 complexType languagetext60
diagram
children LANGUAGE
used by
elements T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/DECISION_NAME_TEXT T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TEXT T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/GROUP_TITLE T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/OPTION_GROUP_TEXT T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_FEATURE_GROUP_TEXT T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_NAME T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/PRODUCT_GROUP_TEXT T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/SERIE_GROUP_TEXT
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.