 Introduction

Ansicht mit Navigationswerkzeuge

IDMP 3.1.0 XML schema

Documentation

Last revised 22/11/2021

Documented XML schema:

IDMP_3_1_0.xsd

Contakt DCC e.V.

Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telephon 0 52 21/12 65-37

Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telephon 0 52 21/12 65-38


 Basic structure of the IDM schema

IDMP 3.1.0 XML schema documentation

Introduction > The basic structure of the IDM schema

The basic structure of the IDMP schema

The main element T_NEW_CATALOG defines that a new and complete catalogue data pool is made available.

The IDM schema is subdivided in data ranges that are specified in the subsequent child-elements (see figure 1) in T_NEW_CATALOG.

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

Figure 1 - child elements in T_NEW_CATALOG

The data ranges are not used in isolation from each other. In some data ranges, data is initially created and used from other data ranges via referencing.

Description of the data ranges

CATALOG

CATALOG is used to store administrative information concerning the data pool. E.g. the version of the data format, release date or the unique identification of the data pool.

SUPPLIER

SUPPLIER is used to store administrative information concerning the manufacturer. Example: specification of contact data, EDI communication parameters or the manufacturer's country of origin.

GLOBAL_DEFINITION

The GLOBAL_DEFINITION data range is a kind of data pool for information used in the other data ranges. Example: storage of media, e.g. photos and installation and/or various notes instructions.

SERIES

SERIES is used to store the data for the description of the items. Items are combined into product groups, such as armchairs or intermediate elements.

PART_LISTS

PARTS_LISTS is used to assemble dynamic piece lists, with the sub-positions assigned to rules (DECISIONS) that determine depending on the version in which quantity the respective position exists in the piece list.

FEATURE_DEFINITION

The version information is specified in FEATURE_DEFINITION. Example: Data for version families (FEATURE_CLASS), version types (FEATURE), the associated versions (OPTIONS) or rules (DECISIONS) are specified.

PRICE_DEFINITION

The price information is specified in PRICE_DEFINITION. Example: Data for price characteristics groups (PRICE_FEATURE_GROUP),, VAT (VALUE_ADDED_TAXES), product categories (MERCHANDISE GROUP) or price types (PRICE_TYPE) are specified.


 Elements of the catalogue structure

IDMP 3.1.0 XML schema documentation

Introduction > Elements of the catalogue structure

Creating elements of the catalogue structure

Creating series information

Series are defined in the following element:

T_NEW_CATALOG/SERIES/SERIE

Ein Bild, das Text enthält. Automatisch generierte Beschreibung

All child elements are used to describe the properties of the series.Versions are assigned to series via assessment procedures (RESTRICTION_REF).

Creating versions

Example: creating versions

1. Definition of the version properties/version variations

The version properties are defined in the following element:

FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

</OPTION_DEFINITION>

This element is used to define the properties of colours, materials, shape versions and dimensions.

2. Creating the versions

The versions are created in the following element:

FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_KEY="L"

</OPTION>

<OPTION OPTION_KEY="S"

</OPTION>

</OPTIONS>

</FEATURE>

Version types are defined via version type numbers, e.g. 1. The version is unequivocally identified by the combination of FEATURE_NO in FEATURE_DEFINITION/FEATURES/FEATURE and OPTION_KEY in FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.

Creating item information

Item information is specified in the following element:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The element ITEM has a multitude of elements used to describe the properties of items. An item is identified via the attribute TYPE_NO.

Please note that depending on the series, an item may have different properties. Consequently, an item and its properties can only be unequivocally identified in combination with the series.

Series-specific item information

Depending on the series, items may have different properties. Items are automatically assigned to a series because the element ITEM is a child element of the SERIE element.

Creating version information

Version information is created in the IDM schema as described in the following:

- Creation of variations for the versions

- Assignment of variation and version type

Creating variations

The variations for the versions are defined as a data pool in the element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION.

Figure 2 - The element OPTION_DEFINITION

The OPTION_DEFINITION element contains elements in which the respective variations are specified:

MATERIAL | This element is used to define the properties of materials using colours and textures. These elements are referenced from variation version types.
OPTION_MEASURE | This element is used to specify the values of versions that are expressed in a dimension (e.g. sitting height (variation type 35)).

Example: variations for colours

<OPTION_DEFINITION>

<MATERIAL>

<COLOR COLOR_NO="1">

<RGB_RED>255</RGB_RED>

<RGB_GREEN>0</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="2">

<RGB_RED>133</RGB_RED>

<RGB_GREEN>273</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="3">

<RGB_RED>0</RGB_RED>

<RGB_GREEN>89</RGB_GREEN>

<RGB_BLUE>89</RGB_BLUE>

</COLOR>

</MATERIAL>

</OPTION_DEFINITION>

The above elements define three colours that are identified by numbers (COLOR_NO) 1-3.

Assignment of variation and version type

To use the colours defined in the example above, version types must be assigned, which results in versions.

The assignment of version types (FEATURE) and variations (OPTION) to versions is done in the element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE. A variation is formed and identified by the combination of FEATURE and OPTION. The following XML elements define 2 feed heights (version type 15).

Example: assembly of versions from version type and variations

<FEATURE FEATURE_NO="15">

<OPTIONS>

<OPTION OPTION_KEY="10">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

<OPTION OPTION_KEY="30">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

</OPTIONS>

<FEATURE_TEXT>

</FEATURE_TEXT>

<HEADER_POS_VARIATION_TYPE>K</HEADER_POS_VARIATION_TYPE>

</FEATURE>

The child elements of FEATURE describe the properties of the version type, the child elements of OPTION describe the properties of the version. Analogous to this principle, which applies for essentially all elements in the IDM schema, the OPTION_TEXT defines a text that designates the version. The element FEATURE_TEXT defines a text that designates the version type.

Soll in den Daten eine Variante referenziert werden, muss immer die Kombination aus FEATURE_NO und OPTION_KEY als Referenzierungschlüssel angegeben werden.

Soll in den Daten eine Variante referenziert werden, muss immer die Kombination aus FEATURE_NO und OPTION_KEY als Referenzierungschlüssel angegeben werden.Soll in den Daten eine Variante referenziert werden, muss immer die Kombination aus FEATURE_NO und OPTION_KEY als Referenzierungschlüssel angegeben werden.

If the data is supposed to reference a version, the combination of FEATURE_NO and OPTION_KEY must always be specified as a reference key.


 Arranging the catalogue structure

IDMP 3.1.0 XML schema documentation

Introduction > Arranging the catalogue structure

Arranging the catalogue structure

Assigning series to versions

Ranges are assigned to all series in the following element:

SERIES/DECISIONS/DECISION_REF

The version is assigned to the series by referencing a rule that defines the version as a valid combination in the SERIES/SERIE/DECISIONS/DECISION_REF element.

Assigning items, series and versions

Item-series assignment

Items are automatically assigned to series because the ITEM element is a child element of the SERIES element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Item-specific rules can be defined via SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISIONS_REF.

Example: Rule for version assignment

Element: FEATURE_DEFINITION/DECISIONS/DECISION

<DECISIONS>
 <DECISIONVALIDATION_TYPE="0"DECISION_NO="1">
 <DECISION_NAME_TEXT>
 <LANGUAGEISO_LANGUAGE_ID="EN">
 <TEXT_LINESEQUENCE_NO="1">
 <TEXT>item numbers</TEXT>
 </TEXT_LINE>
 </LANGUAGE>
 </DECISION_NAME_TEXT>
 <OPTION_COMBINATIONSEQUENCE="1">
 <FEATURE_REFFEATURE_NO="1">
 <OPTION_REF_OPOPTION_KEY="1"OPERATOR="eq"/>
 </FEATURE_REF>
 <FEATURE_REFFEATURE_NO="201">
 <OPTION_REF_OPOPTION_KEY="0"OPERATOR="eq"/>
 </FEATURE_REF>
 <FEATURE_REFFEATURE_NO="202">
 <OPTION_REF_OPOPTION_KEY="00"OPERATOR="eq"/>
 </FEATURE_REF>
 <ACTIONS>
 <SET_FEATURE_FIXEDFEATURE_NO="204">
 <OPTION_REFOPTION_KEY="1000"/>
 </SET_FEATURE_FIXED>
 </ACTIONS>
 </OPTION_COMBINATION>
 </DECISION>
 </DECISIONS>


 Catalogue structure

IDMP 3.1.0 XML schema documentation

Introduction > Catalogue structure

Catalogue and element structure

The catalogue structure in the IDM schema is mapped by the following element hierarchy:

Figure 1 - Element hierarchy in the IDM schema

The SERIE element is used to define the properties of a series.Product groups (PRODUCT_GROUPS) in which items (ITEMS) with similar version types are combined are defined within the series. The items are automatically assigned to a series because they are child elements of the SERIE element. The DECISIONS elements are used to cross-series assign versions to a series, product group or item via rules. It is also possible to assign actions (ACTIONS) to the rules defined in DECISIONS.


 Referencing

IDMP 3.1.0 XML schema documentation

Introduction > Referencing

Referencing of elements

The IDM schema establishes relationships between elements and defines information at a central point which are used on multiple occasions in another position. The reuse of the information and the structure of element relationships takes place via referencing. The type of referencing used in the IDM schema is described in the following.

Definition of terms

The IDM schema uses the following terms for the referencing of elements:

Key element | An XML element referenced by other elements.
Ref element | An XML element referencing other elements.

Referencing procedure

The key element has attributes that allow for its unequivocal identification. The ref element has at least the key attributes of the key element. The reference in which the attribute values of the ref element are identical to those of the key element is established between the elements.

Example: Referencing the rule across multiple series, from the series, the product group and the item.

The following example shows how a rule (DECISION) is referenced from an item (ITEM). Only some of the XML elements are explained.

Key element

T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS

<DECISIONS>                                                                                                                        <DECISION DECISION_NO="1"/>
… </DECISION>                                                                   <DECISION DECISION_NO="2"/>
… </DECISION>                                                                   <DECISION DECISION_NO="3"/>
… </DECISION>                                                                    . . .
</DECISIONS>

Ref element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS> <ITEM TYPE_NO="1111"> <DECISIONS> <DECISION_REF DECISION_NO="1" > … </DECISION_REF> . . . </ITEMS>

Example: referencing of a version

The following example shows how to reference a version from an assessment procedure.

Key element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>                                                                                                                          <FEATURE FEATURE_NO="15">
<!-- Fußhöhe -->                                                                               <OPTIONS>                                                                                                                                      <OPTION OPTION_KEY="100"> … </OPTION>                                                                        <OPTION OPTION_KEY="120">
… </OPTION>                                                                            <OPTION OPTION_KEY="30"> … </OPTION>                                                                  </OPTIONS>                                                                                                          </FEATURE>                                                                                                              <FEATURE FEATURE_NO="17">
<!-- Fußform -->                                                                         <OPTIONS>                                                                                                                                      <OPTION OPTION_KEY="F00">
… </OPTION>                                                                        <OPTION OPTION_KEY="F3Z">
… </OPTION>                                                                        <OPTION OPTION_KEY="F70"> … </OPTION>                                                            </OPTIONS>                                                                                                              </FEATURE>
</FEATURES>

For version type 15, the XML elements define three versions (OPTION) with codes 100,120,30. For version type 17, three versions with codes F00, F3Z, F70 are defined. A version is identified via the combination of FEATURE_NO and OPTION_KEY.


 Assessment procedure

IDMP 3.1.0 XML schema documentation

Introduction > Assessment procedure

Definition and assignment of rules

The earlier assessments (RESTRICTIONS) are now fully replaced by rules (DECISIONS).

The rules/assessment procedures are assigned to serious or items by references from the corresponding elements. In total, all assessment procedures defined in this element must be referenced from either series or items.

Rules that are referenced by items take priority over rules referenced by series.

DECISIONS have 3 types of rules (identified by TEST_ID).

Depending on the TEST_ID element, different rules can be specified.

If the value in TEST_ID is 1, the rule is a "preparation rule".

This allows for the definition of valid versions in OPTION_COMBINATION. These are used to determine the valid versions of a version type. These rules do not have an action part ("ACTIONS") and they define a quantity of version combinations that are either true or false. This is a table with the version types (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, version groups that are linked by quantity operators.

The conditions are supplemented with operators. The special data type operator was defined for this purpose. It may contain the following values:

eq (equal) ne (not equal) in (is contained in a quantity) nin (is not contained in a quantity) gt (greater) lt (less) ge (greater than or equal) le (less than or equal)

The individual OPTION_COMBINATIONs must be considered as ELSE branches. This means that as soon as a condition line (OPTION_COMBINATIONS) receives a hit, the others will not be executed anymore.

If the value in TEST_ID is 2, the rule is a an action rule. It allows for the definition of actions in addition to the conditions.

If all conditions within an „OPTION_COMBINATION“ are satisfied, all signed actions (ACTIONS) then can set values or make version types (FEATURES) invisible depending on conditions. If an OPTION_COMBINATION is satisfied, the other conditions are not processed.

Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

· The setting of versions (SET_FEATURE_FIXED) with the following options:

o   Direct, e.g. main fabric = "blue" (OPTION)

o   the setting of version values from another version type (FEATURE), e.g. ledge fabric = main fabric

o   the calculation of versions (e.g. sitting height + 5 cm).

This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.

This requires the version type (e.g. sitting height) to be assigned with a parameter (e.g. "sh").

The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

· Setting default versions (SET_FEATURE_DEFAULT):

These can be filled if no value has been entered yet. The same options as above apply.

· The visibility of version types (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):

Example: for wooden feet, a potentially existing version type for a shade can be displayed and made invisible if a metal foot is selected.

Action rules are usually used in the configurator if an option value (a version) changes. If, for example, the foot version is changed from stainless steel to wood, a version type for the shade can be displayed.


 Data types

IDMP 3.1.0 XML schema documentation

Introduction > Data types

Data types and value ranges

The IDM schema uses the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

It uses the following data types:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDMP, the data type date is used in conformity with the XML schemas as follows:
 | YYYY-MM-DD
 | Y = year, M = moth, D = day
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDMP for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 or -45.98000 or +27.0.
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDMP for URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used in the IDMP for the mapping of valid language keys.language represents codes for natural languages Tags for the Identification of Languagesas defined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.
Additionally, there is also a user-defined data type:
operator | Thy data type is used for rules in the IDMP. This simple, self-defined data type defines an operator for comparisons. The comparison operator is a string of 1 to 4 characters length and may contain the following values:
 | eq (equal)
 | ne (not equal)
 | in (is contained in a quantity)
 | nin (is not contained in a quantity)
 | gt (greater)
 | lt (less)
 | ge (greater than or equal)
 | le (less than or equal)

The value ranges of the above data types are usually restricted for the elements in the IDMP. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters (pattern) and value lists.

In the documentation of the XML schema of the IDM, the value ranges are specified by the information coming after M and P.


 Notes to the documentation

IDMP 3.1.0 XML schema documentation

Introduction > Notes to the documentation

Notes to the IDMP documentation

Notes to the IDM documentation schema are stored in this section.

Explanation of the element properties

Each element is documented on the basis of a description and its properties. The following shows an example for an element description:

Description:

This element is used to specify the currency key for the prices stated in the data pool. For the currency keyISO Währungs-ID must be used.

Changing currencies within the same data pool are not permitted. Updates during the year must be delivered in the same currency as the base file.

D string

P [A-Z]{1,3}

M [1:3]

The element properties are documented on the right side. They have the following meaning:

D | The data type of the element is documented here. If this position is left blank, the element does not contain any reference data but additional child-elements.
P | The entries made in P and M document the value range of an element. A regular expression that defines the permitted values must be entered in P.
M | The minimum and maximum permitted values must be entered in M. In the case of a string data type, P defines the permitted characters and M the minimum and maximum character length. In the case of a numeric data type, the permitted minimum and maximum value is defined.


 Version types

IDMP 3.1.0 XML schema documentation

Introduction > Version types

Version types

The following version types have been defined:

Freely defined version types are available from 213 to 999.

Type: A = finish

F = colour

P = planning

Version_type | Version_type_text | Type | Remark/possible variations
1 | Reference type | A |
2 | Main reference type | A |
3 | Main reference colour | F |
4 | base cover material | A |
5 | base cover colour | F |
6 | back cover type | A |
7 | back cover colour | F |
8 | seam pattern | A | UNKNOWN TERM
9 | Seat cushion type | A |
10 | Seat cushion colour | F |
11 | Decorative cushion type | A | soft, firm, round, rectangular, ...
12 | Decorative cushion colour | F |
13 | Contrast stitching type / variation | A |
14 | Contrast stitching colour | F |
15 | Foot height | A |
16 | Foot material | A | Metal, timber, plastic, beech,. ..
17 | Foot shape | A | metal runner, wooden runner, metal leg, wooden leg, castor, plastic glider
18 | Foot colour | F |
19 | chatose type | A |
20 | chatose colour | F |
21 | UNKNOWN TERM | A |
22 | UNKNOWN TERM | F |
23 | UNKNOWN TERM | A |
24 | UNKNOWN TERM | F |
25 | Side pocket type | A |
26 | Side pocket colour | F |
27 | material of piping | A |
28 | colour of piping | F |
29 | kind of bottom linen | A |
30 | colour of bottom linen | F |
31 | Zipper type | A |
32 | Zipper colour | F |
33 | Seat hardness, quality | A | with/without spring core, ...
34 | Drive type | A | Nozzle, manual, gas pressure spring, motor plug-in, motor battery, do
35 | Seat height | A |
36 | Seat depth | A |
37 | Seat width | A |
38 | Back height | A |
39 | Back cushion height | A |
40 | Back cushion type | A |
41 | Armrests/side element configuration | A | without, left, right, both sides, ...
42 | Armrests/side element type | A |
43 | Side element adjustment | A |
44 | Headrest type | A | movable, fixed, neck rest, ...
45 | Headrest colour | F |
46 | lower front part | A | floor level, floor-free
47 | Fabric combination | K |
48 | Fire / flame retardant | A |
49 | Resting area type | A |
50 | Resting area colour | F |
51 | Country version | A |
52 | Crossways sleepers | A |
53 | Seat angle adjustment | A |
54 | Seat depth adjustment | A | Mechanical, electrical, gas spring, ...
55 | Backrest adjustment | A | Mechanical, electrical, gas spring, ...
56 | Footrest adjustment | A | Mechanical, electrical, gas spring, ...
57 | Massage function | A |
58 | Seat heating | A |
59 | Lumbar support | A |
60 | Swivel base | A |
61 | Stand-up aid | A | Mechanical, electrical, gas spring, ...
62 | Folding table | A |
63 | plug-in table | A |
64 | Pull-out table | A |
65 | Cupholder | A |
66 | Headboard | A | Shape 1, shape 2 etc., headboard shortening at a surcharge, without K
67 | Headboard fabric | A |
68 | Throw-over | A | short, half-length, full length, shroud
69 | Day cover fabric | A |
70 | Lying surface | A | 160x200, 180x200, 200x200 at a surcharge, other lengths at a surcharge
71 | Bedding box | A | standard, inserting mechanism, highline etc.
72 | Bedding box upholstery | A |
73 | Slatted base | A | Standard or alternatives at a surcharge, separate slats if appropriate
74 | Mattress | A | Standard or alternatives at a surcharge >> firmness level H2
75 | Handles (for bedside tables) | F |
76 | Bedside tables | A | Drawer with plastic or metal rails
77 | Lamp colour and finish | A |
78 | Knob cover | F |
79 | Slatted base adjustment | A | Mechanical, electrical, gas spring, multiple, ...
80 | Function/adjustment in general | A |
81 | freely defined version type | F |
82 | freely defined version type | F |
83 | freely defined version type | F |
84 | freely defined version type | F |
85 | freely defined version type | F |
86 | freely defined version type | F |
87 | freely defined version type | F |
88 | freely defined version type | F |
89 | Connection type L | P | ID of the connection vector in the SVG: AVL
90 | Connection type R | P | ID of the connection vector in the SVG: AVR
91 | freely defined version type | P |
92 | freely defined version type | P |
93 | freely defined version type | P |
94 | freely defined version type | P |
95 | Planning width | P | Item width
96 | Planning depth | P | Item depth
97 | Planning height | P | Item height
98 | Drive position | A |
99 | Table colour | F |
100 | Head-section adjustment | A |
101 | Relax function | A |
102 | Vitalising function | A |
103 | Power source/motor | A |
104 | Accessories | A |
105 | Top table | A |
106 | Back holder | A |
107 | Slot-in back | A |
108 | Intermediate table | A |
109 | Newspaper rack | A |
110 | Swivel function | A |
111 | Reading lamp | A |
112 | Decorative item | A |
150 | freely defined version type | P |
151 | freely defined version type | P |
152 | freely defined version type | P |
153 | freely defined version type | P |
154 | freely defined version type | P |
155 | freely defined version type | P |
160 | Connection type top 1 | P | ID of the connection vector in the SVG: AVO1
161 | Connection type top 2 | P | ID of the connection vector in the SVG: AVO2
162 | Connection type top 3 | P | ID of the connection vector in the SVG: AVO3
163 | Connection type top 4 | P | ID of the connection vector in the SVG: AVO4
164 | Connection type top 5 | P | ID of the connection vector in the SVG: AVO5
165 | Connection type bottom 1 | P | ID of the connection vector in the SVG: AVU1
166 | Connection type bottom 2 | P | ID of the connection vector in the SVG: AVU2
167 | Connection type bottom 3 | P | ID of the connection vector in the SVG: AVU3
168 | Connection type bottom 4 | P | ID of the connection vector in the SVG: AVU4
169 | Connection type bottom 5 | P | ID of the connection vector in the SVG: AVU5
170 | Connection type top 6 | P | ID of the connection vector in the SVG: AVO6
171 | Connection type top 7 | P | ID of the connection vector in the SVG: AVO7
172 | Connection type top 8 | P | ID of the connection vector in the SVG: AVO8
173 | Connection type top 9 | P | ID of the connection vector in the SVG: AVO9
174 | Connection type top 10 | P | ID of the connection vector in the SVG: AVO10
175 | Connection type bottom 6 | P | ID of the connection vector in the SVG: AVU6
176 | Connection type bottom 7 | P | ID of the connection vector in the SVG: AVU7
177 | Connection type bottom 8 | P | ID of the connection vector in the SVG: AVU8
178 | Connection type bottom 9 | P | ID of the connection vector in the SVG: AVU9
179 | Connection type bottom 10 | P | ID of the connection vector in the SVG: AVU10
180 | Connection type north 1 | P | ID of the connection vector in the SVG: AVN1
181 | Connection type north 2 | P | ID of the connection vector in the SVG: AVN2
182 | Connection type north 3 | P | ID of the connection vector in the SVG: AVN3
183 | Connection type north 4 | P | ID of the connection vector in the SVG: AVN4
184 | Connection type north 5 | P | ID of the connection vector in the SVG: AVN5
185 | Connection type north 6 | P | ID of the connection vector in the SVG: AVN6
186 | Connection type north 7 | P | ID of the connection vector in the SVG: AVN7
187 | Connection type north 8 | P | ID of the connection vector in the SVG: AVN8
188 | Connection type north 9 | P | ID of the connection vector in the SVG: AVN9
189 | Connection type north 10 | P | ID of the connection vector in the SVG: AVN10
190 | Connection type south 1 | P | ID of the connection vector in the SVG: AVS1
191 | Connection type south 2 | P | ID of the connection vector in the SVG: AVS2
192 | Connection type south 3 | P | ID of the connection vector in the SVG: AVS3
193 | Connection type south 4 | P | ID of the connection vector in the SVG: AVS4
194 | Connection type south 5 | P | ID of the connection vector in the SVG: AVS5
195 | Connection type south 6 | P | ID of the connection vector in the SVG: AVS6
196 | Connection type south 7 | P | ID of the connection vector in the SVG: AVS7
197 | Connection type south 8 | P | ID of the connection vector in the SVG: AVS8
198 | Connection type south 9 | P | ID of the connection vector in the SVG: AVS9
199 | Connection type south 10 | P | ID of the connection vector in the SVG: AVS10
200 | freely defined version type | F |
201 | freely defined version type | F |
202 | freely defined version type | F |
203 | freely defined version type | F |
204 | freely defined version type | F |
205 | freely defined version type | F |
206 | freely defined version type | F |
207 | freely defined version type | F |
208 | freely defined version type | F |
209 | freely defined version type | F |
210 | freely defined version type | F |
211 | fabric requirement | A | in linear metres
212 | leather requirement | A | in m²


 Model code

IDMP 3.1.0 XML schema documentation

Introduction > Model code

This element is used to specify the model code:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

The following model codes have been defined:

Typ-Nr. | Bezeichnung (deutsch)
1 | Sessel / Hochlehnsessel
2 | Clubchair
3 | TV-Sessel / Ruhe- / Liege- / Relaxsessel
4 | Longchair
5 | Sofa / Canapé
6 | Zwischenelement
7 | Ecke / Trapezteil
8 | Einzelliege / Recamiere / Ottomane / Cheselon / Chaiselongue
9 | Hocker
10 | Kissen
11 | Couchtisch / Anstelltische / Stecktische ...
12 | Esstisch
13 | Kombinationen
14 | Abschlusselement
15 | Bettsofa / Bettcouch / Liegesofa / Schlafelement / Polsterliegen
16 | Sitzbank, Essplatzbank, Dinnersofa, ...
17 | Stühle
18 | Fußbank
19 | Kopfstütze
20 | Leuchten
21 | Teppiche
22 | Zubehör / Kleinteile
23 | Polsterbetten / Polsterbett-Systeme
24 | Polsterbettgestelle
25 | Metrage
26 | Sonstiges


 Language key

IDMP 3.1.0 XML schema documentation

Introduction > Language key

Language key | Language name
AA | Afar
AB | Abkhazian
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AV | Avarisch
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CR | Cree
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundish
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothish
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VE | Tshivenda
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu

According to the ISO standard, the language keys are generally written with small letters. Capital letters are used for the IDM data.


 Country code

IDMP 3.1.0 XML schema documentation

Introduction > Country code

country code | country
AC | Ascension
AD | Andorra
AE | United Arab Emirates
AF | Afghanistan
AG | Antigua and Barbuda
AI | Anguilla
AL | Albania
AM | Armenia
AN | Dutch Antilles
AO | Angola
AQ | Antarctica
AR | Argentina
AS | American Samoa
AT | Austria
AU | Australia
AW | Aruba
AX | Aland
AZ | Azerbaijan
BA | Bosnia and Herzegovina
BB | Barbados
BD | Bangladesh
BE | Belgium
BF | Burkina Faso
BG | Bulgaria
BH | Bahrain
BI | Burundi
BJ | Benin
BL | Saint-Barthélemy
BM | Bermuda
BN | Brunei Darussalam
BO | Bolivia
BQ | Bonaire, Sint Eustatius and Saba
BR | Brazil
BS | Bahamas
BT | Bhutan
BU | Burma
BV | Bouvet Island
BW | Botswana
BY | Belarus
BZ | Belize
CA | Canada
CC | Cocos) Islands
CD | Democratic Republic of the Congo
CF | Central African Republic
CG | Republic of the Congo
CH | Switzerland
CI | Ivory Coast
CK | Cook Islands
CL | Chile
CM | Cameroon
CN | China
CO | Columbia
CP | Clipperton
CR | Costa Rica
CU | Cuba
CV | Cape Verde
CW | Curaçao
CX | Christmas Island
CY | Cyprus
CZ | Czech Republic
DE | Germany
DG | Diego Garcia
DJ | Djibouti
DK | Denmark
DM | Dominica
DO | Dominican Republic
DZ | Algeria
EA | Ceuta, Melilla
EC | Ecuador
EE | Estonia
EG | Egypt
EH | Westsahara
EN | England
ER | Eritrea
ES | Spain
ET | Ethiopia
FI | Finland
FJ | Fiji
FK | Falklands
FM | Micronesia
FO | Faeroe Islands
FR | France
GA | Gabon
GB | England/Great Britain
GD | Grenada
GE | Georgia
GF | French Guiana
GG | Guernsey (Channel Island)
GH | Ghana
GI | Gibraltar
GL | Greenland
GM | Gambia
GN | Guinea
GP | Guadeloupe
GQ | Equatorial Guinea
GR | Greece
GS | South Georgia and the South Sandwich Islands
GT | Guatemala
GU | Guam
GW | Guinea-Bissau
GY | Guyana
HK | Hong Kong
HM | Heard and McDonald Islands
HN | Honduras
HR | Croatia
HT | Haiti
HU | Hungary
ID | Indonesian
IE | Ireland
IL | Israel
IM | Isle of Man
IN | India
IO | British Indian Ocean Territory
IQ | Iraq
IR | Islamic Republic of Iran
IS | Iceland
IT | Italy
JE | Channel Island of Jersey
JM | Jamaica
JO | Jordan
JP | Japan
KE | Kenya
KG | Kyrgyzstan
KH | Cambodia
KI | Kiribati
KM | Comoros
KN | Saint Kitts and Nevis
KP | Democratic People's Republic of Korea
KR | Republic of Korea
KW | Kuwait
KY | Cayman Islands
KZ | Kazakstan
LA | Laos
LB | Lebanon
LC | Saint Lucia
LI | Liechtenstein
LK | Sri Lanka
LR | Liberia
LS | Lesotho
LT | Lithuania
LU | Luxembourg
LV | Latvia
LY | Libya
MA | Morocco
MC | Monaco
MD | Moldavia
ME | Montenegro
MF | Saint Martin
MG | Madagascar
MH | Marshall Islands
MK | North Macedonia
ML | Mali
MM | Myanmar (Burma)
MN | Mongolia
MO | Macau
MP | Northern Mariana Islands
MQ | Martinique
MR | Mauritania
MS | Montserrat
MT | Malta
MU | Mauritius
MV | Maldives
MW | Malawi
MX | Mexico
MY | Malaysia
MZ | Mozambique
NA | Namibia
NC | New Caledonia
NE | Niger
NF | Norfolk Island
NG | Nigeria
NI | Nicaragua
NL | Netherlands
NO | Norway
NP | Nepal
NR | Nauru
NU | Niue
NZ | New Zealand
OM | Oman
PA | Panama
PE | Peru
PF | French Polynesia
PG | Papuan New Guinea
PH | Philippine
PK | Pakistan
PL | Poland
PM | St. Pierre and Miquelon
PN | Pitcairn Islands
PR | Puerto Rica
PS | Palestine
PT | Portugal
PW | Palau
PY | Paraguay
QA | Qatar
RE | Reunion
RO | Romania
RS | Serbia
RU | Russia
RW | Ruanda
SA | Saudi Arabia
SB | Solomon Islands
SC | Seychelles
SD | Sudan
SE | Sweden
SG | Singapore
SH | St. Helena
SI | Slovenia
SJ | Svalbard and Jan Mayen Islands
SK | Slovak Republic
SL | Sierra Leone
SM | San Marino
SN | Senegal
SO | Somalia
SR | Suriname
SS | South Sudan
ST | Democratic Republic of São Tomé and Príncipe
SV | El Salvador
SX | Sint Maarten
SY | Syrian Arab Republic
SZ | Swaziland
TC | Turks and Caicos Islands
TD | Chad
TF | French Southern and Antarctic Territories
TG | Togo
TH | Thailand
TJ | Tadschikistan
TK | Tokelau
TL | East Timor
TM | Turkmenistan
TN | Tunisia
TO | Tonga
TR | Turkey
TT | Trinidad and Tobago
TV | Tuvalu
TW | Taiwan
TZ | Tanzania
UA | Ukraine
UG | Uganda
UM | United States Minor Outlying Islands
US | United States of America
UY | Uruguay
UZ | Uzbekistan
VA | Vatican City
VC | Saint Vincent and the Grenadines
VE | Venezuela
VG | British Virgin Islands
VI | American Virgin Islands
VN | Vietnam
VU | Vanuatu
WF | Wallis and Futuna Islands
WS | Samoa
YE | Yemen
YT | Mayotte
ZA | South Africa
ZM | Sambia
ZW | Zimbabwe


 Types of detailed information

IDMP 3.1.0 XML schema documentation

Introduction > Types of detailed information

The following info types can be used to describe the type of detail information:

1 = Milieu photo

2 = Item pictogram (type/item overview)

3 = Magnetic planner drawing (SVGs in top view)

4 = Version photo

5 = Version texture (leather type, ...)

6 = Manufacturer logo/product brand

7 = Colour consultancy (the versions are defined in an assessment procedure)

8 = Fabric sample book (PDF for fabric groups)

9 = Model description sheets (PDF below series)

10 = Installation instructions

11 = Marketing

12 = Miscellaneous

13 = Colour consultancy wall

14 = Colour consultancy floor

15 = Description of function

16 = Planning advice

17 = Catalogue image


 Schema IDMP_3_1_0.xsd.EN.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\IDMP\Doku IDMP\IDMP_3_1_0.xsd.EN.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types | Simple types
T_NEW_CATALOG | languagetext | measure_unit
 | languagetext30 | operator
 | languagetext40 |
 | languagetext60 |


 element T_NEW_CATALOG
diagram
properties
content complex
children CATALOG SUPPLIER GLOBAL_DEFINITION SERIES PART_LISTS FEATURE_DEFINITION PRICE_DEFINITION
annotation
documentation
This element is used to specify all information and data for the provisioning of a complete catalogue/data pool.


 attribute T_NEW_CATALOG/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 3 |
maxInclusive | 3 |
annotation
documentation
The version number "MAJOR" specifies the format version the data pool is delivered. The major version number will only change in the case of a fundamental revision of the entire format.
The complete information about the format version in which a data pool is delivered consists of MAJOR, MINOR and REVISION.


 attribute T_NEW_CATALOG/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 1 |
annotation
documentation
The sub-version number "MINOR" usually changes every year. If the main version MAJOR is modified, the subversion is reset to 0.


 attribute T_NEW_CATALOG/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 0 |
annotation
documentation
The revision number "REVISION" highlights changes during the year resultant from individual working groups. The revisions are not published if they are not concerned with necessary corrections. Revision is reset to 0 with each new MINOR sub-version number.


 attribute T_NEW_CATALOG/@FORMAT
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [ABGKOPSWZ] |
annotation
documentation
This element is used to specify the manufacturer's industry code. The following industry codes are currently defined:

A = worktop manufacturers
B = bathroom furniture manufacturers
G = appliance manufacturers
K = kitchen furniture manufacturers
O = office furniture manufacturers
P = upholstered furniture manufacturers
S = sanitary products manufacturers
W = living room furniture manufacturers
Z = accessories manufacturers


 element T_NEW_CATALOG/CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CURRENCY_KEY CATALOG_LANGUAGE CATALOG_NAME DATA_VERSION VALID_FROM_DATE VALID_UNTIL_DATE FILE_ID CATALOG_MARK CATALOG_MERGE_TYPE CATALOG_DATA_VERSION CATALOG_INFO CATALOG_VERSION FALL_BACK_LANGUAGE DETAIL_INFOS
annotation
documentation
This element is used to store administrative information concerning the catalogue/data pool.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children GLN_NO CATALOG_ID MAJOR_NO MINOR_NO FILE_RELEASE_DATE
annotation
documentation
This element is used to specify the catalogue's identifying characteristics.

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/GLN_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | (0-9){13} |
annotation
documentation
This element is used to enter a unique global location number (GLN). The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
The manufacturer must enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.
This ID is required for identification in the case of multi-manufacturer catalogues.

A manufacturer catalogue must always have the same ID for the same dealership.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MAJOR_NO
diagram
type restriction of xs:gYear
properties
content simple
annotation
documentation
The catalogue version number MAJOR_NO provides the year in which the data pool was produced. The full indication of the catalogue version in which a data pool is delivered consists of MAJOR and MINOR.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MINOR_NO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
The catalogue sub-version number MINOR_NO is given in serial numbers for the year. The full indication of the catalogue version in which a data pool is delivered consists of MAJOR and MINOR. If the catalogue version MAJOR is changed, the catalogue sub-version is reset to 0.


 element T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
This element provides the time stamp for the creation of the data pool in UTC time.


 element T_NEW_CATALOG/CATALOG/CURRENCY_KEY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{1,3} |
annotation
documentation
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year must be delivered in the same currency as the base file.


 element T_NEW_CATALOG/CATALOG/CATALOG_LANGUAGE
diagram
properties
content complex
children ISO_LANGUAGE_ID
annotation
documentation
This element indicates the languages used in the data pool.


 element T_NEW_CATALOG/CATALOG/CATALOG_LANGUAGE/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.


 element T_NEW_CATALOG/CATALOG/CATALOG_NAME
diagram
type | languagetext30
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to specify the catalogue name of the data pool. It serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.


 element languagetext30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetext30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_NEW_CATALOG/CATALOG/DATA_VERSION
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
The data version (DATA_VERSION) defines the date until which catalogue data, supplements and error corrections published by the manufacturer was included in the data pool.


 element T_NEW_CATALOG/CATALOG/VALID_FROM_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
The element is used to specify the validity period date of the catalogue and thereby of the current data pool.


 element T_NEW_CATALOG/CATALOG/VALID_UNTIL_DATE
diagram
type restriction of xs:date
properties
content simple
annotation
documentation
The element is used to specify the validity period date of the catalogue and thereby of the current data pool.


 element T_NEW_CATALOG/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data


 element T_NEW_CATALOG/CATALOG/CATALOG_MARK
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [BKVF] |
annotation
documentation
This element is used to specify whether the provisions data are

B = block data with prices
K = catalogue data
V = block data without prices (fictional prices must be specified)
F = correction update.


 element T_NEW_CATALOG/CATALOG/CATALOG_MERGE_TYPE
diagram
type xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element CATALOG_MERGE_TYPE is optional and contains boolean data with the following values.

0: The value if the element is not present; it means that this catalogue does not have to be part of a multi-manufacturer catalogue.

1: This catalogue is always part of a multi-manufacturer catalogue.


 element T_NEW_CATALOG/CATALOG/CATALOG_DATA_VERSION
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element must be filled if the CATALOG_MARK element (catalogue identifier) contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates.


 element T_NEW_CATALOG/CATALOG/CATALOG_INFO
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element is used to store the information texts.


 element languagetext/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute languagetext/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
b Bold font
br line break


 element T_NEW_CATALOG/CATALOG/CATALOG_VERSION
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
The manufacturer can assign a version number for the catalogue in this field.


 element T_NEW_CATALOG/CATALOG/FALL_BACK_LANGUAGE
diagram
type restriction of xs:language
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified. The two-digit ISO language code must be used. The specified fallback language must be included in the catalogue.


 element T_NEW_CATALOG/CATALOG/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element serves to specify images on catalogue level, e.g. a manufacturer or catalogue logo.


 element T_NEW_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference the detailed information.


 attribute T_NEW_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced detailed information.


 attribute T_NEW_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute allows for the specification of detailed information for the catalogue with a freely-defined sorting order.


 element T_NEW_CATALOG/SUPPLIER
diagram
properties
content complex
children ISO_COUNTRY_ID WEEE_NO CONTACT_PERSON CONTACT_SUPPLIER
annotation
documentation
This element is used to specify the manufacturer's data, e.g. communication and contact information.


 element T_NEW_CATALOG/SUPPLIER/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element is used to specify the manufacturer's country in accordance with the ISO standard.


 element T_NEW_CATALOG/SUPPLIER/WEEE_NO
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to enter the WEEE registration number. A WEEE registration number is mandatory for everyone classified as a manufacturer or importer of electrical appliances in accordance with the "Electrical and Electronic Equipment Act (ElektroG)".
In Germany, WEEE numbers look as follows: "DE12345678".
Dealers can verify the validity of WEEE numbers on the website of the register for Waste Electrical Appliances (http://www.stiftung-ear.de).


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON
diagram
properties
minOcc | 1
maxOcc | 2
content | complex
children CONTACT_PERSON_NO CONTACT_ROLE CONTACT_NAME FIRST_NAME FORM_OF_ADDRESS DEPARTMENT TELEPHONE FAX EMAIL STREET ZIPCODE_STREET CITY ISO_COUNTRY_ID
annotation
documentation
This element is used to specify the information of a contact person.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CONTACT_PERSON_NO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
This element is used to specify the priorities of methods for making contact with the contact person. (1=1st Contact, 2=2nd contact)


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CONTACT_ROLE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 60 |
annotation
documentation
This element is used to specify the role of the newly created contact. The role designation certified by the manufacturer (e.g. substitute, person responsible for IT).


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CONTACT_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
This element is used to specify the last name of the direct contact person for the software house.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/FIRST_NAME
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
This element is used to specify the first name of the direct contact person.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/FORM_OF_ADDRESS
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 2 |
annotation
documentation
This element is used to specify the salutation for the direct contact person.
1 = Mrs
2 = Mr


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/DEPARTMENT
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
This element is, if present, used to specify the department of the direct contact person.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/TELEPHONE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element is used to specify the telephone number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(1234)56-7890.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/FAX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element is used to specify the fax number of the direct contact person. This also includes all (international) dialling codes, e.g. +49(5251)60-3284.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
This element is used to specify the email address.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element as you specify the street of the manufacturer's business address.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
This element is used to specify the postcode of the manufacturer's business address.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/CITY
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to specify the manufacturer's place registered office.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_PERSON/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element is used to specify the manufacturer's country in accordance with theISO standard.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER
diagram
properties
content complex
children MANUFACTURER_NAME_1 MANUFACTURER_NAME_2 EMAIL INTERNET_ADDRESS STREET ZIPCODE_STREET CITY ISO_COUNTRY_ID ZIPCODE_POSTBOX POSTBOX TELEPHONE_SWITCHBOARD FAX_SWITCHBOARD
annotation
documentation
This element is used to specify the manufacturer's contact data.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_1
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to specify the first line of the company name.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/MANUFACTURER_NAME_2
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
If activated, this element is used to store the second line of the company name.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/EMAIL
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [a-zA-Z0-9._%+\-!#$%'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,} |
annotation
documentation
This element is used to specify the official email address for the dealership or consumer.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/INTERNET_ADDRESS
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element, if present, is used to specify the official URL (e.g. http://www.company.com) for dealerships or consumers.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element as you specify the street of the manufacturer's business address.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_STREET
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
This element is used to specify the postcode of the manufacturer's business address.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/CITY
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to specify the manufacturer's place registered office.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/ISO_COUNTRY_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element is used to specify the manufacturer's country in accordance with theISO standard.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/ZIPCODE_POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 8 |
annotation
documentation
This element is, if present, used to specify the postcode associated with the PO Box.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/POSTBOX
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{0,10} |
annotation
documentation
This element is, if present, used to specify the PO Box line of the manufacturer's address. The word "PO Box" must be omitted.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/TELEPHONE_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element is used to specify the telephone number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890.


 element T_NEW_CATALOG/SUPPLIER/CONTACT_SUPPLIER/FAX_SWITCHBOARD
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 18 |
annotation
documentation
This element is here to specify the fax number of the manufacturer's switchboard. This also includes all (international) dialling codes, e.g. +49(1234)56-7890.


 element T_NEW_CATALOG/GLOBAL_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFOS MESSAGES
annotation
documentation
This element is used to specify data that is valid for the entire catalogue/data pool (global information).


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO
annotation
documentation
This element is used to specify detailed information.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION INFO_TYPE EXTERNAL_NAME INTERNAL_NAME TOOL_TIP URL LAYER
annotation
documentation
This element is used to specify URLs to detailed information.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute identifies a detailed information.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/CLASSIFICATION
diagram
type restriction of xs:string
properties
content simple
annotation
documentation
This element is used to classify detailed information.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INFO_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 17 |
annotation
documentation
This element is here to describe the type of detailed information.
The values of the available info types can be found in the corresponding table in the introduction.
An image size of 2048x2048px is recommended for images of typical settings (INFO_TYPE = 1).


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains the display name of the link (e.g. "sketch 4711").


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
diagram
type | languagetext40
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
A more detailed description of the link can be included here.
This information is not intended for disclosure to the dealership, but to provide further information to the software houses.


 element languagetext40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetext40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,40} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains the text for a link note.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL
diagram
properties
content complex
children LANGUAGE
annotation
documentation
This element specifies the URL to the detailed information. In multilingual catalogues, the URL is only to be saved once in the specified fallback language.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT HASH_VALUE
annotation
documentation
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/TEXT
diagram
type xs:anyURI
properties
content simple
annotation
documentation
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/HASH_VALUE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 32 |
maxLength | 32 |
annotation
documentation
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/LAYER
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children LAYER_TYPE DPI
annotation
documentation
This element is used to place add-on items, e.g. headrests.
This element is only allowed for SVG files.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/LAYER/LAYER_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
pattern | [1-6]0 |
annotation
documentation
This element is used to place add-on items, e.g. headrests.
Within the outline type of a SVG, the following applies:
There is no overlapping of any areas designated by our clients within the same layer.
The following values applied to the element:
10 Carpet
20 Sofa/furniture/table (default value)
30 Cushions
40 Decorative cushions
50 Headrest
60 Plate/ throw


 element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/LAYER/DPI
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
enumeration | 72 |
enumeration | 96 |
annotation
documentation
This element specifies the dot density (dpi) of the SVG files that belong to the data pool. With the usual drawing tools, this is either 72 dpi (e.g. Adobe Illustrator) or 96 dpi (e.g. Coral Draw).


 element T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MESSAGE
annotation
documentation
The possible warnings and information are stored under this element.
The possible warnings and information notices with the corresponding text, the level and the unique identifier are stored under this element.


 element T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES/MESSAGE
diagram
properties
minOcc | 1
maxOcc | 99999
content | complex
children MESSAGE_TEXT
annotation
documentation
This element is used to store a message.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES/MESSAGE/@MESSAGE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 99999 |
annotation
documentation
This attribute is used to identify the message.


 attribute T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES/MESSAGE/@LEVEL
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 1 |
annotation
documentation
The message level is specified here:
0 Notice/information
1 Warning


 element T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES/MESSAGE/MESSAGE_TEXT
diagram
type | languagetext
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to store the message text.


 element T_NEW_CATALOG/SERIES
diagram
properties
content complex
children SERIE DECISIONS SERIE_GROUPS
annotation
documentation
This element is used to specify all series of the catalogue/data with the properties and elements assigned to them, e.g. product groups or items.
A series usually corresponds to a model.


 element T_NEW_CATALOG/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 1000000
content | complex
children SERIES_TEXT PURCHASE_RETAIL_ID DECISIONS PRODUCT_GROUPS COLOR_CONSULTANCIES DETAIL_INFOS VALID_FROM VALID_UNTIL OPTIONAL_CONNECTION
annotation
documentation
This element is used to define the series. A series usually corresponds to a model.
An item from series 0 is valid in all other series, which means that items of series 0 must not exist with the same type designation (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in any other series. Items of other series (other than 0) may however exist in multiple series with identical type designation.


 attribute T_NEW_CATALOG/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the serial number of the series.


 attribute T_NEW_CATALOG/SERIES/SERIE/@SEQUENCE_NO
type xs:positiveInteger
properties
use required
annotation
documentation
This attribute allows for the specification of series with a freely-defined sorting order.
If a SEQUENCE_NO is specified for one series, a SEQUENCE_NO must be specified for all series.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT
diagram
properties
content complex
children SHORT_TEXT FULL_TEXT PLANNING_ADVICE
annotation
documentation
This element is used to define the series-specific texts. These may be characteristic short, descriptive long and planning advice texts. At least one series short text must be specified for each item.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/SHORT_TEXT
diagram
properties
content complex
children LANGUAGE
annotation
documentation
This element contains a short text that describes the series.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/SHORT_TEXT/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE
diagram
properties
content complex
children TEXT
annotation
documentation
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/FULL_TEXT
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
The full text contains the complete description of the series. The HTML tags bold and line break can be used within the text. Images are not be be included.
This element contains the full text in a CDATA node. The text must be specified in HTML format:
b Fettdruck
br Zeilenumbruch


 element T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/PLANNING_ADVICE
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains planning advice that applies to the entire series.


 element T_NEW_CATALOG/SERIES/SERIE/PURCHASE_RETAIL_ID
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 3 |
annotation
documentation
This element assigns an identifier for series-specific purchasing/sales prices:
EK_VK_ID
0 = purchasing price including VAT (or list price)
1 = sales price including VAT ( recommended sales price)
2 = purchasing price excluding VAT
3 = purchasing price excl. VAT/VAT
This element is very important for pricing. If the purchasing prices are used, this must be the dealership's purchasing price, not the manufacturer purchasing price.


 element T_NEW_CATALOG/SERIES/SERIE/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
This element is used to collect series specific rules.


 element T_NEW_CATALOG/SERIES/SERIE/DECISIONS/DECISION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference a rule assigned to a series.


 attribute T_NEW_CATALOG/SERIES/SERIE/DECISIONS/DECISION_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to reference a rule.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
content complex
children PRODUCT_GROUP
annotation
documentation
This element is used to define product groups. Product groups are used to combine articles with identical version types (e.g. upholstered furniture with armrests).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRODUCT_GROUP_TEXT FEATURE_CLASS_REF ITEMS DECISIONS
annotation
documentation
This element is used to create modified items that are combined in product groups. "Identical" product groups must therefore not be captured.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/PRODUCT_GROUP_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
This element contains the designation of a product group.


 element languagetext60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetext60/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext60/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,60} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/FEATURE_CLASS_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element is used to assign a version family to the product group. A version family referenced in the FEATURE_DEFINITION/FEATURE_CLASSES element is defined here.


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/FEATURE_CLASS_REF/@FEATURE_CLASS_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to identify the referenced version family (FEATURE_CLASS).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
This element is used to define all items of a product group.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_REF PRICE_FEATURE_GROUP_BASE_PRICE_REF PRICE_TYPE_REF ADDITIONAL_PRICE_GROUP MINIMUM_PRICE DECISIONS ADDITIONAL_ITEMS EDP_NUMBER EAN_NUMBER ITEM_IDENTIFICATION CATALOG_PAGE VALID_FROM VALID_UNTIL WEIGHT_BRUTTO WEIGHT_NETTO VOLUME MINIMUM_DELIVERY_TIME BASIC_PROFILE ITEM_TEXT TYPE_KEY CLASSIFICATIONS DETAIL_INFOS SALES_NUMBER PART_LIST_REF PART_LIST_EXCLUSIVE
annotation
documentation
This element is used to define items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.
Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to enter the item code/item type.


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@SEQUENCE_NO
type restriction of xs:positiveInteger
annotation
documentation
This attribute allows for the specification of items with a freely-defined sorting order.
The sorting of the items always relates to the series in which the items are stored. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference an item that has already been created and developed in another series.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to specify the item number of the referenced item.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the serial number of the referenced item.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
This element is used to reference a base price group. A base price group is a PRICE_FEATURE_GROUP (path 1) where the ADDITIONAL_PRICE element as a value of 0.
An item must be assigned to precisely one base price group. Additional price groups are assigned via the ADDITIONAL_PRICE_GROUP element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute is used to reference a PRICE_FEATURE_GROUP.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE PRICE_MINIMUM_BASIC BASIC_PRICE_UNIT VALID_FROM VALID_UNTIL
annotation
documentation
This element is used to specify the item price and additional price data.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This element is used to specify the price field for the price.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE >
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
The prices according to their price groups (price field, element PRICE_FIELD) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.
(Example: EUR -9.00 corresponds to -900)
If a price of 0 is entered, the item is free of charge within this price group. If an item within a price group is unavailable, the PRICE_FEATURE_GROUP_BASE_PRICE_REF of the item does not contain an element for the corresponding price group.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC >
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
This element is used to enter minimum prices or base prices. The prices are entered in accordance with their price groups (price field, PRICE_FIELD).
If the price type referenced by the item is not base price-dependent, the minimum price is entered, otherwise a base price. If a price of 0 is entered, the item does not have a minimum or base price, but is also not free of charge.
The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Identification numbers are entered without decimal places. Settlement points are entered with exactly 2 decimal places (excluding the decimal point itself).
If an item within a price group is unavailable, no data record of the corresponding price group is specified.
The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price.
The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined by the price type (path1/PRICE_TYPE_REF). Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.
The effective item prices are collated as follows:
The dimensions of the base price unit (path2/BASIC_PRICE_UNIT) must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions. To calculate the price for the infill dimensions, the logic from the price type in conjunction with the item price (path2/PRICE) is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.
This element must be specified for an item if the item's price type (Path 1/PRICE_TYPE_REF) is base price-dependent.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT >
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999999 |
annotation
documentation
If a price type (path 1/PRICE_TYPE_REF) is defined as base price-dependent, the dimensions for the base price unit must be specified here. The base price unit depends on the number of dimensions specified as "1 or true" in the price type.
If, for example, the base price of a length-dependent item relates to 1.5 m, the value of 1500 bees is entered in this element. In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³].
If they are piece prices, i.e. no dimension was specified as ?1?, the value 0 must be entered in this element.

Element paths:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/VALID_FROM

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/VALID_FROM >
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_SINCE must not contain a date prior to the catalogue start date.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/VALID_UNTIL

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/VALID_UNTIL >
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank if the range is unrestricted.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF/@PRICE_TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_TYPE_REF/@PRICE_TYPE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies a price type.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_REF PRICE_TYPE_REF
annotation
documentation
This element is used to reference PRICE_FEATURE_GROUPS with additional price groups. The base price group that must be referenced precisely 1x by an item is specified in the PRICE_FEATURE_GROUP_BASE_PRICE_REF element.

The following combinations are permitted when assigning different price types to items and surcharges for the same item:

Item Surcharge
Unit price Unit price
length-dependent length-dependent
length-dependent Unit price

The following combination is not permitted:

Item Surcharge
Unit price length-dependent


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF >
diagram
properties
content complex
children ITEM_PRICE
annotation
documentation
This element is used to reference a surcharge group. Surcharge groups referenced here must not be used as design ranges.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/@PRICE_FEATURE_GROUP_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/@PRICE_FEATURE_GROUP_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute is used to reference a PRICE_FEATURE_GROUP.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children PRICE_FIELD PRICE
annotation
documentation
This element is used for the item price and additional price information.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_FIELD

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE_FIELD >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
This element is used to specify the price field for the price.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE >
diagram
type restriction of xs:integer
properties
content simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
The prices according to their price groups (price field) are entered in this field. The prices must always be specified in the smallest currency unit (e.g. EUR 300.00 = 30000 cents). Negative prices can also be entered in this field. Negative prices are designated with the "-" symbol before the number. The number of digits for negative values is one less than for positive values. The first digit following the minus sign must not be 0. Spaces are not permitted.
(Example: field with 9 digits. The value of minus EUR 9.00 is entered as -900)


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF >
diagram
properties
content complex
annotation
documentation
This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element.

Element paths:
Path 1: PRICE_DEFINITION/PRICE_TYPES


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF/@PRICE_TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_TYPE_REF/@PRICE_TYPE_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute identifies a price type.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MINIMUM_PRICE
diagram
type restriction of xs:integer
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | -99999999 |
maxInclusive | 999999999 |
annotation
documentation
This element states the minimum price of an item.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
This element is used to combine product item-specific rules.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISION_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISION_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference a rule assigned to an item.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISION_REF/@DECISION_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISION_REF/@DECISION_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to reference a rule.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTIONAL_ITEMS MANDATORY_ITEMS
annotation
documentation
This element is used to assign additional items. It defines quantities of optional and/or necessary additional items, from which the additional items will be selected during planning.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTIONAL_ITEM_GROUP
annotation
documentation
This element is used to reference optional additional items. Multiple items may be selected from the available optional additional items.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP >
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children GROUP_TITLE ITEM_REF
annotation
documentation
This element is used to form a group of optional items.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@SET_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@SET_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9 |
annotation
documentation
A quantity of optional additional items can be defined for each item. Multiple additional items may be selected from the available optional additional items if MULTIPLE_CHOICE = true. If only one item is defined within a quantity of optional additional items, the item will be selected automatically.
1-9= status for defining the quantities of optional additional items.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@MULTIPLE_CHOICE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/@MULTIPLE_CHOICE >
type xs:boolean
properties
use required
annotation
documentation
This attribute specifies whether multiple selections within the group are permitted.
true = multiple selection permitted


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/GROUP_TITLE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/GROUP_TITLE >
diagram
type | languagetext60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element is used to designate the group of optional items.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference an optional additional item.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the serial number of the referenced series.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to enter the item code.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@OPTIONAL_QUANTITY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/ITEM_REF/@OPTIONAL_QUANTITY >
type restriction of xs:nonNegativeInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Quantity of additional items. Suggested value for planning systems. The quantity is a non-binding suggestion for optional additional items; for mandatory items, the quantity is binding during planning.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MANDATORY_ITEM_GROUP
annotation
documentation
This element is used to assign necessary additional items to an item. Only one additional item may be selected from the available additional items. An item may however be assigned multiple quantities of necessary additional items.
If only one additional item is assigned to a quantity, the item will be selected automatically.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP >
diagram
properties
minOcc | 1
maxOcc | 9
content | complex
children ITEM_REF
annotation
documentation
This element is used to form a group of necessary items. Precisely one item must be selected from this group.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/@SET_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/@SET_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9 |
annotation
documentation
For each item, a quantity of optional additional items and nine quantities of mandatory additional items can be defined.
Multiple additional items may be selected from the available optional additional items. For each quantity, only one item may be selected from the quantities of mandatory additional items.
If only one item is defined within a quantity of mandatory additional items, the item will be selected automatically.
1-9= status for defining the quantities of mandatory additional items.
This element is not necessary, but is retained in IDM 2.0 for reasons of compatibility to ISM 1.7.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references an item.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the serial number of the referenced series.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to enter the item code.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@MANDATORY_QUANTITY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/MANDATORY_ITEMS/MANDATORY_ITEM_GROUP/ITEM_REF/@MANDATORY_QUANTITY >
type restriction of xs:nonNegativeInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
Quantity of additional items. Suggested value for planning systems.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EDP_NUMBER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to enter the internal) item EDP number of the manufacturer.
If the EDP_NUMBER is used, it must be unique within a series and created for all items.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EAN_NUMBER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 15 |
annotation
documentation
If existing, the EAN number of the item must be entered in this element.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_IDENTIFICATION
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [K123] |
annotation
documentation
This element is used to assign an identifier to the item:
K = Catalogue item
1 = Planning proposal
2 = Preferred combination
3 = preferred combination with pricing on individual item level

The following applies for the planning proposal (1):
The individual items in the part list can accept the default values. There must not be any sub-positions that are only sub-positions and that cannot be ordered individually. Only the resulting items are ordered. The composition itself never appears in the order forms. The positions are eliminated and options passed down in the planning. The individual positions must then be positioned in the magnet planner in their order from left-to-right. Planning suggestions may contain preferred combinations.

The following rules apply to preferred combinations:
It must not contain a planning suggestion. If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies. The pricing takes place exclusively on main position level.

The price for the preferred combination with pricing on individual item level results from the main position and the individual items.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CATALOG_PAGE
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 7 |
annotation
documentation
This element should be used to specify the item's catalogue page. This information helps to quickly find an item within the printed catalogue.
Items may feature on multiple catalogue pages. In this case, the number of the page on which the item appears first should be used. In the case of accessories, it makes sense to use the page that contains a full description of the item. This is often done in the section/register "accessories".


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element specifies the date on which the item becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank if the range is unrestricted.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/WEIGHT_BRUTTO
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This element is used to specify the item gross weight (100 g), i.e. including packaging material. (e.g. 50 = 5000 g).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/WEIGHT_NETTO
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This element is used to specify the item net weight (100 g), i.e. excluding packaging material. (e.g. 50 = 5000 g).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/VOLUME
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This element is used to specify the item volume [dm³] including packaging material. (e.g. 50 = 50 dm³)


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/MINIMUM_DELIVERY_TIME
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This element is used to specify the minimum delivery time in weeks.
The minimum delivery time is for information, the planning software does not interfere with the order controlling (e.g. postponement of the order, partial delivery).


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CARCASE_BASIC_SHAPE ITEM_DIMENSIONAL_DRAWING
annotation
documentation
This element is used to specify the basic shapes assigned to an item.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE >
diagram
properties
content complex
children BASIC_PROFILE_SHAPE BASIC_SHAPE_PARAMETERS
annotation
documentation
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation. If there are no parameter values for items with basic shape = 0, parameters must be filled with a value of 0.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/@CARCASE_BASIC_SHAPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/@CARCASE_BASIC_SHAPE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]|[1-4][0-9]|5[0-2]|99[2-9] |
annotation
documentation
This element is used to enter the basic shape number. In addition to the assigned basic shape numbers, the following values are possible:
0 = Items that are irrelevant for visual presentation and/or for which the manufacturer prohibits visual presentation in the dealership system. If possible, the parameters for width, height and depth must be specified for items that are irrelevant for visual presentation.
If no parameters are specified for the basic shape, the BASIC_PROFILE node can be omitted in the place of specifying the basic shape parameters as 0.
999 = items that are relevant for visual presentation, but for which no basic shape exists and that are visualised by a graphic model (also see MODELING_GRAPHIC_ID element). The parameters for width, height and depth must also be specified when using real visual presentations.
998 = items for which there is no basic shape or real visual presentation.
997 = items for which neither a basic shape nor a real visual presentation are delivered. For this, the SUBCONTRACTOR_ID and SUBCONTRACTOR_ITEM_NO must be filled and the manufacturer must ensure that the supplier's graphical information is available.
996 = items that are relevant for visual presentation, but for which no graphical information are delivered. This basic shape no. only applies to filling levels lower than 3.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE >
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children OPTION_REF
annotation
documentation
Here, a basic shape that describes the profile geometry is referenced. The dimensions of the profile must be specified in accordance with the parameters specified in the basic shape.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/@BASIC_PROFILE_SHAPE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/@BASIC_PROFILE_SHAPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [\S ]{1,5} |
annotation
documentation
This element is used to specify the number of the basic profile shape.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF >
diagram
properties
content complex
annotation
documentation
The version type and version code for the profile shape version are specified here.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to specify a version type.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_PROFILE_SHAPE/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version that is to be assigned to a basic profile shape.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS >
diagram
properties
content complex
children BASIC_SHAPE_PARAMETER
annotation
documentation
This element is used to assign graphically relevant parameters with corresponding values to the item.

The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.

If the values in the elements BASIC_SHAPE_NOMINAL_VALUE (path 1), BASIC_SHAPE_FROM (path 1) and BASIC_SHAPE_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.

For items with a basic shape number = 0 that do not have any dimensions, such as calculation positions (e.g. surcharge for feet shape), the parameters must be filled with 0.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to specify the values of the parameters describing a basic shape.
If an item that is not relevant for visual presentation is created and the item does not have any parameters, then the superordinate node BASIC_PROFILE can be omitted instead of filling the parameters with 0.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NAME

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NAME >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{1,13} |
annotation
documentation
This attribute is used to specify the parameter name.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NOMINAL_VALUE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_NOMINAL_VALUE >
type restriction of xs:decimal
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until). The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_FROM

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_FROM >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_TO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_TO >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_STEP_SIZE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER/@BASIC_SHAPE_STEP_SIZE >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING >
diagram
properties
content complex
children DOCUMENT_REFERENCE DIMENSIONAL_PARAMETERS
annotation
documentation
This element is used to specify a dimensional drawing for which the parameters are specified in the DIMENSIONAL_PARAMETERS element. The dimensional drawing describes additional items.
The element must not be created if the BASIC_PROFILE_SHAPE already exists.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/@ITEM_DIMENSIONAL_DRAWING_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/@ITEM_DIMENSIONAL_DRAWING_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 20 |
annotation
documentation
This element is used to specify a dimensional drawing for which the parameters are specified in the PARAMETERS element. The dimensional drawing describes additional items.
Even if this element is not specified, at least the dimensions of the bounding box (w, h, d) must be specified in the BASIC_PROFILES/PARAMETERS element.
the element must not be created if the BASIC_PROFILE_SHAPE already exists.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DOCUMENT_REFERENCE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DOCUMENT_REFERENCE >
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 240 |
annotation
documentation
The name of a document or a reference to a document is specified in this field.
The documents may e.g. contain additional technical information about the installation or templates for cutouts and drilling.
If only the document name is specified, the document must be delivered with the data. A document reference is specified for an URI/URL.
If a document reference is specified in this element, the NAME element must be set to 23. The value of 23 stands for document reference (see value tables).


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS >
diagram
properties
content complex
children DIMENSIONAL_PARAMETER
annotation
documentation
This element is used to assign graphically relevant parameters with corresponding values to the item.
The item dimensions allowed for by the factory are described here. If item dimensions that fall outside of the specified dimension ranges are required, these will be custom-made products. Custom-made products must be coordinated with the manufacturer.
If the values in the elements DIMENSIONAL_NOMINAL_VALUE (path 1), DIMENSIONAL_FROM (path 1) and DIMENSIONAL_TO (path 1) are identical, these parameters must be left unchanged, it is neither possible to change these parameters to custom-made product in the factory.
If the created item is an electrical appliance, the dimensions W, H and D of that appliance must be specified.
If absolutely necessary (e.g. for diagonal corner infill pieces), the values for basic shapes 21, 24 and 25 may be specified in 1/10 mm. Beispiel: 27,3 mm =&gt; Elementinhalt : 0027.3
This element can only be omitted from an item if the item has basic shape number 0 assigned to it and no dimensions, such as for calculation positions (e.g. surcharge for or handle).

Path1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to specify the values of the parameters describing a basic shape.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NAME

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NAME >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9a-zA-Z]{1,13} |
annotation
documentation
This attribute is used to specify the parameter name.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NOMINAL_VALUE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_NOMINAL_VALUE >
type restriction of xs:decimal
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Each parameter is assigned a fixed nominal value, and optionally a value pair (from, until) The variable parameters can, for example, be helpful for the mapping of permitted width reductions.
The unit used for lengths is [mm] without any decimal places, for angles the unit is [°] with 3 digits before and 3 digits after the decimal sign.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_FROM

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_FROM >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This element contains the smallest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the element must be left blank.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_TO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_TO >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This field contains the largest dimension available for delivery and must be filled if the item is flexible within this parameter's range. If the parameter is not flexible, the field must be left blank.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_STEP_SIZE

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILE/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER/@DIMENSIONAL_STEP_SIZE >
type restriction of xs:decimal
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
Increments may be specified for variable parameters. The unit of measure is the unit of measure of the parameter. The increment must be smaller than the difference between the from and until value.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT
diagram
properties
content complex
children SHORT_TEXT FULL_TEXT PLANNING_ADVICE
annotation
documentation
This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. At least one item text must be specified for each item.
The following text combinations are permitted:
- Short text;
- Short text + recommended text;
- Short text + recommended text + long text;
- Short text + long text (only if no recommended text is been stored).
The short text may consist of three lines.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT >
diagram
properties
content complex
children LANGUAGE


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID >
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE >
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
children TEXT
annotation
documentation
This element is used to specify a line of text.
The SEQUENCE_NO attribute is used to specify the order of the text line. The order of the text line must be specified because it cannot be assured that the originally specified order of elements is retained during processing of the XML data.
The TEXT element contains the text.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute defines the order of the text line in a text of multiple lines. The value 1 is entered for a text with a single line.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT >
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.
This element contains the full text in a CDATA node.
The text must be specified in HTML format:
b bold font
br line break


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE >
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains planning advice.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY
diagram
properties
content complex
children TK_TYPE
annotation
documentation
This element is used to define the item's model code.
The values for model codes can be found in a table in the introduction, section model code.
The model code is specified precisely once for each item.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE >
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
maxInclusive | 26 |
annotation
documentation
A value from row type in table "model code" in the introduction is entered here.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CLASSIFICATION
annotation
documentation
This element is used to store standardized classifications.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION_CODE VALID_FROM VALID_UNTIL
annotation
documentation
This element contains the characteristics of a classification scheme.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
pattern | ([1-9]{1}|1[0]{2}) |
annotation
documentation
This attribute specifies the classification scheme. The values in the following list are available to choose from:

ID Classification scheme
1 eCl@ss
2 Begros organisation classification
3 VME organisation classification
4 Eco Mobilier code
5 eco system EEE
6 free classification scheme
7 free classification scheme
8 free classification scheme
9 free classification scheme
10 free classification scheme

If the scheme that is to be maintained is not in the list, then an ID from 6 is to be chosen for free classification scheme.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE >
diagram
type xs:string
properties
content simple
annotation
documentation
This element contains the code for the category of the classification scheme that is to be assigned to the ITEM.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM >
diagram
type xs:date
properties
content simple
annotation
documentation
This element indicates the date from which the classification specification is valid.


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL >
diagram
type xs:date
properties
content simple
annotation
documentation
This element indicates the date until which the classification specification is valid.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF


element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF

 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to directly assign precisely 1 version to the figure.
The assignment is done via DETAIL_INFO_NO and DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).
This assignment must only be used for magnet planner figures (assignments).
Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this version here.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced detailed information.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DECISION_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@DECISION_NO >
type restriction of xs:positiveInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) must be specified within a preparation rule.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute allows for the specification of detailed information for the item with a freely-defined sorting order.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SALES_NUMBER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
If existing, the sale number of the item must be entered in this element.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PART_LIST_REF
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
annotation
documentation
This element references a piece list contained in an item.
The item passes on its versions (OPTIONS) to the sub positions if these have identical version types (FEATURES) in the version family associated with the respective sub-position.
The sub-positions can have rules that determine whether a sub-position is displayed. The sub-position is then specified with the corresponding piece quantity.
Items that are only permitted as sub-positions are marked separately (element PARTS_LIST_EXCLUSIVE).
If the item is a catalogue item (ITEM_IDENTIFICATION 'K'), prices may be assigned to the item.The total price of the catalogue item results from the price assigned to it and the prices of the components from the piece list.
The following applies for the planning proposal (ITEM_IDENTIFICATION '1'):
The individual items in the piece list can accept the default values.
There must not be any sub-positions that are only sub-positions and that cannot be ordered individually.
Only the resulting items are ordered. The composition itself never shows in the order forms.
The positions are eliminated and versions passed down in the planning.
The individual positions must then be positioned in the magnet planner in their order from left-to-right.
Planning suggestions may contain preferred combinations.
The following rules apply to preferred combinations (ITEM_IDENTIFICATION '2'):
It must not contain a planning suggestion.
If a preferred combination is eliminated (e.g. by deleting a sub-position), the individual prices are newly determined for the individual positions, and the price advantage no longer applies.
The pricing then takes place exclusively on main position level.


attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PART_LIST_REF/@PART_LIST_KEY

 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PART_LIST_REF/@PART_LIST_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to specify the piece list key.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PART_LIST_EXCLUSIVE
diagram
type restriction of xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to identify whether the item is only permitted as a sub position within a piece list (value set to 1 (true)).
The value 0 (false) has the same meaning as no value at all.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
This element is used to combine product group-specific rules.


 element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/DECISIONS/DECISION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference a rule assigned to a product group.


 attribute T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/DECISIONS/DECISION_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to reference a rule.


 element T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children COLOR_CONSULTANCY
annotation
documentation
This element is used to define colour consultancies.
Each colour consultancy COLOR_CONSULTANCY contains any number of references to combinations of detailed information and assessments FEATURE_DETAIL_INFO_REF, which are sorted by SEQUENCE_NO. The applied assessments must contain colour variations.


 element T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FEATURE_DETAIL_INFO_REF
annotation
documentation
This element is used to directly assign image layers to rules.
The applied rules must contain colour versions.


 attribute T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY/@COLOR_CONSULTANCY_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This attribute defines the colour consultancy number.


 element T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY/FEATURE_DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element allows for the assignment of precisely one assessment or rule to the image layers.
The assessment and/or rule must contain a colour version type. The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO. Either an assessment (RESTRICTION) or rule (DECISION) can be assigned.


 attribute T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY/FEATURE_DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute references a detailed information.


 attribute T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY/FEATURE_DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute defines the order of the colour consultancy.


 attribute T_NEW_CATALOG/SERIES/SERIE/COLOR_CONSULTANCIES/COLOR_CONSULTANCY/FEATURE_DETAIL_INFO_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute references a rule.


 element T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.


 element T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference the detailed information.


 attribute T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced detailed information.


 attribute T_NEW_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute allows for the specification of detailed information for the series with a freely-defined sorting order.


 element T_NEW_CATALOG/SERIES/SERIE/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element specifies the date on which the series becomes available for delivery.
If this element is left blank, the CATALOG/VALID_FROM_DATE element will apply.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date.


 element T_NEW_CATALOG/SERIES/SERIE/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element specifies the date until which the item is available for delivery. If the date element is left blank, the item is available for delivery indefinitely.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank if the range is unrestricted.


 element T_NEW_CATALOG/SERIES/SERIE/OPTIONAL_CONNECTION
diagram
type restriction of xs:boolean
properties
content | simple
default | 0
annotation
documentation
This element makes it possible to allow further connection options beyond the standard connection options.
0 = no additional connection options, only the connection options described in the 2D documentation
1 = additional connection options AVN1-n to AVL and AVS1-n to AVR


 element T_NEW_CATALOG/SERIES/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
This element is used to collect cross-series rules.


 element T_NEW_CATALOG/SERIES/DECISIONS/DECISION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference a cross-series rule.


 attribute T_NEW_CATALOG/SERIES/DECISIONS/DECISION_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to reference a rule.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SERIE_GROUP
annotation
documentation
This element can be used to combine different series in groups (model groups).


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children SERIE_REF SERIE_GROUP_TEXT DETAIL_INFOS
annotation
documentation
A model group (combination of multiple series) is defined here.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/@SERIE_GROUP_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute assigns unique identifiers to series groups/model groups.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
This attribute allows for the specification of series groups with a freely-defined sorting order.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/SERIE_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference series.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/SERIE_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to reference a series.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/SERIE_REF/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
This attribute defines the order of the series within a series group.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/SERIE_GROUP_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to specify the designation of the series group/model group.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element is used to specify detailed media information, such as milieu photos, PDFs or video links.


 element T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference the detailed information.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute references a detailed information.


 attribute T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute allows for the specification of detailed information for the series group with a freely-defined sorting order.


 element T_NEW_CATALOG/PART_LISTS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PART_LIST
annotation
documentation
This element is used to assemble dynamic piece lists, with the sub-positions assigned to rules that determine depending on the version in which quantity the respective position exists in the piece list.
Only items in a corresponding series or items of series 0 are contained.
A contained item may however contain a piece list.
The item that contains a piece list passes on its versions (OPTIONS) to the sub positions if these have identical version types (FEATURES) in the version family associated with the respective sub-position.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PART_LIST_POS
annotation
documentation
This version is used to define a piece list.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/@PART_LIST_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a piece list.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/@INCLUDE_INORDER
type xs:boolean
properties
use | optional
default | 0
annotation
documentation
This attribute can be assigned to a part list. The value true (1) means that the part list is included as an item in an order. The value false (0) means it is not in the order, and the default value is true.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children SEQUENCE_NO ITEM_REF DECISIONS POS_COUNT_VALUE DECISION_POS_COUNT POS_INVISIBILITY CONFIGURATION_MODE
annotation
documentation
This element is used to describe the piece list positions.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/@INCLUDE_INORDER
type xs:boolean
properties
use | optional
default | 0
annotation
documentation
This attribute can be assigned to any position in the part list. The value true (1) means that the position is included in an order. The value false (0) means it is not in the order, and the default value is true.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/SEQUENCE_NO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute allows for the specification of piece lists with a freely-defined sorting order.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/ITEM_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference an item.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference an item with an item number.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the serial number of the referenced item.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
The rules for the corresponding piece list position are collected in this element. It thereby influences the versions and dimensions available for this position.
A rule with a quantity factor must not be specified here.Thisrule is referenced via DECISION_POS_COUNT.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISIONS/DECISION_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element references a rule corresponding to the piece list position and thereby influences the dimensions and versions available for this position. A rule with a quantity factor must not be specified here.The rule is referenced via DECISION_POS_COUNT.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISIONS/DECISION_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to reference a rule.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/POS_COUNT_VALUE
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
This element is used to specify the quantity of the item in the piece list.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISION_POS_COUNT
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION_REF
annotation
documentation
This element is used to specify a rule that sets the quantity factor.The maximum number is one for each position.This rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible version combinations.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISION_POS_COUNT/DECISION_REF
diagram
properties
content complex
annotation
documentation
This element references a rulethat determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible version combinations.


 attribute T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/DECISION_POS_COUNT/DECISION_REF/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to reference a rule that determines the quantity factor. This type of rule is specifically identified via the attribute DECISION_TYPE 3 (with OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) and determines how often the position appears depending on possible version combinations.


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/POS_INVISIBILITY
diagram
type restriction of xs:boolean
properties
content | simple
default | 0
annotation
documentation
This element controls the visibility of a position in the configurator. The invisibility only applies to the specific position, not to a potentially existing sub-tree. This means that invisibility must in this case be specified at each sub-position.
0 = completely visible
1 = fully invisible


 element T_NEW_CATALOG/PART_LISTS/PART_LIST/PART_LIST_POS/CONFIGURATION_MODE
diagram
type restriction of xs:nonNegativeInteger
properties
minOcc | 0
maxOcc | 1
content | simple
default | 0
facets
Kind | Value | Annotation
maxInclusive | 2 |
annotation
documentation
A CONFIGURATION_MODE value can be given for each PART_LIST_POS element:

0 = configuration allowed for non-inherited versions
1 = fully configurable
2 = configuration not permitted

The default value is 0.


 element T_NEW_CATALOG/FEATURE_DEFINITION
diagram
properties
content complex
children FEATURE_CLASSES FEATURES OPTION_DEFINITION DECISIONS OPTION_GROUPS FORMULAS
annotation
documentation
This element is used to specify version-specific information.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES
diagram
properties
content complex
children FEATURE_CLASS
annotation
documentation
This element is used to combine version types in families. These version families can be used to carry out plausibility and completeness checks with respect to the valid version types.

The defined version families (path 1) can be assigned to series or product groups via FEATURE_CLASS_REF in SERIE and PRODUCT_GROUP. There is no relationship with respect to a priority between version families on series and item level. The number of version types that are valid for an item results from the total number of version types declared in the items product group.

All version types that are referenced via the elements in PRICE_FEATURE_GROUP (path 3), PRICE_FEATURE_BASE_PRICE_GROUP_REF (path 4), FINISH (path 5) and PERCENTAGE_SURCHARGE (path 5) must be contained in the version family of the item.

The version types used via the rules ( elements DECISION_REF (path 6, 7 and 8)) must also be contained in the item's version family.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
Path 2 : FEATURE_DEFINITION/FEATURES
Path 3 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Path 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 5 : PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Path 6 : SERIES/DECISIONS/DECISION_REF
Path 7: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Path 8: SERIES/SERIE/DECISIONS


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FEATURE_REF
annotation
documentation
This element is used to define a version family.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/@FEATURE_CLASS_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to identify a version family.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/FEATURE_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This version type refers to the FEATURE (path 1) element.
Only helpful versions must be referenced in the version family of an item. Example: the version family vacation must not contain any version types for feet shapes.

Element paths
Path 1 : FEATURE_DEFINITION/FEATURES


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/FEATURE_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS/FEATURE_REF/@INVISIBLE
type xs:boolean
annotation
documentation
If the value of this attribute is set to true (or 1), it specifies that the corresponding version type is invisible.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES
diagram
properties
content complex
children FEATURE
annotation
documentation
This element is used to define the version types (FEATURE) and the associated versions. Only the version types needed for correctly mapping the catalogue are defined.

The combination of finish and colour is used for some version types.

If this is the case, version types must always be created in pairs. The corresponding colour version type exists for the respective finish version types; a corresponding finish version type exists for the colour version type.

Version types declared as invisible version types are not be referenced in a version family.

All version types in the FEATURES (path 3) element that are not declared as invisible head version type must be referenced in at least one version family.

Further information about version types can be found in the Introduction in section "version types"

Element paths
Path 1 : FEATURE_DEFINITION/FEATURES
Path 2: FEATURE_DEFINITION/FEATURES/FEATURE
Path 3: FEATURE_DEFINITION


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTIONS FEATURE_TEXT SEQUENCE_NO HEADER_POS_VARIATION_TYPE FEATURE_TYPE DETAIL_INFOS
annotation
documentation
This element is used to define a version type.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to identify a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTION
annotation
documentation
It is a container element in which the possible variations of a version type are stored.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children MATERIAL_REF OPTION_MEASURE_REF OPTION_TEXT OPTION_COMMENT_TEXT VALID_FROM VALID_UNTIL DETAIL_INFOS OPTION_FREETEXT
annotation
documentation
This element is used to define the versions for the superordinate version type.All versions necessary in the data pool are stored here. If the version to be created is a variation version (introduction: table version types identified by type A), no colour values must be specified.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
This attribute allows for the specification of a freely-defined sorting order.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/MATERIAL_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a material.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/MATERIAL_REF/@MATERIAL_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used to reference a material.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_MEASURE_REF
diagram
properties
content complex
annotation
documentation
This attribute is used to reference a dimensional variation of a version type.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_MEASURE_REF/@OPTION_MEASURE_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute is used to reference a dimension variation.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to define a version text.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_COMMENT_TEXT
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element is used to reference a general comment as a notice of special properties of a version. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements,
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FRONT element is filled: available for delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank if the range is unrestricted.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
These elements VALID_FROM and VALID_UNTIL are used to define the modified validity periods of versions.
If the validity periods have expired, the user of the planning system will be given a warning notice. Use of the version is continued for the planning. The following conditions apply for filling the elements:
Both elements filled: available for delivery in the resulting period.
Both elements left blank: always available for delivery.
Only the VALID_FRONT element is filled: available for delivery from this date onwards.
Only the VALID_UNTIL element is filled: only available for delivery until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank if the range is unrestricted.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element is used to assign media. It is possible to assign a number of detail information to one version, and each image of the version can then be assigned to specific series or items. The respective image will then only be displayed for the corresponding series or item.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children SERIE_REF ITEM_REF
annotation
documentation
This element is used to reference the detailed information.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced detailed information.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute allows for the specification of detailed information for the options with a freely-defined sorting order.


element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF

 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference the series.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF/@SERIE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced series.


element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF

 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF >
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference an item.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@SERIE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@SERIE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the serial number of the referenced item.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@TYPE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@TYPE_NO >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference an item with an item number.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_FREETEXT
diagram
type restriction of xs:boolean
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
This element contains texts for version types.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/SEQUENCE_NO
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This element is used to specify a manufacturer-specific sorting for the version types.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the versions during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head versions (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [IKP] |
annotation
documentation
This element is an identifier that specifies whether a version type is an
I = implicit version type,
K = head version type, or
P = position version type.
It serves the purpose of controlling the processing method on head or position level, version types designated with a "P" must, according to the manufacturer, not be processed on head level.
Version types designated with an "I" are visible and result implicitly from other version types.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE
diagram
properties
content complex
children MEASURE
annotation
documentation
This element is used to identify the version type corresponding to the version. A version can be assigned dimensional variations (value of FEATURE_T "M"), colour variations (value of FEATURE_T "C") or other version types (value of FEATURE_T "O").


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE/@FEATURE_T
type restriction of xs:string
facets
Kind | Value | Annotation
length | 1 |
pattern | [MCO] |
annotation
documentation
This attribute is used to define the version type assigned to the version.
M = dimensional versions
C = colour versions
O = other versions


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE/MEASURE
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MEASURE_UNIT MEASURE_PARAMETER
annotation
documentation
If the versions assigned to the version type are dimensional versions, the dimensional information is entered in this element.
They consist of a dimensional parameter, the unit of measure and can then, for example, be used in the formulas of the rules (DECISIONS).


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE/MEASURE/MEASURE_UNIT
diagram
type measure_unit
properties
content simple
facets
Kind | Value | Annotation
enumeration | MMT |
enumeration | CMT |
enumeration | DMT |
enumeration | MTR |
enumeration | KTM |
enumeration | INH |
enumeration | FOT |
enumeration | YRD |
enumeration | MMK |
enumeration | CMK |
enumeration | DMK |
enumeration | MTK |
enumeration | INK |
enumeration | FTK |
enumeration | YDK |
enumeration | MGM |
enumeration | GRM |
enumeration | KGM |
enumeration | TNE |
enumeration | LBR |
enumeration | MMQ |
enumeration | CMQ |
enumeration | DMQ |
enumeration | MTQ |
enumeration | INQ |
enumeration | FTQ |
enumeration | YDQ |
enumeration | HLT |
enumeration | LTR |
enumeration | MLT |
enumeration | H87 |
annotation
documentation
This element is used to specify the unit of measure.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE/MEASURE/MEASURE_PARAMETER
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
maxLength | 20 |
annotation
documentation
This element is used to specify the parameters for defining a formula, e.g. planning width = 2 * st +sb,
with the parameters st for side unit width and sb for seat width.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element is used to assign media. It is possible to assign a number of detailed information points to one version, and each image of the version can then be assigned to specific series or items. The respective image will then only be displayed for the corresponding series or item.
The referencing of media (detailed information) to version types that also contain information on series or items may only be done once per medium, which means that if a number of series or items are referenced, then they all need to be listed when specifying the detailed information.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children SERIE_REF ITEM_REF
annotation
documentation
This element is used to reference the detailed information.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced detailed information.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute allows for the specification of detailed information for the features with a freely-defined sorting order.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference the series.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/SERIE_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced series.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference an item.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the serial number of the referenced item.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/DETAIL_INFOS/DETAIL_INFO_REF/ITEM_REF/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference an item with an item number.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children MATERIAL OPTION_MEASURE
annotation
documentation
This element is used to define the properties of colours, materials, shape versions and dimensions.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children COLOR
annotation
documentation
This element is used to define a material.
If the version to be created is a variation version (identified by A), no colour values (COLOR) must be specified.

Variation versions are defined via T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/@MATERIAL_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 5 |
annotation
documentation
This attribute is used to identify a material.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR
diagram
properties
content complex
children RGB_RED RGB_GREEN RGB_BLUE
annotation
documentation
This element is used to define colours.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR/RGB_RED
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 255 |
annotation
documentation
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR/RGB_GREEN
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 255 |
annotation
documentation
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/MATERIAL/COLOR/RGB_BLUE
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 255 |
annotation
documentation
These elements are used to specify a base colour (diffused reflection) of the material via the RGB value. It can only be used for single-colour materials.
0 = no colour intensity
255 = full colour intensity


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children MEASURE_VALUE MEASURE_UNIT
annotation
documentation
This element is used to specify the values of versions that are expressed in a dimension (e.g. backrest or cushion height).


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/@OPTION_MEASURE_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute identifies a dimensional variation.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/MEASURE_VALUE
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999 |
annotation
documentation
This element is used to specify the dimensions.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/MEASURE_UNIT
diagram
type measure_unit
properties
content simple
facets
Kind | Value | Annotation
enumeration | MMT |
enumeration | CMT |
enumeration | DMT |
enumeration | MTR |
enumeration | KTM |
enumeration | INH |
enumeration | FOT |
enumeration | YRD |
enumeration | MMK |
enumeration | CMK |
enumeration | DMK |
enumeration | MTK |
enumeration | INK |
enumeration | FTK |
enumeration | YDK |
enumeration | MGM |
enumeration | GRM |
enumeration | KGM |
enumeration | TNE |
enumeration | LBR |
enumeration | MMQ |
enumeration | CMQ |
enumeration | DMQ |
enumeration | MTQ |
enumeration | INQ |
enumeration | FTQ |
enumeration | YDQ |
enumeration | HLT |
enumeration | LTR |
enumeration | MLT |
enumeration | H87 |
annotation
documentation
This element is used to specify the unit of measure.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DECISION
annotation
documentation
This element is used to specify rules for versions and version types.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION
diagram
properties
minOcc | 1
maxOcc | 99999
content | complex
children DECISION_NAME_TEXT OPTION_COMBINATION VALID_FROM VALID_UNTIL FEATURE_REF PRIO
annotation
documentation
This element is used to define and describe a rule that maps technically feasible configurations.
The rules are assigned to series or items by references from the corresponding elements. In total, all rules defined in this element must be referenced from either series or items.

Depending on the DECISION_TYPE attribute, different rules can be specified.
If the value in DECISION_TYPE is 0 or 1, the rule is a "preparation rule".

This allows for the definition of invalid and/or valid versions in OPTION_COMBINATION. These are used to determine the valid versions of a version type. These rules do not have an action part ("ACTIONS") and they define a quantity of version combinations that are either true or false. This is a table with the version types (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, version groups that are linked by quantity operators.

The conditions are supplemented with operators. The special data type operator was defined for this purpose. It may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

The individual OPTION_COMBINATIONs must be considered as ELSE branches. This means that as soon as a condition line (OPTION_COMBINATION) receives a hit, the others will not be executed anymore.

If the value in DECISION_TYPE is 2, the rule is an action rule. It allows for the definition of actions depending on the conditions.

If all conditions within an „OPTION_COMBINATION“ are satisfied, all signed actions (ACTIONS) then can set values or make version types (FEATURES) invisible depending on conditions. If an OPTION_COMBINATION is satisfied, the other conditions are not processed.

Actions (ACTIONS)
are instructions that are executed if a condition is met. The following actions can be executed:
The setting of versions (SET_FEATURE_FIXED) with the following options:

Direct, e.g. main fabric = "blue" (OPTION)
the setting of version values from another version type (FEATURE), e.g. ledge fabric = main fabric
the calculation of versions (e.g. sitting height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the version type (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width)

The setting of standard versions (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
These can be filled if no value has been entered yet. The same options as above apply.

The visibility of version types (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
Example: for wooden feet, a potentially existing version type for a shade can be displayed and made invisible if a metal foot is selected.

Action rules are usually used in the configurator if an option value (a version) changes. If, for example, the foot version is changed from stainless steel to wood, a version type for the shade can be displayed.

If the value in DECISION_TYPE is 3, the rule is an action rule for piece lists. The quantity (SET_POS_COUNT_VALUE) in the piece list can be defined here depending on the conditions.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/@DECISION_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to identify the rule.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/@DECISION_TYPE
type restriction of xs:int
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 3 |
annotation
documentation
This attribute is used to specify the rule type.

0 = excluding preparation rule
This allows for the definition of invalid versions in OPTION_COMBINATION/FEATURE_REF. These are used to determine the invalid versions of a version type. These rules do not have an action part ("ACTIONS") and they define a quantity of version combinations that are either true or false. This is a table with the version types (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, version groups that are linked by quantity operators.

1 = Preparation rule
This allows for the definition of valid versions in OPTION_COMBINATION/FEATURE_REF. These are used to determine the valid versions of a version type. These rules do not have an action part ("ACTIONS") and they define a quantity of version combinations that are either true or false. This is a table with the version types (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, version groups that are linked by quantity operators.

2 = Action rule
It allows for the definition of actions in addition to the conditions.
The rules are analysed before a version is entered for an item.
Once a value has been selected, the action rules apply and then set values or make written types invisible.
For action rules, it is always the first line (OPTIONS_SET_REF) that applies. In this case, all associated ACTIONS are executed.

3 = Action rule for quantity in piece lists (PositionCounter Rule)
The quantity in the piece list can be defined here depending on the conditions via the action SET_POS_COUNT_VALUE.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/DECISION_NAME_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to specify the designation of a rule.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTIONS_SET_REF ACTIONS
annotation
documentation
This element is used to form a version combination that is linked to certain conditions.
If the value of DECISION_TYPE is 2 or 3, actions (ACTIONS) can also be assigned to the version combination.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/@SEQUENCE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element is used to specify the sequence in which the assigned assessment procedures will be executed.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTION_INTERVAL OPTION_LIST OPTION_GROUP_REF_OP OPTION_REF_OP OPTION_LIKE FEATURE_REF_OP MEASURE_VALUE_OP MEASURE_INTERVAL
annotation
documentation
This element is used to reference a version type and define a rule for its version variations. The rules may be defined via values, lists, intervals or version groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/@REF_LEVEL
type restriction of xs:nonNegativeInteger
properties
use optional
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
In piece lists, sub-positions can query version types of the main position (PARENT), the uppermost position (ROOT) and the item itself (SELF) via the REF_LEVEL and depending on them trigger an action or integrate the action in a condition.
1 = ROOT
2 = PARENT
3 = SELF (default is SELF if no REF level is specified)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_INTERVAL
diagram
properties
content complex
annotation
documentation
This element is used to evaluate whether a version falls within or outside of an interval.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a version is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.
in (is contained in a quantity)
nin (is not contained in a quantity)


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MIN
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to specify the starting value of the interval.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MAX
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to specify the end value of the interval.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST
diagram
properties
content complex
children OPTION_REF
annotation
documentation
This element is used to evaluate whether a version corresponds to a value in a list.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a version falls within or without a list of values.
in (is contained in a quantity)
nin (is not contained in a quantity)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference the options in a comparison list.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_GROUP_REF_OP
diagram
properties
content complex
annotation
documentation
This element is used to evaluate whether a version falls within a version group.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPTION_GROUP_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version group.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a version falls within a version group.
in (is contained in a quantity)
nin (is not contained in a quantity)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_REF_OP
diagram
properties
content complex
annotation
documentation
This element is used to define a comparison with a version.
The comparison operator may contain the following values:
eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_REF_OP/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to define a comparison with a version.
The comparison operator may contain the following values:
eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIKE
diagram
properties
content complex
annotation
documentation
This element is used to compare versions in text patterns.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIKE/@LIKE_VALUE
type restriction of xs:string
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This is where the comparison string is entered. Similar to the SQL comparison operator LIKE, it may contain the characters '_' for any character, and '%' for any string.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/FEATURE_REF_OP
diagram
properties
content complex
annotation
documentation
This element is used to directly compare the version type.
The comparison operator may contain the following values:
eq (equal)
ne (not equal)


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/FEATURE_REF_OP/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/FEATURE_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to define a comparison with a version type.
The comparison operator may contain the following values:
eq (equal)
ne (not equal)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_VALUE_OP
diagram
properties
content complex
annotation
documentation
This element is used to check the dimension of a version using another dimension.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_VALUE_OP/@MEASURE_VALUE
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute is used to specify the comparison dimension.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to define a comparison with a dimension.
The comparison operator may contain the following values:
eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL
diagram
properties
content complex
annotation
documentation
This element is used to evaluate whether a version's dimension falls within or outside of an interval.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.
in (is contained in a quantity)
nin (is not contained in a quantity)


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MIN
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute is used to specify the starting value of the interval.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MAX
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute is used to specify the end value of the interval.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_STEP
type xs:nonNegativeInteger
annotation
documentation
This attribute is used to specify the widths in the interval.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SET_FEATURE_DEFAULT SET_FEATURE_FIXED ENABLE_DECISION DISABLE_DECISION SET_FEATURE_VISIBLE SET_FEATURE_INVISIBLE SET_FEATURE SET_FEATURE_DEFAULT_NULL SET_POS_COUNT_VALUE SET_MESSAGE
annotation
documentation
This element is used to determine actions that are executed under certain conditions.

Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

- The setting of versions (SET_FEATURE_FIXED) with the following options:
° Direct, e.g. main fabric = "blue" (OPTION)
° the setting of version values from another version type (FEATURE), e.g. ledge fabric = main fabric
° the calculation of versions (e.g. sitting height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the version type (e.g. sitting height) to be assigned with a parameter (e.g. "sh"). The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

- The setting of standard versions (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
These can be filled if no value has been entered yet. The same options as above apply.

- The visibility of version types (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
Example: for wooden feet, a potentially existing version type for a shade can be displayed and made invisible if a metal foot is selected.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT
diagram
properties
content complex
children FEATURE_REF OPTION_REF FORMULA_REF
annotation
documentation
This action is used to set standard versions.

These can be filled if no value has been entered yet.

The following options are available for the setting of versions:

Directe.g. main fabric = "blue" (OPTION)
the setting of version values from another version type (FEATURE), e.g. ledge fabric = main fabric
the calculation of versions (e.g. sitting height + 5 cm).

This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the version type (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FEATURE_REF
diagram
properties
content complex
annotation
documentation
This element references another version type for the setting of version values.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FEATURE_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FEATURE_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/OPTION_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a version (OPTION) that is directly set as standard.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FORMULA_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a formula for the calculation of standard values.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FORMULA_REF/@FORMULA_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT/FORMULA_REF/@FORMULA_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a formula.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED
diagram
properties
content complex
children FEATURE_REF OPTION_REF FORMULA_REF
annotation
documentation
This action is used to set versions.

The following options are available for the setting of versions:

- Direct, e.g. main fabric = "blue" (OPTION)
- the setting of version values from another version type (FEATURE), e.g. ledge fabric = main fabric
- the calculation of versions (e.g. sitting height + 5 cm). This function is only available for dimension versions and takes place via a formula string that may contain parameters and values. This requires the version type (e.g. sitting height) to be assigned with a parameter (e.g. "sh"). The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FEATURE_REF
diagram
properties
content complex
annotation
documentation
This element references another version type for the setting of version values.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FEATURE_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FEATURE_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/OPTION_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a version (OPTION) that is set directly.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FORMULA_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a formula for the calculation of versions.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FORMULA_REF/@FORMULA_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_FIXED/FORMULA_REF/@FORMULA_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a formula.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/ENABLE_DECISION
diagram
properties
content complex
annotation
documentation
This action activates rules.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/ENABLE_DECISION/@DECISION_NO
type restriction of xs:positiveInteger
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to reference a rule.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/DISABLE_DECISION
diagram
properties
content complex
annotation
documentation
This action deactivates rules.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/DISABLE_DECISION/@DECISION_NO
type restriction of xs:positiveInteger
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999999999 |
annotation
documentation
This attribute is used to reference a rule.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_VISIBLE
diagram
properties
content complex
annotation
documentation
This action makes version types visible.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_VISIBLE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_INVISIBLE
diagram
properties
content complex
annotation
documentation
This action makes version types invisible.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_INVISIBLE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE
diagram
properties
content complex
children FEATURE_REF OPTION_REF FORMULA_REF
annotation
documentation
This action sets a value for a version of a version type. Contrary to „SET_FEATURE FIXED“, this value can be modified if permitted by the conditions. This value rule also applies if the corresponding field was previously set to default or manual.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FEATURE_REF
diagram
properties
content complex
annotation
documentation
This element references another version type for the setting of version values.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FEATURE_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FEATURE_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/OPTION_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a version (OPTION) that is set directly.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FORMULA_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a formula for the calculation of versions.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FORMULA_REF/@FORMULA_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE/FORMULA_REF/@FORMULA_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a formula.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL
diagram
properties
content complex
children FEATURE_REF OPTION_REF FORMULA_REF
annotation
documentation
This action is used to set standard versions.
The default value only applies if the relevant version field was previously blank.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FEATURE_REF
diagram
properties
content complex
annotation
documentation
This element references another version type for the setting of NULL.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FEATURE_REF/@FEATURE_NO

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FEATURE_REF/@FEATURE_NO >
type restriction of xs:nonNegativeInteger
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/OPTION_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a version (OPTION) that is set to NULL.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FORMULA_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference a formula for the calculation of versions.


attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FORMULA_REF/@FORMULA_KEY

 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_FEATURE_DEFAULT_NULL/FORMULA_REF/@FORMULA_KEY >
type restriction of xs:string
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a formula.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This version is used to set a quantity in the piece list.
This action must only be specified for rules with DECISION_TYPE = 3.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_MESSAGE
diagram
properties
content complex
annotation
documentation
This element is used to set a message for the purpose of triggering warnings or notices for certain version combinations.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/ACTIONS/SET_MESSAGE/@MESSAGE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to reference a message.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to specify the date from which date onwards a rule is valid.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element specifies the date until which a rule is valid.
Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank if the range is unrestricted.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/FEATURE_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference a version type.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/FEATURE_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/PRIO
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This element is used to specify a value for the priority of a rule.
A low value means a high priority. This means that the rule takes a lower priority the higher this value is.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children OPTION_GROUP
annotation
documentation
This element is use to group quantities of versions. They can be reference in the rules below OPTION_COMBINATION/FEATURE_REF in DECISIONS. These versions are to be considered an independent pool and have no connection to any version type.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children OPTION OPTION_GROUP_TEXT
annotation
documentation
This element is used to specify a version group.
It can be referenced in assessments belowOPTION_COMBINATION/FEATURE_REFin theDECISIONS. These versions are to be considered an independent pool and have no connection to any version type.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/@OPTION_GROUP_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to identify a version group.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/OPTION
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference a version.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/OPTION/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/OPTION/@SEQUENCE_NO
type restriction of xs:nonNegativeInteger
annotation
documentation
This attribute defines the order of the versions in a version group.


 element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/OPTION_GROUP_TEXT
diagram
type | languagetext60
properties
content complex
children | LANGUAGE
annotation
documentation
This element contains texts for version groups.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FORMULAS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FORMULA
annotation
documentation
This element is used for the calculation of versions (e.g. sitting height + 5 cm). The function is however only permitted for dimensional versions with a version type that contains the value "M", the unit of measure can be entered in MEASURE_UNIT, the parameter (e.g. sh for sitting height) in MEASURE_PARAMETER. The calculation is carried out via a formula string that may contain parameters and values.Das Rechnen geschieht über einen Formelstring, der Parameter und Werte enthalten darf.


 element T_NEW_CATALOG/FEATURE_DEFINITION/FORMULAS/FORMULA
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children FORMULA_STRING


 attribute T_NEW_CATALOG/FEATURE_DEFINITION/FORMULAS/FORMULA/@FORMULA_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |


 element T_NEW_CATALOG/FEATURE_DEFINITION/FORMULAS/FORMULA/FORMULA_STRING
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [+\-*/()A-Za-z0-9. ]* |
annotation
documentation
This element is used to specify a formula.


 element T_NEW_CATALOG/PRICE_DEFINITION
diagram
properties
content complex
children PRICE_FEATURE_GROUPS PRICE_TYPES
annotation
documentation
This element is used to specify information for the catalogue modification that is necessary for the price calculation, such as price tables and design ranges.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS
diagram
properties
content complex
children PRICE_FEATURE_GROUP
annotation
documentation
This element is used to define PRICE_FEATURE_GROUPS.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children PRICE_FEATURE_GROUP_TEXT FINISH PERCENTAGE_SURCHARGE
annotation
documentation
This element is used to specify price control information. The PRICE_FEATURE_GROUP is used to control the conditions under which a price (e.g. version combinations) applies.

A PRICE_FEATURE_GROUP is referenced by the item. The specific prices are also specified in the item.

The following rules apply to PRICE_FEATURE_GROUP and/or items:
- A price group-neutral item has zero versions, only price field 1 must be specified for these items.
- Variation-dependent items have one or a number of version types.
- An item must reference precisely one base price group (ADDITIONAL_PRICE=0).

Multiple PRICE_FEATURE_GROUPs with the same combination of version types are prohibited. Example: PRICE_FEATURE_GROUP with version type feet shape should only exist once and map everything that is related to the feet shape.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@PRICE_FEATURE_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute is used to reference a PRICE_FEATURE_GROUP.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/@ADDITIONAL_PRICE
type restriction of xs:boolean
properties
use required
annotation
documentation
Identifier whether the specified price is a base price or a surcharge. (0=base price, 1=surcharge)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_FEATURE_GROUP_TEXT
diagram
type | languagetext60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains texts for variation groups.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTIONS_SET_REF PRICE_FIELD SUPPLIER_PRICE_GROUP VALID_FROM VALID_UNTIL
annotation
documentation
This element is used to assign price fields (PRICE_FIELD) and a manufacturer price group to valid version combinations.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/@SEQUENCE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The price group is determined by the first matching version combination.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTION_INTERVAL OPTION_LIST OPTION_GROUP_REF_OP OPTION_REF_OP MEASURE_VALUE_OP MEASURE_INTERVAL
annotation
documentation
This element is used to reference a version type and define a price group for its version variations. The price groups may be defined via values, lists, intervals or version groups in conjunction with a quantity operator.
The simple data type operator was defined for this purpose and may contain the following values:
eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_INTERVAL
diagram
properties
content complex
annotation
documentation
This element is used to evaluate whether a version falls within or outside of an interval.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a version is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.
in (is contained in a quantity)
nin (is not contained in a quantity)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MIN
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to specify the starting value of the interval.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MAX
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to specify the end value of the interval.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST
diagram
properties
content complex
children OPTION_REF
annotation
documentation
This element is used to evaluate whether a version corresponds to a value in a list.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a version falls within or without a list of values.
in (is contained in a quantity)
nin (is not contained in a quantity)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference the options in a comparison list.


attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_GROUP_REF_OP
diagram
properties
content complex
annotation
documentation
This element is used to evaluate whether a version falls within a version group.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPTION_GROUP_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version group.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a version falls within a version group.
in (is contained in a quantity)
nin (is not contained in a quantity)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_REF_OP
diagram
properties
content complex
annotation
documentation
This element is used to define a comparison with a version.
The comparison operator may contain the following values:
eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_REF_OP/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to define a comparison with a version.
The comparison operator may contain the following values:
eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_VALUE_OP
diagram
properties
content complex
annotation
documentation
This element is used to check the dimension of a version using another dimension.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_VALUE_OP/@MEASURE_VALUE
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute is used to specify the comparison dimension.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to define a comparison with a dimension.
The comparison operator may contain the following values:
eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_INTERVAL
diagram
properties
content complex
annotation
documentation
This element is used to evaluate whether a version's dimension falls within or outside of an interval.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.
in (is contained in a quantity)
nin (is not contained in a quantity)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MIN
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute is used to specify the starting value of the interval.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MAX
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute is used to specify the end value of the interval.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/PRICE_FIELD
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 9999 |
annotation
documentation
These element specifies the price field in which the price of an item in this variation is specified. The corresponding price field with the associated price is specified in the ITEM_PREIS elements (path 1 or path 2).

In the case of the same catalogue being used across different customer groups, the price group allocations must not be changed. The same applies to correction files within the same product round.

Element paths
Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/SUPPLIER_PRICE_GROUP
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 10 |
annotation
documentation
This catalogue is used to specify the manufacturer's price group.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to specify the date from which date onwards a price field is valid.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to specify the date until which a price field is valid.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTIONS_SET_REF PRICE_FACTOR PRICE_FEATURE_GROUP_REF VALID_FROM VALID_UNTIL
annotation
documentation
To allow for percentage surcharges, the element FINISH supplemented below PRICE_FEATURE_GROUP by the element PERCENTAGE_SURCHARGE consisting of OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM and VALID_UNTIL.
This element must only be used for PRICE_FEATURE_GROUP's for which the attribute ADDITIONAL_PRICE is set to 1 (1=surcharge).
The percentage surcharge may refer to different PRICE_FEATURE_GROUPs:

Case 1
Base price 500.00
Surcharge headrest 50.00
Surcharge function 66.00
Surcharge seat heating 10% of base price --&gt; factor 0.1 * 500 = 50
Surcharge rapport base price 10% of base price + headrest --&gt; factor 0.1 * (500+50) = 55
Surcharge XY 20% on everything --&gt; factor 0.2 * (500+50+66+50+55) = 144.20
Position value = 865.20

Case 2
Base price 500.00
Surcharge seat heating 10% of base price --&gt; factor 0.1 * 500 = 50
Position value = 550.00

Case 3
Base price 500.00
Surcharge headrest 50.00
Surcharge function 66.00
Surcharge XY 20% of base price + headrest + function --&gt; factor 0.2 * (500+50+66)=123.20
Position value = 739.20

Case 4
Base price 500.00
Surcharge headrest 50.00
Surcharge function 66.00
Surcharge XY 20% of ( base price + headrest + function ) --&gt; factor 0.2 * (500+50+66)=123.20
Surcharge ZZ -10% of ( base price + function ) --&gt; factor 0.1 * (500+66)=56.60
Position value = 682.60

Case 5
Base price 500.00
Surcharge headrest 50.00
Surcharge function 66.00
Condition value 616.00
Surcharge Global1 10% on everything --&gt; factor 0.1 * 616 results in condition value = 61.60
Surcharge Global2 20% on everything --&gt; factor 0.2 * 616 results in condition value = 123.20
Position value = 800.80

The factor value must be specified in the PRICE_FACTOR element.
The price groups to which the percentage surcharge relates are specified under PRICE_FEATURE_GROUP_REF.
The validity is specified in the VALID_FROM and VALID_UNTIL elements.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/@SEQUENCE
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This element is used to specify the sequence in which the analyses will be executed. These configurators must in this order run through the individual elements of OPTION_SET_REF. The percentage surcharge is determined by the first matching version combination.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
children OPTION_INTERVAL OPTION_LIST OPTION_GROUP_REF_OP OPTION_REF_OP MEASURE_VALUE_OP MEASURE_INTERVAL
annotation
documentation
This element is used to reference a version type and defines a percentage surcharge for its version variations. The percentage surcharges may be defined via values, lists, intervals or version groups in conjunction with a quantity operator.

The simple data type operator was defined for this purpose and may contain the following values:
eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/@FEATURE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999 |
annotation
documentation
This attribute is used to reference a version type.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_INTERVAL
diagram
properties
content complex
annotation
documentation
This element is used to evaluate whether a version falls within or outside of an interval.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a version is within or without the interval specified in OPTION_KEY_MIN and OPTION_KEY_MAX.
in (is contained in a quantity)
nin (is not contained in a quantity)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MIN
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to specify the starting value of the interval.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_INTERVAL/@OPTION_KEY_MAX
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to specify the end value of the interval.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST
diagram
properties
content complex
children OPTION_REF
annotation
documentation
This element is used to evaluate whether a version corresponds to a value in a list.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a version falls within or without a list of values.
in (is contained in a quantity)
nin (is not contained in a quantity)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF
diagram
properties
content complex
annotation
documentation
This element is used to reference the options in a comparison list.


attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY

 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST/OPTION_REF/@OPTION_KEY >
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_GROUP_REF_OP
diagram
properties
content complex
annotation
documentation
This element is used to evaluate whether a version falls within a version group.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPTION_GROUP_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version group.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a version falls within a version group.
in (is contained in a quantity)
nin (is not contained in a quantity)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_REF_OP
diagram
properties
content complex
annotation
documentation
This element is used to define a comparison with a version.

The comparison operator may contain the following values:
eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_REF_OP/@OPTION_KEY
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This attribute is used to reference a version variation.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to define a comparison with a version.
The comparison operator may contain the following values:
eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_VALUE_OP
diagram
properties
content complex
annotation
documentation
This element is used to check the dimension of a version using another dimension.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_VALUE_OP/@MEASURE_VALUE
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute is used to specify the comparison dimension.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | eq|ne|gt|lt|ge|le |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to define a comparison with a dimension.
The comparison operator may contain the following values:
eq (equal)
ne (not equal)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_INTERVAL
diagram
properties
content complex
annotation
documentation
This element is used to evaluate whether a version's dimension falls within or outside of an interval.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR
type restriction of operator
properties
use required
facets
Kind | Value | Annotation
maxLength | 4 |
pattern | in|nin |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This attribute is used to evaluate whether a value is within the interval specified in MEASURE_MIN and MEASURE_MAX.
in (is contained in a quantity)
nin (is not contained in a quantity)


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MIN
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute is used to specify the starting value of the interval.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_INTERVAL/@MEASURE_MAX
type xs:nonNegativeInteger
properties
use required
annotation
documentation
This attribute is used to specify the end value of the interval.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/PRICE_FACTOR
diagram
type extension of xs:int
properties
content complex
annotation
documentation
This element specifies a percentage surcharge. It is specified with five decimal places.

A value of 1050000 corresponds to a surcharge of 10.5%, meaning a factor of 0.105.
A value of -1000000 corresponds to a surcharge of -10%, meaning a factor of -0.1.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/PRICE_FACTOR/@ROUNDING_TYPE
type restriction of xs:positiveInteger
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
This element specifies the type of rounding.
1 = rounding up
2 = rounding down
3 = commercial rounding


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/PRICE_FACTOR/@ROUNDING_SCALE
type restriction of xs:integer
facets
Kind | Value | Annotation
minInclusive | -3 |
maxInclusive | 2 |
annotation
documentation
This element indicates how many digits to round to.
-3 = round to 1000s
-2 = round to 100s
-1 = round to 10s
0 = round to 1s
1 = round to 1 decimal place
2 = round to 2 decimal places


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/PRICE_FEATURE_GROUP_REF
diagram
properties
minOcc | 0
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference a price group irrespective of the version type and/or calculation method (PRICE_FEATURE_GROUP).


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/PRICE_FEATURE_GROUP_REF/@PRICE_FEATURE_GROUP_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 99999 |
annotation
documentation
This attribute is used to reference a PRICE_FEATURE_GROUP.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/VALID_FROM
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to specify the date from which date onwards a percentage surcharge is valid.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/VALID_UNTIL
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element is used to specify the date until a percentage surcharge is valid.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES
diagram
properties
content complex
children PRICE_TYPE
annotation
documentation
This element is used to define the price types for piece or dimension-variable calculation of variation-neutral or variation-dependent items.
The child elements WIDTH_X, DEPTH_Y, HEIGHT_Z specify whether the price calculated for an item with this price type depends on the width, height, depth, surface area or volume.
If no dimension is specified as "1", the price does not depend on dimensions and is calculated on a per piece basis (e.g. for a sitting element). The values in BASIC_UNIT and ROUNDING_UNIT are then set to 0.
If "1" is set for a dimension, the price calculation will be based on this dimension (e.g. fabrics).
If exactly two dimensions are set to "1", the price is based on the surface area (e.g. carpets).
If exactly three dimensions are set to "1", the price is based on the volume (e.g. lounge sections).


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE
diagram
properties
content complex
children WIDTH_X DEPTH_Y HEIGHT_Z BASIC_UNIT ROUNDING_UNIT ROUNDING_TYPE BASIC_PRICE_DEPENDENT PRICE_TYPE_FORMULA PRICE_TYPE_NAME PRICE_TYPE_RULES
annotation
documentation
This version is used to define a price type.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/@PRICE_TYPE_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999 |
annotation
documentation
This attribute unequivocally identifies a defined price type.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/WIDTH_X
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
If the price that is to be calculated depends on the dimension width, this element is set to 1, otherwise it is set to 0.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/DEPTH_Y
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
If the price that is to be calculated depends on the dimension depth, this element is set to 1, otherwise it is set to 0.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/HEIGHT_Z
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
If the price that is to be calculated depends on the dimension height , this element is set to 1, otherwise it is set to 0.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/BASIC_UNIT
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999999 |
annotation
documentation
The base unit (BASIC_UNIT) specifies on which dimension the prices in the ITEM_PRICE (P1) and ADDITIONAL_PRICE (P2) elements relate.
The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one meter, the value in this element must be entered as "1000". In the case of a volume-dependent price, 1 m³ will be entered as "1000000000" [mm³]. If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0".

Path 1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ROUNDING_UNIT
diagram
type restriction of xs:nonNegativeInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999999999 |
annotation
documentation
The rounding unit (ROUNDING_UNIT) is used to specify the upward rounding for the length, the surface area and/or the volume. The unit of measure depends on the number of dimensions specified as "1". Possible options are: mm, mm² and mm³. If the price of a width-dependent item refers to one centimetre, the value in this element must be entered as "10". If they are piece prices, i.e. no dimension was specified as "1", the value "0" must be entered in this element. If the price is not a piece price, the value must be different from "0".


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ROUNDING_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 3 |
annotation
documentation
To specify the different types of the rounding, the ROUNDING_UNIT element is supplemented with the element ROUNDING_TYPE, with possible values being 1, 2 and 3, that identifies commercial rounding (up and down).

The values have the following meaning:
1 rounding up
2 rounding down
3 commercial rounding


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/BASIC_PRICE_DEPENDENT
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
If the element is set to 1, the price will be calculated on the basis of the base price and a base price unit. If the value is 0, the price calculation is independent from a base price.

The item's base price applicable for the calculation is entered in the .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC element, the base price unit assigned to the base price is entered in
the .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT element. The base price unit is used as the base value and/or starting point for the dimensional-variable calculation.

The price required as a basis for calculation the filler price that refers to the base unit defined in the BASIC_UNIT element is specified in the ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE element.
The base price is always a piece price. If an item is assigned a base price calculation, the same item cannot be assigned a minimum price. The end price of the item generally consists of the base price plus the calculated infill price in consideration of the logic defined in the element. Base prices can only be assigned to items for which at least one dimension is used for calculation purposes.

The effective item prices are collated as follows:
The dimensions of the base price unit must be subtracted from the item dimensions. The remaining dimensions are the infill dimensions.
To calculate the price for the infill dimensions, the logic from the PRICE_TYPE element in conjunction with the price from the .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE element is used. If the infill dimensions are less than 0, the calculations continue with an infill dimension value of 0.

##LINK:PRICE_DEFINITION_PRICE_TYPE_BASIC_PRICE_DEPENDENT.JPG##


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_FORMULA
diagram
type restriction of xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 100 |
pattern | [\+\-\*/\(\)bhtBHT]{0,} |
annotation
documentation
Price calculation formulas can be specified when defining price types (PRICE_TYPE). Formulas must not be specified for standard price types, such as a calculation that relies squares or cubic metres.
The following rules apply for the definition of price type formulas:
- the parameters w, h and d can be used in formulas. Parameters w, h, d correspond to the parameters w, h and d of the carcase basic shape. Depending on the w, h, d parameters used, the corresponding element WIDTH_X (P1) (w), DEPTH_Y (P1) (d) or HEIGHT_Z (P1) (h) must be set to "true".
- the basic calculation methods addition (+), subtraction (-), multiplication (*) and division (/) can be used;
- arithmetic brackets can be used;
- +/minus signs must not be used;
- only the final result is rounded;
- elements BASIC_UNIT (P1), ROUNDING_UNIT (P1) and BASIC_PRICE_DEPENDENT (P1) also apply in conjunction with the price type formula

Path:
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_NAME
diagram
type | languagetext60
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element is used to specify a designation for the defined price type.
The designation simplifies data collection and communication. The designation is not analysed by the planning software.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_RULES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PRICE_TYPE_RULE
annotation
documentation
This element is used to define rules for determining the price type.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_RULES/PRICE_TYPE_RULE
diagram
properties
minOcc | 1
maxOcc | 100
content | complex
children RULE
annotation
documentation
This element is used to define rules for determining the price type.


 attribute T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_RULES/PRICE_TYPE_RULE/@RULE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 9999 |
annotation
documentation
This element is used to specify the rule number.


 element T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_RULES/PRICE_TYPE_RULE/RULE
diagram
type xs:string
properties
content simple
annotation
documentation
This element is used to define the rule.


 complexType languagetext
diagram
children LANGUAGE
used by
elements T_NEW_CATALOG/CATALOG/CATALOG_INFO T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/FULL_TEXT T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT T_NEW_CATALOG/GLOBAL_DEFINITION/MESSAGES/MESSAGE/MESSAGE_TEXT T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_COMMENT_TEXT T_NEW_CATALOG/SERIES/SERIE/SERIES_TEXT/PLANNING_ADVICE T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/PLANNING_ADVICE T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
annotation
documentation
This data type is used to create multiple-language texts of any length.


 simpleType measure_unit
type restriction of xs:string
properties
base xs:string
used by
elements T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TYPE/MEASURE/MEASURE_UNIT T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION/OPTION_MEASURE/MEASURE_UNIT
facets
Kind | Value | Annotation
enumeration | MMT |
enumeration | CMT |
enumeration | DMT |
enumeration | MTR |
enumeration | KTM |
enumeration | INH |
enumeration | FOT |
enumeration | YRD |
enumeration | MMK |
enumeration | CMK |
enumeration | DMK |
enumeration | MTK |
enumeration | INK |
enumeration | FTK |
enumeration | YDK |
enumeration | MGM |
enumeration | GRM |
enumeration | KGM |
enumeration | TNE |
enumeration | LBR |
enumeration | MMQ |
enumeration | CMQ |
enumeration | DMQ |
enumeration | MTQ |
enumeration | INQ |
enumeration | FTQ |
enumeration | YDQ |
enumeration | HLT |
enumeration | LTR |
enumeration | MLT |
enumeration | H87 |
annotation
documentation
This simple data type defines a list of values for units of measurement in common code.


 complexType languagetext30
diagram
children LANGUAGE
used by
element T_NEW_CATALOG/CATALOG/CATALOG_NAME
annotation
documentation
This data type is used to create multiple-language texts with a maximum length of 30 characters.


 simpleType operator
type restriction of xs:string
properties
base xs:string
used by
attributes T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/FEATURE_REF_OP/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/OPTION_COMBINATION/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_INTERVAL/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_LIST/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_GROUP_REF_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/OPTION_REF_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_VALUE_OP/@OPERATOR T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PERCENTAGE_SURCHARGE/OPTIONS_SET_REF/MEASURE_INTERVAL/@OPERATOR
facets
Kind | Value | Annotation
maxLength | 4 |
enumeration | eq |
enumeration | ne |
enumeration | in |
enumeration | nin |
enumeration | gt |
enumeration | lt |
enumeration | ge |
enumeration | le |
annotation
documentation
This simple data type defines an operator for comparisons.
The comparison operator may contain the following values:

eq (equal)
ne (not equal)
in (is contained in a quantity)
nin (is not contained in a quantity)
gt (greater)
lt (less)
ge (greater than or equal)
le (less than or equal)

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy


 complexType languagetext40
diagram
children LANGUAGE
used by
element T_NEW_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
annotation
documentation
This data type is used to create multiple-language texts with a maximum length of 40 characters.


 complexType languagetext60
diagram
children LANGUAGE
used by
elements T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS/DECISION/DECISION_NAME_TEXT T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TEXT T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_ITEMS/OPTIONAL_ITEMS/OPTIONAL_ITEM_GROUP/GROUP_TITLE T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_GROUPS/OPTION_GROUP/OPTION_GROUP_TEXT T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_FEATURE_GROUP_TEXT T_NEW_CATALOG/PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/PRICE_TYPE_NAME T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/PRODUCT_GROUP_TEXT T_NEW_CATALOG/SERIES/SERIE_GROUPS/SERIE_GROUP/SERIE_GROUP_TEXT
annotation
documentation
This data type is used to create multiple-language texts with a maximum length of 60 characters.