 Einleitung

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

MODIFY_CONTENT_IDMP 3.0.1

XML-Schema Dokumentation

Stand 06.12.2021

Dokumentiertes XML-Schema:

MODIFY_CONTENT_IDMP_3_0_1.xsd

Kontakt DCC e.V.

Geschäftsführer
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37

Verantwortliche IDM Arbeitskreise und Dokumentation
Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telefon 0 52 21/12 65-38


 Grundstruktur des IDM-Schemas

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Grundstruktur des IDM-Schemas

Einleitung > Grundstruktur des IDM-Schemas

Die Grundstruktur des IDMP-Schemas

Das Hauptelement T_MODIFY_CONTENT_CATALOG definiert, dass ein neuer, vollständiger Katalogdatenbestand bereitgestellt wird.

Der MODIFY_CONTENT_IDMP ersetzt im jeweils referenzierten Knotenpunkt vollständig den Inhalt des Basiskataloges. Sollen an einem Knotenpunkt z.B. DETAIL_INFOS aus dem Basiskatalog beibehalten werden, müssen diese auch im MODIFY_CONTENT_IDMP enthalten sein.

Die übersteuernden Angaben aus dem MODIFY_CONTENT_IDMP sind nicht für die Bestellabwicklung vorgesehen. Dort müssen die Ursprungs-ID´s und Bezeichnungen aus dem Basiskatalog angegeben werden.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_MODIFY_CONTENT_CATALOG abgebildet werden.

Abbildung 1 - Child-Elemente von T_ADD_PRICE_CATALOG

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.
Darüber hinaus referenzieren viele Datenbereiche auf den zugehörigen Basiskatalog.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

REF_CATALOG

In REF_CATALOG werden Informationen zum Basiskatalog hinterlegt.

GLOBAL_DEFINITION

Der Datenbereich GLOBAL_DEFINITION ist ein Datenpool für Informationen, die in den anderen Datenbereichen verwendet werden. Hier sind es die Angaben zu den Preisarten, zu denen die Zusatzpreise in diesem Datenbestand gespeichert werden.

SERIES

In SERIES werden die zusätzlichen Preise für die Artikel des Basiskataloges hinterlegt. Dabei werden die Artikel in Produktgruppen wie beispielsweise Sessel oder Zwischenelemente gruppiert.


 Datentypen

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Datentypen

Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

Es werden folgende Datentypen verwendet:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDMP wird der Datentyp date XML-Schema konform in folgender Weise angewendet:
 | YYYY-MM-DD
 | Y = Jahr, M = Monat, D = Tag
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDMP für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDMP für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDMP für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.
Zusätzlich gibt es einen benutzerdefinierten Datentyp
operator | Der Datentyp wird im IDMP für Regeln genutzt. Mit diesem einfachen selbst definierten Datentyp wird ein Operator für Vergleiche formuliert. Der Vergleichsoperator stellt sich als string der Länge 1 bis 4 dar und kann der folgende Werte enthalten:
 | eq (ist gleich)
 | ne (ist nicht gleich)
 | in (ist enthalten in einer Menge)
 | nin (ist nicht enthalten in der Menge)
 | gt (größer)
 | lt (kleiner)
 | ge (größer gleich)
 | le (kleiner gleich)


 Erläuterung zur Dokumentation

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Erläuterung zur Dokumentation

Einleitung > Erläuterung zur Dokumentation

Erläuterungen zur Dokumentation des IDMP

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

Beschreibung:

In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden.

D string
P [A-Z]{1,3}
M [1:3]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.
D |  | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P |  | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M |  | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge.
 |  | Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


 Variantenarten

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Variantenarten

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Variantenarten

Folgende Variantenarten wurden definiert:

Varianten_Art | Varianten_Art_Text | Typ | Bemerkung / mögliche Ausprägungen
1 | Bezugsart | A |
2 | Hauptbezugsart | A |
3 | Hauptbezugsfarbe | F |
4 | Absatzbezugsausführung | A |
5 | Absatzbezugsfarbe | F |
6 | Rückenbezugsart | A |
7 | Rückenbezugsfarbe | F |
8 | Rückenbild | A | mit/ohne Kimme, mit/ohne Steppung etc.
9 | Sitzkissenausführung | A |
10 | Sitzkissenfarbe | F |
11 | Zierkissenausführung | A | lose, fest, rund, rechteckig, …
12 | Zierkissenfarbe | F |
13 | Kontrastfadenart / -ausführung | A |
14 | Kontrastfadenfarbe | F |
15 | Fußhöhe | A |
16 | Fußmaterial | A | Metall, Holz, Kunststoff, Buche, …
17 | Fußform | A | Kufe, Rehling, Einzelfuß, Rollen, Gleiter, …
18 | Fußfarbe | F |
19 | Holz- / Chatosenausführung | A |
20 | Holz- / Chatosenfarbe / -beizton | F |
21 | Behangausführung | A |
22 | Behangfarbe | F |
23 | Besatzausführung | A |
24 | Besatzfarbe | F |
25 | Seitentaschenausführung | A |
26 | Seitentaschenfarbe | F |
27 | Kederausführung | A |
28 | Kederfarbe | F |
29 | Drellausführung | A |
30 | Drellfarbe | F |
31 | Reissverschlussausführung | A |
32 | Reissverschlussfarbe | F |
33 | Sitzhärte, - qualität | A | mit /ohne Federkern, …
34 | Antriebsart | A | Schlaufe, manuell, Gasdruckfeder, Motor Netz, Motor Accu, Do
35 | Sitzhöhe | A |
36 | Sitztiefe | A |
37 | Sitzbreite | A |
38 | Rückenhöhe | A |
39 | Rückenkissenhöhe | A |
40 | Rückenkissenausführung | A |
41 | Armlehnen- / Seitenteilanordnung | A | ohne, links, rechts, beidseitig, …
42 | Armlehnen- / Seitenteilausführung | A |
43 | Seitenteilverstellung | A |
44 | Kopfstützenausführung | A | lose, fest, Nackenstütze, …
45 | Kopfstützenfarbe | F |
46 | Vorderblendenausführung | A | bodeneben, bodenfrei
47 | Stoffkombination | K |
48 | Brand- / Flammschutz | A |
49 | Liegeflächenausführung | A |
50 | Liegeflächenfarbe | F |
51 | Länderausführung | A |
52 | Querschläfer | A |
53 | Sitzneigungsverstellung | A |
54 | Sitztiefenverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
55 | Rückenverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
56 | Fußstützenverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
57 | Massagefunktion | A |
58 | Sitzheizung | A |
59 | Lordose | A |
60 | Drehgestell | A |
61 | Aufstehhilfe | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
62 | Klapptisch | A |
63 | Stecktisch | A |
64 | Ausziehtisch | A |
65 | Getränkehalter | A |
66 | Kopfteil | A | Form 1, Form 2 usw., Kopfteilkürzung gegen Mehrpreis, ohne K
67 | Kopfteilbezug | A |
68 | Tagesdecke | A | kurz, halblang, lang, Haube
69 | Tagesdeckenbezug | A |
70 | Liegefläche | A | 160x200, 180x200, 200x200 usw., Sonderlänge gegen Mehrpreis
71 | Bettkasten | A | Standard, Einlegevorrichtung, Highline usw.
72 | Bettkastenbezug | A |
73 | Lattenrost | A | Standard oder Alternativen gegen Mehrpreis, ggf. Einlegelatten
74 | Matratze | A | Standard oder Alternativen gegen Mehrpreis >> Härtegrad H2,
75 | Griffe (bei Konsolen) | F |
76 | Konsolen | A | Schub mit Kunststoff oder Metallführung
77 | Lampenfarbe und -ausführung | A |
78 | Knopfbezug | F |
79 | Lattenrostverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, mehrfach …
80 | Funktion / Verstellung allgemein | A |
81 | freie Variantenart | F |
82 | freie Variantenart | F |
83 | freie Variantenart | F |
84 | freie Variantenart | F |
85 | freie Variantenart | F |
86 | freie Variantenart | F |
87 | freie Variantenart | F |
88 | freie Variantenart | F |
89 | Anschlusstyp L | P |
90 | Anschlusstyp R | P |
91 | freie Variantenart | F |
92 | freie Variantenart | F |
93 | freie Variantenart | F |
94 | freie Variantenart | F |
95 | Planungsbreite | P | Breite des Artikels
96 | Planungstiefe | P | Tiefe des Artikels
97 | Planungshöhe | P | Höhe des Artikels
98 | Antriebsposition | A |
99 | Tischfarbe | F |
100 | Kopfteilverstellung | A |
101 | Relaxfunktion | A |
102 | Vitalfunktion | A |
103 | Stromquelle/Motor | A |
104 | Zubehör | A |
105 | Auflagetisch | A |
106 | Rückenhalter | A |
107 | Steckrücken | A |
108 | Zwischentisch | A |
109 | Zeitschriftenablage | A |
110 | Schwenkfunktion | A |
111 | Leseleuchte | A |
112 | Decoartikel | A |
150 | freie Variantenart | F |
151 | freie Variantenart | F |
152 | freie Variantenart | F |
153 | freie Variantenart | F |
154 | freie Variantenart | F |
155 | freie Variantenart | F |
160 | Anschlusstyp Oben 1 | P | ID des Anschlussvektors in der SVG: AVO1
161 | Anschlusstyp Oben 2 | P | ID des Anschlussvektors in der SVG: AVO2
162 | Anschlusstyp Oben 3 | P | ID des Anschlussvektors in der SVG: AVO3
163 | Anschlusstyp Oben 4 | P | ID des Anschlussvektors in der SVG: AVO4
164 | Anschlusstyp Oben 5 | P | ID des Anschlussvektors in der SVG: AVO5
165 | Anschlusstyp Unten 1 | P | ID des Anschlussvektors in der SVG: AVU1
166 | Anschlusstyp Unten 2 | P | ID des Anschlussvektors in der SVG: AVU2
167 | Anschlusstyp Unten 3 | P | ID des Anschlussvektors in der SVG: AVU3
168 | Anschlusstyp Unten 4 | P | ID des Anschlussvektors in der SVG: AVU4
169 | Anschlusstyp Unten 5 | P | ID des Anschlussvektors in der SVG: AVU5
170 | Anschlusstyp Oben 6 | P | ID des Anschlussvektors in der SVG: AVO6
171 | Anschlusstyp Oben 7 | P | ID des Anschlussvektors in der SVG: AVO7
172 | Anschlusstyp Oben 8 | P | ID des Anschlussvektors in der SVG: AVO8
173 | Anschlusstyp Oben 9 | P | ID des Anschlussvektors in der SVG: AVO9
174 | Anschlusstyp Oben 10 | P | ID des Anschlussvektors in der SVG: AVO10
175 | Anschlusstyp Unten 6 | P | ID des Anschlussvektors in der SVG: AVU6
176 | Anschlusstyp Unten 7 | P | ID des Anschlussvektors in der SVG: AVU7
177 | Anschlusstyp Unten 8 | P | ID des Anschlussvektors in der SVG: AVU8
178 | Anschlusstyp Unten 9 | P | ID des Anschlussvektors in der SVG: AVU9
179 | Anschlusstyp Unten 10 | P | ID des Anschlussvektors in der SVG: AVU10
180 | Anschlusstyp Nord 1 | P | ID des Anschlussvektors in der SVG: AVN1
181 | Anschlusstyp Nord 2 | P | ID des Anschlussvektors in der SVG: AVN2
182 | Anschlusstyp Nord 3 | P | ID des Anschlussvektors in der SVG: AVN3
183 | Anschlusstyp Nord 4 | P | ID des Anschlussvektors in der SVG: AVN4
184 | Anschlusstyp Nord 5 | P | ID des Anschlussvektors in der SVG: AVN5
185 | Anschlusstyp Nord 6 | P | ID des Anschlussvektors in der SVG: AVN6
186 | Anschlusstyp Nord 7 | P | ID des Anschlussvektors in der SVG: AVN7
187 | Anschlusstyp Nord 8 | P | ID des Anschlussvektors in der SVG: AVN8
188 | Anschlusstyp Nord 9 | P | ID des Anschlussvektors in der SVG: AVN9
189 | Anschlusstyp Nord 10 | P | ID des Anschlussvektors in der SVG: AVN10
190 | Anschlusstyp Süd 1 | P | ID des Anschlussvektors in der SVG: AVS1
191 | Anschlusstyp Süd 2 | P | ID des Anschlussvektors in der SVG: AVS2
192 | Anschlusstyp Süd 3 | P | ID des Anschlussvektors in der SVG: AVS3
193 | Anschlusstyp Süd 4 | P | ID des Anschlussvektors in der SVG: AVS4
194 | Anschlusstyp Süd 5 | P | ID des Anschlussvektors in der SVG: AVS5
195 | Anschlusstyp Süd 6 | P | ID des Anschlussvektors in der SVG: AVS6
196 | Anschlusstyp Süd 7 | P | ID des Anschlussvektors in der SVG: AVS7
197 | Anschlusstyp Süd 8 | P | ID des Anschlussvektors in der SVG: AVS8
198 | Anschlusstyp Süd 9 | P | ID des Anschlussvektors in der SVG: AVS9
199 | Anschlusstyp Süd 10 | P | ID des Anschlussvektors in der SVG: AVS10
200 | freie Variantenart | F |
201 | freie Variantenart | F |
202 | freie Variantenart | F |
203 | freie Variantenart | F |
204 | freie Variantenart | F |
205 | freie Variantenart | F |
206 | freie Variantenart | F |
207 | freie Variantenart | F |
208 | freie Variantenart | F |
209 | freie Variantenart | F |
210 | freie Variantenart | F |
211 | Stoffbedarf | A | in laufenden m
212 | Lederbedarf | A | in m²

Von 213 bis 999 stehen freie Variantenarten zur Verfügung.

Typ: A = Ausführung

F = Farbe

P = Planung


 Sprachenschlüssel

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Sprachenschlüssel

Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Niederländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu


 Länderschlüssel

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Einleitung > Länderschlüssel

ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Länderschlüssel

AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


 Typen für Detailinformationen

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Einleitung > Länderschlüssel

ADD_PRICE_IDMP 3.1.0 XML-Schema Dokumentation

Einleitung > Typen für Detailinformationen

Einleitung > Typen für Detailinformationen

Für die Beschreibung der Art der Detailinformation gibt es folgende Info-Typen:

1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Funktionsbeschreibung                                                                                                            16
= Planungshinweis                                                                                                                             17
= Katalogbild

Im MODIFY-CONTENT-IDMP sind davon nur die Info-Typen 1, 9, 10 und 17 erlaubt.


 Schema MODIFY_CONTENT_IDMP_3_1_0.xsd.DE.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\MODDIFY_CONTENT\Doku_Modify_Content\MODIFY_CONTENT_IDMP_3_1_0.xsd.DE.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
T_MODIFY_CONTENT_CATALOG | languagetext
 | languagetext30
 | languagetext40
 | languagetext60


 element T_MODIFY_CONTENT_CATALOG
diagram
properties
content complex
children CATALOG REF_CATALOG GLOBAL_DEFINITION SERIES
annotation
documentation
Dieses Element bietet den Einstieg für veränderte Texte und Bezeichnungen, handelsspezifische Medien oder zusätzliche Klassifizierungen bezogen auf einen Katalog im IDMP-Format. Hersteller dieser Daten kann sowohl der Handel als auch die Verbände u. Ä. sein, die für die Artikel und Varianten angepasste Texte, Medien bzw. Klassifizierungen transferieren möchten. Diese Texte und Medien sind nur für den Verkauf relevant, für Bestellungen müssen die Texte und Bezeichnungen des Original-Katalogs im IDMP-Format genutzt werden. Werden an einem Element Medien in dem Datenbestand referenziert, müssen bei der Referenzierung alle relevanten Medien angegeben werden, auch die, die vom Originalkatalog genutzt werden sollen. Das gilt insbesondere auch für Magnetplanerinformationen.


 attribute T_MODIFY_CONTENT_CATALOG/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 3 |
maxInclusive | 3 |
annotation
documentation
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION.


 attribute T_MODIFY_CONTENT_CATALOG/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 1 |
annotation
documentation
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.


 attribute T_MODIFY_CONTENT_CATALOG/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 0 |
annotation
documentation
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.


 element T_MODIFY_CONTENT_CATALOG/CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CATALOG_LANGUAGE CATALOG_NAME FILE_ID CATALOG_DATA_VERSION CATALOG_INFO CATALOG_VERSION FALL_BACK_LANGUAGE DETAIL_INFOS RECEIVER_ID
annotation
documentation
In diesem Element werden administrative Informationen zum Datenbestand hinterlegt.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children GLN_NO CATALOG_ID FILE_RELEASE_DATE
annotation
documentation
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten müssen identisch sein.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_IDENTIFICATION/GLN_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | (0-9){13} |
annotation
documentation
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) des Datenlieferanten dieses Content-Rucksackes (nicht des Lieferanten des Basiskataloges) eingetragen.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_IDENTIFICATION/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
In diesem Element soll der Zeitstempel für die Erstellung des Datenbestandes in der UTC Zeit angegeben werden.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_LANGUAGE
diagram
properties
content complex
children ISO_LANGUAGE_ID
annotation
documentation
In diesem Element werden die im Datenbestand verwendeten Sprachen angegeben.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_LANGUAGE/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_NAME
diagram
type | languagetext30
properties
content complex
children | LANGUAGE
annotation
documentation
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.


 element languagetext30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetext30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_DATA_VERSION
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_INFO
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
In diesem Element werden die Informationstexte abgelegt.


 element languagetext/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute languagetext/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
b Fettdruck
br Zeilenumbruch


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_VERSION
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
Hier kann der Hersteller des Datenbestandes eine Versions-Nr. für den Katalog vergeben. Wird zu einem Basiskatalog ein neuer Modifizierungsdatenbestand herausgegeben, muss der Wert von CATALOG_VERSION hoch gezählt werden.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/FALL_BACK_LANGUAGE
diagram
type restriction of xs:language
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
Dieses Element dient der veränderten Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos bzw. eines speziellen Labels.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Detailinformationen referenziert.


 attribute T_MODIFY_CONTENT_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.


 attribute T_MODIFY_CONTENT_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut ermöglicht eine selbstdefinierte Sortierreihnfolge der Detailinformationen.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/RECEIVER_ID
diagram
type xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
Hier wird die ID des Empfängers eingetragen.


 element T_MODIFY_CONTENT_CATALOG/REF_CATALOG
diagram
properties
content complex
annotation
documentation
Hier wird der Katalog, auf den sich die modifizierten Texte und Bilder beziehen, über die GLN des Herstellers und die CATALOG_ID des Basiskataloges referenziert.

Die aktuellste Rucksackdatei ist dabei immer zum aktuellsten Basiskatalog gültig.


 attribute T_MODIFY_CONTENT_CATALOG/REF_CATALOG/@SUPPLIER_GLN_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]{13} |
annotation
documentation
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) des Herstellers des Basiskataloges eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.


 attribute T_MODIFY_CONTENT_CATALOG/REF_CATALOG/@CATALOG_ID
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
Hier wird die eindeutige ID (z.B.GUID) des Herstellers eingeben, um den BasisKatalog eindeutig zu referenziern. Sie muss den gleichen Wert wie die CATALOG_ID unterhalb von CATALOG im Basiskatalog haben.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFOS
annotation
documentation
In diesem Element werden für den Datenbestand gültige Daten (globale Informationen) hinterlegt.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO
annotation
documentation
In diesem Element werden für den Datenbestand als globale Informationen die Detail-Informationen (Medien) hinterlegt.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION INFO_TYPE EXTERNAL_NAME INTERNAL_NAME TOOL_TIP URL
annotation
documentation
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.


 attribute T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
Dieses Attribut identifiziert eine Detailinformation.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/CLASSIFICATION
diagram
type restriction of xs:string
properties
content simple
annotation
documentation
Dieses Element dient der Klassifizierung der Detailinformation.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INFO_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
maxInclusive | 14 |
pattern | (1[0,7] | [1,9]) |
annotation
documentation
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen.

Für Milieufotos (INFO_TYPE = 1) wird eine Bildgröße von 2048x2048px empfohlen.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
diagram
type | languagetext40
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.


 element languagetext40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetext40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,40} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Dieses Element enthält Text für einen Hinweis zum Link.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL
diagram
properties
content complex
children LANGUAGE
annotation
documentation
Dieses Element gibt die URL zur Detailinformation an.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT HASH_VALUE
annotation
documentation
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/TEXT
diagram
type xs:anyURI
properties
content simple
annotation
documentation
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/HASH_VALUE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 32 |
maxLength | 32 |
annotation
documentation
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht.


 element T_MODIFY_CONTENT_CATALOG/SERIES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SERIE
annotation
documentation
In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren zugeordneten Elementen wie beispielsweise Produktgruppen oder Artikeln hinterlegt, an denen veränderte Texte, Detailinformationen oder zusätzliche Klassifizierungen hinterlegt werden.

Eine Serie entspricht im Allgemeinen einem Modell.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 1000000
content | complex
children SERIES_TEXT PRODUCT_GROUPS DETAIL_INFOS
annotation
documentation
In diesem Element wird eine Serie mit ihren entsprechenden Artikeln gespeichert. Einen Serie entspricht einem Modell. Die Angaben der Nummern und Bezeichnungen müssen denen des Basiskataloges entsprechen.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
In diesem Attribut wird die Seriennummer der Serie des Basiskataloges angegeben.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/SERIES_TEXT
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FULL_TEXT
annotation
documentation
In diesem Element werden die serienspezifischen Texte definiert.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/SERIES_TEXT/FULL_TEXT
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Im Volltext steht die komplette Beschreibung der Serie. Innerhalb des Textes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden. Bilder dürfen nicht enthalten sein.
Dieses Element enthält den Volltext in einem CDATA - Knoten. Die Formatierung des Textes ist HTML konform anzugeben:
b Fettdruck
br Zeilenumbruch


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PRODUCT_GROUP
annotation
documentation
In diesem Element werden Produktgruppen gespeichert. Sie müssen denen des Basiskataloges entsprechen. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Polstermöbel mit Armlehne).


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEMS
annotation
documentation
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
In diesem Element werden alle Artikel einer Produktgruppe angegeben, für die die Texte, Detailinformationen oder Klassifizierungen handelspezifisch verändert werden.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_TEXT CLASSIFICATIONS
annotation
documentation
In diesem Element werden Artikel entsprechend des Basiskataloges gespeichert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SHORT_TEXT FULL_TEXT
annotation
documentation
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Der Kurztext darf aus drei Zeilen bestehen.

Dieses Element ist nur anzugeben, wenn für den Artikel ein handelsspezifischer Text vorgesehen ist.

Die spätere Bestellung muss den Originaltext enthalten.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT >
diagram
properties
content complex
children LANGUAGE
annotation
documentation
Dieses Element enthält Kurztexte.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID >
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE >
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
children TEXT
annotation
documentation
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT >
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

b Fettdruck
br Zeilenumbruch


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CLASSIFICATION
annotation
documentation
In diesem Element werden standardisierte Klassifikationen hinterlegt.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION_CODE VALID_FROM VALID_UNTIL
annotation
documentation
Dieses Element enthält die Merkmale eines Klassifikationsschemas.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
pattern | ([1-9]{1}|1[0]{2}) |
annotation
documentation
Dieses Attribut gibt das jeweilige Klassifikationsschema an. Zur Auswahl stehen die Werte der folgenden Liste:

ID Klassifikationsschema
1 eCl@ss
2 Verbandsklassifikation Begros
3 Verbandsklassifikation VME
4 Code Eco Mobilier
5 Ecosystem EEE
6 freies Klassifikationsschema
7 freies Klassifikationsschema
8 freies Klassifikationsschema
9 freies Klassifikationsschema
10 freies Klassifikationsschema

Ist das zu pflegende Schema in der Liste nicht aufgeführt ist eine ID ab 6 für freies Klassifikationsschema auszuwählen.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE >
diagram
type xs:string
properties
content simple
annotation
documentation
Dieses Element enthält den Code für die, dem ITEM zuzuordnende Kategorie des jeweiligen Klassifikationsschemas.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM >
diagram
type xs:date
properties
content simple
annotation
documentation
Dieses Element gibt das Datum an, ab wann die Klassifikationsangabe gültig ist.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL >
diagram
type xs:date
properties
content simple
annotation
documentation
Dieses Element gibt das Datum an, bis wann die Klassifikationsangabe gültig ist.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
In diesem Element können handelsspezifische mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks für die Serie hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
In diesem Element werden die Detailinformationen referenziert.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
Dieses Attribut gibt die Möglichkeit, Detailinformationen an der Serie mit einer selbstdefinierten Sortierreihenfolge anzulegen.


 complexType languagetext
diagram
children LANGUAGE
used by
elements T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_INFO T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/SERIES_TEXT/FULL_TEXT T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.


 complexType languagetext30
diagram
children LANGUAGE
used by
element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.


 complexType languagetext40
diagram
children LANGUAGE
used by
element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.


 complexType languagetext60
diagram
children LANGUAGE
annotation
documentation
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.


 element languagetext60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.


 attribute languagetext60/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird.


 element languagetext60/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,60} |
annotation
documentation
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy