 Introduction

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

MODIFY_CONTENT_IDMP 3.1.0

XML schema documentation

Last revised 06/12/2021

Documented XML schema:

MODIFY_CONTENT_IDMP_3_1_0.xsd

Contakt DCC e.V.

Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telephon 0 52 21/12 65-37

Anika Degenhard
E-Mail degenhard@dcc-moebel.org
Telephon 0 52 21/12 65-38


 Basic structure of the IDM schema

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] MODIFY_CONTENT_IDMP 3.1.0 XML schema documentation

Introduction > Basic structure of the IDM schema

Einleitung > Grundstruktur des IDM-Schemas

The basic structure of the IDMP schema

The main element T_MODIFY_CONTENT_CATALOG defines that a new and complete catalogue data pool is made available.

The IDM schema is subdivided in data ranges that are specified in the subsequent child-elements (see figure 1) in T_MODIFY_CONTENT_CATALOG.

Figure 1 - child elements in T_MODIFY_CONTENT_CATALOG

The data ranges are not used in isolation from each other. In some data ranges, data is initially created and used from other data ranges via referencing.

Additionally, many data ranges contain references to the associated base catalogue.

Description of the data ranges

CATALOG

CATALOG is used to store administrative information concerning the data pool. E.g. the version of the data format, release date or the unique identification of the data pool.

REF_CATALOG

Information on the base catalogue is specified in REF_CATALOG.

GLOBAL_DEFINITION

The GLOBAL_DEFINITION data range is a kind of data pool for information used in the other data ranges. In this case, the detail information for this data pool is stored.

SERIES

The modified trade-specific texts, detail information and classifications for the items of the base catalogue are specified in SERIES. Items are combined into product groups, such as armchairs or intermediate elements.

FEATURE_DEFINITION

Trade-specific texts and detail information for feature information are stored in FEATURE_DEFINITION.


 Data types

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] MODIFY_CONTENT_IDMP 3.1.0 XML schema documentation

Introduction > Data types

Einleitung > Datentypen

Datentypen und Wertebereiche

The IDM schema uses the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

It uses the following data types:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDMP, the data type date is used in conformity with the XML schemas as follows:
 | YYYY-MM-DD
 | Y = year, M = month, D = day
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDMP for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 or -45.98000 or +27.0.
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDMP for URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used in the IDMP for the mapping of valid language keys.language represents codes for natural languages Tags for the Identification of Languagesas defined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.
Additionally, there is also a user-defined data type:
operator | Thy data type is used for rules in the IDMP. This simple, self-defined data type defines an operator for comparisons. The comparison operator is a string of 1 to 4 characters length and may contain the following values: eq (equal) ne (not equal) in (is contained in a quantity) nin (is not contained in a quantity) gt (greater) lt (less) ge (greater than or equal) le (less than or equal)

The value ranges of the above data types are usually restricted for the elements in the IDMP. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters (pattern) and value lists.

In the documentation of the XML schema of the IDM, the value ranges are specified by the information coming after M and P.


 Notes to the documentation

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] MODIFY_CONTENT_IDMP 3.1.0 XML schema documentation

Introduction > Notes to the documentation

Einleitung > Erläuterung zur Dokumentation

Notes to the IDMP documentation

Notes to the IDM documentation schema are stored in this section.

Explanation of the element properties

Each element is documented on the basis of a description and its properties. The following shows an example for an element description:

Description:

In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden.

D string
P [A-Z]{1,3}
M [1:3]

The element properties are documented on the right side. They have the following meaning:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.
D |  | The data type of the element is documented here. If this position is left blank, the element does not contain any reference data but additional child-elements.
P |  | The entries made in P and M document the value range of an element. A regular expression that defines the permitted values must be entered in P.
M |  | The minimum and maximum permitted values must be entered in M. In the case of a string data type, P defines the permitted characters and M the minimum and maximum character length. In the case of a numeric data type, the permitted minimum and maximum value is defined.


 Version types

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge [image] MODIFY_CONTENT_IDMP 3.1.0 XML schema documentation

Introduction > Version types

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Version types

The following version types have been defined:

Freely defined version types are available from 213 to 999.

Type: A = finish F = colour P = planning

Version_type | Version_type_text | Type | Remark/possible variations
1 | Reference type | A |
2 | Main reference type | A |
3 | Main reference colour | F |
4 | base cover material | A |
5 | base cover colour | F |
6 | back cover type | A |
7 | back cover colour | F |
8 | seam pattern | A | UNKNOWN TERM
9 | Seat cushion type | A |
10 | Seat cushion colour | F |
11 | Decorative cushion type | A | soft, firm, round, rectangular, ...
12 | Decorative cushion colour | F |
13 | Contrast stitching type / variation | A |
14 | Contrast stitching colour | F |
15 | Foot height | A |
16 | Foot material | A | Metal, timber, plastic, beech,. ..
17 | Foot shape | A | metal runner, wooden runner, metal leg, wooden leg, castor, plastic glider
18 | Foot colour | F |
19 | chatose type | A |
20 | chatose colour | F |
21 | UNKNOWN TERM | A |
22 | UNKNOWN TERM | F |
23 | UNKNOWN TERM | A |
24 | UNKNOWN TERM | F |
25 | Side pocket type | A |
26 | Side pocket colour | F |
27 | material of piping | A |
28 | colour of piping | F |
29 | kind of bottom linen | A |
30 | colour of bottom linen | F |
31 | Zipper type | A |
32 | Zipper colour | F |
33 | Seat hardness, quality | A | with/without spring core, ...
34 | Drive type | A | Nozzle, manual, gas pressure spring, motor plug-in, motor battery, do
35 | Seat height | A |
36 | Seat depth | A |
37 | Seat width | A |
38 | Back height | A |
39 | Back cushion height | A |
40 | Back cushion type | A |
41 | Armrests/side element configuration | A | without, left, right, both sides, ...
42 | Armrests/side element type | A |
43 | Side element adjustment | A |
44 | Headrest type | A | movable, fixed, neck rest, ...
45 | Headrest colour | F |
46 | lower front part | A | floor level, floor-free
47 | Fabric combination | K |
48 | Fire / flame retardant | A |
49 | Resting area type | A |
50 | Resting area colour | F |
51 | Country version | A |
52 | Crossways sleepers | A |
53 | Seat angle adjustment | A |
54 | Seat depth adjustment | A | Mechanical, electrical, gas spring, ...
55 | Backrest adjustment | A | Mechanical, electrical, gas spring, ...
56 | Footrest adjustment | A | Mechanical, electrical, gas spring, ...
57 | Massage function | A |
58 | Seat heating | A |
59 | Lumbar support | A |
60 | Swivel base | A |
61 | Stand-up aid | A | Mechanical, electrical, gas spring, ...
62 | Folding table | A |
63 | plug-in table | A |
64 | Pull-out table | A |
65 | Cupholder | A |
66 | Headboard | A | Shape 1, shape 2 etc., headboard shortening at a surcharge, without K
67 | Headboard fabric | A |
68 | Throw-over | A | short, half-length, full length, shroud
69 | Day cover fabric | A |
70 | Lying surface | A | 160x200, 180x200, 200x200 at a surcharge, other lengths at a surcharge
71 | Bedding box | A | standard, inserting mechanism, highline etc.
72 | Bedding box upholstery | A |
73 | Slatted base | A | Standard or alternatives at a surcharge, separate slats if appropriate
74 | Mattress | A | Standard or alternatives at a surcharge >> firmness level H2
75 | Handles (for bedside tables) | F |
76 | Bedside tables | A | Drawer with plastic or metal rails
77 | Lamp colour and finish | A |
78 | Knob cover | F |
79 | Slatted base adjustment | A | Mechanical, electrical, gas spring, multiple, ...
80 | Function/adjustment in general | A |
81 | freely defined version type | F |
82 | freely defined version type | F |
83 | freely defined version type | F |
84 | freely defined version type | F |
85 | freely defined version type | F |
86 | freely defined version type | F |
87 | freely defined version type | F |
88 | freely defined version type | F |
89 | Connection type L | P | ID of the connection vector in the SVG: AVL
90 | Connection type R | P | ID of the connection vector in the SVG: AVR
91 | freely defined version type | P |
92 | freely defined version type | P |
93 | freely defined version type | P |
94 | freely defined version type | P |
95 | Planning width | P | Item width
96 | Planning depth | P | Item depth
97 | Planning height | P | Item height
98 | Drive position | A |
99 | Table colour | F |
100 | Head-section adjustment | A |
101 | Relax function | A |
102 | Vitalising function | A |
103 | Power source/motor | A |
104 | Accessories | A |
105 | Top table | A |
106 | Back holder | A |
107 | Slot-in back | A |
108 | Intermediate table | A |
109 | Newspaper rack | A |
110 | Swivel function | A |
111 | Reading lamp | A |
112 | Decorative item | A |
150 | freely defined version type | P |
151 | freely defined version type | P |
152 | freely defined version type | P |
153 | freely defined version type | P |
154 | freely defined version type | P |
155 | freely defined version type | P |
160 | Connection type top 1 | P | ID of the connection vector in the SVG: AVO1
161 | Connection type top 2 | P | ID of the connection vector in the SVG: AVO2
162 | Connection type top 3 | P | ID of the connection vector in the SVG: AVO3
163 | Connection type top 4 | P | ID of the connection vector in the SVG: AVO4
164 | Connection type top 5 | P | ID of the connection vector in the SVG: AVO5
165 | Connection type bottom 1 | P | ID of the connection vector in the SVG: AVU1
166 | Connection type bottom 2 | P | ID of the connection vector in the SVG: AVU2
167 | Connection type bottom 3 | P | ID of the connection vector in the SVG: AVU3
168 | Connection type bottom 4 | P | ID of the connection vector in the SVG: AVU4
169 | Connection type bottom 5 | P | ID of the connection vector in the SVG: AVU5
170 | Connection type top 6 | P | ID of the connection vector in the SVG: AVO6
171 | Connection type top 7 | P | ID of the connection vector in the SVG: AVO7
172 | Connection type top 8 | P | ID of the connection vector in the SVG: AVO8
173 | Connection type top 9 | P | ID of the connection vector in the SVG: AVO9
174 | Connection type top 10 | P | ID of the connection vector in the SVG: AVO10
175 | Connection type bottom 6 | P | ID of the connection vector in the SVG: AVU6
176 | Connection type bottom 7 | P | ID of the connection vector in the SVG: AVU7
177 | Connection type bottom 8 | P | ID of the connection vector in the SVG: AVU8
178 | Connection type bottom 9 | P | ID of the connection vector in the SVG: AVU9
179 | Connection type bottom 10 | P | ID of the connection vector in the SVG: AVU10
180 | Connection type north 1 | P | ID of the connection vector in the SVG: AVN1
181 | Connection type north 2 | P | ID of the connection vector in the SVG: AVN2
182 | Connection type north 3 | P | ID of the connection vector in the SVG: AVN3
183 | Connection type north 4 | P | ID of the connection vector in the SVG: AVN4
184 | Connection type north 5 | P | ID of the connection vector in the SVG: AVN5
185 | Connection type north 6 | P | ID of the connection vector in the SVG: AVN6
186 | Connection type north 7 | P | ID of the connection vector in the SVG: AVN7
187 | Connection type north 8 | P | ID of the connection vector in the SVG: AVN8
188 | Connection type north 9 | P | ID of the connection vector in the SVG: AVN9
189 | Connection type north 10 | P | ID of the connection vector in the SVG: AVN10
190 | Connection type south 1 | P | ID of the connection vector in the SVG: AVS1
191 | Connection type south 2 | P | ID of the connection vector in the SVG: AVS2
192 | Connection type south 3 | P | ID of the connection vector in the SVG: AVS3
193 | Connection type south 4 | P | ID of the connection vector in the SVG: AVS4
194 | Connection type south 5 | P | ID of the connection vector in the SVG: AVS5
195 | Connection type south 6 | P | ID of the connection vector in the SVG: AVS6
196 | Connection type south 7 | P | ID of the connection vector in the SVG: AVS7
197 | Connection type south 8 | P | ID of the connection vector in the SVG: AVS8
198 | Connection type south 9 | P | ID of the connection vector in the SVG: AVS9
199 | Connection type south 10 | P | ID of the connection vector in the SVG: AVS10
200 | freely defined version type | F |
201 | freely defined version type | F |
202 | freely defined version type | F |
203 | freely defined version type | F |
204 | freely defined version type | F |
205 | freely defined version type | F |
206 | freely defined version type | F |
207 | freely defined version type | F |
208 | freely defined version type | F |
209 | freely defined version type | F |
210 | freely defined version type | F |
211 | fabric requirement | A | in linear metres
212 | leather requirement | A | in m²


 Language key

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

MODIFY_CONTENT_IDMP 3.1.0 XML schema documentation

Introduction > Language key

Einleitung > Sprachenschlüssel

Language key | Language name
AA | Afar
AB | Abkhazian
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AV | Avarisch
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CR | Cree
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundish
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothish
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VE | Tshivenda
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu


 Country code

Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Einleitung > Länderschlüssel

MODIFY_CONTENT_IDMP 3.1.0 XML schema documentation

Introduction > Country code

country code | country
AC | Ascension
AD | Andorra
AE | United Arab Emirates
AF | Afghanistan
AG | Antigua and Barbuda
AI | Anguilla
AL | Albania
AM | Armenia
AN | Dutch Antilles
AO | Angola
AQ | Antarctica
AR | Argentina
AS | American Samoa
AT | Austria
AU | Australia
AW | Aruba
AX | Aland
AZ | Azerbaijan
BA | Bosnia and Herzegovina
BB | Barbados
BD | Bangladesh
BE | Belgium
BF | Burkina Faso
BG | Bulgaria
BH | Bahrain
BI | Burundi
BJ | Benin
BL | Saint-Barthélemy
BM | Bermuda
BN | Brunei Darussalam
BO | Bolivia
BQ | Bonaire, Sint Eustatius and Saba
BR | Brazil
BS | Bahamas
BT | Bhutan
BU | Burma
BV | Bouvet Island
BW | Botswana
BY | Belarus
BZ | Belize
CA | Canada
CC | Cocos) Islands
CD | Democratic Republic of the Congo
CF | Central African Republic
CG | Republic of the Congo
CH | Switzerland
CI | Ivory Coast
CK | Cook Islands
CL | Chile
CM | Cameroon
CN | China
CO | Columbia
CP | Clipperton
CR | Costa Rica
CU | Cuba
CV | Cape Verde
CW | Curaçao
CX | Christmas Island
CY | Cyprus
CZ | Czech Republic
DE | Germany
DG | Diego Garcia
DJ | Djibouti
DK | Denmark
DM | Dominica
DO | Dominican Republic
DZ | Algeria
EA | Ceuta, Melilla
EC | Ecuador
EE | Estonia
EG | Egypt
EH | Westsahara
EN | England
ER | Eritrea
ES | Spain
ET | Ethiopia
FI | Finland
FJ | Fiji
FK | Falklands
FM | Micronesia
FO | Faeroe Islands
FR | France
GA | Gabon
GB | England/Great Britain
GD | Grenada
GE | Georgia
GF | French Guiana
GG | Guernsey (Channel Island)
GH | Ghana
GI | Gibraltar
GL | Greenland
GM | Gambia
GN | Guinea
GP | Guadeloupe
GQ | Equatorial Guinea
GR | Greece
GS | South Georgia and the South Sandwich Islands
GT | Guatemala
GU | Guam
GW | Guinea-Bissau
GY | Guyana
HK | Hong Kong
HM | Heard and McDonald Islands
HN | Honduras
HR | Croatia
HT | Haiti
HU | Hungary
ID | Indonesian
IE | Ireland
IL | Israel
IM | Isle of Man
IN | India
IO | British Indian Ocean Territory
IQ | Iraq
IR | Islamic Republic of Iran
IS | Iceland
IT | Italy
JE | Channel Island of Jersey
JM | Jamaica
JO | Jordan
JP | Japan
KE | Kenya
KG | Kyrgyzstan
KH | Cambodia
KI | Kiribati
KM | Comoros
KN | Saint Kitts and Nevis
KP | Democratic People's Republic of Korea
KR | Republic of Korea
KW | Kuwait
KY | Cayman Islands
KZ | Kazakstan
LA | Laos
LB | Lebanon
LC | Saint Lucia
LI | Liechtenstein
LK | Sri Lanka
LR | Liberia
LS | Lesotho
LT | Lithuania
LU | Luxembourg
LV | Latvia
LY | Libya
MA | Morocco
MC | Monaco
MD | Moldavia
ME | Montenegro
MF | Saint Martin
MG | Madagascar
MH | Marshall Islands
MK | North Macedonia
ML | Mali
MM | Myanmar (Burma)
MN | Mongolia
MO | Macau
MP | Northern Mariana Islands
MQ | Martinique
MR | Mauritania
MS | Montserrat
MT | Malta
MU | Mauritius
MV | Maldives
MW | Malawi
MX | Mexico
MY | Malaysia
MZ | Mozambique
NA | Namibia
NC | New Caledonia
NE | Niger
NF | Norfolk Island
NG | Nigeria
NI | Nicaragua
NL | Netherlands
NO | Norway
NP | Nepal
NR | Nauru
NU | Niue
NZ | New Zealand
OM | Oman
PA | Panama
PE | Peru
PF | French Polynesia
PG | Papuan New Guinea
PH | Philippine
PK | Pakistan
PL | Poland
PM | St. Pierre and Miquelon
PN | Pitcairn Islands
PR | Puerto Rica
PS | Palestine
PT | Portugal
PW | Palau
PY | Paraguay
QA | Qatar
RE | Reunion
RO | Romania
RS | Serbia
RU | Russia
RW | Ruanda
SA | Saudi Arabia
SB | Solomon Islands
SC | Seychelles
SD | Sudan
SE | Sweden
SG | Singapore
SH | St. Helena
SI | Slovenia
SJ | Svalbard and Jan Mayen Islands
SK | Slovak Republic
SL | Sierra Leone
SM | San Marino
SN | Senegal
SO | Somalia
SR | Suriname
SS | South Sudan
ST | Democratic Republic of São Tomé and Príncipe
SV | El Salvador
SX | Sint Maarten
SY | Syrian Arab Republic
SZ | Swaziland
TC | Turks and Caicos Islands
TD | Chad
TF | French Southern and Antarctic Territories
TG | Togo
TH | Thailand
TJ | Tadschikistan
TK | Tokelau
TL | East Timor
TM | Turkmenistan
TN | Tunisia
TO | Tonga
TR | Turkey
TT | Trinidad and Tobago
TV | Tuvalu
TW | Taiwan
TZ | Tanzania
UA | Ukraine
UG | Uganda
UM | United States Minor Outlying Islands
US | United States of America
UY | Uruguay
UZ | Uzbekistan
VA | Vatican City
VC | Saint Vincent and the Grenadines
VE | Venezuela
VG | British Virgin Islands
VI | American Virgin Islands
VN | Vietnam
VU | Vanuatu
WF | Wallis and Futuna Islands
WS | Samoa
YE | Yemen
YT | Mayotte
ZA | South Africa
ZM | Sambia
ZW | Zimbabwe


 Types of detailed information Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge Alles zusammenklappen Alles ausklappen Ansicht mit Navigationswerkzeuge

Einleitung > Länderschlüssel

MODIFY_CONTENT_IDMP 3.1.0 XML schema documentation

Introduction > Types of detailed information

Einleitung > Typen für Detailinformationen

The following info types can be used to describe the type of detail information:

1 = Milieu photo
2 = Item pictogram (type/item overview)
3 = Magnetic planner drawing (SVGs in top view)
4 = Version photo
5 = Version texture (leather type, ...)
6 = Manufacturer logo/product brand
7 = Colour consultancy (the versions are defined in an assessment procedure)
8 = Fabric sample book (PDF for fabric groups)
9 = Model description sheets (PDF below series)
10 = Installation instructions
11 = Marketing
12 = Miscellaneous
13 = Colour consultancy wall
14 = Colour consultancy floor
                                                  15 = Description of
function                                                                                                    16
= Planning advice                                                                                                                         17
= Catalogue image

Only info types 1, 9, 10 and 17 are permitted in the MODIFY-CONTENT-IDMP.


 Schema MODIFY_CONTENT_IDMP_3_1_0.xsd.EN.xsd

schema location: | C:\Users\degenhard\Desktop\Dokumentationen\MODDIFY_CONTENT\Doku_Modify_Content\MODIFY_CONTENT_IDMP_3_1_0.xsd.EN.xsd
attributeFormDefault: | unqualified
elementFormDefault: | qualified
Elements | Complex types
T_MODIFY_CONTENT_CATALOG | languagetext
 | languagetext30
 | languagetext40
 | languagetext60


 element T_MODIFY_CONTENT_CATALOG
diagram
properties
content complex
children CATALOG REF_CATALOG GLOBAL_DEFINITION SERIES
annotation
documentation
This element offers an entry point for modified texts and designations, trade-specific media or additional classifications with respect to a catalogue in IDMP format. This data can be created by the trade as well as associations and similar, who would like to transfer texts, media and/or classifications that were adjusted for items and versions. These texts and media are only relevant for sales. For orders, the texts and designations of the original format must be used in IDMP format.If an element in the data pool references media, the reference must specify all relevant media, including those to be used by the base catalogue. This in particular applies to magnet planner information.


 attribute T_MODIFY_CONTENT_CATALOG/@MAJOR
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 3 |
maxInclusive | 3 |
annotation
documentation
The version number "MAJOR" specifies the format version the data pool is delivered. This major version number will only change in the case of a fundamental revision of the entire format.
The complete information about the format version in which a data pool is delivered consists of MAJOR, MINOR and REVISION.


 attribute T_MODIFY_CONTENT_CATALOG/@MINOR
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 1 |
annotation
documentation
The sub-version number "MINOR" usually changes every year. If the main version MAJOR is modified, the subversion is reset to 0.


 attribute T_MODIFY_CONTENT_CATALOG/@REVISION
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 0 |
annotation
documentation
The revision number "REVISION" highlights changes during the year resultant from individual working groups. The revisions are not published if they are not concerned with necessary corrections. Revision is reset to 0 with each new MINOR sub-version number.


 element T_MODIFY_CONTENT_CATALOG/CATALOG
diagram
properties
content complex
children CATALOG_IDENTIFICATION CATALOG_LANGUAGE CATALOG_NAME FILE_ID CATALOG_DATA_VERSION CATALOG_INFO CATALOG_VERSION FALL_BACK_LANGUAGE DETAIL_INFOS RECEIVER_ID
annotation
documentation
This element is used to store administrative information concerning the data pool.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_IDENTIFICATION
diagram
properties
content complex
children GLN_NO CATALOG_ID FILE_RELEASE_DATE
annotation
documentation
This element is used to specify the catalogue's identifying characteristics.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data must be identical.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_IDENTIFICATION/GLN_NO
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | (0-9){13} |
annotation
documentation
This element is used to enter the unique global location number (GLN) of the data supplier of this content backpack (not the provider of the basic catalogue).


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_IDENTIFICATION/CATALOG_ID
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
The manufacturer must enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.
This ID is required for identification in the case of multi-manufacturer catalogues.

A manufacturer catalogue must always have the same ID for the same dealership.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_IDENTIFICATION/FILE_RELEASE_DATE
diagram
type xs:dateTime
properties
content simple
annotation
documentation
This element provides the time stamp for the creation of the data pool in UTC time.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_LANGUAGE
diagram
properties
content complex
children ISO_LANGUAGE_ID
annotation
documentation
This element indicates the languages used in the data pool.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_LANGUAGE/ISO_LANGUAGE_ID
diagram
type restriction of xs:language
properties
minOcc | 1
maxOcc | unbounded
content | simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
The language code defines the language in which the texts in the data pool were created. The ISO language code must be used.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_NAME
diagram
type | languagetext30
properties
content complex
children | LANGUAGE
annotation
documentation
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.


 element languagetext30/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetext30/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext30/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,30} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/FILE_ID
diagram
type restriction of xs:boolean
properties
content simple
annotation
documentation
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_DATA_VERSION
diagram
type restriction of xs:date
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
This element must be filled if theCATALOG_MARK (catalogue identifier) element contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_INFO
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element is used to store the information texts.


 element languagetext/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute languagetext/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext/LANGUAGE/TEXT
diagram
type xs:string
properties
content simple
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
b Bold font
br line break


 element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_VERSION
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 999999999 |
annotation
documentation
The manufacturer of the data records can assign a version number for the catalogue in this field. If a new modification data pool is released for a base catalogue, the value in CATALOG_VERSION must be increased.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/FALL_BACK_LANGUAGE
diagram
type restriction of xs:language
properties
content simple
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified. The two-digit ISO language code must be used. The specified fallback language must be included in the catalogue


 element T_MODIFY_CONTENT_CATALOG/CATALOG/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element serves to specify modified images on catalogue level, e.g. a manufacturer or catalogue logo or special label.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference the detailed information.


 attribute T_MODIFY_CONTENT_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced detailed information.


 attribute T_MODIFY_CONTENT_CATALOG/CATALOG/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute allows for the detailed information a freely-defined sorting order.


 element T_MODIFY_CONTENT_CATALOG/CATALOG/RECEIVER_ID
diagram
type xs:string
properties
minOcc | 0
maxOcc | 1
content | simple
annotation
documentation
The recipient ID is entered here.


 element T_MODIFY_CONTENT_CATALOG/REF_CATALOG
diagram
properties
content complex
annotation
documentation
This references the catalogue to which the modified prices relate via the manufacturer's GLN and the CATALOG_ID of the base catalogue.


 attribute T_MODIFY_CONTENT_CATALOG/REF_CATALOG/@SUPPLIER_GLN_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
pattern | [0-9]{13} |
annotation
documentation
This element is used to enter a unique global location number (GLN) of the manufacturer of the base catalogue. The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data.


 attribute T_MODIFY_CONTENT_CATALOG/REF_CATALOG/@CATALOG_ID
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 64 |
annotation
documentation
The unique ID (e.g. GUID) of a manufacturer is entered here in order to provide a unique identification of the base catalogue. The value must be identical to the value of CATALOG_ID under CATALOG in the base catalogue.

A manufacturer catalogue must always have the same ID for the same dealership.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFOS
annotation
documentation
This element is used to specify data that is valid for the data pool (global information).


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO
annotation
documentation
This element is used to specify the detail information (media) that is valid for the data pool (global information).


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION INFO_TYPE EXTERNAL_NAME INTERNAL_NAME TOOL_TIP URL
annotation
documentation
This element is used to specify URLs to detailed information.


 attribute T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute identifies a detailed information.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/CLASSIFICATION
diagram
type restriction of xs:string
properties
content simple
annotation
documentation
This element is used to classify detailed information.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INFO_TYPE
diagram
type restriction of xs:positiveInteger
properties
content simple
facets
Kind | Value | Annotation
minInclusive | 1 |
maxInclusive | 17 |
pattern | (1[0,7] | [1,9]) |
annotation
documentation
This element is here to describe the type of detailed information. The values of the available info types can be found in the corresponding table in the introduction.
Media references for descriptions of function are possible both on the ITEM and on the SERIES. Format MP4 is recommended for videos.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains the display name of the link (e.g. "sketch 4711").


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
diagram
type | languagetext40
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.


 element languagetext40/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetext40/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext40/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,40} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
This element contains the text for a link note.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL
diagram
properties
content complex
children LANGUAGE
annotation
documentation
This element specifies the URL to the detailed information. In multilingual catalogues, the URL is only to be saved once in the specified fallback language.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT HASH_VALUE
annotation
documentation
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute is used to specify the ISO code of the language in which the text is stored.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/TEXT
diagram
type xs:anyURI
properties
content simple
annotation
documentation
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/URL/LANGUAGE/HASH_VALUE
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
minLength | 32 |
maxLength | 32 |
annotation
documentation
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not.


 element T_MODIFY_CONTENT_CATALOG/SERIES
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SERIE
annotation
documentation
This element is used to specify all series of the catalogue/data pool with the elements assigned to them, e.g. product groups or items, for which modified texts, detail information or additional classifications are specified.

A series usually corresponds to a model.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE
diagram
properties
minOcc | 1
maxOcc | 1000000
content | complex
children SERIES_TEXT PRODUCT_GROUPS DETAIL_INFOS
annotation
documentation
This element is used to store a series together with the corresponding items. A series corresponds to a model. The numbers and designations stated here must correspond to those in the base catalogue.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/@SERIE_NO
type restriction of xs:nonNegativeInteger
properties
use required
facets
Kind | Value | Annotation
minInclusive | 0 |
maxInclusive | 999999 |
annotation
documentation
This attribute is used to specify the serial number of the base catalogue.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/SERIES_TEXT
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children FULL_TEXT
annotation
documentation
This element is used to define the series-specific texts.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/SERIES_TEXT/FULL_TEXT
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
The full text contains the complete description of the series. The HTML tags bold and line break can be used within the text. Images are not be be included.
This element contains the full text in a CDATA node. The text must be specified in HTML format:
b Bold font
br Line break


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children PRODUCT_GROUP
annotation
documentation
This element is used to specify the product groups. They must correspond to those in the base catalogue.Product groups are used to combine articles with identical version types (e.g. upholstered furniture with armrests).


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEMS
annotation
documentation
This element is used to create modified items that are combined in product groups.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
diagram
properties
content complex
children ITEM
annotation
documentation
This element is used to specify all items of a product group for which the texts, detail information or classifications are modified for the specific trade.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children ITEM_TEXT CLASSIFICATIONS
annotation
documentation
This element is used to specify items in accordance with the base catalogue. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.

Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/@TYPE_NO
type restriction of xs:string
properties
use required
facets
Kind | Value | Annotation
minLength | 1 |
maxLength | 30 |
annotation
documentation
This element is used to enter the item code/item type.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children SHORT_TEXT FULL_TEXT
annotation
documentation
This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. The short text may consist of three lines.

This element is only specified if a trade-specific text should be used for the item.

The later order must contain the original text.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT >
diagram
properties
content complex
children LANGUAGE
annotation
documentation
This element contains short texts.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT_LINE
annotation
documentation
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/@ISO_LANGUAGE_ID >
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE >
diagram
properties
minOcc | 1
maxOcc | 3
content | complex
children TEXT
annotation
documentation
This element is used to specify a line of text.
The SEQUENCE_NO attribute is used to specify the order of the text line. The order of the text line must be specified because it cannot be assured that the originally specified order of elements is retained during processing of the XML data.

The TEXT element contains the text.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/@SEQUENCE_NO >
type restriction of xs:positiveInteger
properties
use required
annotation
documentation
This attribute defines the order of the text line in a text of multiple lines. The value 1 is entered for a text with a single line.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE/TEXT_LINE/TEXT >
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\S ]{1,30} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT >
diagram
type | languagetext
properties
minOcc | 0
maxOcc | 1
content | complex
children | LANGUAGE
annotation
documentation
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

b bold font
br line break


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children CLASSIFICATION
annotation
documentation
This element is used to store standardized classifications.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION >
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children CLASSIFICATION_CODE VALID_FROM VALID_UNTIL
annotation
documentation
This element contains the characteristics of a classification scheme.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/@CLASSIFICATION_ID >
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
pattern | ([1-9]{1}|1[0]{2}) |
annotation
documentation
This attribute specifies the classification scheme. The values in the following list are available to choose from:

ID Classification scheme
1 eCl@ss
2 Begros organisation classification
3 VME organisation classification
4 Eco Mobilier code
5 eco system EEE
6 free classification scheme
7 free classification scheme
8 free classification scheme
9 free classification scheme
10 free classification scheme

If the scheme that is to be maintained is not in the list, then an ID from 6 is to be chosen for free classification scheme.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/CLASSIFICATION_CODE >
diagram
type xs:string
properties
content simple
annotation
documentation
This element contains the code for the category of the classification scheme that is to be assigned to the ITEM.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_FROM >
diagram
type xs:date
properties
content simple
annotation
documentation
This element indicates the date from which the classification specification is valid.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/CLASSIFICATIONS/CLASSIFICATION/VALID_UNTIL >
diagram
type xs:date
properties
content simple
annotation
documentation
This element indicates the date until which the classification specification is valid.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/DETAIL_INFOS
diagram
properties
minOcc | 0
maxOcc | 1
content | complex
children DETAIL_INFO_REF
annotation
documentation
This element is used to specify trade-specific detailed media information, such as milieu photos, PDFs or video links for the series. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.


 element T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
annotation
documentation
This element is used to reference the detailed information.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF/@DETAIL_INFO_NO
type restriction of xs:positiveInteger
properties
use required
facets
Kind | Value | Annotation
maxInclusive | 999999999 |
annotation
documentation
This attribute is used to specify the identification number of the referenced detailed information.


 attribute T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/DETAIL_INFOS/DETAIL_INFO_REF/@SEQUENCE_NO
type restriction of xs:positiveInteger
properties
use required


 complexType languagetext
diagram
children LANGUAGE
used by
elements T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_INFO T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/EXTERNAL_NAME T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/SERIES_TEXT/FULL_TEXT T_MODIFY_CONTENT_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/FULL_TEXT T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/TOOL_TIP
annotation
documentation
This data type is used to create multiple-language texts of any length.


 complexType languagetext30
diagram
children LANGUAGE
used by
element T_MODIFY_CONTENT_CATALOG/CATALOG/CATALOG_NAME
annotation
documentation
This data type is used to create multiple-language texts with a maximum length of 30 characters.


 complexType languagetext40
diagram
children LANGUAGE
used by
element T_MODIFY_CONTENT_CATALOG/GLOBAL_DEFINITION/DETAIL_INFOS/DETAIL_INFO/INTERNAL_NAME
annotation
documentation
This data type is used to create multiple-language texts with a maximum length of 40 characters.


 complexType languagetext60
diagram
children LANGUAGE
annotation
documentation
This data type is used to create multiple-language texts with a maximum length of 60 characters.


 element languagetext60/LANGUAGE
diagram
properties
minOcc | 1
maxOcc | unbounded
content | complex
children TEXT
annotation
documentation
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION


 attribute languagetext60/LANGUAGE/@ISO_LANGUAGE_ID
type restriction of xs:language
properties
use required
facets
Kind | Value | Annotation
pattern | [A-Z]{2} |
annotation
documentation
This attribute specifies the ISO code of the stored text's language.


 element languagetext60/LANGUAGE/TEXT
diagram
type restriction of xs:string
properties
content simple
facets
Kind | Value | Annotation
pattern | [\p{L}\p{N}\p{P}\p{S}][\p{L}\p{N}\p{P}\p{S} ]{1,60} |
annotation
documentation
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

XML Schema documentation generated by XMLSpy Schema Editor http://www.altova.com/xmlspy