%%ItemTitle%%

IDMW 2.0 XML-Schema Dokumentation
Einleitung

IDMW 2.0.0 XML-Schema

Dokumentation

Stand 01 .11.2019

Dokumentiertes XML-Schema:

IDMW_2_0_0.xsd

Kontakt

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@vhk-herford.de
Telefon 0 52 21/12 65-37


%%ItemTitle%%

Grundstruktur des IDM-Schemas
Einleitung > Grundstruktur des IDM-Schemas

Die Grundstruktur des IDM-Schemas

Das Hauptelement T_NEW_CATALOG definiert, dass ein neuer, vollständiger Katalogdatenbestand bereitgestellt wird.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_NEW_CATALOG abgebildet werden.

Abbildung 1 - Child-Elemente von T_NEW_CATALOG

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

SUPPLIER

In SUPPLIER werden administrative Informationen zu dem Hersteller hinterlegt. Beispielsweise werden Kontaktdaten, EDI-Kommunikationsparameter oder das Herkunftsland des Herstellers angegeben.

GLOBAL_DEFINITION

Der Datenbereich GLOBAL_DEFINITION ist eine Art Datenpool für Informationen, die in den anderen Datenbereichen verwendet werden. Beispielsweise werden hier Standardgrifflagen oder die Informationen über Serien angelegt.

SERIES

In SERIES werden die Daten für die Beschreibung der Artikel hinterlegt. Dabei werden die Artikel in Produktgruppen wie beispielsweise Unterschränke oder Regale gruppiert.

PART_LISTS

In PART_LISTS werden die Daten für die Beschreibung der dynamischen Stücklisten hinterlegt, wobei die Unterpositionen Regeln (DECISIONS) tragen können, die variantenabhängig bestimmen, in welcher anzahl die jeweilige Position in der Stückliste auftaucht.

FEATURE_DEFINITION

In FEATURE_DEFINITION werden Varianteninformationen hinterlegt. Beispielsweise werden Daten Variantenfamilien (FEATURE_CLASS), Variantenarten (FEATURE), die zugehörigen Varianten (OPTION_DEFINITION) oder Prüfverfahren (RESTRICTION) angelegt.

PRICE_DEFINITION

In PRICE_DEFINITION werden Preisinformationen hinterlegt. Beispielsweise werden Daten für Preiseigenschaftsgruppen (PRICE_FEATURE_GROUP), Mehrwertsteuer (VALUE_ADDED_TAXES), Warengruppen (MERCHANDISE_GROUP) oder Preisarten (PRICE_TYPE) nagelegt.

Siehe auch
T_NEW_CATALOG Element


%%ItemTitle%%

Elemente der Katalogstruktur
Einleitung > Elemente der Katalogstruktur

Elemente der Katalogstruktur anlegen

Serieninformationen anlegen

Serien werden in folgendem Element definiert:

T_NEW_CATALOG/SERIES/SERIE

Alle Child-Elemente werden verwendet, um die Eigenschaften der Serien zu beschreiben. Varianten werden Serien über Prüfverfahren (RESTRICTION_REF) zugeordnet.

Varianten anlegen

Beispiel: Anlegen von Varianten

1. Definition der Varianteneigenschaften/ Variantenausprägungen

Die Varianteneigenschaften werden im folgenden Element definiert:

FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

</OPTION_DEFINITION>

In diesem Element werden die Ausprägungen von Farben, Materialien, Formvarianten und Maßen definiert.

2. Erstellen der Varianten

Die Varianten werden in folgendem Element erstellt:

FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_KEY="L"

</OPTION>

<OPTION OPTION_KEY="S"

</OPTION>

</OPTIONS>

</FEATURE>

Variantenarten werden über Variantenartennummern z. B. 1 definiert. Die Variante wird über die Kombination von FEATURE_NO in FEATURE_DEFINITION/FEATURES/FEATURE und OPTION_KEY in FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION eindeutig identifiziert.

Artikelinformationen anlegen

Artikelinformationen werden im folgenden Element angelegt:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Das Element ITEM besitzt eine Vielzahl von Elementen mit denen die Eigenschaften von Artikeln beschrieben werden können. Die Identifizierung eines Artikels erfolgt über das Attribut TYPE_NO.

Hierbei ist jedoch zu beachten, dass ein Artikel in Abhängigkeit der Serie unterschiedliche Eigenschaften haben kann. Demzufolge wird ein Artikel mit seinen Eigenschaften nur eindeutig in Verbindung mit der Serie identifiziert.

Serienspezifische Artikelinformationen

Artikel können in Anhängigkeit der Serie unterschiedliche Eigenschaften haben. Artikel sind einer Serie automatisch zugeordnet, da das Elemente ITEM ein Kind-Element des Elementes SERIE ist.

Varianteninformationen anlegen

Varianteninformationen werden im IDM-Schema wie nachfolgend beschrieben angelegt:

- Anlegen der Ausprägungen für die Varianten

- Zuordnen von Ausprägung und Variantenart

Anlegen der Ausprägungen

Die Ausprägungen für die Varianten werden als Datenpool in dem Element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert.

Abbildung 2 – Das Element OPTION_DEFINITION

Das Element OPTION_DEFINITION enthält Elemente, in denen die jeweiligen Ausprägungen angelegt werden:

MATERIAL | In diesem Element werden die Eigenschaften von Materialien mittels Farben und Texturen definiert. Diese Elemente werden aus Ausführungsvariantenarten referenziert.
FORM | In diesem Element werden die Nummern für Formvarianten (FORM_NO) definiert. Zum aktuellen Stand des IDM-Schema werden in diesem Element mit Ausnahme der FORM_NO keine weiteren Eigenschaften gepflegt.
OPTION_MEASURE | In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Sitzhöhe(Variantenart 35).

Beispiel: Ausprägungen für Farben

<OPTION_DEFINITION>

<MATERIAL>

<COLOR COLOR_NO="1">

<RGB_RED>255</RGB_RED>

<RGB_GREEN>0</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="2">

<RGB_RED>133</RGB_RED>

<RGB_GREEN>273</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="3">

<RGB_RED>0</RGB_RED>

<RGB_GREEN>89</RGB_GREEN>

<RGB_BLUE>89</RGB_BLUE>

</COLOR>

</MATERIAL>

</OPTION_DEFINITION>

Die obigen Elemente definieren drei Farben, die über die Nummern (COLOR_NO) 1-3 identifiziert werden.

Zuordnen von Ausprägung und Variantenart

Die beispielartig definierten Farben müssen, um sie nutzen zu können, Variantenarten zugeordnet werden, wodurch Varianten entstehen.

Die Zuordnung von Variantenarten (FEATURE) und Ausprägungen (OPTION) zu Varianten erfolgt im Element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE. Eine Variante wird durch die Kombination von FEATURE und OPTION gebildet und identifiziert. Die nachfolgenden XML-Elemente definieren 2 Fußhöhen (Variantenart 15).

Beispiel: Aufbau der Varianten aus Variantenart und Ausprägungen

<FEATURE FEATURE_NO="15">

<OPTIONS>

<OPTION OPTION_KEY="10">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

<OPTION OPTION_KEY="30">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

</OPTIONS>

<FEATURE_TEXT>

</FEATURE_TEXT>

<HEADER_POS_VARIATION_TYPE>K</HEADER_POS_VARIATION_TYPE>

</FEATURE>

Die Child-Elemente von FEATURE beschreiben die Eigenschaften der Variantenart und die Child-Elemente von OPTION beschreiben die Eigenschaften der Variante. Entsprechend diesem Prinzip, welches grundlegend für alle Elemente im IDM-Schema gilt, wird durch das Element OPTION_TEXT ein Text definiert, der die Variante bezeichnet. Das Element FEATURE_TEXT definiert einen Text, der die Variantenart bezeichnet.

Soll in den Daten eine Variante referenziert werden, muss immer die Kombination aus FEATURE_NO und OPTION_KEY als Referenzierungschlüssel angegeben werden.


%%ItemTitle%%

Aufbauen der Katalogstruktur
Einleitung > Aufbauen der Katalogstruktur

Aufbauen der Katalogstruktur

Varianten Serien zuordnen

Varianten werden allen Serien in folgendem Element zugeordnet:

SERIES/DECISIONS/DECISION_REF

Die Variante wird der Serie zugeordnet, in dem eine Regel referenziert wird, welches die Variante als gültige Kombination definiert in dem Element SERIES/SERIE/DECISIONS/DECISION_REF.

Artikel, Serien und Varianten zuordnen

Artikel-Serien Zuordnung

Artikel werden Serien automatisch zugeordnet, da das Element ITEM ein Kind-Element des Elementes SERIES ist:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Es können Artikelspezifisch Regeln über SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISIONS_REF formuliert werden.

Beispiel: Regel zur Varianten-Zuordnung

Element: FEATURE_DEFINITION/DECISIONS/DECISION

<DECISIONS>
<DECISIONVALIDATION_TYPE="0"DECISION_NO="1">
<DECISION_NAME_TEXT>
<LANGUAGEISO_LANGUAGE_ID="EN">
<TEXT_LINESEQUENCE_NO="1">
<TEXT>item numbers</TEXT>
</TEXT_LINE>
</LANGUAGE>
</DECISION_NAME_TEXT>
<OPTION_COMBINATIONSEQUENCE="1">
<FEATURE_REFFEATURE_NO="1">
<OPTION_REF_OPOPTION_KEY="1"OPERATOR="eq"/>
</FEATURE_REF>
<FEATURE_REFFEATURE_NO="201">
<OPTION_REF_OPOPTION_KEY="0"OPERATOR="eq"/>
</FEATURE_REF>
<FEATURE_REFFEATURE_NO="202">
<OPTION_REF_OPOPTION_KEY="00"OPERATOR="eq"/>
</FEATURE_REF>
<ACTIONS>
<SET_FEATURE_FIXEDFEATURE_NO="204">
<OPTION_REFOPTION_KEY="1000"/>
</SET_FEATURE_FIXED>
</ACTIONS>
</OPTION_COMBINATION>
</DECISION>
</DECISIONS>


%%ItemTitle%%

Katalogstruktur
Einleitung > Katalogstruktur

Katalog- und Elementstruktur

Die Katalogstruktur wird im IDM-Schema durch die folgende Elementhierarchie abgebildet:

Abbildung 1 – Elementhierarchie im IDM-Schema

In dem Element SERIE werden die Eigenschaften einer Serie definiert. Innerhalb der Serie werden Produktgruppen (PRODUCT_GROUPS) definiert, in denen Artikel (ITEMS) mit gleichartigen Variantenarten zusammengefasst sind. Die Artikel sind einer Serie automatisch zugeordnet, da sie Kind-Elemente des Elementes SERIE sind. Über die Elemente DECISIONS werden serienübergreifend, einer Serie, einer Produktgruppe oder einem Artikel Varianten über Regeln zugeordnet. Zusätzlich ist es möglich über DECISIONS formulierten Regeln Aktionen (ACTIONS) zuzuordnen.


%%ItemTitle%%

Referenzierung
Einleitung > Referenzierung

Referenzierung von Elementen

Im IDM-Schema werden Beziehungen zwischen Elementen aufgebaut und Informationen an zentraler Stelle definiert und an anderer Stelle mehrfach verwendet. Die Wiederverwendung der Informationen und der Aufbau von Elementbeziehungen erfolgt über Referenzierung. Die im IDM-Schema angewendete Art der Referenzierung wird nachfolgend beschrieben.

Begriffsdefinition

Im IDM-Schema werden für die Referenzierung von Elementen folgende Begriffe verwendet:

Key-Element | Ein XML-Element, welches von anderen Elementen referenziert wird.
Ref-Element | Ein XML-Element, welches andere Elemente referenziert.

Vorgang der Referenzierung

Das Key-Element besitzt Attribute, über die es eindeutig identifiziert wird. Das Ref-Element besitzt minimal die Key-Attribute des Key-Elementes. Zwischen den Elementen wird die Referenz aufgebaut, in dem die Attributwerte des Ref-Elementes denen des Key-Elementes entsprechen.

Beispiel: Referenzierung der Regel serienübergreifend, aus der Serie, der Produktgruppe und dem Artikel

Das nachfolgende Beispiel zeigt, wie von einem Artikel (ITEM) eine Regel (DECISION) referenziert wird. Die XML-Elemente sind nur auszugsweise dargestellt.

Key-Element

T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS

<DECISIONS>

<DECISION DECISION_NO="1"/> … </DECISION>

<DECISION DECISION_NO="2"/> … </DECISION>

<DECISION DECISION_NO="3"/> … </DECISION>

. . .

</DECISIONS>

Ref-Element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS>

<ITEM TYPE_NO="1111">

<DECISIONS>

<DECISION_REF DECISION_NO="1" > … </DECISION_REF>

. . .

</ITEMS>

Beispiel: Referenzierung einer Varianten

Im folgenden Beispiel wird eine Variante aus einem Prüfverfahren heraus referenziert.

Key-Element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="15"> <!-- Fußhöhe -->

<OPTIONS>

<OPTION OPTION_KEY="100"> … </OPTION>

<OPTION OPTION_KEY="120"> … </OPTION>

<OPTION OPTION_KEY="30"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="17"> <!-- Fußform -->

<OPTIONS>

<OPTION OPTION_KEY="F00"> … </OPTION>

<OPTION OPTION_KEY="F3Z"> … </OPTION>

<OPTION OPTION_KEY="F70"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

Die XML-Elemente definieren für die Variantenart 15 (FEATURE) drei Varianten (OPTION) mit den Schlüsseln 100,120,30 sowie für die Variantenart 17 drei Varianten mit den Schlüsseln F00, F3Z, F70. Eine Variante wird identifiziert über die Kombination FEATURE_NO und OPTION_KEY.


%%ItemTitle%%

Pruefverfahren

Definition und Zuordnung von Prüfverfahren

Prüfverfahren können Serien-übergreifend, Serien- oder Artikel-spezifisch gültig sein. Je tiefer in der Hierarchie Serie->Artikel ein Prüfverfahren zugeordnet wird, desto höher ist seine Priorität. Ein Prüfverfahren auf Artikelebene übersteuert beispielsweise ein Prüfverfahren, welches auf Serienebene zugeordnet wurde. Ein übersteuerndes Prüfverfahren kann jedoch nur weitere Einschränkungen definieren. Beispielsweise ist es nicht möglich, dass über ein Artikel-spezifisches Prüfverfahren Varianten wieder verfügbar gemacht werden, die bereits von einem Serien-spezifischen Prüfverfahren ausgeschlossen wurden.

Prüfverfahren werden zunächst unabhängig von ihrer späteren Zuordnung angelegt und dann Serien oder Artikeln zugeordnet.

Anlage von Prüfverfahren

Prüfverfahren werden in folgendem Element angelegt:

FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

In dem Element RESTRICTION werden Variantenarten referenziert, für deren Kombinationen das Prüfverfahren angelegt werden soll. In dem Element OPTION_REF werden die Varianten referenziert, deren Kombinationen geprüft werden sollen. Es dürfen nur die Varianten referenziert werden, deren Variantenarten in dem Element RESTRICTION referenziert wurden. Das Element TEST_ID definiert, ob die angegebene Variantenkombination zulässig oder unzulässig ist.

Beispiel: Definition von Prüfverfahren

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="10017" FEATURE_1_NO="17" FEATURE_2_NO="18" VALDATION_TYPE="0" >

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="F50" FEATURE_NO="17"/> #Holzfuß

<OPTION_REF OPTION_KEY="P44" FEATURE_NO="18"/> #Ahornfarbig

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="F50" FEATURE_NO="17"/> #Holzfuß

<OPTION_REF OPTION_KEY="P51" FEATURE_NO="18"/> #Kirschbaumfarbig

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="F91" FEATURE_NO="17"/> #Metallfuß

<OPTION_REF OPTION_KEY="P20" FEATURE_NO="18"/> #silber

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

Im obigen Beispiel ist ein Prüfverfahren definiert, welches die Kombinationen von Varianten der Variantenart „Fußform “ (Nr. 17) und der Variantenart „Fußfarbe“ (Nr. 18) definiert. Nach dem obigen Prüfverfahren sind die Kombinationen Holzfuß-Ahornfarbig, Holzfuß-Kirschbaumfarbigund Metallfuß-silber erlaubt (TEST_ID = 1). Beim Auflisten der Variantenkombinationen (OPTION_REF) muss die Reihenfolge eingehalten werden, wie diese durch die Attribute von RESTRICTION (FEATURE_1_NO, FEATURE_2_NO) gegeben wird.

Für die Identifizierung wird dem Prüfverfahren eine eindeutige Nummer (RESTRICTION_NO) zugewiesen.

Zuordnung von Prüfverfahren

Serien-übergreifende Zuordnung

Prüfverfahren werden Serien-übergreifend mit folgendem Element zugeordnet:

SERIES/RESTRICTIONS/RESTRICTION_REF

Das Element RESTRICTION_REF ist Kind-Element des Elementes SERIES/RESTRICTIONS, hierdurch werden die in RESTRICTION_REF referenzierten Prüfverfahren allen Serien zugeordnet, die in SERIES/SERIE definiert werden.

Beispiel: Serien-übergreifende Zuordnung von Prüfverfahren

<SERIES>

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="523"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="678"/>

</RESTRICTIONS>

</SERIES>

In dem obigen Beispiel werden die Prüfverfahren 523 und 678 referenziert und damit allen Serien zugeordnet.

Serien-spezifische Zuordnung

Die Serien-spezifische Zuordnung von Prüfverfahren erfolgt nach selbem Muster, wie die Serien-übergreifende Zuordnung. Für die Serien-spezifische Zuordnung wird das folgende Element verwendet:

SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF

Die in RESTRICTION_REF referenzierten Prüfverfahren werden der Serie zugeordnet, innerhalb derer die Referenzierung erfolgte.

Beispiel: Serien-spezifische Zuordnung von Prüfverfahren

<SERIES>

<SERIE SERIE_NO="2">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="67"/>

</RESTRICTIONS>

</SERIE>

<SERIE SERIE_NO="7">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="123"/>

</RESTRICTIONS>

</SERIE>

</SERIES>

Im obigen Beispiel wurden der Serie „2“ die Prüfverfahren 45 und 67 sowie der Serie „7“ die Prüfverfahren 45 und 123 zugeordnet.

Artikelspezifische Zuordnung

Die Artikel-spezifische Zuordnung von Prüfverfahren erfolgt in folgendem Element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

Die Zuordnung der Prüfverfahren erfolgt wie bei der Serien-spezifischen Zuordnung.

Sind einem Artikel keine Prüfverfahren zugeordnet, dann ist dieser ohne Einschränkungen hinsichtlich der Varianten lieferbar.

Produktgruppen-spezifische Zuordnung

Die Produktgruppen-spezifische Zuordnung von Prüfverfahren erfolgt in folgendem Element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF

Die Zuordnung der Prüfverfahren erfolgt wie bei der Serien-spezifischen Zuordnung.

Regeln

Parallel zu den RESTRICTIONS gibt es nun die DECISIONS.

Eine Zuordnung der Regeln/Prüfverfahren zu Serien oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien oder Artikeln referenziert werden.

Regeln, die von Artikeln referenziert werden, haben Vorrang gegenüber den Regeln, die von Serien referenziert werden.

Bei den DECISIONS findet man 3 Typen von Regeln (über die TEST_ID gekennzeichnet).

Abhängig von dem Element TEST_ID können unterschiedliche Regeln formuliert werden.

Ist der Wert von TEST_ID 1, handelt es sich um eine Erstellungsregel (Preparation Rule).

Hierüber können nun Mengen von gültigen Varianten in OPTION_COMBINATION definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

Die Bedingungen wurden um Operatoren ergänzt. Hierfür wurde ein extra Datentyp definiert. Dieser kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Die einzelnen OPTION_COMBINATIONs sind allerdings als ELSE Zweige zu betrachten. Das heißt, sobald eine Bedingungszeile (OPTION_COMBINATIONS) einen Treffer bekommen hat, werden die anderen nicht mehr durchlaufen.

Ist der Wert von TEST_ID 2, handelt es sich um eine Aktionsregel (Action Rule). Hier können zusätzlich zu den Bedingungen noch Aktionen definiert werden.

Wenn alle Bedingungen innerhalb einer „OPTION_COMBINATION“ erfüllt sind, dann werden alle zugeordneten Aktionen (ACTIONS) ausgeführt, die abhängig von Bedingungen Werte setzen oder auch Variantenarten (FEATURES) ausblenden können. Ist eine OPTION_COMBINATION erfüllt, werden auch hier die anderen Bedingungen nicht mehr durchlaufen.

Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

  • Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

§ Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

§ das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

§ das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

  • Das Setzen von Defaultvarianten (SET_FEATURE_DEFAULT):
    Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.
  • Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
    So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

Action Rules werden im Konfigurator meistens genutzt, wenn sich ein Optionswert (eine Variante) ändert. So kann z.B. dann, wenn sich die Fußvariante von Edelstahl auf Holz ändert, eine Variantenart für den Beizton angezeigt werden.


%%ItemTitle%%

Datentypen
Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

In der Version IDMP 2.4 werden folgende Datentypen verwendet:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDMP wird der Datentyp date XML-Schema konform in folgender Weise angewendet: YYYY-MM-DD Y = Jahr, M = Monat, D = Tag
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDMP für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDMP für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDMP für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.

Zusätzlich gibt es einen benutzerdefinierten Datentyp

operator

Der Datentyp wird im IDMP für Regeln genutzt. Mit diesem einfachen selbst definierten Datentyp wird ein Operator für Vergleiche formuliert. Der Vergleichsoperator stellt sich als string der Länge 1 bis 4 dar und kann der folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Die Wertebereiche der obigen Datentypen sind im Allgemeinen für die Elemente im IDMP eingeschränkt. Über "restrictions" bei der Datentypdefinition sind Minimal- und Maximalwerte, zulässige Zeichen (pattern) sowie Wertlisten eingeschränkt.

In der Dokumentation zum XML-Schema des IDMP sind die Wertebereiche durch die Angabe hinter M und P spezifiziert.


%%ItemTitle%%

Erläuterung zur Dokumentation
Einleitung > Erläuterung zur Dokumentation

Erläuterungen zur Dokumentation des IDM

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

EXCHANGE_ID_NO Attribute

Description
" -->
Beschreibung
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


%%ItemTitle%%

Variantenarten
Einleitung > Variantenarten

Variantenarten

Folgende Variantenarten wurden definiert:

Variantenart | Variantentext | Ausführungsart | Bemerkung
1 | Programm | A | Programm als Variantenart
100 | Frontausführung | A |
101 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
102 | Frontfarbe 2 | F | Rahmen
103 | Frontfarbe 3 | F | Lisenen
104 | Kantenfarbe Front | F |
105 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
106 | Frontgruppe | A | Überschreibt die FRONT_GROUP_NO in FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Frontausführung Absetzung 1 | A |
111 | Frontfarbe 1 Absetzung 1 | F | Füllung glatte Front = ganze Fläche
112 | Frontfarbe 2 Absetzung 1 | F | Rahmen
113 | Frontfarbe 3 Absetzung 1 | F | Lisenen
114 | Kantenfarbe Front Absetzung 1 | F |
115 | Front-Kombination Absetzung 1 | K | Darf die Varianten 111 bis 114 enthalten
120 | Frontausführung Absetzung 2 | A |
121 | Frontfarbe 1 Absetzung 2 | F | Füllung glatte Front = ganze Fläche
122 | Frontfarbe 2 Absetzung 2 | F | Rahmen
123 | Frontfarbe 3 Absetzung 2 | F | Lisenen
124 | Kantenfarbe Front Absetzung 2 | F |
125 | Front-Kombination Absetzung 2 | K | Darf die Varianten 121 bis 124 enthalten
150 | Glasausführung | A |
151 | Glasfarbe | F |
152 | Sprossenausführung | A |
153 | Sprossenfarbe | F |
154 | Ausführung Glastürrahmen | A |
155 | Farbe Glastürrahmen | F |
160 | Ausführung Jalousie | A |
161 | Farbe Jalousie | F |
170 | Ausführung Schütte | A |
171 | Farbe Schütte | F |
200 | Korpusausführung | A |
201 | Korpus-Kombination | K | Wenn für mehrere Korpusfarben - innen/außen - nur ein Schlüssel vorhanden ist.
202 | Korpusfarbe außen | F |
203 | Korpusfarbe innen | F |
204 | Kantenausführung Korpus | A |
205 | Kantenfarbe Korpus | F |
206 | Sichtseiten-Ausführung | A |
207 | Sichtseiten-Farbe | F |
208 | Korpusfarbe innen für Glas | F | Glasschränke und offene Schränke, die kein Regal sind.
209 | Korpusausf. innen für Glas | A | Glasschränke und offene Schränke, die kein Regal sind.
300 | Griffausführung | A |
301 | Griff-Farbe 1 | F | Griff-, Knopfsockel- bzw. Hauptfarbe
302 | Griff-Farbe 2 | F | Bügel-, Steg- und Knopfblendenfarbe
303 | Griff-Kombination | K | Wenn nur ein Schlüssel für mehrere Griffbedingungen vorgegeben ist.
304 | Grifflagen |  |
400 | Sockelausführung | A |
401 | Sockelfarbe | F |
402 | Sockelhöhe | A |
410 | Ausführung Sockelboden | A |
411 | Farbe Sockelboden | F |
500 | Ausführung Regale | A |
501 | Farbe Regale | F |
502 | Ausführung Kranzprofil | A | Beinhaltet Form und Material
503 | Farbe Kranzprofil | F |
504 | Ausführung Lichtleiste | A | Beinhaltet Form und Material
505 | Farbe Lichtleiste | F |
506 | Ausführung Deckenblende | A |
507 | Farbe Deckenblende | F |
508 | Ausf. u. Schr.-abschlussleiste | A | Untere Schrankabschlußleiste
509 | Farbe u. Schr.-abschlussleiste | F | Untere Schrankabschlußleiste
510 | Ausführung Oberboden | A |
511 | Farbe Oberboden | F |
512 | Ausführung Oberboden-Kante | A |
513 | Farbe Oberboden-Kante | F |
514 | Ausführung Bord | A |
515 | Farbe Bord | F |
516 | Ausführung Bordkante | A |
517 | Farbe Bordkante | F |
520 | Ausführung Wangen/Riegel | A |
521 | Farbe Wangen/Riegel | F |
522 | Ausführung Wangenkante | A |
523 | Farbe Wangenkante | F |
524 | Ausführung Unterboden | A |
525 | Farbe Unterboden | F |
526 | Ausführung Unterboden-Kante | A |
527 | Farbe Unterboden-Kante | F |
550 | Nischenausführung | A |
551 | Nischenfarbe | F |
560 | Ausführung Nischenzubehör | A |
561 | Farbe Nischenzubehör | F |
562 | Ausführung Pilaster | A |
563 | Farbe Pilaster | F |
564 | Ausführung Pilasterkante | A |
565 | Farbe Pilasterkante | F |
570 | Ausführung Paneel | A |
571 | Farbe Paneel | F |
600 | Arbeitsplatten-Ausführung | A |
601 | Arbeitsplatten-Farbe | F |
602 | Arbeitsplattenkantenausführung | A |
603 | Arbeitsplatten-Kantenfarbe | F |
604 | Barplatten-Ausführung | A |
605 | Barplatten-Farbe | F |
606 | Barplatten-Kantenausführung | A |
607 | Barplatten-Kantenfarbe | F |
620 | Abdeckplatten-Ausführung | A |
621 | Abdeckplatten-Farbe | F |
622 | Abdeckplatten-Kantenausführung | A |
623 | Abdeckplatten-Kantenfarbe | F |
624 | Ansetztisch-Ausführung | A |
625 | Ansetztisch-Farbe | F |
626 | Ansetztisch-Kantenausführung | A |
627 | Ansetztisch-Kantenfarbe | F |
650 | WAP-Ausführung | A | Wandabschlussprofil
651 | WAP-Farbe | F | Wandabschlussprofil
700 | Schubkastenausführung | A | Innenausstattung
701 | Schubkastenfarbe | F | Innenausstattung
702 | Auszugsausführung | A | Innenausstattung
703 | Auszugsfarbe | F | Innenausstattung
750 | Arbeitsplattenform | S |
751 | Kranzleistenform | S |
752 | Lichtleistenform | S |
753 | Sockelform | S |
754 | Wandabschlussform | S |
755 | Abdeckplattenform | S |
756 | Barplattenform | S |
800 | Ausführung Elektrogeräte | A |
801 | Farbe Elektrogeräte | F |
802 | Farbe Elektrogeräte-Zubehör | F |
850 | Ausführung Spülen | A |
851 | Farbe Spülen | F |
852 | Farbe Spülenzubehör | F |
853 | Mischbatterien Farbe | F |
854 | Ausführung Mischbatterien | A |
900 | Ausführung Allgemeines Zubehör | A |
901 | Farbe Allgemeines Zubehör | F |
930 | zus. grafisch relevante Ausführung 1 | A | unbedingt den Softwarehäusern separat mitteilen
931 | zus. grafisch relevante Farbe 1 | F | unbedingt den Softwarehäusern separat mitteilen
932 | zus. grafisch relevante Ausführung 2 | A | unbedingt den Softwarehäusern separat mitteilen
933 | zus. grafisch relevante Farbe 2 | F | unbedingt den Softwarehäusern separat mitteilen
934 | zus. grafisch relevante Ausführung 3 | A | unbedingt den Softwarehäusern separat mitteilen
935 | zus. grafisch relevante Farbe 3 | F | unbedingt den Softwarehäusern separat mitteilen
936 | zus. grafisch relevante Ausführung 4 | A | unbedingt den Softwarehäusern separat mitteilen
937 | zus. grafisch relevante Farbe 4 | F | unbedingt den Softwarehäusern separat mitteilen
938 | zus. grafisch relevante Ausführung 5 | A | unbedingt den Softwarehäusern separat mitteilen
939 | zus. grafisch relevante Farbe 5 | F | unbedingt den Softwarehäusern separat mitteilen
940 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
941 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
942 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
943 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
944 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
945 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
946 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
947 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
948 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
949 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
950 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
951 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
952 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
953 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
954 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
955 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
956 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
957 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
958 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
959 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
960 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
961 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
962 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
963 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
964 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
965 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
966 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
967 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
968 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
969 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
970 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
971 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
972 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
973 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
974 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
975 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
976 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
977 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
978 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
979 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
980 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
981 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
982 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
983 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
984 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
985 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
986 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
987 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
988 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
989 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
990 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
991 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
992 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
993 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
994 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
995 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
996 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
997 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
998 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
999 | zusätzliche Ausführungen und Farben | F | unbedingt den Softwarehäusern separat mitteilen
1001 | Bezugsart | A |
1002 | Hauptbezugsart | A |
1003 | Hauptbezugsfarbe | F |
1004 | Absatzbezugsausführung | A |
1005 | Absatzbezugsfarbe | F |
1006 | Rückenbezugsart | A |
1007 | Rückenbezugsfarbe | F |
1008 | Rückenbild | A | mit/ohne Kimme, mit/ohne Steppung etc.
1009 | Sitzkissenausführung | A |
1010 | Sitzkissenfarbe | F |
1011 | Zierkissenausführung | A | lose, fest, rund, rechteckig, …
1012 | Zierkissenfarbe | F |
1013 | Kontrastfadenart / -ausführung | A |
1014 | Kontrastfadenfarbe | F |
1015 | Fußhöhe | A |
1016 | Fußmaterial | A | Metall, Holz, Kunststoff, Buche, …
1017 | Fußform | A | Kufe, Rehling, Einzelfuß, Rollen, Gleiter, …
1018 | Fußfarbe | F |
1019 | Holz- / Chatosenausführung | A |
1020 | Holz- / Chatosenfarbe / -beizton | F |
1021 | Behangausführung | A |
1022 | Behangfarbe | F |
1023 | Besatzausführung | A |
1024 | Besatzfarbe | F |
1025 | Seitentaschenausführung | A |
1026 | Seitentaschenfarbe | F |
1027 | Kederausführung | A |
1028 | Kederfarbe | F |
1029 | Drellausführung | A |
1030 | Drellfarbe | F |
1031 | Reissverschlussausführung | A |
1032 | Reissverschlussfarbe | F |
1033 | Sitzhärte, - qualität | A | mit /ohne Federkern, …
1034 | Antriebsart | A | Schlaufe, manuell, Gasdruckfeder, Motor Netz, Motor Accu, Do
1035 | Sitzhöhe | A |
1036 | Sitztiefe | A |
1037 | Sitzbreite | A |
1038 | Rückenhöhe | A |
1039 | Rückenkissenhöhe | A |
1040 | Rückenkissenausführung | A |
1041 | Armlehnen- / Seitenteilanordnung | A | ohne, links, rechts, beidseitig, …
1042 | Armlehnen- / Seitenteilausführung | A |
1043 | Seitenteilverstellung | A |
1044 | Kopfstützeausführung | A | lose, fest, Nackenstütze, …
1045 | Kopfstützenfarbe | F |
1046 | Vorderblendenausführung | A | bodeneben, bodenfrei
1047 | Stoffkombination | K |
1048 | Brand- / Flammschutz | A |
1049 | Liegeflächenausführung | A |
1050 | Liegeflächenfarbe | F |
1051 | Länderausführung | A |
1052 | Querschläfer | A |
1053 | Sitzneigungsverstellung | A |
1054 | Sitztiefenverstellung | A | Mechanisch, Elektomotorisch, Gasdruckfeder, …
1055 | Rückenverstellung | A | Mechanisch, Elektomotorisch, Gasdruckfeder, …
1056 | Fußstützenverstellung | A | Mechanisch, Elektomotorisch, Gasdruckfeder, …
1057 | Massagefunktion | A |
1058 | Sitzheizung | A |
1059 | Lordose | A |
1060 | Drehgestell | A |
1061 | Aufstehhilfe | A | Mechanisch, Elektomotorisch, Gasdruckfeder, …
1062 | Klapptisch | A |
1063 | Stecktisch | A |
1064 | Ausziehtisch | A |
1065 | Getränkehalter | A |
1066 | Kopfteil | A | Form 1, Form 2 usw., Kopfteilkürzung gegen Mehrpreis, ohne K
1067 | Kopfteilbezug | A |
1068 | Tagesdecke | A | kurz, halblang, lang, Haube
1069 | Tagesdeckenbezug | A |
1070 | Liegefläche | A | 160x200, 180x200, 200x200 usw., Sonderlänge gegen Mehrpreis
1071 | Bettkasten | A | Standard, Einlegevorrichtung, Highline usw.
1072 | Bettkastenbezug | A |
1073 | Lattenrost | A | Standard oder Alternativen gegen Mehrpreis, ggf. Einlegelatt
1074 | Matratze | A | Standard oder Alternativen gegen Mehrpreis >> Härtegrad H2,
1075 | Griffe (bei Konsolen) | F |
1076 | Konsolen | A | Schub mit Kunststoff oder Metallführung
1077 | Lampenfarbe und -ausführung | A |
1078 | Knopfbezug | F |
1079 | Lattenrostverstellung | A | Mechanisch, Elektomotorisch, Gasdruckfeder, mehrfach …
1080 | Funktion / Verstellung allgemein | A |
1089 | Anschlusstyp L | P | ID des Anschlussvektors in der SVG: AVL
1090 | Anschlusstyp R | P | ID des Anschlussvektors in der SVG: AVR
1091 | Anschlusstyp Custom 1 | P | ID des Anschlussvektors in der SVG: AVC1
1092 | Anschlusstyp Custom 2 | P | ID des Anschlussvektors in der SVG: AVC2
1093 | Anschlusstyp Custom 3 | P | ID des Anschlussvektors in der SVG: AVC3
1094 | Anschlusstyp Custom 4 | P | ID des Anschlussvektors in der SVG: AVC4
1095 | Planungsbreite | P | Breite des Artikels
1096 | Planungstiefe | P | Tiefe des Artikels
1097 | Planungshöhe | P | Höhe des Artikels
1098 | Antriebsposition | A |
1099 | Tischfarbe | F |
1100 | Kopfteilverstellung | A |
1101 | Relaxfunktion | A |
1102 | Vitalfunktion | A |
1103 | Stromquelle/Motor | A |
1104 | Zubehör | A |
1105 | Auflagetisch | A |
1106 | Rückenhalter | A |
1107 | Steckrücken | A |
1108 | Zwischentisch | A |
1109 | Zeitschriftenablage | A |
1110 | Schwenkfunktion | A |
1111 | Leseleuchte | A |
1112 | Decoartikel | A |
1500-1999 | freie Variantenart | F |
2000 | Modelnummer | A |
2001 | Anschlag | A |
2010 | Frontfarbe 4 | F | Frontinnenfarbe
2011 | Fronthöhe | A |
2012 | Frontbreite | A |
2100 | Rückwandausführung | A |
2101 | Rückwandfarbe | F |
2102 | Korpusasuführung hinten f.Raumteile | A | für Raumteiler
2103 | Korpusfarbe hinten f.Raumteile | F | für Raumteiler
2110 | Kleiderstange Ausführung | A |
2111 | Kleiderstange Farbe | F |
2140 | Tischplatten-Ausführung | A | für Tische
2141 | Tischplatten-Farbe | F | für Tische
2142 | Tisch-Kantenausführung | A | für Tische
2143 | Tisch-Kantenfarbe | F | für Tische
2144 | Tischgestell-Ausführung | A | für Tische
2145 | Tischgestell-Farbe | F | für Tische
2146 | Bodenplatten Ausführung | A | für Tische
2147 | Bodenplatten Farbe | F | für Tische
2148 | Höhenverstellung | A | für Tische
2149 | Auszüge | A | für Tische
2150 | Einsätze/Einlagen | A | für Tische
2151 | Einlegeplatten Ausführung | A | für Tische
2152 | Einlegeplatten Farbe | F | für Tische
2153 | Maximale Länge Auszugsplatte | A | für Tische
2160 | Bettgestell Ausführung | A |
2161 | Bettgestell Farbe | F |
2162 | Bettrahmen Ausführung | A |
2163 | Bettrahmen Farbe | F |
2164 | Kopfteil Ausführung | A |
2165 | Kopfteil Farbe | F |
2166 | Kopfteil Stoff | A |
2167 | Kopfteil Stofffarbe | F |
2168 | Fussteil Ausführung | A |
2169 | Fussteil Farbe | F |
2170 | Fussteil Stoff | A |
2171 | Fussteil Stofffarbe | F |
2200 | Griff 2 Ausführung | A |
2201 | Griff 2 Farbe 1 | F | Griff-, Knopfsockel- bzw. Hauptfarbe
2202 | Griff 2 Farbe 2 | F | Bügel-, Steg- und Knopfblendenfarbe
2203 | Griff 2 Kombination | K | Wenn nur ein Schlüssel für mehrere Griffbedingungen vorgegeben ist.
2204 | Griff 2 Lage | A | Siehe Grifflagen S. 5-23
2205 | Griff 3 Ausführung | A |
2206 | Griff 3 Farbe 1 | F | Griff-, Knopfsockel- bzw. Hauptfarbe
2207 | Griff 3 Farbe 2 | F | Bügel-, Steg- und Knopfblendenfarbe
2208 | Griff 3 Kombination | K | Wenn nur ein Schlüssel für mehrere Griffbedingungen vorgegeben ist.
2209 | Griff 3 Lage | A | Siehe Grifflagen S. 5-23
2300 | Frontausführung | A |
2301 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2302 | Frontfarbe 2 | F | Rahmen
2303 | Frontfarbe 3 | F | Lisenen
2304 | Kantenfarbe Front | F |
2305 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2306 | Frontausführung | A |
2307 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2308 | Frontfarbe 2 | F | Rahmen
2309 | Frontfarbe 3 | F | Lisenen
2310 | Kantenfarbe Front | F |
2311 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2312 | Frontausführung | A |
2313 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2314 | Frontfarbe 2 | F | Rahmen
2315 | Frontfarbe 3 | F | Lisenen
2316 | Kantenfarbe Front | F |
2317 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2318 | Frontausführung | A |
2319 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2320 | Frontfarbe 2 | F | Rahmen
2321 | Frontfarbe 3 | F | Lisenen
2322 | Kantenfarbe Front | F |
2323 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2324 | Frontausführung | A |
2325 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2326 | Frontfarbe 2 | F | Rahmen
2327 | Frontfarbe 3 | F | Lisenen
2328 | Kantenfarbe Front | F |
2329 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2330 | Frontausführung | A |
2331 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2332 | Frontfarbe 2 | F | Rahmen
2333 | Frontfarbe 3 | F | Lisenen
2334 | Kantenfarbe Front | F |
2335 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2336 | Frontausführung | A |
2337 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2338 | Frontfarbe 2 | F | Rahmen
2339 | Frontfarbe 3 | F | Lisenen
2340 | Kantenfarbe Front | F |
2341 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2342 | Frontausführung | A |
2343 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2344 | Frontfarbe 2 | F | Rahmen
2345 | Frontfarbe 3 | F | Lisenen
2346 | Kantenfarbe Front | F |
2347 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2348 | Frontausführung | A |
2349 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2350 | Frontfarbe 2 | F | Rahmen
2351 | Frontfarbe 3 | F | Lisenen
2352 | Kantenfarbe Front | F |
2353 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2354 | Frontausführung | A |
2355 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2356 | Frontfarbe 2 | F | Rahmen
2357 | Frontfarbe 3 | F | Lisenen
2358 | Kantenfarbe Front | F |
2359 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2360 | Frontausführung | A |
2361 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2362 | Frontfarbe 2 | F | Rahmen
2363 | Frontfarbe 3 | F | Lisenen
2364 | Kantenfarbe Front | F |
2365 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2366 | Frontausführung | A |
2367 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2368 | Frontfarbe 2 | F | Rahmen
2369 | Frontfarbe 3 | F | Lisenen
2370 | Kantenfarbe Front | F |
2371 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2372 | Frontausführung | A |
2373 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2374 | Frontfarbe 2 | F | Rahmen
2375 | Frontfarbe 3 | F | Lisenen
2376 | Kantenfarbe Front | F |
2377 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2378 | Frontausführung | A |
2379 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2380 | Frontfarbe 2 | F | Rahmen
2381 | Frontfarbe 3 | F | Lisenen
2382 | Kantenfarbe Front | F |
2383 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2384 | Frontausführung | A |
2385 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2386 | Frontfarbe 2 | F | Rahmen
2387 | Frontfarbe 3 | F | Lisenen
2388 | Kantenfarbe Front | F |
2389 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2390 | Frontausführung | A |
2391 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2392 | Frontfarbe 2 | F | Rahmen
2393 | Frontfarbe 3 | F | Lisenen
2394 | Kantenfarbe Front | F |
2395 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2396 | Frontausführung | A |
2397 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2398 | Frontfarbe 2 | F | Rahmen
2399 | Frontfarbe 3 | F | Lisenen
2400 | Kantenfarbe Front | F |
2401 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2402 | Frontausführung | A |
2403 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2404 | Frontfarbe 2 | F | Rahmen
2405 | Frontfarbe 3 | F | Lisenen
2406 | Kantenfarbe Front | F |
2407 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2408 | Frontausführung | A |
2409 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2410 | Frontfarbe 2 | F | Rahmen
2411 | Frontfarbe 3 | F | Lisenen
2412 | Kantenfarbe Front | F |
2413 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2414 | Frontausführung | A |
2415 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2416 | Frontfarbe 2 | F | Rahmen
2417 | Frontfarbe 3 | F | Lisenen
2418 | Kantenfarbe Front | F |
2419 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2420 | Frontausführung | A |
2421 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2422 | Frontfarbe 2 | F | Rahmen
2423 | Frontfarbe 3 | F | Lisenen
2424 | Kantenfarbe Front | F |
2425 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2426 | Frontausführung | A |
2427 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2428 | Frontfarbe 2 | F | Rahmen
2429 | Frontfarbe 3 | F | Lisenen
2430 | Kantenfarbe Front | F |
2431 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2432 | Frontausführung | A |
2433 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2434 | Frontfarbe 2 | F | Rahmen
2435 | Frontfarbe 3 | F | Lisenen
2436 | Kantenfarbe Front | F |
2437 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2438 | Frontausführung | A |
2439 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2440 | Frontfarbe 2 | F | Rahmen
2441 | Frontfarbe 3 | F | Lisenen
2442 | Kantenfarbe Front | F |
2443 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2444 | Frontausführung | A |
2445 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
2446 | Frontfarbe 2 | F | Rahmen
2447 | Frontfarbe 3 | F | Lisenen
2448 | Kantenfarbe Front | F |
2449 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
2500-2699 | freie Variantenart | F | kaufmännisch
2700-2999 | freie Variantenart | F | grafisch

Ab 2500 bis 2999 stehen freie Variantenarten zur Verfügung.

Typ: A = Ausführung

F = Farbe

K = Kombination

S = Form

P = Planung


%%ItemTitle%%

Typenschlüssel
Einleitung > Typenschlüssel

Typenschlüssel

Der Typenschlüssel wird in folgendem Element hinterlegt:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

Folgende Typenschlüssel wurden definiert:

Nr. | Typ
1010 | Korpuselement
1020 | Schrank
1030 | Vitrine
1040 | Regal
1050 | Highboard/Sideboard/Anrichten/Buffet/Lowboard
1060 | TV-, Phono-, Medienmöbel
1070 | Front
1080 | Regalsystemelement
1090 | Konsole/Konsolentisch/Kommode/Frisiertisch
1100 | Couchtisch/Beistelltisch
1110 | Esstisch
1120 | Schreibtisch/Computertisch
1130 | Sekretär
1140 | Stuhl
1150 | Hocker/Barhocker
1160 | Eckbank/Bank
1170 | Kinder-/Spielmöbel/Wickeltisch/-aufsatz
1180 | Bett
1190 | Matratze/Lattenrost/Set
1200 | Nachttisch/-schrank/-kommode/-kästchen
1210 | Roll-/Standcontainer
1220 | Thekenanlagen/Hausbarmöbel
1230 | Gaderobe/Dielenmöbel
1240 | Schuhschrank
1250 | Truhen
1260 | Spiegel
1270 | Paneel
1280 | Sockel/Fußgestell
1290 | Abdeckplatte
1300 | Kranzleiste/Kranzprofile/Passepartout
1310 | Beleuchtung
1320 | Kombination/Set
1330 | Blende/Ausgleichsstück
1340 | Zubehör
1350 | Sonstige


%%ItemTitle%%

Typenschlüssel- Arten
Einleitung > Typenschlüssel- Arten

Nr. | Art | Zuordnung
000 | Alle |
100 | Drehtür | 1010;1020;1030;1050;1060;1070;1090;1230;1240
110 | Falttür/Winkeltür | 1010;1020;1030;1050;1060;1070;1090;1230;1240
120 | Schiebetür/Schwebetür | 1010;1020;1030;1050;1060;1070;1090;1230;1240
130 | Lade | 1010;1020;1030;1050;1060;1070;1090;1230;1240
140 | Klappe | 1010;1020;1030;1050;1060;1070;1090;1230;1240
150 | Auszug | 1010;1020;1030;1050;1060;1070;1090;1230;1240
160 | Kombifront | 1010;1020;1030;1050;1060;1070;1090;1230;1240
170 | Jalousie/Rollladen/Lamellen | 1010;1020;1030;1050;1060;1070;1090;1230;1240
200 | Innenlade | 1340
210 | Innenfach | 1340
220 | Inneneinteilung | 1340
230 | Schrankzubehör (Kleiderstange, Wäschekorb …) | 1340
240 | Boxen/Receiver | 1340
250 | TV-Halterung | 1340
260 | Sonstiges | 1340
300 | Wangen/Stollen/Aufsatzstollen/Vorsatzstollen | 1080
310 | Stollen-/Regal-/Einhänge-/Licht-/Einlegeboden | 1080
320 | Sockelboden | 1080
330 | Bord/Steckbord | 1080:1340
340 | Rückwand | 1080;1120;1340
400 | Tischplatte | 1100;1110;1120;1340
410 | Tischgestelle | 1100;1110;1120;1340
420 | Ansteckplatte/Einlegeplatte | 1100;1110;1120;1340
430 | Vierfußtisch/-gestell | 1100;1110;1120;1340
440 | Säulentische/-gestell | 1100;1110;1120;1340
450 | C-Fußgestell | 1120;1340
460 | A-Fußgestell | 1100;1110;1120;1340
470 | T-Fußgestell | 1100;1110;1120;1340
500 | Esszimmerstuhl/Stapelstuhl | 1140
510 | Dreh-, Roll- und Drehrollstühle | 1140
520 | Kinderstuhl | 1140;1170
600 | Bettrahmen/Kopfteil/Fußteil | 1180
610 | Hochbett/Mittelbett/Etagenbett/Höhlenbett | 1170;1180
620 | Kinderbett/Gitterbett | 1170;1180
630 | Boxspringbett | 1180
640 | Schlafsofa/Gästebett/Klappliege | 1180
650 | Wand-, Klapp- und Schrankbett | 1180
660 | Wasserbett | 1180
670 | Polsterbett | 1180
700 | Bankpolster | 1340
710 | Griffe | 1340
720 | Kleinteile | 1340
800 | Vorzugskombination | 1320
810 | Vorschlagskombination | 1320


%%ItemTitle%%

Ausführungsschlüssel
Einleitung > Ausführungsschlüssel

Nr. | Ausführung
00 | Alle
10 | Einzelelement
20 | Grundelement
30 | Anbauelement
40 | Eckelement
50 | Zwischenbauelement
60 | Aufsatzelement
70 | Hängeelement
80 | Unterteil


%%ItemTitle%%

Informationsschlüssel
Einleitung > Informationsschlüssel

Eigenschaft-Nr.

Bezeichnung

Beschreibung

Maßeinheit

Wertangabe

Information für Waschmaschinen

100

RATED_CAPACITY

Nennkapazität in kg Baumwolle für das Standardprogramm „Baumwolle 60 °C“ oder das Standardprogramm

„Baumwolle 40 °C“, jeweils bei vollständiger Befüllung, wobei der geringere der beiden Werte maßgeblich ist

kg

numerisch

101

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse gemäß Tabelle 1

A+++ … D

102

WEIGHTED_ANNUAL_ENERGY_CONSUMPTION

gewichteter jährlicher Energieverbrauch (AE C ) in kWh/Jahr, auf die nächste Ganzzahl aufgerundet. Dieser ist anzugeben als: Energieverbrauch von ‚X‘ kWh/Jahr auf der Grundlage von 220 Standard-Waschzyklen für 60 °C- und 40 °C- Baumwollprogramme bei vollständiger Befüllung und Teilbefüllung sowie dem Verbrauch der Betriebsarten mit geringer Leistungsaufnahme. Der tatsächliche Energieverbrauch hängt von der Art der Nutzung des Geräts ab.

kWh per year

numerisch

103

ENERGY_CONSUMPTION

Energieverbrauch (E t,60 , E t,60½ , E t,40½ ) des Standardprogramms „Baumwolle 60 °C“ bei vollständiger Befüllung und Teilbefüllung sowie des Standardprogramms „Baumwolle 40 °C“ bei Teilbefüllung

kWh

numerisch

104

WEIGHTED_POWER_CONSUMPTION_OFF

gewichtete Leistungsaufnahme im Aus-Zustand

W

numerisch

105

WEIGHTED_POWER_CONSUMPTION_ON

gewichtete Leistungsaufnahme im unausgeschalteten Zustand

W

numerisch

106

WEIGHTED_ANNUAL_WATER_CONSUMPTION

gewichteter jährlicher Wasserverbrauch (AW C ) in Liter/Jahr, auf die nächste Ganzzahl aufgerundet. Dieser ist anzugeben als: Wasserverbrauch von ‚X‘ Liter/Jahr auf der Grundlage von 220 Standard-Waschzyklen für 60 °C- und 40 °C-Baumwollprogramme bei vollständiger Befüllung und Teilbefüllung. Der tatsächliche Wasserverbrauch hängt von der Art der Nutzung des Geräts ab.

litres per year

numerisch

107

SPIN_DRYING_EFFICIENCY_CLASS

Schleudereffizienzklasse, ermittelt gemäß Tabelle 2 und ausgedrückt als Schleudereffizienzklasse ‚X‘ auf einer Skala von G (geringste Effizienz) bis A (höchste Effizienz). Von dieser Darstellungsweise kann abgewichen werden, sofern deutlich wird, das die Skala von G (geringste Effizienz) bis A (höchste Effizienz) reicht

A … G

108

MAX_SPIN_SPEED

maximale Schleuderdrehzahl beim Standardprogramm „Baumwolle 60 °C“ bei vollständiger Befüllung oder beim Standardprogramm „Baumwolle 40 °C“ bei Teilbefüllung, wobei der niedrigere Wert maßgeblich ist, sowie Restfeuchte beim Standardprogramm „Baumwolle 60 °C“ bei vollständiger Befüllung oder beim Standardprogramm „Baumwolle 40 °C“ bei Teilbefüllung, wobei der höhere Wert maßgeblich ist

revolutions per minute

numerisch

109

INDICATION_STANDARD

Hinweise auf den Umstand, dass die Standardprogramme „Baumwolle 60 °C“ und „Baumwolle 40 °C“ die Standard- Waschprogramme sind, auf die sich die Informationen auf dem Etikett und im Datenblatt beziehen, dass diese Programme zur Reinigung normal verschmutzter Baumwollwäsche geeignet und in Bezug auf den kombinierten Energie- und Wasserverbrauch am effizientesten sind

Zeichenfolge ST oder leer

110

PROGRAMME_TIME

Programmdauer des Standardprogramms „Baumwolle 60 °C“ bei vollständiger Befüllung und Teilbefüllung sowie des Standardprogramms „Baumwolle 40 °C“ bei Teilbefüllung in Minuten, auf die nächstliegende Minute gerundet

min

numerisch

111

DURATION_LEFT_ON_MODE

Dauer des unausgeschalteten Zustands (T l ), falls die Haushaltswaschmaschine mit Leistungssteuerung ausgerüstet ist

min

numerisch

112

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Luftschallemissionen in dB(A) re 1 pW, auf die nächstliegende Ganzzahl gerundet, beim Waschen und Schleudern im Standardprogramm „Baumwolle 60 °C“ bei vollständiger Befüllung

dB

numerisch

Information für Geschirrspüler

120

RATED_CAPACITY

Nennkapazität in Standardgedecken für den Standardreinigungszyklus

Anzahl

numerisch

121

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse gemäß Tabelle 3

A+++ … D

122

ANNUAL_ENERGY_CONSUMPTION

jährlicher Energieverbrauch (AE C ) in kWh/Jahr, auf die nächste Ganzzahl aufgerundet. Dieser ist anzugeben als Energieverbrauch ‚X‘ kWh/Jahr auf der Grundlage von 280 Standardreinigungszyklen bei Kaltwasserbefüllung und dem Verbrauch der Betriebsarten mit geringer Leistungsaufnahme. Der tatsächliche Energieverbrauch hängt von der Art der Nutzung des Geräts ab.

kWh per year

numerisch

123

ENERGY_CONSUMPTION

Energieverbrauch (E t ) des Standardreinigungszyklus

kWh

numerisch

124

POWER_CONSUMPTION_OFF

gewichtete Leistungsaufnahme im Aus-Zustand

W

numerisch

125

POWER_CONSUMPTION_ON

gewichtete Leistungsaufnahme im unausgeschalteten Zustand

W

numerisch

126

WEIGHTED_ANNUAL_WATER_CONSUMPTION

gewichteter jährlicher Wasserverbrauch (AW C ) in Liter/Jahr, auf die nächste Ganzzahl aufgerundet. Dieser ist anzugeben als: Wasserverbrauch ‚X‘ Liter/Jahr, auf der Grundlage von 280 Standardreinigungszyklen. Der tatsächliche Wasserverbrauch hängt von der Art der Nutzung des Geräts ab.

litres per year

numerisch

127

DRYING_EFFICIENCY_CLASS

Trocknungseffizienzklasse, ermittelt gemäß Tabelle4 und ausgedrückt als Trocknungseffizienzklasse ‚X‘ auf einer Skala von G (geringste Effizienz) bis A (höchste Effizienz). Erfolgt die Angabe in Tabellenform, kann von dieser Darstellung abgewichen werden, sofern deutlich wird, dass die Skala von G (geringste Effizienz) bis A (höchste Effizienz) reicht.

A … G

128

INDICATION_STANDARD

Hinweise auf den Umstand, dass das „Standardprogramm“ der Reinigungszyklus ist, auf den sich die Informationen auf dem Etikett und im Datenblatt beziehen, dass dieses Programm zur Reinigung normal verschmutzten Geschirrs geeignet und in Bezug auf den kombinierten Energie- und Wasserverbrauch am effizientesten ist

Zeichenfolge ST oder leer

129

PROGRAMME_TIME

Programmdauer des Standardreinigungszyklus in Minuten, auf die nächstliegende Ganzzahl gerundet

min

numerisch

130

DURATION_LEFT_ON_MODE

Dauer des unausgeschalteten Zustands (T l ), falls der Haushaltsgeschirrspüler mit Leistungssteuerung ausgerüstet ist

min

numerisch

131

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Luftschallemissionen in dB(A) re 1 pW, auf die nächstliegende Ganzzahl gerundet

dB

numerisch

Information für Wäschetrocknern

140

RATED_CAPACITY

Nennkapazität in kg Baumwollwäsche für das Standard-Baumwollprogramm bei vollständiger Befüllung

kg

numerisch

141

TUMBLE_KIND

ob es sich bei dem Haushaltswäschetrockner um einen Abluft-, Kondensations- oder gasbeheizten Haushaltswäschetrockner handelt

Zeichen A, C oder G

142

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse gemäß Tabelle 5

A+++ … D

143

WEIGHTED_ANNUAL_ENERGY_CONSUMPTION

für elektrisch beheizte Haushaltswäschetrockner:

gewichteter jährlicher Energieverbrauch (AE c ) auf eine Dezimalstelle aufgerundet. Dieser ist anzugeben als: Energieverbrauch von ‚X‘ kWh/Jahr auf der Grundlage von 160 Trocknungszyklen für das Standard-Baumwollprogramm bei vollständiger Befüllung und Teilbefüllung sowie des Verbrauchs der Betriebsarten mit geringer Leistungsaufnahme. Der tatsächliche Energieverbrauch je Zyklus hängt von der Art der Nutzung des Geräts ab.

für gasbeheizte Haushaltswäschetrockner:

gewichteter jährlicher Energieverbrauch (AE C(Gas) ), auf eine Dezimalstelle aufgerundet. Dieser ist anzugeben als: Energieverbrauch von ‚X‘ kWh-Gas/Jahr auf der Grundlage von 160 Trocknungszyklen für das Standard-Baumwollprogramm bei vollständiger Befüllung und Teilbefüllung. Der tatsächliche Energieverbrauch je Zyklus hängt von der Art der Nutzung des Geräts ab.

und

gewichteter jährlicher Energieverbrauch (AE C(Gas)el ), auf eine Dezimalstelle aufgerundet.Dieser ist anzugeben als: Energieverbrauch von ‚X‘ kWh/Jahr auf der Grundlage von 160 Trocknungszyklen für das Standard-Baumwollprogramm bei vollständiger Befüllung und Teilbefüllung sowie des Verbrauchs der Betriebsarten mit geringer Leistungsaufnahme. Der tatsächliche Energieverbrauch je Zyklus hängt von der Art der Nutzung des Geräts ab.

kWh per year

numerisch

144

AUTOMATIC

ob es sich bei dem Haushaltswäschetrockner um einen „Wäschetrockner mit Automatik“ oder einen „Wäschetrockner ohne Automatik“ handelt

1=true
0=false

145

ENERGY_CONSUMPTION

Energieverbrauch (E dry , E dry½ , Eg dry , Eg dry½ , Eg dry,a , Eg dry½,a ) des Standard-Baumwollprogramms bei vollständiger Befüllung und Teilbefüllung

kWh

numerisch

146

POWER_CONSUMPTION_OFF

Leistungsaufnahme im Aus-Zustand (P o ) für das Standard-Baumwollprogramm bei vollständiger Befüllung

W

numerisch

147

POWER_CONSUMPTION_ON

Leistungsaufnahme im nichtausgeschalteten Zustand (P l ) für das Standard-Baumwollprogramm bei vollständiger Befüllung

W

numerisch

148

DURATION_LEFT_ON_MODE

Dauer des unausgeschalteten Zustands, falls der Haushaltswäschetrockner mit Leistungssteuerung ausgerüstet ist

min

numerisch

149

INDICATION_STANDARD

Hinweise auf den Umstand, dass das „Standard-Baumwollprogramm“ bei vollständiger Befüllung und Teilbefüllung das Standardtrocknungsprogramm ist, auf das sich die Informationen auf dem Etikett und im Datenblatt beziehen, dass dieses Programm zum Trocknen normaler nasser Baumwolltextilien geeignet und in Bezug auf den Energieverbrauch für Baumwolle am effizientesten ist

Zeichenfolge ST oder leer

150

WEIGHTED_PROGRAMME_TIME

gewichtete Programmdauer (T t ) des „Standard-Baumwollprogramms bei vollständiger Befüllung und Teilbefüllung“ in Minuten, auf die nächste ganze Minute auf- oder abgerundet

min

numerisch

151

WEIGHTED_PROGRAMME_TIME

Programmdauer des „Standard-Baumwollprogramms bei vollständiger Befüllung“ (T dry ) in Minuten, auf die nächste ganze Minute auf- oder abgerundet

min

numerisch

152

WEIGHTED_PROGRAMME_TIME

Programmdauer des „Standard-Baumwollprogramms bei Teilbefüllung“ (T dry½ ) in Minuten, auf die nächste ganze Minute auf- oder abgerundet

min

numerisch

153

CONDENSATION_EFFICIENCY

falls der Haushaltswäschetrockner ein Kondensationswäschetrockner ist, die Kondensationseffizienzklasse gemäß Tabelle 6 und ausgedrückt als „Kondensationseffizienzklasse ‚X‘ auf einer Skala von G (geringste Effizienz) bis A (höchste Effizienz)“; von dieser Darstellungsweise kann abgewichen werden, sofern deutlich wird, dass die Skala von G (geringste Effizienz) bis A (höchste Effizienz) reicht

A … G

154

AVERAGE_CONDENSATION_EFFICIENCY

falls der Haushaltswäschetrockner ein Kondensationswäschetrockner ist, die durchschnittliche Kondensationseffizienz C dry und C dry½ des Standard-Baumwollprogramms bei vollständiger Befüllung und Teilbefüllung und die gewichtete Kondensationseffizienz (C t ) für das „Standard-Baumwollprogramm bei vollständiger Befüllung und Teilbefüllung“ als Prozentsatz, auf das nächste ganze Prozent auf- oder abgerundet

%

numerisch

155

SOUND_POWER_LEVEL

Schallleistungspegel (gewichteter Durchschnittswert — L WA ) in dB, auf die nächste Ganzzahl auf- oder abgerundet, für das Standard-Baumwollprogramm bei vollständiger Befüllung

dB

numerisch

Information für kombinierte Wasch-Trockenautomaten

160

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse des Modells gemäß Tabelle 7 ausgedrückt als „ Energieeffizienzklasse . . . auf einer Skala von A (niedriger Energieverbrauch) bis G (hoher Energieverbrauch)". Erfolgt die Angabe in Tabellenform, kann von dieser Darstellung abgewichen werden, sofern deutlich wird, dass die Skala von A (niedriger Energieverbrauch) bis G (hoher Energieverbrauch) reicht.

A … G

161

ENERGY_CONSUMPTION

Energieverbrauch in kWh pro vollständigem Betriebszyklus (Waschen, Schleudern und Trocknen )

kWh

numerisch

162

ENERGY_CONSUMPTION_W_D_ONLY

Energieverbrauch in kWh nur für Wasch- und Schleuderprogramm

kWh

numerisch

163

WASHING_PERFORMANCE

Waschwirkungsklasse gemäß Tabelle 8, ausgedrückt als „Waschwirkungsklasse . . . auf einer Skala von A (besser) bis G schlechter)". Von dieser Darstellungsweise kann abgewichen werden, sofern deutlich wird, dass die Skala von A (besser) bis G (schlechter) reicht.

A … G

164

WATER_EXTRACTION_EFFICIENCY

Schleuderwirkung beim Standardprogramm „ Baumwolle 60 °C ", ausgedrückt als „ nach dem Schleudervorgang verbleibende Restfeuchte ...% (Anteil am Trockengewicht der Wäsche )"

%

numerisch

165

MAX_SPIN_SPEED

maximale Schleuderdrehzahl beim Standardprogramm „Baumwolle 60 °C“

revolutions per minute

numerisch

166

WASH_CAPACITY

Füllmenge (Waschen ) des Gerätes beim Standardprogramm „Baumwolle 60 °C"

kg

numerisch

167

DRY_CAPACITY

Füllmenge (Trocknen) des Gerätes beim Standardprogramm „Baumwolle, schranktrocken"

kg

numerisch

168

WATER_CONSUMPTION

Wasserverbrauch in 1 pro vollständigen Betriebszyklus (Waschen, Schleudern und Trocknen )

litres

numerisch

169

WATER_CONSUMPTION_W_D_ONLY

Wasserverbrauch in 1 nur für Waschen und Schleudern beim Standardprogramm „ Baumwolle 60 °C "

litres

numerisch

170

WASHING_DRYING_TIME

Wasch- und Trockenzeit: Dauer des vollständigen Betriebszyklus (Waschen, Schleudern und Trocknen )bei Verwendung des Standardprogramms „Baumwolle 60 °C " und des Trockenprogramms „ Baumwolle, schranktrocken " bei Nennfüllmenge

min

numerisch

171

ENERGY_WATER_CONSUMPTION

Energie- und Wasserverbrauch ausgehend von 200 Standardzyklen , ausgedrückt als geschätzter Jahresverbrauch eines Vier-Personen-Haushalts, der diesen Wasch-Trockenautomaten immer zum Trocknen verwendet ( 200 Programme )

kWh

numerisch

172

NOISE_EMISSION

Geräuschemissionen während des Wasch-, Schleuder- und TrockenVorgangs beim Standardprogramm „Baumwolle 60 °C" und „Baumwolle, schranktrocken",

dB

numerisch

Information für Kühlgeräte

180

CATEGORY

Kategorie des Haushaltskühlgerätemodells gemäß Tabelle 9 und 10

numerisch

1 … 10

181

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse des Modells gemäß Tabelle 11

A+++ … G

182

ANNUAL_ENERGY_CONSUMPTION

jährlicher Energieverbrauch (AE C ) in kWh/Jahr gemäß Nummer 3 (2) von Anhang VIII, aufgerundet auf die nächste Ganzzahl. Er ist anzugeben als: Energieverbrauch ‚XYZ‘ kWh/Jahr, auf der Grundlage von Ergebnissen der Normprüfung über 24 Stunden. Der tatsächliche Verbrauch hängt von der Nutzung und vom Standort des Geräts ab.

kWh per year

numerisch

183

STORAGE_VOLUMNE

Nutzinhalt jedes Fachs und gegebenenfalls anwendbare Sternekennzeichnung gemäß Summe der Nutzinhalte aller Gefrierfächer, die eine Stern-Einstufung haben (d. h. mit einer Betriebstemperatur ≤ – 6 °C), gerundet auf die nächste Ganzzahl, und Stern-Einstufung des Fachs mit dem höchsten Anteil an dieser Summe; weist das Haushaltskühlgerät keine Gefrierfächer auf, gibt der Lieferant statt eines Werts „– L“ an und lässt die Position für die Stern-Einstufung leer

litres

numerisch

184

DESIGN_TEMPERATURE

Auslegungstemperatur „sonstiger Fächer“ im Sinne von Anhang I Buchstabe n. Bei Weinlagerfächern ist die niedrigste Lagertemperatur anzugeben, die entweder für das Fach voreingestellt ist oder vom Endnutzer gemäß Herstelleranweisungen eingestellt werden kann und dauerhaft aufrechterhalten wird

°C

numerisch

185

FROST_FREE

Angabe „Frostfrei“ für das betreffende Fach/die betreffenden Fächer, die kein Weinlagerfach sind und für die Lagerung bestimmter Lebensmittel bei einer höheren Temperatur als + 14 °C vorgesehen sind

Fach von unten gezählt

numerisch

186

TEMPERATURE_RISE_TIME

„Lagerzeit bei Störung ‚X‘ h“, definiert als „Temperaturanstiegszeit“

h

numerisch

187

FREEZING_CAPACITY

„Gefriervermögen“ in kg/24 h

kg/24 h

numerisch

188

CLIMATE_CLASS

„Klimaklasse“ gemäß Tabelle 12, angegeben als: Klimaklasse: W [Klimaklasse]. Dieses Gerät ist für den Betrieb bei einer Umgebungstemperatur zwischen ‚X‘ [niedrigste Temperatur] °C und ‚X‘ [höchste Temperatur] °C bestimmt.

SN, N, ST oder T

189

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

Luftschallemissionen in dB(A) re 1 pW, auf die nächstliegende Ganzzahl gerundet

dB

numerisch

190

WINE_ONLY

für Weinschränke ist die folgende Angabe zu machen: „Dieses Gerät ist ausschließlich zur Lagerung von Wein bestimmt.“ Dies gilt weder für Haushaltskühlgeräte, die nicht speziell für die Weinlagerung ausgelegt sind, aber dennoch für diesen Zweck verwendet werden können, noch für Haushaltskühlgeräte, die über ein Weinlagerfach in Kombination mit einem Fach anderer Art verfügen.

1=true

0=false

Information für Backöfen

200

NUMBER_CAVITY

die Zahl der Garräume

Anzahl

numerisch

201

ENERGY_EFFICIENCY_INDEX

der Energieeffizienzindex (EEIcavity) für den ersten Garraum des Modells, die erste Dezimalstelle gerundet

numerisch

202

ENERGY_EFFICIENCY_CLASS

die Energieeffizienzklasse des Modells für den ersten Garraum gemäß Tabelle 13

A+++ … D

203

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den ersten Garraum im konventionellen Modus soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

204

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den ersten Garraum im Umluft-Modus, soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

205

HEAT_SOURCE_CAVITY

die Wärmequelle des ersten Garraums

E oder G

206

VOLUMNE_ CAVITY

das Volumen des ersten Garraums

litres

numerisch

207

ENERGY_EFFICIENCY_INDEX

der Energieeffizienzindex (EEIcavity) für den zweiten Garraum des Modells, die erste Dezimalstelle gerundet

208

ENERGY_EFFICIENCY_CLASS

die Energieeffizienzklasse des Modells für den zweiten Garraum gemäß Tabelle 13

A+++ … D

209

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den zweiten Garraum im konventionellen Modus, soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

210

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den zweiten Garraum im Umluft-Modus, soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

211

HEAT_SOURCE_CAVITY

die Wärmequelle für den zweiten Garraum

E oder G

212

VOLUMNE_ CAVITY

das Volumen den zweiten Garraums

litres

numerisch

213

ENERGY_EFFICIENCY_INDEX

der Energieeffizienzindex (EEIcavity) für den dritten Garraum des Modells, die erste Dezimalstelle gerundet

numerisch

214

ENERGY_EFFICIENCY_CLASS

die Energieeffizienzklasse des Modells für den dritten Garraum gemäß Tabelle 13

A+++ … D

215

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den dritten Garraum im konventionellen Modus, soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

216

ENERGY_CONSUMPTION

der Energieverbrauch pro Zyklus für den dritten Garraum im Umluft-Modus, soweit vorhanden (der gemessene Energieverbrauch ist in kWh (Elektro- und Gasbacköfen) und in MJ (Gasbacköfen) auszudrücken, auf zwei Dezimalstellen gerundet

kWh

numerisch

217

HEAT_SOURCE_CAVITY

die Wärmequelle des dritten Garraums

E oder G

218

VOLUMNE_ CAVITY

das Volumen des dritten Garraums

litres

numerisch

Information für Dunstabzugshauben

220

ANNUAL_ENERGY_CONSUMPTION

der jährliche Energieverbrauch (AEC hood ) in kWh/Jahr, auf die erste Dezimalstelle gerundet

kWh per year

numerisch

221

ENERGY_EFFICIENCY_CLASS

die Energieeffizienzklasse gemäß Tabelle 14

A+++ … G

222

FLUID_DYNAMIC_EFFICIENCY

die berechnete fluiddynamische Effizienz (FDE hood ), auf die erste Dezimalstelle gerundet

numerisch

223

FLUID_DYNAMIC_EFFICIENCY_CLASS

die Klasse für die fluiddynamische Effizienz gemäß Tabelle 15

A … G

224

LIGHTING_EFFICIENCY

der berechnete Beleuchtungseffizienz (LE hood ) in lx/Watt, auf die erste Dezimalstelle gerundet

numerisch

225

LIGHTING _EFFICIENCY_CLASS

die Beleuchtungseffizienzklasse gemäß Tabelle 16; die angegebene Klasse darf nicht besser sein als die in der technischen Dokumentation vermerkte Klasse

A … G

226

GREASE_FILTERING_EFFICIENCY

der berechnete Fettabscheidegrad in Prozent, auf die erste Dezimalstelle gerundet. Der angegebene Wert darf nicht über dem in der technischen Dokumentation vermerkten Wert liegen.

%

numerisch

227

GREASE_FILTERING _EFFICIENCY_CLASS

die Klasse für den Fettabscheidegrad gemäß Tabelle 17

A … G

228

AIR_FLOW

der Luftstrom (in m 3 /h, auf die nächste ganze Zahl gerundet) bei minimaler und bei maximaler Geschwindigkeit im Normalbetrieb, ausgenommen den Betrieb auf der Intensivstufe oder Schnelllaufstufe

m³/h

numerisch

229

AIR_FLOW_INTENSIVE

gegebenenfalls der Luftstrom (in m 3 /h, auf die nächste ganze Zahl gerundet) im Betrieb auf der Intensivstufe oder Schnelllaufstufe

m³/h

numerisch

230

AIRBORNE_ACOUSTICAL_NOISE_EMISSION

die A-bewerteten Luftschallemissionen (in dB, auf die nächste ganze Zahl gerundet) bei minimaler und maximaler verfügbarer Geschwindigkeit im Normalbetrieb

dB

numerisch

231

AIRBORNE_ACOUSTICAL_NOISE_EMISSION_INT

gegebenenfalls die A-bewerteten Luftschallemissionen (in dB, auf die nächste ganze Zahl gerundet) im Betrieb auf der Intensivstufe oder Schnelllaufstufe

dB

numerisch

232

POWER_CONSUMPTION_OFF

gegebenenfalls die Leistungsaufnahme im Aus-Zustand (P o ) in Watt, auf die zweite Dezimalstelle gerundet

W

numerisch

231

POWER_CONSUMPTION_ON

gegebenenfalls die Leistungsaufnahme im Bereitschaftszustand (P s ) in Watt, auf die zweite Dezimalstelle gerundet

W

numerisch

Information für elektrische Lampen und Leuchten

240

ENERGY_EFFICIENCY_CLASS

die Energieeffizienzklasse gemäß Tabelle 18

A++ … E

241

WEIGHTED_ENERGY_CONSUMPTION

gewichteter Energieverbrauch (EC) in kWh/1 000 Stunden auf die nächste Ganzzahl aufgerundet

kWh per 1000 hours

numerisch

242

ENERGY_EFFICIENCY_CLASS_COMPATIBILITY

Energieeffizienzklassen der vom Nutzer austauschbaren Lampen, mit denen die Leuchte gemäß den Anforderungen an die Kompatibilität nach dem Stand der Technik kompatibel ist

A++ … E

243

ENERGY_EFFICIENCY_CLASS_N_COMPATIBILITY

Energieeffizienzklassen von Lampen, mit denen die Leuchte gemäß den Anforderungen an die Kompatibilität nach dem Stand der Technik nicht kompatibel ist

A++ … E

244

ENERGY_EFFICIENCY_CLASS_LED

Energieeffizienzklassen für LED-Module, die nicht dafür bestimmt sind, vom Endnutzer entfernt zu werden

A++ … E

245

ENERGY_EFFICIENCY_CLASS_INCLUDED

Energieeffizienzklassen für Leuchte, die mit Lampen betrieben wird, die vom Endnutzer ausgetauscht werden können, und in der Verpackung der Leuchte enthalten sind

A++ … E

Information für Fernsehgeräte

260

ENERGY_EFFICIENCY_CLASS

Energieeffizienzklasse des Modells gemäß Tabelle 19

A+++ … G

261

SCREEN_DIAGONAL_CM

sichtbare Bildschirmdiagonale in Zentimeter

cm

numerisch

262

SCREEN_DIAGONAL_INCH

sichtbare Bildschirmdiagonale in Zoll

inch

numerisch

263

POWER_CONSUMPTION_ON

Leistungsaufnahme im Ein-Zustand

W

numerisch

264

ANNUAL_ENERGY_CONSUMPTION

der berechnete jährliche Energieverbrauch in kWh/Jahr, gerundet auf die erste Ganzzahl. Dieser ist anzugeben als: Energieverbrauch XYZ kWh/Jahr, auf der Grundlage eines täglich vierstündigen Betriebs des Fernsehgeräts an 365 Tagen. Der tatsächliche Energieverbrauch hängt von der Art der Nutzung des Fernsehgerätes ab.

kWh per year

numerisch

265

POWER_CONSUMPTION_OFF

Leistungsaufnahme im Aus-Zustand

W

numerisch

266

POWER_CONSUMPTION_STANDBY

Leistungsaufnahme im Bereitschaftszustand

W

numerisch

267

SCREEN_RESOLUTION_HORIZONTAL

Bildschirmauflösung in physischer horizontaler Pixelzahl.

pt

numerisch

268

SCREEN_RESOLUTION_VERTICAL

Bildschirmauflösung in physischer vertikaler Pixelzahl.

pt

numerisch

Information für Heizgräte: 280 -300

Information für Luftkonditionierer: 300 -320

Information für Einzelraumheizgeräte:320-340

Information für Staubsauger: 340-360

Information für gewerbliche Kühllagerschränke: 360-380

Information für Wohnraumlüftungsgeräten: 380-400

Information für Festbrennstoffkesseln und Verbundanlagen einschl. Solareinrichtungen: 400-420

Die numerischen Angaben sind in nichtnegativer Form vorzunehmen. Es werden keinen Tausender Stellen gekennzeichnet. Dezimalstellen sind durch einen Punkt zu trennen.

Für die Werte 800 - 999 können freie Eigenschaften vergeben werden.

1. ENERGIEEFFIZIENZKLASSEN für Waschmaschinen

Die Energieeffizienzklasse einer Haushaltswaschmaschine wird auf der Grundlage ihres Energieeffizienzindex (EEI) gemäß Tabelle 1 ermittelt.

Der Energieeffizienzindex (EEI) einer Haushaltswaschmaschine wird gemäß Tabelle 1 ermittelt.

2. SCHLEUDEREFFIZIENZKLASSEN für Waschmaschinen

Die Schleudereffizienzklasse einer Haushaltswaschmaschine wird anhand der Restfeuchte (D) gemäß Tabelle 2 ermittelt.

3. ENERGIEEFFIZIENZKLASSEN für Geschirrspüler

Die Energieeffizienzklasse eines Haushaltsgeschirrspülers wird auf der Grundlage seines Energieeffizienzindex (EEI)

gemäß Tabelle 3 ermittelt.

4. TROCKNUNGSEFFIZIENZKLASSEN für Geschirrspüler

Tabelle 4

5. ENERGIEEFFIZIENZKLASSEN für Wäschetrockner

Die Energieeffizienzklasse eines Haushaltswäschetrockners wird auf der Grundlage seines Energieeffizienzindex (EEI) gemäß Tabelle 5 ermittelt.

Tabelle 5

6. KONDENSATIONSEFFIZIENZKLASSEN

Die Kondensationseffizienzklasse eines Kondensations-Haushaltswäschetrockners wird auf der Grundlage der gewichteten Kondensationseffizienz (C t ) gemäß Tabelle 6 ermittelt.

Tabelle 6

7. EFFIZIENZKLASSEN für kombinierte Wasch-Trockenautomaten

Tabelle 7: Effizienzklassen

Tabelle 8: Waschwirkungsklassen

8. EINSTUFUNG DER HAUSHALTSKÜHLGERÄTE

Die Haushaltskühlgeräte werden in Kategorien gemäß Tabelle 9 eingestuft.

Jede Kategorie ist durch eine bestimmte Fächerzusammensetzung gemäß Tabelle 10 bestimmt und unabhängig von der Zahl der Türen und/oder Schubladen.

Tabelle 9

Haushaltskühlgeräte, die aufgrund der Fächertemperatur nicht in die Kategorien 1 bis 9 eingestuft werden können, sind in Kategorie 10 einzustufen.

Tabelle 10

Haushaltskühlgeräte-Einstufung und Fächerzusammensetzung

9. EFFIZIENZKLASSEN für Kühlgeräte

Die Energieeffizienzklasse eines Haushaltswäschetrockners wird auf der Grundlage seines Energieeffizienzindex (EEI) gemäß Tabelle 5 ermittelt.

Tabelle 11

Tabelle 12

10. ENERGIEEFFIZIENZKLASSEN für Backöfen

Die Energieeffizienzklassen von Haushaltsbacköfen werden für jeden Garraum anhand der Werte in Tabelle 13 einzeln ermittelt.

11. EFFIZIENZKLASSEN für Dunstabzugshauben

Die Energieeffizienzklassen von Dunstabzugshauben anhand der Werte in Tabelle 14 ermittelt.

Die Klassen für die fluiddynamische Effizienz einer Haushaltsdunstabzugshabe werden anhand ihrer fluiddynamischen Effizienz (FDE hood ) gemäß folgender Tabelle 15 ermittelt.

Die Klassen für die Beleuchtungseffizienz einer Haushaltsdunstabzugshabe werden anhand ihrer Beleuchtungseffizienz (LE hood ) gemäß folgender Tabelle 16 ermittelt.

Die Klassen für den Fettabscheidegrad einer Haushaltsdunstabzugshabe werden anhand ihres Fettabscheidegrads (GFE hood ) gemäß folgender Tabelle 17 ermittelt

12. ENERGIEEFFIZIENZKLASSEN für Lampen

Tabelle 18: Energieeffizienzklassen

13. ENERGIEEFFIZIENZKLASSEN für Fernsehgeräte

Tabelle 19: Energieeffizienzklassen für Fernsehgeräte

Die Amtsblätter der EU zu den Verordnungen der Richtlinien sind unter folgenden Links zu finden:

http://www.newenergylabel.com/index.php/start/

http://ec.europa.eu/energy/sites/ener/files/documents/list_of_enegy_labelling_measures.pdf

Hier kann mehrsprachig zu den einzelnen Produktgruppen verzweigt werden.


%%ItemTitle%%

Sprachenschlüssel
Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Holländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu

Nach ISO-Norm werden die Sprachenschlüssel im Allgemeinen mit kleinen Buchstaben geschrieben. Für die IDM-Daten sind große Buchstaben beschlossen.

</


%%ItemTitle%%

Länderschlüssel
Einleitung > Länderschlüssel

Länderkennzeichen | Ländername(deutsch) | Ländername(englisch)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


%%ItemTitle%%

Typen für Detailinformationen
Einleitung > Typen für Detailinformationen

Für die Beschreibung der Art der Detailinformation gibt es folgende Info-Typen:

1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front (Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht


%%ItemTitle%%

Erläuterung zur Dokumentation


%%ItemTitle%%

Elementreferenz


%%LocalItemTitle%%

T_NEW_CATALOG Element
IDMW 2.0 XML-Schema Dokumentation : T_NEW_CATALOG Element
Beschreibung
In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.
Namensraum (none)
Diagramm
PRICE_DEFINITION Element FEATURE_DEFINITION Element PART_LISTS Element SERIES Element GLOBAL_DEFINITION Element SUPPLIER Element CATALOG Element Sequence T_NEW_CATALOG Element
Overview
T_NEW_CATALOG
In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.
MAJOR required List of xs:positiveInteger
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION. 		D positiveInteger
P
M [2:2]
MINOR required Restriction of xs:nonNegativeInteger
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:0]
REVISION required Restriction of xs:nonNegativeInteger
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:0]
FORMAT required Restriction of xs:string

In diesem Element wird das Kennzeichen für die Herstellerbranche angegeben. Derzeit sind folgende Branchenkennzeichen definiert:

A = Arbeitsplattenhersteller
B = Badmöbelhersteller
G = Gerätehersteller
K = Küchenmöbelhersteller
O = Büromöbelhersteller
P = Polstermöbelhersteller
S = Sanitärhersteller
W = Wohnmöbelhersteller
Z = Zubehörhersteller

Für dieses Element ist nur das Kennzeichen W erlaubt.

 D string
P [W]
M [1:1]
Sequence
CATALOG
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Sequence
CATALOG_IDENTIFICATION
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten müssen identisch sein.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen. D language
P [A-Za-z]{1,3}
M [1:3]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_NAME languagetext30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
VALID_UNTIL_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
CATALOG_MERGE_TYPE optional xs:boolean

Dieses Element CATALOG_MERGE_TYPE ist optional und vom Datentyp boolean mit folgenden Werten:

0: entspricht dem Wert, wenn das Element nicht vorhanden ist und bedeutet, dieser Katalog muss nicht Bestandteil eines Multiherstellerkataloges sein.

1: Dieser Katalog ist immer Bestandteil eines Multiherstellerkataloges.

 D boolean
P
M
CATALOG_DATA_VERSION optional Restriction of xs:date
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
CATALOG_INFO optional languagetext Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
CATALOG_ID Restriction of xs:string

Hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.

Wichtig ist, dass ein Herstellerkatalog für einen bestimmten Händler immer dieselbe ID besitzen muss.

D string
P
M [1:64]
CATALOG_VERSION Restriction of xs:positiveInteger
Hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben D positiveInteger
P
M [1:999999999]
FALL_BACK_LANGUAGE Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO- Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
SUPPLIER
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Sequence
EDI_INFO 0..∞
In diesem Element werden den Geschäftspartnern die möglichen EDI-Kommunikationen mitgeteilt. Für jede EDI-Nachricht eines EDI-Formates wird ein Element angelegt.
Sequence
EDI_FORMAT optional Restriction of xs:string
Hier wird das unterstützte EDI-Format angegeben (z. B. EDIData) D string
P
M [1:20]
EDI_FORMAT_VERSION optional Restriction of xs:string
Hier wird angegeben, welche Version des im Element EDI_FORMAT angegebenen EDI-Formates unterstützt wird. D string
P
M [1:10]
EDI_MESSAGE optional Restriction of xs:string
Hier werden die vom Hersteller unterstützten Nachrichten des EDI-Formates angegeben (z. B. Order, Order Response). D string
P
M [1:20]
EDI_COMMUNICATION optional Restriction of xs:string
Hier wird angegeben, auf welchem Weg die EDI-Kommunikation erfolgt (z. B. X.400, Telebox, E-Mail) D string
P
M [1:20]
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
Hier wird die Adresse für den angegebenen Kommunikationsweg angegeben (z. B. X.400 Adresse, E-Mail-Adresse oder nach Rücksprache) D string
P
M [1:40]
EDI_CONTACT optional Restriction of xs:string
Hier wird die Person angegeben, die beim Hersteller als Kontakt für Details zur EDI Abwicklung zur Verfügung steht. Die Angabe der Kontaktinformationen ist frei, d. h. es können im Rahmen der max. Feldlänge die notwendigen Informationen wie beispielsweise Name, Telefon oder E-Mail angegeben werden. D string
P
M [1:60]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
GLN_NO Restriction of xs:string
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
Hat ein Unternehmen mehrere GLN-Werte, ist die Basis-GLN anzugeben. 		D string
P [0-9]{13}
M
WEEE_NO optional Restriction of xs:string
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
GLOBAL_DEFINITION optional
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Sequence
DETAIL_INFOS optional
In diesem Element werden Detail-Informationen hinterlegt.
Sequence
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:15]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
MESSAGES optional

Dieses Element bietet die Möglichkeit der Bereitstellung von Warnungen und Informationen.

Unterhalb dieses Elementes werden die möglichen Warnungen und Hinweise mit dem entsprechenden Text, der Stufe und dem eindeutigen Identifikatorr gespeichert.

Sequence
MESSAGE 1..99999
Dieses Element dient zur Speicherung einer Nachricht.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
Mit diesen Attribut wird die Nachricht identifiziert. D nonNegativeInteger
P
M [0:99999]
LEVEL optional Restriction of xs:nonNegativeInteger

Hier wird die Stufe der Nachricht angegeben:
0 Hinweis/ Information
1 Warnung

 D nonNegativeInteger
P
M [0:1]
Sequence
MESSAGE_TEXT languagetext Complex Type
In diesem Element wird der Text der Nachricht abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PROPERTIES optional

Dieses Element dient zur Aufnahme zusätzlicher Informationen und Eigenschafen wie z. B. Energielabel, Effizienzklassen und ähnlicher Daten. Es werden nur die Eigenschaften definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Die Schlüssel sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

Sequence
PROPERTY 1..∞

In diesem Element wird eine Eigenschaft definiert.

Die Schlüssel, der Text und die Maßeinheit sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

PROPERTY_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die Eigenschaft identifiziert.

Ihre Nummer ist der Tabelle der Informationsschlüssel zu eintnehmen

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetext Complex Type
Dieses Element enthält Texte für Eigenschaften/Merkmale.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PROPERTY_UNIT optional languagetext30 Complex Type
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
SERIES

In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren Eigenschaften und zugeordneten Elementen wie beispielsweise Produktgruppen oder Artikeln hinterlegt.

Eine Serie entspricht im Allgemeinen einem Modell.

Sequence
SERIE 1..1000000
In diesem Element werden die Serien definiert. Eine Serie entspricht im Allgemeinen einem Modell.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
Dieses Attribut gibt die Möglichkeit, Serien mit einer selbstdefinierten Sortierreihenfolge anzulegen.
Wird für eine Serie eine SEQUENCE_NO angegeben, muss für alle Serien eine SEQUENCE_NO angegeben werden. 		D positiveInteger
P
M
Sequence
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{1,3}
M [1:3]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PURCHASE_RETAIL_ID Restriction of xs:nonNegativeInteger

Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:

EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto

In Abhängigkeit der Preis-ID (Element PRICE_ID (Pfad 1)) wird der Preis wie folgt definiert:

Preis-ID = 1 (Preis), dann wird der Wert aus dem Element ITEM_PRICE (Pfad 2) verwendet.

Preis-ID = 2 (Identnummer), dann wird der Preis aus dem Element IDENT_NUMBER/PRICE (Pfad 3), dem Element ITEM_PRICE/PRICE_MINIMUM_BASIC (Pfad 2) oder dem Element ADDITIONAL_PRICE (Pfad 5) verwendet.

Preis_ID = 3 (Verrechnungspunkt), dann wird der Wert aus aus den Elementen ITEM_PRICE (Pfad 2) oder PRICE_MINIMUM_BASIC multipliziert mit dem Verrechnungsfaktor aus dem Element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR verwendet.

Aufgrund des Schlüssels kann innerhalb einer Serie nur eine Preisstellung (Kombination der Elemente VAT (Pfad 4) und PURCHASE_RETAIL_ID ) angegeben werden.
Werden in einer Datei sowohl EK- wie auch VK-Preise aufgeführt, so dürfen bei Typen mit EK-Preisen nicht die gleichen Kalkulationsgruppen (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) wie bei Typen mit VK-Preisen vergeben werden.
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION/
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/
Pfad 3: PRICE_DEFINITION/IDENT_NUMBERS
Pfad 4: CATALOG/CATALOG_IDENTIFICATION
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

 D nonNegativeInteger
P
M [0:3]
DECISIONS optional
In diesem Element werden Serien-spezifische Regeln gesammelt.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Serie zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D nonNegativeInteger
P
M [1:9999999999]
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert.
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:9999999999]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Zu jedem Artikel werden entweder die Merkmale/Eigenschaften oder eine Referenzierung über ITEM_REF auf eine andere Serie (SERIE_NO) und die dort gültige Artikelnummer (TYPE_NO) gespeichert. Ist das Element ITEM_REF gefüllt, handelt es sich um einen Referenzartikel, der zu einer anderen Serie gehört, im anderen Fall gehört der Artikel zu dieser Serie in der er an dieser Stelle angegeben ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
DECISIONS optional
In diesem Element werden Produktgruppen-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Produktgruppe zugeordnete Regel.
COLOR_CONSULTANCIES optional

In diesem Element werden Farbberatungen definiert.

Jede Farbberatung COLOR_CONSULTANCY enthält beliebig viele Referenzen auf Kombinationen von Detailinfos und Prüfungen FEATURE_DETAIL_INFO_REF, die durch SEQUENCE_NO sortiert sind. Die verwendeten Prüfungen müssen Farbvarianten enthalten.

Sequence
COLOR_CONSULTANCY 1..∞
Über dieses Element können Prüfungen direkt den Bildlayern zugeordnet werden.
Die verwendeten Prüfungen müssen Farbvarianten enthalten .
COLOR_CONSULTANCY_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Farbberatungsnummer definiert. D nonNegativeInteger
P
M [0:9999]
Sequence
FEATURE_DETAIL_INFO_REF 1..∞
Über dieses Element kann genau eine Prüfung oder Regel direkt den Bildlayern zugeordnet werden.
Dabei muss eine Farbvariantenart in der Prüfung bzw. Regel enthalten sein. Die Zuordnung erfolgt über DETAIL_INFO_NO, SEQUENCE_NO und RESTRICTION_NO oder DECISION_NO. Es kann entweder eine Prüfung (RESTRICTION) oder Regel (DECISION) zugeordnet werden.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Farbberatung. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Regel. D positiveInteger
P
M [1:9999999999]
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem die Serie lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
DECISIONS optional
In diesem Element werden Serien-übergreifende Regeln gesammelt.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine Serie-übergreifende Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
SERIE_GROUPS optional
Dieses Element gibt die Möglichkeit verschiedene Serien in Gruppen (Modellgruppen) zusammenzufassen.
Sequence
SERIE_GROUP 1..∞
Hier wird eine Modellgruppe (Gruppierung von mehreren Serien) definiert.
SERIE_GROUP_KEY required Restriction of xs:string

Durch dieses Attribut werden Sereiengruppen/Modellgruppen eindeutig identifiziert.

 D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger

Dieses Attribut gibt die Möglichkeit, Seriengruppen mit einer selbstdefinierten Sortierreihenfolge anzulegen.

 D nonNegativeInteger
P
M
Sequence
SERIE_REF 1..∞
Mit diesem Element werden Serien referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Serie referenziert. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut definiert die Reihenfolge der Serien innerhalb der Sereingruppe. D nonNegativeInteger
P
M
SERIE_GROUP_TEXT languagetext60 Complex Type
In diesem Element wird die Bezeichnung ser Sereingruppe/Modellgruppe hinterlegt.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
PART_LISTS optional

Dieses Element dient dem Aufbau von dynamischen Stücklisten, wobei die Unterpositionen Regeln tragen können, die variantenabhängig bestimmen, in welcher Anzahl die jeweilige Position in der Stückliste vorhanden ist.

Es sind nur Artikel einer entsprechenden Serie oder Artikel der Serie 0 enthalten.

Ein enthaltener Artikel kann wiederum eine Stückliste beinhalten.

Der Artikel, der eine Stückliste enthält, vererbt seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleichen Variantenarten (FEATURES) tragen.

Sequence
PART_LIST 1..∞
In diesem Element wird eine Stückliste definiert.
PART_LIST_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Stückliste referenziert. D string
P
M [1:30]
Sequence
PART_LIST_POS 1..∞
Dieses Element dient der Beschreibung der einzelnen Stücklistenpositionen.
Sequence
SEQUENCE_NO Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Stücklisten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D positiveInteger
P
M
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
DECISIONS optional

In diesem Element werden Regeln für die entsprechende Stücklistenposition gesammelt. Es beeinflusst damit die für diese Position verfügbaren Varianten und Maße..

Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

Sequence
DECISION_REF 1..∞

Dieses Element referenziert eine der Stücklistenposition entsprechende Regel und beeinflusst damit die für diese Position verfügbaren Varianten und Maße. Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
Dieses Element gibt die Anzahl des Artikels in der Stückliste an. D nonNegativeInteger
P
M [0:999999999]
DECISION_POS_COUNT optional

In diesem Element wird eine Regel angegeben, die den Mengenfaktor setzt. Es darf maximal eine davon pro Position geben. Diese Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

Sequence
DECISION_REF

Dieses Element referenziert eine Regel, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint. D positiveInteger
P
M [1:9999999999]
POS_INVISIBILITY Restriction of xs:integer

Dieses Element entspricht einem Kennzeichen, das der Artikel in der Bestellung enthalten sein muss, der Konfigurator sollte diese Position nicht anzeigen. Die Unsichtbarkeit gilt aber nur für die entsprechende Position, nicht für einen eventuell vorhandenen Unterbaum. Das heißt, diese muss für so einen Fall an jeder Unterposition ausgeprägt werden.

0 = sichtbar komplett

1 = gar nicht sichtbar

2= nur in EDI-Bestellung sichtbar, wenn der Artikel über eine Regel erzeugt wird

 D integer
P
M [0:2]
FEATURE_DEFINITION
In diesem Element werden variantenabhängige Informationen hinterlegt.
Sequence
FEATURE_CLASSES

In diesem Element werden Variantenarten zu Familien zusammengefasst. Mittels dieser Variantenfamilien können Plausibilitäts- und Vollständigkeitsprüfungen bezüglich der gültigen Variantenarten durchgeführt werden.

Die definierten Variantenfamilien(Pfad 1) können Serien oder Produktgruppen über FEATURE_CLASS_REF in SERIE und PRODUCT_GROUP zugeordnet werden. Zwischen Variantenfamilien auf Serien- oder Artikelebene besteht keine Beziehung hinsichtlich einer Priorität. Die Anzahl der an einem Artikel gültigen Variantenarten ergibt sich aus der Summe der Variantenarten, die in der Produktgruppe des Artikels deklariert sind.

Alle Variantenarten, die über die Elemente in PRICE_FEATURE_GROUP (Pfad 3), PRICE_FEATURE_BASE_PRICE_GROUP_REF (Pfad 4) und FINISH (Pfad 5) referenziert werden, müssen in der Variantenfamilie des Artikels enthalten sein.

Ebenso müssen die über die Elemente RESTRICTION_REF (Pfad 6) und RESTRICTION_REF (Pfad 8)verwendeten Variantenarten in der Variantenfamilie des Artikels enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
Pfad 2: FEATURE_DEFINITION/FEATURES
Pfad 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 6: SERIES/RESTRICTIONS/RESTRICTION_REF
Pfad 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS

Sequence
FEATURE_CLASS 1..∞
In diesem Element wird eine Variantenfamilie definiert
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Variantenfamilie identifiziert. D positiveInteger
P
M [1:9999999999]
Sequence
FEATURE_REF 1..∞
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Kissens keine Variantenarten für z. B. Fußformen enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:9999]
INVISIBLE optional xs:boolean
Ist der Wert von diesem Attribut wahr (bzw. 1), wird angegeben dass die entsprechende Variantenart unsichtbar ist. D boolean
P
M
.
FEATURES

In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten definiert. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Für einige Variantenarten werden die Kombinationen aus Ausführung und Farbe verwendet.

Variantenarten müssen dann immer paarweise angelegt werden. Zu den entsprechenden Ausführungsvariantenarten existiert die zugehörige Farbvariantenart und zu der Farbvariantenart existiert eine zugehörige Ausführungsvariantenart.

Variantenarten, die als unsichtbare Variantenarten deklariert sind, dürfen nicht in einer Variantenfamilie referenziert werden.

Alle Variantenarten, im Element FEATURES (Pfad 3), die nicht als unsichtbare Kopfvariantenart deklariert sind, müssen mindestens in einer Variantenfamilie referenziert werden.

Weitere Erläuterungen zu den Variantenarten sind zu finden in der Einleitung im Abschnitt " Variantenarten"
Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 3: FEATURE_DEFINITION

Sequence
FEATURE 1..∞
In diesem Element wird eine Variantart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:9999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. Dabei werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Einleitung: Tabelle Variantenarten gekennzeichnet durch Typ A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werden und haben Priorität gegenüber entsprechenden Farbvarianten.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
Dieses Element referenziert ein Material.
FORM_REF
Dieses Element referenziert eine Form

OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert.
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein Variantentext definiert.
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden. Es ist möglich einer Variante mehrere Detail-Infos zuzuordnen und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild/Medium nur in der entsprechenden Serie oder bei bestimmten Artikel angezeigt.
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante oder
P = Positions-Variantenart
ist.
Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.

Mit "I" gekennzeichnete Variantenarten sind sichtbar und ergeben sich implizit aus anderen Variantenarten. 		D string
P [IKP]
M [1:1]
FEATURE_TYPE
Dieses Element dient der Kennzeichnung, welchem Variantentyp die Variantenart entspricht. Eine Varintenart kann Maßvarianten (Wert von FEATURE_T "M"), Farbvarianten (Wert von FEATURE_T "C") oder anderen Variantentypen (Wert von FEATURE_T "O") zugeordnet werden.
FEATURE_T optional Restriction of xs:string

Mit diesem Attribut wird für der der Variantenart zugeordneten Varianten entsprechende Variantentyp definiert.

M = Maßvarianten

C = Farbvarianten

O = andere Varianten

 D string
P [MCO]
M [1:1]
Sequence
MEASURE optional

Falls die der Variantenart zugeordneten Varianten Maßvarianten sind, werden in diesem Element die Maßinformationen eingetragen.

Diese bestehen aus einem Maßparameter und der Maßeinheit und können dann z. B. in Formeln der Regeln (DECISIONS) genutzt werden.

Sequence
MEASURE_UNIT xs:string
In diesem Element wird die Maßeinheit hinterlegt. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

In diesem Element werden die Parameter hinterlegt, die der Definition einer Formel dienen, z. B. Planungsbreite =2*st + sb, wobei st für Seitenteilbreite und sb für Sitzbreite als Parameter stehen.

 D string
P
M
OPTION_DEFINITION optional
In diesem Element werden die Ausprägungen von Farben, Materialien, und Maßen definiert.
Sequence
MATERIAL 0..∞
In diesem Element wird ein Material definiert.

Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante ( gekennzeichnet durch A), dann dürfen weder eine Textur (TEXTURE) noch Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material identifiziert. D string
P
M [1:5]
Sequence
COLOR
In diesem Element werden Farben definiert.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
OPTION_MEASURE 0..∞
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Rücken-, Sitzkissenhöhe).
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine maßliche Ausprägung identifiziert. D positiveInteger
P
M [1:99999]
Sequence
MEASURE_VALUE Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß angegeben. D nonNegativeInteger
P
M [0:999999999]
MEASURE_UNIT xs:string
In diesem Element wird die Einheit angegeben. D string
P
M
DECISIONS optional
In diesem Element werden Regeln für Varianten und Variantenarten formuliert.
Sequence
DECISION 1..99999

In diesem Element wird eine Regel definiert und beschrieben, die technisch machbare Konfigurationen abbildet.
Eine Zuordnung der Regeln zu Serien oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Regeln entweder aus Serien oder Artikeln referenziert werden.

Abhängig von dem Attribut DECISION_TYPE können unterschiedliche Regeln formuliert werden.

Ist der Wert von DECISION_TYPE 0 oder1, handelt es sich um eine Vorbereitungsregel (Preparation Rule).

Hierüber können nun Mengen von ungültigen bzw. gültigen Varianten in OPTION_COMBINATION definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

Die Bedingungen wurden um Operatoren ergänzt. Hierfür wurde ein extra Datentyp operator definiert. Dieser kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Die einzelnen OPTION_COMBINATIONs sind als ELSE-Zweige zu betrachten. Das heißt, sobald eine Bedingungszeile (OPTION_COMBINATION) einen Treffer bekommen hat, werden die anderen nicht mehr durchlaufen.

Ist der Wert von DECISION_TYPE 2, handelt es sich um eine Ausführungsregel (Action Rule). Hier können abhängig von den Bedingungen noch Aktionen definiert werden.

Wenn alle Bedingungen innerhalb einer „OPTION_COMBINATION“ erfüllt sind, dann werden alle zugeordneten Aktionen (ACTIONS) ausgeführt, die abhängig von Bedingungen Werte setzen oder auch Variantenarten (FEATURES) ausblenden können. Ist eine OPTION_COMBINATION erfüllt, werden auch hier die anderen Bedingungen nicht mehr durchlaufen.

Aktionen (ACTIONS)

sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

    Das Setzen von Varianten ( SET_FEATURE_FIXED ) mit folgenden Möglichkeiten:

      - Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

      - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

      - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
      Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
      Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
      Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

        Das Setzen von Standardvarianten ( SET_FEATURE_DEFAULT , SET_FEATURE_DEFAULT_NULL ):
        Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

            Die Sichtbarkeit von Variantenarten ( SET_FEATURE_VISIBLE , SET_FEATURE_INVISIBLE ) bzw. das Wegschalten von Regeln ( DISABLE_DECISION , ENABLE_DECISION ):
            So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

              Ausführungsregeln werden im Konfigurator meistens genutzt, wenn sich ein Optionswert (eine Variante) ändert. So kann z.B. dann, wenn sich die Fußvariante von Edelstahl auf Holz ändert, eine Variantenart für den Beizton angezeigt werden.

              Ist der Wert von DECISION_TYPE 3, handelt es sich um eine Ausführungsregel (Action Rule) für Stücklisten.. Hier kann abhängig von den Bedingungen noch anzahl in der Stückliste definiert werden.

              DECISION_NO required Restriction of xs:positiveInteger
              Mit diesem Attribut wird die Regel identifiziert. D positiveInteger
              P
              M [1:9999999999]
              DECISION_TYPE required Restriction of xs:int

              Mit diesem Attribut wird der Typ einer Regel angegeben.

              0 = ausschließende Vorbereitungsregel

              Hierüber können Mengen von ungültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die ungültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind

              1 = Vorbereitungsregel (PreparationRule)

              Hierüber können Mengen von gültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

              2 = Ausführungsregel (Action Rule)
              Hier können zusätzlich zu den Bedingungen noch Aktionen definiert werden.
              Die Regeln werden vor Eingabe einer Variante am Artikel ausgewertet.
              Wenn dann ein Wert ausgewählt wurde, greifen die Aktionsregeln, welche dann Werte setzen oder Variantenarten ausblenden können.
              Bei Action Rules greift immer die erste Zeile (OPTIONS_SET_REF), die zutrifft. In dem Fall werden alle zugehörigen ACTIONS ausgeführt.

              3 = Ausführungsregel für Anzahl in Stücklisten (PositionCounter Rule)

              Hier kann abhängig von den Bedingungen über die Aktion SET_POS_COUNT_VALUE die Anzahl in der Stückliste definiert werden.

                       D int
              P
              M [0-3]
              Sequence
              DECISION_NAME_TEXT languagetext60 Complex Type
              In diesem Element wird die Bezeichnung einer Regel hinterlegt.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
              P [\S ]{1,60}
              M [1:60]
              OPTION_COMBINATION 1..∞

              In diesem Element wird eine Variantenkombination gebildet, die mit bestimmten Bedingungen verknüpft ist.

              Ist der Wert von DECISION_TYPE 2 oder 3, können der Variantenkombination noch Aktionen (ACTIONS) zugeordnet werden.

              SEQUENCE required Restriction of xs:nonNegativeInteger
              Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. D nonNegativeInteger
              P
              M [1:99999]
              Sequence
              OPTIONS_SET_REF 0..∞

              Mit diesem Element wird auf die Variantenart referenziert und eine Regel für ihre Variantenausprägungen definiert. Die Regeln können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

              Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

              eq (ist gleich)

              ne (ist nicht gleich)

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              REF_LEVEL optional Restriction of xs:nonNegativeInteger
              In Stücklisten können Unterpositionen Variantenarten der Hauptposition (PARENT), der obersten Position (ROOT) und von dem Artikel selbst (SELF) über den REF_LEVEL abfragen und abhängig davon eine Aktion auslösen oder diese in einer Bedingung integrieren.

              1 = ROOT

              2 = PARENT

              3 = SELF (Default ist SELF, wenn kein REF-Level angegeben ist)               		D nonNegativeInteger
              P
              M [1:3]
              Choice
              OPTION_INTERVAL
              Mit diesem Element wird überprüft ob eine Variante innerhalb oder außerhalb eines Intervall liegt.
              OPTION_LIST
              Mit diesem Element wird überprüft ob eine Variante einem Wert innerhalb einer Liste entspricht.
              OPTION_GROUP_REF_OP
              Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
              OPTION_REF_OP

              Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

              FEATURE_REF_OP

              Mit diesem Element kann direkt die Variantenart verglichen werden.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              MEASURE_VALUE_OP
              Mit diesem Element wird der Maßwert einer Variante mit einem weitern Maßwert überprüft.
              MEASURE_INTERVAL
              Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
              ACTIONS optional

              Dieses Element dient der Festlegung von Aktionen, die bei bestimmten Bedingungen durchgeführt werden.

              Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

              • Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

              § Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

              § das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

              § das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
              Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
              Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

              • Das Setzen von Standardvarianten (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
                Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

              • Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
                So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

              Choice 1..∞
              SET_FEATURE_DEFAULT

              Mit dieser Aktion können Standardvarianten gesetzt werden.

              Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde.

              • Für das Setzen von Varianten gibt es folgende Möglichkeiten:

              - Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

              - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

              - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
              Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
              Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

              SET_FEATURE_FIXED

              Mit dieser Aktion können Varianten gesetzt werden.

              Für das Setzen von Varianten gibt es folgende Möglichkeiten:

              - Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

              - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

              - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
              Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
              Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

              ENABLE_DECISION

              Mit dieser Aktion können Regeln eingeschaltet werden.

              DISABLE_DECISION

              Mit dieser Aktion können Regeln ausgeschaltet werden.

              SET_FEATURE_VISIBLE
              Mit dieser Aktion können Variantenarten sichtbar gemacht werden.
              SET_FEATURE_INVISIBLE
              Mit dieser Aktion können Variantenarten unsichtbar gemacht werden.
              SET_FEATURE
              Mittels dieser Aktion kann ein Wert für eine Variante einer Variantenart gesetzt werden. Dieser Wert kann im Gegensatz zu „SET_FEATURE FIXED“ verändert werden, wenn die Bedingungen das zulassen. Diese Wertebelegung greift auch dann, wenn das entsprechende Feld vorher durch einen Default oder manuell belegt wurde.
              SET_FEATURE_DEFAULT_NULL

              Mit dieser Aktion können Standardvarianten gesetzt werden.

              Diese Vorbelegung greift nur wenn das entsprechende Variantenfeld vorher leer war.

              SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
              Mit diesem Element wird eine Anzahl in der Stückliste gesetzt.
              Diese Aktion darf nur bei Regeln mit DECISION_TYPE = 3 angegeben werden.               		D nonNegativeInteger
              P
              M [0:9999]
              SET_MESSAGE
              Dieses Element dient zum Setzen einer Nachricht, so dass bei bestimmten Variantenkombinationen Warnungen oder Hinweise ausgelöst werden können.
              VALID_FROM optional Restriction of xs:date
              Dieses Element gibt das Datum an, ab dem eine Regel gültig ist.
              Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt.               		D date
              P
              M
              VALID_UNTIL optional Restriction of xs:date
              Dieses Element gibt das Datum an, bis zu welchem eine Regel gültig ist.
              Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.               		D date
              P
              M
              FEATURE_REF 0..∞
              Mit diesem Element wird auf die Variantenart referenziert.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              PRIO Restriction of xs:positiveInteger
              Dieses Element dient der Angabe eines Wertes für die Priorität einer Regel.
              Dabei stellt ein kleiner Wert ein hohe Priorität dar. Das heißt, je größer dieser Wert ist, desto schlechter ist der Vorrang dieser Regel.               		D positiveInteger
              P
              M [1:999999999]
              OPTION_GROUPS optional
              Dieses Element dient der Gruppierung von Mengen mehrerer Varianten. Sie können in den Prüfungen unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.
              Sequence
              OPTION_GROUP 1..∞

              Dieses Element dient zur Festlegung eine Variantengruppe.

              Sie kann in den Prüfungen unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.

              OPTION_GROUP_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantengruppe identifiziert. D string
              P
              M [1:30]
              Sequence
              OPTION 1..∞
              Mit diesem Element wird auf eine Variante referenziert.
              OPTION_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
              P
              M [1:30]
              SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
              Dieses Attribut definiert die Reihenfolge der Varianten in einer Variantengruppe D nonNegativeInteger
              P
              M
              OPTION_GROUP_TEXT languagetext60 Complex Type
              Dieses Element enthält Texte für Variantengruppen.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
              P [\S ]{1,60}
              M [1:60]
              FORMULAS optional
              Dieses Element steht für das Rechnen von Varianten (z.B. Sitzhöhe + 5cm) zur Verfügung. Die Funktion ist allerdings nur für Maßvarianten erlaubt, deren Variantenart den Wert ″M″ enthält, in dem Element MEASURE_UNIT die Maßeinheit und in MEASURE_PARAMETER der Parameter (z. B. sh für Sitzhöhe) eingetragen werden kann. Das Rechnen geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Sequence
              FORMULA 1..∞
              Das Element dient der Definition einer Formel. Das Attribut FORMULA_KEY enthält den Identifikator, das Element FORMULA_STRING die eigentliche Formel.
              FORMULA_KEY required Restriction of xs:string
              Mit diesem Attribut wird der Schlüssel für die Formel definiert. D string
              P
              M [1:30]
              Sequence
              FORMULA_STRING Restriction of xs:string
              Dieses Element dient der Angabe einer Formel. D string
              P [+\-*/()A-Za-z. ]{0,}
              M
              PRICE_DEFINITION
              In diesem Element werden Informationen hinterlegt, die für die Preisberechnung notwendig sind wie beispielsweise Preistabellen und Ausführungsgruppen.
              Sequence
              PRICE_FEATURE_GROUPS
              In diesem Element werden Ausführungsgruppen (PRICE_FEATURE_GROUPS) definiert.
              Sequence
              PRICE_FEATURE_GROUP 1..∞

              In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

              Eine PRICE_FEATURE_GROUP wird vom Artikel referenziert. Beim Artikel werden auch die konkreten Preise hinterlegt.

              Für die PRICE_FEATURE_GROUP bzw. für Artikel gelten folgende Regelungen:
              - Preisgruppenneutrale Artikel können Varianten haben, die sich jedoch nicht preislich auswirken. Ihr Preis muss nicht in Preisfeld 1 stehen, sie dürfen jedoch nur ein Element FINISH für die Preisfeldangabe haben. Für preisfeldunabhängige Artikel, für die nur ein Element FINISH in der PRICE_FEATURE_GROUP existiert, in dem der Preis festgehalten wird, dürfen nur einen zugeordneten Preis entsprechend des im FINISH-Element angegebenen Preisfeldes haben.

              - Ausführungsabhängige Artikel haben ein oder mehrere Variantenarten.
              - Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0).

              - Es dürfen prinzipiell mehrere PRICE_FEATURE_GROUPs mit derselben Kombination von Variantenarten angelegt werden.

              PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
              Mit diesem Attribut wird eine PRICE_FEATURE_GROUP eindeutig identifiziert. D postiveInteger
              P
              M [1:99999]
              ADDITIONAL_PRICE required Restriction of xs:boolean
              Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis).
                       D boolean
              P
              M
              Sequence
              PRICE_FEATURE_GROUP_TEXT languagetext60 Complex Type
              Dieses Element enthält Texte für Ausführungsgruppen
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
              P [\S ]{1,60}
              M [1:60]
              Choice
              FINISH 0..∞
              In diesem Element werden gültigen Variantenkombinationen Preisfelder (PRICE_FIELD) und eine Herstellerpreisgruppe zugeordnet.
              SEQUENCE required Restriction of xs:nonNegativeInteger
              Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt die Preisgruppe. D nonNegativeInteger
              P
              M [1:99999]
              Sequence
              OPTIONS_SET_REF 0..∞

              Mit diesem Element wird auf die Variantenart referenziert und eine Preisgruppe für ihre Variantenausprägungen definiert. Die Preisgruppen können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

              Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

              eq (ist gleich)
              ne (ist nicht gleich)
              in (ist enthalten in einer Menge)
              nin (ist nicht enthalten in der Menge)
              gt (größer)
              lt (kleiner)
              ge (größer gleich)
              le (kleiner gleich)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              Choice
              OPTION_INTERVAL

              Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt. 

              Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

              OPTION_LIST
              Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
              OPTION_GROUP_REF_OP
              Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
              OPTION_REF_OP

              Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)
              ne (ist nicht gleich)
              gt (größer)
              lt (kleiner)
              ge (größer gleich)
              le (kleiner gleich)

              MEASURE_VALUE_OP
              Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
              MEASURE_INTERVAL
              Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
              PRICE_FIELD Restriction of xs:positiveInteger

              Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

              Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

              Elementpfade
              Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

              Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

                       D positiveInteger
              P
              M [1:9999]
              SUPPLIER_PRICE_GROUP Restriction of xs:string
              In diesem Element wird die Preisgruppe des Herstellers hinterlegt.
                       D string
              P
              M [1:10]
              VALID_FROM optional Restriction of xs:date
              Dieses Element gibt das Datum an, ab dem das Preisfeld gültig ist. D date
              P
              M
              VALID_UNTIL optional Restriction of xs:date
              Dieses Element gibt das Datum an, bis wann das Preisfeld gültig ist. D date
              P
              M
              PERCENTAGE_SURCHARGE 0..∞
              Um prozentuale Mehrpreise zu ermöglichen, gibt es zusätzlich zu dem Element FINISH unterhalb von PRICE_FEATURE_GROUP das Element PERCENTAGE_SURCHARGE bestehend aus OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM und VALID_UNTIL.
              Dieses Element darf nur für PRICE_FEATURE_GROUP's genutzt werden, für die das Kennzeichen ADDITIONAL_PRICE auf 1 gesetzt ist (1=Mehrpreis).
              Der prozentuale Mehrpreis kann sich auf unterschiedliche PRICE_FEATURE_GROUPs beziehen:

              Fall 1

              Basispreis 500,00

              Aufpreis Kopfstütze 50,00

              Aufpreis Funktion 66,00

              Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

              Aufpreis Rapport 10% auf Basis + Kopfstütze --> Faktor 0,1 * (500+50) = 55

              Aufpreis XY 20% auf alles --> Faktor 0,2 * (500+50+66+50+55) = 144,20

              Positionswert = 865,20

              Fall 2

              Basispreis 500,00

              Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

              Positionswert = 550,00

              Fall 3

              Basispreis 500,00

              Aufpreis Kopfstütze 50,00

              Aufpreis Funktion 66,00

              Aufpreis XY 20% auf Basispreis + Kopfstütze + Funktion --> Faktor 0,2 * (500+50+66)=123,20

              Positionswert = 739,20

              Fall 4

              Basispreis 500,00

              Aufpreis Kopfstütze 50,00

              Aufpreis Funktion 66,00

              Aufpreis XY 20% auf ( Basispreis + Kopfstütze + Funktion ) --> Faktor 0,2 * (500+50+66)=123,20

              Aufpreis ZZ -10% auf ( Basispreis + Funktion ) --> Faktor -0,1 * (500+66)= -56,60

              Positionswert = 682,60

              Fall 5

              Basispreis 500,00

              Aufpreis Kopfstütze 50,00

              Aufpreis Funktion 66,00

              Konditionswert 616,00

              Aufpreis Global1 10% auf alles --> Faktor 0,1 * 616 entspricht Konditionswert = 61,60

              Aufpreis Global2 20% auf alles --> Faktor 0,2 * 616 entspricht Konditionswert = 123,20

              Positionswert = 800,80

              Der Wert des Faktors ist im Element PRICE_FACTOR festzuhalten.

              Die Preisgruppen, auf die sich der prozentuale Aufschlag bezieht, werden unter PRICE_FEATURE_GROUP_REF angegeben.

              Die Gültigkeit ist in den Elementen VALID_FROM und VALID_UNTIL vermerkt.

              Positionswert = 800,80
              SEQUENCE required Restriction of xs:nonNegativeInteger
              Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt den prozentualen Mehrpreis.. D nonNegativeInteger
              P
              M [1:99999]
              Sequence
              OPTIONS_SET_REF 0..∞

              Mit diesem Element wird auf die Variantenart referenziert und ein prozentualer Mehrpreis für ihre Variantenausprägungen definiert. Die prozentualen Mehrpreise können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

              Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

              eq (ist gleich)
              ne (ist nicht gleich)
              in (ist enthalten in einer Menge)
              nin (ist nicht enthalten in der Menge)
              gt (größer)
              lt (kleiner)
              ge (größer gleich)
              le (kleiner gleich)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              Choice
              OPTION_INTERVAL

              Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt.

              Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

              OPTION_LIST
              Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
              OPTION_GROUP_REF_OP
              Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
              OPTION_REF_OP

              Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

              MEASURE_VALUE_OP
              Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
              MEASURE_INTERVAL
              Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
              PRICE_FACTOR Restriction of xs:int

              Dieses Element gibt einen prozentualen Mehrpreis an. Er wird als Faktor mit 5 Nachkommastellen angegeben.

              Der Wert 1050000 entspricht einem Aufschlag von 10,5 %.

              Der Wert -1000000 entspricht einem Aufpreis von -10 %.

                       D int
              P
              M [-9999999:99999999]
              PRICE_FEATURE_GROUP_REF 0..∞
              Dieses Element referenziert eine Preisgruppe abhängig von der Variantenart bzw. Kalkulationsmethode (PRICE_FEATURE_GROUP).
              PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
              Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
              P
              M [1:99999]
              VALID_FROM optional Restriction of xs:date
              Dieses Element gibt das Datum an, ab dem der prozentuale Mehrpreis gültig ist. D date
              P
              M
              VALID_UNTIL optional Restriction of xs:date
              Dieses Element gibt das Datum an, bis wann der prozentuale Mehrpreis gültig ist. D date
              P
              M
              PRICE_TYPES
              In diesem Element werden die Preisarten zur stück- oder maßvariablen Berechnung von variantenneutralen und variantenabhängigen Artikeln definiert.
              Die Kind-Elemente WIDTH_X, DEPTH_Y, HEIGHT_Z geben an, ob der Preis für einen Artikel, der nach dieser Preisart berechnet wird, breiten-, höhen-, tiefen-, flächen- bzw. volumenabhängig ist.
              Wenn für keine Dimension eine "1" angegeben ist, ist der Preis nicht maßabhängig, wird also per Stück berechnet (beispielsweise ein Sitzelement). Dann werden die Elemente BASIC_UNIT und ROUNDING_UNIT mit dem Wert 0 belegt.
              Wird für genau eine Dimension eine "1" angegeben, so wird diese Dimension für die Preisberechnung herangezogen (beispielsweise Stoffe).
              Wenn für genau zwei Dimensionen eine "1" angegeben ist, so ist der Preis flächenabhängig (beispielsweise Teppiche).
              Wenn für genau drei Dimensionen eine "1" angegeben ist, so ist der Preis volumenabhängig (beispielsweise Liegeteile).
              Sequence 1..∞
              PRICE_TYPE
              In diesem Element wird eine Preisart definiert.
              PRICE_TYPE_NO required Restriction of xs:positiveInteger
              Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert. D positiveInteger
              P
              M [1:250]
              Sequence
              WIDTH_X Restriction of xs:boolean
              Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
              P
              M
              DEPTH_Y Restriction of xs:boolean
              Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
              P
              M
              HEIGHT_Z Restriction of xs:boolean
              Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
              P
              M
              BASIC_UNIT Restriction of xs:nonNegativeInteger
              Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (P1) und ADDITIONAL_PRICE (P2) beziehen.
              Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in dieses Element "1000" anzugeben. Bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³] eingegeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein.

              P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
              P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/               		D nonNegativeInteger
              P
              M [0:999999999999]
              ROUNDING_UNIT Restriction of xs:nonNegativeInteger
              Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein. D nonNegativeInteger
              P
              M [0:999999999999]
              ROUNDING_TYPE Restriction of xs:positiveInteger

              Um die unterschiedlichen Arten der Rundung angeben zu können, wird zusätzlich zum Element ROUNDING_UNIT das Element ROUNDING_TYPE mit den möglichen Werten 1, 2 und 3 aufgenommen, um ein Auf-, Ab- und kaufmännisches Runden zu kennzeichnen.

              Die Werte haben folgende Bedeutung:

              1 Aufrunden

              2 Abrunden

              3 Kaufmännisches Runden

                       D positiveInteger
              P
              M [1:3]
              BASIC_PRICE_DEPENDENT Restriction of xs:boolean

              Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf
              Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist
              die Preisberechnung unabhängig von einem Grundpreis.

              In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
              für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/
              PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem
              Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als
              Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

              Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
              wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben,
              der sich auf im Element BASIC_UNIT definierte Basiseinheit bezieht.
              Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung
              zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis
              des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem
              berechnetem Restmaßpreis, unter Berücksichtigung der im Element definierten Logik,
              zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens
              eine Dimension zur Berechnung herangezogen wird.

              Der effektive Artikelpreis wird wie folgt berechnet:
              Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
              Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung
              mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE
              herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

                       D boolean
              P
              M
              PRICE_TYPE_FORMULA optional Restriction of xs:string
              Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
              Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
              - es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) oder HEIGHT_Z (P1) (h) auf true gesetzt werden;
              - es können die Grundrechendarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
              - es kann die mathematische Klammerung verwendet werden;
              - es können keine Vorzeichen verwendet werden;
              - es wird nur das Endergebnis gerundet;
              - die Elemente BASIC_UNIT (P1), ROUNDING_UNIT (P1) und BASIC_PRICE_DEPENDENT (P1) gelten auch in Verbindung mit der Preisartformel.

              [SSS_Elementpfade_SSS]Elementpfade[EEE_Elementpfade_EEE]
              P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/               		D string
              P [\+\-\*/\(\)bhtBHT]{0,}
              M [1:100]
              PRICE_TYPE_NAME optional languagetext60 Complex Type
              In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
              Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
              P [\S ]{1,60}
              M [1:60]
              PRICE_TYPE_RULES optional
              In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
              Sequence
              PRICE_TYPE_RULE 1..100
              In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
              RULE_NO required Restriction of xs:nonNegativeInteger
              In diesem Element wird die Nummer der Regel hinterlegt. D nonNegativeInteger
              P
              M [0:9999]
              Sequence
              RULE xs:string
              In diesem Element wird die Regel definiert. D string
              P
              M
              Attribute
              Name Typ Verwenden Standard Festgelegt Beschreibung
              MAJOR List of xs:positiveInteger required 1
              Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
              Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION.               		D positiveInteger
              P
              M [2:2]
              MINOR Restriction of xs:nonNegativeInteger required
              Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.
                       D nonNegativeInteger
              P
              M [0:0]
              REVISION Restriction of xs:nonNegativeInteger required
              Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.
                       D nonNegativeInteger
              P
              M [0:0]
              FORMAT Restriction of xs:string required

              In diesem Element wird das Kennzeichen für die Herstellerbranche angegeben. Derzeit sind folgende Branchenkennzeichen definiert:

              A = Arbeitsplattenhersteller
              B = Badmöbelhersteller
              G = Gerätehersteller
              K = Küchenmöbelhersteller
              O = Büromöbelhersteller
              P = Polstermöbelhersteller
              S = Sanitärhersteller
              W = Wohnmöbelhersteller
              Z = Zubehörhersteller

              Für dieses Element ist nur das Kennzeichen W erlaubt.

                       D string
              P [W]
              M [1:1]
              Bemerkung

              Quelle
              <xs:element name="T_NEW_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version 2.3 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{1,2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetext30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DATA_VERSION">
              <xs:annotation>
                <xs:documentation>100--11--Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_FROM_DATE">
              <xs:annotation>
                <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL_DATE">
              <xs:annotation>
                <xs:documentation>100--12--Gueltig_bis_Datum Neu Build 9</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_ID">
              <xs:annotation>
                <xs:documentation>100--14--Datei_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MARK">
              <xs:annotation>
                <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BKVF]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
                <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_DATA_VERSION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>110--3--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_ID">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Katalog_ID
/Hermann Balke 9.06.2013
neu in 2.3
hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="64" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_VERSION">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Katalog_Version
/Hermann Balke 16.07.2013
neu in 2.3
hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FALL_BACK_LANGUAGE">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
                <xs:documentation>K. Richter 15.08.2017</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
                <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW  </xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW </xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>105--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EDI_FORMAT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--2--EDI_Format</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="10" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_MESSAGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_COMMUNICATION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="40" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EDI_CONTACT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="GLN_NO">
              <xs:annotation>
                <xs:documentation>100--45--GLN_Nr
30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9]{13}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="WEEE_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--47--WEEE_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_PERSON" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONTACT_PERSON_NO">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_ROLE">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_NAME">
                    <xs:annotation>
                      <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FIRST_NAME">
                    <xs:annotation>
                      <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FORM_OF_ADDRESS">
                    <xs:annotation>
                      <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPARTMENT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE">
                    <xs:annotation>
                      <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONTACT_SUPPLIER">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_NAME_1">
                    <xs:annotation>
                      <xs:documentation>100--16--Herstellername_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--17--Herstellername_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INTERNET_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET">
                    <xs:annotation>
                      <xs:documentation>100--20--Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET">
                    <xs:annotation>
                      <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY">
                    <xs:annotation>
                      <xs:documentation>100--22--Ort</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--24--Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GLOBAL_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INFO_TYPE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front(Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht
12.02.2013/Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:maxInclusive value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="URL">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT" type="xs:anyURI">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="HASH_VALUE">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="32" />
                                          <xs:maxLength value="32" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="LAYER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-6]0" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="MESSAGES" minOccurs="0" maxOccurs="1">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MESSAGE" maxOccurs="99999">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MESSAGE_TEXT" type="languagetext" />
                      </xs:sequence>
                      <xs:attribute name="MESSAGE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="LEVEL">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>120--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROPERTY" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>120--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PROPERTY_TEXT" type="languagetext" minOccurs="1" maxOccurs="1" />
                        <xs:element name="PROPERTY_UNIT" type="languagetext30" minOccurs="0" maxOccurs="1" />
                      </xs:sequence>
                      <xs:attribute name="PROPERTY_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE" maxOccurs="1000000">
              <xs:annotation>
                <xs:documentation>200--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIES_NAME">
                    <xs:annotation>
                      <xs:documentation>200--3--Serienname</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>200--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>200--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Za-z]{1,3}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PURCHASE_RETAIL_ID">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Version 2.3 Polster
Hermann Balke 01.07.2013
EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto</xs:documentation>
                      <xs:documentation />
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DECISIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DECISION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRODUCT_GROUPS">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_CLASS_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                                      <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEMS">
                                <xs:annotation>
                                  <xs:documentation>400--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:choice>
                                            <xs:sequence>
                                              <xs:element name="ITEM_REF">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="TYPE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>401--0--NEW</xs:documentation>
                                                      <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:minLength value="1" />
                                                        <xs:maxLength value="30" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="SERIE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>200--1--Satzart</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:sequence>
                                              <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                                <xs:annotation>
                                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence minOccurs="0">
                                                    <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>450/470--1--Satzart</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="PRICE_FIELD">
                                                            <xs:annotation>
                                                              <xs:documentation>450--4--Preisfeld</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="PRICE">
                                                            <xs:annotation>
                                                              <xs:documentation>450--5--Preis</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:integer">
                                                                <xs:minInclusive value="-99999999" />
                                                                <xs:maxInclusive value="999999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>470--4--Preis</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:integer">
                                                                <xs:minInclusive value="-99999999" />
                                                                <xs:maxInclusive value="999999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="VALID_FROM" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:date" />
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="VALID_UNTIL" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:date" />
                                                            </xs:simpleType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="99999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="PRICE_TYPE_REF">
                                                <xs:annotation>
                                                  <xs:documentation>400/407--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>400/407--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PRICE_FEATURE_GROUP_REF">
                                                      <xs:annotation>
                                                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                                            <xs:annotation>
                                                              <xs:documentation>460--1--Satzart</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="PRICE_FIELD">
                                                                  <xs:annotation>
                                                                    <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger">
                                                                      <xs:minInclusive value="1" />
                                                                      <xs:maxInclusive value="9999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:element>
                                                                <xs:element name="PRICE">
                                                                  <xs:annotation>
                                                                    <xs:documentation>460--5--Preis</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:integer">
                                                                      <xs:minInclusive value="-99999999" />
                                                                      <xs:maxInclusive value="999999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="99999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                    <xs:element name="PRICE_TYPE_REF">
                                                      <xs:annotation>
                                                        <xs:documentation>407--5--Preisart</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>407--5--Preisart</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="DECISIONS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>291--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="DECISION_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>291--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="9999999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>406--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                                            <xs:annotation>
                                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                                              <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                                                  <xs:annotation>
                                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                </xs:element>
                                                                <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:complexType>
                                                                    <xs:attribute name="SERIE_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                                        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="0" />
                                                                          <xs:maxInclusive value="999999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                    <xs:attribute name="TYPE_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                                        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:string">
                                                                          <xs:minLength value="1" />
                                                                          <xs:maxLength value="30" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                    <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="1" />
                                                                          <xs:maxInclusive value="999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                  </xs:complexType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                              <xs:attribute name="SET_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:positiveInteger">
                                                                    <xs:minInclusive value="1" />
                                                                    <xs:maxInclusive value="9" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                              <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                    <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                                  <xs:annotation>
                                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:complexType>
                                                                    <xs:attribute name="SERIE_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="0" />
                                                                          <xs:maxInclusive value="999999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                    <xs:attribute name="TYPE_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:string">
                                                                          <xs:minLength value="1" />
                                                                          <xs:maxLength value="30" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                    <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                                      <xs:annotation>
                                                                        <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                                          <xs:minInclusive value="1" />
                                                                          <xs:maxInclusive value="999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                  </xs:complexType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                              <xs:attribute name="SET_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:positiveInteger">
                                                                    <xs:minInclusive value="1" />
                                                                    <xs:maxInclusive value="9" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="EDP_NUMBER" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="EAN_NUMBER" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="ITEM_IDENTIFICATION">
                                                <xs:annotation>
                                                  <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[BEKSMZVP12]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="CATALOG_PAGE" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="7" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="VALID_FROM" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:date" />
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:date" />
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="WEIGHT_NETTO" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="VOLUME" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--21--Volumen</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="BASIC_PROFILE" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:choice>
                                                      <xs:element name="CARCASE_BASIC_SHAPE">
                                                        <xs:annotation>
                                                          <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>400--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType mixed="true">
                                                                <xs:sequence>
                                                                  <xs:element name="OPTION_REF">
                                                                    <xs:annotation>
                                                                      <xs:documentation>430--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:complexType>
                                                                      <xs:attribute name="FEATURE_NO" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>430--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="9999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="OPTION_KEY" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>430--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:string">
                                                                            <xs:minLength value="1" />
                                                                            <xs:maxLength value="30" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                    </xs:complexType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                                <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>400--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:pattern value="[\S ]{1,5}" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                            <xs:element name="BASIC_SHAPE_PARAMETERS">
                                                              <xs:annotation>
                                                                <xs:documentation>500--1--Satzart</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:complexType>
                                                                      <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--Parameter</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:string">
                                                                            <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--5--Nennwert</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="BASIC_SHAPE_FROM">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--6--Von</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="BASIC_SHAPE_TO">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--7--Bis</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                    </xs:complexType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                                        <xs:annotation>
                                                          <xs:documentation>400--32--Massbild</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:minLength value="1" />
                                                                  <xs:maxLength value="240" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="DIMENSIONAL_PARAMETERS">
                                                              <xs:annotation>
                                                                <xs:documentation>500--1--Satzart</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                                    <xs:annotation>
                                                                      <xs:documentation>500--0--NEW</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:complexType>
                                                                      <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:string">
                                                                            <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="DIMENSIONAL_FROM">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="DIMENSIONAL_TO">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                      <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                                        <xs:annotation>
                                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:decimal">
                                                                            <xs:minInclusive value="0" />
                                                                            <xs:maxInclusive value="999999" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:attribute>
                                                                    </xs:complexType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>400--32--Massbild</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="20" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:choice>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="ITEM_TEXT">
                                                <xs:annotation>
                                                  <xs:documentation>410--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="SHORT_TEXT">
                                                      <xs:annotation>
                                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="TEXT_LINE" maxOccurs="3">
                                                                  <xs:annotation>
                                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:complexType>
                                                                    <xs:sequence>
                                                                      <xs:element name="TEXT">
                                                                        <xs:annotation>
                                                                          <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                        </xs:annotation>
                                                                        <xs:simpleType>
                                                                          <xs:restriction base="xs:string">
                                                                            <xs:pattern value="[\S ]{1,30}" />
                                                                          </xs:restriction>
                                                                        </xs:simpleType>
                                                                      </xs:element>
                                                                    </xs:sequence>
                                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:positiveInteger" />
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                  </xs:complexType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                              <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:language">
                                                                    <xs:pattern value="[A-Za-z]{1,3}" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                    <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                    <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="TYPE_KEY">
                                                <xs:annotation>
                                                  <xs:documentation>445--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                                                      <xs:annotation>
                                                        <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:maxInclusive value="2000" />
                                                          <xs:minInclusive value="1000" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="TK_CLASS" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="TK_INFO" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="[0-8]0" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="ECLASS">
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="ECLASS_NO">
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:totalDigits value="8" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:maxInclusive value="999999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="DECISION_NO" use="optional">
                                                          <xs:annotation>
                                                            <xs:documentation>291--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="9999999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="SALES_NUMBER" minOccurs="0">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PART_LIST_REF" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>401--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="PART_LIST_KEY" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>--0--NEW</xs:documentation>
                                                      <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:maxLength value="30" />
                                                        <xs:minLength value="1" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:boolean" />
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PROPERTIES" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="PROPERTY_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="0" />
                                                              <xs:maxInclusive value="999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="VALUE" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:string">
                                                              <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="ECO_MOBILIER" minOccurs="0">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[0-9]{11}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>250--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                          </xs:element>
                                                          <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>250--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                          </xs:element>
                                                          <xs:element name="WIDTH">
                                                            <xs:annotation>
                                                              <xs:documentation>400--20--Gewicht</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="DEPTH">
                                                            <xs:annotation>
                                                              <xs:documentation>400--20--Gewicht</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="HEIGHT">
                                                            <xs:annotation>
                                                              <xs:documentation>400--20--Gewicht</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="WEIGHT" type="xs:decimal">
                                                            <xs:annotation>
                                                              <xs:documentation>400--20--Gewicht</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                            </xs:annotation>
                                                          </xs:element>
                                                          <xs:element name="EAN_NUMBER" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="DECISIONS" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>291--0--NEW</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                                  <xs:annotation>
                                                                    <xs:documentation>291--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:complexType>
                                                                    <xs:attribute name="DECISION_NO" use="required">
                                                                      <xs:annotation>
                                                                        <xs:documentation>291--0--NEW</xs:documentation>
                                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                                      </xs:annotation>
                                                                      <xs:simpleType>
                                                                        <xs:restriction base="xs:positiveInteger">
                                                                          <xs:minInclusive value="1" />
                                                                          <xs:maxInclusive value="9999999999" />
                                                                        </xs:restriction>
                                                                      </xs:simpleType>
                                                                    </xs:attribute>
                                                                  </xs:complexType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger" />
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:choice>
                                        </xs:sequence>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE_NO">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DECISIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>291--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>291--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DECISION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>291--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="COLOR_CONSULTANCIES" minOccurs="0">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="COLOR_CONSULTANCY" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke
                              </xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>255--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>270--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DECISION_NO" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="COLOR_CONSULTANCY_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
                    <xs:documentation>K. Richter 26.02.2015</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SERIE_GROUPS" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM 2.5
Möglichkeit Serien zu gruppieren und auch ein Bild zu hinterlegen</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIE_GROUP" maxOccurs="unbounded">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SERIE_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>200--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SERIE_GROUP_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SERIE_GROUP_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          <xs:documentation>geändert auf SERIE_GROUP_KEY, K.Richter 23.11.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PART_LISTS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PART_LIST" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PART_LIST_POS" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation />
                      <xs:documentation />
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SEQUENCE_NO">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">IDM-2.5
laufende Nummer der Position
bei Planungsvorschlägen sollte diese von links nach rechts gemäß der Planungsvariante geordnet sein</xs:documentation>
                            <xs:documentation xml:lang="DE" />
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DECISIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>291--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DECISION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="POS_COUNT_VALUE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Anzahl der Positionen gemäß der Einheit an den Stammdaten</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DECISION_POS_COUNT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">IDM 2.5
Entscheidungstabellen, die die Anzahl steuern.
Hier dürfen nur Decisions verwendet werden, die im Action_part die Anzahl steuern (set_pos_count).</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DECISION_REF">
                                <xs:annotation>
                                  <xs:documentation />
                                  <xs:documentation />
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DECISION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="POS_INVISIBILITY">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">IDM 2.5 neu
0 = sichtbar komplett
1 = gar nicht sichtbar
2= nur in EDI-Bestellung sichtbar, wenn über Decisions gezogen wird</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="2" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PART_LIST_KEY" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:maxLength value="30" />
                      <xs:minLength value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_DEFINITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_CLASSES">
              <xs:annotation>
                <xs:documentation>255--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>255--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FEATURE_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>255--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>255--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="INVISIBLE" type="xs:boolean">
                              <xs:annotation>
                                <xs:documentation xml:lang="de">neu 2.4 BA/07.03.2014
unsichtbare Variantenart.
Wird nicht im Konfigurator angezeigt.
</xs:documentation>
                              </xs:annotation>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>255--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                          <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURES">
              <xs:annotation>
                <xs:documentation>250--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:choice minOccurs="0">
                                      <xs:element name="MATERIAL_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MATERIAL_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="FORM_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="FORM_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="5" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_MEASURE_REF">
                                        <xs:annotation>
                                          <xs:documentation>260--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                            <xs:annotation>
                                              <xs:documentation>260--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                    <xs:element name="OPTION_TEXT" type="languagetext60">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="30" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                  <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_FREETEXT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FEATURE_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>250--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="SEQUENCE_NO">
                          <xs:annotation>
                            <xs:documentation>250--4--Sortierung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEADER_POS_VARIATION_TYPE">
                          <xs:annotation>
                            <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[IKP]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FEATURE_TYPE">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="MEASURE" minOccurs="0">
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="MEASURE_UNIT" type="xs:string">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="MEASURE_PARAMETER" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:maxLength value="20" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FEATURE_T">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:length value="1" />
                                  <xs:pattern value="[MCO]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_DEFINITION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="COLOR">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RGB_RED">
                                <xs:annotation>
                                  <xs:documentation>260--11--RGB_Rot</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="255" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="RGB_GREEN">
                                <xs:annotation>
                                  <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="255" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="RGB_BLUE">
                                <xs:annotation>
                                  <xs:documentation>260--13--RGB_Blau</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="255" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="MATERIAL_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MEASURE_VALUE">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="MEASURE_UNIT" type="xs:string">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPTION_MEASURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>270/271--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>nicht zwingend anzugeben, K. Richter, 23.05.2014</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION" maxOccurs="99999">
                    <xs:annotation>
                      <xs:documentation>270/271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DECISION_NAME_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>270--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:complexType>
                                  <xs:choice>
                                    <xs:element name="OPTION_INTERVAL">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="in|nin" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY_MIN" use="required">
                                          <xs:annotation>
                                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY_MAX" use="required">
                                          <xs:annotation>
                                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_LIST">
                                      <xs:complexType>
                                        <xs:sequence maxOccurs="unbounded">
                                          <xs:element name="OPTION_REF">
                                            <xs:complexType>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="in|nin" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_GROUP_REF_OP">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>271--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="in|nin" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF_OP">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>271--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FEATURE_REF_OP">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
                                        <xs:documentation />
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>271--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="eq|ne" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="MEASURE_VALUE_OP">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                          </xs:annotation>
                                        </xs:attribute>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="MEASURE_INTERVAL">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="OPERATOR" use="required">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="operator">
                                              <xs:pattern value="in|nin" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                          <xs:annotation>
                                            <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                          </xs:annotation>
                                        </xs:attribute>
                                        <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                          <xs:annotation>
                                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                          </xs:annotation>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="REF_LEVEL" use="optional">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
                                      <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="3" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ACTIONS" minOccurs="0">
                                <xs:complexType>
                                  <xs:choice maxOccurs="unbounded">
                                    <xs:element name="SET_FEATURE_DEFAULT">
                                      <xs:complexType>
                                        <xs:choice>
                                          <xs:element name="FEATURE_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF">
                                            <xs:complexType>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FORMULA_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FORMULA_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:choice>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_FEATURE_FIXED">
                                      <xs:complexType>
                                        <xs:choice>
                                          <xs:element name="FEATURE_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF">
                                            <xs:complexType>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FORMULA_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FORMULA_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:choice>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ENABLE_DECISION">
                                      <xs:complexType>
                                        <xs:attribute name="DECISION_NO">
                                          <xs:annotation>
                                            <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="DISABLE_DECISION">
                                      <xs:complexType>
                                        <xs:attribute name="DECISION_NO">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_FEATURE_VISIBLE">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_FEATURE_INVISIBLE">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_FEATURE">
                                      <xs:complexType>
                                        <xs:choice>
                                          <xs:element name="FEATURE_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF">
                                            <xs:complexType>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FORMULA_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FORMULA_KEY">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:choice>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_FEATURE_DEFAULT_NULL">
                                      <xs:complexType>
                                        <xs:choice>
                                          <xs:element name="FEATURE_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF">
                                            <xs:complexType>
                                              <xs:attribute name="OPTION_KEY">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FORMULA_REF">
                                            <xs:complexType>
                                              <xs:attribute name="FORMULA_KEY">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:choice>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="SET_POS_COUNT_VALUE">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                        <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                                        <xs:documentation>setzt Anzahl</xs:documentation>
                                        <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="SET_MESSAGE">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                        <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                                        <xs:documentation>setzt Anzahl</xs:documentation>
                                        <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="MESSAGE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                            <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                            <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FEATURE_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Entscheidungstabellen wieder entfernt, nur Angabe FEATURE_NO, 02.05.2014</xs:documentation>
                            <xs:documentation xml:lang="de">Version Beta 2.0 Build 12</xs:documentation>
                            <xs:documentation xml:lang="de">minimale Kardinalität auf 0 geändert K.Richter 18.07.2014</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRIO">
                          <xs:annotation>
                            <xs:documentation xml:lang="de">neu IDM 2.4
Priorität von Prüfungen

Am Artikel können nur Decisions mit niedriger Priorität hinzu bzw. ausgeschaltet werden
Mehrere DECISIONS können auf einem gleichen Priolevel liegen

</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="DECISION_TYPE" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">IDM 2.4 Build 14 H.Balke 05.2014
0 = ausschließende (nicht erlaubende) Preparation
1 = Preparation
2 = action Rules
3 = action Rule mit SET_POS_COUNT_VALUE (setzt die Anzahl in der die Position in der Stückliste erscheint)

Restriktions werden vor Eingabe einer Variante am Artikel ausgewertet.
Wenn dann ein Wert ausgewählt wurde, greifen die action Rules, welche dann Werte setzen oder Variantenarten ausblenden können.
Bei Action Rules greift immer die erste Zeile (option combination), die zutrifft. In dem Fall werden alle zugehörigen Actions ausgeführt.
</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:int">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="3" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_GROUPS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_GROUP" maxOccurs="unbounded">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_GROUP_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPTION_GROUP_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORMULAS" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="de">Formeln dürfen nur angewendet werden auf Maßvarianten </xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FORMULA" maxOccurs="unbounded">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FORMULA_STRING">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Formeln dürfen nur Parameter enthalten, die an der Variantenart definiert wurden.</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[+\-*/()A-Za-z0-9. ]*" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FORMULA_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_DEFINITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>300--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:choice>
                          <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                                    <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:choice>
                                      <xs:element name="OPTION_INTERVAL">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPTION_KEY_MIN" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPTION_KEY_MAX" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_LIST">
                                        <xs:complexType>
                                          <xs:sequence maxOccurs="unbounded">
                                            <xs:element name="OPTION_REF">
                                              <xs:complexType>
                                                <xs:attribute name="OPTION_KEY" use="required">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="30" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_GROUP_REF_OP">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                            <xs:annotation>
                                              <xs:documentation>271--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_REF_OP">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_KEY" use="required">
                                            <xs:annotation>
                                              <xs:documentation>271--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MEASURE_VALUE_OP">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MEASURE_INTERVAL">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                          <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                    <xs:attribute name="FEATURE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="PRICE_FIELD">
                                  <xs:annotation>
                                    <xs:documentation>311--5--Preisfeld</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="SUPPLIER_PRICE_GROUP">
                                  <xs:annotation>
                                    <xs:documentation>311--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="10" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="VALID_FROM" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:date" />
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="VALID_UNTIL" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:date" />
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="SEQUENCE" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="PERCENTAGE_SURCHARGE" minOccurs="0" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>geändert K.Richter 23.11.2015</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:sequence>
                                <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                                    <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:choice>
                                      <xs:element name="OPTION_INTERVAL">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPTION_KEY_MIN" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPTION_KEY_MAX" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_LIST">
                                        <xs:complexType>
                                          <xs:sequence maxOccurs="unbounded">
                                            <xs:element name="OPTION_REF">
                                              <xs:complexType>
                                                <xs:attribute name="OPTION_KEY" use="required">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="30" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:attribute>
                                              </xs:complexType>
                                            </xs:element>
                                          </xs:sequence>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_GROUP_REF_OP">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                            <xs:annotation>
                                              <xs:documentation>271--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="OPTION_REF_OP">
                                        <xs:annotation>
                                          <xs:documentation>271--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_KEY" use="required">
                                            <xs:annotation>
                                              <xs:documentation>271--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MEASURE_VALUE_OP">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                      <xs:element name="MEASURE_INTERVAL">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                        </xs:annotation>
                                        <xs:complexType>
                                          <xs:attribute name="OPERATOR" use="required">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="operator">
                                                <xs:pattern value="in|nin" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                          <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                          <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                            <xs:annotation>
                                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                            </xs:annotation>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:choice>
                                    <xs:attribute name="FEATURE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="PRICE_FACTOR">
                                  <xs:annotation>
                                    <xs:documentation>311--5--Preisfeld</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:int">
                                      <xs:maxInclusive value="99999999" />
                                      <xs:minInclusive value="-9999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                                  <xs:annotation>
                                    <xs:documentation>311--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="VALID_FROM" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:date" />
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="VALID_UNTIL" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:date" />
                                  </xs:simpleType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="SEQUENCE" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="ADDITIONAL_PRICE" use="required">
                        <xs:annotation>
                          <xs:documentation>300--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:boolean" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_TYPES">
              <xs:annotation>
                <xs:documentation>150--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence maxOccurs="unbounded">
                  <xs:element name="PRICE_TYPE">
                    <xs:annotation>
                      <xs:documentation>150--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="WIDTH_X">
                          <xs:annotation>
                            <xs:documentation>150--3--Breite_X</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DEPTH_Y">
                          <xs:annotation>
                            <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HEIGHT_Z">
                          <xs:annotation>
                            <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_UNIT">
                          <xs:annotation>
                            <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ROUNDING_UNIT">
                          <xs:annotation>
                            <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ROUNDING_TYPE">
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="3" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BASIC_PRICE_DEPENDENT">
                          <xs:annotation>
                            <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="100" />
                              <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_NAME" type="languagetext60" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_RULES" minOccurs="0" maxOccurs="1">
                          <xs:annotation>
                            <xs:documentation>360--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_TYPE_RULE" maxOccurs="100">
                                <xs:annotation>
                                  <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
                                  <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="RULE" type="xs:string">
                                      <xs:annotation>
                                        <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
                                        <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="RULE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>360--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>150--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" fixed="1" use="required">
      <xs:annotation>
        <xs:documentation>100--3--Versionsnummer</xs:documentation>
        <xs:documentation>Verlegung der Versionierung</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:list itemType="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>100--4--Sub_Versions_Nr</xs:documentation>
        <xs:documentation />
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="0" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="0" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FORMAT" use="required">
      <xs:annotation>
        <xs:documentation>100--8--Branchen_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[ABGKOPSWZ]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
              Siehe auch
              IDMW 2.0 XML-Schema Dokumentation

              © 2019 All Rights Reserved.

              Send comments on this topic.


%%LocalItemTitle%%

CATALOG Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : CATALOG Element
Beschreibung
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Namensraum (none)
Diagramm
DETAIL_INFOS Element FALL_BACK_LANGUAGE Element CATALOG_VERSION Element CATALOG_ID Element LANGUAGE Element Sequence CATALOG_INFO Element CATALOG_DATA_VERSION Element CATALOG_MERGE_TYPE Element CATALOG_MARK Element FILE_ID Element VALID_UNTIL_DATE Element VALID_FROM_DATE Element DATA_VERSION Element LANGUAGE Element Sequence CATALOG_NAME Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element Sequence CATALOG Element
Overview
CATALOG
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Sequence
CATALOG_IDENTIFICATION
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten müssen identisch sein.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen. D language
P [A-Za-z]{1,3}
M [1:3]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_NAME languagetext30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
VALID_UNTIL_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
CATALOG_MERGE_TYPE optional xs:boolean

Dieses Element CATALOG_MERGE_TYPE ist optional und vom Datentyp boolean mit folgenden Werten:

0: entspricht dem Wert, wenn das Element nicht vorhanden ist und bedeutet, dieser Katalog muss nicht Bestandteil eines Multiherstellerkataloges sein.

1: Dieser Katalog ist immer Bestandteil eines Multiherstellerkataloges.

 D boolean
P
M
CATALOG_DATA_VERSION optional Restriction of xs:date
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
CATALOG_INFO optional languagetext Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
CATALOG_ID Restriction of xs:string

Hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.

Wichtig ist, dass ein Herstellerkatalog für einen bestimmten Händler immer dieselbe ID besitzen muss.

D string
P
M [1:64]
CATALOG_VERSION Restriction of xs:positiveInteger
Hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben D positiveInteger
P
M [1:999999999]
FALL_BACK_LANGUAGE Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO- Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Bemerkung

Quelle
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version 2.3 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{1,2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetext30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DATA_VERSION">
        <xs:annotation>
          <xs:documentation>100--11--Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM_DATE">
        <xs:annotation>
          <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL_DATE">
        <xs:annotation>
          <xs:documentation>100--12--Gueltig_bis_Datum Neu Build 9</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_ID">
        <xs:annotation>
          <xs:documentation>100--14--Datei_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MARK">
        <xs:annotation>
          <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BKVF]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
          <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_DATA_VERSION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>110--3--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_ID">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Katalog_ID
/Hermann Balke 9.06.2013
neu in 2.3
hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="64" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_VERSION">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Katalog_Version
/Hermann Balke 16.07.2013
neu in 2.3
hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FALL_BACK_LANGUAGE">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
          <xs:documentation>K. Richter 15.08.2017</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
          <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW </xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_IDENTIFICATION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_IDENTIFICATION Element
Beschreibung
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten müssen identisch sein.
Namensraum (none)
Diagramm
CURRENCY_KEY Element ISO_LANGUAGE_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten müssen identisch sein.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen. D language
P [A-Za-z]{1,3}
M [1:3]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Bemerkung

Quelle
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{1,2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ISO_LANGUAGE_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Beschreibung
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen. D language
P [A-Za-z]{1,3}
M [1:3]
Namensraum (none)
Typ
Restriction of xs:language
Diagramm
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen. D language
P [A-Za-z]{1,3}
M [1:3]
Bemerkung

Quelle
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{1,2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CURRENCY_KEY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Beschreibung
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Bemerkung

Quelle
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_NUMBER Element
Beschreibung
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Bemerkung

Quelle
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_NAME Element
Beschreibung
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.
Namensraum (none)
Typ
languagetext30 Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetext30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Bemerkung

Quelle
<xs:element name="CATALOG_NAME" type="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > languagetext30 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
languagetext30 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > languagetext30 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetext30 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DATA_VERSION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : DATA_VERSION Element
Beschreibung
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
DATA_VERSION Element
Overview
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
Bemerkung

Quelle
<xs:element name="DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--11--Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM_DATE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : VALID_FROM_DATE Element
Beschreibung
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM_DATE Element
Overview
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
Bemerkung

Quelle
<xs:element name="VALID_FROM_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL_DATE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : VALID_UNTIL_DATE Element
Beschreibung
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL_DATE Element
Overview
VALID_UNTIL_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
Bemerkung

Quelle
<xs:element name="VALID_UNTIL_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--12--Gueltig_bis_Datum Neu Build 9</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FILE_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : FILE_ID Element
Beschreibung
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
FILE_ID Element
Overview
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
Bemerkung

Quelle
<xs:element name="FILE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--14--Datei_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_MARK Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_MARK Element
Beschreibung
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_MARK Element
Overview
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
Bemerkung

Quelle
<xs:element name="CATALOG_MARK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BKVF]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_MERGE_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_MERGE_TYPE Element
Beschreibung

Dieses Element CATALOG_MERGE_TYPE ist optional und vom Datentyp boolean mit folgenden Werten:

0: entspricht dem Wert, wenn das Element nicht vorhanden ist und bedeutet, dieser Katalog muss nicht Bestandteil eines Multiherstellerkataloges sein.

1: Dieser Katalog ist immer Bestandteil eines Multiherstellerkataloges.

 D boolean
P
M
Namensraum (none)
Typ
xs:boolean
Diagramm
CATALOG_MERGE_TYPE Element
Overview
CATALOG_MERGE_TYPE optional xs:boolean

Dieses Element CATALOG_MERGE_TYPE ist optional und vom Datentyp boolean mit folgenden Werten:

0: entspricht dem Wert, wenn das Element nicht vorhanden ist und bedeutet, dieser Katalog muss nicht Bestandteil eines Multiherstellerkataloges sein.

1: Dieser Katalog ist immer Bestandteil eines Multiherstellerkataloges.

 D boolean
P
M
Quelle
<xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
    <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_DATA_VERSION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_DATA_VERSION Element
Beschreibung
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
CATALOG_DATA_VERSION Element
Overview
CATALOG_DATA_VERSION optional Restriction of xs:date
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
Bemerkung

Quelle
<xs:element name="CATALOG_DATA_VERSION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_INFO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_INFO Element
Beschreibung
In diesem Element werden die Informationstexte abgelegt.
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO optional languagetext Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>110--3--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > languagetext Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string" />
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
languagetext Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > languagetext Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Namensraum (none)
Typ
xs:string
Diagramm
TEXT Element
Overview
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
LANGUAGE Element | languagetext Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_ID Element
Beschreibung

Hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.

Wichtig ist, dass ein Herstellerkatalog für einen bestimmten Händler immer dieselbe ID besitzen muss.

D string
P
M [1:64]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_ID Element
Overview
CATALOG_ID Restriction of xs:string

Hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.

Wichtig ist, dass ein Herstellerkatalog für einen bestimmten Händler immer dieselbe ID besitzen muss.

D string
P
M [1:64]
Bemerkung

Quelle
<xs:element name="CATALOG_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Katalog_ID
/Hermann Balke 9.06.2013
neu in 2.3
hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="64" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_VERSION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : CATALOG_VERSION Element
Beschreibung
Hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben D positiveInteger
P
M [1:999999999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CATALOG_VERSION Element
Overview
CATALOG_VERSION Restriction of xs:positiveInteger
Hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben D positiveInteger
P
M [1:999999999]
Bemerkung

Quelle
<xs:element name="CATALOG_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Katalog_Version
/Hermann Balke 16.07.2013
neu in 2.3
hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FALL_BACK_LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : FALL_BACK_LANGUAGE Element
Beschreibung
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO- Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:language
Diagramm
FALL_BACK_LANGUAGE Element
Overview
FALL_BACK_LANGUAGE Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO- Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="FALL_BACK_LANGUAGE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element : DETAIL_INFOS Element
Beschreibung
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
Dieses Element dient der Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
    <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW </xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > CATALOG Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | CATALOG Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SUPPLIER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : SUPPLIER Element
Beschreibung
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Namensraum (none)
Diagramm
CONTACT_SUPPLIER Element CONTACT_PERSON Element WEEE_NO Element GLN_NO Element ISO_COUNTRY_ID Element EDI_INFO Element Sequence SUPPLIER Element
Overview
SUPPLIER
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Sequence
EDI_INFO 0..∞
In diesem Element werden den Geschäftspartnern die möglichen EDI-Kommunikationen mitgeteilt. Für jede EDI-Nachricht eines EDI-Formates wird ein Element angelegt.
Sequence
EDI_FORMAT optional Restriction of xs:string
Hier wird das unterstützte EDI-Format angegeben (z. B. EDIData) D string
P
M [1:20]
EDI_FORMAT_VERSION optional Restriction of xs:string
Hier wird angegeben, welche Version des im Element EDI_FORMAT angegebenen EDI-Formates unterstützt wird. D string
P
M [1:10]
EDI_MESSAGE optional Restriction of xs:string
Hier werden die vom Hersteller unterstützten Nachrichten des EDI-Formates angegeben (z. B. Order, Order Response). D string
P
M [1:20]
EDI_COMMUNICATION optional Restriction of xs:string
Hier wird angegeben, auf welchem Weg die EDI-Kommunikation erfolgt (z. B. X.400, Telebox, E-Mail) D string
P
M [1:20]
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
Hier wird die Adresse für den angegebenen Kommunikationsweg angegeben (z. B. X.400 Adresse, E-Mail-Adresse oder nach Rücksprache) D string
P
M [1:40]
EDI_CONTACT optional Restriction of xs:string
Hier wird die Person angegeben, die beim Hersteller als Kontakt für Details zur EDI Abwicklung zur Verfügung steht. Die Angabe der Kontaktinformationen ist frei, d. h. es können im Rahmen der max. Feldlänge die notwendigen Informationen wie beispielsweise Name, Telefon oder E-Mail angegeben werden. D string
P
M [1:60]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
GLN_NO Restriction of xs:string
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
Hat ein Unternehmen mehrere GLN-Werte, ist die Basis-GLN anzugeben. 		D string
P [0-9]{13}
M
WEEE_NO optional Restriction of xs:string
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>105--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EDI_FORMAT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--2--EDI_Format</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_MESSAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_COMMUNICATION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="40" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EDI_CONTACT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="GLN_NO">
        <xs:annotation>
          <xs:documentation>100--45--GLN_Nr
30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9]{13}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WEEE_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--47--WEEE_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_PERSON" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONTACT_PERSON_NO">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_ROLE">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_NAME">
              <xs:annotation>
                <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FIRST_NAME">
              <xs:annotation>
                <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FORM_OF_ADDRESS">
              <xs:annotation>
                <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPARTMENT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE">
              <xs:annotation>
                <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONTACT_SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_NAME_1">
              <xs:annotation>
                <xs:documentation>100--16--Herstellername_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--17--Herstellername_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INTERNET_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET">
              <xs:annotation>
                <xs:documentation>100--20--Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET">
              <xs:annotation>
                <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY">
              <xs:annotation>
                <xs:documentation>100--22--Ort</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--24--Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_INFO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : EDI_INFO Element
Beschreibung
In diesem Element werden den Geschäftspartnern die möglichen EDI-Kommunikationen mitgeteilt. Für jede EDI-Nachricht eines EDI-Formates wird ein Element angelegt.
Namensraum (none)
Diagramm
EDI_CONTACT Element EDI_COMMUNICATION_ADDRESS Element EDI_COMMUNICATION Element EDI_MESSAGE Element EDI_FORMAT_VERSION Element EDI_FORMAT Element Sequence EDI_INFO Element
Overview
EDI_INFO 0..∞
In diesem Element werden den Geschäftspartnern die möglichen EDI-Kommunikationen mitgeteilt. Für jede EDI-Nachricht eines EDI-Formates wird ein Element angelegt.
Sequence
EDI_FORMAT optional Restriction of xs:string
Hier wird das unterstützte EDI-Format angegeben (z. B. EDIData) D string
P
M [1:20]
EDI_FORMAT_VERSION optional Restriction of xs:string
Hier wird angegeben, welche Version des im Element EDI_FORMAT angegebenen EDI-Formates unterstützt wird. D string
P
M [1:10]
EDI_MESSAGE optional Restriction of xs:string
Hier werden die vom Hersteller unterstützten Nachrichten des EDI-Formates angegeben (z. B. Order, Order Response). D string
P
M [1:20]
EDI_COMMUNICATION optional Restriction of xs:string
Hier wird angegeben, auf welchem Weg die EDI-Kommunikation erfolgt (z. B. X.400, Telebox, E-Mail) D string
P
M [1:20]
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
Hier wird die Adresse für den angegebenen Kommunikationsweg angegeben (z. B. X.400 Adresse, E-Mail-Adresse oder nach Rücksprache) D string
P
M [1:40]
EDI_CONTACT optional Restriction of xs:string
Hier wird die Person angegeben, die beim Hersteller als Kontakt für Details zur EDI Abwicklung zur Verfügung steht. Die Angabe der Kontaktinformationen ist frei, d. h. es können im Rahmen der max. Feldlänge die notwendigen Informationen wie beispielsweise Name, Telefon oder E-Mail angegeben werden. D string
P
M [1:60]
Bemerkung

Quelle
<xs:element name="EDI_INFO" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EDI_FORMAT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--2--EDI_Format</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_FORMAT_VERSION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_MESSAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_COMMUNICATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="40" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EDI_CONTACT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_FORMAT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_FORMAT Element
Beschreibung
Hier wird das unterstützte EDI-Format angegeben (z. B. EDIData) D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_FORMAT Element
Overview
EDI_FORMAT optional Restriction of xs:string
Hier wird das unterstützte EDI-Format angegeben (z. B. EDIData) D string
P
M [1:20]
Bemerkung

Quelle
<xs:element name="EDI_FORMAT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--2--EDI_Format</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_FORMAT_VERSION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_FORMAT_VERSION Element
Beschreibung
Hier wird angegeben, welche Version des im Element EDI_FORMAT angegebenen EDI-Formates unterstützt wird. D string
P
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_FORMAT_VERSION Element
Overview
EDI_FORMAT_VERSION optional Restriction of xs:string
Hier wird angegeben, welche Version des im Element EDI_FORMAT angegebenen EDI-Formates unterstützt wird. D string
P
M [1:10]
Bemerkung

Quelle
<xs:element name="EDI_FORMAT_VERSION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--3--EDI_Format_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_MESSAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_MESSAGE Element
Beschreibung
Hier werden die vom Hersteller unterstützten Nachrichten des EDI-Formates angegeben (z. B. Order, Order Response). D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_MESSAGE Element
Overview
EDI_MESSAGE optional Restriction of xs:string
Hier werden die vom Hersteller unterstützten Nachrichten des EDI-Formates angegeben (z. B. Order, Order Response). D string
P
M [1:20]
Bemerkung

Quelle
<xs:element name="EDI_MESSAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--4--EDI_Nachricht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_COMMUNICATION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_COMMUNICATION Element
Beschreibung
Hier wird angegeben, auf welchem Weg die EDI-Kommunikation erfolgt (z. B. X.400, Telebox, E-Mail) D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_COMMUNICATION Element
Overview
EDI_COMMUNICATION optional Restriction of xs:string
Hier wird angegeben, auf welchem Weg die EDI-Kommunikation erfolgt (z. B. X.400, Telebox, E-Mail) D string
P
M [1:20]
Bemerkung

Quelle
<xs:element name="EDI_COMMUNICATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--5--EDI_Kommunikation</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_COMMUNICATION_ADDRESS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_COMMUNICATION_ADDRESS Element
Beschreibung
Hier wird die Adresse für den angegebenen Kommunikationsweg angegeben (z. B. X.400 Adresse, E-Mail-Adresse oder nach Rücksprache) D string
P
M [1:40]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_COMMUNICATION_ADDRESS Element
Overview
EDI_COMMUNICATION_ADDRESS optional Restriction of xs:string
Hier wird die Adresse für den angegebenen Kommunikationsweg angegeben (z. B. X.400 Adresse, E-Mail-Adresse oder nach Rücksprache) D string
P
M [1:40]
Bemerkung

Quelle
<xs:element name="EDI_COMMUNICATION_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--6--EDI_Adresse_Kommunikation</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="40" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDI_CONTACT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > EDI_INFO Element : EDI_CONTACT Element
Beschreibung
Hier wird die Person angegeben, die beim Hersteller als Kontakt für Details zur EDI Abwicklung zur Verfügung steht. Die Angabe der Kontaktinformationen ist frei, d. h. es können im Rahmen der max. Feldlänge die notwendigen Informationen wie beispielsweise Name, Telefon oder E-Mail angegeben werden. D string
P
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDI_CONTACT Element
Overview
EDI_CONTACT optional Restriction of xs:string
Hier wird die Person angegeben, die beim Hersteller als Kontakt für Details zur EDI Abwicklung zur Verfügung steht. Die Angabe der Kontaktinformationen ist frei, d. h. es können im Rahmen der max. Feldlänge die notwendigen Informationen wie beispielsweise Name, Telefon oder E-Mail angegeben werden. D string
P
M [1:60]
Bemerkung

Quelle
<xs:element name="EDI_CONTACT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>105--7--EDI_Kontakt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
EDI_INFO Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ISO_COUNTRY_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : ISO_COUNTRY_ID Element
Beschreibung
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Bemerkung

Quelle
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

GLN_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : GLN_NO Element
Beschreibung
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
Hat ein Unternehmen mehrere GLN-Werte, ist die Basis-GLN anzugeben. 		D string
P [0-9]{13}
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
GLN_NO Element
Overview
GLN_NO Restriction of xs:string
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch.
Hat ein Unternehmen mehrere GLN-Werte, ist die Basis-GLN anzugeben. 		D string
P [0-9]{13}
M
Bemerkung

Quelle
<xs:element name="GLN_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--45--GLN_Nr
30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{13}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WEEE_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : WEEE_NO Element
Beschreibung
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
WEEE_NO Element
Overview
WEEE_NO optional Restriction of xs:string
In dieses Element wird die WEEE-Registrierungsnummer eingetragen. Eine WEEE Registrierungsnummer muss haben, wer nach dem "Elektro- und Elektronikgerätegesetz" (ElektroG) als Hersteller oder Importeur von Elektrogeräten eingestuft wird.
In Deutschland hat die WEEE-Nr. folgenden Aufbau: "DE12345678".
Händler können die Gültigkeit der WEEE-Nummer auf der Internetseite der "Stiftung Elektro-Altgeräte Register" (http://www.stiftung-ear.de) nachvollziehen. 		D string
P
M
Bemerkung

Quelle
<xs:element name="WEEE_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--47--WEEE_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CONTACT_PERSON Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : CONTACT_PERSON Element
Beschreibung
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt
Namensraum (none)
Diagramm
ISO_COUNTRY_ID Element CITY Element ZIPCODE_STREET Element STREET Element EMAIL Element FAX Element TELEPHONE Element DEPARTMENT Element FORM_OF_ADDRESS Element FIRST_NAME Element CONTACT_NAME Element CONTACT_ROLE Element CONTACT_PERSON_NO Element Sequence CONTACT_PERSON Element
Overview
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Bemerkung

Quelle
<xs:element name="CONTACT_PERSON" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONTACT_PERSON_NO">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_ROLE">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_NAME">
        <xs:annotation>
          <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FIRST_NAME">
        <xs:annotation>
          <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FORM_OF_ADDRESS">
        <xs:annotation>
          <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPARTMENT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE">
        <xs:annotation>
          <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CONTACT_PERSON_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_PERSON_NO Element
Beschreibung
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme) D positiveInteger
P
M [1:2]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CONTACT_PERSON_NO Element
Overview
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Kontaktaufnahme) D positiveInteger
P
M [1:2]
Bemerkung

Quelle
<xs:element name="CONTACT_PERSON_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CONTACT_ROLE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_ROLE Element
Beschreibung
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONTACT_ROLE Element
Overview
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
Bemerkung

Quelle
<xs:element name="CONTACT_ROLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CONTACT_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_NAME Element
Beschreibung
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONTACT_NAME Element
Overview
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
Bemerkung

Quelle
<xs:element name="CONTACT_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FIRST_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FIRST_NAME Element
Beschreibung
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FIRST_NAME Element
Overview
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
Quelle
<xs:element name="FIRST_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORM_OF_ADDRESS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FORM_OF_ADDRESS Element
Beschreibung
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
FORM_OF_ADDRESS Element
Overview
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
Bemerkung

Quelle
<xs:element name="FORM_OF_ADDRESS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DEPARTMENT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : DEPARTMENT Element
Beschreibung
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
DEPARTMENT Element
Overview
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
Bemerkung

Quelle
<xs:element name="DEPARTMENT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TELEPHONE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : TELEPHONE Element
Beschreibung
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TELEPHONE Element
Overview
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="TELEPHONE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FAX Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : FAX Element
Beschreibung
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FAX Element
Overview
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="FAX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EMAIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : EMAIL Element
Beschreibung
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Bemerkung

Quelle
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--32/39--E_MAIL_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

STREET Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : STREET Element
Beschreibung
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
STREET Element
Overview
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : ZIPCODE_STREET Element
Beschreibung
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Bemerkung

Quelle
<xs:element name="ZIPCODE_STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CITY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : CITY Element
Beschreibung
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CITY Element
Overview
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="CITY" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ISO_COUNTRY_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_PERSON Element : ISO_COUNTRY_ID Element
Beschreibung
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CONTACT_SUPPLIER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element : CONTACT_SUPPLIER Element
Beschreibung
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt
Namensraum (none)
Diagramm
FAX_SWITCHBOARD Element TELEPHONE_SWITCHBOARD Element POSTBOX Element ZIPCODE_POSTBOX Element ISO_COUNTRY_ID Element CITY Element ZIPCODE_STREET Element STREET Element INTERNET_ADDRESS Element EMAIL Element MANUFACTURER_NAME_2 Element MANUFACTURER_NAME_1 Element Sequence CONTACT_SUPPLIER Element
Overview
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="CONTACT_SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_NAME_1">
        <xs:annotation>
          <xs:documentation>100--16--Herstellername_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--17--Herstellername_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INTERNET_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--19--Internet_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET">
        <xs:annotation>
          <xs:documentation>100--20--Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET">
        <xs:annotation>
          <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY">
        <xs:annotation>
          <xs:documentation>100--22--Ort</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--24--Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9a-zA-Z]{0,10}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MANUFACTURER_NAME_1 Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_1 Element
Beschreibung
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MANUFACTURER_NAME_1 Element
Overview
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="MANUFACTURER_NAME_1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--16--Herstellername_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MANUFACTURER_NAME_2 Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_2 Element
Beschreibung
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MANUFACTURER_NAME_2 Element
Overview
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="MANUFACTURER_NAME_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--17--Herstellername_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EMAIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : EMAIL Element
Beschreibung
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}
M
Bemerkung

Quelle
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

INTERNET_ADDRESS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : INTERNET_ADDRESS Element
Beschreibung
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
INTERNET_ADDRESS Element
Overview
INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
Bemerkung

Quelle
<xs:element name="INTERNET_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--19--Internet_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

STREET Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : STREET Element
Beschreibung
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
STREET Element
Overview
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--20--Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_STREET Element
Beschreibung
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Bemerkung

Quelle
<xs:element name="ZIPCODE_STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CITY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : CITY Element
Beschreibung
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CITY Element
Overview
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="CITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--22--Ort</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ISO_COUNTRY_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ISO_COUNTRY_ID Element
Beschreibung
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ISO_COUNTRY_ID Element
Overview
ISO_COUNTRY_ID Restriction of xs:string
In diesem Element wird das Land, indem der Sitz des Herstellers ist, nach ISO-Norm angegeben. D string
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="ISO_COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--25--ISO_Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ZIPCODE_POSTBOX Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_POSTBOX Element
Beschreibung
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_POSTBOX Element
Overview
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
Bemerkung

Quelle
<xs:element name="ZIPCODE_POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

POSTBOX Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : POSTBOX Element
Beschreibung
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
POSTBOX Element
Overview
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Bemerkung

Quelle
<xs:element name="POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--24--Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9a-zA-Z]{0,10}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TELEPHONE_SWITCHBOARD Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : TELEPHONE_SWITCHBOARD Element
Beschreibung
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TELEPHONE_SWITCHBOARD Element
Overview
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="TELEPHONE_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FAX_SWITCHBOARD Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SUPPLIER Element > CONTACT_SUPPLIER Element : FAX_SWITCHBOARD Element
Beschreibung
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FAX_SWITCHBOARD Element
Overview
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Bemerkung

Quelle
<xs:element name="FAX_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

GLOBAL_DEFINITION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : GLOBAL_DEFINITION Element
Beschreibung
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Namensraum (none)
Diagramm
PROPERTIES Element MESSAGES Element DETAIL_INFOS Element Sequence GLOBAL_DEFINITION Element
Overview
GLOBAL_DEFINITION optional
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Sequence
DETAIL_INFOS optional
In diesem Element werden Detail-Informationen hinterlegt.
Sequence
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:15]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
MESSAGES optional

Dieses Element bietet die Möglichkeit der Bereitstellung von Warnungen und Informationen.

Unterhalb dieses Elementes werden die möglichen Warnungen und Hinweise mit dem entsprechenden Text, der Stufe und dem eindeutigen Identifikatorr gespeichert.

Sequence
MESSAGE 1..99999
Dieses Element dient zur Speicherung einer Nachricht.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
Mit diesen Attribut wird die Nachricht identifiziert. D nonNegativeInteger
P
M [0:99999]
LEVEL optional Restriction of xs:nonNegativeInteger

Hier wird die Stufe der Nachricht angegeben:
0 Hinweis/ Information
1 Warnung

 D nonNegativeInteger
P
M [0:1]
Sequence
MESSAGE_TEXT languagetext Complex Type
In diesem Element wird der Text der Nachricht abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PROPERTIES optional

Dieses Element dient zur Aufnahme zusätzlicher Informationen und Eigenschafen wie z. B. Energielabel, Effizienzklassen und ähnlicher Daten. Es werden nur die Eigenschaften definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Die Schlüssel sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

Sequence
PROPERTY 1..∞

In diesem Element wird eine Eigenschaft definiert.

Die Schlüssel, der Text und die Maßeinheit sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

PROPERTY_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die Eigenschaft identifiziert.

Ihre Nummer ist der Tabelle der Informationsschlüssel zu eintnehmen

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetext Complex Type
Dieses Element enthält Texte für Eigenschaften/Merkmale.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PROPERTY_UNIT optional languagetext30 Complex Type
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Bemerkung

Quelle
<xs:element name="GLOBAL_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INFO_TYPE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front(Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht
12.02.2013/Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="URL">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT" type="xs:anyURI">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="HASH_VALUE">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="32" />
                                    <xs:maxLength value="32" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="LAYER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-6]0" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MESSAGES" minOccurs="0" maxOccurs="1">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MESSAGE" maxOccurs="99999">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MESSAGE_TEXT" type="languagetext" />
                </xs:sequence>
                <xs:attribute name="MESSAGE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="LEVEL">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>120--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROPERTY" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PROPERTY_TEXT" type="languagetext" minOccurs="1" maxOccurs="1" />
                  <xs:element name="PROPERTY_UNIT" type="languagetext30" minOccurs="0" maxOccurs="1" />
                </xs:sequence>
                <xs:attribute name="PROPERTY_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : DETAIL_INFOS Element
Beschreibung
In diesem Element werden Detail-Informationen hinterlegt.
Namensraum (none)
Diagramm
DETAIL_INFO Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
In diesem Element werden Detail-Informationen hinterlegt.
Sequence
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:15]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="INFO_TYPE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front(Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht
12.02.2013/Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="URL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT" type="xs:anyURI">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="HASH_VALUE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="32" />
                              <xs:maxLength value="32" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="LAYER" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-6]0" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element : DETAIL_INFO Element
Beschreibung
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
Namensraum (none)
Diagramm
LAYER Element URL Element LANGUAGE Element Sequence TOOL_TIP Element LANGUAGE Element Sequence INTERNAL_NAME Element LANGUAGE Element Sequence EXTERNAL_NAME Element INFO_TYPE Element CLASSIFICATION Element Sequence DETAIL_INFO Element
Overview
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:15]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="INFO_TYPE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front(Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht
12.02.2013/Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="URL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT" type="xs:anyURI">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="HASH_VALUE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="32" />
                        <xs:maxLength value="32" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="LAYER" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-6]0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CLASSIFICATION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : CLASSIFICATION Element
Beschreibung
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CLASSIFICATION Element
Overview
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
Quelle
<xs:element name="CLASSIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

INFO_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INFO_TYPE Element
Beschreibung
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
INFO_TYPE Element
Overview
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:15]
Quelle
<xs:element name="INFO_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Front(Fronttextur, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Materialpass (PDF an den Fronten)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
15 = Artikelpictogramm Ansicht
12.02.2013/Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EXTERNAL_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : EXTERNAL_NAME Element
Beschreibung
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence EXTERNAL_NAME Element
Overview
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

INTERNAL_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INTERNAL_NAME Element
Beschreibung
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Namensraum (none)
Typ
languagetext40 Complex Type
Diagramm
LANGUAGE Element Sequence INTERNAL_NAME Element
Overview
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TOOL_TIP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : TOOL_TIP Element
Beschreibung

Dieses Element enthält Text für einen Hinweis zum Link.

Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence TOOL_TIP Element
Overview
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="TOOL_TIP" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

URL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : URL Element
Beschreibung
Dieses Element gibt die URL zur Detailinformation an.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence URL Element
Overview
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Quelle
<xs:element name="URL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT" type="xs:anyURI">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="HASH_VALUE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="32" />
                  <xs:maxLength value="32" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
HASH_VALUE Element TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:anyURI">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="HASH_VALUE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="32" />
            <xs:maxLength value="32" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
Namensraum (none)
Typ
xs:anyURI
Diagramm
TEXT Element
Overview
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
Quelle
<xs:element name="TEXT" type="xs:anyURI" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

HASH_VALUE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : HASH_VALUE Element
Beschreibung
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
HASH_VALUE Element
Overview
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Quelle
<xs:element name="HASH_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="32" />
      <xs:maxLength value="32" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LAYER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : LAYER Element
Beschreibung

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
LAYER Element
Overview
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Quelle
<xs:element name="LAYER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-6]0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MESSAGES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : MESSAGES Element
Beschreibung

Dieses Element bietet die Möglichkeit der Bereitstellung von Warnungen und Informationen.

Unterhalb dieses Elementes werden die möglichen Warnungen und Hinweise mit dem entsprechenden Text, der Stufe und dem eindeutigen Identifikatorr gespeichert.

Namensraum (none)
Diagramm
MESSAGE Element Sequence MESSAGES Element
Overview
MESSAGES optional

Dieses Element bietet die Möglichkeit der Bereitstellung von Warnungen und Informationen.

Unterhalb dieses Elementes werden die möglichen Warnungen und Hinweise mit dem entsprechenden Text, der Stufe und dem eindeutigen Identifikatorr gespeichert.

Sequence
MESSAGE 1..99999
Dieses Element dient zur Speicherung einer Nachricht.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
Mit diesen Attribut wird die Nachricht identifiziert. D nonNegativeInteger
P
M [0:99999]
LEVEL optional Restriction of xs:nonNegativeInteger

Hier wird die Stufe der Nachricht angegeben:
0 Hinweis/ Information
1 Warnung

 D nonNegativeInteger
P
M [0:1]
Sequence
MESSAGE_TEXT languagetext Complex Type
In diesem Element wird der Text der Nachricht abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="MESSAGES" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MESSAGE" maxOccurs="99999">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MESSAGE_TEXT" type="languagetext" />
          </xs:sequence>
          <xs:attribute name="MESSAGE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="LEVEL">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MESSAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > MESSAGES Element : MESSAGE Element
Beschreibung
Dieses Element dient zur Speicherung einer Nachricht.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence MESSAGE_TEXT Element Sequence MESSAGE Element
Overview
MESSAGE 1..99999
Dieses Element dient zur Speicherung einer Nachricht.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
Mit diesen Attribut wird die Nachricht identifiziert. D nonNegativeInteger
P
M [0:99999]
LEVEL optional Restriction of xs:nonNegativeInteger

Hier wird die Stufe der Nachricht angegeben:
0 Hinweis/ Information
1 Warnung

 D nonNegativeInteger
P
M [0:1]
Sequence
MESSAGE_TEXT languagetext Complex Type
In diesem Element wird der Text der Nachricht abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MESSAGE_NO Restriction of xs:nonNegativeInteger required
Mit diesen Attribut wird die Nachricht identifiziert. D nonNegativeInteger
P
M [0:99999]
LEVEL Restriction of xs:nonNegativeInteger optional

Hier wird die Stufe der Nachricht angegeben:
0 Hinweis/ Information
1 Warnung

 D nonNegativeInteger
P
M [0:1]
Quelle
<xs:element name="MESSAGE" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MESSAGE_TEXT" type="languagetext" />
    </xs:sequence>
    <xs:attribute name="MESSAGE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="LEVEL">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MESSAGES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MESSAGE_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > MESSAGES Element > MESSAGE Element : MESSAGE_TEXT Element
Beschreibung
In diesem Element wird der Text der Nachricht abgelegt.
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence MESSAGE_TEXT Element
Overview
MESSAGE_TEXT languagetext Complex Type
In diesem Element wird der Text der Nachricht abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="MESSAGE_TEXT" type="languagetext" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
MESSAGE Element | MESSAGES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTIES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element : PROPERTIES Element
Beschreibung

Dieses Element dient zur Aufnahme zusätzlicher Informationen und Eigenschafen wie z. B. Energielabel, Effizienzklassen und ähnlicher Daten. Es werden nur die Eigenschaften definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Die Schlüssel sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

Namensraum (none)
Diagramm
PROPERTY Element Sequence PROPERTIES Element
Overview
PROPERTIES optional

Dieses Element dient zur Aufnahme zusätzlicher Informationen und Eigenschafen wie z. B. Energielabel, Effizienzklassen und ähnlicher Daten. Es werden nur die Eigenschaften definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Die Schlüssel sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

Sequence
PROPERTY 1..∞

In diesem Element wird eine Eigenschaft definiert.

Die Schlüssel, der Text und die Maßeinheit sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

PROPERTY_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die Eigenschaft identifiziert.

Ihre Nummer ist der Tabelle der Informationsschlüssel zu eintnehmen

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetext Complex Type
Dieses Element enthält Texte für Eigenschaften/Merkmale.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PROPERTY_UNIT optional languagetext30 Complex Type
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="PROPERTIES" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PROPERTY_TEXT" type="languagetext" minOccurs="1" maxOccurs="1" />
            <xs:element name="PROPERTY_UNIT" type="languagetext30" minOccurs="0" maxOccurs="1" />
          </xs:sequence>
          <xs:attribute name="PROPERTY_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element : PROPERTY Element
Beschreibung

In diesem Element wird eine Eigenschaft definiert.

Die Schlüssel, der Text und die Maßeinheit sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence PROPERTY_UNIT Element LANGUAGE Element Sequence PROPERTY_TEXT Element Sequence PROPERTY Element
Overview
PROPERTY 1..∞

In diesem Element wird eine Eigenschaft definiert.

Die Schlüssel, der Text und die Maßeinheit sind der entsprechenden Tabelle (Informationsschlüssel) zu entnehmen.

PROPERTY_NO required Restriction of xs:nonNegativeInteger

Mit diesem Attribut wird die Eigenschaft identifiziert.

Ihre Nummer ist der Tabelle der Informationsschlüssel zu eintnehmen

 D nonNegativeInteger
P
M [0:999]
Sequence
PROPERTY_TEXT languagetext Complex Type
Dieses Element enthält Texte für Eigenschaften/Merkmale.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PROPERTY_UNIT optional languagetext30 Complex Type
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PROPERTY_NO Restriction of xs:nonNegativeInteger required

Mit diesem Attribut wird die Eigenschaft identifiziert.

Ihre Nummer ist der Tabelle der Informationsschlüssel zu eintnehmen

 D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="PROPERTY" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY_TEXT" type="languagetext" minOccurs="1" maxOccurs="1" />
      <xs:element name="PROPERTY_UNIT" type="languagetext30" minOccurs="0" maxOccurs="1" />
    </xs:sequence>
    <xs:attribute name="PROPERTY_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTY_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element > PROPERTY Element : PROPERTY_TEXT Element
Beschreibung
Dieses Element enthält Texte für Eigenschaften/Merkmale.
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence PROPERTY_TEXT Element
Overview
PROPERTY_TEXT languagetext Complex Type
Dieses Element enthält Texte für Eigenschaften/Merkmale.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="PROPERTY_TEXT" type="languagetext" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
PROPERTY Element | PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTY_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > GLOBAL_DEFINITION Element > PROPERTIES Element > PROPERTY Element : PROPERTY_UNIT Element
Beschreibung
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Namensraum (none)
Typ
languagetext30 Complex Type
Diagramm
LANGUAGE Element Sequence PROPERTY_UNIT Element
Overview
PROPERTY_UNIT optional languagetext30 Complex Type
In diesem Element kann passend zur Eigenschaft/zum Merkmal die Maßeinheit hinterlegt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="PROPERTY_UNIT" type="languagetext30" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
PROPERTY Element | PROPERTIES Element | GLOBAL_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : SERIES Element
Beschreibung

In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren Eigenschaften und zugeordneten Elementen wie beispielsweise Produktgruppen oder Artikeln hinterlegt.

Eine Serie entspricht im Allgemeinen einem Modell.

Namensraum (none)
Diagramm
SERIE_GROUPS Element DECISIONS Element SERIE Element Sequence SERIES Element
Overview
SERIES

In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren Eigenschaften und zugeordneten Elementen wie beispielsweise Produktgruppen oder Artikeln hinterlegt.

Eine Serie entspricht im Allgemeinen einem Modell.

Sequence
SERIE 1..1000000
In diesem Element werden die Serien definiert. Eine Serie entspricht im Allgemeinen einem Modell.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
Dieses Attribut gibt die Möglichkeit, Serien mit einer selbstdefinierten Sortierreihenfolge anzulegen.
Wird für eine Serie eine SEQUENCE_NO angegeben, muss für alle Serien eine SEQUENCE_NO angegeben werden. 		D positiveInteger
P
M
Sequence
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{1,3}
M [1:3]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PURCHASE_RETAIL_ID Restriction of xs:nonNegativeInteger

Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:

EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto

In Abhängigkeit der Preis-ID (Element PRICE_ID (Pfad 1)) wird der Preis wie folgt definiert:

Preis-ID = 1 (Preis), dann wird der Wert aus dem Element ITEM_PRICE (Pfad 2) verwendet.

Preis-ID = 2 (Identnummer), dann wird der Preis aus dem Element IDENT_NUMBER/PRICE (Pfad 3), dem Element ITEM_PRICE/PRICE_MINIMUM_BASIC (Pfad 2) oder dem Element ADDITIONAL_PRICE (Pfad 5) verwendet.

Preis_ID = 3 (Verrechnungspunkt), dann wird der Wert aus aus den Elementen ITEM_PRICE (Pfad 2) oder PRICE_MINIMUM_BASIC multipliziert mit dem Verrechnungsfaktor aus dem Element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR verwendet.

Aufgrund des Schlüssels kann innerhalb einer Serie nur eine Preisstellung (Kombination der Elemente VAT (Pfad 4) und PURCHASE_RETAIL_ID ) angegeben werden.
Werden in einer Datei sowohl EK- wie auch VK-Preise aufgeführt, so dürfen bei Typen mit EK-Preisen nicht die gleichen Kalkulationsgruppen (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) wie bei Typen mit VK-Preisen vergeben werden.
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION/
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/
Pfad 3: PRICE_DEFINITION/IDENT_NUMBERS
Pfad 4: CATALOG/CATALOG_IDENTIFICATION
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

 D nonNegativeInteger
P
M [0:3]
DECISIONS optional
In diesem Element werden Serien-spezifische Regeln gesammelt.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Serie zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D nonNegativeInteger
P
M [1:9999999999]
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert.
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:9999999999]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Zu jedem Artikel werden entweder die Merkmale/Eigenschaften oder eine Referenzierung über ITEM_REF auf eine andere Serie (SERIE_NO) und die dort gültige Artikelnummer (TYPE_NO) gespeichert. Ist das Element ITEM_REF gefüllt, handelt es sich um einen Referenzartikel, der zu einer anderen Serie gehört, im anderen Fall gehört der Artikel zu dieser Serie in der er an dieser Stelle angegeben ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisgruppe. Eine Basispreisgruppe ist eine PRICE_FEATURE_GROUP (Pfad 1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisgruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
DECISIONS optional
In diesem Element werden Artikel-spzezifische Regeln zusammengefasst.
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil;
K = Katalogartikel;
S = Sonderartikel;
M = Mehrausstattungen;
Z = Zusammenstellung
V = Verrechnungsblock
P = Verrechnungsposition.
1 = Planungsvorschlag
2 = Vorzugskombi

Für den Planungsvorschlag (1) gilt folgendes:
Die einzelnen Artikel können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register ?Zubehör?. 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Brutto-Gewicht des Artikels [100 g] angegeben. D.h. inklusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Netto-Gewicht des Artikels [100 g] angegeben. D.h. exlusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³]des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;
- Kurztext + empfohlener Text;
- Kurztext + empfohlener Text + Langtext;
- Kurztext + Langtext (nur wenn kein empfohlener Text angelegt wurde).

Der Kurztext darf aus drei Zeilen bestehen.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Werte der Typschlüssel werden in einer Tabelle der Einleitung, Abschnitt Typenschlüssel bereitgestellt.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
SALES_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die Verkaufs-Nummer des Artikels eingetragen werden. D string
P
M [1:30]
PART_LIST_REF optional

Dieses Element referenziert eine im Artikel enthaltene Stückliste.

Der Artikel vererbt dabei seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleiche Variantenarten (FEATURES) tragen.

An den Unterpositionen kann es Regeln geben, die bestimmen, ob eine Unterposition dargestellt wird. Die Angabe der Unterposition erfolgt dann mit der entsprechenden Stückzahl.

Artikel, die nur als Unterposition zulässig sind, werden separat markiert (Element PARTS_LIST_EXCLUSIVE).

Handelt es sich bei dem Artikel um einen Katalogartikel (ITEM_IDENTIFICATION 'K'), können dem Artikel Preise zugeordnet werden. Der Gesamtpreis des Katalogartikels ergibt sich aus dem ihm zugeordneten Preis und den Preisen der Bestandteile der Stückliste.

Für den Planungsvorschlag (ITEM_IDENTIFICATION '1'), gilt folgendes:
Die einzelnen Artikel der Stückliste können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi (ITEM_IDENTIFICATION '2') unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
Dieses Element markiert, ob der Artikel nur als Unterposition einer Stückliste zulässig ist (Wert auf 1(true) gesetzt).
Der Wert 0 (false) hat die gleiche Bedeutung wie ein fehlender Wert. 		D boolean
P
M
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

D string P [0-9]{11} M [11:11]

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

Dieses Element dient der Angabe der Packstücke pro Artikel. Dabei ist keine Packstückoptimierung auf Grund von Kaufvorgängen möglich.

Pro Packstück müssen Breite, Tiefe, Höhe ganzzahlig in mm angegeben werden. Die Angabe des Gewichtes erfolgt dezimal in kg.

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

DECISIONS optional
In diesem Element werden Produktgruppen-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Produktgruppe zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
COLOR_CONSULTANCIES optional

In diesem Element werden Farbberatungen definiert.

Jede Farbberatung COLOR_CONSULTANCY enthält beliebig viele Referenzen auf Kombinationen von Detailinfos und Prüfungen FEATURE_DETAIL_INFO_REF, die durch SEQUENCE_NO sortiert sind. Die verwendeten Prüfungen müssen Farbvarianten enthalten.

Sequence
COLOR_CONSULTANCY 1..∞
Über dieses Element können Prüfungen direkt den Bildlayern zugeordnet werden.
Die verwendeten Prüfungen müssen Farbvarianten enthalten .
COLOR_CONSULTANCY_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Farbberatungsnummer definiert. D nonNegativeInteger
P
M [0:9999]
Sequence
FEATURE_DETAIL_INFO_REF 1..∞
Über dieses Element kann genau eine Prüfung oder Regel direkt den Bildlayern zugeordnet werden.
Dabei muss eine Farbvariantenart in der Prüfung bzw. Regel enthalten sein. Die Zuordnung erfolgt über DETAIL_INFO_NO, SEQUENCE_NO und RESTRICTION_NO oder DECISION_NO. Es kann entweder eine Prüfung (RESTRICTION) oder Regel (DECISION) zugeordnet werden.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Farbberatung. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Regel. D positiveInteger
P
M [1:9999999999]
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem die Serie lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
DECISIONS optional
In diesem Element werden Serien-übergreifende Regeln gesammelt.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine Serie-übergreifende Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
SERIE_GROUPS optional
Dieses Element gibt die Möglichkeit verschiedene Serien in Gruppen (Modellgruppen) zusammenzufassen.
Sequence
SERIE_GROUP 1..∞
Hier wird eine Modellgruppe (Gruppierung von mehreren Serien) definiert.
SERIE_GROUP_KEY required Restriction of xs:string

Durch dieses Attribut werden Sereiengruppen/Modellgruppen eindeutig identifiziert.

 D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger

Dieses Attribut gibt die Möglichkeit, Seriengruppen mit einer selbstdefinierten Sortierreihenfolge anzulegen.

 D nonNegativeInteger
P
M
Sequence
SERIE_REF 1..∞
Mit diesem Element werden Serien referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Serie referenziert. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut definiert die Reihenfolge der Serien innerhalb der Sereingruppe. D nonNegativeInteger
P
M
SERIE_GROUP_TEXT languagetext60 Complex Type
In diesem Element wird die Bezeichnung ser Sereingruppe/Modellgruppe hinterlegt.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Bemerkung

Quelle
<xs:element name="SERIES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE" maxOccurs="1000000">
        <xs:annotation>
          <xs:documentation>200--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIES_NAME">
              <xs:annotation>
                <xs:documentation>200--3--Serienname</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>200--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Za-z]{1,3}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PURCHASE_RETAIL_ID">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Version 2.3 Polster
Hermann Balke 01.07.2013
EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRODUCT_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_CLASS_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                                <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEMS">
                          <xs:annotation>
                            <xs:documentation>400--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:choice>
                                      <xs:sequence>
                                        <xs:element name="ITEM_REF">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="TYPE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>401--0--NEW</xs:documentation>
                                                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:minLength value="1" />
                                                  <xs:maxLength value="30" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="SERIE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>200--1--Satzart</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:sequence>
                                        <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                          <xs:annotation>
                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence minOccurs="0">
                                              <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>450/470--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PRICE_FIELD">
                                                      <xs:annotation>
                                                        <xs:documentation>450--4--Preisfeld</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="PRICE">
                                                      <xs:annotation>
                                                        <xs:documentation>450--5--Preis</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:integer">
                                                          <xs:minInclusive value="-99999999" />
                                                          <xs:maxInclusive value="999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>470--4--Preis</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:integer">
                                                          <xs:minInclusive value="-99999999" />
                                                          <xs:maxInclusive value="999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="VALID_FROM" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:date" />
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:date" />
                                                      </xs:simpleType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="99999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="PRICE_TYPE_REF">
                                          <xs:annotation>
                                            <xs:documentation>400/407--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="PRICE_TYPE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>400/407--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PRICE_FEATURE_GROUP_REF">
                                                <xs:annotation>
                                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>460--1--Satzart</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="PRICE_FIELD">
                                                            <xs:annotation>
                                                              <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger">
                                                                <xs:minInclusive value="1" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                          <xs:element name="PRICE">
                                                            <xs:annotation>
                                                              <xs:documentation>460--5--Preis</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:integer">
                                                                <xs:minInclusive value="-99999999" />
                                                                <xs:maxInclusive value="999999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="99999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="PRICE_TYPE_REF">
                                                <xs:annotation>
                                                  <xs:documentation>407--5--Preisart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>407--5--Preisart</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="DECISIONS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>291--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="DECISION_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>291--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="9999999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>406--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                                        <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                                            <xs:annotation>
                                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                          </xs:element>
                                                          <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:attribute name="SERIE_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                                  <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="0" />
                                                                    <xs:maxInclusive value="999999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                              <xs:attribute name="TYPE_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                                  <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:string">
                                                                    <xs:minLength value="1" />
                                                                    <xs:maxLength value="30" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                              <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="1" />
                                                                    <xs:maxInclusive value="999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="SET_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="9" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                            <xs:annotation>
                                                              <xs:documentation>406--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:attribute name="SERIE_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="0" />
                                                                    <xs:maxInclusive value="999999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                              <xs:attribute name="TYPE_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:string">
                                                                    <xs:minLength value="1" />
                                                                    <xs:maxLength value="30" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                              <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                                <xs:annotation>
                                                                  <xs:documentation>406--7--Anzahl</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                                    <xs:minInclusive value="1" />
                                                                    <xs:maxInclusive value="999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="SET_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>406--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="9" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="EDP_NUMBER" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="EAN_NUMBER" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="ITEM_IDENTIFICATION">
                                          <xs:annotation>
                                            <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[BEKSMZVP12]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="CATALOG_PAGE" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="7" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="VALID_FROM" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:date" />
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="VALID_UNTIL" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:date" />
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="WEIGHT_NETTO" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="VOLUME" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--21--Volumen</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="BASIC_PROFILE" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:choice>
                                                <xs:element name="CARCASE_BASIC_SHAPE">
                                                  <xs:annotation>
                                                    <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>400--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType mixed="true">
                                                          <xs:sequence>
                                                            <xs:element name="OPTION_REF">
                                                              <xs:annotation>
                                                                <xs:documentation>430--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="FEATURE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>430--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="9999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="OPTION_KEY" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>430--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:minLength value="1" />
                                                                      <xs:maxLength value="30" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>400--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:pattern value="[\S ]{1,5}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="BASIC_SHAPE_PARAMETERS">
                                                        <xs:annotation>
                                                          <xs:documentation>500--1--Satzart</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--Parameter</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--5--Nennwert</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="BASIC_SHAPE_FROM">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--6--Von</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="BASIC_SHAPE_TO">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--7--Bis</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                                  <xs:annotation>
                                                    <xs:documentation>400--32--Massbild</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:minLength value="1" />
                                                            <xs:maxLength value="240" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="DIMENSIONAL_PARAMETERS">
                                                        <xs:annotation>
                                                          <xs:documentation>500--1--Satzart</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                              <xs:annotation>
                                                                <xs:documentation>500--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="DIMENSIONAL_FROM">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="DIMENSIONAL_TO">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                                <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                                  <xs:annotation>
                                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:decimal">
                                                                      <xs:minInclusive value="0" />
                                                                      <xs:maxInclusive value="999999" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>400--32--Massbild</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="20" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:choice>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="ITEM_TEXT">
                                          <xs:annotation>
                                            <xs:documentation>410--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="SHORT_TEXT">
                                                <xs:annotation>
                                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="TEXT_LINE" maxOccurs="3">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:sequence>
                                                                <xs:element name="TEXT">
                                                                  <xs:annotation>
                                                                    <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:string">
                                                                      <xs:pattern value="[\S ]{1,30}" />
                                                                    </xs:restriction>
                                                                  </xs:simpleType>
                                                                </xs:element>
                                                              </xs:sequence>
                                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:positiveInteger" />
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>410--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:language">
                                                              <xs:pattern value="[A-Za-z]{1,3}" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                              <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                              <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="TYPE_KEY">
                                          <xs:annotation>
                                            <xs:documentation>445--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:maxInclusive value="2000" />
                                                    <xs:minInclusive value="1000" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="TK_CLASS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="TK_INFO" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[0-8]0" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="ECLASS">
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="ECLASS_NO">
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:totalDigits value="8" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:maxInclusive value="999999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="DECISION_NO" use="optional">
                                                    <xs:annotation>
                                                      <xs:documentation>291--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="9999999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="SALES_NUMBER" minOccurs="0">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PART_LIST_REF" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>401--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="PART_LIST_KEY" use="required">
                                              <xs:annotation>
                                                <xs:documentation>--0--NEW</xs:documentation>
                                                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:maxLength value="30" />
                                                  <xs:minLength value="1" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:boolean" />
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PROPERTIES" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="PROPERTY_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="VALUE" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="ECO_MOBILIER" minOccurs="0">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[0-9]{11}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>250--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                    <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>250--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                    <xs:element name="WIDTH">
                                                      <xs:annotation>
                                                        <xs:documentation>400--20--Gewicht</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="DEPTH">
                                                      <xs:annotation>
                                                        <xs:documentation>400--20--Gewicht</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="HEIGHT">
                                                      <xs:annotation>
                                                        <xs:documentation>400--20--Gewicht</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="WEIGHT" type="xs:decimal">
                                                      <xs:annotation>
                                                        <xs:documentation>400--20--Gewicht</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                    <xs:element name="EAN_NUMBER" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="DECISIONS" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>291--0--NEW</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                            <xs:annotation>
                                                              <xs:documentation>291--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:complexType>
                                                              <xs:attribute name="DECISION_NO" use="required">
                                                                <xs:annotation>
                                                                  <xs:documentation>291--0--NEW</xs:documentation>
                                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                                  <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                                </xs:annotation>
                                                                <xs:simpleType>
                                                                  <xs:restriction base="xs:positiveInteger">
                                                                    <xs:minInclusive value="1" />
                                                                    <xs:maxInclusive value="9999999999" />
                                                                  </xs:restriction>
                                                                </xs:simpleType>
                                                              </xs:attribute>
                                                            </xs:complexType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger" />
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:choice>
                                  </xs:sequence>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DECISIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>291--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DECISION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="COLOR_CONSULTANCIES" minOccurs="0">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="COLOR_CONSULTANCY" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke
                              </xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>255--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>270--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="DECISION_NO" use="optional">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="COLOR_CONSULTANCY_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
              <xs:documentation>K. Richter 26.02.2015</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIE_GROUPS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5
Möglichkeit Serien zu gruppieren und auch ein Bild zu hinterlegen</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE_GROUP" maxOccurs="unbounded">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIE_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>200--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SERIE_GROUP_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_GROUP_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                    <xs:documentation>geändert auf SERIE_GROUP_KEY, K.Richter 23.11.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element : SERIE Element
Beschreibung
In diesem Element werden die Serien definiert. Eine Serie entspricht im Allgemeinen einem Modell.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
Namensraum (none)
Diagramm
VALID_UNTIL Element VALID_FROM Element DETAIL_INFOS Element COLOR_CONSULTANCIES Element PRODUCT_GROUPS Element DECISIONS Element PURCHASE_RETAIL_ID Element SERIES_NAME Element Sequence SERIE Element
Overview
SERIE 1..1000000
In diesem Element werden die Serien definiert. Eine Serie entspricht im Allgemeinen einem Modell.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
Dieses Attribut gibt die Möglichkeit, Serien mit einer selbstdefinierten Sortierreihenfolge anzulegen.
Wird für eine Serie eine SEQUENCE_NO angegeben, muss für alle Serien eine SEQUENCE_NO angegeben werden. 		D positiveInteger
P
M
Sequence
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{1,3}
M [1:3]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PURCHASE_RETAIL_ID Restriction of xs:nonNegativeInteger

Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:

EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto

In Abhängigkeit der Preis-ID (Element PRICE_ID (Pfad 1)) wird der Preis wie folgt definiert:

Preis-ID = 1 (Preis), dann wird der Wert aus dem Element ITEM_PRICE (Pfad 2) verwendet.

Preis-ID = 2 (Identnummer), dann wird der Preis aus dem Element IDENT_NUMBER/PRICE (Pfad 3), dem Element ITEM_PRICE/PRICE_MINIMUM_BASIC (Pfad 2) oder dem Element ADDITIONAL_PRICE (Pfad 5) verwendet.

Preis_ID = 3 (Verrechnungspunkt), dann wird der Wert aus aus den Elementen ITEM_PRICE (Pfad 2) oder PRICE_MINIMUM_BASIC multipliziert mit dem Verrechnungsfaktor aus dem Element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR verwendet.

Aufgrund des Schlüssels kann innerhalb einer Serie nur eine Preisstellung (Kombination der Elemente VAT (Pfad 4) und PURCHASE_RETAIL_ID ) angegeben werden.
Werden in einer Datei sowohl EK- wie auch VK-Preise aufgeführt, so dürfen bei Typen mit EK-Preisen nicht die gleichen Kalkulationsgruppen (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) wie bei Typen mit VK-Preisen vergeben werden.
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION/
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/
Pfad 3: PRICE_DEFINITION/IDENT_NUMBERS
Pfad 4: CATALOG/CATALOG_IDENTIFICATION
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

 D nonNegativeInteger
P
M [0:3]
DECISIONS optional
In diesem Element werden Serien-spezifische Regeln gesammelt.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Serie zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D nonNegativeInteger
P
M [1:9999999999]
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert.
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:9999999999]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Zu jedem Artikel werden entweder die Merkmale/Eigenschaften oder eine Referenzierung über ITEM_REF auf eine andere Serie (SERIE_NO) und die dort gültige Artikelnummer (TYPE_NO) gespeichert. Ist das Element ITEM_REF gefüllt, handelt es sich um einen Referenzartikel, der zu einer anderen Serie gehört, im anderen Fall gehört der Artikel zu dieser Serie in der er an dieser Stelle angegeben ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisgruppe. Eine Basispreisgruppe ist eine PRICE_FEATURE_GROUP (Pfad 1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisgruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
DECISIONS optional
In diesem Element werden Artikel-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine dem Artikel zugeordnete Regel.
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden.
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil;
K = Katalogartikel;
S = Sonderartikel;
M = Mehrausstattungen;
Z = Zusammenstellung
V = Verrechnungsblock
P = Verrechnungsposition.
1 = Planungsvorschlag
2 = Vorzugskombi

Für den Planungsvorschlag (1) gilt folgendes:
Die einzelnen Artikel können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register ?Zubehör?. 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Brutto-Gewicht des Artikels [100 g] angegeben. D.h. inklusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Netto-Gewicht des Artikels [100 g] angegeben. D.h. exlusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³]des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
997 = Artikel für die weder Grundform, noch Echtgrafik mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist.
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;
- Kurztext + empfohlener Text;
- Kurztext + empfohlener Text + Langtext;
- Kurztext + Langtext (nur wenn kein empfohlener Text angelegt wurde).

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Werte der Typschlüssel werden in einer Tabelle der Einleitung, Abschnitt Typenschlüssel bereitgestellt.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle "Typschlüssel" der Einleitung eingetragen. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Art der Tabelle "Typschlüssel-Arten"eingetragen. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle " Ausführungsschlüssel"eingetragen. D nonNegativeInteger
P [0-8]0
M [00-80]
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

SALES_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die Verkaufs-Nummer des Artikels eingetragen werden. D string
P
M [1:30]
PART_LIST_REF optional

Dieses Element referenziert eine im Artikel enthaltene Stückliste.

Der Artikel vererbt dabei seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleiche Variantenarten (FEATURES) tragen.

An den Unterpositionen kann es Regeln geben, die bestimmen, ob eine Unterposition dargestellt wird. Die Angabe der Unterposition erfolgt dann mit der entsprechenden Stückzahl.

Artikel, die nur als Unterposition zulässig sind, werden separat markiert (Element PARTS_LIST_EXCLUSIVE).

Handelt es sich bei dem Artikel um einen Katalogartikel (ITEM_IDENTIFICATION 'K'), können dem Artikel Preise zugeordnet werden. Der Gesamtpreis des Katalogartikels ergibt sich aus dem ihm zugeordneten Preis und den Preisen der Bestandteile der Stückliste.

Für den Planungsvorschlag (ITEM_IDENTIFICATION '1'), gilt folgendes:
Die einzelnen Artikel der Stückliste können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi (ITEM_IDENTIFICATION '2') unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

PART_LIST_KEY required Restriction of xs:string
In diesem Attribut wird der Schlüssel der Stückliste angegeben. D string
P
M [1:30]
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
Dieses Element markiert, ob der Artikel nur als Unterposition einer Stückliste zulässig ist (Wert auf 1(true) gesetzt).
Der Wert 0 (false) hat die gleiche Bedeutung wie ein fehlender Wert. 		D boolean
P
M
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

D string P [0-9]{11} M [11:11]

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

Dieses Element dient der Angabe der Packstücke pro Artikel. Dabei ist keine Packstückoptimierung auf Grund von Kaufvorgängen möglich.

Pro Packstück müssen Breite, Tiefe, Höhe ganzzahlig in mm angegeben werden. Die Angabe des Gewichtes erfolgt dezimal in kg.

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Sequence
PACKAGE_LIST_POS 1..∞
Hier werden die Eigenschaften eines Packstücks der Liste festgehalten.
DECISIONS optional
In diesem Element werden Produktgruppen-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Produktgruppe zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
COLOR_CONSULTANCIES optional

In diesem Element werden Farbberatungen definiert.

Jede Farbberatung COLOR_CONSULTANCY enthält beliebig viele Referenzen auf Kombinationen von Detailinfos und Prüfungen FEATURE_DETAIL_INFO_REF, die durch SEQUENCE_NO sortiert sind. Die verwendeten Prüfungen müssen Farbvarianten enthalten.

Sequence
COLOR_CONSULTANCY 1..∞
Über dieses Element können Prüfungen direkt den Bildlayern zugeordnet werden.
Die verwendeten Prüfungen müssen Farbvarianten enthalten .
COLOR_CONSULTANCY_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Farbberatungsnummer definiert. D nonNegativeInteger
P
M [0:9999]
Sequence
FEATURE_DETAIL_INFO_REF 1..∞
Über dieses Element kann genau eine Prüfung oder Regel direkt den Bildlayern zugeordnet werden.
Dabei muss eine Farbvariantenart in der Prüfung bzw. Regel enthalten sein. Die Zuordnung erfolgt über DETAIL_INFO_NO, SEQUENCE_NO und RESTRICTION_NO oder DECISION_NO. Es kann entweder eine Prüfung (RESTRICTION) oder Regel (DECISION) zugeordnet werden.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Farbberatung. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Regel. D positiveInteger
P
M [1:9999999999]
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem die Serie lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO xs:positiveInteger required
Dieses Attribut gibt die Möglichkeit, Serien mit einer selbstdefinierten Sortierreihenfolge anzulegen.
Wird für eine Serie eine SEQUENCE_NO angegeben, muss für alle Serien eine SEQUENCE_NO angegeben werden. 		D positiveInteger
P
M
Bemerkung

Quelle
<xs:element name="SERIE" maxOccurs="1000000" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIES_NAME">
        <xs:annotation>
          <xs:documentation>200--3--Serienname</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>200--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Za-z]{1,3}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PURCHASE_RETAIL_ID">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Version 2.3 Polster
Hermann Balke 01.07.2013
EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRODUCT_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_CLASS_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                          <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEMS">
                    <xs:annotation>
                      <xs:documentation>400--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:choice>
                                <xs:sequence>
                                  <xs:element name="ITEM_REF">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="TYPE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>401--0--NEW</xs:documentation>
                                          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:minLength value="1" />
                                            <xs:maxLength value="30" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="SERIE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>200--1--Satzart</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:sequence>
                                  <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                    <xs:annotation>
                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence minOccurs="0">
                                        <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>450/470--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PRICE_FIELD">
                                                <xs:annotation>
                                                  <xs:documentation>450--4--Preisfeld</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PRICE">
                                                <xs:annotation>
                                                  <xs:documentation>450--5--Preis</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:integer">
                                                    <xs:minInclusive value="-99999999" />
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>470--4--Preis</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:integer">
                                                    <xs:minInclusive value="-99999999" />
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="VALID_FROM" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:date" />
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:date" />
                                                </xs:simpleType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="99999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="PRICE_TYPE_REF">
                                    <xs:annotation>
                                      <xs:documentation>400/407--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>400/407--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PRICE_FEATURE_GROUP_REF">
                                          <xs:annotation>
                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>460--1--Satzart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="PRICE_FIELD">
                                                      <xs:annotation>
                                                        <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                    <xs:element name="PRICE">
                                                      <xs:annotation>
                                                        <xs:documentation>460--5--Preis</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:integer">
                                                          <xs:minInclusive value="-99999999" />
                                                          <xs:maxInclusive value="999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="99999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="PRICE_TYPE_REF">
                                          <xs:annotation>
                                            <xs:documentation>407--5--Preisart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="PRICE_TYPE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>407--5--Preisart</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="DECISIONS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>291--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="DECISION_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>291--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="9999999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>406--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                  <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:element>
                                                    <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="SERIE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>406--0--NEW</xs:documentation>
                                                            <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="0" />
                                                              <xs:maxInclusive value="999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="TYPE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>406--0--NEW</xs:documentation>
                                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:string">
                                                              <xs:minLength value="1" />
                                                              <xs:maxLength value="30" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                          <xs:annotation>
                                                            <xs:documentation>406--7--Anzahl</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="SET_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="9" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="SERIE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>406--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="0" />
                                                              <xs:maxInclusive value="999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="TYPE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>406--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:string">
                                                              <xs:minLength value="1" />
                                                              <xs:maxLength value="30" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                        <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                          <xs:annotation>
                                                            <xs:documentation>406--7--Anzahl</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:nonNegativeInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="SET_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>406--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="9" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="EDP_NUMBER" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="EAN_NUMBER" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="ITEM_IDENTIFICATION">
                                    <xs:annotation>
                                      <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[BEKSMZVP12]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="CATALOG_PAGE" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="7" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="VALID_FROM" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:date" />
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="VALID_UNTIL" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:date" />
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="WEIGHT_NETTO" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="VOLUME" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--21--Volumen</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="BASIC_PROFILE" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:choice>
                                          <xs:element name="CARCASE_BASIC_SHAPE">
                                            <xs:annotation>
                                              <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>400--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType mixed="true">
                                                    <xs:sequence>
                                                      <xs:element name="OPTION_REF">
                                                        <xs:annotation>
                                                          <xs:documentation>430--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="FEATURE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>430--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="9999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="OPTION_KEY" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>430--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="30" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>400--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:pattern value="[\S ]{1,5}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="BASIC_SHAPE_PARAMETERS">
                                                  <xs:annotation>
                                                    <xs:documentation>500--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--Parameter</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>500--5--Nennwert</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="BASIC_SHAPE_FROM">
                                                            <xs:annotation>
                                                              <xs:documentation>500--6--Von</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="BASIC_SHAPE_TO">
                                                            <xs:annotation>
                                                              <xs:documentation>500--7--Bis</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                            <xs:annotation>
                                                              <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                            <xs:annotation>
                                              <xs:documentation>400--32--Massbild</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:minLength value="1" />
                                                      <xs:maxLength value="240" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="DIMENSIONAL_PARAMETERS">
                                                  <xs:annotation>
                                                    <xs:documentation>500--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>500--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="DIMENSIONAL_FROM">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="DIMENSIONAL_TO">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                            <xs:annotation>
                                                              <xs:documentation>500--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:decimal">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--32--Massbild</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="20" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:choice>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="ITEM_TEXT">
                                    <xs:annotation>
                                      <xs:documentation>410--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="SHORT_TEXT">
                                          <xs:annotation>
                                            <xs:documentation>410--5--Texttype</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="TEXT_LINE" maxOccurs="3">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:sequence>
                                                          <xs:element name="TEXT">
                                                            <xs:annotation>
                                                              <xs:documentation>410--6--Textzeile</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:pattern value="[\S ]{1,30}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:element>
                                                        </xs:sequence>
                                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>410--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger" />
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>410--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:language">
                                                        <xs:pattern value="[A-Za-z]{1,3}" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                        <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>410--5--Texttype</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                        <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>410--5--Texttype</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="TYPE_KEY">
                                    <xs:annotation>
                                      <xs:documentation>445--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:maxInclusive value="2000" />
                                              <xs:minInclusive value="1000" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="TK_CLASS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="TK_INFO" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[0-8]0" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="ECLASS">
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="ECLASS_NO">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:totalDigits value="8" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:maxInclusive value="999999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="DECISION_NO" use="optional">
                                              <xs:annotation>
                                                <xs:documentation>291--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="9999999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="SALES_NUMBER" minOccurs="0">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PART_LIST_REF" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>401--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="PART_LIST_KEY" use="required">
                                        <xs:annotation>
                                          <xs:documentation>--0--NEW</xs:documentation>
                                          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:maxLength value="30" />
                                            <xs:minLength value="1" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:boolean" />
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PROPERTIES" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="PROPERTY_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="VALUE" use="required">
                                              <xs:annotation>
                                                <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="ECO_MOBILIER" minOccurs="0">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[0-9]{11}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>250--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                              <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>250--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                              <xs:element name="WIDTH">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="DEPTH">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="HEIGHT">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="WEIGHT" type="xs:decimal">
                                                <xs:annotation>
                                                  <xs:documentation>400--20--Gewicht</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                              <xs:element name="EAN_NUMBER" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="DECISIONS" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>291--0--NEW</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                      <xs:annotation>
                                                        <xs:documentation>291--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:complexType>
                                                        <xs:attribute name="DECISION_NO" use="required">
                                                          <xs:annotation>
                                                            <xs:documentation>291--0--NEW</xs:documentation>
                                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                          </xs:annotation>
                                                          <xs:simpleType>
                                                            <xs:restriction base="xs:positiveInteger">
                                                              <xs:minInclusive value="1" />
                                                              <xs:maxInclusive value="9999999999" />
                                                            </xs:restriction>
                                                          </xs:simpleType>
                                                        </xs:attribute>
                                                      </xs:complexType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="SEQUENCE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger" />
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:choice>
                            </xs:sequence>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DECISIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DECISION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="COLOR_CONSULTANCIES" minOccurs="0">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="COLOR_CONSULTANCY" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke
                              </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>255--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="DECISION_NO" use="optional">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="COLOR_CONSULTANCY_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
        <xs:documentation>K. Richter 26.02.2015</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIES_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : SERIES_NAME Element
Beschreibung
Dieses Element gibt den Seriennamen an.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence SERIES_NAME Element
Overview
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{1,3}
M [1:3]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Bemerkung

Quelle
<xs:element name="SERIES_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--3--Serienname</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>200--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Za-z]{1,3}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{1,3}
M [1:3]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{1,3}
M [1:3]
Bemerkung

Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>200--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Za-z]{1,3}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT_LINE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element : TEXT_LINE Element
Beschreibung
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Namensraum (none)
Diagramm
FULL_TEXT Element TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Bemerkung

Quelle
<xs:element name="TEXT_LINE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Beschreibung
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Bemerkung

Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FULL_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : FULL_TEXT Element
Beschreibung
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
FULL_TEXT Element
Overview
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="FULL_TEXT" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PURCHASE_RETAIL_ID Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : PURCHASE_RETAIL_ID Element
Beschreibung

Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:

EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto

In Abhängigkeit der Preis-ID (Element PRICE_ID (Pfad 1)) wird der Preis wie folgt definiert:

Preis-ID = 1 (Preis), dann wird der Wert aus dem Element ITEM_PRICE (Pfad 2) verwendet.

Preis-ID = 2 (Identnummer), dann wird der Preis aus dem Element IDENT_NUMBER/PRICE (Pfad 3), dem Element ITEM_PRICE/PRICE_MINIMUM_BASIC (Pfad 2) oder dem Element ADDITIONAL_PRICE (Pfad 5) verwendet.

Preis_ID = 3 (Verrechnungspunkt), dann wird der Wert aus aus den Elementen ITEM_PRICE (Pfad 2) oder PRICE_MINIMUM_BASIC multipliziert mit dem Verrechnungsfaktor aus dem Element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR verwendet.

Aufgrund des Schlüssels kann innerhalb einer Serie nur eine Preisstellung (Kombination der Elemente VAT (Pfad 4) und PURCHASE_RETAIL_ID ) angegeben werden.
Werden in einer Datei sowohl EK- wie auch VK-Preise aufgeführt, so dürfen bei Typen mit EK-Preisen nicht die gleichen Kalkulationsgruppen (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) wie bei Typen mit VK-Preisen vergeben werden.
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION/
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/
Pfad 3: PRICE_DEFINITION/IDENT_NUMBERS
Pfad 4: CATALOG/CATALOG_IDENTIFICATION
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

 D nonNegativeInteger
P
M [0:3]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
PURCHASE_RETAIL_ID Element
Overview
PURCHASE_RETAIL_ID Restriction of xs:nonNegativeInteger

Dieses Element gibt ein Kennzeichen für serienspezifische EK-VK-Preise:

EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto

In Abhängigkeit der Preis-ID (Element PRICE_ID (Pfad 1)) wird der Preis wie folgt definiert:

Preis-ID = 1 (Preis), dann wird der Wert aus dem Element ITEM_PRICE (Pfad 2) verwendet.

Preis-ID = 2 (Identnummer), dann wird der Preis aus dem Element IDENT_NUMBER/PRICE (Pfad 3), dem Element ITEM_PRICE/PRICE_MINIMUM_BASIC (Pfad 2) oder dem Element ADDITIONAL_PRICE (Pfad 5) verwendet.

Preis_ID = 3 (Verrechnungspunkt), dann wird der Wert aus aus den Elementen ITEM_PRICE (Pfad 2) oder PRICE_MINIMUM_BASIC multipliziert mit dem Verrechnungsfaktor aus dem Element PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP/CALCULATION_FACTOR verwendet.

Aufgrund des Schlüssels kann innerhalb einer Serie nur eine Preisstellung (Kombination der Elemente VAT (Pfad 4) und PURCHASE_RETAIL_ID ) angegeben werden.
Werden in einer Datei sowohl EK- wie auch VK-Preise aufgeführt, so dürfen bei Typen mit EK-Preisen nicht die gleichen Kalkulationsgruppen (PRICE_DEFINITION/MERCHANDISE_GROUP/CALC_GROUP) wie bei Typen mit VK-Preisen vergeben werden.
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung! Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.

Elementpfade
Pfad 1: CATALOG/CATALOG_IDENTIFICATION/
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/
Pfad 3: PRICE_DEFINITION/IDENT_NUMBERS
Pfad 4: CATALOG/CATALOG_IDENTIFICATION
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

 D nonNegativeInteger
P
M [0:3]
Bemerkung

Quelle
<xs:element name="PURCHASE_RETAIL_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Version 2.3 Polster
Hermann Balke 01.07.2013
EK_VK_ID
0 = EK-Brutto (oder auch Listenpreis)
1 = VK-Brutto (empfohlener Verkaufspreis)
2 = EK-Netto
3 = EK-Netto/Netto</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : DECISIONS Element
Beschreibung
In diesem Element werden Serien-spezifische Regeln gesammelt.
Namensraum (none)
Diagramm
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional
In diesem Element werden Serien-spezifische Regeln gesammelt.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Serie zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D nonNegativeInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DECISIONS Element : DECISION_REF Element
Beschreibung
Dieses Element referenziert eine der Serie zugeordnete Regel.
Namensraum (none)
Diagramm
DECISION_REF Element
Overview
DECISION_REF 1..∞
Dieses Element referenziert eine der Serie zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D nonNegativeInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DECISION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Regel referenziert. D nonNegativeInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DECISIONS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRODUCT_GROUPS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : PRODUCT_GROUPS Element
Beschreibung
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert.
Namensraum (none)
Diagramm
PRODUCT_GROUP Element Sequence PRODUCT_GROUPS Element
Overview
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert.
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:9999999999]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Zu jedem Artikel werden entweder die Merkmale/Eigenschaften oder eine Referenzierung über ITEM_REF auf eine andere Serie (SERIE_NO) und die dort gültige Artikelnummer (TYPE_NO) gespeichert. Ist das Element ITEM_REF gefüllt, handelt es sich um einen Referenzartikel, der zu einer anderen Serie gehört, im anderen Fall gehört der Artikel zu dieser Serie in der er an dieser Stelle angegeben ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisgruppe. Eine Basispreisgruppe ist eine PRICE_FEATURE_GROUP (Pfad 1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisgruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € entspricht -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 ? = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (Pfad 3/ PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (Pfad 5/ BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (Pfad 5/ PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (Pfad 3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: GLOBAL_DEFINITION
Pfad3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (Pfad 1/ PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit ?1? angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_SINCE dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
DECISIONS optional
In diesem Element werden Artikel-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine dem Artikel zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil;
K = Katalogartikel;
S = Sonderartikel;
M = Mehrausstattungen;
Z = Zusammenstellung
V = Verrechnungsblock
P = Verrechnungsposition.
1 = Planungsvorschlag
2 = Vorzugskombi

Für den Planungsvorschlag (1) gilt folgendes:
Die einzelnen Artikel können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register ?Zubehör?. 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Brutto-Gewicht des Artikels [100 g] angegeben. D.h. inklusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Netto-Gewicht des Artikels [100 g] angegeben. D.h. exlusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³]des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
997 = Artikel für die weder Grundform, noch Echtgrafik mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element MODELING_GRAPHIC_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe angegeben werden. Zusätzlich können über die Elemente SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt.
997 = Artikel für die weder Grundform, noch Echtgrafik, mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefällt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.

Dieses Element muss gefällt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern angegeben werden.
BASIC_SHAPE_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Maßbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Fußform) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Für Tische ist ebenfalls B, H und Tanzugeben, in den Planungssystemen wird für T die Bezeichnung Länge (abhängig vom Typenschlüssel) benutzt.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;
- Kurztext + empfohlener Text;
- Kurztext + empfohlener Text + Langtext;
- Kurztext + Langtext (nur wenn kein empfohlener Text angelegt wurde).

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Werte der Typschlüssel werden in einer Tabelle der Einleitung, Abschnitt Typenschlüssel bereitgestellt.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle "Typschlüssel" der Einleitung eingetragen. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Art der Tabelle "Typschlüssel-Arten"eingetragen. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle " Ausführungsschlüssel"eingetragen. D nonNegativeInteger
P [0-8]0
M [00-80]
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden und es darf nicht gleichzeitig auf eine Prüfung referenziert werden (kein Wert für RESTRICTION_NO) . 		D positiveInteger
P
M [1:9999999999]
SALES_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die Verkaufs-Nummer des Artikels eingetragen werden. D string
P
M [1:30]
PART_LIST_REF optional

Dieses Element referenziert eine im Artikel enthaltene Stückliste.

Der Artikel vererbt dabei seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleiche Variantenarten (FEATURES) tragen.

An den Unterpositionen kann es Regeln geben, die bestimmen, ob eine Unterposition dargestellt wird. Die Angabe der Unterposition erfolgt dann mit der entsprechenden Stückzahl.

Artikel, die nur als Unterposition zulässig sind, werden separat markiert (Element PARTS_LIST_EXCLUSIVE).

Handelt es sich bei dem Artikel um einen Katalogartikel (ITEM_IDENTIFICATION 'K'), können dem Artikel Preise zugeordnet werden. Der Gesamtpreis des Katalogartikels ergibt sich aus dem ihm zugeordneten Preis und den Preisen der Bestandteile der Stückliste.

Für den Planungsvorschlag (ITEM_IDENTIFICATION '1'), gilt folgendes:
Die einzelnen Artikel der Stückliste können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi (ITEM_IDENTIFICATION '2') unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

PART_LIST_KEY required Restriction of xs:string
In diesem Attribut wird der Schlüssel der Stückliste angegeben. D string
P
M [1:30]
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
Dieses Element markiert, ob der Artikel nur als Unterposition einer Stückliste zulässig ist (Wert auf 1(true) gesetzt).
Der Wert 0 (false) hat die gleiche Bedeutung wie ein fehlender Wert. 		D boolean
P
M
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

D string P [0-9]{11} M [11:11]

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

Dieses Element dient der Angabe der Packstücke pro Artikel. Dabei ist keine Packstückoptimierung auf Grund von Kaufvorgängen möglich.

Pro Packstück müssen Breite, Tiefe, Höhe ganzzahlig in mm angegeben werden. Die Angabe des Gewichtes erfolgt dezimal in kg.

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Sequence
PACKAGE_LIST_POS 1..∞
Hier werden die Eigenschaften eines Packstücks der Liste festgehalten.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Element dient der eindeutigen Nummerierung innerhalb der Liste . D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
Dieses Element enthält den Namen der Packstückliste.
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
Hier erfolgt die Beschreibung der Packstückliste.
WIDTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Breite angegeben.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Tiefe angegeben.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Höhe angegeben.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

Mit diesem Element wird das Gewicht angegeben.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

Mit diesem Element wird die EAN-Nummer angegeben.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

Mit diesem Element wird die Material-Nummer angegeben.

 D string
P
M [1:15]
DECISIONS optional

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Dieses Element dient der Referenzierung von Regeln.

DECISIONS optional
In diesem Element werden Produktgruppen-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Produktgruppe zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Bemerkung

Quelle
<xs:element name="PRODUCT_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
                    <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEMS">
              <xs:annotation>
                <xs:documentation>400--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:choice>
                          <xs:sequence>
                            <xs:element name="ITEM_REF">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="TYPE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>401--0--NEW</xs:documentation>
                                    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="30" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="SERIE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>200--1--Satzart</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:sequence>
                            <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                              <xs:annotation>
                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence minOccurs="0">
                                  <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>450/470--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PRICE_FIELD">
                                          <xs:annotation>
                                            <xs:documentation>450--4--Preisfeld</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PRICE">
                                          <xs:annotation>
                                            <xs:documentation>450--5--Preis</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:integer">
                                              <xs:minInclusive value="-99999999" />
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>470--4--Preis</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:integer">
                                              <xs:minInclusive value="-99999999" />
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="VALID_FROM" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                            <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:date" />
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="VALID_UNTIL" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                            <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:date" />
                                          </xs:simpleType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="99999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="PRICE_TYPE_REF">
                              <xs:annotation>
                                <xs:documentation>400/407--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="PRICE_TYPE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>400/407--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PRICE_FEATURE_GROUP_REF">
                                    <xs:annotation>
                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>460--1--Satzart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="PRICE_FIELD">
                                                <xs:annotation>
                                                  <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                              <xs:element name="PRICE">
                                                <xs:annotation>
                                                  <xs:documentation>460--5--Preis</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:integer">
                                                    <xs:minInclusive value="-99999999" />
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="99999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="PRICE_TYPE_REF">
                                    <xs:annotation>
                                      <xs:documentation>407--5--Preisart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>407--5--Preisart</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="DECISIONS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="DECISION_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>291--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>406--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                              </xs:element>
                                              <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="SERIE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>406--0--NEW</xs:documentation>
                                                      <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="TYPE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>406--0--NEW</xs:documentation>
                                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:minLength value="1" />
                                                        <xs:maxLength value="30" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                                    <xs:annotation>
                                                      <xs:documentation>406--7--Anzahl</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="SET_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>1000--0--NEW</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="9" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="SERIE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>406--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="0" />
                                                        <xs:maxInclusive value="999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="TYPE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>406--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:string">
                                                        <xs:minLength value="1" />
                                                        <xs:maxLength value="30" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                  <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                                    <xs:annotation>
                                                      <xs:documentation>406--7--Anzahl</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:nonNegativeInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="SET_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="9" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="EDP_NUMBER" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="EAN_NUMBER" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="ITEM_IDENTIFICATION">
                              <xs:annotation>
                                <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="[BEKSMZVP12]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="CATALOG_PAGE" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="7" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="VALID_FROM" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:date" />
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="VALID_UNTIL" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:date" />
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="WEIGHT_NETTO" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="VOLUME" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--21--Volumen</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="BASIC_PROFILE" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:choice>
                                    <xs:element name="CARCASE_BASIC_SHAPE">
                                      <xs:annotation>
                                        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType mixed="true">
                                              <xs:sequence>
                                                <xs:element name="OPTION_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>430--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="FEATURE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>430--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="9999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="OPTION_KEY" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>430--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="30" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[\S ]{1,5}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="BASIC_SHAPE_PARAMETERS">
                                            <xs:annotation>
                                              <xs:documentation>500--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--Parameter</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>500--5--Nennwert</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="BASIC_SHAPE_FROM">
                                                      <xs:annotation>
                                                        <xs:documentation>500--6--Von</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="BASIC_SHAPE_TO">
                                                      <xs:annotation>
                                                        <xs:documentation>500--7--Bis</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                      <xs:annotation>
                                                        <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                      <xs:annotation>
                                        <xs:documentation>400--32--Massbild</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="240" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="DIMENSIONAL_PARAMETERS">
                                            <xs:annotation>
                                              <xs:documentation>500--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>500--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="DIMENSIONAL_FROM">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="DIMENSIONAL_TO">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                      <xs:annotation>
                                                        <xs:documentation>500--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:decimal">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--32--Massbild</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="20" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="ITEM_TEXT">
                              <xs:annotation>
                                <xs:documentation>410--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="SHORT_TEXT">
                                    <xs:annotation>
                                      <xs:documentation>410--5--Texttype</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="TEXT_LINE" maxOccurs="3">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:sequence>
                                                    <xs:element name="TEXT">
                                                      <xs:annotation>
                                                        <xs:documentation>410--6--Textzeile</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:pattern value="[\S ]{1,30}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:element>
                                                  </xs:sequence>
                                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>410--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger" />
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                              <xs:annotation>
                                                <xs:documentation>410--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:language">
                                                  <xs:pattern value="[A-Za-z]{1,3}" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                  <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>410--5--Texttype</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                  <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>410--5--Texttype</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="TYPE_KEY">
                              <xs:annotation>
                                <xs:documentation>445--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="2000" />
                                        <xs:minInclusive value="1000" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="TK_CLASS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="TK_INFO" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[0-8]0" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="CLASSIFICATIONS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="ECLASS">
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="ECLASS_NO">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:totalDigits value="8" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="DETAIL_INFOS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:maxInclusive value="999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="DECISION_NO" use="optional">
                                        <xs:annotation>
                                          <xs:documentation>291--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="SALES_NUMBER" minOccurs="0">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PART_LIST_REF" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>401--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="PART_LIST_KEY" use="required">
                                  <xs:annotation>
                                    <xs:documentation>--0--NEW</xs:documentation>
                                    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:maxLength value="30" />
                                      <xs:minLength value="1" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:boolean" />
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PROPERTIES" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="PROPERTY_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="VALUE" use="required">
                                        <xs:annotation>
                                          <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="ECO_MOBILIER" minOccurs="0">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="[0-9]{11}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>250--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                        <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>250--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                        <xs:element name="WIDTH">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="DEPTH">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="HEIGHT">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="WEIGHT" type="xs:decimal">
                                          <xs:annotation>
                                            <xs:documentation>400--20--Gewicht</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                        <xs:element name="EAN_NUMBER" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="DECISIONS" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>291--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                                <xs:annotation>
                                                  <xs:documentation>291--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:complexType>
                                                  <xs:attribute name="DECISION_NO" use="required">
                                                    <xs:annotation>
                                                      <xs:documentation>291--0--NEW</xs:documentation>
                                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                    </xs:annotation>
                                                    <xs:simpleType>
                                                      <xs:restriction base="xs:positiveInteger">
                                                        <xs:minInclusive value="1" />
                                                        <xs:maxInclusive value="9999999999" />
                                                      </xs:restriction>
                                                    </xs:simpleType>
                                                  </xs:attribute>
                                                </xs:complexType>
                                              </xs:element>
                                            </xs:sequence>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="SEQUENCE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger" />
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:choice>
                      </xs:sequence>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRODUCT_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element : PRODUCT_GROUP Element
Beschreibung
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Namensraum (none)
Diagramm
DECISIONS Element ITEMS Element FEATURE_CLASS_REF Element LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element Sequence PRODUCT_GROUP Element
Overview
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:9999999999]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Zu jedem Artikel werden entweder die Merkmale/Eigenschaften oder eine Referenzierung über ITEM_REF auf eine andere Serie (SERIE_NO) und die dort gültige Artikelnummer (TYPE_NO) gespeichert. Ist das Element ITEM_REF gefüllt, handelt es sich um einen Referenzartikel, der zu einer anderen Serie gehört, im anderen Fall gehört der Artikel zu dieser Serie in der er an dieser Stelle angegeben ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisgruppe. Eine Basispreisgruppe ist eine PRICE_FEATURE_GROUP (Pfad 1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisgruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € entspricht -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 ? = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (Pfad 3/ PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (Pfad 5/ BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (Pfad 5/ PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (Pfad 3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: GLOBAL_DEFINITION
Pfad3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (Pfad 1/ PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit ?1? angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_SINCE dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden: -900) 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
DECISIONS optional
In diesem Element werden Artikel-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine dem Artikel zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist. Wird in einer Menge von optionalen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
Dieses Element dient der Bezeichnung der Gruppe von optionalen Artikeln.
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln und neun Mengen
zwingender Zusatzartikel definiert werden.
Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt
werden. Aus den Mengen von zwingenden Zusatzartikeln darf je Menge
nur ein Artikel ausgewählt werden.
Wird in einer Menge von zwingenden Zusatzartikeln nur ein Artikel definiert,
wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von zwingenden Zusatzartikeln.

Dieses Element ist inhaltlich nicht notwendig, bleibt aber aus Kompatibilitätsgründen zum IDM 1.7 im IDM 2.0 zunächst erhalten. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil;
K = Katalogartikel;
S = Sonderartikel;
M = Mehrausstattungen;
Z = Zusammenstellung
V = Verrechnungsblock
P = Verrechnungsposition.
1 = Planungsvorschlag
2 = Vorzugskombi

Für den Planungsvorschlag (1) gilt folgendes:
Die einzelnen Artikel können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register ?Zubehör?. 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Brutto-Gewicht des Artikels [100 g] angegeben. D.h. inklusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Netto-Gewicht des Artikels [100 g] angegeben. D.h. exlusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³]des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
997 = Artikel für die weder Grundform, noch Echtgrafik mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element MODELING_GRAPHIC_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe angegeben werden. Zusätzlich können über die Elemente SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt.
997 = Artikel für die weder Grundform, noch Echtgrafik, mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefällt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.

Dieses Element muss gefällt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern angegeben werden.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
BASIC_SHAPE_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Maßbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Fußform) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Für Tische ist ebenfalls B, H und Tanzugeben, in den Planungssystemen wird für T die Bezeichnung Länge (abhängig vom Typenschlüssel) benutzt.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;
- Kurztext + empfohlener Text;
- Kurztext + empfohlener Text + Langtext;
- Kurztext + Langtext (nur wenn kein empfohlener Text angelegt wurde).

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
Sequence
TEXT_LINE 1..3
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Werte der Typschlüssel werden in einer Tabelle der Einleitung, Abschnitt Typenschlüssel bereitgestellt.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle "Typschlüssel" der Einleitung eingetragen. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Art der Tabelle "Typschlüssel-Arten"eingetragen. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle " Ausführungsschlüssel"eingetragen. D nonNegativeInteger
P [0-8]0
M [00-80]
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden und es darf nicht gleichzeitig auf eine Prüfung referenziert werden (kein Wert für RESTRICTION_NO) . 		D positiveInteger
P
M [1:9999999999]
SALES_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die Verkaufs-Nummer des Artikels eingetragen werden. D string
P
M [1:30]
PART_LIST_REF optional

Dieses Element referenziert eine im Artikel enthaltene Stückliste.

Der Artikel vererbt dabei seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleiche Variantenarten (FEATURES) tragen.

An den Unterpositionen kann es Regeln geben, die bestimmen, ob eine Unterposition dargestellt wird. Die Angabe der Unterposition erfolgt dann mit der entsprechenden Stückzahl.

Artikel, die nur als Unterposition zulässig sind, werden separat markiert (Element PARTS_LIST_EXCLUSIVE).

Handelt es sich bei dem Artikel um einen Katalogartikel (ITEM_IDENTIFICATION 'K'), können dem Artikel Preise zugeordnet werden. Der Gesamtpreis des Katalogartikels ergibt sich aus dem ihm zugeordneten Preis und den Preisen der Bestandteile der Stückliste.

Für den Planungsvorschlag (ITEM_IDENTIFICATION '1'), gilt folgendes:
Die einzelnen Artikel der Stückliste können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi (ITEM_IDENTIFICATION '2') unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

PART_LIST_KEY required Restriction of xs:string
In diesem Attribut wird der Schlüssel der Stückliste angegeben. D string
P
M [1:30]
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
Dieses Element markiert, ob der Artikel nur als Unterposition einer Stückliste zulässig ist (Wert auf 1(true) gesetzt).
Der Wert 0 (false) hat die gleiche Bedeutung wie ein fehlender Wert. 		D boolean
P
M
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

D string P [0-9]{11} M [11:11]

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

Dieses Element dient der Angabe der Packstücke pro Artikel. Dabei ist keine Packstückoptimierung auf Grund von Kaufvorgängen möglich.

Pro Packstück müssen Breite, Tiefe, Höhe ganzzahlig in mm angegeben werden. Die Angabe des Gewichtes erfolgt dezimal in kg.

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Sequence
PACKAGE_LIST_POS 1..∞
Hier werden die Eigenschaften eines Packstücks der Liste festgehalten.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Element dient der eindeutigen Nummerierung innerhalb der Liste . D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
Dieses Element enthält den Namen der Packstückliste.
Sequence
LANGUAGE 1..∞
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
Hier erfolgt die Beschreibung der Packstückliste.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
WIDTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Breite angegeben.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Tiefe angegeben.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Höhe angegeben.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

Mit diesem Element wird das Gewicht angegeben.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

Mit diesem Element wird die EAN-Nummer angegeben.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

Mit diesem Element wird die Material-Nummer angegeben.

 D string
P
M [1:15]
DECISIONS optional

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Dieses Element dient der Referenzierung von Regeln.

Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Packstückliste zugeordnete Regel.
DECISIONS optional
In diesem Element werden Produktgruppen-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Produktgruppe zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Bemerkung

Quelle
<xs:element name="PRODUCT_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FEATURE_CLASS_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
              <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEMS">
        <xs:annotation>
          <xs:documentation>400--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:choice>
                    <xs:sequence>
                      <xs:element name="ITEM_REF">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="TYPE_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>401--0--NEW</xs:documentation>
                              <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:minLength value="1" />
                                <xs:maxLength value="30" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                          <xs:attribute name="SERIE_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>200--1--Satzart</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                    <xs:sequence>
                      <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                        <xs:annotation>
                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence minOccurs="0">
                            <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>450/470--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PRICE_FIELD">
                                    <xs:annotation>
                                      <xs:documentation>450--4--Preisfeld</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PRICE">
                                    <xs:annotation>
                                      <xs:documentation>450--5--Preis</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:integer">
                                        <xs:minInclusive value="-99999999" />
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>470--4--Preis</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:integer">
                                        <xs:minInclusive value="-99999999" />
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="VALID_FROM" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                      <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:date" />
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="VALID_UNTIL" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                      <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:date" />
                                    </xs:simpleType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="99999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="PRICE_TYPE_REF">
                        <xs:annotation>
                          <xs:documentation>400/407--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="PRICE_TYPE_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>400/407--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PRICE_FEATURE_GROUP_REF">
                              <xs:annotation>
                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>460--1--Satzart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="PRICE_FIELD">
                                          <xs:annotation>
                                            <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                        <xs:element name="PRICE">
                                          <xs:annotation>
                                            <xs:documentation>460--5--Preis</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:integer">
                                              <xs:minInclusive value="-99999999" />
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="99999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="PRICE_TYPE_REF">
                              <xs:annotation>
                                <xs:documentation>407--5--Preisart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="PRICE_TYPE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>407--5--Preisart</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="DECISIONS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="DECISION_REF" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="DECISION_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>291--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>406--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                        </xs:element>
                                        <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="SERIE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="TYPE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:minLength value="1" />
                                                  <xs:maxLength value="30" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                              <xs:annotation>
                                                <xs:documentation>406--7--Anzahl</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="SET_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>1000--0--NEW</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="SERIE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="0" />
                                                  <xs:maxInclusive value="999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="TYPE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>406--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:string">
                                                  <xs:minLength value="1" />
                                                  <xs:maxLength value="30" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                            <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                              <xs:annotation>
                                                <xs:documentation>406--7--Anzahl</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:nonNegativeInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="SET_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>406--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="EDP_NUMBER" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="EAN_NUMBER" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="ITEM_IDENTIFICATION">
                        <xs:annotation>
                          <xs:documentation>400--14--Artikelkennung</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:pattern value="[BEKSMZVP12]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="CATALOG_PAGE" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="7" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="VALID_FROM" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:date" />
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="VALID_UNTIL" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:date" />
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="WEIGHT_NETTO" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="VOLUME" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--21--Volumen</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="BASIC_PROFILE" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:choice>
                              <xs:element name="CARCASE_BASIC_SHAPE">
                                <xs:annotation>
                                  <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType mixed="true">
                                        <xs:sequence>
                                          <xs:element name="OPTION_REF">
                                            <xs:annotation>
                                              <xs:documentation>430--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>430--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="9999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>430--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[\S ]{1,5}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="BASIC_SHAPE_PARAMETERS">
                                      <xs:annotation>
                                        <xs:documentation>500--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--Parameter</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>500--5--Nennwert</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="BASIC_SHAPE_FROM">
                                                <xs:annotation>
                                                  <xs:documentation>500--6--Von</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="BASIC_SHAPE_TO">
                                                <xs:annotation>
                                                  <xs:documentation>500--7--Bis</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                                <xs:annotation>
                                                  <xs:documentation>500--8--Schrittweite</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                                <xs:annotation>
                                  <xs:documentation>400--32--Massbild</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="240" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="DIMENSIONAL_PARAMETERS">
                                      <xs:annotation>
                                        <xs:documentation>500--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>500--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="DIMENSIONAL_FROM">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="DIMENSIONAL_TO">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                                <xs:annotation>
                                                  <xs:documentation>500--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:decimal">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--32--Massbild</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="20" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="ITEM_TEXT">
                        <xs:annotation>
                          <xs:documentation>410--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="SHORT_TEXT">
                              <xs:annotation>
                                <xs:documentation>410--5--Texttype</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="TEXT_LINE" maxOccurs="3">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:sequence>
                                              <xs:element name="TEXT">
                                                <xs:annotation>
                                                  <xs:documentation>410--6--Textzeile</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:pattern value="[\S ]{1,30}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:element>
                                            </xs:sequence>
                                            <xs:attribute name="SEQUENCE_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>410--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger" />
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                        <xs:annotation>
                                          <xs:documentation>410--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:language">
                                            <xs:pattern value="[A-Za-z]{1,3}" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                            <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>410--5--Texttype</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                            <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>410--5--Texttype</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="TYPE_KEY">
                        <xs:annotation>
                          <xs:documentation>445--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="2000" />
                                  <xs:minInclusive value="1000" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="TK_CLASS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="TK_INFO" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-8]0" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="CLASSIFICATIONS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="ECLASS">
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="ECLASS_NO">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:totalDigits value="8" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="DETAIL_INFOS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="DETAIL_INFO_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:maxInclusive value="999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="DECISION_NO" use="optional">
                                  <xs:annotation>
                                    <xs:documentation>291--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="SALES_NUMBER" minOccurs="0">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PART_LIST_REF" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>401--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="PART_LIST_KEY" use="required">
                            <xs:annotation>
                              <xs:documentation>--0--NEW</xs:documentation>
                              <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:maxLength value="30" />
                                <xs:minLength value="1" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:boolean" />
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PROPERTIES" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="PROPERTY_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="VALUE" use="required">
                                  <xs:annotation>
                                    <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="ECO_MOBILIER" minOccurs="0">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:pattern value="[0-9]{11}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>250--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                  <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>250--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                  <xs:element name="WIDTH">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="DEPTH">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="HEIGHT">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="WEIGHT" type="xs:decimal">
                                    <xs:annotation>
                                      <xs:documentation>400--20--Gewicht</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                  <xs:element name="EAN_NUMBER" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="DECISIONS" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                          <xs:annotation>
                                            <xs:documentation>291--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:complexType>
                                            <xs:attribute name="DECISION_NO" use="required">
                                              <xs:annotation>
                                                <xs:documentation>291--0--NEW</xs:documentation>
                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                              </xs:annotation>
                                              <xs:simpleType>
                                                <xs:restriction base="xs:positiveInteger">
                                                  <xs:minInclusive value="1" />
                                                  <xs:maxInclusive value="9999999999" />
                                                </xs:restriction>
                                              </xs:simpleType>
                                            </xs:attribute>
                                          </xs:complexType>
                                        </xs:element>
                                      </xs:sequence>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="SEQUENCE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger" />
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:choice>
                </xs:sequence>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRODUCT_GROUP_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : PRODUCT_GROUP_TEXT Element
Beschreibung
Dieses Element enthält die Bezeichung einer Produktgruppe.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element
Overview
PRODUCT_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="PRODUCT_GROUP_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > languagetext60 Complex Type : LANGUAGE Element
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
languagetext60 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > languagetext60 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetext60 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_CLASS_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : FEATURE_CLASS_REF Element
Beschreibung
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
Namensraum (none)
Diagramm
FEATURE_CLASS_REF Element
Overview
FEATURE_CLASS_REF optional
Mit diesem Element wird der Produktgruppe eine Variantenfamilie zugeordnet. Es wird eine Variantenfamilie referenziert, die im Element FEATURE_DEFINITION/FEATURE_CLASSES definiert ist.
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird die referenzierte Variantenfamilie (FEATURE_CLASS) identifiziert. D positiveInteger
P
M [1:9999999999]
Bemerkung

Quelle
<xs:element name="FEATURE_CLASS_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 1</xs:documentation>
        <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEMS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : ITEMS Element
Beschreibung
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Namensraum (none)
Diagramm
ITEM Element Sequence ITEMS Element
Overview
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Zu jedem Artikel werden entweder die Merkmale/Eigenschaften oder eine Referenzierung über ITEM_REF auf eine andere Serie (SERIE_NO) und die dort gültige Artikelnummer (TYPE_NO) gespeichert. Ist das Element ITEM_REF gefüllt, handelt es sich um einen Referenzartikel, der zu einer anderen Serie gehört, im anderen Fall gehört der Artikel zu dieser Serie in der er an dieser Stelle angegeben ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisgruppe. Eine Basispreisgruppe ist eine PRICE_FEATURE_GROUP (Pfad 1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisgruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € entspricht -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 ? = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (Pfad 3/ PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (Pfad 5/ BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (Pfad 5/ PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (Pfad 3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: GLOBAL_DEFINITION
Pfad3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (Pfad 1/ PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit ?1? angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_SINCE dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden: -900) 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
DECISIONS optional
In diesem Element werden Artikel-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine dem Artikel zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist. Wird in einer Menge von optionalen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
Dieses Element dient der Bezeichnung der Gruppe von optionalen Artikeln.
Sequence
LANGUAGE 1..∞
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar, für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln und neun Mengen
zwingender Zusatzartikel definiert werden.
Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt
werden. Aus den Mengen von zwingenden Zusatzartikeln darf je Menge
nur ein Artikel ausgewählt werden.
Wird in einer Menge von zwingenden Zusatzartikeln nur ein Artikel definiert,
wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von zwingenden Zusatzartikeln.

Dieses Element ist inhaltlich nicht notwendig, bleibt aber aus Kompatibilitätsgründen zum IDM 1.7 im IDM 2.0 zunächst erhalten. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. D nonNegativeInteger
P
M [1:999]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil;
K = Katalogartikel;
S = Sonderartikel;
M = Mehrausstattungen;
Z = Zusammenstellung
V = Verrechnungsblock
P = Verrechnungsposition.
1 = Planungsvorschlag
2 = Vorzugskombi

Für den Planungsvorschlag (1) gilt folgendes:
Die einzelnen Artikel können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register ?Zubehör?. 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Brutto-Gewicht des Artikels [100 g] angegeben. D.h. inklusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Netto-Gewicht des Artikels [100 g] angegeben. D.h. exlusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³]des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
997 = Artikel für die weder Grundform, noch Echtgrafik mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element MODELING_GRAPHIC_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe angegeben werden. Zusätzlich können über die Elemente SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt.
997 = Artikel für die weder Grundform, noch Echtgrafik, mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefällt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.

Dieses Element muss gefällt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern angegeben werden.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:30]
BASIC_SHAPE_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Maßbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Fußform) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (von, bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefällt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Für Tische ist ebenfalls B, H und Tanzugeben, in den Planungssystemen wird für T die Bezeichnung Länge (abhängig vom Typenschlüssel) benutzt.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maßund muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;
- Kurztext + empfohlener Text;
- Kurztext + empfohlener Text + Langtext;
- Kurztext + Langtext (nur wenn kein empfohlener Text angelegt wurde).

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
Sequence
TEXT_LINE 1..3
SEQUENCE_NO required Restriction of xs:positiveInteger
Sequence
TEXT Restriction of xs:string
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Werte der Typschlüssel werden in einer Tabelle der Einleitung, Abschnitt Typenschlüssel bereitgestellt.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle "Typschlüssel" der Einleitung eingetragen. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Art der Tabelle "Typschlüssel-Arten"eingetragen. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle " Ausführungsschlüssel"eingetragen. D nonNegativeInteger
P [0-8]0
M [00-80]
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden und es darf nicht gleichzeitig auf eine Prüfung referenziert werden (kein Wert für RESTRICTION_NO) . 		D positiveInteger
P
M [1:9999999999]
SALES_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die Verkaufs-Nummer des Artikels eingetragen werden. D string
P
M [1:30]
PART_LIST_REF optional

Dieses Element referenziert eine im Artikel enthaltene Stückliste.

Der Artikel vererbt dabei seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleiche Variantenarten (FEATURES) tragen.

An den Unterpositionen kann es Regeln geben, die bestimmen, ob eine Unterposition dargestellt wird. Die Angabe der Unterposition erfolgt dann mit der entsprechenden Stückzahl.

Artikel, die nur als Unterposition zulässig sind, werden separat markiert (Element PARTS_LIST_EXCLUSIVE).

Handelt es sich bei dem Artikel um einen Katalogartikel (ITEM_IDENTIFICATION 'K'), können dem Artikel Preise zugeordnet werden. Der Gesamtpreis des Katalogartikels ergibt sich aus dem ihm zugeordneten Preis und den Preisen der Bestandteile der Stückliste.

Für den Planungsvorschlag (ITEM_IDENTIFICATION '1'), gilt folgendes:
Die einzelnen Artikel der Stückliste können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi (ITEM_IDENTIFICATION '2') unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

PART_LIST_KEY required Restriction of xs:string
In diesem Attribut wird der Schlüssel der Stückliste angegeben. D string
P
M [1:30]
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
Dieses Element markiert, ob der Artikel nur als Unterposition einer Stückliste zulässig ist (Wert auf 1(true) gesetzt).
Der Wert 0 (false) hat die gleiche Bedeutung wie ein fehlender Wert. 		D boolean
P
M
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

D string P [0-9]{11} M [11:11]

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

Dieses Element dient der Angabe der Packstücke pro Artikel. Dabei ist keine Packstückoptimierung auf Grund von Kaufvorgängen möglich.

Pro Packstück müssen Breite, Tiefe, Höhe ganzzahlig in mm angegeben werden. Die Angabe des Gewichtes erfolgt dezimal in kg.

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Sequence
PACKAGE_LIST_POS 1..∞
Hier werden die Eigenschaften eines Packstücks der Liste festgehalten.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Element dient der eindeutigen Nummerierung innerhalb der Liste . D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
Dieses Element enthält den Namen der Packstückliste.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
Hier erfolgt die Beschreibung der Packstückliste.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
WIDTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Breite angegeben.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Tiefe angegeben.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Höhe angegeben.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

Mit diesem Element wird das Gewicht angegeben.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

Mit diesem Element wird die EAN-Nummer angegeben.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

Mit diesem Element wird die Material-Nummer angegeben.

 D string
P
M [1:15]
DECISIONS optional

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Dieses Element dient der Referenzierung von Regeln.

Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Packstückliste zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Bemerkung

Quelle
<xs:element name="ITEMS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:choice>
              <xs:sequence>
                <xs:element name="ITEM_REF">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="TYPE_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>401--0--NEW</xs:documentation>
                        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:minLength value="1" />
                          <xs:maxLength value="30" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                    <xs:attribute name="SERIE_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>200--1--Satzart</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
              <xs:sequence>
                <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                  <xs:annotation>
                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence minOccurs="0">
                      <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>450/470--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PRICE_FIELD">
                              <xs:annotation>
                                <xs:documentation>450--4--Preisfeld</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PRICE">
                              <xs:annotation>
                                <xs:documentation>450--5--Preis</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:integer">
                                  <xs:minInclusive value="-99999999" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>470--4--Preis</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:integer">
                                  <xs:minInclusive value="-99999999" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="VALID_FROM" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:date" />
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="VALID_UNTIL" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:date" />
                              </xs:simpleType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="99999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
                <xs:element name="PRICE_TYPE_REF">
                  <xs:annotation>
                    <xs:documentation>400/407--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="PRICE_TYPE_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>400/407--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
                <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="PRICE_FEATURE_GROUP_REF">
                        <xs:annotation>
                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>460--1--Satzart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="PRICE_FIELD">
                                    <xs:annotation>
                                      <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                  <xs:element name="PRICE">
                                    <xs:annotation>
                                      <xs:documentation>460--5--Preis</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:integer">
                                        <xs:minInclusive value="-99999999" />
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="99999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="PRICE_TYPE_REF">
                        <xs:annotation>
                          <xs:documentation>407--5--Preisart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="PRICE_TYPE_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>407--5--Preisart</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="DECISIONS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="DECISION_REF" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="DECISION_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>291--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9999999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>406--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                  </xs:element>
                                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="SERIE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>406--0--NEW</xs:documentation>
                                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="TYPE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>406--0--NEW</xs:documentation>
                                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:minLength value="1" />
                                            <xs:maxLength value="30" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                        <xs:annotation>
                                          <xs:documentation>406--7--Anzahl</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="SET_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="SERIE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>406--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="TYPE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>406--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:string">
                                            <xs:minLength value="1" />
                                            <xs:maxLength value="30" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                      <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                        <xs:annotation>
                                          <xs:documentation>406--7--Anzahl</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="SET_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>406--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="EDP_NUMBER" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="EAN_NUMBER" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="ITEM_IDENTIFICATION">
                  <xs:annotation>
                    <xs:documentation>400--14--Artikelkennung</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[BEKSMZVP12]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="CATALOG_PAGE" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="7" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="VALID_FROM" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:date" />
                  </xs:simpleType>
                </xs:element>
                <xs:element name="VALID_UNTIL" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:date" />
                  </xs:simpleType>
                </xs:element>
                <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--20--Gewicht</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="WEIGHT_NETTO" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--20--Gewicht</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="VOLUME" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--21--Volumen</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="BASIC_PROFILE" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:choice>
                        <xs:element name="CARCASE_BASIC_SHAPE">
                          <xs:annotation>
                            <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType mixed="true">
                                  <xs:sequence>
                                    <xs:element name="OPTION_REF">
                                      <xs:annotation>
                                        <xs:documentation>430--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>430--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>430--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[\S ]{1,5}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="BASIC_SHAPE_PARAMETERS">
                                <xs:annotation>
                                  <xs:documentation>500--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                          <xs:annotation>
                                            <xs:documentation>500--0--Parameter</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>500--5--Nennwert</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="BASIC_SHAPE_FROM">
                                          <xs:annotation>
                                            <xs:documentation>500--6--Von</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="BASIC_SHAPE_TO">
                                          <xs:annotation>
                                            <xs:documentation>500--7--Bis</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                          <xs:annotation>
                                            <xs:documentation>500--8--Schrittweite</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                          <xs:annotation>
                            <xs:documentation>400--32--Massbild</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="240" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="DIMENSIONAL_PARAMETERS">
                                <xs:annotation>
                                  <xs:documentation>500--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>500--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                          <xs:annotation>
                                            <xs:documentation>500--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>500--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="DIMENSIONAL_FROM">
                                          <xs:annotation>
                                            <xs:documentation>500--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="DIMENSIONAL_TO">
                                          <xs:annotation>
                                            <xs:documentation>500--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                          <xs:annotation>
                                            <xs:documentation>500--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:decimal">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--32--Massbild</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="20" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="ITEM_TEXT">
                  <xs:annotation>
                    <xs:documentation>410--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="SHORT_TEXT">
                        <xs:annotation>
                          <xs:documentation>410--5--Texttype</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="LANGUAGE" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="TEXT_LINE" maxOccurs="3">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:sequence>
                                        <xs:element name="TEXT">
                                          <xs:annotation>
                                            <xs:documentation>410--6--Textzeile</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:pattern value="[\S ]{1,30}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:element>
                                      </xs:sequence>
                                      <xs:attribute name="SEQUENCE_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>410--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger" />
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                  <xs:annotation>
                                    <xs:documentation>410--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:language">
                                      <xs:pattern value="[A-Za-z]{1,3}" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                      <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>410--5--Texttype</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>410--5--Texttype</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="TYPE_KEY">
                  <xs:annotation>
                    <xs:documentation>445--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="2000" />
                            <xs:minInclusive value="1000" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="TK_CLASS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="TK_INFO" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-8]0" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="CLASSIFICATIONS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="ECLASS">
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="ECLASS_NO">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:totalDigits value="8" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="DETAIL_INFOS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="DETAIL_INFO_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:maxInclusive value="999999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                          <xs:attribute name="DECISION_NO" use="optional">
                            <xs:annotation>
                              <xs:documentation>291--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9999999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="SALES_NUMBER" minOccurs="0">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="PART_LIST_REF" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>401--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="PART_LIST_KEY" use="required">
                      <xs:annotation>
                        <xs:documentation>--0--NEW</xs:documentation>
                        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:maxLength value="30" />
                          <xs:minLength value="1" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
                <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:boolean" />
                  </xs:simpleType>
                </xs:element>
                <xs:element name="PROPERTIES" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:attribute name="PROPERTY_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                          <xs:attribute name="VALUE" use="required">
                            <xs:annotation>
                              <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="ECO_MOBILIER" minOccurs="0">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9]{11}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>250--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                            <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>250--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                            <xs:element name="WIDTH">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="DEPTH">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="HEIGHT">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="WEIGHT" type="xs:decimal">
                              <xs:annotation>
                                <xs:documentation>400--20--Gewicht</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                            <xs:element name="EAN_NUMBER" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="DECISIONS" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:complexType>
                                      <xs:attribute name="DECISION_NO" use="required">
                                        <xs:annotation>
                                          <xs:documentation>291--0--NEW</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:positiveInteger">
                                            <xs:minInclusive value="1" />
                                            <xs:maxInclusive value="9999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:attribute>
                                    </xs:complexType>
                                  </xs:element>
                                </xs:sequence>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="SEQUENCE_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger" />
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:choice>
          </xs:sequence>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element : ITEM Element
Beschreibung
In diesem Element werden Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Zu jedem Artikel werden entweder die Merkmale/Eigenschaften oder eine Referenzierung über ITEM_REF auf eine andere Serie (SERIE_NO) und die dort gültige Artikelnummer (TYPE_NO) gespeichert. Ist das Element ITEM_REF gefüllt, handelt es sich um einen Referenzartikel, der zu einer anderen Serie gehört, im anderen Fall gehört der Artikel zu dieser Serie in der er an dieser Stelle angegeben ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
Namensraum (none)
Diagramm
PACKAGE_LIST Element ECO_MOBILIER Element PROPERTIES Element PART_LIST_EXCLUSIVE Element PART_LIST_REF Element SALES_NUMBER Element DETAIL_INFOS Element CLASSIFICATIONS Element TYPE_KEY Element ITEM_TEXT Element BASIC_PROFILE Element MINIMUM_DELIVERY_TIME Element VOLUME Element WEIGHT_NETTO Element WEIGHT_BRUTTO Element VALID_UNTIL Element VALID_FROM Element CATALOG_PAGE Element ITEM_IDENTIFICATION Element EAN_NUMBER Element EDP_NUMBER Element ADDITIONAL_ITEMS Element DECISIONS Element ADDITIONAL_PRICE_GROUP Element PRICE_TYPE_REF Element PRICE_FEATURE_GROUP_BASE_PRICE_REF Element Sequence ITEM_REF Element Sequence Choice Sequence ITEM Element
Overview
ITEM 1..∞
In diesem Element werden Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1).

Zu jedem Artikel werden entweder die Merkmale/Eigenschaften oder eine Referenzierung über ITEM_REF auf eine andere Serie (SERIE_NO) und die dort gültige Artikelnummer (TYPE_NO) gespeichert. Ist das Element ITEM_REF gefüllt, handelt es sich um einen Referenzartikel, der zu einer anderen Serie gehört, im anderen Fall gehört der Artikel zu dieser Serie in der er an dieser Stelle angegeben ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: PRICE_DEFINITION/PRICE_TABLES/PRICE_TABLE
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
Choice
Sequence
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisgruppe. Eine Basispreisgruppe ist eine PRICE_FEATURE_GROUP (Pfad 1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisgruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € entspricht -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 ? = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (Pfad 3/ PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (Pfad 5/ BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (Pfad 5/ PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (Pfad 3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: GLOBAL_DEFINITION
Pfad3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (Pfad 1/ PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit ?1? angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_SINCE dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden: -900) 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
DECISIONS optional
In diesem Element werden Artikel-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine dem Artikel zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist. Wird in einer Menge von optionalen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
Dieses Element dient der Bezeichnung der Gruppe von optionalen Artikeln.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar, für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln und neun Mengen
zwingender Zusatzartikel definiert werden.
Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt
werden. Aus den Mengen von zwingenden Zusatzartikeln darf je Menge
nur ein Artikel ausgewählt werden.
Wird in einer Menge von zwingenden Zusatzartikeln nur ein Artikel definiert,
wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von zwingenden Zusatzartikeln.

Dieses Element ist inhaltlich nicht notwendig, bleibt aber aus Kompatibilitätsgründen zum IDM 1.7 im IDM 2.0 zunächst erhalten. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. D nonNegativeInteger
P
M [1:999]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:30]
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil;
K = Katalogartikel;
S = Sonderartikel;
M = Mehrausstattungen;
Z = Zusammenstellung
V = Verrechnungsblock
P = Verrechnungsposition.
1 = Planungsvorschlag
2 = Vorzugskombi

Für den Planungsvorschlag (1) gilt folgendes:
Die einzelnen Artikel können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

D string
P [BEKSMZVP12]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register ?Zubehör?. 		D string
P
M [1:7]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Brutto-Gewicht des Artikels [100 g] angegeben. D.h. inklusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Netto-Gewicht des Artikels [100 g] angegeben. D.h. exlusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³]des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung) 		D nonNegativeInteger
P
M [0:999]
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
997 = Artikel für die weder Grundform, noch Echtgrafik mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element MODELING_GRAPHIC_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe angegeben werden. Zusätzlich können über die Elemente SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt.
997 = Artikel für die weder Grundform, noch Echtgrafik, mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefällt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.

Dieses Element muss gefällt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern angegeben werden.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:30]
BASIC_SHAPE_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Maßbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Fußform) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (von, bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefällt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Für Tische ist ebenfalls B, H und Tanzugeben, in den Planungssystemen wird für T die Bezeichnung Länge (abhängig vom Typenschlüssel) benutzt.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maßund muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;
- Kurztext + empfohlener Text;
- Kurztext + empfohlener Text + Langtext;
- Kurztext + Langtext (nur wenn kein empfohlener Text angelegt wurde).

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
Sequence
TEXT_LINE 1..3
SEQUENCE_NO required Restriction of xs:positiveInteger
Sequence
TEXT Restriction of xs:string
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Werte der Typschlüssel werden in einer Tabelle der Einleitung, Abschnitt Typenschlüssel bereitgestellt.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle "Typschlüssel" der Einleitung eingetragen. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Art der Tabelle "Typschlüssel-Arten"eingetragen. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle " Ausführungsschlüssel"eingetragen. D nonNegativeInteger
P [0-8]0
M [00-80]
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden und es darf nicht gleichzeitig auf eine Prüfung referenziert werden (kein Wert für RESTRICTION_NO) . 		D positiveInteger
P
M [1:9999999999]
SALES_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die Verkaufs-Nummer des Artikels eingetragen werden. D string
P
M [1:30]
PART_LIST_REF optional

Dieses Element referenziert eine im Artikel enthaltene Stückliste.

Der Artikel vererbt dabei seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleiche Variantenarten (FEATURES) tragen.

An den Unterpositionen kann es Regeln geben, die bestimmen, ob eine Unterposition dargestellt wird. Die Angabe der Unterposition erfolgt dann mit der entsprechenden Stückzahl.

Artikel, die nur als Unterposition zulässig sind, werden separat markiert (Element PARTS_LIST_EXCLUSIVE).

Handelt es sich bei dem Artikel um einen Katalogartikel (ITEM_IDENTIFICATION 'K'), können dem Artikel Preise zugeordnet werden. Der Gesamtpreis des Katalogartikels ergibt sich aus dem ihm zugeordneten Preis und den Preisen der Bestandteile der Stückliste.

Für den Planungsvorschlag (ITEM_IDENTIFICATION '1'), gilt folgendes:
Die einzelnen Artikel der Stückliste können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi (ITEM_IDENTIFICATION '2') unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

PART_LIST_KEY required Restriction of xs:string
In diesem Attribut wird der Schlüssel der Stückliste angegeben. D string
P
M [1:30]
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
Dieses Element markiert, ob der Artikel nur als Unterposition einer Stückliste zulässig ist (Wert auf 1(true) gesetzt).
Der Wert 0 (false) hat die gleiche Bedeutung wie ein fehlender Wert. 		D boolean
P
M
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

D string P [0-9]{11} M [11:11]

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

PACKAGE_LIST optional

Dieses Element dient der Angabe der Packstücke pro Artikel. Dabei ist keine Packstückoptimierung auf Grund von Kaufvorgängen möglich.

Pro Packstück müssen Breite, Tiefe, Höhe ganzzahlig in mm angegeben werden. Die Angabe des Gewichtes erfolgt dezimal in kg.

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Sequence
PACKAGE_LIST_POS 1..∞
Hier werden die Eigenschaften eines Packstücks der Liste festgehalten.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Element dient der eindeutigen Nummerierung innerhalb der Liste . D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
Dieses Element enthält den Namen der Packstückliste.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
Hier erfolgt die Beschreibung der Packstückliste.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
WIDTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Breite angegeben.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Tiefe angegeben.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Höhe angegeben.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

Mit diesem Element wird das Gewicht angegeben.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

Mit diesem Element wird die EAN-Nummer angegeben.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

Mit diesem Element wird die Material-Nummer angegeben.

 D string
P
M [1:15]
DECISIONS optional

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Dieses Element dient der Referenzierung von Regeln.

Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Packstückliste zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:positiveInteger optional

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Bemerkung

Quelle
<xs:element name="ITEM" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice>
        <xs:sequence>
          <xs:element name="ITEM_REF">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:attribute name="TYPE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>401--0--NEW</xs:documentation>
                  <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="30" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:attribute>
              <xs:attribute name="SERIE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>200--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
        <xs:sequence>
          <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
            <xs:annotation>
              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence minOccurs="0">
                <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>450/470--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="PRICE_FIELD">
                        <xs:annotation>
                          <xs:documentation>450--4--Preisfeld</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PRICE">
                        <xs:annotation>
                          <xs:documentation>450--5--Preis</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:integer">
                            <xs:minInclusive value="-99999999" />
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>470--4--Preis</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:integer">
                            <xs:minInclusive value="-99999999" />
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="VALID_FROM" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:date" />
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="VALID_UNTIL" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:date" />
                        </xs:simpleType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
              <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                <xs:annotation>
                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="99999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
          <xs:element name="PRICE_TYPE_REF">
            <xs:annotation>
              <xs:documentation>400/407--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:attribute name="PRICE_TYPE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>400/407--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
          <xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="PRICE_FEATURE_GROUP_REF">
                  <xs:annotation>
                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>460--1--Satzart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="PRICE_FIELD">
                              <xs:annotation>
                                <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                            <xs:element name="PRICE">
                              <xs:annotation>
                                <xs:documentation>460--5--Preis</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:integer">
                                  <xs:minInclusive value="-99999999" />
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="99999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
                <xs:element name="PRICE_TYPE_REF">
                  <xs:annotation>
                    <xs:documentation>407--5--Preisart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="PRICE_TYPE_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>407--5--Preisart</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="DECISIONS" minOccurs="0">
            <xs:annotation>
              <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="DECISION_REF" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="DECISION_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>291--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="9999999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="ADDITIONAL_ITEMS" minOccurs="0">
            <xs:annotation>
              <xs:documentation>406--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                            </xs:element>
                            <xs:element name="ITEM_REF" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="SERIE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>406--0--NEW</xs:documentation>
                                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="TYPE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>406--0--NEW</xs:documentation>
                                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="30" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                                  <xs:annotation>
                                    <xs:documentation>406--7--Anzahl</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="SET_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                          <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="MANDATORY_ITEMS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="ITEM_REF" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="SERIE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>406--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="TYPE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>406--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:string">
                                      <xs:minLength value="1" />
                                      <xs:maxLength value="30" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                                <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                                  <xs:annotation>
                                    <xs:documentation>406--7--Anzahl</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="SET_NO" use="required">
                            <xs:annotation>
                              <xs:documentation>406--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="EDP_NUMBER" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--10--EDV_Nummer</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="EAN_NUMBER" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--11--EAN_Nummer</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="ITEM_IDENTIFICATION">
            <xs:annotation>
              <xs:documentation>400--14--Artikelkennung</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[BEKSMZVP12]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="CATALOG_PAGE" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--15--Katalog_Seite</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="7" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="VALID_FROM" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:date" />
            </xs:simpleType>
          </xs:element>
          <xs:element name="VALID_UNTIL" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:date" />
            </xs:simpleType>
          </xs:element>
          <xs:element name="WEIGHT_BRUTTO" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--20--Gewicht</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="WEIGHT_NETTO" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--20--Gewicht</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="VOLUME" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--21--Volumen</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="BASIC_PROFILE" minOccurs="0">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:choice>
                  <xs:element name="CARCASE_BASIC_SHAPE">
                    <xs:annotation>
                      <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType mixed="true">
                            <xs:sequence>
                              <xs:element name="OPTION_REF">
                                <xs:annotation>
                                  <xs:documentation>430--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>430--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>430--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:pattern value="[\S ]{1,5}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="BASIC_SHAPE_PARAMETERS">
                          <xs:annotation>
                            <xs:documentation>500--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                                    <xs:annotation>
                                      <xs:documentation>500--0--Parameter</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>500--5--Nennwert</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="BASIC_SHAPE_FROM">
                                    <xs:annotation>
                                      <xs:documentation>500--6--Von</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="BASIC_SHAPE_TO">
                                    <xs:annotation>
                                      <xs:documentation>500--7--Bis</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                                    <xs:annotation>
                                      <xs:documentation>500--8--Schrittweite</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_DIMENSIONAL_DRAWING">
                    <xs:annotation>
                      <xs:documentation>400--32--Massbild</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="240" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DIMENSIONAL_PARAMETERS">
                          <xs:annotation>
                            <xs:documentation>500--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>500--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DIMENSIONAL_NAME" use="required">
                                    <xs:annotation>
                                      <xs:documentation>500--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>500--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DIMENSIONAL_FROM">
                                    <xs:annotation>
                                      <xs:documentation>500--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DIMENSIONAL_TO">
                                    <xs:annotation>
                                      <xs:documentation>500--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                                    <xs:annotation>
                                      <xs:documentation>500--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:decimal">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--32--Massbild</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="20" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="ITEM_TEXT">
            <xs:annotation>
              <xs:documentation>410--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="SHORT_TEXT">
                  <xs:annotation>
                    <xs:documentation>410--5--Texttype</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="LANGUAGE" maxOccurs="unbounded">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="TEXT_LINE" maxOccurs="3">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:sequence>
                                  <xs:element name="TEXT">
                                    <xs:annotation>
                                      <xs:documentation>410--6--Textzeile</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:pattern value="[\S ]{1,30}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:element>
                                </xs:sequence>
                                <xs:attribute name="SEQUENCE_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>410--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger" />
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                            <xs:annotation>
                              <xs:documentation>410--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:language">
                                <xs:pattern value="[A-Za-z]{1,3}" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:attribute>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
                <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>410--5--Texttype</xs:documentation>
                  </xs:annotation>
                </xs:element>
                <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation>410--5--Texttype</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="TYPE_KEY">
            <xs:annotation>
              <xs:documentation>445--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="2000" />
                      <xs:minInclusive value="1000" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="TK_CLASS" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
                <xs:element name="TK_INFO" minOccurs="0">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-8]0" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="CLASSIFICATIONS" minOccurs="0">
            <xs:annotation>
              <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="ECLASS">
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="ECLASS_NO">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:totalDigits value="8" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                    </xs:sequence>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="DETAIL_INFOS" minOccurs="0">
            <xs:annotation>
              <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="DETAIL_INFO_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:maxInclusive value="999999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                    <xs:attribute name="DECISION_NO" use="optional">
                      <xs:annotation>
                        <xs:documentation>291--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="9999999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="SALES_NUMBER" minOccurs="0">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="PART_LIST_REF" minOccurs="0">
            <xs:annotation>
              <xs:documentation>401--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:attribute name="PART_LIST_KEY" use="required">
                <xs:annotation>
                  <xs:documentation>--0--NEW</xs:documentation>
                  <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:maxLength value="30" />
                    <xs:minLength value="1" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
          <xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0">
            <xs:annotation>
              <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:boolean" />
            </xs:simpleType>
          </xs:element>
          <xs:element name="PROPERTIES" minOccurs="0">
            <xs:annotation>
              <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:attribute name="PROPERTY_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                    <xs:attribute name="VALUE" use="required">
                      <xs:annotation>
                        <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
          <xs:element name="ECO_MOBILIER" minOccurs="0">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9]{11}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
          <xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1">
            <xs:annotation>
              <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                  </xs:annotation>
                  <xs:complexType>
                    <xs:sequence>
                      <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="WIDTH">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="DEPTH">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="HEIGHT">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="WEIGHT" type="xs:decimal">
                        <xs:annotation>
                          <xs:documentation>400--20--Gewicht</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
                        </xs:annotation>
                      </xs:element>
                      <xs:element name="EAN_NUMBER" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="MATERIAL_NUMBER" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:element>
                      <xs:element name="DECISIONS" minOccurs="0">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:complexType>
                          <xs:sequence>
                            <xs:element name="DECISION_REF" maxOccurs="unbounded">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:complexType>
                                <xs:attribute name="DECISION_NO" use="required">
                                  <xs:annotation>
                                    <xs:documentation>291--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:positiveInteger">
                                      <xs:minInclusive value="1" />
                                      <xs:maxInclusive value="9999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:attribute>
                              </xs:complexType>
                            </xs:element>
                          </xs:sequence>
                        </xs:complexType>
                      </xs:element>
                    </xs:sequence>
                    <xs:attribute name="SEQUENCE_NO" use="required">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger" />
                      </xs:simpleType>
                    </xs:attribute>
                  </xs:complexType>
                </xs:element>
              </xs:sequence>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
      </xs:choice>
    </xs:sequence>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_REF Element
Beschreibung
Dieses Element dient der Referenzierung eines Artikels.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO Restriction of xs:nonNegativeInteger required
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Beschreibung
Dieses Element referenziert eine Basispreisgruppe. Eine Basispreisgruppe ist eine PRICE_FEATURE_GROUP (Pfad 1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisgruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
Namensraum (none)
Diagramm
ITEM_PRICE Element Sequence PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Overview
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisgruppe. Eine Basispreisgruppe ist eine PRICE_FEATURE_GROUP (Pfad 1), in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Einem Artikel muss genau eine Basispreisgruppe zugeordnet werden. Weitere Preisgruppen werden über das Element ADDITIONAL_PRICE_GROUP zugeordnet.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € entspricht -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 ? = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (Pfad 3/ PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (Pfad 5/ BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (Pfad 5/ PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (Pfad 3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: GLOBAL_DEFINITION
Pfad3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (Pfad 1/ PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit ?1? angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_SINCE dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Quelle
<xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence minOccurs="0">
      <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>450/470--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>450--4--Preisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>450--5--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
              <xs:annotation>
                <xs:documentation>470--4--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_PRICE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element : ITEM_PRICE Element
Beschreibung
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Namensraum (none)
Diagramm
VALID_UNTIL Element VALID_FROM Element BASIC_PRICE_UNIT Element PRICE_MINIMUM_BASIC Element PRICE Element PRICE_FIELD Element Sequence ITEM_PRICE Element
Overview
ITEM_PRICE 0..∞
In diesem Element wird der Artikelpreis und weitere Preisdaten hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € entspricht -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 ? = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (Pfad 3/ PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (Pfad 5/ BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (Pfad 5/ PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (Pfad 3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: GLOBAL_DEFINITION
Pfad3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (Pfad 1/ PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit ?1? angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_SINCE dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450/470--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>450--4--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>450--5--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0">
        <xs:annotation>
          <xs:documentation>470--4--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_PRICE_UNIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FIELD Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_FIELD Element
Beschreibung
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
Quelle
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--4--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE Element
Beschreibung
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € entspricht -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
Namensraum (none)
Typ
Restriction of xs:integer
Diagramm
PRICE Element
Overview
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € entspricht -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in der PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Elemente für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
Quelle
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--5--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_MINIMUM_BASIC Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_MINIMUM_BASIC Element
Beschreibung
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 ? = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (Pfad 3/ PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (Pfad 5/ BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (Pfad 5/ PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (Pfad 3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: GLOBAL_DEFINITION
Pfad3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
Namensraum (none)
Typ
Restriction of xs:integer
Diagramm
PRICE_MINIMUM_BASIC Element
Overview
PRICE_MINIMUM_BASIC optional Restriction of xs:integer
In diesem Element werden Mindestpreise oder Grundpreise eingetragen. Die Preise werden entsprechend ihrer Preisgruppen (Preisfeld, PRICE_FIELD) eingetragen.

Wenn die vom Artikel referenzierte Preisart nicht grundpreisabhängig ist, wird hier ein Mindestpreis eingetragen, andernfalls ein Grundpreis. Wird der Preis 0 eingetragen, so hat der Artikel keinen Mindest- oder Grundpreis, er ist aber nicht kostenlos.

Die Preise sind immer in der kleinsten Währungseinheit anzugeben (z. B. 300,00 ? = 30000 Cent). Identnummern werden ohne Nachkommastellen eingetragen. Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst).

Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird kein Datensatz der entsprechenden Preisgruppe angelegt.

Der Grundpreis ist immer ein Stückpreis. Wird einem Artikel eine Grundpreisberechnung zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden.
Der Endpreis des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem berechnetem Restmaßpreis, unter Berücksichtigung der durch die Preisart (Pfad 3/ PRICE_TYPE_REF) definierten Logik, zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist das Maß der Grundpreiseinheit (Pfad 5/ BASIC_PRICE_UNIT) abzuziehen. Das verbleibende Maß ist das Restmaß. Zur Berechnung des Preises für das Restmaß wird die Logik aus der Preisart in Verbindung mit dem Artikelpreis (Pfad 5/ PRICE) herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

Dieses Element muss für einen Artikel angelegt werden, wenn die Preisart (Pfad 3/PRICE_TYPE_REF) des Artikels grundpreisabhängig ist.

Elementpfade:
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 2: GLOBAL_DEFINITION
Pfad3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE 		D integer
P
M [-99999999:999999999]
Quelle
<xs:element name="PRICE_MINIMUM_BASIC" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>470--4--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_PRICE_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : BASIC_PRICE_UNIT Element
Beschreibung
Wenn eine Preisart (Pfad 1/ PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit ?1? angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BASIC_PRICE_UNIT Element
Overview
BASIC_PRICE_UNIT optional Restriction of xs:nonNegativeInteger
Wenn eine Preisart (Pfad 1/ PRICE_TYPE_REF) als grundpreisabhängig definiert ist, muss hier das Maß für die Grundpreiseinheit angegeben werden. Die Grundpreiseinheit hängt von der Anzahl der Dimensionen ab, die in der Preisart "1 bzw. true" angegeben sind.

Wenn sich der Grundpreis eines längenabhängigen Artikels beispielsweise auf 1,5 m bezieht, wird in dieses Element der Wert 1500 eingetragen. Bei einem volumenabhängigen Preis wird beispielsweise 1 m³ als "1000000000" [mm³] eingegeben.
Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit ?1? angegeben, so muss in dieses Element der Wert 0 eingetragen werden.

Elementpfade:
P1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D nonNegativeInteger
P
M [0:999999999999]
Quelle
<xs:element name="BASIC_PRICE_UNIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>470--6--Grundpreiseinheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_SINCE dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_SINCE dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_TYPE_REF Element
Beschreibung
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
Namensraum (none)
Diagramm
PRICE_TYPE_REF Element
Overview
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_TYPE_NO Restriction of xs:positiveInteger required
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Quelle
<xs:element name="PRICE_TYPE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400/407--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400/407--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ADDITIONAL_PRICE_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ADDITIONAL_PRICE_GROUP Element
Beschreibung
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Namensraum (none)
Diagramm
PRICE_TYPE_REF Element PRICE_FEATURE_GROUP_REF Element Sequence ADDITIONAL_PRICE_GROUP Element
Overview
ADDITIONAL_PRICE_GROUP 0..∞
In diesem Element werden PRICE_FEATURE_GROUPS mit weiteren Preisgruppen referenziert. Die Basispreisgruppe, die von einem Artikel genau 1x referenziert werden muss, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF angelegt.

Alle Artikel, welche die selbe PRICE_FEATURE_GROUP referenzieren, müssen auch auf die selbe Kalkulationsgruppe (CALC_GROUP_REF) und Tausch-ID (EXCHANGE_ID_REF) referenzieren.

Bei der Zuweisung unterschiedlicher Preisarten für Artikel und Mehrpreise des gleichen Artikels sind folgende Kombinationen erlaubt:

Artikel | Mehrpreis
Stückpreis | Stückpreis
längenabhängig | längenabhängig
längenabhängig | Stückpreis

Nicht erlaubt ist folgende Kombination:

Artikel | Mehrpreis
Stückpreis | längenabhängig
Sequence
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden: -900) 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Quelle
<xs:element name="ADDITIONAL_PRICE_GROUP" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP_REF">
        <xs:annotation>
          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>460--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE">
                    <xs:annotation>
                      <xs:documentation>460--5--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPE_REF">
        <xs:annotation>
          <xs:documentation>407--5--Preisart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--5--Preisart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : PRICE_FEATURE_GROUP_REF Element
Beschreibung
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
Namensraum (none)
Diagramm
ITEM_PRICE Element Sequence PRICE_FEATURE_GROUP_REF Element
Overview
PRICE_FEATURE_GROUP_REF
Dieses Element referenziert eine Mehrpreisgruppe. Mehrpreisgruppen, die hier referenziert werden, dürfen nicht als Ausführungsgruppen verwendet werden.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
Sequence
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden: -900) 		D integer
P
M [-99999999:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
Quelle
<xs:element name="PRICE_FEATURE_GROUP_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_PRICE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>460--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>460--5--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_PRICE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element : ITEM_PRICE Element
Beschreibung
In diesem Element wird der Artikelpreis hinterlegt.
Namensraum (none)
Diagramm
PRICE Element PRICE_FIELD Element Sequence ITEM_PRICE Element
Overview
ITEM_PRICE 1..∞
In diesem Element wird der Artikelpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden: -900) 		D integer
P
M [-99999999:999999999]
Quelle
<xs:element name="ITEM_PRICE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>460--5--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FIELD Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element > ITEM_PRICE Element : PRICE_FIELD Element
Beschreibung
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger
In diesem Element wird das Preisfeld für den Preis angegeben. D positiveInteger
P
M [1:9999]
Quelle
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--4--Preisfeld/Aufpreisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element > PRICE_FEATURE_GROUP_REF Element > ITEM_PRICE Element : PRICE Element
Beschreibung
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden: -900) 		D integer
P
M [-99999999:999999999]
Namensraum (none)
Typ
Restriction of xs:integer
Diagramm
PRICE Element
Overview
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch Negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Werte ist um eins geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: Feld 9-stellig. Es soll minus 9,00 € abgebildet werden: -900) 		D integer
P
M [-99999999:999999999]
Quelle
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>460--5--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_REF Element | ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_PRICE_GROUP Element : PRICE_TYPE_REF Element
Beschreibung
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
Namensraum (none)
Diagramm
PRICE_TYPE_REF Element
Overview
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad 1/PRICE_TYPE definiert.

Elementpfade:
Pfad 1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_TYPE_NO Restriction of xs:positiveInteger required
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Quelle
<xs:element name="PRICE_TYPE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>407--5--Preisart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--5--Preisart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_PRICE_GROUP Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : DECISIONS Element
Beschreibung
In diesem Element werden Artikel-spzezifische Regeln zusammengefasst.
Namensraum (none)
Diagramm
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional
In diesem Element werden Artikel-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine dem Artikel zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>hinter RESTRICTION geschoben, K. Richter, 12.06.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > DECISIONS Element : DECISION_REF Element
Beschreibung
Dieses Element referenziert eine dem Artikel zugeordnete Regel.
Namensraum (none)
Diagramm
DECISION_REF Element
Overview
DECISION_REF 1..∞
Dieses Element referenziert eine dem Artikel zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DECISION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DECISIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ADDITIONAL_ITEMS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ADDITIONAL_ITEMS Element
Beschreibung
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Namensraum (none)
Diagramm
MANDATORY_ITEMS Element OPTIONAL_ITEMS Element Sequence ADDITIONAL_ITEMS Element
Overview
ADDITIONAL_ITEMS optional
In diesem Element werden Zusatzartikel zugeordnet. Es werden Mengen von optionalen und/oder notwendigen Zusatzartikel definiert, aus denen in der Planung die Zusatzartikel ausgewählt werden.
Sequence
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist. Wird in einer Menge von optionalen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
Dieses Element dient der Bezeichnung der Gruppe von optionalen Artikeln.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar, für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln und neun Mengen
zwingender Zusatzartikel definiert werden.
Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt
werden. Aus den Mengen von zwingenden Zusatzartikeln darf je Menge
nur ein Artikel ausgewählt werden.
Wird in einer Menge von zwingenden Zusatzartikeln nur ein Artikel definiert,
wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von zwingenden Zusatzartikeln.

Dieses Element ist inhaltlich nicht notwendig, bleibt aber aus Kompatibilitätsgründen zum IDM 1.7 im IDM 2.0 zunächst erhalten. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. D nonNegativeInteger
P
M [1:999]
Quelle
<xs:element name="ADDITIONAL_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONAL_ITEMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                        <xs:annotation>
                          <xs:documentation>406--7--Anzahl</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SET_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="MANDATORY_ITEMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                        <xs:annotation>
                          <xs:documentation>406--7--Anzahl</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SET_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONAL_ITEMS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element : OPTIONAL_ITEMS Element
Beschreibung
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden.
Namensraum (none)
Diagramm
OPTIONAL_ITEM_GROUP Element Sequence OPTIONAL_ITEMS Element
Overview
OPTIONAL_ITEMS optional
In diesem Element werden optionale Zusatzartikel referenziert. Aus der Menge optionaler Zusatzartikel können mehrere ausgewählt werden.
Sequence
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist. Wird in einer Menge von optionalen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
Dieses Element dient der Bezeichnung der Gruppe von optionalen Artikeln.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar, für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
Quelle
<xs:element name="OPTIONAL_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="ITEM_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
                  <xs:annotation>
                    <xs:documentation>406--7--Anzahl</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SET_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONAL_ITEM_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element : OPTIONAL_ITEM_GROUP Element
Beschreibung
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
Namensraum (none)
Diagramm
ITEM_REF Element LANGUAGE Element Sequence GROUP_TITLE Element Sequence OPTIONAL_ITEM_GROUP Element
Overview
OPTIONAL_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von optionalen Artikeln gebildet.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist. Wird in einer Menge von optionalen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE required xs:boolean
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Sequence
GROUP_TITLE optional languagetext60 Complex Type
Dieses Element dient der Bezeichnung der Gruppe von optionalen Artikeln.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar, für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SET_NO Restriction of xs:positiveInteger required
Je Artikel kann eine Menge von optionalen Zusatzartikeln definiert werden. Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt werden, wenn MULTIPLE_CHOICE = true ist. Wird in einer Menge von optionalen Zusatzartikeln nur ein Artikel definiert, wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von optionalen Zusatzartikeln. 		D positiveInteger
P
M [1:9]
MULTIPLE_CHOICE xs:boolean required
Dieses Attribut gibt an ob Mehrfachauswahlen innerhalb der Gruppe möglich sind.

true = Mehrfachauswahl möglich. 		D boolean
P
M
Quelle
<xs:element name="OPTIONAL_ITEM_GROUP" maxOccurs="9" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>maxOcc von 1 auf 9 geändert 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="ITEM_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
            <xs:annotation>
              <xs:documentation>406--7--Anzahl</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SET_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MULTIPLE_CHOICE" type="xs:boolean" use="required" />
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

GROUP_TITLE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element > OPTIONAL_ITEM_GROUP Element : GROUP_TITLE Element
Beschreibung
Dieses Element dient der Bezeichnung der Gruppe von optionalen Artikeln.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence GROUP_TITLE Element
Overview
GROUP_TITLE optional languagetext60 Complex Type
Dieses Element dient der Bezeichnung der Gruppe von optionalen Artikeln.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="GROUP_TITLE" type="languagetext60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTIONAL_ITEM_GROUP Element | OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > OPTIONAL_ITEMS Element > OPTIONAL_ITEM_GROUP Element : ITEM_REF Element
Beschreibung
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF 1..∞
Mit diesem Element wird ein optionaler Zusatzartikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar, für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:30]
OPTIONAL_QUANTITY Restriction of xs:nonNegativeInteger optional
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. Für optionale Zusatzartikel stellt die Anzahl einen unverbindlichen Vorschlagswert dar, für Pflichtartikel ist die Anzahl in der Planung bindend. D nonNegativeInteger
P
M [1:999]
Quelle
<xs:element name="ITEM_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTIONAL_QUANTITY" use="optional">
      <xs:annotation>
        <xs:documentation>406--7--Anzahl</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONAL_ITEM_GROUP Element | OPTIONAL_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MANDATORY_ITEMS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element : MANDATORY_ITEMS Element
Beschreibung
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Namensraum (none)
Diagramm
MANDATORY_ITEM_GROUP Element Sequence MANDATORY_ITEMS Element
Overview
MANDATORY_ITEMS optional
Mit diesem Element können einem Artikel notwendige Zusatzartikel zugeordnet werden. Aus einer Menge notwendiger Zusatzartikel darf nur 1 Zusatzartikel ausgewählt werden. Einem Artikel können aber mehrere Mengen notwendiger Zusatzartikel zugeordnet werden.
Wird einer Menge nur 1 Zusatzartikel zugeordnet, wird dieser automatisch ausgewählt.
Sequence
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln und neun Mengen
zwingender Zusatzartikel definiert werden.
Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt
werden. Aus den Mengen von zwingenden Zusatzartikeln darf je Menge
nur ein Artikel ausgewählt werden.
Wird in einer Menge von zwingenden Zusatzartikeln nur ein Artikel definiert,
wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von zwingenden Zusatzartikeln.

Dieses Element ist inhaltlich nicht notwendig, bleibt aber aus Kompatibilitätsgründen zum IDM 1.7 im IDM 2.0 zunächst erhalten. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. D nonNegativeInteger
P
M [1:999]
Quelle
<xs:element name="MANDATORY_ITEMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MANDATORY_QUANTITY" use="optional">
                  <xs:annotation>
                    <xs:documentation>406--7--Anzahl</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SET_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MANDATORY_ITEM_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > MANDATORY_ITEMS Element : MANDATORY_ITEM_GROUP Element
Beschreibung
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
Namensraum (none)
Diagramm
ITEM_REF Element Sequence MANDATORY_ITEM_GROUP Element
Overview
MANDATORY_ITEM_GROUP 1..9
Mit diesem Element wird eine Gruppe von notwendigen Artikeln gebildet. Aus dieser Gruppe muss genau ein Artikel ausgewählt werden.
SET_NO required Restriction of xs:positiveInteger
Je Artikel kann eine Menge von optionalen Zusatzartikeln und neun Mengen
zwingender Zusatzartikel definiert werden.
Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt
werden. Aus den Mengen von zwingenden Zusatzartikeln darf je Menge
nur ein Artikel ausgewählt werden.
Wird in einer Menge von zwingenden Zusatzartikeln nur ein Artikel definiert,
wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von zwingenden Zusatzartikeln.

Dieses Element ist inhaltlich nicht notwendig, bleibt aber aus Kompatibilitätsgründen zum IDM 1.7 im IDM 2.0 zunächst erhalten. 		D positiveInteger
P
M [1:9]
Sequence
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. D nonNegativeInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SET_NO Restriction of xs:positiveInteger required
Je Artikel kann eine Menge von optionalen Zusatzartikeln und neun Mengen
zwingender Zusatzartikel definiert werden.
Aus der Menge der optionalen Zusatzartikel dürfen mehrere Zusatzartikel ausgewählt
werden. Aus den Mengen von zwingenden Zusatzartikeln darf je Menge
nur ein Artikel ausgewählt werden.
Wird in einer Menge von zwingenden Zusatzartikeln nur ein Artikel definiert,
wird dieser automatisch ausgewählt.

1-9 = Status zur Definition der Mengen von zwingenden Zusatzartikeln.

Dieses Element ist inhaltlich nicht notwendig, bleibt aber aus Kompatibilitätsgründen zum IDM 1.7 im IDM 2.0 zunächst erhalten. 		D positiveInteger
P
M [1:9]
Quelle
<xs:element name="MANDATORY_ITEM_GROUP" maxOccurs="9" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MANDATORY_QUANTITY" use="optional">
            <xs:annotation>
              <xs:documentation>406--7--Anzahl</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SET_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MANDATORY_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ADDITIONAL_ITEMS Element > MANDATORY_ITEMS Element > MANDATORY_ITEM_GROUP Element : ITEM_REF Element
Beschreibung
Dieses Element referenziert einen Artikel.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF 1..∞
Dieses Element referenziert einen Artikel.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. D string
P
M [1:30]
MANDATORY_QUANTITY optional Restriction of xs:nonNegativeInteger
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. D nonNegativeInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. D string
P
M [1:30]
MANDATORY_QUANTITY Restriction of xs:nonNegativeInteger optional
Anzahl der Zusatzartikel. Vorschlagswert für Planungssysteme. D nonNegativeInteger
P
M [1:999]
Quelle
<xs:element name="ITEM_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MANDATORY_QUANTITY" use="optional">
      <xs:annotation>
        <xs:documentation>406--7--Anzahl</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MANDATORY_ITEM_GROUP Element | MANDATORY_ITEMS Element | ADDITIONAL_ITEMS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EDP_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EDP_NUMBER Element
Beschreibung
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDP_NUMBER Element
Overview
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:30]
Quelle
<xs:element name="EDP_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--10--EDV_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EAN_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EAN_NUMBER Element
Beschreibung
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EAN_NUMBER Element
Overview
EAN_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die EAN-Nummer des Artikels eingetragen werden. D string
P
M [1:15]
Quelle
<xs:element name="EAN_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--11--EAN_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_IDENTIFICATION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_IDENTIFICATION Element
Beschreibung

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil;
K = Katalogartikel;
S = Sonderartikel;
M = Mehrausstattungen;
Z = Zusammenstellung
V = Verrechnungsblock
P = Verrechnungsposition.
1 = Planungsvorschlag
2 = Vorzugskombi

Für den Planungsvorschlag (1) gilt folgendes:
Die einzelnen Artikel können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

D string
P [BEKSMZVP12]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ITEM_IDENTIFICATION Element
Overview
ITEM_IDENTIFICATION Restriction of xs:string

In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil;
K = Katalogartikel;
S = Sonderartikel;
M = Mehrausstattungen;
Z = Zusammenstellung
V = Verrechnungsblock
P = Verrechnungsposition.
1 = Planungsvorschlag
2 = Vorzugskombi

Für den Planungsvorschlag (1) gilt folgendes:
Die einzelnen Artikel können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

D string
P [BEKSMZVP12]
M [1:1]
Quelle
<xs:element name="ITEM_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--14--Artikelkennung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BEKSMZVP12]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CATALOG_PAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CATALOG_PAGE Element
Beschreibung
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register ?Zubehör?. 		D string
P
M [1:7]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_PAGE Element
Overview
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register ?Zubehör?. 		D string
P
M [1:7]
Quelle
<xs:element name="CATALOG_PAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--15--Katalog_Seite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="7" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefällt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TK_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_TYPE Element
Beschreibung
Hier wird ein Wert aus der Spalte Nr. der Tabelle "Typschlüssel" der Einleitung eingetragen. D poisitiveInteger
P
M [1000:2000]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_TYPE Element
Overview
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle "Typschlüssel" der Einleitung eingetragen. D poisitiveInteger
P
M [1000:2000]
Quelle
<xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="2000" />
      <xs:minInclusive value="1000" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WEIGHT_BRUTTO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : WEIGHT_BRUTTO Element
Beschreibung
In dieses Element wird das Brutto-Gewicht des Artikels [100 g] angegeben. D.h. inklusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
WEIGHT_BRUTTO Element
Overview
WEIGHT_BRUTTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Brutto-Gewicht des Artikels [100 g] angegeben. D.h. inklusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="WEIGHT_BRUTTO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WEIGHT_NETTO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : WEIGHT_NETTO Element
Beschreibung
In dieses Element wird das Netto-Gewicht des Artikels [100 g] angegeben. D.h. exlusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
WEIGHT_NETTO Element
Overview
WEIGHT_NETTO optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Netto-Gewicht des Artikels [100 g] angegeben. D.h. exlusive Verpackungsmaterial. (z. B. 50 = 5000 g) D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="WEIGHT_NETTO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Netto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VOLUME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VOLUME Element
Beschreibung
In dieses Element wird das Volumen [dm³]des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
VOLUME Element
Overview
VOLUME optional Restriction of xs:nonNegativeInteger
In dieses Element wird das Volumen [dm³]des Artikels inklusive Verpackungsmaterial angegeben. (z. B. 50 = 50 dm³) D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="VOLUME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--21--Volumen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MINIMUM_DELIVERY_TIME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : MINIMUM_DELIVERY_TIME Element
Beschreibung
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung) 		D nonNegativeInteger
P
M [0:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MINIMUM_DELIVERY_TIME Element
Overview
MINIMUM_DELIVERY_TIME optional Restriction of xs:nonNegativeInteger
In diesem Element wird die Mindestlieferzeit in Wochen angegeben.
Die Angabe der Mindestlieferzeit dient zur Information, die Planungssoftware greift nicht in die Auftragssteuerung ein (z. B. Rückstellen des Auftrages, Teillieferung) 		D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="MINIMUM_DELIVERY_TIME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--36--Mindest_Lieferzeit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_PROFILE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BASIC_PROFILE Element
Beschreibung
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Namensraum (none)
Diagramm
ITEM_DIMENSIONAL_DRAWING Element CARCASE_BASIC_SHAPE Element Choice Sequence BASIC_PROFILE Element
Overview
BASIC_PROFILE optional
In diesem Element werden die einem Artikel zugeordneten Grundformen hinterlegt.
Sequence
Choice
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
997 = Artikel für die weder Grundform, noch Echtgrafik mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element MODELING_GRAPHIC_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe angegeben werden. Zusätzlich können über die Elemente SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt.
997 = Artikel für die weder Grundform, noch Echtgrafik, mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefällt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.

Dieses Element muss gefällt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern angegeben werden.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:30]
BASIC_SHAPE_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Maßbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Fußform) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (von, bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefällt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Für Tische ist ebenfalls B, H und Tanzugeben, in den Planungssystemen wird für T die Bezeichnung Länge (abhängig vom Typenschlüssel) benutzt.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maßund muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Quelle
<xs:element name="BASIC_PROFILE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice>
        <xs:element name="CARCASE_BASIC_SHAPE">
          <xs:annotation>
            <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>400--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                </xs:annotation>
                <xs:complexType mixed="true">
                  <xs:sequence>
                    <xs:element name="OPTION_REF">
                      <xs:annotation>
                        <xs:documentation>430--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="FEATURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>430--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>430--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,5}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="BASIC_SHAPE_PARAMETERS">
                <xs:annotation>
                  <xs:documentation>500--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>500--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--Parameter</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>500--5--Nennwert</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_FROM">
                          <xs:annotation>
                            <xs:documentation>500--6--Von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_TO">
                          <xs:annotation>
                            <xs:documentation>500--7--Bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                          <xs:annotation>
                            <xs:documentation>500--8--Schrittweite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
              <xs:annotation>
                <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="ITEM_DIMENSIONAL_DRAWING">
          <xs:annotation>
            <xs:documentation>400--32--Massbild</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="240" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="DIMENSIONAL_PARAMETERS">
                <xs:annotation>
                  <xs:documentation>500--1--Satzart</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>500--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSIONAL_NAME" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_FROM">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_TO">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                          <xs:annotation>
                            <xs:documentation>500--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:decimal">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
              <xs:annotation>
                <xs:documentation>400--32--Massbild</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CARCASE_BASIC_SHAPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element : CARCASE_BASIC_SHAPE Element
Beschreibung
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
997 = Artikel für die weder Grundform, noch Echtgrafik mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
Namensraum (none)
Diagramm
BASIC_SHAPE_PARAMETERS Element BASIC_PROFILE_SHAPE Element Sequence CARCASE_BASIC_SHAPE Element
Overview
CARCASE_BASIC_SHAPE
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden. Sind für Artikel mit Grundform = 0 keine Parameterwerte vorhanden, so müssen die Werte mit 0 gefüllt werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
997 = Artikel für die weder Grundform, noch Echtgrafik mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefüllt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.
Dieses Element muss gefüllt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist.
CARCASE_BASIC_SHAPE_NO required Restriction of xs:nonNegativeInteger
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element MODELING_GRAPHIC_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe angegeben werden. Zusätzlich können über die Elemente SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt.
997 = Artikel für die weder Grundform, noch Echtgrafik, mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefällt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.

Dieses Element muss gefällt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Sequence
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern angegeben werden.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:30]
BASIC_SHAPE_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Maßbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Fußform) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (von, bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefällt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
CARCASE_BASIC_SHAPE_NO Restriction of xs:nonNegativeInteger required
In dieses Element wird die Grundformnummer eingetragen. Neben den vergebenen Grundformnummern sind folgende Werte möglich:
0 = Artikel, die grafisch nicht relevant sind und/oder der Hersteller bewusst fordert, dass diese vom Händlersystem grafisch nicht visualisiert werden. Auch bei der Angabe von grafisch nicht relevanten Artikeln, müssen wenn möglich die Parameter Breite, Höhe und Tiefe angegeben werden.
Sollen keine Parametereintragungen für die Grundform vorgenommen werden, so kann der BASIC_PROFILE Knoten entfallen, anstatt die Parameter der Grundform mit 0 zu füllen.
999 = Artikel, die grafisch relevant sind, für die es jedoch keine Grundform gibt und die durch eine Echtgrafik abgebildet werden (siehe Element MODELING_GRAPHIC_ID). Auch bei der Verwendung von Echtgrafiken müssen die Parameter Breite, Höhe und Tiefe angegeben werden. Zusätzlich können über die Elemente SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO Informationen für diesen Artikel mitgegeben werden.
998 = Artikel für die es keine Grundform und keine Echtgrafik gibt.
997 = Artikel für die weder Grundform, noch Echtgrafik, mitgeliefert werden. Dafür müssen die Elemente SUBCONTRACTOR_ID und SUBCONTRACTOR_ITEM_NO gefällt sein und der Hersteller muss dafür Sorge tragen, dass Grafikinformationen des Zulieferers bereitstehen.
996 = Artikel, die grafisch relevant sind, für die aber keine Grafikinformationen mitgeliefert werden. Diese Grundform_Nr gilt nur für Füllstufen kleiner 3.

Dieses Element muss gefällt werden, wenn das Element BASIC_PROFILE_SHAPE leer ist. 		D nonNegativeInteger
P [0-9]|[1-4][0-9]|5[0-2]|99[2-9]
M [0:999]
Quelle
<xs:element name="CARCASE_BASIC_SHAPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType mixed="true">
          <xs:sequence>
            <xs:element name="OPTION_REF">
              <xs:annotation>
                <xs:documentation>430--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>430--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>430--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,5}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="BASIC_SHAPE_PARAMETERS">
        <xs:annotation>
          <xs:documentation>500--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>500--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="BASIC_SHAPE_NAME" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--Parameter</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
                  <xs:annotation>
                    <xs:documentation>500--5--Nennwert</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_FROM">
                  <xs:annotation>
                    <xs:documentation>500--6--Von</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_TO">
                  <xs:annotation>
                    <xs:documentation>500--7--Bis</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
                  <xs:annotation>
                    <xs:documentation>500--8--Schrittweite</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="CARCASE_BASIC_SHAPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--22--Korpus_Grundform</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-4][0-9]|5[0-2]|99[2-9]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_PROFILE_SHAPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element : BASIC_PROFILE_SHAPE Element
Beschreibung
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern angegeben werden.
Namensraum (none)
Diagramm
OPTION_REF Element Sequence BASIC_PROFILE_SHAPE Element
Overview
BASIC_PROFILE_SHAPE optional
Hier wird auf eine Grundform verwiesen, die das Profil geometrisch beschreibt. Die Maße des Profils müssen entsprechend den in der Grundform angegebenen Parametern angegeben werden.
BASIC_PROFILE_SHAPE_NO required Restriction of xs:string
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Sequence
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
BASIC_PROFILE_SHAPE_NO Restriction of xs:string required
In diesem Element wird die Nummer der Profilgrundform hinterlegt. D string
P [\S ]{1,5}
M [1:5]
Quelle
<xs:element name="BASIC_PROFILE_SHAPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType mixed="true">
    <xs:sequence>
      <xs:element name="OPTION_REF">
        <xs:annotation>
          <xs:documentation>430--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>430--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>430--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="BASIC_PROFILE_SHAPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[\S ]{1,5}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element > BASIC_PROFILE_SHAPE Element : OPTION_REF Element
Beschreibung
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Hier werden die Variantenart und der Varianteschlüssel für die Variante der Profilform angegeben.
FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird eine Variantenart angegeben. D nonNegativeInteger
P
M [0:9999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variante referenziert, die der Profilgrundform zugeordnet werden soll. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>430--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>430--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>430--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BASIC_PROFILE_SHAPE Element | CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_SHAPE_PARAMETERS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element : BASIC_SHAPE_PARAMETERS Element
Beschreibung
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Maßbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Fußform) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Namensraum (none)
Diagramm
BASIC_SHAPE_PARAMETER Element Sequence BASIC_SHAPE_PARAMETERS Element
Overview
BASIC_SHAPE_PARAMETERS
In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmaße beschrieben. Werden Artikelmaße benötigt, die auserhalb der angegebenen Maßbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen BASIC_SHAPE_NOMINAL_VALUE (Pfad 1), BASIC_SHAPE_FROM (Pfad 1) und BASIC_SHAPE_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Für Artikel mit Grundformnummer 0, die keine Dimensionen haben, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Fußform) sind die Parameter mit 0 zu füllen.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/CARCASE_BASIC_SHAPE/BASIC_SHAPE_PARAMETERS/BASIC_SHAPE_PARAMETER
Sequence
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (von, bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefällt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Quelle
<xs:element name="BASIC_SHAPE_PARAMETERS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>500--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="BASIC_SHAPE_NAME" use="required">
            <xs:annotation>
              <xs:documentation>500--0--Parameter</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
            <xs:annotation>
              <xs:documentation>500--5--Nennwert</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_FROM">
            <xs:annotation>
              <xs:documentation>500--6--Von</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_TO">
            <xs:annotation>
              <xs:documentation>500--7--Bis</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
            <xs:annotation>
              <xs:documentation>500--8--Schrittweite</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_SHAPE_PARAMETER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > CARCASE_BASIC_SHAPE Element > BASIC_SHAPE_PARAMETERS Element : BASIC_SHAPE_PARAMETER Element
Beschreibung
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
Namensraum (none)
Diagramm
BASIC_SHAPE_PARAMETER Element
Overview
BASIC_SHAPE_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.

Wird ein nicht grafisch relevanter Artikel angelegt, für den keine Parameter existieren, dann kann der übergeordnete Knoten BASIC_PROFILE entfallen, anstatt die Parameter mit 0 zu füllen.
BASIC_SHAPE_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (von, bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maß und muss gefällt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
BASIC_SHAPE_NAME Restriction of xs:string required
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
BASIC_SHAPE_NOMINAL_VALUE Restriction of xs:decimal required
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (von, bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
BASIC_SHAPE_FROM Restriction of xs:decimal optional
Das Element beinhaltet das kleinste lieferbare Maß und muss gefällt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_TO Restriction of xs:decimal optional
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
BASIC_SHAPE_STEP_SIZE Restriction of xs:decimal optional
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Quelle
<xs:element name="BASIC_SHAPE_PARAMETER" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="BASIC_SHAPE_NAME" use="required">
      <xs:annotation>
        <xs:documentation>500--0--Parameter</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_NOMINAL_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>500--5--Nennwert</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_FROM">
      <xs:annotation>
        <xs:documentation>500--6--Von</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_TO">
      <xs:annotation>
        <xs:documentation>500--7--Bis</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="BASIC_SHAPE_STEP_SIZE">
      <xs:annotation>
        <xs:documentation>500--8--Schrittweite</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BASIC_SHAPE_PARAMETERS Element | CARCASE_BASIC_SHAPE Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_DIMENSIONAL_DRAWING Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element : ITEM_DIMENSIONAL_DRAWING Element
Beschreibung
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist.
Namensraum (none)
Diagramm
DIMENSIONAL_PARAMETERS Element DOCUMENT_REFERENCE Element Sequence ITEM_DIMENSIONAL_DRAWING Element
Overview
ITEM_DIMENSIONAL_DRAWING
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element DIMENSIONAL_PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist.
ITEM_DIMENSIONAL_DRAWING_NO required Restriction of xs:string
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. 		D string
P
M [1:20]
Sequence
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
DIMENSIONAL_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Für Tische ist ebenfalls B, H und Tanzugeben, in den Planungssystemen wird für T die Bezeichnung Länge (abhängig vom Typenschlüssel) benutzt.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maßund muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ITEM_DIMENSIONAL_DRAWING_NO Restriction of xs:string required
In diesem Element wird ein Maßbild angegeben für das die Parameter im Element PARAMETERS hinterlegt werden. Mit dem Maßbild werden Zubehörartikel beschrieben.
Auch wenn dieses Element nicht angelegt ist, muss das Element BASIC_PROFILES/PARAMETERS mit mindestens den Maßen der Boundingbox (b, h, t) angelegt werden.
Das Element darf nicht angelegt werden, wenn das Element BASIC_PROFILE_SHAPE angelegt ist. 		D string
P
M [1:20]
Quelle
<xs:element name="ITEM_DIMENSIONAL_DRAWING" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--32--Massbild</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DOCUMENT_REFERENCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="240" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DIMENSIONAL_PARAMETERS">
        <xs:annotation>
          <xs:documentation>500--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>500--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DIMENSIONAL_NAME" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[0-9a-zA-Z]{1,13}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_FROM">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_TO">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DIMENSIONAL_STEP_SIZE">
                  <xs:annotation>
                    <xs:documentation>500--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:decimal">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ITEM_DIMENSIONAL_DRAWING_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--32--Massbild</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="20" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DOCUMENT_REFERENCE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element : DOCUMENT_REFERENCE Element
Beschreibung
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
DOCUMENT_REFERENCE Element
Overview
DOCUMENT_REFERENCE optional Restriction of xs:string
In diesem Feld wird der Name eines Dokumentes oder eine Referenz auf ein Dokument hinterlegt.

Die Dokumente enthalten beispielsweise zusätzliche technische Informationen über den Einbau oder Schablonen für Ausschnitte und Bohrungen.
Wird nur der Dokumentname angegeben, so muss das Dokument mit den Daten geliefert werden. Eine Dokumentenreferenz wird über eine URI/URL hinterlegt.

Wird in diesem Element eine Dokumentreferenz angegeben, muss im Element NAME der Wert 23 angegeben werden. Der Wert 23 bedeutet Dokumentreferenz (siehe Wertetabellen). 		D string
P
M [1:240]
Quelle
<xs:element name="DOCUMENT_REFERENCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>505--9--Referenz_Dokument</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="240" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DIMENSIONAL_PARAMETERS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element : DIMENSIONAL_PARAMETERS Element
Beschreibung

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Für Tische ist ebenfalls B, H und Tanzugeben, in den Planungssystemen wird für T die Bezeichnung Länge (abhängig vom Typenschlüssel) benutzt.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Namensraum (none)
Diagramm
DIMENSIONAL_PARAMETER Element Sequence DIMENSIONAL_PARAMETERS Element
Overview
DIMENSIONAL_PARAMETERS

In diesem Element werden dem Artikel grafisch relevante Parameter mit entsprechenden Werten zugeordnet.

Es werden die werkseitig möglichen Artikelmase beschrieben. Werden Artikelmase benötigt, die auserhalb der angegebenen Massbereiche liegen, handelt es sich um Sonderanfertigungen. Sonderanfertigungen, müssen mit dem Hersteller abgestimmt werden.

Sind die Werte in den Elementen DIMENSIONAL_NOMINAL_VALUE (Pfad 1), DIMENSIONAL_FROM (Pfad 1) und DIMENSIONAL_TO (Pfad 1) gleich, so dürfen diese Parameter nicht geändert werden, eine werkseitige Änderung dieser Parameter als Sonderanfertigung ist ebenfalls nicht möglich.

Wird als Artikel ein E-Gerät angelegt, so müssen hierzu die Mase B, H und T dieses E-Gerätes angelegt werden.

Für Tische ist ebenfalls B, H und Tanzugeben, in den Planungssystemen wird für T die Bezeichnung Länge (abhängig vom Typenschlüssel) benutzt.

Wenn es zwingend erforderlich ist (beispielsweise bei diagonalen Eckblenden), können für die Grundformen 21, 24 und 25 1/10 mm Werte angegeben werden. Beispiel: 27,3 mm => Elementinhalt : 0027.3

Dieses Element muss für einen Artikel nur dann nicht angelegt werden, wenn dieser die Grundformnummer 0 und keine Dimension hat, wie beispielsweise kalkulatorische Positionen (z. B. Mehrpreis für Stangengriff).

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES/ITEM_DIMENSIONAL_DRAWING/DIMENSIONAL_PARAMETERS/DIMENSIONAL_PARAMETER

Sequence
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maßund muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Quelle
<xs:element name="DIMENSIONAL_PARAMETERS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>500--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DIMENSIONAL_NAME" use="required">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9a-zA-Z]{1,13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_FROM">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_TO">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DIMENSIONAL_STEP_SIZE">
            <xs:annotation>
              <xs:documentation>500--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:decimal">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DIMENSIONAL_PARAMETER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BASIC_PROFILE Element > ITEM_DIMENSIONAL_DRAWING Element > DIMENSIONAL_PARAMETERS Element : DIMENSIONAL_PARAMETER Element
Beschreibung
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
Namensraum (none)
Diagramm
DIMENSIONAL_PARAMETER Element
Overview
DIMENSIONAL_PARAMETER 1..∞
In diesem Element werden die Werte der Parameter hinterlegt, welche eine Grundform beschreiben.
DIMENSIONAL_NAME required Restriction of xs:string
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE required Restriction of xs:decimal
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM optional Restriction of xs:decimal
Das Element beinhaltet das kleinste lieferbare Maßund muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO optional Restriction of xs:decimal
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE optional Restriction of xs:decimal
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DIMENSIONAL_NAME Restriction of xs:string required
In diesem Attribut wird der Parametername angegeben. D string
P [0-9a-zA-Z]{1,13}
M [1:13]
DIMENSIONAL_NOMINAL_VALUE Restriction of xs:decimal required
Jedem Parameter wird ein fester Nennwert und optional ein Wertepaar (Von, Bis) zugeordnet. Die variablen Parameter sind beispielsweise für die Abbildung von erlaubten Breitenkürzungen sinnvoll.
Als Einheit für Längenmaße dient [mm] ohne Nachkommastellen und für Winkel [°] mit 3 Vor- und 3 Nachkommastellen. 		D decimal
P
M [0:999999]
DIMENSIONAL_FROM Restriction of xs:decimal optional
Das Element beinhaltet das kleinste lieferbare Maßund muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Element nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_TO Restriction of xs:decimal optional
Das Feld beinhaltet das größte lieferbare Maß und muss gefüllt werden, wenn der Artikel im Bereich dieses Parameters flexibel ist. Ist der Parameter nicht flexibel, so darf das Feld nicht gefüllt werden. D decimal
P
M [0:999999]
DIMENSIONAL_STEP_SIZE Restriction of xs:decimal optional
Bei variablen Parametern kann eine Schrittweite angegeben werden. Als Einheit dient die Einheit der Parameter. Die Schrittweite muss kleiner als die Differenz zwischen Von- und Bis-Wert sein. D decimal
P
M [0:999999]
Quelle
<xs:element name="DIMENSIONAL_PARAMETER" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>500--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSIONAL_NAME" use="required">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9a-zA-Z]{1,13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_NOMINAL_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_FROM">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_TO">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSIONAL_STEP_SIZE">
      <xs:annotation>
        <xs:documentation>500--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:decimal">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DIMENSIONAL_PARAMETERS Element | ITEM_DIMENSIONAL_DRAWING Element | BASIC_PROFILE Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_TEXT Element
Beschreibung
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;
- Kurztext + empfohlener Text;
- Kurztext + empfohlener Text + Langtext;
- Kurztext + Langtext (nur wenn kein empfohlener Text angelegt wurde).

Der Kurztext darf aus drei Zeilen bestehen.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence PLANNING_ADVICE Element LANGUAGE Element Sequence FULL_TEXT Element SHORT_TEXT Element Sequence ITEM_TEXT Element
Overview
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;
- Kurztext + empfohlener Text;
- Kurztext + empfohlener Text + Langtext;
- Kurztext + Langtext (nur wenn kein empfohlener Text angelegt wurde).

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
Sequence
TEXT_LINE 1..3
SEQUENCE_NO required Restriction of xs:positiveInteger
Sequence
TEXT Restriction of xs:string
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="ITEM_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SHORT_TEXT">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>410--6--Textzeile</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Za-z]{1,3}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SHORT_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : SHORT_TEXT Element
Beschreibung
Dieses Element enthält Kurztexte.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence SHORT_TEXT Element
Overview
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
Sequence
TEXT_LINE 1..3
SEQUENCE_NO required Restriction of xs:positiveInteger
Sequence
TEXT Restriction of xs:string
Quelle
<xs:element name="SHORT_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>410--6--Textzeile</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Za-z]{1,3}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element : LANGUAGE Element
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
Sequence
TEXT_LINE 1..3
SEQUENCE_NO required Restriction of xs:positiveInteger
Sequence
TEXT Restriction of xs:string
Attribute
Name | Typ | Verwenden | Standard | Festgelegt | Beschreibung
ISO_LANGUAGE_ID | Restriction of xs:language | required |  |  |
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>410--6--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Za-z]{1,3}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT_LINE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element : TEXT_LINE Element
Namensraum (none)
Diagramm
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..3
SEQUENCE_NO required Restriction of xs:positiveInteger
Sequence
TEXT Restriction of xs:string
Attribute
Name | Typ | Verwenden | Standard | Festgelegt | Beschreibung
SEQUENCE_NO | Restriction of xs:positiveInteger | required |  |  |
Quelle
<xs:element name="TEXT_LINE" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>410--6--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--6--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FULL_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : FULL_TEXT Element
Beschreibung
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence FULL_TEXT Element
Overview
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="FULL_TEXT" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PLANNING_ADVICE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : PLANNING_ADVICE Element
Beschreibung
Dieses Element enthält Planungshinweise.
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence PLANNING_ADVICE Element
Overview
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TYPE_KEY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : TYPE_KEY Element
Beschreibung
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Werte der Typschlüssel werden in einer Tabelle der Einleitung, Abschnitt Typenschlüssel bereitgestellt.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Namensraum (none)
Diagramm
TK_INFO Element TK_CLASS Element TK_TYPE Element Sequence TYPE_KEY Element
Overview
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Werte der Typschlüssel werden in einer Tabelle der Einleitung, Abschnitt Typenschlüssel bereitgestellt.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle "Typschlüssel" der Einleitung eingetragen. D poisitiveInteger
P
M [1000:2000]
TK_CLASS optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Art der Tabelle "Typschlüssel-Arten"eingetragen. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
TK_INFO optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle " Ausführungsschlüssel"eingetragen. D nonNegativeInteger
P [0-8]0
M [00-80]
Quelle
<xs:element name="TYPE_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_TYPE" minOccurs="1" maxOccurs="1">
        <xs:annotation>
          <xs:documentation xml:lang="DE">3 stufiger Schlüssel laut Sitzung am 10.06.2015 /ba</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="2000" />
            <xs:minInclusive value="1000" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_CLASS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_INFO" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:pattern value="[0-8]0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TK_CLASS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_CLASS Element
Beschreibung
Hier wird ein Wert aus der Spalte Art der Tabelle "Typschlüssel-Arten"eingetragen. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
TK_CLASS Element
Overview
TK_CLASS optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Art der Tabelle "Typschlüssel-Arten"eingetragen. D nonNegativeInteger
P 000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0
M [000:810]
Quelle
<xs:element name="TK_CLASS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Drehtür, Lade, Klappe...</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:pattern value="000|[146][0-7]0|2[0-6]0|3[0-4]0|[57][012]0|8[01]0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TK_INFO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_INFO Element
Beschreibung
Hier wird ein Wert aus der Spalte Nr. der Tabelle " Ausführungsschlüssel"eingetragen. D nonNegativeInteger
P [0-8]0
M [00-80]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
TK_INFO Element
Overview
TK_INFO optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Nr. der Tabelle " Ausführungsschlüssel"eingetragen. D nonNegativeInteger
P [0-8]0
M [00-80]
Quelle
<xs:element name="TK_INFO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Info füber Art der Type z.B. Einzelelement, Anbauelement, Unterteil...</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:pattern value="[0-8]0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

CLASSIFICATIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CLASSIFICATIONS Element
Beschreibung
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Namensraum (none)
Diagramm
ECLASS Element Sequence CLASSIFICATIONS Element
Overview
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="CLASSIFICATIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS_NO">
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:totalDigits value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ECLASS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element : ECLASS Element
Beschreibung
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Namensraum (none)
Diagramm
ECLASS_NO Element Sequence ECLASS Element
Overview
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="ECLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS_NO">
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:totalDigits value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ECLASS_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element > ECLASS Element : ECLASS_NO Element
Beschreibung

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
ECLASS_NO Element
Overview
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="ECLASS_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:totalDigits value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ECLASS Element | CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : DETAIL_INFOS Element
Beschreibung
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden und es darf nicht gleichzeitig auf eine Prüfung referenziert werden (kein Wert für RESTRICTION_NO) . 		D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DECISION_NO" use="optional">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden und es darf nicht gleichzeitig auf eine Prüfung referenziert werden (kein Wert für RESTRICTION_NO) . 		D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO Restriction of xs:positiveInteger optional
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden und es darf nicht gleichzeitig auf eine Prüfung referenziert werden (kein Wert für RESTRICTION_NO) . 		D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DECISION_NO" use="optional">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SALES_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : SALES_NUMBER Element
Beschreibung
In dieses Element muss, falls vorhanden, die Verkaufs-Nummer des Artikels eingetragen werden. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
SALES_NUMBER Element
Overview
SALES_NUMBER optional Restriction of xs:string
In dieses Element muss, falls vorhanden, die Verkaufs-Nummer des Artikels eingetragen werden. D string
P
M [1:30]
Quelle
<xs:element name="SALES_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PART_LIST_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PART_LIST_REF Element
Beschreibung

Dieses Element referenziert eine im Artikel enthaltene Stückliste.

Der Artikel vererbt dabei seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleiche Variantenarten (FEATURES) tragen.

An den Unterpositionen kann es Regeln geben, die bestimmen, ob eine Unterposition dargestellt wird. Die Angabe der Unterposition erfolgt dann mit der entsprechenden Stückzahl.

Artikel, die nur als Unterposition zulässig sind, werden separat markiert (Element PARTS_LIST_EXCLUSIVE).

Handelt es sich bei dem Artikel um einen Katalogartikel (ITEM_IDENTIFICATION 'K'), können dem Artikel Preise zugeordnet werden. Der Gesamtpreis des Katalogartikels ergibt sich aus dem ihm zugeordneten Preis und den Preisen der Bestandteile der Stückliste.

Für den Planungsvorschlag (ITEM_IDENTIFICATION '1'), gilt folgendes:
Die einzelnen Artikel der Stückliste können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi (ITEM_IDENTIFICATION '2') unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

Namensraum (none)
Diagramm
PART_LIST_REF Element
Overview
PART_LIST_REF optional

Dieses Element referenziert eine im Artikel enthaltene Stückliste.

Der Artikel vererbt dabei seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleiche Variantenarten (FEATURES) tragen.

An den Unterpositionen kann es Regeln geben, die bestimmen, ob eine Unterposition dargestellt wird. Die Angabe der Unterposition erfolgt dann mit der entsprechenden Stückzahl.

Artikel, die nur als Unterposition zulässig sind, werden separat markiert (Element PARTS_LIST_EXCLUSIVE).

Handelt es sich bei dem Artikel um einen Katalogartikel (ITEM_IDENTIFICATION 'K'), können dem Artikel Preise zugeordnet werden. Der Gesamtpreis des Katalogartikels ergibt sich aus dem ihm zugeordneten Preis und den Preisen der Bestandteile der Stückliste.

Für den Planungsvorschlag (ITEM_IDENTIFICATION '1'), gilt folgendes:
Die einzelnen Artikel der Stückliste können die Defaultwerte übernehmen.
Es dürfen keine Unterpositionen auftauchen, die nur Unterposition sind und nicht einzeln bestellbar sind.
Es werden immer nur die sich ergebenen Artikel bestellt. Die Zusammenstellung selber taucht nie auf in den Bestellformularen auf.
Bei Verplanung werden die Positionen aufgelöst und die Varianten vererbt.
Die einzelnen Positionen müssen dann in ihrer Reihenfolge von links nach rechts im Magnetplaner positioniert werden.
Planungsvorschläge können Vorzugskombis enthalten.

Die Vorzugskombi (ITEM_IDENTIFICATION '2') unterliegt folgenden Regeln:
Sie darf keinen Planungsvorschlag enthalten.
Wird eine Vorzugskombination aufgelöst (z.B. durch Löschung einer Unterposition), dann werden zu den einzelnen Positionen die Einzelpreise neu ermittelt und der Preisvorteil ist weg.
Die Preisfindung findet nur auf Hauptpositionslevel statt.

PART_LIST_KEY required Restriction of xs:string
In diesem Attribut wird der Schlüssel der Stückliste angegeben. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PART_LIST_KEY Restriction of xs:string required
In diesem Attribut wird der Schlüssel der Stückliste angegeben. D string
P
M [1:30]
Quelle
<xs:element name="PART_LIST_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PART_LIST_KEY" use="required">
      <xs:annotation>
        <xs:documentation>--0--NEW</xs:documentation>
        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="30" />
          <xs:minLength value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PART_LIST_EXCLUSIVE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PART_LIST_EXCLUSIVE Element
Beschreibung
Dieses Element markiert, ob der Artikel nur als Unterposition einer Stückliste zulässig ist (Wert auf 1(true) gesetzt).
Der Wert 0 (false) hat die gleiche Bedeutung wie ein fehlender Wert. 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
PART_LIST_EXCLUSIVE Element
Overview
PART_LIST_EXCLUSIVE optional Restriction of xs:boolean
Dieses Element markiert, ob der Artikel nur als Unterposition einer Stückliste zulässig ist (Wert auf 1(true) gesetzt).
Der Wert 0 (false) hat die gleiche Bedeutung wie ein fehlender Wert. 		D boolean
P
M
Quelle
<xs:element name="PART_LIST_EXCLUSIVE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5 /ba:
Dieser Artikel kann nur in einer Stückliste vorkommen und ist nicht als einzelner Artikel bestellbar
</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTIES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PROPERTIES Element
Beschreibung
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Namensraum (none)
Diagramm
PROPERTY_REF Element Sequence PROPERTIES Element
Overview
PROPERTIES optional
In diesem Element werden Artikel-spzezifische Eigenschaften/Merkmale zusammengefasst.
Sequence
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Quelle
<xs:element name="PROPERTIES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PROPERTY_NO" use="required">
            <xs:annotation>
              <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="VALUE" use="required">
            <xs:annotation>
              <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PROPERTY_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PROPERTIES Element : PROPERTY_REF Element
Beschreibung
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
Namensraum (none)
Diagramm
PROPERTY_REF Element
Overview
PROPERTY_REF 1..∞
Dieses Element referenziert eine Eigenschaft, die unter GLOBAL_DEFINITION/PROPERTIES definiert ist.
PROPERTY_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE required Restriction of xs:string

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PROPERTY_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Eigenschaft referenziert. D nonNegativeInteger
P
M [0:999]
VALUE Restriction of xs:string required

Mit diesem Attribut wird der Wert zur Eigenschaft angegeben.

 D string
P ([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)
M
Quelle
<xs:element name="PROPERTY_REF" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Propertyzuordnung für Energieinfo 23.06.2014/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PROPERTY_NO" use="required">
      <xs:annotation>
        <xs:documentation>Nummer der Property, K. Richter 2.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="VALUE" use="required">
      <xs:annotation>
        <xs:documentation>Wert für Property K. Richter 23.06.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="([3-9]?[A-Z]+\+*)|([0-9]+(\.[0-9]+)?)" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PROPERTIES Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ECO_MOBILIER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ECO_MOBILIER Element
Beschreibung

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

D string P [0-9]{11} M [11:11]

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ECO_MOBILIER Element
Overview
ECO_MOBILIER optional Restriction of xs:string

Bei dem 11-stelligen Code handelt es sich um eine von Eco-mobilier erstellte Nomenklatur zur Einteilung der Einrichtungsgegenstände nach den Eigenschaften, deren Angabe von der französischen Agentur für Umwelt und Energiewirtschaft (ADEME) und von Eco-mobilier vorschriftsmäßig gefordert wird.

Um die für die Mitteilung notwendigen Produktcodes zu bestimmen, muss der auf der Internetseite von Eco-mobilier verfügbare Simulator verwendet werden. Zur Veranschaulichung ist nachstehend dargestellt, wie sich der Produktcode zusammensetzt:

D string P [0-9]{11} M [11:11]

Informationen erhält man z.B. über folgenden Link:

http://www.eco-mobilier.fr/sites/default/files/resources/guide_des_ecoparticipations_2016.pdf

bzw.

http://www.eco-mobilier.fr/sites/default/files/resources/20150929_baremedimensiondesecoparticipationsallemand_7_1.pdf

Quelle
<xs:element name="ECO_MOBILIER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9]{11}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PACKAGE_LIST Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PACKAGE_LIST Element
Beschreibung

Dieses Element dient der Angabe der Packstücke pro Artikel. Dabei ist keine Packstückoptimierung auf Grund von Kaufvorgängen möglich.

Pro Packstück müssen Breite, Tiefe, Höhe ganzzahlig in mm angegeben werden. Die Angabe des Gewichtes erfolgt dezimal in kg.

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Namensraum (none)
Diagramm
PACKAGE_LIST_POS Element Sequence PACKAGE_LIST Element
Overview
PACKAGE_LIST optional

Dieses Element dient der Angabe der Packstücke pro Artikel. Dabei ist keine Packstückoptimierung auf Grund von Kaufvorgängen möglich.

Pro Packstück müssen Breite, Tiefe, Höhe ganzzahlig in mm angegeben werden. Die Angabe des Gewichtes erfolgt dezimal in kg.

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Sequence
PACKAGE_LIST_POS 1..∞
Hier werden die Eigenschaften eines Packstücks der Liste festgehalten.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Element dient der eindeutigen Nummerierung innerhalb der Liste . D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
Dieses Element enthält den Namen der Packstückliste.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
Hier erfolgt die Beschreibung der Packstückliste.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
WIDTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Breite angegeben.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Tiefe angegeben.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Höhe angegeben.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

Mit diesem Element wird das Gewicht angegeben.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

Mit diesem Element wird die EAN-Nummer angegeben.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

Mit diesem Element wird die Material-Nummer angegeben.

 D string
P
M [1:15]
DECISIONS optional

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Dieses Element dient der Referenzierung von Regeln.

Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Packstückliste zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="PACKAGE_LIST" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="WIDTH">
              <xs:annotation>
                <xs:documentation>400--20--Gewicht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPTH">
              <xs:annotation>
                <xs:documentation>400--20--Gewicht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEIGHT">
              <xs:annotation>
                <xs:documentation>400--20--Gewicht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="WEIGHT" type="xs:decimal">
              <xs:annotation>
                <xs:documentation>400--20--Gewicht</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="EAN_NUMBER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MATERIAL_NUMBER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--11--EAN_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PACKAGE_LIST_POS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element : PACKAGE_LIST_POS Element
Beschreibung
Hier werden die Eigenschaften eines Packstücks der Liste festgehalten.
Namensraum (none)
Diagramm
DECISIONS Element MATERIAL_NUMBER Element EAN_NUMBER Element WEIGHT Element HEIGHT Element DEPTH Element WIDTH Element LANGUAGE Element Sequence PACKAGE_LIST_COMMENT_TEXT Element LANGUAGE Element Sequence PACKAGE_LIST_TEXT Element Sequence PACKAGE_LIST_POS Element
Overview
PACKAGE_LIST_POS 1..∞
Hier werden die Eigenschaften eines Packstücks der Liste festgehalten.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Element dient der eindeutigen Nummerierung innerhalb der Liste . D positiveInteger
P
M
Sequence
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
Dieses Element enthält den Namen der Packstückliste.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
Hier erfolgt die Beschreibung der Packstückliste.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
WIDTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Breite angegeben.

 D nonNegativeInteger
P
M [0:9999]
DEPTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Tiefe angegeben.

 D nonNegativeInteger
P
M [0:9999]
HEIGHT Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Höhe angegeben.

 D nonNegativeInteger
P
M [0:9999]
WEIGHT xs:decimal

Mit diesem Element wird das Gewicht angegeben.

 D decimal
P
M
EAN_NUMBER optional Restriction of xs:string

Mit diesem Element wird die EAN-Nummer angegeben.

 D string
P
M [1:15]
MATERIAL_NUMBER optional Restriction of xs:string

Mit diesem Element wird die Material-Nummer angegeben.

 D string
P
M [1:15]
DECISIONS optional

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Dieses Element dient der Referenzierung von Regeln.

Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Packstückliste zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE_NO Restriction of xs:positiveInteger required
Dieses Element dient der eindeutigen Nummerierung innerhalb der Liste . D positiveInteger
P
M
Quelle
<xs:element name="PACKAGE_LIST_POS" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="WIDTH">
        <xs:annotation>
          <xs:documentation>400--20--Gewicht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPTH">
        <xs:annotation>
          <xs:documentation>400--20--Gewicht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT">
        <xs:annotation>
          <xs:documentation>400--20--Gewicht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="WEIGHT" type="xs:decimal">
        <xs:annotation>
          <xs:documentation>400--20--Gewicht</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="EAN_NUMBER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MATERIAL_NUMBER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--11--EAN_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PACKAGE_LIST_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : PACKAGE_LIST_TEXT Element
Beschreibung
Dieses Element enthält den Namen der Packstückliste.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence PACKAGE_LIST_TEXT Element
Overview
PACKAGE_LIST_TEXT optional languagetext60 Complex Type
Dieses Element enthält den Namen der Packstückliste.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="PACKAGE_LIST_TEXT" type="languagetext60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PACKAGE_LIST_COMMENT_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : PACKAGE_LIST_COMMENT_TEXT Element
Beschreibung
Hier erfolgt die Beschreibung der Packstückliste.
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence PACKAGE_LIST_COMMENT_TEXT Element
Overview
PACKAGE_LIST_COMMENT_TEXT optional languagetext Complex Type
Hier erfolgt die Beschreibung der Packstückliste.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="PACKAGE_LIST_COMMENT_TEXT" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WIDTH Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : WIDTH Element
Beschreibung

Mit diesem Element wird die Breite angegeben.

 D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
WIDTH Element
Overview
WIDTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Breite angegeben.

 D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="WIDTH" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DEPTH Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : DEPTH Element
Beschreibung

Mit diesem Element wird die Tiefe angegeben.

 D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
DEPTH Element
Overview
DEPTH Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Tiefe angegeben.

 D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="DEPTH" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

HEIGHT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : HEIGHT Element
Beschreibung

Mit diesem Element wird die Höhe angegeben.

 D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
HEIGHT Element
Overview
HEIGHT Restriction of xs:nonNegativeInteger

Mit diesem Element wird die Höhe angegeben.

 D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="HEIGHT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WEIGHT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : WEIGHT Element
Beschreibung

Mit diesem Element wird das Gewicht angegeben.

 D decimal
P
M
Namensraum (none)
Typ
xs:decimal
Diagramm
WEIGHT Element
Overview
WEIGHT xs:decimal

Mit diesem Element wird das Gewicht angegeben.

 D decimal
P
M
Quelle
<xs:element name="WEIGHT" type="xs:decimal" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--20--Gewicht</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation xml:lang="de">Gewicht-Brutto IDM 21-Build 15</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

EAN_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : EAN_NUMBER Element
Beschreibung

Mit diesem Element wird die EAN-Nummer angegeben.

 D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EAN_NUMBER Element
Overview
EAN_NUMBER optional Restriction of xs:string

Mit diesem Element wird die EAN-Nummer angegeben.

 D string
P
M [1:15]
Quelle
<xs:element name="EAN_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--11--EAN_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MATERIAL_NUMBER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : MATERIAL_NUMBER Element
Beschreibung

Mit diesem Element wird die Material-Nummer angegeben.

 D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MATERIAL_NUMBER Element
Overview
MATERIAL_NUMBER optional Restriction of xs:string

Mit diesem Element wird die Material-Nummer angegeben.

 D string
P
M [1:15]
Quelle
<xs:element name="MATERIAL_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--11--EAN_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element : DECISIONS Element
Beschreibung

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Dieses Element dient der Referenzierung von Regeln.

Namensraum (none)
Diagramm
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional

Die Packstücke können regelbasiert sein, das heißt von Varianten abhängig, z. B. wenn Schubladen oder Spiegel als Variante hinzugefügt werden, bedeutet das auch ein neues Packstück. Die Ausprägung einer Variante für ein neues Packstück soll nur bei einfachen Fällen genutzt werden. Damit kann jedes Element der Liste der Packstücke auch Regeln referenzieren.

Dieses Element dient der Referenzierung von Regeln.

Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Packstückliste zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PACKAGE_LIST Element > PACKAGE_LIST_POS Element > DECISIONS Element : DECISION_REF Element
Beschreibung
Dieses Element referenziert eine der Packstückliste zugeordnete Regel.
Namensraum (none)
Diagramm
DECISION_REF Element
Overview
DECISION_REF 1..∞
Dieses Element referenziert eine der Packstückliste zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DECISION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DECISIONS Element | PACKAGE_LIST_POS Element | PACKAGE_LIST Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : DECISIONS Element
Beschreibung
In diesem Element werden Produktgruppen-spzezifische Regeln zusammengefasst.
Namensraum (none)
Diagramm
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional
In diesem Element werden Produktgruppen-spzezifische Regeln zusammengefasst.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine der Produktgruppe zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > DECISIONS Element : DECISION_REF Element
Beschreibung
Dieses Element referenziert eine der Produktgruppe zugeordnete Regel.
Namensraum (none)
Diagramm
DECISION_REF Element
Overview
DECISION_REF 1..∞
Dieses Element referenziert eine der Produktgruppe zugeordnete Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DECISION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DECISIONS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

COLOR_CONSULTANCIES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : COLOR_CONSULTANCIES Element
Beschreibung

In diesem Element werden Farbberatungen definiert.

Jede Farbberatung COLOR_CONSULTANCY enthält beliebig viele Referenzen auf Kombinationen von Detailinfos und Prüfungen FEATURE_DETAIL_INFO_REF, die durch SEQUENCE_NO sortiert sind. Die verwendeten Prüfungen müssen Farbvarianten enthalten.

Namensraum (none)
Diagramm
COLOR_CONSULTANCY Element Sequence COLOR_CONSULTANCIES Element
Overview
COLOR_CONSULTANCIES optional

In diesem Element werden Farbberatungen definiert.

Jede Farbberatung COLOR_CONSULTANCY enthält beliebig viele Referenzen auf Kombinationen von Detailinfos und Prüfungen FEATURE_DETAIL_INFO_REF, die durch SEQUENCE_NO sortiert sind. Die verwendeten Prüfungen müssen Farbvarianten enthalten.

Sequence
COLOR_CONSULTANCY 1..∞
Über dieses Element können Prüfungen direkt den Bildlayern zugeordnet werden.
Die verwendeten Prüfungen müssen Farbvarianten enthalten .
COLOR_CONSULTANCY_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Farbberatungsnummer definiert. D nonNegativeInteger
P
M [0:9999]
Sequence
FEATURE_DETAIL_INFO_REF 1..∞
Über dieses Element kann genau eine Prüfung oder Regel direkt den Bildlayern zugeordnet werden.
Dabei muss eine Farbvariantenart in der Prüfung bzw. Regel enthalten sein. Die Zuordnung erfolgt über DETAIL_INFO_NO, SEQUENCE_NO und RESTRICTION_NO oder DECISION_NO. Es kann entweder eine Prüfung (RESTRICTION) oder Regel (DECISION) zugeordnet werden.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Farbberatung. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Regel. D positiveInteger
P
M [1:9999999999]
Bemerkung

Quelle
<xs:element name="COLOR_CONSULTANCIES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="COLOR_CONSULTANCY" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke
                              </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>255--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DECISION_NO" use="optional">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="COLOR_CONSULTANCY_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

COLOR_CONSULTANCY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > COLOR_CONSULTANCIES Element : COLOR_CONSULTANCY Element
Beschreibung
Über dieses Element können Prüfungen direkt den Bildlayern zugeordnet werden.
Die verwendeten Prüfungen müssen Farbvarianten enthalten .
Namensraum (none)
Diagramm
FEATURE_DETAIL_INFO_REF Element Sequence COLOR_CONSULTANCY Element
Overview
COLOR_CONSULTANCY 1..∞
Über dieses Element können Prüfungen direkt den Bildlayern zugeordnet werden.
Die verwendeten Prüfungen müssen Farbvarianten enthalten .
COLOR_CONSULTANCY_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Farbberatungsnummer definiert. D nonNegativeInteger
P
M [0:9999]
Sequence
FEATURE_DETAIL_INFO_REF 1..∞
Über dieses Element kann genau eine Prüfung oder Regel direkt den Bildlayern zugeordnet werden.
Dabei muss eine Farbvariantenart in der Prüfung bzw. Regel enthalten sein. Die Zuordnung erfolgt über DETAIL_INFO_NO, SEQUENCE_NO und RESTRICTION_NO oder DECISION_NO. Es kann entweder eine Prüfung (RESTRICTION) oder Regel (DECISION) zugeordnet werden.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Farbberatung. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Regel. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
COLOR_CONSULTANCY_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Farbberatungsnummer definiert. D nonNegativeInteger
P
M [0:9999]
Bemerkung

Quelle
<xs:element name="COLOR_CONSULTANCY" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke
                              </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>255--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>270--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DECISION_NO" use="optional">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="COLOR_CONSULTANCY_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
COLOR_CONSULTANCIES Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > COLOR_CONSULTANCIES Element > COLOR_CONSULTANCY Element : FEATURE_DETAIL_INFO_REF Element
Beschreibung
Über dieses Element kann genau eine Prüfung oder Regel direkt den Bildlayern zugeordnet werden.
Dabei muss eine Farbvariantenart in der Prüfung bzw. Regel enthalten sein. Die Zuordnung erfolgt über DETAIL_INFO_NO, SEQUENCE_NO und RESTRICTION_NO oder DECISION_NO. Es kann entweder eine Prüfung (RESTRICTION) oder Regel (DECISION) zugeordnet werden.
Namensraum (none)
Diagramm
FEATURE_DETAIL_INFO_REF Element
Overview
FEATURE_DETAIL_INFO_REF 1..∞
Über dieses Element kann genau eine Prüfung oder Regel direkt den Bildlayern zugeordnet werden.
Dabei muss eine Farbvariantenart in der Prüfung bzw. Regel enthalten sein. Die Zuordnung erfolgt über DETAIL_INFO_NO, SEQUENCE_NO und RESTRICTION_NO oder DECISION_NO. Es kann entweder eine Prüfung (RESTRICTION) oder Regel (DECISION) zugeordnet werden.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Farbberatung. D positiveInteger
P
M
DECISION_NO optional Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Regel. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
SEQUENCE_NO Restriction of xs:positiveInteger required
Dieses Attribut definiert die Reihenfolge der Farbberatung. D positiveInteger
P
M
DECISION_NO Restriction of xs:positiveInteger optional
Dieses Attribut referenziert eine Regel. D positiveInteger
P
M [1:9999999999]
Bemerkung

Quelle
<xs:element name="FEATURE_DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                          30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>270--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DECISION_NO" use="optional">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
COLOR_CONSULTANCY Element | COLOR_CONSULTANCIES Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : DETAIL_INFOS Element
Beschreibung
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Bemerkung

Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Bemerkung

Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum an, ab dem die Serie lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem die Serie lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element : DECISIONS Element
Beschreibung
In diesem Element werden Serien-übergreifende Regeln gesammelt.
Namensraum (none)
Diagramm
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional
In diesem Element werden Serien-übergreifende Regeln gesammelt.
Sequence
DECISION_REF 1..∞
Dieses Element referenziert eine Serie-übergreifende Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > DECISIONS Element : DECISION_REF Element
Beschreibung
Dieses Element referenziert eine Serie-übergreifende Regel.
Namensraum (none)
Diagramm
DECISION_REF Element
Overview
DECISION_REF 1..∞
Dieses Element referenziert eine Serie-übergreifende Regel.
DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DECISION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DECISIONS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE_GROUPS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element : SERIE_GROUPS Element
Beschreibung
Dieses Element gibt die Möglichkeit verschiedene Serien in Gruppen (Modellgruppen) zusammenzufassen.
Namensraum (none)
Diagramm
SERIE_GROUP Element Sequence SERIE_GROUPS Element
Overview
SERIE_GROUPS optional
Dieses Element gibt die Möglichkeit verschiedene Serien in Gruppen (Modellgruppen) zusammenzufassen.
Sequence
SERIE_GROUP 1..∞
Hier wird eine Modellgruppe (Gruppierung von mehreren Serien) definiert.
SERIE_GROUP_KEY required Restriction of xs:string

Durch dieses Attribut werden Sereiengruppen/Modellgruppen eindeutig identifiziert.

 D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger

Dieses Attribut gibt die Möglichkeit, Seriengruppen mit einer selbstdefinierten Sortierreihenfolge anzulegen.

 D nonNegativeInteger
P
M
Sequence
SERIE_REF 1..∞
Mit diesem Element werden Serien referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Serie referenziert. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut definiert die Reihenfolge der Serien innerhalb der Sereingruppe. D nonNegativeInteger
P
M
SERIE_GROUP_TEXT languagetext60 Complex Type
In diesem Element wird die Bezeichnung ser Sereingruppe/Modellgruppe hinterlegt.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="SERIE_GROUPS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
Möglichkeit Serien zu gruppieren und auch ein Bild zu hinterlegen</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE_GROUP" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SERIE_GROUP_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_GROUP_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
              <xs:documentation>geändert auf SERIE_GROUP_KEY, K.Richter 23.11.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE_GROUPS Element : SERIE_GROUP Element
Beschreibung
Hier wird eine Modellgruppe (Gruppierung von mehreren Serien) definiert.
Namensraum (none)
Diagramm
DETAIL_INFOS Element LANGUAGE Element Sequence SERIE_GROUP_TEXT Element SERIE_REF Element Sequence SERIE_GROUP Element
Overview
SERIE_GROUP 1..∞
Hier wird eine Modellgruppe (Gruppierung von mehreren Serien) definiert.
SERIE_GROUP_KEY required Restriction of xs:string

Durch dieses Attribut werden Sereiengruppen/Modellgruppen eindeutig identifiziert.

 D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger

Dieses Attribut gibt die Möglichkeit, Seriengruppen mit einer selbstdefinierten Sortierreihenfolge anzulegen.

 D nonNegativeInteger
P
M
Sequence
SERIE_REF 1..∞
Mit diesem Element werden Serien referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Serie referenziert. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut definiert die Reihenfolge der Serien innerhalb der Sereingruppe. D nonNegativeInteger
P
M
SERIE_GROUP_TEXT languagetext60 Complex Type
In diesem Element wird die Bezeichnung ser Sereingruppe/Modellgruppe hinterlegt.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_GROUP_KEY Restriction of xs:string required

Durch dieses Attribut werden Sereiengruppen/Modellgruppen eindeutig identifiziert.

 D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional

Dieses Attribut gibt die Möglichkeit, Seriengruppen mit einer selbstdefinierten Sortierreihenfolge anzulegen.

 D nonNegativeInteger
P
M
Quelle
<xs:element name="SERIE_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIE_GROUP_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_GROUP_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
        <xs:documentation>geändert auf SERIE_GROUP_KEY, K.Richter 23.11.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE_GROUPS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE_GROUPS Element > SERIE_GROUP Element : SERIE_REF Element
Beschreibung
Mit diesem Element werden Serien referenziert.
Namensraum (none)
Diagramm
SERIE_REF Element
Overview
SERIE_REF 1..∞
Mit diesem Element werden Serien referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Serie referenziert. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut definiert die Reihenfolge der Serien innerhalb der Sereingruppe. D nonNegativeInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Serie referenziert. D nonNegativInteger
P
M [0:999999]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional
Dieses Attribut definiert die Reihenfolge der Serien innerhalb der Sereingruppe. D nonNegativeInteger
P
M
Quelle
<xs:element name="SERIE_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE_GROUP Element | SERIE_GROUPS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE_GROUP_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE_GROUPS Element > SERIE_GROUP Element : SERIE_GROUP_TEXT Element
Beschreibung
In diesem Element wird die Bezeichnung ser Sereingruppe/Modellgruppe hinterlegt.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence SERIE_GROUP_TEXT Element
Overview
SERIE_GROUP_TEXT languagetext60 Complex Type
In diesem Element wird die Bezeichnung ser Sereingruppe/Modellgruppe hinterlegt.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="SERIE_GROUP_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
SERIE_GROUP Element | SERIE_GROUPS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE_GROUPS Element > SERIE_GROUP Element : DETAIL_INFOS Element
Beschreibung
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS 0..∞
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE_GROUP Element | SERIE_GROUPS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > SERIES Element > SERIE_GROUPS Element > SERIE_GROUP Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
Dieses Attribut referenziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | SERIE_GROUP Element | SERIE_GROUPS Element | SERIES Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PART_LISTS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : PART_LISTS Element
Beschreibung

Dieses Element dient dem Aufbau von dynamischen Stücklisten, wobei die Unterpositionen Regeln tragen können, die variantenabhängig bestimmen, in welcher Anzahl die jeweilige Position in der Stückliste vorhanden ist.

Es sind nur Artikel einer entsprechenden Serie oder Artikel der Serie 0 enthalten.

Ein enthaltener Artikel kann wiederum eine Stückliste beinhalten.

Der Artikel, der eine Stückliste enthält, vererbt seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleichen Variantenarten (FEATURES) tragen.

Namensraum (none)
Diagramm
PART_LIST Element Sequence PART_LISTS Element
Overview
PART_LISTS optional

Dieses Element dient dem Aufbau von dynamischen Stücklisten, wobei die Unterpositionen Regeln tragen können, die variantenabhängig bestimmen, in welcher Anzahl die jeweilige Position in der Stückliste vorhanden ist.

Es sind nur Artikel einer entsprechenden Serie oder Artikel der Serie 0 enthalten.

Ein enthaltener Artikel kann wiederum eine Stückliste beinhalten.

Der Artikel, der eine Stückliste enthält, vererbt seine Varianten (OPTIONS) an die Unterpositionen, wenn diese in der zur jeweiligen Unterposition zugehörigen Variantenfamilie gleichen Variantenarten (FEATURES) tragen.

Sequence
PART_LIST 1..∞
In diesem Element wird eine Stückliste definiert.
PART_LIST_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Stückliste referenziert. D string
P
M [1:30]
Sequence
PART_LIST_POS 1..∞
Dieses Element dient der Beschreibung der einzelnen Stücklistenpositionen.
Sequence
SEQUENCE_NO Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Stücklisten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D positiveInteger
P
M
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
DECISIONS optional

In diesem Element werden Regeln für die entsprechende Stücklistenposition gesammelt. Es beeinflusst damit die für diese Position verfügbaren Varianten und Maße..

Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

Sequence
DECISION_REF 1..∞

Dieses Element referenziert eine der Stücklistenposition entsprechende Regel und beeinflusst damit die für diese Position verfügbaren Varianten und Maße. Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
Dieses Element gibt die Anzahl des Artikels in der Stückliste an. D nonNegativeInteger
P
M [0:999999999]
DECISION_POS_COUNT optional

In diesem Element wird eine Regel angegeben, die den Mengenfaktor setzt. Es darf maximal eine davon pro Position geben. Diese Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

Sequence
DECISION_REF

Dieses Element referenziert eine Regel, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint. D positiveInteger
P
M [1:9999999999]
POS_INVISIBILITY Restriction of xs:integer

Dieses Element entspricht einem Kennzeichen, das der Artikel in der Bestellung enthalten sein muss, der Konfigurator sollte diese Position nicht anzeigen. Die Unsichtbarkeit gilt aber nur für die entsprechende Position, nicht für einen eventuell vorhandenen Unterbaum. Das heißt, diese muss für so einen Fall an jeder Unterposition ausgeprägt werden.

0 = sichtbar komplett

1 = gar nicht sichtbar

2= nur in EDI-Bestellung sichtbar, wenn der Artikel über eine Regel erzeugt wird

 D integer
P
M [0:2]
Quelle
<xs:element name="PART_LISTS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
dynamische Stückliste</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PART_LIST" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PART_LIST_POS" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation />
                <xs:documentation />
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SEQUENCE_NO">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">IDM-2.5
laufende Nummer der Position
bei Planungsvorschlägen sollte diese von links nach rechts gemäß der Planungsvariante geordnet sein</xs:documentation>
                      <xs:documentation xml:lang="DE" />
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DECISIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DECISION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>291--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="POS_COUNT_VALUE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Anzahl der Positionen gemäß der Einheit an den Stammdaten</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DECISION_POS_COUNT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">IDM 2.5
Entscheidungstabellen, die die Anzahl steuern.
Hier dürfen nur Decisions verwendet werden, die im Action_part die Anzahl steuern (set_pos_count).</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DECISION_REF">
                          <xs:annotation>
                            <xs:documentation />
                            <xs:documentation />
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="POS_INVISIBILITY">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">IDM 2.5 neu
0 = sichtbar komplett
1 = gar nicht sichtbar
2= nur in EDI-Bestellung sichtbar, wenn über Decisions gezogen wird</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PART_LIST_KEY" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:maxLength value="30" />
                <xs:minLength value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PART_LIST Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element : PART_LIST Element
Beschreibung
In diesem Element wird eine Stückliste definiert.
Namensraum (none)
Diagramm
PART_LIST_POS Element Sequence PART_LIST Element
Overview
PART_LIST 1..∞
In diesem Element wird eine Stückliste definiert.
PART_LIST_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Stückliste referenziert. D string
P
M [1:30]
Sequence
PART_LIST_POS 1..∞
Dieses Element dient der Beschreibung der einzelnen Stücklistenpositionen.
Sequence
SEQUENCE_NO Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Stücklisten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D positiveInteger
P
M
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
DECISIONS optional

In diesem Element werden Regeln für die entsprechende Stücklistenposition gesammelt. Es beeinflusst damit die für diese Position verfügbaren Varianten und Maße..

Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

Sequence
DECISION_REF 1..∞

Dieses Element referenziert eine der Stücklistenposition entsprechende Regel und beeinflusst damit die für diese Position verfügbaren Varianten und Maße. Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
Dieses Element gibt die Anzahl des Artikels in der Stückliste an. D nonNegativeInteger
P
M [0:999999999]
DECISION_POS_COUNT optional

In diesem Element wird eine Regel angegeben, die den Mengenfaktor setzt. Es darf maximal eine davon pro Position geben. Diese Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

Sequence
DECISION_REF

Dieses Element referenziert eine Regel, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint. D positiveInteger
P
M [1:9999999999]
POS_INVISIBILITY Restriction of xs:integer

Dieses Element entspricht einem Kennzeichen, das der Artikel in der Bestellung enthalten sein muss, der Konfigurator sollte diese Position nicht anzeigen. Die Unsichtbarkeit gilt aber nur für die entsprechende Position, nicht für einen eventuell vorhandenen Unterbaum. Das heißt, diese muss für so einen Fall an jeder Unterposition ausgeprägt werden.

0 = sichtbar komplett

1 = gar nicht sichtbar

2= nur in EDI-Bestellung sichtbar, wenn der Artikel über eine Regel erzeugt wird

 D integer
P
M [0:2]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PART_LIST_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Stückliste referenziert. D string
P
M [1:30]
Quelle
<xs:element name="PART_LIST" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PART_LIST_POS" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation />
          <xs:documentation />
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SEQUENCE_NO">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM-2.5
laufende Nummer der Position
bei Planungsvorschlägen sollte diese von links nach rechts gemäß der Planungsvariante geordnet sein</xs:documentation>
                <xs:documentation xml:lang="DE" />
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation> K. Richter 12.02.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DECISIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>291--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="POS_COUNT_VALUE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Anzahl der Positionen gemäß der Einheit an den Stammdaten</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DECISION_POS_COUNT" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM 2.5
Entscheidungstabellen, die die Anzahl steuern.
Hier dürfen nur Decisions verwendet werden, die im Action_part die Anzahl steuern (set_pos_count).</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_REF">
                    <xs:annotation>
                      <xs:documentation />
                      <xs:documentation />
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="POS_INVISIBILITY">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM 2.5 neu
0 = sichtbar komplett
1 = gar nicht sichtbar
2= nur in EDI-Bestellung sichtbar, wenn über Decisions gezogen wird</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PART_LIST_KEY" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:maxLength value="30" />
          <xs:minLength value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PART_LIST_POS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element : PART_LIST_POS Element
Beschreibung
Dieses Element dient der Beschreibung der einzelnen Stücklistenpositionen.
Namensraum (none)
Diagramm
POS_INVISIBILITY Element DECISION_POS_COUNT Element POS_COUNT_VALUE Element DECISIONS Element ITEM_REF Element SEQUENCE_NO Element Sequence PART_LIST_POS Element
Overview
PART_LIST_POS 1..∞
Dieses Element dient der Beschreibung der einzelnen Stücklistenpositionen.
Sequence
SEQUENCE_NO Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Stücklisten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D positiveInteger
P
M
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
DECISIONS optional

In diesem Element werden Regeln für die entsprechende Stücklistenposition gesammelt. Es beeinflusst damit die für diese Position verfügbaren Varianten und Maße..

Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

Sequence
DECISION_REF 1..∞

Dieses Element referenziert eine der Stücklistenposition entsprechende Regel und beeinflusst damit die für diese Position verfügbaren Varianten und Maße. Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
Dieses Element gibt die Anzahl des Artikels in der Stückliste an. D nonNegativeInteger
P
M [0:999999999]
DECISION_POS_COUNT optional

In diesem Element wird eine Regel angegeben, die den Mengenfaktor setzt. Es darf maximal eine davon pro Position geben. Diese Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

Sequence
DECISION_REF

Dieses Element referenziert eine Regel, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint. D positiveInteger
P
M [1:9999999999]
POS_INVISIBILITY Restriction of xs:integer

Dieses Element entspricht einem Kennzeichen, das der Artikel in der Bestellung enthalten sein muss, der Konfigurator sollte diese Position nicht anzeigen. Die Unsichtbarkeit gilt aber nur für die entsprechende Position, nicht für einen eventuell vorhandenen Unterbaum. Das heißt, diese muss für so einen Fall an jeder Unterposition ausgeprägt werden.

0 = sichtbar komplett

1 = gar nicht sichtbar

2= nur in EDI-Bestellung sichtbar, wenn der Artikel über eine Regel erzeugt wird

 D integer
P
M [0:2]
Quelle
<xs:element name="PART_LIST_POS" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation />
    <xs:documentation />
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SEQUENCE_NO">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM-2.5
laufende Nummer der Position
bei Planungsvorschlägen sollte diese von links nach rechts gemäß der Planungsvariante geordnet sein</xs:documentation>
          <xs:documentation xml:lang="DE" />
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation> K. Richter 12.02.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation> K. Richter 12.02.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>291--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="POS_COUNT_VALUE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Anzahl der Positionen gemäß der Einheit an den Stammdaten</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DECISION_POS_COUNT" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5
Entscheidungstabellen, die die Anzahl steuern.
Hier dürfen nur Decisions verwendet werden, die im Action_part die Anzahl steuern (set_pos_count).</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_REF">
              <xs:annotation>
                <xs:documentation />
                <xs:documentation />
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="POS_INVISIBILITY">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5 neu
0 = sichtbar komplett
1 = gar nicht sichtbar
2= nur in EDI-Bestellung sichtbar, wenn über Decisions gezogen wird</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SEQUENCE_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : SEQUENCE_NO Element
Beschreibung
Dieses Attribut gibt die Möglichkeit, Stücklisten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D positiveInteger
P
M
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
SEQUENCE_NO Element
Overview
SEQUENCE_NO Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Stücklisten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D positiveInteger
P
M
Quelle
<xs:element name="SEQUENCE_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM-2.5
laufende Nummer der Position
bei Planungsvorschlägen sollte diese von links nach rechts gemäß der Planungsvariante geordnet sein</xs:documentation>
    <xs:documentation xml:lang="DE" />
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : ITEM_REF Element
Beschreibung
Dieses Element dient der Referenzierung eines Artikels.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF
Dieses Element dient der Referenzierung eines Artikels.
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
SERIE_NO Restriction of xs:nonNegativeInteger required
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:99999]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation> K. Richter 12.02.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : DECISIONS Element
Beschreibung

In diesem Element werden Regeln für die entsprechende Stücklistenposition gesammelt. Es beeinflusst damit die für diese Position verfügbaren Varianten und Maße..

Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

Namensraum (none)
Diagramm
DECISION_REF Element Sequence DECISIONS Element
Overview
DECISIONS optional

In diesem Element werden Regeln für die entsprechende Stücklistenposition gesammelt. Es beeinflusst damit die für diese Position verfügbaren Varianten und Maße..

Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

Sequence
DECISION_REF 1..∞

Dieses Element referenziert eine der Stücklistenposition entsprechende Regel und beeinflusst damit die für diese Position verfügbaren Varianten und Maße. Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>291--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element > DECISIONS Element : DECISION_REF Element
Beschreibung

Dieses Element referenziert eine der Stücklistenposition entsprechende Regel und beeinflusst damit die für diese Position verfügbaren Varianten und Maße. Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

Namensraum (none)
Diagramm
DECISION_REF Element
Overview
DECISION_REF 1..∞

Dieses Element referenziert eine der Stücklistenposition entsprechende Regel und beeinflusst damit die für diese Position verfügbaren Varianten und Maße. Es darf hier keine Regel angegeben werden, die den Mengenfaktor setzt. Diese Regel wird über DECISION_POS_COUNT referenziert.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DECISION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>291--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DECISIONS Element | PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

POS_COUNT_VALUE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : POS_COUNT_VALUE Element
Beschreibung
Dieses Element gibt die Anzahl des Artikels in der Stückliste an. D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
POS_COUNT_VALUE Element
Overview
POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
Dieses Element gibt die Anzahl des Artikels in der Stückliste an. D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="POS_COUNT_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Anzahl der Positionen gemäß der Einheit an den Stammdaten</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_POS_COUNT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : DECISION_POS_COUNT Element
Beschreibung

In diesem Element wird eine Regel angegeben, die den Mengenfaktor setzt. Es darf maximal eine davon pro Position geben. Diese Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

Namensraum (none)
Diagramm
DECISION_REF Element Sequence DECISION_POS_COUNT Element
Overview
DECISION_POS_COUNT optional

In diesem Element wird eine Regel angegeben, die den Mengenfaktor setzt. Es darf maximal eine davon pro Position geben. Diese Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

Sequence
DECISION_REF

Dieses Element referenziert eine Regel, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISION_POS_COUNT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
Entscheidungstabellen, die die Anzahl steuern.
Hier dürfen nur Decisions verwendet werden, die im Action_part die Anzahl steuern (set_pos_count).</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_REF">
        <xs:annotation>
          <xs:documentation />
          <xs:documentation />
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element > DECISION_POS_COUNT Element : DECISION_REF Element
Beschreibung

Dieses Element referenziert eine Regel, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

Namensraum (none)
Diagramm
DECISION_REF Element
Overview
DECISION_REF

Dieses Element referenziert eine Regel, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint.

DECISION_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DECISION_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Regel referenziert, die den Mengenfaktor setzt. So eine Regel wird gesondert markiert über das Attribut DECISION_TYPE 3 (mit OPTION_COMBINATION/ACTIONS/SET_POS_COUNT_VALUE) und bestimmt, in welcher Anzahl in Abhängigkeit von möglichen Variantenkombinationen die Position erscheint. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DECISION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation />
    <xs:documentation />
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DECISION_POS_COUNT Element | PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

POS_INVISIBILITY Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PART_LISTS Element > PART_LIST Element > PART_LIST_POS Element : POS_INVISIBILITY Element
Beschreibung

Dieses Element entspricht einem Kennzeichen, das der Artikel in der Bestellung enthalten sein muss, der Konfigurator sollte diese Position nicht anzeigen. Die Unsichtbarkeit gilt aber nur für die entsprechende Position, nicht für einen eventuell vorhandenen Unterbaum. Das heißt, diese muss für so einen Fall an jeder Unterposition ausgeprägt werden.

0 = sichtbar komplett

1 = gar nicht sichtbar

2= nur in EDI-Bestellung sichtbar, wenn der Artikel über eine Regel erzeugt wird

 D integer
P
M [0:2]
Namensraum (none)
Typ
Restriction of xs:integer
Diagramm
POS_INVISIBILITY Element
Overview
POS_INVISIBILITY Restriction of xs:integer

Dieses Element entspricht einem Kennzeichen, das der Artikel in der Bestellung enthalten sein muss, der Konfigurator sollte diese Position nicht anzeigen. Die Unsichtbarkeit gilt aber nur für die entsprechende Position, nicht für einen eventuell vorhandenen Unterbaum. Das heißt, diese muss für so einen Fall an jeder Unterposition ausgeprägt werden.

0 = sichtbar komplett

1 = gar nicht sichtbar

2= nur in EDI-Bestellung sichtbar, wenn der Artikel über eine Regel erzeugt wird

 D integer
P
M [0:2]
Quelle
<xs:element name="POS_INVISIBILITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5 neu
0 = sichtbar komplett
1 = gar nicht sichtbar
2= nur in EDI-Bestellung sichtbar, wenn über Decisions gezogen wird</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PART_LIST_POS Element | PART_LIST Element | PART_LISTS Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_DEFINITION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : FEATURE_DEFINITION Element
Beschreibung
In diesem Element werden variantenabhängige Informationen hinterlegt.
Namensraum (none)
Diagramm
FORMULAS Element OPTION_GROUPS Element DECISIONS Element OPTION_DEFINITION Element FEATURES Element FEATURE_CLASSES Element Sequence FEATURE_DEFINITION Element
Overview
FEATURE_DEFINITION
In diesem Element werden variantenabhängige Informationen hinterlegt.
Sequence
FEATURE_CLASSES

In diesem Element werden Variantenarten zu Familien zusammengefasst. Mittels dieser Variantenfamilien können Plausibilitäts- und Vollständigkeitsprüfungen bezüglich der gültigen Variantenarten durchgeführt werden.

Die definierten Variantenfamilien(Pfad 1) können Serien oder Produktgruppen über FEATURE_CLASS_REF in SERIE und PRODUCT_GROUP zugeordnet werden. Zwischen Variantenfamilien auf Serien- oder Artikelebene besteht keine Beziehung hinsichtlich einer Priorität. Die Anzahl der an einem Artikel gültigen Variantenarten ergibt sich aus der Summe der Variantenarten, die in der Produktgruppe des Artikels deklariert sind.

Alle Variantenarten, die über die Elemente in PRICE_FEATURE_GROUP (Pfad 3), PRICE_FEATURE_BASE_PRICE_GROUP_REF (Pfad 4) und FINISH (Pfad 5) referenziert werden, müssen in der Variantenfamilie des Artikels enthalten sein.

Ebenso müssen die über die Elemente RESTRICTION_REF (Pfad 6) und RESTRICTION_REF (Pfad 8)verwendeten Variantenarten in der Variantenfamilie des Artikels enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
Pfad 2: FEATURE_DEFINITION/FEATURES
Pfad 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 6: SERIES/RESTRICTIONS/RESTRICTION_REF
Pfad 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS

Sequence
FEATURE_CLASS 1..∞
In diesem Element wird eine Variantenfamilie definiert
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Variantenfamilie identifiziert. D positiveInteger
P
M [1:9999999999]
Sequence
FEATURE_REF 1..∞
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Kissens keine Variantenarten für z. B. Fußformen enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:9999]
INVISIBLE optional xs:boolean
Ist der Wert von diesem Attribut wahr (bzw. 1), wird angegeben dass die entsprechende Variantenart unsichtbar ist. D boolean
P
M
.
FEATURES

In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten definiert. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Für einige Variantenarten werden die Kombinationen aus Ausführung und Farbe verwendet.

Variantenarten müssen dann immer paarweise angelegt werden. Zu den entsprechenden Ausführungsvariantenarten existiert die zugehörige Farbvariantenart und zu der Farbvariantenart existiert eine zugehörige Ausführungsvariantenart.

Variantenarten, die als unsichtbare Variantenarten deklariert sind, dürfen nicht in einer Variantenfamilie referenziert werden.

Alle Variantenarten, im Element FEATURES (Pfad 3), die nicht als unsichtbare Kopfvariantenart deklariert sind, müssen mindestens in einer Variantenfamilie referenziert werden.

Weitere Erläuterungen zu den Variantenarten sind zu finden in der Einleitung im Abschnitt " Variantenarten"
Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 3: FEATURE_DEFINITION

Sequence
FEATURE 1..∞
In diesem Element wird eine Variantart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:9999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. Dabei werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Einleitung: Tabelle Variantenarten gekennzeichnet durch Typ A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werden und haben Priorität gegenüber entsprechenden Farbvarianten.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
FORM_REF
Dieses Element referenziert eine Form

FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert. D string
P
M [1:5]
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Maßausprägung referenziert. D positiveInteger
P
M [1:99999]
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden. Es ist möglich einer Variante mehrere Detail-Infos zuzuordnen und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild/Medium nur in der entsprechenden Serie oder bei bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante oder
P = Positions-Variantenart
ist.
Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.

Mit "I" gekennzeichnete Variantenarten sind sichtbar und ergeben sich implizit aus anderen Variantenarten. 		D string
P [IKP]
M [1:1]
FEATURE_TYPE
Dieses Element dient der Kennzeichnung, welchem Variantentyp die Variantenart entspricht. Eine Varintenart kann Maßvarianten (Wert von FEATURE_T "M"), Farbvarianten (Wert von FEATURE_T "C") oder anderen Variantentypen (Wert von FEATURE_T "O") zugeordnet werden.
FEATURE_T optional Restriction of xs:string

Mit diesem Attribut wird für der der Variantenart zugeordneten Varianten entsprechende Variantentyp definiert.

M = Maßvarianten

C = Farbvarianten

O = andere Varianten

 D string
P [MCO]
M [1:1]
Sequence
MEASURE optional

Falls die der Variantenart zugeordneten Varianten Maßvarianten sind, werden in diesem Element die Maßinformationen eingetragen.

Diese bestehen aus einem Maßparameter und der Maßeinheit und können dann z. B. in Formeln der Regeln (DECISIONS) genutzt werden.

Sequence
MEASURE_UNIT xs:string
In diesem Element wird die Maßeinheit hinterlegt. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

In diesem Element werden die Parameter hinterlegt, die der Definition einer Formel dienen, z. B. Planungsbreite =2*st + sb, wobei st für Seitenteilbreite und sb für Sitzbreite als Parameter stehen.

 D string
P
M
OPTION_DEFINITION optional
In diesem Element werden die Ausprägungen von Farben, Materialien, und Maßen definiert.
Sequence
MATERIAL 0..∞
In diesem Element wird ein Material definiert.

Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante ( gekennzeichnet durch A), dann dürfen weder eine Textur (TEXTURE) noch Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material identifiziert. D string
P
M [1:5]
Sequence
COLOR
In diesem Element werden Farben definiert.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
OPTION_MEASURE 0..∞
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Rücken-, Sitzkissenhöhe).
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine maßliche Ausprägung identifiziert. D positiveInteger
P
M [1:99999]
Sequence
MEASURE_VALUE Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß angegeben. D nonNegativeInteger
P
M [0:999999999]
MEASURE_UNIT xs:string
In diesem Element wird die Einheit angegeben. D string
P
M
DECISIONS optional
In diesem Element werden Regeln für Varianten und Variantenarten formuliert.
Sequence
DECISION 1..99999

In diesem Element wird eine Regel definiert und beschrieben, die technisch machbare Konfigurationen abbildet.
Eine Zuordnung der Regeln zu Serien oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Regeln entweder aus Serien oder Artikeln referenziert werden.

Abhängig von dem Attribut DECISION_TYPE können unterschiedliche Regeln formuliert werden.

Ist der Wert von DECISION_TYPE 0 oder1, handelt es sich um eine Vorbereitungsregel (Preparation Rule).

Hierüber können nun Mengen von ungültigen bzw. gültigen Varianten in OPTION_COMBINATION definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

Die Bedingungen wurden um Operatoren ergänzt. Hierfür wurde ein extra Datentyp operator definiert. Dieser kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Die einzelnen OPTION_COMBINATIONs sind als ELSE-Zweige zu betrachten. Das heißt, sobald eine Bedingungszeile (OPTION_COMBINATION) einen Treffer bekommen hat, werden die anderen nicht mehr durchlaufen.

Ist der Wert von DECISION_TYPE 2, handelt es sich um eine Ausführungsregel (Action Rule). Hier können abhängig von den Bedingungen noch Aktionen definiert werden.

Wenn alle Bedingungen innerhalb einer „OPTION_COMBINATION“ erfüllt sind, dann werden alle zugeordneten Aktionen (ACTIONS) ausgeführt, die abhängig von Bedingungen Werte setzen oder auch Variantenarten (FEATURES) ausblenden können. Ist eine OPTION_COMBINATION erfüllt, werden auch hier die anderen Bedingungen nicht mehr durchlaufen.

Aktionen (ACTIONS)

sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

    Das Setzen von Varianten ( SET_FEATURE_FIXED ) mit folgenden Möglichkeiten:

      - Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

      - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

      - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
      Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
      Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
      Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

        Das Setzen von Standardvarianten ( SET_FEATURE_DEFAULT , SET_FEATURE_DEFAULT_NULL ):
        Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

            Die Sichtbarkeit von Variantenarten ( SET_FEATURE_VISIBLE , SET_FEATURE_INVISIBLE ) bzw. das Wegschalten von Regeln ( DISABLE_DECISION , ENABLE_DECISION ):
            So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

              Ausführungsregeln werden im Konfigurator meistens genutzt, wenn sich ein Optionswert (eine Variante) ändert. So kann z.B. dann, wenn sich die Fußvariante von Edelstahl auf Holz ändert, eine Variantenart für den Beizton angezeigt werden.

              Ist der Wert von DECISION_TYPE 3, handelt es sich um eine Ausführungsregel (Action Rule) für Stücklisten.. Hier kann abhängig von den Bedingungen noch anzahl in der Stückliste definiert werden.

              DECISION_NO required Restriction of xs:positiveInteger
              Mit diesem Attribut wird die Regel identifiziert. D positiveInteger
              P
              M [1:9999999999]
              DECISION_TYPE required Restriction of xs:int

              Mit diesem Attribut wird der Typ einer Regel angegeben.

              0 = ausschließende Vorbereitungsregel

              Hierüber können Mengen von ungültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die ungültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind

              1 = Vorbereitungsregel (PreparationRule)

              Hierüber können Mengen von gültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

              2 = Ausführungsregel (Action Rule)
              Hier können zusätzlich zu den Bedingungen noch Aktionen definiert werden.
              Die Regeln werden vor Eingabe einer Variante am Artikel ausgewertet.
              Wenn dann ein Wert ausgewählt wurde, greifen die Aktionsregeln, welche dann Werte setzen oder Variantenarten ausblenden können.
              Bei Action Rules greift immer die erste Zeile (OPTIONS_SET_REF), die zutrifft. In dem Fall werden alle zugehörigen ACTIONS ausgeführt.

              3 = Ausführungsregel für Anzahl in Stücklisten (PositionCounter Rule)

              Hier kann abhängig von den Bedingungen über die Aktion SET_POS_COUNT_VALUE die Anzahl in der Stückliste definiert werden.

                       D int
              P
              M [0-3]
              Sequence
              DECISION_NAME_TEXT languagetext60 Complex Type
              In diesem Element wird die Bezeichnung einer Regel hinterlegt.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
              P [\S ]{1,60}
              M [1:60]
              OPTION_COMBINATION 1..∞

              In diesem Element wird eine Variantenkombination gebildet, die mit bestimmten Bedingungen verknüpft ist.

              Ist der Wert von DECISION_TYPE 2 oder 3, können der Variantenkombination noch Aktionen (ACTIONS) zugeordnet werden.

              SEQUENCE required Restriction of xs:nonNegativeInteger
              Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. D nonNegativeInteger
              P
              M [1:99999]
              Sequence
              OPTIONS_SET_REF 0..∞

              Mit diesem Element wird auf die Variantenart referenziert und eine Regel für ihre Variantenausprägungen definiert. Die Regeln können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

              Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

              eq (ist gleich)

              ne (ist nicht gleich)

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              REF_LEVEL optional Restriction of xs:nonNegativeInteger
              In Stücklisten können Unterpositionen Variantenarten der Hauptposition (PARENT), der obersten Position (ROOT) und von dem Artikel selbst (SELF) über den REF_LEVEL abfragen und abhängig davon eine Aktion auslösen oder diese in einer Bedingung integrieren.

              1 = ROOT

              2 = PARENT

              3 = SELF (Default ist SELF, wenn kein REF-Level angegeben ist)               		D nonNegativeInteger
              P
              M [1:3]
              Choice
              OPTION_INTERVAL
              Mit diesem Element wird überprüft ob eine Variante innerhalb oder außerhalb eines Intervall liegt.
              OPERATOR required Restriction of operator Simple Type

              Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

                       D operator
              P in|nin
              M
              OPTION_KEY_MIN required Restriction of xs:string

              Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

                       D string
              P
              M [1:30]
              OPTION_KEY_MAX required Restriction of xs:string
              Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
              P
              M [1:30]
              OPTION_LIST
              Mit diesem Element wird überprüft ob eine Variante einem Wert innerhalb einer Liste entspricht.
              OPERATOR required Restriction of operator Simple Type

              Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

                       D operator
              P in|nin
              M
              Sequence 1..∞
              OPTION_REF
              Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
              OPTION_GROUP_REF_OP
              Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
              OPTION_GROUP_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantengruppe referenziert. D string
              P
              M [1:30]
              OPERATOR required Restriction of operator Simple Type

              Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

                       D operator
              P in|nin
              M
              OPTION_REF_OP

              Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

              OPTION_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
              P
              M [1:30]
              OPERATOR required Restriction of operator Simple Type
              Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

                       D operator
              P eq|ne|gt|lt|ge|le
              M
              FEATURE_REF_OP

              Mit diesem Element kann direkt die Variantenart verglichen werden.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              OPERATOR required Restriction of operator Simple Type
              Mit diesem Attribut wird ein Vergleich mit einer Variantenart formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

                       D operator
              P eq|ne
              M
              MEASURE_VALUE_OP
              Mit diesem Element wird der Maßwert einer Variante mit einem weitern Maßwert überprüft.
              MEASURE_VALUE required xs:nonNegativeInteger

              Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

                       D nonNegativeInteger
              P
              M
              OPERATOR required Restriction of operator Simple Type
              Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

                       D operator
              P eq|ne|gt|lt|ge|le
              M
              MEASURE_INTERVAL
              Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
              OPERATOR required Restriction of operator Simple Type

              Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

                       D operator
              P in|nin
              M
              MEASURE_MIN required xs:nonNegativeInteger

              Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

                       D nonNegativeInteger
              P
              M
              MEASURE_MAX required xs:nonNegativeInteger
              Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
              P
              M
              ACTIONS optional

              Dieses Element dient der Festlegung von Aktionen, die bei bestimmten Bedingungen durchgeführt werden.

              Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

              • Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

              § Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

              § das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

              § das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
              Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
              Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

              • Das Setzen von Standardvarianten (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
                Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

              • Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
                So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

              Choice 1..∞
              SET_FEATURE_DEFAULT

              Mit dieser Aktion können Standardvarianten gesetzt werden.

              Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde.

              • Für das Setzen von Varianten gibt es folgende Möglichkeiten:

              - Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

              - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

              - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
              Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
              Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
              OPTION_REF
              Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt als Standard gesetzt wird.
              FORMULA_REF
              Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Standardwerten.
              SET_FEATURE_FIXED

              Mit dieser Aktion können Varianten gesetzt werden.

              Für das Setzen von Varianten gibt es folgende Möglichkeiten:

              - Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

              - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

              - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
              Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
              Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
              OPTION_REF
              Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
              FORMULA_REF
              Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
              ENABLE_DECISION

              Mit dieser Aktion können Regeln eingeschaltet werden.

              DECISION_NO optional Restriction of xs:positiveInteger
              Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
              P
              M [1:9999999999]
              DISABLE_DECISION

              Mit dieser Aktion können Regeln ausgeschaltet werden.

              DECISION_NO optional Restriction of xs:positiveInteger
              Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
              P
              M [1:9999999999]
              SET_FEATURE_VISIBLE
              Mit dieser Aktion können Variantenarten sichtbar gemacht werden.
              FEATURE_NO optional Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              SET_FEATURE_INVISIBLE
              Mit dieser Aktion können Variantenarten unsichtbar gemacht werden.
              FEATURE_NO optional Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              SET_FEATURE
              Mittels dieser Aktion kann ein Wert für eine Variante einer Variantenart gesetzt werden. Dieser Wert kann im Gegensatz zu „SET_FEATURE FIXED“ verändert werden, wenn die Bedingungen das zulassen. Diese Wertebelegung greift auch dann, wenn das entsprechende Feld vorher durch einen Default oder manuell belegt wurde.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
              OPTION_REF
              Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
              FORMULA_REF
              Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
              SET_FEATURE_DEFAULT_NULL

              Mit dieser Aktion können Standardvarianten gesetzt werden.

              Diese Vorbelegung greift nur wenn das entsprechende Variantenfeld vorher leer war.

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              Dieses Element referenziert auf eine andere Variantenart für das Setzen von NULL.
              OPTION_REF
              Mit diesem Element wird auf eine Variante (OPTION) referenziert, die auf NULL gesetzt wird.
              FORMULA_REF
              Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
              SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
              Mit diesem Element wird eine Anzahl in der Stückliste gesetzt.
              Diese Aktion darf nur bei Regeln mit DECISION_TYPE = 3 angegeben werden.               		D nonNegativeInteger
              P
              M [0:9999]
              SET_MESSAGE
              Dieses Element dient zum Setzen einer Nachricht, so dass bei bestimmten Variantenkombinationen Warnungen oder Hinweise ausgelöst werden können.
              MESSAGE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Nachricht referenziert. D nonNegativeInteger
              P
              M [0:999999]
              VALID_FROM optional Restriction of xs:date
              Dieses Element gibt das Datum an, ab dem eine Regel gültig ist.
              Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt.               		D date
              P
              M
              VALID_UNTIL optional Restriction of xs:date
              Dieses Element gibt das Datum an, bis zu welchem eine Regel gültig ist.
              Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.               		D date
              P
              M
              FEATURE_REF 0..∞
              Mit diesem Element wird auf die Variantenart referenziert.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              PRIO Restriction of xs:positiveInteger
              Dieses Element dient der Angabe eines Wertes für die Priorität einer Regel.
              Dabei stellt ein kleiner Wert ein hohe Priorität dar. Das heißt, je größer dieser Wert ist, desto schlechter ist der Vorrang dieser Regel.               		D positiveInteger
              P
              M [1:999999999]
              OPTION_GROUPS optional
              Dieses Element dient der Gruppierung von Mengen mehrerer Varianten. Sie können in den Prüfungen unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.
              Sequence
              OPTION_GROUP 1..∞

              Dieses Element dient zur Festlegung eine Variantengruppe.

              Sie kann in den Prüfungen unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.

              OPTION_GROUP_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantengruppe identifiziert. D string
              P
              M [1:30]
              Sequence
              OPTION 1..∞
              Mit diesem Element wird auf eine Variante referenziert.
              OPTION_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
              P
              M [1:30]
              SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
              Dieses Attribut definiert die Reihenfolge der Varianten in einer Variantengruppe D nonNegativeInteger
              P
              M
              OPTION_GROUP_TEXT languagetext60 Complex Type
              Dieses Element enthält Texte für Variantengruppen.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
              P [\S ]{1,60}
              M [1:60]
              FORMULAS optional
              Dieses Element steht für das Rechnen von Varianten (z.B. Sitzhöhe + 5cm) zur Verfügung. Die Funktion ist allerdings nur für Maßvarianten erlaubt, deren Variantenart den Wert ″M″ enthält, in dem Element MEASURE_UNIT die Maßeinheit und in MEASURE_PARAMETER der Parameter (z. B. sh für Sitzhöhe) eingetragen werden kann. Das Rechnen geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Sequence
              FORMULA 1..∞
              Das Element dient der Definition einer Formel. Das Attribut FORMULA_KEY enthält den Identifikator, das Element FORMULA_STRING die eigentliche Formel.
              FORMULA_KEY required Restriction of xs:string
              Mit diesem Attribut wird der Schlüssel für die Formel definiert. D string
              P
              M [1:30]
              Sequence
              FORMULA_STRING Restriction of xs:string
              Dieses Element dient der Angabe einer Formel. D string
              P [+\-*/()A-Za-z. ]{0,}
              M
              Bemerkung

              Quelle
              <xs:element name="FEATURE_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_CLASSES">
        <xs:annotation>
          <xs:documentation>255--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>255--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>255--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>255--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="INVISIBLE" type="xs:boolean">
                        <xs:annotation>
                          <xs:documentation xml:lang="de">neu 2.4 BA/07.03.2014
unsichtbare Variantenart.
Wird nicht im Konfigurator angezeigt.
</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_CLASS_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>255--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                    <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURES">
        <xs:annotation>
          <xs:documentation>250--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:choice minOccurs="0">
                                <xs:element name="MATERIAL_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MATERIAL_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="FORM_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="FORM_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="5" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_MEASURE_REF">
                                  <xs:annotation>
                                    <xs:documentation>260--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                              <xs:element name="OPTION_TEXT" type="languagetext60">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_FREETEXT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="SEQUENCE_NO">
                    <xs:annotation>
                      <xs:documentation>250--4--Sortierung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEADER_POS_VARIATION_TYPE">
                    <xs:annotation>
                      <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[IKP]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FEATURE_TYPE">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MEASURE" minOccurs="0">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="MEASURE_UNIT" type="xs:string">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="MEASURE_PARAMETER" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:maxLength value="20" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_T">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:length value="1" />
                            <xs:pattern value="[MCO]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>250--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="COLOR">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RGB_RED">
                          <xs:annotation>
                            <xs:documentation>260--11--RGB_Rot</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="255" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="RGB_GREEN">
                          <xs:annotation>
                            <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="255" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="RGB_BLUE">
                          <xs:annotation>
                            <xs:documentation>260--13--RGB_Blau</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="255" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="MATERIAL_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MEASURE_VALUE">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MEASURE_UNIT" type="xs:string">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPTION_MEASURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DECISIONS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>270/271--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>nicht zwingend anzugeben, K. Richter, 23.05.2014</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION" maxOccurs="99999">
              <xs:annotation>
                <xs:documentation>270/271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DECISION_NAME_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>270--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:complexType>
                            <xs:choice>
                              <xs:element name="OPTION_INTERVAL">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="in|nin" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY_MIN" use="required">
                                    <xs:annotation>
                                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY_MAX" use="required">
                                    <xs:annotation>
                                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_LIST">
                                <xs:complexType>
                                  <xs:sequence maxOccurs="unbounded">
                                    <xs:element name="OPTION_REF">
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="in|nin" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_GROUP_REF_OP">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="in|nin" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF_OP">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FEATURE_REF_OP">
                                <xs:annotation>
                                  <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
                                  <xs:documentation />
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="eq|ne" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="MEASURE_VALUE_OP">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                    </xs:annotation>
                                  </xs:attribute>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="MEASURE_INTERVAL">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="OPERATOR" use="required">
                                    <xs:annotation>
                                      <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="operator">
                                        <xs:pattern value="in|nin" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                    <xs:annotation>
                                      <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                    </xs:annotation>
                                  </xs:attribute>
                                  <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                    <xs:annotation>
                                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                    </xs:annotation>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="REF_LEVEL" use="optional">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
                                <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="3" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ACTIONS" minOccurs="0">
                          <xs:complexType>
                            <xs:choice maxOccurs="unbounded">
                              <xs:element name="SET_FEATURE_DEFAULT">
                                <xs:complexType>
                                  <xs:choice>
                                    <xs:element name="FEATURE_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF">
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FORMULA_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FORMULA_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_FEATURE_FIXED">
                                <xs:complexType>
                                  <xs:choice>
                                    <xs:element name="FEATURE_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF">
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FORMULA_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FORMULA_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ENABLE_DECISION">
                                <xs:complexType>
                                  <xs:attribute name="DECISION_NO">
                                    <xs:annotation>
                                      <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DISABLE_DECISION">
                                <xs:complexType>
                                  <xs:attribute name="DECISION_NO">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_FEATURE_VISIBLE">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_FEATURE_INVISIBLE">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_FEATURE">
                                <xs:complexType>
                                  <xs:choice>
                                    <xs:element name="FEATURE_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF">
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FORMULA_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FORMULA_KEY">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_FEATURE_DEFAULT_NULL">
                                <xs:complexType>
                                  <xs:choice>
                                    <xs:element name="FEATURE_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="9999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF">
                                      <xs:complexType>
                                        <xs:attribute name="OPTION_KEY">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FORMULA_REF">
                                      <xs:complexType>
                                        <xs:attribute name="FORMULA_KEY">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:choice>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="SET_POS_COUNT_VALUE">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                  <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                                  <xs:documentation>setzt Anzahl</xs:documentation>
                                  <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="SET_MESSAGE">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                  <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                                  <xs:documentation>setzt Anzahl</xs:documentation>
                                  <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="MESSAGE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                      <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                      <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FEATURE_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Entscheidungstabellen wieder entfernt, nur Angabe FEATURE_NO, 02.05.2014</xs:documentation>
                      <xs:documentation xml:lang="de">Version Beta 2.0 Build 12</xs:documentation>
                      <xs:documentation xml:lang="de">minimale Kardinalität auf 0 geändert K.Richter 18.07.2014</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRIO">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">neu IDM 2.4
Priorität von Prüfungen

Am Artikel können nur Decisions mit niedriger Priorität hinzu bzw. ausgeschaltet werden
Mehrere DECISIONS können auf einem gleichen Priolevel liegen

</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DECISION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DECISION_TYPE" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">IDM 2.4 Build 14 H.Balke 05.2014
0 = ausschließende (nicht erlaubende) Preparation
1 = Preparation
2 = action Rules
3 = action Rule mit SET_POS_COUNT_VALUE (setzt die Anzahl in der die Position in der Stückliste erscheint)

Restriktions werden vor Eingabe einer Variante am Artikel ausgewertet.
Wenn dann ein Wert ausgewählt wurde, greifen die action Rules, welche dann Werte setzen oder Variantenarten ausblenden können.
Bei Action Rules greift immer die erste Zeile (option combination), die zutrifft. In dem Fall werden alle zugehörigen Actions ausgeführt.
</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:int">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="3" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_GROUPS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_GROUP" maxOccurs="unbounded">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_GROUP_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPTION_GROUP_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORMULAS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="de">Formeln dürfen nur angewendet werden auf Maßvarianten </xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FORMULA" maxOccurs="unbounded">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FORMULA_STRING">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Formeln dürfen nur Parameter enthalten, die an der Variantenart definiert wurden.</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[+\-*/()A-Za-z0-9. ]*" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FORMULA_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
              T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_CLASSES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : FEATURE_CLASSES Element
Beschreibung

In diesem Element werden Variantenarten zu Familien zusammengefasst. Mittels dieser Variantenfamilien können Plausibilitäts- und Vollständigkeitsprüfungen bezüglich der gültigen Variantenarten durchgeführt werden.

Die definierten Variantenfamilien(Pfad 1) können Serien oder Produktgruppen über FEATURE_CLASS_REF in SERIE und PRODUCT_GROUP zugeordnet werden. Zwischen Variantenfamilien auf Serien- oder Artikelebene besteht keine Beziehung hinsichtlich einer Priorität. Die Anzahl der an einem Artikel gültigen Variantenarten ergibt sich aus der Summe der Variantenarten, die in der Produktgruppe des Artikels deklariert sind.

Alle Variantenarten, die über die Elemente in PRICE_FEATURE_GROUP (Pfad 3), PRICE_FEATURE_BASE_PRICE_GROUP_REF (Pfad 4) und FINISH (Pfad 5) referenziert werden, müssen in der Variantenfamilie des Artikels enthalten sein.

Ebenso müssen die über die Elemente RESTRICTION_REF (Pfad 6) und RESTRICTION_REF (Pfad 8)verwendeten Variantenarten in der Variantenfamilie des Artikels enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
Pfad 2: FEATURE_DEFINITION/FEATURES
Pfad 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 6: SERIES/RESTRICTIONS/RESTRICTION_REF
Pfad 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS

Namensraum (none)
Diagramm
FEATURE_CLASS Element Sequence FEATURE_CLASSES Element
Overview
FEATURE_CLASSES

In diesem Element werden Variantenarten zu Familien zusammengefasst. Mittels dieser Variantenfamilien können Plausibilitäts- und Vollständigkeitsprüfungen bezüglich der gültigen Variantenarten durchgeführt werden.

Die definierten Variantenfamilien(Pfad 1) können Serien oder Produktgruppen über FEATURE_CLASS_REF in SERIE und PRODUCT_GROUP zugeordnet werden. Zwischen Variantenfamilien auf Serien- oder Artikelebene besteht keine Beziehung hinsichtlich einer Priorität. Die Anzahl der an einem Artikel gültigen Variantenarten ergibt sich aus der Summe der Variantenarten, die in der Produktgruppe des Artikels deklariert sind.

Alle Variantenarten, die über die Elemente in PRICE_FEATURE_GROUP (Pfad 3), PRICE_FEATURE_BASE_PRICE_GROUP_REF (Pfad 4) und FINISH (Pfad 5) referenziert werden, müssen in der Variantenfamilie des Artikels enthalten sein.

Ebenso müssen die über die Elemente RESTRICTION_REF (Pfad 6) und RESTRICTION_REF (Pfad 8)verwendeten Variantenarten in der Variantenfamilie des Artikels enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURE_CLASSES/FEATURE_CLASS
Pfad 2: FEATURE_DEFINITION/FEATURES
Pfad 3: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 4: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Pfad 5: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP
Pfad 6: SERIES/RESTRICTIONS/RESTRICTION_REF
Pfad 8: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS

Sequence
FEATURE_CLASS 1..∞
In diesem Element wird eine Variantenfamilie definiert
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Variantenfamilie identifiziert. D positiveInteger
P
M [1:9999999999]
Sequence
FEATURE_REF 1..∞
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Kissens keine Variantenarten für z. B. Fußformen enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:9999]
INVISIBLE optional xs:boolean
Ist der Wert von diesem Attribut wahr (bzw. 1), wird angegeben dass die entsprechende Variantenart unsichtbar ist. D boolean
P
M
.
Bemerkung

Quelle
<xs:element name="FEATURE_CLASSES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_CLASS" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>255--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>255--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>255--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="INVISIBLE" type="xs:boolean">
                  <xs:annotation>
                    <xs:documentation xml:lang="de">neu 2.4 BA/07.03.2014
unsichtbare Variantenart.
Wird nicht im Konfigurator angezeigt.
</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_CLASS_NO" use="required">
            <xs:annotation>
              <xs:documentation>255--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_CLASS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURE_CLASSES Element : FEATURE_CLASS Element
Beschreibung
In diesem Element wird eine Variantenfamilie definiert
Namensraum (none)
Diagramm
FEATURE_REF Element Sequence FEATURE_CLASS Element
Overview
FEATURE_CLASS 1..∞
In diesem Element wird eine Variantenfamilie definiert
FEATURE_CLASS_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Variantenfamilie identifiziert. D positiveInteger
P
M [1:9999999999]
Sequence
FEATURE_REF 1..∞
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Kissens keine Variantenarten für z. B. Fußformen enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:9999]
INVISIBLE optional xs:boolean
Ist der Wert von diesem Attribut wahr (bzw. 1), wird angegeben dass die entsprechende Variantenart unsichtbar ist. D boolean
P
M
.
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_CLASS_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Variantenfamilie identifiziert. D positiveInteger
P
M [1:9999999999]
Bemerkung

Quelle
<xs:element name="FEATURE_CLASS" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>255--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>255--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="INVISIBLE" type="xs:boolean">
            <xs:annotation>
              <xs:documentation xml:lang="de">neu 2.4 BA/07.03.2014
unsichtbare Variantenart.
Wird nicht im Konfigurator angezeigt.
</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_CLASS_NO" use="required">
      <xs:annotation>
        <xs:documentation>255--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        <xs:documentation xml:lang="DE">Version 2.1 Build 7 für Polster erweitert auf 10 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_CLASSES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURE_CLASSES Element > FEATURE_CLASS Element : FEATURE_REF Element
Beschreibung
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Kissens keine Variantenarten für z. B. Fußformen enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Namensraum (none)
Diagramm
FEATURE_REF Element
Overview
FEATURE_REF 1..∞
Die Variantenart verweist auf das Element FEATURE (Pfad 1) .
In der Variantenfamilie eines Artikels dürfen nur sinnvolle Varianten referenziert werden. Beispielsweise darf in der Variantenfamilie eines Kissens keine Variantenarten für z. B. Fußformen enthalten sein.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:9999]
INVISIBLE optional xs:boolean
Ist der Wert von diesem Attribut wahr (bzw. 1), wird angegeben dass die entsprechende Variantenart unsichtbar ist. D boolean
P
M
.
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:9999]
INVISIBLE xs:boolean optional
Ist der Wert von diesem Attribut wahr (bzw. 1), wird angegeben dass die entsprechende Variantenart unsichtbar ist. D boolean
P
M
.
Bemerkung

Quelle
<xs:element name="FEATURE_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>255--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>255--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="INVISIBLE" type="xs:boolean">
      <xs:annotation>
        <xs:documentation xml:lang="de">neu 2.4 BA/07.03.2014
unsichtbare Variantenart.
Wird nicht im Konfigurator angezeigt.
</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_CLASS Element | FEATURE_CLASSES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : FEATURES Element
Beschreibung

In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten definiert. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Für einige Variantenarten werden die Kombinationen aus Ausführung und Farbe verwendet.

Variantenarten müssen dann immer paarweise angelegt werden. Zu den entsprechenden Ausführungsvariantenarten existiert die zugehörige Farbvariantenart und zu der Farbvariantenart existiert eine zugehörige Ausführungsvariantenart.

Variantenarten, die als unsichtbare Variantenarten deklariert sind, dürfen nicht in einer Variantenfamilie referenziert werden.

Alle Variantenarten, im Element FEATURES (Pfad 3), die nicht als unsichtbare Kopfvariantenart deklariert sind, müssen mindestens in einer Variantenfamilie referenziert werden.

Weitere Erläuterungen zu den Variantenarten sind zu finden in der Einleitung im Abschnitt " Variantenarten"
Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 3: FEATURE_DEFINITION

Namensraum (none)
Diagramm
FEATURE Element Sequence FEATURES Element
Overview
FEATURES

In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten definiert. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Kataloges erforderlich sind.

Für einige Variantenarten werden die Kombinationen aus Ausführung und Farbe verwendet.

Variantenarten müssen dann immer paarweise angelegt werden. Zu den entsprechenden Ausführungsvariantenarten existiert die zugehörige Farbvariantenart und zu der Farbvariantenart existiert eine zugehörige Ausführungsvariantenart.

Variantenarten, die als unsichtbare Variantenarten deklariert sind, dürfen nicht in einer Variantenfamilie referenziert werden.

Alle Variantenarten, im Element FEATURES (Pfad 3), die nicht als unsichtbare Kopfvariantenart deklariert sind, müssen mindestens in einer Variantenfamilie referenziert werden.

Weitere Erläuterungen zu den Variantenarten sind zu finden in der Einleitung im Abschnitt " Variantenarten"
Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES
Pfad 2: FEATURE_DEFINITION/FEATURES/FEATURE
Pfad 3: FEATURE_DEFINITION

Sequence
FEATURE 1..∞
In diesem Element wird eine Variantart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:9999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. Dabei werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Einleitung: Tabelle Variantenarten gekennzeichnet durch Typ A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werden und haben Priorität gegenüber entsprechenden Farbvarianten.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
FORM_REF
Dieses Element referenziert eine Form

FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert. D string
P
M [1:5]
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Maßausprägung referenziert. D positiveInteger
P
M [1:99999]
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden. Es ist möglich einer Variante mehrere Detail-Infos zuzuordnen und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild/Medium nur in der entsprechenden Serie oder bei bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
ITEM_REF 0..∞
In diesem Element wird ein Artikel referenziert.
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante oder
P = Positions-Variantenart
ist.
Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.

Mit "I" gekennzeichnete Variantenarten sind sichtbar und ergeben sich implizit aus anderen Variantenarten. 		D string
P [IKP]
M [1:1]
FEATURE_TYPE
Dieses Element dient der Kennzeichnung, welchem Variantentyp die Variantenart entspricht. Eine Varintenart kann Maßvarianten (Wert von FEATURE_T "M"), Farbvarianten (Wert von FEATURE_T "C") oder anderen Variantentypen (Wert von FEATURE_T "O") zugeordnet werden.
FEATURE_T optional Restriction of xs:string

Mit diesem Attribut wird für der der Variantenart zugeordneten Varianten entsprechende Variantentyp definiert.

M = Maßvarianten

C = Farbvarianten

O = andere Varianten

 D string
P [MCO]
M [1:1]
Sequence
MEASURE optional

Falls die der Variantenart zugeordneten Varianten Maßvarianten sind, werden in diesem Element die Maßinformationen eingetragen.

Diese bestehen aus einem Maßparameter und der Maßeinheit und können dann z. B. in Formeln der Regeln (DECISIONS) genutzt werden.

Sequence
MEASURE_UNIT xs:string
In diesem Element wird die Maßeinheit hinterlegt. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

In diesem Element werden die Parameter hinterlegt, die der Definition einer Formel dienen, z. B. Planungsbreite =2*st + sb, wobei st für Seitenteilbreite und sb für Sitzbreite als Parameter stehen.

 D string
P
M
Bemerkung

Quelle
<xs:element name="FEATURES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:choice minOccurs="0">
                          <xs:element name="MATERIAL_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MATERIAL_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="FORM_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="FORM_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="5" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_MEASURE_REF">
                            <xs:annotation>
                              <xs:documentation>260--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_MEASURE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:element name="OPTION_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_FREETEXT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="SEQUENCE_NO">
              <xs:annotation>
                <xs:documentation>250--4--Sortierung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEADER_POS_VARIATION_TYPE">
              <xs:annotation>
                <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[IKP]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FEATURE_TYPE">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MEASURE" minOccurs="0">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="MEASURE_UNIT" type="xs:string">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="MEASURE_PARAMETER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:maxLength value="20" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_T">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:length value="1" />
                      <xs:pattern value="[MCO]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>250--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element : FEATURE Element
Beschreibung
In diesem Element wird eine Variantart definiert.
Namensraum (none)
Diagramm
FEATURE_TYPE Element HEADER_POS_VARIATION_TYPE Element SEQUENCE_NO Element LANGUAGE Element Sequence FEATURE_TEXT Element OPTIONS Element Sequence FEATURE Element
Overview
FEATURE 1..∞
In diesem Element wird eine Variantart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:9999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. Dabei werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Einleitung: Tabelle Variantenarten gekennzeichnet durch Typ A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werden und haben Priorität gegenüber entsprechenden Farbvarianten.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
FORM_REF
Dieses Element referenziert eine Form

FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert. D string
P
M [1:5]
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Maßausprägung referenziert. D positiveInteger
P
M [1:99999]
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden. Es ist möglich einer Variante mehrere Detail-Infos zuzuordnen und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild/Medium nur in der entsprechenden Serie oder bei bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
In diesem Element wird ein Artikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der Serie des referenzierten Artikels angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
HEADER_POS_VARIATION_TYPE Restriction of xs:string
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante oder
P = Positions-Variantenart
ist.
Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.

Mit "I" gekennzeichnete Variantenarten sind sichtbar und ergeben sich implizit aus anderen Variantenarten. 		D string
P [IKP]
M [1:1]
FEATURE_TYPE
Dieses Element dient der Kennzeichnung, welchem Variantentyp die Variantenart entspricht. Eine Varintenart kann Maßvarianten (Wert von FEATURE_T "M"), Farbvarianten (Wert von FEATURE_T "C") oder anderen Variantentypen (Wert von FEATURE_T "O") zugeordnet werden.
FEATURE_T optional Restriction of xs:string

Mit diesem Attribut wird für der der Variantenart zugeordneten Varianten entsprechende Variantentyp definiert.

M = Maßvarianten

C = Farbvarianten

O = andere Varianten

 D string
P [MCO]
M [1:1]
Sequence
MEASURE optional

Falls die der Variantenart zugeordneten Varianten Maßvarianten sind, werden in diesem Element die Maßinformationen eingetragen.

Diese bestehen aus einem Maßparameter und der Maßeinheit und können dann z. B. in Formeln der Regeln (DECISIONS) genutzt werden.

Sequence
MEASURE_UNIT xs:string
In diesem Element wird die Maßeinheit hinterlegt. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

In diesem Element werden die Parameter hinterlegt, die der Definition einer Formel dienen, z. B. Planungsbreite =2*st + sb, wobei st für Seitenteilbreite und sb für Sitzbreite als Parameter stehen.

 D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:9999]
Bemerkung

Quelle
<xs:element name="FEATURE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:choice minOccurs="0">
                    <xs:element name="MATERIAL_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MATERIAL_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="FORM_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="FORM_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="5" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_MEASURE_REF">
                      <xs:annotation>
                        <xs:documentation>260--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_MEASURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:element name="OPTION_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_FREETEXT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="SEQUENCE_NO">
        <xs:annotation>
          <xs:documentation>250--4--Sortierung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEADER_POS_VARIATION_TYPE">
        <xs:annotation>
          <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[IKP]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FEATURE_TYPE">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MEASURE" minOccurs="0">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MEASURE_UNIT" type="xs:string">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="MEASURE_PARAMETER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_T">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:length value="1" />
                <xs:pattern value="[MCO]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>250--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : OPTIONS Element
Beschreibung
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Namensraum (none)
Diagramm
OPTION Element Sequence OPTIONS Element
Overview
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Das Element wird bei erbenden Variantenarten (HEADER_POS_VARIATION_TYPE=V) nicht angelegt.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. Dabei werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Einleitung: Tabelle Variantenarten gekennzeichnet durch Typ A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werden und haben Priorität gegenüber entsprechenden Farbvarianten.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
FORM_REF
Dieses Element referenziert eine Form

FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert. D string
P
M [1:5]
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Maßausprägung referenziert. D positiveInteger
P
M [1:99999]
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden. Es ist möglich einer Variante mehrere Detail-Infos zuzuordnen und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild/Medium nur in der entsprechenden Serie oder bei bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
In diesem Element wird ein Artikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der Serie des referenzierten Artikels angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
Bemerkung

Quelle
<xs:element name="OPTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:choice minOccurs="0">
              <xs:element name="MATERIAL_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="MATERIAL_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="FORM_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="FORM_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="5" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="OPTION_MEASURE_REF">
                <xs:annotation>
                  <xs:documentation>260--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="OPTION_MEASURE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:choice>
            <xs:element name="OPTION_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_FREETEXT" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element : OPTION Element
Beschreibung
In diesem Element werden die Varianten für Variantenart definiert. Dabei werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Einleitung: Tabelle Variantenarten gekennzeichnet durch Typ A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werden und haben Priorität gegenüber entsprechenden Farbvarianten.
Namensraum (none)
Diagramm
OPTION_FREETEXT Element DETAIL_INFOS Element VALID_UNTIL Element VALID_FROM Element LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element LANGUAGE Element Sequence OPTION_TEXT Element OPTION_MEASURE_REF Element FORM_REF Element MATERIAL_REF Element Choice Sequence OPTION Element
Overview
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. Dabei werden alle im Datenbestand benötigten Varianten abgelegt. Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante (Einleitung: Tabelle Variantenarten gekennzeichnet durch Typ A), dann dürfen weder eine Textur noch Farbwerte angegeben werden. Glanz und Transparenz können optional einer Ausführungsvariante zugeordnet werden und haben Priorität gegenüber entsprechenden Farbvarianten.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D nonNegativeInteger
P
M
Sequence
Choice optional
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
FORM_REF
Dieses Element referenziert eine Form

FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert. D string
P
M [1:5]
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Maßausprägung referenziert. D positiveInteger
P
M [1:99999]
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden. Es ist möglich einer Variante mehrere Detail-Infos zuzuordnen und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild/Medium nur in der entsprechenden Serie oder bei bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
In diesem Element wird ein Artikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der Serie des referenzierten Artikels angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen. D nonNegativeInteger
P
M
Bemerkung

Quelle
<xs:element name="OPTION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:choice minOccurs="0">
        <xs:element name="MATERIAL_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="MATERIAL_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="FORM_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="FORM_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="5" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="OPTION_MEASURE_REF">
          <xs:annotation>
            <xs:documentation>260--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="OPTION_MEASURE_NO" use="required">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:choice>
      <xs:element name="OPTION_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_FREETEXT" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MATERIAL_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : MATERIAL_REF Element
Beschreibung
Dieses Element referenziert ein Material.
Namensraum (none)
Diagramm
MATERIAL_REF Element
Overview
MATERIAL_REF
Dieses Element referenziert ein Material.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MATERIAL_NO Restriction of xs:string required
Mit diesem Attribut wird ein Material referenziert. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="MATERIAL_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MATERIAL_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : FORM_REF Element
Beschreibung
Dieses Element referenziert eine Form

Namensraum (none)
Diagramm
FORM_REF Element
Overview
FORM_REF
Dieses Element referenziert eine Form

FORM_NO required Restriction of xs:string
Mit diesem Attribut wird eine Profilform referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FORM_NO Restriction of xs:string required
Mit diesem Attribut wird eine Profilform referenziert. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="FORM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FORM_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_MEASURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_MEASURE_REF Element
Beschreibung
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert.
Namensraum (none)
Diagramm
OPTION_MEASURE_REF Element
Overview
OPTION_MEASURE_REF
Mit diesem Element wird eine maßliche Ausprägung einer Variantenart referenziert.
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Maßausprägung referenziert. D positiveInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_MEASURE_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine Maßausprägung referenziert. D positiveInteger
P
M [1:99999]
Bemerkung

Quelle
<xs:element name="OPTION_MEASURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_MEASURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_TEXT Element
Beschreibung
In diesem Element wird ein Variantentext definiert.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence OPTION_TEXT Element
Overview
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein Variantentext definiert.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="OPTION_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_COMMENT_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_COMMENT_TEXT Element
Beschreibung
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element
Overview
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_FROM Element
Beschreibung
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Bemerkung

Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_UNTIL Element
Beschreibung
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:
Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
Beide Elemente leer: uneingeschränkt lieferbar.
Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Bemerkung

Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFOS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : DETAIL_INFOS Element
Beschreibung
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden. Es ist möglich einer Variante mehrere Detail-Infos zuzuordnen und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild/Medium nur in der entsprechenden Serie oder bei bestimmten Artikel angezeigt.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
In diesem Element können mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks hinterlegt werden. Es ist möglich einer Variante mehrere Detail-Infos zuzuordnen und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild/Medium nur in der entsprechenden Serie oder bei bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
In diesem Element wird ein Artikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der Serie des referenzierten Artikels angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
Bemerkung

Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
ITEM_REF Element SERIE_REF Element Sequence DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
In diesem Element wird ein Artikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der Serie des referenzierten Artikels angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SERIE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element > DETAIL_INFO_REF Element : SERIE_REF Element
Beschreibung
In diesem Element wird die Serie referenziert.
Namensraum (none)
Diagramm
SERIE_REF Element
Overview
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFO_REF Element | DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ITEM_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element > DETAIL_INFO_REF Element : ITEM_REF Element
Beschreibung
In diesem Element wird ein Artikel referenziert.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF 0..∞
In diesem Element wird ein Artikel referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der Serie des referenzierten Artikels angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Identifikationsnummer der Serie des referenzierten Artikels angegeben. D nonNegativeInteger
P
M [0:999999]
TYPE_NO Restriction of xs:string required
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
Quelle
<xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFO_REF Element | DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_FREETEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_FREETEXT Element
Beschreibung
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
OPTION_FREETEXT Element
Overview
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
Quelle
<xs:element name="OPTION_FREETEXT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : FEATURE_TEXT Element
Beschreibung
Dieses Element enthält Texte für Variantenarten.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence FEATURE_TEXT Element
Overview
FEATURE_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="FEATURE_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SEQUENCE_NO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : SEQUENCE_NO Element
Beschreibung
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
SEQUENCE_NO Element
Overview
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten (HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ 		D nonNegativeInteger
P
M [0:999]
Bemerkung

Quelle
<xs:element name="SEQUENCE_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--4--Sortierung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

HEADER_POS_VARIATION_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : HEADER_POS_VARIATION_TYPE Element
Beschreibung
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante oder
P = Positions-Variantenart
ist.
Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.

Mit "I" gekennzeichnete Variantenarten sind sichtbar und ergeben sich implizit aus anderen Variantenarten. 		D string
P [IKP]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
HEADER_POS_VARIATION_TYPE Element
Overview
HEADER_POS_VARIATION_TYPE Restriction of xs:string
Dieses Element ist ein Kennzeichen, ob die Variantenart eine
I = Implizite Variantenart,
K = Kopfvariante oder
P = Positions-Variantenart
ist.
Es dient für die Steuerung der Verarbeitungsweise auf Kopf- oder Positionsebene; die mit "P" gekennzeichneten Variantenarten dürfen nach Herstellerangabe nicht auf Kopfebene verarbeitet werden.

Mit "I" gekennzeichnete Variantenarten sind sichtbar und ergeben sich implizit aus anderen Variantenarten. 		D string
P [IKP]
M [1:1]
Bemerkung

Quelle
<xs:element name="HEADER_POS_VARIATION_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--5--Kopf_Pos_Varianten_Art</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[IKP]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : FEATURE_TYPE Element
Beschreibung
Dieses Element dient der Kennzeichnung, welchem Variantentyp die Variantenart entspricht. Eine Varintenart kann Maßvarianten (Wert von FEATURE_T "M"), Farbvarianten (Wert von FEATURE_T "C") oder anderen Variantentypen (Wert von FEATURE_T "O") zugeordnet werden.
Namensraum (none)
Diagramm
MEASURE Element Sequence FEATURE_TYPE Element
Overview
FEATURE_TYPE
Dieses Element dient der Kennzeichnung, welchem Variantentyp die Variantenart entspricht. Eine Varintenart kann Maßvarianten (Wert von FEATURE_T "M"), Farbvarianten (Wert von FEATURE_T "C") oder anderen Variantentypen (Wert von FEATURE_T "O") zugeordnet werden.
FEATURE_T optional Restriction of xs:string

Mit diesem Attribut wird für der der Variantenart zugeordneten Varianten entsprechende Variantentyp definiert.

M = Maßvarianten

C = Farbvarianten

O = andere Varianten

 D string
P [MCO]
M [1:1]
Sequence
MEASURE optional

Falls die der Variantenart zugeordneten Varianten Maßvarianten sind, werden in diesem Element die Maßinformationen eingetragen.

Diese bestehen aus einem Maßparameter und der Maßeinheit und können dann z. B. in Formeln der Regeln (DECISIONS) genutzt werden.

Sequence
MEASURE_UNIT xs:string
In diesem Element wird die Maßeinheit hinterlegt. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

In diesem Element werden die Parameter hinterlegt, die der Definition einer Formel dienen, z. B. Planungsbreite =2*st + sb, wobei st für Seitenteilbreite und sb für Sitzbreite als Parameter stehen.

 D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_T Restriction of xs:string optional

Mit diesem Attribut wird für der der Variantenart zugeordneten Varianten entsprechende Variantentyp definiert.

M = Maßvarianten

C = Farbvarianten

O = andere Varianten

 D string
P [MCO]
M [1:1]
Quelle
<xs:element name="FEATURE_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MEASURE" minOccurs="0">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MEASURE_UNIT" type="xs:string">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="MEASURE_PARAMETER" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_T">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:length value="1" />
          <xs:pattern value="[MCO]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > FEATURE_TYPE Element : MEASURE Element
Beschreibung

Falls die der Variantenart zugeordneten Varianten Maßvarianten sind, werden in diesem Element die Maßinformationen eingetragen.

Diese bestehen aus einem Maßparameter und der Maßeinheit und können dann z. B. in Formeln der Regeln (DECISIONS) genutzt werden.

Namensraum (none)
Diagramm
MEASURE_PARAMETER Element MEASURE_UNIT Element Sequence MEASURE Element
Overview
MEASURE optional

Falls die der Variantenart zugeordneten Varianten Maßvarianten sind, werden in diesem Element die Maßinformationen eingetragen.

Diese bestehen aus einem Maßparameter und der Maßeinheit und können dann z. B. in Formeln der Regeln (DECISIONS) genutzt werden.

Sequence
MEASURE_UNIT xs:string
In diesem Element wird die Maßeinheit hinterlegt. D string
P
M
MEASURE_PARAMETER optional Restriction of xs:string

In diesem Element werden die Parameter hinterlegt, die der Definition einer Formel dienen, z. B. Planungsbreite =2*st + sb, wobei st für Seitenteilbreite und sb für Sitzbreite als Parameter stehen.

 D string
P
M
Quelle
<xs:element name="MEASURE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MEASURE_UNIT" type="xs:string">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="MEASURE_PARAMETER" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_TYPE Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > FEATURE_TYPE Element > MEASURE Element : MEASURE_UNIT Element
Beschreibung
In diesem Element wird die Maßeinheit hinterlegt. D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
MEASURE_UNIT Element
Overview
MEASURE_UNIT xs:string
In diesem Element wird die Maßeinheit hinterlegt. D string
P
M
Quelle
<xs:element name="MEASURE_UNIT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
MEASURE Element | FEATURE_TYPE Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_PARAMETER Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > FEATURE_TYPE Element > MEASURE Element : MEASURE_PARAMETER Element
Beschreibung

In diesem Element werden die Parameter hinterlegt, die der Definition einer Formel dienen, z. B. Planungsbreite =2*st + sb, wobei st für Seitenteilbreite und sb für Sitzbreite als Parameter stehen.

 D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MEASURE_PARAMETER Element
Overview
MEASURE_PARAMETER optional Restriction of xs:string

In diesem Element werden die Parameter hinterlegt, die der Definition einer Formel dienen, z. B. Planungsbreite =2*st + sb, wobei st für Seitenteilbreite und sb für Sitzbreite als Parameter stehen.

 D string
P
M
Quelle
<xs:element name="MEASURE_PARAMETER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">HB Maßparameter darf nur gesetzt sein, wenn die Varianten auch ein Maß tragen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
MEASURE Element | FEATURE_TYPE Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_DEFINITION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : OPTION_DEFINITION Element
Beschreibung
In diesem Element werden die Ausprägungen von Farben, Materialien, und Maßen definiert.
Namensraum (none)
Diagramm
OPTION_MEASURE Element MATERIAL Element Sequence OPTION_DEFINITION Element
Overview
OPTION_DEFINITION optional
In diesem Element werden die Ausprägungen von Farben, Materialien, und Maßen definiert.
Sequence
MATERIAL 0..∞
In diesem Element wird ein Material definiert.

Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante ( gekennzeichnet durch A), dann dürfen weder eine Textur (TEXTURE) noch Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material identifiziert. D string
P
M [1:5]
Sequence
COLOR
In diesem Element werden Farben definiert.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
OPTION_MEASURE 0..∞
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Rücken-, Sitzkissenhöhe).
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine maßliche Ausprägung identifiziert. D positiveInteger
P
M [1:99999]
Sequence
MEASURE_VALUE Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß angegeben. D nonNegativeInteger
P
M [0:999999999]
MEASURE_UNIT xs:string
In diesem Element wird die Einheit angegeben. D string
P
M
Bemerkung

Quelle
<xs:element name="OPTION_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="COLOR">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RGB_RED">
                    <xs:annotation>
                      <xs:documentation>260--11--RGB_Rot</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="255" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RGB_GREEN">
                    <xs:annotation>
                      <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="255" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RGB_BLUE">
                    <xs:annotation>
                      <xs:documentation>260--13--RGB_Blau</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="255" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="MATERIAL_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MEASURE_VALUE">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MEASURE_UNIT" type="xs:string">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPTION_MEASURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MATERIAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : MATERIAL Element
Beschreibung
In diesem Element wird ein Material definiert.

Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante ( gekennzeichnet durch A), dann dürfen weder eine Textur (TEXTURE) noch Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.
Namensraum (none)
Diagramm
COLOR Element Sequence MATERIAL Element
Overview
MATERIAL 0..∞
In diesem Element wird ein Material definiert.

Handelt es sich bei der anzulegenden Variante um eine Ausführungsvariante ( gekennzeichnet durch A), dann dürfen weder eine Textur (TEXTURE) noch Farbwerte (COLOR) angegeben werden.

Ausführungsvarianten werden über T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION definiert.
MATERIAL_NO required Restriction of xs:string
Mit diesem Attribut wird ein Material identifiziert. D string
P
M [1:5]
Sequence
COLOR
In diesem Element werden Farben definiert.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MATERIAL_NO Restriction of xs:string required
Mit diesem Attribut wird ein Material identifiziert. D string
P
M [1:5]
Bemerkung

Quelle
<xs:element name="MATERIAL" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="COLOR">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RGB_RED">
              <xs:annotation>
                <xs:documentation>260--11--RGB_Rot</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="255" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="RGB_GREEN">
              <xs:annotation>
                <xs:documentation>260--12--RGB_Gruen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="255" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="RGB_BLUE">
              <xs:annotation>
                <xs:documentation>260--13--RGB_Blau</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="255" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MATERIAL_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

COLOR Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element : COLOR Element
Beschreibung
In diesem Element werden Farben definiert.
Namensraum (none)
Diagramm
RGB_BLUE Element RGB_GREEN Element RGB_RED Element Sequence COLOR Element
Overview
COLOR
In diesem Element werden Farben definiert.
Sequence
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
Quelle
<xs:element name="COLOR" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RGB_RED">
        <xs:annotation>
          <xs:documentation>260--11--RGB_Rot</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RGB_GREEN">
        <xs:annotation>
          <xs:documentation>260--12--RGB_Gruen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="RGB_BLUE">
        <xs:annotation>
          <xs:documentation>260--13--RGB_Blau</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="255" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

RGB_RED Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_RED Element
Beschreibung
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
RGB_RED Element
Overview
RGB_RED Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
Quelle
<xs:element name="RGB_RED" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--11--RGB_Rot</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

RGB_GREEN Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_GREEN Element
Beschreibung
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
RGB_GREEN Element
Overview
RGB_GREEN Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
Quelle
<xs:element name="RGB_GREEN" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--12--RGB_Gruen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

RGB_BLUE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > MATERIAL Element > COLOR Element : RGB_BLUE Element
Beschreibung
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
RGB_BLUE Element
Overview
RGB_BLUE Restriction of xs:nonNegativeInteger
Über diese Elemente wird eine Grundfarbe (diffuse Reflexion) eines Materials über den RGB-Wert angegeben. Dieser kann nur für einfarbige Materialien verwendet werden.
0 = kein Farbanteil
255 = voller Farbanteil 		D nonNegativeInteger
P
M [0:255]
Quelle
<xs:element name="RGB_BLUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--13--RGB_Blau</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="255" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COLOR Element | MATERIAL Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_MEASURE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element : OPTION_MEASURE Element
Beschreibung
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Rücken-, Sitzkissenhöhe).
Namensraum (none)
Diagramm
MEASURE_UNIT Element MEASURE_VALUE Element Sequence OPTION_MEASURE Element
Overview
OPTION_MEASURE 0..∞
In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Rücken-, Sitzkissenhöhe).
OPTION_MEASURE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine maßliche Ausprägung identifiziert. D positiveInteger
P
M [1:99999]
Sequence
MEASURE_VALUE Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß angegeben. D nonNegativeInteger
P
M [0:999999999]
MEASURE_UNIT xs:string
In diesem Element wird die Einheit angegeben. D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_MEASURE_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine maßliche Ausprägung identifiziert. D positiveInteger
P
M [1:99999]
Bemerkung

Quelle
<xs:element name="OPTION_MEASURE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MEASURE_VALUE">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MEASURE_UNIT" type="xs:string">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPTION_MEASURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_VALUE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > OPTION_MEASURE Element : MEASURE_VALUE Element
Beschreibung
In diesem Element wird das Maß angegeben. D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MEASURE_VALUE Element
Overview
MEASURE_VALUE Restriction of xs:nonNegativeInteger
In diesem Element wird das Maß angegeben. D nonNegativeInteger
P
M [0:999999999]
Bemerkung

Quelle
<xs:element name="MEASURE_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION_MEASURE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_DEFINITION Element > OPTION_MEASURE Element : MEASURE_UNIT Element
Beschreibung
In diesem Element wird die Einheit angegeben. D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
MEASURE_UNIT Element
Overview
MEASURE_UNIT xs:string
In diesem Element wird die Einheit angegeben. D string
P
M
Bemerkung

Quelle
<xs:element name="MEASURE_UNIT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION_MEASURE Element | OPTION_DEFINITION Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : DECISIONS Element
Beschreibung
In diesem Element werden Regeln für Varianten und Variantenarten formuliert.
Namensraum (none)
Diagramm
DECISION Element Sequence DECISIONS Element
Overview
DECISIONS optional
In diesem Element werden Regeln für Varianten und Variantenarten formuliert.
Sequence
DECISION 1..99999

In diesem Element wird eine Regel definiert und beschrieben, die technisch machbare Konfigurationen abbildet.
Eine Zuordnung der Regeln zu Serien oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Regeln entweder aus Serien oder Artikeln referenziert werden.

Abhängig von dem Attribut DECISION_TYPE können unterschiedliche Regeln formuliert werden.

Ist der Wert von DECISION_TYPE 0 oder1, handelt es sich um eine Vorbereitungsregel (Preparation Rule).

Hierüber können nun Mengen von ungültigen bzw. gültigen Varianten in OPTION_COMBINATION definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

Die Bedingungen wurden um Operatoren ergänzt. Hierfür wurde ein extra Datentyp operator definiert. Dieser kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Die einzelnen OPTION_COMBINATIONs sind als ELSE-Zweige zu betrachten. Das heißt, sobald eine Bedingungszeile (OPTION_COMBINATION) einen Treffer bekommen hat, werden die anderen nicht mehr durchlaufen.

Ist der Wert von DECISION_TYPE 2, handelt es sich um eine Ausführungsregel (Action Rule). Hier können abhängig von den Bedingungen noch Aktionen definiert werden.

Wenn alle Bedingungen innerhalb einer „OPTION_COMBINATION“ erfüllt sind, dann werden alle zugeordneten Aktionen (ACTIONS) ausgeführt, die abhängig von Bedingungen Werte setzen oder auch Variantenarten (FEATURES) ausblenden können. Ist eine OPTION_COMBINATION erfüllt, werden auch hier die anderen Bedingungen nicht mehr durchlaufen.

Aktionen (ACTIONS)

sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

    Das Setzen von Varianten ( SET_FEATURE_FIXED ) mit folgenden Möglichkeiten:

      - Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

      - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

      - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
      Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
      Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
      Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

        Das Setzen von Standardvarianten ( SET_FEATURE_DEFAULT , SET_FEATURE_DEFAULT_NULL ):
        Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

            Die Sichtbarkeit von Variantenarten ( SET_FEATURE_VISIBLE , SET_FEATURE_INVISIBLE ) bzw. das Wegschalten von Regeln ( DISABLE_DECISION , ENABLE_DECISION ):
            So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

              Ausführungsregeln werden im Konfigurator meistens genutzt, wenn sich ein Optionswert (eine Variante) ändert. So kann z.B. dann, wenn sich die Fußvariante von Edelstahl auf Holz ändert, eine Variantenart für den Beizton angezeigt werden.

              Ist der Wert von DECISION_TYPE 3, handelt es sich um eine Ausführungsregel (Action Rule) für Stücklisten.. Hier kann abhängig von den Bedingungen noch anzahl in der Stückliste definiert werden.

              DECISION_NO required Restriction of xs:positiveInteger
              Mit diesem Attribut wird die Regel identifiziert. D positiveInteger
              P
              M [1:9999999999]
              DECISION_TYPE required Restriction of xs:int

              Mit diesem Attribut wird der Typ einer Regel angegeben.

              0 = ausschließende Vorbereitungsregel

              Hierüber können Mengen von ungültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die ungültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind

              1 = Vorbereitungsregel (PreparationRule)

              Hierüber können Mengen von gültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

              2 = Ausführungsregel (Action Rule)
              Hier können zusätzlich zu den Bedingungen noch Aktionen definiert werden.
              Die Regeln werden vor Eingabe einer Variante am Artikel ausgewertet.
              Wenn dann ein Wert ausgewählt wurde, greifen die Aktionsregeln, welche dann Werte setzen oder Variantenarten ausblenden können.
              Bei Action Rules greift immer die erste Zeile (OPTIONS_SET_REF), die zutrifft. In dem Fall werden alle zugehörigen ACTIONS ausgeführt.

              3 = Ausführungsregel für Anzahl in Stücklisten (PositionCounter Rule)

              Hier kann abhängig von den Bedingungen über die Aktion SET_POS_COUNT_VALUE die Anzahl in der Stückliste definiert werden.

                       D int
              P
              M [0-3]
              Sequence
              DECISION_NAME_TEXT languagetext60 Complex Type
              In diesem Element wird die Bezeichnung einer Regel hinterlegt.
              Sequence
              LANGUAGE 1..∞
              ISO_LANGUAGE_ID required Restriction of xs:language
              In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
              P [A-Z]{2}
              M [2:2]
              Sequence
              TEXT Restriction of xs:string
              In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
              P [\S ]{1,60}
              M [1:60]
              OPTION_COMBINATION 1..∞

              In diesem Element wird eine Variantenkombination gebildet, die mit bestimmten Bedingungen verknüpft ist.

              Ist der Wert von DECISION_TYPE 2 oder 3, können der Variantenkombination noch Aktionen (ACTIONS) zugeordnet werden.

              SEQUENCE required Restriction of xs:nonNegativeInteger
              Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. D nonNegativeInteger
              P
              M [1:99999]
              Sequence
              OPTIONS_SET_REF 0..∞

              Mit diesem Element wird auf die Variantenart referenziert und eine Regel für ihre Variantenausprägungen definiert. Die Regeln können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

              Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

              eq (ist gleich)

              ne (ist nicht gleich)

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              REF_LEVEL optional Restriction of xs:nonNegativeInteger
              In Stücklisten können Unterpositionen Variantenarten der Hauptposition (PARENT), der obersten Position (ROOT) und von dem Artikel selbst (SELF) über den REF_LEVEL abfragen und abhängig davon eine Aktion auslösen oder diese in einer Bedingung integrieren.

              1 = ROOT

              2 = PARENT

              3 = SELF (Default ist SELF, wenn kein REF-Level angegeben ist)               		D nonNegativeInteger
              P
              M [1:3]
              Choice
              OPTION_INTERVAL
              Mit diesem Element wird überprüft ob eine Variante innerhalb oder außerhalb eines Intervall liegt.
              OPERATOR required Restriction of operator Simple Type

              Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

                       D operator
              P in|nin
              M
              OPTION_KEY_MIN required Restriction of xs:string

              Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

                       D string
              P
              M [1:30]
              OPTION_KEY_MAX required Restriction of xs:string
              Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
              P
              M [1:30]
              OPTION_LIST
              Mit diesem Element wird überprüft ob eine Variante einem Wert innerhalb einer Liste entspricht.
              OPERATOR required Restriction of operator Simple Type

              Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

                       D operator
              P in|nin
              M
              Sequence 1..∞
              OPTION_REF
              Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
              OPTION_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
              P
              M [1:30]
              OPTION_GROUP_REF_OP
              Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
              OPTION_GROUP_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantengruppe referenziert. D string
              P
              M [1:30]
              OPERATOR required Restriction of operator Simple Type

              Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

                       D operator
              P in|nin
              M
              OPTION_REF_OP

              Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

              OPTION_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
              P
              M [1:30]
              OPERATOR required Restriction of operator Simple Type
              Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

                       D operator
              P eq|ne|gt|lt|ge|le
              M
              FEATURE_REF_OP

              Mit diesem Element kann direkt die Variantenart verglichen werden.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              OPERATOR required Restriction of operator Simple Type
              Mit diesem Attribut wird ein Vergleich mit einer Variantenart formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

                       D operator
              P eq|ne
              M
              MEASURE_VALUE_OP
              Mit diesem Element wird der Maßwert einer Variante mit einem weitern Maßwert überprüft.
              MEASURE_VALUE required xs:nonNegativeInteger

              Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

                       D nonNegativeInteger
              P
              M
              OPERATOR required Restriction of operator Simple Type
              Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

              Der Vergleichsoperator kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

                       D operator
              P eq|ne|gt|lt|ge|le
              M
              MEASURE_INTERVAL
              Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
              OPERATOR required Restriction of operator Simple Type

              Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

                       D operator
              P in|nin
              M
              MEASURE_MIN required xs:nonNegativeInteger

              Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

                       D nonNegativeInteger
              P
              M
              MEASURE_MAX required xs:nonNegativeInteger
              Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
              P
              M
              ACTIONS optional

              Dieses Element dient der Festlegung von Aktionen, die bei bestimmten Bedingungen durchgeführt werden.

              Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

              • Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

              § Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

              § das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

              § das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
              Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
              Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

              • Das Setzen von Standardvarianten (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
                Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

              • Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
                So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

              Choice 1..∞
              SET_FEATURE_DEFAULT

              Mit dieser Aktion können Standardvarianten gesetzt werden.

              Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde.

              • Für das Setzen von Varianten gibt es folgende Möglichkeiten:

              - Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

              - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

              - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
              Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
              Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              OPTION_REF
              Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt als Standard gesetzt wird.
              OPTION_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
              P
              M [1:30]
              FORMULA_REF
              Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Standardwerten.
              FORMULA_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Formel referenziert. D string
              P
              M [1:30]
              SET_FEATURE_FIXED

              Mit dieser Aktion können Varianten gesetzt werden.

              Für das Setzen von Varianten gibt es folgende Möglichkeiten:

              - Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

              - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

              - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
              Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
              Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
              Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              OPTION_REF
              Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
              OPTION_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
              P
              M [1:30]
              FORMULA_REF
              Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
              FORMULA_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Formel referenziert. D string
              P
              M [1:30]
              ENABLE_DECISION

              Mit dieser Aktion können Regeln eingeschaltet werden.

              DECISION_NO optional Restriction of xs:positiveInteger
              Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
              P
              M [1:9999999999]
              DISABLE_DECISION

              Mit dieser Aktion können Regeln ausgeschaltet werden.

              DECISION_NO optional Restriction of xs:positiveInteger
              Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
              P
              M [1:9999999999]
              SET_FEATURE_VISIBLE
              Mit dieser Aktion können Variantenarten sichtbar gemacht werden.
              FEATURE_NO optional Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              SET_FEATURE_INVISIBLE
              Mit dieser Aktion können Variantenarten unsichtbar gemacht werden.
              FEATURE_NO optional Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              SET_FEATURE
              Mittels dieser Aktion kann ein Wert für eine Variante einer Variantenart gesetzt werden. Dieser Wert kann im Gegensatz zu „SET_FEATURE FIXED“ verändert werden, wenn die Bedingungen das zulassen. Diese Wertebelegung greift auch dann, wenn das entsprechende Feld vorher durch einen Default oder manuell belegt wurde.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              OPTION_REF
              Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
              OPTION_KEY required Restriction of xs:string
              Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
              P
              M [1:30]
              FORMULA_REF
              Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
              FORMULA_KEY optional Restriction of xs:string
              Mit diesem Attribut wird eine Formel referenziert. D string
              P
              M [1:30]
              SET_FEATURE_DEFAULT_NULL

              Mit dieser Aktion können Standardvarianten gesetzt werden.

              Diese Vorbelegung greift nur wenn das entsprechende Variantenfeld vorher leer war.

              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              Choice
              FEATURE_REF
              Dieses Element referenziert auf eine andere Variantenart für das Setzen von NULL.
              FEATURE_NO optional Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              OPTION_REF
              Mit diesem Element wird auf eine Variante (OPTION) referenziert, die auf NULL gesetzt wird.
              OPTION_KEY optional Restriction of xs:string
              Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
              P
              M [1:30]
              FORMULA_REF
              Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
              FORMULA_KEY optional Restriction of xs:string
              Mit diesem Attribut wird eine Formel referenziert. D string
              P
              M [1:30]
              SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
              Mit diesem Element wird eine Anzahl in der Stückliste gesetzt.
              Diese Aktion darf nur bei Regeln mit DECISION_TYPE = 3 angegeben werden.               		D nonNegativeInteger
              P
              M [0:9999]
              SET_MESSAGE
              Dieses Element dient zum Setzen einer Nachricht, so dass bei bestimmten Variantenkombinationen Warnungen oder Hinweise ausgelöst werden können.
              MESSAGE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Nachricht referenziert. D nonNegativeInteger
              P
              M [0:999999]
              VALID_FROM optional Restriction of xs:date
              Dieses Element gibt das Datum an, ab dem eine Regel gültig ist.
              Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt.               		D date
              P
              M
              VALID_UNTIL optional Restriction of xs:date
              Dieses Element gibt das Datum an, bis zu welchem eine Regel gültig ist.
              Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.               		D date
              P
              M
              FEATURE_REF 0..∞
              Mit diesem Element wird auf die Variantenart referenziert.
              FEATURE_NO required Restriction of xs:nonNegativeInteger
              Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
              P
              M [0:999]
              PRIO Restriction of xs:positiveInteger
              Dieses Element dient der Angabe eines Wertes für die Priorität einer Regel.
              Dabei stellt ein kleiner Wert ein hohe Priorität dar. Das heißt, je größer dieser Wert ist, desto schlechter ist der Vorrang dieser Regel.               		D positiveInteger
              P
              M [1:999999999]
              Quelle
              <xs:element name="DECISIONS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>nicht zwingend anzugeben, K. Richter, 23.05.2014</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION" maxOccurs="99999">
        <xs:annotation>
          <xs:documentation>270/271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DECISION_NAME_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>270--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:complexType>
                      <xs:choice>
                        <xs:element name="OPTION_INTERVAL">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="in|nin" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY_MIN" use="required">
                              <xs:annotation>
                                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY_MAX" use="required">
                              <xs:annotation>
                                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_LIST">
                          <xs:complexType>
                            <xs:sequence maxOccurs="unbounded">
                              <xs:element name="OPTION_REF">
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="in|nin" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_GROUP_REF_OP">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="OPTION_GROUP_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="in|nin" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF_OP">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FEATURE_REF_OP">
                          <xs:annotation>
                            <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
                            <xs:documentation />
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="eq|ne" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="MEASURE_VALUE_OP">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                              </xs:annotation>
                            </xs:attribute>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="MEASURE_INTERVAL">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="OPERATOR" use="required">
                              <xs:annotation>
                                <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="operator">
                                  <xs:pattern value="in|nin" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                              <xs:annotation>
                                <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                              </xs:annotation>
                            </xs:attribute>
                            <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                              <xs:annotation>
                                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                              </xs:annotation>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="REF_LEVEL" use="optional">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
                          <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="3" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ACTIONS" minOccurs="0">
                    <xs:complexType>
                      <xs:choice maxOccurs="unbounded">
                        <xs:element name="SET_FEATURE_DEFAULT">
                          <xs:complexType>
                            <xs:choice>
                              <xs:element name="FEATURE_REF">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF">
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FORMULA_REF">
                                <xs:complexType>
                                  <xs:attribute name="FORMULA_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_FEATURE_FIXED">
                          <xs:complexType>
                            <xs:choice>
                              <xs:element name="FEATURE_REF">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF">
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FORMULA_REF">
                                <xs:complexType>
                                  <xs:attribute name="FORMULA_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ENABLE_DECISION">
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO">
                              <xs:annotation>
                                <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DISABLE_DECISION">
                          <xs:complexType>
                            <xs:attribute name="DECISION_NO">
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_FEATURE_VISIBLE">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_FEATURE_INVISIBLE">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_FEATURE">
                          <xs:complexType>
                            <xs:choice>
                              <xs:element name="FEATURE_REF">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF">
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FORMULA_REF">
                                <xs:complexType>
                                  <xs:attribute name="FORMULA_KEY">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_FEATURE_DEFAULT_NULL">
                          <xs:complexType>
                            <xs:choice>
                              <xs:element name="FEATURE_REF">
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="9999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF">
                                <xs:complexType>
                                  <xs:attribute name="OPTION_KEY">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FORMULA_REF">
                                <xs:complexType>
                                  <xs:attribute name="FORMULA_KEY">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:choice>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="SET_POS_COUNT_VALUE">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                            <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                            <xs:documentation>setzt Anzahl</xs:documentation>
                            <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="SET_MESSAGE">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                            <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                            <xs:documentation>setzt Anzahl</xs:documentation>
                            <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="MESSAGE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="FEATURE_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Entscheidungstabellen wieder entfernt, nur Angabe FEATURE_NO, 02.05.2014</xs:documentation>
                <xs:documentation xml:lang="de">Version Beta 2.0 Build 12</xs:documentation>
                <xs:documentation xml:lang="de">minimale Kardinalität auf 0 geändert K.Richter 18.07.2014</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRIO">
              <xs:annotation>
                <xs:documentation xml:lang="de">neu IDM 2.4
Priorität von Prüfungen

Am Artikel können nur Decisions mit niedriger Priorität hinzu bzw. ausgeschaltet werden
Mehrere DECISIONS können auf einem gleichen Priolevel liegen

</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DECISION_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DECISION_TYPE" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="de">IDM 2.4 Build 14 H.Balke 05.2014
0 = ausschließende (nicht erlaubende) Preparation
1 = Preparation
2 = action Rules
3 = action Rule mit SET_POS_COUNT_VALUE (setzt die Anzahl in der die Position in der Stückliste erscheint)

Restriktions werden vor Eingabe einer Variante am Artikel ausgewertet.
Wenn dann ein Wert ausgewählt wurde, greifen die action Rules, welche dann Werte setzen oder Variantenarten ausblenden können.
Bei Action Rules greift immer die erste Zeile (option combination), die zutrifft. In dem Fall werden alle zugehörigen Actions ausgeführt.
</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:int">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="3" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
              Siehe auch
              FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element : DECISION Element
Beschreibung

In diesem Element wird eine Regel definiert und beschrieben, die technisch machbare Konfigurationen abbildet.
Eine Zuordnung der Regeln zu Serien oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Regeln entweder aus Serien oder Artikeln referenziert werden.

Abhängig von dem Attribut DECISION_TYPE können unterschiedliche Regeln formuliert werden.

Ist der Wert von DECISION_TYPE 0 oder1, handelt es sich um eine Vorbereitungsregel (Preparation Rule).

Hierüber können nun Mengen von ungültigen bzw. gültigen Varianten in OPTION_COMBINATION definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

Die Bedingungen wurden um Operatoren ergänzt. Hierfür wurde ein extra Datentyp operator definiert. Dieser kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Die einzelnen OPTION_COMBINATIONs sind als ELSE-Zweige zu betrachten. Das heißt, sobald eine Bedingungszeile (OPTION_COMBINATION) einen Treffer bekommen hat, werden die anderen nicht mehr durchlaufen.

Ist der Wert von DECISION_TYPE 2, handelt es sich um eine Ausführungsregel (Action Rule). Hier können abhängig von den Bedingungen noch Aktionen definiert werden.

Wenn alle Bedingungen innerhalb einer „OPTION_COMBINATION“ erfüllt sind, dann werden alle zugeordneten Aktionen (ACTIONS) ausgeführt, die abhängig von Bedingungen Werte setzen oder auch Variantenarten (FEATURES) ausblenden können. Ist eine OPTION_COMBINATION erfüllt, werden auch hier die anderen Bedingungen nicht mehr durchlaufen.

Aktionen (ACTIONS)

sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

    Das Setzen von Varianten ( SET_FEATURE_FIXED ) mit folgenden Möglichkeiten:

      - Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

      - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

      - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
      Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
      Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
      Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

        Das Setzen von Standardvarianten ( SET_FEATURE_DEFAULT , SET_FEATURE_DEFAULT_NULL ):
        Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

            Die Sichtbarkeit von Variantenarten ( SET_FEATURE_VISIBLE , SET_FEATURE_INVISIBLE ) bzw. das Wegschalten von Regeln ( DISABLE_DECISION , ENABLE_DECISION ):
            So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

              Ausführungsregeln werden im Konfigurator meistens genutzt, wenn sich ein Optionswert (eine Variante) ändert. So kann z.B. dann, wenn sich die Fußvariante von Edelstahl auf Holz ändert, eine Variantenart für den Beizton angezeigt werden.

              Ist der Wert von DECISION_TYPE 3, handelt es sich um eine Ausführungsregel (Action Rule) für Stücklisten.. Hier kann abhängig von den Bedingungen noch anzahl in der Stückliste definiert werden.

              Namensraum (none)
              Diagramm
              PRIO Element FEATURE_REF Element VALID_UNTIL Element VALID_FROM Element OPTION_COMBINATION Element LANGUAGE Element Sequence DECISION_NAME_TEXT Element Sequence DECISION Element
              Overview
              DECISION 1..99999

              In diesem Element wird eine Regel definiert und beschrieben, die technisch machbare Konfigurationen abbildet.
              Eine Zuordnung der Regeln zu Serien oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Regeln entweder aus Serien oder Artikeln referenziert werden.

              Abhängig von dem Attribut DECISION_TYPE können unterschiedliche Regeln formuliert werden.

              Ist der Wert von DECISION_TYPE 0 oder1, handelt es sich um eine Vorbereitungsregel (Preparation Rule).

              Hierüber können nun Mengen von ungültigen bzw. gültigen Varianten in OPTION_COMBINATION definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

              Die Bedingungen wurden um Operatoren ergänzt. Hierfür wurde ein extra Datentyp operator definiert. Dieser kann folgende Werte enthalten:

              eq (ist gleich)

              ne (ist nicht gleich)

              in (ist enthalten in einer Menge)

              nin (ist nicht enthalten in der Menge)

              gt (größer)

              lt (kleiner)

              ge (größer gleich)

              le (kleiner gleich)

              Die einzelnen OPTION_COMBINATIONs sind als ELSE-Zweige zu betrachten. Das heißt, sobald eine Bedingungszeile (OPTION_COMBINATION) einen Treffer bekommen hat, werden die anderen nicht mehr durchlaufen.

              Ist der Wert von DECISION_TYPE 2, handelt es sich um eine Ausführungsregel (Action Rule). Hier können abhängig von den Bedingungen noch Aktionen definiert werden.

              Wenn alle Bedingungen innerhalb einer „OPTION_COMBINATION“ erfüllt sind, dann werden alle zugeordneten Aktionen (ACTIONS) ausgeführt, die abhängig von Bedingungen Werte setzen oder auch Variantenarten (FEATURES) ausblenden können. Ist eine OPTION_COMBINATION erfüllt, werden auch hier die anderen Bedingungen nicht mehr durchlaufen.

              Aktionen (ACTIONS)

              sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

                Das Setzen von Varianten ( SET_FEATURE_FIXED ) mit folgenden Möglichkeiten:

                  - Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

                  - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

                  - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
                  Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
                  Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
                  Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

                    Das Setzen von Standardvarianten ( SET_FEATURE_DEFAULT , SET_FEATURE_DEFAULT_NULL ):
                    Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

                        Die Sichtbarkeit von Variantenarten ( SET_FEATURE_VISIBLE , SET_FEATURE_INVISIBLE ) bzw. das Wegschalten von Regeln ( DISABLE_DECISION , ENABLE_DECISION ):
                        So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

                          Ausführungsregeln werden im Konfigurator meistens genutzt, wenn sich ein Optionswert (eine Variante) ändert. So kann z.B. dann, wenn sich die Fußvariante von Edelstahl auf Holz ändert, eine Variantenart für den Beizton angezeigt werden.

                          Ist der Wert von DECISION_TYPE 3, handelt es sich um eine Ausführungsregel (Action Rule) für Stücklisten.. Hier kann abhängig von den Bedingungen noch anzahl in der Stückliste definiert werden.

                          DECISION_NO required Restriction of xs:positiveInteger
                          Mit diesem Attribut wird die Regel identifiziert. D positiveInteger
                          P
                          M [1:9999999999]
                          DECISION_TYPE required Restriction of xs:int

                          Mit diesem Attribut wird der Typ einer Regel angegeben.

                          0 = ausschließende Vorbereitungsregel

                          Hierüber können Mengen von ungültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die ungültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind

                          1 = Vorbereitungsregel (PreparationRule)

                          Hierüber können Mengen von gültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

                          2 = Ausführungsregel (Action Rule)
                          Hier können zusätzlich zu den Bedingungen noch Aktionen definiert werden.
                          Die Regeln werden vor Eingabe einer Variante am Artikel ausgewertet.
                          Wenn dann ein Wert ausgewählt wurde, greifen die Aktionsregeln, welche dann Werte setzen oder Variantenarten ausblenden können.
                          Bei Action Rules greift immer die erste Zeile (OPTIONS_SET_REF), die zutrifft. In dem Fall werden alle zugehörigen ACTIONS ausgeführt.

                          3 = Ausführungsregel für Anzahl in Stücklisten (PositionCounter Rule)

                          Hier kann abhängig von den Bedingungen über die Aktion SET_POS_COUNT_VALUE die Anzahl in der Stückliste definiert werden.

                                   D int
                          P
                          M [0-3]
                          Sequence
                          DECISION_NAME_TEXT languagetext60 Complex Type
                          In diesem Element wird die Bezeichnung einer Regel hinterlegt.
                          Sequence
                          LANGUAGE 1..∞
                          ISO_LANGUAGE_ID required Restriction of xs:language
                          In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
                          P [A-Z]{2}
                          M [2:2]
                          Sequence
                          TEXT Restriction of xs:string
                          In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
                          P [\S ]{1,60}
                          M [1:60]
                          OPTION_COMBINATION 1..∞

                          In diesem Element wird eine Variantenkombination gebildet, die mit bestimmten Bedingungen verknüpft ist.

                          Ist der Wert von DECISION_TYPE 2 oder 3, können der Variantenkombination noch Aktionen (ACTIONS) zugeordnet werden.

                          SEQUENCE required Restriction of xs:nonNegativeInteger
                          Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. D nonNegativeInteger
                          P
                          M [1:99999]
                          Sequence
                          OPTIONS_SET_REF 0..∞

                          Mit diesem Element wird auf die Variantenart referenziert und eine Regel für ihre Variantenausprägungen definiert. Die Regeln können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

                          Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

                          eq (ist gleich)

                          ne (ist nicht gleich)

                          in (ist enthalten in einer Menge)

                          nin (ist nicht enthalten in der Menge)

                          gt (größer)

                          lt (kleiner)

                          ge (größer gleich)

                          le (kleiner gleich)

                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          REF_LEVEL optional Restriction of xs:nonNegativeInteger
                          In Stücklisten können Unterpositionen Variantenarten der Hauptposition (PARENT), der obersten Position (ROOT) und von dem Artikel selbst (SELF) über den REF_LEVEL abfragen und abhängig davon eine Aktion auslösen oder diese in einer Bedingung integrieren.

                          1 = ROOT

                          2 = PARENT

                          3 = SELF (Default ist SELF, wenn kein REF-Level angegeben ist)                           		D nonNegativeInteger
                          P
                          M [1:3]
                          Choice
                          OPTION_INTERVAL
                          Mit diesem Element wird überprüft ob eine Variante innerhalb oder außerhalb eines Intervall liegt.
                          OPERATOR required Restriction of operator Simple Type

                          Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

                          in (ist enthalten in einer Menge)

                          nin (ist nicht enthalten in der Menge)

                                   D operator
                          P in|nin
                          M
                          OPTION_KEY_MIN required Restriction of xs:string

                          Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

                                   D string
                          P
                          M [1:30]
                          OPTION_KEY_MAX required Restriction of xs:string
                          Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
                          P
                          M [1:30]
                          OPTION_LIST
                          Mit diesem Element wird überprüft ob eine Variante einem Wert innerhalb einer Liste entspricht.
                          OPERATOR required Restriction of operator Simple Type

                          Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

                          in (ist enthalten in einer Menge)

                          nin (ist nicht enthalten in der Menge)

                                   D operator
                          P in|nin
                          M
                          Sequence 1..∞
                          OPTION_REF
                          Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
                          OPTION_KEY required Restriction of xs:string
                          Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
                          P
                          M [1:30]
                          OPTION_GROUP_REF_OP
                          Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
                          OPTION_GROUP_KEY required Restriction of xs:string
                          Mit diesem Attribut wird eine Variantengruppe referenziert. D string
                          P
                          M [1:30]
                          OPERATOR required Restriction of operator Simple Type

                          Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

                          in (ist enthalten in einer Menge)

                          nin (ist nicht enthalten in der Menge)

                                   D operator
                          P in|nin
                          M
                          OPTION_REF_OP

                          Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

                          Der Vergleichsoperator kann folgende Werte enthalten:

                          eq (ist gleich)

                          ne (ist nicht gleich)

                          gt (größer)

                          lt (kleiner)

                          ge (größer gleich)

                          le (kleiner gleich)

                          OPTION_KEY required Restriction of xs:string
                          Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
                          P
                          M [1:30]
                          OPERATOR required Restriction of operator Simple Type
                          Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

                          Der Vergleichsoperator kann folgende Werte enthalten:

                          eq (ist gleich)

                          ne (ist nicht gleich)

                          gt (größer)

                          lt (kleiner)

                          ge (größer gleich)

                          le (kleiner gleich)

                                   D operator
                          P eq|ne|gt|lt|ge|le
                          M
                          FEATURE_REF_OP

                          Mit diesem Element kann direkt die Variantenart verglichen werden.

                          Der Vergleichsoperator kann folgende Werte enthalten:

                          eq (ist gleich)

                          ne (ist nicht gleich)

                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          OPERATOR required Restriction of operator Simple Type
                          Mit diesem Attribut wird ein Vergleich mit einer Variantenart formuliert.

                          Der Vergleichsoperator kann folgende Werte enthalten:

                          eq (ist gleich)

                          ne (ist nicht gleich)

                                   D operator
                          P eq|ne
                          M
                          MEASURE_VALUE_OP
                          Mit diesem Element wird der Maßwert einer Variante mit einem weitern Maßwert überprüft.
                          MEASURE_VALUE required xs:nonNegativeInteger

                          Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

                                   D nonNegativeInteger
                          P
                          M
                          OPERATOR required Restriction of operator Simple Type
                          Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

                          Der Vergleichsoperator kann folgende Werte enthalten:

                          eq (ist gleich)

                          ne (ist nicht gleich)

                          gt (größer)

                          lt (kleiner)

                          ge (größer gleich)

                          le (kleiner gleich)

                                   D operator
                          P eq|ne|gt|lt|ge|le
                          M
                          MEASURE_INTERVAL
                          Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
                          OPERATOR required Restriction of operator Simple Type

                          Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

                          in (ist enthalten in einer Menge)

                          nin (ist nicht enthalten in der Menge)

                                   D operator
                          P in|nin
                          M
                          MEASURE_MIN required xs:nonNegativeInteger

                          Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

                                   D nonNegativeInteger
                          P
                          M
                          MEASURE_MAX required xs:nonNegativeInteger
                          Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
                          P
                          M
                          ACTIONS optional

                          Dieses Element dient der Festlegung von Aktionen, die bei bestimmten Bedingungen durchgeführt werden.

                          Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

                          • Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

                          § Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

                          § das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

                          § das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
                          Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
                          Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
                          Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

                          • Das Setzen von Standardvarianten (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
                            Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

                          • Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
                            So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

                          Choice 1..∞
                          SET_FEATURE_DEFAULT

                          Mit dieser Aktion können Standardvarianten gesetzt werden.

                          Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde.

                          • Für das Setzen von Varianten gibt es folgende Möglichkeiten:

                          - Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

                          - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

                          - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
                          Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
                          Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
                          Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          Choice
                          FEATURE_REF
                          Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          OPTION_REF
                          Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt als Standard gesetzt wird.
                          OPTION_KEY required Restriction of xs:string
                          Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
                          P
                          M [1:30]
                          FORMULA_REF
                          Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Standardwerten.
                          FORMULA_KEY required Restriction of xs:string
                          Mit diesem Attribut wird eine Formel referenziert. D string
                          P
                          M [1:30]
                          SET_FEATURE_FIXED

                          Mit dieser Aktion können Varianten gesetzt werden.

                          Für das Setzen von Varianten gibt es folgende Möglichkeiten:

                          - Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

                          - das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

                          - das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
                          Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
                          Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
                          Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          Choice
                          FEATURE_REF
                          Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          OPTION_REF
                          Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
                          OPTION_KEY required Restriction of xs:string
                          Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
                          P
                          M [1:30]
                          FORMULA_REF
                          Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
                          FORMULA_KEY required Restriction of xs:string
                          Mit diesem Attribut wird eine Formel referenziert. D string
                          P
                          M [1:30]
                          ENABLE_DECISION

                          Mit dieser Aktion können Regeln eingeschaltet werden.

                          DECISION_NO optional Restriction of xs:positiveInteger
                          Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
                          P
                          M [1:9999999999]
                          DISABLE_DECISION

                          Mit dieser Aktion können Regeln ausgeschaltet werden.

                          DECISION_NO optional Restriction of xs:positiveInteger
                          Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
                          P
                          M [1:9999999999]
                          SET_FEATURE_VISIBLE
                          Mit dieser Aktion können Variantenarten sichtbar gemacht werden.
                          FEATURE_NO optional Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          SET_FEATURE_INVISIBLE
                          Mit dieser Aktion können Variantenarten unsichtbar gemacht werden.
                          FEATURE_NO optional Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          SET_FEATURE
                          Mittels dieser Aktion kann ein Wert für eine Variante einer Variantenart gesetzt werden. Dieser Wert kann im Gegensatz zu „SET_FEATURE FIXED“ verändert werden, wenn die Bedingungen das zulassen. Diese Wertebelegung greift auch dann, wenn das entsprechende Feld vorher durch einen Default oder manuell belegt wurde.
                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          Choice
                          FEATURE_REF
                          Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          OPTION_REF
                          Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
                          OPTION_KEY required Restriction of xs:string
                          Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
                          P
                          M [1:30]
                          FORMULA_REF
                          Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
                          FORMULA_KEY optional Restriction of xs:string
                          Mit diesem Attribut wird eine Formel referenziert. D string
                          P
                          M [1:30]
                          SET_FEATURE_DEFAULT_NULL

                          Mit dieser Aktion können Standardvarianten gesetzt werden.

                          Diese Vorbelegung greift nur wenn das entsprechende Variantenfeld vorher leer war.

                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          Choice
                          FEATURE_REF
                          Dieses Element referenziert auf eine andere Variantenart für das Setzen von NULL.
                          FEATURE_NO optional Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          OPTION_REF
                          Mit diesem Element wird auf eine Variante (OPTION) referenziert, die auf NULL gesetzt wird.
                          OPTION_KEY optional Restriction of xs:string
                          Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
                          P
                          M [1:30]
                          FORMULA_REF
                          Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
                          FORMULA_KEY optional Restriction of xs:string
                          Mit diesem Attribut wird eine Formel referenziert. D string
                          P
                          M [1:30]
                          SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
                          Mit diesem Element wird eine Anzahl in der Stückliste gesetzt.
                          Diese Aktion darf nur bei Regeln mit DECISION_TYPE = 3 angegeben werden.                           		D nonNegativeInteger
                          P
                          M [0:9999]
                          SET_MESSAGE
                          Dieses Element dient zum Setzen einer Nachricht, so dass bei bestimmten Variantenkombinationen Warnungen oder Hinweise ausgelöst werden können.
                          MESSAGE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Nachricht referenziert. D nonNegativeInteger
                          P
                          M [0:999999]
                          VALID_FROM optional Restriction of xs:date
                          Dieses Element gibt das Datum an, ab dem eine Regel gültig ist.
                          Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt.                           		D date
                          P
                          M
                          VALID_UNTIL optional Restriction of xs:date
                          Dieses Element gibt das Datum an, bis zu welchem eine Regel gültig ist.
                          Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.                           		D date
                          P
                          M
                          FEATURE_REF 0..∞
                          Mit diesem Element wird auf die Variantenart referenziert.
                          FEATURE_NO required Restriction of xs:nonNegativeInteger
                          Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
                          P
                          M [0:999]
                          PRIO Restriction of xs:positiveInteger
                          Dieses Element dient der Angabe eines Wertes für die Priorität einer Regel.
                          Dabei stellt ein kleiner Wert ein hohe Priorität dar. Das heißt, je größer dieser Wert ist, desto schlechter ist der Vorrang dieser Regel.                           		D positiveInteger
                          P
                          M [1:999999999]
                          Attribute
                          Name Typ Verwenden Standard Festgelegt Beschreibung
                          DECISION_NO Restriction of xs:positiveInteger required
                          Mit diesem Attribut wird die Regel identifiziert. D positiveInteger
                          P
                          M [1:9999999999]
                          DECISION_TYPE Restriction of xs:int required

                          Mit diesem Attribut wird der Typ einer Regel angegeben.

                          0 = ausschließende Vorbereitungsregel

                          Hierüber können Mengen von ungültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die ungültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind

                          1 = Vorbereitungsregel (PreparationRule)

                          Hierüber können Mengen von gültigen Varianten in OPTION_COMBINATION/FEATURE_REF definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

                          2 = Ausführungsregel (Action Rule)
                          Hier können zusätzlich zu den Bedingungen noch Aktionen definiert werden.
                          Die Regeln werden vor Eingabe einer Variante am Artikel ausgewertet.
                          Wenn dann ein Wert ausgewählt wurde, greifen die Aktionsregeln, welche dann Werte setzen oder Variantenarten ausblenden können.
                          Bei Action Rules greift immer die erste Zeile (OPTIONS_SET_REF), die zutrifft. In dem Fall werden alle zugehörigen ACTIONS ausgeführt.

                          3 = Ausführungsregel für Anzahl in Stücklisten (PositionCounter Rule)

                          Hier kann abhängig von den Bedingungen über die Aktion SET_POS_COUNT_VALUE die Anzahl in der Stückliste definiert werden.

                                   D int
                          P
                          M [0-3]
                          Quelle
                          <xs:element name="DECISION" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DECISION_NAME_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>270--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:complexType>
                <xs:choice>
                  <xs:element name="OPTION_INTERVAL">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="in|nin" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY_MIN" use="required">
                        <xs:annotation>
                          <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY_MAX" use="required">
                        <xs:annotation>
                          <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_LIST">
                    <xs:complexType>
                      <xs:sequence maxOccurs="unbounded">
                        <xs:element name="OPTION_REF">
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="in|nin" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_GROUP_REF_OP">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="OPTION_GROUP_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="in|nin" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF_OP">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="eq|ne|gt|lt|ge|le" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE_REF_OP">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
                      <xs:documentation />
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="eq|ne" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="MEASURE_VALUE_OP">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                      <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="eq|ne|gt|lt|ge|le" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="MEASURE_INTERVAL">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                      <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="OPERATOR" use="required">
                        <xs:annotation>
                          <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="operator">
                            <xs:pattern value="in|nin" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                        <xs:annotation>
                          <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                      <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                        <xs:annotation>
                          <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="REF_LEVEL" use="optional">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
                    <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="3" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ACTIONS" minOccurs="0">
              <xs:complexType>
                <xs:choice maxOccurs="unbounded">
                  <xs:element name="SET_FEATURE_DEFAULT">
                    <xs:complexType>
                      <xs:choice>
                        <xs:element name="FEATURE_REF">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF">
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FORMULA_REF">
                          <xs:complexType>
                            <xs:attribute name="FORMULA_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_FEATURE_FIXED">
                    <xs:complexType>
                      <xs:choice>
                        <xs:element name="FEATURE_REF">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF">
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FORMULA_REF">
                          <xs:complexType>
                            <xs:attribute name="FORMULA_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ENABLE_DECISION">
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO">
                        <xs:annotation>
                          <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DISABLE_DECISION">
                    <xs:complexType>
                      <xs:attribute name="DECISION_NO">
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_FEATURE_VISIBLE">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_FEATURE_INVISIBLE">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_FEATURE">
                    <xs:complexType>
                      <xs:choice>
                        <xs:element name="FEATURE_REF">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF">
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FORMULA_REF">
                          <xs:complexType>
                            <xs:attribute name="FORMULA_KEY">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_FEATURE_DEFAULT_NULL">
                    <xs:complexType>
                      <xs:choice>
                        <xs:element name="FEATURE_REF">
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF">
                          <xs:complexType>
                            <xs:attribute name="OPTION_KEY">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FORMULA_REF">
                          <xs:complexType>
                            <xs:attribute name="FORMULA_KEY">
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:choice>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SET_POS_COUNT_VALUE">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                      <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                      <xs:documentation>setzt Anzahl</xs:documentation>
                      <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="SET_MESSAGE">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                      <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                      <xs:documentation>setzt Anzahl</xs:documentation>
                      <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="MESSAGE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="FEATURE_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Entscheidungstabellen wieder entfernt, nur Angabe FEATURE_NO, 02.05.2014</xs:documentation>
          <xs:documentation xml:lang="de">Version Beta 2.0 Build 12</xs:documentation>
          <xs:documentation xml:lang="de">minimale Kardinalität auf 0 geändert K.Richter 18.07.2014</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRIO">
        <xs:annotation>
          <xs:documentation xml:lang="de">neu IDM 2.4
Priorität von Prüfungen

Am Artikel können nur Decisions mit niedriger Priorität hinzu bzw. ausgeschaltet werden
Mehrere DECISIONS können auf einem gleichen Priolevel liegen

</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DECISION_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DECISION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="de">IDM 2.4 Build 14 H.Balke 05.2014
0 = ausschließende (nicht erlaubende) Preparation
1 = Preparation
2 = action Rules
3 = action Rule mit SET_POS_COUNT_VALUE (setzt die Anzahl in der die Position in der Stückliste erscheint)

Restriktions werden vor Eingabe einer Variante am Artikel ausgewertet.
Wenn dann ein Wert ausgewählt wurde, greifen die action Rules, welche dann Werte setzen oder Variantenarten ausblenden können.
Bei Action Rules greift immer die erste Zeile (option combination), die zutrifft. In dem Fall werden alle zugehörigen Actions ausgeführt.
</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:int">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
                          Siehe auch
                          DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DECISION_NAME_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : DECISION_NAME_TEXT Element
Beschreibung
In diesem Element wird die Bezeichnung einer Regel hinterlegt.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence DECISION_NAME_TEXT Element
Overview
DECISION_NAME_TEXT languagetext60 Complex Type
In diesem Element wird die Bezeichnung einer Regel hinterlegt.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="DECISION_NAME_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_COMBINATION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : OPTION_COMBINATION Element
Beschreibung

In diesem Element wird eine Variantenkombination gebildet, die mit bestimmten Bedingungen verknüpft ist.

Ist der Wert von DECISION_TYPE 2 oder 3, können der Variantenkombination noch Aktionen (ACTIONS) zugeordnet werden.

Namensraum (none)
Diagramm
ACTIONS Element OPTIONS_SET_REF Element Sequence OPTION_COMBINATION Element
Overview
OPTION_COMBINATION 1..∞

In diesem Element wird eine Variantenkombination gebildet, die mit bestimmten Bedingungen verknüpft ist.

Ist der Wert von DECISION_TYPE 2 oder 3, können der Variantenkombination noch Aktionen (ACTIONS) zugeordnet werden.

SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und eine Regel für ihre Variantenausprägungen definiert. Die Regeln können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
REF_LEVEL optional Restriction of xs:nonNegativeInteger
In Stücklisten können Unterpositionen Variantenarten der Hauptposition (PARENT), der obersten Position (ROOT) und von dem Artikel selbst (SELF) über den REF_LEVEL abfragen und abhängig davon eine Aktion auslösen oder diese in einer Bedingung integrieren.

1 = ROOT

2 = PARENT

3 = SELF (Default ist SELF, wenn kein REF-Level angegeben ist) 		D nonNegativeInteger
P
M [1:3]
Choice
OPTION_INTERVAL
Mit diesem Element wird überprüft ob eine Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
FEATURE_REF_OP

Mit diesem Element kann direkt die Variantenart verglichen werden.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variantenart formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

 D operator
P eq|ne
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weitern Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
ACTIONS optional

Dieses Element dient der Festlegung von Aktionen, die bei bestimmten Bedingungen durchgeführt werden.

Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

  • Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

§ Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

§ das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

§ das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

  • Das Setzen von Standardvarianten (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
    Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

  • Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
    So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

Choice 1..∞
SET_FEATURE_DEFAULT

Mit dieser Aktion können Standardvarianten gesetzt werden.

Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde.

  • Für das Setzen von Varianten gibt es folgende Möglichkeiten:

- Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

- das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

- das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt als Standard gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Standardwerten.
FORMULA_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
SET_FEATURE_FIXED

Mit dieser Aktion können Varianten gesetzt werden.

Für das Setzen von Varianten gibt es folgende Möglichkeiten:

- Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

- das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

- das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
ENABLE_DECISION

Mit dieser Aktion können Regeln eingeschaltet werden.

DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
DISABLE_DECISION

Mit dieser Aktion können Regeln ausgeschaltet werden.

DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
SET_FEATURE_VISIBLE
Mit dieser Aktion können Variantenarten sichtbar gemacht werden.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
SET_FEATURE_INVISIBLE
Mit dieser Aktion können Variantenarten unsichtbar gemacht werden.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
SET_FEATURE
Mittels dieser Aktion kann ein Wert für eine Variante einer Variantenart gesetzt werden. Dieser Wert kann im Gegensatz zu „SET_FEATURE FIXED“ verändert werden, wenn die Bedingungen das zulassen. Diese Wertebelegung greift auch dann, wenn das entsprechende Feld vorher durch einen Default oder manuell belegt wurde.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
SET_FEATURE_DEFAULT_NULL

Mit dieser Aktion können Standardvarianten gesetzt werden.

Diese Vorbelegung greift nur wenn das entsprechende Variantenfeld vorher leer war.

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von NULL.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die auf NULL gesetzt wird.
OPTION_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
Mit diesem Element wird eine Anzahl in der Stückliste gesetzt.
Diese Aktion darf nur bei Regeln mit DECISION_TYPE = 3 angegeben werden. 		D nonNegativeInteger
P
M [0:9999]
SET_MESSAGE
Dieses Element dient zum Setzen einer Nachricht, so dass bei bestimmten Variantenkombinationen Warnungen oder Hinweise ausgelöst werden können.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Nachricht referenziert. D nonNegativeInteger
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE Restriction of xs:nonNegativeInteger required
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="OPTION_COMBINATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:complexType>
          <xs:choice>
            <xs:element name="OPTION_INTERVAL">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MIN" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MAX" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_LIST">
              <xs:complexType>
                <xs:sequence maxOccurs="unbounded">
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_GROUP_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_GROUP_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE_REF_OP">
              <xs:annotation>
                <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
                <xs:documentation />
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_VALUE_OP">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_INTERVAL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="REF_LEVEL" use="optional">
            <xs:annotation>
              <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
              <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="3" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ACTIONS" minOccurs="0">
        <xs:complexType>
          <xs:choice maxOccurs="unbounded">
            <xs:element name="SET_FEATURE_DEFAULT">
              <xs:complexType>
                <xs:choice>
                  <xs:element name="FEATURE_REF">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FORMULA_REF">
                    <xs:complexType>
                      <xs:attribute name="FORMULA_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_FEATURE_FIXED">
              <xs:complexType>
                <xs:choice>
                  <xs:element name="FEATURE_REF">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FORMULA_REF">
                    <xs:complexType>
                      <xs:attribute name="FORMULA_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ENABLE_DECISION">
              <xs:complexType>
                <xs:attribute name="DECISION_NO">
                  <xs:annotation>
                    <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DISABLE_DECISION">
              <xs:complexType>
                <xs:attribute name="DECISION_NO">
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_FEATURE_VISIBLE">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_FEATURE_INVISIBLE">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_FEATURE">
              <xs:complexType>
                <xs:choice>
                  <xs:element name="FEATURE_REF">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FORMULA_REF">
                    <xs:complexType>
                      <xs:attribute name="FORMULA_KEY">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_FEATURE_DEFAULT_NULL">
              <xs:complexType>
                <xs:choice>
                  <xs:element name="FEATURE_REF">
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FORMULA_REF">
                    <xs:complexType>
                      <xs:attribute name="FORMULA_KEY">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:choice>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_POS_COUNT_VALUE">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                <xs:documentation>setzt Anzahl</xs:documentation>
                <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="SET_MESSAGE">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
                <xs:documentation>setzt Anzahl</xs:documentation>
                <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="MESSAGE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONS_SET_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element : OPTIONS_SET_REF Element
Beschreibung

Mit diesem Element wird auf die Variantenart referenziert und eine Regel für ihre Variantenausprägungen definiert. Die Regeln können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Namensraum (none)
Diagramm
MEASURE_INTERVAL Element MEASURE_VALUE_OP Element FEATURE_REF_OP Element OPTION_REF_OP Element OPTION_GROUP_REF_OP Element OPTION_LIST Element OPTION_INTERVAL Element Choice OPTIONS_SET_REF Element
Overview
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und eine Regel für ihre Variantenausprägungen definiert. Die Regeln können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
REF_LEVEL optional Restriction of xs:nonNegativeInteger
In Stücklisten können Unterpositionen Variantenarten der Hauptposition (PARENT), der obersten Position (ROOT) und von dem Artikel selbst (SELF) über den REF_LEVEL abfragen und abhängig davon eine Aktion auslösen oder diese in einer Bedingung integrieren.

1 = ROOT

2 = PARENT

3 = SELF (Default ist SELF, wenn kein REF-Level angegeben ist) 		D nonNegativeInteger
P
M [1:3]
Choice
OPTION_INTERVAL
Mit diesem Element wird überprüft ob eine Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
FEATURE_REF_OP

Mit diesem Element kann direkt die Variantenart verglichen werden.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variantenart formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

 D operator
P eq|ne
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weitern Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
REF_LEVEL Restriction of xs:nonNegativeInteger optional
In Stücklisten können Unterpositionen Variantenarten der Hauptposition (PARENT), der obersten Position (ROOT) und von dem Artikel selbst (SELF) über den REF_LEVEL abfragen und abhängig davon eine Aktion auslösen oder diese in einer Bedingung integrieren.

1 = ROOT

2 = PARENT

3 = SELF (Default ist SELF, wenn kein REF-Level angegeben ist) 		D nonNegativeInteger
P
M [1:3]
Quelle
<xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice>
      <xs:element name="OPTION_INTERVAL">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MIN" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MAX" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_LIST">
        <xs:complexType>
          <xs:sequence maxOccurs="unbounded">
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_GROUP_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_GROUP_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_REF_OP">
        <xs:annotation>
          <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
          <xs:documentation />
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_VALUE_OP">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_INTERVAL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REF_LEVEL" use="optional">
      <xs:annotation>
        <xs:documentation xml:lang="DE">1 = ROOT
2 = PARENT
3 = SELF
Standardfall ist SELF, wenn kein REF-Level angegeben ist</xs:documentation>
        <xs:documentation xml:lang="DE">12.02.2015 K. Richter</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="3" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : OPTION_INTERVAL Element
Beschreibung
Mit diesem Element wird überprüft ob eine Variante innerhalb oder außerhalb eines Intervall liegt.
Namensraum (none)
Diagramm
OPTION_INTERVAL Element
Overview
OPTION_INTERVAL
Mit diesem Element wird überprüft ob eine Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN Restriction of xs:string required

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX Restriction of xs:string required
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MIN" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MAX" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_LIST Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : OPTION_LIST Element
Beschreibung
Mit diesem Element wird überprüft ob eine Variante einem Wert innerhalb einer Liste entspricht.
Namensraum (none)
Diagramm
OPTION_REF Element Sequence OPTION_LIST Element
Overview
OPTION_LIST
Mit diesem Element wird überprüft ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Quelle
<xs:element name="OPTION_LIST" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element > OPTION_LIST Element : OPTION_REF Element
Beschreibung
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_LIST Element | OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUP_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : OPTION_GROUP_REF_OP Element
Beschreibung
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
Namensraum (none)
Diagramm
OPTION_GROUP_REF_OP Element
Overview
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_GROUP_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Quelle
<xs:element name="OPTION_GROUP_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_GROUP_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : OPTION_REF_OP Element
Beschreibung

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Namensraum (none)
Diagramm
OPTION_REF_OP Element
Overview
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Quelle
<xs:element name="OPTION_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : FEATURE_REF_OP Element
Beschreibung

Mit diesem Element kann direkt die Variantenart verglichen werden.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

Namensraum (none)
Diagramm
FEATURE_REF_OP Element
Overview
FEATURE_REF_OP

Mit diesem Element kann direkt die Variantenart verglichen werden.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variantenart formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

 D operator
P eq|ne
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPERATOR Restriction of operator Simple Type required
Mit diesem Attribut wird ein Vergleich mit einer Variantenart formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

 D operator
P eq|ne
M
Quelle
<xs:element name="FEATURE_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Darf nur bei ACTION RULES vorkommen
Action Rules sind DECISIONS, die einen ActionPart enthalten</xs:documentation>
    <xs:documentation />
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_VALUE_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : MEASURE_VALUE_OP Element
Beschreibung
Mit diesem Element wird der Maßwert einer Variante mit einem weitern Maßwert überprüft.
Namensraum (none)
Diagramm
MEASURE_VALUE_OP Element
Overview
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weitern Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MEASURE_VALUE xs:nonNegativeInteger required

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR Restriction of operator Simple Type required
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Quelle
<xs:element name="MEASURE_VALUE_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > OPTIONS_SET_REF Element : MEASURE_INTERVAL Element
Beschreibung
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
Namensraum (none)
Diagramm
MEASURE_INTERVAL Element
Overview
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN xs:nonNegativeInteger required

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX xs:nonNegativeInteger required
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
Quelle
<xs:element name="MEASURE_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ACTIONS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element : ACTIONS Element
Beschreibung

Dieses Element dient der Festlegung von Aktionen, die bei bestimmten Bedingungen durchgeführt werden.

Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

  • Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

§ Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

§ das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

§ das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

  • Das Setzen von Standardvarianten (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
    Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

  • Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
    So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

Namensraum (none)
Diagramm
SET_MESSAGE Element SET_POS_COUNT_VALUE Element SET_FEATURE_DEFAULT_NULL Element SET_FEATURE Element SET_FEATURE_INVISIBLE Element SET_FEATURE_VISIBLE Element DISABLE_DECISION Element ENABLE_DECISION Element SET_FEATURE_FIXED Element SET_FEATURE_DEFAULT Element Choice ACTIONS Element
Overview
ACTIONS optional

Dieses Element dient der Festlegung von Aktionen, die bei bestimmten Bedingungen durchgeführt werden.

Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

  • Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

§ Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

§ das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

§ das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

  • Das Setzen von Standardvarianten (SET_FEATURE_DEFAULT, SET_FEATURE_DEFAULT_NULL):
    Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.

  • Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
    So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

Choice 1..∞
SET_FEATURE_DEFAULT

Mit dieser Aktion können Standardvarianten gesetzt werden.

Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde.

  • Für das Setzen von Varianten gibt es folgende Möglichkeiten:

- Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

- das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

- das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt als Standard gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Standardwerten.
FORMULA_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
SET_FEATURE_FIXED

Mit dieser Aktion können Varianten gesetzt werden.

Für das Setzen von Varianten gibt es folgende Möglichkeiten:

- Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

- das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

- das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
ENABLE_DECISION

Mit dieser Aktion können Regeln eingeschaltet werden.

DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
DISABLE_DECISION

Mit dieser Aktion können Regeln ausgeschaltet werden.

DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
SET_FEATURE_VISIBLE
Mit dieser Aktion können Variantenarten sichtbar gemacht werden.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
SET_FEATURE_INVISIBLE
Mit dieser Aktion können Variantenarten unsichtbar gemacht werden.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
SET_FEATURE
Mittels dieser Aktion kann ein Wert für eine Variante einer Variantenart gesetzt werden. Dieser Wert kann im Gegensatz zu „SET_FEATURE FIXED“ verändert werden, wenn die Bedingungen das zulassen. Diese Wertebelegung greift auch dann, wenn das entsprechende Feld vorher durch einen Default oder manuell belegt wurde.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
SET_FEATURE_DEFAULT_NULL

Mit dieser Aktion können Standardvarianten gesetzt werden.

Diese Vorbelegung greift nur wenn das entsprechende Variantenfeld vorher leer war.

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von NULL.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die auf NULL gesetzt wird.
OPTION_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
Mit diesem Element wird eine Anzahl in der Stückliste gesetzt.
Diese Aktion darf nur bei Regeln mit DECISION_TYPE = 3 angegeben werden. 		D nonNegativeInteger
P
M [0:9999]
SET_MESSAGE
Dieses Element dient zum Setzen einer Nachricht, so dass bei bestimmten Variantenkombinationen Warnungen oder Hinweise ausgelöst werden können.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Nachricht referenziert. D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="ACTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice maxOccurs="unbounded">
      <xs:element name="SET_FEATURE_DEFAULT">
        <xs:complexType>
          <xs:choice>
            <xs:element name="FEATURE_REF">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORMULA_REF">
              <xs:complexType>
                <xs:attribute name="FORMULA_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_FEATURE_FIXED">
        <xs:complexType>
          <xs:choice>
            <xs:element name="FEATURE_REF">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORMULA_REF">
              <xs:complexType>
                <xs:attribute name="FORMULA_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ENABLE_DECISION">
        <xs:complexType>
          <xs:attribute name="DECISION_NO">
            <xs:annotation>
              <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DISABLE_DECISION">
        <xs:complexType>
          <xs:attribute name="DECISION_NO">
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_FEATURE_VISIBLE">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_FEATURE_INVISIBLE">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_FEATURE">
        <xs:complexType>
          <xs:choice>
            <xs:element name="FEATURE_REF">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORMULA_REF">
              <xs:complexType>
                <xs:attribute name="FORMULA_KEY">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_FEATURE_DEFAULT_NULL">
        <xs:complexType>
          <xs:choice>
            <xs:element name="FEATURE_REF">
              <xs:complexType>
                <xs:attribute name="FEATURE_NO">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="FORMULA_REF">
              <xs:complexType>
                <xs:attribute name="FORMULA_KEY">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_POS_COUNT_VALUE">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
          <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
          <xs:documentation>setzt Anzahl</xs:documentation>
          <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SET_MESSAGE">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
          <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
          <xs:documentation>setzt Anzahl</xs:documentation>
          <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="MESSAGE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE_DEFAULT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE_DEFAULT Element
Beschreibung

Mit dieser Aktion können Standardvarianten gesetzt werden.

Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde.

  • Für das Setzen von Varianten gibt es folgende Möglichkeiten:

- Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

- das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

- das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

Namensraum (none)
Diagramm
FORMULA_REF Element OPTION_REF Element FEATURE_REF Element Choice SET_FEATURE_DEFAULT Element
Overview
SET_FEATURE_DEFAULT

Mit dieser Aktion können Standardvarianten gesetzt werden.

Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde.

  • Für das Setzen von Varianten gibt es folgende Möglichkeiten:

- Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

- das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

- das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt als Standard gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Standardwerten.
FORMULA_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="SET_FEATURE_DEFAULT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice>
      <xs:element name="FEATURE_REF">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORMULA_REF">
        <xs:complexType>
          <xs:attribute name="FORMULA_KEY" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT Element : FEATURE_REF Element
Beschreibung
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
Namensraum (none)
Diagramm
FEATURE_REF Element
Overview
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE_DEFAULT Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT Element : OPTION_REF Element
Beschreibung
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt als Standard gesetzt wird.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt als Standard gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE_DEFAULT Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT Element : FORMULA_REF Element
Beschreibung
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Standardwerten.
Namensraum (none)
Diagramm
FORMULA_REF Element
Overview
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Standardwerten.
FORMULA_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FORMULA_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Quelle
<xs:element name="FORMULA_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FORMULA_KEY" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE_DEFAULT Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE_FIXED Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE_FIXED Element
Beschreibung

Mit dieser Aktion können Varianten gesetzt werden.

Für das Setzen von Varianten gibt es folgende Möglichkeiten:

- Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

- das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

- das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

Namensraum (none)
Diagramm
FORMULA_REF Element OPTION_REF Element FEATURE_REF Element Choice SET_FEATURE_FIXED Element
Overview
SET_FEATURE_FIXED

Mit dieser Aktion können Varianten gesetzt werden.

Für das Setzen von Varianten gibt es folgende Möglichkeiten:

- Direkt , wie z.B. Haupstoff = „blau“ (OPTION)

- das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

- das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt).

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="SET_FEATURE_FIXED" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice>
      <xs:element name="FEATURE_REF">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORMULA_REF">
        <xs:complexType>
          <xs:attribute name="FORMULA_KEY" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_FIXED Element : FEATURE_REF Element
Beschreibung
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
Namensraum (none)
Diagramm
FEATURE_REF Element
Overview
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE_FIXED Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_FIXED Element : OPTION_REF Element
Beschreibung
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE_FIXED Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_FIXED Element : FORMULA_REF Element
Beschreibung
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
Namensraum (none)
Diagramm
FORMULA_REF Element
Overview
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FORMULA_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Quelle
<xs:element name="FORMULA_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FORMULA_KEY" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE_FIXED Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ENABLE_DECISION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : ENABLE_DECISION Element
Beschreibung

Mit dieser Aktion können Regeln eingeschaltet werden.

Namensraum (none)
Diagramm
ENABLE_DECISION Element
Overview
ENABLE_DECISION

Mit dieser Aktion können Regeln eingeschaltet werden.

DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DECISION_NO Restriction of xs:positiveInteger optional
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="ENABLE_DECISION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="DECISION_NO">
      <xs:annotation>
        <xs:documentation>einheitlich auf 1 bis 9999999999 gesetzt, K. Richter 10.03.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DISABLE_DECISION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : DISABLE_DECISION Element
Beschreibung

Mit dieser Aktion können Regeln ausgeschaltet werden.

Namensraum (none)
Diagramm
DISABLE_DECISION Element
Overview
DISABLE_DECISION

Mit dieser Aktion können Regeln ausgeschaltet werden.

DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DECISION_NO Restriction of xs:positiveInteger optional
Mit diesem Attribut wird eine Regel referenziert. D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DISABLE_DECISION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="DECISION_NO">
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE_VISIBLE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE_VISIBLE Element
Beschreibung
Mit dieser Aktion können Variantenarten sichtbar gemacht werden.
Namensraum (none)
Diagramm
SET_FEATURE_VISIBLE Element
Overview
SET_FEATURE_VISIBLE
Mit dieser Aktion können Variantenarten sichtbar gemacht werden.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger optional
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="SET_FEATURE_VISIBLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE_INVISIBLE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE_INVISIBLE Element
Beschreibung
Mit dieser Aktion können Variantenarten unsichtbar gemacht werden.
Namensraum (none)
Diagramm
SET_FEATURE_INVISIBLE Element
Overview
SET_FEATURE_INVISIBLE
Mit dieser Aktion können Variantenarten unsichtbar gemacht werden.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger optional
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="SET_FEATURE_INVISIBLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE Element
Beschreibung
Mittels dieser Aktion kann ein Wert für eine Variante einer Variantenart gesetzt werden. Dieser Wert kann im Gegensatz zu „SET_FEATURE FIXED“ verändert werden, wenn die Bedingungen das zulassen. Diese Wertebelegung greift auch dann, wenn das entsprechende Feld vorher durch einen Default oder manuell belegt wurde.
Namensraum (none)
Diagramm
FORMULA_REF Element OPTION_REF Element FEATURE_REF Element Choice SET_FEATURE Element
Overview
SET_FEATURE
Mittels dieser Aktion kann ein Wert für eine Variante einer Variantenart gesetzt werden. Dieser Wert kann im Gegensatz zu „SET_FEATURE FIXED“ verändert werden, wenn die Bedingungen das zulassen. Diese Wertebelegung greift auch dann, wenn das entsprechende Feld vorher durch einen Default oder manuell belegt wurde.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="SET_FEATURE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice>
      <xs:element name="FEATURE_REF">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORMULA_REF">
        <xs:complexType>
          <xs:attribute name="FORMULA_KEY">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE Element : FEATURE_REF Element
Beschreibung
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
Namensraum (none)
Diagramm
FEATURE_REF Element
Overview
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von Variantenwerten.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE Element : OPTION_REF Element
Beschreibung
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die direkt gesetzt wird.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>use required aufgenommen, K. Rchter, 12.06.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE Element : FORMULA_REF Element
Beschreibung
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
Namensraum (none)
Diagramm
FORMULA_REF Element
Overview
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FORMULA_KEY Restriction of xs:string optional
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Quelle
<xs:element name="FORMULA_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FORMULA_KEY">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_FEATURE_DEFAULT_NULL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_FEATURE_DEFAULT_NULL Element
Beschreibung

Mit dieser Aktion können Standardvarianten gesetzt werden.

Diese Vorbelegung greift nur wenn das entsprechende Variantenfeld vorher leer war.

Namensraum (none)
Diagramm
FORMULA_REF Element OPTION_REF Element FEATURE_REF Element Choice SET_FEATURE_DEFAULT_NULL Element
Overview
SET_FEATURE_DEFAULT_NULL

Mit dieser Aktion können Standardvarianten gesetzt werden.

Diese Vorbelegung greift nur wenn das entsprechende Variantenfeld vorher leer war.

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von NULL.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die auf NULL gesetzt wird.
OPTION_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="SET_FEATURE_DEFAULT_NULL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:choice>
      <xs:element name="FEATURE_REF">
        <xs:complexType>
          <xs:attribute name="FEATURE_NO">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="FORMULA_REF">
        <xs:complexType>
          <xs:attribute name="FORMULA_KEY">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT_NULL Element : FEATURE_REF Element
Beschreibung
Dieses Element referenziert auf eine andere Variantenart für das Setzen von NULL.
Namensraum (none)
Diagramm
FEATURE_REF Element
Overview
FEATURE_REF
Dieses Element referenziert auf eine andere Variantenart für das Setzen von NULL.
FEATURE_NO optional Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger optional
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FEATURE_NO">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE_DEFAULT_NULL Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT_NULL Element : OPTION_REF Element
Beschreibung
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die auf NULL gesetzt wird.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Mit diesem Element wird auf eine Variante (OPTION) referenziert, die auf NULL gesetzt wird.
OPTION_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string optional
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE_DEFAULT_NULL Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element > SET_FEATURE_DEFAULT_NULL Element : FORMULA_REF Element
Beschreibung
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
Namensraum (none)
Diagramm
FORMULA_REF Element
Overview
FORMULA_REF
Dieses Element dient der Referenzierung auf eine Formel zum Berechnen von Varianten.
FORMULA_KEY optional Restriction of xs:string
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FORMULA_KEY Restriction of xs:string optional
Mit diesem Attribut wird eine Formel referenziert. D string
P
M [1:30]
Quelle
<xs:element name="FORMULA_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="FORMULA_KEY">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_FEATURE_DEFAULT_NULL Element | ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_POS_COUNT_VALUE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_POS_COUNT_VALUE Element
Beschreibung
Mit diesem Element wird eine Anzahl in der Stückliste gesetzt.
Diese Aktion darf nur bei Regeln mit DECISION_TYPE = 3 angegeben werden. 		D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
SET_POS_COUNT_VALUE Element
Overview
SET_POS_COUNT_VALUE Restriction of xs:nonNegativeInteger
Mit diesem Element wird eine Anzahl in der Stückliste gesetzt.
Diese Aktion darf nur bei Regeln mit DECISION_TYPE = 3 angegeben werden. 		D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="SET_POS_COUNT_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
    <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
    <xs:documentation>setzt Anzahl</xs:documentation>
    <xs:documentation>darf nur von DECISION_TYPE 3 gesetzt werden</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SET_MESSAGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element > OPTION_COMBINATION Element > ACTIONS Element : SET_MESSAGE Element
Beschreibung
Dieses Element dient zum Setzen einer Nachricht, so dass bei bestimmten Variantenkombinationen Warnungen oder Hinweise ausgelöst werden können.
Namensraum (none)
Diagramm
SET_MESSAGE Element
Overview
SET_MESSAGE
Dieses Element dient zum Setzen einer Nachricht, so dass bei bestimmten Variantenkombinationen Warnungen oder Hinweise ausgelöst werden können.
MESSAGE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Nachricht referenziert. D nonNegativeInteger
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MESSAGE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Nachricht referenziert. D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="SET_MESSAGE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
    <xs:documentation>bestimmt, ob Unterposition gezogen wird</xs:documentation>
    <xs:documentation>setzt Anzahl</xs:documentation>
    <xs:documentation>darf nur von DECISION_TYPE 4 gesetzt werden</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MESSAGE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ACTIONS Element | OPTION_COMBINATION Element | DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum an, ab dem eine Regel gültig ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem eine Regel gültig ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum an, bis zu welchem eine Regel gültig ist.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem eine Regel gültig ist.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FEATURE_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : FEATURE_REF Element
Beschreibung
Mit diesem Element wird auf die Variantenart referenziert.
Namensraum (none)
Diagramm
FEATURE_REF Element
Overview
FEATURE_REF 0..∞
Mit diesem Element wird auf die Variantenart referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Entscheidungstabellen wieder entfernt, nur Angabe FEATURE_NO, 02.05.2014</xs:documentation>
    <xs:documentation xml:lang="de">Version Beta 2.0 Build 12</xs:documentation>
    <xs:documentation xml:lang="de">minimale Kardinalität auf 0 geändert K.Richter 18.07.2014</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRIO Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > DECISIONS Element > DECISION Element : PRIO Element
Beschreibung
Dieses Element dient der Angabe eines Wertes für die Priorität einer Regel.
Dabei stellt ein kleiner Wert ein hohe Priorität dar. Das heißt, je größer dieser Wert ist, desto schlechter ist der Vorrang dieser Regel. 		D positiveInteger
P
M [1:999999999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRIO Element
Overview
PRIO Restriction of xs:positiveInteger
Dieses Element dient der Angabe eines Wertes für die Priorität einer Regel.
Dabei stellt ein kleiner Wert ein hohe Priorität dar. Das heißt, je größer dieser Wert ist, desto schlechter ist der Vorrang dieser Regel. 		D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="PRIO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">neu IDM 2.4
Priorität von Prüfungen

Am Artikel können nur Decisions mit niedriger Priorität hinzu bzw. ausgeschaltet werden
Mehrere DECISIONS können auf einem gleichen Priolevel liegen

</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DECISION Element | DECISIONS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUPS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : OPTION_GROUPS Element
Beschreibung
Dieses Element dient der Gruppierung von Mengen mehrerer Varianten. Sie können in den Prüfungen unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.
Namensraum (none)
Diagramm
OPTION_GROUP Element Sequence OPTION_GROUPS Element
Overview
OPTION_GROUPS optional
Dieses Element dient der Gruppierung von Mengen mehrerer Varianten. Sie können in den Prüfungen unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.
Sequence
OPTION_GROUP 1..∞

Dieses Element dient zur Festlegung eine Variantengruppe.

Sie kann in den Prüfungen unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.

OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe identifiziert. D string
P
M [1:30]
Sequence
OPTION 1..∞
Mit diesem Element wird auf eine Variante referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut definiert die Reihenfolge der Varianten in einer Variantengruppe D nonNegativeInteger
P
M
OPTION_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Variantengruppen.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="OPTION_GROUPS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_GROUP" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_GROUP_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPTION_GROUP_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_GROUPS Element : OPTION_GROUP Element
Beschreibung

Dieses Element dient zur Festlegung eine Variantengruppe.

Sie kann in den Prüfungen unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence OPTION_GROUP_TEXT Element OPTION Element Sequence OPTION_GROUP Element
Overview
OPTION_GROUP 1..∞

Dieses Element dient zur Festlegung eine Variantengruppe.

Sie kann in den Prüfungen unterhalb von OPTION_COMBINATION/FEATURE_REF in den DECISIONS referenziert werden. Diese Varianten sind als unabhängiger Pool zu betrachten und haben keine Verbindung zu einer Variantenart.

OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe identifiziert. D string
P
M [1:30]
Sequence
OPTION 1..∞
Mit diesem Element wird auf eine Variante referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut definiert die Reihenfolge der Varianten in einer Variantengruppe D nonNegativeInteger
P
M
OPTION_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Variantengruppen.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_GROUP_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantengruppe identifiziert. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_GROUP_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPTION_GROUP_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_GROUPS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_GROUPS Element > OPTION_GROUP Element : OPTION Element
Beschreibung
Mit diesem Element wird auf eine Variante referenziert.
Namensraum (none)
Diagramm
OPTION Element
Overview
OPTION 1..∞
Mit diesem Element wird auf eine Variante referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut definiert die Reihenfolge der Varianten in einer Variantengruppe D nonNegativeInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional
Dieses Attribut definiert die Reihenfolge der Varianten in einer Variantengruppe D nonNegativeInteger
P
M
Quelle
<xs:element name="OPTION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_GROUP Element | OPTION_GROUPS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUP_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > OPTION_GROUPS Element > OPTION_GROUP Element : OPTION_GROUP_TEXT Element
Beschreibung
Dieses Element enthält Texte für Variantengruppen.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence OPTION_GROUP_TEXT Element
Overview
OPTION_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Variantengruppen.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="OPTION_GROUP_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION_GROUP Element | OPTION_GROUPS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULAS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element : FORMULAS Element
Beschreibung
Dieses Element steht für das Rechnen von Varianten (z.B. Sitzhöhe + 5cm) zur Verfügung. Die Funktion ist allerdings nur für Maßvarianten erlaubt, deren Variantenart den Wert ″M″ enthält, in dem Element MEASURE_UNIT die Maßeinheit und in MEASURE_PARAMETER der Parameter (z. B. sh für Sitzhöhe) eingetragen werden kann. Das Rechnen geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Namensraum (none)
Diagramm
FORMULA Element Sequence FORMULAS Element
Overview
FORMULAS optional
Dieses Element steht für das Rechnen von Varianten (z.B. Sitzhöhe + 5cm) zur Verfügung. Die Funktion ist allerdings nur für Maßvarianten erlaubt, deren Variantenart den Wert ″M″ enthält, in dem Element MEASURE_UNIT die Maßeinheit und in MEASURE_PARAMETER der Parameter (z. B. sh für Sitzhöhe) eingetragen werden kann. Das Rechnen geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Sequence
FORMULA 1..∞
Das Element dient der Definition einer Formel. Das Attribut FORMULA_KEY enthält den Identifikator, das Element FORMULA_STRING die eigentliche Formel.
FORMULA_KEY required Restriction of xs:string
Mit diesem Attribut wird der Schlüssel für die Formel definiert. D string
P
M [1:30]
Sequence
FORMULA_STRING Restriction of xs:string
Dieses Element dient der Angabe einer Formel. D string
P [+\-*/()A-Za-z. ]{0,}
M
Quelle
<xs:element name="FORMULAS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Formeln dürfen nur angewendet werden auf Maßvarianten </xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FORMULA" maxOccurs="unbounded">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FORMULA_STRING">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Formeln dürfen nur Parameter enthalten, die an der Variantenart definiert wurden.</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[+\-*/()A-Za-z0-9. ]*" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FORMULA_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FORMULAS Element : FORMULA Element
Beschreibung
Das Element dient der Definition einer Formel. Das Attribut FORMULA_KEY enthält den Identifikator, das Element FORMULA_STRING die eigentliche Formel.
Namensraum (none)
Diagramm
FORMULA_STRING Element Sequence FORMULA Element
Overview
FORMULA 1..∞
Das Element dient der Definition einer Formel. Das Attribut FORMULA_KEY enthält den Identifikator, das Element FORMULA_STRING die eigentliche Formel.
FORMULA_KEY required Restriction of xs:string
Mit diesem Attribut wird der Schlüssel für die Formel definiert. D string
P
M [1:30]
Sequence
FORMULA_STRING Restriction of xs:string
Dieses Element dient der Angabe einer Formel. D string
P [+\-*/()A-Za-z. ]{0,}
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FORMULA_KEY Restriction of xs:string required
Mit diesem Attribut wird der Schlüssel für die Formel definiert. D string
P
M [1:30]
Quelle
<xs:element name="FORMULA" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FORMULA_STRING">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Formeln dürfen nur Parameter enthalten, die an der Variantenart definiert wurden.</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[+\-*/()A-Za-z0-9. ]*" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FORMULA_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FORMULAS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FORMULA_STRING Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > FEATURE_DEFINITION Element > FORMULAS Element > FORMULA Element : FORMULA_STRING Element
Beschreibung
Dieses Element dient der Angabe einer Formel. D string
P [+\-*/()A-Za-z. ]{0,}
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FORMULA_STRING Element
Overview
FORMULA_STRING Restriction of xs:string
Dieses Element dient der Angabe einer Formel. D string
P [+\-*/()A-Za-z. ]{0,}
M
Quelle
<xs:element name="FORMULA_STRING" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Formeln dürfen nur Parameter enthalten, die an der Variantenart definiert wurden.</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[+\-*/()A-Za-z0-9. ]*" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FORMULA Element | FORMULAS Element | FEATURE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_DEFINITION Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element : PRICE_DEFINITION Element
Beschreibung
In diesem Element werden Informationen hinterlegt, die für die Preisberechnung notwendig sind wie beispielsweise Preistabellen und Ausführungsgruppen.
Namensraum (none)
Diagramm
PRICE_TYPES Element PRICE_FEATURE_GROUPS Element Sequence PRICE_DEFINITION Element
Overview
PRICE_DEFINITION
In diesem Element werden Informationen hinterlegt, die für die Preisberechnung notwendig sind wie beispielsweise Preistabellen und Ausführungsgruppen.
Sequence
PRICE_FEATURE_GROUPS
In diesem Element werden Ausführungsgruppen (PRICE_FEATURE_GROUPS) definiert.
Sequence
PRICE_FEATURE_GROUP 1..∞

In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

Eine PRICE_FEATURE_GROUP wird vom Artikel referenziert. Beim Artikel werden auch die konkreten Preise hinterlegt.

Für die PRICE_FEATURE_GROUP bzw. für Artikel gelten folgende Regelungen:
- Preisgruppenneutrale Artikel können Varianten haben, die sich jedoch nicht preislich auswirken. Ihr Preis muss nicht in Preisfeld 1 stehen, sie dürfen jedoch nur ein Element FINISH für die Preisfeldangabe haben. Für preisfeldunabhängige Artikel, für die nur ein Element FINISH in der PRICE_FEATURE_GROUP existiert, in dem der Preis festgehalten wird, dürfen nur einen zugeordneten Preis entsprechend des im FINISH-Element angegebenen Preisfeldes haben.

- Ausführungsabhängige Artikel haben ein oder mehrere Variantenarten.
- Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0).

- Es dürfen prinzipiell mehrere PRICE_FEATURE_GROUPs mit derselben Kombination von Variantenarten angelegt werden.

PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP eindeutig identifiziert. D postiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis).
 D boolean
P
M
Sequence
PRICE_FEATURE_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Ausführungsgruppen
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Choice
FINISH 0..∞
In diesem Element werden gültigen Variantenkombinationen Preisfelder (PRICE_FIELD) und eine Herstellerpreisgruppe zugeordnet.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt die Preisgruppe. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und eine Preisgruppe für ihre Variantenausprägungen definiert. Die Preisgruppen können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt. 

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.
 D string
P
M [1:10]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem das Preisfeld gültig ist. D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis wann das Preisfeld gültig ist. D date
P
M
PERCENTAGE_SURCHARGE 0..∞
Um prozentuale Mehrpreise zu ermöglichen, gibt es zusätzlich zu dem Element FINISH unterhalb von PRICE_FEATURE_GROUP das Element PERCENTAGE_SURCHARGE bestehend aus OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM und VALID_UNTIL.
Dieses Element darf nur für PRICE_FEATURE_GROUP's genutzt werden, für die das Kennzeichen ADDITIONAL_PRICE auf 1 gesetzt ist (1=Mehrpreis).
Der prozentuale Mehrpreis kann sich auf unterschiedliche PRICE_FEATURE_GROUPs beziehen:

Fall 1

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

Aufpreis Rapport 10% auf Basis + Kopfstütze --> Faktor 0,1 * (500+50) = 55

Aufpreis XY 20% auf alles --> Faktor 0,2 * (500+50+66+50+55) = 144,20

Positionswert = 865,20

Fall 2

Basispreis 500,00

Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

Positionswert = 550,00

Fall 3

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis XY 20% auf Basispreis + Kopfstütze + Funktion --> Faktor 0,2 * (500+50+66)=123,20

Positionswert = 739,20

Fall 4

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis XY 20% auf ( Basispreis + Kopfstütze + Funktion ) --> Faktor 0,2 * (500+50+66)=123,20

Aufpreis ZZ -10% auf ( Basispreis + Funktion ) --> Faktor -0,1 * (500+66)= -56,60

Positionswert = 682,60

Fall 5

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Konditionswert 616,00

Aufpreis Global1 10% auf alles --> Faktor 0,1 * 616 entspricht Konditionswert = 61,60

Aufpreis Global2 20% auf alles --> Faktor 0,2 * 616 entspricht Konditionswert = 123,20

Positionswert = 800,80

Der Wert des Faktors ist im Element PRICE_FACTOR festzuhalten.

Die Preisgruppen, auf die sich der prozentuale Aufschlag bezieht, werden unter PRICE_FEATURE_GROUP_REF angegeben.

Die Gültigkeit ist in den Elementen VALID_FROM und VALID_UNTIL vermerkt.

Positionswert = 800,80
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt den prozentualen Mehrpreis.. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und ein prozentualer Mehrpreis für ihre Variantenausprägungen definiert. Die prozentualen Mehrpreise können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt.

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
PRICE_FACTOR Restriction of xs:int

Dieses Element gibt einen prozentualen Mehrpreis an. Er wird als Faktor mit 5 Nachkommastellen angegeben.

Der Wert 1050000 entspricht einem Aufschlag von 10,5 %.

Der Wert -1000000 entspricht einem Aufpreis von -10 %.

 D int
P
M [-9999999:99999999]
PRICE_FEATURE_GROUP_REF 0..∞
Dieses Element referenziert eine Preisgruppe abhängig von der Variantenart bzw. Kalkulationsmethode (PRICE_FEATURE_GROUP).
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der prozentuale Mehrpreis gültig ist. D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis wann der prozentuale Mehrpreis gültig ist. D date
P
M
PRICE_TYPES
In diesem Element werden die Preisarten zur stück- oder maßvariablen Berechnung von variantenneutralen und variantenabhängigen Artikeln definiert.
Die Kind-Elemente WIDTH_X, DEPTH_Y, HEIGHT_Z geben an, ob der Preis für einen Artikel, der nach dieser Preisart berechnet wird, breiten-, höhen-, tiefen-, flächen- bzw. volumenabhängig ist.
Wenn für keine Dimension eine "1" angegeben ist, ist der Preis nicht maßabhängig, wird also per Stück berechnet (beispielsweise ein Sitzelement). Dann werden die Elemente BASIC_UNIT und ROUNDING_UNIT mit dem Wert 0 belegt.
Wird für genau eine Dimension eine "1" angegeben, so wird diese Dimension für die Preisberechnung herangezogen (beispielsweise Stoffe).
Wenn für genau zwei Dimensionen eine "1" angegeben ist, so ist der Preis flächenabhängig (beispielsweise Teppiche).
Wenn für genau drei Dimensionen eine "1" angegeben ist, so ist der Preis volumenabhängig (beispielsweise Liegeteile).
Sequence 1..∞
PRICE_TYPE
In diesem Element wird eine Preisart definiert.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (P1) und ADDITIONAL_PRICE (P2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in dieses Element "1000" anzugeben. Bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³] eingegeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein.

P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein. D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_TYPE Restriction of xs:positiveInteger

Um die unterschiedlichen Arten der Rundung angeben zu können, wird zusätzlich zum Element ROUNDING_UNIT das Element ROUNDING_TYPE mit den möglichen Werten 1, 2 und 3 aufgenommen, um ein Auf-, Ab- und kaufmännisches Runden zu kennzeichnen.

Die Werte haben folgende Bedeutung:

1 Aufrunden

2 Abrunden

3 Kaufmännisches Runden

 D positiveInteger
P
M [1:3]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean

Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf
Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist
die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/
PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem
Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als
Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben,
der sich auf im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung
zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis
des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem
berechnetem Restmaßpreis, unter Berücksichtigung der im Element definierten Logik,
zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens
eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung
mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE
herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

 D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) oder HEIGHT_Z (P1) (h) auf true gesetzt werden;
- es können die Grundrechendarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (P1), ROUNDING_UNIT (P1) und BASIC_PRICE_DEPENDENT (P1) gelten auch in Verbindung mit der Preisartformel.

[SSS_Elementpfade_SSS]Elementpfade[EEE_Elementpfade_EEE]
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetext60 Complex Type
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PRICE_TYPE_RULES optional
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
Sequence
PRICE_TYPE_RULE 1..100
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Element wird die Nummer der Regel hinterlegt. D nonNegativeInteger
P
M [0:9999]
Sequence
RULE xs:string
In diesem Element wird die Regel definiert. D string
P
M
Bemerkung

Quelle
<xs:element name="PRICE_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>300--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:choice>
                    <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                              <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:choice>
                                <xs:element name="OPTION_INTERVAL">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPTION_KEY_MIN" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPTION_KEY_MAX" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_LIST">
                                  <xs:complexType>
                                    <xs:sequence maxOccurs="unbounded">
                                      <xs:element name="OPTION_REF">
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_KEY" use="required">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_GROUP_REF_OP">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_REF_OP">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_KEY" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MEASURE_VALUE_OP">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MEASURE_INTERVAL">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                    <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                              <xs:attribute name="FEATURE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="PRICE_FIELD">
                            <xs:annotation>
                              <xs:documentation>311--5--Preisfeld</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:positiveInteger">
                                <xs:minInclusive value="1" />
                                <xs:maxInclusive value="9999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="SUPPLIER_PRICE_GROUP">
                            <xs:annotation>
                              <xs:documentation>311--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:string">
                                <xs:minLength value="1" />
                                <xs:maxLength value="10" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="VALID_FROM" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:date" />
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="VALID_UNTIL" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:date" />
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="SEQUENCE" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="PERCENTAGE_SURCHARGE" minOccurs="0" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>geändert K.Richter 23.11.2015</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:sequence>
                          <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                              <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:choice>
                                <xs:element name="OPTION_INTERVAL">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPTION_KEY_MIN" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPTION_KEY_MAX" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_LIST">
                                  <xs:complexType>
                                    <xs:sequence maxOccurs="unbounded">
                                      <xs:element name="OPTION_REF">
                                        <xs:complexType>
                                          <xs:attribute name="OPTION_KEY" use="required">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="30" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:attribute>
                                        </xs:complexType>
                                      </xs:element>
                                    </xs:sequence>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_GROUP_REF_OP">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="OPTION_REF_OP">
                                  <xs:annotation>
                                    <xs:documentation>271--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_KEY" use="required">
                                      <xs:annotation>
                                        <xs:documentation>271--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MEASURE_VALUE_OP">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MEASURE_INTERVAL">
                                  <xs:annotation>
                                    <xs:documentation>1000--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="OPERATOR" use="required">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="operator">
                                          <xs:pattern value="in|nin" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                    <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                      </xs:annotation>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:choice>
                              <xs:attribute name="FEATURE_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="PRICE_FACTOR">
                            <xs:annotation>
                              <xs:documentation>311--5--Preisfeld</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:int">
                                <xs:maxInclusive value="99999999" />
                                <xs:minInclusive value="-9999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                            <xs:annotation>
                              <xs:documentation>311--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                <xs:annotation>
                                  <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="VALID_FROM" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:date" />
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="VALID_UNTIL" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                              <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:date" />
                            </xs:simpleType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="SEQUENCE" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="ADDITIONAL_PRICE" use="required">
                  <xs:annotation>
                    <xs:documentation>300--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:boolean" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPES">
        <xs:annotation>
          <xs:documentation>150--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence maxOccurs="unbounded">
            <xs:element name="PRICE_TYPE">
              <xs:annotation>
                <xs:documentation>150--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="WIDTH_X">
                    <xs:annotation>
                      <xs:documentation>150--3--Breite_X</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPTH_Y">
                    <xs:annotation>
                      <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HEIGHT_Z">
                    <xs:annotation>
                      <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_UNIT">
                    <xs:annotation>
                      <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ROUNDING_UNIT">
                    <xs:annotation>
                      <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ROUNDING_TYPE">
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BASIC_PRICE_DEPENDENT">
                    <xs:annotation>
                      <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="100" />
                        <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_NAME" type="languagetext60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_RULES" minOccurs="0" maxOccurs="1">
                    <xs:annotation>
                      <xs:documentation>360--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_TYPE_RULE" maxOccurs="100">
                          <xs:annotation>
                            <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
                            <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RULE" type="xs:string">
                                <xs:annotation>
                                  <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
                                  <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="RULE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>360--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="9999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>150--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUPS Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element : PRICE_FEATURE_GROUPS Element
Beschreibung
In diesem Element werden Ausführungsgruppen (PRICE_FEATURE_GROUPS) definiert.
Namensraum (none)
Diagramm
PRICE_FEATURE_GROUP Element Sequence PRICE_FEATURE_GROUPS Element
Overview
PRICE_FEATURE_GROUPS
In diesem Element werden Ausführungsgruppen (PRICE_FEATURE_GROUPS) definiert.
Sequence
PRICE_FEATURE_GROUP 1..∞

In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

Eine PRICE_FEATURE_GROUP wird vom Artikel referenziert. Beim Artikel werden auch die konkreten Preise hinterlegt.

Für die PRICE_FEATURE_GROUP bzw. für Artikel gelten folgende Regelungen:
- Preisgruppenneutrale Artikel können Varianten haben, die sich jedoch nicht preislich auswirken. Ihr Preis muss nicht in Preisfeld 1 stehen, sie dürfen jedoch nur ein Element FINISH für die Preisfeldangabe haben. Für preisfeldunabhängige Artikel, für die nur ein Element FINISH in der PRICE_FEATURE_GROUP existiert, in dem der Preis festgehalten wird, dürfen nur einen zugeordneten Preis entsprechend des im FINISH-Element angegebenen Preisfeldes haben.

- Ausführungsabhängige Artikel haben ein oder mehrere Variantenarten.
- Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0).

- Es dürfen prinzipiell mehrere PRICE_FEATURE_GROUPs mit derselben Kombination von Variantenarten angelegt werden.

PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP eindeutig identifiziert. D postiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis).
 D boolean
P
M
Sequence
PRICE_FEATURE_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Ausführungsgruppen
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Choice
FINISH 0..∞
In diesem Element werden gültigen Variantenkombinationen Preisfelder (PRICE_FIELD) und eine Herstellerpreisgruppe zugeordnet.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt die Preisgruppe. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und eine Preisgruppe für ihre Variantenausprägungen definiert. Die Preisgruppen können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt. 

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.
 D string
P
M [1:10]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem das Preisfeld gültig ist. D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis wann das Preisfeld gültig ist. D date
P
M
PERCENTAGE_SURCHARGE 0..∞
Um prozentuale Mehrpreise zu ermöglichen, gibt es zusätzlich zu dem Element FINISH unterhalb von PRICE_FEATURE_GROUP das Element PERCENTAGE_SURCHARGE bestehend aus OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM und VALID_UNTIL.
Dieses Element darf nur für PRICE_FEATURE_GROUP's genutzt werden, für die das Kennzeichen ADDITIONAL_PRICE auf 1 gesetzt ist (1=Mehrpreis).
Der prozentuale Mehrpreis kann sich auf unterschiedliche PRICE_FEATURE_GROUPs beziehen:

Fall 1

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

Aufpreis Rapport 10% auf Basis + Kopfstütze --> Faktor 0,1 * (500+50) = 55

Aufpreis XY 20% auf alles --> Faktor 0,2 * (500+50+66+50+55) = 144,20

Positionswert = 865,20

Fall 2

Basispreis 500,00

Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

Positionswert = 550,00

Fall 3

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis XY 20% auf Basispreis + Kopfstütze + Funktion --> Faktor 0,2 * (500+50+66)=123,20

Positionswert = 739,20

Fall 4

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis XY 20% auf ( Basispreis + Kopfstütze + Funktion ) --> Faktor 0,2 * (500+50+66)=123,20

Aufpreis ZZ -10% auf ( Basispreis + Funktion ) --> Faktor -0,1 * (500+66)= -56,60

Positionswert = 682,60

Fall 5

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Konditionswert 616,00

Aufpreis Global1 10% auf alles --> Faktor 0,1 * 616 entspricht Konditionswert = 61,60

Aufpreis Global2 20% auf alles --> Faktor 0,2 * 616 entspricht Konditionswert = 123,20

Positionswert = 800,80

Der Wert des Faktors ist im Element PRICE_FACTOR festzuhalten.

Die Preisgruppen, auf die sich der prozentuale Aufschlag bezieht, werden unter PRICE_FEATURE_GROUP_REF angegeben.

Die Gültigkeit ist in den Elementen VALID_FROM und VALID_UNTIL vermerkt.

Positionswert = 800,80
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt den prozentualen Mehrpreis.. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und ein prozentualer Mehrpreis für ihre Variantenausprägungen definiert. Die prozentualen Mehrpreise können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt.

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
PRICE_FACTOR Restriction of xs:int

Dieses Element gibt einen prozentualen Mehrpreis an. Er wird als Faktor mit 5 Nachkommastellen angegeben.

Der Wert 1050000 entspricht einem Aufschlag von 10,5 %.

Der Wert -1000000 entspricht einem Aufpreis von -10 %.

 D int
P
M [-9999999:99999999]
PRICE_FEATURE_GROUP_REF 0..∞
Dieses Element referenziert eine Preisgruppe abhängig von der Variantenart bzw. Kalkulationsmethode (PRICE_FEATURE_GROUP).
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der prozentuale Mehrpreis gültig ist. D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis wann der prozentuale Mehrpreis gültig ist. D date
P
M
Bemerkung

Quelle
<xs:element name="PRICE_FEATURE_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>300--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:choice>
              <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>1000--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                        <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:choice>
                          <xs:element name="OPTION_INTERVAL">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPTION_KEY_MIN" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPTION_KEY_MAX" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_LIST">
                            <xs:complexType>
                              <xs:sequence maxOccurs="unbounded">
                                <xs:element name="OPTION_REF">
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_KEY" use="required">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_GROUP_REF_OP">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_REF_OP">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_KEY" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MEASURE_VALUE_OP">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MEASURE_INTERVAL">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                              <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:attribute name="FEATURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="PRICE_FIELD">
                      <xs:annotation>
                        <xs:documentation>311--5--Preisfeld</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:positiveInteger">
                          <xs:minInclusive value="1" />
                          <xs:maxInclusive value="9999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="SUPPLIER_PRICE_GROUP">
                      <xs:annotation>
                        <xs:documentation>311--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:string">
                          <xs:minLength value="1" />
                          <xs:maxLength value="10" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="VALID_FROM" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:date" />
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="VALID_UNTIL" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:date" />
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="SEQUENCE" use="required">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="PERCENTAGE_SURCHARGE" minOccurs="0" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>geändert K.Richter 23.11.2015</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:sequence>
                    <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                        <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:choice>
                          <xs:element name="OPTION_INTERVAL">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPTION_KEY_MIN" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPTION_KEY_MAX" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_LIST">
                            <xs:complexType>
                              <xs:sequence maxOccurs="unbounded">
                                <xs:element name="OPTION_REF">
                                  <xs:complexType>
                                    <xs:attribute name="OPTION_KEY" use="required">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="30" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_GROUP_REF_OP">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_GROUP_KEY" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="OPTION_REF_OP">
                            <xs:annotation>
                              <xs:documentation>271--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPTION_KEY" use="required">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MEASURE_VALUE_OP">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="eq|ne|gt|lt|ge|le" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MEASURE_INTERVAL">
                            <xs:annotation>
                              <xs:documentation>1000--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="OPERATOR" use="required">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="operator">
                                    <xs:pattern value="in|nin" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                              <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                                  <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                                </xs:annotation>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:choice>
                        <xs:attribute name="FEATURE_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="PRICE_FACTOR">
                      <xs:annotation>
                        <xs:documentation>311--5--Preisfeld</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:int">
                          <xs:maxInclusive value="99999999" />
                          <xs:minInclusive value="-9999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                      <xs:annotation>
                        <xs:documentation>311--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                          <xs:annotation>
                            <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="VALID_FROM" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:date" />
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="VALID_UNTIL" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                        <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:date" />
                      </xs:simpleType>
                    </xs:element>
                  </xs:sequence>
                  <xs:attribute name="SEQUENCE" use="required">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:choice>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="ADDITIONAL_PRICE" use="required">
            <xs:annotation>
              <xs:documentation>300--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:boolean" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element : PRICE_FEATURE_GROUP Element
Beschreibung

In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

Eine PRICE_FEATURE_GROUP wird vom Artikel referenziert. Beim Artikel werden auch die konkreten Preise hinterlegt.

Für die PRICE_FEATURE_GROUP bzw. für Artikel gelten folgende Regelungen:
- Preisgruppenneutrale Artikel können Varianten haben, die sich jedoch nicht preislich auswirken. Ihr Preis muss nicht in Preisfeld 1 stehen, sie dürfen jedoch nur ein Element FINISH für die Preisfeldangabe haben. Für preisfeldunabhängige Artikel, für die nur ein Element FINISH in der PRICE_FEATURE_GROUP existiert, in dem der Preis festgehalten wird, dürfen nur einen zugeordneten Preis entsprechend des im FINISH-Element angegebenen Preisfeldes haben.

- Ausführungsabhängige Artikel haben ein oder mehrere Variantenarten.
- Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0).

- Es dürfen prinzipiell mehrere PRICE_FEATURE_GROUPs mit derselben Kombination von Variantenarten angelegt werden.

Namensraum (none)
Diagramm
PERCENTAGE_SURCHARGE Element FINISH Element Choice LANGUAGE Element Sequence PRICE_FEATURE_GROUP_TEXT Element Sequence PRICE_FEATURE_GROUP Element
Overview
PRICE_FEATURE_GROUP 1..∞

In diesem Element werden Informationen für die Preissteuerung hinterlegt. Über die PRICE_FEATURE_GROUP wird gesteuert, unter welchen Bedingungen (z. B. Variantenkombinationen) ein Preis gezogen wird.

Eine PRICE_FEATURE_GROUP wird vom Artikel referenziert. Beim Artikel werden auch die konkreten Preise hinterlegt.

Für die PRICE_FEATURE_GROUP bzw. für Artikel gelten folgende Regelungen:
- Preisgruppenneutrale Artikel können Varianten haben, die sich jedoch nicht preislich auswirken. Ihr Preis muss nicht in Preisfeld 1 stehen, sie dürfen jedoch nur ein Element FINISH für die Preisfeldangabe haben. Für preisfeldunabhängige Artikel, für die nur ein Element FINISH in der PRICE_FEATURE_GROUP existiert, in dem der Preis festgehalten wird, dürfen nur einen zugeordneten Preis entsprechend des im FINISH-Element angegebenen Preisfeldes haben.

- Ausführungsabhängige Artikel haben ein oder mehrere Variantenarten.
- Ein Artikel muss genau eine Basispreisgruppe referenzieren (ADDITIONAL_PRICE=0).

- Es dürfen prinzipiell mehrere PRICE_FEATURE_GROUPs mit derselben Kombination von Variantenarten angelegt werden.

PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP eindeutig identifiziert. D postiveInteger
P
M [1:99999]
ADDITIONAL_PRICE required Restriction of xs:boolean
Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis).
 D boolean
P
M
Sequence
PRICE_FEATURE_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Ausführungsgruppen
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Choice
FINISH 0..∞
In diesem Element werden gültigen Variantenkombinationen Preisfelder (PRICE_FIELD) und eine Herstellerpreisgruppe zugeordnet.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt die Preisgruppe. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und eine Preisgruppe für ihre Variantenausprägungen definiert. Die Preisgruppen können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt. 

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.
 D string
P
M [1:10]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem das Preisfeld gültig ist. D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis wann das Preisfeld gültig ist. D date
P
M
PERCENTAGE_SURCHARGE 0..∞
Um prozentuale Mehrpreise zu ermöglichen, gibt es zusätzlich zu dem Element FINISH unterhalb von PRICE_FEATURE_GROUP das Element PERCENTAGE_SURCHARGE bestehend aus OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM und VALID_UNTIL.
Dieses Element darf nur für PRICE_FEATURE_GROUP's genutzt werden, für die das Kennzeichen ADDITIONAL_PRICE auf 1 gesetzt ist (1=Mehrpreis).
Der prozentuale Mehrpreis kann sich auf unterschiedliche PRICE_FEATURE_GROUPs beziehen:

Fall 1

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

Aufpreis Rapport 10% auf Basis + Kopfstütze --> Faktor 0,1 * (500+50) = 55

Aufpreis XY 20% auf alles --> Faktor 0,2 * (500+50+66+50+55) = 144,20

Positionswert = 865,20

Fall 2

Basispreis 500,00

Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

Positionswert = 550,00

Fall 3

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis XY 20% auf Basispreis + Kopfstütze + Funktion --> Faktor 0,2 * (500+50+66)=123,20

Positionswert = 739,20

Fall 4

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis XY 20% auf ( Basispreis + Kopfstütze + Funktion ) --> Faktor 0,2 * (500+50+66)=123,20

Aufpreis ZZ -10% auf ( Basispreis + Funktion ) --> Faktor -0,1 * (500+66)= -56,60

Positionswert = 682,60

Fall 5

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Konditionswert 616,00

Aufpreis Global1 10% auf alles --> Faktor 0,1 * 616 entspricht Konditionswert = 61,60

Aufpreis Global2 20% auf alles --> Faktor 0,2 * 616 entspricht Konditionswert = 123,20

Positionswert = 800,80

Der Wert des Faktors ist im Element PRICE_FACTOR festzuhalten.

Die Preisgruppen, auf die sich der prozentuale Aufschlag bezieht, werden unter PRICE_FEATURE_GROUP_REF angegeben.

Die Gültigkeit ist in den Elementen VALID_FROM und VALID_UNTIL vermerkt.

Positionswert = 800,80
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt den prozentualen Mehrpreis.. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und ein prozentualer Mehrpreis für ihre Variantenausprägungen definiert. Die prozentualen Mehrpreise können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt.

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
PRICE_FACTOR Restriction of xs:int

Dieses Element gibt einen prozentualen Mehrpreis an. Er wird als Faktor mit 5 Nachkommastellen angegeben.

Der Wert 1050000 entspricht einem Aufschlag von 10,5 %.

Der Wert -1000000 entspricht einem Aufpreis von -10 %.

 D int
P
M [-9999999:99999999]
PRICE_FEATURE_GROUP_REF 0..∞
Dieses Element referenziert eine Preisgruppe abhängig von der Variantenart bzw. Kalkulationsmethode (PRICE_FEATURE_GROUP).
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der prozentuale Mehrpreis gültig ist. D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis wann der prozentuale Mehrpreis gültig ist. D date
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP eindeutig identifiziert. D postiveInteger
P
M [1:99999]
ADDITIONAL_PRICE Restriction of xs:boolean required
Kennzeichen, ob es sich bei dem hinterlegten Preis um einen Grund- oder Mehrpreis handelt. (0 = Grundpreis, 1=Mehrpreis).
 D boolean
P
M
Bemerkung

Quelle
<xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>300--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:choice>
        <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                  <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:choice>
                    <xs:element name="OPTION_INTERVAL">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY_MIN" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY_MAX" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_LIST">
                      <xs:complexType>
                        <xs:sequence maxOccurs="unbounded">
                          <xs:element name="OPTION_REF">
                            <xs:complexType>
                              <xs:attribute name="OPTION_KEY" use="required">
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_GROUP_REF_OP">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_GROUP_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_REF_OP">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MEASURE_VALUE_OP">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MEASURE_INTERVAL">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                        <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:attribute name="FEATURE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="PRICE_FIELD">
                <xs:annotation>
                  <xs:documentation>311--5--Preisfeld</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger">
                    <xs:minInclusive value="1" />
                    <xs:maxInclusive value="9999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="SUPPLIER_PRICE_GROUP">
                <xs:annotation>
                  <xs:documentation>311--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:string">
                    <xs:minLength value="1" />
                    <xs:maxLength value="10" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="VALID_FROM" minOccurs="0">
                <xs:annotation>
                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:date" />
                </xs:simpleType>
              </xs:element>
              <xs:element name="VALID_UNTIL" minOccurs="0">
                <xs:annotation>
                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:date" />
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="SEQUENCE" use="required">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="PERCENTAGE_SURCHARGE" minOccurs="0" maxOccurs="unbounded">
          <xs:annotation>
            <xs:documentation>geändert K.Richter 23.11.2015</xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:sequence>
              <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
                  <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:choice>
                    <xs:element name="OPTION_INTERVAL">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY_MIN" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPTION_KEY_MAX" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_LIST">
                      <xs:complexType>
                        <xs:sequence maxOccurs="unbounded">
                          <xs:element name="OPTION_REF">
                            <xs:complexType>
                              <xs:attribute name="OPTION_KEY" use="required">
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="30" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_GROUP_REF_OP">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_GROUP_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="OPTION_REF_OP">
                      <xs:annotation>
                        <xs:documentation>271--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPTION_KEY" use="required">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="30" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MEASURE_VALUE_OP">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="eq|ne|gt|lt|ge|le" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MEASURE_INTERVAL">
                      <xs:annotation>
                        <xs:documentation>1000--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="OPERATOR" use="required">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="operator">
                              <xs:pattern value="in|nin" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                        <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                            <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                          </xs:annotation>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:choice>
                  <xs:attribute name="FEATURE_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="PRICE_FACTOR">
                <xs:annotation>
                  <xs:documentation>311--5--Preisfeld</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:int">
                    <xs:maxInclusive value="99999999" />
                    <xs:minInclusive value="-9999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
                <xs:annotation>
                  <xs:documentation>311--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                    <xs:annotation>
                      <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="VALID_FROM" minOccurs="0">
                <xs:annotation>
                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:date" />
                </xs:simpleType>
              </xs:element>
              <xs:element name="VALID_UNTIL" minOccurs="0">
                <xs:annotation>
                  <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
                  <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:date" />
                </xs:simpleType>
              </xs:element>
            </xs:sequence>
            <xs:attribute name="SEQUENCE" use="required">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="ADDITIONAL_PRICE" use="required">
      <xs:annotation>
        <xs:documentation>300--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:boolean" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_TEXT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : PRICE_FEATURE_GROUP_TEXT Element
Beschreibung
Dieses Element enthält Texte für Ausführungsgruppen
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence PRICE_FEATURE_GROUP_TEXT Element
Overview
PRICE_FEATURE_GROUP_TEXT languagetext60 Complex Type
Dieses Element enthält Texte für Ausführungsgruppen
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="PRICE_FEATURE_GROUP_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>300--3--Ausf_Gruppen_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

FINISH Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : FINISH Element
Beschreibung
In diesem Element werden gültigen Variantenkombinationen Preisfelder (PRICE_FIELD) und eine Herstellerpreisgruppe zugeordnet.
Namensraum (none)
Diagramm
VALID_UNTIL Element VALID_FROM Element SUPPLIER_PRICE_GROUP Element PRICE_FIELD Element OPTIONS_SET_REF Element Sequence FINISH Element
Overview
FINISH 0..∞
In diesem Element werden gültigen Variantenkombinationen Preisfelder (PRICE_FIELD) und eine Herstellerpreisgruppe zugeordnet.
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt die Preisgruppe. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und eine Preisgruppe für ihre Variantenausprägungen definiert. Die Preisgruppen können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt. 

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.
 D string
P
M [1:10]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem das Preisfeld gültig ist. D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis wann das Preisfeld gültig ist. D date
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE Restriction of xs:nonNegativeInteger required
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt die Preisgruppe. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
          <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:choice>
            <xs:element name="OPTION_INTERVAL">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MIN" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MAX" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_LIST">
              <xs:complexType>
                <xs:sequence maxOccurs="unbounded">
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_GROUP_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_GROUP_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_VALUE_OP">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_INTERVAL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>311--5--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SUPPLIER_PRICE_GROUP">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONS_SET_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : OPTIONS_SET_REF Element
Beschreibung

Mit diesem Element wird auf die Variantenart referenziert und eine Preisgruppe für ihre Variantenausprägungen definiert. Die Preisgruppen können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

Namensraum (none)
Diagramm
MEASURE_INTERVAL Element MEASURE_VALUE_OP Element OPTION_REF_OP Element OPTION_GROUP_REF_OP Element OPTION_LIST Element OPTION_INTERVAL Element Choice OPTIONS_SET_REF Element
Overview
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und eine Preisgruppe für ihre Variantenausprägungen definiert. Die Preisgruppen können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt. 

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
    <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:choice>
      <xs:element name="OPTION_INTERVAL">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MIN" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MAX" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_LIST">
        <xs:complexType>
          <xs:sequence maxOccurs="unbounded">
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_GROUP_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_GROUP_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_VALUE_OP">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_INTERVAL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : OPTION_INTERVAL Element
Beschreibung

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt. 

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

Namensraum (none)
Diagramm
OPTION_INTERVAL Element
Overview
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt. 

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN Restriction of xs:string required

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX Restriction of xs:string required
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MIN" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MAX" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_LIST Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : OPTION_LIST Element
Beschreibung
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
Namensraum (none)
Diagramm
OPTION_REF Element Sequence OPTION_LIST Element
Overview
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Quelle
<xs:element name="OPTION_LIST" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element > OPTION_LIST Element : OPTION_REF Element
Beschreibung
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_LIST Element | OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUP_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : OPTION_GROUP_REF_OP Element
Beschreibung
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
Namensraum (none)
Diagramm
OPTION_GROUP_REF_OP Element
Overview
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_GROUP_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Quelle
<xs:element name="OPTION_GROUP_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_GROUP_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : OPTION_REF_OP Element
Beschreibung

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

Namensraum (none)
Diagramm
OPTION_REF_OP Element
Overview
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Quelle
<xs:element name="OPTION_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_VALUE_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : MEASURE_VALUE_OP Element
Beschreibung
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
Namensraum (none)
Diagramm
MEASURE_VALUE_OP Element
Overview
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MEASURE_VALUE xs:nonNegativeInteger required

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR Restriction of operator Simple Type required
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)
ne (ist nicht gleich)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Quelle
<xs:element name="MEASURE_VALUE_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element > OPTIONS_SET_REF Element : MEASURE_INTERVAL Element
Beschreibung
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
Namensraum (none)
Diagramm
MEASURE_INTERVAL Element
Overview
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN xs:nonNegativeInteger required

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX xs:nonNegativeInteger required
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
Quelle
<xs:element name="MEASURE_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FIELD Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : PRICE_FIELD Element
Beschreibung

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2) abgelegt.

Bei gleichen Katalogen für unterschiedliche Kundengruppen dürfen die Preisgruppenzuordnungen nicht verändert werden. Das Gleiche gilt auch für Korrekturdateien innerhalb der gleichen Produktrunde.

Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:9999]
Quelle
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--5--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

SUPPLIER_PRICE_GROUP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : SUPPLIER_PRICE_GROUP Element
Beschreibung
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.
 D string
P
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
SUPPLIER_PRICE_GROUP Element
Overview
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die Preisgruppe des Herstellers hinterlegt.
 D string
P
M [1:10]
Quelle
<xs:element name="SUPPLIER_PRICE_GROUP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum an, ab dem das Preisfeld gültig ist. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem das Preisfeld gültig ist. D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum an, bis wann das Preisfeld gültig ist. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis wann das Preisfeld gültig ist. D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PERCENTAGE_SURCHARGE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : PERCENTAGE_SURCHARGE Element
Beschreibung
Um prozentuale Mehrpreise zu ermöglichen, gibt es zusätzlich zu dem Element FINISH unterhalb von PRICE_FEATURE_GROUP das Element PERCENTAGE_SURCHARGE bestehend aus OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM und VALID_UNTIL.
Dieses Element darf nur für PRICE_FEATURE_GROUP's genutzt werden, für die das Kennzeichen ADDITIONAL_PRICE auf 1 gesetzt ist (1=Mehrpreis).
Der prozentuale Mehrpreis kann sich auf unterschiedliche PRICE_FEATURE_GROUPs beziehen:

Fall 1

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

Aufpreis Rapport 10% auf Basis + Kopfstütze --> Faktor 0,1 * (500+50) = 55

Aufpreis XY 20% auf alles --> Faktor 0,2 * (500+50+66+50+55) = 144,20

Positionswert = 865,20

Fall 2

Basispreis 500,00

Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

Positionswert = 550,00

Fall 3

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis XY 20% auf Basispreis + Kopfstütze + Funktion --> Faktor 0,2 * (500+50+66)=123,20

Positionswert = 739,20

Fall 4

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis XY 20% auf ( Basispreis + Kopfstütze + Funktion ) --> Faktor 0,2 * (500+50+66)=123,20

Aufpreis ZZ -10% auf ( Basispreis + Funktion ) --> Faktor -0,1 * (500+66)= -56,60

Positionswert = 682,60

Fall 5

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Konditionswert 616,00

Aufpreis Global1 10% auf alles --> Faktor 0,1 * 616 entspricht Konditionswert = 61,60

Aufpreis Global2 20% auf alles --> Faktor 0,2 * 616 entspricht Konditionswert = 123,20

Positionswert = 800,80

Der Wert des Faktors ist im Element PRICE_FACTOR festzuhalten.

Die Preisgruppen, auf die sich der prozentuale Aufschlag bezieht, werden unter PRICE_FEATURE_GROUP_REF angegeben.

Die Gültigkeit ist in den Elementen VALID_FROM und VALID_UNTIL vermerkt.

Positionswert = 800,80
Namensraum (none)
Diagramm
VALID_UNTIL Element VALID_FROM Element PRICE_FEATURE_GROUP_REF Element PRICE_FACTOR Element OPTIONS_SET_REF Element Sequence PERCENTAGE_SURCHARGE Element
Overview
PERCENTAGE_SURCHARGE 0..∞
Um prozentuale Mehrpreise zu ermöglichen, gibt es zusätzlich zu dem Element FINISH unterhalb von PRICE_FEATURE_GROUP das Element PERCENTAGE_SURCHARGE bestehend aus OPTION_REF, PRICE_FACTOR, PRICE_FEATURE_GROUP_REF, VALID_FROM und VALID_UNTIL.
Dieses Element darf nur für PRICE_FEATURE_GROUP's genutzt werden, für die das Kennzeichen ADDITIONAL_PRICE auf 1 gesetzt ist (1=Mehrpreis).
Der prozentuale Mehrpreis kann sich auf unterschiedliche PRICE_FEATURE_GROUPs beziehen:

Fall 1

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

Aufpreis Rapport 10% auf Basis + Kopfstütze --> Faktor 0,1 * (500+50) = 55

Aufpreis XY 20% auf alles --> Faktor 0,2 * (500+50+66+50+55) = 144,20

Positionswert = 865,20

Fall 2

Basispreis 500,00

Aufpreis Sitzheizung 10% auf Basispreis --> Faktor 0,1 * 500 = 50

Positionswert = 550,00

Fall 3

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis XY 20% auf Basispreis + Kopfstütze + Funktion --> Faktor 0,2 * (500+50+66)=123,20

Positionswert = 739,20

Fall 4

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Aufpreis XY 20% auf ( Basispreis + Kopfstütze + Funktion ) --> Faktor 0,2 * (500+50+66)=123,20

Aufpreis ZZ -10% auf ( Basispreis + Funktion ) --> Faktor -0,1 * (500+66)= -56,60

Positionswert = 682,60

Fall 5

Basispreis 500,00

Aufpreis Kopfstütze 50,00

Aufpreis Funktion 66,00

Konditionswert 616,00

Aufpreis Global1 10% auf alles --> Faktor 0,1 * 616 entspricht Konditionswert = 61,60

Aufpreis Global2 20% auf alles --> Faktor 0,2 * 616 entspricht Konditionswert = 123,20

Positionswert = 800,80

Der Wert des Faktors ist im Element PRICE_FACTOR festzuhalten.

Die Preisgruppen, auf die sich der prozentuale Aufschlag bezieht, werden unter PRICE_FEATURE_GROUP_REF angegeben.

Die Gültigkeit ist in den Elementen VALID_FROM und VALID_UNTIL vermerkt.

Positionswert = 800,80
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt den prozentualen Mehrpreis.. D nonNegativeInteger
P
M [1:99999]
Sequence
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und ein prozentualer Mehrpreis für ihre Variantenausprägungen definiert. Die prozentualen Mehrpreise können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt.

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
PRICE_FACTOR Restriction of xs:int

Dieses Element gibt einen prozentualen Mehrpreis an. Er wird als Faktor mit 5 Nachkommastellen angegeben.

Der Wert 1050000 entspricht einem Aufschlag von 10,5 %.

Der Wert -1000000 entspricht einem Aufpreis von -10 %.

 D int
P
M [-9999999:99999999]
PRICE_FEATURE_GROUP_REF 0..∞
Dieses Element referenziert eine Preisgruppe abhängig von der Variantenart bzw. Kalkulationsmethode (PRICE_FEATURE_GROUP).
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der prozentuale Mehrpreis gültig ist. D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis wann der prozentuale Mehrpreis gültig ist. D date
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE Restriction of xs:nonNegativeInteger required
Mit diesem Element wird festgelegt, in welcher Reihenfolge die Auswertungen durchgeführt werden. Die Konfiguratoren müssen entsprechend dieser Reihenfolge die einzelnen Elemente von OPTION_SET_REFdurchlaufen. Die erste Variantenkombination, die zutrifft, bestimmt den prozentualen Mehrpreis.. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="PERCENTAGE_SURCHARGE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>geändert K.Richter 23.11.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
          <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:choice>
            <xs:element name="OPTION_INTERVAL">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MIN" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY_MAX" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_LIST">
              <xs:complexType>
                <xs:sequence maxOccurs="unbounded">
                  <xs:element name="OPTION_REF">
                    <xs:complexType>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_GROUP_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_GROUP_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF_OP">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_VALUE_OP">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="eq|ne|gt|lt|ge|le" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="MEASURE_INTERVAL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                <xs:documentation>01.07.2014 K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="OPERATOR" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="operator">
                      <xs:pattern value="in|nin" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
                <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
                  <xs:annotation>
                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
                    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:choice>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_FACTOR">
        <xs:annotation>
          <xs:documentation>311--5--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:int">
            <xs:maxInclusive value="99999999" />
            <xs:minInclusive value="-9999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
          <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTIONS_SET_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element : OPTIONS_SET_REF Element
Beschreibung

Mit diesem Element wird auf die Variantenart referenziert und ein prozentualer Mehrpreis für ihre Variantenausprägungen definiert. Die prozentualen Mehrpreise können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

Namensraum (none)
Diagramm
MEASURE_INTERVAL Element MEASURE_VALUE_OP Element OPTION_REF_OP Element OPTION_GROUP_REF_OP Element OPTION_LIST Element OPTION_INTERVAL Element Choice OPTIONS_SET_REF Element
Overview
OPTIONS_SET_REF 0..∞

Mit diesem Element wird auf die Variantenart referenziert und ein prozentualer Mehrpreis für ihre Variantenausprägungen definiert. Die prozentualen Mehrpreise können über Werte, Listen, Intervalle oder Variantengruppen verbunden durch einen Mengenoperator formuliert werden.

Hierfür wurde ein einfacher Datentyp operator definiert, der folgende Werte enthalten kann:

eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)

FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Choice
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt.

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="OPTIONS_SET_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>umbenannt von FEATURE_REF in OPTIONS_SET_REF</xs:documentation>
    <xs:documentation>K. Richter, 12.02.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:choice>
      <xs:element name="OPTION_INTERVAL">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MIN" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY_MAX" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_LIST">
        <xs:complexType>
          <xs:sequence maxOccurs="unbounded">
            <xs:element name="OPTION_REF">
              <xs:complexType>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_GROUP_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_GROUP_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF_OP">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_VALUE_OP">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="eq|ne|gt|lt|ge|le" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="MEASURE_INTERVAL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
          <xs:documentation>01.07.2014 K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="OPERATOR" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="operator">
                <xs:pattern value="in|nin" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
          <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
            <xs:annotation>
              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
              <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
              <xs:documentation>01.07.2014 K. Richter</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:choice>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : OPTION_INTERVAL Element
Beschreibung

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt.

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

Namensraum (none)
Diagramm
OPTION_INTERVAL Element
Overview
OPTION_INTERVAL

Mit diesem Element wird überprüft, ob eine Variante innerhalb oder außerhalb eines Intervalls liegt.

Für das Element OPTION_INTERVAL gilt: OPTION_KEY_MIN <= zu_prüfender_wert <= OPTION_KEY_MAX.

OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN required Restriction of xs:string

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX required Restriction of xs:string
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb eines durch OPTION_KEY_MIN und OPTION_KEY_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
OPTION_KEY_MIN Restriction of xs:string required

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D string
P
M [1:30]
OPTION_KEY_MAX Restriction of xs:string required
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
"IN" und "NIN" möglich
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MIN" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY_MAX" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_LIST Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : OPTION_LIST Element
Beschreibung
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
Namensraum (none)
Diagramm
OPTION_REF Element Sequence OPTION_LIST Element
Overview
OPTION_LIST
Mit diesem Element wird überprüft, ob eine Variante einem Wert innerhalb einer Liste entspricht.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Sequence 1..∞
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob sich eine Variante innerhalb oder außerhalb einer Liste von Werten befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Quelle
<xs:element name="OPTION_LIST" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element name="OPTION_REF">
        <xs:complexType>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NOTIN" möglich</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element > OPTION_LIST Element : OPTION_REF Element
Beschreibung
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF
Mit diesem Element wird auf die Optionen in der Vergleichsliste referenziert.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
Quelle
<xs:element name="OPTION_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_LIST Element | OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_GROUP_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : OPTION_GROUP_REF_OP Element
Beschreibung
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
Namensraum (none)
Diagramm
OPTION_GROUP_REF_OP Element
Overview
OPTION_GROUP_REF_OP
Mit diesem Element wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.
OPTION_GROUP_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_GROUP_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantengruppe referenziert. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob eine Variante innerhalb einer Variantengruppe liegt.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
Quelle
<xs:element name="OPTION_GROUP_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_GROUP_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator
hier sind nur "IN" und "NOTIN" möglich, da es sich um eine Mengenoperation handelt
</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

OPTION_REF_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : OPTION_REF_OP Element
Beschreibung

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Namensraum (none)
Diagramm
OPTION_REF_OP Element
Overview
OPTION_REF_OP

Mit diesem Element wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:30]
OPERATOR Restriction of operator Simple Type required
Mit diesem Attribut wird ein Vergleich mit einer Variante formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Quelle
<xs:element name="OPTION_REF_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator

</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_VALUE_OP Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : MEASURE_VALUE_OP Element
Beschreibung
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
Namensraum (none)
Diagramm
MEASURE_VALUE_OP Element
Overview
MEASURE_VALUE_OP
Mit diesem Element wird der Maßwert einer Variante mit einem weiteren Maßwert überprüft.
MEASURE_VALUE required xs:nonNegativeInteger

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR required Restriction of operator Simple Type
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MEASURE_VALUE xs:nonNegativeInteger required

Mit diesem Attribut wird der Vergleichsmaßwert angegeben.

 D nonNegativeInteger
P
M
OPERATOR Restriction of operator Simple Type required
Mit diesem Attribut wird ein Vergleich mit einem Maßwert formuliert.

Der Vergleichsoperator kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D operator
P eq|ne|gt|lt|ge|le
M
Quelle
<xs:element name="MEASURE_VALUE_OP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="MEASURE_VALUE" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="eq|ne|gt|lt|ge|le" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

MEASURE_INTERVAL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element > OPTIONS_SET_REF Element : MEASURE_INTERVAL Element
Beschreibung
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
Namensraum (none)
Diagramm
MEASURE_INTERVAL Element
Overview
MEASURE_INTERVAL
Mit diesem Element wird überprüft ob der Maßwert einer Variante innerhalb oder außerhalb eines Intervall liegt.
OPERATOR required Restriction of operator Simple Type

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN required xs:nonNegativeInteger

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX required xs:nonNegativeInteger
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPERATOR Restriction of operator Simple Type required

Mit diesem Attribut wird überprüft, ob sich ein Wert innerhalb oder außerhalb eines durch MEASURE_MIN und MEASURE_MAX angegebenen Intervalls befindet.

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

 D operator
P in|nin
M
MEASURE_MIN xs:nonNegativeInteger required

Mit diesem Attribut wird der Anfangswert des Intervalls angegeben.

 D nonNegativeInteger
P
M
MEASURE_MAX xs:nonNegativeInteger required
Mit diesem Attribut wird der Endewert des Intervalls angegeben. D nonNegativeInteger
P
M
Quelle
<xs:element name="MEASURE_INTERVAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
    <xs:documentation>01.07.2014 K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="OPERATOR" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">eigener Typ Operator "IN" und "NIN" möglich </xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="operator">
          <xs:pattern value="in|nin" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MEASURE_MIN" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Min_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
    <xs:attribute name="MEASURE_MAX" type="xs:nonNegativeInteger" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.4 Build 1</xs:documentation>
        <xs:documentation>01.07.2014 K. Richter</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS_SET_REF Element | PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FACTOR Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element : PRICE_FACTOR Element
Beschreibung

Dieses Element gibt einen prozentualen Mehrpreis an. Er wird als Faktor mit 5 Nachkommastellen angegeben.

Der Wert 1050000 entspricht einem Aufschlag von 10,5 %.

Der Wert -1000000 entspricht einem Aufpreis von -10 %.

 D int
P
M [-9999999:99999999]
Namensraum (none)
Typ
Restriction of xs:int
Diagramm
PRICE_FACTOR Element
Overview
PRICE_FACTOR Restriction of xs:int

Dieses Element gibt einen prozentualen Mehrpreis an. Er wird als Faktor mit 5 Nachkommastellen angegeben.

Der Wert 1050000 entspricht einem Aufschlag von 10,5 %.

Der Wert -1000000 entspricht einem Aufpreis von -10 %.

 D int
P
M [-9999999:99999999]
Quelle
<xs:element name="PRICE_FACTOR" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--5--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 28.05.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:int">
      <xs:maxInclusive value="99999999" />
      <xs:minInclusive value="-9999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_REF Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element : PRICE_FEATURE_GROUP_REF Element
Beschreibung
Dieses Element referenziert eine Preisgruppe abhängig von der Variantenart bzw. Kalkulationsmethode (PRICE_FEATURE_GROUP).
Namensraum (none)
Diagramm
PRICE_FEATURE_GROUP_REF Element
Overview
PRICE_FEATURE_GROUP_REF 0..∞
Dieses Element referenziert eine Preisgruppe abhängig von der Variantenart bzw. Kalkulationsmethode (PRICE_FEATURE_GROUP).
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D postiveInteger
P
M [1:99999]
Quelle
<xs:element name="PRICE_FEATURE_GROUP_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_FROM Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum an, ab dem der prozentuale Mehrpreis gültig ist. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der prozentuale Mehrpreis gültig ist. D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar ab</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 07</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

VALID_UNTIL Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > PERCENTAGE_SURCHARGE Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum an, bis wann der prozentuale Mehrpreis gültig ist. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis wann der prozentuale Mehrpreis gültig ist. D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">21.07.2011/balke - Polsterbranche Lieferbar bis</xs:documentation>
    <xs:documentation xml:lang="DE">Version Beta 2.1 Build 7</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
PERCENTAGE_SURCHARGE Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element : PRICE_TYPES Element
Beschreibung
In diesem Element werden die Preisarten zur stück- oder maßvariablen Berechnung von variantenneutralen und variantenabhängigen Artikeln definiert.
Die Kind-Elemente WIDTH_X, DEPTH_Y, HEIGHT_Z geben an, ob der Preis für einen Artikel, der nach dieser Preisart berechnet wird, breiten-, höhen-, tiefen-, flächen- bzw. volumenabhängig ist.
Wenn für keine Dimension eine "1" angegeben ist, ist der Preis nicht maßabhängig, wird also per Stück berechnet (beispielsweise ein Sitzelement). Dann werden die Elemente BASIC_UNIT und ROUNDING_UNIT mit dem Wert 0 belegt.
Wird für genau eine Dimension eine "1" angegeben, so wird diese Dimension für die Preisberechnung herangezogen (beispielsweise Stoffe).
Wenn für genau zwei Dimensionen eine "1" angegeben ist, so ist der Preis flächenabhängig (beispielsweise Teppiche).
Wenn für genau drei Dimensionen eine "1" angegeben ist, so ist der Preis volumenabhängig (beispielsweise Liegeteile).
Namensraum (none)
Diagramm
PRICE_TYPE Element Sequence PRICE_TYPES Element
Overview
PRICE_TYPES
In diesem Element werden die Preisarten zur stück- oder maßvariablen Berechnung von variantenneutralen und variantenabhängigen Artikeln definiert.
Die Kind-Elemente WIDTH_X, DEPTH_Y, HEIGHT_Z geben an, ob der Preis für einen Artikel, der nach dieser Preisart berechnet wird, breiten-, höhen-, tiefen-, flächen- bzw. volumenabhängig ist.
Wenn für keine Dimension eine "1" angegeben ist, ist der Preis nicht maßabhängig, wird also per Stück berechnet (beispielsweise ein Sitzelement). Dann werden die Elemente BASIC_UNIT und ROUNDING_UNIT mit dem Wert 0 belegt.
Wird für genau eine Dimension eine "1" angegeben, so wird diese Dimension für die Preisberechnung herangezogen (beispielsweise Stoffe).
Wenn für genau zwei Dimensionen eine "1" angegeben ist, so ist der Preis flächenabhängig (beispielsweise Teppiche).
Wenn für genau drei Dimensionen eine "1" angegeben ist, so ist der Preis volumenabhängig (beispielsweise Liegeteile).
Sequence 1..∞
PRICE_TYPE
In diesem Element wird eine Preisart definiert.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (P1) und ADDITIONAL_PRICE (P2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in dieses Element "1000" anzugeben. Bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³] eingegeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein.

P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein. D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_TYPE Restriction of xs:positiveInteger

Um die unterschiedlichen Arten der Rundung angeben zu können, wird zusätzlich zum Element ROUNDING_UNIT das Element ROUNDING_TYPE mit den möglichen Werten 1, 2 und 3 aufgenommen, um ein Auf-, Ab- und kaufmännisches Runden zu kennzeichnen.

Die Werte haben folgende Bedeutung:

1 Aufrunden

2 Abrunden

3 Kaufmännisches Runden

 D positiveInteger
P
M [1:3]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean

Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf
Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist
die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/
PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem
Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als
Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben,
der sich auf im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung
zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis
des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem
berechnetem Restmaßpreis, unter Berücksichtigung der im Element definierten Logik,
zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens
eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung
mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE
herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

 D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) oder HEIGHT_Z (P1) (h) auf true gesetzt werden;
- es können die Grundrechendarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (P1), ROUNDING_UNIT (P1) und BASIC_PRICE_DEPENDENT (P1) gelten auch in Verbindung mit der Preisartformel.

[SSS_Elementpfade_SSS]Elementpfade[EEE_Elementpfade_EEE]
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetext60 Complex Type
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PRICE_TYPE_RULES optional
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
Sequence
PRICE_TYPE_RULE 1..100
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Element wird die Nummer der Regel hinterlegt. D nonNegativeInteger
P
M [0:9999]
Sequence
RULE xs:string
In diesem Element wird die Regel definiert. D string
P
M
Bemerkung

Quelle
<xs:element name="PRICE_TYPES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence maxOccurs="unbounded">
      <xs:element name="PRICE_TYPE">
        <xs:annotation>
          <xs:documentation>150--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="WIDTH_X">
              <xs:annotation>
                <xs:documentation>150--3--Breite_X</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPTH_Y">
              <xs:annotation>
                <xs:documentation>150--4--Tiefe_Y</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="HEIGHT_Z">
              <xs:annotation>
                <xs:documentation>150--5--Hoehe_Z</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_UNIT">
              <xs:annotation>
                <xs:documentation>150--6--Basis_Einheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ROUNDING_UNIT">
              <xs:annotation>
                <xs:documentation>150--7--Rundungseinheit</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ROUNDING_TYPE">
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BASIC_PRICE_DEPENDENT">
              <xs:annotation>
                <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
              <xs:annotation>
                <xs:documentation>150--9--Preisart_Formel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="100" />
                  <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_TYPE_NAME" type="languagetext60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="PRICE_TYPE_RULES" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>360--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_TYPE_RULE" maxOccurs="100">
                    <xs:annotation>
                      <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
                      <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RULE" type="xs:string">
                          <xs:annotation>
                            <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
                            <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="RULE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>360--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="9999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element : PRICE_TYPE Element
Beschreibung
In diesem Element wird eine Preisart definiert.
Namensraum (none)
Diagramm
PRICE_TYPE_RULES Element LANGUAGE Element Sequence PRICE_TYPE_NAME Element PRICE_TYPE_FORMULA Element BASIC_PRICE_DEPENDENT Element ROUNDING_TYPE Element ROUNDING_UNIT Element BASIC_UNIT Element HEIGHT_Z Element DEPTH_Y Element WIDTH_X Element Sequence PRICE_TYPE Element
Overview
PRICE_TYPE
In diesem Element wird eine Preisart definiert.
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert. D positiveInteger
P
M [1:250]
Sequence
WIDTH_X Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
DEPTH_Y Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
HEIGHT_Z Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
BASIC_UNIT Restriction of xs:nonNegativeInteger
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (P1) und ADDITIONAL_PRICE (P2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in dieses Element "1000" anzugeben. Bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³] eingegeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein.

P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein. D nonNegativeInteger
P
M [0:999999999999]
ROUNDING_TYPE Restriction of xs:positiveInteger

Um die unterschiedlichen Arten der Rundung angeben zu können, wird zusätzlich zum Element ROUNDING_UNIT das Element ROUNDING_TYPE mit den möglichen Werten 1, 2 und 3 aufgenommen, um ein Auf-, Ab- und kaufmännisches Runden zu kennzeichnen.

Die Werte haben folgende Bedeutung:

1 Aufrunden

2 Abrunden

3 Kaufmännisches Runden

 D positiveInteger
P
M [1:3]
BASIC_PRICE_DEPENDENT Restriction of xs:boolean

Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf
Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist
die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/
PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem
Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als
Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben,
der sich auf im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung
zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis
des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem
berechnetem Restmaßpreis, unter Berücksichtigung der im Element definierten Logik,
zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens
eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung
mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE
herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

 D boolean
P
M
PRICE_TYPE_FORMULA optional Restriction of xs:string
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) oder HEIGHT_Z (P1) (h) auf true gesetzt werden;
- es können die Grundrechendarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (P1), ROUNDING_UNIT (P1) und BASIC_PRICE_DEPENDENT (P1) gelten auch in Verbindung mit der Preisartformel.

[SSS_Elementpfade_SSS]Elementpfade[EEE_Elementpfade_EEE]
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
PRICE_TYPE_NAME optional languagetext60 Complex Type
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
PRICE_TYPE_RULES optional
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
Sequence
PRICE_TYPE_RULE 1..100
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Element wird die Nummer der Regel hinterlegt. D nonNegativeInteger
P
M [0:9999]
Sequence
RULE xs:string
In diesem Element wird die Regel definiert. D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_TYPE_NO Restriction of xs:positiveInteger required
Über das hier angelegte Attribut wird eine definierte Preisart eindeutig identifiziert. D positiveInteger
P
M [1:250]
Bemerkung

Quelle
<xs:element name="PRICE_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="WIDTH_X">
        <xs:annotation>
          <xs:documentation>150--3--Breite_X</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPTH_Y">
        <xs:annotation>
          <xs:documentation>150--4--Tiefe_Y</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="HEIGHT_Z">
        <xs:annotation>
          <xs:documentation>150--5--Hoehe_Z</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_UNIT">
        <xs:annotation>
          <xs:documentation>150--6--Basis_Einheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ROUNDING_UNIT">
        <xs:annotation>
          <xs:documentation>150--7--Rundungseinheit</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ROUNDING_TYPE">
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BASIC_PRICE_DEPENDENT">
        <xs:annotation>
          <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_TYPE_FORMULA" minOccurs="0">
        <xs:annotation>
          <xs:documentation>150--9--Preisart_Formel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="100" />
            <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_TYPE_NAME" type="languagetext60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PRICE_TYPE_RULES" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>360--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_TYPE_RULE" maxOccurs="100">
              <xs:annotation>
                <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
                <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RULE" type="xs:string">
                    <xs:annotation>
                      <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
                      <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="RULE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>360--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="9999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

WIDTH_X Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : WIDTH_X Element
Beschreibung
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
WIDTH_X Element
Overview
WIDTH_X Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Breite ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Bemerkung

Quelle
<xs:element name="WIDTH_X" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--3--Breite_X</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

DEPTH_Y Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : DEPTH_Y Element
Beschreibung
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
DEPTH_Y Element
Overview
DEPTH_Y Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Tiefe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Bemerkung

Quelle
<xs:element name="DEPTH_Y" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--4--Tiefe_Y</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

HEIGHT_Z Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : HEIGHT_Z Element
Beschreibung
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
HEIGHT_Z Element
Overview
HEIGHT_Z Restriction of xs:boolean
Wenn der zu berechnende Preis abhängig von der Dimension Höhe ist, wird in diesem Element eine 1, andernfalls eine 0 eingetragen. D boolean
P
M
Bemerkung

Quelle
<xs:element name="HEIGHT_Z" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--5--Hoehe_Z</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : BASIC_UNIT Element
Beschreibung
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (P1) und ADDITIONAL_PRICE (P2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in dieses Element "1000" anzugeben. Bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³] eingegeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein.

P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BASIC_UNIT Element
Overview
BASIC_UNIT Restriction of xs:nonNegativeInteger
Die Basiseinheit (BASIC_UNIT) dient zur Angabe, auf welches Maß sich die Preise in den Elementen ITEM_PRICE (P1) und ADDITIONAL_PRICE (P2) beziehen.
Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Bezieht sich der Preis eines breitenabhängigen Artikels beispielsweise auf einen Meter, so ist in dieses Element "1000" anzugeben. Bei einem volumenabhängigen Preis beispielsweise 1 m³ als "1000000000" [mm³] eingegeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein.

P1: PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/
P2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ 		D nonNegativeInteger
P
M [0:999999999999]
Bemerkung

Quelle
<xs:element name="BASIC_UNIT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--6--Basis_Einheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ROUNDING_UNIT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : ROUNDING_UNIT Element
Beschreibung
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein. D nonNegativeInteger
P
M [0:999999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
ROUNDING_UNIT Element
Overview
ROUNDING_UNIT Restriction of xs:nonNegativeInteger
Die Rundungseinheit (ROUNDING_UNIT) dient zur Angabe, auf welches Maß die Länge, die Fläche bzw. das Volumen aufgerundet wird. Die Einheit hängt von der Anzahl der Dimensionen ab, die mit "1" angegeben sind. Möglich sind mm, mm² sowie mm³. Wird der Preis eines breitenabhängigen Artikels beispielsweise auf einen Zentimeter gerundet, so ist in dieses Element "10" anzugeben. Handelt es sich um Stückpreise, d. h. es wurde keine Dimension mit "1" angegeben, so muss in dieses Element eine "0" eingetragen werden. Handelt es sich nicht um einen Stückpreis, so muss der Wert ungleich "0" sein. D nonNegativeInteger
P
M [0:999999999999]
Bemerkung

Quelle
<xs:element name="ROUNDING_UNIT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--7--Rundungseinheit</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

ROUNDING_TYPE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : ROUNDING_TYPE Element
Beschreibung

Um die unterschiedlichen Arten der Rundung angeben zu können, wird zusätzlich zum Element ROUNDING_UNIT das Element ROUNDING_TYPE mit den möglichen Werten 1, 2 und 3 aufgenommen, um ein Auf-, Ab- und kaufmännisches Runden zu kennzeichnen.

Die Werte haben folgende Bedeutung:

1 Aufrunden

2 Abrunden

3 Kaufmännisches Runden

 D positiveInteger
P
M [1:3]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
ROUNDING_TYPE Element
Overview
ROUNDING_TYPE Restriction of xs:positiveInteger

Um die unterschiedlichen Arten der Rundung angeben zu können, wird zusätzlich zum Element ROUNDING_UNIT das Element ROUNDING_TYPE mit den möglichen Werten 1, 2 und 3 aufgenommen, um ein Auf-, Ab- und kaufmännisches Runden zu kennzeichnen.

Die Werte haben folgende Bedeutung:

1 Aufrunden

2 Abrunden

3 Kaufmännisches Runden

 D positiveInteger
P
M [1:3]
Quelle
<xs:element name="ROUNDING_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

BASIC_PRICE_DEPENDENT Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : BASIC_PRICE_DEPENDENT Element
Beschreibung

Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf
Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist
die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/
PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem
Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als
Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben,
der sich auf im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung
zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis
des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem
berechnetem Restmaßpreis, unter Berücksichtigung der im Element definierten Logik,
zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens
eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung
mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE
herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

 D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
BASIC_PRICE_DEPENDENT Element
Overview
BASIC_PRICE_DEPENDENT Restriction of xs:boolean

Wenn das Element mit dem Wert 1 gefüllt wird, dann erfolgt die Preisberechnung auf
Basis eines Grundpreises in Abhängigkeit einer Grundpreiseinheit. Beim Wert 0 ist
die Preisberechnung unabhängig von einem Grundpreis.

In dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE_MINIMUM_BASIC wird der
für die Berechnung gültige Grundpreis des Artikels und im Element .../ITEM/
PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/BASIC_PRICE_UNIT die dem
Grundpreis zugeordnete Grundpreiseinheit eingetragen. Die Grundpreiseinheit wird als
Basiswert bzw. Startpunkt für die maßvariable Berechnung verwendet.

Im Element ...ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF/ITEM_PRICE/PRICE
wird der als Grundlage zur Berechnung des Restmaßpreises notwendige Preis angegeben,
der sich auf im Element BASIC_UNIT definierte Basiseinheit bezieht.
Der Grundpreis ist immer Stückpreis. Wird einem Artikel eine Grundpreisberechnung
zugewiesen, so kann diesem Artikel kein Mindestpreis zugewiesen werden. Der Endpreis
des Artikels setzt sich grundsätzlich aus dem Grundpreis zuzüglich dem
berechnetem Restmaßpreis, unter Berücksichtigung der im Element definierten Logik,
zusammen. Grundpreise können nur Artikeln zugewiesen werden, bei denen mindestens
eine Dimension zur Berechnung herangezogen wird.

Der effektive Artikelpreis wird wie folgt berechnet:
Von dem Artikelmaß ist die Grundpreiseinheit abzuziehen. Das verbleibende Maß ist das Restmaß.
Zur Berechnung des Preises für das Restmaß wird die Logik aus dem Element PRICE_TYPE in Verbindung
mit dem Preis aus dem Element .../ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF/ITEM_PRICE/PRICE
herangezogen. Ist das Restmaß kleiner als 0, so wird mit einem Restmaß von 0 weitergerechnet.

 D boolean
P
M
Bemerkung

Quelle
<xs:element name="BASIC_PRICE_DEPENDENT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--8--Grundpreisabhaengig</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_FORMULA Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : PRICE_TYPE_FORMULA Element
Beschreibung
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) oder HEIGHT_Z (P1) (h) auf true gesetzt werden;
- es können die Grundrechendarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (P1), ROUNDING_UNIT (P1) und BASIC_PRICE_DEPENDENT (P1) gelten auch in Verbindung mit der Preisartformel.

[SSS_Elementpfade_SSS]Elementpfade[EEE_Elementpfade_EEE]
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
PRICE_TYPE_FORMULA Element
Overview
PRICE_TYPE_FORMULA optional Restriction of xs:string
Bei der Definition von Preisarten (PRICE_TYPE) können Formeln für die Preisberechnung hinterlegt werden. Für Standardpreisarten wie z. B. eine reine Berechnung nach Quadrat- oder Kubikmetern darf eine Formel nicht angelegt werden.
Für das Definieren von Preisartformeln gelten die nachfolgenden Regeln:
- es können die Formelparameter b, h und t verwendet werden. Die Parameter b, h, t entsprechen den Parametern b, h und t der Korpusgrundform. Je nach verwendetem Parameter b, h, t muss das korrespondierende Element WIDTH_Y (P1) (b), DEPTH_Y (P1) (t) oder HEIGHT_Z (P1) (h) auf true gesetzt werden;
- es können die Grundrechendarten Addition (+), Subtraktion (-), Multiplikation (*) und Division (/) verwendet werden;
- es kann die mathematische Klammerung verwendet werden;
- es können keine Vorzeichen verwendet werden;
- es wird nur das Endergebnis gerundet;
- die Elemente BASIC_UNIT (P1), ROUNDING_UNIT (P1) und BASIC_PRICE_DEPENDENT (P1) gelten auch in Verbindung mit der Preisartformel.

[SSS_Elementpfade_SSS]Elementpfade[EEE_Elementpfade_EEE]
P1: PRICE_DEFINITION/PRICE_TYPES/PRICE_TYPE/ 		D string
P [\+\-\*/\(\)bhtBHT]{0,}
M [1:100]
Bemerkung

Quelle
<xs:element name="PRICE_TYPE_FORMULA" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--9--Preisart_Formel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="100" />
      <xs:pattern value="[\+\-\*/\(\)bhtBHT]{0,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_NAME Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : PRICE_TYPE_NAME Element
Beschreibung
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence PRICE_TYPE_NAME Element
Overview
PRICE_TYPE_NAME optional languagetext60 Complex Type
In diesem Element wird eine Bezeichnung für die definierte Preisart hinterlegt.
Die Bezeichung dient zur Vereinfachung der Datenanlage und Kommunikation. Vom Planungsprogramm wird die Bezeichnung nicht ausgewertet.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Bemerkung

Quelle
<xs:element name="PRICE_TYPE_NAME" type="languagetext60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--10--Bezeichnung_Preisart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_RULES Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element : PRICE_TYPE_RULES Element
Beschreibung
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
Namensraum (none)
Diagramm
PRICE_TYPE_RULE Element Sequence PRICE_TYPE_RULES Element
Overview
PRICE_TYPE_RULES optional
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
Sequence
PRICE_TYPE_RULE 1..100
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Element wird die Nummer der Regel hinterlegt. D nonNegativeInteger
P
M [0:9999]
Sequence
RULE xs:string
In diesem Element wird die Regel definiert. D string
P
M
Bemerkung

Quelle
<xs:element name="PRICE_TYPE_RULES" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>360--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_TYPE_RULE" maxOccurs="100">
        <xs:annotation>
          <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
          <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RULE" type="xs:string">
              <xs:annotation>
                <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
                <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="RULE_NO" use="required">
            <xs:annotation>
              <xs:documentation>360--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="9999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

PRICE_TYPE_RULE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element > PRICE_TYPE_RULES Element : PRICE_TYPE_RULE Element
Beschreibung
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
Namensraum (none)
Diagramm
RULE Element Sequence PRICE_TYPE_RULE Element
Overview
PRICE_TYPE_RULE 1..100
In diesem Element können Regeln zur Ermittlung der Preisart definiert werden.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Element wird die Nummer der Regel hinterlegt. D nonNegativeInteger
P
M [0:9999]
Sequence
RULE xs:string
In diesem Element wird die Regel definiert. D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
RULE_NO Restriction of xs:nonNegativeInteger required
In diesem Element wird die Nummer der Regel hinterlegt. D nonNegativeInteger
P
M [0:9999]
Bemerkung

Quelle
<xs:element name="PRICE_TYPE_RULE" maxOccurs="100" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Polster
Regeln zur ermittelung der Preisart
z.B. if Preisgruppe A &gt; Preisgruppe B dann nimm Preisgruppe A </xs:documentation>
    <xs:documentation xml:lang="DE">Version 2.1 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RULE" type="xs:string">
        <xs:annotation>
          <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
          <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="RULE_NO" use="required">
      <xs:annotation>
        <xs:documentation>360--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_TYPE_RULES Element | PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

RULE Element
IDMW 2.0 XML-Schema Dokumentation > T_NEW_CATALOG Element > PRICE_DEFINITION Element > PRICE_TYPES Element > PRICE_TYPE Element > PRICE_TYPE_RULES Element > PRICE_TYPE_RULE Element : RULE Element
Beschreibung
In diesem Element wird die Regel definiert. D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
RULE Element
Overview
RULE xs:string
In diesem Element wird die Regel definiert. D string
P
M
Bemerkung

Quelle
<xs:element name="RULE" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Feld zur Aufnahme von Regeln</xs:documentation>
    <xs:documentation xml:lang="DE">Version 2.1 Build 7 Polster</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PRICE_TYPE_RULE Element | PRICE_TYPE_RULES Element | PRICE_TYPE Element | PRICE_TYPES Element | PRICE_DEFINITION Element | T_NEW_CATALOG Element | IDMW 2.0 XML-Schema Dokumentation


%%ItemTitle%%

Komplexe Datentypen


%%LocalItemTitle%%

Beschreibung
Mit diesem einfachen Datentyp wird ein Operator für Vergleiche formuliert.

Der Vergleichsoperator kann der folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Elemente
Element | Beschreibung
T_NEW_CATALOG | In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Kataloges/Datenbestandes hinterlegt.
Komplexe Typen
Complex Type | Beschreibung
languagetext | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.
languagetext30 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
languagetext40 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.
languagetext60 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.
Einfache Typen
Simple Type Beschreibung
operator
Mit diesem einfachen Datentyp wird ein Operator für Vergleiche formuliert.

Der Vergleichsoperator kann der folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D string
P eq|ne|in|nin|gt|lt|ge|le
M [1:4]


%%LocalItemTitle%%

languagetext Complex Type
IDMW 2.0 XML-Schema Dokumentation : languagetext Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext Complex Type
Overview
languagetext

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Verwendet von
CATALOG_INFO Element
EXTERNAL_NAME Element
TOOL_TIP Element
MESSAGE_TEXT Element
PROPERTY_TEXT Element
FULL_TEXT Element
PLANNING_ADVICE Element
PACKAGE_LIST_COMMENT_TEXT Element
OPTION_COMMENT_TEXT Element
Quelle
<xs:complexType name="languagetext" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string" />
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

languagetext30 Complex Type
IDMW 2.0 XML-Schema Dokumentation : languagetext30 Complex Type
Beschreibung
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext30 Complex Type
Overview
languagetext30
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Verwendet von
CATALOG_NAME Element
PROPERTY_UNIT Element
Quelle
<xs:complexType name="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

languagetext40 Complex Type
IDMW 2.0 XML-Schema Dokumentation : languagetext40 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext40 Complex Type
Overview
languagetext40

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Verwendet von
INTERNAL_NAME Element
Quelle
<xs:complexType name="languagetext40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

LANGUAGE Element
IDMW 2.0 XML-Schema Dokumentation > languagetext40 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
languagetext40 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

TEXT Element
IDMW 2.0 XML-Schema Dokumentation > languagetext40 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetext40 Complex Type | IDMW 2.0 XML-Schema Dokumentation


%%LocalItemTitle%%

languagetext60 Complex Type
IDMW 2.0 XML-Schema Dokumentation : languagetext60 Complex Type
Beschreibung
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext60 Complex Type
Overview
languagetext60
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.
Sequence
LANGUAGE 1..∞
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Verwendet von
PRODUCT_GROUP_TEXT Element
GROUP_TITLE Element
PACKAGE_LIST_TEXT Element
SERIE_GROUP_TEXT Element
OPTION_TEXT Element
FEATURE_TEXT Element
DECISION_NAME_TEXT Element
OPTION_GROUP_TEXT Element
PRICE_FEATURE_GROUP_TEXT Element
PRICE_TYPE_NAME Element
Quelle
<xs:complexType name="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,60}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDMW 2.0 XML-Schema Dokumentation


%%ItemTitle%%

Einfache Datentypen

Für die Formulierung bestimmter Bedingungen wurde ein eigener Datentyp operator geschaffen

operator Simple Type


%%LocalItemTitle%%

operator Simple Type
IDMW 2.0 XML-Schema Dokumentation : operator Simple Type
Beschreibung
Mit diesem einfachen Datentyp wird ein Operator für Vergleiche formuliert.

Der Vergleichsoperator kann der folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D string
P eq|ne|in|nin|gt|lt|ge|le
M [1:4]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
operator Simple Type
Overview
operator Restriction of xs:string
Mit diesem einfachen Datentyp wird ein Operator für Vergleiche formuliert.

Der Vergleichsoperator kann der folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

 D string
P eq|ne|in|nin|gt|lt|ge|le
M [1:4]
Facette (Aspekt)
MaxLength | 4
Enumeration | eq
Enumeration | ne
Enumeration | in
Enumeration | nin
Enumeration | gt
Enumeration | lt
Enumeration | ge
Enumeration | le
Quelle
<xs:simpleType name="operator" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:appinfo source="de">eq (ist gleich)
ne (ist nicht gleich)
in (ist enthalten in einer Menge)
nin (ist nicht enthalten in der Menge)
gt (größer)
lt (kleiner)
ge (größer gleich)
le (kleiner gleich)</xs:appinfo>
  </xs:annotation>
  <xs:restriction base="xs:string">
    <xs:maxLength value="4" />
    <xs:enumeration value="eq" />
    <xs:enumeration value="ne" />
    <xs:enumeration value="in" />
    <xs:enumeration value="nin" />
    <xs:enumeration value="gt" />
    <xs:enumeration value="lt" />
    <xs:enumeration value="ge" />
    <xs:enumeration value="le" />
  </xs:restriction>
</xs:simpleType>
IDMW 2.0 XML-Schema Dokumentation